Legal Notice

R&S®FSW
Signal and Spectrum Analyzer

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.

Top


Preface
Contents
  • Conventions Used in the Documentation
  • How to Use the Help System


Conventions Used in the Documentation

Preface > Conventions Used in the Documentation
Conventions Used in the Documentation
Contents
  • Typographical Conventions
  • Conventions for Procedure Descriptions


Typographical Conventions

Preface > Conventions Used in the Documentation > Typographical Conventions
Typographical Conventions

The following text markers are used throughout this documentation:

Convention | Description
"Graphical user interface elements" | All names of graphical user interface elements on the screen, such as dialog boxes, menus, options, buttons, and softkeys are enclosed by quotation marks.
KEYS | Key names are written in capital letters.
File names, commands, program code | File names, commands, coding samples and screen output are distinguished by their font.
Input | Input to be entered by the user is displayed in italics.
Links | Links that you can click are displayed in blue font.
"References" | References to other parts of the documentation are enclosed by quotation marks.


Conventions for Procedure Descriptions

Preface > Conventions Used in the Documentation > Conventions for Procedure Descriptions
Conventions for Procedure Descriptions

When describing how to operate the instrument, several alternative methods may be available to perform the same task. In this case, the procedure using the touchscreen is described. Any elements that can be activated by touching can also be clicked using an additionally connected mouse. The alternative procedure using the keys on the instrument or the on-screen keyboard is only described if it deviates from the standard operating procedures.

The term "select" may refer to any of the described methods, i.e. using a finger on the touchscreen, a mouse pointer in the display, or a key on the instrument or on a keyboard.


How to Use the Help System

Preface > How to Use the Help System
How to Use the Help System
Calling context-sensitive and general help
►

To display the general help dialog box, press the HELP key on the front panel.

The help dialog box "View" tab is displayed. A topic containing information about the current menu or the currently opened dialog box and its function is displayed.

For standard Windows dialog boxes (e.g. File Properties, Print dialog etc.), no context-sensitive help is available.

►

If the help is already displayed, press the softkey for which you want to display help.

A topic containing information about the softkey and its function is displayed.

If a softkey opens a submenu and you press the softkey a second time, the submenu of the softkey is displayed.

Contents of the help dialog box

The help dialog box contains four tabs:

  • "Contents" - contains a table of help contents
  • "View" - contains a specific help topic
  • "Index" - contains index entries to search for help topics
  • "Zoom" - contains zoom functions for the help display

To change between these tabs, press the tab on the touchscreen.

Navigating in the table of contents
  • To move through the displayed contents entries, use the UP ARROW and DOWN ARROW keys. Entries that contain further entries are marked with a plus sign.
  • To display a help topic, press the ENTER key. The "View" tab with the corresponding help topic is displayed.
  • To change to the next tab, press the tab on the touchscreen.
Navigating in the help topics
  • To scroll through a page, use the rotary knob or the UP ARROW and DOWN ARROW keys.
  • To jump to the linked topic, press the link text on the touchscreen.
Searching for a topic

  1. Change to the "Index" tab.

  2. Enter the first characters of the topic you are interested in. The entries starting with these characters are displayed.

  3. Change the focus by pressing the ENTER key.

  4. Select the suitable keyword by using the UP ARROW or DOWN ARROW keys or the rotary knob.

  5. Press the ENTER key to display the help topic.

    The "View" tab with the corresponding help topic is displayed.

Changing the zoom

  1. Change to the "Zoom" tab.

  2. Set the zoom using the rotary knob. Four settings are available: 1-4. The smallest size is selected by number 1, the largest size is selected by number 4.

Closing the help window
►

Press the ESC key or a function key on the front panel.


Welcome to the R&S FSW

The R&S FSW is a new high-performance Rohde & Schwarz signal and spectrum analyzer developed to meet demanding customer requirements. Offering low phase noise, wide analysis bandwidth and straightforward and intuitive operation, the analyzer makes measurements fast and easy.

This user manual contains a description of the functionality that the instrument provides, including remote control operation. The latest version is available for download at the product homepage (http://www2.rohde-schwarz.com/product/FSW.html).


Getting Started

Note: the following chapters are identical to those in the printed R&S FSW Getting Started manual.

Contents
  • Preparing for Use
  • Instrument Tour
  • Trying Out the Instrument
  • Operating the Instrument


Preparing for Use

Getting Started > Preparing for Use
Preparing for Use
Contents
  • Putting into Operation
  • Windows Operating System
  • Connecting USB Devices
  • Connecting an External Monitor
  • Setting Up a Network (LAN) Connection
  • Configuring the Initial Instrument Settings
  • Protecting Data Using the Secure User Mode


Putting into Operation

Getting Started > Preparing for Use > Putting into Operation
Putting into Operation

This section describes the basic steps to be taken when setting up the R&S FSW for the first time.

Risk of injury and instrument damage
The instrument must be used in an appropriate manner to prevent electric shock, fire, personal injury, or damage.
  • Do not open the instrument casing.
  • Read and observe the "Basic Safety Instructions" at the beginning of this manual or on the documentation CD-ROM, in addition to the safety instructions in the following sections. Notice that the data sheet may specify additional operating conditions.
Risk of instrument damage

Note that the general safety instructions also contain information on operating conditions that will prevent damage to the instrument. The instrument's data sheet may contain additional operating conditions.

Risk of electrostatic discharge (ESD)

Electrostatic discharge (ESD) can cause damage to the electronic components of the instrument and the device under test (DUT). ESD is most likely to occur when you connect or disconnect a DUT or test fixture to the instrument's test ports. To prevent ESD, use a wrist strap and cord and connect yourself to the ground, or use a conductive floor mat and heel strap combination.

For details, refer to the safety instructions delivered in electronic format on the documentation CD-ROM.

Risk of instrument damage during operation
An unsuitable operating site or test setup can cause damage to the instrument and to connected devices. Ensure the following operating conditions before you switch on the instrument:
  • All fan openings are unobstructed and the airflow perforations are unimpeded. The minimum distance from the wall is 10 cm.
  • The instrument is dry and shows no sign of condensation.
  • The instrument is positioned as described in the following sections.
  • The ambient temperature does not exceed the range specified in the data sheet.
  • Signal levels at the input connectors are all within the specified ranges.
  • Signal outputs are correctly connected and are not overloaded.
EMI impact on measurement results

Electromagnetic interference (EMI) may affect the measurement results.

To suppress generated electromagnetic interference (EMI):
  • Use suitable shielded cables of high quality. For example, use double-shielded RF and LAN cables.
  • Always terminate open cable ends.
  • Note the EMC classification in the data sheet.
Contents
  • Unpacking and Checking the Instrument
  • Accessory List
  • Placing or Mounting the Instrument
  • Connecting the AC Power
  • Switching the Instrument On and Off
  • Performing a Self-Alignment and a Selftest
  • Checking the Supplied Options


Unpacking and Checking the Instrument

Getting Started > Preparing for Use > Putting into Operation > Unpacking and Checking the Instrument
Unpacking and Checking the Instrument

Check the equipment for completeness using the delivery note and the accessory lists for the various items. Check the instrument for any damage. If there is damage, immediately contact the carrier who delivered the instrument. Make sure not to discard the box and packing material.

Packing material

Retain the original packing material. If the instrument needs to be transported or shipped at a later date, you can use the material to protect the control elements and connectors.

Risk of damage during transportation and shipment

Insufficient protection against mechanical and electrostatic effects during transportation and shipment can damage the instrument.

  • Always make sure that sufficient mechanical and electrostatic protection is provided.
  • When shipping an instrument, the original packaging should be used. If you do not have the original packaging, use sufficient padding to prevent the instrument from moving around inside the box. Pack the instrument in antistatic wrap to protect it from electrostatic charging.
  • Secure the instrument to prevent any movement and other mechanical effects during transportation.

The carrying handles at the front and side of the casing are designed to lift or carry the instrument. Do not apply an excessive external force to the handles.

Observe the information on transporting heavy instruments in the basic safety instructions included at the front of the printed manual and on the supplied CD ROM.


Accessory List

Getting Started > Preparing for Use > Putting into Operation > Accessory List
Accessory List

The instrument comes with the following accessories:

  • Power cable
  • Printed Getting Started manual
  • "R&S FSW User Documentation" CD-ROM


Placing or Mounting the Instrument

Getting Started > Preparing for Use > Putting into Operation > Placing or Mounting the Instrument
Placing or Mounting the Instrument

The R&S FSW is designed for use under laboratory conditions, either on a bench top or in a rack.

Bench Top Operation

If the R&S FSW is operated on a bench top, the surface should be flat. The instrument can be used in horizontal position, standing on its feet, or with the support feet on the bottom extended.

Risk of injury if feet are folded out
The feet may fold in if they are not folded out completely or if the instrument is shifted. This may cause damage or injury.
  • Fold the feet completely in or completely out to ensure stability of the instrument. Never shift the instrument when the feet are folded out.
  • When the feet are folded out, do not work under the instrument or place anything underneath.
  • The feet can break if they are overloaded. The overall load on the folded-out feet must not exceed 500 N.
Risk of injury and instrument damage if stacking instruments

A stack of instruments may tilt over and cause injury. Furthermore, the instruments at the bottom of the stack may be damaged due to the load imposed by the instruments on top.

Observe the following instructions when stacking instruments:
  • Never stack more than three instruments. If you need to stack more than three instruments, install them in a rack.
  • The overall load imposed on the lowest instrument must not exceed 500 N.
  • All instruments must have the same dimensions (width and length).
  • If the instruments have foldable feet, fold them in completely.
Rackmounting

The R&S FSW can be installed in a rack using a rack adapter kit (order no. see data sheet). The installation instructions are part of the adapter kit.

Risk of instrument damage in a rack

An insufficient airflow can cause the instrument to overheat, which may disturb the operation and even cause damage.

Make sure that all fan openings are unobstructed, that the airflow perforations are unimpeded, and that the minimum distance from the wall is 10 cm.


Connecting the AC Power

Getting Started > Preparing for Use > Putting into Operation > Connecting the AC Power
Connecting the AC Power

In the standard version, the R&S FSW is equipped with an AC power supply connector. The R&S FSW can be used with different AC power voltages and adapts itself automatically to it. Refer to the datasheet for the requirements of voltage and frequency. The AC power connector is located on the rear panel of the instrument.

For details on the connector refer to "AC Power Supply Connection and Main Power Switch".

►

Connect the R&S FSW to the AC power supply using the supplied power cable.

Since the instrument is assembled in line with the specifications for safety class EN61010, it may only be connected to an outlet that has a ground contact.


Switching the Instrument On and Off

Getting Started > Preparing for Use > Putting into Operation > Switching the Instrument On and Off
Switching the Instrument On and Off
Switching the instrument on
►

Press the AC power switch on the rear panel to position "I".

The instrument is supplied with AC power. After booting, the instrument is ready for operation. A green LED above the POWER key indicates this.

An orange LED indicates the instrument is in standby mode

Warm-up time for OCXO

When the instrument is switched on, the OCXO requires an extended warm-up time (see data sheet). No warm-up time is required when starting from standby mode.

Switching the instrument off

  1. Press the POWER key on the front panel.

    The R&S FSW switches to standby mode.

  2. Set the AC power switch on the rear panel to position "O", or disconnect the instrument from the AC power supply.

    The R&S FSW changes into off mode.

Risk of losing data

If you switch off the running instrument using the rear panel switch or by disconnecting the power cord, the instrument loses its current settings. Furthermore, program data may be lost.

Press the Power key first to shut down the application properly.


Performing a Self-Alignment and a Selftest

Getting Started > Preparing for Use > Putting into Operation > Performing a Self-Alignment and a Selftest
Performing a Self-Alignment and a Selftest

During instrument start, the installed hardware is checked against the current firmware version to ensure the hardware is supported. If not, an error message is displayed ("WRONG_FW") and you are asked to update the firmware. Until the firmware version is updated, self-alignment fails.

(For details refer to the R&S FSW User Manual).

Furthermore, it may be necessary to align the data to a reference source by performing a self-alignment when strong temperature changes occur.

Operating temperature

Before performing this functional test, make sure that the instrument has reached its operating temperature (for details, refer to the data sheet).

A message in the status bar ("Instrument warming up...") indicates that the operating temperature has not yet been reached.

Performing a self-alignment

  1. Press the SETUP key.

  2. Press the "Alignment" softkey.

  3. Select the "Start Self-Alignment" button in the "Alignment" dialog box.

    Once the system correction values have been calculated successfully, a message is displayed.

To display the alignment results again later
  • Press the SETUP key.
  • Press the "Alignment" softkey.
Performing a selftest

The selftest does not need to be repeated every time the instrument is switched on. It is only necessary when instrument malfunction is suspected.

  1. Press the SETUP key.

  2. Press the "Service" softkey.

  3. Switch to the "Selftest" tab in the "Service" dialog box.

  4. Select the "Start Selftest" button.

    Once the instrument modules have been checked successfully, a message is displayed.


Checking the Supplied Options

Getting Started > Preparing for Use > Putting into Operation > Checking the Supplied Options
Checking the Supplied Options

The instrument may be equipped with both hardware and firmware options. In order to check whether the installed options correspond to the options indicated on the delivery note, proceed as follows.

  1. Press the SETUP key.

  2. Press the "System Config" softkey.

  3. Switch to the "Versions + Options" tab in the "System Configuration" dialog box.

    A list with hardware and firmware information is displayed.

  4. Check the availability of the hardware options as indicated in the delivery note.


Windows Operating System

Getting Started > Preparing for Use > Windows Operating System
Windows Operating System

The instrument contains the Windows 7 operating system which has been configured according to the instrument's features and needs. Changes in the system setup are only required when peripherals like keyboard or a printer are installed or if the network configuration does not comply with the default settings. After the R&S FSW is started, the operating system boots and the instrument firmware is started automatically.

To ensure that the instrument software functions properly, certain rules must be adhered to concerning the operating system.

Risk of causing instrument unusability

The instrument is equipped with the Windows 7 operating system. Additional software can therefore be installed on the instrument. The use and installation of additional software may impair instrument function. Thus, run only programs that Rohde & Schwarz has tested for compatibility with the instrument software.

The drivers and programs used on the instrument under Windows 7 have been adapted to the instrument. Existing instrument software must always be modified using only update software released by Rohde & Schwarz.

The following program packages have been tested:
  • R&S Power Viewer Plus - virtual power meter for displaying results of the Power Sensor R&S NRP-Zxx (install only this component!)
  • Symantec Endpoint Security – Virus-protection software
  • FileShredder - for reliable deletion of files on the hard disk
Contents
  • Virus Protection
  • Service Packs and Updates
  • Login
  • Accessing the Start Menu
  • Accessing the Windows Task Bar


Virus Protection

Getting Started > Preparing for Use > Windows Operating System > Virus Protection
Virus Protection

Users must take appropriate steps to protect their instruments from infection. Beside the use of strong firewall settings and regularly scanning any removable storage device used with a Rohde & Schwarz instrument, it is also recommended that anti-virus software be installed on the instrument. While Rohde & Schwarz does NOT recommend running anti-virus software in the background ("on- access" mode) on Windows-based instruments, due to potentially degrading instrument performance, it does recommend running it during non-critical hours.

For details and recommendations, see the Rohde & Schwarz White Paper "Malware Protection" available at http://www.rohde-schwarz.com/appnote/1EF73.


Service Packs and Updates

Getting Started > Preparing for Use > Windows Operating System > Service Packs and Updates
Service Packs and Updates

Microsoft regularly creates security updates and other patches to protect Windows-based operating systems. These are released through the Microsoft Update website and associated update server. Instruments using Windows, especially those that connect to a network, should be updated regularly.

For more details and information on configuring automatic updates see the R&S White Paper "Malware Protection" (available at http://www.rohde-schwarz.com/appnote/1EF73).


Login

Getting Started > Preparing for Use > Windows Operating System > Login
Login

Windows 7 requires that users identify themselves by entering a user name and password in a login window. By default, the R&S FSW provides two user accounts: an administrator account ("Instrument") with unrestricted access to the computer/domain, and a standard user account ("NormalUser") with limited access. In both cases the initial password is 894129. Note that this password is very weak, and it is recommended that you change the password for both users after initial login. You can change the password in Windows 7 for any user at any time via "Start > Control Panel > User Accounts".

Secure User Mode

If the secure user mode option (R&S FSW-K33) is installed, an additional account is provided: the "SecureUser", also with the password 894129.

When the secure user mode is activated the first time after installation, the user is prompted to change the passwords for all user accounts in order to improve system security.

For details see "Protecting Data Using the Secure User Mode".

For the administrator account, an automatic login function is active by default. If activated, login is carried out automatically for the administrator (with full access) in the background when the R&S FSW is started, without having to enter a password.

For information on how to deactivate the automatic login, refer to "Deactivating the automatic login function".

Some administrative tasks require administrator rights (e.g. the configuration of a LAN network). Refer to the description of the basic instrument setup (SETUP menu) to find out which functions are affected.

Contents
  • The Automatic Login Function


The Automatic Login Function

Getting Started > Preparing for Use > Windows Operating System > Login > The Automatic Login Function
The Automatic Login Function
Deactivating the automatic login function

When shipped, the instrument is already configured to automatically log on under Windows 7. To deactivate the automatic login function, perform the following steps:

  1. Select the "Windows" icon in the toolbar to access the operating system of the R&S FSW (see also "Accessing the Start Menu").

  2. In the "Start" menu, select "Run".

    The "Run" dialog box is displayed.

  3. Enter the command C:\R_S\INSTR\USER\NO_AUTOLOGIN.REG.

  4. Press the ENTER key to confirm.

    The automatic login function is deactivated. The next time you switch on the instrument, you are prompted to enter your user name and password before the firmware is started.

Reactivating the automatic login function

  1. In the "Start" menu, select "Run".

    The "Run" dialog box is displayed.

  2. Enter the command C:\R_S\INSTR\USER\AUTOLOGIN.REG.

  3. Press the ENTER key to confirm.

    The automatic login function is reactivated. It will be applied the next time the instrument is switched on.

Switching users when using the automatic login function

Which user account is used is defined during login. However, you can also switch the user account to be used when the automatic login function is active.

►

In the "Start" menu, select the arrow next to the "Shut down" button and then "Log off".

The "Login" dialog box is displayed, in which you can enter the different user account name and password.


Accessing the Start Menu

Getting Started > Preparing for Use > Windows Operating System > Accessing the Start Menu
Accessing the Start Menu

The Windows "Start" menu provides access to the Windows 7 functionality and installed programs. To open the "Start" menu, select the "Windows" icon on the R&S FSW toolbar, or press the "Windows" key or the CTRL + ESC key combination on the (external) keyboard.

All necessary system settings can be defined in the "Start > Control Panel" menu (for required settings refer to the Windows 7 documentation and to the hardware description).


Accessing the Windows Task Bar

Getting Started > Preparing for Use > Windows Operating System > Accessing the Windows Task Bar
Accessing the Windows Task Bar

The Windows task bar also provides quick access to commonly used programs, for example Paint or Wordpad, but also IECWIN, the auxiliary remote control tool provided free of charge and installed by Rohde & Schwarz.

For details on the IECWIN tool, see the "Network and Remote Control" chapter of the R&S FSW User Manual.

To open the task bar, select the "Windows" icon on the R&S FSW toolbar, or press the "Windows" key or the CTRL + ESC key combination on your (external) keyboard.


Connecting USB Devices

Getting Started > Preparing for Use > Connecting USB Devices
Connecting USB Devices

The USB interfaces on the front and (optionally) rear panels of the R&S FSW allow you to connect USB devices directly to the instrument. This number can be increased as necessary by using USB hubs. Due to the large number of available USB devices, there is almost no limit to the expansions that are possible with the R&S FSW.

The following list shows various USB devices that can be useful:
  • Memory stick for easy transfer of data to/from a computer (e.g. firmware updates)
  • CD-ROM drives for easy installation of firmware applications
  • Keyboard or mouse to simplify the entry of data, comments, file names, etc.
  • Printer for printing out measurement results
  • Power sensors, e.g. of the NRP Zxy family

Installing USB devices is easy under Windows, because all USB devices are plug&play. After a device is connected to the USB interface, automatically searches for a suitable device driver.

If Windows does not find a suitable driver, it will prompt you to specify a directory that contains the driver software. If the driver software is on a CD, connect a USB CD-ROM drive to the instrument before proceeding.

When a USB device is subsequently disconnected from the R&S FSW, Windows immediately detects the change in hardware configuration and deactivates the corresponding driver.

All USB devices can be connected to or disconnected from the instrument during operation.

Connecting a memory stick or CD-ROM drive

If installation of a memory stick or CD-ROM drive is successful, Windows informs you that the device is ready to use. The device is made available as a new drive and is displayed in Windows Explorer. The name of the drive depends on the manufacturer.

Connecting a keyboard

The keyboard is detected automatically when it is connected. The default input language is English – US.

However, you can also connect foreign language keyboards; currently the following languages are supported for the R&S FSW:
  • German
  • Swiss
  • French
  • Russian

Select "Start > Control Panel > Clock, Language, and Region > Change keyboards or other input methods" to configure the keyboard properties. To access the Windows operating system, press the Windows key on the external keyboard.

Connecting a mouse

The mouse is detected automatically when it is connected.

Select "Start > Control Panel > Devices and Printers > Mouse" to configure the mouse properties. To access the Windows operating system, press the Windows key on the external keyboard.

Connecting a printer

When printing a file, the instrument checks whether a printer is connected and turned on and whether the appropriate printer driver is installed. If required, printer driver installation is initiated. A printer driver needs to be installed only once.

To install a printer, select "Start > Control Panel > Devices and Printers > Add a printer". To access the Windows operating system, press the Windows key on the external keyboard.

You can load updated and improved driver versions or new drivers from an installation disk, USB memory stick or another external storage medium. If the instrument is integrated in a network, you can also install driver data stored in a network directory.

Select "Start > Control Panel > Devices and Printers > Device Manager > Update Device drivers" to install the driver.


Connecting an External Monitor

Getting Started > Preparing for Use > Connecting an External Monitor
Connecting an External Monitor

You can connect an external monitor (or projector) to the DVI or DISPLAY PORT connector on the instrument's rear panel (see also "DISPLAY PORT and DVI").

Screen resolution and format

The touchscreen of the R&S FSW is calibrated for a 16:10 format. If you connect a monitor or projector using a different format (e.g. 4:3), the calibration will not be correct and the screen will not react to your touch actions properly.

The touchscreen has a screen resolution of 1280x800 pixels. Most external monitors have a higher screen resolution. If the screen resolution of the monitor is set higher than the instrument's resolution, the application window uses an area of 1280x800 pixels on the monitor display. For full screen display, adjust the monitor's screen resolution.

The R&S FSW supports a minimum resolution of 1280x768 pixels.

  1. Connect the external monitor to the R&S FSW.

  2. Press the SETUP key.

  3. Press the "Display" softkey.

  4. Select the "Configure Monitor" tab in the "Display" dialog box.

    The standard Windows "Screen Resolution" dialog box is displayed.

  5. If necessary, change the screen resolution to be used. Consider the information in the note above.

  6. Select the instrument to be used for display:

    • "Display 1": internal monitor only
    • "Display 2": external monitor only
    • "Duplicate": both internal and external monitor

  7. Tap "Apply" to try out the settings before they are accepted permanently, then you can easily return to the previous settings, if necessary.

  8. Select "OK" if the settings are suitable.


Setting Up a Network (LAN) Connection

Getting Started > Preparing for Use > Setting Up a Network (LAN) Connection
Setting Up a Network (LAN) Connection

The R&S FSW is equipped with a network interface and can be connected to an Ethernet LAN (local area network). Provided the appropriate rights have been assigned by the network administrator and the Windows firewall configuration is adapted accordingly, the interface can be used, for example:

  • To transfer data between a controlling device and the test device, e.g. in order to run a remote control program.
    See chapter "Remote Control"
  • To access or control the measurement from a remote computer using the "Remote Desktop" application (or a similar tool)
  • To connect external network devices (e.g. printers)
  • To transfer data from a remote computer and back, e.g. using network folders

This section describes how to configure the LAN interface. It includes the following topics:

  • "Connecting the Instrument to the Network"
  • "Assigning the IP Address"

Note that only user accounts with administrator rights can configure LAN networks.

LXI

The R&S FSW complies with LXI Class C. LXI gives you direct access to the LAN settings described below.

For further information on the LXI interface refer to "LXI Settings".

Contents
  • Connecting the Instrument to the Network
  • Assigning the IP Address
  • Using computer names
  • Changing the Windows Firewall Settings


Connecting the Instrument to the Network

Getting Started > Preparing for Use > Setting Up a Network (LAN) Connection > Connecting the Instrument to the Network
Connecting the Instrument to the Network

There are two methods to establish a LAN connection to the instrument:

  • A non-dedicated network (Ethernet) connection from the instrument to an existing network made with an ordinary RJ-45 network cable. The instrument is assigned an IP address and can coexist with a computer and with other hosts on the same network.
  • A dedicated network connection (Point-to-point connection) between the instrument and a single computer made with a (crossover) RJ-45 network cable. The computer must be equipped with a network adapter and is directly connected to the instrument. The use of hubs, switches, or gateways is not required, however, data transfer is still performed using the TCP/IP protocol. An IP address has to be assigned to the instrument and the computer, see "Assigning the IP Address".
    Note: As the R&S FSW uses a 1 GBit LAN, a crossover cable is not necessary (due to Auto-MDI(X) functionality).
Risk of network failure

Before connecting the instrument to the network or configuring the network, consult your network administrator. Errors may affect the entire network.

►

To establish a non-dedicated network connection, connect a commercial RJ-45 cable to one of the LAN ports.

To establish a dedicated connection, connect a (crossover) RJ-45 cable between the instrument and a single PC.

If the instrument is connected to the LAN, Windows automatically detects the network connection and activates the required drivers.

The network card can be operated with a 1 GBit Ethernet IEEE 802.3u interface.


Assigning the IP Address

Getting Started > Preparing for Use > Setting Up a Network (LAN) Connection > Assigning the IP Address
Assigning the IP Address
Depending on the network capacities, the TCP/IP address information for the instrument can be obtained in different ways.
  • If the network supports dynamic TCP/IP configuration using the Dynamic Host Configuration Protocol (DHCP), all address information can be assigned automatically.
  • If the network does not support DHCP, or if the instrument is set to use alternate TCP/IP configuration, the addresses must be set manually.

By default, the instrument is configured to use dynamic TCP/IP configuration and obtain all address information automatically. This means that it is safe to establish a physical connection to the LAN without any previous instrument configuration.

Risk of network errors

Connection errors can affect the entire network. If your network does not support DHCP, or if you choose to disable dynamic TCP/IP configuration, you must assign valid address information before connecting the instrument to the LAN. Contact your network administrator to obtain a valid IP address.

Assigning the IP address on the instrument

  1. Press the SETUP key.

  2. Press the "Network + Remote" softkey.

  3. Select the "Network" tab.

  4. In the "Network + Remote" dialog, toggle the "DHCP On/Off" setting to the required mode.

    If DHCP is "Off", you must enter the IP address manually, as described in the following steps.

    Note: When DHCP is changed from "On" to "Off", the previously set IP address and subnet mask are retrieved.

    If DHCP is "On", the IP address of the DHCP server is obtained automatically. The configuration is saved, and you are prompted to restart the instrument. You can skip the remaining steps.

    Note: When a DHCP server is used, a new IP address may be assigned each time the instrument is restarted. This address must first be determined on the instrument itself. Thus, when using a DHCP server, it is recommended that you use the permanent computer name, which determines the address via the DNS server (see "Using a DNS server to determine the IP address" and "Using computer names").

  5. Enter the "IP Address", for example 192.0.2.0. The IP address consists of four number blocks separated by dots. Every block contains 3 numbers in maximum.

  6. Enter the "Subnet Mask", for example 255.255.255.0. The subnet mask consists of four number blocks separated by dots. Every block contains 3 numbers in maximum.

  7. Select "Configure Network".

    If you have entered an invalid IP address or subnet mask, the message "out of range" is displayed in the status line. If the settings are correct, the configuration is saved, and you are prompted to restart the instrument.

  8. Confirm the displayed message ("Yes" button) to restart the instrument.

Using a DNS server to determine the IP address

If a DNS server is configured on the R&S FSW, the server can determine the current IP address for the connection using the permanent computer name.

  1. Obtain the name of your DNS domain and the IP addresses of the DNS and WINS servers on your network.

  2. Press the SETUP key and then the "Network + Remote" softkey.

  3. In the "Network" tab, select the "Open Dialog 'Network Configuration" button.

  4. Double-tap the "Local Area Connection" icon.

  5. In the "Local Area Connection Status" dialog box, select the "Properties" button.

    The items used by the LAN connection are displayed.

  6. Tap the entry named "Internet Protocol Version 4 (TCP/IPv4)" to highlight it.

  7. Select the "Properties" button.

  8. On the "General" tab, select "Use the following DNS server addresses" and enter your own DNS addresses.

    For more information refer to the Windows operating system Help.


Using computer names

Getting Started > Preparing for Use > Setting Up a Network (LAN) Connection > Using computer names
Using computer names

In a LAN that uses a DNS server (Domain Name System server), each PC or instrument connected in the LAN can be accessed via an unambiguous computer name instead of the IP address. The DNS server translates the host name to the IP address. This is especially useful when a DHCP server is used, as a new IP address may be assigned each time the instrument is restarted.

Each instrument is delivered with an assigned computer name, but this name can be changed.

To change the computer name

  1. Press the SETUP key and then the "Network + Remote" softkey.

    The current "Computer Name" is displayed in the "Network" tab.

  2. Enter the new computer name and close the dialog box.


Changing the Windows Firewall Settings

Getting Started > Preparing for Use > Setting Up a Network (LAN) Connection > Changing the Windows Firewall Settings
Changing the Windows Firewall Settings

A firewall protects an instrument by preventing unauthorized users from gaining access to it through a network. Rohde & Schwarz highly recommends the use of the firewall on your instrument. Rohde & Schwarz instruments are shipped with the Windows firewall enabled and preconfigured in such a way that all ports and connections for remote control are enabled. For more details on firewall configuration see the Rohde & Schwarz White Paper "Malware Protection" (available at http://www2.rohde-schwarz.com/file_13784/1EF73_0E.pdf) and the Windows Help system.

Note that changing firewall settings requires administrator rights.


Configuring the Initial Instrument Settings

Getting Started > Preparing for Use > Configuring the Initial Instrument Settings
Configuring the Initial Instrument Settings

This section describes how to setup the R&S FSW initially. For further basic instrument settings see the R&S FSW User Manual.

Contents
  • Setting the Date and Time


Setting the Date and Time

Getting Started > Preparing for Use > Configuring the Initial Instrument Settings > Setting the Date and Time
Setting the Date and Time

Users with administrator rights can set the date and time for the internal real time clock as follows:

Opening the Date and Time Properties dialog box

  1. Press the SETUP key.

  2. Press the "Display" softkey.

  3. Select the "General" tab in the "Display" dialog box.

  4. Press the "Set Date and Time" button to open the standard Windows "Date and Time Properties" dialog box.

  5. If necessary, toggle the "Date and Time Format" between German (DE) and US.

    After you have made a change and closed the dialog box, the new date and time is also adopted by the instrument.


Protecting Data Using the Secure User Mode

Getting Started > Preparing for Use > Protecting Data Using the Secure User Mode
Protecting Data Using the Secure User Mode

During normal operation, the R&S FSW uses a solid-state drive to store its operating system, instrument firmware, instrument self-alignment data, and any user data created during operation. If necessary, the solid-state drive can be removed from the R&S FSW and locked in a secure place to protect any classified data it may contain.

Redirecting storage to volatile memory

Alternatively, to avoid storing any sensitive data on the R&S FSW permanently, the secure user mode was introduced (option R&S FSW-K33). In secure user mode the instrument’s solid-state drive is write-protected so that no information can be written to memory permanently. Data that the R&S FSW normally stores on the solid-state drive is redirected to volatile memory instead, which remains available only until the instrument is switched off. This data includes:

  • Windows 7 operating system files
  • Firmware shutdown files containing information on last instrument state
  • Self-alignment data
  • General instrument settings such as the IP address
  • Measurement settings
  • User data created during operation
    (see also table "Items that can be stored to files")
  • Any data created by other applications installed on the R&S FSW, for example text editors (Notepad), the Clipboard, drawing tools etc.

Data that is stored in volatile memory can be accessed by the user just as in normal operation; however, when the instrument’s power is removed, all data in this memory is cleared. Thus, in secure user mode, the instrument always starts in a defined, fixed state when switched on.

In order to store data such as measurement results permanently, it must be stored to an external storage device, such as a memory stick.

Limited storage space

The volatile memory used to store data in secure user mode is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

Storing required data permanently

Any data that is to be available for subsequent sessions with the R&S FSW, such as predefined instrument settings, transducer factors or self-alignment data, must be stored on the instrument permanently, prior to activating the secure user mode.

Self-alignment data

Note that self-alignment data becomes invalid with time and due to temperature changes. Therefore, to achieve optimal accuracy, it may be preferable to perform a new self-alignment at the start of each new session on the R&S FSW.

Restricted operation
Due to the fact that permanent storage is not possible, the following functions are not available in secure user mode:
  • Firmware update
  • Activating a new option key
Activating and deactivating secure user mode

Only a user with administrator rights can activate the secure user mode. Once activated, a restart is required. The special user "SecureUser" is then logged on to the R&S FSW automatically (using the automatic login function, see "The Automatic Login Function"). While the secure user mode is active, a message is displayed in the status bar at the bottom of the screen.

Secure Passwords

By default, the initial password for both the administrator account ("Instrument") and the "SecureUser" account is "894129". When the secure user mode is activated the first time after installation, you are prompted to change the passwords for all user accounts in order to improve system security. Although it is possible to continue without changing the passwords, it is strongly recommended that you do so.

You can change the password in Windows 7 for any user at any time via "Start > Control Panel > User Accounts".

In order to deactivate the secure user mode, the "SecureUser" must log off and the "Instrument" user (administrator) must log on.

Switching users when using the automatic login function

In the "Start" menu, select the arrow next to the "Shut down" button and then "Log off".

The "Login" dialog box is displayed, in which you can enter the different user account name and password.

The secure user mode setting and automatic login is automatically deactivated when the "Instrument" user logs on. The "SecureUser" is no longer available.

The secure user mode setting is available in the general system configuration settings (see "General Configuration Settings").

Remote control

Initially after installation of the R&S FSW-K33 option, secure user mode must be enabled manually once before remote control is possible. This is necessary to prompt for a change of passwords.


Instrument Tour

Getting Started > Instrument Tour
Instrument Tour
Contents
  • Front Panel View
  • Rear Panel View


Front Panel View

Getting Started > Instrument Tour > Front Panel View
Front Panel View

This chapter describes the front panel, including all function keys and connectors.

Front panel view
1 = Touchscreen
2 = POWER key
3 = SYSTEM keys
4 = Headphones connector and volume control
5 = USB connectors
6 = POWER SENSOR connector
7 = PROBE connector
8 = NOISE SOURCE CONTROL
9 = Function keys
10 = Keypad
11 = Navigation controls
12 = (Analog) Baseband Input 50Ω connectors for I/Q signal or Rohde&Schwarz active probes (optional)
13 = (Analog) Baseband Input 50Ω connectors for inverse part of differential I/Q signal (optional)
14 = TRIGGER INPUT/OUTPUT connectors
15 = EXT MIXER connector (optional)
16 = RF Input 50 Ω connector
Instrument damage caused by cleaning agents

Cleaning agents contain substances that may damage the instrument, for example cleaning agents that contain a solvent may damage the front panel labeling, plastic parts, or the display.

Never use cleaning agents such as solvents (thinners, acetone, etc), acids, bases, or other substances.

The outside of the instrument can be cleaned sufficiently using a soft, lint-free dust cloth.

Contents
  • Touchscreen
  • POWER Key
  • SYSTEM Keys
  • PHONES and VOLUME
  • USB
  • POWER SENSOR
  • PROBE
  • NOISE SOURCE CONTROL
  • Function Keys
  • Keypad
  • Navigation Controls
  • UNDO/REDO keys
  • (Analog) Baseband Input 50 Ω Connectors (optional)
  • TRIGGER INPUT / OUTPUT
  • EXT MIXER Connector (optional)
  • RF INPUT 50 Ω


Touchscreen

Getting Started > Instrument Tour > Front Panel View > Touchscreen
Touchscreen

All measurement results are displayed on the screen on the front panel. Additionally, the screen display provides status and setting information and allows you to switch between various measurement tasks. The screen is touch-sensitive, offering an alternative means of user interaction for quick and easy handling of the instrument.

Risk of touchscreen damage during operation

The touchscreen may be damaged by inappropriate tools or excessive force.

Observe the following instructions when operating or cleaning the touchscreen:
  • Never touch the screen with ball point pens or other pointed objects with sharp edges.
  • It is recommended that you operate the touchscreen by finger only.
    As an alternative, you may use a stylus pen with a smooth soft tip.
  • Never apply excessive force to the screen. Touch it gently.
  • Never scratch the screen surface, for example with a finger nail.
    Never rub it strongly, for example with a dust cloth.
Touchscreen elements
1 = Toolbar with standard application functions, e.g. print, save/open file etc.
2 = Tabs for individual measurement channels
3 = Channel bar for firmware and measurement settings
4 = Input field for measurement setting
5 = Softkeys for function access
6 = Window title bar with diagram-specific (trace) information
7 = Measurement results area
8 = Diagram footer with diagram-specific information, depending on application
9 = Instrument status bar with error messages, progress bar and date/time display

A touchscreen is a screen that is touch-sensitive, i.e. it reacts in a specified way when a particular element on the screen is tapped by a finger or a pointing device, for example. Any user interface elements that can be clicked on by a mouse pointer can also be tapped on the screen to trigger the same behavior, and vice versa. Using the touchscreen, the following tasks (among others) can be performed by the tap of your finger (see also "Trying Out the Instrument"):

  • Changing a setting
  • Changing the display
  • Moving a marker
  • Zooming into a diagram
  • Selecting a new evaluation method
  • Scrolling through a result list
  • Saving or printing results and settings

To imitate a right-click by mouse using the touchscreen, for example to open a context-sensitive menu for a specific item, press the screen for about 1 second.

Contents
  • Toolbar
  • Softkeys
  • Context-sensitive Menus
  • On-screen Keyboard


Toolbar

Getting Started > Instrument Tour > Front Panel View > Touchscreen > Toolbar
Toolbar

Standard functions can be performed via the icons in the toolbar at the top of the screen.

You can hide the toolbar display, e.g. when using remote control, in order to enlarge the display area for the measurement results ("Setup > Display > Displayed Items"). See the R&S FSW User Manual for details.

The following functions are available:

Standard Application Functions in the Toolbar
Icon | Description
 | Windows: displays the Windows "Start" menu and task bar
 | Open: opens a file from the instrument ("Save/Recall" menu)
 | Store: stores data on the instrument ("Save/Recall" menu)
 | Print: defines print settings ("Print" menu)
 | Undo: reverts last operation
 | Redo: repeats previously reverted operation
 | Selection mode: the cursor can be used to select (and move) markers in a zoomed display
 | Zoom mode: displays a dotted rectangle in the diagram that can be expanded to define the zoom area
 | Multiple zoom mode: multiple zoom areas can be defined for the same diagram
 | Zoom off: displays the diagram in its original size
 | SmartGrid: activates "SmartGrid" mode to configure the screen layout
 | Sequencer: opens the "Sequencer" menu to perform consecutive measurements
 | Help (+ Select): allows you to select an object for which context-specific help is displayed
AL | Analysis line (MSRA mode only): opens a dialog box to display and position an analysis line in MSRA measurements (see R&S FSW MSRA User Manual)
 | Help: displays context-sensitive help topic for currently selected element
 | Print immediately: prints the current display (screenshot) as configured
In "SmartGrid" mode only:
 | Exit "SmartGrid" mode


Softkeys

Getting Started > Instrument Tour > Front Panel View > Touchscreen > Softkeys
Softkeys

Softkeys are virtual keys provided by the software. Thus, more functions can be provided than those that can be accessed directly via the function keys on the instrument. Softkeys are dynamic, i.e. depending on the selected function key, a different list of softkeys is displayed on the right side of the screen.

A list of softkeys for a certain function key is also called a menu. Softkeys can either perform a specific function or open a dialog box.

The "More" softkey indicates that the menu contains more softkeys than can be displayed at once on the screen. When pressed, it displays the next set of softkeys.

Recognizing the softkey status by color
Color | Meaning
orange | associated dialog box is open
blue | associated function is active; for toggle keys: currently active state
gray | instrument function is temporarily not available due to a specific setting or missing option

You can hide the softkey display, e.g. when using remote control, in order to enlarge the display area for the measurement results ("Setup > Display > Displayed Items"). See the User Manual for details.


Context-sensitive Menus

Getting Started > Instrument Tour > Front Panel View > Touchscreen > Context-sensitive Menus
Context-sensitive Menus

Markers and traces in the display, as well as the information in the channel bar, have context-sensitive menus. If you right-click on a marker or trace in the display, or information in the channel bar (or tap it for about 1 second), a menu is displayed which contains the same functions as the corresponding softkey. This is useful, for example, when the softkey display is hidden.


On-screen Keyboard

Getting Started > Instrument Tour > Front Panel View > Touchscreen > On-screen Keyboard
On-screen Keyboard

The on-screen keyboard is an additional means of interacting with the instrument without having to connect an external keyboard.

The on-screen keyboard display can be switched on and off as desired using the "On-Screen Keyboard" function key beneath the screen.

When you press this key, the display switches between the following options:

  • Keyboard displayed at the top of the screen
  • Keyboard displayed at the bottom of the screen
  • No keyboard displayed

You can use the TAB key on the on-screen keyboard to move the focus from one field to another in dialog boxes.


POWER Key

Getting Started > Instrument Tour > Front Panel View > POWER Key
POWER Key

The POWER key is located on the lower left corner of the front panel. It starts up and shuts down the instrument.

See also "Switching the Instrument On and Off".


SYSTEM Keys

Getting Started > Instrument Tour > Front Panel View > SYSTEM Keys
SYSTEM Keys

SYSTEM keys set the instrument to a predefined state, change basic settings, and provide print and display functions.

A detailed description of the corresponding functions is provided in the User Manual.

SYSTEM keys

SYSTEM key

Assigned functions

PRESET

Resets the instrument to the default state.

MODE

Provides the selection between applications

SETUP

Provides basic instrument configuration functions, e.g.:
  • Reference frequency (external/internal), noise source
  • Date, time, display configuration
  • LAN interface
  • Self-alignment
  • Firmware update and enabling of options
  • Information about instrument configuration incl. firmware version and system error messages
  • Service support functions (self test etc.)
Switches between the on-screen keyboard display:
  • at the top of the screen
  • at the bottom of the screen
  • off

Switches between maximized and split display of focus area.

Moves focus area from one active window to the next.


PHONES and VOLUME

Getting Started > Instrument Tour > Front Panel View > PHONES and VOLUME
PHONES and VOLUME

Headphones equipped with a miniature jack plug can be connected to the PHONES female connector. The internal impedance is 10 Ω. The output voltage can be set by using the VOLUME control to the right of the female connector. If a plug is connected, the internal loudspeaker is automatically switched off.

To use the PHONES connector, in the "Output" dialog box (INPUT/OUTPUT key), select "Video Output" = "Video". The output voltage (volume) is 1V.

Risk of hearing damage

To protect your hearing, make sure that the volume setting is not too high before putting on the headphones.


USB

Getting Started > Instrument Tour > Front Panel View > USB
USB

The front panel provides three female USB connectors (USB-A) to connect devices like a keyboard (recommended: R&S PSL-Z2, order number 1157.6870.03) or a mouse (recommended: R&S PSL-Z10, order number 1157.7060.03). In addition, a memory stick can be connected to store and reload instrument settings and measurement data.

The rear panel provides further USB connectors, including a male (USB-B) connector. See "USB".

All USB connectors support standard 2.0.


POWER SENSOR

Getting Started > Instrument Tour > Front Panel View > POWER SENSOR
POWER SENSOR

The LEMOSA female connector is used to connect power sensors of the R&S NRP-Zxy family. For a detailed list of supported sensors see the data sheet.

For details on configuring and using power sensors, see "Power Sensors".


PROBE

Getting Started > Instrument Tour > Front Panel View > PROBE
PROBE

The R&S FSW provides a connector for supply voltages of +15 V to -12 V and ground for active probes and preamplifiers. A maximum current of 140 mA is available. This connector is suitable as power supply for high-impedance probes.


NOISE SOURCE CONTROL

Getting Started > Instrument Tour > Front Panel View > NOISE SOURCE CONTROL
NOISE SOURCE CONTROL

The noise source control female connector is used to provide the supply voltage for an external noise source, e.g., to measure the noise figure and gain of amplifiers and frequency converting devices.

Conventional noise sources require a voltage of +28 V in order to be switched on and 0 V to be switched off. The output supports a maximum load of 100 mA.


Function Keys

Getting Started > Instrument Tour > Front Panel View > Function Keys
Function Keys

Function keys provide access to the most common measurement settings and functions.

A detailed description of the corresponding functions is provided in the User Manual.

Function keys
Function key | Assigned functions
Basic measurement settings
FREQ | Sets the center frequency as well as the start and stop frequencies for the frequency range under consideration. This key is also used to set the frequency offset and the signal track function.
SPAN | Sets the frequency span to be analyzed.
AMPT | Sets the reference level, the displayed dynamic range, the RF attenuation and the unit for the level display. Sets the level offset and the input impedance. Activates the preamplifier (option RF Preamplifier, R&S FSW-B24).
AUTO SET | Enables automatic settings for level, frequency or sweep type mode.
BW | Sets the resolution bandwidth and the video bandwidth.
SWEEP | Sets the sweep time and the number of measurement points. Selects continuous measurement or single measurement.
TRACE | Configures the measured data acquisition and the analysis of the measurement data.
TRIG | Sets the trigger mode, the trigger threshold, the trigger delay, and the gate configuration in the case of gated sweep.
Marker functions
MKR | Sets and positions the absolute and relative measurement markers (markers and delta markers).
PEAK SEARCH | Performs a peak search for active marker. If no marker is active, normal marker 1 is activated and the peak search is performed for it.
MKR FUNC | Provides additional analysis functions of the measurement markers: Frequency counter (Sig Count) Fixed reference point for relative measurement markers (Ref Fixed) Noise marker (Noise Meas) Phase noise (Phase Noise) n dB down function AM/FM audio demodulation Peak list
MKR-> | Used for search functions of the measurement markers (maximum/minimum of the trace). Assigns the marker frequency to the center frequency, and the marker level to the reference level. Restricts the search area (Search Limits) and characterizes the maximum points and minimum points (Peak Excursion).
Measurement and evaluation functions
MEAS | Provides the measurement functions. Measurement of multicarrier adjacent channel power (Ch Power ACLR) Carrier to noise spacing (C/N C/No) Occupied bandwidth (OBW) Spectrum emission mask measurement (Spectrum Emission Mask) Spurious emissions (Spurious Emissions) Measurement of time domain power (Time Domain Power) Signal statistics: amplitude probability distribution (APD) and cumulative complementary distribution function (CCDF) Third-order intercept point (TOI) AM modulation depth (AM Mod Depth)
MEAS CONFIG | Used to define measurement configuration.
LINES | Configures display lines and limit lines.
INPUT/OUTPUT | Displays softkeys for input/output functions.
Measurement start functions
RUN SINGLE | Starts a single new measurement (Single Sweep Mode).
RUN CONT | Starts a continuous measurement (Continuous Sweep Mode).
Function execution (in navigation controls area)
UNDO | Reverts last operation
REDO | Repeats previously reverted operation.


Keypad

Getting Started > Instrument Tour > Front Panel View > Keypad
Keypad

The keypad is used to enter alphanumeric parameters, including the corresponding units (see also "Entering Data"). It contains the following keys:

Keys on the keypad

Type of key

Description

Alphanumeric keys

Enter numbers and (special) characters in edit dialog boxes.

Decimal point

Inserts a decimal point "." at the cursor position.

Sign key

Changes the sign of a numeric parameter. In the case of an alphanumeric parameter, inserts a "-" at the cursor position.

Unit keys (GHz/-dBm MHz/dBm, kHz/dB and Hz/dB)

Adds the selected unit to the entered numeric value and complete the entry.

In the case of level entries (e.g. in dB) or dimensionless values, all units have the value "1" as multiplying factor. Thus, they have the same function as an ENTER key.

ESC key

Closes all kinds of dialog boxes, if the edit mode is not active. Quits the edit mode, if the edit mode is active. In dialog boxes that contain a "Cancel" button it activates that button.

For "Edit" dialog boxes the following mechanism is used:

  • If data entry has been started, it retains the original value and closes the dialog box.
  • If data entry has not been started or has been completed, it closes the dialog box.

BACKSPACE key

If an alphanumeric entry has already been started, this key deletes the character to the left of the cursor.

ENTER key

  • Concludes the entry of dimensionless entries. The new value is accepted.
  • With other entries, this key can be used instead of the "Hz/dB" unit key.
  • In a dialog box, selects the default or focused element.


Navigation Controls

Getting Started > Instrument Tour > Front Panel View > Navigation Controls
Navigation Controls

The navigation controls include a rotary knob, navigation keys, and UNDO / REDO keys. They allow you to navigate within the display or within dialog boxes.

Contents
  • Rotary Knob
  • Navigation Keys


Rotary Knob

Getting Started > Instrument Tour > Front Panel View > Navigation Controls > Rotary Knob
Rotary Knob

The rotary knob has several functions:

  • For numeric entries: increments (clockwise direction) or decrements (counter-clockwise direction) the instrument parameter at a defined step width
  • In lists: toggles between entries
  • For markers, limit lines, and other graphical elements on the screen: moves their position
  • For active scroll bars: moves the scroll bar vertically
  • For dialog boxes: Acts like the ENTER key when pressed


Navigation Keys

Getting Started > Instrument Tour > Front Panel View > Navigation Controls > Navigation Keys
Navigation Keys

The navigation keys can be used alternatively to the rotary knob to navigate through dialog boxes, diagrams or tables.

Arrow Up/Arrow Down Keys
The <arrow up> or <arrow down> keys do the following:
  • For numeric entries: increments (Arrow Up) or decrements (Arrow Down) the instrument parameter at a defined step width
  • In a list: scrolls forward and backward through the list entries
  • In a table: moves the selection bar vertically
  • In windows or dialog boxes with a vertical scroll bar: moves the scroll bar
Arrow Left/Arrow Right Keys
The <arrow left> or <arrow right> keys do the following:
  • In an alphanumeric edit dialog box, move the cursor.
  • In a list, scroll forward and backward through the list entries.
  • In a table, move the selection bar horizontally.
  • In windows or dialog boxes with horizontal scroll bar, move the scroll bar.


UNDO/REDO keys

Getting Started > Instrument Tour > Front Panel View > UNDO/REDO keys
UNDO/REDO keys
  • The UNDO key reverts the previously performed action, i.e. the status before the previous action is retrieved.
    The undo function is useful, for example, if you are performing a zero span measurement with several markers and a limit line defined and accidentally select a different measurement. In this case, many settings would be lost. However, if you press UNDO immediately afterwards, the previous status is retrieved, i.e. the zero span measurement and all settings.
  • The REDO key repeats the previously reverted action, i.e. the most recently performed action is repeated.

The UNDO function is not available after a PRESET or "RECALL" operation. When these functions are used, the history of previous actions is deleted.

The UNDO/REDO functions are not available for some applications; see Release Notes for details.


(Analog) Baseband Input 50 Ω Connectors (optional)

Getting Started > Instrument Tour > Front Panel View > (Analog) Baseband Input 50 Ω Connectors (optional)
(Analog) Baseband Input 50 Ω Connectors (optional)

The R&S FSW Analog Baseband Interface option (R&S FSW-B71) provides four BASEBAND INPUT BNC connectors on the front panel of the instrument for analog I and Q signals.

The upper BNC connectors BASEBAND INPUT I and BASEBAND INPUT Q are used to input single-ended signals, the positive signal input for differential signals, as well as input from active Rohde & Schwarz probes (R&S RT-ZSxx and differential probes RT-ZDxx).

The lower BNC connectors Ī and Ǭ are used to input the negative signal for differential signals.

For complex signal input (I+jQ), always use two identical cables for the I and Q connectors (same length, same type, same manufacturer). Otherwise, time delay or gain imbalance may occur between the different cables, which cannot be calibrated.

All connectors have a fixed impedance of 50 Ω and may receive a maximum input level of 4 Vpp each.

Risk of instrument damage

Do not overload the BASEBAND INPUT connectors. An input voltage of 4 V must never be exceeded. Noncompliance will destroy the Analog Baseband Interface components.

The device that provides analog baseband input (or the probe) must be connected to the R&S FSW accordingly.

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Input via the Analog Baseband Interface can be enabled in the I/Q Analyzer, the Analog Demodulation application, or in one of the optional applications that process I/Q data (where available).


TRIGGER INPUT / OUTPUT

Getting Started > Instrument Tour > Front Panel View > TRIGGER INPUT / OUTPUT
TRIGGER INPUT / OUTPUT

The female TRIGGER INPUT connector for external trigger or gate input is used to control the measurement by means of an external signal. The voltage levels can range from 0.5 to 3.5 V. The default value is 1.4 V. The typical input impedance is 10 kΩ.

The female BNC TRIGGER INPUT / OUTPUT connector can be used to receive a second external signal or to provide a signal to another device. The signal is TTL compatible (0 V / 5 V). You can control the connector usage in the "Trigger" settings (TRIG key).

The rear panel provides a third TRIGGER INPUT / OUTPUT connector, see "TRIGGER 3 INPUT/ OUTPUT".


EXT MIXER Connector (optional)

Getting Started > Instrument Tour > Front Panel View > EXT MIXER Connector (optional)
EXT MIXER Connector (optional)

External mixers can be connected at the EXT MIXER LO OUT/IF IN and IF IN female connectors to increase the available frequency range. This connector is optional and only available with R&S FSW-B21.

If no external mixers are connected to the R&S FSW, cover the two front connectors LO OUT / IF IN and IF IN with the supplied SMA caps.


RF INPUT 50 Ω

Getting Started > Instrument Tour > Front Panel View > RF INPUT 50 Ω
RF INPUT 50 Ω

A device under test (DUT) can be connected to the R&S FSW to provide RF input which is then analyzed. The DUT is connected to the instrument's RF INPUT via a cable equipped with an appropriate connector.

Risk of instrument damage

Do not overload the input. For maximum allowed values, see the data sheet. For AC-coupling, a DC input voltage of 50 V must never be exceeded. For DC-coupling, DC voltage must not be applied at the input. In both cases, noncompliance will destroy the input mixers.


Rear Panel View

Getting Started > Instrument Tour > Rear Panel View
Rear Panel View

This figure shows the rear panel view of the R&S FSW. The individual elements are described in more detail in the subsequent sections.

Rear panel view
1 = Removable system hard drive
2 = AC Power Supply Connection and Main Power Switch
3 = DISPLAY PORT for external display
4 = DVI connector for external display
5 = LAN connector
6 = USB (DEVICE) connectors
7 = Bandwidth Extension 160 MHz/ 320 MHz/ 500 MHz with IF WIDE OUTPUT connector (option B160/ B320/B500)
8 = IF/VIDEO/DEMOD connector
9 = DIGITAL BASEBAND INPUT/OUTPUT connectors (option B17)
10 = TRIGGER 3 INPUT/OUTPUT connector
11 = SYNC TRIGGER OUTPUT/INPUT
12 = AUX PORT
13 = GPIB interface
14 = Analog baseband interface (option B71)
15 = External generator control (option B10)
16 = IF OUT (2GHz) connector, for models R&S FSW43/50/67 only
17 = OCXO external reference (option B4)
18 = REF INPUT/OUTPUT connectors
Contents
  • Removable System Hard Drive
  • AC Power Supply Connection and Main Power Switch
  • DISPLAY PORT and DVI
  • LAN
  • USB
  • Bandwidth Extension 160 MHz/ 320 MHz/ 500 MHz with IF WIDE OUTPUT Connector (R&S FSW-B160/-B320/-B500/-U160/-U320)
  • IF/VIDEO/DEMOD OUTPUT
  • IF OUTPUT (2 GHz)
  • Digital Baseband Interface (R&S FSW-B17) and R&S EX-IQ-BOX
  • TRIGGER 3 INPUT/ OUTPUT
  • SYNC TRIGGER OUTPUT/INPUT
  • AUX PORT
  • GPIB Interface
  • External Generator Control Option (R&S FSW-B10)
  • OCXO Option (R&S FSW-B4)
  • REF INPUT / REF OUTPUT


Removable System Hard Drive

Getting Started > Instrument Tour > Rear Panel View > Removable System Hard Drive
Removable System Hard Drive

The removable system hard drive contains all measurement data from the R&S FSW, allowing you to store the data securely in an external location.


AC Power Supply Connection and Main Power Switch

Getting Started > Instrument Tour > Rear Panel View > AC Power Supply Connection and Main Power Switch
AC Power Supply Connection and Main Power Switch

An AC power supply connector and main power switch are located in a unit on the rear panel of the instrument.

Main power switch function:

Position 1: The instrument is in operation.

Position O: The entire instrument is disconnected from the AC power supply.

For details refer to "Connecting the AC Power".


DISPLAY PORT and DVI

Getting Started > Instrument Tour > Rear Panel View > DISPLAY PORT and DVI
DISPLAY PORT and DVI

You can connect an external monitor or other display device to the R&S FSW to provide an enlarged display. Two different types of connectors are provided for this purpose:

  • DISPLAY PORT
  • DVI (Digital visual interface)

For details see "Connecting an External Monitor".


LAN

Getting Started > Instrument Tour > Rear Panel View > LAN
LAN

The LAN interface can be used to connect the R&S FSW to a local network for remote control, printouts or data transfer. The assignment of the RJ-45 connector supports twisted-pair category 5 UTP/STP cables in a star configuration (UTP stands for unshielded twisted pair, and STP for shielded twisted pair).

For details see "Network and Remote Operation".


USB

Getting Started > Instrument Tour > Rear Panel View > USB
USB

The rear panel provides four additional female USB (USB-A) connectors to connect devices like a keyboard, a mouse or a memory stick (see also "USB").

Furthermore, a male USB DEVICE connector (USB-B) is provided, for example for a printer.

All USB connectors support standard 2.0.


Bandwidth Extension 160 MHz/ 320 MHz/ 500 MHz with IF WIDE OUTPUT Connector (R&S FSW-B160/-B320/-B500/-U160/-U320)

Getting Started > Instrument Tour > Rear Panel View > Bandwidth Extension 160 MHz/ 320 MHz/ 500 MHz with IF WIDE OUTPUT Connector (R&S FSW-B160/-B320/-B500/-U160/-U320)
Bandwidth Extension 160 MHz/ 320 MHz/ 500 MHz with IF WIDE OUTPUT Connector (R&S FSW-B160/-B320/-B500/-U160/-U320)

The signal analysis bandwidth of the R&S FSW can be extended by a hardware option (R&S FSW-B160/-B320/-B500 or R&S FSW-U160/-U320). The bandwidth extension allows for a linear bandwidth up to a maximum of 160 MHz (with option B160/U160), 320 MHz (with option B320/U320), or 500 MHz (with option B500), with an output sample rate of up to 10 GHz. While the extension can be activated or deactivated manually in the R&S FSW base unit (I/Q Analyzer application), it is activated automatically in some applications that also support I/Q data analysis. See the application-specific documentation for details.

The bandwidth extension option R&S FSW-B320/-U320 requires a reference board revision 3.14 or higher.

The bandwidth extension option R&S FSW-B500 requires a reference board (1312.8075.06) revision 4.06 or higher and a motherboard 1313.4180.02 or 1313.7698.02.

Together with the bandwidth extension an additional IF output connector is provided (IF WIDE OUTPUT). As opposed to the default "IF/VIDEO/DEMOD OUTPUT" connector, the IF output frequency of the optional connector cannot be defined manually, but is determined automatically depending on the center frequency. For details on the used frequencies see the data sheet. The IF WIDE OUTPUT connector is used automatically when the bandwidth extension is activated (i.e. for bandwidths > 80 MHz).


IF/VIDEO/DEMOD OUTPUT

Getting Started > Instrument Tour > Rear Panel View > IF/VIDEO/DEMOD OUTPUT
IF/VIDEO/DEMOD OUTPUT

The female BNC connector can be used for various outputs:

  • Intermediate frequency (IF) output of approximately 20 MHz
  • Video output (1V)

Which output is provided is defined in the software (INPUT/OUTPUT key).

For details see "IF/VIDEO/DEMOD Output".


IF OUTPUT (2 GHz)

Getting Started > Instrument Tour > Rear Panel View > IF OUTPUT (2 GHz)
IF OUTPUT (2 GHz)

The female SMA connector is only available for instrument models R&S FSW43/50/67 and can be used to provide intermediate frequency (IF) output of approximately 2 GHz at a frequency of 2 GHz.

Output is activated in the software (INPUT/OUTPUT key).

For details see "IF/VIDEO/DEMOD Output".


Digital Baseband Interface (R&S FSW-B17) and R&S EX-IQ-BOX

Getting Started > Instrument Tour > Rear Panel View > Digital Baseband Interface (R&S FSW-B17) and R&S EX-IQ-BOX
Digital Baseband Interface (R&S FSW-B17) and R&S EX-IQ-BOX

The R&S FSW Digital Baseband Interface option (R&S FSW-B17) provides an online digital I/Q data interface on the rear panel of the instrument for input and output. The digital input and output can be enabled in the base unit or in one of the applications (where available).

Optionally, an R&S EX-IQ-BOX can be connected to the Digital Baseband Interface to convert signal properties and the transmission protocol of the R&S FSW into user-defined or standardized signal formats and vice versa.

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

For more information on the Digital Baseband Interface (R&S FSW-B17) and typical applications see the R&S FSW I/Q Analyzer User Manual.


TRIGGER 3 INPUT/ OUTPUT

Getting Started > Instrument Tour > Rear Panel View > TRIGGER 3 INPUT/ OUTPUT
TRIGGER 3 INPUT/ OUTPUT

The additional female BNC TRIGGER INPUT / OUTPUT connector can be used to receive a third external signal or to provide a signal to another device. The signal is TTL compatible (0 V / 5 V). You can control the connector usage in the "Trigger" settings (TRIG key).


SYNC TRIGGER OUTPUT/INPUT

Getting Started > Instrument Tour > Rear Panel View > SYNC TRIGGER OUTPUT/INPUT
SYNC TRIGGER OUTPUT/INPUT

The SYNC TRIGGER OUTPUT/INPUT connectors allow you to synchronize several devices (e.g. two R&S FSWs) with respect to the trigger signal, but also the reference frequency. A 100 MHz signal can be output as a trigger or reference signal to another device, and an external trigger or reference signal can be received at the input connector by the R&S FSW.


AUX PORT

Getting Started > Instrument Tour > Rear Panel View > AUX PORT
AUX PORT

The 9 pole SUB-D male connector provides control signals for controlling external devices. The voltage levels are of the TTL type (max. 5 V).

Pin | Signal | Description
1 | +5 V / max. 250 mA | Supply voltage for external circuits
2 to 7 | I/O | Control lines for user ports (see User manual)
8 | GND | Ground
9 | READY FOR TRIGGER | Signal indicating that the instrument is ready to receive a trigger signal (Low active = 0 V)
Short-circuit hazard

Always observe the designated pin assignment. A short-circuit may damage the instrument.


GPIB Interface

Getting Started > Instrument Tour > Rear Panel View > GPIB Interface
GPIB Interface

The GPIB interface is in compliance with IEEE488 and SCPI. A computer for remote control can be connected via this interface. To set up the connection, a shielded cable is recommended. For more details refer to "Setting Up Remote Control" in the User Manual.


External Generator Control Option (R&S FSW-B10)

Getting Started > Instrument Tour > Rear Panel View > External Generator Control Option (R&S FSW-B10)
External Generator Control Option (R&S FSW-B10)

The external generator control option provides an additional GPIB connector and AUX port.

The GPIB connector can be used to connect the external generator to the R&S FSW.

The AUX port is required for TTL synchronization, if supported by the generator. It is identical to the standard AUX port (see "AUX PORT").

For details on connecting an external generator see "External Generator Connections".


OCXO Option (R&S FSW-B4)

Getting Started > Instrument Tour > Rear Panel View > OCXO Option (R&S FSW-B4)
OCXO Option (R&S FSW-B4)

This option generates a 10 MHz reference signal with a very precise frequency. If installed, and if no external signal is used, this signal is used as an internal reference. It can also be used to synchronize other connected devices via the REF OUTPUT 10 MHz connector.

Warm-up time for OCXO

When the instrument is switched on, the OCXO requires an extended warm-up time (see data sheet). No warm-up time is required when starting from standby mode.


REF INPUT / REF OUTPUT

Getting Started > Instrument Tour > Rear Panel View > REF INPUT / REF OUTPUT
REF INPUT / REF OUTPUT

The REF INPUT connectors are used to provide an external reference signal to the R&S FSW.

The REF OUTPUT connectors can be used to provide an external reference signal (or the optional OCXO reference signal) from the R&S FSW to other devices that are connected to this instrument.

Various connectors are provided for different reference signals:

Connector | Reference signal | Usage
REF INPUT | 1...20 MHz 0...10 dBm | To provide an external reference signal on the R&S FSW.
REF OUTPUT | 1...20 MHz 0...10 dBm | To provide the same external reference signal received by the REF INPUT 1...20 MHZ connector to another device, when available.
REF OUTPUT | 10 MHz 10 dBm | To provide the internal reference signal from the R&S FSW to another device continuously. Also used to provide OCXO reference signal to another device.
REF INPUT | 100 MHz 0...10 dBm | To provide an external reference signal on the R&S FSW.
REF OUTPUT | 100 MHz 6 dBm | To provide a 100 MHz reference signal from the R&S FSW to another device.
REF OUTPUT | 640 MHz 16 dBm | To provide a 640 MHz reference signal from the R&S FSW to another device.
SYNC TRIGGER

The SYNC TRIGGER connector can also be used to synchronize the reference frequency on several devices (see "SYNC TRIGGER OUTPUT/INPUT").


Trying Out the Instrument

Getting Started > Trying Out the Instrument
Trying Out the Instrument

This chapter introduces the most important functions and settings of the R&S FSW step by step. The complete description of the functionality and its usage is given in the R&S FSW User Manual. Basic instrument operation is described in "Operating the Instrument".

Prerequisites
  • The instrument is set up, connected to the mains system, and started up as described in "Preparing for Use".

For these first measurements, you use the internal calibration signal, so you do not need any additional signal source or instruments. Try out the following:

Contents
  • Measuring a Basic Signal
  • Displaying a Spectrogram
  • Activating Additional Measurement Channels
  • Performing Sequential Measurements
  • Setting and Moving a Marker
  • Displaying a Marker Peak List
  • Zooming into the Display
  • Saving Settings
  • Printing and Saving Results


Measuring a Basic Signal

Getting Started > Trying Out the Instrument > Measuring a Basic Signal
Measuring a Basic Signal

We will start out by measuring a simple sinus wave, using the internal calibration signal as the input.

To display the internal 64 MHz calibration signal

  1. Press the PRESET key to start out in a defined instrument configuration.

  2. Press the SETUP key on the front panel.

  3. Tap the "Service" softkey.

  4. Tap the "Calibration Signal" tab.

  5. Tap the "Calibration Frequency RF" option. Leave the frequency at the default 64 MHz, with a narrowband spectrum.

    The calibration signal is now sent to the RF input of the R&S FSW. By default, a continuous frequency sweep is performed, so that the spectrum of the calibration signal is now displayed in the standard level versus frequency diagram.

    Calibration signal as RF input
Instrument warmup time

Note that the instrument requires an initial warmup time after switching it on. A message in the status bar ("Instrument warming up...") indicates that the operating temperature has not yet been reached. Wait till this message is no longer displayed before you start a measurement.

To optimize the display

In order to optimize the display for the calibration signal, we will adjust the main measurement settings.

  1. Set the center frequency to the calibration frequency:

    1. Tap the "Overview" softkey to display the configuration "Overview".

    2. Tap the "Frequency" button.

    3. In the "Center" field, enter 64 on the number pad on the front panel.

    4. Press the "MHz" key next to the number pad.

  2. Reduce the span to 20 MHz:

    1. In the "Span" field of the "Frequency" dialog box, enter 20 MHz.

    2. Close the "Frequency" dialog box.

  3. Set the reference level to -25 dBm:

    1. In the configuration "Overview", tap the "Amplitude" button.

    2. In the "Value" field of the "Amplitude" dialog box, enter -25 dBm.

    The display of the calibration signal is now improved. The maximum at the center frequency (=calibration frequency) of 64 MHz becomes visible.

    Calibration signal with optimized display settings


Displaying a Spectrogram

Getting Started > Trying Out the Instrument > Displaying a Spectrogram
Displaying a Spectrogram

In addition to the standard "level versus frequency" spectrum display, the R&S FSW also provides a spectrogram display of the measured data. A spectrogram shows how the spectral density of a signal varies over time. The x-axis shows the frequency, the y-axis shows the time. A third dimension, the power level, is indicated by different colors. Thus you can see how the strength of the signal varies over time for different frequencies.

  1. Tap the "Overview" softkey to display the general configuration dialog box.

  2. Tap the "Display Config" button.

    The SmartGrid mode is activated, and the evaluation bar with the available evaluation methods is displayed.

  3. Drag the "Spectrogram" icon from the evaluation bar to the diagram area. The blue area indicates that the new diagram would replace the previous spectrum display. Since we do not want to replace the spectrum, drag the icon to the lower half of the display to add an additional window instead.

    Adding a Spectrogram to the display

    Drop the icon.

  4. Close the SmartGrid mode by tapping the "Close" icon at the top right corner of the toolbar.

    You see the spectrogram compared to the standard spectrum display. Since the calibration signal does not change over time, the color of the frequency levels does not change over time, i.e. vertically. The legend at the top of the spectrogram window describes the power levels the colors represent.

Spectrogram of the calibration signal


Activating Additional Measurement Channels

Getting Started > Trying Out the Instrument > Activating Additional Measurement Channels
Activating Additional Measurement Channels

The R&S FSW features multiple measurement channels, i.e. you can define several measurement configurations in parallel and then switch between the channels automatically to perform the measurements sequentially. We will demonstrate this feature by activating additional measurement channels for a different frequency range, a zero span measurement, and an I/Q analysis.

To activate additional measurement channels

  1. Press the MODE key on the front panel.

  2. On the "New Channel" tab of the "Signal + Spectrum Mode" dialog box, tap the "Spectrum" button.

    Adding a new measurement channel

  3. Change the frequency range for this spectrum display:

    In the "Frequency" dialog box, set the center frequency to 500 MHz and the span to 1 GHz.

    Frequency spectrum of the calibration signal with a larger span

  4. Repeat the previous steps to activate a third Spectrum window.

    Change the frequency range for this spectrum display:

    In the "Frequency" dialog box, set the center frequency to 64 MHz and tap "Zero Span".

    As the calibration signal does not vary over time, the level versus time diagram displays a straight line.

    Time domain display of the calibration signal

  5. Create a new channel for I/Q analysis:

    1. Press the MODE key.

    2. Tap the "IQ Analyzer" button to activate a channel for the I/Q Analyzer application.

    3. Tap the "Display Config" softkey to activate the SmartGrid mode.

    4. Drag the "Real/Imag (I/Q)" icon from the evaluation bar to the SmartGrid.

      Inserting a Real/Imag diagram for I/Q analysis

    5. Close the SmartGrid mode.

    The "IQ Analyzer" channel displays the real and imaginary signal parts in separate windows.

To display the MultiView tab

An overview of all active channels is provided in the "MultiView" tab. This tab is always displayed and cannot be closed.

►

Tap the "MultiView" tab.

The "MultiView" tab


Performing Sequential Measurements

Getting Started > Trying Out the Instrument > Performing Sequential Measurements
Performing Sequential Measurements

Although only one measurement can be performed at any one time, the measurements configured in the active channels can be performed sequentially, that means: one after the other, automatically, either once or continuously.

  1. Tap the "Sequencer" icon in the toolbar.

  2. Toggle the "Sequencer" softkey in the "Sequencer" menu to "On".

    A continuous sequence is started, i.e. each channel measurement is performed one after the other until the Sequencer is stopped.

    "MultiView" tab with active Sequencer

    In figure ""MultiView" tab with active Sequencer", the "Spectrum 2" measurement is currently active (indicated by the "channel active" icon in the tab label).

  3. Stop the Sequencer by tapping the "Sequencer" softkey again.


Setting and Moving a Marker

Getting Started > Trying Out the Instrument > Setting and Moving a Marker
Setting and Moving a Marker

Markers are useful to determine the position of particular effects in the trace. The most common use is to determine a peak, which is the default setting when you activate a marker. We will set a marker on the peak in our first Spectrum measurement.

  1. In the "MultiView" tab, double-tap the "Spectrum" window (frequency sweep with spectrogram display) to return to the "Spectrum" channel.

  2. Tap the spectrum display to set the focus on that window.

  3. Press the "Split/Maximize" key on the front panel to maximize the spectrum window, as we currently do not need the spectrogram display.

  4. Press the "RUN SINGLE" key on the front panel to perform a single sweep so we have a fixed trace to set a marker on.

  5. Press the MKR key on the front panel to display the "Marker" menu.

    Marker 1 is activated and automatically set to the maximum of trace 1. The marker position and value is indicated in the diagram area as M1[1].

  6. Now you can move the marker by tapping and dragging it to a different position. The current position is indicated by a dotted blue line. Notice how the position and value change in the marker area of the diagram.


Displaying a Marker Peak List

Getting Started > Trying Out the Instrument > Displaying a Marker Peak List
Displaying a Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum automatically. We will display a marker peak list for the Spectrum 2 channel.

  1. Tap the "Spectrum 2" tab.

  2. Press the "RUN SINGLE" key on the front panel to perform a single sweep for which we will determine the peaks.

  3. Tap the "SmartGrid" icon in the toolbar to activate SmartGrid mode.

  4. Drag the "Marker Peak List" icon from the evaluation bar to the lower half of the display to add a new window for the peak list.

  5. Close the SmartGrid mode.

  6. To obtain a more conclusive peak list that does not contain noise peaks, for example, define a threshold that is higher than the noise floor:

    1. Press the MKR key on the front panel.

    2. Tap the "Marker Config" softkey in the "Marker" menu.

    3. Tap the "Search" tab in the "Marker" dialog box.

    4. In the "Threshold" field, enter -68 dBm.

    5. Tap the "State" box for "Threshold" to activate its use.

      Only peaks that are larger than -68 dBm will be included in the peak list.

    The marker peak list displays the determined peaks that are above the defined threshold.

    Marker Peak List


Zooming into the Display

Getting Started > Trying Out the Instrument > Zooming into the Display
Zooming into the Display

In order to analyze the areas around the peak levels in more detail, we will zoom into the top 3 peaks.

  1. Tap the "Multiple Zoom" icon in the toolbar.

    The icon is highlighted orange to indicate that multiple zoom mode is active.

  2. Tap the diagram near the first peak and drag your finger to the opposite corner of the zoom area. A white rectangle is displayed from the point where you tapped to the current position.

    Defining the zoom area

    When you remove your finger, the zoom area is enlarged in a second (sub-)window.

    Zoomed display around a peak

    Zoom mode is automatically disabled, and the default selection mode is restored, indicated by the highlighted "Selection mode" icon.

  3. In figure "Zoomed display around a peak" the enlarged peak is represented by a very thick trace. This is due to the insufficient number of sweep points. The missing sweep points for the zoomed display are interpolated, which provides poor results. To optimize the results, we will increase the number of sweep points from the default 1001 to 32001.

    1. Press the SWEEP key on the front panel.

    2. Tap the "Sweep Config" softkey in the "Sweep" menu.

    3. In the "Sweep Points" field, enter 32001.

    4. Press the RUN SINGLE key on the front panel to perform a new sweep with the increased number of sweep points.

    Zoomed peak with increased number of sweep points

    Note that the trace becomes much more precise.

  4. Tap the "Multiple Zoom" icon in the toolbar again and define a zoom area around markers M4, M5 and M6.

    Multiple zoom windows

  5. Tap the [image] "Multiple Zoom" icon in the toolbar again and define a zoom area around marker M8.

  6. To increase the size of the third zoom window, drag the "splitter" between the windows to the left or right or up or down.

    Enlarged zoom window


Saving Settings

Getting Started > Trying Out the Instrument > Saving Settings
Saving Settings

In order to restore the results of our measurements at a later time, we will store the instrument settings to a file.

To save the instrument settings to a file

  1. Tap the "Save" icon in the toolbar.

  2. Press the keyboard key on the front panel to display the online keyboard, as you will have to enter text in the next step.

  3. In the "Save" dialog box, tap the "File Name" field and enter MyMultiViewSetup using the keyboard.

    Keep the default "File Type" setting "Instrument with all Channels" to store the configuration of all channels.

    Saving the instrument settings to a file

  4. Tap the "Save" button.

    The file MyMultiViewSetup.dfl is stored in the default directory C:/R_S/instr/user.

To load stored instrument settings

You can restore the settings to the instrument at any time using the settings file.

  1. Press the PRESET button to restore the default instrument settings so you can check that the stored user settings are actually restored afterwards.

  2. Tap the "Load" icon in the toolbar.

  3. In the "Load" dialog box, select the MyMultiViewSetup.dfl file in the default directory C:/R_S/instr/user.

  4. Tap the "Load" button.

    All instrument settings are restored and the display should resemble figure "Enlarged zoom window", which shows the instrument display right before the settings were stored.


Printing and Saving Results

Getting Started > Trying Out the Instrument > Printing and Saving Results
Printing and Saving Results

Finally, after a successful measurement, we will document our results. First we will export the numeric trace data, then we will create a screenshot of the graphical display.

To export the trace data

  1. Press the TRACE key on the front panel.

  2. Tap the "Trace Config" softkey.

  3. Tap the "Trace Export" tab.

  4. Tap the "Export Trace to ASCII File" button.

  5. Enter the file name MyMultiViewResults.

    The trace data is stored to MyMultiViewResults.DAT

To create a screenshot of the display

  1. Tap the "Print immediately" icon in the toolbar.

    A screenshot of the current display is created. Note that the colors on the screen are inverted in the screenshot to improve printout results.

  2. In the "Save Hardcopy as Portable Network Graphics (PNG)" dialog box, enter a file name, e.g. MyMultiViewDisplay.

    The screenshot is stored to MyMultiViewDisplay.png.


Operating the Instrument

Getting Started > Operating the Instrument
Operating the Instrument

This chapter provides an overview on how to work with the R&S FSW. It describes what kind of information is displayed in the diagram area, how to operate the R&S FSW via the front panel keys and other interaction methods, and how to use the Online Help.

Contents
  • Understanding the Display Information
  • Accessing the Functionality
  • Changing the Focus
  • Entering Data
  • Displaying Results
  • Getting Help
  • Remote Control


Understanding the Display Information

Getting Started > Operating the Instrument > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram in Spectrum mode. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area with marker information
5 = Diagram footer with diagram-specific information, depending on measurement application
6 = Instrument status bar with error messages, progress bar and date/time display
Hiding elements in the display

You can hide some of the elements in the display, for example the status bar or channel bar, in order to enlarge the display area for the measurement results ("Setup > Display > Displayed Items").

For details see "Display Settings".

Contents
  • Channel Bar
  • Window Title Bar
  • Marker Information
  • Frequency and Span Information in Diagram Footer
  • Instrument and Status Information
  • Error Information


Channel Bar

Getting Started > Operating the Instrument > Understanding the Display Information > Channel Bar
Channel Bar

Using the R&S FSW you can handle several different measurement tasks (channels) at the same time (although they can only be performed asynchronously). For each channel, a separate tab is displayed on the screen. In order to switch from one channel display to another, simply select the corresponding tab.

Alternatively, if many tabs are displayed, select the tab selection list icon at the right end of the channel bar and select the channel you want to switch to from the list.

MultiView tab

An additional tab labelled "MultiView" provides an overview of all active channels at a glance. In the "MultiView" tab, each individual window contains its own channel bar with an additional button. Tap this button to switch to the corresponding channel display quickly.

Icons in the channel bar

The [image] icon on the tab label indicates that the displayed trace no longer matches the current instrument settings. This may be the case, for example, if a trace is frozen and the instrument settings are changed. As soon as a new measurement is performed, the icon disappears.

The [image] icon indicates that an error or warning is available for that measurement channel. This is particularly useful if the MultiView tab is displayed.

An orange "IQ" (in MSRA mode only) indicates that the results displayed in the MSRA application(s) no longer match the data captured by the MSRA Master. The "IQ" disappears after the results in the application(s) are refreshed.

The [image] icon indicates the currently active channel during an automatic measurement sequence (Sequencer functionality).

Channel-specific settings

Beneath the channel name, information on channel-specific settings for the measurement are displayed in the channel bar. Channel information varies depending on the active application.

In the Spectrum application, the R&S FSW shows the following settings:

Channel settings displayed in the channel bar in the Spectrum application

Ref Level

Reference level

m.+el.Att

Mechanical and electronic RF attenuation that has been set.

Ref Offset

Reference level offset

SWT

Sweep time that has been set.

If the sweep time does not correspond to the value for automatic coupling, a bullet is displayed in front of the field. The color of the bullet turns red if the sweep time is set below the value for automatic coupling. In addition, the UNCAL flag is shown. In this case, the sweep time must be increased.

Meas Time

Measurement time, calculated from analysis bandwidth and number of samples (for statistics measurements)

RBW

Resolution bandwidth that has been set.

If the bandwidth does not correspond to the value for automatic coupling, a green bullet appears in front of the field.

VBW

Video bandwidth that has been set.

If the bandwidth does not correspond to the value for automatic coupling, a green bullet is displayed in front of the field.

AnBW

Analysis bandwidth (for statistics measurements)

Compatible

Compatible device mode (FSP, FSU, default; default not displayed)

Mode

Indicates which sweep mode type is selected:

  • "Auto FFT": automatically selected FFT sweep mode
  • "Auto sweep": automatically selected swept sweep mode
  • "FFT": manually selected FFT sweep mode
Icons for individual settings

A bullet next to the setting indicates that user-defined settings are used, not automatic settings. A green bullet indicates this setting is valid and the measurement is correct. A red bullet indicates an invalid setting that does not provide useful results.

Common settings

In addition to the channel-specific settings, the channel bar above the diagram also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values. This information is displayed in gray font and only when applicable for the current measurement, as opposed to the channel-specific settings that are always displayed.

The following types of information may be displayed, if applicable.

Common settings displayed in the channel bar

SGL

The sweep is set to single sweep mode.

Sweep Count

The current signal count for measurement tasks that involve a specific number of subsequent sweeps

TRG

Trigger source

  • BBP: Baseband power (with Digital Baseband Interface R&S FSW-B17 only)
  • EXT: External
  • GP_0: General purpose bit (with Digital Baseband Interface R&S FSW-B17 only)
  • IFP: IF power (+trigger bandwidth)
  • PSE: Power sensor
  • RFP: RF power
  • SQL: Squelch
  • TIM: Time
  • VID: Video

6dB/RRC/CHN

Filter type for sweep bandwidth

see "Filter Type"

PA

The preamplifier is activated.

YIG Bypass

The YIG filter is deactivated.

GAT

The frequency sweep is controlled via the TRIGGER INPUT connector.

TDF

A transducer factor is activated.

75 Ω

The input impedance of the instrument is set to 75 Ω.

FRQ

A frequency offset ≠ 0 Hz is set.

DC/AC

An external DC or AC calibration signal is in use.

ExtMix <band>

An external mixer is activated for input (requires option R&S FSW-B21); the used band is also indicated

<NOR | APR>

Ext. Gen

An external generator is being controlled by the R&S FSW (requires option R&S FSW-B10).

NOR: the measurements are normalized with the results of the external generator calibration

APR (approximation): the measurements are normalized with the results of the external generator calibration; however, the measurement settings have been changed since calibration

If neither label is displayed, no calibration has been performed yet or normalization is not active.

LVL

A level offset is applied to the external generator signal (only if external generator control is active).


Window Title Bar

Getting Started > Operating the Instrument > Understanding the Display Information > Window Title Bar
Window Title Bar

Each channel in the R&S FSW display may contain several windows. Each window can display either a graph or a table as a result of the channel measurement. Which type of result evaluation is displayed in which window is defined in the display configuration (see "Displaying Results"). The window's title bar indicates which type of evaluation is displayed.

Trace Information in Window Title Bar

Information on the displayed traces is indicated in the window title bar.

Trace color |  | Color of trace display in diagram
Trace no. |  | Trace number (1 to 6)
Detector |  | Selected detector:
 | AP | AUTOPEAK detector
 | Pk | MAX PEAK detector
 | Mi | MIN PEAK detector
 | Sa | SAMPLE detector
 | Av | AVERAGE detector
 | Rm | RMS detector
 | QP | QUASIPEAK detector
Trace Mode |  | Sweep mode:
 | Clrw | CLEAR/WRITE
 | Max | MAX HOLD
 | Min | MIN HOLD
 | Avg | AVERAGE (Lin/Log/Pwr)
 | View | VIEW
Norm/NCor |  | Correction data is not used.


Marker Information

Getting Started > Operating the Instrument > Understanding the Display Information > Marker Information
Marker Information

Marker information is provided either in the diagram grid or in a separate marker table, depending on the configuration.

Marker information in diagram grid

Within the diagram grid, the x-axis and y-axis positions of the last 2 markers or delta markers that were set are displayed, if available, as well as their index. The value in the square brackets after the index indicates the trace to which the marker is assigned. (Example: M2[1] defines marker 2 on trace 1.) For more than 2 markers, a separate marker table is displayed beneath the diagram by default.

Marker information in marker table

In addition to the marker information displayed within the diagram grid, a separate marker table may be displayed beneath the diagram. This table provides the following information for all active markers:

Type | Marker type: N (normal), D (delta), T (temporary, internal), PWR (power sensor)
Ref | Reference (for delta markers)
Trc | Trace to which the marker is assigned
X-value | x-value of the marker
Y-value | y-value of the marker
Func | Activated marker or measurement function
Func .Result | Result of the active marker or measurement function

The functions are indicated with the following abbreviations:

FXD | Fixed reference marker
PHNoise | Phase noise measurement
CNT | Signal count
TRK | Signal tracking
NOIse | Noise measurement
MDepth | AM modulation depth
TOI | Third order intercept measurement


Frequency and Span Information in Diagram Footer

Getting Started > Operating the Instrument > Understanding the Display Information > Frequency and Span Information in Diagram Footer
Frequency and Span Information in Diagram Footer

The information in the diagram footer (beneath the diagram) depends on the current application.

For Spectrum mode, it contains the following information:

Label | Information
CF | Center frequency
Span | Frequency span (frequency domain display)
ms/ | Time per division (time domain display)
Pts | Number of sweep points or (rounded) number of currently displayed points in zoom mode


Instrument and Status Information

Getting Started > Operating the Instrument > Understanding the Display Information > Instrument and Status Information
Instrument and Status Information

Global instrument settings and functions (such as LXI configuration mode), the instrument status and any irregularities are indicated in the status bar beneath the diagram.

In the MultiView tab the status bar always displays the information for the currently selected measurement.

The following information is displayed:

Instrument status

The instrument is configured for operation with an external reference.

The optional Digital Baseband Interface (R&S FSW-B17) is being used for digital input

(See "Digital Input" )

The optional Digital Baseband Interface (R&S FSW-B17) is being used to provide digital output

(See "Digital Input" )

Progress

The progress of the current operation is displayed in the status bar.

In the MultiView tab, the progress bar indicates the status of the currently selected measurement, not the measurement currently being performed by a Sequencer, for example.

Date and time

The date and time settings of the instrument are displayed in the status bar.

Error messages

If errors or irregularities are detected, a keyword and an error message, if available, are displayed in the status bar.


Error Information

Getting Started > Operating the Instrument > Understanding the Display Information > Error Information
Error Information

If errors or irregularities are detected, a keyword and an error message, if available, are displayed in the status bar.

Depending on the type of message, the status message is indicated in varying colors.

Status bar information - color coding
Color | Type | Description
red | Fatal | A serious error occurred in the application; regular operation is no longer possible.
red | Error | An error occurred during a measurement, e.g. due to missing data or wrong settings, so that the measurement cannot be completed correctly.
orange | Warning | An irregular situation occurred during measurement, e.g. the settings no longer match the displayed results, or the connection to an external device was interrupted temporarily.
gray | Information | Information on the status of individual processing steps.
gray | Message | An event or state has occurred that may lead to an error during further operation.
green | No errors | No messages displayed.

If any error information is available for a measurement channel, the [image] icon is displayed next to the channel name. This is particularly useful when the MultiView tab is displayed, as the status bar in the MultiView tab always displays the information for the currently selected measurement only.

Furthermore, a status bit is set in the STATus:QUEStionable:EXTended:INFO register for the application concerned (see "STATus:QUEStionable:EXTended:INFO Register"). Messages of a specific type can be queried using the SYST:ERR:EXT? command, see SYSTem:​ERRor:​EXTended?.

The following keywords are used:

DATA ERR

For Digital Baseband Interface (R&S FSW-B17) only:

Error in digital I/Q input data

(See "Digital Input" )

FIFO OVLD

For Digital Baseband Interface (R&S FSW-B17) only:

Input sample rate from connected instrument is too high

(See "Digital Input" )

IF OVLD

Overload of the IF signal path after the input mixer.

  • Increase the reference level.

INPUT OVLD

The signal level at the RF input connector exceeds the maximum.

The RF input is disconnected from the input mixer to protect the device. In order to re-enable measurement, decrease the level at the RF input connector and reconnect the RF input to the mixer input.

( See "RF Input Protection").

LOUNL

Error in the instrument's frequency processing hardware was detected.

NO REF

Instrument was set to an external reference but no signal was detected on the reference input.

OVEN

OCXO reference frequency (option R&S FSW-B4) has not yet reached its operating temperature. The message usually disappears a few minutes after power has been switched on.

OVLD

Overload of the input signal path after the input mixer (only when RF INPUT path is NOT used, e.g. for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71)).

  • Reduce the input level.

PLL UNLOCK

For Digital Baseband Interface (R&S FSW-B17) only:

Error in digital I/Q input data

(See "Digital Input" )

RF OVLD

Overload of the input mixer.

  • Increase the RF attenuation (for RF input).
  • Reduce the input level (for digital input)

UNCAL

One of the following conditions applies:

  • Correction data has been switched off.
  • No correction values are available, for example after a firmware update.
  • Record the correction data by performing a self alignment
    (For details refer to "Alignment Settings").

WRONG_FW

The firmware version is out-of-date and does not support the currently installed hardware. Until the firmware version is updated, this error message is displayed and self-alignment fails.

(For details refer to "Firmware Updates").


Accessing the Functionality

Getting Started > Operating the Instrument > Accessing the Functionality
Accessing the Functionality

All tasks necessary to operate the instrument can be performed using this user interface. Apart from instrument specific keys, all other keys that correspond to an external keyboard (e.g. arrow keys, ENTER key) operate conform to Microsoft.

For most tasks, there are at least 2 alternative methods to perform them:

  • Using the touchscreen
  • Using other elements provided by the front panel, e.g. the keypad, rotary knob, or arrow and position keys.

The measurement and instrument functions and settings can be accessed by selecting one of the following elements:

  • System and function keys on the front panel of the instrument
  • Softkeys on the touchscreen
  • Context-sensitive menus for specific elements on the touchscreen
  • Icons on the tool bar in the touchscreen
  • Displayed setting on the touchscreen


Changing the Focus

Getting Started > Operating the Instrument > Changing the Focus
Changing the Focus

Any selected function is always performed on the currently focused element in the display, e.g. a dialog field, diagram, or table row. Which element is focused is indicated by a blue frame (diagram, window, table) or is otherwise highlighted (softkey, marker etc.). Moving the focus is most easily done by tapping on the element on the touchscreen. Alternatively, use the "Tab" key on the on-screen keyboard or the rotary knob to move the focus from one element to the next on the display.

To move the focus between any displayed diagrams or tables in a window, press the "Change focus" key on the front panel. The focus moves from the diagram to the first table to the next table etc. and then back to the diagram, within the same window.

In fullscreen mode, where a single window is displayed in full size on the screen, this key switches the focus (and the display) from one active window to the next.


Entering Data

Getting Started > Operating the Instrument > Entering Data
Entering Data

Data can be entered in dialog boxes using one of the following methods:

  • Using the touchscreen, via the online keyboard
  • Using other elements provided by the front panel, e.g. the keypad, rotary knob, or navigation keys
    The rotary knob acts like the ENTER key when it is pressed.
  • Using a connected external keyboard
Particularities in Windows dialog boxes

In some cases, e.g. if you want to install a printer, original Windows dialog boxes are used. In these dialog boxes, the rotary knob and function keys do not work. Use the touchscreen instead.

Contents
  • Entering Numeric Parameters
  • Entering Alphanumeric Parameters


Entering Numeric Parameters

Getting Started > Operating the Instrument > Entering Data > Entering Numeric Parameters
Entering Numeric Parameters

If a field requires numeric input, the keypad provides only numbers.

  1. Enter the parameter value using the keypad, or change the currently used parameter value by using the rotary knob (small steps) or the UP or DOWN keys (large steps).

  2. After entering the numeric value via keypad, press the corresponding unit key.

    The unit is added to the entry.

  3. If the parameter does not require a unit, confirm the entered value by pressing the ENTER key or any of the unit keys.

    The editing line is highlighted in order to confirm the entry.


Entering Alphanumeric Parameters

Getting Started > Operating the Instrument > Entering Data > Entering Alphanumeric Parameters
Entering Alphanumeric Parameters

If a field requires alphanumeric input, you can use the on-screen keyboard to enter numbers and (special) characters (see "On-screen Keyboard").

Alternatively, you can use the keypad. Every alphanumeric key represents several characters and one number. The decimal point key (.) represents special characters, and the sign key (-) toggles between capital and small letters. For the assignment refer to table "Keys for alphanumeric parameters".

Entering numbers and (special) characters via the keypad

  1. Press the key once to enter the first possible value.

  2. All characters available via this key are displayed.

  3. To choose another value provided by this key, press the key again, until your desired value is displayed.

  4. With every key stroke the next possible value of this key is displayed. If all possible values have been displayed, the series starts with the first value again. For information on the series refer to table "Keys for alphanumeric parameters".

  5. To change from capital to small letters and vice versa, press the sign key (-).

  6. When you have chosen the desired value, wait for 2 seconds (to use the same key again), or start the next entry by pressing another key.

Entering a blank
►

Press the "Space" bar, or press the "0" key and wait 2 seconds.

Correcting an entry:

  1. Using the arrow keys, move the cursor to the right of the entry you want to delete.

  2. Press the BACKSPACE key.

    The entry to the left of the cursor is deleted.

  3. Enter your correction.

Completing the entry
►

Press the ENTER key or the rotary knob.

Aborting the entry
►

Press the ESC key.

The dialog box is closed without changing the settings.

Keys for alphanumeric parameters
Key name (upper inscription) | Series of (special) characters and number provided
7 | 7 µ Ω ° € ¥ $ ¢
8 | A B C 8 Ä ÆÅ Ç
9 | D E F 9 É
4 | G H I 4
5 | J K L 5
6 | M N O 6 Ň Ö
1 | P Q R S 1
2 | T U V 2 Ü
3 | W X Y Z 3
0 | <blank> 0 – @ + / \ < > = % &
. | . * : _ , ; " ' ? ( ) #
– | <toggles between capital and small letters>


Displaying Results

Getting Started > Operating the Instrument > Displaying Results
Displaying Results

The R&S FSW provides several instrument applications for different analysis tasks and different types of signals, e.g. 3G FDD, I/Q analysis or basic spectrum analysis. For each application, a new measurement channel is created and displayed in a separate tab on the screen.

The results of a measurement channel can be evaluated in many different ways, both graphically and numerically. For each evaluation method the results are displayed in a separate window in the tab.

The R&S FSW allows you to configure the display to suit your specific requirements and optimize analysis.

Contents
  • Activating and Deactivating Channels
  • Laying out the Result Display with the SmartGrid
  • Changing the Size of Windows
  • Switching Between a Split and Maximized Window Display
  • Changing the Display


Activating and Deactivating Channels

Getting Started > Operating the Instrument > Displaying Results > Activating and Deactivating Channels
Activating and Deactivating Channels

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application. Whenever you switch channels, the corresponding measurement settings are restored. Each channel is displayed in a separate tab on the screen.

An additional tab ("MultiView") provides an overview of all currently active channels at once.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

To start a new channel

  1. Select the MODE key.

  2. In the "Mode" dialog box, select the required application on the "New Channel" tab.

    A new tab is displayed for the new channel.

Remote command:

INSTrument:​CREate[:​NEW]/ INSTrument:​CREate:​DUPLicate

To change the application in an active channel

  1. Select the tab of the channel you want to change.

  2. Select the MODE key.

  3. In the "Mode" dialog box, select the new application to be displayed on the "Replace Current Channel" tab.

    The selected application is displayed in the current channel.

Remote command:

INSTrument:​CREate:​REPLace

To close a measurement channel
► | Select the "Close" icon on the tab of the measurement channel.
 | The tab is closed, any running measurements are aborted, and all results for that channel are deleted.
Remote command:

INSTrument:​DELete


Laying out the Result Display with the SmartGrid

Getting Started > Operating the Instrument > Displaying Results > Laying out the Result Display with the SmartGrid
Laying out the Result Display with the SmartGrid

Measurement results can be evaluated in many different ways, for example graphically, as summary tables, statistical evaluations etc. Each type of evaluation is displayed in a separate window in the channel tab. Up to 16 individual windows can be displayed per measurement channel (i.e. per tab). To arrange the diagrams and tables on the screen, the Rohde & Schwarz SmartGrid function helps you find the target position simply and quickly.

(For details on evaluation methods see "Basic Evaluation Methods".)

Principally, the layout of the windows on the screen is based on an underlying grid, the SmartGrid. However, the SmartGrid is dynamic and flexible, allowing for many different layout possibilities. The SmartGrid functionality provides the following basic features:

  • Windows can be arranged in columns or in rows, or in a combination of both.
  • Windows can be arranged in up to four rows and four columns.
  • Windows are moved simply by dragging them to a new position on the screen, possibly changing the layout of the other windows, as well.
  • All evaluation methods available for the currently selected measurement are displayed as icons in the evaluation bar. If the evaluation bar contains more icons than can be displayed at once on the screen, it can be scrolled vertically. The same evaluation method can be displayed in multiple windows simultaneously.
  • New windows are added by dragging an evaluation icon from the evaluation bar to the screen. The position of each new window depends on where you drop the evaluation icon in relation to the existing windows.
  • All display configuration actions are only possible in SmartGrid mode. When SmartGrid mode is activated, the evaluation bar replaces the current softkey menu display. When the SmartGrid mode is deactivated again, the previous softkey menu display is restored.
Contents
  • Background Information: The SmartGrid Principle
  • How to Activate SmartGrid Mode
  • How to Add a New Result Window
  • How to Close a Result Window
  • How to Arrange the Result Windows


Background Information: The SmartGrid Principle

Getting Started > Operating the Instrument > Displaying Results > Laying out the Result Display with the SmartGrid > Background Information: The SmartGrid Principle
Background Information: The SmartGrid Principle
SmartGrid display

During any positioning action, the underlying SmartGrid is displayed. Different colors and frames indicate the possible new positions. The position in the SmartGrid where you drop the window determines its position on the screen.

Moving a window in SmartGrid mode

The brown area indicates the possible "drop area" for the window, i.e. the area in which the window can be placed. A blue area indicates the (approximate) layout of the window as it would be if the icon were dropped at the current position. The frames indicate the possible destinations of the new window with respect to the existing windows: above/below, right/left or replacement (as illustrated in figure "SmartGrid window positions"). If an existing window would be replaced, the drop area is highlighted in a darker color shade.

Positioning the window

The screen can be divided into up to four rows. Each row can be split into up to four columns, where each row can have a different number of columns. However, rows always span the entire width of the screen and may not be interrupted by a column. A single row is available as the drop area for the window in the SmartGrid. The row can be split into columns, or a new row can be inserted above or below the existing row (if the maximum of 4 has not yet been reached).

SmartGrid window positions
1 = Insert row above or below the existing row
2 = Create a new column in the existing row
3 = Replace a window in the existing row
SmartGrid functions

Once the evaluation icon has been dropped, icons in each window provide delete and move functions.

The "Move" icon allows you to move the position of the window, possibly changing the size and position of the other displayed windows.

The "Delete" icon allows you to close the window, enlarging the display of the remaining windows.


How to Activate SmartGrid Mode

Getting Started > Operating the Instrument > Displaying Results > Laying out the Result Display with the SmartGrid > How to Activate SmartGrid Mode
How to Activate SmartGrid Mode

All display configuration actions are only possible in SmartGrid mode. In SmartGrid mode the evaluation bar replaces the current softkey menu display. When the SmartGrid mode is deactivated again, the previous softkey menu display is restored.

►

To activate SmartGrid mode, do one of the following:

  • Select the "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the configuration "Overview".
  • Select the "Display Config" softkey from the MEAS CONFIG menu.

The SmartGrid functions and the evaluation bar are displayed.

To close the SmartGrid mode and restore the previous softkey menu select the "Close" icon in the right-hand corner of the toolbar, or press any key on the front panel.


How to Add a New Result Window

Getting Started > Operating the Instrument > Displaying Results > Laying out the Result Display with the SmartGrid > How to Add a New Result Window
How to Add a New Result Window

Each type of evaluation is displayed in a separate window. Up to 16 individual windows can be displayed per measurement channel (i.e. per tab).

  1. Activate SmartGrid mode.

    All evaluation methods available for the currently selected measurement are displayed as icons in the evaluation bar.

  2. Select the icon for the required evaluation method from the evaluation bar.

    If the evaluation bar contains more icons than can be displayed at once on the screen, it can be scrolled vertically. Touch the evaluation bar between the icons and move it up or down until the required icon appears.

  3. Drag the required icon from the evaluation bar to the SmartGrid, which is displayed in the diagram area, and drop it at the required position. (See "How to Arrange the Result Windows" for more information on positioning the window).

Remote command:

LAYout:​ADD[:​WINDow]? / LAYout:​WINDow<n>:​ADD?


How to Close a Result Window

Getting Started > Operating the Instrument > Displaying Results > Laying out the Result Display with the SmartGrid > How to Close a Result Window
How to Close a Result Window
►

To close a window, activate SmartGrid mode and select the "Delete" icon for the window.

Remote command:

LAYout:​REMove[:​WINDow] / LAYout:​WINDow<n>:​REMove


How to Arrange the Result Windows

Getting Started > Operating the Instrument > Displaying Results > Laying out the Result Display with the SmartGrid > How to Arrange the Result Windows
How to Arrange the Result Windows

  1. Select an icon from the evaluation bar or the "Move" icon for an existing evaluation window.

  2. Drag the evaluation over the SmartGrid.

    A blue area shows where the window will be placed.

  3. Move the window until a suitable area is indicated in blue.

  4. Drop the window in the target area.

    The windows are rearranged to the selected layout, and "Delete" and "Move" icons are displayed in each window.

  5. To close a window, select the corresponding "Delete" icon.

Remote command:

LAYout:​REPLace[:​WINDow] / LAYout:​WINDow<n>:​REPLace


Changing the Size of Windows

Getting Started > Operating the Instrument > Displaying Results > Changing the Size of Windows
Changing the Size of Windows

Each channel tab may contain several windows to evaluate the measurement results using different methods. A "splitter" allows you to change the size of neighboring windows.

The splitters are not available in SmartGrid mode.

►

To change the size of two neighboring windows, drag the splitter between the windows in either direction.


Switching Between a Split and Maximized Window Display

Getting Started > Operating the Instrument > Displaying Results > Switching Between a Split and Maximized Window Display
Switching Between a Split and Maximized Window Display

To get an overview of the results, displaying several windows at the same time may be helpful. However, the individual windows may become rather small. In this case it is useful to maximize an individual window to the entire screen temporarily in order to analyze the results in more detail.

To switch between a split and a maximized display without having to close and re-open windows, press the SPLIT/MAXIMIZE key on the front panel. In maximized display, the currently focused window is maximized. In split display, all active windows are displayed.


Changing the Display

Getting Started > Operating the Instrument > Displaying Results > Changing the Display
Changing the Display

The display can be optimized for your individual needs. The following display functions are available and are described in detail in "Display Settings" and "Common Analysis and Display Functions".

  • Displaying a simulation of the entire front panel of the instrument on the screen ("Front Panel")
  • Displaying the main function hardkeys in a separate window on the screen ("Mini Front Panel")
  • Hiding or showing various screen elements
  • Selecting a display theme and colors
  • Changing the display update rate
  • Activating or deactivating the touch-sensitivity of the screen
  • Zooming into the diagram


Getting Help

Getting Started > Operating the Instrument > Getting Help
Getting Help

If any questions or problems concerning the R&S FSW arise, an extensive online help system is provided on the instrument and can be consulted at any time. The help system is context-sensitive and provides information specifically for the current operation or setting to be performed. In addition, general topics provide an overview on complete tasks or function groups as well as background information.

Contents
  • Calling Up Help
  • Using the Help Window


Calling Up Help

Getting Started > Operating the Instrument > Getting Help > Calling Up Help
Calling Up Help

The online help can be opened at any time by selecting one of the "Help" icons on the toolbar or by pressing the F1 key on an external or the online keyboard.

Calling context-sensitive help
►

To display the "Help" dialog box for the currently focused screen element, e.g. a softkey or a setting in an opened dialog box, select the "Help" icon on the toolbar.

The "Help" dialog box "View" tab is displayed. A topic containing information about the focused screen element is displayed.

If no context-specific help topic is available, a more general topic or the "Contents" tab is displayed.

For standard Windows dialog boxes (e.g. File Properties, Print dialog etc.), no context-sensitive help is available.

►

To display a help topic for a screen element not currently focused:

  1. Select the "Help pointer" icon on the toolbar.

    The pointer changes its shape to a "?" and an arrow.

  2. Select the screen element to change the focus.

A topic containing information about the selected (now focused) screen element is displayed.


Using the Help Window

Getting Started > Operating the Instrument > Getting Help > Using the Help Window
Using the Help Window
The Help window contains several tabs:
  • "View" - shows the selected help topic
  • "Contents" - contains a table of help contents
  • "Index" - contains index entries to search for help topics
  • "Search" - provides text search
The Help toolbar provides some buttons:
  • To browse the topics in the order of the table of contents: Up arrow = previous topic, Down arrow = next topic
  • To browse the topics visited before: Left arrow = back, Right arrow = forward
  • To increase or decrease the font

To navigate the Help, use the touchscreen. Alternatively, you can also use the navigation keys on the front panel.

To search for a topic in the index

The index is sorted alphabetically. You can browse the list, or search for entries in the list.

  1. Switch to the "Index" tab.

  2. Select the "Keyboard" icon besides the entry field.

  3. Enter the first characters of the keyword you are interested in.

    The entries containing these characters are displayed.

  4. Double-tap the suitable index entry.

    The "View" tab with the corresponding help topic is displayed.

To search topics for a text string

  1. Switch to the "Search" tab.

  2. Select the "Keyboard" icon besides the entry field.

  3. Enter the string you want to find.

    If you enter several strings with blanks between, topics containing all words are found (same as AND operator).

    For advanced search, consider the following:
    • To find a defined string of several words, enclose it in quotation marks. For example, a search for "trigger qualification" finds all topics with exactly "trigger qualification". A search for trigger qualification finds all topics that contain the words trigger and qualification.
    • Use "Match whole word" and "Match case" to refine the search.
    • Use operators AND, OR, and NOT.
To close the Help window
►

Select the "Close" icon in the upper right corner of the help window.

Or:

Press the ESC key on the front panel.


Remote Control

Getting Started > Operating the Instrument > Remote Control
Remote Control

In addition to working with the R&S FSW interactively, located directly at the instrument, it is also possible to operate and control it from a remote PC. Various methods for remote control are supported:

  • Connecting the instrument to a (LAN) network (see "Setting Up a Network (LAN) Connection")
  • Using the LXI browser interface in a LAN network
  • Using the Windows Remote Desktop application in a LAN network
  • Connecting a PC via the GPIB interface

How to configure the remote control interfaces is described in the User Manual.

The R&S FSW is delivered with IECWIN installed, the auxiliary remote control tool provided free of charge by R&S.

For details on the IECWIN tool, see the "Network and Remote Control" chapter of the R&S FSW User Manual.

Contents
  • Using the LXI Browser Interface in a LAN
  • Remote Desktop Connection
  • Connecting a PC via the GPIB Interface


Using the LXI Browser Interface in a LAN

Getting Started > Operating the Instrument > Remote Control > Using the LXI Browser Interface in a LAN
Using the LXI Browser Interface in a LAN

LAN eXtensions for Instrumentation (LXI) is an instrumentation platform for measuring instruments and test systems that is based on standard Ethernet technology. LXI is intended to be the LAN-based successor to GPIB, combining the advantages of Ethernet with the simplicity and familiarity of GPIB. The LXI browser interface allows for easy configuration of the LAN.

Restrictions

Only user accounts with administrator rights can make use of the LXI functionality. For details see "Login".


Remote Desktop Connection

Getting Started > Operating the Instrument > Remote Control > Remote Desktop Connection
Remote Desktop Connection

Remote Desktop is a Windows application which can be used to access and control the instrument from a remote computer through a LAN connection. While the instrument is in operation, the instrument screen contents are displayed on the remote computer, and Remote Desktop provides access to all of the applications, files, and network resources of the instrument. Thus, remote operation of the instrument is possible.

With Windows 7, Remote Desktop Client is part of the operating system. For other versions of Windows, Microsoft offers the Remote Desktop Client as an add-on.


Connecting a PC via the GPIB Interface

Getting Started > Operating the Instrument > Remote Control > Connecting a PC via the GPIB Interface
Connecting a PC via the GPIB Interface

A GPIB interface is integrated on the rear panel of the instrument. You can set the GPIB address and the ID response string. The GPIB language is set as SCPI by default but can be changed to emulate other instruments. By connecting a PC to the R&S FSW via the GPIB connection you can send remote commands to control and operate the instrument.


Applications and Operating Modes

The R&S FSW provides several applications for different analysis tasks and different types of signals, e.g. W-CDMA, I/Q analysis or basic spectrum analysis. When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application. Each channel is displayed in a separate tab on the screen.

The maximum number may be limited further by the available memory on the instrument.

Independent vs correlating measurements

With the conventional R&S FSW Signal and Spectrum Analyzer you can perform several different measurements almost simultaneously. However, the individual measurements are independent of each other - each application captures and evaluates its own set of data, regardless of what the other applications do.

In some cases it may be useful to analyze the exact same input data using different applications. For example, imagine capturing data from a base station and analyzing the RF spectrum in the Analog Demodulation application. If a spur or an unexpected peak occurs, you may want to analyze the same data in the I/Q Analyzer to see the real and imaginary components of the signal and thus detect the reason for the irregular signal. Normally when you switch to a different application, evaluation is performed on the data that was captured by that application, and not the previous one. In our example that would mean the irregular signal would be lost. Therefore, a second operating mode is available in the R&S FSW: Multi-Standard Radio Analyzer (MSRA) mode.

Multi-Standard Radio Analyzer mode

In Multi-Standard Radio Analyzer (MSRA) mode, data acquisition is performed once as an I/Q measurement, and the captured data is then evaluated by any number of applications for different radio standards. Data acquisition and global configuration settings are controlled globally, while the evaluation and display settings can be configured individually for each application. Using the Multi-Standard Radio Analyzer, unwanted correlations between different signal components using different transmission standards can be detected. Thus, for example, an irregularity in a GSM burst can be examined closer in the R&S FSW 3G FDD BTS (W-CDMA) application to reveal dependencies like a change in the EVM value.

Multi-Standard Realtime mode

In order to combine the advantages of the MSRA mode with its correlated measurements and the gapless results provided by realtime measurements, a third operating mode has been introduced: the Multi-Standard Realtime (MSRT) mode. This operating mode is only available if one of the realtime options (R&S FSW-K85R/-U85R/-K160R/-U160R) is installed.

In this operating mode, data acquisition is performed once as a realtime measurement, and the captured data is then evaluated by any number of applications. Thus, a realtime measurement triggered with a frequency mask can be performed, and the results can be evaluated in the VSA application, for example, to detect the cause of a frequency exception.

Distinct operating modes

Although the applications themselves are identical in all operating modes, the handling of the data between applications is not. Thus, the operating mode determines which applications are available and active. Whenever you change the operating mode, the currently active measurement channels are closed. The default operating mode is Signal and Spectrum Analyzer mode; however, the presetting can be changed.

Remote command:

INST:MODE SAN, see INSTrument:​MODE

Switching between applications
When you switch to a new application, a set of parameters is passed on from the current application to the new one:
  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Contents
  • R&S MultiView
  • Available Applications
  • Selecting the Operating Mode
  • Starting an Application
  • Running a Sequence of Measurements


R&S MultiView

Applications and Operating Modes > R&S MultiView
R&S MultiView

Each application is displayed in a separate tab. An additional tab ("MultiView") provides an overview of all currently active channels at a glance. In the "MultiView" tab, each individual window contains its own channel bar with an additional button. Select this button to switch to the corresponding channel display quickly.


Available Applications

Applications and Operating Modes > Available Applications
Available Applications

The R&S FSW provides some applications in the base unit while others are available only if the corresponding firmware options are installed. Not all R&S FSW applications are supported in MSRA or MSRT mode. For an overview of supported MSRA applications see the R&S FSW MSRA User Manual. For an overview of supported MSRA applications see the R&S FSW Realtime Spectrum Application and MSRT Operating Mode User Manual.

Spectrogram application

Spectrogram measurements are not a separate application, but rather a trace evaluation method, thus they are available as an evaluation method for the Display Configuration, not by creating a new channel. Spectrograms are configured and activated in the "Trace" settings. See "Working with Spectrograms" for details.

Duplicate current Channel

For a description of the "Duplicate current Channel" button see "Duplicate Current Channel".

└ Spectrum
└ 1xEV-DO BTS
└ 1xEV-DO MS
└ 3G FDD BTS
└ 3G FDD UE
└ Analog Demodulation
└ cdma2000 BTS
└ cdma2000 MS
└ (Multi-Carrier) Group Delay
└ GSM
└ I/Q Analyzer
└ LTE
└ Noise Figure
└ Phase Noise
└ Pulse Measurements
└ Realtime Spectrum
└ TD-SCDMA BTS
└ TD-SCDMA UE
└ Transient Analysis
└ Vector Signal Analysis (VSA)
└ WLAN


Spectrum

Applications and Operating Modes > Available Applications > Spectrum
Spectrum

In the Spectrum application the provided functions correspond to those of a conventional spectrum analyzer. The analyzer measures the frequency spectrum of the RF input signal over the selected frequency range with the selected resolution and sweep time, or, for a fixed frequency, displays the waveform of the video signal. This application is used in the initial configuration.

For details see "Measurements".

Remote command:

INST:SEL SAN, see INSTrument[:​SELect]


1xEV-DO BTS

Applications and Operating Modes > Available Applications > 1xEV-DO BTS
1xEV-DO BTS

The 1xEV-DO BTS application requires an instrument equipped with the 1xEV-DO BTS Measurements option, R&S FSW-K84. This application provides test measurements for 1xEV-DO BTS downlink signals (base station signals) according to the test specification.

For details refer to "Welcome to the Applications" .

Remote command:

INST:SEL BDO, see INSTrument[:​SELect]


1xEV-DO MS

Applications and Operating Modes > Available Applications > 1xEV-DO MS
1xEV-DO MS

The 1xEV-DO MS application requires an instrument equipped with the 1xEV-DO MS Measurements option, R&S FSW-K85. This application provides test measurements for 1xEV-DO MS uplink signals (mobile signals) according to the test specification.

For details refer to "Welcome to the Applications" .

Remote command:

INST:SEL MDO, see INSTrument[:​SELect]


3G FDD BTS

Applications and Operating Modes > Available Applications > 3G FDD BTS
3G FDD BTS

The 3G FDD BTS application requires an instrument equipped with the 3GPP Base Station Measurements option, R&S FSW-K72. This application provides test measurements for W-CDMA downlink signals (base station signals) according to the test specification.

For details refer to "Welcome to the 3GPP FDD Applications" .

Remote command:

INST:SEL BWCD, see INSTrument[:​SELect]


3G FDD UE

Applications and Operating Modes > Available Applications > 3G FDD UE
3G FDD UE

The 3G FDD UE application requires an instrument equipped with the 3GPP User Equipment Measurements option, R&S FSW-K73. This application provides test measurements for W-CDMA uplink signals (mobile signals) according to the test specification.

For details refer to "Welcome to the 3GPP FDD Applications" .

Remote command:

INST:SEL MWCD, see INSTrument[:​SELect]


Analog Demodulation

Applications and Operating Modes > Available Applications > Analog Demodulation
Analog Demodulation

The Analog Demodulation application requires an instrument equipped with the corresponding optional software. This application provides measurement functions for demodulating AM, FM, or PM signals.

For details refer to "Welcome to the Analog Demodulation Application" .

Remote command:

INST:SEL ADEM, see INSTrument[:​SELect]


cdma2000 BTS

Applications and Operating Modes > Available Applications > cdma2000 BTS
cdma2000 BTS

The cdma2000 BTS application requires an instrument equipped with the cdma2000 BTS Measurements option, R&S FSW-K82. This application provides test measurements for cdma2000 BTS downlink signals (base station signals) according to the test specification.

For details refer to "Welcome to the Applications" .

Remote command:

INST:SEL BC2K, see INSTrument[:​SELect]


cdma2000 MS

Applications and Operating Modes > Available Applications > cdma2000 MS
cdma2000 MS

The cdma2000 MS application requires an instrument equipped with the cdma2000 MS Measurements option, R&S FSW-K83. This application provides test measurements for cdma2000 MS uplink signals (mobile signals) according to the test specification.

For details refer to "Welcome to the Applications" .

Remote command:

INST:SEL MC2K, see INSTrument[:​SELect]


(Multi-Carrier) Group Delay

Applications and Operating Modes > Available Applications > (Multi-Carrier) Group Delay
(Multi-Carrier) Group Delay

The Group Delay application requires an instrument equipped with the Multi-Carrier Group Delay Measurements option R&S FSW-K17. This application provides a Multi-Carrier Group Delay measurement.

For details refer to "Welcome to the Multi-Carrier Group Delay Application" .

Remote command:

INST:SEL MCGD, see INSTrument[:​SELect]


GSM

Applications and Operating Modes > Available Applications > GSM
GSM

The GSM application requires an instrument equipped with the GSM Measurements option R&S FSW-K10. This application provides GSM measurements.

For details refer to "Welcome to the GSM Application" .

Remote command:

INST:SEL GSM, see INSTrument[:​SELect]


I/Q Analyzer

Applications and Operating Modes > Available Applications > I/Q Analyzer
I/Q Analyzer

The I/Q Analyzer application provides measurement and display functions for I/Q data.

For details refer to "Welcome to the I/Q Analyzer Application" .

Remote command:

INST:SEL IQ, see INSTrument[:​SELect]


LTE

Applications and Operating Modes > Available Applications > LTE
LTE

The LTE application requires an instrument equipped with the LTE Measurements option R&S FSW-K10. This application provides LTE measurements.

For details refer to "Welcome to the LTE Measurement Application" .

Remote command:

INST:SEL LTE, see INSTrument[:​SELect]


Noise Figure

Applications and Operating Modes > Available Applications > Noise Figure
Noise Figure

The Noise Figure application requires an instrument equipped with the Noise Figure Measurements option R&S FSW-K30. This application provides noise figure measurements.

For details refer to "Welcome to the Noise Figure Measurement Application" .

Remote command:

INST:SEL NOISE, see INSTrument[:​SELect]


Phase Noise

Applications and Operating Modes > Available Applications > Phase Noise
Phase Noise

The Phase Noise application requires an instrument equipped with the Phase Noise Measurements option, R&S FSW-K40. This application provides measurements for phase noise tests.

For details refer to "Welcome to the Phase Noise Measurement Application" .

Remote command:

INST:SEL PNOISE, see INSTrument[:​SELect]


Pulse Measurements

Applications and Operating Modes > Available Applications > Pulse Measurements
Pulse Measurements

The Pulse application requires an instrument equipped with the Pulse Measurements option, R&S FSW-K6. This application provides measurement functions for pulsed signals.

For details refer to "Welcome to the Pulse Measurements Application" .

Remote command:

INST:SEL PULSE, see INSTrument[:​SELect]


Realtime Spectrum

Applications and Operating Modes > Available Applications > Realtime Spectrum
Realtime Spectrum

The Realtime Spectrum application requires an instrument equipped with the Realtime Spectrum option, R&S FSW-K160R. This application provides realtime measurement functions.

For details refer to "Welcome to the Realtime Extension" .

Remote command:

INST:SEL RTIM, see INSTrument[:​SELect]


TD-SCDMA BTS

Applications and Operating Modes > Available Applications > TD-SCDMA BTS
TD-SCDMA BTS

The TD-SCDMA BTS application requires an instrument equipped with the TD-SCDMA Base Station Measurements option, R&S FSW-K76. This application provides test measurements for TD-SCDMA downlink signals (base station signals) according to the test specification.

For details refer to "Welcome to the TD-SCDMA Applications" .

Remote command:

INST:SEL BTDS, see INSTrument[:​SELect]


TD-SCDMA UE

Applications and Operating Modes > Available Applications > TD-SCDMA UE
TD-SCDMA UE

The TD-SCDMA UE application requires an instrument equipped with the TD-SCDMA User Equipment Measurements option, R&S FSW-K77. This application provides test measurements for TD-SCDMA uplink signals (mobile signals) according to the test specification.

For details refer to "Welcome to the TD-SCDMA Applications" .

Remote command:

INST:SEL MTDS, see INSTrument[:​SELect]


Transient Analysis

Applications and Operating Modes > Available Applications > Transient Analysis
Transient Analysis

The Transient Analysis application requires an instrument equipped with the Transient Analysis option, R&S FSW-K60. This application provides measurements and evaluations for Transient Analysis.

For details refer to "Welcome to the Transient Analysis Application" .

Remote command:

INST:SEL TA, see INSTrument[:​SELect]


Vector Signal Analysis (VSA)

Applications and Operating Modes > Available Applications > Vector Signal Analysis (VSA)
Vector Signal Analysis (VSA)

The VSA application requires an instrument equipped with the Vector Signal Analysis option, R&S FSW-K70. This application provides measurements and evaluations for Vector Signal Analysis.

For details refer to "Welcome to the Vector Signal Analysis Application" .

Remote command:

INST:SEL DDEM, see INSTrument[:​SELect]


WLAN

Applications and Operating Modes > Available Applications > WLAN
WLAN

The WLAN application requires an instrument equipped with the WLAN option, R&S FSW-K91/91n. This application provides measurements and evaluations according to the WLAN IEEE 802.11 standards.

For details refer to "Welcome to the WLAN Application" .

Remote command:

INST:SEL WLAN, see INSTrument[:​SELect]


Selecting the Operating Mode

Applications and Operating Modes > Selecting the Operating Mode
Selecting the Operating Mode

The default operating mode is Signal and Spectrum Analyzer mode, however, the presetting can be changed.

(See "General Configuration Settings").

Both the operating mode and the application can be selected in the "Mode" dialog box which is displayed when you press the MODE key.

To switch the operating mode, select the corresponding tab.

The remote commands required to perform these tasks are described in "Selecting the Operating Mode and Application".

To activate the Signal and Spectrum Analyzer operating mode

  1. Select the MODE key.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Signal and Spectrum Analyzer" tab.

  3. Confirm the message informing you that you are changing operating modes.

    The R&S FSW stores and closes all active measurement channels in the current operating mode, then opens a new measurement channel for the Signal and Spectrum Analyzer operating mode.

    Note: when you return to the previous operating mode, the stored configuration of all measurement channels is restored.

    The default Spectrum measurement channel is displayed and the Sequencer is automatically activated in continuous mode (see "Running a Sequence of Measurements").


Starting an Application

Applications and Operating Modes > Starting an Application
Starting an Application

The default application in Signal and Spectrum Analyzer mode is a Spectrum measurement.

The application can be selected in the "Mode" dialog box which is displayed when you press the MODE key.

To select an application, select the corresponding button.

The available applications are described in "Available Applications".

The measurement channels are labeled with their default name. If that name already exists, a sequential number is added. In remote control, the name of the measurement channel can be changed. For details and an overview of default names see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Switching between applications
When you switch to a new application, a set of parameters is passed on from the current application to the new one:
  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

To deactivate a channel, simply close the corresponding tab.

The remote commands required to perform these tasks are described in "Selecting the Operating Mode and Application".

└ New Channel
└ Replace Current Channel
└ Duplicate Current Channel


New Channel

Applications and Operating Modes > Starting an Application > New Channel
New Channel

The applications selected on this tab are started in a new channel, i.e. a new tab in the display.

For a list of available applications see "Available Applications"

Remote command:

INSTrument:​CREate[:​NEW]

INSTrument[:​SELect]


Replace Current Channel

Applications and Operating Modes > Starting an Application > Replace Current Channel
Replace Current Channel

The applications selected on this tab are started in the currently displayed channel, replacing the current application.

For a list of available applications see "Available Applications"

Remote command:

INSTrument:​CREate:​REPLace


Duplicate Current Channel

Applications and Operating Modes > Starting an Application > Duplicate Current Channel
Duplicate Current Channel

The currently active channel can be duplicated, i.e. a new measurement channel of the same type and with the identical measurement settings is started. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

This command is not available if the MSRA Master channel is selected.

Remote command:

INSTrument:​CREate:​DUPLicate


Running a Sequence of Measurements

Applications and Operating Modes > Running a Sequence of Measurements
Running a Sequence of Measurements

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

The Sequencer function is slightly different in MSRA or MSRT operating mode. For details see the R&S FSW MSRA User Manual or the R&S FSW Realtime Spectrum Application and MSRT Operating Mode User Manual.

Contents
  • The Sequencer Concept
  • Sequencer Settings
  • How to Set Up the Sequencer


The Sequencer Concept

Applications and Operating Modes > Running a Sequence of Measurements > The Sequencer Concept
The Sequencer Concept

The instrument can only be in one specific channel at any time. Thus, only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided, which changes the application of the instrument as required. If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. For each individual measurement, the sweep count is considered. Thus, each measurement may consist of several sweeps. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

Sequencer modes

Three different Sequencer modes are available:

  • Single Sequence
    Similar to single sweep mode; each measurement is performed once, until all measurements in all active channels have been performed.
  • Continuous Sequence
    Similar to continuous sweep mode; the measurements in each active channel are performed one after the other, repeatedly, in the same order, until sequential operation is stopped. This is the default Sequencer mode.
  • Channel-defined Sequence
    First, a single sequence is performed. Then, only channels in continuous sweep mode are repeated continuously.
Example: Sequencer procedure

Assume the following active channel definition:

Tab name | application | Sweep mode | Sweep count
Spectrum | Spectrum | Cont. Sweep | 5
Spectrum 2 | Spectrum | Single Sweep | 6
Spectrum 3 | Spectrum | Cont. Sweep | 2
IQ Analyzer | IQ Analyzer | Single Sweep | 7

For single Sequence, the following sweeps will be performed:

5x Spectrum, 6x Spectrum 2, 2 x Spectrum 3, 7x IQ Analyzer

For continuous Sequence, the following sweeps will be performed:

5x Spectrum, 6x Spectrum 2, 2 x Spectrum 3, 7x IQ Analyzer,

5x Spectrum, 6x Spectrum 2, 2 x Spectrum 3, 7x IQ Analyzer,

...

For channel-defined Sequence, the following sweeps will be performed:

5x Spectrum, 6x Spectrum 2, 2 x Spectrum 3, 7x IQ Analyzer,

5x Spectrum, 2 x Spectrum 3,

5x Spectrum, 2 x Spectrum 3,

...

RUN SINGLE/RUN CONT and Single Sweep/Sweep Continuous keys

While the Sequencer is active, the RUN SINGLE and RUN CONT keys control the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode, while RUN CONT starts the Sequencer in continuous mode.

The "Single Sweep" and "Continuous Sweep" softkeys control the sweep mode for the currently selected channel only; the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer. A channel in continuous sweep mode is swept repeatedly.


Sequencer Settings

Applications and Operating Modes > Running a Sequence of Measurements > Sequencer Settings
Sequencer Settings

The "Sequencer" menu is available from the toolbar.

Sequencer in MSRA/MSRT mode

In MSRA/MSRT operating mode and in the Realtime Spectrum Application, the Sequencer behaves slightly differently.

For details on the MSRA operating mode see "Using the Sequencer in MSRA Mode" . For details on the MSRT operating mode see "Using the Sequencer in MSRT Mode" . For details on the Realtime Spectrum application see "Multiple Measurement Channels and Sequencer Function" .

└ Sequencer State
└ Sequencer Mode


Sequencer State

Applications and Operating Modes > Running a Sequence of Measurements > Sequencer Settings > Sequencer State
Sequencer State

Activates or deactivates the Sequencer. If activated, sequential operation according to the selected Sequencer mode is started immediately.

For details on sequential operation see "The Sequencer Concept".

Remote command:

SYSTem:​SEQuencer

INITiate:​SEQuencer:​IMMediate

INITiate:​SEQuencer:​ABORt


Sequencer Mode

Applications and Operating Modes > Running a Sequence of Measurements > Sequencer Settings > Sequencer Mode
Sequencer Mode

Defines how often which measurements are performed. The currently selected mode softkey is highlighted blue. During an active Sequencer process, the selected mode softkey is highlighted orange.

For details on sequential operation see "Sequencer modes".

"Single Sequence"

Each measurement is performed once, until all measurements in all active channels have been performed.

"Continuous Sequence"

The measurements in each active channel are performed one after the other, repeatedly, in the same order, until sequential operation is stopped.

This is the default Sequencer mode.

In MSRT mode, the behaviour of a continuous sequence depends on the trigger setting, see "Using the Sequencer in MSRT Mode" .

"Channel-defined Sequence"

First, a single sequence is performed. Then, only channels in continuous sweep mode are repeated.

Channel-defined sequence is not available in Multi-Standard Realtime (MSRT) operating mode.

Remote command:

INITiate:​SEQuencer:​MODE


How to Set Up the Sequencer

Applications and Operating Modes > Running a Sequence of Measurements > How to Set Up the Sequencer
How to Set Up the Sequencer

In order to perform the configured measurements consecutively, a Sequencer function is provided.

  1. Configure a channel for each measurement configuration as required, including the sweep mode.

  2. In the toolbar, select the "Sequencer" icon.

    The "Sequencer" menu is displayed.

  3. Toggle the "Sequencer" softkey to "On".

    A continuous sequence is started immediately.

  4. To change the Sequencer mode and start a new sequence immediately, select the corresponding mode softkey, or press the RUN SINGLE or RUN CONT key.

    The measurements configured in the currently active channels are performed one after the other in the order of the tabs until the Sequencer is stopped.

    The result displays in the individual channels are updated as the measurements are performed.

To stop the Sequencer
►

To stop the Sequencer temporarily, press the highlighted RUN SINGLE or RUN CONT key (not for a channel-defined sequence). To continue the Sequencer, press the key again.

To stop the Sequencer permanently, select the "Sequencer" icon in the toolbar and toggle the "Sequencer" softkey to "Off".


Measurements

In the Spectrum application, the R&S FSW provides a variety of different measurement functions.

  • Basic measurements - measure the spectrum of your signal or watch your signal in time domain
  • Power measurements - calculate the powers involved in modulated carrier signals
  • Emission measurements - detect unwanted signal emission
  • Statistic measurements - evaluate the spectral distribution of the signal
  • Special measurements - provide characteristic values of the signal
  • EMI measurements - detect electromagnetic interference in the signal
Measurements on I/Q-based data

The I/Q Analyzer application (not Master) in MSRA mode can also perform measurements on the captured I/Q data in the time and frequency domain.

The measurements are configured using the same settings as described here for the Spectrum application.

The results, however, may differ slightly as hardware settings are not adapted automatically as for the Spectrum application. Additionally, the analysis interval used for the measurement is indicated as in all MSRA applications.

For more information see "Measurements in the Time and Frequency Domain" .

Contents
  • Available Measurement Functions
  • Basic Measurements
  • Channel Power and Adjacent-Channel Power (ACLR) Measurement
  • Carrier-to-Noise Measurements
  • Occupied Bandwidth Measurement (OBW)
  • Spectrum Emission Mask (SEM) Measurement
  • Spurious Emissions Measurement
  • Statistical Measurements (APD, CCDF)
  • Time Domain Power Measurement
  • Harmonic Distortion Measurement
  • Third Order Intercept (TOI) Measurement
  • AM Modulation Depth Measurement
  • Electromagnetic Interference (EMI) Measurement (R&S FSW-K54)


Available Measurement Functions

Measurements > Available Measurement Functions
Available Measurement Functions

The measurement function determines which settings, functions and evaluation methods are available in the R&S FSW. The various measurement functions are described in detail here. They are selected in the "Select Measurement" dialog box that is displayed when you press the MEAS key or select "Select Measurement" in the configuration "Overview".

When you select a measurement function, the measurement is started with its default settings immediately and the corresponding measurement configuration menu is displayed. The measurement configuration menu can be displayed at any time by pressing the MEAS CONFIG key.

Measurements on I/Q-based data

The I/Q Analyzer application (not Master) in MSRA mode can also perform measurements on the captured I/Q data in the time and frequency domain.

The measurements are configured using the same settings as described here for the Spectrum application.

The results, however, may differ slightly as hardware settings are not adapted automatically as for the Spectrum application. Additionally, the analysis interval used for the measurement is indicated as in all MSRA applications.

For more information see "Measurements in the Time and Frequency Domain" .

The easiest way to configure measurements is using the configuration "Overview", see "Configuration Overview".

In addition to the measurement-specific parameters, the general parameters can be configured as usual, see "Common Measurement Settings". Many measurement functions provide special result displays or evaluation methods; however, in most cases the general evaluation methods are also available, see "Common Analysis and Display Functions".

After a preset, the R&S FSW performs a basic frequency sweep.

└ Frequency Sweep
└ Zero Span
└ I/Q Analyzer (MSRA mode only)
└ Ch Power ACLR
└ C/N, C/No
└ OBW
└ Spectrum Emission Mask
└ Spurious Emissions
└ APD
└ CCDF
└ Time Domain Power
└ TOI
└ AM Mod Depth
└ Harmonic Distortion
└ EMI
└ Marker Functions
└ All Functions Off


Frequency Sweep

Measurements > Available Measurement Functions > Frequency Sweep
Frequency Sweep

A common frequency sweep of the input signal over a specified span. Can be used for general purposes to obtain basic measurement results such as peak levels and spectrum traces. The "Frequency" menu is displayed. This is the default measurement if no other function is selected.

Use the general measurement settings to configure the measurement, e.g. via the "Overview" (see "Common Measurement Settings").

Remote command:

[SENSe:​]FREQuency:​STARt, [SENSe:​]FREQuency:​STOP

INITiate[:​IMMediate]

INITiate:​CONTinuous


Zero Span

Measurements > Available Measurement Functions > Zero Span
Zero Span

A sweep in the time domain at the specified (center) frequency, i.e. the frequency span is set to zero. The display shows the time on the x-axis and the signal level on the y-axis, as on an oscilloscope. On the time axis, the grid lines correspond to 1/10 of the current sweep time.

Use the general measurement settings to configure the measurement, e.g. via the "Overview" (see "Common Measurement Settings").

Most result evaluations can also be used for zero span measurements, although some functions (e.g. markers) may work slightly differently and some may not be available. If so, this will be indicated in the function descriptions (see "Common Analysis and Display Functions").

Remote command:

[SENSe:​]FREQuency:​SPAN

INITiate[:​IMMediate]

INITiate:​CONTinuous


I/Q Analyzer (MSRA mode only)

Measurements > Available Measurement Functions > I/Q Analyzer (MSRA mode only)
I/Q Analyzer (MSRA mode only)

The I/Q Analyzer application (not Master) in MSRA mode can also perform measurements on the captured I/Q data in the time and frequency domain. This button is provided in order to return to the conventional I/Q analysis functions.

The I/Q Analyzer application is described in "Configuration" .

Remote command:

CALCulate:​IQ:​MODE


Ch Power ACLR

Measurements > Available Measurement Functions > Ch Power ACLR
Ch Power ACLR

Measures the active channel or adjacent-channel power for one or more carrier signals, depending on the current measurement configuration, and opens a submenu to configure the channel power measurement.

For details see "Channel Power and Adjacent-Channel Power (ACLR) Measurement".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

CALC:MARK:FUNC:POW:SEL ACP, see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect

Results:

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

"Measuring the Channel Power and ACLR"


C/N, C/No

Measurements > Available Measurement Functions > C/N, C/No
C/N, C/No

Measures the carrier/noise ratio and opens a submenu to configure the measurement. Measurements without (C/N) and measurements with reference to the bandwidth (C/No) are possible.

Carrier/noise measurement is only possible in the frequency domain (span > 0).

For details see "Carrier-to-Noise Measurements".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

CALC:MARK:FUNC:POW:SEL CN | CN0 CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect

Results:

CALC:MARK:FUNC:POW:RES? CN | CN0, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

"Measuring the Carrier-to-Noise Ratio"


OBW

Measurements > Available Measurement Functions > OBW
OBW

Measures the occupied bandwidth, i.e. the bandwidth which must contain a defined percentage of the power, and opens a submenu to configure the measurement. For details see "Occupied Bandwidth Measurement (OBW)".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

OBW measurement is only possible in the frequency domain (span > 0).

Remote command:

CALC:MARK:FUNC:POW:SEL OBW CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect

Results:

CALC:MARK:FUNC:POW:RES? OBW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

"Measuring the Occupied Bandwidth"


Spectrum Emission Mask

Measurements > Available Measurement Functions > Spectrum Emission Mask
Spectrum Emission Mask

Activates a Spectrum Emission Mask (SEM) measurement, which monitors compliance with a spectral mask, and opens a submenu to configure the measurement.

For details see "Spectrum Emission Mask (SEM) Measurement".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

SENS:SWE:MODE ESP, see [SENSe:​]SWEep:​MODE

Results:

CALC:MARK:FUNC:POW:RES? CPOW | PPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:LIM:FAIL?, see CALCulate:​LIMit<k>:​FAIL?

TRACe<n>[:​DATA]

TRACe<n>[:​DATA]:​X?

"Measuring the Spectrum Emission Mask"


Spurious Emissions

Measurements > Available Measurement Functions > Spurious Emissions
Spurious Emissions

Activates the Spurious Emissions measurement, which monitors unwanted RF products outside the assigned frequency band generated by an amplifier. A submenu to configure the measurement is opened.

For details see "Spurious Emissions Measurement".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

SENS:SWE:MODE LIST, see [SENSe:​]SWEep:​MODE

Results:

TRAC:DATA? SPUR, see TRACe<n>[:​DATA]

"Measuring Spurious Emissions"


APD

Measurements > Available Measurement Functions > APD
APD

Measures the amplitude probability density (APD) and opens a submenu to configure the measurement.

For details see "Statistical Measurements (APD, CCDF)".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

CALCulate<n>:​STATistics:​APD[:​STATe]

Results:

CALCulate:​STATistics:​RESult<t>?


CCDF

Measurements > Available Measurement Functions > CCDF
CCDF

Measures the complementary cumulative distribution function (CCDF) and opens a submenu to configure the measurement.

For details see "Statistical Measurements (APD, CCDF)".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

CALCulate<n>:​STATistics:​CCDF[:​STATe]

Results:

CALCulate<n>:​STATistics:​CCDF:​X<t>?

CALCulate:​STATistics:​RESult<t>?


Time Domain Power

Measurements > Available Measurement Functions > Time Domain Power
Time Domain Power

Measures the power in zero span and opens a submenu to configure the measurement. For details see "Basic Measurements".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

A time domain power measurement is only possible for zero span.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary[:​STATe]

"Measuring the Time Domain Power"


TOI

Measurements > Available Measurement Functions > TOI
TOI

Measures the third order intercept point and opens a submenu to configure the measurement.

For details see "Third Order Intercept (TOI) Measurement".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​TOI[:​STATe]

CALCulate<n>:​MARKer<m>:​FUNCtion:​TOI:​RESult?

"Measuring the Third Order Intercept Point"


AM Mod Depth

Measurements > Available Measurement Functions > AM Mod Depth
AM Mod Depth

Measures the AM modulation depth and opens a submenu to configure the measurement. An AM-modulated carrier is required in the window to ensure correct operation.

For details see "AM Modulation Depth Measurement".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​MDEPth[:​STATe]

CALCulate<n>:​MARKer<m>:​FUNCtion:​MDEPth:​RESult?

"Measuring the AM Modulation Depth"


Harmonic Distortion

Measurements > Available Measurement Functions > Harmonic Distortion
Harmonic Distortion

Measures the harmonic distortion, including the total harmonic distortion, and opens a submenu to configure the measurement.

For details see "Harmonic Distortion Measurement".

For details on measurents on I/Q data see "Measurements in the Time and Frequency Domain" .

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics[:​STATe]

First harmonic: CALCulate<n>:​MARKer<m>:​FUNCtion:​CENTer.

THD: CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics:​DISTortion?

List of harmonics: CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics:​LIST?

"Measuring the Harmonic Distortion"


EMI

Measurements > Available Measurement Functions > EMI
EMI

Detects electromagnetic interference in the signal, and opens a submenu to configure the measurement.

For details see "Electromagnetic Interference (EMI) Measurement (R&S FSW-K54)".

Remote command:

CALCulate:​MARKer:​FUNCtion:​FMEasurement:​STATe

"Remote Commands for EMI Measurements"


Marker Functions

Measurements > Available Measurement Functions > Marker Functions
Marker Functions

In addition to the measurement functions, some special marker functions are available. See "Marker Function Configuration".


All Functions Off

Measurements > Available Measurement Functions > All Functions Off
All Functions Off

Switches off all measurement functions and returns to a basic frequency sweep.


Basic Measurements

Measurements > Basic Measurements
Basic Measurements

Basic measurements are common sweeps in the time or frequency domain which provide an overview of the basic input signal characteristics.

If no other measurement function is selected, or if all measurement functions are switched off, the R&S FSW performs a basic frequency or time sweep. After a preset, a frequency sweep is performed.

Use the general measurement settings to configure the measurement, e.g. via the "Overview" (see "Common Measurement Settings").

Contents
  • How to Perform a Basic Sweep Measurement
  • Measurement Examples - Measuring a Sinusoidal Signal
  • Measurement Example – Measuring Levels at Low S/N Ratios
  • Measurement Examples - Measuring Signal Spectra with Multiple Signals
  • Measurement Examples in Zero Span


How to Perform a Basic Sweep Measurement

Measurements > Basic Measurements > How to Perform a Basic Sweep Measurement
How to Perform a Basic Sweep Measurement
To perform one or more single sweeps

  1. Configure the frequency and span to be measured ("Frequency" dialog box, see "Frequency and Span Configuration").

  2. Configure the number of sweeps to be performed in a single measurement ("Sweep Config" dialog box, see "Sweep/Average Count").

  3. If necessary, configure how the signal is processed internally ("Bandwidth" dialog box, see "Sweep Type").

  4. If necessary, configure a trigger for the measurement ("Trigger/Gate Settings" dialog box, see "Trigger and Gate Configuration").

  5. Define how the results are evaluated for display ("Trace" dialog box, see "Trace Settings").

  6. If necessary, configure the vertical axis of the display ("Amplitude" dialog box, see "Amplitude and Vertical Axis Configuration").

  7. To start the measurement, select one of the following:

    • RUN SINGLE key
    • "Single Sweep" softkey in the "Sweep" menu

    The defined number of sweeps are performed, then the measurement is stopped. While the measurement is running, the RUN SINGLE key is highlighted. To abort the measurement, press the RUN SINGLE key again. The key is no longer highlighted. The results are not deleted until a new measurement is started.

  8. To repeat the same number of sweeps without deleting the last trace, select the "Continue Single Sweep" softkey in the "Sweep" menu.

To start continuous sweeping

  1. If you want to average the trace or search for a maximum over more (or less) than 10 sweeps, configure the "Average/Sweep Count" ("Sweep Config" dialog box, see "Sweep/Average Count").

  2. To start the measurement, select one of the following:

    • RUN CONT key
    • "Continuous Sweep" softkey in the "Sweep" menu

    After each sweep is completed, a new one is started automatically. While the measurement is running, the RUN CONT key is highlighted. To stop the measurement, press the RUN CONT key again. The key is no longer highlighted. The results are not deleted until a new measurement is started.


Measurement Examples - Measuring a Sinusoidal Signal

Measurements > Basic Measurements > Measurement Examples - Measuring a Sinusoidal Signal
Measurement Examples - Measuring a Sinusoidal Signal

One of the most common measurement tasks that can be handled using a signal analyzer is determining the level and frequency of a signal. When measuring an unknown signal, you can usually start with the presettings.

High input values

If levels higher than +30 dBm (=1 W) are expected or are possible, a power attenuator must be inserted before the RF input of the analyzer. Otherwise, signal levels exceeding 30 dBm can damage the RF attenuator or the input mixer. The total power of all occurring signals must be taken into account.

Test setup
  • Connect the RF output of the signal generator to the RF input of the R&S FSW.
Signal generator settings (e.g. R&S SMU)
Frequency | 128 MHz
Level | -30 dBm
Contents
  • Measuring the Level and Frequency Using Markers
  • Measuring the Signal Frequency Using the Signal Counter


Measuring the Level and Frequency Using Markers

Measurements > Basic Measurements > Measurement Examples - Measuring a Sinusoidal Signal > Measuring the Level and Frequency Using Markers
Measuring the Level and Frequency Using Markers

The level and frequency of a sinusoidal signal can be measured easily using the marker function. The R&S FSW always displays its amplitude and frequency at the marker position. The frequency measurement uncertainty is determined by the reference frequency of the R&S FSW, the resolution of the marker frequency display and the number of sweep points.

  1. Select PRESET to reset the instrument.

  2. Connect the signal to be measured to the RF INPUT connector on the R&S FSW.

  3. Set the center frequency to 128 MHz.

  4. Reduce the frequency span to 1 MHz.

    Note: Coupled settings. When the frequency span is defined, the resolution bandwidth, the video bandwidth and the sweep time are automatically adjusted, because these functions are defined as coupled functions in the presettings.

  5. Select MKR to activate marker 1 and automatically set it to the maximum of the trace.

    The level and frequency values measured by the marker are displayed in the marker information at the top of the display.

    Note: Performing a peak search. When a marker is initially activated, it automatically performs the peak search function (as shown in the example).
    If a marker was already active, select the PEAK SEARCH key or the "Peak" softkey in the MKR > menu in order to set the currently active marker to the maximum of the displayed signal.

Contents
  • Increasing the Frequency Resolution
  • Setting the Reference Level


Increasing the Frequency Resolution

Measurements > Basic Measurements > Measurement Examples - Measuring a Sinusoidal Signal > Measuring the Level and Frequency Using Markers > Increasing the Frequency Resolution
Increasing the Frequency Resolution

The frequency resolution of the marker is determined by the resolution of the trace. A trace consists of 1001 trace points, i.e. if the frequency span is 1 MHz, each trace point represents a span of approximately 1 kHz. This corresponds to a maximum uncertainty of +/- 0.5 kHz.

You can increase the resolution of the trace by reducing the frequency span.

Reducing the frequency span to 10 kHz
► | Reduce the frequency span to 1 MHz.
 | The resolution of the trace is now approximately 10 Hz (10 kHz span / 1001 trace points), thus, the precision of the marker frequency display increases to approximately ±5 Hz.


Setting the Reference Level

Measurements > Basic Measurements > Measurement Examples - Measuring a Sinusoidal Signal > Measuring the Level and Frequency Using Markers > Setting the Reference Level
Setting the Reference Level

The reference level is the level at the upper limit of the diagram. To achieve the widest dynamic range possible for a spectrum measurement, use the entire level span of the R&S FSW. In other words, the highest level that occurs in the signal should be located at the top edge of the diagram ( = reference level) or immediately below it.

Low Reference Levels

If the selected reference level is lower than the highest signal that occurs in the spectrum, the signal path in the R&S FSW is overloaded.

In this case, the message "IFOVL" is displayed in the error message field.

In the presettings, the value of the reference level is 0 dBm. If the input signal is -30 dBm, the reference level can be reduced by 30 dB without causing the signal path to be overloaded.

Reducing the reference level by 30 dB
► | Set the reference level to -30 dBm.
 | The maximum of the trace is near the maximum of the measurement diagram. The increase in the displayed noise is not substantial. Thus, the distance between the signal maximum and the noise display (=dynamic range) has increased.
Setting the reference level with the help of a marker

You can also use a marker to shift the maximum value of the trace directly to the top edge of the diagram. If the marker is located at the maximum level of the trace (as in this example), the reference level can be moved to the marker level as follows:

  1. Press the MKR -> key.

  2. Select "Ref Lvl = Mkr Lvl".

    The reference level is set to the current marker level.


Measuring the Signal Frequency Using the Signal Counter

Measurements > Basic Measurements > Measurement Examples - Measuring a Sinusoidal Signal > Measuring the Signal Frequency Using the Signal Counter
Measuring the Signal Frequency Using the Signal Counter

The built-in signal counter allows you to measure the frequency more accurately than measuring it with the marker. The frequency sweep is stopped at the marker, and the R&S FSW measures the frequency of the signal at the marker position (see also "Performing a Highly Accurate Frequency Measurement (Signal Count)").

In the following example, the frequency of the generator at 128 MHz is shown using the marker.

Prerequisite

Precise frequency measurements require a precise reference frequency. Therefore, an external reference frequency from the signal generator is used. Connect the signal generator's "Ref OUT" connector to the analyzer's "Ref IN" connector.

  1. Select PRESET to reset the instrument.

  2. Set the center frequency to 128 MHz.

  3. Set the frequency span to 1 MHz.

  4. Select "Setup" > "Reference" > "External Reference 10 MHz" to activate the external reference frequency.

  5. Select MKR to activate marker 1 and automatically set it to the maximum of the trace.

    The level and the frequency of the marker are displayed in the marker results in the diagram or the marker table.

  6. Select MKR FUNC > "Signal Count" to activate the signal counter.

    The result of the signal counter is displayed in the marker results.

  7. If necessary, increase the resolution of the signal counter by selecting "Signal Count Resolution" (in the "Signal Count" menu).

Prerequisites for using the internal signal counter

In order to obtain a correct result when measuring the frequency with the internal signal counter, an RF sinusoidal signal or a spectral line must be available. The marker must be located more than 25 dB above the noise level to ensure that the specified measurement accuracy is adhered to.


Measurement Example – Measuring Levels at Low S/N Ratios

Measurements > Basic Measurements > Measurement Example – Measuring Levels at Low S/N Ratios
Measurement Example – Measuring Levels at Low S/N Ratios

The minimum signal level a signal analyzer can measure is limited by its intrinsic noise. Small signals can be swamped by noise and therefore cannot be measured. For signals that are just above the intrinsic noise, the accuracy of the level measurement is influenced by the intrinsic noise of the R&S FSW.

The displayed noise level of a signal analyzer depends on its noise figure, the selected RF attenuation, the selected reference level, the selected resolution and video bandwidth and the detector.

For details see:
  • "RF Attenuation"
  • "Reference Level"
  • "Separating Signals by Selecting an Appropriate Resolution Bandwidth"
  • "Smoothing the Trace Using the Video Bandwidth"
  • "Mapping Samples to Sweep Points with the Trace Detector"

This measurement example shows the different factors influencing the S/N ratio.

Signal generator settings (e.g. R&S SMU)
Frequency | 128 MHz
Level | -95 dBm

  1. Preset the R&S FSW.

  2. Set the center frequency to 128 MHz.

  3. Set the span to 100 MHz.

  4. Set the reference level to-30 dBm.

    The signal is measured with the auto peak detector and is completely hidden in the intrinsic noise of the R&S FSW.

    Sine wave signal with low S/N ratio

  5. To suppress noise spikes, average the trace. In the "Traces" configuration dialog, set the "Trace mode" to "Average" (see "Trace Mode").

    The traces of consecutive sweeps are averaged. To perform averaging, the R&S FSW automatically switches on the sample detector. The RF signal, therefore, can be more clearly distinguished from noise.

    RF sine wave signal with low S/N ratio with an averaged trace

  6. Instead of trace averaging, you can select a video filter that is narrower than the resolution bandwidth. Set the trace mode back to "Clear Write", then set the VBW to 10 kHz manually in the "Bandwidth" configuration dialog.

    The RF signal can be distinguished from noise more clearly.

    RF sine wave signal with low S/N ratio with a smaller video bandwidth

  7. By reducing the resolution bandwidth by a factor of 10, the noise is reduced by 10 dB. Set the RBW to 100 kHz.

    The displayed noise is reduced by approximately 10 dB. The signal, therefore, emerges from noise by about 10 dB. Compared to the previous setting, the video bandwidth has remained the same, i.e. it has increased relative to the smaller resolution bandwidth. The averaging effect of the video bandwidth is therefore reduced. The trace will be noisier.

    Reference signal at a smaller resolution bandwidth


Measurement Examples - Measuring Signal Spectra with Multiple Signals

Measurements > Basic Measurements > Measurement Examples - Measuring Signal Spectra with Multiple Signals
Measurement Examples - Measuring Signal Spectra with Multiple Signals
Contents
  • Separating Signals by Selecting the Resolution Bandwidth
  • Measuring the Modulation Depth of an AM-Modulated Carrier in the Frequency Domain
  • Measuring AM-Modulated Signals


Separating Signals by Selecting the Resolution Bandwidth

Measurements > Basic Measurements > Measurement Examples - Measuring Signal Spectra with Multiple Signals > Separating Signals by Selecting the Resolution Bandwidth
Separating Signals by Selecting the Resolution Bandwidth

A basic feature of a Signal and Spectrum Analyzer is the ability to separate the spectral components of a mixture of signals. The resolution at which the individual components can be separated is determined by the resolution bandwidth. Selecting a resolution bandwidth that is too large may make it impossible to distinguish between spectral components, i.e. they are displayed as a single component (see also "Separating Signals by Selecting an Appropriate Resolution Bandwidth").

Two signals with the same amplitude can be resolved if the resolution bandwidth is smaller than or equal to the frequency spacing of the signal. If the resolution bandwidth is equal to the frequency spacing, the spectrum display shows a level drop of 3 dB precisely in the center of the two signals. Decreasing the resolution bandwidth makes the level drop larger, which thus makes the individual signals clearer.

In this measurement example we will analyze two signals with a level of -30 dBm each and a frequency spacing of 30 kHz.

Test setup
Signal generator settings (e.g. R&S SMU)
 | Level | Frequency
Signal generator 1 | -30 dBm | 128,00 MHz
Signal generator 2 | -30 dBm | 128,03 MHz

  1. Select PRESET to reset the instrument.

  2. Set the center frequency to 128.015 MHz.

  3. Set the frequency span to 300 kHz.

  4. Set the resolution bandwidth to 30 kHz and the video bandwidth to 1 kHz.

    Note: Larger video bandwidths. The video bandwidth is set to 1 kHz in order to make the level drop in the center of the two signals clearly visible. At larger video bandwidths, the video voltage that results from envelope detection is not sufficiently suppressed. This produces additional voltages, which are visible in the trace, in the transition area between the two signals.

    Measurement of two equally-leveled RF sinusoidal signals with the resolution bandwidth which corresponds to the frequency spacing of the signals
    Matching generator and R&S FSW frequencies
    The level drop is located exactly in the center of the display only if the generator frequencies match the frequency display of the R&S FSW exactly. To achieve exact matching, the frequencies of the generators and the R&S FSW must be synchronized.

  5. Set the resolution bandwidth to 100 kHz.

    It is no longer possible to clearly distinguish the two generator signals.

    Measurement of two equally-leveled RF sinusoidal signals with a resolution bandwidth which is larger than their frequency spacing

  6. Set the resolution bandwidth to 1 kHz.

    The two generator signals are shown with high resolution. However, the sweep time becomes longer. At smaller bandwidths, the noise display decreases simultaneously (10 dB decrease in noise floor for a decrease in bandwidth by a factor of 10).

    Measurement of two equally-leveled RF sinusoidal signals with a resolution bandwidth (1 kHz) which is significantly smaller than their frequency spacing


Measuring the Modulation Depth of an AM-Modulated Carrier in the Frequency Domain

Measurements > Basic Measurements > Measurement Examples - Measuring Signal Spectra with Multiple Signals > Measuring the Modulation Depth of an AM-Modulated Carrier in the Frequency Domain
Measuring the Modulation Depth of an AM-Modulated Carrier in the Frequency Domain

In the frequency range display, the AM side bands can be resolved with a narrow bandwidth and measured separately. The modulation depth of a carrier modulated with a sinusoidal signal can then be measured. Since the dynamic range of a signal analyzer is very large, extremely small modulation depths can also be measured precisely. For this purpose, the R&S FSW provides measurement routines that output the modulation depth numerically in percent directly.

Test setup
Signal generator settings (e.g. R&S SMU)
Frequency | 128 MHz
Level | -30 dBm
Modulation | 50 % AM, 10 kHz AF

  1. Select PRESET to reset the instrument.

  2. Set the center frequency to 128 MHz.

  3. Set the frequency span to 50 kHz.

  4. Select MEAS > "AM Modulation Depth" to activate the modulation depth measurement.

    The R&S FSW automatically sets a marker to the carrier signal in the center of the diagram and one delta marker each to the upper and lower AM sidebands. The R&S FSW calculates the AM modulation depth from the level differences of the delta markers to the main marker and outputs the numeric value in the marker information.

Measurement of the AM modulation depth

The modulation depth is displayed as "MDepth". The frequency of the AF signal can be obtained from the frequency display of the delta marker.


Measuring AM-Modulated Signals

Measurements > Basic Measurements > Measurement Examples - Measuring Signal Spectra with Multiple Signals > Measuring AM-Modulated Signals
Measuring AM-Modulated Signals

The R&S FSW rectifies the RF input signal (that is, removes the negative parts) and displays it as a magnitude spectrum. The rectification also demodulates AM-modulated signals. The AF voltage can be displayed in zero span if the modulation sidebands fall within the resolution bandwidth.

Displaying the AF of an AM-modulated signal (Zero Span)

Test setup
Signal generator settings (e.g. R&S SMU)
Frequency | 128 MHz
Level | -30 dBm
Modulation | 50 % AM, 1 kHz AF

  1. Select PRESET to reset the instrument.

  2. Set the center frequency to 128 MHz.

  3. Set the frequency span to 0 Hz or select "Zero Span".

  4. Set the sweep time to 2.5 ms.

  5. Set the reference level to 6 dBm and the display range to linear (AMPT > "Scale Config" > "Scaling: Linear Percent").

  6. Define triggering in response to the AF signal using the video trigger to produce a static image.

    1. Press the TRIG key.

    2. Select "Video".

    3. Set the "Trg/Gate Level" to 50%.

    The trigger level is displayed as a horizontal line across the entire measurement diagram. The R&S FSW displays the 1 kHz AF signal as a static image in zero span.

    Measurement of the AF signal of a carrier that is AM-modulated with 1 kHz

  7. Activate the internal AM demodulator to output the audio signal.

    1. Press the MKR FUNC key.

    2. Select "Marker Demodulation".

      The R&S FSW automatically switches on the AM audio demodulator. A 1 kHz tone can be heard over headset (via the PHONES connector). If necessary, use the volume control to turn up the volume.


Measurement Examples in Zero Span

Measurements > Basic Measurements > Measurement Examples in Zero Span
Measurement Examples in Zero Span

For radio transmission systems that use the TDMA method (for example, GSM), transmission quality is determined not only by spectral characteristics but also by characteristics in zero span. A timeslot is assigned to each user since several users share the same frequency. Smooth operation is ensured only if all users adhere exactly to their assigned timeslots.

Both the power during the send phase as well as the timing and duration of the TDMA burst, and rise and fall times of the burst, are important.

Contents
  • Measuring the Power Characteristic of Burst Signals
  • Measuring the Signal-to-Noise Ratio of Burst Signals


Measuring the Power Characteristic of Burst Signals

Measurements > Basic Measurements > Measurement Examples in Zero Span > Measuring the Power Characteristic of Burst Signals
Measuring the Power Characteristic of Burst Signals

To measure power in zero span, the R&S FSW offers easy-to-use functions that measure the power over a predefined time.

Contents
  • Measuring the Power of a GSM Burst During the Activation Phase
  • Measuring the Edges of a GSM Burst with High Time Resolution


Measuring the Power of a GSM Burst During the Activation Phase

Measurements > Basic Measurements > Measurement Examples in Zero Span > Measuring the Power Characteristic of Burst Signals > Measuring the Power of a GSM Burst During the Activation Phase
Measuring the Power of a GSM Burst During the Activation Phase
Test setup
Signal generator settings (e.g. R&S SMU)
Frequency | 890 MHz
Level | 0 dBm
Modulation | GSM, one timeslot activated

  1. Select PRESET to reset the instrument.

  2. Set the center frequency to 890 MHz (FREQ).

  3. Set the frequency span to 0 Hz (SPAN > "Zero Span").

  4. Set the reference level to 10 dBm (= level of the signal generator +10 dB) (AMPT).

  5. Set the attenuation to 20 dB (AMPT > "Rf Atten Manual").

  6. Set the resolution bandwidth to 1 MHz (BW > "Res BW").

  7. Set the sweep time to 1 ms (SWEEP > "Sweeptime Manual").

    The R&S FSW shows the GSM burst continuously across the display.

  8. Using the video trigger, set triggering on the rising edge of the burst.

    1. Press the TRIG key.

    2. Set the "Trg/Gate Source" to "Video".

    3. Set the "Trg/Gate Level" to 70%.

    The R&S FSW shows a static image with the GSM burst at the start of the trace. The trigger level is displayed as a horizontal line labeled with the absolute level for the trigger threshold in the measurement diagram.

  9. Activate power measurement within the activation phase of the burst in zero span.

    1. Press the MEAS key.

    2. Select "Time Domain Power".

    3. Select "Time Dom Power Config".

    4. Set the "Limits" state to "On".

    5. Select the "Left Limit" input field.

    6. By turning the rotary knob clockwise, move the vertical line "S1" to the start of the burst.

    7. Select the "Right Limit" input field.

    8. By turning the rotary knob clockwise, move the vertical line "S2" to the end of the burst.

    The R&S FSW displays the average (mean) power during the activation phase of the burst.

    Measurement of the average power during the burst of a GSM signal


Measuring the Edges of a GSM Burst with High Time Resolution

Measurements > Basic Measurements > Measurement Examples in Zero Span > Measuring the Power Characteristic of Burst Signals > Measuring the Edges of a GSM Burst with High Time Resolution
Measuring the Edges of a GSM Burst with High Time Resolution

Due to the high time resolution of the R&S FSW at the 0 Hz display range, the edges of TDMA bursts can be measured precisely. The edges can be shifted to the display area using the trigger offset.

Test setup
Signal generator settings (e.g. R&S SMU)
Frequency | 890 MHz
Level | 0 dBm
Modulation | GSM, one timeslot activated

The measurement is based on the example "Measuring the Power of a GSM Burst During the Activation Phase".

  1. Switch off the power measurement.

    1. Press the MEAS key.

    2. Select "All Functions Off".

  2. Increase the time resolution to 100 µs (SWEEP > "Sweeptime Manual").

  3. Shift the rising edge of the GSM burst to the center of the display by defining a trigger offset.

    1. Press the TRIG key.

    2. Select "Trigger Offset".

    3. By turning the rotary knob counterclockwise, reduce the trigger offset until the burst edge is displayed in the center of the display, or enter -50 µs.

      The R&S FSW displays the rising edge of the GSM burst.

      Rising edge of the GSM burst displayed with high time resolution

  4. Move the falling edge of the burst to the center of the display. To do so, switch the trigger "Slope" to "Falling" (TRIG > "Trigger/Gate Config").

    The R&S FSW displays the falling edge of the GSM burst.

    Falling edge of the GSM burst displayed with high time resolution


Measuring the Signal-to-Noise Ratio of Burst Signals

Measurements > Basic Measurements > Measurement Examples in Zero Span > Measuring the Signal-to-Noise Ratio of Burst Signals
Measuring the Signal-to-Noise Ratio of Burst Signals

When TDMA transmission methods are used, the signal-to-noise ratio or the dynamic range for deactivation can be measured by comparing the power values during the activation phase and the deactivation phase of the transmission burst. Therefore, the R&S FSW provides a measurement for absolute and relative power in zero span. In the following example, the measurement is performed using a GSM burst.

Signal-to-Noise Ratio of a GSM Signal

Test setup
Signal generator settings (e.g. R&S SMU)
Frequency | 890 MHz
Level | 0 dBm
Modulation | GSM, one time slot is switched on

  1. Select PRESET to reset the instrument.

  2. Set the center frequency to 890 MHz.

  3. Set the frequency span to 0 Hz.

  4. Set the resolution bandwidth to 1 MHz.

  5. Set the reference level to 0 dBm (= level of the signal generator).

  6. Set the sweep time to 2 ms (SWEEP > "Sweeptime Manual").

    The R&S FSW shows the GSM burst continuously across the display.

  7. Use the trigger source "Video" and the trigger slope "Rising" to trigger on the rising edge of the burst and shift the start of the burst to the center of the display (see step 3 in "Measuring the Edges of a GSM Burst with High Time Resolution").

  8. Activate power measurement within the activation phase of the burst in zero span.

    1. Press the MEAS key.

    2. Select "Time Domain Power".

    3. Select "Time Dom Power Config".

    4. Set the "Limits" state to "On".

    5. Select the "Left Limit" input field.

    6. By turning the rotary knob clockwise, move the vertical line "S1" to the start of the burst.

    7. Select the "Right Limit" input field.

    8. By turning the rotary knob clockwise, move the vertical line "S2" to the end of the burst.

  9. Measure the power during the deactivation phase of the burst by switching the trigger slope to "Falling" (TRIG > "Trigger/Gate Config").

    The R&S FSW initiates triggering in response to the falling edge of the burst. This shifts the burst to the left-hand side of the measurement diagram. The power is measured in the deactivation phase.

    Measurement of the signal-to-noise ratio of a GSM burst signal in zero span


Channel Power and Adjacent-Channel Power (ACLR) Measurement

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement
Channel Power and Adjacent-Channel Power (ACLR) Measurement

Measuring the power in channels adjacent to the carrier or transmission channel is useful to detect interference. The results are displayed as a bar chart for the individual channels.

Contents
  • About Channel Power Measurements
  • Channel Power Results
  • Channel Power Basics
  • Channel Power Configuration
  • MSR ACLR Configuration
  • How to Perform Channel Power Measurements
  • Measurement Examples
  • Optimizing and Troubleshooting the Measurement
  • Reference: Predefined CP/ACLR Standards


About Channel Power Measurements

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > About Channel Power Measurements
About Channel Power Measurements

Measuring channel power and adjacent channel power is one of the most important tasks for a signal analyzer with the necessary test routines in the field of digital transmission. While, theoretically, channel power could be measured at highest accuracy with a power meter, its low selectivity means that it is not suitable for measuring adjacent channel power as an absolute value or relative to the transmit channel power. The power in the adjacent channels can only be measured with a selective power meter.

A signal analyzer cannot be classified as a true power meter, because it displays the IF envelope voltage. However, it is calibrated such as to correctly display the power of a pure sine wave signal irrespective of the selected detector. This calibration cannot be applied for non-sinusoidal signals. Assuming that the digitally modulated signal has a Gaussian amplitude distribution, the signal power within the selected resolution bandwidth can be obtained using correction factors. These correction factors are normally used by the signal analyzer's internal power measurement routines in order to determine the signal power from IF envelope measurements. These factors apply if and only if the assumption of a Gaussian amplitude distribution is correct.

Apart from this common method, the R&S FSW also has a true power detector, i.e. an RMS detector. It displays the power of the test signal within the selected resolution bandwidth correctly, irrespective of the amplitude distribution, without additional correction factors being required.

The R&S FSW allows you to perform ACLR measurements on input containing multiple signals for different communication standards. A measurement standard is provided that allows you to define multiple discontiguous transmit channels at specified frequencies, independent from the selected center frequency. The ACLR measurement determines the power levels of the individual transmit, adjacent, and CACLR channels, as well as the total power for each sub block of transmit channels.

A detailed measurement example is provided in "Measurement Examples".


Channel Power Results

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Results
Channel Power Results

For channel or adjacent-channel power measurements, the individual channels are indicated by different colored bars in the diagram. The height of each bar corresponds to the measured power of that channel. In addition, the name of the channel ("Adj", "Alt1", "TX1", etc. or a user-defined name) is indicated above the bar (separated by a line which has no further meaning). For "Fast ACLR" measurements, which are performed in the time domain, the power versus time is shown for each channel.

Results are provided for the TX channel and the number of defined adjacent channels above and below the TX channel. If more than one TX channel is defined, the carrier channel to which the relative adjacent-channel power values should be referenced must be defined. By default, this is the TX channel with the maximum power.

Measurements performed depending on the number of adjacent channels
0 | Only the channel powers are measured.
1 | The channel powers and the power of the upper and lower adjacent channel are measured.
2 | The channel powers, the power of the upper and lower adjacent channel, and of the next higher and lower channel (alternate channel 1) are measured.
3 | The channel power, the power of the upper and lower adjacent channel, the power of the next higher and lower channel (alternate channel 1), and of the next but one higher and lower adjacent channel (alternate channel 2) are measured.
… | …
12 | The channel power, the power of the upper and lower adjacent channel, and the power of all the higher and lower channels (alternate channels 1 to 11) are measured.

In the R&S FSW's display, only the first neighboring channel of the carrier (TX) channel is labelled "Adj" (adjacent) channel; all others are labelled "Alt" (alternate) channels. In this manual, "adjacent" refers to both adjacent and alternate channels.

The measured power values for the TX and adjacent channels are also output as a table in the second window. Which powers are measured depends on the number of configured channels.

For each channel, the following values are displayed:

Label | Description
Channel | Channel name as specified in the "Channel Settings" (see "Channel Names").
Bandwidth | Configured channel bandwidth (see "Channel Bandwidths")
Offset | Offset of the channel to the TX channel (Configured channel spacing, see "Channel Bandwidths")
Power (Lower/Upper) | The measured power values for the TX and lower and upper adjacent channels. The powers of the transmission channels are output in dBm or dBm/Hz, or in dBc, relative to the specified reference TX channel.
Retrieving Results via Remote Control

All or specific channel power measurement results can be retrieved using the CALC:MARK:FUNC:POW:RES? command from a remote computer (see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?). Alternatively, the results can be output as channel power density, i.e. in reference to the measurement bandwidth.

Furthermore, the measured power values of the displayed trace can be retrieved as usual using the TRAC:DATA? commands (see TRACe<n>[:​DATA]). In this case, the measured power value for each sweep point (by default 1001) is returned.


Channel Power Basics

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics
Channel Power Basics

Some background knowledge on basic terms and principles used in channel power measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Measurement Methods
  • Measurement Repeatability
  • Recommended Common Measurement Parameters
  • Measurement on Multi-Standard Radio (MSR) Signals


Measurement Methods

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Measurement Methods
Measurement Methods

The channel power is defined as the integration of the power across the channel bandwidth.

The Adjacent Channel Leakage Power Ratio (ACLR), also known as the Adjacent Channel Power Ratio (ACPR), is defined as the ratio between the total power of the adjacent channel to the carrier channel's power. An ACLR measurement with several carrier channels (also known as transmission or TX channels) is also possible and is referred to as a "multicarrier ACLR measurement".

There are two possible methods for measuring channel and adjacent channel power with a signal analyzer:

  • IBW method (Integration BandWidth method)
  • Fast ACLR (Zero-span method ), i.e. using a channel filter
IBW method

When measuring the channel power, the R&S FSW integrates the linear power which corresponds to the levels of the measurement points within the selected channel. The signal analyzer uses a resolution bandwidth which is far smaller than the channel bandwidth. When sweeping over the channel, the channel filter is formed by the passband characteristics of the resolution bandwidth.

Approximating the channel filter by sweeping with a small resolution bandwidth

The following steps are performed:

  1. The linear power of all the trace points within the channel is calculated.

    Pi = 10(Li/10)

    where Pi = power of the trace pixel i

    Li = displayed level of trace point i

  2. The powers of all trace points within the channel are summed up and the sum is divided by the number of trace points in the channel.

  3. The result is multiplied by the quotient of the selected channel bandwidth and the noise bandwidth of the resolution filter (RBW).

Since the power calculation is performed by integrating the trace within the channel bandwidth, this method is called the IBW method (Integration Bandwidth method).

Fast ACLR

The integrated bandwidth method (IBW) calculates channel power and ACLR from the trace data obtained during a continuous sweep over the selected span. Most parts of this sweep are neither part of the channel itself nor the defined adjacent channels. Therefore, most of the samples taken during the sweep time cannot be used for channel power or ACLR calculation.

To decrease the measurement times, the R&S FSW offers a "Fast ACLR" mode. In Fast ACLR mode, the power of the frequency range between the channels of interest is not measured, because it is not required for channel power or ACLR calculation. The measurement time per channel is set with the sweep time. It is equal to the selected measurement time divided by the selected number of channels.

In the "Fast ACLR" mode, the R&S FSW measures the power of each channel in the time domain, with the defined channel bandwidth, at the center frequency of the channel in question. The digital implementation of the resolution bandwidths makes it possible to select filter characteristics that are precisely tailored to the signal. In case of CDMA2000, for example, the power in the useful channel is measured with a bandwidth of 1.23 MHz and that of the adjacent channels with a bandwidth of 30 kHz. Therefore the R&S FSW changes from one channel to the other and measures the power at a bandwidth of 1.23 MHz or 30 kHz using the RMS detector.

Measuring the channel power and adjacent channel power ratio for CDMA2000 signals with zero span (Fast ACLR)


Measurement Repeatability

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Measurement Repeatability
Measurement Repeatability

The repeatability of the results, especially in the narrow adjacent channels, strongly depends on the measurement time for a given resolution bandwidth. A longer sweep time may increase the probability that the measured value converges to the true value of the adjacent channel power, but obviously increases measurement time.

Assuming a measurement with five channels (1 channel plus 2 lower and 2 upper adjacent channels) and a sweep time of 100 ms, a measurement time per channel of 20 ms is required. The number of effective samples taken into account for power calculation in one channel is the product of sweep time in channel times the selected resolution bandwidth.

Assuming a sweep time of 100 ms, there are (30 kHz / 4.19 MHz) * 100 ms * 10 kHz ≈ 7 samples. Whereas in Fast ACLR mode, there are (100 ms / 5) * 30 kHz ≈ 600 samples. Comparing these numbers explains the increase of repeatability with a 95% confidence level (2δ) from ± 2.8 dB to ± 0.34 dB for a sweep time of 100 ms.

For the same repeatability, the sweep time would have to be set to 8.5 s with the integration method. The figure "Repeatability of adjacent channel power measurement on CDMA2000 standard signals if the integration bandwidth method is used" shows the standard deviation of the results as a function of the sweep time.

Repeatability of adjacent channel power measurement on CDMA2000 standard signals if the integration bandwidth method is used

The figure "Repeatability of adjacent channel power measurements on CDMA2000 signals in the fast ACLR mode" shows the repeatability of power measurements in the transmit channel and of relative power measurements in the adjacent channels as a function of sweep time. The standard deviation of measurement results is calculated from 100 consecutive measurements. Take scaling into account if comparing power values.

Repeatability of adjacent channel power measurements on CDMA2000 signals in the fast ACLR mode


Recommended Common Measurement Parameters

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters
Recommended Common Measurement Parameters

The following sections provide recommendations on the most important measurement parameters for channel power measurements.

All instrument settings for the selected channel setup (channel bandwidth, channel spacing) can be optimized automatically using the "Adjust Settings" function (see "Optimized Settings (Adjust Settings)").

The easiest way to configure a measurement is using the configuration "Overview", see "Configuration Overview".

Contents
  • Sweep Time
  • Frequency Span
  • Resolution Bandwidth (RBW)
  • Video Bandwidth (VBW)
  • Detector
  • Trace Averaging
  • Reference Level


Sweep Time

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters > Sweep Time
Sweep Time

The sweep time is selected depending on the desired reproducibility of results. Reproducibility increases with sweep time since power measurement is then performed over a longer time period. As a general approach, it can be assumed that approx. 500 non-correlated measured values are required for a reproducibility of 0.5 dB (99 % of the measurements are within 0.5 dB of the true measured value). This holds true for white noise. The measured values are considered as non-correlated if their time interval corresponds to the reciprocal of the measured bandwidth.

With IS 136 the measurement bandwidth is approx. 25 kHz, i.e. measured values at an interval of 40 µs are considered as non-correlated. A measurement time of 40 ms is thus required per channel for 1000 measured values. This is the default sweep time which the R&S FSW sets in coupled mode. Approx. 5000 measured values are required for a reproducibility of 0.1 dB (99 %), i.e. the measurement time is to be increased to 200 ms.

The number of A/D converter values, N, used to calculate the power, is defined by the sweep time. The time per trace pixel for power measurements is directly proportional to the selected sweep time.

If the sample detector is used, it is best to select the smallest sweep time possible for a given span and resolution bandwidth. The minimum time is obtained if the setting is coupled. This means that the time per measurement is minimal. Extending the measurement time does not have any advantages as the number of samples for calculating the power is defined by the number of trace points in the channel.

If the RMS detector is used, the repeatability of the measurement results can be influenced by the selection of sweep times. Repeatability is increased at longer sweep times.

If the RMS detector is used, the number of samples can be estimated as follows:

Since only uncorrelated samples contribute to the RMS value, the number of samples can be calculated from the sweep time and the resolution bandwidth.

Samples can be assumed to be uncorrelated if sampling is performed at intervals of 1/RBW. The number of uncorrelated samples is calculated as follows:

Ndecorr = SWT * RBW

(Ndecorr means uncorrelated samples)

The number of uncorrelated samples per trace pixel is obtained by dividing Ndecorr by 1001 (= pixels per trace).

The "Sweep Time" can be defined using the softkey in the "Ch Power" menu or in the "Sweep" configuration dialog box (see "Sweep Time").


Frequency Span

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters > Frequency Span
Frequency Span

The frequency span must cover at least the channels to be measured plus a measurement margin of approximately 10 %.

If the frequency span is large in comparison to the channel bandwidth (or the adjacent-channel bandwidths) being analyzed, only a few points on the trace are available per channel. This reduces the accuracy of the waveform calculation for the channel filter used, which has a negative effect on the measurement accuracy. It is therefore strongly recommended that the formulas mentioned be taken into consideration when selecting the frequency span.

The frequency span for the defined channel settings can be optimized using the "Adjust Settings" function in the "Ch Power" menu or the "General Settings" tab of the "ACLR Setup" dialog box (see "Optimized Settings (Adjust Settings)"). You can set the frequency span manually in the "Frequency" configuration dialog box, see "How To Define the Frequency Range".

For channel power measurements the "Adjust Settings" function sets the frequency span as follows:

"(No. of transmission channels – 1) x transmission channel spacing + 2 x transmission channel bandwidth + measurement margin"

For adjacent-channel power measurements, the "Adjust Settings" function sets the frequency span as a function of the number of transmission channels, the transmission channel spacing, the adjacent-channel spacing, and the bandwidth of one of adjacent-channels ADJ, ALT1 or ALT2, whichever is furthest away from the transmission channels:

"(No. of transmission channels – 1) x transmission channel spacing + 2 x (adjacent-channel spacing + adjacent-channel bandwidth) + measurement margin"

The measurement margin is approx. 10 % of the value obtained by adding the channel spacing and the channel bandwidth.


Resolution Bandwidth (RBW)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters > Resolution Bandwidth (RBW)
Resolution Bandwidth (RBW)

To ensure both acceptable measurement speed and the required selection (to suppress spectral components outside the channel to be measured, especially of the adjacent channels), the resolution bandwidth must not be selected too small or too large. As a general approach, the resolution bandwidth is to be set to values between 1% and 4% of the channel bandwidth.

A larger resolution bandwidth can be selected if the spectrum within the channel to be measured and around it has a flat characteristic. In the standard setting, e.g. for standard IS95A REV at an adjacent channel bandwidth of 30 kHz, a resolution bandwidth of 30 kHz is used. This yields correct results since the spectrum in the neighborhood of the adjacent channels normally has a constant level.

The resolution bandwidth for the defined channel settings can be optimized using the "Adjust Settings" function in the "Ch Power" menu or the "General Settings" tab of the "ACLR Setup" dialog box (see "Optimized Settings (Adjust Settings)"). You can set the RBW manually in the "Bandwidth" configuration dialog box, see "RBW".

With the exception of the IS95 CDMA standards, the "Adjust Settings" function sets the resolution bandwidth (RBW) as a function of the channel bandwidth:

"RBW ≤ 1/40 of channel bandwidth"

The maximum possible resolution bandwidth (with respect to the requirement RBW ≤ 1/40) resulting from the available RBW steps (1, 3) is selected.


Video Bandwidth (VBW)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters > Video Bandwidth (VBW)
Video Bandwidth (VBW)

For a correct power measurement, the video signal must not be limited in bandwidth. A restricted bandwidth of the logarithmic video signal would cause signal averaging and thus result in a too low indication of the power (-2.51 dB at very low video bandwidths). The video bandwidth should therefore be selected at least three times the resolution bandwidth:

"VBW ≥ 3 x RBW"

The video bandwidth for the defined channel settings can be optimized using the "Adjust Settings" function in the "Ch Power" menu or the "General Settings" tab of the "ACLR Setup" dialog box (see "Optimized Settings (Adjust Settings)"). You can set the VBW manually in the "Bandwidth" configuration dialog box, see "VBW".

The video bandwidth (VBW) is set as a function of the channel bandwidth (see formula above) and the smallest possible VBW with regard to the available step size is selected.


Detector

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters > Detector
Detector

The RMS detector correctly indicates the power irrespective of the characteristics of the signal to be measured. The whole IF envelope is used to calculate the power for each measurement point. The IF envelope is digitized using a sampling frequency which is at least five times the resolution bandwidth which has been selected. Based on the sample values, the power is calculated for each measurement point using the following formula:

where:

si = linear digitized video voltage at the output of the A/D converter

N = number of A/D converter values per measurement point

PRMS = power represented by a measurement point

When the power has been calculated, the power units are converted into decibels and the value is displayed as a measurement point.

In principle, the sample detector would be possible as well. Due to the limited number of measurement points used to calculate the power in the channel, the sample detector would yield less stable results.

The RMS detector can be set for the defined channel settings automatically using the "Adjust Settings" function in the "Ch Power" menu or the "General Settings" tab of the "ACLR Setup" dialog box (see "Optimized Settings (Adjust Settings)"). You can set the detector manually in the "Traces" configuration dialog box, see "Detector".


Trace Averaging

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters > Trace Averaging
Trace Averaging

Averaging, which is often performed to stabilize the measurement results, leads to a level indication that is too low and should therefore be avoided. The reduction in the displayed power depends on the number of averages and the signal characteristics in the channel to be measured.

The "Adjust Settings" function switches off trace averaging. You can deactivate the trace averaging manually in the "Traces" configuration dialog box, see "Average Mode".


Reference Level

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Recommended Common Measurement Parameters > Reference Level
Reference Level

To achieve an optimum dynamic range, the reference level has to be set such that the signal is as close to the reference level as possible without forcing an overload message or limiting the dynamic range by an S/N ratio that is too small. Since the measurement bandwidth for channel power measurements is significantly smaller than the signal bandwidth, the signal path may be overloaded although the trace is still significantly below the reference level.

The reference level is not influenced by the selection of a predefined standard or by the automatic setting adjustment. The reference level can be set automatically using the "Auto Level" function in the AUTO SET menu, or manually in the "Amplitude" menu.


Measurement on Multi-Standard Radio (MSR) Signals

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Basics > Measurement on Multi-Standard Radio (MSR) Signals
Measurement on Multi-Standard Radio (MSR) Signals

Modern base stations may contain multiple signals for different communication standards. A new measurement standard is provided for the R&S FSW ACLR measurement that allows you to measure such MSR signals, including non-contiguous setups. Multiple (also non-)contiguous transmit channels can be specified at absolute frequencies, independent from the common center frequency selected for display.

Signal structure

Up to 18 transmit channels can be grouped in a maximum of 5 sub blocks. Between two sub blocks, two gaps are defined: a lower gap and an upper gap. Each gap in turn contains 2 channels. The channels in the upper gap are identical to those in the lower gap, but inverted. To either side of the outermost transmit channels, lower and upper adjacent channels can be defined as in common ACLR measurement setups.

MSR signal structure
Sub block and channel definition

The sub blocks are defined by a specified center frequency, RF bandwidth, and number of transmit channels.

Sub block definition

As opposed to common ACLR channel definitions, the Tx channels are defined at absolute frequencies, rather than by a spacing relative to the (common) center frequency. Each transmit channel can be assigned a different technology, used to predefine the required bandwidth.

CACLR channels

If two or more sub blocks are defined, the power in the gaps between the sub blocks must also be measured (referred to as the Cumulative Adjacent Channel Leakage Ratio (CACLR) power). According to the MSR standard, the CACLR is measured in the two channels for the upper and lower gap (thus referred to as CACLR channels). The power in the CACLR channels is then set in relation to the power of the two closest transmission channels to either side of the gap.

CACLR channels are defined using bandwidths and spacings, relative to the outer edges of the surrounding sub blocks. Since the upper and lower CACLR channels are identical, only two channels must be configured. The required spacing can be determined according to the following formula (indicated for lower channels):

Spacing = [CF of the gap channel] - [left sub block center] + ([RF bandwidth of left sub block] /2)

Adjacent channels

Adjacent channels are defined as in common ACLR measurements, using bandwidths and spacings, however, relative to the start and stop frequency of the total block of transmit channels:

  • The spacing of the lower adjacent channels refers to the CF of the first Tx channel in the first sub block.
  • The spacing of the upper adjacent channels refers to the CF of the last Tx channel in the last sub block.
Channel display for MSR signals

As in common ACLR measurements, the individual channels are indicated by different colored bars in the diagram. The height of each bar corresponds to the measured power of that channel. In addition, the name of the channel is indicated above the bar. Sub blocks are named A,B,C,D,E and are also indicated by a slim blue bar along the frequency axis.

Note that Tx channel names correspond to the specified technology (for LTE including the bandwidth), followed by a consecutive number. (If the channel is too narrow to display the channel name, it is replaced by "..." on the screen.) Channel names cannot be defined manually. The assigned sub block is indicated with the channel name, e.g. "B:LTE_5M1" for the first Tx channel in sub block B that uses the LTE 5 MHz bandwidth technology.

Gap channels (CACLR) are indicated by the names of the surrounding sub blocks (e.g. "AB" for the gap between sub blocks A and B), followed by the channel name ("Gap1" or "Gap2") and an "L" (for lower) or a "U" (for upper). Both the lower and upper gap channels are displayed. However, if the gap between two sub blocks is too narrow, the second gap channel may not be displayed. If the gap is even narrower, no gap channels are displayed.

Adjacent and alternate channels are displayed as in common ACLR measurements.

Channel power results

The Result Summary for MRS signal measurements is similar to the table for common signals (see "Channel Power Results"). However, the Tx channel results are grouped by sub blocks, and sub block totals are provided instead of a total Tx channel power. Instead of the individual channel frequency offsets, the absolute center frequencies are indicated for the transmit channels. The CACLR results for each gap channel are appended at the end of the table. The CACLR results are calculated as the power in the CACLR channel divided by the power sum of the two closest transmission channels to either side of it.

Restrictions and dependencies

As the signal structure in multi-standard radio signals may vary considerably, the channels can be defined very flexibly for the ACLR measurement with the R&S FSW. No checks or limitations are implemented concerning the channel definitions, apart from the maximum number of channels to be defined. Thus, you will not be notified if transmit channels for a specific sub block lie outside the sub block's defined frequency range, or if transmit and CACLR channels overlap.


Channel Power Configuration

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration
Channel Power Configuration

Channel Power (CP) and Adjacent-Channel Power (ACLR) measurements are selected via the "Channel Power ACLR" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "ACLR Setup" dialog box, which is displayed when you select the "CP/ACLR Config" softkey from the "CH Power" menu.

If the "Multi-Standard Radio" standard is selected (see "Standard"), the "ACLR Setup" dialog box is replaced by the "MSR ACLR Setup" dialog box. See "MSR ACLR Configuration" for a description of these settings.

The easiest way to configure a measurement is using the configuration "Overview", see "Configuration Overview".

The remote commands required to perform these tasks are described in "Measuring the Channel Power and ACLR".

Contents
  • General CP/ACLR Measurement Settings
  • Channel Setup


General CP/ACLR Measurement Settings

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings
General CP/ACLR Measurement Settings

General measurement settings are defined in the "ACLR Setup" dialog, in the "General Settings" tab.

The "Channel Settings" tab provides all the channel settings to configure the channel power or ACLR measurement (see "Channel Setup").

└ Standard
└ Predefined Standards
└ User-Defined Standards
└ Number of Channels (Tx, ADJ)
└ Reference Channel
└ Noise cancellation
└ Fast ACLR
└ Selected Trace
└ Absolute and Relative Values (ACLR Mode)
└ Channel Power Levels and Density (Power Unit)
└ Power Mode
└ Setting a Fixed Reference for Channel Power Measurements (Set CP Reference)
└ Optimized Settings (Adjust Settings)
└ Sweep Time


Standard

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Standard
Standard

The main measurement settings can be stored as a standard file. When such a standard is loaded, the required channel and general measurement settings are automatically set on the R&S FSW. However, the settings can be changed. Predefined standards are available for standard measurements, but standard files with user-defined configurations can also be created.

Note: If the "Multi-Standard Radio" standard is selected, the "ACLR Setup" dialog box is replaced by the "MSR ACLR Setup" dialog box (see "MSR ACLR Configuration").
If any other predefined standard (or "NONE") is selected, the "ACLR Setup" dialog box is restored (see "Channel Power Configuration").
Note that changes in the configuration are not stored when the dialog boxes are exchanged.

└ Predefined Standards
└ User-Defined Standards


Predefined Standards

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Standard > Predefined Standards
Predefined Standards

Predefined standards contain the main measurement settings for standard measurements. When such a standard is loaded, the required channel settings are automatically set on the R&S FSW. However, the settings can be changed.

The predefined standards contain the following settings:

  • Channel bandwidths
  • Channel spacings
  • Detector
  • Trace Average setting
  • Resolution Bandwidth (RBW)
  • Weighting Filter

For details on the available standards see "Reference: Predefined CP/ACLR Standards".

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet


User-Defined Standards

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Standard > User-Defined Standards
User-Defined Standards

In addition to the predefined standards you can save your own standards with your specific measurement settings in an xml file so you can use them again at a later time. User-defined standards are stored on the instrument in the C:\R_S\instr\acp_std directory.

A sample file is provided for an MSR ACLR measurement (MSR_ACLRExample.xml). It sets up the measurement for the MSR signal generator waveform described in the file C:\R_S\instr\user\waveform\MSRA_GSM_WCDMA_LET_GSM.wv.

Note that ACLR user standards are not supported for Fast ACLR and multicarrier ACLR measurements.

Note: User standards created on an analyzer of the R&S FSP family are compatible to the R&S FSW. User standards created on an R&S FSW, however, are not necessarily compatible to the analyzers of the R&S FSP family and may not work there.

The following parameter definitions are saved in a user-defined standard:
  • Number of adjacent channels
  • Channel bandwidth of transmission (Tx), adjacent (Adj) and alternate (Alt) channels
  • Channel spacings
  • Weighting filters
  • Resolution bandwidth
  • Video bandwidth
  • Detector
  • ACLR limits and their state
  • Sweep time and sweep time coupling
  • Trace and power mode
  • (MSR only: sub block and gap channel definition)

In the "Manage" dialog box you can save the current measurement settings as a user-defined standard, or load a stored measurement configuration. Furthermore, you can delete an existing configuration file.

For details see "How to Manage User-Defined Configurations".

Remote command:

To query all available standards:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​STANdard:​CATalog?

To load a standard:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet

To save a standard:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​STANdard:​SAVE

To delete a standard:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​STANdard:​DELete


Number of Channels (Tx, ADJ)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Number of Channels (Tx, ADJ)
Number of Channels (Tx, ADJ)

Up to 18 carrier channels and up to 12 adjacent channels can be defined.

Results are provided for the Tx channel and the number of defined adjacent channels above and below the Tx channel. If more than one Tx channel is defined, the carrier channel to which the relative adjacent-channel power values should be referenced must be defined (see "Reference Channel").

Note: If several carriers (Tx channels) are activated for the measurement, the number of sweep points is increased to ensure that adjacent-channel powers are measured with adequate accuracy.

For more information on how the number of channels affects the measured powers, see "Channel Power Results".

Remote command:

Number of Tx channels:

[SENSe:​]POWer:​ACHannel:​TXCHannel:​COUNt

Number of Adjacent channels:

[SENSe:​]POWer:​ACHannel:​ACPairs


Reference Channel

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Reference Channel
Reference Channel

The measured power values in the adjacent channels can be displayed relative to the transmission channel. If more than one Tx channel is defined, you must select which one is to be used as a reference channel.

Tx Channel 1 | Transmission channel 1 is used. (Not available for MSR ACLR)
Min Power Tx Channel | The transmission channel with the lowest power is used as a reference channel.
Max Power Tx Channel | The transmission channel with the highest power is used as a reference channel (Default).
Lowest & Highest Channel | The outer left-hand transmission channel is the reference channel for the lower adjacent channels, the outer right-hand transmission channel that for the upper adjacent channels.
Remote command:

[SENSe:​]POWer:​ACHannel:​REFerence:​TXCHannel:​MANual

[SENSe:​]POWer:​ACHannel:​REFerence:​TXCHannel:​AUTO


Noise cancellation

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Noise cancellation
Noise cancellation

The results can be corrected by the instrument's inherent noise, which increases the dynamic range.

In this case, a reference measurement of the instrument's inherent noise is carried out. The measured noise power is then subtracted from the power in the channel that is being analyzed (first active trace only).

The inherent noise of the instrument depends on the selected center frequency, resolution bandwidth and level setting. Therefore, the correction function is disabled whenever one of these parameters is changed. A disable message is displayed on the screen. To enable the correction function after changing one of these settings, activate it again. A new reference measurement is carried out.

Noise cancellation is also available in zero span.

Currently, noise cancellation is only available for the following trace detectors (see "Detector"):

  • RMS
  • Average
  • Sample
  • Positive Peak
Remote command:

[SENSe:​]POWer:​NCORrection


Fast ACLR

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Fast ACLR
Fast ACLR

If activated, instead of using the IBW method, the R&S FSW sets the center frequency to the different channel center frequencies consecutively and measures the power with the selected measurement time (= sweep time/number of channels).

For details see "Measurement Methods".

Remote command:

[SENSe:​]POWer:​HSPeed


Selected Trace

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Selected Trace
Selected Trace

The CP/ACLR measurement can be performed on any active trace.

Remote command:

[SENSe:​]POWer:​TRACe


Absolute and Relative Values (ACLR Mode)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Absolute and Relative Values (ACLR Mode)
Absolute and Relative Values (ACLR Mode)

The powers of the adjacent channels are output in dBm or dBm/Hz (absolute values), or in dBc, relative to the specified reference Tx channel.

"Abs" | The absolute power in the adjacent channels is displayed in the unit of the y-axis, e.g. in dBm, dBµV.
"Rel" | The level of the adjacent channels is displayed relative to the level of the transmission channel in dBc.
Remote command:

[SENSe:​]POWer:​ACHannel:​MODE


Channel Power Levels and Density (Power Unit)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Channel Power Levels and Density (Power Unit)
Channel Power Levels and Density (Power Unit)

By default, the channel power is displayed in absolute values. If "/Hz" is activated, the channel power density is displayed instead. Thus, the absolute unit of the channel power is switched from dBm to dBm/Hz.

Note: The channel power density in dBm/Hz corresponds to the power inside a bandwidth of 1 Hz and is calculated as follows:
"channel power density = channel power – log10(channel bandwidth)"

Thus you can measure the signal/noise power density, for example, or use the additional functions "Absolute and Relative Values (ACLR Mode)" and "Reference Channel" to obtain the signal to noise ratio.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​RESult:​PHZ


Power Mode

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Power Mode
Power Mode

The measured power values can be displayed directly for each trace ("Clear/Write"), or only the maximum values over a series of measurements can be displayed ("Max Hold"). In the latter case, the power values are calculated from the current trace and compared with the previous power value using a maximum algorithm. The higher value is retained. If "Max Hold" mode is activated, "Pwr Max" is indicated in the table header. Note that the trace mode remains unaffected by this setting.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​MODE


Setting a Fixed Reference for Channel Power Measurements (Set CP Reference)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Setting a Fixed Reference for Channel Power Measurements (Set CP Reference)
Setting a Fixed Reference for Channel Power Measurements (Set CP Reference)

For pure channel power measurements (no adjacent channels defined) with only one Tx channel, the currently measured channel power can be used as a fixed reference value for subsequent channel power measurements.

When you select this button, the channel power currently measured on the Tx channel is stored as a fixed reference power. In the following channel power measurements, the power is indicated relative to the fixed reference power. The reference value is displayed in the "Reference" field (in relative ACLR mode); the default value is 0 dBm.

Note: In adjacent-channel power measurement, the power is always referenced to a transmission channel (see "Reference Channel"), thus, this function is not available.

Remote command:

[SENSe:​]POWer:​ACHannel:​REFerence:​AUTO ONCE


Optimized Settings (Adjust Settings)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Optimized Settings (Adjust Settings)
Optimized Settings (Adjust Settings)

All instrument settings for the selected channel setup (channel bandwidth, channel spacing) can be optimized automatically.

The adjustment is carried out only once. If necessary, the instrument settings can be changed later.

The following settings are optimized by "Adjust Settings":

  • "Frequency Span"
  • "Resolution Bandwidth (RBW)"
  • "Video Bandwidth (VBW)"
  • "Detector"
  • " Trace Averaging"

Note: The reference level is not affected by this function. To adjust the reference level automatically, use the "Setting the Reference Level Automatically (Auto Level)" function in the AUTO SET menu.

Remote command:

[SENSe:​]POWer:​ACHannel:​PRESet


Sweep Time

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > General CP/ACLR Measurement Settings > Sweep Time
Sweep Time

With the RMS detector, a longer sweep time increases the stability of the measurement results. For recommendations on setting this parameter, see "Sweep Time".

The sweep time can be set via the softkey in the "Ch Power" menu and is identical to the general setting in the "Sweep" configuration dialog box.

Remote command:

[SENSe:​]SWEep:​TIME


Channel Setup

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > Channel Setup
Channel Setup

The "Channel Settings" tab in the "ACLR Setup" dialog box provides all the channel settings to configure the channel power or ACLR measurement. You can define the channel settings for all channels, independent of the defined number of used Tx or adjacent channels (see "Number of Channels (Tx, ADJ)").

For details on setting up channels, see "How to Set up the Channels".

In addition to the specific channel settings, the general settings "Standard" and "Number of Channels (Tx, ADJ)" are also available in this tab.

ACLR measurements can also be performed on input containing multiple signals for different communication standards. If the "Multi-Standard Radio" standard is selected (see "Standard"), the "ACLR Setup" dialog box is replaced by the "MSR ACLR Setup" dialog box. Channel configuration for MSR ACLR measurements is described in "MSR Sub block and Tx Channel Definition" and "MSR Adjacent and Gap Channel Setup".

└ Channel Bandwidths
└ Channel Spacings
└ Limit Checking
└ Weighting Filters
└ Channel Names


Channel Bandwidths

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > Channel Setup > Channel Bandwidths
Channel Bandwidths

The Tx channel bandwidth is normally defined by the transmission standard. The correct bandwidth is set automatically for the selected standard. The bandwidth for each channel is indicated by a colored bar in the display.

For measurements that require channel bandwidths which deviate from those defined in the selected standard, use the IBW method ("Fast ACLR Off"). With the IBW method, the channel bandwidth borders are right and left of the channel center frequency. Thus, you can visually check whether the entire power of the signal under test is within the selected channel bandwidth.

The channel bandwidths are defined in the "Bandwidth" subtab of the "Channel Setup" tab in the "ACLR Setup" dialog box.

The value entered for any Tx channel is automatically also defined for all subsequent Tx channels. Thus, only one value needs to be entered if all Tx channels have the same bandwidth.

The value entered for any ADJ or ALT channel is automatically also defined for all alternate (ALT) channels. Thus, only one value needs to be entered if all adjacent channels have the same bandwidth.

Remote command:

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth[:​CHANnel<ch>]

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth:​ACHannel

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth:​ALTernate<ch>


Channel Spacings

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > Channel Setup > Channel Spacings
Channel Spacings

Channel spacings are normally defined by the selected standard but can be changed.

If the spacings are not equal, the channel distribution in relation to the center frequency is as follows:

Odd number of Tx channels | The middle Tx channel is centered to center frequency.
Even number of Tx channels | The two Tx channels in the middle are used to calculate the frequency between those two channels. This frequency is aligned to the center frequency.

The spacings between all Tx channels can be defined individually. When you change the spacing for one channel, the value is automatically also defined for all subsequent Tx channels in order to set up a system with equal Tx channel spacing quickly. For different spacings, a setup from top to bottom is necessary.

Tx1-2 | spacing between the first and the second carrier
Tx2-3 | spacing between the second and the third carrier
… | …

If you change the adjacent-channel spacing (ADJ), all higher adjacent channel spacings (ALT1, ALT2, …) are multiplied by the same factor (new spacing value/old spacing value). Again, only one value needs to be entered for equal channel spacing. For different spacing, configure the spacings from top to bottom.

For details see "How to Set up the Channels"

Remote command:

[SENSe:​]POWer:​ACHannel:​SPACing:​CHANnel<ch>

[SENSe:​]POWer:​ACHannel:​SPACing[:​ACHannel]

[SENSe:​]POWer:​ACHannel:​SPACing:​ALTernate<ch>


Limit Checking

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > Channel Setup > Limit Checking
Limit Checking

During an ACLR measurement, the power values can be checked whether they exceed user-defined or standard-defined limits. A relative or absolute limit can be defined, or both. Both limit types are considered, regardless whether the measured levels are absolute or relative values. The check of both limit values can be activated independently. If any active limit value is exceeded, the measured value is displayed in red and marked by a preceding asterisk in the result table.

The results of the power limit checks are also indicated in the STAT:QUES:ACPL status registry (see "STATus:QUEStionable:ACPLimit Register").

Remote command:

CALCulate:​LIMit:​ACPower[:​STATe]

CALCulate:​LIMit:​ACPower:​ACHannel:​ABSolute:​STATe

CALCulate:​LIMit:​ACPower:​ACHannel:​ABSolute

CALCulate:​LIMit:​ACPower:​ACHannel[:​RELative]:​STATe

CALCulate:​LIMit:​ACPower:​ACHannel[:​RELative]

CALCulate:​LIMit:​ACPower:​ALTernate<ch>:​ABSolute:​STATe

CALCulate:​LIMit:​ACPower:​ALTernate<ch>:​ABSolute

CALCulate:​LIMit:​ACPower:​ALTernate<ch>[:​RELative]:​STATe

CALCulate:​LIMit:​ACPower:​ALTernate<ch>[:​RELative]

CALCulate:​LIMit:​ACPower:​ACHannel:​RESult?


Weighting Filters

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > Channel Setup > Weighting Filters
Weighting Filters

Weighting filters allow you to determine the influence of individual channels on the total measurement result. For each channel you can activate or deactivate the use of the weighting filter and define an individual weighting factor ("Alpha" value).

Weighting filters are not available for all supported standards and cannot always be defined manually where they are available.

Remote command:

Activating/Deactivating:

[SENSe:​]POWer:​ACHannel:​FILTer[:​STATe]:​CHANnel<ch>

[SENSe:​]POWer:​ACHannel:​FILTer[:​STATe]:​ACHannel

[SENSe:​]POWer:​ACHannel:​FILTer[:​STATe]:​ALTernate<ch>

Alpha value:

[SENSe:​]POWer:​ACHannel:​FILTer:​ALPHa:​CHANnel<ch>

[SENSe:​]POWer:​ACHannel:​FILTer:​ALPHa:​ACHannel

[SENSe:​]POWer:​ACHannel:​FILTer:​ALPHa:​ALTernate<ch>


Channel Names

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Channel Power Configuration > Channel Setup > Channel Names
Channel Names

In the R&S FSW's display, carrier channels are labelled "Tx" by default; the first neighboring channel is labelled "Adj" (adjacent) channel; all others are labelled "Alt" (alternate) channels. You can define user-specific channel names for each channel which are displayed in the result diagram and result table.

Remote command:

[SENSe:​]POWer:​ACHannel:​NAME:​ACHannel

[SENSe:​]POWer:​ACHannel:​NAME:​ALTernate<ch>

[SENSe:​]POWer:​ACHannel:​NAME:​CHANnel<ch>


MSR ACLR Configuration

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration
MSR ACLR Configuration

ACLR measurements can also be performed on input containing multiple signals for different communication standards. A new measurement standard is provided that allows you to define multiple discontiguous transmit channels at specified frequencies, independent from the selected center frequency. If the "Multi-Standard Radio" standard is selected (see "Standard"), the "ACLR Setup" dialog box is replaced by the "MSR ACLR Setup" dialog box.

To display the "MSR ACLR Setup" dialog box, do one of the following:

  • Select the "CP/ACLR Standard" softkey from the "CH Power" menu and select the "Multi-Standard Radio" standard. Then select the "CP/ACLR Config" softkey.
  • Select the "CP/ACLR Config" softkey from the "CH Power" menu. Then select the "Multi-Standard Radio" standard from the "Standard" selection list.

For more information see "Measurement on Multi-Standard Radio (MSR) Signals".

The remote commands required to perform these tasks are described in "Measuring the Channel Power and ACLR".

Contents
  • General MSR ACLR Measurement Settings
  • MSR Sub block and Tx Channel Definition
  • MSR Adjacent and Gap Channel Setup


General MSR ACLR Measurement Settings

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings
General MSR ACLR Measurement Settings

ACLR measurements can also be performed on input containing multiple signals for different communication standards. A new measurement standard is provided that allows you to define multiple discontiguous transmit channels at specified frequencies, independent from the selected center frequency. If the "Multi-Standard Radio" standard is selected (see "Standard"), the "ACLR Setup" dialog box is replaced by the "MSR ACLR Setup" dialog box.

General MSR ACLR measurement settings are defined in the "MSR ACLR Setup" dialog, in the "MSR General Settings" tab.

Channel configuration is described in "MSR Sub block and Tx Channel Definition" and "MSR Adjacent and Gap Channel Setup".

└ Standard
└ Predefined Standards
└ User-Defined Standards
└ Number of Sub blocks
└ Reference Channel
└ Noise cancellation
└ Selected Trace
└ Absolute and Relative Values (ACLR Mode)
└ Channel Power Levels and Density (Power Unit)
└ Power Mode
└ Optimized Settings (Adjust Settings)


Number of Sub blocks

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings > Number of Sub blocks
Number of Sub blocks

Defines the number of sub blocks, i.e. groups of transmission channels in an MSR signal.

For more information see "Measurement on Multi-Standard Radio (MSR) Signals".

Remote command:

[SENSe:​]POWer:​ACHannel:​SBCount


Reference Channel

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings > Reference Channel
Reference Channel

The measured power values in the adjacent channels can be displayed relative to the transmission channel. If more than one Tx channel is defined, you must select which one is to be used as a reference channel.

Tx Channel 1 | Transmission channel 1 is used. (Not available for MSR ACLR)
Min Power Tx Channel | The transmission channel with the lowest power is used as a reference channel.
Max Power Tx Channel | The transmission channel with the highest power is used as a reference channel (Default).
Lowest & Highest Channel | The outer left-hand transmission channel is the reference channel for the lower adjacent channels, the outer right-hand transmission channel that for the upper adjacent channels.
Remote command:

[SENSe:​]POWer:​ACHannel:​REFerence:​TXCHannel:​MANual

[SENSe:​]POWer:​ACHannel:​REFerence:​TXCHannel:​AUTO


Selected Trace

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings > Selected Trace
Selected Trace

The CP/ACLR measurement can be performed on any active trace.

Remote command:

[SENSe:​]POWer:​TRACe


Absolute and Relative Values (ACLR Mode)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings > Absolute and Relative Values (ACLR Mode)
Absolute and Relative Values (ACLR Mode)

The powers of the adjacent channels are output in dBm or dBm/Hz (absolute values), or in dBc, relative to the specified reference Tx channel.

"Abs" | The absolute power in the adjacent channels is displayed in the unit of the y-axis, e.g. in dBm, dBµV.
"Rel" | The level of the adjacent channels is displayed relative to the level of the transmission channel in dBc.
Remote command:

[SENSe:​]POWer:​ACHannel:​MODE


Channel Power Levels and Density (Power Unit)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings > Channel Power Levels and Density (Power Unit)
Channel Power Levels and Density (Power Unit)

By default, the channel power is displayed in absolute values. If "/Hz" is activated, the channel power density is displayed instead. Thus, the absolute unit of the channel power is switched from dBm to dBm/Hz.

Note: The channel power density in dBm/Hz corresponds to the power inside a bandwidth of 1 Hz and is calculated as follows:
"channel power density = channel power – log10(channel bandwidth)"

Thus you can measure the signal/noise power density, for example, or use the additional functions "Absolute and Relative Values (ACLR Mode)" and "Reference Channel" to obtain the signal to noise ratio.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​RESult:​PHZ


Power Mode

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings > Power Mode
Power Mode

The measured power values can be displayed directly for each trace ("Clear/Write"), or only the maximum values over a series of measurements can be displayed ("Max Hold"). In the latter case, the power values are calculated from the current trace and compared with the previous power value using a maximum algorithm. The higher value is retained. If "Max Hold" mode is activated, "Pwr Max" is indicated in the table header. Note that the trace mode remains unaffected by this setting.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​MODE


Optimized Settings (Adjust Settings)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > General MSR ACLR Measurement Settings > Optimized Settings (Adjust Settings)
Optimized Settings (Adjust Settings)

All instrument settings for the selected channel setup (channel bandwidth, channel spacing) can be optimized automatically.

The adjustment is carried out only once. If necessary, the instrument settings can be changed later.

The following settings are optimized by "Adjust Settings":

  • "Frequency Span"
  • "Resolution Bandwidth (RBW)"
  • "Video Bandwidth (VBW)"
  • "Detector"
  • " Trace Averaging"

Note: The reference level is not affected by this function. To adjust the reference level automatically, use the "Setting the Reference Level Automatically (Auto Level)" function in the AUTO SET menu.

Remote command:

[SENSe:​]POWer:​ACHannel:​PRESet


MSR Sub block and Tx Channel Definition

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition
MSR Sub block and Tx Channel Definition

The "Tx Channel Settings" tab in the "MSR ACLR Setup" dialog box provides all the channel settings to configure sub blocks and Tx channels in MSR ACLR measurements.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

For details on setting up channels, see "How to Configure an MSR ACLR Measurement".

The Tx channel settings for the individual sub blocks are configured in individual subtabs of the "Tx Channel Settings" tab.

└ Sub block Definition
└ Sub block Center Frequency
└ RF Bandwidth
└ Number of Tx Channels (Tx Count)
└ Tx Channel Definition
└ Tx Center Frequency
└ Technology Used for Transmission
└ Tx Channel Bandwidth
└ Weighting Filters


Sub block Definition

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Sub block Definition
Sub block Definition

Sub blocks are groups of transmit channels in an MSR signal. Up to 5 sub blocks can be defined. They are defined as an RF bandwidth around a center frequency with a specific number of transmit channels (max. 18).

Sub blocks are named A,B,C,D,E and are indicated by a slim blue bar along the frequency axis.

The Tx channel settings for the individual sub blocks are configured in individual subtabs of the "Tx Channel Settings" tab.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

└ Sub block Center Frequency
└ RF Bandwidth
└ Number of Tx Channels (Tx Count)


Sub block Center Frequency

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Sub block Definition > Sub block Center Frequency
Sub block Center Frequency

Defines the center of an MSR sub block. Note that the position of the sub block also affects the position of the adjacent gap channels (CACLR).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Remote command:

[SENSe:​]POWer:​ACHannel:​SBLock<sb>:​FREQuency:​CENTer


RF Bandwidth

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Sub block Definition > RF Bandwidth
RF Bandwidth

Defines the bandwidth of the individual MSR sub block. Note that sub block ranges also affect the position of the adjacent gap channels (CACLR).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Remote command:

[SENSe:​]POWer:​ACHannel:​SBLock<sb>:​RFBWidth


Number of Tx Channels (Tx Count)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Sub block Definition > Number of Tx Channels (Tx Count)
Number of Tx Channels (Tx Count)

Defines the number of transmit channels the specific sub block contains. The maximum is 18 Tx channels.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Remote command:

[SENSe:​]POWer:​ACHannel:​SBLock<sb>:​TXCHannel:​COUNt


Tx Channel Definition

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Tx Channel Definition
Tx Channel Definition

As opposed to common ACLR channel definitions, the Tx channels are defined at absolute frequencies, rather than by a spacing relative to the (common) center frequency. Each transmit channel can be assigned a different technology, used to predefine the required bandwidth.

The Tx channel settings for the individual sub blocks are configured in individual subtabs of the "Tx Channel Settings" tab.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

For details on configuring MSR Tx channels see "How to Configure an MSR ACLR Measurement".

Note: Channel names. In MSR ACLR measurements, Tx channel names correspond to the specified technology (for LTE including the bandwidth), followed by a consecutive number. (If the channel is too narrow to display the channel name, it is replaced by "..." on the screen.) Channel names cannot be defined manually. The assigned sub block (A,B,C,D,E) is indicated with the channel name (e.g. B:LTE_5M1).

Remote command:

[SENSe:​]POWer:​ACHannel:​SBLock<sb>:​NAME[:​CHANnel<ch>]?

└ Tx Center Frequency
└ Technology Used for Transmission
└ Tx Channel Bandwidth
└ Weighting Filters


Tx Center Frequency

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Tx Channel Definition > Tx Center Frequency
Tx Center Frequency

Defines the (absolute) center frequency of an MSR Tx channel. Each Tx channel is defined independently of the others; automatic spacing as in common ACLR measurements is not performed.

Note that the position of the first Tx channel in the first sub block and the last Tx channel in the last sub block also affect the position of the adjacent channels.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Remote command:

[SENSe:​]POWer:​ACHannel:​SBLock<sb>:​CENTer[:​CHANnel<ch>]


Technology Used for Transmission

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Tx Channel Definition > Technology Used for Transmission
Technology Used for Transmission

The technology used for transmission by the individual channel can be defined for each channel. The required channel bandwidth and use of a weighting filter are preconfigured automatically according to the selected technology standard.

"GSM" | Transmission according to GSM standard
"W-CDMA" | Transmission according to W-CDMA standard
"LTE_xxx" | Transmission according to LTE standard for different channel bandwidths
"USER" | User-defined transmission; no automatic preconfiguration possible
Remote command:

[SENSe:​]POWer:​ACHannel:​SBLock<sb>:​TECHnology[:​CHANnel<ch>]


Tx Channel Bandwidth

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Tx Channel Definition > Tx Channel Bandwidth
Tx Channel Bandwidth

The Tx channel bandwidth is normally defined by the transmission technology standard. The correct bandwidth is predefined automatically for the selected technology. Each Tx channel is defined independently of the others; automatic bandwidth configuration for subsequent channels as in common ACLR measurements is not performed.

The bandwidth for each channel is indicated by a colored bar in the display.

Remote command:

[SENSe:​]POWer:​ACHannel:​SBLock<sb>:​BANDwidth|BWIDth[:​CHANnel<ch>]


Weighting Filters

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Sub block and Tx Channel Definition > Tx Channel Definition > Weighting Filters
Weighting Filters

Weighting filters allow you to determine the influence of individual channels on the total measurement result. For each channel you can activate or deactivate the use of the weighting filter and define an individual weighting factor ("Alpha" value).

Remote command:

Activating/Deactivating:

[SENSe:​]POWer:​ACHannel:​FILTer:​STATe:​SBLock<sb>:​CHANnel<ch>

Alpha value:

[SENSe:​]POWer:​ACHannel:​FILTer:​ALPHa:​SBLock<sb>:​CHANnel<ch>


MSR Adjacent and Gap Channel Setup

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup
MSR Adjacent and Gap Channel Setup

The "Adj/Gap Channel Settings" tab in the "MSR ACLR Setup" dialog box provides all the channel settings to configure adjacent and gap (CACLR) channels in MSR ACLR measurements.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

For details on setting up channels see "How to Configure an MSR ACLR Measurement".

└ Number of Adjacent Channels (ADJ Count)
└ Limit Checking
└ Adjacent Channel Definition
└ Adjacent Channel Spacings
└ Adjacent Channel Bandwidths
└ Weighting Filters
└ Limit Checking
└ Gap (CACLR) Channel Definition
└ Gap (CACLR) Channel Spacings
└ Gap (CACLR) Channel Bandwidths
└ Weighting Filters
└ Limit Checking


Number of Adjacent Channels (ADJ Count)

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Number of Adjacent Channels (ADJ Count)
Number of Adjacent Channels (ADJ Count)

Defines the number of adjacent channels above and below the Tx channel block in an MSR signal. The carrier channel to which the relative adjacent-channel power values should be referenced must be defined (see "Reference Channel").

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Remote command:

[SENSe:​]POWer:​ACHannel:​ACPairs


Limit Checking

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Limit Checking
Limit Checking

Activates or deactivates limit checks globally for all adjacent and gap (CACLR) channels. In addition, limits must be defined and activated individually for each channel.

The results of the power limit checks are also indicated in the STAT:QUES:ACPL status registry (see "STATus:QUEStionable:ACPLimit Register").

Remote command:

CALCulate:​LIMit:​ACPower[:​STATe]


Adjacent Channel Definition

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Adjacent Channel Definition
Adjacent Channel Definition

Defines the channels adjacent to the transmission channel block in MSR signals. A maximum of 12 adjacent channels can be defined.

For MSR signals, adjacent channels are defined in relation to the center frequency of the first and last transmission channel in the entire block, i.e.:

The lower adjacent channels are defined in relation to the CF of the first Tx channel in the first sub block.

The upper adjacent channels are defined in relation to the CF of the last Tx channel in the last sub block.

Adjacent channels are named "Adj" and "Alt1" to "Alt11"; the names cannot be changed manually.

In all other respects, channel definition is identical to common ACLR measurements.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

└ Adjacent Channel Spacings
└ Adjacent Channel Bandwidths
└ Weighting Filters
└ Limit Checking


Adjacent Channel Spacings

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Adjacent Channel Definition > Adjacent Channel Spacings
Adjacent Channel Spacings

Channel spacings are normally predefined by the selected technology but can be changed.

For MSR signals, adjacent channels are defined in relation to the center frequency of the first and last transmission channel in the entire block, i.e.:

The spacing of the lower adjacent channels refers to the CF of the first Tx channel in the first sub block.

The spacing of the upper adjacent channels refers to the CF of the last Tx channel in the last sub block.

If you change the adjacent-channel spacing (ADJ), all higher adjacent channel spacings (ALT1, ALT2, …) are multiplied by the same factor (new spacing value/old spacing value). Again, only one value needs to be entered for equal channel spacing. For different spacing, configure the spacings from top to bottom.

For details see "How to Configure an MSR ACLR Measurement"

Remote command:

[SENSe:​]POWer:​ACHannel:​SPACing[:​ACHannel]

[SENSe:​]POWer:​ACHannel:​SPACing:​ALTernate<ch>


Adjacent Channel Bandwidths

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Adjacent Channel Definition > Adjacent Channel Bandwidths
Adjacent Channel Bandwidths

The adjacent channel bandwidth is normally predefined by the transmission technology standard. The correct bandwidth is set automatically for the selected technology. The bandwidth for each channel is indicated by a colored bar in the display.

The value entered for any ADJ or ALT channel is automatically also defined for all subsequent alternate (ALT) channels. Thus, only one value needs to be entered if all adjacent channels have the same bandwidth.

Remote command:

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth:​ACHannel

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth:​ALTernate<ch>


Weighting Filters

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Adjacent Channel Definition > Weighting Filters
Weighting Filters

Weighting filters allow you to determine the influence of individual channels on the total measurement result. For each channel you can activate or deactivate the use of the weighting filter and define an individual weighting factor ("Alpha" value).

Remote command:

Activating/Deactivating:

[SENSe:​]POWer:​ACHannel:​FILTer[:​STATe]:​ACHannel

[SENSe:​]POWer:​ACHannel:​FILTer[:​STATe]:​ALTernate<ch>

Alpha value:

[SENSe:​]POWer:​ACHannel:​FILTer:​ALPHa:​ACHannel

[SENSe:​]POWer:​ACHannel:​FILTer:​ALPHa:​ALTernate<ch>


Limit Checking

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Adjacent Channel Definition > Limit Checking
Limit Checking

During an ACLR measurement, the power values can be checked whether they exceed user-defined or standard-defined limits. A relative or absolute limit can be defined, or both, for each individual adjacent channel. Both limit types are considered, regardless whether the measured levels are absolute or relative values. The check of both limit values can be activated independently. If any active limit value is exceeded, the measured value is displayed in red and marked by a preceding asterisk in the result table.

Note that in addition to activating limit checking for individual channels, limit checking must also be activated globally for the MSR ACLR measurement (see "Limit Checking").

Remote command:

CALCulate:​LIMit:​ACPower[:​STATe]

CALCulate:​LIMit:​ACPower:​ACHannel:​ABSolute:​STATe

CALCulate:​LIMit:​ACPower:​ACHannel:​ABSolute

CALCulate:​LIMit:​ACPower:​ACHannel[:​RELative]:​STATe

CALCulate:​LIMit:​ACPower:​ACHannel[:​RELative]

CALCulate:​LIMit:​ACPower:​ALTernate<ch>:​ABSolute:​STATe

CALCulate:​LIMit:​ACPower:​ALTernate<ch>:​ABSolute

CALCulate:​LIMit:​ACPower:​ALTernate<ch>[:​RELative]:​STATe

CALCulate:​LIMit:​ACPower:​ALTernate<ch>[:​RELative]

CALCulate:​LIMit:​ACPower:​ACHannel:​RESult?


Gap (CACLR) Channel Definition

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Gap (CACLR) Channel Definition
Gap (CACLR) Channel Definition

Between two sub blocks in an MSR signal, two gaps are defined: a lower gap and an upper gap. Each gap in turn contains 2 channels, the CACLR channels. The channels in the upper gap are identical to those in the lower gap, but inverted. Thus, in the R&S FSW MSR ACLR measurement, only 2 gap channels are configured.

Gap channels (CACLR) are indicated by the names of the surrounding sub blocks (e.g. "AB" for the gap between sub blocks A and B), followed by the channel name ("Gap1" or "Gap2") and an "L" (for lower) or a "U" (for upper). Both the lower and upper gap channels are displayed. However, if the gap between two sub blocks is too narrow, the second gap channel may not be displayed. If the gap is even narrower, no gap channels are displayed.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

└ Gap (CACLR) Channel Spacings
└ Gap (CACLR) Channel Bandwidths
└ Weighting Filters
└ Limit Checking


Gap (CACLR) Channel Spacings

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Gap (CACLR) Channel Definition > Gap (CACLR) Channel Spacings
Gap (CACLR) Channel Spacings

CACLR channel spacings are normally predefined by the MSR standard but can be changed.

CACLR channels are defined using bandwidths and spacings, relative to the outer edges of the surrounding sub blocks. Since the upper and lower CACLR channels are identical, only two channels must be configured. The required spacing can be determined according to the following formula (indicated for lower channels):

Spacing = [CF of the gap channel] - [left sub block center] + ([RF bandwidth of left sub block] /2)

Spacing = [CF of the gap channel] - [left sub block center] + ([RF bandwidth of left sub block] /2)

(See also figure "MSR signal structure" and figure "Sub block definition".)

For details see "How to Configure an MSR ACLR Measurement".

Remote command:

[SENSe:​]POWer:​ACHannel:​SPACing:​GAP<gap>


Gap (CACLR) Channel Bandwidths

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Gap (CACLR) Channel Definition > Gap (CACLR) Channel Bandwidths
Gap (CACLR) Channel Bandwidths

The gap channel bandwidth is normally predefined by the transmission technology standard. The correct bandwidth is set automatically for the selected technology. The bandwidth for each channel is indicated by a colored bar in the display (if the gap is not too narrow, see "Channel display for MSR signals").

Remote command:

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth:​GAP<gap>


Weighting Filters

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Gap (CACLR) Channel Definition > Weighting Filters
Weighting Filters

Weighting filters allow you to determine the influence of individual channels on the total measurement result. For each channel you can activate or deactivate the use of the weighting filter and define an individual weighting factor ("Alpha" value).

Remote command:

[SENSe:​]POWer:​ACHannel:​FILTer:​STATe:​GAP<gap>

[SENSe:​]POWer:​ACHannel:​FILTer:​ALPHa:​GAP<gap>


Limit Checking

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > MSR ACLR Configuration > MSR Adjacent and Gap Channel Setup > Gap (CACLR) Channel Definition > Limit Checking
Limit Checking

During an ACLR measurement, the power values can be checked whether they exceed user-defined or standard-defined limits. A relative or absolute limit can be defined, or both, for each individual gap channel. Both limit types are considered, regardless whether the measured levels are absolute or relative values. The check of both limit values can be activated independently. If any active limit value is exceeded, the measured value is displayed in red and marked by a preceding asterisk in the result table.

Note that in addition to activating limit checking for individual channels, limit checking must also be activated globally for the MSR ACLR measurement (see "Limit Checking").

Remote command:

CALCulate:​LIMit:​ACPower[:​STATe]

CALCulate:​LIMit:​ACPower:​GAP<gap>:​ABSolute:​STATe

CALCulate:​LIMit:​ACPower:​GAP<gap>:​ABSolute

CALCulate:​LIMit:​ACPower:​GAP<gap>[:​RELative:​]STATe

CALCulate:​LIMit:​ACPower:​GAP<gap>[:​RELative]

CALCulate:​LIMit:​ACPower:​GAP<gap>:​RESult?


How to Perform Channel Power Measurements

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > How to Perform Channel Power Measurements
How to Perform Channel Power Measurements

The following step-by-step instructions demonstrate the most common tasks when performing channel power measurements.

Contents
  • How to Perform a Standard Channel Power Measurement
  • How to Set up the Channels
  • How to Configure an MSR ACLR Measurement
  • How to Manage User-Defined Configurations
  • How to Compare the Tx Channel Power in Successive Measurements


How to Perform a Standard Channel Power Measurement

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > How to Perform Channel Power Measurements > How to Perform a Standard Channel Power Measurement
How to Perform a Standard Channel Power Measurement

Performing a channel power or ACLR measurement according to common standards is a very easy and straightforward task with the R&S FSW.

  1. Press the MEAS key or select "Select Measurement" in the "Overview".

  2. Select "Channel Power ACLR".

    The measurement is started immediately with the default settings.

  3. Select the "CP / ACLR Standard" softkey and select a standard from the list.

    The measurement is restarted with the predefined settings for the selected standard.

  4. If necessary, edit the settings for your specific measurement as described in "How to Set up the Channels", or load a user-defined configuration (see "To load a user-defined configuration").


How to Set up the Channels

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > How to Perform Channel Power Measurements > How to Set up the Channels
How to Set up the Channels

Channel definition is the basis for measuring power levels in certain frequency ranges. Usually, the power levels in one or more carrier (Tx) channels and possibly the adjacent channels are of interest. Up to 18 carrier channels and up to 12 adjacent channels can be defined.

When a measurement standard is selected in the "Ch Power" menu or the "ACLR Setup" dialog box, all settings including the channel bandwidths and channel spacings are set according to the selected standard and can be adjusted afterwards.

Channel setup consists of the following settings:

  • The number of transmission (Tx) and adjacent channels
  • The bandwidth of each channel
  • For multicarrier ACLR measurements: which Tx channel is used as a reference
  • The spacing between the individual channels
  • Optionally: the names of the channels displayed in the diagram and result table
  • Optionally: the influence of individual channels on the total measurement result ("Weighting Filter")
  • Optionally: limits for a limit check on the measured power levels

Changes to an existing standard can be stored as a user-defined standard, see "How to Manage User-Defined Configurations".

►

In the "Ch Power" menu, select the "CP / ACLR Config" softkey, then select the "Channel Settings" tab to configure the channels in the "ACLR Setup" dialog box.

In the "Channel Setup" dialog box you can define the channel settings for all channels, independent of the defined number of used Tx or adjacent channels.

To define channel spacings

Channel spacings are normally defined by the selected standard but can be changed.

►

In the "Channel Settings" tab of the "ACLR Setup" dialog box, select the "Spacing" subtab.

The value entered for any Tx channel is automatically also defined for all subsequent Tx channels. Thus, only one value needs to be entered if all Tx channels have the same spacing.

If the channel spacing for the adjacent or an alternate channel is changed, all higher alternate channel spacings are multiplied by the same factor (new spacing value/old spacing value). The lower adjacent-channel spacings remain unchanged. Only one value needs to be entered for equal channel spacing.

Example: Defining channel spacing

In the default setting, the adjacent channels have the following spacing: 20 kHz ("ADJ"), 40 kHz ("ALT1"), 60 kHz ("ALT2"), 80 kHz ("ALT3"), 100 kHz ("ALT4"), …

If the spacing of the first adjacent channel ("ADJ") is set to 40 kHz, the spacing of all other adjacent channels is multiplied by factor 2 to result in 80 kHz ("ALT1"), 120 kHz ("ALT2"), 160 kHz ("ALT3"), …

If, starting from the default setting, the spacing of the 5th adjacent channel ("ALT4") is set to 150 kHz, the spacing of all higher adjacent channels is multiplied by factor 1.5 to result in 180 kHz ("ALT5"), 210 kHz ("ALT6"), 240 kHz ("ALT7"), …


How to Configure an MSR ACLR Measurement

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > How to Perform Channel Power Measurements > How to Configure an MSR ACLR Measurement
How to Configure an MSR ACLR Measurement

Performing an ACLR measurement on MSR signals is supported by a special configuration with the R&S FSW.

  1. Press the MEAS key or select "Select Measurement" in the "Overview".

  2. Select "Channel Power ACLR".

    The measurement is started immediately with the default settings.

  3. Select the "CP / ACLR Standard" softkey and select the "Multi-Standard Radio" standard from the list.

  4. Select the "CP / ACLR Config" softkey to configure general MSR settings, including the number of sub blocks (up to 5).

  5. Select the "Tx Channel Settings" tab to configure the sub blocks and transmission channels.

    For each sub block:

    1. Define the (center frequency) position and bandwidth of the sub block, as well as the number of transmission channels it contains.

    2. For each transmission channel in the sub block, define the center frequency and select the technology used for transmission. If necessary, edit the bandwidth and define the use of a weighting filter for the channel.

  6. Select the "Adj/Gap Channel Settings" tab to configure the adjacent and gap (CACLR) channels.

  7. Define the number of adjacent channels and the settings for each channel:

    • The spacing, defined as the distance from the center frequency of the first transmission channel in the first sub block. If the distance between each adjacent channel and the next is identical, you only need to define the spacing for the first adjacent channel, the others are adapted automatically.
    • The bandwidth; if it is identical for all adjacent channels, you only need to define the bandwidth for the first channel, the others are adapted automatically.
    • If necessary, a weighting filter
    • Optionally, define and activate relative or absolute limits, or both, against which the power levels of the channel are to be checked.

  8. Define the settings for the two (upper or lower) gap (CACLR) channels; since the upper and lower channels are identical, it is only necessary to configure two channels.

    • The spacing, defined as the distance from the outer edge of the sub block to the left or right of the gap. The required spacing can be determined as follows:
      Spacing = [CF of the gap channel] - [left sub block center] + ([RF bandwidth of left sub block] /2)
    • The bandwidth
    • If necessary, a weighting filter
    • Optionally, define and activate relative or absolute limits, or both, against which the power levels of the channel are to be checked.

  9. If power limits are defined and activated, activate global limit checking for the measurement on the "Adj/Gap Channel Settings" tab.

  10. Optionally, store the settings for the MSR ACLR measurement as a user-defined standard as described in "To store a user-defined configuration". Otherwise the configuration will be lost when you select a different measurement standard!


How to Manage User-Defined Configurations

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > How to Perform Channel Power Measurements > How to Manage User-Defined Configurations
How to Manage User-Defined Configurations

You can define measurement configurations independently of a predefined standard and save the current ACLR configuration as a "user standard" in an xml file. You can then load the file and thus the settings again at a later time.

User-defined standards are not supported for "Fast ACLR" and multicarrier ACLR measurements.

Compatibility to R&S FSP

User standards created on an analyzer of the R&S FSP family are compatible to the R&S FSW. User standards created on an R&S FSW, however, are not necessarily compatible to the analyzers of the R&S FSP family and may not work there.

To store a user-defined configuration

  1. In the "Ch Power" menu, select the "CP / ACLR Config" softkey to display the "ACLR Setup" dialog box.

  2. Configure the measurement as required (see also "How to Set up the Channels").

  3. In the "General Settings" tab, select the "Manage User Standards" button to display the "Manage" dialog box.

  4. Define a file name for the user standard and select its storage location.

    By default, the xml file is stored in C:\R_S\Instr\acp_std\. However, you can define any other storage location.

  5. Select "Save".

To load a user-defined configuration

  1. In the "General Settings" tab of the "ACLR Setup" dialog box, select the "Manage User Standards" button to display the "Manage" dialog box.

  2. Select the user standard file.

  3. Select "Load".

    The stored settings are automatically set on the R&S FSW and the measurement is restarted with the new parameters.


How to Compare the Tx Channel Power in Successive Measurements

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > How to Perform Channel Power Measurements > How to Compare the Tx Channel Power in Successive Measurements
How to Compare the Tx Channel Power in Successive Measurements

For pure channel power measurements, where no adjacent channels and only one Tx channel is defined, you can define a fixed reference power and compare subsequent measurement results to the stored reference power.

  1. Configure a measurement with only one Tx channel and no adjacent channels (see also "How to Set up the Channels").

  2. Select the "Set CP Reference" softkey in the "Ch Power" menu, or the "Set CP Reference" button in the "ACLR Setup" dialog box.

    The channel power currently measured on the Tx channel is stored as a fixed reference power. The reference value is displayed in the "Reference" field of the result table (in relative ACLR mode).

  3. Start a new measurement.

    The resulting power is indicated relative to the fixed reference power.

  4. Repeat this for any number of measurements.

  5. To start a new measurement without the fixed reference, temporarily define a second channel or preset the instrument.


Measurement Examples

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Measurement Examples
Measurement Examples

The R&S FSW has test routines for simple channel and adjacent channel power measurements. These routines give quick results without any complex or tedious setting procedures.

Contents
  • Measurement Example 1 – ACPR Measurement on an CDMA2000 Signal
  • Measurement Example 2 – Measuring Adjacent Channel Power of a W-CDMA Uplink Signal
  • Measurement Example 3 – Measuring the Intrinsic Noise of the R&S FSW with the Channel Power Function


Measurement Example 1 – ACPR Measurement on an CDMA2000 Signal

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Measurement Examples > Measurement Example 1 – ACPR Measurement on an CDMA2000 Signal
Measurement Example 1 – ACPR Measurement on an CDMA2000 Signal
Test setup:
Signal generator settings (e.g. R&S SMU):
Frequency: | 850 MHz
Level: | 0 dBm
Modulation: | CDMA2000
Procedure:

  1. Preset the R&S FSW.

  2. Set the center frequency to 850 MHz.

  3. Set the span to 4 MHz.

  4. Set the reference level to +10 dBm.

  5. Select the "Channel Power ACLR" measurement function from the "Select Measurement" dialog box.

  6. Set the "CDMA2000 1X" standard for adjacent channel power measurement in the "ACLR Setup" dialog box.

    The R&S FSW sets the channel configuration according to the 2000 standard with 2 adjacent channels above and 2 below the transmit channel. The spectrum is displayed in the upper part of the screen, the numeric values of the results and the channel configuration in the lower part of the screen. The various channels are represented by vertical lines on the graph.

    The frequency span, resolution bandwidth, video bandwidth and detector are selected automatically to give correct results. To obtain stable results – especially in the adjacent channels (30 kHz bandwidth) which are narrow in comparison with the transmission channel bandwidth (1.23 MHz) – the RMS detector is used.

  7. Set the optimal reference level and RF attenuation for the applied signal level using the "Auto Level" function in the AUTO SET menu.

  8. Activate "Fast ACLR" mode in the "ACLR Setup" dialog box to increase the repeatability of results.

    The R&S FSW sets the optimal RF attenuation and the reference level based on the transmission channel power to obtain the maximum dynamic range. The figure "Adjacent channel power measurement on a CDMA2000 1x signal" shows the result of the measurement.

    Adjacent channel power measurement on a CDMA2000 1x signal


Measurement Example 2 – Measuring Adjacent Channel Power of a W-CDMA Uplink Signal

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Measurement Examples > Measurement Example 2 – Measuring Adjacent Channel Power of a W-CDMA Uplink Signal
Measurement Example 2 – Measuring Adjacent Channel Power of a W-CDMA Uplink Signal
Test setup:
Signal generator settings (e.g. R&S FSW SMU):
Frequency: | 1950 MHz
Level: | 4 dBm
Modulation: | 3GPP W-CDMA Reverse Link
Procedure:

  1. Preset the R&S FSW.

  2. Set the center frequency to 1950 MHz.

  3. Select the "Channel Power ACLR" measurement function from the "Select Measurement" dialog box.

  4. Set the "W-CDMA 3GPP REV" standard for adjacent channel power measurement in the "ACLR Setup" dialog box.

    The R&S FSW sets the channel configuration to the W-CDMA standard for mobiles with two adjacent channels above and below the transmit channel. The frequency span, the resolution and video bandwidth and the detector are automatically set to the correct values. The spectrum is displayed in the upper window and the channel power, the level ratios of the adjacent channel powers and the channel configuration in the lower window. The individual channels are displayed as bars in the graph.

  5. Set the optimal reference level and RF attenuation for the applied signal level using the "Auto Level" function.

    The R&S FSW sets the optimum RF attenuation and the reference level for the power in the transmission channel to obtain the maximum dynamic range. The following figure shows the result of the measurement.

    Measuring the relative adjacent channel power on a W-CDMA uplink signal

    The R&S FSW measures the power of the individual channels with zero span. A root raised cosine filter with the parameters α = 0.22 and chip rate 3.84 Mcps (= receive filter for W-CDMA) is used as channel filter.

Optimum Level Setting for ACLR Measurements on W-CDMA Signals

The dynamic range for ACLR measurements is limited by the thermal noise floor, the phase noise and the intermodulation (spectral regrowth) of the signal analyzer. The power values produced by the R&S FSW due to these factors accumulate linearly. They depend on the applied level at the input mixer. The three factors are shown in the figure below for the adjacent channel (5 MHz carrier offset).

Dynamic range for ACLR measurements on W-CDMA uplink signals as a function of the mixer level

The level of the W-CDMA signal at the input mixer is shown on the horizontal axis, i.e. the measured signal level minus the selected RF attenuation. The individual components which contribute to the power in the adjacent channel and the resulting relative level (total ACPR) in the adjacent channel are displayed on the vertical axis. The optimum mixer level is -12 dBm. The relative adjacent channel power (ACPR) at an optimum mixer level is -77 dBc. Since, at a given signal level, the mixer level is set in 1 dB steps with the 1 dB RF attenuator, the optimum range spreads from -10 dBm to -14 dBm.

To set the attenuation parameter manually, the following method is recommended:

►

Set the RF attenuation so that the mixer level (= measured channel power – RF attenuation) is between -10 dBm and -14 dBm.

This method is automated with the "Auto Level" function. Especially in remote control mode, e.g. in production environments, it is best to correctly set the attenuation parameters prior to the measurement, as the time required for automatic setting can be saved.

To measure the R&S FSW's intrinsic dynamic range for W-CDMA adjacent channel power measurements, a filter which suppresses the adjacent channel power is required at the output of the transmitter. A SAW filter with a bandwidth of 4 MHz, for example, can be used.


Measurement Example 3 – Measuring the Intrinsic Noise of the R&S FSW with the Channel Power Function

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Measurement Examples > Measurement Example 3 – Measuring the Intrinsic Noise of the R&S FSW with the Channel Power Function
Measurement Example 3 – Measuring the Intrinsic Noise of the R&S FSW with the Channel Power Function

Noise in any bandwidth can be measured with the channel power measurement functions. Thus the noise power in a communication channel can be determined, for example. If the noise spectrum within the channel bandwidth is flat, the noise marker can be used to determine the noise power in the channel by considering the channel bandwidth. If, however, phase noise and noise that normally increases towards the carrier is dominant in the channel to be measured, or if there are discrete spurious signals in the channel, the channel power measurement method must be used to obtain correct measurement results.

Test setup:
►

Leave the RF input of the R&S FSW open-circuited or terminate it with 50 Ω.

Procedure:

  1. Preset the R&S FSW.

  2. Set the center frequency to 1 GHz and the span to 1 MHz.

  3. To obtain maximum sensitivity, set RF attenuation to 0 dB and the reference level to -40 dBm.

  4. Select the "Channel Power ACLR" measurement function from the "Select Measurement" dialog box.

  5. In the "ACLR Setup" dialog box, set up a single Tx channel with the channel bandwidth 1.23 MHz.

  6. Select the "Adjust Settings" softkey.

    The settings for the frequency span, the bandwidth (RBW and VBW) and the detector are automatically set to the optimum values required for the measurement.

  7. Stabilize the measurement result by increasing the sweep time.

    Set the sweep time to 1 s.

    The trace becomes much smoother because of the RMS detector and the channel power measurement display is much more stable.

    Measurement of the R&S FSW's intrinsic noise power in a 1.23 MHz channel bandwidth.


Optimizing and Troubleshooting the Measurement

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, or if you want to minimize the measurement duration, try the following methods to optimize the measurement:

  • Only activate as many adjacent channels as necessary in order to minimize the required span and thus the required measurement time for the measurement.
  • Increase the RBW to minimize the measurement time; however, consider the requirements of the standard if you need to measure according to standard! The automatic settings are always according to standard.
  • Take advantage of the speed optimization mode in the "Sweep" settings if you do not require the larger dynamic range (see "Optimization").
  • Reduce the sweep time and thus the amount of data to be captured and calculated; however, consider the requirements regarding the standard deviation.
  • To improve the stability of the measured results, increase the sweep time, which also leads to more averaging steps.
  • Instead of trace averaging, use an RMS detector with a higher sweep time to obtain better average power results in less time.
  • To determine a channel power level quickly, use the "Time Domain Power Measurement" (TDP) rather than a Channel Power measurement. The TDP measurement is a zero span measurement where the sweep time determines the measurement time. Due to the FFT measurement, duplicate averaging is performed, providing very stable results very quickly.
    Note, however, that for TDP measurements, channel filters are not available and a fixed RBW is used, so that the measurement may not be according to standard for some test cases.


Reference: Predefined CP/ACLR Standards

Measurements > Channel Power and Adjacent-Channel Power (ACLR) Measurement > Reference: Predefined CP/ACLR Standards
Reference: Predefined CP/ACLR Standards

When using predefined standards for ACLR measurement, the test parameters for the channel and adjacent-channel measurements are configured automatically.

You can select a predefined standard via the "CP / ACLR Standard" softkey in the "Ch Power" menu or the selection list in the "General Settings" tab of the "ACLR Setup" dialog box (see "Standard").

Predefined CP / ACLR standards with remote command parameters
Standard | Remote parameter
None | NONE
Multi-Standard Radio | MSR
EUTRA/LTE Square | EUTRa
EUTRA/LTE Square/RRC | REUTra
W-CDMA 3GPP FWD | FW3Gppcdma
W-CDMA 3GPP REV | RW3Gppcdma
CDMA IS95A FWD | F8CDma
CDMA IS95A REV | R8CDma
CDMA IS95C Class 0 FWD | FIS95c0
CDMA IS95C Class 0 REV | RIS95c0
CDMA J-STD008 FWD | F19Cdma
CDMA J-STD008 REV | R19Cdma
CDMA IS95C Class 1 FWD | FIS95c1
CDMA IS95C Class 1 REV | RIS95c1
CDMA2000 | S2CDma
TD-SCDMA FWD | FTCDma
TD-SCDMA REV | TRCDma
WLAN 802.11A | AWLAN
WLAN 802.11B | BWLAN
WIMAX | WIMax
WIBRO | WIBRo
GSM | GSM
RFID 14443 | RFID14443
TETRA | TETRa
PDC | PDC
PHS | PHS
CDPD | CDPD
APCO-25 P2 | PAPCo25
User Standard | USER
Customized Standard | <string>

For the R&S FSW, the channel spacing is defined as the distance between the center frequency of the adjacent channel and the center frequency of the transmission channel. The definition of the adjacent-channel spacing in standards IS95C and CDMA 2000 is different. These standards define the adjacent-channel spacing from the center of the transmission channel to the closest border of the adjacent channel. This definition is also used by the R&S FSW for the standards marked with an asterisk *).


Carrier-to-Noise Measurements

Measurements > Carrier-to-Noise Measurements
Carrier-to-Noise Measurements

The R&S FSW can easily determine the carrier-to-noise ratio, also normalized to a 1 Hz bandwidth.

Contents
  • About the Measurement
  • Carrier-to-Noise Results
  • Carrier-to-Noise Configuration
  • How to Determine the Carrier-to-Noise Ratio


About the Measurement

Measurements > Carrier-to-Noise Measurements > About the Measurement
About the Measurement

The largest signal in the frequency span is the carrier. It is searched when the C/N or C/NO function is activated and is marked using a fixed reference marker ("FXD").

To determine the noise power, a channel with a defined bandwidth at the defined center frequency is analyzed. The power within this channel is integrated to obtain the noise power level. (If the carrier is within this channel, an extra step is required to determine the correct noise power level, see below.)

The noise power of the channel is subtracted from the maximum carrier signal level, and in the case of a C/NO measurement, it is referred to a 1 Hz bandwidth.

For this measurement, the RMS detector is activated.

The carrier-to-noise measurements are only available in the frequency domain (span >0).

Measurement process

Depending on whether the carrier is inside or outside the analyzed channel, the measurement process for the carrier-to-noise ratio varies:

  • The carrier is outside the analyzed channel: In this case, it is sufficient to switch on the desired measurement function and to set the channel bandwidth. The carrier/noise ratio is displayed on the screen.
  • The carrier is inside the analyzed channel: In this case, the measurement must be performed in two steps:
    – First, perform the reference measurement by switching on either the C/N or the C/NO measurement and waiting for the end of the next measurement run. The fixed reference marker is set to the maximum of the measured carrier signal.
    – Then, switch off the carrier so that only the noise of the test setup is active in the channel. The carrier-to-noise ratio is displayed after the subsequent measurement has been completed.
Frequency Span

The frequency span should be set to approximately 4 times the channel bandwidth in order to measure the carrier-to-noise ratio correctly. This setting is defined automatically by the "Adjust Settings" function.


Carrier-to-Noise Results

Measurements > Carrier-to-Noise Measurements > Carrier-to-Noise Results
Carrier-to-Noise Results

As a result of the carrier-to-noise measurement the evaluated bandwidth and the calculated C/N ratio are displayed in the result window. The fixed reference marker is indicated in the diagram.

Remote command:

You can also query the determined carrier-to-noise ratio via the remote command CALC:MARK:FUNC:POW:RES? CN or CALC:MARK:FUNC:POW:RES? CN0, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?.


Carrier-to-Noise Configuration

Measurements > Carrier-to-Noise Measurements > Carrier-to-Noise Configuration
Carrier-to-Noise Configuration

The Carrier-to-noise ratio (C/N) and the Carrier-to-noise ratio in relation to the bandwidth (C/N0) measurements are selected via the corresponding button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "Carrier Noise" configuration dialog box, which is displayed as a tab in the "Analysis" dialog box or when you select the "Carrier Noise Config" softkey from the "Carrier Noise" menu.

Carrier-to-noise measurements are not available in zero span mode.

The easiest way to configure a measurement is using the configuration "Overview", see "Configuration Overview".

The remote commands required to perform these tasks are described in "Measuring the Carrier-to-Noise Ratio".

└ C/N
└ C/No
└ Channel Bandwidth
└ Adjust Settings


C/N

Measurements > Carrier-to-Noise Measurements > Carrier-to-Noise Configuration > C/N
C/N

Switches the measurement of the carrier/noise ratio on or off. If no marker is active, marker 1 is activated.

The measurement is performed on the trace that marker 1 is assigned to. To shift marker 1 and measure another trace, use the "Marker to Trace" softkey in the "Marker" menu (see "Assigning the Marker to a Trace").

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect

CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]


C/No

Measurements > Carrier-to-Noise Measurements > Carrier-to-Noise Configuration > C/No
C/No

Switches the measurement of the carrier/noise ratio with reference to a 1 Hz bandwidth on or off. If no marker is active, marker 1 is activated.

The measurement is performed on the trace that marker 1 is assigned to. To shift marker 1 and measure another trace, use the "Marker to Trace" softkey in the "Marker" menu (see "Assigning the Marker to a Trace").

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect

CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]


Channel Bandwidth

Measurements > Carrier-to-Noise Measurements > Carrier-to-Noise Configuration > Channel Bandwidth
Channel Bandwidth

Defines the measurement channel bandwidth.

The default setting is 14 kHz.

Remote command:

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth[:​CHANnel<ch>]


Adjust Settings

Measurements > Carrier-to-Noise Measurements > Carrier-to-Noise Configuration > Adjust Settings
Adjust Settings

Enables the RMS detector and adjusts the span to the selected channel bandwidth according to:

"4 x channel bandwidth + measurement margin"

The adjustment is performed once; if necessary, the setting can be changed later on.

Remote command:

[SENSe:​]POWer:​ACHannel:​PRESet


How to Determine the Carrier-to-Noise Ratio

Measurements > Carrier-to-Noise Measurements > How to Determine the Carrier-to-Noise Ratio
How to Determine the Carrier-to-Noise Ratio

  1. Press the "C/N, C/NO" softkey to configure the carrier-to-noise ratio measurement.

  2. To change the channel bandwidth to be analyzed, press the "Channel Bandwidth" softkey.

  3. To optimize the settings for the selected channel configuration, press the "Adjust Settings" softkey.

  4. To activate the measurements without reference to the bandwidth, press the "C/N" softkey.

    To activate the measurements with reference to the bandwidth, press the "C/NO" softkey .

  5. If the carrier signal is located within the analyzed channel bandwidth, switch off the carrier signal so that only the noise is displayed in the channel and perform a second measurement.

    The carrier-to-noise ratio is displayed after the measurement has been completed.


Occupied Bandwidth Measurement (OBW)

Measurements > Occupied Bandwidth Measurement (OBW)
Occupied Bandwidth Measurement (OBW)

An important characteristic of a modulated signal is its occupied bandwidth. In a radio communications system, for instance, the occupied bandwidth must be limited to enable distortion-free transmission in adjacent channels.

Contents
  • About the Measurement
  • OBW Results
  • OBW Configuration
  • How to Determine the Occupied Bandwidth
  • Measurement Example


About the Measurement

Measurements > Occupied Bandwidth Measurement (OBW) > About the Measurement
About the Measurement

The occupied bandwidth is defined as the bandwidth containing a defined percentage of the total transmitted power. A percentage between 10 % and 99.9 % can be set.

Measurement principle

The bandwidth containing 99% of the signal power is to be determined, for example. The algorithm first calculates the total power of all displayed points of the trace. In the next step, the points from the right edge of the trace are summed up until 0.5 % of the total power is reached. Auxiliary marker 1 is positioned at the corresponding frequency. Then the points from the left edge of the trace are summed up until 0.5 % of the power is reached. Auxiliary marker 2 is positioned at this point. 99 % of the power is now between the two markers. The distance between the two frequency markers is the occupied bandwidth which is displayed in the marker field.

OBW within defined search limits - multicarrier OBW measurement in one sweep

The occupied bandwidth of the signal can also be determined within defined search limits instead of for the entire signal. Thus, only a single sweep is required to determine the OBW for a multicarrier signal. To do so, search limits are defined for an individual carrier and the OBW measurement is restricted to the frequency range contained within those limits. Then the search limits are adapted for the next carrier and the OBW is automatically re-calculated for the new range.

For step-by-step instructions see "How to determine the OBW for a multicarrier signal using search limits".

Prerequisites

To ensure correct power measurement, especially for noise signals, and to obtain the correct occupied bandwidth, the following prerequisites and settings are necessary:

  • Only the signal to be measured is displayed in the window, or search limits are defined to include only one (carrier) signal. An additional signal would falsify the measurement.
  • RBW << occupied bandwidth (approx. 1/20 of occupied bandwidth, for voice communication type: 300 Hz or 1 kHz)
  • VBW ≥ 3 x RBW
  • RMS detector
  • Span ≥ 2 to 3 x occupied bandwidth

Some of the measurement specifications (e.g. PDC, RCR STD-27B) require measurement of the occupied bandwidth using a peak detector. The detector setting of the R&S FSW has to be changed accordingly then.


OBW Results

Measurements > Occupied Bandwidth Measurement (OBW) > OBW Results
OBW Results

As a result of the OBW measurement the occupied bandwidth ("Occ BW") is indicated in the marker results. Furthermore, the marker at the center frequency and the temporary markers are indicated.

The measurement is performed on the trace with marker 1. In order to evaluate another trace, marker 1 must be placed on another trace (see "Assigning the Marker to a Trace").

The OBW calculation is repeated if the "Search Limits" are changed, without performing a new sweep. Thus, the OBW for a multicarrier signal can be determined using only one sweep.

Remote command:

The determined occupied bandwidth can also be queried using the remote command CALC:MARK:FUNC:POW:RES? OBW or CALC:MARK:FUNC:POW:RES? AOBW. While the OBW parameter returns only the occupied bandwidth, the AOBW parameter also returns the position and level of the temporary markers T1 and T2 used to calculate the occupied bandwidth.

CALC:MARK:FUNC:POW:SEL OBW, see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]

CALC:MARK:FUNC:POW:RES? OBW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


OBW Configuration

Measurements > Occupied Bandwidth Measurement (OBW) > OBW Configuration
OBW Configuration

OBW measurements are selected via the "OBW" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "Occupied Bandwidth" dialog box, which is displayed as a tab in the "Analysis" dialog box or when you select the "OBW Config" softkey from the "OBW" menu.

This measurement is not available in zero span.

Configuring search limits for OBW measurement

The occupied bandwidth of the signal can also be determined within defined search limits instead of for the entire signal.

The OBW measurement uses the same search limits as defined for marker search (see "Search Limits"). However, only the left and right limits are considered.

For step-by-step instructions see "How to determine the OBW for a multicarrier signal using search limits".

The remote commands required to perform these tasks are described in "Measuring the Occupied Bandwidth".

└ % Power Bandwidth
└ Channel Bandwidth
└ Adjust Settings
└ Search Limits (Left / Right)
└ Deactivating All Search Limits


% Power Bandwidth

Measurements > Occupied Bandwidth Measurement (OBW) > OBW Configuration > % Power Bandwidth
% Power Bandwidth

Defines the percentage of total power in the displayed frequency range which defines the occupied bandwidth. Values from 10% to 99.9% are allowed.

Remote command:

[SENSe:​]POWer:​BANDwidth|BWIDth


Channel Bandwidth

Measurements > Occupied Bandwidth Measurement (OBW) > OBW Configuration > Channel Bandwidth
Channel Bandwidth

Defines the channel bandwidth for the transmission channel in single-carrier measurements. This bandwidth is used to optimize the test parameters (for details see "Adjust Settings"). The default setting is 14 kHz.

For measurements according to a specific transmission standard, define the bandwidth specified by the standard for the transmission channel.

For multicarrier measurements this setting is irrelevant.

Remote command:

[SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth[:​CHANnel<ch>]


Adjust Settings

Measurements > Occupied Bandwidth Measurement (OBW) > OBW Configuration > Adjust Settings
Adjust Settings

Optimizes the instrument settings for the measurement of the occupied bandwidth according to the specified channel bandwidth.

This function is only useful for single carrier measurements.

All instrument settings relevant for power measurement within a specific frequency range are optimized:

  • Frequency span: 3 × channel bandwidth
  • RBW ≤ 1/40 of channel bandwidth
  • VBW ≥ 3 × RBW
  • Detector: RMS

The reference level is not affected by "Adjust Settings". For an optimum dynamic range it should be selected such that the signal maximum is close to the reference level (see "Setting the Reference Level Automatically (Auto Level)").

The adjustment is carried out only once. If necessary, the instrument settings can be changed later.

Remote command:

[SENSe:​]POWer:​ACHannel:​PRESet


Search Limits (Left / Right)

Measurements > Occupied Bandwidth Measurement (OBW) > OBW Configuration > Search Limits (Left / Right)
Search Limits (Left / Right)

If activated, limit lines are defined and displayed for the search. Only results within the limited search range are considered.

For details on limit lines for searches see "Peak search limits".

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​MARKer:​X:​SLIMits:​LEFT

CALCulate:​MARKer:​X:​SLIMits:​RIGHT


Deactivating All Search Limits

Measurements > Occupied Bandwidth Measurement (OBW) > OBW Configuration > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​THReshold:​STATe


How to Determine the Occupied Bandwidth

Measurements > Occupied Bandwidth Measurement (OBW) > How to Determine the Occupied Bandwidth
How to Determine the Occupied Bandwidth
How to determine the OBW for a single signal

  1. Select the "OBW" measurement function from the "Select Measurement" dialog box.

  2. Select the "OBW Config" softkey to display the "Occupied Bandwidth" configuration dialog box.

  3. Define the percentage of power ("% Power Bandwidth") that defines the bandwidth to be determined.

  4. If necessary, change the channel bandwidth for the transmission channel.

  5. To optimize the settings for the selected channel configuration, select "Adjust Settings".

  6. Start a sweep.

    The result is displayed as OBW in the marker results.

How to determine the OBW for a multicarrier signal using search limits

  1. Select the "OBW" measurement function from the "Select Measurement" dialog box.

  2. Select the "OBW Config" softkey to display the "Occupied Bandwidth" configuration dialog box.

  3. Define the percentage of power ("% Power Bandwidth") that defines the bandwidth to be determined.

  4. Define search limits so the search area contains only the first carrier signal:

    1. Enter values for the left or right limits, or both.

    2. Enable the use of the required limits.

  5. Start a sweep.

    The result for the first carrier is displayed as OBW in the marker results.

  6. Change the search limits so the search area contains the next carrier signal as described in step 4.

    The OBW is re-calculated and the result for the next carrier is displayed. A new sweep is not necessary!

  7. Continue in this way until all carriers have been measured.


Measurement Example

Measurements > Occupied Bandwidth Measurement (OBW) > Measurement Example
Measurement Example

In the following example, the bandwidth that occupies 99% of the total power of a PDC signal at 800 MHz, level 0 dBm is measured.

  1. Preset the R&S FSW.

  2. Set the center frequency to 800 MHz.

  3. Set the reference level to -10 dBm.

  4. Select the "OBW" measurement function from the "Select Measurement" dialog box.

  5. Set the percentage of power to 99%.

  6. Set the channel bandwidth to 21 kHz as specified by the PDC standard.

  7. Optimize the settings for the selected channel configuration by selecting "Adjust Settings".

  8. Adjust the reference level to the measured total power by selecting the "Auto Level" softkey in the AUTO SET menu.

  9. The PDC standard requires the peak detector for OBW measurement. In the "Traces" configuration dialog, set the trace detector to "Positive Peak".

  10. Start a sweep.

    The result is displayed as OBW in the marker results.


Spectrum Emission Mask (SEM) Measurement

Measurements > Spectrum Emission Mask (SEM) Measurement
Spectrum Emission Mask (SEM) Measurement

The R&S FSW supports Spectrum Emission Mask (SEM) measurements.

Contents
  • About the Measurement
  • Typical Applications
  • SEM Results
  • SEM Basics
  • SEM Configuration
  • How to Perform a Spectrum Emission Mask Measurement
  • Measurement Example: Multi-SEM Measurement
  • Reference: SEM File Descriptions


About the Measurement

Measurements > Spectrum Emission Mask (SEM) Measurement > About the Measurement
About the Measurement

The Spectrum Emission Mask (SEM) measurement defines a measurement that monitors compliance with a spectral mask. The mask is defined with reference to the input signal power. The R&S FSW allows for a flexible definition of all parameters in the SEM measurement. The analyzer performs measurements in predefined frequency ranges with settings that can be specified individually for each of these ranges.

In the basic Spectrum application, spectrum emissions can be measured for multiple sub blocks of channels, where the sub blocks may include gaps or overlap, and define separate masks. Radio signals using multiple standards can also be analyzed.

SEM measurement configurations can be saved to an xml file which can then be exported to another application or loaded on the R&S FSW again at a later time. Some predefined XML files are provided that contain ranges and parameters according to the selected standard.

In order to improve the performance of the R&S FSW for spectrum emission mask measurements, a "Fast SEM" mode is available.

Monitoring compliance of the spectrum is supported by a special limit check for SEM measurements.


Typical Applications

Measurements > Spectrum Emission Mask (SEM) Measurement > Typical Applications
Typical Applications

Spectrum Emission Mask measurements are typically performed to ensure that modulated signals remain within the valid signal level ranges defined by a particular transmission standard, both in the transmission channel and neighboring channels. Any violations of the mask may interfere with other transmissions.

The 3GPP TS 34.122 standard, for example, defines a mask for emissions outside the transmission channel. This mask is defined relative to the input signal power. Three frequency ranges to each side of the transmission channel are defined.


SEM Results

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Results
SEM Results

As a result of the Spectrum Emission Mask measurement, the measured signal levels, the result of the limit check (mask monitoring) and the defined limit lines are displayed in a diagram (see also "Limit Lines in SEM Measurements"). Furthermore, the TX channel power "P" is indicated with the used power class.

Multi-SEM measurements

For multi-SEM measurements, that is, SEM measurements with more than one sub block, each sub block has its own power class definitions. In this case, the power class is not indicated in the graphical result displays.

Example:

For example, in figure "Spectrum Emission Mask result displays", "31 < P < 39" is indicated as the used power class is defined from 31 to 39.

Spectrum Emission Mask result displays

In addition to the graphical results of the SEM measurement displayed in the diagram, a result summary is displayed to evaluate the limit check results (see also "Limit Lines in SEM Measurements").

The following information is provided in the result summary:

Label | Description
General Information
Standard | Loaded standard settings
Tx Power | Power of the reference range
Tx Bandwidth | Tx bandwidth used by the reference range
RBW | RBW used by the reference range
Range results
Range Low | Frequency range start the peak value was found in
Range Up | Frequency range end the peak value was found in
RBW | RBW of the range
Frequency | Frequency of the peak power level
Power Abs | Absolute peak power level within the range
Power Rel | Peak power level within the range, relative to the "Tx Power"
ΔLimit | Deviation of the peak power level from the limit line

You can define in which detail the data is displayed in the result summary in the "List Evaluation" settings (see "List Evaluation (Results Configuration)"). By default, one peak per range is displayed. However, you can change the settings to display only peaks that exceed a threshold ("Margin").

In addition to listing the peaks in the Result Summary, detected peaks can be indicated by blue squares in the diagram (see "Show Peaks" in the "List Evaluation" settings).

Detected peak display in SEM measurement

Furthermore, you can export the results of the result summary to a file which can be exported to another application for further analysis.

Results for SEM with multiple sub blocks

As of firmware version 1.91, and in the Spectrum application only, spectrum emissions can be measured for multiple sub blocks of channels (see "SEM with Multiple Sub Blocks ("Multi-SEM")" for details). Up to three sub blocks (with two gaps) can be defined. For each sub block and each gap, the results described above are provided individually in the result summary.

SEM results for multiple sub blocks
Retrieving Results via Remote Control

The measurement results of the spectrum emission mask test can be retrieved using the CALC:LIM:FAIL? command from a remote computer; see CALCulate:​LIMit<k>:​FAIL? for a detailed description.

The power result for the reference range can be queried using CALC:MARK:FUNC:POW:RES? CPOW;

The peak power for the reference range can be queried using CALC:MARK:FUNC:POW:RES? PPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?.

The measured power trace can be queried using TRAC:DATA? and TRAC:DATA:X?, see TRACe<n>[:​DATA] and TRACe<n>[:​DATA]:​X?:

The measured peak power list can be queried using TRAC:DATA? LIST, see TRACe<n>[:​DATA].


SEM Basics

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Basics
SEM Basics

Some background knowledge on basic terms and principles used in SEM measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Ranges and Range Settings
  • Limit Lines in SEM Measurements
  • Fast SEM Measurements
  • Multi-Standard Radio (MSR) SEM Measurements
  • SEM with Multiple Sub Blocks ("Multi-SEM")


Ranges and Range Settings

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Basics > Ranges and Range Settings
Ranges and Range Settings

In the Spectrum Emission Mask measurements, a range defines a segment for which you can define the following parameters separately:

  • Start and stop frequency
  • RBW
  • VBW
  • Sweep time
  • Sweep points
  • Reference level
  • Attenuator settings
  • Preamplifier settings
  • Transducer settings
  • Limit values

Via the sweep list, you define the ranges and their settings. For details on settings refer to "Sweep List".

For details on defining the limits (masks) see "Limit Lines in SEM Measurements".

For details on defining the limits (masks) see the base unit description "Working with Lines in SEM".

Range definition

After a preset, the sweep list contains a set of default ranges and parameters. For each range, you can change the parameters listed above. You can insert or delete ranges.

The changes of the sweep list are only kept until you load another parameter set (by pressing PRESET or by loading an XML file). If you want a parameter set to be available permanently, create an XML file for this configuration (for details refer to "How to save a user-defined SEM settings file").

If you load one of the provided XML files, the sweep list contains ranges and parameters according to the selected standard.

Reference range

The range centered around the center frequency is defined as the reference range for all other ranges in the sweep list. All range limits are defined in relation to the reference range. The TX power used as a reference for all power level results in the result summary is also calculated for this reference range. You can define whether the power used for reference is the peak power level or the integrated power of the reference range. In the "Sweep List", the reference range is highlighted in blue and cannot be deleted.

Rules

The following rules apply to ranges:

  • The minimum span of a range is 20 Hz.
  • The individual ranges must not overlap (but may have gaps).
  • The maximum number of ranges is 30 (in firmware versions < 1.60: 20 ranges).
  • The minimum number of ranges is 3.
  • The reference range cannot be deleted.
  • The reference range has to be centered on the center frequency.
  • The minimum span of the reference range is given by the current "TX Bandwidth" (see "Channel Power Settings").
  • Frequency values for each range have to be defined relative to the center frequency.

In order to change the start frequency of the first range or the stop frequency of the last range, select the appropriate span with the SPAN key. If you set a span that is smaller than the overall span of the ranges, the measurement includes only the ranges that lie within the defined span and have a minimum span of 20 Hz. The first and last ranges are adapted to the given span as long as the minimum span of 20 Hz is not violated.

Sweep points

As of firmware version 1.91, a minimum number of sweep points for each range can be defined. The total number of available sweep points (defined by the global "Sweep Points" setting) is then distributed between the ranges in consideration of the minimum values. If necessary to fulfill all minimum sweep point requirements in all ranges, the global "Sweep Points" setting is increased. By default, each range is supplied with a minimum of one sweep point.

This allows you to increase the resolution within a specific range for detailed analysis, without increasing the overall number of sweep points and thus the measurement time for the SEM measurement.

Symmetrical ranges

You can easily define a sweep list with symmetrical range settings, i.e. the ranges to the left and right of the reference range are defined symmetrically. When symmetrical setup is activated, the current sweep list configuration is changed to define a symmetrical setup regarding the reference range. The number of ranges to the left of the reference range is reflected to the right, i.e. any missing ranges on the right are inserted, while superfluous ranges are removed. The values in the ranges to the right of the reference range are adapted symmetrically to those in the left ranges.

Symmetrical ranges fulfill the conditions required for "Fast SEM" mode (see "Fast SEM Measurements").

Power classes

If the signal power level to be monitored may vary and the limits will vary accordingly, you can define power classes, which can then be assigned to the frequency ranges. Thus, the limits for the signal levels can be defined differently for varying input levels. For instance, for higher input levels a transmission standard may allow for higher power levels in adjacent channels, whereas for lower input levels the allowed deviation may be stricter. Up to four different power classes can be defined.


Limit Lines in SEM Measurements

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Basics > Limit Lines in SEM Measurements
Limit Lines in SEM Measurements

On the R&S FSW, the spectrum emission mask is defined using limit lines. Limit lines allow you to check the measured data (that is, the trace results) against specified limit values. Generally, it is possible to define limit lines for any measurement in the Spectrum application using the LINES key. For SEM measurements, however, special limit lines are available via the "Sweep List", and it is strongly recommended that you use only these limit line definitions.

In the "Sweep List" you can define a limit line for each power class that varies its level according to the specified frequency ranges. Special limit lines are automatically defined for each power class according to the current "Sweep List" settings every time the settings change. These limit lines are labeled "_SEM_LINE_<xxx>_ABS<0...3>" and "_SEM_LINE_<xxx>_REL<0...3>", where <xxx> is an index to distinguish limit lines between different measurement channels.

The limit line defined for the currently used power class is indicated by a red line in the display, and the result of the limit check is indicated at the top of the diagram. Note that only "Pass" or "Fail" is indicated; a "margin" function as for general limit lines is not available.

The indicated limit line depends on the settings in the "Sweep List". Several types of limit checks are possible:

Limit check types
Limit check type | Pass/fail criteria | Limit line definition
Absolute | Absolute power levels may not exceed limit line | Defined by the "Abs Limit Start"/ "Abs Limit Stop" values for each range
Relative | Power deviations relative to the TX channel power may not exceed limit line | Defined by the "Rel Limit Start"/ "Rel Limit Stop" values (relative to the TX channel power), fixed for each range.
Relative with function f(x) | If the power exceeds both the absolute and the relative limits, the check fails (see "Relative limit line functions" below) | Defined by the maximum of the absolute or relative start and stop limit values for each range. Thus, the start or stop point of the limit range, or both, are variable (since the maximum may vary).
Abs and Rel | If the power exceeds both the absolute and the relative limits, the check fails. | The less strict (higher) limit line is displayed for each range. If you use a function to define the relative limit start or stop value, the signal is checked against an additional condition: the power must exceed the absolute limit, as well as the absolute and relative function values.
Abs or Rel | If the power exceeds either the absolute or the relative limits, the check fails. | The stricter (lower) limit line is displayed for each range. If you use a function to define the relative limit start or stop value, the signal is checked against an additional condition: if the power exceeds the absolute limit, or the higher of the absolute and relative function values, the check fails.
Relative limit line functions

A new function allows you to define limit lines whose start or end points (or both) are variable, depending on the carrier power. Thus, the resulting limit line may change its slope within the range, depending on the carrier power. Common relative limit lines are calculated once for the defined start and end points and maintain a constant slope.

If the relative limit value function is used in combination with the "Abs and Rel" or "Abs or Rel" limit check types, an additional condition is considered for the limit check (see table "Limit check types").

Limit check results in the result summary

For each range, the peak measured value and the deviation of these values from the limit line are displayed in the result summary. If the limit check is passed for the range, the deviation represents the closest value to the limit line. If the limit check is passed for the range, the deviation represents the closest value to the limit line. If the limit check for the range fails, the deviation represents the maximum violation against the limit line. Furthermore, the absolute power levels and the relative deviation of the peaks from the TX channel power are displayed. Values that exceed the limit are indicated in red and by an asterisk (*).

Although a margin functionality is not available for the limit check, a margin (threshold) for the peak values to be displayed in the Result Summary can be defined in the "List Evaluation" settings. For details see "List Evaluation (Results Configuration)".


Fast SEM Measurements

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Basics > Fast SEM Measurements
Fast SEM Measurements

In order to improve the performance of the R&S FSW for spectrum emission mask measurements, a "Fast SEM" mode is available. If this mode is activated, several consecutive ranges with identical sweep settings are combined to one sweep internally, which makes the measurement considerably faster. The displayed results remain unchanged and still consist of several ranges. Thus, measurement settings that apply only to the results, such as limits or transducer factors, can nevertheless be defined individually for each range.

Prerequisites
"Fast SEM" mode is available if the following criteria apply:
  • The frequency ranges are consecutive, without frequency gaps
  • The following sweep settings are identical (for details see "Sweep List"):
    – Filter Type
    – RBW
    – VBW
    – Sweep Time Mode
    – Reference Level
    – Rf Attenuation Mode
    – RF Attenuation
    – Preamplification
Activating Fast SEM mode

"Fast SEM" mode is activated in the sweep list (see "Sweep List") or using a remote command. Activating the mode for one range automatically activates it for all ranges in the sweep list.

Remote command:

[SENSe:​]ESPectrum<sb>:​HighSPeed

Fast SEM not supported for multiple sub blocks

For SEM with multiple sub blocks, fast SEM is not available. If more than 1 sub block is defined and a standard is loaded which contains an active fast SEM setting, this setting is disabled.

For more information on multi-SEM measurements see "SEM with Multiple Sub Blocks ("Multi-SEM")".

Consequences

When the "Fast SEM" mode is activated, the ranges for which these criteria apply are displayed as one single range. The sweep time is defined as the sum of the individual sweep times, initially, but can be changed.

If "Symmetrical Setup" mode is active when "Fast SEM" mode is activated, not all sweep list settings can be configured symmetrically automatically (see also "Symmetric Setup").

Any other changes to the sweep settings of the combined range are applied to each included range and remain changed even after deactivating "Fast SEM" mode.

Example
Sweep list using Fast SEM mode

In figure " Sweep list using Fast SEM mode", a sweep list is shown for which Fast SEM is activated. The formerly 5 separately defined ranges are combined to 2 sweep ranges internally.


Multi-Standard Radio (MSR) SEM Measurements

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Basics > Multi-Standard Radio (MSR) SEM Measurements
Multi-Standard Radio (MSR) SEM Measurements

Multi-standard radio (MSR) measurements allow you to perform SEM tests on signals with multiple carriers using different digital standards. MSR measurements are described in the specification 3GPP TS 37.141. Various typical combinations of standards for base station tests are described, e.g. LTE FDD and W-CDMA carriers. By performing an MSR SEM measurement you can determine if or how the different carriers affect each other, i.e. if unwanted emissions occur. On the R&S FSW, the MSR SEM measurement is a standard measurement as for single carriers. The MSR settings merely provide a convenient way of configuring the sweep list for all required ranges according to the specification very quickly.

As of firmware version 2.00, refined settings allow the R&S FSW to calculate the SEM limits according to standard 3GPP 37.141 V12.2.0, which distinguishes between base station configurations and power values.


SEM with Multiple Sub Blocks ("Multi-SEM")

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Basics > SEM with Multiple Sub Blocks ("Multi-SEM")
SEM with Multiple Sub Blocks ("Multi-SEM")

As of firmware version 1.91, and in the Spectrum application only, spectrum emissions can be measured for multiple sub blocks of channels (also referred to as a "Multi-SEM" measurement). Sub blocks are a set of multiple ranges around a defined center frequency (carrier). Multiple sub blocks may include gaps or overlap, and each sub block defines a separate mask. The behavior in the overlapping masks is defined by multi-limit line calculation. Up to three sub blocks (with two gaps) can be defined. For each sub block, the familiar configuration settings concerning ranges, limit lines and MSR can be defined individually.

Comparison to "traditional" SEM measurement

The default SEM measurement as performed and configured in previous firmware versions is simply a special case of "Multi-SEM" - consisting of one single block. Only when you define a number of sub blocks larger than 1 in the basic SEM configuration, multiple sub blocks are inserted in the configuration settings and result tables.

Particular features of configuring multiple sub blocks

The sub blocks are independent of the global start, stop, center and span frequencies for the complete SEM measurement. Thus, there can be gaps that may even include other carrier ranges, but are not configured for the SEM measurement.

For each sub block, you define:
  • the center frequency of the reference range of the sub block; center frequencies must be defined in ascending order for sub blocks A,B,C
  • the reference range; note that although individual ranges of different sub blocks may overlap, reference ranges for different sub blocks may not; they must define distinct frequency ranges
  • the sweep list, including the limit lines
  • optionally: a standard file or MSR settings to be used for measurement (if one is selected, the other is disabled)
Fast SEM not supported for multiple sub blocks

For SEM with multiple sub blocks, fast SEM is not available. If more than 1 sub block is defined and a standard is loaded which contains an active fast SEM setting, this setting is disabled.

Absolute vs relative frequencies

In the default configuration with only 1 sub block, frequencies are defined relative to the center frequency; this is the familiar configuration.

For setups with more than 1 sub block, frequencies are defined relative to the center frequency of the reference ranges for the individual sub blocks. However, in the result summary, frequencies are indicated as absolute values. Relative frequencies that refer to different reference ranges would be inconvenient and difficult to analyze.

Limit check behavior for overlapping masks

Since spectrum emission masks are defined individually for each sub block, and sub blocks may overlap, the question arises what happens during the limit check in the overlapping regions? To answer this question we must distinguish the following cases:

  • For the reference range, no limit checking is performed, as the reference range contains the carrier
  • For other ranges, only the limit lines defined for ranges between the carriers, that is the reference ranges, to either side are significant. In other words, if a limit line definition covers the frequency area of several carriers, only the limit lines for ranges between the corresponding reference range and the next closest reference range are significant.
    Behavior for overlapping masks
  • For these ranges, in which multiple limit lines are significant, a range-specific function determines the behavior of the limit check
Limit calculation for individual ranges
For each range a function can be defined that determines the behavior of the limit check in case of multiple limit lines:
  • "NONE": In reference ranges no limit check is performed;
    Reference ranges always use the function "NONE".
    For other ranges, see the combinations for overlapping ranges below.
  • "SUM": sum of the two limit lines (calculated for linear powers) is used
  • "MAX": maximum of the two limit lines is used

This leads to the following combinations for overlapping ranges:

  • "MAX+MAX": maximum of the two limit lines is used
  • "MAX+SUM": maximum of the two limit lines is used
  • "SUM+SUM": sum of the two limit lines (calculated for linear powers) is used
  • "NONE+MAX"/"NONE+SUM": limit line (and parameters) of the "NONE" range are ignored
  • "NONE+NONE": depends on the position of the overlapping ranges in relation to the mid-frequency between the two neighboring sub blocks:
    – overlap is completely below the mid-frequency: limits and parameters of the left sub block are used
    – overlap is completely above the mid-frequency: limits and parameters of the right sub block are used
    – overlap crosses the mid-frequency: new subranges are created: one to the left of the mid-frequency, one to the right of the mid-frequency. The left subrange uses the limits and parameters of the left sub block, the right subrange uses the limits and parameters of the right sub block.
Different RBWs in overlapping ranges

If different RBWs are defined for the overlapping ranges, the RBW, as well as the VBW, attenuation, reference level, transducer, filter type and (proportional) sweep time of the range with the smaller RBW are considered for both ranges. In the range with the higher RBW, the following offset is applied to the limit line:

-10*log(RBWlarge / RBWsmall)

Limit lines in overlapping ranges crossing the mid-frequency
Initial situation: overlapping ranges Range 4 ("None") + Range 5 ("None") overlap and cross the mid-frequency between sub blocks 1 and 2 | Result: Subranges 4a and 5a are created left and right of the mid-frequency; For subrange 4a: limit line and parameters of range 4 apply For subrange 5a: limit line and parameters of range 5 apply
Global SEM limit check

For the complete SEM measurement, which may consist of multiple sub blocks, only one single limit check is performed. A single limit line is calculated according to the individual range limit lines and the defined functions for overlapping ranges. The measured values are then compared with this single limit line. If the limit is exceeded in any range, the result of the limit check is "failed".

Summarized limit line for multiple sub blocks


SEM Configuration

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration
SEM Configuration

SEM measurements are selected via the "Spectrum Emission Mask" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "Spectrum Emission Mask" configuration dialog box, which is displayed when you select the "SEM Setup" button in the "Overview" or one of the softkeys from the "SEMask" menu.

The remote commands required to perform these tasks are described in "Measuring the Spectrum Emission Mask".

Global span settings

The span of the signal to be monitored is configured in the general span settings (see "Frequency and Span Settings"). Only ranges within this global span are considered for the SEM measurement.

Multi-SEM configuration

As of firmware version 1.91, and in the Spectrum application only, spectrum emissions can be measured for multiple sub blocks of channels (see "SEM with Multiple Sub Blocks ("Multi-SEM")"). Up to three sub blocks (with two gaps) can be defined. For each sub block, the familiar configuration settings concerning ranges, limit lines and MSR can be defined in individual tabs. In addition, settings on the sub blocks themselves must be configured in the "Sub Blocks" tab of the "Spectrum Emission Mask" configuration dialog box (see "Multi-SEM (Sub Block) Settings ").

Contents
  • Sweep List
  • Multi-SEM (Sub Block) Settings
  • Reference Range
  • Power Classes
  • MSR Settings
  • Standard Files
  • List Evaluation (Results Configuration)


Sweep List

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List
Sweep List

For SEM measurements, the input signal is split into several frequency ranges which are swept individually and for which different limitations apply. In the "Sweep List" tab of the "Spectrum Emission Mask" dialog box you configure the individual frequency ranges and mask limits.

If you edit the sweep list, always follow the rules and consider the limitations described in "Ranges and Range Settings".

└ Range Start / Range Stop
└ Fast SEM
└ Filter Type
└ RBW
└ VBW
└ Sweep Time Mode
└ Sweep Time
└ Ref. Level
└ RF Att. Mode
└ RF Attenuator
└ Preamp
└ Transd. Factor
└ Limit Check <n>
└ Abs Limit Start/Stop <n>
└ Rel Limit Start/Stop <n>
└ Multi-Limit Calc <n>
└ Minimum Sweep Points
└ Insert before/after Range
└ Delete Range
└ Symmetric Setup


Range Start / Range Stop

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Range Start / Range Stop
Range Start / Range Stop

Sets the start frequency/stop frequency of the selected range.

Follow the rules described in "Ranges and Range Settings".

In order to change the start/stop frequency of the first or last range, respectively, select the appropriate span with the SPAN key. If you set a span that is smaller than the overall span of the ranges, the measurement includes only the ranges that lie within the defined span and have a minimum span of 20 Hz. The first and last ranges are adapted to the given span as long as the minimum span of 20 Hz is not violated.

Frequency values for each range have to be defined relative to the center frequency. The reference range has to be centered on the center frequency. The minimum span of the reference range is given by the current "TX Bandwidth" (see "Channel Power Settings").

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>[:​FREQuency]:​STARt

[SENSe:​]ESPectrum<sb>:​RANGe<range>[:​FREQuency]:​STOP


Fast SEM

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Fast SEM
Fast SEM

Activates "Fast SEM" mode for all ranges in the sweep list. For details see "Fast SEM Measurements".

Note: If you deactivate "Fast SEM" mode while "Symmetrical Setup" mode is on, "Symmetrical Setup" mode is automatically also deactivated.
If you activate "Fast SEM" mode while "Symmetrical Setup" mode is on, not all range settings can be configured symmetrically automatically.

Remote command:

[SENSe:​]ESPectrum<sb>:​HighSPeed


Filter Type

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Filter Type
Filter Type

Sets the filter type for this range.

For details on filter types see "Which Data May Pass: Filter Types".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​FILTer:​TYPE


RBW

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > RBW
RBW

Sets the resolution bandwidth for this range.

For details on the RBW see "Separating Signals by Selecting an Appropriate Resolution Bandwidth".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​BANDwidth[:​RESolution]


VBW

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > VBW
VBW

Sets the video bandwidth for this range.

For details on the VBW see "Smoothing the Trace Using the Video Bandwidth".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​BANDwidth:​VIDeo


Sweep Time Mode

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Sweep Time Mode
Sweep Time Mode

Activates or deactivates the auto mode for the sweep time.

For details on the sweep time mode see "How Long the Data is Measured: Sweep Time"

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​SWEep:​TIME:​AUTO


Sweep Time

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Sweep Time
Sweep Time

Sets the sweep time value for the range.

For details on the sweep time see "How Long the Data is Measured: Sweep Time"

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​SWEep:​TIME


Ref. Level

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Ref. Level
Ref. Level

Sets the reference level for the range.

For details on the reference level see "Reference Level".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​RLEVel


RF Att. Mode

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > RF Att. Mode
RF Att. Mode

Activates or deactivates the auto mode for RF attenuation.

For details on attenuation see "RF Attenuation".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​INPut:​ATTenuation:​AUTO


RF Attenuator

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > RF Attenuator
RF Attenuator

Sets the attenuation value for the range.

For details on attenuation see "RF Attenuation".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​INPut:​ATTenuation


Preamp

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Preamp
Preamp

Switches the preamplifier on or off.

For details on the preamplifier see "Preamplifier (option B24)".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​INPut:​GAIN:​STATe


Transd. Factor

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Transd. Factor
Transd. Factor

Sets a transducer for the specified range. You can only choose a transducer that fulfills the following conditions:

  • The transducer overlaps or equals the span of the range.
  • The x-axis is linear.
  • The unit is dB.

For details on transducers see "Basics on Transducer Factors".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​TRANsducer


Limit Check <n>

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Limit Check <n>
Limit Check <n>

Sets the type of limit check for the n-th power class in the range. Up to four limits are possible.

For details on limit checks see "Limit Lines in SEM Measurements".

The limit state affects the availability of all limit settings.

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe:​LIMit<PClass>:​STATe

CALCulate:​LIMit<k>:​FAIL?


Abs Limit Start/Stop <n>

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Abs Limit Start/Stop <n>
Abs Limit Start/Stop <n>

Sets an absolute limit value for the n-th power class at the start or stop frequency of the range [dBm].

This parameter is only available if the limit check is set accordingly (see "Limit Check <n>").

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​ABSolute:​STARt

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​ABSolute:​STOP


Rel Limit Start/Stop <n>

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Rel Limit Start/Stop <n>
Rel Limit Start/Stop <n>

Sets a relative limit value for the n-th power class at the start or stop frequency of the range [dBc].

This parameter is only available if the limit check is set accordingly (see "Limit Check <n>").

By default, this value is a fixed relative limit, i.e. no function is defined. To define a function for the relative limit, select the input field for "Rel Limit Start" or "Rel Limit Stop" and then the "f(x)" icon that appears.

If the function is set to "MAX", you can define a relative and an absolute limit level. In this case, the maximum of the two values is used as the limit level.

For more information see "Relative limit line functions".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STARt

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STOP

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STARt:​FUNCtion

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STOP:​FUNCtion

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STARt:​ABS

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STOP:​ABSolute


Multi-Limit Calc <n>

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Multi-Limit Calc <n>
Multi-Limit Calc <n>

Defines the function used to calculate the limit line for the n-th power class for overlapping ranges in Multi-SEM measurements. For details see "Limit calculation for individual ranges".

"NONE" | (reference ranges only:) the limit of the reference range is used
"SUM" | sum of the two limit lines (calculated for linear powers) is used
"MAX" | maximum of the two limit lines is used
Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​MLCalc


Minimum Sweep Points

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Minimum Sweep Points
Minimum Sweep Points

Defines the minimum number of sweep points for the range.

If necessary to fulfill all minimum sweep point requirements in all ranges, the global "Sweep Points" setting is increased. By default, each range is supplied with a minimum of one sweep point.

For details see "Sweep points"

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​POINts:​MIN[:​VALue]


Insert before/after Range

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Insert before/after Range
Insert before/after Range

Inserts a new range to the left (before) or to the right (after) of the range in which the cursor is currently displayed. The range numbers of the currently focused range and all higher ranges are increased accordingly. The maximum number of ranges is 30.

For more details see "Ranges and Range Settings".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​INSert


Delete Range

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Delete Range
Delete Range

Deletes the currently focused range, if possible (The reference range cannot be deleted. A minimum of 3 ranges is required.) The range numbers are updated accordingly.

For more details see "Ranges and Range Settings".

Remote command:

[SENSe:​]ESPectrum<sb>:​RANGe<range>:​DELete


Symmetric Setup

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Sweep List > Symmetric Setup
Symmetric Setup

Any changes to the range settings in active "Symmetric Setup" mode lead to symmetrical changes in the other ranges (where possible). In particular, this means:

  • Inserting ranges: a symmetrical range is inserted on the other side of the reference range
  • Deleting ranges: the symmetrical range on the other side of the reference range is also deleted
  • Editing range settings: the settings in the symmetrical range are adapted accordingly

Note: If "Fast SEM" mode is deactivated while "Symmetric Setup" mode is on, "Sym Setup" mode is automatically also deactivated.
If "Fast SEM" mode is activated while "Symmetric Setup" mode is on, not all range settings can be set automatically.

For more details see "Ranges and Range Settings".


Multi-SEM (Sub Block) Settings

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Multi-SEM (Sub Block) Settings
Multi-SEM (Sub Block) Settings

As of firmware version 1.91, and in the Spectrum application only, spectrum emissions can be measured for multiple sub blocks of channels (see "SEM with Multiple Sub Blocks ("Multi-SEM")"). Sub blocks are a set of multiple ranges around a defined center frequency (carrier). Global settings on the sub blocks are configured in the "Sub Blocks" tab of the "Spectrum Emission Mask" configuration dialog box.

By default, a single sub block is assumed, which corresponds to the familiar SEM measurement from previous firmware versions. If more than 1 sub blocks are defined, additional tabs are inserted for each sub block in the individual tabs of the "Spectrum Emission Mask" configuration dialog box.

└ Sub Block Count
└ Sub Block Center Frequency
└ Standard / MSR Settings
└ Edit sweep list


Sub Block Count

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Multi-SEM (Sub Block) Settings > Sub Block Count
Sub Block Count

Defines the number of sub blocks. By default, the familiar SEM measurement with just one single block of ranges is configured.

If more than 1 sub blocks are defined, additional tabs are inserted for each sub block in the individual tabs of the "Spectrum Emission Mask" configuration dialog box.

For details on Multi-SEM measurements see "SEM with Multiple Sub Blocks ("Multi-SEM")".

Remote command:

[SENSe:​]ESPectrum:​SBCount


Sub Block Center Frequency

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Multi-SEM (Sub Block) Settings > Sub Block Center Frequency
Sub Block Center Frequency

Defines the center frequency for an individual sub block. The center frequency determines the reference range used for each block.

For measurements with only 1 sub block, this setting corresponds to the global setting in the "Frequency" settings (see "Center frequency").

Remote command:

[SENSe:​]ESPectrum<sb>:​SBCenter


Standard / MSR Settings

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Multi-SEM (Sub Block) Settings > Standard / MSR Settings
Standard / MSR Settings

Defines the use of a standard settings file or a multi-standard radio configuration for a particular sub block. For details see "Standard Files" and "MSR Settings".

Note that either a standard or an MSR setting can be selected; if one is selected, the other is disabled.

Remote command:

[SENSe:​]ESPectrum<sb>:​PRESet[:​STANdard]

"Configuring a Multi-SEM Measurement"


Edit sweep list

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Multi-SEM (Sub Block) Settings > Edit sweep list
Edit sweep list

Switches to the "Sweep List" tab of the "Spectrum Emission Mask" dialog box to configure the individual frequency ranges and mask limits for the corresponding sub block. See "Sweep List".


Reference Range

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Reference Range
Reference Range

The range centered around the center frequency is defined as the reference range for all other ranges in the sweep list.

In the "Reference Range" tab of the "Spectrum Emission Mask" dialog box you define the general settings for the reference range.

└ Power Reference Type
└ Channel Power Settings
└ Tx Bandwidth
└ RRC Filter State
└ Alpha


Power Reference Type

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Reference Range > Power Reference Type
Power Reference Type

Defines how the reference power is calculated.

"Channel Power" | Measures the channel power within the reference range using the integration bandwidth method (see also "IBW method"). Additional settings can be configured for this method.
"Peak Power" | Determines the peak power within the reference range.
Remote command:

[SENSe:​]ESPectrum<sb>:​RTYPe


Channel Power Settings

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Reference Range > Channel Power Settings
Channel Power Settings

If the Power Reference Type "Channel Power" was selected, additional parameters can be configured.

For details on the IBW method used to determine the channel power, see "IBW method".

└ Tx Bandwidth
└ RRC Filter State
└ Alpha


Tx Bandwidth

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Reference Range > Channel Power Settings > Tx Bandwidth
Tx Bandwidth

Defines the bandwidth used for measuring the channel power, with:

minimum span ≤ Tx Bandwidth ≤ span of reference range

Remote command:

[SENSe:​]ESPectrum<sb>:​BWID


RRC Filter State

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Reference Range > Channel Power Settings > RRC Filter State
RRC Filter State

Activates or deactivates the use of an RRC filter.

Remote command:

[SENSe:​]ESPectrum<sb>:​FILTer[:​RRC][:​STATe]


Alpha

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Reference Range > Channel Power Settings > Alpha
Alpha

Sets the alpha value of the RRC filter (if activated).

Remote command:

[SENSe:​]ESPectrum<sb>:​FILTer[:​RRC]:​ALPHa


Power Classes

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Power Classes
Power Classes

In the "Power Classes" tab of the "Spectrum Emission Mask" dialog box you configure power classes for which you can then define sweep list ranges. For details see "Power classes".

└ Used Power Classes
└ PMin/PMax
└ Sweep List
└ Adding or Removing a Power Class


Used Power Classes

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Power Classes > Used Power Classes
Used Power Classes

Defines which power classes are considered for the SEM measurement. Limits can be defined only for used power classes. It is only possible to select either one specific power class or all of the defined power classes.

If "All" is selected, the power class that corresponds to the currently measured power in the reference range is used for monitoring. The limits assigned to that power class are applied (see "Abs Limit Start/Stop <n>" and "Rel Limit Start/Stop <n>").

Remote command:

CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>[:​EXCLusive]

To define all limits in one step:

CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>:​LIMit[:​STATe]


PMin/PMax

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Power Classes > PMin/PMax
PMin/PMax

Defines the power limits for each power class. The first range always starts at -200 dBm (-INF) and the last range always stops at 200 dBm (+INF). These fields cannot be modified. If more than one power class is defined, the value of "PMin" must be equal to the value of "PMax" of the previous power class and vice versa.

Note that the power level may be equal to the lower limit(s), but must be lower than the upper limit(s):

Pmin≦P<Pmax

Otherwise the ranges are corrected automatically.

Remote command:

CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>:​MINimum

CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>:​MAXimum


Sweep List

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Power Classes > Sweep List
Sweep List

Switches to the "Sweep List" tab of the "Spectrum Emission Mask" dialog box and focuses the "Limit Check" setting for the corresponding power class (1-4) in the reference range (see "Limit Check <n>").


Adding or Removing a Power Class

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Power Classes > Adding or Removing a Power Class
Adding or Removing a Power Class

Adds a new power class at the end of the list or removes the last power class. After adding or removing, the last power class is adapted to end at "+INF". Note that a maximum of 4 power classes are available.

Remote command:

CALCulate:​LIMit:​ESPectrum<sb>:​PCLass:​COUNt


MSR Settings

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings
MSR Settings

In the "MSR Settings" tab of the "Spectrum Emission Mask" dialog box you configure multi-standard radio (MSR) measurements, which allow you to perform SEM tests on multiple carriers using different digital standards.

For details see "Multi-Standard Radio (MSR) SEM Measurements".

└ Band Category
└ Base Station Class
└ Base Station Maximum Output Power
└ Bands
└ Base Station RF Bandwidth
└ Carrier Adjacent to RF Bandwidth Edge
└ Power GSM Carrier
└ Apply to SEM


Band Category

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Band Category
Band Category

Defines the band category for MSR measurements, i.e. the combination of available carriers to measure.

For details see "Multi-Standard Radio (MSR) SEM Measurements".

"BC1" | LTE FDD and W-CDMA
"BC2" | LTE FDD, W-CDMA and GSM/EDGE
"BC3" | LTE TDD and TD-SCDMA
Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​BCATegory


Base Station Class

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Base Station Class
Base Station Class

Defines the class of the base station according to its sending range.

This setting is required to calculate the SEM limits according to standard 3GPP 37.141 V12.2.0.

Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​CLAS


Base Station Maximum Output Power

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Base Station Maximum Output Power
Base Station Maximum Output Power

Defines the maximum output power of the base station. Possible values are from 0 to 100 dBm in 1 dB steps.

This setting is only available for base stations with a medium range "Base Station Class".

This value is required to calculate the SEM limits according to standard 3GPP 37.141 V12.2.0.

Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​MPOWer


Bands

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Bands
Bands

Defines the frequency range of the bands used by the base station.

This setting is only available for "Band Category" 1 or 3.

This setting is required to calculate the SEM limits according to standard 3GPP 37.141 V12.2.0.

Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​BAND


Base Station RF Bandwidth

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Base Station RF Bandwidth
Base Station RF Bandwidth

Defines the relevant RF bandwidth (span) required to measure all available carriers in MSR SEM measurements.

For details see "Multi-Standard Radio (MSR) SEM Measurements".

Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​RFBWidth


Carrier Adjacent to RF Bandwidth Edge

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Carrier Adjacent to RF Bandwidth Edge
Carrier Adjacent to RF Bandwidth Edge

For particular measurement setups the specification demands specific limits for the SEM ranges.

These settings are only available for "Band Category" 2.

For details see "Multi-Standard Radio (MSR) SEM Measurements".

"GSM/EDGE present" | A GSM/EDGE carrier is located at the edge of the RF band. In this case, the power of the GSM carrier must be specified (see "Power GSM Carrier").
"LTE FDD 1.4 MHz / 3 MHz present" | An LTE FDD 1.4 MHz or 3 MHz carrier is located at the edge of the RF band.
Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​GSM:​CPResent

[SENSe:​]ESPectrum<sb>:​MSR:​LTE:​CPResent


Power GSM Carrier

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Power GSM Carrier
Power GSM Carrier

Defines the power of the GSM carrier (if available, see "Carrier Adjacent to RF Bandwidth Edge"). Possible values are from 0 to 100 dBm in 1 dB steps.

This setting is only available for "Band Category"2.

This setting is required to calculate the SEM limits according to standard 3GPP 37.141 V12.2.0.

Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​GSM:​CARR


Apply to SEM

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > MSR Settings > Apply to SEM
Apply to SEM

Configures the SEM sweep list according to the specified MSR settings.

For details see "Multi-Standard Radio (MSR) SEM Measurements".

Remote command:

[SENSe:​]ESPectrum<sb>:​MSR:​APPLy


Standard Files

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Standard Files
Standard Files

In the "Standard Files" tab of the "Spectrum Emission Mask" dialog box you can save the current measurement settings as a user-defined standard (xml file), or load stored measurement settings. Furthermore, you can delete an existing settings file.

For details see "How to Manage SEM Settings Files".

└ Selecting the Storage Location - Drive/ Path/ Files
└ File Name
└ Load Standard
└ Save Standard
└ Delete Standard
└ Restore Standard Files


Selecting the Storage Location - Drive/ Path/ Files

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Standard Files > Selecting the Storage Location - Drive/ Path/ Files
Selecting the Storage Location - Drive/ Path/ Files

Select the storage location of the settings file on the instrument or an external drive.

The "Drive" indicates the internal (C:) or any connected external drives (e.g. a USB storage device).

The "Path" contains the drive and the complete file path to the currently selected folder.

The "Files" list contains all subfolders and files of the currently selected path.

The default storage location for the SEM settings files is: C:\R_S\instr\sem_std.

Note: Saving instrument settings in secure user mode. In secure user mode all data is stored to volatile memory, and is only available during the current instrument session. As soon as the power is switched off on the R&S FSW, the data is cleared.
To store settings permanently, select an external storage location, such as a USB memory device.
For details see "Protecting Data Using the Secure User Mode".

Remote command:

MMEMory:​CATalog?


File Name

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Standard Files > File Name
File Name

Contain the name of the data file without the path or extension.

By default, the name of a settings file consists of a base name followed by an underscore. Multiple files with the same base name are extended by three numbers, e.g. limit_lines_005.

For details on the file name and location see "Storage Location and File Name".

Note: Secure user mode. In secure user mode, settings that are to be stored on the instrument are stored to volatile memory. To store data permanently, select an external storage location such as a USB memory device.
For details see "Protecting Data Using the Secure User Mode".


Load Standard

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Standard Files > Load Standard
Load Standard

Loads the selected measurement settings file.

Remote command:

[SENSe:​]ESPectrum<sb>:​PRESet[:​STANdard]


Save Standard

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Standard Files > Save Standard
Save Standard

Saves the current measurement settings for a specific standard as a file with the defined name.

Remote command:

[SENSe:​]ESPectrum<sb>:​PRESet:​STORe


Delete Standard

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Standard Files > Delete Standard
Delete Standard

Deletes the selected standard. Standards predefined by Rohde & Schwarz can also be deleted. A confirmation query is displayed to avoid unintentional deletion of the standard.

Note: Restoring predefined standard files. The standards predefined by Rohde & Schwarz available at the time of delivery can be restored using the "Restore Standards" softkey.
(See "Restore Standard Files").


Restore Standard Files

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > Standard Files > Restore Standard Files
Restore Standard Files

Restores the standards predefined by Rohde & Schwarz available at the time of delivery.

The XML files from the C:\R_S\instr\sem_backup folder are copied to the C:\R_S\instr\sem_std folder.

Note that this function will overwrite customized standards that have the same name as predefined standards.

Remote command:

[SENSe:​]ESPectrum<sb>:​PRESet:​RESTore


List Evaluation (Results Configuration)

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > List Evaluation (Results Configuration)
List Evaluation (Results Configuration)

In the "List Evaluation" dialog box, which is displayed when you select the "Analysis" button in the "Overview" dialog box, or the "List Evaluation" softkey in the "SEMAsk" menu, you configure the contents and display of the SEM results.

└ List Evaluation (Result Summary) State
└ Show Peaks
└ Margin
└ Saving the Result Summary (Evaluation List) to a File


List Evaluation (Result Summary) State

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > List Evaluation (Results Configuration) > List Evaluation (Result Summary) State
List Evaluation (Result Summary) State

Activates or deactivates the Result Summary.

Remote command:

CALCulate<n>:​ESPectrum:​PSEarch|PEAKsearch:​AUTO

TRACe<n>[:​DATA]


Show Peaks

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > List Evaluation (Results Configuration) > Show Peaks
Show Peaks

If activated, all peaks that have been detected during an active SEM measurement are marked with blue squares in the Spectrum diagram.

Remote command:

CALCulate<n>:​ESPectrum:​PSEarch|PEAKsearch:​PSHow


Margin

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > List Evaluation (Results Configuration) > Margin
Margin

Although a margin functionality is not available for the limit check, a margin (threshold) for the peak values to be displayed in the result summary (and diagram, if activated) can be defined. Only peaks that exceed the margin value are displayed.

Remote command:

CALCulate<n>:​ESPectrum:​PSEarch|PEAKsearch:​MARGin


Saving the Result Summary (Evaluation List) to a File

Measurements > Spectrum Emission Mask (SEM) Measurement > SEM Configuration > List Evaluation (Results Configuration) > Saving the Result Summary (Evaluation List) to a File
Saving the Result Summary (Evaluation List) to a File

Exports the Result Summary of the SEM measurement to an ASCII file for evaluation in an external application. If necessary, change the decimal separator for evaluation in other languages.

Define the file name and storage location in the file selection dialog box that is displayed when you select the "Save" function.

For details see "ASCII File Export Format (Spectrum Emission Mask)".

Remote command:

MMEMory:​STORe:​LIST

FORMat:​DEXPort:​DSEParator


How to Perform a Spectrum Emission Mask Measurement

Measurements > Spectrum Emission Mask (SEM) Measurement > How to Perform a Spectrum Emission Mask Measurement
How to Perform a Spectrum Emission Mask Measurement

SEM measurements can be performed according to a specific standard or freely configured. Configuration for signals with a very regular channel definition can be configured very quickly and easily. Selecting the SEM measurement is a prerequisite for all other tasks. For multi-standard radio SEM measurements, configuration for specified scenarios can be done automatically.

For signals with multiple carriers, also in non-contiguous ranges, an SEM measurement with multiple sub blocks can be configured.

The following tasks are described:

  • "To select an SEM measurement"
  • "To perform an SEM measurement according to a standard"
  • "To configure a user-defined SEM measurement"
  • "To perform an MSR SEM measurement"
  • "To perform a Multi-SEM measurement"
To select an SEM measurement
►

Press the MEAS key, then select the "Spectrum Emission Mask" measurement.

To perform an SEM measurement according to a standard
►

Load the settings file as described in "How to load an SEM settings file" and start a measurement.

To configure a user-defined SEM measurement

  1. Define the span of the signal to be monitored in the general span settings.

  2. Split the frequency span of the measurement into ranges for signal parts with similar characteristics.

    Starting from the center frequency, determine which sections of the signal to the left and right can be swept and monitored using the same parameters. Criteria for such a range definition may be, for example:

    • The signal power level
    • The required resolution bandwidth or sweep time
    • Transducer factors
    • Permitted deviation from the defined signal level, i.e. the required limit values for monitoring

    If the signal consists of a transmission channel and adjacent channels, the channel ranges can usually be used for the range definition.

  3. If the signal power level to be monitored may vary and the limits will vary accordingly, define power classes. For each range of levels that can be monitored in the same way, define a power class.

    1. Select the "Overview" softkey, then select the "SEM Setup" button and switch to the "Power Classes" tab.

    2. Add a power class by selecting the "Add" button.

    3. Enter the start and stop power levels to define the class.

    4. Select the power classes to be used for the current measurement: either a specific class, or all classes, to have the required class selected automatically according to the input level measured in the reference range.

  4. Select the "Sweep List" tab of the "Spectrum Emission Mask" dialog box.

  5. Insert the required ranges using the "Insert before Range" and "Insert after Range" buttons, which refer to the currently selected range (the reference range by default).

    If the signal trace is symmetric to the center frequency, activate the "Sym Setup" option to make setup easier and quicker.

  6. Define the measurement parameters for each range as required. If symmetrical setup is activated, you only have to configure the ranges to one side of the center range.

    In particular, define the limits for each range of the signal, i.e. the area in which the signal level may deviate without failing the limit check. If several power classes were defined (see step 3), define limits for each power class.

    1. Define the type of limit check, i.e. whether absolute values or relative values are to be checked, or both. The type of limit check is identical for all power classes.

    2. Define the limit start and stop values.

  7. If the sweep list settings - other than the limit and transducer values - are identical for several adjacent ranges, activate "Fast SEM" mode to speed up the measurement. You only have to activate the mode for one range, the others are adapted automatically.

  8. If necessary, change the settings for the reference power to which all SEM results refer in the "Reference Range" tab.

  9. To indicate the determined peaks in the display during an SEM measurement, select the "Analysis" button in the "Overview" and activate the "Show Peaks" option.

  10. To save the current SEM measurement settings to a file to re-use them later, save a settings file as described in "How to save a user-defined SEM settings file".

  11. Start a sweep.

    The determined powers and limit deviations for each range are indicated in the Result Summary. If activated, the peak power levels for each range are also indicated in the Spectrum diagram.

  12. To save the Result Summary, export the results to a file as described in "How to Save SEM Result Files".

To perform an MSR SEM measurement

  1. Select the "MSR Config" softkey.

  2. Select the band category that determines the digital standards used in the measurement setup (see "Band Category").

  3. Define the bandwidth that contains all relevant carrier signals to be measured.

  4. For measurements with GSM/EDGE, LTE FDD and W-CDMA carriers (BC2), define whether a GSM/EDGE or an LTE FDD carrier, or both, are located at the edge of the bandwidth.

  5. Select the "Apply to SEM" button.

    The sweep list is configured according to the MSR specification, with the required number of ranges and defined limits.

  6. Start a sweep.

    The determined powers and limit deviations for each range are indicated in the Result Summary. If activated, the peak power levels for each range are also indicated in the Spectrum diagram.

  7. To save the Result Summary, export the results to a file as described in "How to Save SEM Result Files".

To perform a Multi-SEM measurement

  1. Define the span of the signal to be monitored in the general span settings.

  2. Select the "Multi-SEM Config" softkey.

  3. Define the number of sub blocks (up to 3) that contain the relevant carriers.

  4. For each sub block, define the center frequency, that is, the frequency of the TX carrier or a frequency in the dedicated reference range.

  5. For each sub block, do one of the following:

    1. Select a standard settings file to be used.

    2. Select the "MSR Settings" button and define the MSR configuration as described in "To perform an MSR SEM measurement".

    3. Select the "Edit" button and configure the sweep list manually as defined in "To configure a user-defined SEM measurement". Be sure to select the correct vertical tab for the corresponding sub block within each subtab of the "Spectrum Emission Mask" configuration dialog.

      Define a function to be used for overlapping ranges in the "Multi-Limit Calc" field of the sweep list.

  6. Start a sweep.

    The determined powers and limit deviations for each sub block, each gap, and each range are indicated in the Result Summary. If activated, the peak power levels for each range are also indicated in the Spectrum diagram.

  7. To save the Result Summary, export the results to a file as described in "How to Save SEM Result Files".

Contents
  • How to Manage SEM Settings Files
  • How to Save SEM Result Files


How to Manage SEM Settings Files

Measurements > Spectrum Emission Mask (SEM) Measurement > How to Perform a Spectrum Emission Mask Measurement > How to Manage SEM Settings Files
How to Manage SEM Settings Files

SEM measurement settings can be saved to an xml file which can then be exported to another application or loaded on the R&S FSW again at a later time. Some predefined XML files are provided that contain ranges and parameters according to the selected standard. All XML files are stored under C:\r_s\instr\sem_std.

For details on the file format of the SEM settings file, see "Format Description of SEM XML Files".

SEM settings or standard files are managed in the "Standards" tab of the "Spectrum Emission Mask" dialog box. To display this dialog box, select the "Overview" softkey and then the "SEM Setup" button.

How to load an SEM settings file

  1. From the file selection dialog box, select the settings file (with an ".xml" extension).

  2. Select the "Load" button.

    The settings from the selected file are restored to the R&S FSW and you can repeat the SEM measurement with the stored settings.

How to save a user-defined SEM settings file

  1. Configure the SEM measurement as required (see "How to Perform a Spectrum Emission Mask Measurement").

  2. In the "Standard Files" tab of the "Spectrum Emission Mask" dialog box, define a file name and storage location for the settings file.

  3. Select the "Save" button.

    The settings are stored to a file with the extension ".xml" as specified.

How to delete an SEM settings file

  1. In the "Standard Files" tab of the "Spectrum Emission Mask" dialog box, select the file you want to delete.

  2. Select the "Delete" button.

  3. Confirm the message.

    The settings file is removed from the R&S FSW.

How to restore default SEM settings files

The R&S FSW is delivered with predefined settings files which can be edited and overwritten. However, you can restore the original files.

► | In the "Standard Files" tab of the "Spectrum Emission Mask" dialog box, select the "Restore Standard Files" button.
 | The original predefined settings files are available for selection on the R&S FSW.


How to Save SEM Result Files

Measurements > Spectrum Emission Mask (SEM) Measurement > How to Perform a Spectrum Emission Mask Measurement > How to Save SEM Result Files
How to Save SEM Result Files

The Result Summary from an SEM measurement can be saved to a file, which can be exported to another application for further analysis, for example.

For details on the file format of the SEM export file, see "ASCII File Export Format (Spectrum Emission Mask)".

  1. Configure and perform an SEM measurement as described in "How to Perform a Spectrum Emission Mask Measurement".

  2. In the "Overview", select the "Analysis" button.

  3. If necessary, change the "Decimal Separator" to "COMMA" for evaluation in other languages.

  4. Select the "Save" button.

  5. In the file selection dialog box, select a storage location and file name for the result file.

  6. Select the "Save" button.

    The file with the specified name and the extension .dat is stored in the defined storage location.


Measurement Example: Multi-SEM Measurement

Measurements > Spectrum Emission Mask (SEM) Measurement > Measurement Example: Multi-SEM Measurement
Measurement Example: Multi-SEM Measurement

The following measurement example demonstrates an SEM measurement for a signal with multiple sub blocks.

Test setup:
Signal generator settings (e.g. R&S FSW SMU):
Device | Standard | Center Frequency | Level | Test Model
SigGen 1 | 3GPP/FDD | 900 MHz | 0 dBm | 1-16
SigGen 2 | EUTRA/LTE | 906.5 MHz | 0 dBm | 1_1_5MHz
Setting up the measurement

  1. Preset the R&S FSW.

  2. Set the center frequency to 903.25 MHz.

  3. Set the reference level to 10 dBm with an offset of to 30 dB.

  4. Press the MEAS key and select the "SEM" measurement function from the "Select Measurement" dialog box.

  5. Select the "Sub Blocks" softkey and define a subblock count of 2.

  6. For sub block A, define the settings for the 3GPP/FDD signal:

    1. Set the center frequency to 900 MHz

    2. Select "MSR Settings".

    3. Set the "Base Station RF Bandwidth" to 5 MHz.

    4. Select "Apply to SEM".

  7. For sub block B, define the settings for the EUTRA/LTE signal:

    1. Set the center frequency to 906.5 MHz

    2. Select "MSR Settings".

    3. Set the "Base Station RF Bandwidth" to 5 MHz.

    4. Select "Apply to SEM".

  8. Select RUN SINGLE to perform a measurement with the new settings.

    The results of the measurement for each sub block are displayed in the Result Summary. The summarized limit line is indicated in the Spectrum graph.

    Multi-SEM measurement: results of the measurement for each sub block


Reference: SEM File Descriptions

Measurements > Spectrum Emission Mask (SEM) Measurement > Reference: SEM File Descriptions
Reference: SEM File Descriptions

This reference provides details on the format of the SEM settings and result files.

Contents
  • Format Description of SEM XML Files
  • ASCII File Export Format (Spectrum Emission Mask)


Format Description of SEM XML Files

Measurements > Spectrum Emission Mask (SEM) Measurement > Reference: SEM File Descriptions > Format Description of SEM XML Files
Format Description of SEM XML Files

The SEM XML files offer a quick way to change the measurement settings. A set of ready-made XML files for different standards is already provided. You can also create and use your own XML files. Alternatively, edit the settings directly in the "Spectrum Emission Mask" dialog box and save the XML file afterwards. This way, no modifications have to be done in the XML file itself.

In addition to saving the current settings to a file, settings files can also be created independently of the R&S FSW, in an external application. When creating your own XML files, be sure to comply with the following conventions because the R&S FSW can only interpret XML files of a known structure. For sample files look in the C:\r_s\instr\sem_std directory of the R&S FSW.

To load a settings file, use the "Load" function in the "Standard Files" tab of the "Spectrum Emission Mask" dialog box (see "How to load an SEM settings file"). All XML files are stored under C:\r_s\instr\sem_std.

The files for importing range settings obey the rules of the XML standard. The child nodes, attributes, and structure defined for the data import are described here.

Be sure to follow the structure exactly as shown below or else the R&S FSW is not able to interpret the XML file and error messages are shown on the screen. It is recommended that you make a copy of an existing file and edit the copy of the file.

Basically, the file consists of three elements that can be defined:

  • The "BaseFormat" element
  • The "PowerClass" element
  • The "Range" element
The "BaseFormat" element

It carries information about basic settings. In this element only the "ReferencePower" child node has any effects on the measurement itself. The other attributes and child nodes are used to display information about the Spectrum Emission Mask Standard on the measurement screen. The child nodes and attributes of this element are shown in table "Attributes and child nodes of the BaseFormat element".

Example:

In the sample file PowerClass_39_43.xml under C:\r_s\instr\sem_std\WCDMA\3GPP, these attributes are defined as follows:

  • Standard="W-CDMA 3GPP"
  • LinkDirection="DL"
  • PowerClass="(39,43)dBm"
The "PowerClass" element

It is embedded in the "BaseFormat" element and contains settings information about the power classes. Up to four different power classes can be defined. For details refer to "Power Classes". The child nodes and attributes of this element are shown in table "Attributes and child nodes of the PowerClass element".

The "Range" element

This element is embedded in the "PowerClass" element. It contains the settings information of the range. There have to be at least three defined ranges: one reference range and at least one range to either side of the reference range. The maximum number of ranges is 30. Note that the R&S FSW uses the same ranges in each power class. Therefore, the contents of the ranges of each defined power class have to be identical to the first power class. An exception are the Start and Stop values of the two Limit nodes that are used to determine the power class. Note also, that there are two Limit nodes to be defined: one that gives the limit in absolute values and one in relative values. Make sure units for the Start and Stop nodes are identical for each Limit node.

For details refer to "Sweep List". The child nodes and attributes of this element are shown in table " Attributes and child nodes of the Range element (normal ranges)".

The following tables show the child nodes and attributes of each element and show if a child node or attribute is mandatory for the R&S FSW to interpret the file or not. Since the hierarchy of the XML can not be seen in the tables, either view one of the default files already stored on the R&S FSW in the "C:\r_s\instr\sem_std" directory or check the structure as shown below.

Below, a basic example of the structure of the file is shown, containing all mandatory attributes and child nodes. Note that the "PowerClass" element and the range element are themselves elements of the "BaseFormat" element and are to be inserted where noted. The separation is done here simply for reasons of a better overview. Also, no example values are given here to allow a quick reference to the tables above. Italic font shows the placeholders for the values.

  • The "BaseFormat" element is structured as follows:
    – <RS_SEM_ACP_FileFormat Version="1.0.0.0">
    <Name>"Standard"</Name>
    <Instrument>
    <Type>"Instrument Type"</Type>
    <Application>"Application"</Application>
    </Instrument>
    <LinkDirection Name="Name">
    <ReferencePower>
    <Method>"Method"</Method>
    </ReferencePower>
    <PowerClass Index="n">
    <!-- For contents of the PowerClass node see table "Attributes and child nodes of the PowerClass element" -->
    <!-- Define up to four PowerClass nodes -->
    </PowerClass>
    </LinkDirection>
    </RS_SEM_ACP_File>
  • The "PowerClass" element is structured as follows:
    – <PowerClass Index="n">
    <StartPower Unit="dBm" InclusiveFlag="true" Value="StartPowerValue"/>
    <StopPower Unit="dBm" InclusiveFlag="false" Value="StopPowerValue"/>
    <DefaultLimitFailMode>"Limit Fail Mode"</DefaultLimitFailMode>
    <Range Index="n">
    <!-- For contents of the Range node see table " Attributes and child nodes of the Range element (normal ranges)" -->
    <!-- Define up to twenty Range nodes -->
    </Range>
    …
    </PowerClass>
  • The "Range" element is structured as follows:
    – <Range Index="n">
    <Name="Name">
    <ChannelType>"Channel Type"</Channel Type>
    <WeightingFilter>
    <Type>"FilterType"</Type>
    <RollOffFactor>"Factor"</RollOffFactor>
    <Bandwith>"Bandwidth"</Bandwidth>
    </WeightingFilter>
    <FrequencyRange>
    <Start>"RangeStart"</Start>
    <Stop>"RangeStop"</Stop>
    </FrequencyRange>
    <Limit>
    <Start Unit="Unit" Value="Value"/>
    <Stop Unit="Unit" Value="Value"/>
    </Limit>
    <Limit>
    <Start Unit="Unit" Value="Value"/>
    <Stop Unit="Unit" Value="Value"/>
    </Limit>
    <RBW Bandwidth="Bandwidth" Type="FilterType"/>
    <VBW Bandwidth="Bandwidth"/>
    <Detector>"Detector"</Detector>
    <Sweep Mode="SweepMode" Time="SweepTime"/>
    <Amplitude>
    <ReferenceLevel Unit="dBm" Value="Value"/>
    <RFAttenuation Mode="Auto" Unit="dB" Value="Value"/>
    <Preamplifier State="State"/>
    </Amplitude>
    <MeasPointsMin>1</MeasPointsMin>
    <CalcRuleMulti>Sum</CalcRuleMulti>
    </Range>
Attributes and child nodes of the BaseFormat element
Child Node | Attribute | Value | Parameter Description | Mand.
 | FileFormatVersion | 1.0.0.0 |  | Yes
 | Date | YYYY-MM-DD HH:MM:SS | Date in ISO 8601 format | No
Name |  | <string> | Name of the standard | Yes
Instrument | Type | FSL | Name of the instrument | No
 | Application | SA | K72 | K82 | Name of the application | No
LinkDirection | Name | Downlink | Uplink | None |  | Yes
 | ShortName | DL | UL |  | No
ReferencePower |  |  |  | Yes
Method | TX Channel Power | TX Channel Peak Power |  |  | Yes
ReferenceChannel | <string> |  |  | No
Attributes and child nodes of the PowerClass element
Child Node | Attribute | Value | Parameter Description | Mand.
StartPower | Value | <power in dBm> | The start power must be equal to the stop power of the previous power class. The StartPower value of the first range is -200 | Yes
 | Unit | dBm |  | Yes
 | InclusiveFlag | true |  | Yes
StopPower | Value | <power in dBm> | The stop power must be equal to the start power of the next power class. The StopPower value of the last range is 200 | Yes
 | Unit | dBm |  |
 | InclusiveFlag | false |  | Yes
DefaultLimitFailMode |  | Absolute | Relative | Absolute and Relative | Absolute or Relative |  | Yes
Attributes and child nodes of the Range element (normal ranges)
Child Node | Attribute | Value | Parameter Description | Mand.
 | Index | 0…19 | Indices are continuous and have to start with 0 | Yes
 | Name | <string> | Name of the range | Only if ReferenceChannel contains a name and the range is the reference range
 | ShortName | <string> | Short name of the range | No
ChannelType |  | TX | Adjacent |  | Yes
WeightingFilter |  |  |  | Only if ReferencePower method is TX Channel Power and the range is the reference range
Type |  | RRC | CFilter | Type of the weighting filter | Yes
Roll Off Factor |  | 0…1 | Excess bandwidth of the filter | Only if the filter type is RRC
Bandwidth |  | <bandwidth in Hz> | Filter bandwidth | Only if the filter type is RRC
FrequencyRange |  |  |  | Yes
Start |  | <frequency in Hz> | Start value of the range | Yes
Stop |  | <frequency in Hz> | Stop value of the range | Yes
Limit |  | dBm/Hz | dBm | dBc | dBr | dB | A Range must contain exactly two limit nodes; one of the limit nodes has to have a relative unit (e.g. dBc), the other one must have an absolute unit (e.g. dBm) | Yes
Start | Value | <numeric_value> | Power limit at start frequency | Yes
 | Unit | dBm/Hz | dBm | dBc | dBr | dB | Sets the unit of the start value |
Stop | Value | <numeric_value> | Power limit at stop frequency |
 | Unit | dBm/Hz | dBm | dBc | dBr | dB | Sets the unit of the stop value |
LimitFailMode |  | Absolute | Relative | Absolute and Relative | Absolute or Relative | If used, it has to be identical to DefaultLimitFailMode | No
RBW | Bandwidth | <bandwidth in Hz> | "RBW" | Yes
 | Type | NORM | PULS | CFIL | RRC |  | No
VBW | Bandwidth | <bandwidth in Hz> | "VBW" | Yes
Detector |  | NEG | POS | SAMP | RMS | AVER | QUAS | If used, it has to be identical in all ranges. | No
Sweep | Mode | Manual | Auto | "Sweep Time Mode" | Yes
 | Time | <time in sec> | "Sweep Time" | No
Amplitude |  |  |  | No
ReferenceLevel | Value | <power in dBm> | "Ref. Level" | Yes, if the ReferenceLevel child node is used
 | Unit | dBm | Defines dBm as unit | Yes, if the ReferenceLevel node is used
RFAttenuation | Mode | Manual | Auto | "RF Att. Mode" | Yes, if the ReferenceLevel child node is used
Preamplifier |  | ON | OFF | "Preamp" | Yes


ASCII File Export Format (Spectrum Emission Mask)

Measurements > Spectrum Emission Mask (SEM) Measurement > Reference: SEM File Descriptions > ASCII File Export Format (Spectrum Emission Mask)
ASCII File Export Format (Spectrum Emission Mask)

When trace data from an SEM measurement is exported, the data is stored in ASCII format as described below. The first part of the file lists information about the signal analyzer and the general setup.

File contents | Explanation
File header
Type;FSW-26; | Model
Version;1.00; | Firmware version
Date;31.Mar 11; | Storage date of data set
Mode;ANALYZER;SEM; | Operating mode and measurement function
Center Freq;13250000000.000000;Hz | X-axis settings
Freq Offset;0.000000;Hz
Span;25500000.000000;Hz
x-Axis;LIN;
Start;13237250000.000000;Hz
Stop;13262750000.000000;Hz
Level Offset;0.000000;dB | Y-axis settings
Ref Position;100.000000;%
y-Axis;LOG;
Level Range;100.000000;dB
Trace settings
Trace Mode;CLR/WRITE; |
Detector;RMS;
Sweep Count;0;
Trace 1:;
x-Unit;Hz;
y-Unit;dBm;
List evaluation settings
Margin;200; | Peak List margin
Reference range settings
RefType; CPOWER; | Reference power type
TxBandwidth;3840000;;Hz | Channel power settings
Filter State; ON;
Alpha;0.22;
PeaksPerRange;1; | Max. number of peaks per range to be detected
Values;2; | Number of detected peaks
File data section
0;-12750000;-2515000;30000;13242367500;-43.844722747802734;-0.33028793334960938;49.669712066650391;FAIL; | Measured peak values: <range number>; <start frequency>; <stop frequency>; <resolution bandwidth of range>; <frequency of peak>; <absolute power in dBm of peak>; <relative power in dBc of peak>; (related to the channel power) <distance to the limit line in dB>; (positive value means above the limit) <limit fail (pass = 0, fail =1)>;
2;2515000;12750000;30000;13257632500;-43.844722747802734;-0.33028793334960938;49.669712066650391;FAIL;


Spurious Emissions Measurement

Measurements > Spurious Emissions Measurement
Spurious Emissions Measurement

The R&S FSW supports Spurious Emissions measurements.

Contents
  • About the Measurement
  • Spurious Emissions Measurement Results
  • Spurious Emissions Basics
  • Spurious Emissions Measurement Configuration
  • How to Perform a Spurious Emissions Measurement
  • Reference: ASCII Export File Format (Spurious)


About the Measurement

Measurements > Spurious Emissions Measurement > About the Measurement
About the Measurement

The Spurious Emissions measurement monitors unwanted RF products outside the assigned frequency band generated by an amplifier. The spurious emissions are usually measured across a wide frequency range. The Spurious Emissions measurement allows a flexible definition of all parameters. A result table indicates the largest deviations of the absolute power from the limit line for each range, and the results can be checked against defined limits automatically.


Spurious Emissions Measurement Results

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Results
Spurious Emissions Measurement Results

The measured signal, including any spurious emissions, and optionally the detected peaks are displayed in the Spurious Emissions measurement diagram. If defined, the limit lines and the limit check results are also indicated. In addition to the graphical results, a result table can be displayed to evaluate the measured powers and limit check results (see also "Limit Lines in Spurious Measurements"). The details of the evaluation list can be configured.

The following information is provided in the evaluation list for each range:

Column | Description
Range Low | Frequency range start for the range the peak value belongs to
Range Up | Frequency range end for the range the peak value belongs to
RBW | RBW of the range
Frequency | Frequency at the peak value
Power Abs | Absolute power level at the peak value
ΔLimit | Deviation of the absolute power level from the defined limit for the peak value

By default, one peak per range is displayed. However, you can change the settings to:

  • Display all peaks
  • Display a certain number of peaks per range
  • Display only peaks that exceed a threshold ("Margin")

In addition to listing the peaks in the list evaluation, detected peaks can be indicated by blue squares in the diagram.

Furthermore, you can save the evaluation list to a file.

Retrieving Results via Remote Control

The measured spurious values of the displayed trace can be retrieved using the TRAC:DATA? SPUR command (see TRACe<n>[:​DATA]).


Spurious Emissions Basics

Measurements > Spurious Emissions Measurement > Spurious Emissions Basics
Spurious Emissions Basics

Some background knowledge on basic terms and principles used in Spurious Emissions measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Ranges and Range Settings
  • Limit Lines in Spurious Measurements


Ranges and Range Settings

Measurements > Spurious Emissions Measurement > Spurious Emissions Basics > Ranges and Range Settings
Ranges and Range Settings
Conditions for ranges

The following rules apply to ranges:

  • The minimum span of a range is 20 Hz.
  • The individual ranges must not overlap (but may have gaps).
  • The maximum number of ranges is 30 (in firmware versions < 1.60: 20 ranges).
  • The maximum number of sweep points in all ranges is limited to 100001.

If you set a span that is smaller than the overall span of the ranges, the measurement includes only the ranges that lie within the defined span and have a minimum span of 20 Hz.

Defining ranges by remote control

In Spurious Emissions measurements, there are no remote commands to insert new ranges between existing ranges directly. However, you can delete or re-define the existing ranges to create the required order.

A remote command example for defining parameters and ranges in Spurious Emissions measurements is described in "Programming Example: Spurious Emissions Measurement".


Limit Lines in Spurious Measurements

Measurements > Spurious Emissions Measurement > Spurious Emissions Basics > Limit Lines in Spurious Measurements
Limit Lines in Spurious Measurements

Limit lines allow you to check the measured data against specified limit values. Generally, it is possible to define limit lines for any measurement in the Spectrum application using the LINES key. For Spurious measurements, however, a special limit line is available via the "Sweep List", and it is strongly recommended that you use only this limit line definition.

In the "Sweep List" you can define a limit line that varies its level according to the specified frequency ranges. A distinguished limit line is automatically defined according to the current "Sweep List" settings every time the settings change. This limit line is labeled "_SPURIOUS_LINE_ABS_<xxx>", where <xxx> is an index to distinguish limit lines between different measurement channels.

If a limit check is activated in the "Sweep List", the "_SPURIOUS_LINE_ABS" limit line is indicated by a red line in the display, and the result of the limit check is indicated at the top of the diagram. Note that only "Pass" or "Fail" is indicated; a "margin" function as for general limit lines is not available. Also, only absolute limits can be checked, not relative ones.

As for general limit lines, the results of each limit line check are displayed (here: "_SPURIOUS_LINE_ABS"), as well as the combined result for all defined limit lines ("Limit Check").

The limit check is considered to be "failed" if any signal level outside the absolute limits is measured.

In addition to the limit line itself, the largest deviations of the absolute power from the limit line for each range are displayed in the evaluation list if the limit check is activated. Values that exceed the limit are indicated in red and by an asterisk (*).

Although a margin functionality is not available for the limit check, a margin (threshold) for the peak values to be displayed in the evaluation list can be defined in the list evaluation settings. Furthermore, you can define how many peaks per range are listed. For details see "List Evaluation".


Spurious Emissions Measurement Configuration

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration
Spurious Emissions Measurement Configuration

Spurious emissions measurements are selected via the "Spurious Emissions" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "Spurious Emissions" dialog box, which is displayed when you select the "Spurious Setup" button in the "Overview" or the "Sweep List" softkey from the "Spurious Emissions" menu.

For details on using the configuration "Overview", see "Configuration Overview".

The remote commands required to perform these tasks are described in "Measuring Spurious Emissions".

Contents
  • Sweep List
  • Adjusting the X-Axis to the Range Definitions
  • List Evaluation


Sweep List

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List
Sweep List

For Spurious Emissions measurements, the input signal is split into several frequency ranges which are swept individually and for which different limitations apply. In the "Sweep List" dialog box you configure the individual frequency ranges and limits.

If you edit the sweep list, always follow the rules and consider the limitations described in "Ranges and Range Settings".

└ Range Start / Range Stop
└ Filter Type
└ RBW
└ VBW
└ Sweep Time Mode
└ Sweep Time
└ Detector
└ Ref. Level
└ RF Att. Mode
└ RF Attenuator
└ Preamp
└ Sweep Points
└ Stop After Sweep
└ Transducer
└ Limit Check
└ Abs Limit Start/Stop
└ Insert before/after Range
└ Delete Range


Range Start / Range Stop

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Range Start / Range Stop
Range Start / Range Stop

Sets the start frequency/stop frequency of the selected range.

Follow the rules described in "Ranges and Range Settings".

If you set a span that is smaller than the overall span of the ranges, the measurement includes only the ranges that lie within the defined span and have a minimum span of 20 Hz.

Remote command:

[SENSe:​]LIST:​RANGe<range>[:​FREQuency]:​STARt

[SENSe:​]LIST:​RANGe<range>[:​FREQuency]:​STOP


Filter Type

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Filter Type
Filter Type

Sets the filter type for this range.

For details on filter types see "Which Data May Pass: Filter Types".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​FILTer:​TYPE


RBW

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > RBW
RBW

Sets the RBW value for this range.

For details on the RBW see "Separating Signals by Selecting an Appropriate Resolution Bandwidth".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​BANDwidth[:​RESolution]


VBW

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > VBW
VBW

Sets the VBW value for this range.

For details on the VBW see "Smoothing the Trace Using the Video Bandwidth".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​BANDwidth:​VIDeo


Sweep Time Mode

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Sweep Time Mode
Sweep Time Mode

Activates or deactivates the auto mode for the sweep time.

For details on the sweep time mode see "How Long the Data is Measured: Sweep Time"

Remote command:

[SENSe:​]LIST:​RANGe<range>:​SWEep:​TIME:​AUTO


Sweep Time

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Sweep Time
Sweep Time

Sets the sweep time value for the range.

For details on the sweep time see "How Long the Data is Measured: Sweep Time"

Remote command:

[SENSe:​]LIST:​RANGe<range>:​SWEep:​TIME


Detector

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Detector
Detector

Sets the detector for the range.

For details refer to "Mapping Samples to Sweep Points with the Trace Detector".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​DETector


Ref. Level

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Ref. Level
Ref. Level

Sets the reference level for the range.

For details on the reference level see "Reference Level".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​RLEVel


RF Att. Mode

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > RF Att. Mode
RF Att. Mode

Activates or deactivates the auto mode for RF attenuation.

For details on attenuation see "RF Attenuation".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​INPut:​ATTenuation:​AUTO


RF Attenuator

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > RF Attenuator
RF Attenuator

Sets the attenuation value for that range.

For details on attenuation see "RF Attenuation".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​INPut:​ATTenuation


Preamp

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Preamp
Preamp

Switches the preamplifier on or off.

For details on the preamplifier see "Preamplifier (option B24)".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​INPut:​GAIN:​STATe


Sweep Points

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Sweep Points
Sweep Points

Sets the number of sweep points for the specified range.

For details on sweep points see "How Much Data is Measured: Sweep Points and Sweep Count".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​POINts[:​VALue]


Stop After Sweep

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Stop After Sweep
Stop After Sweep

This command configures the sweep behavior.

"ON" | The R&S FSW stops after one range is swept and continues only if you confirm (a message box is displayed).
"OFF" | The R&S FSW sweeps all ranges in one go.
Remote command:

[SENSe:​]LIST:​RANGe:​BREak


Transducer

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Transducer
Transducer

Sets a transducer for the specified range. You can only choose a transducer that fulfills the following conditions:

  • The transducer overlaps or equals the span of the range.
  • The x-axis is linear.
  • The unit is dB.

For details on transducers see "Basics on Transducer Factors".

Remote command:

[SENSe:​]LIST:​RANGe<range>:​TRANsducer


Limit Check

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Limit Check
Limit Check

Activates or deactivates the limit check for all ranges.

For details on limit checks see "Limit Lines in Spurious Measurements".

"Absolute" | Signal is checked against absolute limit values
"None" | No limit check is performed.
Remote command:

[SENSe:​]LIST:​RANGe:​LIMit:​STATe

CALCulate:​LIMit<k>:​FAIL?


Abs Limit Start/Stop

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Abs Limit Start/Stop
Abs Limit Start/Stop

Sets an absolute limit value at the start or stop frequency of the range [dBm].

This parameter is only available if the limit check is set accordingly (see "Limit Check").

Remote command:

[SENSe:​]LIST:​RANGe<range>:​LIMit:​STARt

[SENSe:​]LIST:​RANGe<range>:​LIMit:​STOP


Insert before/after Range

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Insert before/after Range
Insert before/after Range

Inserts a new range to the left of the currently focused range (before) or to the right (after). The range numbers of the currently focused range and all higher ranges are increased accordingly. The maximum number of ranges is 30.

For more details see "Ranges and Range Settings".


Delete Range

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Sweep List > Delete Range
Delete Range

Deletes the currently focused range. The range numbers are updated accordingly.

For more details see "Ranges and Range Settings".


Adjusting the X-Axis to the Range Definitions

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > Adjusting the X-Axis to the Range Definitions
Adjusting the X-Axis to the Range Definitions

The frequency axis of the measurement diagram can be adjusted automatically so that the span of all sweep list ranges corresponds to the displayed span. Thus, the x-axis range is set from the start frequency of the first sweep range to the stop frequency of the last sweep range.


List Evaluation

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > List Evaluation
List Evaluation

In the "List Evaluation" dialog box, which is displayed when you select the "Evaluations" button in the "Overview" or the "List Evaluation" softkey in the "Spurious Emissions" menu, you configure the contents and display of the result list.

└ List Evaluation State
└ Show Peaks
└ Margin
└ Details
└ Peaks per Range
└ Saving the Evaluation List


List Evaluation State

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > List Evaluation > List Evaluation State
List Evaluation State

Activates or deactivates the list evaluation.

Remote command:

CALCulate<n>:​ESPectrum:​PSEarch|PEAKsearch:​AUTO

TRACe<n>[:​DATA]


Show Peaks

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > List Evaluation > Show Peaks
Show Peaks

If activated, all peaks that have been detected during an active list evaluation are marked with blue squares in the diagram.

Remote command:

CALCulate<n>:​ESPectrum:​PSEarch|PEAKsearch:​PSHow


Margin

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > List Evaluation > Margin
Margin

Although a margin functionality is not available for the limit check, a margin (threshold) for the peak values to be displayed in the evaluation list (and diagram, if activated) can be defined. Only peaks that exceed the margin value are displayed.

Remote command:

CALCulate<n>:​ESPectrum:​PSEarch|PEAKsearch:​MARGin


Details

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > List Evaluation > Details
Details

Configures how detailed the list in the Result Summary is.

On | Includes all detected peaks (up to a maximum defined by "Peaks per Range").
Off | Includes only one peak per range.


Peaks per Range

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > List Evaluation > Peaks per Range
Peaks per Range

Defines the maximum number of peaks per range that are stored in the list. Once the selected number of peaks has been reached, the peak search is stopped in the current range and continued in the next range. The maximum value is 50.

Remote command:

CALCulate<n>:​PSEarch|PEAKsearch:​SUBRanges


Saving the Evaluation List

Measurements > Spurious Emissions Measurement > Spurious Emissions Measurement Configuration > List Evaluation > Saving the Evaluation List
Saving the Evaluation List

Exports the evaluation list of the Spurious Emissions measurement to an ASCII file for evaluation in an external application. If necessary, change the decimal separator for evaluation in other languages.

Define the file name and storage location in the file selection dialog box that is displayed when you select the "Save" function.

For details see "How to Save the Spurious Emissions Evaluation List".

Remote command:

MMEMory:​STORe:​LIST

FORMat:​DEXPort:​DSEParator


How to Perform a Spurious Emissions Measurement

Measurements > Spurious Emissions Measurement > How to Perform a Spurious Emissions Measurement
How to Perform a Spurious Emissions Measurement

  1. Press the MEAS key, then select the "Spurious Emissions" measurement.

  2. Define the span of the signal to be monitored in the general span settings.

  3. Select the "Overview" softkey, then select the "Spurious Setup" button.

    The "Spurious Emissions" dialog box is displayed.

  4. Split the frequency span of the measurement into ranges for signal parts with similar characteristics.

    Define the required ranges in the "Sweep List" using the "Insert before Range" and "Insert after Range" buttons, which refer to the currently selected range.

  5. Define the measurement parameters for each range as required.

  6. Optionally, define a limit check.

    1. Activate the limit check by setting "Limit Check" to "Absolute". The limit check is always activated or deactivated for all ranges simultaneously.

    2. Define the limit line's start and stop values for each range of the signal. If a signal level higher than the defined limit is measured, the limit check fails, which may indicate a spurious emission.

  7. Configure the peak detection during a Spurious Emissions measurement: select the "Evaluations" button in the "Overview".

    • To indicate the determined peaks in the display, activate the "Show Peaks" option.
    • To restrict peak detection, define a "Margin". Only peaks that exceed this value are detected.
    • To allow for more peaks per range to be detected than the default 1, increase the "Peaks Per Range" value and set "Details" to "On".

  8. Start a sweep.

    The determined powers and limit deviations for each range are indicated in the evaluation list. If activated, the peak power levels for each range are also indicated in the diagram.

  9. To save the evaluation list, export the results to a file as described in "How to Save the Spurious Emissions Evaluation List".

How to Save the Spurious Emissions Evaluation List

The evaluation list from a Spurious Emissions measurement can be saved to a file, which can be exported to another application for further analysis, for example.

  1. Configure and perform an Spurious Emissions measurement as described in "How to Perform a Spurious Emissions Measurement".

  2. Select the "Evaluations" button in the "Overview".

  3. If necessary, change the "Decimal Separator" to "COMMA" for evaluation in other languages.

  4. Select the "Save" button.

  5. In the file selection dialog box, select a storage location and file name for the result file.

  6. Select the "Save" button.

    The file with the specified name and the extension .dat is stored in the defined storage location.


Reference: ASCII Export File Format (Spurious)

Measurements > Spurious Emissions Measurement > Reference: ASCII Export File Format (Spurious)
Reference: ASCII Export File Format (Spurious)

The file has a header containing important parameters for scaling, several data sections containing the sweep settings per range, and a data section containing the peak list.

The header data is made up of three columns, separated by ';', with the syntax:

parameter name; numeric value; basic unit

File contents | Explanation
File header
Type;FSW-26; | Model
Version;1.00; | Firmware version
Date;31.Mar 11; | Storage date of data set
Mode;ANALYZER; SPURIOUS; | Operating mode and measurement function
Center Freq;13250000000.000000;Hz | X-axis settings
Freq Offset;0.000000;Hz
Span;26499982000.000000;Hz
x-Axis;LIN;
Start;9000.000000;Hz Stop;8000000000.000000;Hz
Level Offset;0.000000;dB | Y-axis settings
Ref Position;100.000000;%
y-Axis;LOG;
Level Range;100.000000;dB
Trace settings
Trace Mode;CLR/WRITE; |
Sweep Count;1;
TRACE 1:
Trace Mode;CLR/WRITE;
x-Unit;Hz;
y-Unit;dBm;
List evaluation settings
Margin;6.000000;s | Peak List margin
PeaksPerRange;25; | Max. number of peaks per range to be detected
Values;3; | Number of detected peaks
File data section
0;9000;150000;1000;79500;-25.006643295288086;-12.006643295288086;PASS; 0;9000;150000;1000;101022.11126961483;-47.075111389160156;-34.075111389160156;PASS; 0;9000;150000;1000;58380.171184022824;-47.079341888427734;-34.079341888427734;PASS; | Measured peak values: <range number>; <start frequency>; <stop frequency>; <resolution bandwidth of range>; <frequency of peak>; <absolute power in dBm of peak>; <distance to the limit line in dB>; (positive value means above the limit) <limit fail (pass = 0, fail =1)>;


Statistical Measurements (APD, CCDF)

Measurements > Statistical Measurements (APD, CCDF)
Statistical Measurements (APD, CCDF)

To measure the amplitude distribution, the R&S FSW has simple measurement functions to determine both the Amplitude Probability Distribution (APD) and the Complementary Cumulative Distribution Function (CCDF). Only one of the signal statistic functions can be switched on at a time.

Contents
  • About the Measurements
  • Typical Applications
  • APD and CCDF Results
  • APD and CCDF Basics - Gated Triggering
  • APD and CCDF Configuration
  • How to Perform an APD or CCDF Measurement
  • Examples
  • Optimizing and Troubleshooting the Measurement


About the Measurements

Measurements > Statistical Measurements (APD, CCDF) > About the Measurements
About the Measurements

The probability of amplitude values can be measured with the Amplitude Probability Distribution function (APD). During a selectable measurement time all occurring amplitude values are assigned to an amplitude range. The number of amplitude values in the individual ranges is counted and the result is displayed as a histogram.

Alternatively, the Complementary Cumulative Distribution Function (CCDF) can be displayed. It shows the probability that the mean signal power amplitude will be exceeded in percent.

Only one of the signal statistic functions can be switched on at a time. When a statistic function is switched on, the R&S FSW is set into zero span mode automatically. The R&S FSW measures the statistics of the signal applied to the RF input with the defined analysis bandwidth. To avoid affecting the peak amplitudes the video bandwidth is automatically set to 10 times the analysis bandwidth. The sample detector is used for detecting the video voltage.

Statistic measurements on pulsed signals can be performed using a gated trigger. For details see "APD and CCDF Basics - Gated Triggering".


Typical Applications

Measurements > Statistical Measurements (APD, CCDF) > Typical Applications
Typical Applications

Digital modulated signals are similar to white noise within the transmit channel, but are different in their amplitude distribution. In order to transmit the modulated signal without distortion, all amplitudes of the signal have to be transmitted linearly from the output power amplifier. Most critical are the peak amplitude values. Degradation in transmit quality caused by a transmitter two port network is dependent on the amplitude of the peak values as well as on their probability.

If modulation types are used that do not have a constant envelope in zero span, the transmitter has to handle peak amplitudes that are greater than the average power. This includes all modulation types that involve amplitude modulation, QPSK for example. CDMA transmission modes in particular may have power peaks that are large compared to the average power.

For signals of this kind, the transmitter must provide large reserves for the peak power to prevent signal compression and thus an increase of the bit error rate at the receiver. The peak power or the crest factor of a signal is therefore an important transmitter design criterion. The crest factor is defined as the peak power to mean power ratio or, logarithmically, as the peak level minus the average level of the signal. To reduce power consumption and cut costs, transmitters are not designed for the largest power that could ever occur, but for a power that has a specified probability of being exceeded (e.g. 0.01 %).

The statistical functions provide information on such signal criteria.


APD and CCDF Results

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Results
APD and CCDF Results
Amplitude Probability Distribution (APD)

As a result of the Amplitude Probability Distribution (APD) function, the probability of measured amplitude values is displayed. During a selectable measurement time all measured amplitude values are assigned to an amplitude range (bin). The number of amplitude values in the individual ranges is counted and the result is displayed as a histogram. Each bar of the histogram represents the percentage of measured amplitudes within the specific amplitude range. The x-axis represents the amplitude values and is scaled in absolute values (dBm).

The size of each amplitude range (bin) determines the resolution of the histogram and is indicated in the channel bar, for example / 0.10 dB. In this case, a single bar in the histogram represents an amplitude range of 0.10 dB.

In addition to the histogram, a result table is displayed containing the following information:

  • Number of samples used for calculation
  • For each displayed trace:
    – Mean amplitude
    – Peak amplitude
    – Crest factor
    The crest factor is defined as the peak power to mean power ratio or, logarithmically, as the peak level minus the average level of the signal.
Complementary Cumulative Distribution Function (CCDF)

The Complementary Cumulative Distribution Function (CCDF) shows the probability that the mean signal power amplitude will be exceeded in percent. The level above the mean power is plotted along the x-axis of the graph. The origin of the axis corresponds to the mean power level. The probability that a level will be exceeded is plotted along the y-axis.

A red line indicates the ideal Gaussian distribution for the measured amplitude range.

The displayed amplitude range is indicated as "Mean Pwr + <x dB>"

In addition to the histogram, a result table is displayed containing the following information:

  • Number of samples used for calculation
  • For each displayed trace:
Mean | Mean power
Peak | Peak power
Crest | Crest factor (peak power – mean power)
10 % | Level values over 10 % above mean power
1 % | Level values over 1 % above mean power
0,1 % | Level values over 0,1 % above mean power
0,01 % | Level values over 0,01 % above mean power
Percent marker

In addition to the results for specific percentages in the table, a percent marker can be activated for a freely selectable percentage. This marker indicates how many level values are over <x> % above the mean power.

Percent marker

As all markers, the percent marker can be moved simply by selecting it with a finger or mouse cursor and dragging it to the desired position.

Diagram Scaling

The scaling for both the x-axis and y-axis of the statistics diagram can be configured. In particular, you can restrict the range of amplitudes to be evaluated and the probabilities to be displayed.

Remote commands:

CALCulate<n>:​STATistics:​CCDF:​X<t>?

CALCulate:​STATistics:​RESult<t>?


APD and CCDF Basics - Gated Triggering

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Basics - Gated Triggering
APD and CCDF Basics - Gated Triggering

Statistic measurements on pulsed signals can be performed using a gated trigger. An external frame trigger is required as a time (frame) reference.

The gate ranges define the part of the measured data taken into account for the statistics calculation. These ranges are defined relative to a reference point T=0. The gate interval is repeated for each period until the end of the capture buffer.

The reference point T=0 is defined by the external trigger event and the instrument's trigger offset.

For each trace you can define up to 3 separate ranges of a single period to be traced.


APD and CCDF Configuration

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration
APD and CCDF Configuration

Configuration consists of the following settings:

Contents
  • Basic Settings
  • Gate Range Definition for APD and CCDF
  • Scaling for Statistics Diagrams


Basic Settings

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Basic Settings
Basic Settings

APD measurements are selected via the "APD" button in the "Select Measurement" dialog box. CCDF measurements are selected via the "CCDF" button in the "Select Measurement" dialog box. The measurements are started immediately with the default settings. They can be configured via the MEAS CONFIG key or in the "APD/CCDF" dialog boxes, which are displayed as a tab in the "Analysis" dialog box or when you select the "APD Config" softkey from the "APD" menu or the "CCDF Config" softkey from the "CCDF" menu.

For background information on defining gate ranges see "APD and CCDF Basics - Gated Triggering".

The remote commands required to perform these tasks are described in "Analyzing Statistics (APD, CCDF)".

Both dialog boxes are identical except for the "Percent Marker" setting, which is only available for CCDF measurements.

└ Percent Marker (CCDF only)
└ Analysis Bandwidth
└ Number of Samples
└ Gated Trigger
└ Edit Gate Ranges
└ Adjust Settings


Percent Marker (CCDF only)

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Basic Settings > Percent Marker (CCDF only)
Percent Marker (CCDF only)

Defines a probability value. Thus, the power which is exceeded with a given probability can be determined very easily. If marker 1 is deactivated, it is switched on automatically.

For details on the results of the CCDF measurement see "APD and CCDF Results".

Remote command:

CALCulate<n>:​MARKer<m>:​Y:​PERCent


Analysis Bandwidth

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Basic Settings > Analysis Bandwidth
Analysis Bandwidth

Defines the analysis bandwidth.

For correct measurement of the signal statistics, the analysis bandwidth has to be wider than the signal bandwidth in order to measure the peaks of the signal amplitude correctly. To avoid influencing the peak amplitudes, the video bandwidth is automatically set to 10 MHz. The sample detector is used for detecting the video voltage.

The calculated measurement time is displayed for reference only.

For details on the measurement see "About the Measurements".

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]


Number of Samples

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Basic Settings > Number of Samples
Number of Samples

Defines the number of power measurements that are taken into account for the statistics.

For statistics measurements with the R&S FSW, the number of samples to be measured is defined instead of the sweep time. Since only statistically independent samples contribute to statistics, the sweep or measurement time is calculated automatically and displayed in the channel bar ("Meas Time"). The samples are statistically independent if the time difference is at least 1/RBW. The measurement time is, therefore, expressed as follows:

Meas Time = NSamples/RBW

For details on the measurement see "About the Measurements".

Remote command:

CALCulate<n>:​STATistics:​NSAMples


Gated Trigger

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Basic Settings > Gated Trigger
Gated Trigger

Activates and deactivates gating for statistics functions for the ACP and the CCDF measurements. If activated, the trigger source is changed to "External Trigger 1". The gate ranges are defined using the "Edit Gate Ranges" function.

For details on using a gated trigger see "APD and CCDF Basics - Gated Triggering".

Remote command:

[SENSe:​]SWEep:​EGATe:​TRACe<k>[:​STATe<range>]


Edit Gate Ranges

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Basic Settings > Edit Gate Ranges
Edit Gate Ranges

Opens a dialog box to configure up to 3 gate ranges for each trace. For details see "Gate Range Definition for APD and CCDF".


Adjust Settings

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Basic Settings > Adjust Settings
Adjust Settings

Adjusts the level settings according to the measured difference between peak and minimum power for APD measurement or peak and mean power for CCDF measurement in order to obtain maximum power resolution. Adjusts the reference level to the current input signal.

Remote command:

CALCulate<n>:​STATistics:​SCALe:​AUTO ONCE


Gate Range Definition for APD and CCDF

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Gate Range Definition for APD and CCDF
Gate Range Definition for APD and CCDF

Gate ranges for gated triggering in statistical measurements can be configured in the "Gate Ranges" dialog box, which is displayed when you select the "Edit Gate Ranges" button in the "APD" or "CCDF" configuration dialog boxes.

For background information on defining gate ranges see "APD and CCDF Basics - Gated Triggering".

The remote commands required to perform these tasks are described in "Using Gate Ranges for Statistical Measurements".

Up to three ranges can be defined for each of the six available traces.

└ Comment
└ Period
└ Range <x> Use
└ Range <x> Start/Stop


Comment

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Gate Range Definition for APD and CCDF > Comment
Comment

An optional comment can be defined for the gate range settings of each trace.

For details on using a gated trigger see "APD and CCDF Basics - Gated Triggering".

Remote command:

[SENSe:​]SWEep:​EGATe:​TRACe<k>:​COMMent


Period

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Gate Range Definition for APD and CCDF > Period
Period

Length of the period to be traced. The period is the same for all traces. If you change the period for one trace, it is automatically changed for all traces.

Make sure the defined period is not longer than the total measurement time of the current measurement. Keep in mind that the measurement time depends on the bandwidth and the number of samples (see "Number of Samples"). The current measurement time is indicated as "Meas Time" in the channel bar.

For details on using a gated trigger see "APD and CCDF Basics - Gated Triggering".

Remote command:

[SENSe:​]SWEep:​EGATe:​TRACe:​PERiod


Range <x> Use

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Gate Range Definition for APD and CCDF > Range <x> Use
Range <x> Use

Activates tracing of the defined range during a gated measurement.

For details on using a gated trigger see "APD and CCDF Basics - Gated Triggering".

Remote command:

[SENSe:​]SWEep:​EGATe:​TRACe<k>[:​STATe<range>]


Range <x> Start/Stop

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Gate Range Definition for APD and CCDF > Range <x> Start/Stop
Range <x> Start/Stop

Defines the start and stop points of the range within the tracing period. Make sure the value for the stopping time is smaller than the length of the period.

Note: You can define the time values with a greater numerical resolution than is displayed; the values are only rounded for display.

For details on using a gated trigger see "APD and CCDF Basics - Gated Triggering".

Remote command:

[SENSe:​]SWEep:​EGATe:​TRACe<k>:​STARt<range>

[SENSe:​]SWEep:​EGATe:​TRACe<k>:​STOP<range>


Scaling for Statistics Diagrams

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams
Scaling for Statistics Diagrams

The diagram scaling for statistical measurements can be configured in the "Scaling" dialog box, which is displayed when you select the AMPT key and then the "Scale Config" softkey.

The remote commands required to perform these tasks are described in "Scaling the Diagram".

In statistical diagrams, the x-axis displays the signal level values (= y-axis in standard display), while the y-axis displays the probability of the values.

└ X-Axis
└ Range
└ Ref Level
└ Shifting the Display (Offset)
└ Y-Axis
└ Y-Unit
└ Y-Max / Y-Min
└ Default Settings
└ Adjust Settings


X-Axis

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > X-Axis
X-Axis

Defines the scaling settings for signal level values.

└ Range
└ Ref Level
└ Shifting the Display (Offset)


Range

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > X-Axis > Range
Range

Defines the level range in dB to be evaluated by the statistics measurement.

For details on the results of the measurement see "APD and CCDF Results".

Remote command:

CALCulate<n>:​STATistics:​SCALe:​X:​RANGe


Ref Level

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > X-Axis > Ref Level
Ref Level

Defines the reference level for the signal levels in the currently active unit (dBm, dBµV, etc).

For the APD function this value corresponds to the right diagram border. For the CCDF function there is no direct representation of this value on the diagram as the x-axis is scaled relatively to the measured mean power.

For details on the results of the measurement see "APD and CCDF Results".

Remote command:

CALCulate<n>:​STATistics:​SCALe:​X:​RLEVel


Shifting the Display (Offset)

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > X-Axis > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the x-axis is changed accordingly. The setting range is ±200 dB in 0.1 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Y-Axis

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > Y-Axis
Y-Axis

Defines the scaling settings for the probability distribution.

└ Y-Unit
└ Y-Max / Y-Min


Y-Unit

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > Y-Axis > Y-Unit
Y-Unit

Defines the scaling type of the y-axis as either percentage or absolute. The default value is absolute scaling.

Remote command:

CALCulate<n>:​STATistics:​SCALe:​Y:​UNIT


Y-Max / Y-Min

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > Y-Axis > Y-Max / Y-Min
Y-Max / Y-Min

Defines the upper (max) and lower (min) limit of the displayed probability range. Values on the y-axis are normalized which means that the maximum value is 1.0. The minimum value must be in the range:

1E-9 < Y-Min < 0.1

The distance between Y-max and Y-min must be at least one decade.

Remote command:

CALCulate<n>:​STATistics:​SCALe:​Y:​UPPer

CALCulate<n>:​STATistics:​SCALe:​Y:​LOWer


Default Settings

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > Default Settings
Default Settings

Resets the x- and y-axis scalings to their preset values.

x-axis ref level: | -10 dBm
x-axis range APD: | 100 dB
x-axis range CCDF: | 20 dB
y-axis upper limit: | 1.0
y-axis lower limit: | 1E-6
Remote command:

CALCulate<n>:​STATistics:​PRESet


Adjust Settings

Measurements > Statistical Measurements (APD, CCDF) > APD and CCDF Configuration > Scaling for Statistics Diagrams > Adjust Settings
Adjust Settings

Adjusts the level settings according to the measured difference between peak and minimum power for APD measurement or peak and mean power for CCDF measurement in order to obtain maximum power resolution. Adjusts the reference level to the current input signal.

Remote command:

CALCulate<n>:​STATistics:​SCALe:​AUTO ONCE


How to Perform an APD or CCDF Measurement

Measurements > Statistical Measurements (APD, CCDF) > How to Perform an APD or CCDF Measurement
How to Perform an APD or CCDF Measurement
To start a basic statistic measurement

  1. Press the MEAS key, then select the "APD" or "CCDF" measurement.

  2. Start a sweep.

    As soon as the defined number of samples have been measured, the statistical evaluation is displayed.

To perform a statistic measurement using gate ranges

For pulsed signals, the transmission intervals should not be included in the statistical evaluation. Thus, you must define gate ranges to be included in the measurement.

  1. Press the MEAS CONFIG key, then select the "APD Config" or "CCDF Config" softkey.

    The "APD" or "CCDF" dialog box is displayed.

  2. Select the "Edit Gate Ranges" button.

  3. Define the time period for which the input signal is to be analyzed, for example the duration of 3 signal pulses.

  4. For each active trace, define up to three ranges within the time period to be measured. In the example covering 3 pulses, you could define one range for each pulse.

    1. Assuming the external trigger determines T=0 as the start of the first pulse, define the start time of range 1 at 0 s.

    2. Define the stop time of range 1 at the duration of the first pulse.

    3. Activate range 1 by setting "Range 1 Use" to On.

    4. Define the start time of range 2 as (duration of pulse 1 + duration of interval)

    5. Define the stop time of range 2 as (start time of range 2 + duration of pulse 2)

    6. Activate range 2 by setting "Range 2 Use" to On.

    7. Define the third range in the same way.

  5. Start a sweep.

    As soon as the defined number of samples have been measured, the statistical evaluation is displayed. Only the signal levels within the pulse periods are considered.


Examples

Measurements > Statistical Measurements (APD, CCDF) > Examples
Examples
Contents
  • Configuration Example: Gated Statistics
  • Measurement Example – Measuring the APD and CCDF of White Noise Generated by the R&S FSW


Configuration Example: Gated Statistics

Measurements > Statistical Measurements (APD, CCDF) > Examples > Configuration Example: Gated Statistics
Configuration Example: Gated Statistics

A statistics evaluation has to be done over the useful part of the signal between t3 and t4. The period of the GSM signal is 4.61536 ms.

t1: External positive trigger slope

t2: Begin of burst (after 25 µs)

t3: Begin of useful part, to be used for statistics (after 40 µs)

t4: End of useful part, to be used for statistics (after 578 µs)

t5: End of burst (after 602 µs)

The instrument has to be configured as follows:

Trigger Offset | t2 – t1 = 25 µs | now the gate ranges are relative to t2
Range1 Start | t3 – t2 = 15 µs | start of range 1 relative to t2
Range1 End | t4 – t2 = 553 µs | end of range 1 relative to t2


Measurement Example – Measuring the APD and CCDF of White Noise Generated by the R&S FSW

Measurements > Statistical Measurements (APD, CCDF) > Examples > Measurement Example – Measuring the APD and CCDF of White Noise Generated by the R&S FSW
Measurement Example – Measuring the APD and CCDF of White Noise Generated by the R&S FSW
Setting the RBW

When the amplitude distribution is measured, the analysis bandwidth must be set so that the complete spectrum of the signal to be measured falls within the bandwidth. This is the only way of ensuring that all the amplitudes will pass through the IF filter without being distorted. If the selected bandwidth is too small for a digitally modulated signal, the amplitude distribution at the output of the IF filter becomes a Gaussian distribution according to the central limit theorem and thus corresponds to a white noise signal. The true amplitude distribution of the signal therefore cannot be determined.

  1. Preset the R&S FSW.

  2. Set the reference level to -60 dBm.

    The R&S FSW's intrinsic noise is displayed at the top of the screen.

  3. Select the "APD" measurement function from the "Select Measurement" dialog box.

    The R&S FSW sets the frequency span to 0 Hz and measures the amplitude probability distribution (APD). The number of uncorrelated level measurements used for the measurement is 100000. The mean power and the peak power are displayed in dBm. The crest factor (peak power – mean power) is output as well.

    Amplitude probability distribution of white noise

  4. Now select the "CCDF" measurement function from the "Select Measurement" dialog box.

    CCDF of white noise

    The CCDF trace indicates the probability that a level will exceed the mean power. The level above the mean power is plotted along the x-axis of the graph. The origin of the axis corresponds to the mean power level. The probability that a level will be exceeded is plotted along the y-axis.


Optimizing and Troubleshooting the Measurement

Measurements > Statistical Measurements (APD, CCDF) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement:

  • Make sure the defined bandwidth is wide enough for the signal bandwidth of the device under test to be fully analyzed (see "Analysis Bandwidth").
  • If the complete signal is be measured, increase the number of samples so that the resulting measurement time is longer than one period of a bursted signal.
  • If only parts of the signal are to be examined, define a trigger source and a gate.


Time Domain Power Measurement

Measurements > Time Domain Power Measurement
Time Domain Power Measurement

The R&S FSW can determine the power of a signal in the time domain using the Time Domain Power measurement function.

Contents
  • About the Measurement
  • Time Domain Power Results
  • Time Domain Power Basics - Range Definition Using Limit Lines
  • Time Domain Power Configuration
  • How to Measure Powers in the Time Domain
  • Measurement Example


About the Measurement

Measurements > Time Domain Power Measurement > About the Measurement
About the Measurement

Using the Time Domain Power measurement function, the R&S FSW determines the power of the signal in zero span by summing up the power at the individual measurement points and dividing the result by the number of measurement points. Thus it is possible to measure the power of TDMA signals during transmission, for example, or during the muting phase. Both the mean power and the RMS power can be measured.

For this measurement, the sample detector is activated.


Time Domain Power Results

Measurements > Time Domain Power Measurement > Time Domain Power Results
Time Domain Power Results

Several different power results can be determined simultaneously:

Mode | Description
Peak | Peak value from the points of the displayed trace or a segment thereof.
RMS | RMS value from the points of the displayed trace or a segment thereof.
Mean | Mean value from the points of the displayed trace or a segment thereof. The linear mean value of the equivalent voltages is calculated. For example to measure the mean power during a GSM burst
Std Dev | The standard deviation of the measurement points from the mean value.

The result is displayed in the marker results, indicated by "Power" and the selected power mode, e.g. "RMS". The measured values are updated after each sweep or averaged over a user-defined number of sweeps (trace averaging).

The results can also be queried using the remote commands described in "Measuring the Time Domain Power".


Time Domain Power Basics - Range Definition Using Limit Lines

Measurements > Time Domain Power Measurement > Time Domain Power Basics - Range Definition Using Limit Lines
Time Domain Power Basics - Range Definition Using Limit Lines

The range of the measured signal to be evaluated for the power measurement can be restricted using limit lines. The left and right limit lines (S1, S2) define the evaluation range and are indicated by vertical red lines in the diagram. If activated, the power results are only calculated from the levels within the limit lines.

For example, if both the on and off phase of a burst signal are displayed, the measurement range can be limited to the transmission or to the muting phase. The ratio between signal and noise power of a TDMA signal for instance can be measured by using a measurement as a reference value and then varying the measurement range.

In order to get stable measurement results for a limited evaluation range, usually a trigger is required.


Time Domain Power Configuration

Measurements > Time Domain Power Measurement > Time Domain Power Configuration
Time Domain Power Configuration

Time Domain Power measurements are selected via the "Time Domain Power" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "Time Domain Power" dialog box, which is displayed as a tab in the "Analysis" dialog box or when you select the "Time Dom Power Config" softkey from the "Time Dom Pwr" menu.

The remote commands required to perform these tasks are described in "Measuring the Time Domain Power".

└ Results
└ Limit State
└ Left Limit / Right Limit


Results

Measurements > Time Domain Power Measurement > Time Domain Power Configuration > Results
Results

Activates the power results to be evaluated from the displayed trace or a limited area of the trace.

"Peak" | Peak power over several measurements (uses trace averaging, Max Hold)
"RMS" | RMS value from the points of the displayed trace or a segment thereof.
"Mean" | Mean value from the points of the displayed trace or a segment thereof. The linear mean value of the equivalent voltages is calculated.
"Std Dev" | The standard deviation of the measurement points from the mean value. The measurement of the mean power is automatically switched on at the same time.
Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​PPEak[:​STATe]

CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​PPEak:​RESult?

CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​RMS[:​STATe]

CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​RMS:​RESult?

CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​MEAN[:​STATe]

CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​MEAN:​RESult?


Limit State

Measurements > Time Domain Power Measurement > Time Domain Power Configuration > Limit State
Limit State

Switches the limitation of the evaluation range on or off. Default setting is off.

If deactivated, the entire sweep time is evaluated. If switched on, the evaluation range is defined by the left and right limit. If only one limit is set, it corresponds to the left limit and the right limit is defined by the stop frequency. If the second limit is also set, it defines the right limit.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]


Left Limit / Right Limit

Measurements > Time Domain Power Measurement > Time Domain Power Configuration > Left Limit / Right Limit
Left Limit / Right Limit

Defines a power level limit for line S1 (left) or S2 (right).

Remote command:

CALCulate:​MARKer:​X:​SLIMits:​LEFT

CALCulate:​MARKer:​X:​SLIMits:​RIGHT


How to Measure Powers in the Time Domain

Measurements > Time Domain Power Measurement > How to Measure Powers in the Time Domain
How to Measure Powers in the Time Domain
To measure the power in the time domain

  1. Select the "Time Domain Power" measurement function from the "Select Measurement" dialog box.

  2. Select the type of power measurement results to be determined by selecting the corresponding softkeys.

  3. To restrict the power evaluation range, define limits:

    1. Select the "Time Dom Power Config" softkey to display the "Time Domain Power" configuration dialog box.

    2. Switch on the limits by setting the "Limit State" to "On".

      The limit lines S1 and S2 are displayed.

    3. Define the left limit (limit line S1), the right limit (S2), or both.

  4. Start a sweep.

    The measured powers are displayed in the marker results.


Measurement Example

Measurements > Time Domain Power Measurement > Measurement Example
Measurement Example

This measurement example demonstrates the time domain power calculation for a GSM burst.

Test setup:
Signal generator settings (e.g. R&S FSW SMU):
Frequency: | 1.8 GHz
Level: | -10 dBm
Modulation: | GSM/EDGE
Procedure:

  1. Preset the R&S FSW.

  2. Set the center frequency to 1.8 GHz.

  3. Set the RBW to 100 kHz.

  4. Set the sweep time to 640 μs.

  5. Set the trigger source to "IF Power".

  6. Define a trigger offset of -50 μs.

  7. Select the "Time Domain Power" measurement function from the "Select Measurement" dialog box.

  8. In the Time Domain Power configuration dialog box, set all four results to "ON".

  9. Set the "Limit State" to "ON".

  10. Define the left limit at 326 μs and the right limit at 538 μs.

    This range corresponds to the useful part of the GSM burst.

    The mean power of the useful part of the GSM burst is calculated to be -13 dBm.


Harmonic Distortion Measurement

Measurements > Harmonic Distortion Measurement
Harmonic Distortion Measurement

The harmonics and their distortion can be measured using the "Harmonic Distortion" function.

Contents
  • About the Measurement
  • Harmonic Distortion Basics
  • Harmonic Distortion Results
  • Harmonic Distortion Configuration
  • How to Determine the Harmonic Distortion


About the Measurement

Measurements > Harmonic Distortion Measurement > About the Measurement
About the Measurement

With this measurement it is possible to measure the harmonics easily, for example from a VCO. In addition, the total harmonic distortion (THD) is calculated.

For measurements in the frequency domain, the Harmonic Distortion measurement starts with an automatic search for the first harmonic (= peak) within the set frequency range. The center frequency is set to this frequency and the reference level is adjusted accordingly.

For measurements in zero span, the center frequency remains unchanged.

The Harmonic Distortion measurement then performs zero span sweeps at the center frequency and at each harmonic, i.e. at frequencies that are a multiple of the center frequency.

As a result, the zero span sweeps on all harmonics are shown, as well as the RMS values and the total harmonic distortion (THD).


Harmonic Distortion Basics

Measurements > Harmonic Distortion Measurement > Harmonic Distortion Basics
Harmonic Distortion Basics

Measuring the harmonics of a signal is a frequent problem which can be solved best using a signal analyzer. In general, every signal contains harmonics. Harmonics are generated by nonlinear characteristics, which add frequencies to a pure sinewave. They can often be reduced by low pass filters. Since the signal analyzer itself has a nonlinear characteristic, for example in its first mixer, measures must be taken to ensure that harmonics produced in the signal analyzer do not cause spurious results. If necessary, the fundamental wave must be attenuated selectively with respect to the other harmonics with a high pass filter. Harmonics are particularly critical regarding high-power transmitters such as transceivers because large harmonics can interfere with other radio services.

Harmonic distortion can be determined as the level of the individual components, or as the root mean square of all components together, the total harmonic distortion (THD). The THD is set in relation to the power of the fundamental frequency (= center frequency).

Obtainable dynamic range

When harmonics are being measured, the obtainable dynamic range depends on the second harmonic intercept of the signal analyzer. The second harmonic intercept is the virtual input level at the RF input mixer at which the level of the 2nd harmonic becomes equal to the level of the fundamental wave. In practice, however, applying a level of this magnitude would damage the mixer. Nevertheless the available dynamic range for measuring the harmonic distance of a DUT can be calculated relatively easily using the second harmonic intercept.

As shown in figure "Extrapolation of the 1st and 2nd harmonics to the 2nd harmonic intercept at 40 dBm", the level of the 2nd harmonic drops by 20 dB if the level of the fundamental wave is reduced by 10 dB.

Extrapolation of the 1st and 2nd harmonics to the 2nd harmonic intercept at 40 dBm

The following formula for the obtainable harmonic distortion d2 in dB is derived from the straight-line equations and the given intercept point:

d2 = S.H.I – PI (1)

where:

d2 | = | harmonic distortion
S.H.I. | = | second harmonic intercept
PI | = | mixer level/dBm

The mixer level is the RF level applied to the RF input minus the set RF attenuation.

The formula for the internally generated level P1 at the 2nd harmonic in dBm is:

P1 = 2 * PI – S.H.I. (2)

The lower measurement limit for the harmonic is the noise floor of the signal analyzer. The harmonic of the measured DUT should – if sufficiently averaged by means of a video filter – be at least 4 dB above the noise floor so that the measurement error due to the input noise is less than 1 dB.

Rules for measuring high harmonic ratios

The following rules for measuring high harmonic ratios can be derived:

  • Select the smallest possible IF bandwidth for a minimal noise floor.
  • Select an RF attenuation which is high enough to measure the harmonic ratio only.

The maximum harmonic distortion is obtained if the level of the harmonic equals the intrinsic noise level of the receiver. The level applied to the mixer, according to (2), is:

At a resolution bandwidth of 10 Hz (noise level -143 dBm, S.H.I. = 40 dBm), the optimum mixer level is – 51.5 dBm. According to (1) a maximum measurable harmonic distortion of 91.5 dB minus a minimum S/N ratio of 4 dB is obtained.

Detecting the origin of harmonics

If the harmonic emerges from noise sufficiently (approx. >15 dB), it is easy to check (by changing the RF attenuation) whether the harmonics originate from the DUT or are generated internally by the signal analyzer. If a harmonic originates from the DUT, its level remains constant if the RF attenuation is increased by 10 dB. Only the displayed noise is increased by 10 dB due to the additional attenuation. If the harmonic is exclusively generated by the signal analyzer, the level of the harmonic is reduced by 20 dB or is lost in noise. If both – the DUT and the signal analyzer – contribute to the harmonic, the reduction in the harmonic level is correspondingly smaller.

High-sensitivity harmonics measurements

If harmonics have very small levels, the resolution bandwidth required to measure them must be reduced considerably. The sweep time is, therefore, also increased considerably. In this case, the measurement of individual harmonics is carried out with the R&S FSW set to a small span. Only the frequency range around the harmonics will then be measured with a small resolution bandwidth.

Required measurement time

During the harmonics measurement, zero span sweeps are performed at the center frequency and at each harmonic. The duration of each sweep ("Harmonic Sweep Time", SWT) and the "Number of Harmonics" (n) are defined in the "Harmonic Distortion" configuration dialog box. Thus, the required measurement time for the harmonic distortion measurement (Cumulated Measurement Time, CMT) is:

CMT = n*SWT

The required measurement time is indicated as "CMT" in the channel bar.


Harmonic Distortion Results

Measurements > Harmonic Distortion Measurement > Harmonic Distortion Results
Harmonic Distortion Results

As a result of the harmonics distortion measurement, the zero span sweeps of all detected harmonics are shown in the diagram, separated by red display lines. This provides a very good overview of the measurement.

In addition, a result table is displayed providing the following information:

  • First harmonic frequency
  • THD (total harmonic distortion), relative and absolute values
  • For each detected harmonic:
    – Frequency
    – RBW
    – Power
Remote commands

The results can also be queried using remote commands.

The first harmonic frequency can be read out via the general center frequency command [SENSe:​]FREQuency:​CENTer.

THD: CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics:​DISTortion?

List of harmonics: CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics:​LIST?


Harmonic Distortion Configuration

Measurements > Harmonic Distortion Measurement > Harmonic Distortion Configuration
Harmonic Distortion Configuration

Harmonic Distortion measurements are selected via the "Harmonic Distortion" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "Harmonic Distortion" dialog box, which is displayed as a tab in the "Analysis" dialog box or when you select the "Harmonic Distortion Config" softkey from the "Harm Dist" menu.

The remote commands required to perform these tasks are described in "Measuring the Harmonic Distortion".

└ No. of Harmonics
└ Harmonic Sweep Time
└ Harmonic RBW Auto
└ Adjust Settings


No. of Harmonics

Measurements > Harmonic Distortion Measurement > Harmonic Distortion Configuration > No. of Harmonics
No. of Harmonics

Defines the number of harmonics to be measured. The range is from 1 to 26. Default is 10.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics:​NHARmonics


Harmonic Sweep Time

Measurements > Harmonic Distortion Measurement > Harmonic Distortion Configuration > Harmonic Sweep Time
Harmonic Sweep Time

Defines the sweep time for the zero span measurement on each harmonic frequency. This setting is identical to the normal sweep time for zero span, see also "Sweep Time".

Remote command:

[SENSe:​]SWEep:​TIME:​AUTO


Harmonic RBW Auto

Measurements > Harmonic Distortion Measurement > Harmonic Distortion Configuration > Harmonic RBW Auto
Harmonic RBW Auto

Enables/disables the automatic adjustment of the resolution bandwidth for Normal (3dB) (Gaussian) and 5-Pole filter types. The automatic adjustment is carried out according to:

"RBWn = RBW1 * n"

If RBWn is not available, the next higher value is used.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics:​BANDwidth:​AUTO


Adjust Settings

Measurements > Harmonic Distortion Measurement > Harmonic Distortion Configuration > Adjust Settings
Adjust Settings

If harmonic measurement was performed in the frequency domain, a new peak search is started in the frequency range that was set before starting the harmonic measurement. The center frequency is set to this frequency and the reference level is adjusted accordingly.

If harmonic measurement was performed in the time domain, this function adjusts the reference level only.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​HARMonics:​PRESet


How to Determine the Harmonic Distortion

Measurements > Harmonic Distortion Measurement > How to Determine the Harmonic Distortion
How to Determine the Harmonic Distortion

In "Measurement Example: Measuring Harmonics Using Marker Functions", measuring harmonics was described using marker functions. This task can be performed much simpler using the Harmonic Distortion measurement, as described in the following procedure.

  1. Select the "Harmonic Distortion" measurement function from the "Select Measurement" dialog box.

  2. Define the number of harmonics to be determined using the "No. of Harmonics" softkey.

  3. Perform a sweep.

    The trace for the determined harmonics are displayed in the diagram, separated by red display lines. The measured power for each harmonic in relation to the fundamental is indicated in the result table.

  4. If the signal changes significantly during or after the harmonics measurement, use the "Adjust Settings" function to adjust the settings automatically and restart the measurement.


Third Order Intercept (TOI) Measurement

Measurements > Third Order Intercept (TOI) Measurement
Third Order Intercept (TOI) Measurement

The third order intercept point of the R&S FSW can be determined if a two-tone signal with equal carrier levels is applied to the input.

Contents
  • About the TOI Measurement
  • TOI Basics
  • TOI Results
  • TOI Configuration
  • How to Determine the Third Order Intercept
  • Measurement Example – Measuring the R&S FSW's Intrinsic Intermodulation


About the TOI Measurement

Measurements > Third Order Intercept (TOI) Measurement > About the TOI Measurement
About the TOI Measurement

If several signals are applied to a transmission two-port device with nonlinear characteristic, intermodulation products appear at its output at the sums and differences of the signals. The nonlinear characteristic produces harmonics of the useful signals which intermodulate at the characteristic. The intermodulation products of lower order have a special effect since their level is largest and they are near the useful signals. The intermodulation product of third order causes the highest interference. It is the intermodulation product generated from one of the useful signals and the 2nd harmonic of the second useful signal in case of two-tone modulation.

In order to measure the third order intercept point (TOI), a two-tone signal with equal carrier levels is expected at the R&S FSW input. Marker 1 and marker 2 (both normal markers) are set to the maximum of the two signals. Marker 3 and marker 4 are placed on the intermodulation products.

The R&S FSW calculates the third order intercept point from the level difference between the first 2 markers and the markers 3 and 4 and displays it in the marker field.


TOI Basics

Measurements > Third Order Intercept (TOI) Measurement > TOI Basics
TOI Basics

If several signals are applied to a transmission two-port device with nonlinear characteristic, intermodulation products appear at its output at the sums and differences of the signals. The nonlinear characteristic produces harmonics of the useful signals which intermodulate at the characteristic.

The frequencies of the intermodulation products are above and below the useful signals. The figure "Intermodulation products Ps1 and Ps2" shows intermodulation products PS1 and PS2 generated by the two useful signals PU1 and PU2.

Intermodulation products Ps1 and Ps2

The intermodulation product at fi2 is generated by mixing the 2nd harmonic of useful signal PU2 and signal PU1.

Tthe intermodulation product at fi1 is generated by mixing the 2nd harmonic of useful signal PU1 and signal PU2.

fi1 = 2 × fu1 – fu2 (1)

fi2 = 2 × fu2 – fu1 (2)

Dependency on level of useful signals

The level of the intermodulation products depends on the level of the useful signals. If the two useful signals are increased by 1 dB, the level of the intermodulation products increases by 3 dB, which means that the spacing aD3 between intermodulation signals and useful signals is reduced by 2 dB. This is illustrated in figure "Dependency of intermodulation products on level of useful signals".

Dependency of intermodulation products on level of useful signals

The useful signals at the two-port output increase proportionally with the input level as long as the two-port is in the linear range. A level change of 1 dB at the input causes a level change of 1 dB at the output. Beyond a certain input level, the two-port goes into compression and the output level stops increasing. The intermodulation products of the third order increase three times as quickly as the useful signals. The intercept point is the fictitious level where the two lines intersect. It cannot be measured directly since the useful level is previously limited by the maximum two-port output power.

Calculation method

However, the intercept point can be calculated from the known line slopes and the measured spacing aD3 at a given level according to the following formula:

The third order intercept point (TOI), for example, is calculated for an intermodulation of 60 dB and an input level PU of -20 dBm according to the following formula:

Intermodulation-free dynamic range

The "Intermodulation-free dynamic range", i.e. the level range in which no internal intermodulation products are generated if two-tone signals are measured, is determined by the third order intercept point, the phase noise and the thermal noise of the signal analyzer. At high signal levels, the range is determined by intermodulation products. At low signal levels, intermodulation products disappear below the noise floor, i.e. the noise floor and the phase noise of the signal analyzer determine the range. The noise floor and the phase noise depend on the resolution bandwidth that has been selected. At the smallest resolution bandwidth, the noise floor and phase noise are at a minimum and so the maximum range is obtained. However, a large increase in sweep time is required for small resolution bandwidths. It is therefore best to select the largest resolution bandwidth possible to obtain the range that is required. Since phase noise decreases as the carrier-offset increases, its influence decreases with increasing frequency offset from the useful signals.

The following diagrams illustrate the intermodulation-free dynamic range as a function of the selected bandwidth and of the level at the input mixer (= signal level – set RF attenuation) at different useful signal offsets.

Intermodulation-free range as a function of level at the input mixer and the set resolution bandwidth

(Useful signal offset = 1 MHz, DANL = -145 dBm/Hz, TOI = 15 dBm; typical values at 2 GHz)

The optimum mixer level, i.e. the level at which the intermodulation distance is at its maximum, depends on the bandwidth. At a resolution bandwidth of 10 Hz, it is approx. -35 dBm and at 1 kHz increases to approx. -30 dBm.

Phase noise has a considerable influence on the intermodulation-free range at carrier offsets between 10 and 100 kHz ( see figure "Intermodulation-free dynamic range as a function of level at the input mixer and of the selected resolution bandwidth"). At greater bandwidths, the influence of the phase noise is greater than it would be with small bandwidths. The optimum mixer level at the bandwidths under consideration becomes almost independent of bandwidth and is approx. -40 dBm.

Intermodulation-free dynamic range as a function of level at the input mixer and of the selected resolution bandwidth

(Useful signal offset = 10 to 100 kHz, DANL = -145 dBm/Hz, TOI = 15 dBm; typical values at 2 GHz).

If the intermodulation products of a DUT with a very high dynamic range are to be measured and the resolution bandwidth to be used is therefore very small, it is best to measure the levels of the useful signals and those of the intermodulation products separately using a small span. The measurement time will be reduced, in particular if the offset of the useful signals is large. To find signals reliably when frequency span is small, it is best to synchronize the signal sources and the R&S FSW.


TOI Results

Measurements > Third Order Intercept (TOI) Measurement > TOI Results
TOI Results

As a result of the TOI measurement, the following values are displayed in the marker area of the diagram:

Label | Description
TOI | Third-order intercept point
M1 | Maximum of first useful signal
M2 | Maximum of second useful signal
M3 | First intermodulation product
M4 | Second intermodulation product
Remote command

The TOI can also be queried using the remote command CALCulate<n>:​MARKer<m>:​FUNCtion:​TOI:​RESult?.


TOI Configuration

Measurements > Third Order Intercept (TOI) Measurement > TOI Configuration
TOI Configuration

Third Order Intercept (TOI) measurements are selected via the "Third Order Intercept" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "Third Order Intercept" dialog box, which is displayed as a tab in the "Analysis" dialog box, or when you select the "TOI Config" softkey from the "TOI" menu.

The remote commands required to perform these tasks are described in "Measuring the Third Order Intercept Point".

└ Marker 1/2/3/4
└ Search Signals


Marker 1/2/3/4

Measurements > Third Order Intercept (TOI) Measurement > TOI Configuration > Marker 1/2/3/4
Marker 1/2/3/4

Indicates the detected characteristic values as determined by the TOI measurement (see "TOI Results").

The marker positions can be edited; the TOI is then recalculated according to the new marker values.

To reset all marker positions automatically, use the "Search Signals" function.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?


Search Signals

Measurements > Third Order Intercept (TOI) Measurement > TOI Configuration > Search Signals
Search Signals

Performs a new search on the input signals and recalculates the TOI according to the measured values.

Remote command:

CALCulate:​MARKer:​FUNCtion:​TOI:​SEARchsignal ONCE


How to Determine the Third Order Intercept

Measurements > Third Order Intercept (TOI) Measurement > How to Determine the Third Order Intercept
How to Determine the Third Order Intercept

The precise TOI for the R&S FSW in relation to the input signals is provided in the data sheet.

  1. Apply a two-tone signal with equal carrier levels to the R&S FSW input.

  2. On the R&S FSW, press the MEAS key.

  3. Select the "Third Order Intercept" measurement function from the "Select Measurement" dialog box.

    The calculated TOI is indicated in the marker information. The markers required for calculation are displayed in the marker table.

  4. If the signal changes significantly during or after the TOI measurement, use the "Search Signals" function to start a new signal search automatically and restart the calculation of the TOI.


Measurement Example – Measuring the R&S FSW's Intrinsic Intermodulation

Measurements > Third Order Intercept (TOI) Measurement > Measurement Example – Measuring the R&S FSW's Intrinsic Intermodulation
Measurement Example – Measuring the R&S FSW's Intrinsic Intermodulation
Test setup:
Signal generator settings (e.g. R&S FSW SMU):
Device | Level | Frequency
Signal generator 1 | -4 dBm | 799.6 MHz
Signal generator 2 | -4 dBm | 800.4 MHz
Setting up the measurement

  1. Preset the R&S FSW.

  2. Set the center frequency to 800 MHz and the frequency span to 3 MHz.

  3. Set the reference level to -10 dBm and RF attenuation to 0 dB.

  4. Set the resolution bandwidth to 10 kHz.

    The noise is reduced, the trace is smoothed further and the intermodulation products can be seen clearly.

  5. Set the VBW to "1 kHz".

Measuring intermodulation using the Third Order Intercept (TOI) measurement function

  1. Press the MEAS key and select the "Third Order Intercept" measurement function from the "Select Measurement" dialog box.

    The R&S FSW activates four markers to measure the intermodulation distance. Two markers are positioned on the useful signals and two on the intermodulation products. The TOI is calculated from the level difference between the useful signals and the intermodulation products. It is then displayed on the screen:

    The third order intercept (TOI) is displayed in the marker information.

  2. The level of a signal analyzer's intrinsic intermodulation products depends on the RF level of the useful signals at the input mixer. When the RF attenuation is added, the mixer level is reduced and the intermodulation distance is increased. With an additional RF attenuation of 10 dB, the levels of the intermodulation products are reduced by 20 dB. The noise level is, however, increased by 10 dB.

    Increase the RF attenuation to 20 dB to reduce intermodulation products.

    The R&S FSW's intrinsic intermodulation products disappear below the noise floor.


AM Modulation Depth Measurement

Measurements > AM Modulation Depth Measurement
AM Modulation Depth Measurement

Using the R&S FSW you can measure the AM modulation depth of a modulated signal.

Contents
  • About the Measurement
  • AM Modulation Depth Results
  • AM Modulation Depth Configuration
  • Optimizing and Troubleshooting the Measurement
  • How to Determine the AM Modulation Depth


About the Measurement

Measurements > AM Modulation Depth Measurement > About the Measurement
About the Measurement

The AM modulation depth, also known as a modulation index, indicates how much the modulated signal varies around the carrier amplitude. It is defined as:

MDepth = peak signal amplitude / unmodulated carrier amplitude

So for MDepth = 0.5, for example, the carrier amplitude varies by 50% above and below its unmodulated level, and for MDepth = 1.0 it varies by 100%.

When this measurement is activated, marker 1 is set to the peak level, which is considered to be the carrier level. Delta markers 2 and 3 are automatically set symmetrically to the carrier on the adjacent peak values of the trace. The markers can be adjusted manually, if necessary.

The R&S FSW calculates the power at the marker positions from the measured levels. The AM modulation depth is calculated as the ratio between the power values at the reference marker and at the delta markers. If the powers of the two AM side bands are unequal, the mean value of the two power values is used for AM modulation depth calculation.


AM Modulation Depth Results

Measurements > AM Modulation Depth Measurement > AM Modulation Depth Results
AM Modulation Depth Results

As a result of the AM Modulation Depth measurement, the following values are displayed in the marker area of the diagram:

Label | Description
MDepth | AM modulation depth in percent
M1 | Maximum of the signal (= carrier level)
D2 | Offset of next peak to the right of the carrier
D3 | Offset of the next peak to the left of the carrier
Remote command:

The AM modulation depth can also be queried using the remote command CALCulate<n>:​MARKer<m>:​FUNCtion:​MDEPth:​RESult?.


AM Modulation Depth Configuration

Measurements > AM Modulation Depth Measurement > AM Modulation Depth Configuration
AM Modulation Depth Configuration

AM Modulation Depth measurements are selected via the "AM Modulation Depth" button in the "Select Measurement" dialog box. The measurement is started immediately with the default settings. It can be configured via the MEAS CONFIG key or in the "AM Modulation Depth" dialog box, which is displayed as a tab in the "Analysis" dialog box or when you select the "AM Mod Depth Config" softkey from the "AM Mod Depth" menu.

The remote commands required to perform these tasks are described in "Measuring the AM Modulation Depth".

└ Marker 1/2/3
└ Search Signals


Marker 1/2/3

Measurements > AM Modulation Depth Measurement > AM Modulation Depth Configuration > Marker 1/2/3
Marker 1/2/3

Indicates the detected characteristic values as determined by the AM Modulation Depth measurement:

Marker | Description
M1 | Maximum of the signal (= carrier level)
D2 | Offset of next peak to the right of the carrier
D3 | Offset of the next peak to the left of the carrier

The marker positions can be edited; the modulation depth is then recalculated according to the new marker values.

To reset all marker positions automatically, use the "Search Signals" function.

Note: Moving the marker positions manually. When the position of delta marker 2 is changed, delta marker 3 is moved symmetrically with respect to the reference marker 1.
Delta marker 3, on the other hand, can be moved for fine adjustment independently of marker 2.
Marker 1 can also be moved manually for re-adjustment without affecting the position of the delta markers.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?


Search Signals

Measurements > AM Modulation Depth Measurement > AM Modulation Depth Configuration > Search Signals
Search Signals

Performs a new search on the input signal and recalculates the AM Modulation Depth according to the measured values.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​MDEPth:​SEARchsignal ONCE


Optimizing and Troubleshooting the Measurement

Measurements > AM Modulation Depth Measurement > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement:

  • Set the center frequency to the frequency of the device under test.
  • Adjust the span so the peaks to the left and right of the carrier, produced by the AM modulated signal, are clearly visible.
    If the span is too wide, these signals may fall together with the carrier and the measurement can not be performed.
    If the span is too narrow, theses signals are outside of the measured span and the delta markers can not find these peaks.
    The rule of thumb is to set the span to three times the value of the AM modulation frequency.


How to Determine the AM Modulation Depth

Measurements > AM Modulation Depth Measurement > How to Determine the AM Modulation Depth
How to Determine the AM Modulation Depth

  1. Apply a modulated carrier signal to the R&S FSW input.

  2. On the R&S FSW, press the MEAS key.

  3. Select the "AM Modulation Depth" measurement function from the "Select Measurement" dialog box.

    The calculated AM Modulation Depth is indicated in the marker information. The markers required for calculation are displayed in the marker table.

  4. If the signal changes significantly during or after the AM Modulation Depth measurement, use the "Search Signals" function to start a new peak search automatically and restart the calculation of the AM Modulation Depth.


Electromagnetic Interference (EMI) Measurement (R&S FSW-K54)

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54)
Electromagnetic Interference (EMI) Measurement (R&S FSW-K54)

The optional electromagnetic interference (EMI) measurement (R&S FSW-K54) is suitable for measurements according to commercial and military electromagnetic compatibility (EMC) standards. The functionality of the measurement is particularly useful in research and development.

The EMI measurement features:

  • EMI marker functionality
  • Marker demodulation
  • Measurement bandwidths and detectors for EMI measurements
  • Logarithmic scaling of the frequency axis
  • Additional predefined limit lines for EMC standards
  • Predefined transducer factors
  • LISN control
Contents
  • About the EMI Measurement
  • EMI Measurement Results
  • EMI Measurement Basics
  • EMI Measurement Configuration
  • EMI Result Analysis
  • How to Perform EMI Measurements
  • Measurement Example: Measuring Radio Frequency Interference
  • Optimizing and Troubleshooting EMI Measurements


About the EMI Measurement

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > About the EMI Measurement
About the EMI Measurement

EMI measurements can be very time-consuming, especially if weighting detectors are required for the measurement. In addition, EMC testing often requires various procedures to locate local EMI maxima. Such procedures are, for example, movements of an absorbing clamp, variations in the height of the test antenna or the rotation of the DUT.

Covering all test setups with one of the (slow) EMI weighting detectors over the required frequency range would lead to very high measurement times.

Splitting the measurement procedure into several stages, however, can eliminate this problem.

The first stage, or peak search, is used to get a rough idea about the location of peak levels that may indicate interference over the required frequency range. You can use a detector that allows for a fast sweep time, e.g. the peak detector.

During the second stage, or final test, the R&S FSW performs the actual EMC test, a refined measurement with detectors designed for and required by EMC standards. To keep measurement times brief, the R&S FSW performs a final measurement only on frequencies you have marked with a marker or delta marker. You can assign a different detector to every marker and thus test a particular frequency easily for compliance.

Optionally, you can activate continuous demodulation of the signal during the initial measurement and at the peak marker positions during the final test.

After the final measurement, you can check the signal levels against specified limits.


EMI Measurement Results

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Results
EMI Measurement Results

As the result of an R&S FSW EMI measurement, the measured signal levels and active markers are displayed in a Spectrum diagram.

Initial peak search results - Marker Table

As a result of the initial peak search, the active markers are set to the positive peaks of the measured signal.

If Auto peak search and limit lines are active, the active markers are set to the peak delta values between the measured signal and the limit lines.

The active marker levels and positions are displayed in the Marker Table.

(Note: the marker results are also displayed in the Result Summary; in addition, the Marker Table contains the marker results for those markers for which no final EMI test is performed.)

Final test results - Result Summary

The results of the final EMI tests at the active marker frequencies are displayed in the Result Summary.

The Result Summary provides the following information:

Label

Description

Type

Marker name

Ref

Reference marker for delta markers

Trace

Assigned trace

X-value

Marker x-value (frequency for final test)

Y-value

Marker y-value (level during inital measurement)

Final Test

Detector used for final EMI test

Line name

Line activated for limit check

Δ Limit

Delta between measured level and limit line (if active)

The value is colored to indicate the following states:

  • green: does not exceed limit
  • yellow: within margin
  • red: exceeds limit

Final Result

Value measured during final EMI test using specified detector at marker frequency


EMI Measurement Basics

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics
EMI Measurement Basics

Some background knowledge on basic terms and principles used in EMI measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Resolution Bandwidth and Filter Types
  • Detectors and Dwell Time
  • Frequency Resolution - Sweep Points and Scaling
  • Controlling V-Networks (LISN)
  • Using Transducer Factors
  • Initial Measurement - Peak Search
  • Final Measurement at the Marker Position
  • Limit Checks


Resolution Bandwidth and Filter Types

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Resolution Bandwidth and Filter Types
Resolution Bandwidth and Filter Types

EMI testing requires resolution filters with a 6 dB bandwidth. The R&S FSW EMI measurement adds the following bandwidths that comply to commercial and military standards to those already available with the base unit:

Commercial (CISPR, FFC etc.)
  • 200 Hz
  • 9 kHz
  • 120 kHz
  • 1 MHz (not with Quasipeak detector, see "Quasipeak detector (CISPR filter only)")
Military (MIL Std)
  • 10 Hz
  • 100 Hz
  • 1 kHz
  • 10 kHz
  • 100 kHz
  • 1 MHz

For the Quasipeak, CISPR Average, or Average RMS detector, the bandwidth is fixed depending on the frequency. For more information see "Detectors and Dwell Time".


Detectors and Dwell Time

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Detectors and Dwell Time
Detectors and Dwell Time

The R&S FSW EMI measurement adds new detectors to those already available with the base unit. The additional detectors are especially designed for and required by EMI applications.

The additional detectors are available only if the EMI (R&S FSW-K54) measurement option is installed and the filter type "CISPR" or "MIL" is selected (see "Resolution Bandwidth and Filter Types"). However, the EMI measurement need not be active.

The detector to be used for the initial peak search is configured in the trace settings (see "Trace Settings"), while the detector for the final test is configured in the EMI marker settings, see "EMI Marker Configuration".

Dwell time

EMC tests often require a specific dwell time for an EMI measurement. The dwell time defines how long the R&S FSW measures the signal at the individual frequencies. Each detector needs a different period of time to fully charge and discharge; the individual requirements on the dwell time are described for each detector. For details on defining the dwell time for an R&S FSW EMI measurement see "Defining a Dwell Time for the Final Measurement".

Positive and negative peak detector

The maximum and minimum peak detectors display the maximum and minimum signal level that was detected during the specified dwell time.

The minimum and maximum peak detectors are already available with the base unit.

Consider the following when defining the dwell time:
  • Unmodulated signals: minimum time required by the detector
  • Pulsed signals: the time must be long enough to capture at least one complete pulse
Average detector

The average detector displays the average signal level of the samples that were collected during the specified dwell time.

The average detector is already available with the base unit.

Consider the following when defining the dwell time:
  • Unmodulated signals: minimum time required by the detector
  • Pulsed signals: the time must be long enough to capture several complete pulses (at least 10)
  • The time is determined by the lowest modulation frequency to be averaged
RMS detector

The RMS detector displays the root mean square (RMS) value over the specified dwell time. The integration time is the specified dwell time.

The RMS detector is already available with the base unit.

The same considerations apply to the dwell time as for the average detector.

Sample detector

The sample detector displays the last value from the samples allocated to a pixel.

The sample detector is used for noise or phase noise marker calculation. However, it is unreliable if the displayed span is much greater then the resolution bandwidth or if the tuning steps of the local oscillator are too large. The sample detector is not recommended for EMI tests.

Quasipeak detector (CISPR filter only)

The quasipeak detector displays the maximum signal level weighted to CISPR 16-1-1 that was detected during the dwell time.

The quasipeak detector is only available for the CISPR filter, and not for an RBW of 1 MHz.

The filter bandwidth and time parameters of the detector depend on the measured frequency. The time lag of the simulated pointer instrument reflects the weighting factor of the signal depending on its form, modulation, etc.

Required parameters depending on frequency for CISPR quasipeak detector
 | Band A | Band B | Band C/D
Frequency range | < 150 kHz | 150 kHz to 30 MHz | > 30 MHz
Resolution bandwidth | 200 Hz | 9 kHz | 120 kHz
Charge time | 45 ms | 1 ms | 1 ms
Discharge time | 500 ms | 160 ms | 550 ms
Time lag of the simulated pointer instrument | 160 ms | 160 ms | 100 ms
Consider the following when defining the dwell time:
  • Unknown signals: select a dwell time of at least 1 second to ensure that pulses down to a frequency of 5 Hz are weighted correctly
  • Known signals: shorter dwell time possible, as the signal level does not change during the final measurement

When you change the frequency or the attenuation, the R&S FSW waits until the lowpass filter has settled before starting the measurement.

CISPR Average detector (CISPR filter only)

The CISPR Average detector displays a weighted average signal level according to CISPR 16-1-1.

The average value according to CISPR 16-1-1 is the maximum value detected while calculating the linear average value during the specified dwell time.

The CISPR Average detector is only available for the CISPR filter.

The CISPR Average detector is applied to measure pulsed sinusoidal signals with a low pulse frequency, for example. It is calibrated with the RMS value of an unmodulated sinusoidal signal. The average value is determined by lowpass filters of the 2nd order (simulating a mechanical pointer instrument).

The filter bandwidth and time lag of the detector depend on the measured frequency. The time lag of the simulated pointer instrument reflects the weighting factor of the signal depending on its form, modulation, etc.

Required parameters depending on frequency for CISPR Average detector
 | Band A | Band B | Band C/D | Band E
Frequency range | <150 kHz | 150 kHz to 30 MHz | 30 MHz to 1 GHz | >1 GHz
IF bandwidth | 200 Hz | 9 kHz | 120 kHz | 1 MHz
Time lag of the simulated pointer instrument | 160 ms | 160 ms | 100 ms | 100 ms
Consider the following when defining the dwell time:
  • Unknown signals: select a dwell time of at least 1 second to ensure that pulses down to a frequency of 5 Hz are weighted correctly
  • Pulsed signals or signals that fluctuate slowly: the dwell time must cover at least the time until the first signal peak is measured; can require long dwell time
  • unmodulated signals or signals with a high modulation frequency: the dwell time must cover at least the time until the first signal peak is measured; usually shorter than for pulsed signals

When you change the frequency or the attenuation, the R&S FSW waits until the lowpass filter has settled before starting the measurement. In this case, the measurement time depends on the resolution bandwidth and the characteristics of the signal.

RMS Average detector (CISPR filter only)

The RMS Average detector is a combination of the RMS detector (for pulse repetition frequencies above a corner frequency) and the Average detector (for pulse repetition frequencies below the corner frequency). It thus achieves a pulse response curve with the following characteristics:

  • 10 dB/decade above the corner frequency
  • 20 dB/decade below the corner frequency

The average value is determined by lowpass filters of the 2nd order (simulation of a mechanical pointer instrument).

The RMS Average detector is only available for the CISPR filter.

The detector is used, for example, to measure broadband emissions and may replace the quasipeak detector in the future.

The detector parameters depend on the measured frequency. The time lag of the simulated pointer instrument reflects the weighting factor of the signal depending on its form, modulation, etc.

Required parameters depending on frequency for RMS Average detector
 | Band A | Band B | Band C/D | Band E
Frequency range | <150 kHz | 150 kHz to 30 MHz | 30 MHz to 1 GHz | >1 GHz
IF bandwidth | 200 Hz | 9 kHz | 120 kHz | 1 MHz
Time lag of simulated pointer instrument | 160 ms | 160 ms | 100 ms | 100 ms
Corner frequency | 10 Hz | 100 Hz | 100 Hz | 1 kHz

The same considerations apply to the dwell time as for the CISPR average detector.


Frequency Resolution - Sweep Points and Scaling

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Frequency Resolution - Sweep Points and Scaling
Frequency Resolution - Sweep Points and Scaling

The number of sweep points defines the number of measurement values collected during one sweep. Thus, increasing the sweep points also increases the accuracy of the results regarding the frequency resolution.

Because EMI measurements often cover a large frequency range you should define an adequate number of sweep points, especially when performing the measurement on a logarithmic axis. As on a linear axis, the distance from one sweep point to the next is calculated graphically on a logarithmic axis, and is not based on the frequency itself. Thus, the frequency resolution between two sweep points deteriorates with higher frequencies.

The resolution bandwidth should cover at least one sweep point (more is better). If this condition is not met, signals or interferences could be missed during refined measurement of narrowband interferers. If the distance between two sweep points is larger than RBW/3, a warning is displayed in the status bar ("Increase sweep points").

Example:

Linear axis:

With a linear axis, the distance between the sweep points is equal, e.g. 200 kHz.

Logarithmic axis:

With a logarithmic axis, the distance between sweep points is variable. In the spectrum from 10 Hz to 100 Hz, the distance is a few Hz. Between 100 MHz and 1 GHz, the distance is several MHz.

The R&S FSW EMI measurement supports a maximum of 200000 sweep points. This number is based on typical bands measured with a single resolution bandwidth. There are sufficient sweep points to make sure that a signal is found during the refined measurement, even when covering 30 MHz to 1 GHz with logarithmic scaling and 120 kHz RBW.


Controlling V-Networks (LISN)

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Controlling V-Networks (LISN)
Controlling V-Networks (LISN)

For measurements on power lines, the R&S FSW EMI measurement adds functionality to control a line impedance stabilization network (LISN) directly. Thus you can determine the interference caused by power supplies and cables.

You can connect the LISN to the user port of the R&S FSW. Control cables for the various LISNs are available as accessories. The R&S FSW then controls which phase of the LISN is to be tested and outputs the information to the user port.

The R&S FSW EMI measurement supports several V-networks. For each type of network, you can define the phase you want to test for interferences. The R&S FSW EMI measurement allows you to test one phase at a time.

Supported networks and phases
Network type | Phases
Two-line V-networks
ESH3-Z5 | N, L1
ENV216 | N, L1
Four-line V-networks
ESH2-Z5 | N, L1. L2, L3
ENV4200 | N, L1. L2, L3

For the ENV216 network, a 150 kHz high pass filter is available to protect the input of the R&S FSW.


Using Transducer Factors

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Using Transducer Factors
Using Transducer Factors

The R&S FSW EMI measurement provides functionality to include transducer factors in the test setup. Transducers are devices like antennas, probes or current probes that are connected to the R&S FSW to measure interferences or useful signals. The transducer converts the measured value such as field strength, current or RFI voltage into a voltage across 50 Ω. During the measurement, the transducer is considered a part of the instrument.

A transducer usually has a frequency-dependent transducer factor that includes the frequency response of the corresponding device. During level measurement, the transducer factor automatically converts the results into the correct unit and magnitude. A transducer factor consists of a maximum of 1001 reference values. Each reference value includes frequency, unit and level.

The R&S FSW EMI measurement adds several predefined transducer factors. In addition you can also create new and edit existing transducer factors.

For more information see "Basics on Transducer Factors".


Initial Measurement - Peak Search

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Initial Measurement - Peak Search
Initial Measurement - Peak Search

The purpose of an initial peak search is to find signals with a high interference level quickly. Usually the peak search is performed with a fast detector like the peak or average detector. The initial peak search is the basis for a possible refined measurement of interferences with the detectors specific to EMI measurements.

The results of the initial peak search are shown in the Marker Table (see "EMI Measurement Results").

Peak searches can be performed automatically or manually.

Automatic peak search

If enabled, the automatic peak search starts as soon as you select the EMI measurement and one or more markers are active. During automatic peak search, the R&S FSW looks for the strongest peaks in the frequency range you are measuring and positions a marker on those peaks after each sweep. If a limit line is assigned to the trace, the peak search is based on the level difference between the trace and the limit line. For each active marker a peak is searched. You can use up to 16 markers simultaneously.

The largest peak is always assigned to the active marker with the lowest number; subsequent peaks are assigned to the active markers in ascending order.

The R&S FSW allows you to distribute markers among several traces. If you do so, the marker with the lowest number assigned to a particular trace is positioned on the largest peak of the corresponding trace.

Manual peak search

If automatic peak search is off, you can set the markers to any frequency you need more information about manually. You can change the marker position with the rotary knob or the cursor keys, or position it to a particular frequency with the number keys.

Setting markers is the same as setting markers in other Spectrum measurements. For more information see "Marker Usage".

Searching for peaks over several traces

You can search for peaks on six traces simultaneously with a different weighting detector for each trace.

In this case, the R&S FSW searches for peaks on all traces separately, provided that you have assigned at least one marker to each trace.

A typical selection for EMI measurement is to use the peak and the average detector. After initial measurement, search for peaks on the peak trace and the average trace separately so that the distribution of narrowband and wideband sources of interference can be taken into account.

Example:
  • In the initial measurement, determine the peak on one trace using the average detector by assigning a marker to that trace. For the marker frequency, perform a refined measurement using the CISPR or RMS average detector.
  • In the initial measurement, determine the peak on another trace using the peak detector by assigning another marker to that trace. For this marker frequency, perform a refined measurement using the quasipeak detector.


Final Measurement at the Marker Position

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Final Measurement at the Marker Position
Final Measurement at the Marker Position

Finding peaks with the help of an initial marker peak search reduces data to be evaluated and thus measurement time. A final measurement with a special EMI detector can then refine the intial results.

The R&S FSW EMI measurement performs the final measurement automatically as soon as a detector for the final test is defined for an EMI marker and the marker is activated. The final measurement starts immediately after the marker has been set. The advantage of an immediate final measurement is that it eliminates the risk of measurement errors based on frequency drifts of the disturbance signal.

The final measurement at the marker frequency may have a different detector than during the initial peak search. Thus, the final measurement consumes much less time because detectors with a long measurement time are needed only at the critical frequency.

The R&S FSW EMI measurement also allows you to use multiple detectors for the final measurement. The advantage of multiple detection is that you only need one test run to see if the results comply with the limits specified in a standard. The detectors for the final EMI tests are defined in the marker configuration (as opposed to the trace detector which is used for the initial peak search).

The results of the final measurement are shown in the Result Summary (see "EMI Measurement Results").

Defining a Dwell Time for the Final Measurement

EMC tests often require a specific dwell time for an EMI measurement. The dwell time defines how long the R&S FSW measures the signal at the frequencies of the marker positions. The dwell time is identical for all EMI final measurements and is thus defined in the EMI measurement configuration. Select a dwell time according to the characteristics of the measured signal. See also "Detectors and Dwell Time".


Limit Checks

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Basics > Limit Checks
Limit Checks

General limit line functionality is provided by the R&S FSW base unit. The base unit also provides various predefined limit lines that you can use for various applications. The R&S FSW EMI measurement adds further predefined limit lines designed in compliance with several EMC standards.

When using limit lines in combination with EMI measurements, the marker levels from the initial measurement are compared to the limit line values. The result of the limit line check is displayed in the diagram as usual.

In the EMI Result Summary, the limit check is based on the results of the final test. Since the marker may be determined using a different detector than the final test results, the two limit check results may differ. The difference between the limit line and the measured value is colored to indicate the following states:

  • green: does not exceed limit
  • yellow: within margin
  • red: exceeds limit

For more information on using limit lines see "Basics on Limit Lines".


EMI Measurement Configuration

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration
EMI Measurement Configuration

On the R&S FSW, EMI measurement configuration consists of the following settings, most of which are accessible from the main EMI menu. This menu is displayed when you select the EMI measurement and then press the MEAS CONFIG key.

  • "Res BW CISPR"
  • "Res BW MIL"
  • "Bandwidth, Filter and Sweep Settings"
  • "Select Marker"
  • "Marker Settings"
  • "Marker Demodulation"

In addition, some common settings are also relevant for EMI measurements:

  • "Transducer Settings"
  • "Limit Line Settings and Functions"
Contents
  • EMI Marker Configuration
  • EMI Final Measurement Configuration
  • LISN Control Settings


EMI Marker Configuration

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration
EMI Marker Configuration

The inital peak search for the R&S FSW EMI measurement is defined by the marker configuration.

To configure EMI markers select the EMI measurement, then press the MEAS CONFIG or MKR key and select "Marker Config".

└ Selected Marker
└ Marker State
└ Marker Position (X-value)
└ Marker Type
└ Reference Marker
└ Linking to Another Marker
└ Assigning the Marker to a Trace
└ Final Test Detector
└ Select Marker


Selected Marker

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Position (X-value)

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Marker Position (X-value)
Marker Position (X-value)

Defines the position (x-value) of the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X


Marker Type

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

If a fixed reference point is configured (see "Defining a Fixed Reference"), the reference point ("FXD") can also be selected instead of another marker.

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Linking to Another Marker

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Linking to Another Marker
Linking to Another Marker

Links the current marker to the marker selected from the list of active markers. If the x-axis value of the inital marker is changed, the linked marker follows on the same x-position. Linking is off by default.

Using this function you can set two markers on different traces to measure the difference (e.g. between a max hold trace and a min hold trace or between a measurement and a reference trace).

Remote command:

CALCulate<n>:​MARKer<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m>:​LINK


Assigning the Marker to a Trace

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

The marker can also be assigned to the currently active trace using the "Marker to Trace" softkey in the "Marker" menu.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


Final Test Detector

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Final Test Detector
Final Test Detector

Defines the detector to be used for the final EMI test at the marker frequency. This setting is only available if the EMI (R&S FSW-K54) measurement option is installed.

For details see "Detectors and Dwell Time".

Note: The trace detector configured in the trace settings is used for the initial peak search only, see "Trace Settings".

"Off"

No final test is performed.

"Positive peak"

Determines the maximum signal level that was detected during the specified dwell time.

"Average"

Determines the average signal level of the samples that were collected during the specified dwell time.

"Quasipeak"

Determines the maximum signal level weighted to CISPR 16-1-1 that was detected during the dwell time.

The quasipeak detector is only available for the CISPR filter, and not for an RBW of 1 MHz.

"CISPR Average"

Determines a weighted average signal level according to CISPR 16-1-1.

The average value according to CISPR 16-1-1 is the maximum value detected while calculating the linear average value during the specified dwell time.

The CISPR Average detector is only available for the CISPR filter.

"RMS Average"

A combination of the RMS detector (for pulse repetition frequencies above a corner frequency) and the Average detector (for pulse repetition frequencies below the corner frequency).

The average value is determined by lowpass filters of the 2nd order (simulation of a mechanical pointer instrument).

The RMS Average detector is only available for the CISPR filter.

Remote command:

CALCulate:​MARKer<m>:​FUNCtion:​FMEasurement:​DETector

CALCulate:​DELTamarker<m>:​FUNCtion:​FMEasurement:​DETector


Select Marker

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Marker Configuration > Select Marker
Select Marker

Opens a dialog box to select and activate or deactivate one or more markers quickly.

Remote command:

Marker selected via suffix <m> in remote commands.


EMI Final Measurement Configuration

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration
EMI Final Measurement Configuration

The final EMI measurement can be performed with different settings than the initial peak search. These settings are described here.

The detector to be used for the final EMI test can be defined differently for each frequency, thus the detector is configured in the EMI marker settings, see "Final Test Detector".

└ Filter Type
└ RBW
└ Automatic Peak Search
└ Dwell Time
└ Frequency Axis Scaling
└ Res BW CISPR
└ Res BW MIL


Filter Type

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration > Filter Type
Filter Type

Defines the filter type.

The following filter types are available:

  • Normal (3dB)
  • Channel
  • RRC
  • 5-Pole (not available for sweep type "FFT")
  • CISPR (6 dB) - requires EMI (R&S FSW-K54) option
  • MIL Std (6 dB) - requires EMI (R&S FSW-K54) option

For more information see "Which Data May Pass: Filter Types".

Note: The EMI-specific filter types are available if the EMI (R&S FSW-K54) measurement option is installed, even if EMI measurement is not active. For details see "Resolution Bandwidth and Filter Types".
The RBW filter configured in the bandwidth settings is identical to the filter configured in the EMI configuration.

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​TYPE


RBW

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration > RBW
RBW

Defines the resolution bandwidth. The available resolution bandwidths are specified in the data sheet. Numeric input is always rounded to the nearest possible bandwidth.

If "AUTO" is selected, the resolution bandwidth is coupled to the selected span (for span > 0). If the span is changed, the resolution bandwidth is automatically adjusted.

If the resolution bandwidth is defined manually, a green bullet is displayed next to the "RBW" display in the channel bar.

For more information see "Separating Signals by Selecting an Appropriate Resolution Bandwidth".

For measurements on I/Q data in the frequency domain, the maximum RBW is 1 MHz.

For EMI measurements using the quasipeak detector, the 1 MHz RBW filter is not available (see "Resolution Bandwidth and Filter Types").

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​AUTO


Automatic Peak Search

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration > Automatic Peak Search
Automatic Peak Search

If activated, a peak search is performed automatically for all active markers after each sweep.

If Auto peak search and limit lines are active, the active markers are set to the peak delta values between the measured signal and the limit lines.

Note: The general search functions "Auto Max / Min Peak Search" are not available for EMI measurements.

Remote command:

CALCulate:​MARKer:​FUNCtion:​FMEasurement:​PSEarch|PEAKsearch:​AUTO


Dwell Time

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration > Dwell Time
Dwell Time

Sets the dwell time for the EMI marker measurement.

For more information see "Detectors and Dwell Time".

Remote command:

CALCulate:​MARKer:​FUNCtion:​FMEasurement:​DWELl


Frequency Axis Scaling

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration > Frequency Axis Scaling
Frequency Axis Scaling

Switches between linear and logarithmic scaling for the frequency axis.

By default, the frequency axis has linear scaling. Logarithmic scaling of the frequency axis, however, is common for EMI measurements over large frequency ranges as it enhances the resolution of the lower frequencies. On the other hand, high frequencies get more crowded and become harder to distinguish.

For more information see "Coping with Large Frequency Ranges - Logarithmic Scaling".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​X:​SPACing


Res BW CISPR

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration > Res BW CISPR
Res BW CISPR

Defines the measurement bandwidth for commercial EMC standards according to CISPR.

For more information see "Resolution Bandwidth and Filter Types".

Remote command:

Filter type:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​TYPE

Filter bandwidth:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]


Res BW MIL

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > EMI Final Measurement Configuration > Res BW MIL
Res BW MIL

Defines the measurement bandwidth for military EMC standards.

For more information see "Resolution Bandwidth and Filter Types".

Remote command:

Filter type:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​TYPE

Filter bandwidth:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]


LISN Control Settings

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > LISN Control Settings
LISN Control Settings

For measurements with power lines, the following settings are available for the R&S FSW to control which phase of the LISN is to be tested (e.g. for EMI measurements). LISN control requires the EMI measurement (R&S FSW-K54) option.

The LISN control settings are available when you do one of the following:

  • If the EMI measurement is selected, press the MEAS CONFIG key, then select "LISN Config".
  • Press the INPUT/OUTPUT key, then select "LISN Config".
  • In the "Overview", select "Output", then select "LISN Config".

For more information see "Controlling V-Networks (LISN)".

└ LISN Type
└ Phase
└ 150 kHz Highpass Filter


LISN Type

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > LISN Control Settings > LISN Type
LISN Type

Selects the network type and activates output to the network via the user port of the R&S FSW. The network type determines the supported phases (see table "Supported networks and phases").

"Off" disables LISN control and output.

For more information see "Controlling V-Networks (LISN)".

Remote command:

INPut:​LISN:​TYPE


Phase

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > LISN Control Settings > Phase
Phase

Selects the phase to be measured. Phase N and L1 are included in all four LISN. Phase L2 and L3 are only included in four-line networks.

You can select one phase only for each measurement.

For more information see "Controlling V-Networks (LISN)".

Remote command:

INPut:​LISN:​PHASe


150 kHz Highpass Filter

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Measurement Configuration > LISN Control Settings > 150 kHz Highpass Filter
150 kHz Highpass Filter

Enables or disables the use of an additional 150 kHz highpass filter to protect the R&S FSW LISN from excessive input.

The filter is available for the ENV 216 network only.

For more information see "Controlling V-Networks (LISN)".

Remote command:

INPut:​LISN:​FILTer:​HPASs[:​STATe]


EMI Result Analysis

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > EMI Result Analysis
EMI Result Analysis

The R&S FSW EMI measurement provides functionality to analyze the results.

Marker Demodulation

The R&S FSW is able to demodulate AM and FM signals for acoustic tests and monitoring purposes. When the demodulator function is active, the R&S FSW EMI measurement demodulates the signal continuously (regardless of the "Continuous Demodulation" setting in the marker function configuration). The demodulation begins as soon as a marker is activated. During the initial measurement, demodulation is performed for the entire measurement span; during the final measurement only the detected peak marker positions are demodulated (for the defined dwell time). You can listen to the results during the measurement with headphones or with the internal speaker.

For more information see "Marker Demodulation".

Limit Lines

General limit line functionality is provided by the R&S FSW base unit. The base unit also provides various predefined limit lines that you can use for various applications. The R&S FSW EMI measurement adds further predefined limit lines designed in compliance with several EMC standards.

Limit line configuration is described in "Limit Line Settings and Functions".


How to Perform EMI Measurements

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > How to Perform EMI Measurements
How to Perform EMI Measurements

The following step-by-step instructions demonstrate how to perform an EMI measurement with the R&S FSW EMI measurement option.

  1. Press the MODE key on the front panel and select the "Spectrum" application.

  2. Define the frequency range of the EMI measurement.

    1. Press the FREQ key and then the "Frequency Config" softkey.

    2. Define the start and stop frequency.

  3. Configure the traces for the intial EMI measurement.

    1. Press the TRACE key.

    2. Select the "Trace Config" softkey to configure as many traces as required.

    3. Define the detectors to use for the initial measurement, for example the peak detector and the average detector.

  4. Press the MEAS key on the front panel and select the "EMI" measurement.

    The EMI main menu is displayed.

  5. Select the "EMI Config" softkey and define the resolution bandwidth and filter type to be used for the measurement.

    By default, the R&S FSW uses a filter with a 3 db bandwidth. EMI measurements usually require a filter with a 6 dB bandwidth.

  6. Define the dwell time for which each marker position is measured during the final measurement.

  7. To obtain an overview of peak values in the input signal during the initial measurement, activate the "Auto Peak Search".

    As soon as a sweep is started, the R&S FSW looks for the strongest peaks in the frequency range you are measuring and positions one of the active markers on those peaks. The number of active markers determines the number of detected peaks; no additional markers are activated.

  8. Define the type of scaling for the frequency axis according to the definition of the limit lines in the standard.

  9. Optionally, select the "LISN Config" softkey to configure a LISN control.

  10. Configure the EMI measurement markers.

    1. Select the "Marker Config" softkey and activate the number of markers or delta markers you want to analyze.

    2. For each active marker, select a detector to be used for the "Final Test", i.e. the subsequent EMI measurement at the marker position.

    3. If you already know which frequencies cause irregular values, set the markers to those positions. (Otherwise perform an initial peak search to obtain an overview, see step 7).

  11. Optionally, select the "Marker Demod Config" softkey to configure continuous marker demodulation.

    Demodulation begins immediately with the next measurement. During the initial measurement, demodulation is performed for the entire measurement span; during the final measurement only the detected peak marker positions are demodulated (for the defined dwell time).

  12. Increase the number of sweep points for the EMI measurement.

    1. Press the SWEEP key on the front panel.

    2. Select the "Sweep Config" softkey.

    3. Set the number of "Sweep Points" (up to 200001) so that the distance between two sweep points is smaller than RBW/3.

  13. Optionally, select or configure limit lines against which the marker results are checked.

    1. Press the LINES key and then the "Lines Config" softkey, then select the "Lines Config" tab.

    2. In the "Line Config" dialog box, select the "View filter" option: "Show compatible".

      All stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder of the instrument that are compatible to the current EMI measurement settings are displayed in the overview.

    3. Select the "Check Traces" setting for a limit line in the overview and select the trace numbers to be included in the limit check. One limit line can be assigned to several traces.

  14. Define a suitable unit for the measured values, as the default unit dBm is not suitable for EMI measurements, or select a transducer.

    To change the unit:

    Press the AMPT key, then select the "Amplitude Config" softkey and, in the "Amplitude" dialog box, select the required unit.

    To select a transducer:

    1. Press the SETUP key.

    2. Select the "Transducer" softkey.

    3. In the "Transducer" dialog box, set the "View Filter" to "Show compatible" to determine the available transducers for the current EMI measurement setup.

    4. Select a transducer line in the overview and select the "Active" setting for it.

  15. Press the RUN SINGLE key to start a new EMI measurement.

    If activated, a peak search is performed. For each active marker, a final measurement is performed using the specified detector for the specified dwell time. If activated, the signal is demodulated at the active marker positions.

    The specified traces to be checked are compared with the active limit lines. The status of the limit check for the final measurement is indicated in the Result Summary.


Measurement Example: Measuring Radio Frequency Interference

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > Measurement Example: Measuring Radio Frequency Interference
Measurement Example: Measuring Radio Frequency Interference

A common measurement task that you can do with the R&S FSW EMI measurement is to detect radio frequency interference (RFI) or electromagnetic interferences (EMI).

The measurement shows signal levels over a particular frequency range. A typical frequency range for EMI measurements is 150 kHz to 1 GHz. As the captured signal characteristics will most likely be unknown, the best way to start the measurement is to preset the R&S FSW and perform a peak search to obtain a general overview.

If you perform measurements according to a particular EMI standard, a preset also eliminates the risk of wrong settings inherited from previous measurements. Note that EMI measurements are possible in the Spectrum application only.

Preparing the measurement

  1. Press the PRESET key.

    The R&S FSW restores the default settings.

  2. Define the frequency range of the measurement.

    1. Press the FREQ key.

    2. Press the "Start Frequency" softkey and enter a frequency of 150 kHz.

    3. Press the "Stop Frequency" softkey and enter a frequency of 1 GHz.

    The R&S FSW scales the horizontal axis accordingly.

  3. Press the MEAS key on the front panel and select the "EMI" measurement.

    The EMI main menu is displayed.

  4. Select the "EMI Config" softkey and define the resolution bandwidth and filter type to be used for the measurement.

    By default, the R&S FSW uses a filter with a 3 db bandwidth. EMI measurements usually require a filter with a 6R&S FSWdB bandwidth.

  5. Define the dwell time for which each marker position is measured during the final measurement.

  6. To obtain an overview of exceptional values in the input signal during the initial measurement, activate the "Auto Peak Search".

  7. Select the measurement bandwidth.

    1. Select the "Res BW CISPR" softkey.

      A CISPR (6 dB) filter is configured.

    2. Set the bandwidth to 1 MHz.

    The R&S FSW shows the currently selected resolution bandwidth in the diagram header.

  8. Configure the traces for the initial EMI measurement.

    1. Press the TRACE key.

    2. Press the "Trace Config" softkey to configure two traces.

    3. Define the detectors to use for the initial measurement. Select the peak detector for trace 1 and the average detector for trace 2.

      The peak detector ensures that the detected peak levels in the frequency range covered by one pixel are displayed.

    The R&S FSW now displays two traces. Trace 1 shows the peak values, trace 2 shows the average values.

  9. Increase the number of sweep points for the EMI measurement.

    1. Press the SWEEP key on the front panel.

    2. Select the "Sweep Config" softkey.

    3. Set the number of "Sweep Points" to 200000.

  10. Press the AMPT key, then select the "Amplitude Config" softkey and, in the "Amplitude" dialog box, select V as the "Unit".

Performing the measurement

  1. Configure the EMI measurement markers. In this example we will use 6 markers.

    1. Select the "Marker Config" softkey and activate six normal markers.

    2. Set markers 1 to 3 on trace 1. Set markers 4 to 6 on trace 2.

    3. For each of these markers, select the "CISPR AV" detector to be used for the "Final Test", i.e. the subsequent EMI measurement at the marker positions.

  2. Select a limit line against which the marker results are checked.

    1. Press the LINES key and then the "Lines Config" softkey, then select the "Lines Config" tab.

    2. In the "Line Config" dialog box, select the "View filter" option: "Show compatible".

      All stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder of the instrument that are compatible to the current EMI measurement settings are displayed in the overview.

    3. In the overview, click the "Check Traces" setting for the EN55011A limit line and select trace 1 to be included in the limit check. (Trace 2, which is defined as the average, will always be lower than trace 1, which contains peak values.)

  3. Press the RUN SINGLE key to start a new EMI measurement.

    If activated, a peak search is performed. For each active marker, a final measurement is performed using the specified detector for the specified dwell time.

    If activated, the signal is demodulated. During the initial measurement, demodulation is performed for the entire measurement span; during the final measurement only the detected peak marker positions are demodulated (for the defined dwell time).

    The specified traces to be checked are compared with the active limit line. The status of the limit check for the final measurement is indicated in the Result Summary.

Evaluating the measurement

Check the Result Summary to detect exceeded limit values.

Zoom into the diagram at the conspicuous frequency for more details.

If necessary, decrease the span to the area in which irregular values occurred and repeat the measurement.


Optimizing and Troubleshooting EMI Measurements

Measurements > Electromagnetic Interference (EMI) Measurement (R&S FSW-K54) > Optimizing and Troubleshooting EMI Measurements
Optimizing and Troubleshooting EMI Measurements

If the results do not meet your expectations, try the following methods to optimize the measurement:

Number of sweep points

The resolution bandwidth should cover at least one sweep point (more is better). If this condition is not met, signals or interferences could be missed during refined measurement of narrowband interferers. See "Frequency Resolution - Sweep Points and Scaling".

If the distance between two sweep points is larger than RBW/3, a warning is displayed in the status bar ("Increase sweep points or RBW").

Dwell time
Consider the following when defining the dwell time:
  • Unknown signals: select a dwell time of at least 1 second to ensure that pulses down to a frequency of 5 Hz are weighted correctly
  • Pulsed signals or signals that fluctuate slowly: the dwell time must cover at least the time until the first signal peak is measured; can require long dwell time
  • unmodulated signals or signals with a high modulation frequency: the dwell time must cover at least the time until the first signal peak is measured; usually shorter than for pulsed signals


Common Measurement Settings

Basic measurement settings that are common to many measurement tasks, regardless of the application or operating mode, are described here. If you are performing a specific measurement task, using an operating mode other than Signal and Spectrum Analyzer mode, or an application other than the Spectrum application, be sure to check the specific application or mode description for settings that may deviate from these common settings.

Contents
  • Configuration Overview
  • Data Input and Output
  • Frequency and Span Configuration
  • Amplitude and Vertical Axis Configuration
  • Bandwidth, Filter and Sweep Configuration
  • Trigger and Gate Configuration
  • Adjusting Settings Automatically


Configuration Overview

Common Measurement Settings > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the configuration "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. "Select Measurement"

    See "Available Measurement Functions"

  2. Input

    See "Input Source Settings"

  3. Amplitude

    See "Amplitude and Vertical Axis Configuration"

  4. Frequency

    See "Frequency and Span Configuration"

  5. (Optionally:) Trigger/Gate

    See "Trigger and Gate Configuration"

  6. Bandwidth

    See "Bandwidth, Filter and Sweep Settings"

    (For SEM measurements: SEM Setup, see "SEM Configuration")

    (For Spurious measurements: Spurious Setup, see "Spurious Emissions Measurement Configuration")

  7. (Optionally:) Outputs

    See "Output Settings"

  8. Analysis

    See "Common Analysis and Display Functions"

  9. Display

    See "Result Display Configuration"

To configure settings
►

Select any button to open the corresponding dialog box.

└ Preset Channel


Preset Channel

Common Measurement Settings > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Restoring the Default Instrument Configuration (Preset)".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Data Input and Output

Common Measurement Settings > Data Input and Output
Data Input and Output

The R&S FSW can analyze signals from different input sources and provide various types of output (such as video or trigger signals).

The "DigiConf" softkey is described in "Digital I/Q Input Settings" .

Contents
  • Receiving Data Input and Providing Data Output
  • Input Source Settings
  • Power Sensors
  • External Generator Control (Option R&S FSW-B10)
  • External Mixer (Option R&S FSW-B21)
  • Output Settings


Receiving Data Input and Providing Data Output

Common Measurement Settings > Data Input and Output > Receiving Data Input and Providing Data Output
Receiving Data Input and Providing Data Output

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Contents
  • RF Input Protection
  • RF Input from the Analog Baseband Connector
  • Using Probes
  • Input from Noise Sources
  • Receiving and Providing Trigger Signals
  • IF and Video Signal Output


RF Input Protection

Common Measurement Settings > Data Input and Output > Receiving Data Input and Providing Data Output > RF Input Protection
RF Input Protection

The RF input connector of the R&S FSW must be protected against signal levels that exceed the ranges specified in the data sheet. Therefore, the R&S FSW is equipped with an overload protection mechanism. This mechanism becomes active as soon as the power at the input mixer exceeds the specified limit. It ensures that the connection between RF input and input mixer is cut off.

When the overload protection is activated, an error message is displayed in the status bar ("INPUT OVLD"), and a message box informs you that the RF Input was disconnected. Furthermore, a status bit (bit 3) in the STAT:QUES:POW status register is set. In this case you must decrease the level at the RF input connector and then close the message box. Then measurement is possible again. Reactivating the RF input is also possible via the remote command INPut:​ATTenuation:​PROTection:​RESet.


RF Input from the Analog Baseband Connector

Common Measurement Settings > Data Input and Output > Receiving Data Input and Providing Data Output > RF Input from the Analog Baseband Connector
RF Input from the Analog Baseband Connector

RF input can not only be taken from the RF INPUT connector on the front panel of the R&S FSW. If the optional Analog Baseband Interface (R&S FSW-B71) is installed and active for input, an RF signal can be input at the BASEBAND INPUT I connector and redirected from there to the RF input path. A transducer is activated to compensate for the additional path of the redirected signal. The signal is then processed as usual in the frequency and time domain as for any other RF input.

This is useful, for example, to perform frequency sweep measurements with (single-ended or differential) active probes, which can also be connected to the BASEBAND INPUT I connector.

Frequency sweep measurements on probe input

You can perform RF measurements (measurements in the time or frequency domain) by connecting a probe to the BASEBAND INPUT I connector and switching the input source to this connector in the RF input configuration (see "Input Connector").

The probe's attenuation is compensated automatically by the R&S FSW using a transducer named "Probe on Baseband Input I". (The probe can only be connected on I, as only input at the I connector can be redirected to the RF path). A comment is assigned that includes the type, name and serial number of the detected probe. The transducer is deleted as soon as the probe is disconnected.

For details on transducers see "Basics on Transducer Factors".

For more information on using probes for input see "Using Probes".


Using Probes

Common Measurement Settings > Data Input and Output > Receiving Data Input and Providing Data Output > Using Probes
Using Probes

As an alternative means of input to the R&S FSW, active probes from Rohde&Schwarz can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband Interface (option R&S FSW-B71) is installed. These probes allow you to perform voltage measurements very flexibly and precisely on all sorts of devices to be tested, without interfering with the signal.

Connecting probes

Probes are automatically detected when you plug them into the upper BASEBAND INPUT connectors on the front panel of the R&S FSW. The detected information on the probe is displayed in the "Probes" tab of the "Input" dialog box, individually for each connector.

Availability of probe input

Analog baseband input from connected probes can only be analyzed in applications that support I/Q data processing and the Analog Baseband Interface (R&S FSW-B71), such as the I/Q Analyzer, the Analog Demodulation application, or one of the optional applications.

Frequency sweep measurements with probes

Probes can also be used as an alternative method of providing RF input to the R&S FSW. In this case, the probe must be connected to the BASEBAND INPUT I connector, and the input is redirected to the RF input path (see "RF Input from the Analog Baseband Connector"). As opposed to common RF input processing, a transducer is activated before the common process to compensate for the additional path of the redirected signal. Probe signals that are redirected to the RF input path can also be analyzed in the Spectrum application of the R&S FSW base unit. Then you can perform RF measurements (measurements in the time or frequency domain) on the input from a probe.

Microbutton action

You can define an action to be performed by the R&S FSW when the probe's microbutton (if available) is pressed. Currently, a single data acquisition via the probe can be performed simply by pressing the microbutton.

Impedance and attenuation

The measured signal from the probe is attenuated internally by the probe's specific attenuation. For probe signals that are redirected to the RF path, the attenuation is compensated using a transducer (see "Frequency sweep measurements on probe input"). The reference level is adjusted automatically.

For analog baseband input, the attenuation is compensated without a transducer. In this case, higher levels are available for the full scale level.

A fixed impedance of 50 Ω is used for all probes to convert voltage values to power levels.


Input from Noise Sources

Common Measurement Settings > Data Input and Output > Receiving Data Input and Providing Data Output > Input from Noise Sources
Input from Noise Sources

The R&S FSW provides a connector (NOISE SOURCE CONTROL) with a voltage supply for an external noise source. By switching the supply voltage for an external noise source on or off in the firmware, you can activate or deactive the device as required.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of an amplifier.

In this case, you can first connect an external noise source (whose noise power level is known in advance) to the R&S FSW and measure the total noise power. From this value you can determine the noise power of the R&S FSW. Then when you measure the power level of the actual DUT, you can deduct the known noise level from the total power to obtain the power level of the DUT.

The noise source is controlled in the "Output" settings, see "Noise Source"


Receiving and Providing Trigger Signals

Common Measurement Settings > Data Input and Output > Receiving Data Input and Providing Data Output > Receiving and Providing Trigger Signals
Receiving and Providing Trigger Signals

Using one of the variable TRIGGER INPUT/OUTPUT connectors of the R&S FSW, the R&S FSW can use a signal from an external reference as a trigger to capture data. Alternatively, the internal trigger signal used by the R&S FSW can be output for use by other connected devices. Using the same trigger on several devices is useful to synchronize the transmitted and received signals within a measurement.

For details on the connectors see the R&S FSW "Getting Started" manual.

External trigger as input

If the trigger signal for the R&S FSW is provided by an external reference, the reference signal source must be connected to the R&S FSW and the trigger source must be defined as "External" on the R&S FSW.

Trigger output

The R&S FSW can provide output to another device either to pass on the internal trigger signal, or to indicate that the R&S FSW itself is ready to trigger.

The trigger signal can be output by the R&S FSW automatically, or manually by the user. If it is provided automatically, a high signal is output when the R&S FSW has triggered due to a sweep start ("Device Triggered"), or when the R&S FSW is ready to receive a trigger signal after a sweep start ("Trigger Armed").

Manual triggering

If the trigger output signal is initiated manually, the length and level (high/low) of the trigger pulse is also user-definable. Note, however, that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is provided.

Providing trigger signals as output is described in detail in "How to Output a Trigger Signal".


IF and Video Signal Output

Common Measurement Settings > Data Input and Output > Receiving Data Input and Providing Data Output > IF and Video Signal Output
IF and Video Signal Output

The measured IF signal or displayed video signal (i.e. the filtered and detected IF signal) can be provided at the IF/VIDEO/DEMOD or IF OUT output connector.

The video output is a signal of 1 V. It can be used, for example, to control demodulated audio frequencies.

The IF output is a signal of the measured level at a specified frequency.

The IF 2 GHz output is a signal with a bandwidth of 2 GHz at the frequency 2 GHz.

Restrictions

Note the following restrictions for IF output:

  • IF and video output is only available in the time domain (zero span).
  • For I/Q data, only IF output is available.
  • IF output is not available if any of the following conditions apply:
    – The Digital Baseband Interface (R&S FSW-B17) is active (for input or output)
    – MSRA operating mode is active
    – MSRT operating mode is active
    – A wideband extension is used (hardware options R&S FSW-B160/-B320/-B500; used automatically for bandwidths > 80 MHz; in this case use the IF WIDE OUTPUT connector)
    – The sample rate is larger than 200 MHz (upsampling)
IF WIDE OUTPUT

If optional hardware R&S FSW-B160/-B320/-B500 for bandwidth extension is installed and activated (i.e. for bandwidths > 80 MHz), the IF output is not available at the IF/VIDEO/DEMOD output connector, but rather at the additional IF WIDE OUTPUT connector provided by the option.

In this case, the IF output frequency cannot be defined manually, but is determined automatically depending on the center frequency. For details on the used frequencies see the data sheet. The currently used output frequency is indicated in the field otherwise used to define the frequency manually (in the "Output" settings dialog box, see "IF (Wide) Out Frequency").

IF 2 GHz Output

For instrument models R&S FSW43/50/67, the IF output can also be provided at the alternative IF OUT output connector at a frequency of 2 GHz and with a bandwidth of 2 GHz. The IF output can then be analyzed by a different instrument, for example an R&S®RTO oscilloscope. If IF 2 GHZ OUT output is activated, the measured values are no longer available on the display; thus, the trace data currently displayed on the R&S FSW becomes invalid. A message in the status bar indicates this situation. The message also indicates whether the sidebands of the IF spectrum output are in normal or inverted order compared to the RF signal, which depends on the used center frequency.

Prerequisites
Note the following prerequisites for output to the IF OUT connector:
  • Instrument model R&S FSW43/50/67; external mixers can be used
  • Zero span mode, I/Q Analyzer, or VSA (R&S FSW-K70) application
  • Center frequency ≥ 8 GHz


Input Source Settings

Common Measurement Settings > Data Input and Output > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

The Digital I/Q and the Analog Baseband input sources are only available in applications that support I/Q data processing and are described in detail in "Basics on I/Q Data Acquisition and Processing" .

External mixers are not supported in MSRA/MSRT mode.

Contents
  • Radio Frequency Input
  • Probe Settings


Radio Frequency Input

Common Measurement Settings > Data Input and Output > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Radio Frequency State

Common Measurement Settings > Data Input and Output > Input Source Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

Common Measurement Settings > Data Input and Output > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

Common Measurement Settings > Data Input and Output > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion (see "Reference Level").

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

Common Measurement Settings > Data Input and Output > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

Common Measurement Settings > Data Input and Output > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Note:

For the following measurements, the YIG-Preselector is off by default (if available).
  • I/Q Analyzer (and thus in all applications in MSRA operating mode)
  • Realtime (and thus in all applications in MSRT operating mode)
  • Multi-Carrier Group Delay
  • GSM
  • VSA

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

Common Measurement Settings > Data Input and Output > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​CONNector


Probe Settings

Common Measurement Settings > Data Input and Output > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes".

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

Common Measurement Settings > Data Input and Output > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


Power Sensors

Common Measurement Settings > Data Input and Output > Power Sensors
Power Sensors

The R&S FSW can also analyze data from a connected power sensor.

Contents
  • Basics on Power Sensors
  • Power Sensor Settings
  • How to Work With a Power Sensor


Basics on Power Sensors

Common Measurement Settings > Data Input and Output > Power Sensors > Basics on Power Sensors
Basics on Power Sensors

For precise power measurement up to 4 power sensors can be connected to the instrument via the power sensor interface (on the front panel). Both manual operation and remote control are supported.

Currently, only R&S NRP-Zxy power sensors are supported. For a detailed list of supported sensors see the data sheet.

Power sensors can also be used to trigger a measurement at a specified power level, e.g. from a signal generator (see "Using a Power Sensor as an External Power Trigger").

Power sensor support – standard test setup
Using the power sensor with several applications

The power sensor cannot be used from the R&S FSW firmware and the R&S Power Viewer Plus (virtual power meter for displaying results of the R&S NRP power sensors) simultaneously.

Result display

The results of the power sensor measurements are displayed in the marker table. For each power sensor, a row is inserted. The sensor index is indicated in the "Type" column.

Contents
  • Using a Power Sensor as an External Power Trigger


Using a Power Sensor as an External Power Trigger

Common Measurement Settings > Data Input and Output > Power Sensors > Basics on Power Sensors > Using a Power Sensor as an External Power Trigger
Using a Power Sensor as an External Power Trigger

Power sensors can be used to trigger a measurement at a specified power level, e.g. from a signal generator.

Currently, only the following power sensors are supported as power triggers:

  • R&S NRP-Z81
  • R&S NRP-Z85
  • R&S NRP-Z86

With the R&S FSW, the power sensors can be connected to the "Power Sensor" interface directly, and no further cables are required. They can then be configured as an external power sensor trigger.

Connecting a power sensor using the POWER SENSOR interface

The R&S FSW receives an external trigger signal when the defined trigger level is measured by the power sensor. Power measurement results are provided as usual.

The "Gate Mode" Level is not supported for R&S power sensors. The signal sent by these sensors merely reflects the instant the level is first exceeded, rather than a time period. However, only time periods can be used for gating in level mode. Thus, the trigger impulse from the sensors is not long enough for a fully gated measurement; the measurement cannot be completed. For details on gating see "Gated Measurements".

For details see "How to Configure a Power Sensor as an External (PSE) Trigger".


Power Sensor Settings

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings
Power Sensor Settings

Power sensor settings are available in the "Power Sensor" tab of the "Input" dialog box. Each sensor is configured on a separate tab.

└ State
└ Continuous Value Update
└ Select
└ Zeroing Power Sensor
└ Frequency Manual
└ Frequency Coupling
└ Unit/Scale
└ Meas Time/Average
└ Setting the Reference Level from the Measurement (Meas->Ref)
└ Reference Value
└ Use Ref Lev Offset
└ Average Count (Number of Readings)
└ Duty Cycle
└ Using the power sensor as an external trigger
└ External Trigger Level
└ Hysteresis
└ Trigger Holdoff
└ Drop-Out Time
└ Slope


State

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > State
State

Switches the power measurement for all power sensors on or off. Note that in addition to this general setting, each power sensor can be activated or deactivated individually by the "Select" setting on each tab. However, the general setting overrides the individual settings.

Remote command:

[SENSe:​]PMETer<p>[:​STATe]


Continuous Value Update

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Continuous Value Update
Continuous Value Update

If activated, the power sensor data is updated continuously during a sweep with a long sweep time, and even after a single sweep has completed.

This function cannot be activated for individual sensors.

If the power sensor is being used as a trigger (see "Using the power sensor as an external trigger"), continuous update is not possible; this setting is ignored.

Remote command:

[SENSe:​]PMETer<p>:​UPDate[:​STATe]


Select

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Select
Select

Selects the individual power sensor for usage if power measurement is generally activated ("State" function).

The detected serial numbers of the power sensors connected to the instrument are provided in a selection list. For each of the four available power sensor indexes ("Power Sensor 1"..."Power Sensor 4"), which correspond to the tabs in the configuration dialog, one of the detected serial numbers can be assigned. The physical sensor is thus assigned to the configuration setting for the selected power sensor index.

By default, serial numbers not yet assigned are automatically assigned to the next free power sensor index for which "Auto Assignment" is selected.

Alternatively, you can assign the sensors manually by deactivating the "Auto" option and selecting a serial number from the list.

Remote command:

[SENSe:​]PMETer<p>[:​STATe]

SYSTem:​COMMunicate:​RDEVice:​PMETer<p>:​DEFine

SYSTem:​COMMunicate:​RDEVice:​PMETer<p>:​CONFigure:​AUTO[:​STATe]

SYSTem:​COMMunicate:​RDEVice:​PMETer:​COUNt?


Zeroing Power Sensor

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Zeroing Power Sensor
Zeroing Power Sensor

Starts zeroing of the power sensor.

For details on the zeroing process refer to "How to Zero the Power Sensor".

Remote command:

CALibration:​PMETer<p>:​ZERO:​AUTO ONCE


Frequency Manual

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Frequency Manual
Frequency Manual

Defines the frequency of the signal to be measured. The power sensor has a memory with frequency-dependent correction factors. This allows extreme accuracy for signals of a known frequency.

Remote command:

[SENSe:​]PMETer<p>:​FREQuency


Frequency Coupling

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Frequency Coupling
Frequency Coupling

Selects the coupling option. The frequency can be coupled automatically to the center frequency of the instrument or to the frequency of marker 1.

Remote command:

[SENSe:​]PMETer<p>:​FREQuency:​LINK


Unit/Scale

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Unit/Scale
Unit/Scale

Selects the unit with which the measured power is to be displayed. Available units are dBm, dB, W and %.

If dB or % is selected, the display is relative to the reference value that is defined with either the "Meas -> Ref" setting or the "Reference Value" setting.

Remote command:

UNIT<n>:​PMETer<p>:​POWer

UNIT<n>:​PMETer<p>:​POWer:​RATio


Meas Time/Average

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Meas Time/Average
Meas Time/Average

Selects the measurement time or switches to manual averaging mode. In general, results are more precise with longer measurement times. The following settings are recommended for different signal types to obtain stable and precise results:

"Short" | Stationary signals with high power (> -40dBm), because they require only a short measurement time and short measurement time provides the highest repetition rates.
"Normal" | Signals with lower power or modulated signals
"Long" | Signals at the lower end of the measurement range (<-50 dBm) or Signals with lower power to minimize the influence of noise
"Manual" | Manual averaging mode. The average count is set with the "Average Count (Number of Readings)" setting.
Remote command:

[SENSe:​]PMETer<p>:​MTIMe

[SENSe:​]PMETer<p>:​MTIMe:​AVERage[:​STATe]


Setting the Reference Level from the Measurement (Meas->Ref)

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Setting the Reference Level from the Measurement (Meas->Ref)
Setting the Reference Level from the Measurement (Meas->Ref)

Sets the currently measured power as a reference value for the relative display. The reference value can also be set manually via the "Reference Value" setting.

Remote command:

CALCulate<n>:​PMETer<p>:​RELative[:​MAGNitude]:​AUTO ONCE


Reference Value

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Reference Value
Reference Value

Defines the reference value for relative measurements in the unit dBm.

Remote command:

CALCulate<n>:​PMETer<p>:​RELative[:​MAGNitude]


Use Ref Lev Offset

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Use Ref Lev Offset
Use Ref Lev Offset

If activated, takes the reference level offset defined for the analyzer into account for the measured power (see "Shifting the Display (Offset)"). If deactivated, takes no offset into account.

Remote command:

[SENSe:​]PMETer<p>:​ROFFset[:​STATe]


Average Count (Number of Readings)

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Average Count (Number of Readings)
Average Count (Number of Readings)

Defines the number of readings (averages) to be performed after a single sweep has been started. This setting is only available if manual averaging is selected ("Meas Time/Average" setting).

The values for the average count range from 0 to 256 in binary steps (1, 2, 4, 8, …). For average count = 0 or 1, one reading is performed. The general averaging and sweep count for the trace are independent from this setting.

(See"Bandwidth, Filter and Sweep Settings").

Results become more stable with extended average, particularly if signals with low power are measured. This setting can be used to minimize the influence of noise in the power sensor measurement.

Remote command:

[SENSe:​]PMETer<p>:​MTIMe:​AVERage:​COUNt


Duty Cycle

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Duty Cycle
Duty Cycle

Sets the duty cycle to a percent value for the correction of pulse-modulated signals and activates the duty cycle correction. With the correction activated, the sensor calculates the signal pulse power from this value and the mean power.

Remote command:

[SENSe:​]PMETer<p>:​DCYCle[:​STATe]

[SENSe:​]PMETer<p>:​DCYCle:​VALue


Using the power sensor as an external trigger

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger
Using the power sensor as an external trigger

If activated, the power sensor creates a trigger signal when a power higher than the defined "External Trigger Level" is measured. This trigger signal can be used as an external power trigger by the R&S FSW.

This setting is only available in conjunction with a compatible power sensor.

For details on using a power sensor as an external trigger, see "Using a Power Sensor as an External Power Trigger".

Remote command:

[SENSe:​]PMETer<p>:​TRIGger[:​STATe]

TRIG:SOUR PSE, see TRIGger[:​SEQuence]:​SOURce

└ External Trigger Level
└ Hysteresis
└ Trigger Holdoff
└ Drop-Out Time
└ Slope


External Trigger Level

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > External Trigger Level
External Trigger Level

Defines the trigger level for the power sensor trigger.

For details on supported trigger levels, see the data sheet.

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​LEVel


Hysteresis

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Setting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

For more information see "Trigger Hysteresis".

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​HYSTeresis


Trigger Holdoff

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff".

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​HOLDoff


Drop-Out Time

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time".


Slope

Common Measurement Settings > Data Input and Output > Power Sensors > Power Sensor Settings > Using the power sensor as an external trigger > Slope
Slope

Defines whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

[SENSe:​]PMETer<p>:​TRIGger:​SLOPe


How to Work With a Power Sensor

Common Measurement Settings > Data Input and Output > Power Sensors > How to Work With a Power Sensor
How to Work With a Power Sensor

The following step-by-step instructions demonstrate how to set up a power sensor. For details on individual functions and settings see "Power Sensor Settings".

The remote commands required to perform these tasks are described in "Working with Power Sensors".

Power sensors can also be used to trigger a measurement at a specified power level, e.g. from a signal generator. This is described in "How to Configure a Power Sensor as an External (PSE) Trigger".

Contents
  • How to Set Up a Power Sensor
  • How to Zero the Power Sensor
  • How to Configure a Power Sensor as an External (PSE) Trigger


How to Set Up a Power Sensor

Common Measurement Settings > Data Input and Output > Power Sensors > How to Work With a Power Sensor > How to Set Up a Power Sensor
How to Set Up a Power Sensor

Up to 4 external power sensors can be configured separately and used for precise power measurement, as a trigger, or both. All power sensors can be activated and deactivated individually.

The following procedure describes in detail how to configure and activate power sensors.

  1. To display the "Power Sensor" tab of the "Input" dialog box, do one of the following:

    • Select "Input" from the "Overview".
    • Select the INPUT/OUTPUT key and then the "Power Sensor Config" softkey.

  2. Select the tab for the power sensor index you want to configure, e.g. "Sensor 1".

  3. Press "Select" to analyze the power sensor data according to the current configuration when power measurement is activated.

  4. From the selection list with serial numbers of connected power sensors, select the sensor you want to configure.

    To have newly connected power sensors assigned to a tab automatically (default), select "Auto".

  5. Define the frequency of the signal whose power you want to measure.

    1. To define the frequency manually, select "Frequency Manual" and enter a frequency.

    2. To determine the frequency automatically, select "Frequency Coupling" and then either "Center", to use the center frequency, or "Marker", to use the frequency defined by marker 1.

  6. Select the unit for the power result display.

  7. Select the measurement time for which the average is calculated, or define the number of readings to average. To define the number of readings to be taken into account manually, select "Manual" and enter the number in the "Number of Readings" field.

  8. To activate the duty cycle correction, select "DutyCycle" and enter a percentage as the correction value.

  9. If you selected "dB" or "%" as units (relative display), define a reference value:

    1. To set the currently measured power as a reference value, press the "Meas -> Ref" button.

    2. Alternatively, enter a value manually in the "Reference Value" field.

    3. Optionally, select the "Use Ref Level Offset" option to take the reference level offset set for the analyzer into account for the measured power.

  10. To use the power sensor as an external power trigger, select the "External Power Trigger" option and define the trigger settings.

    For details see "How to Configure a Power Sensor as an External (PSE) Trigger".

  11. If necessary, repeat steps 3-10 for another power sensor.

  12. Set the "Power Sensor State" at the top of the "Power Sensor" tab to "On" to activate power measurement for the selected power sensors.

    The results of the power measurement are displayed in the marker table (Function: "Sensor<1...4>").


How to Zero the Power Sensor

Common Measurement Settings > Data Input and Output > Power Sensors > How to Work With a Power Sensor > How to Zero the Power Sensor
How to Zero the Power Sensor

  1. To display the "Power Sensor" tab of the "Input" dialog box, do one of the following:

    • Select "Input" from the "Overview".
    • Select the INPUT/OUTPUT key and then the "Power Sensor Config" softkey.

  2. Select the tab that is assigned to the power sensor you want to zero.

  3. Press the "Zeroing Power Sensor" button.

    A dialog box is displayed that prompts you to disconnect all signals from the input of the power sensor.

  4. Disconnect all signals sending input to the power sensor and press ENTER to continue.

  5. Wait until zeroing is complete.

    A corresponding message is displayed.


How to Configure a Power Sensor as an External (PSE) Trigger

Common Measurement Settings > Data Input and Output > Power Sensors > How to Work With a Power Sensor > How to Configure a Power Sensor as an External (PSE) Trigger
How to Configure a Power Sensor as an External (PSE) Trigger

The following step-by-step instructions demonstrate how to configure a power sensor to be used as an external power sensor trigger.

To configure a power sensor as an external power sensor (PSE) trigger

  1. Connect a compatible power sensor to the "Power Sensor" interface on the front panel of the R&S FSW. (For details on supported sensors see "Using a Power Sensor as an External Power Trigger").

  2. Set up the power sensor as described in "How to Set Up a Power Sensor".

  3. In the "Power Sensor" tab of the "Input" dialog box, select the "External Power Trigger" option.

  4. Enter the power level at which a trigger signal is to be generated ("External Trigger Level") and the other trigger settings for the power sensor trigger.

  5. Press the TRIG key on the front panel of the instrument and then select "Trigger /Gate Config".

  6. In the "Trigger and Gate" dialog box, select "Signal Source" = "PSE".

    The R&S FSW is configured to trigger when the defined conditions for the power sensor occur. Power measurement results are provided as usual.


External Generator Control (Option R&S FSW-B10)

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10)
External Generator Control (Option R&S FSW-B10)

If the R&S FSW External Generator Control (R&S FSW-B10) is installed, you can operate various commercially available generators as an external generator with the R&S FSW. Thus, scalar network analysis with the R&S FSW is possible.

Contents
  • About External Generator Control
  • Basics on External Generator Control
  • External Generator Control Settings
  • How to Work With External Generator Control
  • Measurement Example: Calibration with an External Generator


About External Generator Control

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > About External Generator Control
About External Generator Control

A common measurement setup includes a signal generator, a device under test (DUT), and a signal and spectrum analyzer, for example the R&S FSW. In this setup, the signal analyzer can control which signal the generator is to send, which is in turn measured by the analyzer. This process is referred to as external generator control. The generator in this setup is referred to as a tracking generator.

A measurement with a tracking generator is useful to measure any effects on the power level caused by the cables and connectors from the signal generator and the signal analyzer in advance. The known effects can then be removed from the measurement results in order to obtain accurate information on the DUT.


Basics on External Generator Control

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control
Basics on External Generator Control

Some background knowledge on basic terms and principles used for external generator control is provided here for a better understanding of the required configuration settings.

External generator control is only available in the Spectrum, I/Q Analyzer, Analog Demodulation and Noise Figure applications.

Contents
  • External Generator Connections
  • Overview of Generators Supported by the R&S FSW-B10 Option
  • Generator Setup Files
  • Calibration Mechanism
  • Normalization
  • Reference Trace, Reference Line and Reference Level
  • Coupling the Frequencies
  • Displayed Information and Errors


External Generator Connections

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > External Generator Connections
External Generator Connections

The external generator is controlled either via a LAN connection or via the EXT. GEN. CONTROL GPIB interface of the R&S FSW supplied with the R&S FSW-B10 option.

For more information on configuring interfaces see "Remote Control Interfaces and Protocols".

TTL synchronization

In addition, TTL synchronization can be used with some Rohde & Schwarz generators connected via GPIB. The TTL interface is included in the AUX CONTROL connector of the R&S FSW-B10 option.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator. For details see "Coupling the Frequencies".

In figure " TTL connection for an SMU generator" the TTL connection is illustrated using an SMU generator, for example.

TTL connection for an SMU generator

The external generator can be used to calibrate the data source by performing either transmission or reflection measurements.

Transmission Measurement

This measurement yields the transmission characteristics of a two-port network. The external generator is used as a signal source. It is connected to the input connector of the DUT. The input of the R&S FSW is fed from the output of the DUT. A calibration can be carried out to compensate for the effects of the test setup (e.g. frequency response of connecting cables).

Test setup for transmission measurement
Reflection Measurement

Scalar reflection measurements can be carried out using a reflection-coefficient measurement bridge.

Test setup for reflection measurement
Generated signal input

In order to use the functions of the external generator, an appropriate generator must be connected and configured correctly. In particular, the generator output must be connected to the RF input of the R&S FSW.

External reference frequency

In order to enhance measurement accuracy, a common reference frequency should be used for both the R&S FSW and the generator. If no independent 10 MHz reference frequency is available, it is recommended that you connect the reference output of the generator with the reference input of the R&S FSW and that you enable usage of the external reference on the R&S FSW via "SETUP" > "Reference" > "External Reference".

For more information on external references see "Reference Frequency Input".

Connection errors

If no external generator is connected, if the connection address is not correct, or the generator is not ready for operation, an error message is displayed (e.g."Ext. Generator TCPIP Handshake Error!", see "Displayed Information and Errors").


Overview of Generators Supported by the R&S FSW-B10 Option

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > Overview of Generators Supported by the R&S FSW-B10 Option
Overview of Generators Supported by the R&S FSW-B10 Option
Generator type | TTL support | Generator type | TTL support
SGS100A12 | X | SMP02 | X
SMA01A 1) | X | SMP03 | X
SMA100A3 | X | SMP04 | X
SMA100A6 | X | SMP22 | X
SMB100A1 | X | SMR20 | -
SMB100A12 | X | SMR20B11 3) | X
SMB100A2 | X | SMR27 | X
SMB100A20 | X | SMR27B11 3) | X
SMB100A3 | X | SMR30 | X
SMB100A40 | X | SMR30B11 3) | X
SMBV100A3 | X | SMR40 | X
SMBV100A6 | X | SMR40B11 3) | X
SMC100A1 | - | SMR50 | X
SMC100A3 | - | SMR50B11 3) | X
SME02 | X | SMR60 | X
SME03 | X | SMR60B11 3) | X
SME06 | X | SMT02 | -
SMF100A | X | SMT03 | -
SMF22 | X | SMT06 | -
SMF22B2 | X | SMU02 | X
SMF43 | X | SMU02B31 2) | X
SMF43B2 | X | SMU03 2) | X
SMG | - | SMU03B31 2) | X
SMGL | - | SMU04 2) | X
SMGU | - | SMU04B31 2) | X
SMH | - | SMU06 2) | X
SMHU | - | SMU06B31 2) | X
SMIQ02 | X | SMV03 | -
SMIQ02B | X | SMW03 | -
SMIQ02E | - | SMW06 | -
SMIQ03 | X | SMX | -
SMIQ03B | X | SMY01 | -
SMIQ03E | - | SMY02 | -
SMIQ04B | X | HP8254A | -
SMIQ06B | X | HP8257D | -
SMJ03 | X | HP8340A | -
SMJ06 | X | HP8648 | -
SML01 | - | HP ESG-A Series 1000A, 2000A, 3000A, 4000A | -
SML02 | - | HP ESG B Sereies | -
SML03 | - | HP ESG-D SERIES E4432B | -
1) Requires firmware version V2.10.x or higher 2) Requires firmware version V1.10.x or higher 3) Requires the option SMR-B11


Generator Setup Files

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > Generator Setup Files
Generator Setup Files

For each signal generator type to be controlled by the R&S FSW a generator setup file must be configured and stored on the R&S FSW. The setup file defines the frequency and power ranges supported by the generator, as well as information required for communication. For the signal generators listed in "Overview of Generators Supported by the R&S FSW-B10 Option", default setup files are provided. If necessary, these files can be edited or duplicated for varying measurement setups or other instruments.

The existing setup files can be displayed in an editor in read-only mode directly from the "External Generator" configuration dialog box. From there, they can be edited and stored under a different name, and are then available on the R&S FSW.

(For details see "To define a new generator setup file").


Calibration Mechanism

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > Calibration Mechanism
Calibration Mechanism

A common measurement setup includes a signal generator, a device under test (DUT), and a signal and spectrum analyzer. Therefore, it is useful to measure the attenuation or gain caused by the cables and connectors from the signal generator and the signal analyzer in advance. The known level offsets can then be removed from the measurement results in order to obtain accurate information on the DUT.

Calculating the difference between the currently measured power and a reference trace is referred to as calibration. Thus, the measurement results from the controlled external generator - including the inherent distortions - can be used as a reference trace to calibrate the measurement setup.

The inherent frequency and power level distortions can be determined by connecting the R&S FSW to the signal generator. The R&S FSW sends a predefined list of frequencies to the signal generator (see also "Coupling the Frequencies"). The signal generator then sends a signal with the specified level at each frequency in the predefined list. The R&S FSW measures the signal and determines the level offsets to the expected values.

Saving calibration results

A reference dataset for the calibration results is stored internally as a table of value pairs (frequency/level), one for each sweep point. The measured offsets can then be used as calibration factors for subsequent measurement results.

The calibration can be performed using either transmission or reflection measurements. The selected type of measurement used to determine the reference trace is included in the reference dataset.


Normalization

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > Normalization
Normalization

Once the measurement setup has been calibrated and the reference trace is available, subsequent measurement results can be corrected according to the calibration factors, if necessary. This is done by subtracting the reference trace from the measurement results. This process is referred to as normalization and can be activated or deactivated as required. If normalization is activated, "NOR" is displayed in the channel bar, next to the indication that an external generator is being used ("Ext.Gen").The normalized trace from the calibration sweep is a constant 0 dB line, as <calibration trace> - <reference trace> = 0.

As long as the same settings are used for measurement as for calibration, the normalized measurement results should not contain any inherent frequency or power distortions. Thus, the measured DUT values are very accurate.

Approximate normalization

As soon as any of the calibration measurement settings are changed, the stored reference trace will no longer be identical to the new measurement results. However, if the measurement settings do not deviate too much, the measurement results can still be normalized approximately using the stored reference trace. This is indicated by the "APX" label in the channel bar (instead of "NOR").

This is the case if one or more of the following values deviate from the calibration settings:
  • coupling (RBW, VBW, SWT)
  • reference level, RF attenuation
  • start or stop frequency
  • output level of external generator
  • detector (max. peak, min. peak, sample, etc.)
  • frequency deviation at a maximum of 1001 points within the set sweep limits (corresponds to a doubling of the span)

Differences in level settings between the reference trace and the current instrument settings are taken into account automatically. If the span is reduced, a linear interpolation of the intermediate values is applied. If the span increases, the values at the left or right border of the reference dataset are extrapolated to the current start or stop frequency, i.e. the reference dataset is extended by constant values.

Thus, the instrument settings can be changed in a wide area without giving up normalization. This reduces the necessity to carry out a new normalization to a minimum.

If approximation becomes too poor, however, normalization is aborted and an error message is displayed (see "Displayed Information and Errors").

The normalized trace in the display

The normalized reference trace is also displayed in the spectrum diagram, by default at the top of the diagram (= 100% of the window height). It is indicated by a red line labeled "NOR", followed by the current reference value. However, it can be shifted vertically to reflect an attenuation or gain caused by the measured DUT (see also "Shifting the reference line (and normalized trace)").

Restoring the calibration settings

If the measurement settings no longer match the instrument settings with which the calibration was performed (indicated by the "APX" or no label next to "Ext.TG" in the channel bar), you can restore the calibration settings, which are stored with the reference dataset on the R&S FSW.

Storing the normalized reference trace as a transducer factor

The (inverse) normalized reference trace can also be stored as a transducer factor for use in other R&S FSW applications that do not support external generator control. The normalized trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under c:\r_s\instr\trd. The frequency points are allocated in equidistant steps between the start and stop frequency.

This is useful, for example, to determine the effects of a particular device component and then remove these effects from a subsequent measurement which includes this component.

For an example see "How to Remove the Effects of a Particular Component from Measurement Results Using Calibration".

Note that the normalized measurement data is stored, not the original reference trace! Thus, if you store the normalized trace directly after calibration, without changing any settings, the transducer factor will be 0 dB for the entire span (by definition of the normalized trace).


Reference Trace, Reference Line and Reference Level

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > Reference Trace, Reference Line and Reference Level
Reference Trace, Reference Line and Reference Level
Reference trace

The calibration results are stored internally on the R&S FSW as a reference trace. For each measured sweep point the offset to the expected values is determined. If normalization is activated, the offsets in the reference trace are removed from the current measurement results to compensate for the inherent distortions.

Reference line

The reference line is defined by the "Reference Value" and "Reference Position" in the "External Generator" > "Source Calibration" settings. It is similar to the "Reference Level" defined in the "Amplitude" settings. However, as opposed to the reference level, this reference line only affects the y-axis scaling in the diagram, it has no effect on the expected input power level or the hardware settings.

The reference line determines the range and the scaling of the y-axis, just as the reference level does.

The normalized reference trace (0 dB directly after calibration) is displayed on this reference line, indicated by a red line in the diagram. By default, the reference line is displayed at the top of the diagram. If you shift the reference line, the normalized trace is shifted, as well.

Shifting the reference line (and normalized trace)

You can shift the reference line - and thus the normalized trace - in the result display by changing the "Reference Position" or the "Reference Value".

If the DUT inserts a gain or an attenuation in the measurement, this effect can be reflected in the result display on the R&S FSW. To reflect a power offset in the measurement trace, change the "Reference Value".

For a detailed example see "Measurement Example: Calibration with an External Generator".


Coupling the Frequencies

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > Coupling the Frequencies
Coupling the Frequencies

As described in "Normalization", normalized measurement results are very accurate as long as the same settings are used as for calibration. Although approximate normalization is possible, it is important to consider the required frequencies for calibration in advance. The frequencies and levels supported by the connected signal generator are provided for reference with the interface configuration.

Two different methods are available to define the frequencies for calibration, that is to couple the frequencies of the R&S FSW with those of the signal generator:

  • Manual coupling: a single frequency is defined
  • Automatic coupling: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW; the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)
Automatic coupling

If automatic coupling is used, the output frequency of the generator (source frequency) is calculated as follows:

Output frequency of the generator

where:

FGenerator = output frequency of the generator

FAnalyzer = current frequency at the RF input of the R&S FSW

Numerator = multiplication factor for the current analyzer frequency

Denominator = division factor for the current analyzer frequency

FOffset = frequency offset for the current analyzer frequency, for example for frequency-converting measurements or harmonics measurements

The value range for the offset depends on the selected generator. The default setting is 0 Hz. Offsets other than 0 Hz are indicated by the "FRQ" label in the channel bar (see also "Displayed Information and Errors").

Swept frequency range

The FAnalyzer values for the calibration sweep start with the start frequency and end with the stop frequency defined in the "Frequency" settings of the R&S FSW. The resulting output frequencies ("Result Frequency Start" and "Result Frequency Stop") are displayed in the "External Generator" > "Measurement Configuration" for reference.

If the resulting frequency range exeeds the allowed ranges of the signal generator, an error message is displayed (see "Displayed Information and Errors") and the "Result Frequency Start" and "Result Frequency Stop" values are corrected to comply with the range limits.

The calibration sweep nevertheless covers the entire span defined by the R&S FSW; however, no input is received from the generator outside the generator's defined limits.

TTL synchronization

Some Rohde & Schwarz signal generators support TTL synchronization when connected via GPIB. The TTL interface is included in the AUX CONTROL connector of the R&S FSW-B10 option.

When pure GPIB connections are used between the R&S FSW and the signal generator, the R&S FSW sets the generator frequency for each frequency point individually via GPIB, and only when the setting procedure is finished, the R&S FSW can measure the next sweep point.

For generators with a TTL interface, the R&S FSW sends a list of the frequencies to be set to the generator before the beginning of the first sweep. Then the R&S FSW starts the sweep and the next frequency point is selected by both the R&S FSW and the generator using the TTL handshake line "TRIGGER". The R&S FSW can only measure a value when the generator signals the end of the setting procedure via the "BLANK" signal.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator.

Reverse sweep

The frequency offset for automatic coupling can be used to sweep in the reverse direction. To do so, define a negative offset in the external generator measurement configuration. (Note that the frequency is defined as the unsigned value of the equation, thus a negative frequency is not possible.)

Example: Example for reverse sweep

FAnalyzerStart= 100 MHz

FAnalyzerStop = 200 MHz

FOffset = -300 MHz

Numerator = Denominator = 1

→FGeneratorStart = 200 MHz

→FGeneratorStop = 100 MHz

If the offset is adjusted so that the sweep of the generator crosses the minimum generator frequency, a message is displayed in the status bar ("Reverse Sweep via min. Ext. Generator Frequency!").

Example: Example for reverse sweep via minimum frequency

FAnalyzerStart= 100 MHz

FAnalyzerStop = 200 MHz

FOffset = -150 MHz

Fmin = 20 MHz

Numerator = Denominator = 1

→FGeneratorStart = 50 MHz

→FGeneratorStop = 50 MHz via Fmin


Displayed Information and Errors

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Basics on External Generator Control > Displayed Information and Errors
Displayed Information and Errors
Channel bar

If external generator control is active, some additional information is displayed in the channel bar.

Label | Description
EXT TG: <source power> | External generator active; signal sent with <source power> level
LVL | Power Offset (see "Source Offset"
FRQ | Frequency Offset (see "(Automatic) Source Frequency (Numerator/Denominator/Offset)"
NOR | Normalization on; No difference between reference setting and measurement
APX (approximation) | Normalization on; Deviation from the reference setting occurs
- | Aborted normalization or no calibration performed yet
Error and status messages

The following status and error messages may occur during external generator control.

Message | Description
"Ext. Generator GPIB Handshake Error!" / "Ext. Generator TCPIP Handshake Error!" / "Ext. Generator TTL Handshake Error!" | Connection to the generator is not possible, e.g. due to a cable damage or loose connection or wrong address.
"Ext. Generator Limits Exceeded!" | The allowed frequency or power ranges for the generator were exceeded.
"Reverse Sweep via min. Ext. Generator Frequency!" | Reverse sweep is performed; frequencies are reduced to the minimum frequency, then increased again; see " Reverse sweep"
"Ext. Generator File Syntax Error!" | Syntax error in the generator setup file (see "Generator Setup Files"
"Ext. Generator Command Error!" | Missing or wrong command in the generator setup file (see "Generator Setup Files"
"Ext. Generator Visa Error!!" | Error with Visa driver provided with installation (very unlikely)
Overloading

At a reference level of -10 dBm and at a external generator output level of the same value, the R&S FSW operates without overrange reserve. That means the R&S FSW is in danger of being overloaded if a signal is applied whose amplitude is higher than the reference line. In this case, either the message "RF OVLD" for overload or "IF OVLD" for exceeded display range (clipping of the trace at the upper diagram border = overrange) is displayed in the status line.

Overloading can be avoided as follows:
  • Reducing the output level of the external generator ("Source Power" in "External Generator > Measurement Configuration")
  • Increasing the reference level ("Reference Level" in the "Amplitude" menu)


External Generator Control Settings

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings
External Generator Control Settings

The "External Generator" settings are available in the "Input" dialog box if the R&S FSW External Generator Control option (R&S FSW-B10) is installed. For each measurement channel one external generator can be configured. To switch between different configurations define multiple measurement channels.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

Contents
  • Interface Configuration Settings
  • Measurement Settings
  • Source Calibration Functions


Interface Configuration Settings

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings
Interface Configuration Settings

The interface settings for the connection to the external generator are defined in the "Interface Configuration" subtab of the "External Generator" tab.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

For more information on configuring interfaces see "Remote Control Interfaces and Protocols".

└ Generator Type
└ Interface
└ TTL Handshake
└ GPIB Address / TCP/IP Address
└ Reference
└ Edit Generator Setup File
└ Frequency Min. / Frequency Max.
└ Level Min. / Level Max.


Generator Type

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > Generator Type
Generator Type

Selects the generator type and thus defines the generator setup file to use.

For an overview of supported generators see "Overview of Generators Supported by the R&S FSW-B10 Option". For information on generator setup files see "Generator Setup Files".

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​TYPE


Interface

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > Interface
Interface

Type of interface connection used. The following interfaces are currently supported:

  • GPIB
  • TCP/IP (not by all generators)

For details on which signal generators support which interfaces, see the documentation of the corresponding signal generator.

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​INTerface


TTL Handshake

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > TTL Handshake
TTL Handshake

If available for the specified generator type, this option activates TTL synchronization via handshake for GPIB connections.

Using the TTL interface allows for considerably higher measurement rates than pure GPIB control, because the frequency stepping of the R&S FSW is directly coupled with the frequency stepping of the generator.

For more information on TTL synchronization see "TTL synchronization".

For an overview of which generators support TTL synchronization see "Overview of Generators Supported by the R&S FSW-B10 Option".

Remote command:

SYSTem:​COMMunicate:​RDEVice:​GENerator:​LINK


GPIB Address / TCP/IP Address

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > GPIB Address / TCP/IP Address
GPIB Address / TCP/IP Address

For LAN connections: TCP/IP address of the signal generator

For GPIB connections: GPIB address of the signal generator.

For details on interfaces see "Remote Control Interfaces and Protocols".

Remote command:

SYSTem:​COMMunicate:​GPIB:​RDEVice:​GENerator:​ADDRess

SYSTem:​COMMunicate:​TCPip:​RDEVice:​GENerator:​ADDRess


Reference

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > Reference
Reference

Selects the internal R&S FSW or an external frequency reference to synchronize the R&S FSW with the generator (default: internal).

Remote command:

SOURce:​EXTernal:​ROSCillator[:​SOURce]


Edit Generator Setup File

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > Edit Generator Setup File
Edit Generator Setup File

Displays the setup file for the currently selected "Generator Type" in read-only mode in an editor.

Although the existing setup files are displayed in read-only mode in the editor, they can be saved under a different name (using "File > SaveAs").

Be careful, however, to adhere to the required syntax and commands. Errors will only be detected and displayed when you try to use the new generator (see also "Displayed Information and Errors").

For details see "Generator Setup Files".


Frequency Min. / Frequency Max.

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > Frequency Min. / Frequency Max.
Frequency Min. / Frequency Max.

For reference only: Lower and upper frequency limit for the generator.


Level Min. / Level Max.

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Interface Configuration Settings > Level Min. / Level Max.
Level Min. / Level Max.

For reference only: Lower and upper power limit for the generator.


Measurement Settings

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings
Measurement Settings

The measurement settings for external generator control are configured in the "Measurement Configuration" subtab of the "External Generator" tab.

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

└ Source State
└ Source Power
└ Source Offset
└ Source Frequency Coupling
└ (Manual) Source Frequency
└ (Automatic) Source Frequency (Numerator/Denominator/Offset)
└ Result Frequency Start
└ Result Frequency Stop


Source State

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > Source State
Source State

Activates or deactivates control of an external generator.

For more information on external generator control see "Basics on External Generator Control".

Remote command:

SOURce:​EXTernal[:​STATe]


Source Power

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > Source Power
Source Power

The output power of the external generator. The default output power is -20 dBm. The range is specified in the data sheet.

Remote command:

SOURce:​EXTernal:​POWer[:​LEVel]


Source Offset

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > Source Offset
Source Offset

Constant level offset for the external generator. Values from -200 dB to +200 dB in 1 dB steps are allowed. The default setting is 0 dB. Offsets are indicated by the "LVL" label in the channel bar (see also "Displayed Information and Errors").

With this offset, attenuators or amplifiers at the output connector of the external generator can be taken into account for the displayed output power values on screen or during data entry, for example. Positive offsets apply to an amplifier and negative offsets to an attenuator subsequent to the external generator.

Remote command:

SOURce:​POWer[:​LEVel][:​IMMediate]:​OFFSet


Source Frequency Coupling

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > Source Frequency Coupling
Source Frequency Coupling

Defines the frequency coupling mode between the R&S FSW and the generator.

For more information on coupling frequencies see "Coupling the Frequencies".

"Auto" | Default setting: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW (see "(Automatic) Source Frequency (Numerator/Denominator/Offset)"); the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)
"Manual" | The generator uses a single fixed frequency, defined by "(Manual) Source Frequency" which is displayed when you select "Manual" coupling.
Remote command:

SOURce:​EXTernal:​FREQuency:​COUPling[:​STATe]


(Manual) Source Frequency

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > (Manual) Source Frequency
(Manual) Source Frequency

Defines the fixed frequency to be used by the generator.

Remote command:

SOURce:​EXTernal:​FREQuency


(Automatic) Source Frequency (Numerator/Denominator/Offset)

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > (Automatic) Source Frequency (Numerator/Denominator/Offset)
(Automatic) Source Frequency (Numerator/Denominator/Offset)

With automatic frequency coupling, a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW.

However, the frequency used by the generator may differ from the input from the R&S FSW. The RF frequency may be multiplied by a specified factor, or a frequency offset can be added, or both.

Note: The input for the generator frequency is not validated, i.e. you can enter any values. However, if the allowed frequency ranges of the generator are exceeded, an error message is displayed on the R&S FSW and the values for "Result Frequency Start" and "Result Frequency Stop" are corrected to comply with the range limits.

The value range for the offset depends on the selected generator. The default setting is 0 Hz. Offsets <> 0 Hz are indicated by the "FRQ" label in the channel bar. Negative offsets can be used to define reverse sweeps.

For more information on coupling frequencies and reverse sweeps see "Coupling the Frequencies". For more information on error messages and the channel bar see "Displayed Information and Errors".

Remote command:

SOURce:​EXTernal:​FREQuency[:​FACTor]:​DENominator

SOURce:​EXTernal:​FREQuency[:​FACTor]:​NUMerator

SOURce:​EXTernal:​FREQuency:​OFFSet


Result Frequency Start

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > Result Frequency Start
Result Frequency Start

For reference only: The start frequency for the generator, calculated from the configured generator frequency and the start value defined for the R&S FSW.


Result Frequency Stop

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Measurement Settings > Result Frequency Stop
Result Frequency Stop

For reference only: The stop frequency for the generator, calculated from the configured generator frequency and the stop value defined for the R&S FSW.


Source Calibration Functions

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions
Source Calibration Functions

The calibration functions of the external generator are available in the "Source Calibration" subtab of the "External Generator" tab, but only if external generator control is active (see "Source State").

To display this dialog box, press the INPUT/OUPUT key and then select "External Generator Config".

For more information on external generator control see "Basics on External Generator Control".

└ Calibrate Transmission
└ Calibrate Reflection Short
└ Calibrate Reflection Open
└ Source Calibration Normalize
└ Recall
└ Save As Trd Factor
└ Reference Position
└ Reference Value


Calibrate Transmission

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Calibrate Transmission
Calibrate Transmission

Starts a transmission type measurement to determine a reference trace. This trace is used to calculate the difference for the normalized values.

This function is only available if external generator control is active (see "Source State").

For details see "Calibration Mechanism".

Remote command:

[SENSe:​]CORRection:​METHod


Calibrate Reflection Short

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Calibrate Reflection Short
Calibrate Reflection Short

Starts a short-circuit reflection type measurement to determine a reference trace for calibration.

This function is only available if external generator control is active (see "Source State").

If both calibrations (open circuit, short circuit) are carried out, the calibration trace is calculated by averaging the two measurements. The order of the two calibration measurements is irrelevant.

Remote command:

[SENSe:​]CORRection:​METHod

Selects the reflection method.

[SENSe:​]CORRection:​COLLect[:​ACQuire]

Starts the sweep for short-circuit calibration.


Calibrate Reflection Open

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Calibrate Reflection Open
Calibrate Reflection Open

Starts an open-circuit reflection type measurement to determine a reference trace for calibration.

This function is only available if external generator control is active (see "Source State").

If both reflection-type calibrations (open circuit, short circuit) are carried out, the reference trace is calculated by averaging the two measurements. The order of the two calibration measurements is irrelevant.

Remote command:

[SENSe:​]CORRection:​METHod

Selects the reflection method.

[SENSe:​]CORRection:​COLLect[:​ACQuire]

Starts the sweep for open-circuit calibration.


Source Calibration Normalize

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Source Calibration Normalize
Source Calibration Normalize

Switches the normalization of measurement results on or off. This function is only available if the memory contains a reference trace, that is, after a calibration has been performed.

For details on normalization see "Normalization".

Remote command:

[SENSe:​]CORRection[:​STATe]


Recall

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Recall
Recall

Restores the settings that were used during source calibration. This can be useful if instrument settings were changed after calibration (e.g. center frequency, frequency deviation, reference level, etc).

This function is only available if external generator control is active (see "Source State").

Remote command:

[SENSe:​]CORRection:​RECall


Save As Trd Factor

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Save As Trd Factor
Save As Trd Factor

Uses the normalized measurement data to generate a transducer factor. The trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under "c:\r_s\instr\trd". The frequency points are allocated in equidistant steps between start and stop frequency. The generated transducer factor can be further adapted using the "Transducer" softkey in the SETUP menu.

For more information on transducers see "Basics on Transducer Factors".

This function is only available if "Source Calibration Normalize" is switched on.

Note: Note that the normalized measurement data is used, not the reference trace! Thus, if you store the normalized trace directly after calibration, without changing any settings, the transducer factor will be 0 dB for the entire span (by definition of the normalized trace).

Remote command:

[SENSe:​]CORRection:​TRANsducer:​GENerator


Reference Position

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Reference Position
Reference Position

Defines the position of the "Result Frequency Stop" in percent of the total y-axis range. The top of the diagram is 100%, the bottom is 0%. By default, the 0 dB line is displayed at the top of the diagram (100%).

This setting is only available if normalization is on (see "Source Calibration Normalize").

The reference line defined by the reference value and reference position is similar to the "Reference Level" defined in the "Amplitude" settings. However, this reference line only affects the y-axis scaling in the diagram, it has no effect on the expected input power level or the hardware settings.

The normalized trace (0 dB directly after calibration) is displayed on this reference line, indicated by a red line in the diagram. If you shift the reference line, the normalized trace is shifted, as well.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Reference Value

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > External Generator Control Settings > Source Calibration Functions > Reference Value
Reference Value

Defines the reference value to be displayed at the specified "Result Frequency Start".

This setting can be used to shift the reference line and thus the normalized trace, similar to the "Shifting the Display (Offset)" defined in the "Amplitude" settings shifts the reference level in the display.

Shifting the normalized trace is useful, for example, to reflect an attenuation or gain caused by the measured DUT. If you then zoom into the diagram around the normalized trace, the measured trace still remains fully visible.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


How to Work With External Generator Control

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > How to Work With External Generator Control
How to Work With External Generator Control

The following step-by-step instructions demonstrate how to work with External Generator Control (R&S FSW-B10 option).

Contents
  • How to Calibrate a Measurement Setup using an External Generator
  • How to Remove the Effects of a Particular Component from Measurement Results Using Calibration
  • How to Compensate for Additional Gain or Attenuation after Calibration


How to Calibrate a Measurement Setup using an External Generator

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > How to Work With External Generator Control > How to Calibrate a Measurement Setup using an External Generator
How to Calibrate a Measurement Setup using an External Generator

  1. Connect the signal generator's GPIB interface connector to the EXT. GEN.CONTROL GPIB connector on the rear panel of the R&S FSW.

  2. Connect the signal generator output to the RF INPUT connector on the front panel of the R&S FSW.

  3. If the signal generator supports TTL synchronization, connect the signal generator to the FSW - B10 AUX.CONTROL port.

  4. If the measurement setup does not require the full span of the R&S FSW, change the "Frequency Start" and "Frequency Stop" values (FREQ key > "Frequency Config" softkey).

  5. Press the INPUT/OUTPUT key and select "External Generator Config".

  6. In the "Interface Configuration" subtab, select the "Generator Type" connected to the R&S FSW.

    If the required generator type is not available, define a new setup file as described in "To define a new generator setup file".

  7. Select the type of interface and the address used to connect the generator to the R&S FSW.

  8. If the generator supports "TTL Synchronization", activate this function.

  9. Select "Reference: External" to synchronize the analyzer with the generator.

  10. Switch to the "Measurement Configuration" subtab.

  11. Set the "Source State" to "On".

  12. Define the generator output level as the "Source Power".

  13. Optionally, to define a constant level offset for the external generator, define a "Source Offset".

  14. The default frequency list for the calibration sweep contains 1001 values, divided in equi-distant frequencies between the R&S FSW's start and stop frequency. For most cases, this automatic coupling should be correct. Check the "Result Frequency Start" and "Result Frequency Stop" values to make sure the required measurement span is covered. If necessary, change the frequency settings on the R&S FSW (FREQ key > "Frequency Config" softkey), or use a different generator type.

  15. Switch to the "Source Calibration" subtab.

  16. Select the "Source Calibration Type": "Transmission" to perform a calibration sweep and store a reference trace for the measurement setup.

  17. Select "Source Calibration Normalize": "On".

  18. Optionally, shift the reference line further down in the result display by descreasing the "Reference": "Position".

    The measurement setup is now calibrated. Subsequent measurement results are normalized, so that any unwanted effects from the cables and connectors are removed.

To define a new generator setup file

  1. Press the INPUT/OUTPUT key and select "External Generator Config".

  2. In the "Interface Configuration" subtab, select a generator type that has similar characteristics (frequency and power ranges).

  3. Select "Edit Generator Setup File".

    The configuration file for the selected generator type is displayed (read-only) in an editor.

  4. Edit the configuration values according to your generator. Be sure not to change the syntax of the file - only change the values of the parameters.

    Errors will only be detected and displayed when you try to use the new generator (see also "Displayed Information and Errors").

  5. Save the file under a different name with the extension .gen:

    1. In the editor, select "File > SaveAs".

    2. Select "Save as type: All Files (*.*)".

    3. Specify a name with the extension .gen.

  6. In the R&S FSW firmware, close the "External Generator Config" dialog and re-open it.

    Now you can select the new generator type from the selection list on the "Interface Configuration" tab.


How to Remove the Effects of a Particular Component from Measurement Results Using Calibration

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > How to Work With External Generator Control > How to Remove the Effects of a Particular Component from Measurement Results Using Calibration
How to Remove the Effects of a Particular Component from Measurement Results Using Calibration

  1. Set up the measurement, including the component, and perform a calibration as described in "How to Calibrate a Measurement Setup using an External Generator".

  2. After setting "Source Calibration Normalize": "On", select "Save as Trd Factor" to store the normalized reference trace as a transducer factor.

  3. If necessary, switch to another measurement channel for a different R&S FSW application.

  4. Press the SETUP key, then select the "Transducer" softkey.

  5. Select the stored transducer in the list of available transducers and select the "Active" setting for it.

  6. Perform any measurement with the setup that contains the calibrated component.

    The measurement results do not include the effects from the component.


How to Compensate for Additional Gain or Attenuation after Calibration

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > How to Work With External Generator Control > How to Compensate for Additional Gain or Attenuation after Calibration
How to Compensate for Additional Gain or Attenuation after Calibration

If a gain or an attenuation is inserted in the measurement after calibration, this effect can be reflected in the display of the normalized trace on the R&S FSW. Thus, the measured trace and the normalized trace are not so far apart in the display, so that you can zoom into the normalized trace without cropping the measurement trace.

Prerequisite: a calibration has been performed for the original measurement setup, except for the component causing an additional gain or attenuation (as described in "How to Calibrate a Measurement Setup using an External Generator")

  1. Insert the additional component in the calibrated measurement setup and perform a new measurement.

  2. Press the INPUT/OUTPUT key and select "External Generator Config".

  3. Switch to the "Source Calibration" subtab.

  4. With active normalization, set the "Reference":"Value" to the same value as the gain or attenuation the inserted component causes.

  5. Optionally, shift the reference line further down in the result display by decreasing the "Reference": "Position".

    The normalized reference trace moves to the position of the measured trace.

  6. Optionally, zoom into the measured trace by changing the y-axis scaling (or the range: "AMPT > Scale Config > Range").

    The measured trace is still fully visible, and the absolute values are still valid.


Measurement Example: Calibration with an External Generator

Common Measurement Settings > Data Input and Output > External Generator Control (Option R&S FSW-B10) > Measurement Example: Calibration with an External Generator
Measurement Example: Calibration with an External Generator

The following measurement example demonstrates the most common functions using an external generator. This example requires the External Generator Control (R&S FSW-B10) option.

The example assumes an SMU06 generator is connected to the R&S FSW. A band elimination filter is the device under test. After calibration, an additional attenuator is inserted between the DUT and the R&S FSW.

The following procedures are described:

  • "Calibrating the measurement setup"
  • "Measuring the effects of the DUT"
  • "Compensating the effects of additional attenuation after calibration"
Calibrating the measurement setup

  1. Connect the signal generator's GPIB interface connector to the EXT. GEN.CONTROL GPIB connector on the rear panel of the R&S FSW.

  2. Connect the signal generator output to the RF INPUT connector on the front panel of the R&S FSW.

  3. Adapt the measurement range of the R&S FSW to the filter to be tested. In this measurement, define the following settings:

    1. Press the FREQ key, select "Frequency Config" and enter "Frequency Start": 100 MHz.

    2. Enter "Frequency Stop": 300 MHz

  4. Press the INPUT/OUTPUT key and select "External Generator Config".

  5. In the "Interface Configuration" sub-tab, select "Generator Type":"SMU06".

  6. Select "Reference: External" to synchronize the analyzer with the generator.

  7. Switch to the "Measurement Configuration" sub-tab.

  8. Set the "Source State" to "On".

  9. Define the generator output level as the "Source Power": -20 dBm.

  10. Set the "Coupling State" to "Auto".

    The "Result Frequency Start" value for the generator is indicated as 100.0 MHz.

    The "Result Frequency Stop" value is indicated as 300.0 MHz.

  11. Switch to the "Source Calibration" sub-tab.

  12. Select the "Source Calibration Type": "Transmission" to perform a calibration sweep and store a reference trace for the measurement setup.

    Measurement results from generator, analyzer and connecting cables

  13. Select "Source Calibration Normalize": "On" to set the measurement results for the current setup to 0, thus eliminating all effects from the generator, the analyzer and the connecting cables from subsequent measurements with the band elimination filter.

    The reference line is displayed at 0 dB at the top of the diagram (100%).

    Normalized measurement results after calibration
Measuring the effects of the DUT

After calibration we can insert the band elimination filter (our DUT) in the measurement setup.

  1. Connect the signal generator output to the band elimination filter.

  2. Connect the band elimination filter output to the RF INPUT connector on the front panel of the R&S FSW.

    Band elimination filter results

  3. Shift the reference line from the top of the diagram to the middle of the diagram by changing the position of the reference point 0.0 dB to 50 %.

    In the "Source Calibration" tab, enter "Position": 50 %.

    At the same time, the range of the displayed y-axis moves from [-100.0 dB to 0 dB] to [-50 dB to +50 dB].

    Reference line shifted to middle of diagram (50%)
Compensating the effects of additional attenuation after calibration

After calibration, an additional attenuator is inserted between the DUT and the R&S FSW. This may be necessary, for example, to protect the analyzer's input connector. Nevertheless, we are only interested in the effects of the DUT, not those of the additional protective attenuator. Thus, we will compensate these effects in the result display on the R&S FSW by moving the reference line.

  1. Connect a 3 dB attenuator between the band elimination filter output and the RF INPUT connector on the R&S FSW.

    The measurement results are now 3 dB lower.

    Measurement results with additional attenuator

  2. In the "Source Calibration" tab, enter "Reference Value":-3 dB.

    The reference line is shifted down by 3 dB so that the measurement trace is displayed on the reference line again.

    At the same time, the scaling of the y-axis is changed: -3 dB are now shown at 50% of the diagram; the range is [-53 dB to +47 dB].

    Reference line with an offset of -3 dB and shifted to middle of diagram (50%)

  3. After the reference trace has been shifted, you can zoom into the measured trace to determine the offsets to the reference line, which represent the effects of the band elimination filter in the measurement setup.

    Change the y-axis scaling to 1 dB/div (or the range to 10 dB).

    1. Press the AMPT key, then select "Scale Config" > "Range".

    2. Enter 10 dB.

    Reference line with measurement results using larger scale


External Mixer (Option R&S FSW-B21)

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21)
External Mixer (Option R&S FSW-B21)

If the R&S FSW External Mixer option (R&S FSW-B21) is installed, an external mixer can be connected to the R&S FSW to increase the available frequency range. In this case, the input to measure is not taken from the RF input connector, but from the EXT MIXER connector(s).

Contents
  • Basics on External Mixers
  • External Mixer Settings
  • How to Work with External Mixers
  • Measurement Example: Using an External Mixer


Basics on External Mixers

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > Basics on External Mixers
Basics on External Mixers

Some background knowledge on basic terms and principles used with external mixers is provided here for a better understanding of the required configuration settings.

Contents
  • Frequency Ranges
  • Two-port and Three-port Mixers
  • Bias Current
  • Conversion Loss Tables
  • Automatic Signal Identification


Frequency Ranges

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > Basics on External Mixers > Frequency Ranges
Frequency Ranges

In a common spectrum analyzer, rather than providing one large (and thus inaccurate) filter, or providing several filters to cover the required frequency range of the input signal (at a high cost), a single, very accurate filter is used. Therefore, the input signal must be converted to the frequencies covered by the single accurate filter. This is done by a mixer, which converts and multiplies the frequency of the input signal with the help of the local oscillator (LO). The result is a higher and lower intermediate frequency (IF). The local oscillator can be tuned within the supported frequency range of the input signal.

In order to extend the supported frequency range of the input signal, an external mixer can be used. In this case, the LO frequency is output to the external mixer, where it is mixed with the RF input from the original input signal. In addition, the harmonics of the LO are mixed with the input signal, and converted to new intermediate frequencies. Thus, a wider range of frequencies can be obtained. The IF from the external mixer is then returned to the spectrum analyzer.

The frequency of the input signal can be expressed as a function of the LO frequency and the selected harmonic of the first LO as follows:

fin = n * fLO + fIF

where:

fin: frequency of input signal

n: order of harmonic used for conversion

fLO: frequency of first LO: 7.65 GHz to 17.45 GHz

fIF: intermediate frequency (variable; defined internally depending on RBW and span)

Thus, depending on the required frequency band, the appropriate order of harmonic must be selected. For commonly required frequency ranges, predefined-bands with the appropriate harmonic order setting are provided. By default, the lowest harmonic order is selected that allows conversion of input signals in the whole band.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 16.53 GHz.

The frequency ranges for pre-defined bands are described in table " Frequency ranges for pre-defined bands".

Changes to the band and mixer settings are maintained even after using the PRESET function. A "Preset band" function allows you to restore the original band settings.

Extending predefined ranges

In some cases, the harmonics defined for a specific band allow for an even larger frequency range than the band requires. By default, the pre-defined range is used. However, you can take advantage of the extended frequency range by overriding the defined start and stop frequencies by the maximum possible values ("RF Overrange" option).

Additional ranges

If due to the LO frequency the conversion of the input signal is not possible using one harmonic, the band must be split. An adjacent, partially overlapping frequency range can be defined using different harmonics. In this case, the sweep begins using the harmonic defined for the first range, and at a specified frequency in the overlapping range ("handover frequency"), switches to the harmonic for the second range.

Which harmonics are supported depends on the mixer type.


Two-port and Three-port Mixers

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > Basics on External Mixers > Two-port and Three-port Mixers
Two-port and Three-port Mixers

External mixers are connected to the R&S FSW at the LO OUT/IF IN and IF IN connectors.

When using three-port mixers, the LO signal output from the R&S FSW and the IF input from the mixer are transmitted on separate connectors, whereas for two-port mixers, both signals are exchanged via the same connector (LO OUT/IF IN). Because of the diplexer contained in the R&S FSW, the IF signal can be tapped from the line which is used to feed the LO signal to the mixer.

Two-port mixer | Three-port mixer

In both cases, the nominal LO level is 15.5 dBm.


Bias Current

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > Basics on External Mixers > Bias Current
Bias Current

Single-diode mixers generally require a DC voltage which is applied via the LO line. This DC voltage is to be tuned to the minimum conversion loss versus frequency. Such a DC voltage can be set via the "BIAS" function using the D/A converter of the R&S FSW. The value to be entered is not the voltage but the short-circuit current. The current is defined in the "Bias Settings" or set to the value of the conversion loss table (see "Bias Settings" and "Bias".

Bias circuit of the R&S FSW

The voltage U0 at the output of the operational amplifier can be set in the range –2.0 to +2.0 V. An open-circuit voltage Vbias of –0.5 to +0.5 V is obtained accordingly at the output of the voltage divider. A short-circuit current of Ishort = V0 / 200 Ω = 10 mA to + 10 mA is obtained for a short circuit at the output of the voltage divider. In order to use biasing it is not important to know the exact current flowing through the diode since the conversion loss must be set to a minimum with the frequency. Therefore, it makes no difference whether the setting is performed by an open-circuit voltage or by a short-circuit current. A DC return path is ensured via the 66 Ω resistor, which is an advantage in some mixers.


Conversion Loss Tables

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > Basics on External Mixers > Conversion Loss Tables
Conversion Loss Tables

Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value (see figure "Conversion loss outside the band's frequency range").

Conversion loss outside the band's frequency range

Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Conversion loss tables are configured and managed in the "Conversion loss Table Settings" tab of the "External Mixer Configuration" dialog box (see "Managing Conversion Loss Tables").

Importing CVL tables

The conversion loss table to be used for a particular range is also defined in the "External Mixer Configuration" dialog box. All tables stored on the instrument in the C:\r_s\instr\user\cvl\ directory are offered for selection. A validation check is then performed on the selected table to ensure that it complies with the settings. In particular, the following is checked:

  • the assigned band name
  • the harmonic order
  • the mixer type
  • the table must contain at least one frequency that lies within the frequency range for the band
Reference level

The maximum possible reference level depends on the maximum used conversion loss value. Thus, the reference level can be adjusted for each range according to the used conversion loss table or average conversion loss value. If a conversion loss value is used which exceeds the maximum reference level, the reference level is adjusted to the maximum value permitted by the firmware.


Automatic Signal Identification

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > Basics on External Mixers > Automatic Signal Identification
Automatic Signal Identification

Automatic signal identification allows you to compare the upper and lower band results of the mixer, thus detecting unwanted mixer products due to conversion.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Signal ID function

Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

The reference sweep is performed using an LO setting shifted downwards by 2*IF/<Harmonic order>. Input signals in the desired sideband that are converted using the specified harmonic are displayed in both traces at the same position on the frequency axis. Image signals and mixer products caused by other harmonics are displayed at different positions in both traces. The user identifies the signals visually by comparing the two traces.

Since the LO frequency is displaced downwards in the reference sweep, the conversion loss of the mixer may differ from the test sweep. Therefore the signal level should only be measured in the test sweep (trace 1).

Auto ID function

The Auto ID fucntion basically functions like "Signal ID function". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Test sweep and reference sweep traces

Depending on which of the automatic signal identification functions are used, the traces are used to display either the test sweep (the upper side-band sweep) or the reference sweep (lower side-band sweep).

Function | Trace 1 | Trace 2 | Trace 3
Signal ID | Signal ID upper side-band | Signal ID lower side-band | -
Auto ID | Auto ID | - | -
Signal ID + Auto ID | Signal ID upper side-band | Signal ID lower side-band | Auto ID
Tolerance for the comparison of test sweep and reference

Since the LO frequency is displaced downwards in the reference sweep, the conversion loss of the mixer may differ from that of the test sweep. This is due to the fact that the LO output power of the R&S FSW varies with the frequency, and also due to the non-ideal characteristics of the mixer. A certain tolerance should therefore be permitted for the comparison of the signal levels in the test sweep and reference sweep. A user-defined threshold is used to determine deviations.

Auto ID detection threshold

Real input signals are displayed at the same frequency in the test and reference sweeps, i.e. theoretically, identical signal levels are expected at the frequency of the real mixer product in both sweeps. If the level difference is lower than the the user-defined threshold, the signal obtained in the test sweep is displayed. If a signal occurs only in the test sweep or reference sweep, it is an unwanted mixer product. The level of this signal is compared to the noise floor in the other sweep. If the S/N ratio is sufficiently large, the threshold is exceeded. This means that the signal with the lower level, i.e. noise in this case, is displayed.

Note that the Auto ID method operates according to the fail-safe principle, i.e. unwanted mixer products may not be detected as such but signals which are in fact real input signals are not blanked out.

Time-constant spectrum

The automatic comparison of the test sweep and reference sweep with the Auto ID function can only be applied usefully for signals with a time-constant spectrum since the two sweeps are always required to determine the actual spectrum.

Mixer products with low S/N ratio

If the S/N ratio of a mixer product is lower than the user-defined thereshold, the level difference between the test sweep and reference sweep at the frequency of this mixer product is always within limits, even if the signal occurs in one of the sweeps only. Such mixer products cannot be identified by the Auto ID function. It is therefore recommended that you perform a visual comparison of the test sweep and reference sweep using the Signal ID function.

Examining unwanted mixer products with small span

With large spans in which non-modulated sinewave signals are represented as single lines, unwanted mixer products are generally completely blanked out. However, if you examine the frequency range containing a blanked signal in detail using a small span, e.g. an image-frequency response, part of the signal may nevertheless be displayed. This happens when the displayed components of a blanked signal have a level difference which is smaller than the user-defined threshold when compared with the noise floor. These components are therefore not blanked out.

An unwanted signal with a S/N ratio that corresponds approximately to the user-defined threshold may not be blanked out permanently. Due to the fact that the noise display varies from one sweep to another, the S/N ratio changes and thus the level difference between the test sweep and reference sweep measured at a frequency changes as well. As a result, the criterion for detecting unwanted signals is not fulfilled. To blank out unwanted signals permanently, an almost constant noise indication is therefore required. This can be achieved by reducing the video bandwidth. Since the average noise indication lies well below the generated noise peak values, the minimum level diminishes. For identification using the Auto ID function, signals should have this minimum noise level.

Display of mixer products at the same frequency

If the input signal consists of a very large number of spectral components, it will become more and more probable that two different unwanted mixer products will be displayed at the same frequency in the test sweep and reference sweep.

Different mixer products displayed at the same frequency in the test sweep and reference sweep (large span)
Example:

The external mixer is set to use the 2nd order harmonic. The signal recorded in the test sweep is displayed by trace 1. The IF filter of the R&S FSW is represented at a 3 dB bandwidth of 20 kHz, the real IF bandwidth being 30 kHz. If, however, the 3 dB bandwidth of the signal recorded in the reference sweep is examined (trace 2), it will be found to be larger exactly by a factor of 2. This shows that the two products were generated by mixing with LO harmonics of different orders. The signal recorded in the test sweep was generated by mixing with the 3rd order harmonic. Since the frequency axis scaling is based on the 2nd order, the mixer product or the resulting diagram of the IF filter is compressed by a factor of 2/3. The signal recorded in the reference sweep was generated by mixing with the fundamental of the LO signal. Since the frequency axis scaling is based on the 2nd order, the mixer product or the resulting diagram of the IF filter is expanded by a factor of 2.

Automatic identification with a large span is not possible since the two mixer products are displayed at the same frequency. The diagram shown in figure "Unwanted mixer products displayed for small span" is obtained when examining products with a narrow span using the Auto ID function. You can easily recognize unwanted mixer products in the diagram obtained using one of the automatic detection functions.

Unwanted mixer products displayed for small span


External Mixer Settings

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings
External Mixer Settings

The external mixer is configured in the "External Mixer" tab of the "Input" dialog box which is available when you do one of the following, if the R&S FSW-B21 option is installed:

  • Press the INPUT/OUTPUT key, then select the "External Mixer Config" softkey.
  • From the "Overview", select "Input", then switch to the "External Mixer" tab under "Input Source".

Note that external mixers are not supported in MSRA/MSRT mode.

Contents
  • Mixer Settings
  • Basic Settings
  • Managing Conversion Loss Tables
  • Creating and Editing Conversion Loss Tables


Mixer Settings

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings
Mixer Settings

In this tab you configure the band and specific mixer settings.

└ External Mixer State
└ RF Start / RF Stop
└ Handover Freq.
└ Band
└ RF Overrange
└ Preset Band
└ Mixer Type
└ Mixer Settings (Harmonics Configuration)
└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


External Mixer State

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


RF Start / RF Stop

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > RF Start / RF Stop
RF Start / RF Stop

Displays the start and stop frequency of the selected band (read-only).

The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges".

For details on available frequency ranges see table " Frequency ranges for pre-defined bands".

Remote command:

[SENSe:​]MIXer:​FREQuency:​STARt?

[SENSe:​]MIXer:​FREQuency:​STOP?


Handover Freq.

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Handover Freq.
Handover Freq.

Defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency can be selected freely within the overlapping frequency range.

For details see "Frequency Ranges".

Remote command:

[SENSe:​]MIXer:​FREQuency:​HANDover


Band

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Band
Band

Defines the waveguide band or user-defined band to be used by the mixer.

The start and stop frequencies of the selected band are displayed in the "RF Start" and "RF Stop" fields.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

The mixer settings for the user-defined band can be selected freely. The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges".

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND[:​VALue]


RF Overrange

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > RF Overrange
RF Overrange

If enabled, the frequency range is not restricted by the band limits ("RF Start" and "RF Stop"). In this case, the full LO range of the selected harmonics is used.

For details see "Frequency Ranges".

Remote command:

[SENSe:​]MIXer:​RFOVerrange[:​STATe]


Preset Band

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Preset Band
Preset Band

Restores the presettings for the selected band.

Note: changes to the band and mixer settings are maintained even after using the PRESET function. This function allows you to restore the original band settings.

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND:​PRESet


Mixer Type

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Mixer Type
Mixer Type

The R&S FSW option B21 supports the following external mixer types:

(See also "Two-port and Three-port Mixers")

"2 Port" | LO and IF data use the same port
"3 Port" | LO and IF data use separate ports
Remote command:

[SENSe:​]MIXer:​PORTs


Mixer Settings (Harmonics Configuration)

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration)
Mixer Settings (Harmonics Configuration)

The harmonics configuration determines the frequency range for user-defined bands (see "Band").

See also "Frequency Ranges".

└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


Harmonic Type

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Type
Harmonic Type

Defines if only even, only odd, or even and odd harmonics can be used for conversion. Depending on this selection, the order of harmonic to be used for conversion changes (see "Harmonic Order"). Which harmonics are supported depends on the mixer type.

See also "Frequency Ranges".

Remote command:

[SENSe:​]MIXer:​HARMonic:​TYPE


Range 1/2

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Range 1/2
Range 1/2

Enables the use of a second harmonic to cover the band's frequency range.

For each range you can define which harmonic to use and how the "Conversion loss" is handled.

See also "Frequency Ranges".

Remote command:

[SENSe:​]MIXer:​HARMonic:​HIGH:​STATe


Harmonic Order

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Order
Harmonic Order

Defines which of the available harmonic orders of the LO is used to cover the frequency range.

By default, the lowest order of the specified harmonic type is selected that allows conversion of input signals in the whole band. If due to the LO frequency the conversion is not possible using one harmonic, the band is split.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 26.5 GHz.

See also "Frequency Ranges".

Remote command:

[SENSe:​]MIXer:​HARMonic[:​LOW]

[SENSe:​]MIXer:​HARMonic:​HIGH[:​VALue]


Conversion loss

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Conversion loss
Conversion loss

Defines how the conversion loss is handled. The following methods are available:

"Average" | Defines the average conversion loss for the entire range in dB.
"Table" | Defines the conversion loss via the table selected from the list. Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Imported tables are checked for compatibility with the current settings before being assigned. Conversion loss tables are configured and managed in the "Managing Conversion Loss Tables" tab. For details on conversion loss tables, see "Conversion Loss Tables". For details on importing tables, see "Import Table".
Remote command:

Average for range 1:

[SENSe:​]MIXer:​LOSS[:​LOW]

Table for range 1:

[SENSe:​]MIXer:​LOSS:​TABLe[:​LOW]

Average for range 2:

[SENSe:​]MIXer:​LOSS:​HIGH

Table for range 2:

[SENSe:​]MIXer:​LOSS:​TABLe:​HIGH


Basic Settings

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings
Basic Settings

The basic settings concern general use of an external mixer. They are only available if the "External Mixer State" is "On".

└ External Mixer State
└ LO Level
└ Signal ID
└ Auto ID
└ Auto ID Threshold
└ Bias Settings
└ Write to <CVL table name>


External Mixer State

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


LO Level

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings > LO Level
LO Level

Defines the LO level of the external mixer's LO port. Possible values are from 13.0 dBm to 17.0 dBm in 0.1 dB steps. Default value is 15.5 dB.

Remote command:

[SENSe:​]MIXer:​LOPower


Signal ID

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings > Signal ID
Signal ID

Activates or deactivates visual signal identification. Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

(See also "Automatic Signal Identification").

Mathematical functions with traces and trace copy cannot be used with the Signal ID function.

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings > Auto ID
Auto ID

Activates or deactivates automatic signal identification.

Auto ID basically functions like "Signal ID". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

See also "Automatic Signal Identification".

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID Threshold

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings > Auto ID Threshold
Auto ID Threshold

Defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison ("Auto ID" function). The input range is between 0.1 dB and 100 dB. Values of about 10 dB (i.e. default setting) generally yield satisfactory results.

See also "Automatic Signal Identification".

Remote command:

[SENSe:​]MIXer:​THReshold


Bias Settings

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings > Bias Settings
Bias Settings

Define the bias current for each range, which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

The trace is adapted to the settings immediately so you can check the results. To store the bias setting in the currently selected conversion loss table, select the "Write to <CVL table name>" button.

Remote command:

[SENSe:​]MIXer:​BIAS[:​LOW]

[SENSe:​]MIXer:​BIAS:​HIGH

└ Write to <CVL table name>


Write to <CVL table name>

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Basic Settings > Bias Settings > Write to <CVL table name>
Write to <CVL table name>

Stores the bias setting in the currently selected "Conversion loss table" for the range (see "Managing Conversion Loss Tables"). If no conversion loss table is selected yet, this function is not available ("CVL Table not selected").

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Managing Conversion Loss Tables

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Managing Conversion Loss Tables
Managing Conversion Loss Tables

In this tab you configure and manage conversion loss tables. Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. The correction values for frequencies between the reference points are obtained via interpolation.

The currently selected table for each range is displayed at the top of the dialog box. All conversion loss tables found in the instrument's C:\r_s\instr\user\cvl\ directory are listed in the "Modify Tables" list.

└ External Mixer State
└ New Table
└ Edit Table
└ Delete Table
└ Import Table


External Mixer State

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Managing Conversion Loss Tables > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


New Table

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Managing Conversion Loss Tables > New Table
New Table

Opens the "Edit Conversion loss table" dialog box to configure a new conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Edit Table

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Managing Conversion Loss Tables > Edit Table
Edit Table

Opens the "Edit Conversion loss table" dialog box to edit the selected conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Delete Table

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Managing Conversion Loss Tables > Delete Table
Delete Table

Deletes the currently selected conversion loss table after you confirm the action.

Remote command:

[SENSe:​]CORRection:​CVL:​CLEAr


Import Table

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Managing Conversion Loss Tables > Import Table
Import Table

Imports a stored conversion loss table from any directory and copies it to the instrument's C:\r_s\instr\user\cvl\ directory. It can then be assigned for use for a specific frequency range (see "Conversion loss").

For details see "Conversion Loss Tables".


Creating and Editing Conversion Loss Tables

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables
Creating and Editing Conversion Loss Tables

Conversion loss tables can be defined and edited in the "Edit conversion loss table" dialog box which is displayed when you select the "New Table" button in the "External Mixer > Conversion loss table" settings.

A preview pane displays the current configuration of the conversion loss function as described by the position/value entries.

└ File Name
└ Comment
└ Band
└ Harmonic Order
└ Bias
└ Mixer Name
└ Mixer S/N
└ Mixer Type
└ Position/Value
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


File Name

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > File Name
File Name

Defines the name under which the table is stored in the C:\r_s\instr\user\cvl\ directory on the instrument. The name of the table is identical with the name of the file (without extension) in which the table is stored. This setting is mandatory. The .ACL extension is automatically appended during storage.

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Comment

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Comment
Comment

An optional comment that describes the conversion loss table. The comment can be freely defined by the user.

Remote command:

[SENSe:​]CORRection:​CVL:​COMMent


Band

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Band
Band

The waveguide or user-defined band for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

Remote command:

[SENSe:​]CORRection:​CVL:​BAND


Harmonic Order

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Harmonic Order
Harmonic Order

The harmonic order of the range for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​HARMonic


Bias

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Bias
Bias

The bias current which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

Tip: You can also define the bias interactively while a preview of the trace with the changed setting is displayed, see "Bias Settings".

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Mixer Name

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Name
Mixer Name

Specifies the name of the external mixer for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​MIXer


Mixer S/N

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer S/N
Mixer S/N

Specifies the serial number of the external mixer for which the table is to be applied.

This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​SNUMber


Mixer Type

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Type
Mixer Type

Specifies whether the external mixer for which the table is to be applied is a two-port or three-port type. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​PORTs


Position/Value

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Position/Value
Position/Value

Each position/value pair defines the correction value for conversion loss for a specific frequency. The reference values must be entered in order of increasing frequencies. A maximum of 50 reference values can be entered. To enter a new value pair, select the "Position/Value" table, or select the "Insert Value" button.

Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value.

(See "Conversion Loss Tables".)

The current configuration of the conversion loss function as described by the position/value entries is displayed in the preview pane to the right of the table.

Remote command:

[SENSe:​]CORRection:​CVL:​DATA


Insert Value

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Insert Value
Insert Value

Inserts a new position/value entry in the table.

If the table is empty, a new entry at 0 Hz is inserted.

If entries already exist, a new entry is inserted above the selected entry. The position of the new entry is selected such that it divides the span to the previous entry in half.


Delete Value

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Delete Value
Delete Value

Deletes the currently selected position/value entry.


Shift x

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift x
Shift x

Shifts all positions in the table by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the x-axis.


Shift y

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift y
Shift y

Shifts all conversion loss values by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the y-axis.


Save

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > External Mixer Settings > Creating and Editing Conversion Loss Tables > Save
Save

The conversion loss table is stored under the specified name in the C:\r_s\instr\user\cvl\ directory of the instrument.


How to Work with External Mixers

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > How to Work with External Mixers
How to Work with External Mixers

The required tasks to work with external mixers are described step-by-step:

  • "To connect a three-port mixer"
  • "To connect a two-port mixer"
  • "To activate and configure the external mixer"
  • "To define a new conversion loss table"
  • "To shift the conversion loss values"
To connect a three-port mixer

External mixers can be connected at the LO OUT/IF IN and IF IN female connectors (option R&S FSW-B21). Both two-port and three-port mixers can be used. Connect the mixer as follows:

Use the supplied coaxial cable to feed in the LO signal. If no external mixers are connected to the R&S FSW, cover the two front connectors LO OUT / IF IN and IF IN with the SMA caps supplied.

  1. Connect the LO OUT / IF IN output of the R&S FSW to the LO port of the external mixer.

  2. Connect the IF IN input of the R&S FSW to the IF port of the external mixer.

  3. Feed the signal to be measured to the RF input of the external mixer.

To connect a two-port mixer

  1. 1. Connect the LO OUT / IF IN output of the R&S FSW to the LO/IF port of the external mixer. The nominal LO level is 15.5 dBm.

    Because of the diplexer contained in the R&S FSW, the IF signal can be tapped from the line which is used to feed the LO signal to the mixer.

  2. Feed the signal to be measured to the RF input of the external mixer.

To activate and configure the external mixer

  1. Select "INPUT > Input Source Config > External Mixer: ON" to activate the external mixer for the current application.

  2. Select "Mixer Settings > Band" to define the required frequency range.

  3. From the "Band" selection list, select the required band.

  4. In the Mixer Settings, select "Conversion Loss: Table" for Range 1 to define frequency-dependent level correction.

  5. From the selection list, select a conversion loss table stored on the instrument. No further settings are necessary since the selected file contains all required parameters. If the selected table is not valid for the selected band, an error message is displayed.

    If no conversion loss table is available yet, create a new table first (as described in "To define a new conversion loss table").

  6. Optionally, select "Basic Settings> Auto ID: On" to activate automatic signal identification.

  7. If necessary, adapt the tolerance limit by selecting "Basic Settings> Auto ID Threshold".

To define a new conversion loss table

  1. Select "INPUT > Input Source Config > External Mixer > Conversion Loss Table".

  2. Select "New Table".

  3. Define a file name and, optionally, a comment for the new table.

  4. Define the band and mixer settings for which the conversion loss table is to be used. These settings will be compared to the current mixer settings during the validation check when the table is imported.

  5. Define the reference values for the frequency-dependant conversion loss:

    1. Select "Insert Value" to add a new row in the table.

    2. Enter the first reference frequency.

    3. Enter the corresponding conversion loss value.

      The conversion loss function is updated and displayed in the preview diagram in the dialog box.

    4. Repeat these steps to define up to 50 reference values.

  6. Select "Save".

    The table is stored and is then available for import and assignment to a specific frequency range.

To shift the conversion loss values

In order to increase each reference value in the conversion-loss table a constant value (a0), the values can be shifted either in x-directoin or in y-direction.

  1. Select "INPUT > Input Source Config > External Mixer > Conversion Loss Table".

  2. Select the assigned conversion loss table.

  3. Select "Edit Table".

  4. Select "Shift y" and enter the constant value <a0> to shift all y-values in the table by this value.

    Or:

    Select "Shift x" and enter the constant value <a0> to shift all x-values in the table by this value.

  5. Select "Save".


Measurement Example: Using an External Mixer

Common Measurement Settings > Data Input and Output > External Mixer (Option R&S FSW-B21) > Measurement Example: Using an External Mixer
Measurement Example: Using an External Mixer

The following example demonstrates the operation of external mixers as well as the required settings. A sine wave signal with f = 14.5 GHz is applied to the input of a multiplier. The spectrum at the multiplier output is to be recorded in the range of 52 GHz to 60 GHz using a 2-port mixer for the V band. The mixer used is a double-diode mixer. The example of operation is described in the following steps:

  • "To set up the measurement"
  • "To activate and configure the external mixer"
  • "To take into account the cable loss in the IF path"
To set up the measurement
External Mixer test setup

  1. 1. Connect the LO OUT / IF IN output of the R&S FSW to the LO/IF port of the external mixer.

  2. Connect the multiplier to the RF input of the external mixer.

  3. Apply a sine wave signal with f = 14.5 GHz to the input of the multiplier.

To activate and configure the external mixer

  1. Select "INPUT > Input Source Config > External Mixer: ON" to activate the external mixer for the current application.

  2. Select "Mixer Settings > Band" to define the required frequency range.

  3. From the "Band" selection list, select the band "V".

  4. In the Mixer Settings, select "Conversion Loss: Table" for Range 1 to define frequency-dependent level correction.

  5. From the selection list, select a conversion loss table stored on the instrument. No further settings are necessary since the selected file contains all required parameters. If the selected table is not valid for the selected band, an error message is displayed.

    If no conversion loss table is available yet, create a new table first (as described in "To define a new conversion loss table").

  6. A span is automatically set which covers the whole V band (50 to 75 GHz).

  7. Reduce the video bandwidth by selecting "BW > Video Bandwidth Manual"=1 MHz. This allows for correct signal identification using the Auto ID function (see also "Automatic Signal Identification").

  8. Select "Basic Settings> Auto ID: On" to activate automatic signal identification.

  9. Adapt the tolerance limit by selecting "Basic Settings> Auto ID Threshold". The tolerance limit is set to 5 dB in this example.

To take into account the cable loss in the IF path

On performing level correction, the conversion loss of the mixer and also the insertion loss a0 of the cable used to tap off the IF signal are to be taken into account. This additional loss is frequency-dependent.

  1. Determine the insertion of the cable at the used intermediate frequency.

  2. Increase each reference value in the conversion-loss table by the insertion loss (a0).

    1. Select "INPUT > Input Source Config > External Mixer > Conversion Loss Table".

    2. Select the assigned conversion loss table.

    3. Select "Edit Table".

    4. Select "Shift y" and enter the insertion loss value <a0> to shift all y-values in the table by this value.

  3. Select "Save".


Output Settings

Common Measurement Settings > Data Input and Output > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour".

Providing trigger signals as output is described in "How to Output a Trigger Signal".

Providing output for LISN control in EMI measurements is described in "LISN Control Settings".

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ IF/VIDEO/DEMOD Output
└ IF (Wide) Out Frequency
└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


IF/VIDEO/DEMOD Output

Common Measurement Settings > Data Input and Output > Output Settings > IF/VIDEO/DEMOD Output
IF/VIDEO/DEMOD Output

Defines the type of signal available at the IF/VIDEO/DEMOD or IF OUT connector on the rear panel of the R&S FSW.

For restrictions and additional information see "IF and Video Signal Output".

"IF" | The measured IF value is available at the IF/VIDEO/DEMOD output connector. The frequency at which this value is available is defined in "IF (Wide) Out Frequency".
"IF 2 GHz Out" | The measured IF value is available at the IF OUT output connector at a frequency of 2 GHz (with a bandwidth of 2 GHz). This setting is only available for instrument models R&S FSW43/50/67. For further prerequisites see "IF 2 GHz Output".
"VIDEO" | The displayed video signal (i.e. the filtered and detected IF signal) is available at the IF/VIDEO/DEMOD output connector. This setting is required to provide demodulated audio frequencies at the output.
Remote command:

OUTPut:​IF[:​SOURce]

OUTPut:​IF:​SBANd?


IF (Wide) Out Frequency

Common Measurement Settings > Data Input and Output > Output Settings > IF (Wide) Out Frequency
IF (Wide) Out Frequency

Defines or indicates the frequency at which the IF signal level is provided at the IF/VIDEO/DEMOD connector if "IF/VIDEO/DEMOD Output" is set to "IF".

Note: The IF output frequency of the IF WIDE OUTPUT connector cannot be defined manually, but is determined automatically depending on the center frequency. It is indicated in this field when the IF WIDE OUTPUT connector is used. For details on the used frequencies see the data sheet.
The IF WIDE OUTPUT connector is used automatically instead of the IF/VIDEO/DEMOD connector if the bandwidth extension (hardware option R&S FSW-B160 / -U160) is activated (i.e. for bandwidths > 80 MHz).
If the IF 2 GHZ OUT output is activated, the measured IF value is provided at a fixed frequency of 2 GHz.

For more information see "IF and Video Signal Output".

Remote command:

OUTPut:​IF:​IFFRequency


Noise Source

Common Measurement Settings > Data Input and Output > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

For details see "Input from Noise Sources"

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

Common Measurement Settings > Data Input and Output > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal".

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

Common Measurement Settings > Data Input and Output > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9). For details see "STATus:OPERation Register" and the R&S FSW Getting Started manual.
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

Common Measurement Settings > Data Input and Output > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

Common Measurement Settings > Data Input and Output > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

Common Measurement Settings > Data Input and Output > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Frequency and Span Configuration

Common Measurement Settings > Frequency and Span Configuration
Frequency and Span Configuration

The frequency and span settings define the scope of the signal and spectrum to be analyzed with the R&S FSW.

Contents
  • Impact of the Frequency and Span Settings
  • Frequency and Span Settings
  • How To Define the Frequency Range
  • How to Move the Center Frequency through the Frequency Range
  • How to Keep the Center Frequency Stable


Impact of the Frequency and Span Settings

Common Measurement Settings > Frequency and Span Configuration > Impact of the Frequency and Span Settings
Impact of the Frequency and Span Settings

Some background knowledge on the impact of the described settings is provided here for a better understanding of the required configuration.

Contents
  • Defining the Scope of the Measurement - Frequency Range
  • Stepping Through the Frequency Range - Center Frequency Stepsize
  • Keeping the Center Frequency Stable - Signal Tracking
  • Coping with Large Frequency Ranges - Logarithmic Scaling


Defining the Scope of the Measurement - Frequency Range

Common Measurement Settings > Frequency and Span Configuration > Impact of the Frequency and Span Settings > Defining the Scope of the Measurement - Frequency Range
Defining the Scope of the Measurement - Frequency Range

The frequency range defines the scope of the signal and spectrum to be analyzed. It can either be defined as a span around a center frequency, or as a range from a start to a stop frequency. Furthermore, the full span comprising the entire possible frequency range can be selected, or a zero span. The full span option allows you to perform an overview measurement over the entire span. Using the "Last Span" function you can easily switch back to the detailed measurement of a specific frequency range.

For sinusoidal signals, the center frequency can be defined automatically by the R&S FSW as the highest frequency level in the frequency span (see "Adjusting the Center Frequency Automatically (Auto Freq)").


Stepping Through the Frequency Range - Center Frequency Stepsize

Common Measurement Settings > Frequency and Span Configuration > Impact of the Frequency and Span Settings > Stepping Through the Frequency Range - Center Frequency Stepsize
Stepping Through the Frequency Range - Center Frequency Stepsize

Using the arrow keys you can move the center frequency in discrete steps through the available frequency range. The step size by which the center frequency is increased or decreased is defined by the "Center Frequency Stepsize".

The "Center Frequency Stepsize" also defines the step size by which the value is increased or decreased when you use the rotary knob to change the center frequency; however, the rotary knob moves in steps of only 1/10 of the "Center Frequency Stepsize" to allow for a more precise setting.

By default, the step size is set in relation to the selected span or resolution bandwidth (for zero span measurements). In some cases, however, it may be useful to set the step size to other values.

For example, to analyze signal harmonics, you can define the step size to be equal to the center frequency. In this case, each stroke of the arrow key selects the center frequency of another harmonic. Similarly, you can define the step size to be equal to the current marker frequency.


Keeping the Center Frequency Stable - Signal Tracking

Common Measurement Settings > Frequency and Span Configuration > Impact of the Frequency and Span Settings > Keeping the Center Frequency Stable - Signal Tracking
Keeping the Center Frequency Stable - Signal Tracking

If the signal drifts on the display but you want to keep the center frequency on the signal peak, the center frequency can be adjusted automatically using signal tracking. In this case, the signal trace is surveyed in a specified bandwidth around the expected center frequency. After each sweep, the center frequency is set to the maximum signal found within the searched bandwidth. If no maximum signal above a defined threshold value is found in the searched bandwidth, the center frequency remains unchanged. The search bandwidth and the threshold value are shown in the diagram by red lines which are labeled as "TRK".


Coping with Large Frequency Ranges - Logarithmic Scaling

Common Measurement Settings > Frequency and Span Configuration > Impact of the Frequency and Span Settings > Coping with Large Frequency Ranges - Logarithmic Scaling
Coping with Large Frequency Ranges - Logarithmic Scaling

In a linear display, the frequencies are distributed linearly across the x-axis. That means the entire frequency range is divided by the number of sweep points, and the distance between sweep points is equal. Linear scaling is useful to determine precise frequencies within a small range.

Linear x-axis scaling: the distance between the sweep points is equal, e.g. 200 kHz

However, if high and low frequencies appear in the same display, it is difficult to determine individual frequencies precisely or to distinguish frequencies that are close together.

In a logarithmic display, lower frequencies are distributed among a much larger area of the display, while high frequencies are condensed to a smaller area. Now it is much easier to distinguish several lower frequencies, as they are spread over a wider area. Logarithmic scaling is useful for overview measurements when a large frequency range must be displayed in one diagram.

However, with logarithmic scaling, the frequency resolution between two sweep points deteriorates with higher frequencies.

Logarithmic x-axis scaling: the distance between sweep points is variable

In the spectrum from 10 Hz to 100 Hz, the distance is a few Hz. Between 100 MHz and 1 GHz, the distance is several MHz.

Thus, for logarithmic x-axis scaling, the number of sweep points must be sufficiently high in order to distinguish high frequencies precisely. The resolution bandwidth should cover at least one sweep point (that means: the distance between two sweep points should not exceed the RBW). If this condition is not met, signals or interferers could be missed, especially narrowband interferers.


Frequency and Span Settings

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings
Frequency and Span Settings

Frequency and span settings can be configured via the "Frequency" dialog box. Signal tracking is configured in the "Signal Tracking" tab of this dialog box. For details see "How To Define the Frequency Range".

└ Center frequency
└ Span
└ Start / Stop
└ Frequency Axis Scaling
└ Full Span
└ Zero Span
└ Last Span
└ Center Frequency Stepsize
└ Frequency Offset
└ Signal Tracking
└ Signal Tracking State
└ Tracking Bandwidth
└ Tracking Threshold
└ Signal Track Trace


Center frequency

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

zero span: 0 Hz ≤ fcenter ≤ fmax

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Span

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Span
Span

Defines the frequency span. The center frequency is kept constant. The following range is allowed:

span = 0: 0 Hz

span >0:

spanmin ≤ f span ≤ f max

fmax and spanmin are specified in the data sheet.

For more information see "Defining the Scope of the Measurement - Frequency Range".

Remote command:

[SENSe:​]FREQuency:​SPAN


Start / Stop

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Start / Stop
Start / Stop

Defines the start and stop frequencies. The following range of values is allowed:

fmin ≤ fstart ≤ fmax – spanmin

fmin + spanmin ≤ fstop ≤ fmax

fmin, fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​STARt

[SENSe:​]FREQuency:​STOP


Full Span

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Full Span
Full Span

Sets the span to the full frequency range of the R&S FSW specified in the data sheet. This setting is useful for overview measurements.

Remote command:

[SENSe:​]FREQuency:​SPAN:​FULL


Zero Span

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Zero Span
Zero Span

Sets the span to 0 Hz (zero span). The x-axis becomes the time axis with the grid lines corresponding to 1/10 of the current sweep time ("SWT").

For details see "Basic Measurements".

Remote command:

FREQ:SPAN 0Hz, see [SENSe:​]FREQuency:​SPAN:​FULL


Last Span

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Last Span
Last Span

Sets the span to the previous value. With this function you can switch between an overview measurement and a detailed measurement quickly.

Remote command:

[SENSe:​]FREQuency:​SPAN


Center Frequency Stepsize

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to the span (span > 0) or the resolution bandwidth (span = 0), or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize".

"0.1 * Span / RBW" | Sets the step size for the center frequency to 10 % of the span / RBW. This is the default setting.
"0.5 * Span / RBW" | Sets the step size for the center frequency to 50 % of the span / RBW.
"X * Span / RBW" | Sets the step size for the center frequency to a manually defined factor of the span / RBW. The "X-Factor" defines the percentage of the span / RBW. Values between 1 and 100 % in steps of 1 % are allowed. The default setting is 10 %.
"= Center" | Sets the step size to the value of the center frequency and removes the coupling of the step size to span or resolution bandwidth. The used value is indicated in the "Value" field.
"= Marker" | This setting is only available if a marker is active. Sets the step size to the value of the current marker and removes the coupling of the step size to span or resolution bandwidth. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP:​LINK

[SENSe:​]FREQuency:​CENTer:​STEP:​LINK:​FACTor

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Signal Tracking

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Signal Tracking
Signal Tracking

Defines the settings for signal tracking. These settings are only available for spans > 0.

For more details see "Keeping the Center Frequency Stable - Signal Tracking".

└ Signal Tracking State
└ Tracking Bandwidth
└ Tracking Threshold
└ Signal Track Trace


Signal Tracking State

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Signal Tracking > Signal Tracking State
Signal Tracking State

Activates or deactivates signal tracking. This function is only available for spans > 0.

If activated, after each sweep, the center frequency is set to the maximum level of the specified trace found within the searched bandwidth.

For more details see "Keeping the Center Frequency Stable - Signal Tracking".

Remote command:

CALCulate:​MARKer:​FUNCtion:​STRack[:​STATe]


Tracking Bandwidth

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Signal Tracking > Tracking Bandwidth
Tracking Bandwidth

Defines the search bandwidth for signal tracking around the center frequency.

For more details see "Keeping the Center Frequency Stable - Signal Tracking".

Remote command:

CALCulate:​MARKer:​FUNCtion:​STRack:​BANDwidth


Tracking Threshold

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Signal Tracking > Tracking Threshold
Tracking Threshold

Defines the threshold value for signal tracking. If the signal level does not pass the threshold, the center frequency is not changed.

For more details see "Keeping the Center Frequency Stable - Signal Tracking".

Remote command:

CALCulate:​MARKer:​FUNCtion:​STRack:​THReshold


Signal Track Trace

Common Measurement Settings > Frequency and Span Configuration > Frequency and Span Settings > Signal Tracking > Signal Track Trace
Signal Track Trace

Defines the trace to be tracked.

For more details see "Keeping the Center Frequency Stable - Signal Tracking".

Remote command:

CALCulate:​MARKer:​FUNCtion:​STRack:​TRACe


How To Define the Frequency Range

Common Measurement Settings > Frequency and Span Configuration > How To Define the Frequency Range
How To Define the Frequency Range

The following step-by-step instructions demonstrate how to configure the frequency and span settings. For details on individual functions and settings see "Frequency and Span Settings".

The remote commands required to perform these tasks are described in "Defining the Frequency and Span".

To configure the frequency and span

Frequency and span settings can be configured via the "Frequency" dialog box. Signal tracking is configured in the "Signal Tracking" tab of this dialog box.

  1. To display the "Frequency" dialog box, do one of the following:

    • Select "Frequency" from the "Overview".
    • Select the FREQ key and then the "Frequency Config" softkey.
    • Select the SPAN key and then the "Frequency Config" softkey.

  2. Define the frequency range using one of the following methods:

    • Define the "Center frequency" and "Span".
    • Define the "Start frequency" and "Stop frequency".
    • To perform a measurement in the time domain, define the "Center frequency" and select the "Zero span" button.
    • To perform a measurement over the entire available frequency range, select the "Full span" button.
    • To return to the previously set frequency range, select the "Last span" button.


How to Move the Center Frequency through the Frequency Range

Common Measurement Settings > Frequency and Span Configuration > How to Move the Center Frequency through the Frequency Range
How to Move the Center Frequency through the Frequency Range

In some cases it may be useful to move the center frequency through a larger frequency range, for example from one harmonic to another.

  1. In the "Frequency" dialog box, define the "Center Frequency Stepsize". This is the size by which the center frequency is to be increased or decreased in each step. Enter a manual or relative value, or set the step size to the current center frequency or marker value. To move from one harmonic to the next, use the center frequency or marker value.

  2. Select the "Center Frequency" dialog field.

  3. Use the arrow keys to move the center frequency in discrete steps through the available frequency range.


How to Keep the Center Frequency Stable

Common Measurement Settings > Frequency and Span Configuration > How to Keep the Center Frequency Stable
How to Keep the Center Frequency Stable

If the signal is slightly instable on the display but you want to keep the center frequency on the signal peak, the center frequency can be adjusted automatically using signal tracking.

  1. In the "Frequency" dialog box, select the "Signal Tracking" tab.

  2. Define the following settings:

    • "Signal Tracking Bandwidth": the frequency range around the center frequency to be tracked
    • "Signal Tracking Threshold": the minimum level the trace must reach to be detected as a maximum
    • "Signal Tracking Trace": the trace to be tracked

  3. Activate signal tracking by selecting "State: ON".

    After each sweep, the center frequency is set to the maximum signal found within the searched bandwidth. If no maximum signal above the defined threshold value is found in the searched bandwidth, the center frequency remains unchanged. The search bandwidth and the threshold value are shown in the diagram by red lines which are labeled as "TRK".


Amplitude and Vertical Axis Configuration

Common Measurement Settings > Amplitude and Vertical Axis Configuration
Amplitude and Vertical Axis Configuration

In the Spectrum application, measurement results usually consist of the measured signal levels (amplitudes) displayed on the vertical (y-)axis for the determined frequency spectrum or for the measurement time (horizontal, x-axis). The settings for the vertical axis, regarding amplitude and scaling, are described here.

Contents
  • Impact of the Vertical Axis Settings
  • Amplitude Settings
  • Scaling the Y-Axis
  • How to Optimize the Amplitude Display


Impact of the Vertical Axis Settings

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Impact of the Vertical Axis Settings
Impact of the Vertical Axis Settings

Some background knowledge on the impact of the described settings is provided here for a better understanding of the required configuration.

Contents
  • Reference Level
  • RF Attenuation
  • Scaling


Reference Level

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Impact of the Vertical Axis Settings > Reference Level
Reference Level

The reference level value is the maximum value the AD converter can handle without distortion of the measured value. Signal levels above this value will not be measured correctly, which is indicated by the "IF OVLD" status display. The reference level should correspond with the maximum expected RF input level.

When determining the expected input level, consider that the power from all input signals contribute to the total power. The reference level must be higher than the total power from all signals.

The optimum reference level for the current measurement settings can be set automatically by the R&S FSW (see "Reference Level").

The reference level determines the amplitude represented by the topmost grid line in the display. When you change the reference level, the measurement is not restarted; the results are merely shifted in the display. Only if the reference level changes due to a coupled RF attenuation (see "Attenuation Mode / Value"), the measurement is restarted.

In general, the R&S FSW measures the signal voltage at the RF input. The level display is calibrated in RMS values of an unmodulated sine wave signal. In the default state, the level is displayed at a power of 1 mW (= dBm). Via the known input impedance (50 Ω or 75 Ω, see "Impedance"), conversion to other units is possible.


RF Attenuation

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Impact of the Vertical Axis Settings > RF Attenuation
RF Attenuation

The attenuation is meant to protect the input mixer from high RF input levels. The level at the input mixer is determined by the set RF attenuation according to the formula:

"levelmixer = levelinput – RF attenuation"

The maximum mixer level allowed is 0 dBm. Mixer levels above this value may lead to incorrect measurement results, which is indicated by the "RF OVLD" status display. Furthermore, higher input levels may damage the instrument. Therefore, the required RF attenuation is determined automatically according to the reference level by default.

High attenuation levels also avoid intermodulation. On the other hand, attenuation must be compensated for by re-amplifying the signal levels after the mixer. Thus, high attenuation values cause the inherent noise (i.e the noise floor) to rise and the sensitivity of the analyzer decreases.

The sensitivity of a signal analyzer is directly influenced by the selected RF attenuation. The highest sensitivity is obtained at an RF attenuation of 0 dB. Each additional 10 dB step reduces the sensitivity by 10 dB, i.e. the displayed noise is increased by 10 dB. To measure a signal with an improved signal-to-noise ratio, decrease the RF attenuation.

For ideal sinusoidal signals, the displayed signal level is independent of the RF attenuation.

Depending on the type of measurement evaluation that is required, a compromise must be found between a low noise floor and high intermodulation levels, and protecting the instrument from high input levels. This is best done by letting the R&S FSW determine the optimum level automatically (see "Attenuation Mode / Value").

Electronic attenuation

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator. For details see "Using Electronic Attenuation (Option B25)".


Scaling

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Impact of the Vertical Axis Settings > Scaling
Scaling

In a linear display, the measurement values are distributed linearly throughout the grid. That means the entire range of measured values is divided by the number of rows in the grid (10) and each row corresponds to 1/10 of the total range. Linear scaling is useful to determine precise levels for a small range of values. However, if large and small values appear in the same display, it is difficult to determine individual values precisely or to distinguish values that are close together.

In a logarithmic display, smaller values are distributed among a much larger area of the display, while large values are condensed to a smaller area. Now it is much easier to distinguish several lower values, as they are spread over a wider area. Logarithmic scaling is useful when large ranges of values must be combined in one display. Logarithmic scaling is best applied to measurement values in logarithmic units (dB, dBm etc.).

In addition to linear or logarithmic scaling, the vertical axis can be set to display either absolute or relative values. Absolute values show the measured levels, while relative values show the difference between the measured level and the defined reference level. Relative values are indicated in percent for linear scaling, and in dB for logarithmic scaling.


Amplitude Settings

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

The scaling settings are described in "Scaling the Y-Axis".

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Amplitude" from the "Overview".
  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.

The remote commands required to define these settings are described in "Amplitude Settings".

└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance
└ Range
└ Noise cancellation


Reference Level

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display.

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level".

Note that for input from the External Mixer (R&S FSW-B21) the maximum reference level also depends on the conversion loss, see "Reference level".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)


Shifting the Display (Offset)

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Unit

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Reference Level > Unit
Unit

The R&S FSW measures the signal voltage at the RF input. In the default state, the level is displayed at a power of 1 mW (= dBm). Via the known input impedance (50 Ω or 75 Ω, see "Impedance"), conversion to other units is possible. The following units are available and directly convertible:

  • dBm
  • dBmV
  • dBμV
  • dBμA
  • dBpW
  • Volt
  • Ampere
  • Watt
Remote command:

INPut:​IMPedance

CALCulate<n>:​UNIT:​POWer


Setting the Reference Level Automatically (Auto Level)

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Reference Level > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


RF Attenuation

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

└ Attenuation Mode / Value


Attenuation Mode / Value

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation".

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance
└ Range


Preamplifier (option B24)

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Range

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Amplitude Settings > Input Settings > Range
Range

Defines the displayed y-axis range in dB.

The default value is 100 dB.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]


Scaling the Y-Axis

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Scaling the Y-Axis
Scaling the Y-Axis

The individual scaling settings that affect the vertical axis are described here.

The remote commands required to define these settings are described in "Configuring the Vertical Axis (Amplitude, Scaling)".

└ Range
└ Ref Level Position
└ Auto Scale Once
└ Scaling


Ref Level Position

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Scaling the Y-Axis > Ref Level Position
Ref Level Position

Defines the reference level position, i.e. the position of the maximum AD converter value on the level axis in %, where 0 % corresponds to the lower and 100 % to the upper limit of the diagram.

For spectrograms, this value defines the position of the reference level value within the span covered by the color map. In this case, the value is given in %, where 0 % corresponds to the maximum (right end) and 100 % to the minimum (left end) of the color map.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Auto Scale Once

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Scaling the Y-Axis > Auto Scale Once
Auto Scale Once

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings.

The display is only set once; it is not adapted further if the measurement settings are changed again.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE


Scaling

Common Measurement Settings > Amplitude and Vertical Axis Configuration > Scaling the Y-Axis > Scaling
Scaling

Defines the scaling method for the y-axis.

For more information see "Scaling".

"Logarithmic" | Logarithmic scaling (only available for logarithmic units - dB..., and A, V, Watt)
"Linear Unit" | Linear scaling in the unit of the measured signal
"Linear Percent" | Linear scaling in percentages from 0 to 100
"Absolute" | The labeling of the level lines refers to the absolute value of the reference level (not available for "Linear Percent")
"Relative" | The scaling is in dB, relative to the reference level (only available for logarithmic units - dB...). The upper line of the grid (reference level) is always at 0 dB.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE


How to Optimize the Amplitude Display

Common Measurement Settings > Amplitude and Vertical Axis Configuration > How to Optimize the Amplitude Display
How to Optimize the Amplitude Display

This section gives you some advice on how to optimize the display of the measured signal amplitudes depending on the required evaluation.

  1. Perform a measurement with the default settings to get an impression of the values to be expected.

  2. Use the "Auto Level" function (AUTO menu) to optimize the reference level.

  3. Use the "Auto Scale" function (AUTO menu) to optimize the scaling.

  4. To determine a precise level at a specific point in the signal:

    • Reduce the "Range" of the y-axis to a small area around the required level. If necessary, change the "Ref Level Position" so the required range remains visible.
    • Select "Linear Unit" scaling.

    Now you can set a marker at the point in question and read the result.

  5. To detect a spurious signal close to the noise floor:

    • Set the "RF attenuation" to "Manual" mode and reduce the "Value" to lower the noise floor.
    • Select "Relative - Logarithmic" scaling.

    Now you can determine if any spurious levels of a certain size are visible.


Bandwidth, Filter and Sweep Configuration

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration
Bandwidth, Filter and Sweep Configuration

The basic bandwidth, filter and sweep settings that apply to most measurements are described here. These parameters define how the data is measured: how much data is collected internally and which filters are used.

Contents
  • Impact of the Bandwidth, Filter and Sweep Settings
  • Bandwidth, Filter and Sweep Settings
  • Reference: List of Available RRC and Channel Filters


Impact of the Bandwidth, Filter and Sweep Settings

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings
Impact of the Bandwidth, Filter and Sweep Settings

The bandwidth, filter and sweep settings are closely related and interdependant. The values available for resolution bandwidth and video bandwidth depend on the selected filter type. In addition, these settings have an impact on other measurement parameters. The following equation shows the interdependency of these settings:

TsweepMIN = K*Span/RBW2

where K = Filter constant

By default, a Gaussian filter is used. The resolution bandwidth, the video bandwidth and the sweep time are set automatically according to the set span, and default coupling is used. Thus, the following settings are applied:

RBW = 100 * Span

VBW = RBW = 100 * Span

Sweep time = Tmin for set Span, RBW, VBW

When defining the bandwidth and filter settings, consider the impact of the individual settings on the other settings and the measurement result, as described in more detail in the following sections.

Contents
  • Separating Signals by Selecting an Appropriate Resolution Bandwidth
  • Smoothing the Trace Using the Video Bandwidth
  • Coupling VBW and RBW
  • Coupling Span and RBW
  • How Data is Measured: the Sweep Type
  • Which Data May Pass: Filter Types
  • How Long the Data is Measured: Sweep Time
  • How Much Data is Measured: Sweep Points and Sweep Count
  • How Often Data is Measured: Sweep Mode


Separating Signals by Selecting an Appropriate Resolution Bandwidth

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > Separating Signals by Selecting an Appropriate Resolution Bandwidth
Separating Signals by Selecting an Appropriate Resolution Bandwidth

The resolution bandwidth defines the 3 dB bandwidth of the resolution filter to be used. An RF sinusoidal signal is displayed according to the passband characteristic of the resolution filter (RBW), i.e. the signal display reflects the shape of the filter.

A basic feature of a signal analyzer is being able to separate the spectral components of a mixture of signals. The resolution at which the individual components can be separated is determined by the resolution bandwidth. Selecting a resolution bandwidth that is too large may make it impossible to distinguish between spectral components, i.e. they are displayed as a single component. Smaller resolution bandwidths, however, increase the required measurement time.

Two signals with the same amplitude can be resolved if the resolution bandwidth is smaller than or equal to the frequency spacing of the signal. If the resolution bandwidth is equal to the frequency spacing, the spectrum display screen shows a level drop of 3 dB precisely in the center of the two signals. Decreasing the resolution bandwidth makes the level drop larger, which thus makes the individual signals clearer.

The highest sensitivity is obtained at the smallest bandwidth (1 Hz). If the bandwidth is increased, the reduction in sensitivity is proportional to the change in bandwidth. Increasing the bandwidth by a factor of 3 increases the displayed noise by approx. 5 dB (4.77 dB precisely). If the bandwidth is increased by a factor of 10, the displayed noise increases by a factor of 10, i.e. 10 dB.

If there are large level differences between signals, the resolution is determined by selectivity as well as by the resolution bandwidth that has been selected. The measure of selectivity used for signal analyzers is the ratio of the 60 dB bandwidth to the 3 dB bandwidth (= shape factor).

For the R&S FSW, the shape factor for bandwidths is < 5, i.e. the 60 dB bandwidth of the 30 kHz filter is <150 kHz.

The higher spectral resolution with smaller bandwidths is won by longer sweep times for the same span. The sweep time has to allow the resolution filters to settle during a sweep at all signal levels and frequencies to be displayed.

If the RBW is too large, signal parts that are very far away (e.g. from a different signal) are considered in the measurement and distort the results. The noise increases.

If the RBW is too small, parts of the signal are lost. As the displayed signal always reflects the shape of the filter, select a bandwidth large enough so the displayed signal reflects the entire shape of the filter.


Smoothing the Trace Using the Video Bandwidth

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > Smoothing the Trace Using the Video Bandwidth
Smoothing the Trace Using the Video Bandwidth

The video filters are responsible for smoothing the displayed trace. Using video bandwidths that are small compared to the resolution bandwidth, only the signal average is displayed and noise peaks and pulsed signals are repressed. If pulsed signals are to be measured, it is advisable to use a video bandwidth that is large compared to the resolution bandwidth (VBW = 10 x RBW) for the amplitudes of pulses to be measured correctly.

The level of a sine wave signal is not influenced by the video bandwidth. A sine wave signal can therefore be freed from noise by using a video bandwidth that is small compared with the resolution bandwidth, and thus be measured more accurately.

RMS/Average detector and VBW

If an RMS or average detector is used, the video bandwidth in the hardware is bypassed. Thus, duplicate trace averaging with small VBWs and RMS or average detector no longer occurs. However, the VBW is still considered when calculating the sweep time. This leads to a longer sweep time for small VBW values. Thus, you can reduce the VBW value to achieve more stable trace curves even when using an RMS or average detector. Normally, if the RMS or average detector is used the sweep time should be increased to get more stable traces.


Coupling VBW and RBW

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > Coupling VBW and RBW
Coupling VBW and RBW

The video bandwidth can be coupled to the resolution bandwidth automatically. In this case, if the resolution bandwidth is changed, the video bandwidth is automatically adjusted.

Coupling is recommended if a minimum sweep time is required for a selected resolution bandwidth. Narrow video bandwidths require longer sweep times due to the longer settling time. Wide bandwidths reduce the signal/noise ratio.

Overview of RBW/VBW ratios and recommendations for use
Ratio RBW/VBW | Recommendation for use
1/1 | Recommended for sinusoidal signals This is the default setting for automatic coupling.
0.1 | Recommended when the amplitudes of pulsed signals are to be measured correctly. The IF filter is exclusively responsible for the pulse shape. No additional evaluation is performed by the video filter.
10 | Recommended to suppress noise and pulsed signals in the video domain.
Manually set (0.001 to 1000) | Recommended for other measurement requirements


Coupling Span and RBW

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > Coupling Span and RBW
Coupling Span and RBW

The resolution bandwidth can be coupled to the span setting, either by a manually defined factor or automatically. If the span is changed, the resolution bandwidth is automatically adjusted. The automatic coupling adapts the resolution bandwidth to the currently set frequency span/100.

The 6 dB bandwidths 200 Hz, 9 kHz and 120 kHz and the available channel filters are not changed by the coupling.

With a span/RBW ratio of 100 and a screen resolution of 1000 pixels, each frequency in the spectrum is displayed by 10 pixels. A span/RBW ratio of 1000 provides the highest resolution.

A higher span/RBW ratio (i.e. low RBW values and large frequency spans), however, results in large amounts of data.


How Data is Measured: the Sweep Type

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > How Data is Measured: the Sweep Type
How Data is Measured: the Sweep Type

In a standard analog frequency sweep, the local oscillator of the analyzer sweeps the applied signal quasi analog from the start to the stop frequency to determine the frequency spectrum.

Alternatively, the analyzer can sample signal levels over time at a defined frequency and transform the data to a spectrum by Fast Fourier Transformation (FFT). Although this measurement method requires additional calculations, it can provide results much faster than the frequency sweep, in particular for small RBWs.

Which sweep mode is appropriate for the current measurement depends on the span, RBW, VBW and sweep time settings. By default ("Auto" sweep type), the R&S FSW automatically uses the sweep type with the highest sweep rate depending on these measurement settings.

Restrictions for FFT mode

FFT mode is not available when using 5-Pole filters, Channel filters or RRC filters, or the Quasi peak detector. In this case, sweep mode is used.

The same applies when an external generator (option R&S FSW-B10) is active.

Optimization

In FFT mode, FFT analysis is performed to determine a spectrum of frequencies. Several analysis steps are required to cover the entire span. The partial span which is covered by one FFT analysis depends on the RBW. The partial span cannot be defined directly, but it can be optimized according to measurement requirements.

Narrow partial spans provide a higher dynamic range, and also allow you to perform measurements near a carrier with a reduced reference level. With a wide partial span, the carrier and the useful signal are likely to be measured at the same time, in which case the powers of both signals are summarized, so the reference level must be high enough to consider this factor. With a narrow partial span, this is less likely to happen, so the reference level can be reduced.

For an optimal dynamic range, the narrowest possible partial span (depending on the RBW) is used. Furthermore, the autorange function for the internal IF gain calculation is activated to obtain the best control range of the A/D converter.

On the other hand, the narrower the partial span, the more steps are required to cover the entire span, thus increasing analysis and calculation time. To optimize the sweep rate, the widest possible partial span (depending on the RBW) is used.

For an optimal sweep rate, it is recommended that you set the sweep time to "Auto", as well.

For general purpose measurements, an "Auto" mode is available, which provides a compromise between a large dynamic range and a fast sweep. In this case, a medium-sized partial span is used.

FFT mode and external mixers (R&S FSW-B21)

The partial span optimation modes "Dynamic" and "Auto" include automatic suppression of unwanted mixing products. Thus, when using external mixers (R&S FSW-B21), use the "Speed" mode to obtain similar results in FFT mode as in normal sweep mode.

FFT mode and EMI measurements (R&S FSW-K54)

For EMI measurements (using R&S FSW-K54), the partial span optimation mode "Dynamic" is not supported. "Auto" mode always uses "Speed" optimization.

Optimization for zero span sweeps

For normal sweeps in the time domain (zero span), the optimization mode determines the selection of the A/D converter prefilter, which depends on the RBW.

In "Dynamic" mode, the narrowest possible prefilter is used.

In "Speed" mode, the widest possible prefilter is used.

In "Auto" mode, a medium-sized prefilter is used.


Which Data May Pass: Filter Types

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > Which Data May Pass: Filter Types
Which Data May Pass: Filter Types

While the filter is irrelevant when measuring individual narrowband signals (as long as the signal remains within the RBW), the measurement result for broadband signals is very dependant on the selected filter type and its shape. If the filter is too narrow, the signal is distorted by the filter. If the filter is too wide, multiple signals can no longer be distinguished. Generally, the smaller the filter width and the steeper its edges, the longer the settling time and thus the longer the sweep time must be.

All resolution bandwidths are realized with digital filters. Normal (3dB) Gaussian filters are set by default. Some communication standards require different filters.

For a list of available filter types, see "Reference: List of Available RRC and Channel Filters".

Normal (3dB) Gaussian filters

Gaussian filters provide a good compromise between steep edges and a short settling time. This filter is suitable for most measurement tasks and is used by default.

The available Gaussian (3dB) sweep filters are listed in the R&S FSW data sheet.

Channel filters

Channel filters are fairly steep but require a long settling time; they are useful for pulse measurements in the time domain.

RRC filters

Root raised cosine filters are similar in shape to channel filters and are required by some measurement standards.

5-Pole filters

5-Pole filters are very broad and allow for a large bandwidth to pass.


How Long the Data is Measured: Sweep Time

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > How Long the Data is Measured: Sweep Time
How Long the Data is Measured: Sweep Time

Each filter has a settling time that must be awaited in order to obtain correct results. Since the resolution bandwidth and video bandwidth define the filter, the smaller of the two determines the minimum sweep time required for the measurement. Allowed values depend on the ratio of span to RBW and RBW to VBW.

If the selected sweep time is too short for the selected bandwidth and span, level measurement errors will occur. In this case, the R&S FSW displays the error message "Sweep time too low" and marks the indicated sweep time with a red bullet. Furthermore, a status bit indicates an error (see "STATus:QUEStionable:TIMe Register").

The sweep time can be coupled to the span (not zero span), video bandwidth (VBW) and resolution bandwidth (RBW) automatically. If the span, resolution bandwidth or video bandwidth is changed, the sweep time is automatically adjusted.


How Much Data is Measured: Sweep Points and Sweep Count

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > How Much Data is Measured: Sweep Points and Sweep Count
How Much Data is Measured: Sweep Points and Sweep Count

By default, 1001 data points are determined in a single sweep. During the next sweep, 1001 new data points are collected, and so on. The number of sweep points defines how much of the entire span is covered by a single data point. By increasing the number of sweep points you can increase the reliability of the individual data points and thus the accuracy of the analyzed results. However, these data points are all stored on the instrument, occupying a large amount of memory, and each sweep point increases the overall measurement time. Up to 200 000 points can be swept at once.

The number of sweeps to be performed in single sweep mode is defined by the "Sweep Count". Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed. The sweep count is applied to all the traces in a diagram.

If the trace configurations "Average", "Max Hold" or "Min Hold" are set, the "sweep/average count" also determines the number of averaging or maximum search procedures (see "Analyzing Several Traces - Trace Mode").

For details on how the number of sweep points and the sweep count affect the trace results on the screen, see "Mapping Samples to Sweep Points with the Trace Detector".


How Often Data is Measured: Sweep Mode

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Impact of the Bandwidth, Filter and Sweep Settings > How Often Data is Measured: Sweep Mode
How Often Data is Measured: Sweep Mode

How often the spectrum is swept depends on the sweep mode. Either a certain number of sweeps can be defined ("Sweep Count") which are performed in "Single Sweep" mode, or the sweep is repeated continuously ("Continuous Sweep" mode).

By default, the data is collected for the specified number of sweeps and the corresponding trace is displayed. When the next sweep is started, the previous trace is deleted.

However, the data from a single sweep run can also be retained and displayed together with the new data ("Continue Single Sweep" mode). This is particularly of interest when using the trace configurations "Average" or "Max Hold" to take previously recorded measurements into account for averaging/maximum search (see "Analyzing Several Traces - Trace Mode").


Bandwidth, Filter and Sweep Settings

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings
Bandwidth, Filter and Sweep Settings

The remote commands required to define these settings are described in "Configuring Bandwidth and Sweep Settings".

How to perform a basic sweep measurement is described in "How to Perform a Basic Sweep Measurement".

└ RBW
└ VBW
└ Sweep Time
└ Span/RBW
└ RBW/VBW
└ Filter Type
└ Default Coupling
└ Sweep/Average Count
└ Sweep Points
└ Optimization
└ Sweep Type
└ Single Sweep/ RUN SINGLE
└ Continuous Sweep/RUN CONT
└ Continue Single Sweep
└ Spectrogram Frames
└ Selecting a frame to display
└ Continue Frame
└ Frame Count
└ Clear Spectrogram


RBW

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > RBW
RBW

Defines the resolution bandwidth. The available resolution bandwidths are specified in the data sheet. Numeric input is always rounded to the nearest possible bandwidth.

If "AUTO" is selected, the resolution bandwidth is coupled to the selected span (for span > 0). If the span is changed, the resolution bandwidth is automatically adjusted.

If the resolution bandwidth is defined manually, a green bullet is displayed next to the "RBW" display in the channel bar.

For more information see "Separating Signals by Selecting an Appropriate Resolution Bandwidth".

For measurements on I/Q data in the frequency domain, the maximum RBW is 1 MHz.

For EMI measurements using the quasipeak detector, the 1 MHz RBW filter is not available (see "Resolution Bandwidth and Filter Types").

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​AUTO


VBW

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > VBW
VBW

Defines the video bandwidth automatically or manually.

For more information see "Smoothing the Trace Using the Video Bandwidth".

"Auto"

The video bandwidth is coupled to the resolution bandwidth. If the resolution bandwidth is changed, the video bandwidth is automatically adjusted.

"Manual"

For manual mode, define the bandwidth value. The available video bandwidths are specified in the data sheet. Numeric input is always rounded to the nearest possible bandwidth.

If the video bandwidth is defined manually, a green bullet is displayed next to the "VBW" display in the channel bar.

Remote command:

[SENSe:​]BANDwidth|BWIDth:​VIDeo:​AUTO

[SENSe:​]BANDwidth|BWIDth:​VIDeo


Sweep Time

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Sweep Time
Sweep Time

Defines the duration of a single sweep, during which the defined number of sweep points are measured. The sweep time can be defined automatically or manually.

The allowed sweep times depend on the device model; refer to the data sheet.

For more information see "How Long the Data is Measured: Sweep Time".

"Auto" | The sweep time is coupled to the span (not zero span), video bandwidth (VBW) and resolution bandwidth (RBW). If the span, resolution bandwidth or video bandwidth is changed, the sweep time is automatically adjusted.
"Manual" | For manual mode, define the sweep time. Allowed values depend on the ratio of span to RBW and RBW to VBW. For details refer to the data sheet. Numeric input is always rounded to the nearest possible sweep time.
Remote command:

[SENSe:​]SWEep:​TIME:​AUTO

[SENSe:​]SWEep:​TIME


Span/RBW

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Span/RBW
Span/RBW

Sets the coupling ratio if "RBW" is set to auto mode.

For more information see "Coupling Span and RBW".

"Auto [100]" | "resolution bandwidth = span/100" This coupling ratio is the default setting of the R&S FSW.
"Manual" | The coupling ratio is defined manually. The span/resolution bandwidth ratio can be set in the range from 1 to 10000.
Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​RATio


RBW/VBW

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > RBW/VBW
RBW/VBW

Sets the coupling ratio between the resolution bandwidth and the video bandwidth.

This setting is only effective if "VBW" is set to auto mode.

For more information see "Coupling VBW and RBW".

"Sine [1/1]" | "video bandwidth = resolution bandwidth" This is the default setting for the coupling ratio RBW/VBW and is recommended if sinusoidal signals are to be measured.
"Pulse [.1]" | "video bandwidth = 10 × resolution bandwidth" or "video bandwidth = 10 MHz (= max. VBW)" Recommended for pulse signals
"Noise [10]" | "video bandwidth = resolution bandwidth/10" Recommended for noise measurements
"Manual" | The coupling ratio is defined manually. The RBW/VBW ratio can be set in the range of 0.001 to 1000.
Remote command:

[SENSe:​]BANDwidth|BWIDth:​VIDeo:​AUTO

[SENSe:​]BANDwidth|BWIDth:​VIDeo:​RATio


Filter Type

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Filter Type
Filter Type

Defines the filter type.

The following filter types are available:

  • Normal (3dB)
  • Channel
  • RRC
  • 5-Pole (not available for sweep type "FFT")
  • CISPR (6 dB) - requires EMI (R&S FSW-K54) option
  • MIL Std (6 dB) - requires EMI (R&S FSW-K54) option

For more information see "Which Data May Pass: Filter Types".

Note: The EMI-specific filter types are available if the EMI (R&S FSW-K54) measurement option is installed, even if EMI measurement is not active. For details see "Resolution Bandwidth and Filter Types".
The RBW filter configured in the bandwidth settings is identical to the filter configured in the EMI configuration.

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​TYPE


Default Coupling

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Default Coupling
Default Coupling

Sets all coupled functions to the default state ("AUTO"). In addition, the ratio "RBW/VBW" is set to "SINE [1/1]" and the ratio "SPAN/RBW" to 100.

For more information see "Coupling VBW and RBW".

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]:​AUTO

[SENSe:​]BANDwidth|BWIDth:​VIDeo:​AUTO

[SENSe:​]SWEep:​TIME:​AUTO


Sweep/Average Count

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

The sweep count is applied to all the traces in all diagrams.

If the trace modes "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count".

For spectrogram displays, the sweep count determines how many sweeps are combined in one frame in the spectrogram, i.e. how many sweeps the R&S FSW performs to plot one trace in the spectrogram result display. For more details see "Time Frames".

Remote command:

[SENSe:​]SWEep:​COUNt

[SENSe:​]AVERage:​COUNt


Sweep Points

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Sweep Points
Sweep Points

Defines the number of measured values to be collected during one sweep.

For details see "How Much Data is Measured: Sweep Points and Sweep Count".

All values from 101 to 100001 can be set. The default value is 1001 sweep points.

For EMI measurements, 200001 sweep points are available.

Remote command:

[SENSe:​]SWEep:​POINts


Optimization

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Optimization
Optimization

In FFT mode, several FFT analysis steps are required to cover the entire measurement span. The span which is covered by one FFT analysis step is called partial span. The partial span cannot be defined directly, but it can be optimized according to measurement requirements.

Optimization parameters in FFT mode

Optimization mode

Description

Dynamic

Optimizes the dynamic range by using the narrowest possible partial span (depending on the RBW).

The autorange function for the internal IF gain calculation is activated to obtain the best control range for the A/D converter.

Speed

Optimizes the sweep rate by using the widest possible partial span (depending on the RBW).

The autorange function for the internal IF gain calculation is deactivated. (Note: set the reference level accordingly to optimize the control range for the A/D converter).

It is recommended that you set the "Sweep Time" to "Auto" to optimize the sweep rate.

Auto

Uses a medium-sized partial span to obtain a compromise between a large dynamic range and a fast sweep rate.

The autorange function for the internal IF gain calculation is activated to obtain the best control range for the A/D converter.

Note: FFT mode and external mixers (R&S FSW-B21)

The partial span optimization modes "Dynamic" and "Auto" include automatic suppression of unwanted mixing products. Thus, when using external mixers (R&S FSW-B21), use the "Speed" mode to obtain similar results in FFT mode as in frequency sweep mode.

Zero span mode

For zero span measurements, the optimization mode defines the selection of the A/D converter prefilter.

Optimization parameters in zero span mode
Optimization mode | Description
Dynamic | The narrowest filter possible (depending on the RBW) is used.
Speed | The widest filter possible (depending on the RBW) is used.
Auto | A medium-sized prefilter is used.

Note: EMI measurements
For EMI measurements (using R&S FSW-K54), "Dynamic" mode is not supported. "Auto" mode always uses "Speed" optimization.

Remote command:

[SENSe:​]SWEep:​OPTimize


Sweep Type

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Sweep Type
Sweep Type

Defines the sweep type.

For more information see "How Data is Measured: the Sweep Type".

"Auto"

Automatically sets the fastest available sweep type for the current measurement (Frequency or FFT). Auto mode is set by default.

"FFT"

The FFT sweep samples on a defined frequency value and transforms it to the spectrum by fast Fourier transformation (FFT) (see also "How Data is Measured: the Sweep Type").

FFT is not available in the following cases:

  • when using 5-Pole filters, Channel filters or RRC filters
  • when using the Quasi peak detector
  • when an external generator (option B10) is active

In these cases, frequency sweep is used.

Remote command:

[SENSe:​]SWEep:​TYPE


Single Sweep/ RUN SINGLE

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts the number of sweeps set in "Sweep Count". The measurement stops after the defined number of sweeps has been performed.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept".

Remote command:

INITiate[:​IMMediate]

CALCulate:​SGRam|SPECtrogram:​CONT


Continuous Sweep/RUN CONT

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the sweep and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept".

Remote command:

INITiate:​CONTinuous


Continue Single Sweep

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of sweeps set in "Sweep Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Spectrogram Frames

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Spectrogram Frames
Spectrogram Frames

These settings are only available if spectrogram display is active (see "How to Display and Configure a Spectrogram").

└ Selecting a frame to display
└ Continue Frame
└ Frame Count
└ Clear Spectrogram


Selecting a frame to display

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Spectrogram Frames > Selecting a frame to display
Selecting a frame to display

Selects a specific frame, loads the corresponding trace from the memory, and displays it in the Spectrum window.

Note that activating a marker or changing the position of the active marker automatically selects the frame that belongs to that marker.

This function is only available in single sweep mode or if the sweep is stopped, and only if a spectrogram is selected.

The most recent frame is number 0, all previous frames have a negative number.

For more information see "Time Frames".

Remote command:

CALCulate:​SGRam|SPECtrogram:​FRAMe:​SELect


Continue Frame

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Spectrogram Frames > Continue Frame
Continue Frame

Determines whether the results of the previous sweeps are included in the analysis of the next sweeps for trace modes "Max Hold", "Min Hold", and "Average".

This function is available in single sweep mode only.

  • On
    When the average or peak values are determined for the new sweep, the results of the previous sweeps in the spectrogram are also taken into account.
  • Off
    The average or peak values are determined from the results of the newly swept frames only.
Remote command:

CALCulate:​SGRam|SPECtrogram:​CONT


Frame Count

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Spectrogram Frames > Frame Count
Frame Count

Determines how many frames are plotted during a single sweep measurement (as opposed to a continuous sweep). The maximum number of possible frames depends on the history depth (see "History Depth").

For more details see "Time Frames".

Remote command:

CALCulate:​SGRam|SPECtrogram:​FRAMe:​COUNt


Clear Spectrogram

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Bandwidth, Filter and Sweep Settings > Spectrogram Frames > Clear Spectrogram
Clear Spectrogram

Resets the spectrogram result display and clears the history buffer.

This function is only available if a spectrogram is selected.

Remote command:

CALCulate:​SGRam|SPECtrogram:​CLEar[:​IMMediate]


Reference: List of Available RRC and Channel Filters

Common Measurement Settings > Bandwidth, Filter and Sweep Configuration > Reference: List of Available RRC and Channel Filters
Reference: List of Available RRC and Channel Filters

For power measurement a number of especially steep-edged channel filters are available (see the following table). The indicated filter bandwidth is the 3 dB bandwidth. For RRC filters, the fixed roll-off factor (α) is also indicated.

The available Gaussian 3dB sweep filters are listed in the R&S FSW data sheet.

Filter types
Filter Bandwidth | Filter Type | Application
100 Hz | CFILter |
200 Hz | CFILter | A0
300 Hz | CFILter |
500 Hz | CFILter |
1 kHz | CFILter |
1.5 kHz | CFILter |
2 kHz | CFILter |
2.4 kHz | CFILter | SSB
2.7 kHz | CFILter |
3 kHz | CFILter |
3.4 kHz | CFILter |
4 kHz | CFILter | DAB, Satellite
4.5 kHz | CFILter |
5 kHz | CFILter |
6 kHz | CFILter |
6 kHz, α=0.2 | RRC | APCO
8.5 kHz | CFILter | ETS300 113 (12.5 kHz channels)
9 kHz | CFILter | AM Radio
10 kHz | CFILter |
12.5 kHz | CFILter | CDMAone
14 kHz | CFILter | ETS300 113 (20 kHz channels)
15 kHz | CFILter |
16 kHz | CFILter | ETS300 113 (25 kHz channels)
18 kHz, α=0.35 | RRC | TETRA
20 kHz | CFILter |
21 kHz | CFILter | PDC
24.3 kHz, α=0.35 | RRC | IS 136
25 kHz | CFILter |
30 kHz | CFILter | CDPD, CDMAone
50 kHz | CFILter |
100 kHz | CFILter |
150 kHz | CFILter | FM Radio
192 kHz | CFILter | PHS
200 kHz | CFILter |
300 kHz | CFILter |
500 kHz | CFILter | J.83 (8-VSB DVB, USA)
1 MHz | CFILter | CDMAone
1.228 MHz | CFILter | CDMAone
1.28 MHz, α=0.22 | RRC |
1.5 MHz | CFILter | DAB
2 MHz | CFILter |
3 MHz | CFILter |
3.75 MHz | CFILter |
3.84 MHz, α=0.22 | RRC | W-CDMA 3GPP
4.096 MHz, α=0.22 | RRC | W-CDMA NTT DOCoMo
5 MHz | CFILter |
10 MHz *) | CFILter |
20 MHz *) | CFILter |
28 MHz *) | CFILter |
40 MHz *) | CFILter |
80 MHz *) | CFILter |
*) These filters are only available with option R&S FSW-B8 (Resolution Bandwidths > 10 MHz).


Trigger and Gate Configuration

Common Measurement Settings > Trigger and Gate Configuration
Trigger and Gate Configuration

Triggering means to capture the interesting part of the signal. Choosing the right trigger type and configuring all trigger settings correctly allows you to detect various incidents in your signals.

Gating allows you to restrict measurement analysis to the important part or parts of the signal, for example bursts.

Contents
  • Basics of Triggering and Gated Measurements
  • Trigger and Gate Settings
  • How to Configure a Triggered and Gated Measurement
  • How to Output a Trigger Signal


Basics of Triggering and Gated Measurements

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements
Basics of Triggering and Gated Measurements

Some background knowledge on triggering and gated measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Triggered measurements
  • Gated Measurements
  • Determining the Parameters in Preview Mode


Triggered measurements

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Triggered measurements
Triggered measurements

In a basic sweep measurement with default settings, the sweep is started immediately when you start the measurement, for example by pressing the RUN SINGLE key. However, sometimes you want the measurement to start only when a specific condition is fulfilled, for example a signal level is exceeded, or in certain time intervals. For these cases you can define a trigger for the measurement. In FFT sweep mode, the trigger defines when the data acquisition starts for the FFT conversion.

An "Offset" can be defined to delay the measurement after the trigger event, or to include data before the actual trigger event in time domain measurements (pre-trigger offset).

For complex tasks, advanced trigger settings are available:
  • Hysteresis to avoid unwanted trigger events caused by noise
  • Holdoff to define exactly which trigger event will cause the trigger in a jittering signal
Contents
  • Trigger Source
  • Trigger Offset
  • Trigger Hysteresis
  • Trigger Drop-Out Time
  • Trigger Holdoff


Trigger Source

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Triggered measurements > Trigger Source
Trigger Source

The trigger source defines which source must fulfill the condition that triggers the measurement. Basically, this can be:

  • Time: the measurement is repeated in a regular interval
  • Power: an input signal is checked for a defined power level
    The trigger signal can be an internal one (the input signal at one of various stages in the signal analysis process - before or after the input mixer, after the video filter etc.) or it may come from an external device via one of the TRIGGER INPUT connectors on the front or rear panel of the instrument.
    A power sensor can also provide an external trigger, see "Using a Power Sensor as an External Power Trigger".

For details on the available trigger sources see "Trigger Source".


Trigger Offset

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Triggered measurements > Trigger Offset
Trigger Offset

An offset can be defined to delay the measurement after the trigger event, or to include data before the actual trigger event in time domain measurements (pre-trigger offset). Pre-trigger offsets are possible because the R&S FSW captures data continuously in the time domain, even before the trigger occurs.

See "Trigger Offset".


Trigger Hysteresis

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Triggered measurements > Trigger Hysteresis
Trigger Hysteresis

Setting a hysteresis for the trigger helps avoid unwanted trigger events caused by noise, for example. The hysteresis is a threshold to the trigger level that the signal must fall below on a rising slope or rise above on a falling slope before another trigger event occurs.

Example:

In the following example, the second possible trigger event is ignored as the signal does not exceed the hysteresis (threshold) before it reaches the trigger level again on the rising edge. On the falling edge, however, two trigger events occur as the signal exceeds the hysteresis before it falls to the trigger level the second time.

Effects of the trigger hysteresis

See "Hysteresis"


Trigger Drop-Out Time

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Triggered measurements > Trigger Drop-Out Time
Trigger Drop-Out Time

If a modulated signal is instable and produces occassional "drop-outs" during a burst, you can define a minimum duration that the input signal must stay below the trigger level before triggering again. This is called the "drop-out" time. Defining a dropout time helps you stabilize triggering when the analyzer is triggering on undesired events.

Effect of the trigger drop-out time

See "Drop-Out Time".

Drop-out times for falling edge triggers

If a trigger is set to a falling edge ("Slope" = "Falling", see "Slope") the measurement is to start when the power level falls below a certain level. This is useful, for example, to trigger at the end of a burst, similar to triggering on the rising edge for the beginning of a burst.

If a drop-out time is defined, the power level must remain below the trigger level at least for the duration of the drop-out time (as defined above). However, if a drop-out time is defined that is longer than the pulse width, this condition cannot be met before the final pulse, so a trigger event will not occur until the pulsed signal is over!

Trigger drop-out time for falling edge trigger

For gated measurements, a combination of a falling edge trigger and a drop-out time is generally not allowed.


Trigger Holdoff

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Triggered measurements > Trigger Holdoff
Trigger Holdoff

The trigger holdoff defines a waiting period before the next trigger after the current one will be recognized.

Effect of the trigger holdoff

See "Trigger Holdoff".


Gated Measurements

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Gated Measurements
Gated Measurements

Like a gate provides an opening in a fence, a gated measurement lets data from the input signal pass in defined areas only. The gate controls exactly when data is included in the measurement results and when not. The gate is opened by the trigger source, which is also the gate source. Gates can be used in two different modes:

  • Level: The gate opens and the measurement starts when a defined level in the gate source is exceeded and stops when the gate source drops below the "Gate Level".
    Using a pulsed gate signal in level mode, the following behaviour can be achieved: When the gate source signal is active, the input signal data is collected; when the gate signal is inactive, the input signal is ignored.
  • Edge: The gate opens and the measurement starts when a defined level in the gate source is exceeded and stops when the defined "Gate Length" is reached.

The "Gate Mode" Level is not supported for Rohde & Schwarz power sensors. The signal sent by these sensors merely reflects the instant the level is first exceeded, rather than a time period. However, only time periods can be used for gating in level mode. Thus, the trigger impulse from the sensors is not long enough for a fully gated measurement; the measurement cannot be completed. For details on power sensors see "Using a Power Sensor as an External Power Trigger".

Additionally, a delay time can be defined so that the first few measurement points after the gate opening are ignored.

Effects of Gate mode, Gate delay and Gate length
Example:

By using a gate in sweep mode and stopping the measurement while the gate signal is inactive, the spectrum for pulsed RF carriers can be displayed without the superposition of frequency components generated during switching. Similarly, the spectrum can also be analyzed for an inactive carrier. The sweep can be controlled by an external gate or by the internal power trigger.

GSM signal with GATE OFF
GSM signal with GATE ON

Gated sweep operation is also possible for zero span measurements. This allows you to display level variations of individual slots, for instance in burst signals, versus time.

To indicate that a gate is used for the sweep, "GAT" and the gate source is displayed in the channel bar.


Determining the Parameters in Preview Mode

Common Measurement Settings > Trigger and Gate Configuration > Basics of Triggering and Gated Measurements > Determining the Parameters in Preview Mode
Determining the Parameters in Preview Mode

The preview mode allows you to try out trigger and gate settings before actually applying them to the current measurement. When the preview diagram shows the correct results, you can "Update the Main Diagram" and check the results in the background before closing the dialog box.

If preview mode is switched off, changes to the trigger and gate settings are applied to the measurement diagram directly.

The preview diagram displays a zero span measurement at the center frequency with the defined RBW and sweep time. This is useful to analyze bursts, for example, to determine the required gate settings. The main diagram remains unchanged concerning the zero span settings. Only the trigger and gate settings are applied to the measurement.


Trigger and Gate Settings

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings
Trigger and Gate Settings

Trigger and gate settings can be configured via the TRIG key or in the "Trigger and Gate" dialog box, which is displayed when you select the "Trigger/Gate" button in the "Overview".

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered and gated measurements, see "How to Configure a Triggered and Gated Measurement".

└ Preview
└ Frequency
└ RBW
└ Sweep Time
└ Trigger Settings
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Video
└ IF Power/BB Power
└ RF Power
└ Power Sensor
└ Time
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger
└ Gate Settings
└ Gated Trigger
└ Gate Mode
└ Gate Delay
└ Gate Length


Preview

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Preview
Preview

The preview diagram displays a zero span measurement at the center frequency with the defined RBW and sweep time.

For details see "Determining the Parameters in Preview Mode".

Note: The zero span settings refer only to the preview diagram. The main diagram remains unchanged.

The trigger and gate settings are applied to the measurement when the dialog box is closed or "Update Main Diagram" is selected.

If preview mode is switched off, any changes to the settings in this dialog box are applied to the measurement diagram directly. In this case, the zero span settings for the preview diagram are not displayed.

For information on the zero span settings see:
  • "Center frequency"
  • "RBW"
  • "Sweep Time"
└ Frequency
└ RBW
└ Sweep Time


Frequency

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Preview > Frequency
Frequency

Defines the center frequency.

Remote command:

[SENSe:​]FREQuency:​CENTer


RBW

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Preview > RBW
RBW

Defines the bandwidth value. The available resolution bandwidths are specified in the data sheet. Numeric input is always rounded to the nearest possible bandwidth.

Remote command:

[SENSe:​]BANDwidth|BWIDth[:​RESolution]


Sweep Time

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Preview > Sweep Time
Sweep Time

Defines the sweep time. Allowed values depend on the ratio of span to RBW and RBW to VBW. For details refer to the data sheet. Numeric input is always rounded to the nearest possible sweep time.

Remote command:

[SENSe:​]SWEep:​TIME


Trigger Settings

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings
Trigger Settings

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Video
└ IF Power/BB Power
└ RF Power
└ Power Sensor
└ Time
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope


Trigger Source

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

For gated measurements, this setting also defines the gating source.

For more information see "Trigger Source".

Note: When triggering or gating is activated, the squelch function is automatically disabled.
(See "Squelch").

Remote command:

TRIGger[:​SEQuence]:​SOURce

[SENSe:​]SWEep:​EGATe:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ Video
└ IF Power/BB Power
└ RF Power
└ Power Sensor
└ Time


Free Run

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

In the Spectrum application, this is the default setting.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)").

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT".

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce

SWE:EGAT:SOUR EXT for gated triggering, see [SENSe:​]SWEep:​EGATe:​SOURce


Video

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source > Video
Video

Defines triggering by the video signal, i.e. the filtered and detected version of the input signal (the envelope of the IF signal), as displayed on the screen.

Define a trigger level from 0 % to 100 % of the diagram height. The absolute trigger level is indicated by a horizontal trigger line in the diagram, which you can also move graphically to change the trigger level.

Video mode is only available in the time domain, and not for I/Q-based data.

Remote command:

TRIG:SOUR VID, see TRIGger[:​SEQuence]:​SOURce

SWE:EGAT:SOUR VID for gated triggering, see [SENSe:​]SWEep:​EGATe:​SOURce


IF Power/BB Power

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source > IF Power/BB Power
IF Power/BB Power

Depending on the input source type, this softkey defines triggering of the measurement using:

  • the baseband power (for baseband input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)
  • the third intermediate frequency(RF input)
    The R&S FSW is triggered as soon as the trigger threshold is exceeded around the selected frequency (= start frequency in the frequency sweep). The trigger threshold depends on the defined trigger level, as well as on the RF attenuation and preamplification. A reference level offset, if defined, is also considered. The trigger bandwidth at the intermediate frequency depends on the RBW and sweep type. For details on available trigger levels and trigger bandwidths see the data sheet.

Note: Be aware that in auto sweep type mode, due to a possible change in sweep types, the trigger bandwidth may vary considerably for the same RBW setting.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce

SWE:EGAT:SOUR IFP for gated triggering, see [SENSe:​]SWEep:​EGATe:​SOURce

TRIG:SOUR BBP, see TRIGger[:​SEQuence]:​SOURce


RF Power

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce

SWE:EGAT:SOUR RFP for gated triggering, see [SENSe:​]SWEep:​EGATe:​SOURce


Power Sensor

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source > Power Sensor
Power Sensor

Uses an external power sensor as a trigger source. This option is only available if a power sensor is connected and configured.

(See "How to Work With a Power Sensor".)

If a power sensor is selected as the trigger mode, the following softkeys are not available; these settings are configured in the "Power Sensor Configuration" dialog box (see"Power Sensor Settings" ).

  • "Trigger Level (Repetition interval)"
  • "Slope"
  • "Hysteresis"
  • "Trigger Holdoff"

Note: For R&S power sensors, the "Gate Mode" Lvl is not supported. The signal sent by these sensors merely reflects the instant the level is first exceeded, rather than a time period. However, only time periods can be used for gating in level mode. Thus, the trigger impulse from the sensors is not long enough for a fully gated measurement; the measurement cannot be completed.

Remote command:

TRIG:SOUR PSE, see TRIGger[:​SEQuence]:​SOURce

SWE:EGAT:SOUR PSE for gated triggering, see [SENSe:​]SWEep:​EGATe:​SOURce


Time

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Source > Time
Time

Triggers in a specified repetition interval.

Remote command:

TRIG:SOUR TIME, see TRIGger[:​SEQuence]:​SOURce


Trigger Level (Repetition interval)

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Level (Repetition interval)
Trigger Level (Repetition interval)

Defines the trigger level for the specified trigger source. For time triggers, the repetition interval is defined.

For gated measurements, this setting also defines the gate level.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel:​IFPower

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

TRIGger[:​SEQuence]:​LEVel:​VIDeo

TRIGger[:​SEQuence]:​LEVel:​RFPower

TRIGger[:​SEQuence]:​TIME:​RINTerval


Drop-Out Time

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time".

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger) Only possible for zero span (e.g. I/Q Analyzer application) and gated trigger switched off Maximum allowed range limited by the sweep time: pretriggermax = sweep time

For the "Time" trigger source, this function is not available.

Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis".

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff".

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Slope

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Trigger Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

For gated measurements in "Edge" mode, the slope also defines whether the gate starts on a falling or rising edge.

Remote command:

TRIGger[:​SEQuence]:​SLOPe

[SENSe:​]SWEep:​EGATe:​POLarity


Gate Settings

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Gate Settings
Gate Settings

Gate settings define one or more extracts of the signal to be measured.

For details see "Gated Measurements"

Note: Gating is not available for measurements on I/Q-based data.

└ Gated Trigger
└ Gate Mode
└ Gate Delay
└ Gate Length


Gated Trigger

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Gate Settings > Gated Trigger
Gated Trigger

Switches gated triggering on or off.

If the gate is switched on, a gate signal applied to one of the "TRIGGER INPUT" connectors or the internal IF power detector controls the sweep of the analyzer.

For details see "Gated Measurements"


Gate Mode

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Gate Settings > Gate Mode
Gate Mode

Sets the gate mode.

For more information see "Gated Measurements"

"Edge"

The gate opens and the measurement starts when a defined level in the gate source is exceeded and stops when the defined "Gate Length" is reached.

"Lvl"

The gate opens and the measurement starts when a defined level in the gate source is exceeded and stops when the gate source drops below the "Trigger Level".

This mode is not supported when using R&S Power Sensors as power triggers ("Trg/Gate Source" = Power Sensor or External).

Remote command:

[SENSe:​]SWEep:​EGATe:​TYPE


Gate Delay

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Gate Settings > Gate Delay
Gate Delay

Defines the delay time between the gate signal and the continuation of the measurement. The delay position on the time axis in relation to the sweep is indicated by a line labeled "GD".

For more information see "Gated Measurements"

Remote command:

[SENSe:​]SWEep:​EGATe:​HOLDoff


Gate Length

Common Measurement Settings > Trigger and Gate Configuration > Trigger and Gate Settings > Gate Settings > Gate Length
Gate Length

Defines how long the gate is open when it is triggered. The gate length can only be set in the edge-triggered gate mode. In the level-triggered mode the gate length depends on the level of the gate signal.

The gate length in relation to the sweep is indicated by a line labeled "GL".

For more information see "Gated Measurements"

Remote command:

[SENSe:​]SWEep:​EGATe:​LENGth


How to Configure a Triggered and Gated Measurement

Common Measurement Settings > Trigger and Gate Configuration > How to Configure a Triggered and Gated Measurement
How to Configure a Triggered and Gated Measurement

The following step-by-step instructions demonstrate how to configure a triggered and gated measurement manually. For remote operation see "Configuring Triggered and Gated Measurements".

Trigger and gate settings are configured in the "Trigger and Gate" dialog box.

To display the "Trigger and Gate" dialog box, do one of the following:
  • Select "Trigger/Gate" from the "Overview".
  • Select the TRIG key and then the "Trigger/Gate Config" softkey.

The following tasks are described:

Contents
  • How to Determine the Required Trigger/Gate Parameters
  • How to Configure a Triggered Measurement
  • How to Configure a Gated Measurement


How to Determine the Required Trigger/Gate Parameters

Common Measurement Settings > Trigger and Gate Configuration > How to Configure a Triggered and Gated Measurement > How to Determine the Required Trigger/Gate Parameters
How to Determine the Required Trigger/Gate Parameters

The following step-by-step instructions demonstrate how to determine the required trigger and gate parameters manually. For remote operation see "Configuring Triggered and Gated Measurements".

  1. In the "Trigger and Gate" dialog box, switch on "Show Preview".

    A zero span measurement for the currently defined center frequency is displayed.

  2. Set the "Frequency", "RBW" and "Sweep Time" such that the relevant part of the signal is displayed, for example a complete burst.

  3. Determine the parameters you want to use to define the trigger and gate conditions from the preview diagram, for example:

    • the length of a burst or slot
    • the upper or lower power level of a pulse
    • the maximum noise level
    • the power level or time at which a certain incident occurs

  4. Try out different trigger and gate settings as described in "How to Configure a Triggered Measurement" and "How to Configure a Gated Measurement", then select "Update Main Diagram" to see the effect of the current settings on the main measurement in the background.

  5. If the results are as expected, close the dialog box to keep the changes permanently. Otherwise, correct the settings as necessary.


How to Configure a Triggered Measurement

Common Measurement Settings > Trigger and Gate Configuration > How to Configure a Triggered and Gated Measurement > How to Configure a Triggered Measurement
How to Configure a Triggered Measurement

A triggered measurement is started only when the trigger conditions are fulfilled. The following step-by-step instructions demonstrate how to configure a triggered measurement manually. For remote operation see "Configuring Triggered and Gated Measurements".

Trigger and gate settings are configured in the "Trigger and Gate" dialog box which is displayed when you do one of the following:
  • Select "Trigger/Gate" from the "Overview".
  • Select the TRIG key and then the "Trigger/Gate Config" softkey.
To define a time trigger:

  1. In the "Trigger and Gate" dialog box, define the "Trigger Source" = "Time".

  2. Define the "Repetition Interval": the time after which a new measurement is started.

To define an external trigger:

  1. Connect an external device that will provide the trigger signal to one of the TRIGGER INPUT connectors on the front or rear panel (for details see the R&S FSW "Getting Started" manual).

  2. In the "Trigger and Gate" dialog box, define the "Trigger Source" = "External".

  3. If you are using one of the variable TRIGGER INPUT/OUTPUT connectors, you must define their use as input connectors. In the "Trigger In/Out" tab of the "Trigger and Gate" dialog box, set the corresponding trigger to "Input".

    (Note: Trigger 2 is on the front panel, Trigger 3 is on the rear panel.)

  4. Configure the external trigger as described for the other power triggers.

To define a power trigger:

  1. In the "Trigger and Gate" dialog box, define the "Trigger Source" = "IF Power" or "Video". Note that the video signal corresponds to the envelope of the IF signal: it has been processed by the resolution and video filters and the selected detector.

  2. Define the "Trigger Level": the power level at which the measurement will start.

    For a "Video" trigger source you can move the level line graphically to define the level. If you define the value numerically, you must enter a percentage of the full diagram height as the level.

  3. Define whether the signal must cross the trigger level on a falling or on a rising edge ("Slope") to trigger the measurement.

  4. To start the measurement with a time delay, define a "Trigger Offset".

  5. To reject triggers due to noise or jittering in the signal, define a "Hysteresis" that is larger than the expected noise or jittering. After the previous trigger, the signal must exceed this threshold before the next level crossing triggers a new measurement.

  6. To skip multiple triggers in a burst, define a "Holdoff" time that must pass between two triggers. The holdoff time should be slightly larger than the burst.


How to Configure a Gated Measurement

Common Measurement Settings > Trigger and Gate Configuration > How to Configure a Triggered and Gated Measurement > How to Configure a Gated Measurement
How to Configure a Gated Measurement

A gated measurement records data only while the gate conditions are fulfilled. These step-by-step instructions demonstrate how to configure a gated measurement manually. For remote operation see "Configuring Gated Measurements".

To display the "Trigger and Gate" dialog box, do one of the following:
  • Select "Trigger/Gate" from the "Overview".
  • Select the TRIG key and then the "Trigger/Gate Config" softkey.

  1. Determine the required parameters as described in "How to Determine the Required Trigger/Gate Parameters".

  2. The gate is opened by a trigger event, which must be based on a power source. Define the trigger as described in "How to Configure a Triggered Measurement". As the "Trigger Source", use "IF Power", "Video" or "External".

  3. Define how long the gate is to remain open:

    To measure the signal as long as the trigger level is exceeded, for example for one or more pulses, define "Gate Mode" = "Level".

    To measure the signal for a certain time after a level is exceeded, for example during a burst:

    1. Define "Gate Mode" = "Edge".

    2. Define the time to measure for each gate: "Gate Length".

  4. To open the gate with a time delay, for example to ignore an overshoot, define a "Gate Delay".

  5. Select "Gated Trigger" = "On".


How to Output a Trigger Signal

Common Measurement Settings > Trigger and Gate Configuration > How to Output a Trigger Signal
How to Output a Trigger Signal

Using one of the variable TRIGGER INPUT/OUTPUT connectors of the R&S FSW, the internal trigger signal can be output for use by other connected devices. For details on the connectors see the R&S FSW "Getting Started" manual.

To output a trigger to a connected device

  1. In the "Trigger In/Out" tab of the "Trigger and Gate" dialog box, set the trigger to be used to "Output".

    (Note: Trigger 2 is output to the front panel connector, Trigger 3 is output to the rear panel connector.)

  2. Define whether the trigger signal is to be output automatically ("Output Type" = "Device triggered" or "Trigger Armed") or whether you want to start output manually ("Output Type" = "User-defined").

  3. For manual output: Specify the constant signal level and the length of the trigger pulse to be output. Note that the level of the trigger pulse is opposite to the constant output "Level" setting (compare the graphic on the "Send Trigger" button).

  4. Connect a device that will receive the trigger signal to the configured TRIGGER INPUT/OUTPUT connector.

  5. Start a measurement and wait for an internal trigger, or select the "Send Trigger" button.

    The configured trigger is output to the connector.


Adjusting Settings Automatically

Common Measurement Settings > Adjusting Settings Automatically
Adjusting Settings Automatically

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

MSRA/MSRT operating mode

In MSRA and MSRT operating mode, settings related to data acquisition can only be adjusted automatically for the MSRA/MSRT Master, not the applications.

Adjusting settings automatically during triggered measurements

When you select an auto adjust function a measurement is performed to determine the optimal settings. If you select an auto adjust funtion for a triggered measurement, you are asked how the R&S FSW should behave:

  • (default:) The measurement for adjustment waits for the next trigger
  • The measurement for adjustment is performed without waiting for a trigger.
    The trigger source is temporarily set to "Free Run". After the measurement is completed, the original trigger source is restored. The trigger level is adjusted as follows:
    – For IF Power and RF Power triggers:
    Trigger Level = Reference Level - 15 dB
    – For Video trigger:
    Trigger Level = 85 %

Remote command:

[SENSe:​]ADJust:​CONFigure:​TRIG

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Adjusting the Center Frequency Automatically (Auto Freq)
└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Adjusting all Determinable Settings Automatically (Auto All)

Common Measurement Settings > Adjusting Settings Automatically > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Frequency
  • Auto Level
Remote command:

[SENSe:​]ADJust:​ALL


Adjusting the Center Frequency Automatically (Auto Freq)

Common Measurement Settings > Adjusting Settings Automatically > Adjusting the Center Frequency Automatically (Auto Freq)
Adjusting the Center Frequency Automatically (Auto Freq)

This function adjusts the center frequency automatically.

The optimum center frequency is the frequency with the highest S/N ratio in the frequency span. As this function uses the signal counter, it is intended for use with sinusoidal signals.

(See "Performing a Highly Accurate Frequency Measurement (Signal Count)")

Remote command:

[SENSe:​]ADJust:​FREQuency


Resetting the Automatic Measurement Time (Meastime Auto)

Common Measurement Settings > Adjusting Settings Automatically > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

(Spectrum application: 1 ms)

For details see "Adjusting Settings Automatically".

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

Common Measurement Settings > Adjusting Settings Automatically > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically".

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

Common Measurement Settings > Adjusting Settings Automatically > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

Common Measurement Settings > Adjusting Settings Automatically > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


Common Analysis and Display Functions

General methods and basic settings to display and analyze measurements, regardless of the operating mode, are described here. If you are performing a specific measurement task, using an operating mode other than Signal and Spectrum Analyzer mode, or an application other than the Spectrum application, be sure to check the specific application or mode description for settings and functions that may deviate from these common settings.

The analysis settings and functions are available via the "Analysis" dialog box, which is displayed when you select the "Analysis" button in the "Overview". Additional measurement-specific analysis functions may be available in separate tabs in the "Analysis" dialog box. These are described with the individual measurements.

See "Measurements".

Contents
  • Result Display Configuration
  • Zoomed Displays
  • Trace Configuration
  • Marker Usage
  • Display and Limit Lines


Result Display Configuration

Common Analysis and Display Functions > Result Display Configuration
Result Display Configuration

Measurement results can be evaluated in many different ways, for example graphically, as summary tables, statistical evaluations etc. Thus, the result display is highly configurable to suit your specific requirements and optimize analysis. Here you can find out how to optimize the display for your measurement results.

Basic operations concerning the R&S FSW display, for example how to use the SmartGrid, are described in "Laying out the Result Display with the SmartGrid".

General display settings that are usually configured during initial instrument setup, independently of the current measurement, e.g. which items or colors are displayed on the screen, are described in "Display Settings".

Contents
  • Basic Evaluation Methods
  • Laying out the Result Display with the SmartGrid


Basic Evaluation Methods

Common Analysis and Display Functions > Result Display Configuration > Basic Evaluation Methods
Basic Evaluation Methods

Measurement results can be displayed and evaluated using various different methods, also at the same time. Depending on the currently selected measurement, in particular when using optional firmware applications, not all evaluation methods are available.

The evaluation methods described here are available for most measurements in the Spectrum application.

└ Diagram
└ Marker Table
└ Marker Peak List
└ Result Summary
└ Spectrogram


Diagram

Common Analysis and Display Functions > Result Display Configuration > Basic Evaluation Methods > Diagram
Diagram

Displays a basic level vs. frequency or level vs. time diagram of the measured data to evaluate the results graphically. This is the default evaluation method. Which data is displayed in the diagram depends on the "Trace" settings. Scaling for the y-axis can be configured.

See "Trace Configuration" and "Scaling the Y-Axis".

Remote command:

LAY:ADD? '1',RIGH, DIAG, see LAYout:​ADD[:​WINDow]?


Marker Table

Common Analysis and Display Functions > Result Display Configuration > Basic Evaluation Methods > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Marker Peak List

Common Analysis and Display Functions > Result Display Configuration > Basic Evaluation Methods > Marker Peak List
Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum or time domain. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

You can define search and sort criteria to influence the results of the analysis (see "Marker Search Settings").

Remote command:

LAY:ADD? '1',RIGH, PEAK, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Result Summary

Common Analysis and Display Functions > Result Display Configuration > Basic Evaluation Methods > Result Summary
Result Summary

Result summaries provide the results of specific measurement functions in a table for numerical evaluation. The contents of the result summary vary depending on the selected measurement function. See the description of the individual measurement functions for details.

Remote command:

LAY:ADD? '1',RIGH, RSUM, see LAYout:​ADD[:​WINDow]?


Spectrogram

Common Analysis and Display Functions > Result Display Configuration > Basic Evaluation Methods > Spectrogram
Spectrogram

A spectrogram shows how the spectral density of a signal varies over time. The x-axis shows the frequency or sweep time, the y-axis shows the measurement time. A third dimension, the power level, is indicated by different colors. Thus you can see how the strength of the signal varies over time for different frequencies.

The spectrogram display consists of two diagrams: the standard spectrum result display (upper diagram) and the spectrogram result display (lower diagram).

For details see "Working with Spectrograms".

Remote command:

LAY:ADD? '1',RIGH, SGR, see LAYout:​ADD[:​WINDow]?


Zoomed Displays

Common Analysis and Display Functions > Zoomed Displays
Zoomed Displays

You can zoom into the diagram to visualize the measurement results in greater detail. Using the touchscreen or a mouse pointer you can easily define the area to be enlarged.

Zoom and the number of sweep points

Note that zooming is merely a visual tool, it does not change any measurement settings, such as the number of sweep points!

You should increase the number of sweep points before zooming, as otherwise the function has no real effect (see "How Much Data is Measured: Sweep Points and Sweep Count").

Contents
  • Single Zoom Versus Multiple Zoom
  • Zoom Functions
  • How to Zoom Into a Diagram


Single Zoom Versus Multiple Zoom

Common Analysis and Display Functions > Zoomed Displays > Single Zoom Versus Multiple Zoom
Single Zoom Versus Multiple Zoom

Two different zoom modes are available: single zoom and multiple zoom. A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible. In multiple zoom mode, you can enlarge up to four different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom areas can be moved and resized any time. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

Single zoom
Multiple zoom
Using the zoom area to restrict a peak search

The selected zoom area can be used to restrict the search range for a peak search, but only in single zoom mode (see "Using Zoom Limits").


Zoom Functions

Common Analysis and Display Functions > Zoomed Displays > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom".

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

Common Analysis and Display Functions > Zoomed Displays > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays".

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

Common Analysis and Display Functions > Zoomed Displays > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays".

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

Common Analysis and Display Functions > Zoomed Displays > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays".

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

Common Analysis and Display Functions > Zoomed Displays > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays".

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


How to Zoom Into a Diagram

Common Analysis and Display Functions > Zoomed Displays > How to Zoom Into a Diagram
How to Zoom Into a Diagram

The remote commands required to zoom into a display are described in "Zooming into the Display".

The following tasks are described here:

  • "To zoom into the diagram at one position"
  • "To return to selection mode in the diagram"
  • "To return to original display"
  • "To zoom into multiple positions in the diagram"
To zoom into the diagram at one position

  1. Click on the "Single Zoom" icon in the toolbar.

    Zoom mode is activated.

  2. Select the area in the diagram to be enlarged on the touchscreen. The selected area is indicated by a dotted rectangle.

    When you leave the touchscreen, the diagram is replaced by the zoomed trace area.

  3. Repeat these steps, if necessary, to enlarge the diagram further.

Scrolling in the zoomed display

You can scroll the diagram area to display the entire diagram using the scrollbars at the right and at the bottom of the diagram.

To return to selection mode in the diagram

While you are in zoom mode, touching the screen changes the zoom area. In order to select or move a trace or marker, you must switch back to selection mode:

►

Select the "Selection mode" icon in the toolbar.

To return to original display
►

Click on the "Zoom Off" icon in the toolbar.

The original trace display is restored. Zoom mode remains active, however.

To switch off zoom mode and return to selection mode, select the "Selection mode" icon in the toolbar.

To zoom into multiple positions in the diagram

  1. Click on the "Multiple Zoom" icon in the toolbar.

    Multiple zoom mode is activated.

  2. Select the first area in the diagram to be enlarged as described in "To zoom into the diagram at one position". The selected area is indicated by a dotted rectangle.

    When you have completed your selection, the original trace is shown in an overview diagram with the selected area indicated by a dotted rectangle. The zoomed trace area is displayed in a separate window (see figure "Multiple zoom".

  3. In the overview diagram, select the next area to be enlarged.

    The second zoom area is indicated in the overview diagram, and a second zoom window is displayed.

  4. Repeat these steps, if necessary, to zoom into further trace areas (up to four).

To move or change zoom areas

In multiple zoom mode, you can change the size or position of the individual zoom areas easily at any time.

  1. If necessary, switch off zoom mode and return to selection mode by selecting the "Selection mode" icon in the toolbar.

  2. To resize a zoom area, tap directly on the corresponding frame in the overview window and drag the line to change the size of the frame.

    To move a zoom area, tap inside the corresponding frame in the overview window and drag the frame to the new position.

    The contents of the zoom windows are adapted accordingly.


Trace Configuration

Common Analysis and Display Functions > Trace Configuration
Trace Configuration

A trace is a collection of measured data points. The trace settings determine how the measured data is analyzed and displayed on the screen.

Contents
  • Basics on Setting up Traces
  • Trace Configuration
  • How to Configure Traces


Basics on Setting up Traces

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces
Basics on Setting up Traces

Some background knowledge on traces is provided here for a better understanding of the required configuration settings.

Each trace represents an analysis of the measured data. Up to 6 traces can be displayed in each window, and up to 16 windows can be displayed on the screen. So, in theory, you can analyze the data measured by the R&S FSW in almost 100 different ways simultaneously!

Trace settings are stored on the instrument for each window. So when you switch to a different window, the trace settings previously configured for that window are restored.

Contents
  • Mapping Samples to Sweep Points with the Trace Detector
  • Analyzing Several Traces - Trace Mode
  • How Many Traces are Averaged - Sweep Count + Sweep Mode
  • How Trace Data is Averaged - the Averaging Mode
  • Combining Several Trace Results - Trace Math Evaluation
  • Working with Spectrograms


Mapping Samples to Sweep Points with the Trace Detector

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > Mapping Samples to Sweep Points with the Trace Detector
Mapping Samples to Sweep Points with the Trace Detector

A trace displays the values measured at the sweep points. The number of samples taken during a sweep is much larger than the number of sweep points that are displayed in the measurement trace.

Example:

Assume the following measurement parameters:

  • Sample rate: 32 MSamples / s
  • Sweep points: 1000
  • Sweep time: 100 ms
  • Span: 5 GHz

During a single sweep, 3.2 * 106 samples are collected and distributed to 1000 sweep points, i.e. 3200 samples are collected per sweep point. For each sweep point, the measured data for a frequency span of 5 MHz (span/<sweep points>) is analyzed.

Note that if you increase the number of sweep points, the frequency span analyzed for each point in the trace decreases, making the result more stable.

See also "How Much Data is Measured: Sweep Points and Sweep Count".

Obviously, a data reduction must be performed to determine which of the samples are displayed for each sweep point. This is the trace detector's task.

The trace detector can analyze the measured data using various methods:

The detector activated for the specific trace is indicated in the corresponding trace information by an abbreviation.

Detector types

Detector

Abbrev.

Description

Positive Peak

Pk

Determines the largest of all positive peak values of the levels measured at the individual frequencies which are displayed in one sample point

Negative Peak

Mi

Determines the smallest of all negative peak values of the levels measured at the individual frequencies which are displayed in one sample point

Auto Peak

Ap

Combines the peak detectors; determines the maximum and the minimum value of the levels measured at the individual frequencies which are displayed in one sample point

(not available for SEM)

RMS

Rm

Calculates the root mean square of all samples contained in a sweep point.

To this effect, R&S FSW uses the linear voltage after envelope detection. The sampled linear values are squared, summed and the sum is divided by the number of samples (= root mean square). For logarithmic display the logarithm is formed from the square sum. For linear display the root mean square value is displayed. Each sweep point thus corresponds to the power of the measured values summed up in the sweep point.

The RMS detector supplies the power of the signal irrespective of the waveform (CW carrier, modulated carrier, white noise or impulsive signal). Correction factors as needed for other detectors to measure the power of the different signal classes are not required.

Average

Av

Calculates the linear average of all samples contained in a sweep point.

To this effect, R&S FSW uses the linear voltage after envelope detection. The sampled linear values are summed up and the sum is divided by the number of samples (= linear average value). For logarithmic display the logarithm is formed from the average value. For linear display the average value is displayed. Each sweep point thus corresponds to the average of the measured values summed up in the sweep point.

The average detector supplies the average value of the signal irrespective of the waveform (CW carrier, modulated carrier, white noise or impulsive signal).

Sample

Sa

Selects the last measured value of the levels measured at the individual frequencies which are displayed in one sample point; all other measured values for the frequency range are ignored

Quasi Peak

QP

Resembles the behavior of an analog voltmeter by analyzing the measured values for a sample point. The quasipeak detector is especially designed for the requirements of EMI measurements and is used for analyzing pulse-shaped spurious. This detector is only available if the R&S FSW EMI measurement option (K54) is installed.

The result obtained from the selected detector for a sweep point is displayed as the value at this frequency point in the trace.

The trace detector for the individual traces can be selected manually by the user or set automatically by the R&S FSW.

The detectors of the R&S FSW are implemented as pure digital devices. All detectors work in parallel in the background, which means that the measurement speed is independent of the detector combination used for different traces.

RMS detector and VBW

If the RMS detector is selected, the video bandwidth in the hardware is bypassed. Thus, duplicate trace averaging with small VBWs and RMS detector no longer occurs. However, the VBW is still considered when calculating the sweep time. This leads to a longer sweep time for small VBW values. Thus, you can reduce the VBW value to achieve more stable trace curves even when using an RMS detector. Normally, if the RMS detector is used the sweep time should be increased to get more stable traces.

Auto detector

If the R&S FSW is set to define the appropriate detector automatically, the detector is set depending on the selected trace mode:

Trace mode | Detector
Clear Write | Auto Peak
Max Hold | Positive Peak
Min Hold | Negative Peak
Average | Sample Peak
View | –
Blank | –


Analyzing Several Traces - Trace Mode

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > Analyzing Several Traces - Trace Mode
Analyzing Several Traces - Trace Mode

If several sweep are performed one after the other, or continuous sweep are performed, the trace mode determines how the data for subsequent traces is processed. After each sweep, the trace mode determines whether:

  • the data is frozen (View)
  • the data is hidden (Blank)
  • the data is replaced by new values (Clear Write)
  • the data is replaced selectively (Max Hold, Min Hold, Average)

Each time the trace mode is changed, the selected trace memory is cleared.

The trace mode also determines the detector type if the detector is set automatically, see "Mapping Samples to Sweep Points with the Trace Detector".

The R&S FSW supports the following trace modes:

Overview of available trace modes

Trace Mode

Description

Blank

Hides the selected trace.

Clear Write

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

All available detectors can be selected.

Max Hold

The maximum value is determined over several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

This mode is especially useful with modulated or pulsed signals. The signal spectrum is filled up upon each sweep until all signal components are detected in a kind of envelope.

This mode is not available for statistics measurements.

Min Hold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

This mode is useful for example for making an unmodulated carrier in a composite signal visible. Noise, interference signals or modulated signals are suppressed, whereas a CW signal is recognized by its constant level.

This mode is not available for statistics measurements.

Average

The average is formed over several measurements and displayed.

The "Sweep/Average Count" determines the number of averaging procedures.

This mode is not available for statistics measurements.

View

The current contents of the trace memory are frozen and displayed.

If a trace is frozen ("View" mode), the instrument settings, apart from level range and reference level (see below), can be changed without impact on the displayed trace. The fact that the displayed trace no longer matches the current instrument setting is indicated by the [image] icon on the tab label.

If the level range or reference level is changed, the R&S FSW automatically adapts the trace data to the changed display range. This allows an amplitude zoom to be made after the measurement in order to show details of the trace.


How Many Traces are Averaged - Sweep Count + Sweep Mode

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > How Many Traces are Averaged - Sweep Count + Sweep Mode
How Many Traces are Averaged - Sweep Count + Sweep Mode

In "Average" trace mode, the sweep count and sweep mode determine how many traces are averaged. The more traces are averaged, the smoother the trace is likely to become.

The algorithm for averaging traces depends on the sweep mode and sweep count.

  • sweep count = 0 (default)
    – In "Continuous Sweep" mode, a continuous average is calculated for 10 sweeps, according to the following formula:
    Equation 1

    Due to the weighting between the current trace and the average trace, past values have practically no influence on the displayed trace after about ten sweeps. With this setting, signal noise is effectively reduced without need for restarting the averaging process after a change of the signal.
    – In "Single Sweep" mode, the current trace is averaged with the previously stored averaged trace. No averaging is carried out for the first sweep but the measured value is stored in the trace memory. The next time a sweep is performed, the trace average is calculated according to the following formula:

    The averaged trace is then stored in the trace memory.
  • sweep count = 1
    The currently measured trace is displayed and stored in the trace memory. No averaging is performed.
  • sweep count > 1
    For both "Single Sweep" mode and "Continuous Sweep" mode, averaging takes place over the selected number of sweeps. In this case the displayed trace is determined during averaging according to the following formula:
    Equation 2

    where n is the number of the current sweep (n = 2 ... Sweep Count).
    No averaging is carried out for the first sweep but the measured value is stored in the trace memory. With increasing n, the displayed trace is increasingly smoothed since there are more individual sweeps for averaging.
    After the selected number of sweeps the average trace is saved in the trace memory. Until this number of sweeps is reached, a preliminary average is displayed. When the averaging length defined by the "Sweep Count" is attained, averaging is continued in continuous sweep mode or for "Continue Single Sweep" according to the following formula:

    where N is the sweep count


How Trace Data is Averaged - the Averaging Mode

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > How Trace Data is Averaged - the Averaging Mode
How Trace Data is Averaged - the Averaging Mode

When the trace is averaged over several sweeps (Trace mode: "Average"), different methods are available to determine the trace average.

With logarithmic averaging, the dB values of the display voltage are averaged or substracted from each other with trace mathematical functions.

With linear averaging, the level values in dB are converted into linear voltages or powers prior to averaging. Voltage or power values are averaged or offset against each other and reconverted into level values.

For stationary signals the two methods yield the same result.

Logarithmic averaging is recommended if sinewave signals are to be clearly visible against noise since with this type of averaging noise suppression is improved while the sinewave signals remain unchanged.

For noise or pseudo-noise signals the positive peak amplitudes are decreased in logarithmic averaging due to the characteristic involved and the negative peak values are increased relative to the average value. If the distorted amplitude distribution is averaged, a value is obtained that is smaller than the actual average value. The difference is -2.5 dB.

This low average value is usually corrected in noise power measurements by a 2.5 dB factor. Therefore the R&S FSW offers the selection of linear averaging. The trace data is linearized prior to averaging, then averaged and logarithmized again for display on the screen. The average value is always displayed correctly irrespective of the signal characteristic.


Combining Several Trace Results - Trace Math Evaluation

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > Combining Several Trace Results - Trace Math Evaluation
Combining Several Trace Results - Trace Math Evaluation

If you have several traces with different modes, for example an average trace and a maximum trace, it may be of interest to compare the results of both traces. In this example, you could analyze the maximum difference between the average and maximum values. To analyze the span of result values, you could subtract the minimum trace from the maximum trace. For such tasks, mathematical functions on trace results are provided.


Working with Spectrograms

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > Working with Spectrograms
Working with Spectrograms

In addition to the standard "level versus frequency" or "level versus time" traces, the R&S FSW also provides a spectrogram display of the measured data.

A spectrogram shows how the spectral density of a signal varies over time. The x-axis shows the frequency, the y-axis shows the time. A third dimension, the power level, is indicated by different colors. Thus you can see how the strength of the signal varies over time for different frequencies.

Example: Spectrogram for the calibration signal

In this example you see the spectrogram for the calibration signal of the R&S FSW, compared to the standard spectrum display. Since the signal does not change over time, the color of the frequency levels does not change over time, i.e. vertically. The legend above the spectrogram display describes the power levels the colors represent.

Result display

The spectrogram result can consist of the following elements:

Screen layout of the spectrogram result display
1 = Spectrum result display
2 = Spectrogram result display
3 = Current frame indicator
4 = Timestamp / frame number
5 = Color map
6 = Marker
7 = Delta marker
8 = Marker list
Contents
  • Time Frames
  • Color Maps
  • Markers in the Spectrogram


Time Frames

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > Working with Spectrograms > Time Frames
Time Frames

The time information in the spectrogram is displayed vertically, along the y-axis. Each line (or trace) of the y-axis represents one or more captured sweeps and is called a time frame or simply "frame". As with standard spectrum traces, several measured values are combined in one sweep point using the selected detector.

(See "Mapping Samples to Sweep Points with the Trace Detector").

Frames are sorted in chronological order, beginning with the most recently recorded frame at the top of the diagram (frame number 0). With the next sweep, the previous frame is moved further down in the diagram, until the maximum number of captured frames is reached. The display is updated continuously during the measurement, and the measured trace data is stored. Spectrogram displays are continued even after single sweep measurements unless they are cleared manually.

The maximum number of frames that you can capture is summarized in table "Correlation between number of sweep points and number of frames stored in the history buffer".

Correlation between number of sweep points and number of frames stored in the history buffer
Sweep Points | Max. History Depth
≤1250 | 20000
2001 | 12488
4001 | 6247
8.001 | 3124
16.001 | 1562
32.001 | 781

The scaling of the time axis (y-axis) is not configurable. However, you can enlarge the spectrogram display by maximizing the window using the "Split/Maximize" key on the front panel.

Frame analysis - Frame count vs. sweep count

As described for standard spectrum sweeps, the sweep count defines how many sweeps are analyzed to create a single trace. Thus, for a trace in "Average" mode, for example, a sweep count of 10 means that 10 sweeps are averaged to create a single trace, or frame.

The frame count, on the other hand, determines how many frames are plotted during a single sweep measurement (as opposed to a continuous sweep). For a frame count of 2, for example, 2 frames will be plotted during each single sweep. For continuous sweep mode, the frame count is irrelevant; one frame is plotted per sweep until the measurement is stopped.

If you combine the two settings, 20 sweeps will be performed for each single sweep measurement. The first 10 will be averaged to create the first frame, the next 10 will be averaged to create the second frame.

As you can see, increasing the sweep count increases the accuracy of the individual traces, while increasing the frame count increases the number of traces in the diagram.

Especially for "Average" or "Min hold" and "Max hold" trace modes, the number of sweeps that are analyzed to create a single trace has an effect on the accuracy of the results. Thus, you can also define whether the results from frames in previous traces are considered in the analysis for each new trace ("Continue frame").

Tracking absolute time - timestamps

Alternatively to the frame count, the absolute time (that is: a timestamp) at which a frame was captured can be displayed. While the measurement is running, the timestamp shows the system time. In single sweep mode or if the sweep is stopped, the timestamp shows the time and date at the end of the sweep.Thus, the individual frames can be identified by their timestamp or their frame count.

When active, the timestamp replaces the display of the frame number in the diagram footer (see figure "Screen layout of the spectrogram result display").

Displaying individual frames

The spectrogram diagram contains all stored frames since it was last cleared. Arrows on the left and right border of the spectrogram indicate the currently selected frame. The spectrum diagram always displays the spectrum for the currently selected frame. The current frame number is indicated in the diagram footer, or alternatively a timestamp, if activated. The current frame, displayed at the top of the diagram, is frame number 0. Older frames further down in the diagram are indicated by a negative index, e.g."-10". You can display the spectrum diagram of a previous frame by changing the current frame number.

Remote commands:

Activating spectrograms:

CALCulate:​SGRam|SPECtrogram[:​STATe]

Frames:

CALCulate:​SGRam|SPECtrogram:​FRAMe:​COUNt

CALCulate:​SGRam|SPECtrogram:​HDEPth

CALCulate:​SGRam|SPECtrogram:​FRAMe:​SELect

Timestamps:

CALCulate:​SGRam|SPECtrogram:​TSTamp[:​STATe]

CALCulate:​SGRam|SPECtrogram:​TSTamp:​DATA?

Storing results:

MMEMory:​STORe<n>:​SGRam


Color Maps

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > Working with Spectrograms > Color Maps
Color Maps

Spectrograms assign power levels to different colors in order to visualize them. The legend above the spectrogram display describes the power levels the colors represent.

The color display is highly configurable to adapt the spectrograms to your needs. You can define:

  • Which colors to use (Color scheme)
  • Which value range to apply the color scheme to
  • How the colors are distributed within the value range, i.e where the focus of the visualization lies (shape of the color curve)

The individual colors are assigned to the power levels automatically by the R&S FSW.

The Color Scheme

You can select which colors are assigned to the measured values. Four different color ranges or "schemes" are available:

  • Hot

    Uses a color range from blue to red. Blue colors indicate low levels, red colors indicate high ones.
  • Cold

    Uses a color range from red to blue. Red colors indicate low levels, blue colors indicate high ones.
    The "Cold" color scheme is the inverse "Hot" color scheme.
  • Radar

    Uses a color range from black over green to light turquoise with shades of green in between. Dark colors indicate low levels, light colors indicate high ones.
  • Grayscale

    Shows the results in shades of gray. Dark gray indicates low levels, light gray indicates high ones.
The Value Range of the Color Map

If the measured values only cover a small area in the spectrogram, you can optimize the displayed value range so it becomes easier to distinguish between values that are close together, and only parts of interest are displayed at all.

The Shape and Focus of the Color Curve

The color mapping function assigns a specified color to a specified power level in the spectrogram display. By default, colors on the color map are distributed evenly. However, if a certain area of the value range is to be visualized in greater detail than the rest, you can set the focus of the color mapping to that area. Changing the focus is performed by changing the shape of the color curve.

The color curve is a tool to shift the focus of the color distribution on the color map. By default, the color curve is linear. If you shift the curve to the left or right, the distribution becomes non-linear. The slope of the color curve increases or decreases. One end of the color palette then covers a large amount of results, while the other end distributes several colors over a relatively small result range.

You can use this feature to put the focus on a particular region in the diagram and to be able to detect small variations of the signal.

Example:
Linear color curve shape = 0; colors are distributed evenly over the complete result range

In the color map based on the linear color curve, the range from -105.5 dBm to -60 dBm is covered by blue and a few shades of green only. The range from -60 dBm to -20 dBm is covered by red, yellow and a few shades of green.

Spectrogram with default color curve

The sample spectrogram is dominated by blue and green colors. After shifting the color curve to the left (negative value), more colors cover the range from -105.5 dBm to -60 dBm (blue, green and yellow), which occurs more often in the example. The range from -60 dBm to -20 dBm, on the other hand, is dominated by various shades of red only.

Non-linear color curve shape = -0.5
Spectrogram with shifted color curve


Markers in the Spectrogram

Common Analysis and Display Functions > Trace Configuration > Basics on Setting up Traces > Working with Spectrograms > Markers in the Spectrogram
Markers in the Spectrogram

Markers and delta markers are shaped like diamonds in the spectrogram. They are only displayed in the spectrogram if the marker position is inside the visible area of the spectrogram. If more than two markers are active, the marker values are displayed in a separate marker table.

In the spectrum result display, the markers and their frequency and level values (1) are displayed as usual. Additionally, the frame number is displayed to indicate the position of the marker in time (2).

In the spectrogram result display, you can activate up to 16 markers or delta markers at the same time. Each marker can be assigned to a different frame. Therefore, in addition to the frequency you also define the frame number when activating a new marker. If no frame number is specified, the marker is positioned on the currently selected frame. All markers are visible that are positioned on a visible frame. Special search functions are provided for spectrogram markers.

In the spectrum result display, only the markers positioned on the currently selected frame are visible. In "Continuous Sweep" mode this means that only markers positioned on frame 0 are visible. To view markers that are positioned on a frame other than frame 0 in the spectrum result display, you must stop the measurement and select the corresponding frame.


Trace Configuration

Common Analysis and Display Functions > Trace Configuration > Trace Configuration
Trace Configuration

Trace configuration includes the following settings and functions:

Contents
  • Trace Settings
  • Trace Math
  • Trace / Data Export Configuration
  • Spectrogram Settings


Trace Settings

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings
Trace Settings

You can configure the settings for up to 6 individual traces.

For settings on spectrograms, see "Spectrogram Settings".

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace / Data Export Configuration".

└ Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
└ Trace Mode
└ Detector
└ Hold
└ Average Mode
└ Average Count
└ Predefined Trace Settings - Quick Config
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
└ Copy Trace


Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

For details see "How to Configure a Standard Trace".

Remote command:

Selected via numeric suffix of:TRACe<1...6> commands


Trace Mode

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode".

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting. The "Detector" is automatically set to "Auto Peak".
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one. The "Detector" is automatically set to "Positive Peak". This mode is not available for statistics measurements.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one. The "Detector" is automatically set to "Negative Peak". This mode is not available for statistics measurements.
"Average" | The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures. The "Detector" is automatically set to "Sample". This mode is not available for statistics measurements.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Detector

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Detector
Detector

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector".

Note: For EMI measurements, the trace detector is used for the initial peak search only, not for the final test. The detector for the final test is configured in the EMI marker settings, see "EMI Marker Configuration".

"Auto" | Selects the optimum detector for the selected trace and filter mode. This is the default setting.
"Type" | Defines the selected detector type. Note: If the EMI (R&S FSW-K54) measurement option is installed and the filter type "CISPR" is selected, additional detectors are available, even if EMI measurement is not active. For details see "Detectors and Dwell Time".
Remote command:

[SENSe:​][WINDow<n>:​]DETector<trace>[:​FUNCtion]

[SENSe:​][WINDow<n>:​]DETector<t>[:​FUNCtion]:​AUTO


Hold

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Hold
Hold

If activated, traces in "Min Hold", "Max Hold" and "Average" mode are not reset after specific parameter changes have been made.

Normally, the measurement is started anew after parameter changes, before the measurement results are analyzed (e.g. using a marker). In all cases that require a new measurement after parameter changes, the trace is reset automatically to avoid false results (e.g. with span changes). For applications that require no reset after parameter changes, the automatic reset can be switched off.

The default setting is off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE:​HCONtinuous


Average Mode

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Average Mode
Average Mode

Defines the mode with which the trace is averaged over several sweeps. A different averaging mode can be defined for each trace.

This setting is only applicable if trace mode "Average" is selected.

How many sweeps are averaged is defined by the "Sweep/Average Count".

For details see "How Trace Data is Averaged - the Averaging Mode".

"Linear" | The power level values are converted into linear units prior to averaging. After the averaging, the data is converted back into its original unit.
"Logarithmic" | For logarithmic scaling, the values are averaged in dBm. For linear scaling, the behavior is the same as with linear averaging.
"Power" | Activates linear power averaging. The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit. Use this mode to average power values in Volts or Amperes correctly.
Remote command:

[SENSe:​]AVERage<n>:​TYPE


Average Count

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Average Count
Average Count

Determines the number of averaging or maximum search procedures If the trace modes "Average", "Max Hold" or "Min Hold" are set.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

This value is identical to the "Sweep/Average Count" setting in the "Sweep" configuration.

Remote command:

[SENSe:​]AVERage:​COUNt


Predefined Trace Settings - Quick Config

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Predefined Trace Settings - Quick Config
Predefined Trace Settings - Quick Config

Commonly required trace settings have been predefined and can be applied very quickly by selecting the appropriate button.

Function | Trace Settings
Preset All Traces | Trace 1: | Clear Write Auto Detector (Auto Peak)
 | Traces 2-6: | Blank Auto Detector
Set Trace Mode Max | Avg | Min | Trace 1: | Max Hold Auto Detector (Positive Peak)
 | Trace 2: | Average Auto Detector (Sample)
 | Trace 3: | Min Hold Auto Detector (Negative Peak)
 | Traces 4-6: | Blank Auto Detector
Set Trace Mode Max | ClrWrite | Min | Trace 1: | Max Hold Auto Detector (Positive Peak)
 | Trace 2: | Clear Write Auto Detector (Auto Peak)
 | Trace 3: | Min Hold Auto Detector (Negative Peak)
 | Traces 4-6: | Blank Auto Detector


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

For details see "How to Configure a Standard Trace".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Copy Trace

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Settings > Copy Trace
Copy Trace

The "Copy Trace" softkey opens the "Copy Trace" tab of the "Trace Configuration" dialog box.

The "Copy Trace" tab contains functionality to copy trace data to another trace.

The first group of buttons (labelled "Trace 1" to "Trace 6") select the source trace. The second group of buttons (labelled "Copy to Trace 1" to "Copy to Trace 6") select the destination.

Remote command:

TRACe<n>:​COPY


Trace Math

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Math
Trace Math

Trace math settings can be configured via the TRACE key, in the "Trace Math" tab of the "Traces" dialog box.

└ Trace Math Function
└ Trace Math Off
└ Trace Math Position
└ Trace Math Mode


Trace Math Function

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Math > Trace Math Function
Trace Math Function

Defines which trace is subtracted from trace 1. The result is displayed in trace 1 and refers to the zero point defined with the "Trace Math Position" setting. The following subtractions can be performed:

"T1-T2 -> T1" | Subtracts trace 2 from trace 1.
"T1-T3 -> T1" | Subtracts trace 3 from trace 1
"T1-T4 -> T1" | Subtracts trace 4 from trace 1
"T1-T5 -> T1" | Subtracts trace 5 from trace 1
"T1-T6 -> T1" | Subtracts trace 6 from trace 1

To switch off the trace math, use the "Trace Math Off" button.

Remote command:

CALCulate<n>:​MATH[:​EXPression][:​DEFine]

CALCulate<n>:​MATH:​STATe


Trace Math Off

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Math > Trace Math Off
Trace Math Off

Deactivates any previously selected trace math functions.

Remote command:

CALC:MATH:STAT OFF, see CALCulate<n>:​MATH:​STATe


Trace Math Position

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Math > Trace Math Position
Trace Math Position

Defines the zero point on the y-axis of the resulting trace in % of the diagram height. The range of values extends from -100 % to +200 %.

Remote command:

CALCulate<n>:​MATH:​POSition


Trace Math Mode

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace Math > Trace Math Mode
Trace Math Mode

Defines the mode for the trace math calculations.

"Lin"

Activates linear subtraction, which means that the power level values are converted into linear units prior to subtraction. After the subtraction, the data is converted back into its original unit.

This setting takes effect if the grid is set to a linear scale. In this case, subtraction is done in two ways (depending on the set unit):

  • The unit is set to either W or dBm: the data is converted into W prior to subtraction, i.e. averaging is done in W.
  • The unit is set to either V, A, dBmV, dBµV, dBµA or dBpW: the data is converted into V prior to subtraction, i.e. subtraction is done in V.

"Log"

Activates logarithmic subtraction.

This subtraction method only takes effect if the grid is set to a logarithmic scale, i.e. the unit of the data is dBm. In this case the values are subtracted in dBm. Otherwise (i.e. with linear scaling) the behavior is the same as with linear subtraction.

"Power"

Activates linear power subtraction.

The power level values are converted into unit Watt prior to subtraction. After the subtraction, the data is converted back into its original unit.

Unlike the linear mode, the subtraction is always done in W.

Remote command:

CALCulate<n>:​MATH:​MODE


Trace / Data Export Configuration

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace / Data Export Configuration
Trace / Data Export Configuration

The R&S FSW provides various evaluation methods for the results of the performed measurements. However, you may want to evaluate the data with other, external applications. In this case, you can export the measurement data to an ASCII file.

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

For step-by-step instructions on how to export a trace, see "How to Export Trace Data and Numerical Results".

└ Export all Traces and all Table Results
└ Include Instrument Measurement Settings
└ Trace to Export
└ Decimal Separator
└ Export Trace to ASCII File


Export all Traces and all Table Results

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace / Data Export Configuration > Export all Traces and all Table Results
Export all Traces and all Table Results

Selects all displayed traces and result tables (e.g. Result Summary, marker table etc.) in the current application for export to an ASCII file.

Alternatively, you can select one specific trace only for export (see "Trace to Export").

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Remote command:

FORMat:​DEXPort:​TRACes


Include Instrument Measurement Settings

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace / Data Export Configuration > Include Instrument Measurement Settings
Include Instrument Measurement Settings

Includes additional instrument and measurement settings in the header of the export file for result data.

See "Reference: ASCII File Export Format" for details.

Remote command:

FORMat:​DEXPort:​HEADer


Trace to Export

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace / Data Export Configuration > Trace to Export
Trace to Export

Defines an individual trace that will be exported to a file.

This setting is not available if "Export all Traces and all Table Results" is selected.


Decimal Separator

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace / Data Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Trace to ASCII File

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Trace / Data Export Configuration > Export Trace to ASCII File
Export Trace to ASCII File

Opens a file selection dialog box and saves the selected trace in ASCII format (.dat) to the specified file and directory.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

If the spectrogram display is selected when you perform this function, the entire histogram buffer with all frames is exported to a file. The data corresponding to a particular frame begins with information about the frame number and the time that frame was recorded. For large history buffers the export operation may take some time.

For details on the file format see "Reference: ASCII File Export Format".

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Remote command:

MMEMory:​STORe<n>:​TRACe

MMEMory:​STORe<n>:​SGRam


Spectrogram Settings

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings
Spectrogram Settings

The individual settings available for spectrogram display are described here. For settings on color mapping, see "Color Map Settings".

Settings concerning the frames and how they are handled during a sweep are provided as additional sweep settings for spectrogram display, see "Spectrogram Frames".

Search functions for spectrogram markers are described in "Marker Search Settings for Spectrograms".

For background information see also "Working with Spectrograms".

Contents
  • General Spectrogram Settings
  • Color Map Settings


General Spectrogram Settings

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > General Spectrogram Settings
General Spectrogram Settings

This section describes general settings for spectrogram display. They are available when you press the TRACE key and then select the "Spectrogram Config" softkey.

└ State
└ Selecting a frame to display
└ History Depth
└ Timestamp
└ Color Mapping
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Clear Spectrogram


State

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > General Spectrogram Settings > State
State

Activates and deactivates the spectrogram result display

Remote command:

CALCulate:​SGRam|SPECtrogram[:​STATe]


History Depth

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > General Spectrogram Settings > History Depth
History Depth

Sets the number of frames that the R&S FSW stores in its memory.

The maximum number of frames depends on the "Sweep Points". For an overview of the maximum number of frames depending on the number of sweep points, see table "Correlation between number of sweep points and number of frames stored in the history buffer".

If the memory is full, the R&S FSW deletes the oldest frames stored in the memory and replaces them with the new data.

Remote command:

CALCulate:​SGRam|SPECtrogram:​HDEPth


Timestamp

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > General Spectrogram Settings > Timestamp
Timestamp

Activates and deactivates the timestamp. The timestamp shows the system time while the measurement is running. In single sweep mode or if the sweep is stopped, the timestamp shows the time and date of the end of the sweep.

When active, the timestamp replaces the display of the frame number.

Remote command:

CALCulate:​SGRam|SPECtrogram:​TSTamp[:​STATe]

CALCulate:​SGRam|SPECtrogram:​TSTamp:​DATA?


Color Mapping

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > General Spectrogram Settings > Color Mapping
Color Mapping

Opens the "Color Map" dialog.

For details see "Color Maps".


Color Map Settings

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > Color Map Settings
Color Map Settings

The settings for color mapping are displayed in the "Color Mapping" dialog box that is displayed when you press the "Color Mapping" softkey in the "Spectrogram" menu, or select the color map in the spectrogram display.

For more information on color maps see "Color Maps".

For details on changing color mapping settings see "How to Configure the Color Mapping".

In addition to the available color settings, the dialog box displays the current color map and provides a preview of the display with the current settings.

Color Mapping dialog box
1 = Color map: shows the current color distribution
2 = Preview pane: shows a preview of the spectrogram with any changes that you make to the color scheme
3 = Color curve pane: graphical representation of all settings available to customize the color scheme
4/5 = Color range start and stop sliders: define the range of the color map or amplitudes for the spectrogram
6 = Color curve slider: adjusts the focus of the color curve
7 = Histogram: shows the distribution of measured values
8 = Scale of the horizontal axis (value range)
└ Start / Stop
└ Shape
└ Hot/Cold/Radar/Grayscale
└ Auto
└ Set to Default


Start / Stop

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > Color Map Settings > Start / Stop
Start / Stop

Defines the lower and upper boundaries of the value range of the spectrogram.

For details see "Color Maps".

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​LOWer

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​UPPer


Shape

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > Color Map Settings > Shape
Shape

Defines the shape and focus of the color curve for the spectrogram result display.

For details see "Color Maps".

"-1 to <0" | More colors are distributed among the lower values
"0" | Colors are distributed linearly among the values
">0 to 1" | More colors are distributed among the higher values
Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​SHAPe


Hot/Cold/Radar/Grayscale

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > Color Map Settings > Hot/Cold/Radar/Grayscale
Hot/Cold/Radar/Grayscale

Sets the color scheme for the spectrogram.

For details see "Color Maps".

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor[:​STYLe]


Auto

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > Color Map Settings > Auto
Auto

Defines the color range automatically according to the existing measured values for optimized display.


Set to Default

Common Analysis and Display Functions > Trace Configuration > Trace Configuration > Spectrogram Settings > Color Map Settings > Set to Default
Set to Default

Sets the color mapping to the default settings.

Remote command:

DISPlay[:​WINDow<n>]:​SGRam|SPECtrogram:​COLor:​DEFault


How to Configure Traces

Common Analysis and Display Functions > Trace Configuration > How to Configure Traces
How to Configure Traces

The following step-by-step procedures describe the following tasks:

Contents
  • How to Configure a Standard Trace
  • How to Display and Configure a Spectrogram
  • How to Copy Traces


How to Configure a Standard Trace

Common Analysis and Display Functions > Trace Configuration > How to Configure Traces > How to Configure a Standard Trace
How to Configure a Standard Trace

Step-by-step instructions on configuring the trace settings are provided here. For details on individual functions and settings see "Trace Settings".

The remote commands required to perform these tasks are described in "Configuring the Trace Display and Retrieving Trace Data".

Trace settings are configured in the "Traces" dialog box.

To display the "Traces" dialog box, do one of the following:
  • Press the TRACE key and then select the "Trace Config" softkey.
  • Select "Analysis" from the "Overview", then select the "Traces" tab.

  1. For each trace, select the "Trace Mode" and "Trace Detector". Traces with the trace mode "Blank" are not displayed.

  2. To configure several traces to predefined display modes in one step, press the button for the required function:

    • "Preset All Traces"
    • "Set Trace Mode Avg | Max | Min"
    • "Set Trace Mode Max | ClrWrite | Min"

    For details see "Trace Settings".

  3. For "Average" trace mode, define the number of sweeps to be averaged in the "Sweep/Average Count" field of the "Sweep Config" dialog box.

    (Press the SWEEP key and then select the "Sweep Config" softkey to display the "Sweep Config" dialog box.)

  4. If linear scaling is used, select the "Average Mode: Linear".

  5. To improve the trace stability, increase the number of "Sweep Points" or the "Sweep Time".

    All configured traces (not set to "Blank") are displayed after the next sweep.

How to Copy Traces
  1. A trace copy function is provided in a separate tab of the "Traces" dialog box. To display this tab do one of the following:
    • Select the TRACE key and then the "Trace Copy" softkey.
    • Select "Analysis" from the "Overview", then select the "Trace Copy" tab.

  2. Select the "Source" trace to be copied.

  3. Select the "Copy to trace..." button for the trace to which the settings are to be applied.

    The settings from the source trace are applied to the destination trace. The newly configured trace (if not set to "Blank") is displayed after the next sweep.


How to Display and Configure a Spectrogram

Common Analysis and Display Functions > Trace Configuration > How to Configure Traces > How to Display and Configure a Spectrogram
How to Display and Configure a Spectrogram

Step-by-step instructions on how to display and configure a spectrogram are provided here. For details on individual functions and settings see "Spectrogram Settings".

The remote commands required to perform these tasks are described in "Configuring Spectrograms".

The following tasks are described here:

  • "To display a spectrogram"
  • "To remove the spectrogram display"
  • "To set a marker in the spectrogram"
  • "To configure a spectrogram"
  • "To select a color scheme"
  • "To set the value range graphically using the color range sliders"
  • "To set the value range numerically"
  • "To set the color curve shape graphically using the slider"
  • "To set the color curve shape numerically"
To display a spectrogram

  1. In the "Overview", select "Display", then drag the evaluation type "Spectrogram" to the diagram area.

    Alternatively:

    1. Select the TRACE key and then the "Spectrogram Config" softkey.

    2. Toggle "Spectrogram" to "ON".

  2. To clear an existing spectrogram display, select "Clear Spectrogram".

  3. Start a new measurement using RUN SINGLE or RUN CONT.

    The spectrogram is updated continuously with each new sweep.

  4. To display the spectrum diagram for a specific time frame:

    1. Stop the continuous measurement or wait until the single sweep is completed.

    2. Select the frame number in the diagram footer.

    3. Enter the required frame number in the edit dialog box.

      Note that the most recent sweep is frame number 0, all previous frames have negative numbers.

To remove the spectrogram display

  1. Select the TRACE key and then the "Spectrogram Config" softkey.

  2. Toggle "Spectrogram" to "OFF".

    The standard spectrum display is restored.

To set a marker in the spectrogram

  1. While a spectrogram is displayed, select the MARKER key.

  2. Select a "Marker" softkey.

  3. Enter the frequency or time (x-value) of the marker or delta marker.

  4. Enter the frame number for which the marker is to be set, for example 0 for the current frame, or -2 for the second to last frame. Note that the frame number is always 0 or a negative value!

    The marker is only visible in the spectrum diagram if it is defined for the currently selected frame. In the spectrogram result display all markers are visible that are positioned on a visible frame.

To configure a spectrogram

  1. Configure the spectrogram frames:

    1. Select the SWEEP key.

    2. Select the "Sweep Config" softkey.

    3. In the "Sweep/Average Count" field, define how many sweeps are to be analyzed to create a single frame.

    4. In the "Frame Count" field, define how many frames are to be plotted during a single sweep measurement.

    5. To include frames from previous sweeps in the analysis of the new frame (for "Max Hold", "Min Hold" and "Average" trace modes only), select "Continue Frame" = "ON".

  2. Define how many frames are to be stored in total:

    1. Select the TRACE key and then the "Spectrogram Config" softkey.

    2. Select the "History Depth" softkey.

    3. Enter the maximum number of frames to store.

  3. Optionally, replace the frame number by a time stamp by toggling the "Timestamp" softkey to "On".

  4. If necessary, adapt the color mapping for the spectrogram to a different value range or color scheme as described in "How to Configure the Color Mapping".

Contents
  • How to Configure the Color Mapping


How to Configure the Color Mapping

Common Analysis and Display Functions > Trace Configuration > How to Configure Traces > How to Display and Configure a Spectrogram > How to Configure the Color Mapping
How to Configure the Color Mapping

The color display is highly configurable to adapt the spectrograms to your needs.

The settings for color mapping are defined in the "Color Mapping" dialog box. To display this dialog box, do one of the following:

  • Tap the color map in the spectrogram display.
  • Press the "Color Mapping" softkey in the "Spectrogram" menu.
To select a color scheme

You can select which colors are assigned to the measured values.

►

In the "Color Mapping" dialog box, select the option for the color scheme to be used.

Editing the value range of the color map

The distribution of the measured values is displayed as a histogram in the "Color Mapping" dialog box. To cover the entire measurement value range, make sure the first and last bar of the histogram are included.

To ignore noise in a spectrogram, for example, exclude the lower power levels from the histogram.

The value range of the color map must cover at least 10% of the value range on the horizontal axis of the diagram, that means, the difference between the start and stop values must be at least 10%.

The value range can be set numerically or graphically.

To set the value range graphically using the color range sliders

  1. Select and drag the bottom color curve slider (indicated by a gray box at the left of the color curve pane) to the lowest value you want to include in the color mapping.

  2. Select and drag the top color curve slider (indicated by a gray box at the right of the color curve pane) to the highest value you want to include in the color mapping.

To set the value range numerically

  1. In the "Start" field, enter the percentage from the left border of the histogram that marks the beginning of the value range.

  2. In the "Stop" field, enter the percentage from the right border of the histogram that marks the end of the value range.

Example:

The color map starts at -100 dBm and ends at 0 dBm (i.e. a range of 100 dB). In order to suppress the noise, you only want the color map to start at -90 dBm. Thus, you enter 10% in the "Start" field. The R&S FSW shifts the start point 10% to the right, to -90 dBm.

Adjusting the reference level and level range

Note that changing the reference level and level range of the measurement also affects the color mapping in the spectrogram.

Editing the shape of the color curve

The color curve is a tool to shift the focus of the color distribution on the color map. By default, the color curve is linear, i.e. the colors on the color map are distributed evenly. If you shift the curve to the left or right, the distribution becomes non-linear. The slope of the color curve increases or decreases. One end of the color palette then covers a large amount of results, while the other end distributes several colors over a relatively small result range.

The color curve shape can be set numerically or graphically.

To set the color curve shape graphically using the slider
► | Select and drag the color curve shape slider (indicated by a gray box in the middle of the color curve) to the left or right. The area beneath the slider is focussed, i.e. more colors are distributed there.
To set the color curve shape numerically
►

In the "Shape" field, enter a value to change the shape of the curve:

  • A negative value (-1 to <0) focusses the lower values
  • 0 defines a linear distribution
  • A positive value (>0 to 1) focusses the higher values


How to Copy Traces

Common Analysis and Display Functions > Trace Configuration > How to Configure Traces > How to Copy Traces
How to Copy Traces

You can copy the trace settings from one trace to another in the "Copy Trace" tab of the "Traces" dialog box.

►

Select the "Source" trace and then the button for the "Copy to" trace.

Remote command:

TRACe<n>:​COPY


Marker Usage

Common Analysis and Display Functions > Marker Usage
Marker Usage

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display both in the time and frequency domain. In addition to basic markers, sophisticated marker functions are provided for special results such as noise or demodulation.

Markers in Spectrogram Displays

In the spectrogram result display, you can activate up to 16 markers or delta markers at the same time. Each marker can be assigned to a different frame. Therefore, in addition to the frequency you also define the frame number when activating a new marker. If no frame number is specified, the marker is positioned on the currently selected frame. All markers are visible that are positioned on a visible frame.

Contents
  • Basics on Markers and Marker Functions
  • Marker Configuration
  • Marker Function Configuration
  • How to Work With Markers
  • Measurement Example: Measuring Harmonics Using Marker Functions


Basics on Markers and Marker Functions

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions
Basics on Markers and Marker Functions

Some background knowledge on marker settings and functions is provided here for a better understanding of the required configuration settings.

Markers are used to mark points on traces, to read out measurement results and to select a display section quickly. R&S FSW provides 16 markers per display window. In the Spectrum application, the same markers are displayed in all windows.

  • The easiest way to work with markers is using the touch screen. Simply drag the marker and drop it at the required position. When a marker label is selected, a vertical line is displayed which indicates the marker's current x-value.
  • Alternatively, change the position of the selected marker using the rotary knob. By default, the marker is moved from one pixel to the next. If you need to position the marker more precisely, change the step size to move from one sweep point to the next (General Marker Setting).
  • You can also set an active marker to a new position by defining its x-position numerically. When you select the softkey for a marker, an edit dialog box is displayed.
  • The most commonly required marker settings and functions are also available as softkeys or via the context menu. Tap the marker on the touch screen and hold your finger for about 2 seconds until the context menu is opened, then select the required entry.
  • Softkeys for active markers (displayed on the screen) are highlighted blue. The softkey for the currently selected marker (for which functions are performed) is highlighted orange.
  • To set individual markers very quickly, use the softkeys in the "Marker" menu.
  • To set up several markers at once, use the "Marker" dialog box.
  • To position the selected marker to a special value, use the softkeys in the "Marker To" menu.
  • To determine more sophisticated marker results, use the special functions in the "Marker Function" dialog box.

In addition to basic markers, sophisticated marker functions are provided for special results such as noise or demodulation.

Contents
  • Marker Types
  • Activating Markers
  • Marker Results
  • Searching for Signal Peaks
  • Performing a Highly Accurate Frequency Measurement (Signal Count)
  • Defining a Fixed Reference Marker
  • Measuring Noise Density
  • Measuring Phase Noise
  • Measuring Characteristic Bandwidths (n dB Down Marker)
  • Measuring the Power in a Channel (Band)
  • Demodulating Marker Values and Providing Audio Output


Marker Types

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Marker Types
Marker Types

All markers can be used either as normal markers or delta markers. A normal marker indicates the absolute signal value at the defined position in the diagram. A delta marker indicates the value of the marker relative to the specified reference marker (by default marker 1).

In addition, special functions can be assigned to the individual markers. The availability of special marker functions depends on whether the measurement is performed in the frequency or time domain.

Temporary markers are used in addition to the markers and delta markers to analyze the measurement results for special marker functions. They disappear when the associated function is deactivated.


Activating Markers

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Activating Markers
Activating Markers

Only active markers are displayed in the diagram and in the marker table. Active markers are indicated by a highlighted softkey.

By default, marker 1 is active and positioned on the maximum value (peak) of trace 1 as a normal marker. If several traces are displayed, the marker is set to the maximum value of the trace which has the lowest number and is not frozen (View mode). The next marker to be activated is set to the frequency of the next lower level (next peak) as a delta marker; its value is indicated as an offset to marker 1.

A marker can only be activated when at least one trace in the corresponding window is visible. If a trace is switched off, the corresponding markers and marker functions are also deactivated. If the trace is switched on again, the markers along with coupled functions are restored to their original positions, provided the markers have not been used on another trace.


Marker Results

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Marker Results
Marker Results

Normal markers point to a sweep point on the time or frequency axis and display the associated numeric value for that sweep point. Delta markers indicate an offset between the level at the delta marker position and the level at the position of the assigned reference marker, in dB.

Signal count markers determine the frequency of a signal at the marker position very accurately.

The results can be displayed directly within the diagram area or in a separate table. By default, the first two active markers are displayed in the diagram area. If more markers are activated, the results are displayed in a marker table.

Marker information in diagram area

By default, the results of the last two markers or delta markers that were activated are displayed in the diagram area.

The following information is displayed there:

  • The marker type (M for normal, D for delta, or special function name)
  • The marker number (1 to 16)
  • The assigned trace number in square brackets [ ]
  • The marker value on the y-axis, or the result of the marker function
  • The marker position on the x-axis

For n dB down markers, additional information is displayed, see "Measuring Characteristic Bandwidths (n dB Down Marker)".

Marker information in marker table

In addition to the marker information displayed within the diagram area, a separate marker table may be displayed beneath the diagram. This table provides the following information for all active markers:

Type | Marker type: N (normal), D (delta), T (temporary, internal) and number
Ref | Reference marker for delta markers
Trc | Trace to which the marker is assigned
X-value | X-value of the marker
Y-value | Y-value of the marker
Function | Activated marker or measurement function
Function Result | Result of the active marker or measurement function


Searching for Signal Peaks

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Searching for Signal Peaks
Searching for Signal Peaks

A common task in spectrum analysis is determining peak values, i.e. maximum or minimum signal levels. The R&S FSW provides various peak search functions and applications:

  • Setting a marker to a peak value once (Peak Search)
  • Searching for a peak value within a restricted search area (Search Limits)
  • Creating a marker table with all or a defined number of peak values for one sweep (Marker Peak List)
  • Updating the marker position to the current peak value automatically after each sweep (Auto Peak Search)
  • Creating a fixed reference marker at the current peak value of a trace (Peak Search)
Peak search limits

The peak search can be restricted to a search area. The search area is defined by limit lines which are also indicated in the diagram. In addition, a minimum value (threshold) can be defined as a further search condition.

When is a peak a peak? - Peak excursion

During a peak search, for example when a marker peak table is displayed, noise values may be detected as a peak if the signal is very flat or does not contain many peaks. Therefore, you can define a relative threshold ("Peak excursion"). The signal level must increase by the threshold value before falling again before a peak is detected. To avoid identifying noise peaks as maxima or minima, enter a peak excursion value that is higher than the difference between the highest and the lowest value measured for the displayed inherent noise.

Effect of peak excursion settings (example)

The following figure shows a trace to be analyzed.

Trace example

The following table lists the peaks as indicated by the marker numbers in the diagram above, as well as the minimum decrease in amplitude to either side of the peak:

Marker # | Min. amplitude decrease to either side of the signal
1 | 30 dB
2 | 29.85 dB
3 | 20 dB
4 | 10 dB
5 | 18 dB

In order to eliminate the smaller peaks M3,M4 and M5 in the example above, a peak excursion of at least 20 dB is required. In this case, the amplitude must rise at least 20 dB before falling again before a peak is detected.

Marker peak list

The marker peak list determines the frequencies and levels of peaks in the spectrum. It is updated automatically after each sweep. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

Automatic peak search

A peak search can be repeated automatically after each sweep in order to keep the maximum value as the reference point for a phase noise measurement. This is useful to track a drifting source. The delta marker 2, which shows the phase noise measurement result, keeps the delta frequency value. Therefore the phase noise measurement leads to reliable results in a certain offset although the source is drifting.

Using a peak as a fixed reference marker

Some results are analyzed in relation to a peak value, for example a carrier frequency level. In this case, the maximum level can be determined by an initial peak search and then be used as a reference point for further measurement results.


Performing a Highly Accurate Frequency Measurement (Signal Count)

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Performing a Highly Accurate Frequency Measurement (Signal Count)
Performing a Highly Accurate Frequency Measurement (Signal Count)

A normal marker determines the position of the point on the trace and indicates the signal frequency at this position. The trace, however, contains only a limited number of points. Depending on the selected span, each trace point may contain many measurement values. Thus, the frequency resolution of each trace point is limited (see also "How Much Data is Measured: Sweep Points and Sweep Count"). Frequency resolution is further restricted by the RBW and sweep time settings.

In order to determine the frequency of a signal point accurately without changing the sweep settings, the R&S FSW is equipped with a signal counter. The signal counter sets the RF to the current marker position, then counts the zero crossings of the IF (thus the term signal counter) and derives the precise frequency value.

Signal counting can be performed explicitely at the current marker position ("Signal Count" marker function), or implicitely by the R&S FSW for certain functions.

Signal counting is only possible while the instrument is not sweeping. Thus, to perform a signal count for a marker, the sweep is stopped at the marker position. The frequency is determined with the desired resolution and then the sweep is allowed to continue.


Defining a Fixed Reference Marker

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Defining a Fixed Reference Marker
Defining a Fixed Reference Marker

Instead of using a reference marker that may vary its position depending on the measurement results, a fixed reference marker can be defined for trace analysis. Once positioned, the reference marker does not move during subsequent sweeps unless you explicitely move it manually.


Measuring Noise Density

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Measuring Noise Density
Measuring Noise Density

Using the noise measurement marker function, the noise power density is measured at the position of the marker. In the time domain mode, all points of the trace are used to determine the noise power density. When measurements are performed in the frequency domain, two points to the right and left of the marker are used for the measurement to obtain a stable result.

Result display

Noise density is the noise referred to a bandwidth of 1 Hz. With logarithmic amplitude units (dBm, dBmV, dBmµV, dBµA), the noise power density is output in dBm/Hz, i.e. as level in 1 Hz bandwidth with reference to 1 mW. With linear amplitude units (V, A, W), the noise voltage density is analyzed in µV/√Hz, the noise current density in µA/√Hz or the noise power density in µW/√Hz.

The result is indicated as the function result in the Marker Table.

Prerequisite settings

The following settings have to be made to obtain correct values:

  • Detector: Sample or RMS
  • Video bandwidth:
    ≤ 0.1 resolution bandwidth with sample detector
    ≥ 3 x resolution bandwidth with RMS detector
  • Trace averaging:
    In the default setting, the R&S FSW uses the sample detector for the noise function. With the sample detector, the trace can additionally be set to "Average" mode to stabilize the measured values. When the RMS detector is used, trace averaging should not be used since in this case it produces too low noise levels which cannot be corrected. Instead, the sweep time can be increased to obtain stable measurement results.
Correction factors

The R&S FSW uses the following correction factors to analyze the noise density from the marker level:

  • Since the noise power is indicated with reference to 1 Hz bandwidth, the bandwidth correction value is deducted from the marker level. It is 10 x lg (1 Hz/BWNoise), where BWNoise is the noise or power bandwidth of the set resolution filter (RBW).
  • RMS detector: With the exception of bandwidth correction, no further corrections are required since this detector already indicates the power for each point of the trace.
  • Sample detector: As a result of video filter averaging and trace averaging, 1.05 dB is added to the marker level. This is the difference between the average value and the RMS value of white noise. With a logarithmic level axis, 1.45 dB is added additionally. Logarithmic averaging is thus fully taken into account which yields a value that is 1.45 dB lower than that of linear averaging.
  • To allow a more stable noise display the adjacent (symmetric to the measurement frequency) points of the trace are averaged.
  • For span > 0, the measured values are averaged versus time (after a sweep).

The R&S FSW noise figure can be calculated from the measured power density level. It is calculated by deducting the set RF attenuation (RF Att) from the displayed noise level and adding 174 to the result.


Measuring Phase Noise

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Measuring Phase Noise
Measuring Phase Noise

Phase noise is unintentional modulation of a carrier; it creates frequencies next to the carrier frequency. A phase noise measurement consists of noise density measurements at defined offsets from the carrier; the results are given in relation to the carrier level (dBc). The phase noise marker function measures the noise power at the delta markers referred to 1 Hz bandwidth. Marker 1 is used as the reference for the phase noise measurement. By default, the current frequency and level of marker 1 are used as the fixed reference marker. However, a peak search can be started to use the current signal peak as the reference point, or a reference point can be defined manually.

Since the reference point is fixed, the reference level or the center frequency can be set so that the carrier is outside the displayed frequency range after phase noise measurement is started. Or a notch filter can be switched on to suppress the carrier.

Alternatively, the reference point can be determined automatically by a peak search after each sweep. This function can be used to track a drifting source during a phase noise measurement. The delta marker 2, which shows the phase noise measurement result, keeps the delta frequency value. Therefore the phase noise measurement leads to reliable results in a certain offset although the source is drifting. Only if the marker 2 reaches the border of the span, the delta marker value is adjusted to be within the span. In these cases, select a larger span.

The result of the phase noise measurement is the difference in level between the reference point and the noise power density. It is indicated as the function result of the phase noise marker in the Marker Table.

The sample detector is automatically used and the video bandwidth set to 0.1 times the resolution bandwidth (RBW). The two settings are taken into account in the correction values used for the noise power measurement. To obtain stable results, two pixels on the right and the left of the delta marker position are taken for the measurement. The procedure for determining the noise power is identical to the method used for the noise power measurement (see "Measuring Noise Density").


Measuring Characteristic Bandwidths (n dB Down Marker)

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Measuring Characteristic Bandwidths (n dB Down Marker)
Measuring Characteristic Bandwidths (n dB Down Marker)

When characterizing the shape of a signal, the bandwidth at a specified offset from its peak level is often of interest. The offset is specified as a relative decrease in amplitude of n dB. In order to measure this bandwidth, you could use several markers and delta markers and determine the bandwidth manually. However, using the n dB down marker function makes the task very simple and quick.

The n dB down marker function uses the current value of marker 1 as the reference point. It activates two temporary markers T1 and T2 located on the signal, whose level is n dB below the level of the reference point. Marker T1 is placed to the left and marker T2 to the right of the reference marker. The default setting for n is 3 dB, but it can be changed.

If a positive offset is entered, the markers T1 and T2 are placed below the active reference point. If a negative value is entered (for example for notch filter measurements), the markers T1 and T2 are placed above the active reference point.

n dB down marker function

The following marker function results are displayed:

n dB down marker function results
Label | Description
M1 | Current position and level of marker 1
ndB | Offset value (n dB down)
ndB down Bw / PWid | Determined bandwidth or pulse width (zero span) at the offset
Q-factor | Quality factor of the determined bandwidth (characteristic of damping or resonance)
T1, T2 | Current position and level of the temporary markers

If the required position for the temporary markers cannot be determined uniquely, for example due to noise, dashes are displayed as a result.


Measuring the Power in a Channel (Band)

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Measuring the Power in a Channel (Band)
Measuring the Power in a Channel (Band)

When you want to determine the noise power in a transmission channel, you could use a noise marker and multiply the result with the channel bandwidth. However, the results would only be accurate for flat noise.

Band power markers allow you to measure the integrated power for a defined span (band) around a marker (similar to ACP measurements). By default, 5 % of the current span is used. The span is indicated by limit lines in the diagram. The results can be displayed either as a power (dBm) or density (dBm/Hz) value and are indicated in the marker table for each band power marker.

Band power markers are only available for standard frequency measurements (not zero span) in the Spectrum application.

The entire band must lie within the display. If it is moved out of the display, the result cannot be calculated (indicated by "- - -" as the "Function Result"). However, the width of the band is maintained so that the band power can be calculated again when it returns to the display.

All markers can be defined as band power markers, each with a different span. When a band power marker is activated, if no marker is active yet, marker 1 is activated. Otherwise, the currently active marker is used as a band power marker (all other marker functions for this marker are deactivated).

If the detector mode for the marker trace is set to "Auto", the RMS detector is used.


Demodulating Marker Values and Providing Audio Output

Common Analysis and Display Functions > Marker Usage > Basics on Markers and Marker Functions > Demodulating Marker Values and Providing Audio Output
Demodulating Marker Values and Providing Audio Output

The R&S FSW provides demodulators for AM, FM and PM signals. The demodulation marker function sends the demodulated data at the current marker frequency to the audio output. Thus, a displayed signal can be identified acoustically through the use of the internal loudspeaker or with headphones.

This function is not available for Spectrum Emission Mask measurements.

The sweep stops at the frequency determined by marker 1 for the selected time and the RF signal is demodulated in a bandwidth that corresponds to the RBW. Alternatively, demodulation can be activated continuously, i.e. audio output occurs regardless of the marker position and the marker stop time. For measurements in the time domain (zero span), demodulation is always continuous.

Optionally, a mimumum level ("Squelch level") can be defined so that the signal is only demodulated when it exceeds the set level. This is useful during continuous demodulation to avoid listening to noise.

The squelch function activates the video trigger function (see "Video") and deactivates any other trigger or gating settings. The squelch level and trigger level are set to the same value. The trigger source in the channel bar is indicated as "SQL" for squelch. The squelch level is indicated by a red line in the diagram.


Marker Configuration

Common Analysis and Display Functions > Marker Usage > Marker Configuration
Marker Configuration

When working with markers, the following configuration settings and functions are available:

Contents
  • Marker Settings
  • Marker Search Settings and Positioning Functions


Marker Settings

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings
Marker Settings

Marker settings can be configured via the MARKER key or in the "Marker" dialog box. To display the "Marker" dialog box, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.

The remote commands required to define these settings are described in "Setting Up Individual Markers".

The marker "Search" settings are described in "Marker Search Settings and Positioning Functions".

Contents
  • Individual Marker Setup
  • General Marker Settings


Individual Marker Setup

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup
Individual Marker Setup

Up to 17 markers or delta markers can be activated for each window simultaneously. Initial marker setup is performed using the "Marker" dialog box.

The markers are distributed among 3 tabs for a better overview. By default, the first marker is defined as a normal marker, whereas all others are defined as delta markers with reference to the first marker. All markers are assigned to trace 1, but only the first marker is active.

└ Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
└ Selected Marker
└ Marker State
└ Marker Position (X-value)
└ Frame (Spectrogram only)
└ Marker Type
└ Reference Marker
└ Linking to Another Marker
└ Assigning the Marker to a Trace
└ Select Marker
└ Final Test Detector
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 16 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings".

Note: If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?

In spectrogram display:

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​FRAMe

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe


Selected Marker

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Position (X-value)

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Marker Position (X-value)
Marker Position (X-value)

Defines the position (x-value) of the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X


Frame (Spectrogram only)

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Frame (Spectrogram only)
Frame (Spectrogram only)

Spectrogram frame the marker is assigned to.

Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​FRAMe


Marker Type

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

If a fixed reference point is configured (see "Defining a Fixed Reference"), the reference point ("FXD") can also be selected instead of another marker.

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Assigning the Marker to a Trace

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

The marker can also be assigned to the currently active trace using the "Marker to Trace" softkey in the "Marker" menu.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


Final Test Detector

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > Final Test Detector
Final Test Detector

Defines the detector to be used for the final EMI test at the marker frequency. This setting is only available if the EMI (R&S FSW-K54) measurement option is installed.

For details see "Detectors and Dwell Time".

Note: The trace detector configured in the trace settings is used for the initial peak search only, see "Trace Settings".

"Off"

No final test is performed.

"Positive peak"

Determines the maximum signal level that was detected during the specified dwell time.

"Average"

Determines the average signal level of the samples that were collected during the specified dwell time.

"Quasipeak"

Determines the maximum signal level weighted to CISPR 16-1-1 that was detected during the dwell time.

The quasipeak detector is only available for the CISPR filter, and not for an RBW of 1 MHz.

"CISPR Average"

Determines a weighted average signal level according to CISPR 16-1-1.

The average value according to CISPR 16-1-1 is the maximum value detected while calculating the linear average value during the specified dwell time.

The CISPR Average detector is only available for the CISPR filter.

"RMS Average"

A combination of the RMS detector (for pulse repetition frequencies above a corner frequency) and the Average detector (for pulse repetition frequencies below the corner frequency).

The average value is determined by lowpass filters of the 2nd order (simulation of a mechanical pointer instrument).

The RMS Average detector is only available for the CISPR filter.

Remote command:

CALCulate:​MARKer<m>:​FUNCtion:​FMEasurement:​DETector

CALCulate:​DELTamarker<m>:​FUNCtion:​FMEasurement:​DETector


All Markers Off

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > Individual Marker Setup > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > General Marker Settings
General Marker Settings

Some general marker settings allow you to influence the marker behavior for all markers.

These settings are located in the "Marker Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab. Then select the horizontal "Marker Settings" tab.
└ Marker Table Display
└ Marker Stepsize
└ Defining a Fixed Reference
└ Automatic Peak Search
└ Dwell Time


Marker Table Display

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results".

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Marker Stepsize

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > General Marker Settings > Marker Stepsize
Marker Stepsize

Defines the size of the steps that the marker position is moved using the rotary knob.

"Standard" | The marker position is moved from pixel to pixel on the display. This setting is most suitable to move the marker over a larger distance.
"Sweep Points" | The marker position is moved from one sweep point to the next. This setting is required for a very precise positioning if more sweep points are collected than the number of pixels that can be displayed on the screen. It is the default mode.
Remote command:

CALCulate:​MARKer:​X:​SSIZe


Defining a Fixed Reference

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > General Marker Settings > Defining a Fixed Reference
Defining a Fixed Reference

Instead of using a reference marker that may vary its position depending on the measurement results, a fixed reference marker can be defined for trace analysis.

When you set the "State" to "On", a vertical and a horizontal red display line are displayed, marked as "FXD". The normal marker 1 is activated and set to the peak value of the trace assigned to marker 1, and a delta marker to the next peak. The fixed reference marker is set to the position of marker 1 at the peak value. The delta marker refers to the fixed reference marker.

If activated, the fixed reference marker ("FXD") can also be selected as a "Reference Marker" instead of another marker.

The "Level" and "Frequency" or "Time" settings define the position and value of the reference marker.

Alternatively, a Peak Search can be performed to set the current maximum value of the trace assigned to marker 1 as the fixed reference marker.

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed[:​STATe]

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​Y

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​X

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​MAXimum[:​PEAK]


Automatic Peak Search

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > General Marker Settings > Automatic Peak Search
Automatic Peak Search

If activated, a peak search is performed automatically for all active markers after each sweep.

If Auto peak search and limit lines are active, the active markers are set to the peak delta values between the measured signal and the limit lines.

Note: The general search functions "Auto Max / Min Peak Search" are not available for EMI measurements.

Remote command:

CALCulate:​MARKer:​FUNCtion:​FMEasurement:​PSEarch|PEAKsearch:​AUTO


Dwell Time

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Settings > General Marker Settings > Dwell Time
Dwell Time

Sets the dwell time for the EMI marker measurement.

For more information see "Detectors and Dwell Time".

Remote command:

CALCulate:​MARKer:​FUNCtion:​FMEasurement:​DWELl


Marker Search Settings and Positioning Functions

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions
Marker Search Settings and Positioning Functions

Several functions are available to set the marker to a specific position very quickly and easily, or to use the current marker position to define another characteristic value. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

For more information on searching for signal peaks see "Searching for Signal Peaks".

In I/Q Analyzer mode, the search settings for "Real/Imag (I/Q)" evaluation include an additional parameter, see "Branch for Peak Search" .

The remote commands required to define these settings are described in "Positioning the Marker".

Contents
  • Marker Search Settings
  • Marker Search Settings for Spectrograms
  • Positioning Functions


Marker Search Settings

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings
Marker Search Settings

Markers are commonly used to determine peak values, i.e. maximum or minimum values, in the measured signal. Configuration settings allow you to influence the peak search results.

For Spectrograms, special marker settings are available, see "Marker Search Settings for Spectrograms".

These settings are are available as softkeys in the "Marker To" menu, or in the "Search Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search Settings" tab.
└ Search Mode for Next Peak
└ Exclude LO
└ Peak Excursion
└ Auto Max / Min Peak Search
└ Search Limits
└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits


Search Mode for Next Peak

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Exclude LO

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Exclude LO
Exclude LO

If activated, restricts the frequency range for the marker search functions.

"ON" | The minimum frequency included in the peak search range is ≥ 5 × resolution bandwidth (RBW). Due to the interference by the first local oscillator to the first intermediate frequency at the input mixer, the LO is represented as a signal at 0 Hz. To avoid the peak marker jumping to the LO signal at 0 Hz, this frequency is excluded from the peak search.
"OFF" | No restriction to the search range. The frequency 0 Hz is included in the marker search functions.
Remote command:

CALCulate:​MARKer:​LOEXclude


Peak Excursion

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Peak Excursion
Peak Excursion

Defines the minimum level value by which a signal must rise or fall so that it will be identified as a maximum or a minimum by the search functions.

Entries from 0 dB to 80 dB are allowed; the resolution is 0.1 dB. The default setting for the peak excursion is 6 dB.

For more information see "Searching for Signal Peaks".

Remote command:

CALCulate<n>:​MARKer:​PEXCursion


Auto Max / Min Peak Search

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Auto Max / Min Peak Search
Auto Max / Min Peak Search

If activated, a maximum or minimum peak search is performed automatically for marker 1 after each sweep.

For spectrogram displays, define which frame the peak is to be searched in.

For EMI measurements, these functions are not available; use "Automatic Peak Search" instead (see "EMI Final Measurement Configuration").

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​AUTO

CALCulate<n>:​MARKer<m>:​MINimum:​AUTO


Search Limits

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits
Search Limits

The search results can be restricted by limiting the search area or adding search conditions.

└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits


Search Threshold

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Search Threshold
Search Threshold

Defines an absolute threshold as an additional condition for the peak search. Only peaks that exceed the threshold are detected.

Remote command:

CALCulate:​THReshold


Using Zoom Limits

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Using Zoom Limits
Using Zoom Limits

If activated, the peak search is restricted to the active zoom area defined for a single zoom (see "Single Zoom").

Remote command:

CALCulate:​MARKer:​X:​SLIMits:​ZOOM[:​STATe]


Deactivating All Search Limits

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Limits > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​THReshold:​STATe


Marker Search Settings for Spectrograms

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms
Marker Search Settings for Spectrograms

Spectrograms show not only the current sweep results, but also the sweep history. Thus, when searching for peaks, you must define the search settings within a single time frame (x-direction) and within several time frames (y-direction).

These settings are only available for spectrogram displays.

These settings are are available in the "Search Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search Settings" tab.
└ Search Mode for Next Peak in X Direction
└ Search Mode for Next Peak in Y Direction
└ Marker Search Type
└ Marker Search Area
└ Exclude LO
└ Peak Excursion
└ Auto Max / Min Peak Search
└ Search Limits
└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits


Search Mode for Next Peak in X Direction

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Search Mode for Next Peak in X Direction
Search Mode for Next Peak in X Direction

Selects the search mode for the next peak search within the currently selected frame.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Search Mode for Next Peak in Y Direction

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Search Mode for Next Peak in Y Direction
Search Mode for Next Peak in Y Direction

Selects the search mode for the next peak search within all frames at the current marker position.

"Up" | Determines the next maximum/minimum above the current peak (in more recent frames).
"Absolute" | Determines the next maximum/minimum above or below the current peak (in all frames).
"Down" | Determines the next maximum/minimum below the current peak (in older frames).
Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​ABOVe

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​ABOVe

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​BELow

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​BELow

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum:​ABOVe

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum:​ABOVe

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum:​BELow

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum:​BELow

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum:​NEXT


Marker Search Type

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Marker Search Type
Marker Search Type

Defines the type of search to be performed in the spectrogram.

"X-Search" | Searches only within the currently selected frame.
"Y-Search" | Searches within all frames but only at the current marker position.
"XY-Search" | Searches in all frames at all positions.
Remote command:

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​XY:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​XY:​MAXimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​XY:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​XY:​MINimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MAXimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​Y:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​Y:​MINimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Marker Search Area

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Marker Search Area
Marker Search Area

Defines which frames the search is performed in.

"Visible" | Only the visible frames are searched.
"Memory" | All frames stored in the memory are searched.
Remote command:

CALCulate<n>:​MARKer:​SGRam|SPECtrogram:​SARea

CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​SARea


Exclude LO

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Exclude LO
Exclude LO

If activated, restricts the frequency range for the marker search functions.

"ON" | The minimum frequency included in the peak search range is ≥ 5 × resolution bandwidth (RBW). Due to the interference by the first local oscillator to the first intermediate frequency at the input mixer, the LO is represented as a signal at 0 Hz. To avoid the peak marker jumping to the LO signal at 0 Hz, this frequency is excluded from the peak search.
"OFF" | No restriction to the search range. The frequency 0 Hz is included in the marker search functions.
Remote command:

CALCulate:​MARKer:​LOEXclude


Search Limits

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Search Limits
Search Limits

The search results can be restricted by limiting the search area or adding search conditions.

└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits


Search Threshold

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Search Limits > Search Threshold
Search Threshold

Defines an absolute threshold as an additional condition for the peak search. Only peaks that exceed the threshold are detected.

Remote command:

CALCulate:​THReshold


Using Zoom Limits

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Search Limits > Using Zoom Limits
Using Zoom Limits

If activated, the peak search is restricted to the active zoom area defined for a single zoom (see "Single Zoom").

Remote command:

CALCulate:​MARKer:​X:​SLIMits:​ZOOM[:​STATe]


Deactivating All Search Limits

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Marker Search Settings for Spectrograms > Search Limits > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​THReshold:​STATe


Positioning Functions

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Positioning Functions
Positioning Functions

The following functions set the currently selected marker to the result of a peak search or set other characteristic values to the current marker value. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum
└ Center Frequency = Marker Frequency
└ Reference Level = Marker Level


Peak Search

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

For spectrogram displays, define which frame the peak is to be searched in.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

For spectrogram displays, define which frame the next peak is to be searched in.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

For spectrogram displays, define which frame the minimum is to be searched in.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

For spectrogram displays, define which frame the next minimum is to be searched in.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Center Frequency = Marker Frequency

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Positioning Functions > Center Frequency = Marker Frequency
Center Frequency = Marker Frequency

Sets the center frequency to the selected marker or delta marker frequency. A peak can thus be set as center frequency, for example to analyze it in detail with a smaller span.

This function is not available for zero span measurements.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​CENTer


Reference Level = Marker Level

Common Analysis and Display Functions > Marker Usage > Marker Configuration > Marker Search Settings and Positioning Functions > Positioning Functions > Reference Level = Marker Level
Reference Level = Marker Level

Sets the reference level to the selected marker level.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​REFerence


Marker Function Configuration

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration
Marker Function Configuration

Special marker functions can be selected via the "Marker Function" dialog box.

To display this dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab.

The remote commands required to define these settings are described in "Working with Markers".

The Marker Peak List settings are described in "Marker Peak List Configuration".

Contents
  • Precise Frequency (Signal Count) Marker
  • Noise Measurement Marker
  • Phase Noise Measurement Marker
  • n dB Down Marker
  • Reference Fixed
  • Band Power Marker
  • Marker Demodulation
  • Marker Peak List Configuration
  • Deactivating All Marker Functions


Precise Frequency (Signal Count) Marker

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Precise Frequency (Signal Count) Marker
Precise Frequency (Signal Count) Marker

A special marker can be used to determine a particular frequency or time in a measured signal very accurately. Signal counters are configured in the "Signal Count Config" dialog box.

To display the "Signal Count Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "Signal Count" button. Select the "Signal Count Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "Signal Count" button. Select the "Signal Count Config" softkey.

For details see "Performing a Highly Accurate Frequency Measurement (Signal Count)". A measurement example is described in "Measuring the Signal Frequency Using the Signal Counter".

Signal counters are not available for measurements on I/Q-based data.

└ Signal Count Marker State
└ Resolution


Signal Count Marker State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Precise Frequency (Signal Count) Marker > Signal Count Marker State
Signal Count Marker State

Activates or deactivates the special signal count marker function.

When activated, the sweep stops at the reference marker until the signal counter has delivered a result.

For details see "Performing a Highly Accurate Frequency Measurement (Signal Count)".

Remote command:

CALCulate<n>:​MARKer<m>:​COUNt

CALCulate<n>:​MARKer<m>:​COUNt:​FREQuency?


Resolution

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Precise Frequency (Signal Count) Marker > Resolution
Resolution

Defines the resolution with which the signal is analyzed around the reference marker 1.

For details see "Performing a Highly Accurate Frequency Measurement (Signal Count)"

Remote command:

CALCulate<n>:​MARKer<m>:​COUNt:​RESolution


Noise Measurement Marker

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Noise Measurement Marker
Noise Measurement Marker

For each of the 16 markers noise measurement can be activated. Noise measurement markers are configured in the "Noise Measurement Config" dialog box, using the "Noise Measurement" function.

The individual marker settings correspond to those defined in the "Marker" dialog box (see "Individual Marker Setup"). Any settings to the marker state or type changed in the "Marker Function" dialog box are also changed in the "Marker" dialog box and vice versa.

To display the "Noise Measurement Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "Noise Measurement" button. Select the "Noise Meas Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "Noise Measurement" button. Select the "Noise Meas Config" softkey.

For details see "Measuring Noise Density".

└ Marker X / Delta X
└ Marker State
└ Marker Type
└ Noise Measurement State
└ Switching All Noise Measurements Off


Marker X / Delta X

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Noise Measurement Marker > Marker X / Delta X
Marker X / Delta X

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.


Marker State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Noise Measurement Marker > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Type

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Noise Measurement Marker > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Noise Measurement State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Noise Measurement Marker > Noise Measurement State
Noise Measurement State

Activates or deactivates noise measurement for the marker in the diagram.

This function is only available for normal markers.

If activated, the marker displays the noise power density measured at the position of the marker.

For details see "Measuring Noise Density".

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​NOISe[:​STATe]

CALCulate<n>:​MARKer<m>:​FUNCtion:​NOISe:​RESult?


Switching All Noise Measurements Off

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Noise Measurement Marker > Switching All Noise Measurements Off
Switching All Noise Measurements Off

Deactivates noise measurement for all markers.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​NOISe[:​STATe]


Phase Noise Measurement Marker

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Phase Noise Measurement Marker
Phase Noise Measurement Marker

For each of the 16 markers phase noise measurement can be activated. Phase noise measurement markers are configured in the "Phase Noise Config" dialog box, using the "Phase Noise" function.

The individual marker settings correspond to those defined in the "Marker" dialog box. Any settings to the marker state or type changed in the "Marker Function" dialog box are also changed in the "Marker" dialog box and vice versa.

To display the "Phase Noise Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "Phase Noise" button. Select the "Phase Noise Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "Phase Noise" button. Select the "Phase Noise Config" softkey.

For more information see "Measuring Phase Noise".

└ Marker X / Delta X
└ Phase Noise Measurement State
└ Defining a Reference Point
└ Switching All Phase Noise Measurements Off


Marker X / Delta X

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Phase Noise Measurement Marker > Marker X / Delta X
Marker X / Delta X

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.


Phase Noise Measurement State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Phase Noise Measurement Marker > Phase Noise Measurement State
Phase Noise Measurement State

Activates or deactivates phase noise measurement for the reference point in the diagram.

This function is only available for delta markers.

If activated, the delta markers display the phase noise measured at defined offsets from the reference position.

For details see "Measuring Phase Noise".

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise[:​STATe]

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise:​RESult?


Defining a Reference Point

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Phase Noise Measurement Marker > Defining a Reference Point
Defining a Reference Point

Instead of using marker 1 as the reference marker, a fixed reference marker can be defined for phase noise measurement.

The "Level" and "Frequency" or "Time" settings define the position and value of the reference point.

Alternatively, a Peak Search can be performed to set the maximum value of the selected trace as the reference point.

If "Automatic Peak Search" is activated, a peak search is started automatically after each sweep and the result is used as the reference point.

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​Y

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​X

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise:​AUTO


Switching All Phase Noise Measurements Off

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Phase Noise Measurement Marker > Switching All Phase Noise Measurements Off
Switching All Phase Noise Measurements Off

Deactivates phase noise measurement for all markers.

Remote command:

CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise[:​STATe]


n dB Down Marker

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > n dB Down Marker
n dB Down Marker

A special marker can be defined to determine a characteristic bandwidth or time span in a measured signal. n dB down markers are configured in the "N dB Down Config" dialog box, using the "n dB down" function.

To display the "N dB Down Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "n dB down" button. Select the "N dB Down Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "n dB down" button. Select the "N dB Down Config" softkey.

For details see "Measuring Characteristic Bandwidths (n dB Down Marker)".

└ n dB down Marker State
└ n dB down Delta Value


n dB down Marker State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > n dB Down Marker > n dB down Marker State
n dB down Marker State

Activates or deactivates the special n dB down marker function.

For details see "Measuring Characteristic Bandwidths (n dB Down Marker)".

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​STATe

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​RESult?


n dB down Delta Value

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > n dB Down Marker > n dB down Delta Value
n dB down Delta Value

Defines the delta level from the reference marker 1 used to determine the bandwidth or time span.

For details see "Measuring Characteristic Bandwidths (n dB Down Marker)"

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​FREQuency?

CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​TIME?


Reference Fixed

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Reference Fixed
Reference Fixed

Instead of using a reference marker that may vary its position depending on the measurement results, a fixed reference marker can be defined for trace analysis. Once positioned, the reference marker does not move during subsequent sweeps unless you explicitely move it manually.

When you select this marker function, a vertical and a horizontal red display line are displayed, marked as "FXD". A normal marker is activated and set to the peak value and a delta marker to the next peak. The fixed reference marker is set to the position of the normal marker at the peak value. The delta marker refers to the fixed reference marker.

You can move the position of the fixed reference marker graphically by dragging the display lines, or numerically by entering values for the marker position and level.

For more information see "Defining a Fixed Reference Marker".


Band Power Marker

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Band Power Marker
Band Power Marker

For each of the 16 markers band power measurement can be activated. Band power measurement markers are configured in the "Band Power Config" dialog box, using the "Band Power" function.

The individual marker settings correspond to those defined in the "Marker" dialog box (see "Individual Marker Setup"). Any settings to the marker state or type changed in the "Marker Function" dialog box are also changed in the "Marker" dialog box and vice versa.

To display the "Band Power Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "Band Power" button. Select the "Band Power Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "Band Power" button. Select the "Band Power Config" softkey.

For more information see "Measuring the Power in a Channel (Band)".

└ Marker X / Delta X
└ Band Power Measurement State
└ Span
└ Power Mode
└ Switching All Band Power Measurements Off


Marker X / Delta X

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Band Power Marker > Marker X / Delta X
Marker X / Delta X

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.


Band Power Measurement State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Band Power Marker > Band Power Measurement State
Band Power Measurement State

Activates or deactivates band power measurement for the marker in the diagram.

Band power markers are only available for standard frequency measurements (not zero span) in the Spectrum application.

If activated, the markers display the power or density measured in the band around the current marker position.

For details see "Measuring the Power in a Channel (Band)".

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​BPOWer[:​STATe]


Span

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Band Power Marker > Span
Span

Defines the span (band) around the marker for which the power is measured. The span is indicated by lines in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​BPOWer:​SPAN


Power Mode

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Band Power Marker > Power Mode
Power Mode

Defines the mode of the power measurement result.

"Power" | The result is an absolute power level displayed in dBm.
"Density" | The result is a power level in relation to the bandwidth, displayed in dBm/Hz.
Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​BPOWer:​MODE


Switching All Band Power Measurements Off

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Band Power Marker > Switching All Band Power Measurements Off
Switching All Band Power Measurements Off

Deactivates band power measurement for all markers.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​BPOWer[:​STATe]


Marker Demodulation

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Demodulation
Marker Demodulation

A special marker can be used to demodulate the signal at a particular position and send the result to the audio output. Marker Demodulation is configured in the "Marker Demod Config" dialog box, using the "Marker Demodulation" function.

To display the "Marker Demod Config" dialog box, do one of the following:

  • Press the MKR FUNC key, then select the "Select Marker Function" softkey. Then select the "Marker Demodulation" button. Select the "Marker Demod Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Function Config" tab. Then select the "Marker Demodulation" button. Select the "Marker Demod Config" softkey.

This function is not available for Spectrum Emission Mask measurements or measurements on I/Q-based data.

For details see "Demodulating Marker Values and Providing Audio Output".

└ Marker Demodulation State
└ Continuous Demodulation
└ Marker Stop Time
└ Modulation
└ Squelch
└ Squelch level


Marker Demodulation State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Demodulation > Marker Demodulation State
Marker Demodulation State

Activates or deactivates the demodulation output.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​DEModulation[:​STATe]


Continuous Demodulation

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Demodulation > Continuous Demodulation
Continuous Demodulation

If activated, the signal is demodulated continuously (not only at the marker position) and sent to the audio output. This allows you to monitor the frequency range acoustically (assuming the sweep time is long enough).

For zero span and EMI measurements, demodulation is always active continuously.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​DEModulation:​CONTinuous


Marker Stop Time

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Demodulation > Marker Stop Time
Marker Stop Time

Defines how long the sweep is stopped at the marker position to output the demodulated signal.

For zero span measurements, demodulation is always active continuously, regardless of the marker stop time.

For EMI measurements, the duration of the demodulation at each marker position is limited by the dwell time of the EMI measurement marker (see "Dwell Time").

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​DEModulation:​HOLDoff


Modulation

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Demodulation > Modulation
Modulation

Defines the demodulation mode for output (AM/FM). The default setting is AM.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​DEModulation:​SELect


Squelch

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Demodulation > Squelch
Squelch

Activates or deactivates the squelch function. If activated, the audible AF is cut off below a defined threshold level. Thus, you avoid hearing noise at the audio output when no signal is available.

The squelch function activates the video trigger function (see "Video") and deactivates any other trigger or gating settings. The squelch level and trigger level are set to the same value.

The trigger source in the channel bar is indicated as "SQL" for squelch. The squelch level is indicated by a red line in the diagram.

Remote command:

[SENSe:​]DEMod:​SQUelch[:​STATe]


Squelch level

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Demodulation > Squelch level
Squelch level

Defines the level threshold below which the audible AF is cut off if squelching is enabled. The video trigger level is set to the same value.

The squelch level is indicated by a red line in the diagram.

Remote command:

[SENSe:​]DEMod:​SQUelch:​LEVel


Marker Peak List Configuration

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration
Marker Peak List Configuration

The marker peak list provides an overview of all marker peaks in the measurement. You can define search and sort criteria to influence the results of the analysis. The general marker search settings also apply to the marker peak list (see "Marker Search Settings").

For more information see "Searching for Signal Peaks".

To display the "Marker Peak List" dialog, do one of the following:

  • Press the MKR FUNC key, then select the "Marker Peak List" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Peak List" tab.
└ Peak List State
└ Sort Mode
└ Maximum Number of Peaks
└ Peak Excursion
└ Displaying Marker Numbers
└ Search Limits (Left / Right)
└ Search Threshold
└ Using Zoom Limits
└ Deactivating All Search Limits
└ Exporting the Peak List
└ Decimal Separator


Peak List State

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Peak List State
Peak List State

Activates/deactivates the marker peak list. If activated, the peak list is displayed and the peaks are indicated in the trace display.

For each listed peak the frequency/time ("X-value") and level ("Y-value") values are given.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​STAT


Sort Mode

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Sort Mode
Sort Mode

Defines whether the peak list is sorted according to the x-values or y-values. In either case the values are sorted in ascending order.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT


Maximum Number of Peaks

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Maximum Number of Peaks
Maximum Number of Peaks

Defines the maximum number of peaks to be determined and displayed.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​LIST:​SIZE


Displaying Marker Numbers

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Displaying Marker Numbers
Displaying Marker Numbers

By default, the marker numbers are indicated in the diagram so you can find the peaks from the list. However, for large numbers of peaks the marker numbers may decrease readability; in this case, deactivate the marker number display.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​ANNotation:​LABel[:​STATe]


Search Threshold

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Search Threshold
Search Threshold

Defines an absolute threshold as an additional condition for the peak search. Only peaks that exceed the threshold are detected.

Remote command:

CALCulate:​THReshold


Using Zoom Limits

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Using Zoom Limits
Using Zoom Limits

If activated, the peak search is restricted to the active zoom area defined for a single zoom (see "Single Zoom").

Remote command:

CALCulate:​MARKer:​X:​SLIMits:​ZOOM[:​STATe]


Deactivating All Search Limits

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Deactivating All Search Limits
Deactivating All Search Limits

Deactivates the search range limits.

Remote command:

CALCulate:​MARKer:​X:​SLIMits[:​STATe]

CALCulate:​THReshold:​STATe


Exporting the Peak List

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Exporting the Peak List
Exporting the Peak List

The peak list can be exported to an ASCII file (.DAT) for analysis in an external application.

For details see "How to Export a Peak List".

Remote command:

MMEMory:​STORe:​PEAK

FORMat:​DEXPort:​DSEParator

└ Decimal Separator


Decimal Separator

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Marker Peak List Configuration > Exporting the Peak List > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Deactivating All Marker Functions

Common Analysis and Display Functions > Marker Usage > Marker Function Configuration > Deactivating All Marker Functions
Deactivating All Marker Functions

All special marker functions can be deactivated in one step.


How to Work With Markers

Common Analysis and Display Functions > Marker Usage > How to Work With Markers
How to Work With Markers

The following step-by-step instructions demonstrate in detail how to work with markers.

Contents
  • How to Analyze a Signal Point in Detail
  • How to Use a Fixed Reference Marker
  • How to Output the Demodulated Signal Accoustically


How to Analyze a Signal Point in Detail

Common Analysis and Display Functions > Marker Usage > How to Work With Markers > How to Analyze a Signal Point in Detail
How to Analyze a Signal Point in Detail

When you need to analyze a characteristic point in the signal in more detail, the following procedure can be helpful:

  1. Perform a peak search to determine the characteristic point roughly by pressing the PEAK SEARCH key.

  2. If the required signal point is not the maximum, continue the peak search to one of the subsequent maxima or minima:

    1. Press the MKR -> key.

    2. Select the "Next Peak" or "Next Min" key.

    3. If necessary, change the search settings by selecting the "Search Config" softkey.

  3. Center the display around the determined signal point by setting the marker value to the center frequency. Select the "Center = Mkr Freq" softkey.

  4. Determine the precise frequency of the signal point:

    1. Select the "Select Marker Function" softkey.

    2. Select the "Signal Count" button.

    3. Select the "Signal Count Resolution" softkey.

    4. Select the resolution depending on how precise the result needs to be.


How to Use a Fixed Reference Marker

Common Analysis and Display Functions > Marker Usage > How to Work With Markers > How to Use a Fixed Reference Marker
How to Use a Fixed Reference Marker

By default, delta markers refer to marker 1. However, they can also refer to a fixed reference marker.

How to Define and Move a Fixed Reference Marker

  1. To display a fixed reference marker, do one of the following:

    • Press the MKR FUNC key, then select the "Reference Fixed" marker function.
    • In the "Marker" dialog box, in the "Reference Fixed" area of the "Marker Config" tab, set the "State" to "On".

    A vertical and a horizontal red display line are displayed, marked as "FXD". The normal marker 1 is activated and set to the peak value of the trace assigned to marker 1, and a delta marker to the next peak. The fixed reference marker is set to the position of marker 1 at the peak value.

  2. To move the fixed reference marker, do one of the following:

    • Change the "Level" and "Frequency" of the reference point in the "Marker Config" tab of the "Marker" dialog box, . By default, the current peak value of trace 1 is set.
    • Set the fixed reference marker to the current peak value by selecting the "Peak Search" button in the "Marker Config" tab of the "Marker" dialog box.
    • Move the "FXD" display lines that define the position of the fixed reference marker by dragging them on the screen.
How to Assign a Fixed Reference Marker to Delta Markers

  1. In the "Marker" dialog box, select the horizontal "Markers" tab.

  2. For the active delta marker that is to refer to the fixed reference marker, select "FXD" from the "Ref. Marker" list.

    The delta marker indicates the offset of the current trace value at the marker position from the fixed reference value.


How to Output the Demodulated Signal Accoustically

Common Analysis and Display Functions > Marker Usage > How to Work With Markers > How to Output the Demodulated Signal Accoustically
How to Output the Demodulated Signal Accoustically

For long sweep times you may wish to monitor a measurement accoustically rather than visually to determine when a certain signal level is reached.

Risk of hearing damage

To protect your hearing, make sure that the volume setting is not too high before putting on the headphones.

  1. Set marker 1 to the signal level you want to monitor.

  2. Press the MKR FUNCT key.

  3. Select the "Select Marker Function" softkey.

  4. Select the "Marker Demodulation" button.

  5. Select the "Marker Demod Config" softkey.

    The marker function results are determined immediately according to the default settings.

  6. Define how long you want to hear the output signal when the marker value is reached by entering the duration in the "Marker Stop Time" field.

    Alternatively, the audio signal can be output continuously, regardless of the marker value; in this case, set "Continuous Demodulation" to "On".

  7. Select the modulation type (AM/FM/PM) of the signal.

  8. To avoid listening to noise during continuous output, set "Squelch" to "On" and define the signal level below which the signal is ignored ("Squelch level").

  9. Set "Marker Demodulation" to "On".

  10. Plug your headphones into the PHONES connector on the front panel of the R&S FSW.

  11. Adjust the volume using the rotary knob next to the PHONES connector.

    During the next or currently running measurement, when the sweep reaches the marker position, the demodulated signal is output as an audio signal via the headphones for the given duration. Or, depending on the configuration, the demodulated signal is continuously output via the headphones, if the signal level exceeds the squelch level.


Measurement Example: Measuring Harmonics Using Marker Functions

Common Analysis and Display Functions > Marker Usage > Measurement Example: Measuring Harmonics Using Marker Functions
Measurement Example: Measuring Harmonics Using Marker Functions

This measurement example describes how to measure harmonics using the provided marker functions. Note that this task can be performed much simpler using the Harmonic Distortion measurement (see "Harmonic Distortion Measurement").

Signal generator settings (e.g. R&S FSW SMU):
Frequency: | 128 MHz
Level: | - 25 dBm
Procedure:

  1. Preset the R&S FSW.

  2. Set the center frequency to 128 MHz.

  3. Set the span to 100 kHz.

    The R&S FSW displays the reference signal with a span of 100 kHz and resolution bandwidth of 1 kHz.

  4. Switch on the marker by pressing the MKR key.

    The marker is positioned on the trace maximum.

  5. Set the measured signal frequency and the measured level as reference values:

    1. Press the MKR FUNC key

    2. Press the "Reference Fixed" softkey.

    The position of the marker becomes the reference point. The reference point level is indicated by a horizontal line, the reference point frequency with a vertical line. At the same time, the delta marker 2 is switched on.

    Fundamental wave and the frequency and level reference point

  6. Make the step size for the center frequency correspond to the signal frequency: in the "Frequency" configuration dialog box, select "Center Frequency Stepsize = Marker".

    The step size for the center frequency is now equal to the marker frequency.

  7. Move the center frequency to the 2nd harmonic of the signal by pressing the UP ( [image]) key on the front panel.

    The center frequency is set to the 2nd harmonic.

  8. Place the delta marker on the 2nd harmonic: in the "Marker To" menu, select the "Peak" softkey.

    The delta marker moves to the maximum of the 2nd harmonic. The displayed level result is relative to the reference point level (= fundamental wave level).

The other harmonics are measured by repeating steps step 7 and step 8, with the center frequency being incremented or decremented in steps of 128 MHz using the UP or DOWN keys.


Display and Limit Lines

Common Analysis and Display Functions > Display and Limit Lines
Display and Limit Lines

Display and limit lines help you analyze a measurement trace.

Contents
  • Basics on Display Lines
  • Basics on Limit Lines
  • Settings and Functions for Display and Limit Lines
  • How to Work with Display and Limit Lines


Basics on Display Lines

Common Analysis and Display Functions > Display and Limit Lines > Basics on Display Lines
Basics on Display Lines

Display lines help you analyze a trace – as do markers. The function of a display line is comparable to that of a ruler that can be shifted on the trace in order to mark absolute values. They are used exclusively to visually mark relevant frequencies or points in time (zero span), as well as constant level values. It is not possible to check automatically whether the points are below or above the marked level values - use limit lines for that task (see "Basics on Limit Lines").

Two different types of display lines are provided:

  • Two horizontal level lines for marking levels – Display Line 1 and 2
    The level lines are continuous horizontal lines across the entire width of a diagram and can be shifted in y direction.
  • Two vertical frequency or time lines for marking frequencies or points in time – Frequency/Time Line 1 and 2
    The frequency or time lines are continuous vertical lines across the entire height of the diagram and can be shifted in x direction.
Lables

Each line is identified by one of the following abbreviations in the diagrams:

  • D1: Display Line 1
  • D2: Display Line 2
  • F1: Frequency Line 1
  • F2: Frequency Line 2
  • T1: Time Line 1
  • T2: Time Line 2


Basics on Limit Lines

Common Analysis and Display Functions > Display and Limit Lines > Basics on Limit Lines
Basics on Limit Lines

Limit lines are used to define amplitude curves or spectral distribution boundaries in the result diagram which are not to be exceeded. They indicate, for example, the upper limits for interference radiation or spurious waves which are allowed from a device under test (DUT). When transmitting information in TDMA systems (e.g. GSM), the amplitude of the bursts in a time slot must adhere to a curve that falls within a specified tolerance band. The lower and upper limits may each be specified by a limit line. Then, the amplitude curve can be controlled either visually or automatically for any violations of the upper or lower limits (GO/NOGO test).

The R&S FSW supports limit lines with a maximum of 200 data points. Eight of the limit lines stored in the instrument can be activated simultaneously. The number of limit lines stored in the instrument is only limited by the capacity of the storage device used.

Compatibility

Limit lines are compatible with the current measurement settings, if the following applies:

  • The x unit of the limit line has to be identical to the current setting.
  • The y unit of the limit line has to be identical to the current setting with the exception of dB based units; all dB based units are compatible with each other.
Validity

Only limit lines that fulfill the following conditions can be activated:

  • Each limit line must consist of a minimum of 2 and a maximum of 200 data points.
  • The frequencies/times for each data point must be defined in ascending order; however, for any single frequency or time, two data points may be entered (to define a vertical segment of a limit line).
  • Gaps in frequency or time are not allowed. If gaps are desired, two separate limit lines must be defined and then both enabled.
  • The entered frequencies or times need not necessarily be selectable in R&S FSW. A limit line may also exceed the specified frequency or time range. The minimum frequency for a data point is -200 GHz, the maximum frequency is 200 GHz. For the time range representation, negative times may also be entered. The allowed range is -1000 s to +1000 s.
Example for an upper limit line
Limits and Margins

Limit lines define strict values that must not be exceeded by the measured signal. A margin is similar to a limit, but less strict and it still belongs to the valid data range. It can be used as a warning that the limit is almost reached. The margin is not indicated by a separate line in the display, but if it is violated, a warning is displayed. Margins are defined as lines with a fixed distance to the limit line.

To check the signal for maximum levels you must define an upper limit, whereas to check the signal for minimum levels you must define a lower limit.

Limits can be defined relative to the reference level, the beginning of the time scale, or the center frequency, or as absolute values.

Relative scaling is suitable, for example, if masks for bursts are to be defined in zero span, or if masks for modulated signals are required in the frequency domain.

Thresholds

If the y-axis for the limit line data points uses relative scaling, an additional absolute threshold can be defined for the limit check. In this case, both the threshold value and the relative limit line must be exceeded before a violation occurs.

Offsets and Shifting

A configured limit line can easily be moved vertically or horizontally. Two different methods to do so are available:

  • An offset moves the entire line in the diagram without editing the configured values or positions of the individual data points. This option is only available if relative scaling is used.
    Thus, a new limit line can be easily generated based upon an existing limit line which has been shifted horizontally or vertically.
  • Defining a shift width for the values or position of the individual data points changes the line configuration, thus changing the position of the line in the diagram.
Limit Check Results

A limit check is automatically performed as soon as any of the limit lines is activated ("Visibility" setting). Only the specified "Traces to be Checked" are compared with the active limit lines. The status of the limit check for each limit line is indicated in the diagram. If a violation occurs, the limit check status is set to "MARG" for a margin violation, or to"FAIL" for a limit violation.

Margin violation for limit check
Limit violation for limit check


Settings and Functions for Display and Limit Lines

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines
Settings and Functions for Display and Limit Lines

For remote operation, see "Configuring Display and Limit Lines".

Contents
  • Display Line Settings
  • Limit Line Settings and Functions


Display Line Settings

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Display Line Settings
Display Line Settings

Two vertical and two horizontal lines can be defined in the display.

└ Vertical Line 1/2
└ Horizontal Line 1/2


Vertical Line 1/2

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Display Line Settings > Vertical Line 1/2
Vertical Line 1/2

Activates a vertical display line (F1/F2 or T1/T2) in the diagram at the specified frequency or point in time, depending on the frequency span.

Remote command:

CALCulate<n>:​FLINe<k>

CALCulate<n>:​FLINe<k>

CALCulate<n>:​TLINe<Line>

CALCulate<n>:​TLINe<Line>


Horizontal Line 1/2

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Display Line Settings > Horizontal Line 1/2
Horizontal Line 1/2

Activates a horizontal display line (D1/D2) in the diagram at the specified level.

Remote command:

CALCulate<n>:​DLINe<k>

CALCulate<n>:​DLINe<k>


Limit Line Settings and Functions

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions
Limit Line Settings and Functions

Up to 8 limit lines can be displayed simultaneously in the R&S FSW. Many more can be stored on the instrument.

Contents
  • Limit Line Management
  • Limit Line Details


Limit Line Management

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management
Limit Line Management

Limit lines are managed in the "Line Config" dialog box which is displayed when you press the LINES key and then "Lines Config" softkey.

For the limit line overview, the R&S FSW searches for all stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder. The overview allows you to determine which limit lines are available and can be used for the current measurement.

For details on settings for individual lines see "Limit Line Details".

For more basic information on limit lines see "Basics on Limit Lines".

For instructions on configuring and working with limit lines see "Defining Limit Lines".

└ Name
└ Unit
└ Compatibility
└ Visibility
└ Traces to be Checked
└ Comment
└ Included Lines in Overview (View Filter)
└ Show lines for all modes
└ X-Offset
└ Y-Offset
└ Create New Line
└ Edit Line
└ Copy Line
└ Delete Line
└ Disable All Lines


Name

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Name
Name

The name of the stored limit line.


Unit

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Unit
Unit

The unit in which the y-values of the data points of the limit line are defined.


Compatibility

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Compatibility
Compatibility

Indicates whether the limit line definition is compatible with the current measurement settings.

For more information on which conditions a limit line must fulfill to be compatible, see "Basics on Limit Lines".


Visibility

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Visibility
Visibility

Displays or hides the limit line in the diagram. Up to 8 limit lines can be visible at the same time. Inactive limit lines can also be displayed in the diagram.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​STATe

CALCulate:​LIMit<k>:​UPPer:​STATe

CALCulate:​LIMit:​ACTive?


Traces to be Checked

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Traces to be Checked
Traces to be Checked

Defines which traces are automatically checked for conformance with the limit lines. As soon as a trace to be checked is defined, the assigned limit line is active. One limit line can be activated for several traces simultaneously. If any of the "Traces to be Checked" violate any of the active limit lines, a message is indicated in the diagram.

Remote command:

CALCulate:​LIMit<k>:​TRACe<t>:​CHECk


Comment

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Comment
Comment

An optional description of the limit line.


Included Lines in Overview (View Filter)

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Included Lines in Overview (View Filter)
Included Lines in Overview (View Filter)

Defines which of the stored lines are included in the overview.

"Show compatible" | Only compatible lines Whether a line is compatible or not is indicated in the "Compatibility" setting. For more information on which conditions a limit line must fulfill to be compatible, see "Basics on Limit Lines".
"Show all" | All stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder (if not restricted by "Show lines for all modes" setting).
└ Show lines for all modes


Show lines for all modes

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Included Lines in Overview (View Filter) > Show lines for all modes
Show lines for all modes

If activated (default), limit lines from all applications are displayed. Otherwise, only lines that were created in the Spectrum application are displayed.

Note that limit lines from some applications may include additional properties that are lost when the limit lines are edited in the Spectrum application. In this case a warning is displayed when you try to store the limit line.


X-Offset

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > X-Offset
X-Offset

Shifts a limit line that has been specified for relative frequencies or times (x-axis) horizontally.

This setting does not have any effect on limit lines that are defined by absolute values for the x-axis.

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​OFFSet


Y-Offset

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Y-Offset
Y-Offset

Shifts a limit line that has relative values for the y-axis (levels or linear units such as volt) vertically.

This setting does not have any effect on limit lines that are defined by absolute values for the y-axis.

Remote command:

CALCulate:​LIMit<k>:​LOWer:​OFFSet

CALCulate:​LIMit<k>:​UPPer:​OFFSet


Create New Line

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Create New Line
Create New Line

Creates a new limit line.

For instructions see "How to configure a new limit line".


Edit Line

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Edit Line
Edit Line

Edit an existing limit line configuration.

For instructions see "How to edit existing limit lines".


Copy Line

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Copy Line
Copy Line

Copy the selected limit line configuration to create a new line.

For instructions see "How to edit existing limit lines".

Remote command:

CALCulate:​LIMit<k>:​COPY


Delete Line

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Delete Line
Delete Line

Delete the selected limit line configuration.

For instructions see "How to edit existing limit lines".

Remote command:

CALCulate:​LIMit<k>:​DELete


Disable All Lines

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Management > Disable All Lines
Disable All Lines

Disable all limit lines in one step.

Remote command:

CALCulate:​LIMit<k>:​STATe


Limit Line Details

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details
Limit Line Details

Limit lines details are configured in the "Edit Line Line" dialog box which is displayed when you select the "New", "Edit" or "Copy To" buttons in the "Line Config" dialog box.

└ Name
└ Comment
└ Threshold
└ Margin
└ X-Axis
└ Y-Axis
└ Data points
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


Name

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Name
Name

Defines the limit line name. All names must be compatible with Windows conventions for file names. The limit line data is stored under this name (with a .LIN extension).

Remote command:

CALCulate:​LIMit<k>:​NAME


Comment

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Comment
Comment

Defines an optional comment for the limit line. The text may contain up to 40 characters.

Remote command:

CALCulate:​LIMit:​COMMent


Threshold

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Threshold
Threshold

Defines an absolute threshold value (only for relative scaling of the y-axis).

For details on thresholds see "Basics on Limit Lines".

Remote command:

CALCulate:​LIMit<k>:​LOWer:​THReshold

CALCulate:​LIMit<k>:​UPPer:​THReshold


Margin

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Margin
Margin

Defines a margin for the limit line. The default setting is 0 dB (i.e. no margin).

For details on margins see "Basics on Limit Lines".

Remote command:

CALCulate:​LIMit<k>:​LOWer:​MARGin

CALCulate:​LIMit<k>:​UPPer:​MARGin


X-Axis

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > X-Axis
X-Axis

Describes the horizontal axis on which the data points of the limit line are defined. Includes the following settings:

  • Domain:
    – "Hz": for frequency domain
    – "s": for time domain
  • Scaling mode: absolute or relative (Hz/s/%) values
    For relative values, the frequencies are referred to the currently set center frequency. In the zero span mode, the left boundary of the diagram is used as the reference.
  • Scaling: linear or logarithmic
Remote command:

CALCulate:​LIMit<k>:​LOWer:​SPACing

CALCulate:​LIMit<k>:​UPPer:​SPACing

CALCulate:​LIMit<k>:​LOWer:​MODE

CALCulate:​LIMit<k>:​UPPer:​MODE

CALCulate:​LIMit<k>:​CONTrol:​DOMain


Y-Axis

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Y-Axis
Y-Axis

Describes the vertical axis on which the data points of the limit line are defined. Includes the following settings:

  • Level unit
  • Scaling mode: absolute or relative (dB/%) values
    Relative limit values refer to the reference level.
  • Limit type: upper or lower limit; values must stay above the lower limit and below the upper limit to pass the limit check
Remote command:

CALCulate:​LIMit<k>:​UNIT

CALCulate:​LIMit<k>:​LOWer:​SPACing

CALCulate:​LIMit<k>:​UPPer:​SPACing


Data points

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Data points
Data points

Each limit line is defined by a minimum of 2 and a maximum of 200 data points. Each data point is defined by its position (x-axis) and value (y-value). Data points must be defined in ascending order. The same position can have two different values.

Remote command:

CALCulate:​LIMit<k>:​CONTrol[:​DATA]

CALCulate:​LIMit<k>:​LOWer[:​DATA]

CALCulate:​LIMit<k>:​UPPer[:​DATA]


Insert Value

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Insert Value
Insert Value

Inserts a data point in the limit line above the selected one in the "Edit Limit Line" dialog box.


Delete Value

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Delete Value
Delete Value

Deletes the selected data point in the "Edit Limit Line" dialog box.


Shift x

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Shift x
Shift x

Shifts the x-value of each data point horizontally by the defined shift width (as opposed to an additive offset defined for the entire limit line, see "X-Offset").

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​SHIFt


Shift y

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Shift y
Shift y

Shifts the y-value of each data point vertically by the defined shift width (as opposed to an additive offset defined for the entire limit line, see "Y-Offset").

Remote command:

CALCulate:​LIMit<k>:​LOWer:​SHIFt

CALCulate:​LIMit<k>:​UPPer:​SHIFt


Save

Common Analysis and Display Functions > Display and Limit Lines > Settings and Functions for Display and Limit Lines > Limit Line Settings and Functions > Limit Line Details > Save
Save

Saves the currently edited limit line under the name defined in the "Name" field.


How to Work with Display and Limit Lines

Common Analysis and Display Functions > Display and Limit Lines > How to Work with Display and Limit Lines
How to Work with Display and Limit Lines

Step-by-step instructions on configuring display and limit lines are provided here. For details on individual functions and settings see "Settings and Functions for Display and Limit Lines ".

The remote commands required to perform these tasks are described in "Configuring Display and Limit Lines".

Contents
  • Defining Display Lines
  • Defining Limit Lines


Defining Display Lines

Common Analysis and Display Functions > Display and Limit Lines > How to Work with Display and Limit Lines > Defining Display Lines
Defining Display Lines

  1. Display lines are configured in the "Lines Config" dialog box. To display this dialog box, press the LINES key and then "Lines Config".

  2. Select the "Display Lines" tab.

  3. To define a vertical line, select "Vertical Line 1" or 2 and enter the x-value at which the line is to be displayed.

    To define a horizontal line, select "Horizontal Line 1" or 2 and enter the y-value at which the line is to be displayed.


Defining Limit Lines

Common Analysis and Display Functions > Display and Limit Lines > How to Work with Display and Limit Lines > Defining Limit Lines
Defining Limit Lines

Limit lines are configured in the "Lines Config" dialog box. To display this dialog box, do one of the following:

  • Press the LINES key and then the "Lines Config" softkey, then select the "Lines Config" tab.
  • In the "Overview", select "Analysis" and then the vertical "Limit Lines Config" tab.
Limit lines for spurious and SEM measurements

Note that for spurious and SEM measurements, special limit lines can be defined for each frequency range, see "Limit Lines in SEM Measurements" and "Limit Lines in Spurious Measurements". It is strongly recommended that you define limits only via the "Sweep list" dialog for these measurements, not using the LINES key.

Any changes to the special limit lines are automatically overwritten when the sweep list settings are changed.

The following tasks are described here:

  • "How to find compatible limit lines"
  • "How to activate and deactivate a limit check"
  • "How to edit existing limit lines"
  • "How to copy an existing limit line"
  • "How to delete an existing limit line"
  • "How to configure a new limit line"
  • "How to move the limit line vertically or horizontally"
How to find compatible limit lines
►

In the "Line Config" dialog box, select the "View filter" option: "Show compatible".

All stored limit lines with the file extension .LIN in the limits subfolder of the main installation folder of the instrument that are compatible to the current measurement settings are displayed in the overview.

How to activate and deactivate a limit check

A limit check is automatically performed as soon as any of the limit lines is activated.

  1. To activate a limit check:

    Select the "Check Traces" setting for a limit line in the overview and select the trace numbers to be included in the limit check. One limit line can be assigned to several traces.

    The specified traces to be checked are compared with the active limit lines. The status of the limit check is indicated in the diagram.

  2. To deactivate a limit line, deactivate all "Traces to check" for it.

    To deactivate all limit lines at once, select the "Disable All Lines" button.

    The limit checks for the deactivated limit lines are stopped and the results are removed form the display.

How to edit existing limit lines

Existing limit line configurations can be edited.

Note that any changes to the special limit lines for spurious and SEM measurements are automatically overwritten when the sweep list settings are changed.

  1. In the "Line Config" dialog box, select the limit line.

  2. Select the "Edit" button.

  3. Edit the line configuration as described in "How to configure a new limit line".

  4. Save the new configuration by selecting the "Save" button.

    If the limit line is active, the edited limit line is displayed in the diagram.

How to copy an existing limit line

  1. In the "Line Config" dialog box, select the limit line.

  2. Select the "Copy To" button.

  3. Define a new name to create a new limit with the same configuration as the source line.

  4. Edit the line configuration as described in "How to configure a new limit line".

  5. Save the new configuration by selecting the "Save" button.

    The new limit line is displayed in the overview and can be activated.

How to delete an existing limit line

  1. In the "Line Config" dialog box, select the limit line.

  2. Select the "Delete" button.

  3. Confirm the message.

    The limit line and the results of the limit check are deleted.

How to configure a new limit line

  1. In the "Line Config" dialog box, select the "New" button.

    The "Edit Limit Line" dialog box is displayed. The current line configuration is displayed in the preview area of the dialog box. The preview is updated after each change to the configuration.

  2. Define a "Name" and, optionally, a "Comment" for the new limit line.

  3. Define the x-axis configuration:

    • Time domain or frequency domain
    • Absolute or relative limits
    • Linear or logarithmic scaling

  4. Define the y-axis configuration:

    • Level unit
    • Absolute or relative limits
    • Upper or lower limit line

  5. Define the data points: minimum 2, maximum 200:

    1. Select "Insert Value".

    2. Define the x-value ("Position") and y-value ("Value") of the first data point.

    3. Select "Insert Value" again and define the second data point.

    4. Repeat this to insert all other data points.

      To insert a data point before an existing one, select the data point and then "Insert Value".

      To insert a new data point at the end of the list, move the focus to the line after the last entry and then select "Insert Value".

      To delete a data point, select the entry and then "Delete Value".

  6. Check the current line configuration in the preview area of the dialog box. If necessary, correct individual data points or add or delete some.

    If necessary, shift the entire line vertically or horizontally by selecting the "Shift x" or "Shift y" button and defining the shift width.

  7. Optionally, define a "Margin" at a fixed distance to the limit line.

    The margin must be within the valid value range and is not displayed in the diagram or preview area.

  8. Optionally, if the y-axis uses relative scaling, define an absolute "Threshold" as an additional criteria for a violation.

  9. Save the new configuration by selecting the "Save" button.

    The new limit line is displayed in the overview and can be activated.

How to move the limit line vertically or horizontally

A configured limit line can easily be moved vertically or horizontally. Thus, a new limit line can be easily generated based upon an existing limit line which has been shifted horizontally.

  1. In the "Line Config" dialog box, select the limit line.

  2. To shift the complete limit line parallel in the horizontal direction, select the "X-Offset" button and enter an offset value.

    To shift the complete limit line parallel in the vertical direction, select the "Y-Offset" button and enter an offset value.

  3. To shift the individual data points of a limit line by a fixed value (all at once):

    1. Select the "Edit" button.

    2. In the "Edit Limit Line" dialog box, select the "Shift x" or "Shift y" button and define the shift width.

    3. Save the shifted data points by selecting the "Save" button.

    If activated, the limit line is shifted in the diagram.


Data Management

The R&S FSW allows you to store and load instrument settings, as well as import and export measurement data for analysis at a later time. Finally, you can store or print the measurement results displayed on the screen.

General storage and import/export functions are available via the toolbar. Some special storage functions are (also) available via softkeys or dialog boxes in the corresponding menus, e.g. trace data or marker peak lists.

Contents
  • Restoring the Default Instrument Configuration (Preset)
  • Protecting Data Using the Secure User Mode
  • Storing and Recalling Instrument Settings and Measurement Data
  • Importing and Exporting Measurement Results for Evaluation
  • Creating Screenshots of Current Measurement Results and Settings


Restoring the Default Instrument Configuration (Preset)

Data Management > Restoring the Default Instrument Configuration (Preset)
Restoring the Default Instrument Configuration (Preset)

When delivered, the R&S FSW has a default configuration. You can restore this defined initial state at any time as a known starting point for measurements. This is often recommendable as a first step in troubleshooting when unusual measurement results arise.

To restore the default instrument configuration for all channels at once
► | Press the PRESET key.
 | Alternatively to the factory default settings, you can define user-specific recall settings to be restored after a preset or reboot, see "To recall settings automatically after preset or reboot".

After you use the PRESET function, the history of previous actions is deleted, i.e. any actions performed previously cannot be undone or redone using the UNDO/REDO keys.

Remote command:

*RST or SYSTem:PRESet

To restore the default configuration for a single channel

The default measurement settings can also be reset for an individual channel only, rather than resetting the entire instrument.

► | In the "Overview", select the "Preset Channel" button.
 | The factory default settings are restored to the current channel. Note that a user-defined recall settings file is NOT restored.
Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]

Contents
  • Factory Default Configuration


Factory Default Configuration

Data Management > Restoring the Default Instrument Configuration (Preset) > Factory Default Configuration
Factory Default Configuration

The factory default configuration is selected such that the RF input is always protected against overload, provided that the applied signal levels are in the allowed range for the instrument.

Alternatively to the factory default settings, you can define user-specific recall settings to be restored after a preset or reboot, see "To recall settings automatically after preset or reboot".

Factory default configuration
Parameter | Setting
mode | Spectrum
sweep mode | auto
center frequency | fmax/2
center frequency step size | 0.1 * span
span | maximum possible (depends on instrument model)
RF attenuation | 10 dB
reference level | 0 dBm
level range | 100 dB log
level unit | dBm
sweep time | auto
resolution bandwidth | auto (3 MHz)
video bandwidth | auto (3 MHz)
FFT filters | off
span/RBW | 100
RBW/VBW | 1
sweep | cont
trigger | free run
trace mode | 1: clr write; 2/3/4/5/6: blank
detector | auto peak
frequency offset | 0 Hz
reference level offset | 0 dB
reference level position | 100 %
grid | abs
cal correction | on
noise source | off
input | RF


Storing and Recalling Instrument Settings and Measurement Data

Data Management > Storing and Recalling Instrument Settings and Measurement Data
Storing and Recalling Instrument Settings and Measurement Data

Possibly you would like to restore or repeat a measurement you performed under specific conditions on the instrument. Or you want to evaluate imported data in another application on the R&S FSW and would like to restore the measurement settings applied during measurement. In these cases, you can store and recall instrument and measurement settings, and possibly other related measurement data.

Two different methods are available for managing instrument settings:

  • Quick Save/Quick Recall - a defined set of instrument or channel settings are stored or recalled quickly in just one step
  • Configurable Save/Recall - a user-defined set of instrument or channel settings are stored to a definable storage location
Restrictions when recalling measurement settings

When recalling a saved configuration file, the following restrictions apply:

  • The frequency range defined in the configuration file must be supported by the R&S FSW on which the file is to be recalled.
  • Configuration files created on a R&S FSW with certain options in use will not work on an R&S FSW without these options
  • Files created with newer firmware versions may not work with a previous version
Saving instrument settings in secure user mode

Be sure to store instrument settings that you require beyond the current session before "Secure User Mode" is enabled; see "Protecting Data Using the Secure User Mode".

Settings that are saved via QuickSave in secure user mode are only available during the current session. As soon as the power is switched off on the R&S FSW, the data is cleared.

Import and Export functions are described in "Importing and Exporting Measurement Results for Evaluation".

Contents
  • Quick Save/Quick Recall
  • Configurable Storage and Recall
  • How to Save and Load Instrument Settings


Quick Save/Quick Recall

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Quick Save/Quick Recall
Quick Save/Quick Recall

The Quick Save and Quick Recall functions allow you to store instrument or channel settings very easily and quickly in one step. Up to 10 different sets of settings can be stored to or recalled from "save sets". Each save set is identified by its storage date and type (instrument or specific channel) in the display. The save sets are stored in the C:\r_s\instr\user\QuickSave directory, in files named QuickSave1.dfl to QuickSave10.dfl. The storage file names and locations cannot be changed.

Saving instrument settings in secure user mode

Settings that are saved via Quick Save in secure user mode are stored to the SDRAM, and are only available during the current session. As soon as the power is switched off on the R&S FSW, the data is cleared (see "Protecting Data Using the Secure User Mode").

During recall, save sets of type "Instrument" replace the settings of the entire instrument. All other save sets start a new measurement channel with the stored settings.

If a measurement channel with the same name as the channel to be restored is already active, the channel name for the new channel is extended by a consecutive number:

Contents
  • Quick Save / Quick Recall Settings


Quick Save / Quick Recall Settings

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Quick Save/Quick Recall > Quick Save / Quick Recall Settings
Quick Save / Quick Recall Settings

The "QuickSave" dialog box is displayed when you select the "Save" icon in the toolbar.

The "Quick Recall" dialog box is displayed when you select the "Open" icon in the toolbar, or select the "Quick Recall" tab in the "Recall" dialog box.

Both dialog boxes are very similar and closely related.

└ QuickSave 1 / ... / QuickSave 10
└ Storage Type (Save only)
└ Recall
└ Cancel


QuickSave 1 / ... / QuickSave 10

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Quick Save/Quick Recall > Quick Save / Quick Recall Settings > QuickSave 1 / ... / QuickSave 10
QuickSave 1 / ... / QuickSave 10

Selects one of the save sets to store the current settings in or to be recalled. At the time of storage, the "QuickSave 1 / ... / QuickSave 10" placeholder is replaced by a label indicating the storage date and time and the storage type.

During recall, save sets of type "Instrument" replace the settings of the entire instrument. All other save sets start a new measurement channel with the stored settings.

Note: Saving instrument settings in secure user mode. Settings that are saved via Quick Save in secure user mode are only available during the current session. As soon as the power is switched off on the R&S FSW, the data is cleared (see "Protecting Data Using the Secure User Mode").


Storage Type (Save only)

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Quick Save/Quick Recall > Quick Save / Quick Recall Settings > Storage Type (Save only)
Storage Type (Save only)

Defines which type of settings is to be stored in the save set.

"Instrument with all channels" | The instrument settings for all currently active channels are stored.
"Current Channel" | Only the instrument settings for the currently selected measurement channel are stored.


Recall

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Quick Save/Quick Recall > Quick Save / Quick Recall Settings > Recall
Recall

Restores the instrument settings as saved in the selected settings file. If the settings file contains settings for a specific channel only a new channel with the stored settings is activated, otherwise the entire instrument settings are loaded.

Note: After you use the "Recall" function, the history of previous actions is deleted, i.e. any actions performed previously cannot be undone or redone using the UNDO/REDO keys.

Note: If a measurement channel with the same name as the channel to be restored (in a new channel) is already active, the channel name for the new channel is extended by a consecutive number:

In remote commands, you must append this number to the channel name, as well.

Remote command:

MMEMory:​LOAD:​STATe


Cancel

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Quick Save/Quick Recall > Quick Save / Quick Recall Settings > Cancel
Cancel

Closes the dialog box without saving the settings.


Configurable Storage and Recall

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall
Configurable Storage and Recall

The more sophisticated storage and recall functions allow you to define which settings are stored, and where the settings file is stored to. Any settings file can be selected for recall.

Contents
  • Stored Data Types
  • Storage Location and File Name
  • Save and Recall Dialog Boxes
  • Startup Recall Settings


Stored Data Types

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Stored Data Types
Stored Data Types

The following types of data can be stored to and loaded from files via the "Save" dialog box on the R&S FSW:

Items that can be stored to files
Item | Description
Current Settings | Current instrument and measurement settings
All Transducers | Transducer factors for all active transducers.
All Traces | All active traces; R&S FSW-K30 only: also calibration data
All Limit Lines | All limit lines (Note: information on which limit lines are active is stored with the "Current Settings")
Noise - ENR | Data in "ENR Settings" dialog box (R&S FSW-K30 only)
Noise - Loss Settings | Data in "Loss Settings" dialog box (R&S FSW-K30 only)
Noise - Calibration data | Results from calibration measurement (R&S FSW-K30 only)
K40 Results | All current phase noise trace results (R&S FSW-K40 only)


Storage Location and File Name

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Storage Location and File Name
Storage Location and File Name

The data is stored on the internal flash disk or, if selected, on a memory stick or network drive. The operating system, firmware and stored instrument settings are located on drive C. All other folders and drives can be used to store measurement data.

Saving instrument settings in secure user mode

In secure user mode all data is stored to the SDRAM, and is only available during the current session. As soon as the power is switched off on the R&S FSW, the data is cleared (see "Protecting Data Using the Secure User Mode").

Other storage locations cannot be selected in this mode.

The storage location and file name are selected in a file selection dialog box which is displayed when you perform a storage function.

By default, the name of a settings file consists of a base name followed by an underscore and three numbers, e.g. limit_lines_005. In the example, the base name is limit_lines. The base name can contain characters, numbers and underscores. The file extension dfl is added automatically. The default folder for settings files is C:\r_s\instr\user.


Save and Recall Dialog Boxes

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Save and Recall Dialog Boxes
Save and Recall Dialog Boxes

The following dialog boxes are available via softkeys in the "Save/Recall" menu which is displayed when you select the "Save" or "Open" icon in the toolbar. Both dialog boxes are very similar and closely related.

└ Selecting the Storage Location - Drive/ Path/ Files
└ File Name
└ Comment
└ File Type
└ Items
└ Save File
└ Recall in New Channel / Recall in Current Channel
└ Cancel


Comment

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Save and Recall Dialog Boxes > Comment
Comment

An optional description for the data file. A maximum of 60 characters can be displayed.

Remote command:

MMEMory:​COMMent


File Type

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Save and Recall Dialog Boxes > File Type
File Type

Determines whether the global instrument settings with all channels will be stored or recalled, or the current channel settings only.


Items

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Save and Recall Dialog Boxes > Items
Items

Defines which data and settings are stored or will be recalled. Depending on the "File Type", only channel settings or global settings are available. Which items are available also depends on the installed options (see also "Stored Data Types").

Remote command:

MMEMory:​SELect[:​ITEM]:​ALL

MMEMory:​SELect[:​ITEM]:​DEFault

MMEMory:​SELect[:​ITEM]:​HWSettings

MMEMory:​SELect[:​ITEM]:​LINes:​ALL

MMEMory:​SELect[:​ITEM]:​NONE

MMEMory:​SELect[:​ITEM]:​TRACe[:​ACTive]

MMEMory:​SELect[:​ITEM]:​TRANsducer:​ALL


Save File

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Save and Recall Dialog Boxes > Save File
Save File

Saves the settings file with the defined file name.

Note: Secure user mode. In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.
For details see "Protecting Data Using the Secure User Mode".

Remote command:

MMEMory:​STORe:​STATe

MMEMory:​STORe:​STATe:​NEXT


Recall in New Channel / Recall in Current Channel

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Save and Recall Dialog Boxes > Recall in New Channel / Recall in Current Channel
Recall in New Channel / Recall in Current Channel

Restores the instrument settings as saved in the selected settings file. If the settings file contains settings for a specific channel only, select "Recall in New Channel" to activate a new channel with the stored settings, or "Recall in Current Channel" to replace the current channel settings.

Note: After you use the "Recall" function, the history of previous actions is deleted, i.e. any actions performed previously cannot be undone or redone using the UNDO/REDO keys.

Note: If a measurement channel with the same name as the channel to be restored (in a new channel) is already active, the channel name for the new channel is extended by a consecutive number:

In remote commands, you must append this number to the channel name, as well.

Remote command:

MMEMory:​LOAD:​STATe


Cancel

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Save and Recall Dialog Boxes > Cancel
Cancel

Closes the dialog box without saving the settings.


Startup Recall Settings

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Startup Recall Settings
Startup Recall Settings

The "Startup Recall" softkey opens the "Startup Recall" tab of the "Recall" dialog box.

└ Startup Recall
└ Selecting the Storage Location - Drive/ Path/ Files
└ File Name
└ Comment
└ Select File
└ Cancel


Startup Recall

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Startup Recall Settings > Startup Recall
Startup Recall

Activates or deactivates the startup recall function. If activated, the settings stored in the selected file are loaded each time the instrument is started or preset. If deactivated, the default settings are loaded.

Note that only instrument settings files can be selected for the startup recall function, not channel settings files.

Remote command:

MMEMory:​LOAD:​AUTO


Comment

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Startup Recall Settings > Comment
Comment

An optional description for the data file. A maximum of 60 characters can be displayed.

Remote command:

MMEMory:​COMMent


Select File

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Startup Recall Settings > Select File
Select File

Stores the startup recall settings.


Cancel

Data Management > Storing and Recalling Instrument Settings and Measurement Data > Configurable Storage and Recall > Startup Recall Settings > Cancel
Cancel

Closes the dialog box without saving the settings.


How to Save and Load Instrument Settings

Data Management > Storing and Recalling Instrument Settings and Measurement Data > How to Save and Load Instrument Settings
How to Save and Load Instrument Settings

Instrument settings can be saved to a file and loaded again later, so that you can repeat the measurement with the same settings. Optionally, user-defined measurement settings can automatically be restored each time you start or preset the instrument.

To save and recall instrument settings using the Quick Save function

  1. Select the [image] "Save" icon from the toolbar.

  2. Select whether the instrument settings for all channels are to be stored, or only those for the current channel.

  3. Select one of the save sets in which the settings are to be stored ("QuickSaveX").

    The selected settings are stored to the file C:\r_s\instr\user\QuickSave\QuickSaveX.dfl.

  4. To restore the settings, select the [image] "Open" icon from the toolbar.

  5. Select the save set in which the settings were stored ("QuickSaveX").

    The selected settings are restored to the instrument or channel.

To save configurable instrument settings

  1. Select the [image] "Save" icon from the toolbar.

  2. In the "Save" dialog box, switch to the "Save" tab.

  3. In the file selection dialog box, select a file name and storage location for the settings file.

  4. Optionally, define a comment to describe the stored settings.

  5. Select whether the instrument settings for all channels are to be stored, or only those for the current channel.

  6. Select the items to be saved with the settings. Either the settings for the currently selected channel only or for all channels can be stored, and various other items such as lines or traces etc. can be stored as well (see "Stored Data Types").

  7. Select "Save".

    A file with the defined name and path and the extension .dfl is created.

To recall configurable instrument settings

  1. Select the [image] "Open" icon from the toolbar.

  2. In the "Recall" dialog box, switch to the "Recall" tab.

  3. In the file selection dialog box, select the file name and storage location of the settings file.

    Note: The "File Type" indicates whether the file contains instrument settings for all channels, or only those for the current channel.

  4. If several items were saved, select which items are to be restored.

  5. If channel settings were saved, select whether the settings will replace the settings in the current channel, or whether a new channel with the saved settings will be opened.

  6. Select "Recall".

    The settings and selected items from the saved measurement are restored and you can repeat the measurement with the same settings.

To recall settings automatically after preset or reboot

You can define the settings that are restored when you preset or reboot the instrument.

  1. Configure the settings as required and save them as described in "To save configurable instrument settings".

  2. In the "Save/Recall" menu, select the "Startup Recall" softkey.

  3. If the file selection dialog box is not displayed automatically, select the "Select Dataset" softkey.

  4. Select the recall settings that are to be restored.

  5. Select "Select".

  6. Toggle the "Startup Recall" softkey to "On".

    Now when you press the PRESET key or reboot the instrument, the defined settings will be restored.

  7. To restore the factory preset settings, toggle the "Startup Recall" softkey to "Off".


Importing and Exporting Measurement Results for Evaluation

Data Management > Importing and Exporting Measurement Results for Evaluation
Importing and Exporting Measurement Results for Evaluation

The R&S FSW provides various evaluation methods for the results of the performed measurements. However, you may want to evaluate the data with further, external applications. In this case, you can export the measurement data to a standard format file (ASCII or XML). Some of the data stored in these formats can also be re-imported to the R&S FSW for further evaluation at a later time, for example in other applications.

The following data types can be exported:

  • Trace data
  • Table results, such as result summaries, marker peak lists etc.
  • I/Q data

The following data types can be imported:

  • I/Q data

I/Q data can only be imported and exported in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

See the corresponding user manuals for those applications for details.

Contents
  • Import/Export Functions
  • How to Export Trace Data and Numerical Results
  • How to Export a Peak List
  • Reference: ASCII File Export Format


Import/Export Functions

Data Management > Importing and Exporting Measurement Results for Evaluation > Import/Export Functions
Import/Export Functions

The following import and export functions are available via softkeys in the "Save/Recall" menu which is displayed when you select the "Save" or "Open" icon in the toolbar.

Some functions for particular data types are (also) available via softkeys or dialog boxes in the corresponding menus, e.g. trace data or marker peak lists.

For a description of the other functions in the "Save/Recall" menu see "Data Management".

└ Import
└ Export
└ Export Trace to ASCII File
└ Trace Export Configuration
└ I/Q Export


Import

Data Management > Importing and Exporting Measurement Results for Evaluation > Import/Export Functions > Import
Import

Provides functions to import data.

Currently, only I/Q data can be imported, and only by applications that process I/Q data.

See "IQ Import" for more information.


Export

Data Management > Importing and Exporting Measurement Results for Evaluation > Import/Export Functions > Export
Export

Opens a submenu to configure data export.

└ Export Trace to ASCII File
└ Trace Export Configuration
└ I/Q Export


Trace Export Configuration

Data Management > Importing and Exporting Measurement Results for Evaluation > Import/Export Functions > Export > Trace Export Configuration
Trace Export Configuration

Opens the "Traces" dialog box to configure the trace and data export settings. See "Trace / Data Export Configuration".


I/Q Export

Data Management > Importing and Exporting Measurement Results for Evaluation > Import/Export Functions > Export > I/Q Export
I/Q Export

Opens a file selection dialog box to select an export file to which the IQ data will be stored. This function is only available in single sweep mode, and only in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

For details see "I/Q Data Import and Export" .

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".


How to Export Trace Data and Numerical Results

Data Management > Importing and Exporting Measurement Results for Evaluation > How to Export Trace Data and Numerical Results
How to Export Trace Data and Numerical Results

The measured trace data and numerical measurement results in tables can be exported to an ASCII file. For each sweep point the measured trace position and value are output. The file is stored with a .DAT extension. For details on the storage format see "Reference: ASCII File Export Format".

For the results of a Spectrum Emission Mask (SEM) or Spurious Emissions measurement, special file export functions are available, see "How to Save SEM Result Files"(SEM) and "Saving the Evaluation List" (Spurious).

To export trace data and table results

Trace data can be exported either from the "Trace" menu, or from the "Save/Recall" menu.

  1. Press the TRACE key, then select the "Trace Config" softkey and switch to the "Trace/Data Export" tab.

    Or:

    Select the [image] "Save" icon in the toolbar, then select the "Export" softkey.

  2. Select the "Export Config" softkey to configure the export settings.

    1. Select "Export all Traces and all Table Results" to export all available measurement result data for the current application, or select a specific "Trace to Export".

    2. Optionally, select the "Include Instrument Measurement Settings" option to insert additional information in the export file header.

    3. If necessary, change the decimal separator to be used for the ASCII export file.

  3. Select the "Export Trace to ASCII file" button.

  4. In the file selection dialog box, select the storage location and file name for the export file.

  5. Select "Save" to close the dialog box and export the data to the file.


How to Export a Peak List

Data Management > Importing and Exporting Measurement Results for Evaluation > How to Export a Peak List
How to Export a Peak List

You can save the results of a marker peak list to an ASCII file.

  1. Press the MKR FUNCT key.

  2. Select the "Marker Peak List" softkey.

  3. Configure the peak search and list settings as described in "Marker Peak List Configuration".

  4. Set the marker peak list "State" to "On".

  5. Press the RUN SINGLE key to perform a single sweep measurement and create a marker peak list.

  6. Select the "Marker Peak List" softkey to display the "Marker Peak List" dialog box again.

  7. If necessary, change the decimal separator to be used for the ASCII export file.

  8. Select the "Export Peak List" button.

  9. In the file selection dialog box, select the storage location and file name for the export file.

  10. Select "Save" to close the dialog box and export the peak list data to the file.


Reference: ASCII File Export Format

Data Management > Importing and Exporting Measurement Results for Evaluation > Reference: ASCII File Export Format
Reference: ASCII File Export Format

Trace data can be exported to a file in ASCII format for further evaluation in other applications. This reference describes in detail the format of the export files for result data.

(For details see "How to Export Trace Data and Numerical Results").

For a description of the file formats for spectrum emission mask (SEM) measurement settings and results, see "Reference: SEM File Descriptions".

The file format for Spurious Emissions measurement results is described in "Reference: ASCII Export File Format (Spurious)".

The file consists of the header containing important scaling parameters and a data section containing the trace data. Optionally, the header can be excluded from the file (see "Include Instrument Measurement Settings").

The data of the file header consist of three columns, each separated by a semicolon: parameter name; numeric value; basic unit. The data section starts with the keyword "Trace <n>" (<n> = number of stored trace), followed by the measured data in one or several columns (depending on the measurement) which are also separated by a semicolon.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Generally, the format of this ASCII file can be processed by spreadsheet calculation programs, e.g. MS-Excel. Different language versions of evaluation programs may require a different handling of the decimal point. Thus you can define the decimal separator to be used (decimal point or comma, see "Decimal Separator").

If the spectrogram display is selected when you select the "ASCII Trace Export" softkey, the entire histogram buffer with all frames is exported to a file. The data corresponding to a particular frame begins with information about the frame number and the time that frame was recorded.

ASCII file format for trace export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;5.00; | Firmware version
Date;01.Oct 2006; | Date of data set storage
Mode;ANALYZER; | Operating mode
Preamplifier;OFF | Preamplifier status
Transducer; OFF | Transducer status
Center Freq;55000;Hz | Center frequency
Freq Offset;0;Hz | Frequency offset
Start;10000;Hz Stop;100000;Hz | Start/stop of the display range. Unit: Hz for span > 0, s for span = 0, dBm/dB for statistics measurements
Span;90000;Hz | Frequency range (0 Hz in zero span and statistics measurements)
Ref Level;-30;dBm | Reference level
Level Offset;0;dB | Level offset
Rf Att;20;dB | Input attenuation
El Att;2.0;dB | Electrical attenuation
RBW;100000;Hz | Resolution bandwidth
VBW;30000;Hz | Video bandwidth
SWT;0.005;s | Sweep time
Sweep Count;20; | Number of sweeps set
Ref Position;75;% | Position of reference level referred to diagram limits (0 % = lower edge)
Level Range;100;dB | Display range in y direction. Unit: dB with x-axis LOG, % with x-axis LIN
x-Axis;LIN; | Scaling of x-axis linear (LIN) or logarithmic (LOG)
y-Axis;LOG; | Scaling of y-axis linear (LIN) or logarithmic (LOG)
x-Unit;Hz; | Unit of x values: Hz with span > 0; s with span = 0; dBm/dB with statistics measurements
y-Unit;dBm; | Unit of y values: dB*/V/A/W depending on the selected unit with y-axis LOG or % with y-axis LIN
Data section for individual window
Window;1;Frequency Sweep | Window number and name
Trace 1;; | Selected trace
Trace Mode;AVERAGE; | Display mode of trace: CLR/WRITE,AVERAGE,MAXHOLD,MINHOLD
Detector;AUTOPEAK; | Detector set: AUTOPEAK,MAXPEAK,MINPEAK,AVERAGE,RMS,SAMPLE,QUASIPEAK
Values; 1001; | Number of measurement points
10000;-10.3;-15.7 10130;-11.5;-16.9 10360;-12.0;-17.4 ...;...; | Measured values: <x value>, <y1>, <y2>; <y2> being available only with detector AUTOPEAK and containing in this case the smallest of the two measured values for a measurement point.
Data section for individual trace
Trace 2;; | Next trace in same window
... |
Data section for individual window
Window;2 ..; | Name of next window
Data section for individual trace
Trace 1;; | First trace
... |
ASCII file format for spectrogram trace export
File contents | Description
Header |
Type;R&S FSW; | Instrument model
Version;5.00; | Firmware version
Date;01.Oct 2006; | Date of data set storage
Mode;ANALYZER;SPECTROGRAM | Operating mode
Center Freq;55000;Hz | Center frequency
Freq Offset;0;Hz | Frequency offset
Span;90000;Hz | Frequency range (0 Hz in zero span and statistics measurements)
x-Axis;LIN; | Scaling of x-axis linear (LIN) or logarithmic (LOG)
Start;10000;Hz Stop;100000;Hz | Start/stop of the display range. Unit: Hz for span > 0, s for span = 0, dBm/dB for statistics measurements
Ref Level;-30;dBm | Reference level
Level Offset;0;dB | Level offset
Ref Position;75; % | Position of reference level referred to diagram limits (0 % = lower edge)
y-Axis;LOG; | Scaling of y-axis linear (LIN) or logarithmic (LOG)
Level Range;100;dB | Display range in y direction. Unit: dB with x-axis LOG, % with x-axis LIN
Rf Att;20;dB | Input attenuation
RBW;100000;Hz | Resolution bandwidth
VBW;30000;Hz | Video bandwidth
SWT;0.005;s | Sweep time
Trace Mode;AVERAGE; | Display mode of trace: CLR/WRITE,AVERAGE,MAXHOLD,MINHOLD
Detector;AUTOPEAK; | Detector set: AUTOPEAK,MAXPEAK,MINPEAK,AVERAGE,RMS,SAMPLE,QUASIPEAK
Sweep Count;20; | Number of sweeps set
Data section
Trace 1:;; | Selected trace
x-Unit;Hz; | Unit of x values: Hz with span > 0; s with span = 0; dBm/dB with statistics measurements
y-Unit;dBm; | Unit of y values: dB*/V/A/W depending on the selected unit with y-axis LOG or % with y-axis LIN
Values; 1001; | Number of measurement points
Frames;2; | Number of exported frames
Frame;0; | Most recent frame number
Timestamp;17.Mar 11;11:27:05.990 | Timestamp of this frame
10000;-10.3;-15.7 10130;-11.5;-16.9 10360;-12.0;-17.4 ...;...; | Measured values, identical to spectrum data: <x value>, <y1>, <y2>; <y2> being available only with detector AUTOPEAK and containing in this case the smallest of the two measured values for a measurement point.
Frame;-1; | Next frame
Timestamp;17.Mar 11;11:27:05.342 | Timestamp of this frame
... |


Creating Screenshots of Current Measurement Results and Settings

Data Management > Creating Screenshots of Current Measurement Results and Settings
Creating Screenshots of Current Measurement Results and Settings

In order to document the graphical results and the most important settings for the currently performed measurement, you can create a hardcopy or screenshot of the current display. Screenshots can either be printed or stored to a file.

Contents
  • Print and Screenshot Settings
  • How to Store or Print Screenshots of the Display


Print and Screenshot Settings

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings
Print and Screenshot Settings

The settings for saving and printing screenshots are configured via the "Print" menu which is displayed when you select the "Print" icon in the toolbar.

For step-by-step instructions see "How to Store or Print Screenshots of the Display".

Remote commands for these settings are described in "Storing or Printing Screenshots".

To print a screensot of the current display with the current settings immediately, without switching to the "Print" menu, use the "Print immediately" icon at the right-hand side of the toolbar.

└ Printing or Storing a Screenshot (Print Screen)
└ Device Setup
└ Output Medium
└ Print Date and Time
└ Print Logo
└ Suppress File Name Dialog
└ Print Dialog
└ Printer Name
└ Print to File
└ Orientation
└ Device
└ Colors
└ Comment
└ Install Printer


Printing or Storing a Screenshot (Print Screen)

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Printing or Storing a Screenshot (Print Screen)
Printing or Storing a Screenshot (Print Screen)

Starts to print out or store all measurement results displayed on the screen: diagrams, traces, markers, marker lists, limit lines, etc., including the channel and status bars. Optionally, comments and the date and time are included at the bottom margin of the printout. All displayed items belonging to the software user interface (e.g. softkeys or dialog boxes) are not printed out.

Whether the output is sent to the printer or stored in a file or the clipboard depends on the selected device and the device settings.

If the output is stored to a file, a file selection dialog box is opened to select the file name and location. The default path is C:\r_s\instr\user.

The "Print" menu is displayed to configure printing.

Remote command:

HCOPy:​ITEM:​ALL

HCOPy[:​IMMediate<device>]

HCOPy[:​IMMediate<device>]:​NEXT


Device Setup

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup
Device Setup

Defines the behavior of the "Print Screen" function, depending on which device is selected. Two different devices can be configured, e.g. one for printing and one for storage to a file.

└ Output Medium
└ Print Date and Time
└ Print Logo
└ Suppress File Name Dialog
└ Print Dialog
└ Printer Name
└ Print to File
└ Orientation


Output Medium

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Output Medium
Output Medium

Defines the medium to which the screenshot is printed or stored.

"File formats" | Stores the screenshot to a file in the selected format. The file name is queried at the time of storage.
"Clipboard" | Stores the screenshot to the clipboard.
"Printer" | Prints the screenshot on the printer selected from the "Name" list.
Remote command:

HCOPy:​DEVice:​LANGuage<device>


Print Date and Time

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Print Date and Time
Print Date and Time

Activates/deactivates the printout of the current date and time at the bottom of the screenshot.

Remote command:

HCOPy:​TDSTamp:​STATe<device>


Print Logo

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Print Logo
Print Logo

Activates/deactivates the printout of the Rohde & Schwarz company logo in the upper left corner.

Remote command:

DISPlay:​LOGO


Suppress File Name Dialog

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Suppress File Name Dialog
Suppress File Name Dialog

When the screenshot is stored to a file, the file selection dialog box is not displayed. Instead, the current storage location and file name are used (default: C:\r_S\instr\user). Each new the file name is extended by a consecutive number, e.g. File002, File003 etc.


Print Dialog

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Print Dialog
Print Dialog

Includes any currently displayed dialog in the screenshot.


Printer Name

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Printer Name
Printer Name

Defines the printer to print to.

Remote command:

SYSTem:​COMMunicate:​PRINter:​ENUMerate[:​NEXT]?

SYSTem:​COMMunicate:​PRINter:​ENUMerate:​FIRSt?

SYSTem:​COMMunicate:​PRINter:​SELect<device>


Print to File

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Print to File
Print to File

If a printer is selected as the output medium, use this option to store the data in a .prn file using the selected printer driver.


Orientation

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device Setup > Orientation
Orientation

Selects the page orientation of the printout: portrait or landscape (printer only)

Remote command:

HCOPy:​PAGE:​ORIentation<device>


Device

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Device
Device

Two different printout devices can be configured, e.g. one for printing and one for storage to a file. When the "Print Screen" function is executed, the selected device and its settings determine the behavior.

Remote command:

HCOPy:​DESTination<device>


Colors

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Colors
Colors

Opens the "Print Color" dialog box to configure the colors for printing screenshots. For details see "Display Theme and Colors".


Comment

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Comment
Comment

Defines an optional comment to be printed with the screenshot of the display. Maximum 120 characters are allowed. 60 characters fit in one line. In the first line, at any point a manual line-feed can be forced by entering "@".

Date and time are inserted automatically. The comment is printed below the diagram area, but not displayed on the screen. If a comment should not be printed, it must be deleted.

Remote command:

HCOPy:​ITEM:​WINDow:​TEXT


Install Printer

Data Management > Creating Screenshots of Current Measurement Results and Settings > Print and Screenshot Settings > Install Printer
Install Printer

Opens the standard Windows dialog box to install a new printer. All printers that are already installed are displayed.

Only user accounts with administrator rights can install a printer.

For further information refer to the Microsoft Windows documentation.


How to Store or Print Screenshots of the Display

Data Management > Creating Screenshots of Current Measurement Results and Settings > How to Store or Print Screenshots of the Display
How to Store or Print Screenshots of the Display
►

If the R&S FSW has already been set up according to your current requirements, simply press the "Print immediate" icon ( [image]) at the far right end of the toolbar.

A screenshot of the current measurement display is printed or stored to a file, as configured.

To set up screenshot outputs

This configuration assumes a printer has already been installed. To install a new printer, use the "Install Printer" softkey.

  1. Select the [image] "Printer" tool in the toolbar.

  2. Select the "Device Setup" softkey.

  3. Select the tab for Device 1 or Device 2 to configure a device.

  4. To set up the print function to store a screenshot to a file, select the required file format as the output medium.

    To set up the print function to store a screenshot to the clipboard, select "Clipboard" as the output medium.

    To set up the print function to print a screenshot on a printer, select "Printer" as the output medium and an installed printer from the "Name" list.

  5. For printout, select the page orientation.

  6. Optionally, deactivate the date and time or the logo so they are not added to the screenshot.

  7. Select "OK" to close the "Device Setup" dialog box.

  8. Toggle the "Device" softkey to the device configuration you want to use.

  9. Optionally, configure the colors to be used for printout, e.g. as displayed on the screen instead of inversed.

  10. Optionally, add a comment to be included with the screenshot.

  11. Select the "Print Screen" softkey or the "Printer" or "Screenshot" tool in the toolbar to execute the print function and check the results.

  12. If you configured the print function to store the screenshot to a file, enter a file name in the file selection dialog box.


General Instrument Setup

Some basic instrument settings can be configured independently of the selected operating mode or application. Usually, you will configure most of these settings initially when you set up the instrument according to your personal preferences or requirements and then only adapt individual settings to special circumstances when necessary. Some special functions are provided for service and basic system configuration.

Contents
  • Basics on Alignment
  • Basics on Transducer Factors
  • General Instrument Settings
  • Display Settings
  • External Monitor Settings
  • How to Configure the Basic Instrument Settings


Basics on Alignment

General Instrument Setup > Basics on Alignment
Basics on Alignment

When you put the instrument into operation for the first time or when strong temperature changes occur, it may be necessary to align the data to a reference source (see also "Temperature check").

During instrument start, the installed hardware is checked against the current firmware version to ensure the hardware is supported. If not, an error message is displayed ("WRONG_FW") and you are asked to update the firmware. Until the firmware version is updated, self-alignment fails.

The correction data and characteristics required for the alignment are determined by comparison of the results at different settings with the known characteristics of the high-precision calibration signal source at 64 MHz.

Alignment results

The alignment results are displayed and contain the following information:

  • date and time of last correction data record
  • overall results of correction data record
  • list of found correction values according to function/module

The results are classified as follows:

PASSED | Calibration successful without any restrictions
CHECK | Deviation of correction value larger than expected, correction could however be performed
FAILED | Deviations of correction value too large, no correction was possible. The found correction data is not applicable.

The results are available until the next self-alignment process is started or the instrument is switched off.

Temperature check

During self-alignment, the instrument's (frontend) temperature is also measured (as soon as the instrument has warmed up completely). This temperature is used as a reference for a continuous temperature check during operation. If the current temperature deviates from the stored self-alignment temperature by a certain degree, a warning is displayed in the status bar indicating the resulting deviation in the measured power levels. A status bit in the STATUs:QUEStionable:TEMPerature register indicates a possible deviation. The current temperature of the RF Frontend can be queried using a remote command (see SOURce:​TEMPerature:​FRONtend?).

Touchscreen alignment

When the device is delivered, the touchscreen is initially calibrated. However, to ensure that the touchscreen responds to the finger contact correctly, a touchscreen alignment is required.

Alignment of the touchscreen is useful:
  • At first use
  • After an image update or after exchanging a hard disk
  • If you notice that touching a specific point on the screen does not achieve the correct response
  • If the position of the instrument has been changed and you cannot look straight on the screen
  • If another person operates the instrument


Basics on Transducer Factors

General Instrument Setup > Basics on Transducer Factors
Basics on Transducer Factors

The transducer allows you to manipulate the trace at discrete trace points to correct the signal coming from an input device. Transducers are often used to correct the frequency response for antennas, for example. The transducer is configured by defining transducer factors for specific trace points. A set of transducer factors defines an interpolated transducer line and can be stored on the instrument.

In the Spectrum application, the correction factor from all active transducers is calculated for each displayed trace point once in advance and is added to the result of the level measurement during the sweep. If the sweep range changes, the correction values are calculated again. If several measured values are combined in one point, only one value is taken into consideration. If the active transducer line is not defined for the entire sweep range, the missing values are replaced by zeroes.

When a transducer is used, the trace is shifted by a calculated factor. However, an upward shift reduces the dynamic range for the displayed values. Thus, the reference level can be adapted automatically to restore the original dynamic range. The reference level is shifted by the maximum transducer factor. By default, if transducers are active the reference level function is adapted automatically to obtain the best dynamic performance.

If a transducer factor is active, "TDF" is displayed in the channel bar.

Transducers can also be defined when an optional external mixer is used (R&S FSW-B21).

When using probes for RF input, transducers are automatically created according to the probe's detected characteristics as soon as the probe is connected (see "RF Input from the Analog Baseband Connector").

Y-Axis Unit

The individual transducer factors can be defined as absolute values or relative (dB) values. However, all factors for one transducer line use the same unit. As soon as a transducer is activated, the unit of the transducer is automatically used for all the level settings and outputs. The unit cannot be changed in the amplitude settings since the R&S FSW and the active transducer are regarded as one measuring instrument. Only for relative transducer factors (unit dB), the unit originally set on the instrument is maintained and can be changed.

When all transducers have been switched off, the R&S FSW returns to the unit that was used before a transducer was activated.

Configuration

The R&S FSW supports transducer lines with a maximum of 1001 data points. Eight of the transducer lines stored in the instrument can be activated simultaneously. The number of transducer lines stored in the instrument is only limited by the capacity of the storage device used.

A transducer line consists of the following data:

  • A maximum of 1001 data points with a position and value
  • A unit for the values
  • A name to distinguish the transducer lines
Validity

The transducer factors must comply with the following rules to ensure correct operation:

  • The frequencies for the data points must always be defined in ascending order. Otherwise the entry will not be accepted and the an error message is displayed.
  • The frequencies of the data points may exceed the valid frequency range of the R&S FSW since only the set frequency range is taken into account for measurements. The minimum frequency of a data point is 0 Hz, the maximum frequency 200 GHz.
  • The value range for the transducer factor is ±200 dB.
  • Gain has to be entered as a negative value, and attenuation as a positive value.


General Instrument Settings

General Instrument Setup > General Instrument Settings
General Instrument Settings

Instrument settings can be configured via the SETUP key.

Network and Remote Settings, Display Settings

Settings for network and remote operation are described in "Network and Remote Operation".

Display settings are described in "Display Settings".

Contents
  • Reference Frequency Settings
  • Transducer Settings
  • Alignment Settings
  • System Configuration Settings
  • Service Functions


Reference Frequency Settings

General Instrument Setup > General Instrument Settings > Reference Frequency Settings
Reference Frequency Settings

The reference frequency settings are defined in the "Reference" dialog box which is displayed when you press the SETUP key and then select "Reference".

└ Reference Frequency Input
└ Behavior in case of missing external reference
└ Tuning Range
└ Frequency
└ Loop Bandwidth
└ Reference Frequency Output
└ Resetting the Default Values


Reference Frequency Input

General Instrument Setup > General Instrument Settings > Reference Frequency Settings > Reference Frequency Input
Reference Frequency Input

The R&S FSW can use the internal reference source or an external reference source as the frequency standard for all internal oscillators. A 10 MHz crystal oscillator is used as the internal reference source. In the external reference setting, all internal oscillators of the R&S FSW are synchronized to the external reference frequency.

External references are connected to one of the REF INPUT or the SYNC TRIGGER connectors on the rear panel. For details see the "Getting Started" manual.

Note: Optionally (R&S FSW-B4), the more precise OCXO signal can replace the internal reference source.

The default setting is the internal reference. When an external reference is used, "EXT REF" is displayed in the status bar.

The following reference inputs are available:

Available Reference Frequency Input
Source | Frequency | Tuning Range | Loop Bandwidth | Description
Internal | 10 MHz | - | 1-100 Hz | Internal reference signal or OCXO (option R&S FSW-B4)
External Reference 10 MHz | 10 MHz | +/- 6 ppm | 1-100 Hz | External reference from REF INPUT 1..20 MHZ connector; Fixed external 10 MHZ reference frequency. Good phase noise performance
External Reference 1..20 MHz | 1..20 MHz in 1 Hz steps | +/- 0.5 ppm | 0.1 Hz (fixed) | Variable external reference frequency in 0.1 Hz steps from REF INPUT 1..20 MHZ connector; Good external phase noise suppression. Small tuning range.
 |  | +/- 6 ppm | 1-30 Hz | Variable external reference frequency in 0.1 Hz steps from REF INPUT 1..20 MHZ connector; Wide tuning range.
External Reference 100 MHz | 100 MHz | +/- 6 ppm | 1-300 Hz | External reference from REF INPUT 100 MHZ connector Good phase noise performance
Sync Trigger | 100 MHz | +/- 6 ppm | 1-300 Hz | External reference from SYNC TRIGGER INPUT connector
Remote command:

[SENSe:​]ROSCillator:​SOURce

SOURce:​EXTernal:​ROSCillator:​EXTernal:​FREQuency

└ Behavior in case of missing external reference
└ Tuning Range
└ Frequency
└ Loop Bandwidth


Behavior in case of missing external reference

General Instrument Setup > General Instrument Settings > Reference Frequency Settings > Reference Frequency Input > Behavior in case of missing external reference
Behavior in case of missing external reference

If an external reference is selected but none is available, there are different ways the instrument can react.

"Show Error Flag" | The message "NO REF" is displayed to indicate that no synchronization is performed.
"Switch to internal reference" | The instrument automatically switches back to the internal reference if no external reference is available. Note that you must re-activate the external reference if it becomes available again at a later time.
Remote command:

[SENSe:​]ROSCillator:​SOURce

[SENSe:​]ROSCillator:​SOURce:​EAUTo?


Tuning Range

General Instrument Setup > General Instrument Settings > Reference Frequency Settings > Reference Frequency Input > Tuning Range
Tuning Range

The tuning range is only available for the variable external reference frequency. It determines how far the frequency may deviate from the defined level in parts per million (10-6).

For more information see table "Available Reference Frequency Input".

"+/- 0.5 ppm" | With this smaller deviation a very narrow fixed loop bandwidth of 0.1 Hz is realized. With this setting the instrument can synchronize to an external reference signal with a very precise frequency. Due to the very narrow loop bandwidth, unwanted noise or spurious components on the external reference input signal are strongly attenuated. Furthermore, the loop requires about 30 seconds to reach a locked state. During this locking process, "NO REF" is displayed in the status bar.
"+/- 6 ppm" | The larger deviation allows the instrument to synchronize to less precise external reference input signals.
Remote command:

[SENSe:​]ROSCillator:​TRANge


Frequency

General Instrument Setup > General Instrument Settings > Reference Frequency Settings > Reference Frequency Input > Frequency
Frequency

Defines the external reference frequency to be used (for variable connectors only).

For more information see table "Available Reference Frequency Input".


Loop Bandwidth

General Instrument Setup > General Instrument Settings > Reference Frequency Settings > Reference Frequency Input > Loop Bandwidth
Loop Bandwidth

Defines the speed of internal synchronization with the reference frequency. The setting requires a compromise between performance and increasing phase noise.

For a variable external reference frequency with a narrow tuning range (+/- 0.5 ppm), the loop bandwidth is fixed to 0.1 Hz and cannot be changed.

For more information see table "Available Reference Frequency Input".

Remote command:

[SENSe:​]ROSCillator:​LBWidth


Reference Frequency Output

General Instrument Setup > General Instrument Settings > Reference Frequency Settings > Reference Frequency Output
Reference Frequency Output

A reference frequency can be provided by the R&S FSW to other devices that are connected to this instrument. If one of the following options is activated, the reference signal is output to the corresponding connector.

"Output 100 MHz" | Provides a 100 MHz reference signal to the REF OUTPUT 100 MHZ connector.
"Ouput 640 MHz" | Provides a 640 MHz reference signal to the REF OUTPUT 640 MHZ connector.
"Output Sync Trigger" | Provides a 100 MHz reference signal to the SYNC TRIGGER OUTPUT connector.
Remote command:

[SENSe:​]ROSCillator:​O100

[SENSe:​]ROSCillator:​O640

[SENSe:​]ROSCillator:​OSYNc


Resetting the Default Values

General Instrument Setup > General Instrument Settings > Reference Frequency Settings > Resetting the Default Values
Resetting the Default Values

The values for the "Tuning Range", "Frequency" and "Loop Bandwidth" are stored for each source of "Reference Frequency Input". Thus, when you switch the input source, the previously defined settings are restored. You can restore the default values for all input sources using the "Preset Channel" function.


Transducer Settings

General Instrument Setup > General Instrument Settings > Transducer Settings
Transducer Settings

Up to 8 transducer lines can be activated simultaneously in the R&S FSW. Many more can be stored on the instrument.

The transducer settings are defined in the "Transducer" dialog box which is displayed when you press the SETUP key and then select "Transducer".

Transducers can also be defined when an optional external mixer is used (R&S FSW-B21).

Transducer settings in secure user mode

Be sure to store transducer files before "Secure User Mode" is enabled; see "Protecting Data Using the Secure User Mode".

Contents
  • Transducer Management
  • Transducer Factors


Transducer Management

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management
Transducer Management

The settings required to manage all transducer lines on the instrument are described here.

For the transducer line overview, the R&S FSW searches for all stored transducer lines with the file extension .TDF in the trd subfolder of the main installation folder. The overview allows you to determine which transducer lines are available and can be used for the current measurement.

For details on settings for individual lines see "Transducer Factors".

For instructions on configuring and working with transducers see "How to Configure the Transducer".

└ Name
└ Unit
└ Compatibility
└ Activating/Deactivating
└ Comment
└ Included Lines in Overview (View Filter)
└ Adjusting the Reference Level
└ Create New Line
└ Edit Line
└ Copy Line
└ Delete Line


Name

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Name
Name

The name of the stored transducer line.


Unit

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Unit
Unit

The unit in which the y-values of the data points of the transducer line are defined.

The following units are available:
  • dB
  • dBm
  • dBmV
  • dBμV
  • dBμV/m
  • dBμA
  • dBμA/m
  • dBpW
  • dBpT


Compatibility

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Compatibility
Compatibility

Indicates whether the transducer factors are compatible with the current measurement settings.

For more information on which conditions a transducer line must fulfill to be compatible, see "Basics on Transducer Factors".


Activating/Deactivating

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Activating/Deactivating
Activating/Deactivating

Activates/deactivates the transducer line. Up to 8 transducer lines can be active at the same time.

For more information on the effects of using transducer lines see "Basics on Transducer Factors".

Remote command:

[SENSe:​]CORRection:​TRANsducer:​SELect

[SENSe:​]CORRection:​TRANsducer[:​STATe]


Comment

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Comment
Comment

An optional description of the transducer line.


Included Lines in Overview (View Filter)

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Included Lines in Overview (View Filter)
Included Lines in Overview (View Filter)

Defines which of the stored lines are included in the overview. The view can be restricted to compatible lines only or include all lines found. Whether a line is compatible or not is indicated in the "Compatibility" setting.

For more information on which conditions a transducer line must fulfill to be compatible, see "Basics on Transducer Factors".


Adjusting the Reference Level

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Adjusting the Reference Level
Adjusting the Reference Level

Activates or deactivates the automatic adjustment of the reference level to the selected transducer factor.

For more information see "Basics on Transducer Factors".

"Auto" | Activates the automatic adjustment. The original dynamic range is restored by shifting the reference level by the maximum transducer factor.
"Man" | Deactivates the automatic adjustment. Adjust the reference level via the "Amplitude" menu.
Remote command:

[SENSe:​]CORRection:​TRANsducer:​ADJust:​RLEVel[:​STATe]


Create New Line

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Create New Line
Create New Line

Create a new transducer line.

For instructions see "How to Configure the Transducer".

Remote command:

[SENSe:​]CORRection:​TRANsducer:​SELect


Edit Line

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Edit Line
Edit Line

Edit an existing transducer line configuration.

For instructions see "How to Configure the Transducer".


Copy Line

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Copy Line
Copy Line

Copy the selected transducer line configuration to create a new line.

For instructions see "How to Configure the Transducer".


Delete Line

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Management > Delete Line
Delete Line

Delete the selected transducer line.

For instructions see "How to Configure the Transducer".

Remote command:

[SENSe:​]CORRection:​TRANsducer:​DELete


Transducer Factors

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors
Transducer Factors

The settings and functions available for individual transducer lines are described here.

For instructions on creating and editing transducer lines see "How to Configure the Transducer".

└ Name
└ Comment
└ Unit
└ X-Axis Scaling
└ Data points
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


Name

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Name
Name

Defines the transducer line name. All names must be compatible with the Windows 7 conventions for file names. The transducer data is stored under this name (with a .TDF extension) in the trd subfolder of the main installation folder.

Remote command:

[SENSe:​]CORRection:​TRANsducer:​SELect


Comment

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Comment
Comment

Defines an optional comment for the transducer line. The text may contain up to 40 characters.

Remote command:

[SENSe:​]CORRection:​TRANsducer:​COMMent


Unit

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Unit
Unit

The unit in which the y-values of the data points of the transducer line are defined.

As soon as a transducer is activated, the unit of the transducer is automatically used for all the level settings and outputs. The unit cannot be changed in the amplitude settings unless dB is used.

For details see "Y-Axis Unit" "Basics on Transducer Factors".

Remote command:

[SENSe:​]CORRection:​TRANsducer:​UNIT


X-Axis Scaling

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > X-Axis Scaling
X-Axis Scaling

Describes the scaling of the horizontal axis on which the data points of the transducer line are defined. Scaling can be linear or logarithmic.

Remote command:

[SENSe:​]CORRection:​TRANsducer:​SCALing


Data points

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Data points
Data points

Each transducer line is defined by a minimum of 2 and a maximum of 50 data points. Each data point is defined by its position (x-axis) and value (y-value).

The data points must comply with the following rules to ensure correct operation:

  • The frequencies for the data points must always be defined in ascending order. Otherwise the entry will not be accepted and the an error message is displayed.
  • The frequencies of the data points may exceed the valid frequency range of the R&S FSW since only the set frequency range is taken into account for measurements. The minimum frequency of a data point is 0 Hz, the maximum frequency 200 GHz.
  • The value range for the transducer factor is ±200 dB.
  • Gain has to be entered as a negative value, and attenuation as a positive value.
Remote command:

[SENSe:​]CORRection:​TRANsducer:​DATA


Insert Value

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Insert Value
Insert Value

Inserts a data point in the transducer line above the selected one in the "Edit Transducer" dialog box.


Delete Value

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Delete Value
Delete Value

Deletes the selected data point in the "Edit Transducer" dialog box.


Shift x

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Shift x
Shift x

Shifts the x-value of each data point horizontally by the defined shift width.


Shift y

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Shift y
Shift y

Shifts the y-value of each data point vertically by the defined shift width.


Save

General Instrument Setup > General Instrument Settings > Transducer Settings > Transducer Factors > Save
Save

Saves the currently edited transducer line under the name defined in the "Name" field.

Remote command:

MMEMory:​SELect[:​ITEM]:​TRANsducer:​ALL

MMEMory:​STORe:​STATe


Alignment Settings

General Instrument Setup > General Instrument Settings > Alignment Settings
Alignment Settings

Both the instrument and the touchscreen can be aligned when necessary (see "Basics on Alignment").

The alignment settings are defined in the "Alignment" dialog box which is displayed when you press the SETUP key and then select "Alignment".

Self-alignment results in secure user mode

Be sure to store self-alignment results before "Secure User Mode" is enabled; see "Protecting Data Using the Secure User Mode".

If the currently stored self-alignment results are not suitable, you must perform a self-alignment each time you switch on the R&S FSW in secure user mode, as the results are not stored permanently in this case.

└ Starting a Self-alignment
└ Aborting the Self-alignment
└ Starting the Touchscreen Alignment
└ Alignment Results


Starting a Self-alignment

General Instrument Setup > General Instrument Settings > Alignment Settings > Starting a Self-alignment
Starting a Self-alignment

Starts recording correction data for the instrument. If the correction data acquisition fails or if the correction values are deactivated, a corresponding message is displayed in the status field.

For details see "Basics on Alignment".

Note: A running Sequencer operation is aborted when you start a self-alignment.

Note: If self-alignment fails, the firmware may be out-of-date. In this case, an error message ("WRONG_FW") is displayed in the status bar.
See "Firmware Updates".

Remote command:

*CAL?, see also CALibration[:​ALL]?


Aborting the Self-alignment

General Instrument Setup > General Instrument Settings > Alignment Settings > Aborting the Self-alignment
Aborting the Self-alignment

As long as the self-alignment data is being collected the procedure can be cancelled using the "Abort Self-alignment" button.

For details see "Basics on Alignment".


Starting the Touchscreen Alignment

General Instrument Setup > General Instrument Settings > Alignment Settings > Starting the Touchscreen Alignment
Starting the Touchscreen Alignment

Starts the touchscreen alignment.

Tap the 4 markers on the screen as you are asked to do. The touchscreen is aligned according to the executed pointing operations.

For details see "Basics on Alignment".


Alignment Results

General Instrument Setup > General Instrument Settings > Alignment Settings > Alignment Results
Alignment Results

Information on whether the alignment was performed succesfully and on the applied correction data is displayed. The results are available until the next self-alignment process is started or the instrument is switched off.

Remote command:

CALibration:​RESult?


System Configuration Settings

General Instrument Setup > General Instrument Settings > System Configuration Settings
System Configuration Settings

The system configuration information and settings are provided in the "System Configuration" dialog box which is displayed when you press the SETUP key and then select "System Configuration".

Contents
  • Hardware Information
  • Information on Versions and Options
  • System Messages
  • Firmware Updates
  • General Configuration Settings


Hardware Information

General Instrument Setup > General Instrument Settings > System Configuration Settings > Hardware Information
Hardware Information

An overview of the installed hardware in your R&S FSW is provided in the "Hardware Info" tab of the "System Configuration" dialog box.

Every listed component is described by its serial number, order number, model information, hardware code, and hardware revision.

This information can be useful when problems occur with the instrument and you require support from Rohde & Schwarz.

Remote command:

DIAGnostic:​SERVice:​HWINfo?


Information on Versions and Options

General Instrument Setup > General Instrument Settings > System Configuration Settings > Information on Versions and Options
Information on Versions and Options

Information on the firmware version and options installed on your instrument is provided in the "Versions Options" tab of the "System Configuration" dialog box. The unique R&S device ID is also indicated here, as it is required for license and option administration.

You can also install new firmware options in this dialog box.

Installing options in secure user mode

Be sure to install any new options before "Secure User Mode" is enabled; see "Protecting Data Using the Secure User Mode".

For restricted users in secure user mode, this function is not available!

Expired option licenses

If an option is about to expire, a message box is displayed to inform you. You can then use the "Install Option" function to enter a new license key.

If an option has already expired, a message box appears for you to confirm. In this case, all instrument functions are unavailable (including remote control) until the R&S FSW is rebooted. You must then use the "Install Option" function to enter the new license key.

For details on options refer to the "Getting Started" manual, "Checking the Supplied Items".

Remote commands:

SYSTem:​FORMat:​IDENt

DIAGnostic:​SERVice:​BIOSinfo?

└ Install Option
└ Install Option by XML


Install Option

General Instrument Setup > General Instrument Settings > System Configuration Settings > Information on Versions and Options > Install Option
Install Option

Opens an edit dialog box to enter the license key for the option that you want to install.

Only user accounts with administrator rights are able to install options.


Install Option by XML

General Instrument Setup > General Instrument Settings > System Configuration Settings > Information on Versions and Options > Install Option by XML
Install Option by XML

Opens a file selection dialog box to install an additional option to the R&S FSW using an XML file. Enter or browse for the name of an XML file that contains the option key and press "Select".

Only user accounts with administrator rights are able to install options.


System Messages

General Instrument Setup > General Instrument Settings > System Configuration Settings > System Messages
System Messages

The system messages generated by the R&S FSW are displayed in the "System Messages" tab of the "System Configuration" dialog box.

The messages are displayed in the order of their occurrence; the most recent messages are placed at the top of the list. Messages that have occurred since you last visited the system messages tab are marked with an asterisk '*'.

If the number of error messages exceeds the capacity of the error buffer, "Message buffer overflow" is displayed. To clear the message buffer use the "Clear All Messages" button.

The following information is available:

No | device-specific error code
Message | brief description of the message
Component | hardware messages: name of the affected module
 | software messages: name of the affected software
Date/Time | date and time of the occurrence of the message
Remote command:

SYSTem:​ERRor:​LIST?

└ Clear All Messages


Clear All Messages

General Instrument Setup > General Instrument Settings > System Configuration Settings > System Messages > Clear All Messages
Clear All Messages

Deletes all system messages.

Remote command:

SYSTem:​ERRor:​CLEar:​ALL


Firmware Updates

General Instrument Setup > General Instrument Settings > System Configuration Settings > Firmware Updates
Firmware Updates

During instrument start, the installed hardware is checked against the current firmware version to ensure the hardware is supported. If not, an error message is displayed ("WRONG_FW") and you are asked to update the firmware. Until the firmware version is updated, self-alignment fails. To see which components are not supported, see the "System Messages".

The firmware on your R&S FSW may also need to be updated in order to enable additional new features or if reasons for improvement come up. Ask your sales representative or check the Rohde&Schwarz website for availability of firmware updates. A firmware update package includes at least a setup file and release notes.

Before updating the firmware on your instrument, read the release notes delivered with the firmware version.

As of firmware version 1.60, administrator rights are no longer required to perform a firmware update.

Installing options in secure user mode

Be sure to perform any firmware updates before "Secure User Mode" is enabled; see "Protecting Data Using the Secure User Mode".

For restricted users in secure user mode, this function is not available!

The firmware can be updated in the "Firmware Update" tab of the "System Configuration" dialog box.

Enter the name or browse for the firmware installation file and press the "Install" button.


General Configuration Settings

General Instrument Setup > General Instrument Settings > System Configuration Settings > General Configuration Settings
General Configuration Settings

General system settings, for example concerning the initial behaviour of the R&S FSW after booting, are configured in the "Config" tab of the "System Configuration" dialog box.

└ Preset Mode
└ Out-of-range value behavior
└ Secure User Mode
└ Changing the password


Preset Mode

General Instrument Setup > General Instrument Settings > System Configuration Settings > General Configuration Settings > Preset Mode
Preset Mode

The default operating mode is Signal and Spectrum Analyzer mode, however, the presetting can be changed. The defined operating mode is activated when you switch on the R&S FSW or press the PRESET key.

The presettings can be defined in the "Config" tab of the "System Configuration" dialog box.

For details on operating modes see "Applications and Operating Modes".

"SAN" | Signal and Spectrum Analyzer mode
"MSRA" | Multi-Standard Radio Analysis mode
"MSRT" | Multi-Standard Realtime mode
Remote command:

SYSTem:​PRESet:​COMPatible


Out-of-range value behavior

General Instrument Setup > General Instrument Settings > System Configuration Settings > General Configuration Settings > Out-of-range value behavior
Out-of-range value behavior

By default, if you enter a value that is outside the valid range in an input field for a setting, a warning is displayed and the value is not accepted. Alternatively, entries below the minimum value can automatically be set to the minimum possible entry, and entries above the maximum value set to the maximum possible entry. This behavior avoids errors and facilitates setting correct values.


Secure User Mode

General Instrument Setup > General Instrument Settings > System Configuration Settings > General Configuration Settings > Secure User Mode
Secure User Mode

If activated, the R&S FSW requires a reboot and then automatically logs in using the "SecureUser" account.

Data that the R&S FSW normally stores on the solid-state drive is redirected to volatile memory instead. Data that is stored in volatile memory can be accessed by the user during the current instrument session; however, when the instrument’s power is removed, all data in volatile memory is erased.

The Secure User Mode can only be activated or deactivated by a user with administrator rights.

Note: Storing instrument settings permanently. Before you activate secure user mode, store any instrument settings that are required beyond the current session, such as predefined instrument settings, transducer files, or self-alignment data.

For details on the secure user mode see "Protecting Data Using the Secure User Mode".

Remote command:

SYSTem:​SECurity[:​STATe]

Note: Initially after installation of the R&S FSW-K33 option, secure user mode must be enabled manually once before remote control is possible.

└ Changing the password


Changing the password

General Instrument Setup > General Instrument Settings > System Configuration Settings > General Configuration Settings > Secure User Mode > Changing the password
Changing the password

When the secure user mode is activated the first time after installation, you are prompted to change the passwords for all user accounts in order to improve system security.

To save the new password, select "Save". The password dialog for the next user is displayed, until you have been prompted to change the password all user accounts.

If you cancel the dialog without changing the password, the password dialog for the next user is displayed, until you have been prompted to change the password all user accounts. Although it is possible to continue in secure user mode without changing the passwords (and you will not be prompted to do so again), it is strongly recommended that you do define a more secure password for all users.

By default, the password characters are not displayed to ensure confidentiality during input. To display the characters, select "Show password".

To display the onscreen keyboard, select "Keyboard".


Service Functions

General Instrument Setup > General Instrument Settings > Service Functions
Service Functions

When unexpected problems arise with the R&S FSW some service functions may help you solve them.

The service functions are available in the "Service" dialog box which is displayed when you press the SETUP key and then select "Service".

Contents
  • R&S Support Information
  • Selftest Settings and Results
  • Calibration Signal Display
  • Service Functions
  • Hardware Diagnostics


R&S Support Information

General Instrument Setup > General Instrument Settings > Service Functions > R&S Support Information
R&S Support Information

In case of errors you can store useful information for troubleshooting and send it to your Rohde & Schwarz support center.

└ Creating R&S Support Information
└ Save Device Footprint


Creating R&S Support Information

General Instrument Setup > General Instrument Settings > Service Functions > R&S Support Information > Creating R&S Support Information
Creating R&S Support Information

Creates a *.zip file with important support information. The *.zip file contains the system configuration information ("device footprint"), the current eeprom data and a screenshot of the screen display.

This data is stored to the C:\R_S\Instr\user\ directory on the instrument. The file name consists of the unique device ID and the current date and time of the file creation.

If you contact the Rohde&Schwarz support to get help for a certain problem, send these files to the support in order to identify and solve the problem faster.

Remote command:

DIAGnostic:​SERVice:​SINFo?


Save Device Footprint

General Instrument Setup > General Instrument Settings > Service Functions > R&S Support Information > Save Device Footprint
Save Device Footprint

Creates an *.xml file with information on installed hardware, software, image and FPGA versions. The *.xml file is stored under C:\R_S\Instr\devicedata\xml\ on the instrument. It is also included in the service.zip file.


Selftest Settings and Results

General Instrument Setup > General Instrument Settings > Service Functions > Selftest Settings and Results
Selftest Settings and Results

If the R&S FSW fails you can perform a self test of the instrument to identify any defective modules.

The selftest settings and results are available in the "Selftest" tab of the "Service" dialog box.

Once the self test is started, all modules are checked consecutively and the test result is displayed. You can abort a running test.

In case of failure a short description of the failed test, the defective module, the associated value range and the corresponding test results are indicated.

A running Sequencer process is aborted when you start a self-alignment.

Remote command:

*TST?

DIAGnostic:​SERVice:​STESt:​RESult?


Calibration Signal Display

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display
Calibration Signal Display

Alternatively to the RF input signal from the front panel connector you can use the instrument's calibration signal as the input signal, for example to perform service functions on.

The calibration signal settings are available in the "Calibration Signal" tab of the "Service" dialog box.

└ None
└ Calibration Frequency RF
└ Spectrum
└ Frequency
└ Calibration Frequency MW
└ Calibration Analog Baseband
└ Calibration Signal Type


None

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display > None
None

Uses the current RF signal at the input, i.e. no calibration signal (default).

Remote command:

DIAGnostic:​SERVice:​INPut[:​SELect]


Calibration Frequency RF

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display > Calibration Frequency RF
Calibration Frequency RF

Uses the internal calibration signal as the RF input signal.

Remote command:

DIAGnostic:​SERVice:​INPut[:​SELect]

DIAGnostic:​SERVice:​INPut:​PULSed:​CFRequency

└ Spectrum
└ Frequency


Spectrum

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display > Calibration Frequency RF > Spectrum
Spectrum

Defines whether a broadband or narrowband calibration signal is sent to the RF input.

"Narrowband" | Used to calibrate the absolute level of the frontend at 64 MHz.
"Broadband" | Used to calibrate the IF filter.
Remote command:

DIAGnostic:​SERVice:​INPut:​RF:​SPECtrum


Frequency

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display > Calibration Frequency RF > Frequency
Frequency

Defines the frequency of the internal broadband calibration signal to be used for IF filter calibration (max. 64 MHz). For narrowband signals, 64 MHz is sent.


Calibration Frequency MW

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display > Calibration Frequency MW
Calibration Frequency MW

Uses the microwave calibration signal as the RF input (for frequencies greater than 8 GHz; for instrument models R&S FSW13/26/43/50/67 only). This function is used to calibrate the YIG-filter on the microwave converter.

The microwave calibration signal is pulsed. You can define whether the distance between input pulses is small or wide.

Remote command:

DIAGnostic:​SERVice:​INPut[:​SELect]

DIAGnostic:​SERVice:​INPut:​MC:​DISTance


Calibration Analog Baseband

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display > Calibration Analog Baseband
Calibration Analog Baseband

Uses an internal calibration signal as input to the optional Analog Baseband interface. This signal is only available if the R&S FSW-B71 option is installed.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

DIAGnostic:​SERVice:​INPut[:​SELect]

└ Calibration Signal Type


Calibration Signal Type

General Instrument Setup > General Instrument Settings > Service Functions > Calibration Signal Display > Calibration Analog Baseband > Calibration Signal Type
Calibration Signal Type

Defines the type of calibration signal to be used for Analog Baseband.

"AC" | 1.5625 MHz square wave AC signal
"DC" | 1.5625 MHz square wave DC signal
"DC zero" | no signal
Remote command:

DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]


Service Functions

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions
Service Functions
Using service functions

The service functions are not necessary for normal measurement operation. Incorrect use can affect correct operation and/or data integrity of the R&S FSW.

Therefore, only user accounts with administrator rights can use service functions and many of the functions can only be used after entering a password. These functions are described in the instrument service manual.

The service functions are available in the "Service Function" tab of the "Service" dialog box.

└ Service Function
└ Numeric Mode
└ Send
└ Clear History
└ Password
└ Clear Results
└ Save Results
└ Result List


Service Function

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Service Function
Service Function

Selects the service function by its numeric code or textual name.

The selection list includes all functions previously selected (since the last "Clear History" action).

Remote command:

DIAGnostic:​SERVice:​SFUNction


Numeric Mode

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Numeric Mode
Numeric Mode

If activated, the service function is selected by its numeric code. Otherwise, the function is selected by its textual name.


Send

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Send
Send

Starts the selected service function.

Remote command:

DIAGnostic:​SERVice:​SFUNction


Clear History

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Clear History
Clear History

Deletes the list of previously selected service functions.


Password

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Password
Password

Most service functions require a special password as they may disrupt normal operation of the R&S FSW. There are different levels of service functions, depending on how restrictive their use is handled. Each service level has a different password.

"Reset Password" returns to the lowest (least restrictive) service level.


Clear Results

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Clear Results
Clear Results

Clears the result display for all previously performed service functions.

Remote command:

DIAGnostic:​SERVice:​SFUNction:​RESults:​DELete


Save Results

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Save Results
Save Results

Opens a file selection dialog box to save the results of all previously performed service functions to a file.

Remote command:

DIAGnostic:​SERVice:​SFUNction:​RESults:​SAVE


Result List

General Instrument Setup > General Instrument Settings > Service Functions > Service Functions > Result List
Result List

The Results List indicates the status and results of the executed service functions.


Hardware Diagnostics

General Instrument Setup > General Instrument Settings > Service Functions > Hardware Diagnostics
Hardware Diagnostics

In case problems occur with the instrument hardware, some diagnostic tools provide information that may support troubleshooting.

The hardware diagnostics tools are available in the "Hardware Diagnostics" tab of the "Service" dialog box.

└ Relay Cycle Counter
└ Temperatures
└ Ventilation


Relay Cycle Counter

General Instrument Setup > General Instrument Settings > Service Functions > Hardware Diagnostics > Relay Cycle Counter
Relay Cycle Counter

The hardware relays built into the R&S FSW may fail after a large number of switching cycles (see data sheet). The counter indicates how many switching cycles the individual relays have performed since they were installed.

Remote command:

DIAGnostic:​INFO:​CCOunter?


Temperatures

General Instrument Setup > General Instrument Settings > Service Functions > Hardware Diagnostics > Temperatures
Temperatures

Some hardware parts fail at high temperatures. Several temperature sensors in the R&S FSW provide the current temperature for the CPUs and the motherboard, which are indicated here.


Ventilation

General Instrument Setup > General Instrument Settings > Service Functions > Hardware Diagnostics > Ventilation
Ventilation

High temperatures in the R&S FSW may occur when the fans fail. The current speed and temperatures of the built-in fans are displayed. High temperatures or very slow fan speed may indicate a hardware problem.


Display Settings

General Instrument Setup > Display Settings
Display Settings

Some general display settings are available regardless of the current application or operating mode. For information on optimizing your display for measurement results see "Result Display Configuration".

The general display settings are defined in the "Display" dialog box which is displayed when you press the SETUP key and then select "Display".

Contents
  • General Display Settings
  • Displayed Items
  • Display Theme and Colors


General Display Settings

General Instrument Setup > Display Settings > General Display Settings
General Display Settings

This section includes general screen display behavior and date and time display. These settings are available in the "General" tab of the "Display" dialog box.

└ Deactivating and Activating the Touchscreen
└ Display Update Rate
└ Setting the Date and Time
└ Date and Time Format
└ Display Power Save Function


Deactivating and Activating the Touchscreen

General Instrument Setup > Display Settings > General Display Settings > Deactivating and Activating the Touchscreen
Deactivating and Activating the Touchscreen

The touchscreen function can be deactivated, e.g. when the instrument is being used for demonstration purposes and tapping the screen should not provoke an action.

To reactivate the touchscreen, simply press the SETUP key on the front panel. The "Display" dialog box is opened automatically and the "touchscreen" option is set to "ON".

"TOUCH ON" | Touchscreen function is active for the entire screen
"TOUCH OFF" | Touchscreen is deactivated for the entire screen
"TOUCH DIAGRAM OFF" | Touchscreen is deactivated for the diagram area of the screen, but active for the surrounding softkeys, toolbars and menus
Remote command:

DISPlay:​TOUChscreen:​STATe


Display Update Rate

General Instrument Setup > Display Settings > General Display Settings > Display Update Rate
Display Update Rate

By default, a fast update rate ensures the most recent measurement results on the display. However, when performance is poor due to slow data transfer (for example during remote control), it may be helpful to decrease the frequency with which the screen display is updated.


Setting the Date and Time

General Instrument Setup > Display Settings > General Display Settings > Setting the Date and Time
Setting the Date and Time

The current date and time on the instrument is set using the standard Windows "Date and Time Properties" dialog box which is displayed when you select the "Set Date and Time" button in the "Display" dialog box, or when you select the date and time display in the status bar.


Date and Time Format

General Instrument Setup > Display Settings > General Display Settings > Date and Time Format
Date and Time Format

Switches the time and date display on the screen between US and German (DE) format.

Remote command:

DISPlay[:​WINDow]:​TIME:​FORMat


Display Power Save Function

General Instrument Setup > Display Settings > General Display Settings > Display Power Save Function
Display Power Save Function

The touchscreen can be set to a power-save mode in which the display is temporarily switched off, including the backlight. This is useful during remote control, for example, or when a measurement with a long duration is running that needs not be monitored. You can define a waiting time after which the power-save mode sets in automatically if no manual interaction with the instrument occurs.

To switch the display back on, tap the screen or press a key.

Remote command:

DISPlay:​PSAVe[:​STATe]

DISPlay:​PSAVe:​HOLDoff


Displayed Items

General Instrument Setup > Display Settings > Displayed Items
Displayed Items

Several elements on the screen display can be hidden or shown as required, for example to enlarge the display area for the measurement results. These settings are available in the "Displayed Items" tab of the "Display" dialog box.

└ Toolbar
└ Status Bar
└ Softkey Bar
└ Channel Bar
└ Diagram Footer (Annotation)
└ Date and Time
└ Front Panel
└ Mini Front Panel


Toolbar

General Instrument Setup > Display Settings > Displayed Items > Toolbar
Toolbar

The toolbar provides access to frequently used functions via icons at the top of the screen. Some functions, such as zooming, finding help, printing screenshots or storing and loading files are not accessible at all without the toolbar.

Remote command:

DISPlay:​TBAR[:​STATe]


Status Bar

General Instrument Setup > Display Settings > Displayed Items > Status Bar
Status Bar

The status bar beneath the diagram indicates the global instrument settings, the instrument status and any irregularities during measurement or display.

Some of the information displayed in the status bar can be queried from the status registry via remote commands, see "Remote Commands".

Remote command:

DISPlay:​SBAR[:​STATe]


Softkey Bar

General Instrument Setup > Display Settings > Displayed Items > Softkey Bar
Softkey Bar

Softkeys are virtual keys provided by the software. Thus, more functions can be provided than those that can be accessed directly via the function keys on the device.

The functions provided by the softkeys are often also available via dialog boxes. However, some functions may not be accessible at all without the softkey bar.

Note: The softkey bar is hidden while the SmartGrid is displayed and restored automatically when the SmartGrid is closed.
For details see "Laying out the Result Display with the SmartGrid".

Remote command:

DISPlay:​SKEYs[:​STATe]


Channel Bar

General Instrument Setup > Display Settings > Displayed Items > Channel Bar
Channel Bar

The channel bar provides information on firmware and measurement settings for a specific measurement channel.

Remote command:

DISPlay:​ANNotation:​CBAR


Diagram Footer (Annotation)

General Instrument Setup > Display Settings > Displayed Items > Diagram Footer (Annotation)
Diagram Footer (Annotation)

The diagram footer beneath the diagram contains information on the x-axis of the diagram display, such as the current center frequency and span settings, the displayed span per division and the number of sweep points.

Remote command:

DISPlay:​ANNotation:​FREQuency


Date and Time

General Instrument Setup > Display Settings > Displayed Items > Date and Time
Date and Time

The date and time display can be switched off independently of the status bar.

You can set the current date and time and configure the display format in the "General" tab of the "Display" dialog box.

Remote command:

DISPlay[:​WINDow]:​TIME


Front Panel

General Instrument Setup > Display Settings > Displayed Items > Front Panel
Front Panel

The "Front Panel" display simulates the entire front panel of the device (except for the external connectors) on the screen. This allows you to interact with the R&S FSW without requiring the keypad and keys located on the front panel of the device. This is useful, for example, when working with an external monitor or operating via remote control from a computer.

To activate or deactivate the front panel temporarily, press the F6 key on the external keyboard (if available) or the remote computer.

For more information see "How to Work with the Soft Front Panels".

Remote command:

SYSTem:​DISPlay:​FPANel[:​STATe]


Mini Front Panel

General Instrument Setup > Display Settings > Displayed Items > Mini Front Panel
Mini Front Panel

If you require a front panel display but do not want to lose too much space for results in the display area, a mini front panel is available. The mini version displays only the main function hardkeys in a separate window in the display area.

This window can be closed automatically after pressing a key ("Auto Close" option), or remain open, as desired.

For more information see "How to Work with the Soft Front Panels".

Note: You can also activate the Mini Front Panel using the key combination "ALT + m" (be aware of the keyboard language defined in the operating system!). This is useful when you are working from a remote PC and the Front Panel function is not active.

Remote command:

SYSTem:​DISPlay:​FPANel[:​STATe]


Display Theme and Colors

General Instrument Setup > Display Settings > Display Theme and Colors
Display Theme and Colors

You can configure the used colors and styles of display elements on the screen. These settings are available in the "Theme + Color" tab of the "Display" dialog box.

For step-by-step instructions see "How to Configure the Colors for Display and Printing".

└ Theme
└ Screen colors
└ Print colors
└ Showing Print Colors on Display
└ Modifying User-Defined Color Assignments
└ Selecting the Object
└ Predefined Colors
└ Preview
└ Defining User-specific Colors
└ Restoring the User Settings to Default Colors


Theme

General Instrument Setup > Display Settings > Display Theme and Colors > Theme
Theme

The theme defines the colors and style used to display softkeys and other screen objects. The default theme is "BlueOcean".

Remote command:

DISPlay:​THEMe:​SELect


Screen colors

General Instrument Setup > Display Settings > Display Theme and Colors > Screen colors
Screen colors

Two different color sets are provided by the instrument, a third user-defined set can be configured.

The default color schemes provide optimum visibility of all screen objects when regarding the screen from above or below. Default setting is "Default Colors 1".

If "User Defined Colors" is selected, a user-defined color set can be defined.

Remote command:

DISPlay:​CMAP<item>:​DEFault<colors>


Print colors

General Instrument Setup > Display Settings > Display Theme and Colors > Print colors
Print colors

Defines the color settings used for printout. In addition to the predefined settings, a user-defined color set can be configured.

If "Show Print Colors on Display" is activated, the currently selected print colors are displayed as a preview for your selection.

Optimized Colors | Selects an optimized color setting for the printout to improve the visibility of the colors (default setting). Trace 1 is blue, trace 2 black, trace 3 green, and the markers are turquoise. The background is always printed in white and the grid in black.
Screen Colors (Print) | Selects the current screen colors for the printout. The background is always printed in white and the grid in black.
Screen Colors (Hardcopy) | Selects the current screen colors without any changes for a hardcopy.
User Defined Colors | Selects the user-defined color setting.
Remote command:

HCOPy:​CMAP<item>:​DEFault<colors>


Showing Print Colors on Display

General Instrument Setup > Display Settings > Display Theme and Colors > Showing Print Colors on Display
Showing Print Colors on Display

Temporarily shows the currently selected print colors on the screen display. This function can be used as a preview for printing.


Modifying User-Defined Color Assignments

General Instrument Setup > Display Settings > Display Theme and Colors > Modifying User-Defined Color Assignments
Modifying User-Defined Color Assignments

You can configure the colors used to display and print individual screen objects according to your specific requirements.

The colors are configured in the (identical) "Screen Color Setup"/"Printer Color Setup" dialog boxes.

└ Selecting the Object
└ Predefined Colors
└ Preview


Selecting the Object

General Instrument Setup > Display Settings > Display Theme and Colors > Modifying User-Defined Color Assignments > Selecting the Object
Selecting the Object

Selects the object for which the color is to be defined. Colors can be defined for the following objects:

  • Background
  • Grid
  • Individual traces
  • Display lines
  • Limit lines and check results
  • Markers and marker information
Remote command:

Each object is assigned to a specific suffix of the CMAP commands, see "CMAP Suffix Assignment".


Predefined Colors

General Instrument Setup > Display Settings > Display Theme and Colors > Modifying User-Defined Color Assignments > Predefined Colors
Predefined Colors

Displays the available colors from the predefined color set that can be used for the selected object.

Remote command:

HCOPy:​CMAP<item>:​PDEFined


Preview

General Instrument Setup > Display Settings > Display Theme and Colors > Modifying User-Defined Color Assignments > Preview
Preview

Indicates the currently selected color that will be used for the selected object.


Defining User-specific Colors

General Instrument Setup > Display Settings > Display Theme and Colors > Defining User-specific Colors
Defining User-specific Colors

In addition to the colors in the predefined color set you can configure a user-specific color to be used for the selected object.

When you select "Userdefined Colors", the set of predefined colors is replaced by a color palette and color configuration settings.

The color palette allows you to select the color directly. The color settings allow you to define values for tint, saturation and brightness.

Remote command:

HCOPy:​CMAP<item>:​HSL


Restoring the User Settings to Default Colors

General Instrument Setup > Display Settings > Display Theme and Colors > Restoring the User Settings to Default Colors
Restoring the User Settings to Default Colors

In addition to the predefined color settings, a user-defined setting can be configured. By default, the same settings as defined in "Default Colors 1" are used. They can then be modified according to user-specific requirements (see "Modifying User-Defined Color Assignments").

The "Set to Default" function restores the original default settings for the user-defined color set. You can select which of the three default settings are restored.

Remote command:

DISPlay:​CMAP<item>:​PDEFined


External Monitor Settings

General Instrument Setup > External Monitor Settings
External Monitor Settings

You can connect an external monitor (or projector) to the DVI or DISPLAY PORT connector on the instrument's rear panel (see also "DISPLAY PORT and DVI").

Which display device is used by the instrument is configured in the "Configure Monitor" tab of the "Display" dialog box.

Screen resolution and format

The touchscreen of the R&S FSW is calibrated for a 16:10 format. If you connect a monitor or projector using a different format (e.g. 4:3), the calibration will not be correct and the screen will not react to your touch actions properly.

The touchscreen has a screen resolution of 1280x800 pixels. Most external monitors have a higher screen resolution. If the screen resolution of the monitor is set higher than the instrument's resolution, the application window uses an area of 1280x800 pixels on the monitor display. For full screen display, adjust the monitor's screen resolution.

└ External Monitor Off
└ Duplicate
└ Setup


External Monitor Off

General Instrument Setup > External Monitor Settings > External Monitor Off
External Monitor Off

Only the internal monitor of the R&S FSW is used for display.


Duplicate

General Instrument Setup > External Monitor Settings > Duplicate
Duplicate

Both the internal and the external monitor are used.


Setup

General Instrument Setup > External Monitor Settings > Setup
Setup

User-defined configuration; opens the standard Windows configuration dialog box to configure the display devices to be used


How to Configure the Basic Instrument Settings

General Instrument Setup > How to Configure the Basic Instrument Settings
How to Configure the Basic Instrument Settings

The following step-by-step instructions demonstrate how to configure the basic instrument settings. For details on individual functions and settings see "General Instrument Settings".

The remote commands required to perform these tasks are described in "General Instrument Settings".

Contents
  • How to Perform a Self Test
  • How to Align the Instrument
  • How to Align the Touchscreen
  • How to Install an R&S FSW Option
  • How to Update the Instrument Firmware
  • How to Configure the Transducer
  • How to Configure the Colors for Display and Printing
  • How to Work with the Soft Front Panels


How to Perform a Self Test

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Perform a Self Test
How to Perform a Self Test

The self test does not need to be repeated every time the instrument is switched on. It is only necessary when instrument malfunction is suspected.

Operating temperature

Before performing this functional test, make sure that the instrument has reached its operating temperature (for details, refer to the data sheet).

  1. Press the SETUP key.

  2. Press the "Service" softkey.

  3. Press the "Selftest" softkey.

    Once the instrument modules have been checked successfully, a message is displayed.


How to Align the Instrument

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Align the Instrument
How to Align the Instrument
Operating temperature

Before performing this functional test, make sure that the instrument has reached its operating temperature (for details, refer to the data sheet).

To perform a self-alignment

  1. Press the SETUP key.

  2. Select the "Alignment" softkey.

  3. Select the "Start Self-alignment" button.

  4. To abort the self-alignment process, select the "Abort Self-alignment" button.

    Once the system correction values have been calculated successfully, a message is displayed.

To display the alignment results again later
  • Press the SETUP key.
  • Press the "Alignment" softkey.


How to Align the Touchscreen

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Align the Touchscreen
How to Align the Touchscreen
To align the touchscreen

  1. Press the SETUP key.

  2. Select the "Alignment" softkey.

  3. Select "Touchscreen Alignment".

    A blinking cross appears in the lower left corner of the screen.

  4. Touch and hold the blinking cross until it stops blinking.

    Repeat this action for the crosses in the other corners.


How to Install an R&S FSW Option

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Install an R&S FSW Option
How to Install an R&S FSW Option

Additional options for the R&S FSW can be enabled using a license key. To obtain the license key, consult your sales representative. You need the device ID and serial number of your instrument to get a license key (see "System Configuration Settings"). No additional installation is required.


How to Update the Instrument Firmware

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Update the Instrument Firmware
How to Update the Instrument Firmware

  1. Download the update package from the Rohde&Schwarz website and store it on a memory stick, on the instrument, or on a server network drive that can be accessed by the instrument.

  2. NOTICE! Stop measurement. The firmware update must not be performed during a running measurement.

    If a measurement is running, stop it by pressing the highlighted RUN CONT or RUN SINGLE key.

  3. Press the SETUP key.

  4. Select the "Firmware Update" tab.

  5. In the file selection dialog box select the FSWSetup*.exe file.

  6. Select "Install" to start the update.

  7. After the firmware update, the R&S FSW reboots automatically.

  8. Depending on the previous firmware version, a reconfiguration of the hardware might be required during the first startup of the firmware. The reconfiguration starts automatically, and a message box informs you about the process. When the reconfiguration has finished, the instrument again reboots automatically.

    Note: Do not switch off the instrument during the reconfiguration process!

    Now the firmware update is complete. It is recommended that you perform a self-alignment after the update (see "How to Align the Instrument").


How to Configure the Transducer

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Configure the Transducer
How to Configure the Transducer

Configuring the transducer is very similar to configuring limit lines.

The transducer settings are defined in the "Transducer" dialog box which is displayed when you press the SETUP key and then select "Transducer".

The following tasks are described:

  • "How to find compatible transducer lines"
  • "How to activate and deactivate a transducer"
  • "How to edit existing transducer lines"
  • "How to copy an existing transducer line"
  • "How to delete an existing transducer line"
  • "How to configure a new transducer line"
  • "How to move the transducer line vertically or horizontally"
How to find compatible transducer lines
►

In the "Transducer" dialog box, select the "View filter" option: "Show compatible".

All transducer lines stored on the instrument that are compatible to the current measurement settings are displayed in the overview.

How to activate and deactivate a transducer

  1. To activate a transducer select a transducer line in the overview and select the "Active" setting for it.

    The trace is automatically recalculated for the next sweep after a transducer line is activated.

  2. To deactivate a transducer line, deactivate the "Active" setting for it.

    After the next sweep, the originally measured values are displayed.

How to edit existing transducer lines

Existing transducer line configurations can be edited.

  1. In the "Transducer" dialog box, select the transducer line.

  2. Select the "Edit" button.

  3. Edit the line configuration as described in "How to configure a new transducer line".

  4. Save the new configuration by selecting the "Save" button.

    The trace is automatically recalculated for the next sweep if the transducer line is active.

How to copy an existing transducer line

  1. In the "Transducer" dialog box, select the transducer line.

  2. Select the "Copy" button.

    The "Edit Transducer" dialog box is opened with the configuration of the selected transducer.

  3. Define a new name to create a new transducer with the same configuration as the source line.

  4. Edit the line configuration as described in "How to configure a new transducer line".

  5. Save the new configuration by selecting the "Save" button.

    The new transducer line is displayed in the overview and can be activated.

How to delete an existing transducer line

  1. In the "Transducer" dialog box, select the transducer line.

  2. Select the "Delete" button.

  3. Confirm the message.

    The transducer line is deleted. After the next sweep, the originally measured values are displayed.

How to configure a new transducer line

  1. In the "Transducer" dialog box, select the "New" button.

    The "Edit Transducer" dialog box is displayed. The current line configuration is displayed in the preview area of the dialog box. The preview is updated after each change to the configuration.

  2. Define a "Name" and, optionally, a "Comment" for the new transducer line.

  3. Define the scaling for the x-axis.

  4. Define the data points: minimum 2, maximum 50:

    1. Select "Insert Value".

    2. Define the x-value ("Position") and y-value ("Value") of the first data point.

    3. Select "Insert Value" again and define the second data point.

    4. Repeat this to insert all other data points.

      To insert a data point before an existing one, select the data point and then "Insert Value".

      To insert a new data point at the end of the list, move the focus to the line after the last entry and then select "Insert Value".

      To delete a data point, select the entry and then "Delete Value".

  5. Check the current line configuration in the preview area of the dialog box. If necessary, correct individual data points or add or delete some.

    If necessary, shift the entire line vertically or horizontally by selecting the "Shift x" or "Shift y" button and defining the shift width.

  6. Save the new configuration by selecting the "Save" button.

    The new transducer line is displayed in the overview and can be activated.

How to move the transducer line vertically or horizontally

A configured transducer line can easily be moved vertically or horizontally. Thus, a new transducer line can be easily generated based upon an existing transducer line which has been shifted.

  1. In the "Line Config" dialog box, select the transducer line.

  2. Select the "Edit" button.

  3. In the "Edit transducer Line" dialog box, select the "Shift x" or "Shift y" button and define the shift width.

  4. Save the shifted data points by selecting the "Save" button.

    If activated, the trace is recalculated after the next sweep.


How to Configure the Colors for Display and Printing

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Configure the Colors for Display and Printing
How to Configure the Colors for Display and Printing

You can configure the style and colors with which various screen objects are displayed or printed.

To select a color set

  1. Press the SETUP key and select the "Display" softkey.

  2. Select the "Theme + Color" tab.

  3. In the "Screen Colors" area, select a predefined set of colors to be used for screen display, or select "User Defined Colors" to configure the color set yourself.

  4. In the "Print Colors" area, select a predefined set of colors to be used for printing screenshots, or select "User Defined Colors" to configure the color set yourself.

    Activate the "Show Print Colors on Display" option to see a preview of the print colors.

To configure a user-defined color set

  1. In the "Theme + Color" tab of the "Display" dialog box select "User Defined Colors" either for the screen or the print colors.

  2. Select "Modify User Color".

    The "Screen Color Setup" dialog box is opened.

  3. From the "Selected Object" list, select the object to which you want to assign a color.

  4. Select a color from the "Predefined Colors" or select the "Userdefined Colors..." button to define a different color.

    The "Preview" area indicates the currently selected color.

  5. To assign a user-specific color to the selected object, do one of the following:

    • Select the color from the palette.
    • Enter values for the "Tint", "Saturation", and "Brightness".
      Note: In the continuous color spectrum ("Tint") red is represented by 0% and blue by 100%.
    • Enter an "ARGB" value in hexadecimal format.

  6. Select the next object to which you want to assign a color from the "Selected Object" list and assign a color as described.

    Repeat these steps until all objects you want to configure have been assigned a color.

  7. Select "OK" to close the dialog box and apply the colors to the assigned objects.


How to Work with the Soft Front Panels

General Instrument Setup > How to Configure the Basic Instrument Settings > How to Work with the Soft Front Panels
How to Work with the Soft Front Panels

Basic operation with the soft front panels is identical to normal operation, except for the following aspects:

To activate a key, select the key on the touchscreen.

To simulate the use of the rotary knob, use the additional keys displayed between the keypad and the arrow keys:

Icon | Function
 | Turn left
 | Enter
 | Turn right
Mini Front Panel

The Mini Front Panel provides only the hardkeys on the touchscreen, in order to operate the R&S FSW via an external monitor or remote desktop.

By default, the "Auto close" option is activated and the Mini Front Panel window closes automatically after you select a key. This is useful if you only require the Mini Front Panel display occassionally to press a single function key.

If you want the window to remain open, deactivate the "Auto close" option. You can close the window manually by selecting "Close Panel" or the key combination ALT + M (be aware of the keyboard language defined in the operating system!).

To display the soft front panel or mini front panel

  1. Press the SETUP key and select the "Display" softkey.

  2. Select the "Displayed Items" tab.

  3. Select "Front Panel: On" or "Mini Front Panel: On".

To activate or deactivate the front panel temporarily, press the F6 key on the external keyboard (if available) or on the remote computer.


Network and Remote Operation

In addition to working with the R&S FSW interactively, located directly at the instrument, it is also possible to operate and control it from a remote PC. Various methods for remote control are supported:

  • Connecting the instrument to a (LAN) network
  • Using the LXI browser interface in a LAN network
  • Using the Windows Remote Desktop application in a LAN network
  • Connecting a PC via the GPIB interface

How to configure the remote control interfaces is described in "How to Set Up a Network and Remote Control".

Contents
  • Remote Control Basics
  • GPIB Languages
  • The IECWIN Tool
  • Network and Remote Control Settings
  • How to Set Up a Network and Remote Control


Remote Control Basics

Network and Remote Operation > Remote Control Basics
Remote Control Basics

Basic information on operating an instrument via remote control is provided here. this information applies to all applications and operating modes on the R&S FSW.

Contents
  • Remote Control Interfaces and Protocols
  • SCPI (Standard Commands for Programmable Instruments)
  • VISA Libraries
  • Messages
  • SCPI Command Structure
  • Command Sequence and Synchronization
  • Status Reporting System
  • General Programming Recommendations


Remote Control Interfaces and Protocols

Network and Remote Operation > Remote Control Basics > Remote Control Interfaces and Protocols
Remote Control Interfaces and Protocols

The instrument supports different interfaces for remote control. The following table gives an overview.

Remote control interfaces and protocols

Interface

Protocols, VISA*) address string

Remarks

Local Area Network (LAN)

  • HiSLIP High-Speed LAN Instrument Protocol (IVI-6.1)
    TCPIP::host address::hislip0[::INSTR]
  • VXI-11
    TCPIP::host address::inst0[::INSTR]
    Library: VISA
  • socket communication (Raw Ethernet, simple Telnet)
    TCPIP::host address[::LAN device name]::<port>::SOCKET
    Library: VISA or socketcontroller

A LAN connector is located on the rear panel of the instrument.

The interface is based on TCP/IP and supports various protocols.

For a description of the protocols refer to:

"VXI-11 Protocol"

"HiSLIP Protocol"

"Socket Communication"

GPIB (IEC/IEEE Bus Interface)

VISA*) address string:

GPIB::primary address[::INSTR]

(no secondary address)

A GPIB bus interface according to the IEC 625.1/IEEE 488.1 standard is located on the rear panel of the instrument.

For a description of the interface refer to "GPIB Interface (IEC 625/IEEE 418 Bus Interface)".

USB

VISA*) address string:

USB::<vendor ID>::<product_ID>::<serial_number>[::INSTR]

USB connectors are located on the front and rear panel of the instrument.

For a description of the interface refer to "USB Interface".

*) VISA is a standardized software interface library providing input and output functions to communicate with instruments. A VISA installation on the controller is a prerequisite for remote control using the indicated interfaces (see also "VISA Libraries").

Within this interface description, the term GPIB is used as a synonym for the IEC/IEEE bus interface.

Contents
  • LAN Interface
  • GPIB Interface (IEC 625/IEEE 418 Bus Interface)
  • USB Interface


LAN Interface

Network and Remote Operation > Remote Control Basics > Remote Control Interfaces and Protocols > LAN Interface
LAN Interface

To be integrated in a LAN, the instrument is equipped with a LAN interface, consisting of a connector, a network interface card and protocols. The network card can be operated with the following interfaces:

  • 10 Mbit/s Ethernet IEEE 802.3
  • 100 Mbit/s Ethernet IEEE 802.3u
  • 1Gbit/s Ethernet IEEE 802.3ab

For remote control via a network, the PC and the instrument must be connected via the LAN interface to a common network with TCP/IP network protocol. They are connected using a commercial RJ45 cable (shielded or unshielded twisted pair category 5). The TCP/IP network protocol and the associated network services are preconfigured on the instrument. Software for instrument control and the VISA program library must be installed on the controller.

VISA library

Instrument access is usually achieved from high level programming platforms using VISA as an intermediate abstraction layer. VISA encapsulates the low level VXI, GPIB, LAN or USB function calls and thus makes the transport interface transparent for the user. See "VISA Libraries" for details.

The R&S FSW supports various LAN protocols such as LXI, RSIB, raw socket or the newer HiSLIP protocol.

IP address

Only the IP address or a valid DNS host name is required to set up the connection. The host address is part of the "VISA resource string" used by the programs to identify and control the instrument.

The VISA resource string has the form:

TCPIP::host address[::LAN device name][::INSTR]

or

TCPIP::host address::port::SOCKET

where:

  • TCPIP designates the network protocol used
  • host address is the IP address or host name of the device
  • LAN device name defines the protocol and the instance number of a sub-instrument;
    – inst0 selects the VXI-11 protocol (default)
    – hislip0 selects the newer HiSLIP protocol
  • INSTR indicates the instrument resource class (optional)
  • port determines the used port number
  • SOCKET indicates the raw network socket resource class
Example:
  • Instrument has the IP address 192.1.2.3; the valid resource string using VXI-11 protocol is:
    TCPIP::192.1.2.3::INSTR
  • The DNS host name name is FSW-123456; the valid resource string using HiSLIP is:
    TCPIP::FSW-123456::hislip0
  • A raw socket connection can be established using:
    TCPIP::192.1.2.3::5025::SOCKET
Identifying instruments in a network

If several instruments are connected to the network, each instrument has its own IP address and associated resource string. The controller identifies these instruments by means of the resource string.

For details on configuring the LAN connection, see "How to Configure a Network".

Contents
  • VXI-11 Protocol
  • HiSLIP Protocol
  • Socket Communication


VXI-11 Protocol

Network and Remote Operation > Remote Control Basics > Remote Control Interfaces and Protocols > LAN Interface > VXI-11 Protocol
VXI-11 Protocol

The VXI-11 standard is based on the ONC RPC (Open Network Computing Remote Procedure Call) protocol which in turn relies on TCP/IP as the network/transport layer. The TCP/IP network protocol and the associated network services are preconfigured. TCP/IP ensures connection-oriented communication, where the order of the exchanged messages is adhered to and interrupted links are identified. With this protocol, messages cannot be lost.


HiSLIP Protocol

Network and Remote Operation > Remote Control Basics > Remote Control Interfaces and Protocols > LAN Interface > HiSLIP Protocol
HiSLIP Protocol

The HiSLIP (High Speed LAN Instrument Protocol) is the successor protocol for VXI-11 for TCP-based instruments specified by the IVI foundation. The protocol uses two TCP sockets for a single connection - one for fast data transfer, the other for non-sequential control commands (e.g. Device Clear or SRQ).

HiSLIP has the following characteristics:

  • High performance as with raw socket network connections
  • Compatible IEEE 488.2 support for Message Exchange Protocol, Device Clear, Serial Poll, Remote/Local, Trigger, and Service Request
  • Uses a single IANA registered port (4880), which simplifies the configuration of firewalls
  • Supports simultaneous access of multiple users by providing versatile locking mechanisms
  • Usable for IPv6 or IPv4 networks

Note that HiSLIP data is sent to the device using the "fire and forget" method with immediate return, as opposed to VXI-11, where each operation is blocked until a VXI-11 device handshake returns. Thus, a successful return of a VISA operation such as viWrite() does not guarantee that the instrument has finished or started the requested command, but is delivered to the TCP/IP buffers.

For more information see also the application note at: http://www.rohde-schwarz.com/appnote/1MA208.


Socket Communication

Network and Remote Operation > Remote Control Basics > Remote Control Interfaces and Protocols > LAN Interface > Socket Communication
Socket Communication

An alternative way for remote control of the software is to establish a simple network communication using sockets. The socket communication, also referred to as "Raw Ethernet communication", does not necessarily require a VISA installation on the remote controller side. It is available by default on all operating systems.

The simplest way to establish socket communication is to use the built-in telnet program. The telnet program is part of every operating system and supports a communication with the software on a command-by-command basis. For more convenience and to enable automation by means of programs, user-defined sockets can be programmed.

Socket connections are established on a specially defined port. The socket address is a combination of the IP address or the host name of the instrument and the number of the port configured for remote-control. All R&S FSW use port number 5025 for this purpose. The port is configured for communication on a command-to-command basis and for remote control from a program.


GPIB Interface (IEC 625/IEEE 418 Bus Interface)

Network and Remote Operation > Remote Control Basics > Remote Control Interfaces and Protocols > GPIB Interface (IEC 625/IEEE 418 Bus Interface)
GPIB Interface (IEC 625/IEEE 418 Bus Interface)

A GPIB interface is integrated on the rear panel of the instrument. By connecting a PC to the R&S FSW via the GPIB connection you can send remote commands to control and operate the instrument.

To be able to control the instrument via the GPIB bus, the instrument and the controller must be linked by a GPIB bus cable. A GPIB bus card, the card drivers and the program libraries for the programming language used must be provided in the controller. The controller must address the instrument with the GPIB bus address (see "How to Change the GPIB Instrument Address"). You can set the GPIB address and the ID response string. The GPIB language is set as SCPI by default and cannot be changed for the R&S FSW.

Notes and Conditions

In connection with the GPIB interface, note the following:

  • Up to 15 instruments can be connected
  • The total cable length is restricted to a maximum of 15 m or 2 m times the number of devices, whichever is less; the cable lenth between two instruments should not exceed 2 m.
  • A wired "OR"-connection is used if several instruments are connected in parallel.
  • Any connected IEC-bus cables should be terminated by an instrument or controller.


USB Interface

Network and Remote Operation > Remote Control Basics > Remote Control Interfaces and Protocols > USB Interface
USB Interface

For remote control via the USB connection, the PC and the instrument must be connected via the USB type B interface. A USB connection requires the VISA library to be installed. VISA detects and configures the R&S instrument automatically when the USB connection is established. You do not have to enter an address string or install a separate driver.

USB address

The used USB address string is:

USB::<vendor ID>::<product ID>::<serial number>[::INSTR]

where:

  • <vendor ID> is the vendor ID for Rohde & Schwarz (0x0AAD)
  • <product ID> is the product ID for the Rohde & Schwarz instrument
  • <serial number> is the individual serial number on the rear of the instrument
Product IDs for R&S FSW
Instrument model | Product ID
FSW8 | C6
FSW13 | C7
FSW26 | C8
FSW43 | C9
FSW50 | CB
FSW67 | CC
Example:

USB::0x0AAD::0x00C7::100001::INSTR

0x0AAD is the vendor ID for Rohde&Schwarz

0x00C7 is the product ID for the R&S FSW13

100001 is the serial number of the particular instrument


SCPI (Standard Commands for Programmable Instruments)

Network and Remote Operation > Remote Control Basics > SCPI (Standard Commands for Programmable Instruments)
SCPI (Standard Commands for Programmable Instruments)

SCPI commands - messages - are used for remote control. Commands that are not taken from the SCPI standard follow the SCPI syntax rules. The instrument supports the SCPI version 1999. The SCPI standard is based on standard IEEE 488.2 and aims at the standardization of device-specific commands, error handling and the status registers. The tutorial "Automatic Measurement Control - A tutorial on SCPI and IEEE 488.2" from John M. Pieper (R&S order number 0002.3536.00) offers detailed information on concepts and definitions of SCPI.

Tables provide a fast overview of the bit assignment in the status registers. The tables are supplemented by a comprehensive description of the status registers.


VISA Libraries

Network and Remote Operation > Remote Control Basics > VISA Libraries
VISA Libraries

VISA is a standardized software interface library providing input and output functions to communicate with instruments. The I/O channel (LAN or TCP/IP, USB, ...) is selected at initialization time by means of the channel–specific address string ("VISA resource string") indicated in table "Remote control interfaces and protocols", or by an appropriately defined VISA alias (short name).

A VISA installation is a prerequisite for remote control using the following interfaces:

  • "LAN Interface"
  • "GPIB Interface (IEC 625/IEEE 418 Bus Interface)"
  • "USB Interface"

For more information about VISA refer to the user documentation.


Messages

Network and Remote Operation > Remote Control Basics > Messages
Messages

The messages transferred on the data lines are divided into the following categories:

  • Interface messages
    Interface messages are transmitted to the instrument on the data lines, with the attention line being active (LOW). They are used to communicate between the controller and the instrument. Interface messages can only be sent by instruments that have GPIB bus functionality. For details see the sections for the required interface.
  • Instrument messages
    Instrument messages are employed in the same way for all interfaces, if not indicated otherwise in the description. Structure and syntax of the instrument messages are described in "SCPI Command Structure". A detailed description of all messages available for the instrument is provided in the chapter "Remote Control Commands".
    There are different types of instrument messages, depending on the direction they are sent:
    – Commands
    – Instrument responses
Commands
Commands (program messages) are messages the controller sends to the instrument. They operate the instrument functions and request information. The commands are subdivided according to two criteria:
  • According to the effect they have on the instrument:
    – Setting commands cause instrument settings such as a reset of the instrument or setting the frequency.
    – Queries cause data to be provided for remote control, e.g. for identification of the instrument or polling a parameter value. Queries are formed by directly appending a question mark to the command header.
  • According to their definition in standards:
    – Common commands: their function and syntax are precisely defined in standard IEEE 488.2. They are employed identically on all instruments (if implemented). They refer to functions such as management of the standardized status registers, reset and self test.
    – Instrument control commands refer to functions depending on the features of the instrument such as frequency settings. Many of these commands have also been standardized by the SCPI committee. These commands are marked as "SCPI confirmed" in the command reference chapters. Commands without this SCPI label are device-specific; however, their syntax follows SCPI rules as permitted by the standard.
Instrument responses

Instrument responses (response messages and service requests) are messages the instrument sends to the controller after a query. They can contain measurement results, instrument settings and information on the instrument status.


SCPI Command Structure

Network and Remote Operation > Remote Control Basics > SCPI Command Structure
SCPI Command Structure

SCPI commands consist of a so-called header and, in most cases, one or more parameters. The header and the parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). The headers may consist of several mnemonics (keywords). Queries are formed by appending a question mark directly to the header.

The commands can be either device-specific or device-independent (common commands). Common and device-specific commands differ in their syntax.

Contents
  • Syntax for Common Commands
  • Syntax for Device-Specific Commands
  • SCPI Parameters
  • Overview of Syntax Elements
  • Structure of a command line
  • Responses to Queries


Syntax for Common Commands

Network and Remote Operation > Remote Control Basics > SCPI Command Structure > Syntax for Common Commands
Syntax for Common Commands

Common (=device-independent) commands consist of a header preceded by an asterisk (*) and possibly one or more parameters.

Examples:

*RST | RESET | Resets the instrument.
*ESE | EVENT STATUS ENABLE | Sets the bits of the event status enable registers.
*ESR? | EVENT STATUS QUERY | Queries the contents of the event status register.
*IDN? | IDENTIFICATION QUERY | Queries the instrument identification string.


Syntax for Device-Specific Commands

Network and Remote Operation > Remote Control Basics > SCPI Command Structure > Syntax for Device-Specific Commands
Syntax for Device-Specific Commands

Not all commands used in the following examples are necessarily implemented in the instrument.

For demonstration purposes only, assume the existence of the following commands for this section:

  • DISPlay[:WINDow<1...4>]:MAXimize <Boolean>
  • FORMat:READings:DATA <type>[,<length>]
  • HCOPy:DEVice:COLor <Boolean>
  • HCOPy:DEVice:CMAP:COLor:RGB <red>,<green>,<blue>
  • HCOPy[:IMMediate]
  • HCOPy:ITEM:ALL
  • HCOPy:ITEM:LABel <string>
  • HCOPy:PAGE:DIMensions:QUADrant[<N>]
  • HCOPy:PAGE:ORIentation LANDscape | PORTrait
  • HCOPy:PAGE:SCALe <numeric value>
  • MMEMory:COPY <file_source>,<file_destination>
  • SENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>
  • SENSe:FREQuency:STOP <numeric value>
  • SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}
Long and short form

The mnemonics feature a long form and a short form. The short form is marked by upper case letters, the long form corresponds to the complete word. Either the short form or the long form can be entered; other abbreviations are not permitted.

Example:

HCOPy:DEVice:COLor ON is equivalent to HCOP:DEV:COL ON.

Case-insensitivity

Upper case and lower case notation only serves to distinguish the two forms in the manual, the instrument itself is case-insensitive.

Numeric suffixes

If a command can be applied to multiple instances of an object, e.g. specific channels or sources, the required instances can be specified by a suffix added to the command. Numeric suffixes are indicated by angular brackets (<1...4>, <n>, <i>) and are replaced by a single value in the command. Entries without a suffix are interpreted as having the suffix 1.

Example:

Definition: HCOPy:PAGE:DIMensions:QUADrant[<N>]

Command: HCOP:PAGE:DIM:QUAD2

This command refers to the quadrant 2.

Different numbering in remote control

For remote control, the suffix may differ from the number of the corresponding selection used in manual operation. SCPI prescribes that suffix counting starts with 1. Suffix 1 is the default state and used when no specific suffix is specified.

Some standards define a fixed numbering, starting with 0. If the numbering differs in manual operation and remote control, it is indicated for the corresponding command.

Optional mnemonics

Some command systems permit certain mnemonics to be inserted into the header or omitted. These mnemonics are marked by square brackets in the description. The instrument must recognize the long command to comply with the SCPI standard. Some commands are considerably shortened by these optional mnemonics.

Example:

Definition: HCOPy[:IMMediate]

Command: HCOP:IMM is equivalent to HCOP

Optional mnemonics with numeric suffixes

Do not omit an optional mnemonic if it includes a numeric suffix that is relevant for the effect of the command.

Example:

Definition:DISPlay[:WINDow<1...4>]:MAXimize <Boolean>

Command: DISP:MAX ON refers to window 1.

In order to refer to a window other than 1, you must include the optional WINDow parameter with the suffix for the required window.

DISP:WIND2:MAX ON refers to window 2.

Parameters

Parameters must be separated from the header by a "white space". If several parameters are specified in a command, they are separated by a comma (,). For a description of the parameter types, refer to "SCPI Parameters".

Example:

Definition:HCOPy:DEVice:CMAP:COLor:RGB <red>,<green>,<blue>

Command:HCOP:DEV:CMAP:COL:RGB 3,32,44

Special characters

|

Parameters

A vertical stroke in parameter definitions indicates alternative possibilities in the sense of "or". The effect of the command differs, depending on which parameter is used.

Example:

Definition:HCOPy:PAGE:ORIentation LANDscape | PORTrait

Command HCOP:PAGE:ORI LAND specifies landscape orientation

Command HCOP:PAGE:ORI PORT specifies portrait orientation

Mnemonics

A selection of mnemonics with an identical effect exists for several commands. These mnemonics are indicated in the same line; they are separated by a vertical stroke. Only one of these mnemonics needs to be included in the header of the command. The effect of the command is independent of which of the mnemonics is used.

Example:

DefinitionSENSE:BANDwidth|BWIDth[:RESolution] <numeric_value>

The two following commands with identical meaning can be created:

SENS:BAND:RES 1

SENS:BWID:RES 1

[ ]

Mnemonics in square brackets are optional and may be inserted into the header or omitted.

Example: HCOPy[:IMMediate]

HCOP:IMM is equivalent to HCOP

{ }

Parameters in curly brackets are optional and can be inserted once or several times, or omitted.

Example: SENSe:LIST:FREQuency <numeric_value>{,<numeric_value>}

The following are valid commands:

SENS:LIST:FREQ 10

SENS:LIST:FREQ 10,20

SENS:LIST:FREQ 10,20,30,40


SCPI Parameters

Network and Remote Operation > Remote Control Basics > SCPI Command Structure > SCPI Parameters
SCPI Parameters

Many commands are supplemented by a parameter or a list of parameters. The parameters must be separated from the header by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). Allowed parameters are:

  • Numeric values
  • Special numeric values
  • Boolean parameters
  • Text
  • Character strings
  • Block data

The parameters required for each command and the allowed range of values are specified in the command description.

Numeric values

Numeric values can be entered in any form, i.e. with sign, decimal point and exponent. Values exceeding the resolution of the instrument are rounded up or down. The mantissa may comprise up to 255 characters, the exponent must lie inside the value range -32000 to 32000. The exponent is introduced by an "E" or "e". Entry of the exponent alone is not allowed. In the case of physical quantities, the unit can be entered. Allowed unit prefixes are G (giga), MA (mega), MOHM and MHZ are also allowed), K (kilo), M (milli), U (micro) and N (nano). If the unit is missing, the basic unit is used.

Example: SENS:FREQ:STOP 1.5GHz = SENS:FREQ:STOP 1.5E9

Units

For physical quantities, the unit can be entered. Allowed unit prefixes are:

  • G (giga)
  • MA (mega), MOHM, MHZ
  • K (kilo)
  • M (milli)
  • U (micro)
  • N (nano)

If the unit is missing, the basic unit is used.

Example:

SENSe:FREQ:STOP 1.5GHz = SENSe:FREQ:STOP 1.5E9

Some settings allow relative values to be stated in percent. According to SCPI, this unit is represented by the PCT string.

Example:

HCOP:PAGE:SCAL 90PCT

Special numeric values

The texts listed below are interpreted as special numeric values. In the case of a query, the numeric value is provided.

  • MIN/MAX
    MINimum and MAXimum denote the minimum and maximum value.
  • DEF
    DEFault denotes a preset value which has been stored in the EPROM. This value conforms to the default setting, as it is called by the *RST command.
  • UP/DOWN
    UP, DOWN increases or reduces the numeric value by one step. The step width can be specified via an allocated step command for each parameter which can be set via UP, DOWN.
  • INF/NINF
    INFinity, Negative INFinity (NINF) represent the numeric values 9.9E37 or -9.9E37, respectively. INF and NINF are only sent as instrument responses.
  • NAN
    Not A Number (NAN) represents the value 9.91E37. NAN is only sent as a instrument response. This value is not defined. Possible causes are the division of zero by zero, the subtraction of infinite from infinite and the representation of missing values.
Example:

Setting command: SENSe:LIST:FREQ MAXimum

Query: SENS:LIST:FREQ?, Response: 3.5E9

Queries for special numeric values

The numeric values associated to MAXimum/MINimum/DEFault can be queried by adding the corresponding mnemonics to the command. They must be entered following the quotation mark.

Example: SENSe:LIST:FREQ? MAXimum

Returns the maximum numeric value as a result.

Boolean Parameters

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0. The numeric values are provided as the response for a query.

Example:

Setting command: HCOPy:DEV:COL ON

Query: HCOPy:DEV:COL?

Response: 1

Text parameters

Text parameters observe the syntactic rules for mnemonics, i.e. they can be entered using a short or long form. Like any parameter, they have to be separated from the header by a white space. In the case of a query, the short form of the text is provided.

Example:

Setting command: HCOPy:PAGE:ORIentation LANDscape

Query: HCOP:PAGE:ORI?

Response: LAND

Character strings

Strings must always be entered in quotation marks (' or ").

Example:

HCOP:ITEM:LABel "Test1" or HCOP:ITEM:LABel 'Test1'

Block data

Block data is a format which is suitable for the transmission of large amounts of data. A command using a block data parameter has the following structure:

Example:

FORMat:READings:DATA #45168xxxxxxxx

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted.

#0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Overview of Syntax Elements

Network and Remote Operation > Remote Control Basics > SCPI Command Structure > Overview of Syntax Elements
Overview of Syntax Elements

The following table provides an overview of the syntax elements:

:

The colon separates the mnemonics of a command. In a command line the separating semicolon marks the uppermost command level.

;

The semicolon separates two commands of a command line. It does not alter the path.

,

The comma separates several parameters of a command.

?

The question mark forms a query.

*

The asterisk marks a common command.

' '

"

Quotation marks introduce a string and terminate it (both single and double quotation marks are possible).

#

The hash symbol introduces binary, octal, hexadecimal and block data.

  • Binary: #B10110
  • Octal: #O7612
  • Hexa: #HF3A7
  • Block: #21312

A "white space" (ASCII-Code 0 to 9, 11 to 32 decimal, e.g. blank) separates the header from the parameters.


Structure of a command line

Network and Remote Operation > Remote Control Basics > SCPI Command Structure > Structure of a command line
Structure of a command line

A command line may consist of one or several commands. It is terminated by one of the following:

  • a <New Line>
  • a <New Line> with EOI
  • an EOI together with the last data byte

Several commands in a command line must be separated by a semicolon ";". If the next command belongs to a different command system, the semicolon is followed by a colon.

Example:

MMEM:COPY "Test1","MeasurementXY";:HCOP:ITEM ALL

This command line contains two commands. The first command belongs to the MMEM system, the second command belongs to the HCOP system.

If the successive commands belong to the same system, having one or several levels in common, the command line can be abbreviated. To this end, the second command after the semicolon starts with the level that lies below the common levels. The colon following the semicolon must be omitted in this case.

Example:

HCOP:ITEM ALL;:HCOP:IMM

This command line contains two commands. Both commands are part of the HCOP command system, i.e. they have one level in common.

When abbreviating the command line, the second command begins with the level below HCOP. The colon after the semicolon is omitted. The abbreviated form of the command line reads as follows:

HCOP:ITEM ALL;IMM

A new command line always begins with the complete path.

Example:

HCOP:ITEM ALL

HCOP:IMM


Responses to Queries

Network and Remote Operation > Remote Control Basics > SCPI Command Structure > Responses to Queries
Responses to Queries

A query is defined for each setting command unless explicitly specified otherwise. It is formed by adding a question mark to the associated setting command. According to SCPI, the responses to queries are partly subject to stricter rules than in standard IEEE 488.2.

  • The requested parameter is transmitted without a header.
    Example: HCOP:PAGE:ORI?, Response: LAND
  • Maximum values, minimum values and all other quantities that are requested via a special text parameter are returned as numeric values.
    Example: SENSe:FREQuency:STOP? MAX, Response: 3.5E9
  • Numeric values are output without a unit. Physical quantities are referred to the basic units or to the units set using the Unit command. The response 3.5E9 in the previous example stands for 3.5 GHz.
  • Truth values (Boolean values) are returned as 0 (for OFF) and 1 (for ON).
    Example:
    Setting command: HCOPy:DEV:COL ON
    Query: HCOPy:DEV:COL?
    Response: 1
  • Text (character data) is returned in a short form.
    Example:
    Setting command: HCOPy:PAGE:ORIentation LANDscape
    Query: HCOP:PAGE:ORI?
    Response: LAND


Command Sequence and Synchronization

Network and Remote Operation > Remote Control Basics > Command Sequence and Synchronization
Command Sequence and Synchronization

IEEE 488.2 defines a distinction between overlapped and sequential commands:

  • A sequential command is one which finishes executing before the next command starts executing. Commands that are processed quickly are usually implemented as sequential commands.
  • An overlapping command is one which does not automatically finish executing before the next command starts executing. Usually, overlapping commands take longer to process and allow the program to do other tasks while being executed. If overlapping commands do have to be executed in a defined order, e.g. in order to avoid wrong measurement results, they must be serviced sequentially. This is called synchronization between the controller and the instrument.

Setting commands within one command line, even though they may be implemented as sequential commands, are not necessarily serviced in the order in which they have been received. In order to make sure that commands are actually carried out in a certain order, each command must be sent in a separate command line.

Example: Commands and queries in one message

The response to a query combined in a program message with commands that affect the queried value is not predictable.

The following commands always return the specified result:

:FREQ:STAR 1GHZ;SPAN 100;:FREQ:STAR?

Result:

1000000000 (1 GHz)

Whereas the result for the following commands is not specified by SCPI:

:FREQ:STAR 1GHz;STAR?;SPAN 1000000

The result could be the value of STARt before the command was sent since the instrument might defer executing the individual commands until a program message terminator is received. The result could also be 1 GHz if the instrument executes commands as they are received.

As a general rule, send commands and queries in different program messages.

Example: Overlapping command with *OPC

The instrument implements INITiate[:IMMediate] as an overlapped command. Assuming that INITiate[:IMMediate] takes longer to execute than *OPC, sending the following command sequence results in initiating a sweep and, after some time, setting the OPC bit in the ESR:

INIT; *OPC.

Sending the following commands still initiates a sweep:

INIT; *OPC; *CLS

However, since the operation is still pending when the instrument executes *CLS, forcing it into the "Operation Complete Command Idle" State (OCIS), *OPC is effectively skipped. The OPC bit is not set until the instrument executes another *OPC command.

Contents
  • Preventing Overlapping Execution


Preventing Overlapping Execution

Network and Remote Operation > Remote Control Basics > Command Sequence and Synchronization > Preventing Overlapping Execution
Preventing Overlapping Execution

To prevent an overlapping execution of commands, one of the commands *OPC, *OPC? or *WAI can be used. All three commands cause a certain action only to be carried out after the hardware has been set. By suitable programming, the controller can be forced to wait for the corresponding action to occur.

Synchronization using *OPC, *OPC? and *WAI

Command

Action

Programming the controller

*OPC

Sets the Operation Complete bit in the ESR after all previous commands have been executed.

  • Setting bit 0 in the ESE
  • Setting bit 5 in the SRE
  • Waiting for service request (SRQ)

*OPC?

Stops command processing until 1 is returned. This is only the case after the Operation Complete bit has been set in the ESR. This bit indicates that the previous setting has been completed.

Sending *OPC? directly after the command whose processing should be terminated before other commands can be executed.

*WAI

Stops further command processing until all commands sent before *WAI have been executed.

Sending *WAI directly after the command whose processing should be terminated before other commands are executed.

Command synchronization using *WAI or *OPC? appended to an overlapped command is a good choice if the overlapped command takes only little time to process. The two synchronization techniques simply block overlapped execution of the command.

For time consuming overlapped commands it is usually desirable to allow the controller or the instrument to do other useful work while waiting for command execution. Use one of the following methods:

*OPC with a service request

  1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

  2. Set bit no. 5 in the SRE: *SRE 32 to enable ESB service request.

  3. Send the overlapped command with *OPC

  4. Wait for a service request

    The service request indicates that the overlapped command has finished.

*OPC? with a service request

  1. Set bit no. 4 in the SRE: *SRE 16 to enable MAV service request.

  2. Send the overlapped command with *OPC?

  3. Wait for a service request

    The service request indicates that the overlapped command has finished.

Event Status Register (ESE)

  1. Set the OPC mask bit (bit no. 0) in the ESE: *ESE 1

  2. Send the overlapped command without *OPC, *OPC? or *WAI

  3. Poll the operation complete state periodically (by means of a timer) using the sequence: *OPC; *ESR?

    A return value (LSB) of 1 indicates that the overlapped command has finished.

*OPC? with short timeout

  1. Send the overlapped command without *OPC, *OPC? or *WAI

  2. Poll the operation complete state periodically (by means of a timer) using the sequence: <short timeout>; *OPC?

  3. A return value (LSB) of 1 indicates that the overlapped command has finished. In case of a timeout, the operation is ongoing.

  4. Reset timeout to former value

  5. Clear the error queue with SYStem:ERRor? to remove the "-410, Query interrupted" entries.

Using several threads in the controller application

As an alternative, provided the programming environment of the controller application supports threads, separate threads can be used for the application GUI and for controlling the instrument(s) via SCPI.

A thread waiting for a *OPC? thus will not block the GUI or the communication with other instruments.


Status Reporting System

Network and Remote Operation > Remote Control Basics > Status Reporting System
Status Reporting System

The status reporting system stores all information on the current operating state of the instrument, and on errors which have occurred. This information is stored in the status registers and in the error queue. Both can be queried via GPIB bus or LAN interface (STATus... commands, see "Using the Status Register").

Contents
  • Hierarchy of Status Registers
  • Structure of a SCPI Status Register
  • Contents of the Status Registers
  • Application of the Status Reporting System
  • Reset Values of the Status Reporting System


Hierarchy of Status Registers

Network and Remote Operation > Remote Control Basics > Status Reporting System > Hierarchy of Status Registers
Hierarchy of Status Registers

As shown in the following figure, the status information is of hierarchical structure.

Graphical overview of the R&S FSW status registers hierarchy
  • STB, SRE
    The STatus Byte (STB) register and its associated mask register Service Request Enable (SRE) form the highest level of the status reporting system. The STB provides a rough overview of the instrument status, collecting the information of the lower-level registers.
  • ESR, SCPI registers
    The STB receives its information from the following registers:
    – The Event Status Register (ESR) with the associated mask register standard Event Status Enable (ESE).
    – The STATus:OPERation and STATus:QUEStionable registers which are defined by SCPI and contain detailed information on the instrument.
  • IST, PPE
    The IST flag ("Individual STatus"), like the SRQ, combines the entire instrument status in a single bit. The PPE fulfills the same function for the IST flag as the SRE for the service request.
  • Output buffer
    The output buffer contains the messages the instrument returns to the controller. It is not part of the status reporting system but determines the value of the MAV bit in the STB and thus is represented in the overview.

All status registers have the same internal structure.

SRE, ESE

The service request enable register SRE can be used as ENABle part of the STB if the STB is structured according to SCPI. By analogy, the ESE can be used as the ENABle part of the ESR.


Structure of a SCPI Status Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Structure of a SCPI Status Register
Structure of a SCPI Status Register

Each standard SCPI register consists of 5 parts. Each part has a width of 16 bits and has different functions. The individual bits are independent of each other, i.e. each hardware status is assigned a bit number which is valid for all five parts. Bit 15 (the most significant bit) is set to zero for all parts. Thus the contents of the register parts can be processed by the controller as positive integers.

The status-register model
Description of the five status register parts

The five parts of a SCPI register have different properties and functions:

  • CONDition
    The CONDition part is written into directly by the hardware or the sum bit of the next lower register. Its contents reflect the current instrument status. This register part can only be read, but not written into or cleared. Its contents are not affected by reading.
  • PTRansition / NTRansition
    The two transition register parts define which state transition of the CONDition part (none, 0 to 1, 1 to 0 or both) is stored in the EVENt part.
    The Positive-TRansition part acts as a transition filter. When a bit of the CONDition part is changed from 0 to 1, the associated PTR bit decides whether the EVENt bit is set to 1.
    – PTR bit =1: the EVENt bit is set.
    – PTR bit =0: the EVENt bit is not set.

    This part can be written into and read as required. Its contents are not affected by reading.
    The Negative-TRansition part also acts as a transition filter. When a bit of the CONDition part is changed from 1 to 0, the associated NTR bit decides whether the EVENt bit is set to 1.
    – NTR bit =1: the EVENt bit is set.
    – NTR bit =0: the EVENt bit is not set.

    This part can be written into and read as required. Its contents are not affected by reading.
  • EVENt
    The EVENt part indicates whether an event has occurred since the last reading, it is the "memory" of the condition part. It only indicates events passed on by the transition filters. It is permanently updated by the instrument. This part can only be read by the user. Reading the register clears it. This part is often equated with the entire register.
  • ENABle
    The ENABle part determines whether the associated EVENt bit contributes to the sum bit (see below). Each bit of the EVENt part is "ANDed" with the associated ENABle bit (symbol '&'). The results of all logical operations of this part are passed on to the sum bit via an "OR" function (symbol '+').
    ENABle bit = 0: the associated EVENt bit does not contribute to the sum bit
    ENABle bit = 1: if the associated EVENt bit is "1", the sum bit is set to "1" as well.
    This part can be written into and read by the user as required. Its contents are not affected by reading.
Sum bit

The sum bit is obtained from the EVENt and ENABle part for each register. The result is then entered into a bit of the CONDition part of the higher-order register.

The instrument automatically generates the sum bit for each register. Thus an event can lead to a service request throughout all levels of the hierarchy.


Contents of the Status Registers

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers
Contents of the Status Registers

In the following sections, the contents of the status registers are described in more detail.

STATus:QUEStionable:DIQ register

The STATus:QUEStionable:DIQ register is used for digital I/Q data from the optional Digital Baseband Interface (R&S FSW-B17) and is described in "STATus:QUEStionable:DIQ Register" .

STATus:QUEStionable:SYNC register

The STATus:QUEStionable:SYNC register is used by the R&S FSW applications and is described in the individual sections (manuals) for each application.

Contents
  • Status Byte (STB) and Service Request Enable Register (SRE)
  • IST Flag and Parallel Poll Enable Register (PPE)
  • Event Status Register (ESR) and Event Status Enable Register (ESE)
  • STATus:OPERation Register
  • STATus:QUEStionable Register
  • STATus:QUEStionable:ACPLimit Register
  • STATus:QUEStionable:EXTended Register
  • STATus:QUEStionable:EXTended:INFO Register
  • STATus:QUEStionable:FREQuency Register
  • STATus:QUEStionable:LIMit Register
  • STATus:QUEStionable:LMARgin Register
  • STATus:QUEStionable:POWer Register
  • STATus:QUEStionable:TEMPerature Register
  • STATus:QUEStionable:TIMe Register


Status Byte (STB) and Service Request Enable Register (SRE)

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > Status Byte (STB) and Service Request Enable Register (SRE)
Status Byte (STB) and Service Request Enable Register (SRE)

The STatus Byte (STB) is already defined in IEEE 488.2. It provides a rough overview of the instrument status by collecting the pieces of information of the lower registers. A special feature is that bit 6 acts as the sum bit of the remaining bits of the status byte.

The STB can thus be compared with the CONDition part of an SCPI register and assumes the highest level within the SCPI hierarchy.

The STB is read using the command *STB? or a serial poll.

The STatus Byte (STB) is linked to the Service Request Enable (SRE) register. Each bit of the STB is assigned a bit in the SRE. Bit 6 of the SRE is ignored. If a bit is set in the SRE and the associated bit in the STB changes from 0 to 1, a service request (SRQ) is generated. The SRE can be set using the command *SRE and read using the command *SRE?.

Meaning of the bits used in the status byte
Bit No. | Meaning
0...1 | Not used
2 | Error Queue not empty The bit is set when an entry is made in the error queue. If this bit is enabled by the SRE, each entry of the error queue generates a service request. Thus an error can be recognized and specified in greater detail by polling the error queue. The poll provides an informative error message. This procedure is to be recommended since it considerably reduces the problems involved with remote control.
3 | QUEStionable status register summary bit The bit is set if an EVENt bit is set in the QUEStionable status register and the associated ENABle bit is set to 1. A set bit indicates a questionable instrument status, which can be specified in greater detail by querying the STATus:QUEStionable status register.
4 | MAV bit (message available) The bit is set if a message is available in the output queue which can be read. This bit can be used to enable data to be automatically read from the instrument to the controller.
5 | ESB bit Sum bit of the event status register. It is set if one of the bits in the event status register is set and enabled in the event status enable register. Setting of this bit indicates a serious error which can be specified in greater detail by polling the event status register.
6 | MSS bit (master status summary bit) The bit is set if the instrument triggers a service request. This is the case if one of the other bits of this registers is set together with its mask bit in the service request enable register SRE.
7 | STATus:OPERation status register summary bit The bit is set if an EVENt bit is set in the OPERation status register and the associated ENABle bit is set to 1. A set bit indicates that the instrument is just performing an action. The type of action can be determined by querying the STATus:OPERation status register.


IST Flag and Parallel Poll Enable Register (PPE)

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > IST Flag and Parallel Poll Enable Register (PPE)
IST Flag and Parallel Poll Enable Register (PPE)

As with the SRQ, the IST flag combines the entire status information in a single bit. It can be read by means of a parallel poll (see "Parallel Poll") or using the command *IST?.

The parallel poll enable register (PPE) determines which bits of the STB contribute to the IST flag. The bits of the STB are "ANDed" with the corresponding bits of the PPE, with bit 6 being used as well in contrast to the SRE. The IST flag results from the "ORing" of all results. The PPE can be set using commands *PRE and read using command *PRE?.


Event Status Register (ESR) and Event Status Enable Register (ESE)

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > Event Status Register (ESR) and Event Status Enable Register (ESE)
Event Status Register (ESR) and Event Status Enable Register (ESE)

The ESR is defined in IEEE 488.2. It can be compared with the EVENt part of a SCPI register. The event status register can be read out using command *ESR?.

The ESE corresponds to the ENABle part of a SCPI register. If a bit is set in the ESE and the associated bit in the ESR changes from 0 to 1, the ESB bit in the STB is set. The ESE register can be set using the command *ESE and read using the command *ESE?.

Meaning of the bits used in the event status register
Bit No. | Meaning
0 | Operation Complete This bit is set on receipt of the command *OPC exactly when all previous commands have been executed.
1 | Not used
2 | Query Error This bit is set if either the controller wants to read data from the instrument without having sent a query, or if it does not fetch requested data and sends new instructions to the instrument instead. The cause is often a query which is faulty and hence cannot be executed.
3 | Device-dependent Error This bit is set if a device-dependent error occurs. An error message with a number between -300 and -399 or a positive error number, which denotes the error in greater detail, is entered into the error queue.
4 | Execution Error This bit is set if a received command is syntactically correct but cannot be performed for other reasons. An error message with a number between -200 and -300, which denotes the error in greater detail, is entered into the error queue.
5 | Command Error This bit is set if a command is received, which is undefined or syntactically incorrect. An error message with a number between -100 and -200, which denotes the error in greater detail, is entered into the error queue.
6 | User Request This bit is set when the instrument is switched over to manual control.
7 | Power On (supply voltage on) This bit is set on switching on the instrument.


STATus:OPERation Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:OPERation Register
STATus:OPERation Register

The STATus:OPERation register contains information on current activities of the R&S FSW. It also contains information on activities that have been executed since the last read out.

You can read out the register with STATus:​OPERation:​CONDition? or STATus:​OPERation[:​EVENt]?.

Meaning of the bits used in the STATus:OPERation register

Bit No.

Meaning

0

CALibrating

This bit is set as long as the instrument is performing a calibration.

1-2

Not used

3

SWEeping

Sweep is being performed in base unit (applications are not considered); identical to bit 4

In applications, this bit is not used.

4

MEASuring

Measurement is being performed in base unit (applications are not considered); identical to bit 3

In applications, this bit is not used.

5

Waiting for TRIgger

Instrument is ready to trigger and waiting for trigger signal.

6-7

Not used

8

HardCOPy in progress

This bit is set while the instrument is printing a hardcopy.

9

For data acquisition in MSRA/MSRT mode only:

Multi-Standard capture finish

This bit is set if a data acquisition measurement was completed successfully in MSRA/MSRT operating mode and data is available for evaluation.

For details on the MSRA operating mode see "Welcome to the MSRA Operating Mode" . For details on the MSRT operating mode see "Welcome to the Realtime Extension" .

10

Range completed

This bit is set when a range in the sweep list has been completed if "Stop after Range" has been activated.

11-14

Not used

15

This bit is always 0.


STATus:QUEStionable Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable Register
STATus:QUEStionable Register

The STATus:QUEStionable register contains information on instrument states that do not meet the specifications.

The STAT:QUES:SYNC register is used by the applications and is thus described in the individual applications' User Manuals.

You can read out the register with STAT:QUES:COND or STAT:QUES:EVEN.

The STATus:QUEStionable register "sums up" the information from all subregisters (e.g. bit 2 sums up the information for all STATus:QUEStionable:TIMe registers). For some subregisters, there may be separate registers for each active channel. Thus, if a status bit in the STATus:QUEStionable register indicates an error, the error may have occurred in any of the channel-specific subregisters. In this case, you must check the subregister of each channel to determine which channel caused the error. By default, querying the status of a subregister always returns the result for the currently selected channel.

Meaning of the bits used in the STATus:QUEStionable register

Bit No.

Meaning

0 - 1

Unused

2

TIMe

This bit is set if a time error occurs in any of the active channels.

The "STATus:QUEStionable:TIMe Register" provides more information on the error type.

3

POWer

This bit is set if the measured power level in any of the active channels is questionable.

The "STATus:QUEStionable:POWer Register" provides more information on the error type.

4

TEMPerature

This bit is set if the temperature is questionable.

5

FREQuency

This bit is set if there is anything wrong with the frequency of the local oscillator or the reference frequency in any of the active channels.

The "STATus:QUEStionable:FREQuency Register" provides more information on the error type.

6 - 7

Unused

8

CALibration

This bit is set if the R&S FSW is unaligned ("UNCAL" display)

9

LIMit (device-specific)

This bit is set if a limit value is violated in any of the active channels in any window.

The "STATus:QUEStionable:LIMit Register" provides more information on the error type.

10

LMARgin (device-specific)

This bit is set if a margin is violated in any of the active channels in any window.

The "STATus:QUEStionable:LMARgin Register" provides more information on the error type.

11

SYNC (device-specific)

This bit is set if the R&S FSW is not synchronized to the signal that is applied.

The R&S FSW is not synchronized if:

  • it cannot synchronize to midamble during a measurement or premeasurement
  • it cannot find a burst during a measurement or premeasurement
  • the results deviate too much from the expected value during premeasurements

12

ACPLimit (device-specific)

This bit is set if a limit during ACLR measurements is violated in any of the active channels.

The "STATus:QUEStionable:ACPLimit Register" provides more information on the error type.

13

Unused

14

Digital I/Q (device-specific)

This bit is set if a connection error occurs at the Digital Baseband Interface (R&S FSW-B17)

(See "Digital Input" )

15

This bit is always 0.


STATus:QUEStionable:ACPLimit Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:ACPLimit Register
STATus:QUEStionable:ACPLimit Register

The STATus:QUEStionable:ACPLimit register contains information about the results of a limit check during ACLR measurements. A separate ACPLimit register exists for each active channel.

You can read out the register withSTATus:​QUEStionable:​ACPLimit:​CONDition? or STATus:​QUEStionable:​ACPLimit[:​EVENt]?

Meaning of the bits used in the STATus:QUEStionable:ACPLimit register
Bit No. | Meaning
0 | ADJ UPPer FAIL This bit is set if the limit is exceeded in the upper adjacent channel
1 | ADJ LOWer FAIL This bit is set if the limit is exceeded in the lower adjacent channel.
2 | ALT1 UPPer FAIL This bit is set if the limit is exceeded in the upper 1st alternate channel.
3 | ALT1 LOWer FAIL This bit is set if the limit is exceeded in the lower 1st alternate channel.
4 | ALT2 UPPer FAIL This bit is set if the limit is exceeded in the upper 2nd alternate channel.
5 | ALT2 LOWer FAIL This bit is set if the limit is exceeded in the lower 2nd alternate channel.
6 | ALT3 … 11 LOWer/UPPer FAIL This bit is set if the limit is exceeded in one of the lower or upper alternate channels 3 … 11.
7 | CACLR FAIL This bit is set if the limit is exceeded in one of the gap (CACLR) channels.
8 to 14 | Unused
15 | This bit is always 0.


STATus:QUEStionable:EXTended Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:EXTended Register
STATus:QUEStionable:EXTended Register

The STATus:QUEStionable:EXTended register contains further status information not covered by the other status registers of the R&S FSW. A separate EXTended register exists for each active channel.

You can read out the register with STATus:​QUEStionable:​EXTended:​CONDition? or STATus:​QUEStionable:​EXTended[:​EVENt]?

Meaning of the bits used in the STATus:QUEStionable:EXTended register
Bit No. | Meaning
0 | not used
1 | INFO This bit is set if a status message is available for the application. Which type of message occurred is indicated in the "STATus:QUEStionable:EXTended:INFO Register".
2 to 14 | Unused
15 | This bit is always 0.


STATus:QUEStionable:EXTended:INFO Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:EXTended:INFO Register
STATus:QUEStionable:EXTended:INFO Register

The STATus:QUEStionable:EXTended:INFO register contains information on the type of messages that occur during operation of the R&S FSW. A separate INFO register exists for each active channel.

You can read out the register with STATus:​QUEStionable:​EXTended:​INFO:​CONDition? or STATus:​QUEStionable:​EXTended:​INFO[:​EVENt]?. You can query all messages that occur for a specific channel using the command SYSTem:​ERRor:​EXTended?.

Meaning of the bits used in the STATus:QUEStionable:EXTended:INFO register
Bit No. | Meaning
0 | MESSage This bit is set if event or state has occurred that may lead to an error during further operation.
1 | INFO This bit is set if an informational status message is available for the application.
2 | WARNing This bit is set if an irregular situation occurs during measurement, e.g. the settings no longer match the displayed results, or the connection to an external device was interrupted temporarily.
3 | ERRor This bit is set if an error occurs during a measurement, e.g. due to missing data or wrong settings, so that the measurement cannot be completed correctly.
4 | FATal This bit is set if a serious error occurs in the application and regular operation is no longer possible.
5 to 14 | Unused
15 | This bit is always 0.


STATus:QUEStionable:FREQuency Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:FREQuency Register
STATus:QUEStionable:FREQuency Register

The STATus:QUEStionable:FREQuency register contains information about the condition of the local oscillator and the reference frequency. A separate frequency register exists for each active channel.

You can read out the register with STATus:​QUEStionable:​FREQuency:​CONDition? or STATus:​QUEStionable:​FREQuency[:​EVENt]?.

Meaning of the bits used in the STATus:QUEStionable:FREQuency register
Bit No. | Meaning
0 | OVEN COLD This bit is set if the reference oscillator has not yet attained its operating temperature. "OCXO" is displayed.
1 | LO UNLocked This bit is set if the local oscillator no longer locks. "LOUNL" is displayed.
2 to 7 | Not used
8 | EXTernalREFerence This bit is set if you have selected an external reference oscillator but did not connect a useable external reference source. In that case the synthesizer can not lock. The frequency in all probability is not accurate.
9 to 14 | Not used
15 | This bit is always 0.


STATus:QUEStionable:LIMit Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:LIMit Register
STATus:QUEStionable:LIMit Register

The STATus:QUEStionable:LIMit register contains information about the results of a limit check when you are working with limit lines.

A separate LIMit register exists for each active channel and for each window.

You can read out the register with STATus:​QUEStionable:​LIMit<n>:​CONDition? or STATus:​QUEStionable:​LIMit<n>[:​EVENt]?.

Meaning of the bits used in the STATus:QUEStionable:LIMit register
Bit No. | Meaning
0 | LIMit 1 FAIL This bit is set if limit line 1 is violated.
1 | LIMit 2 FAIL This bit is set if limit line 2 is violated.
2 | LIMit 3 FAIL This bit is set if limit line 3 is violated.
3 | LIMit 4 FAIL This bit is set if limit line 4 is violated.
4 | LIMit 5 FAIL This bit is set if limit line 5 is violated.
5 | LIMit 6 FAIL This bit is set if limit line 6 is violated.
6 | LIMit 7 FAIL This bit is set if limit line 7 is violated.
7 | LIMit 8 FAIL This bit is set if limit line 8 is violated.
8 to 14 | Unused
15 | This bit is always 0.


STATus:QUEStionable:LMARgin Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:LMARgin Register
STATus:QUEStionable:LMARgin Register

This register contains information about the observance of limit margins.

A separate LMARgin register exists for each active channel and for each window.

It can be read using the commands STATus:QUEStionable:LMARgin:CONDition? and STATus:QUEStionable:LMARgin[:EVENt]?.

Meaning of the bits used in the STATus:QUEStionable:LMARgin register
Bit No. | Meaning
0 | LMARgin 1 FAIL This bit is set if limit margin 1 is violated.
1 | LMARgin 2 FAIL This bit is set if limit margin 2 is violated.
2 | LMARgin 3 FAIL This bit is set if limit margin 3 is violated.
3 | LMARgin 4 FAIL This bit is set if limit margin 4 is violated.
4 | LMARgin 5 FAIL This bit is set if limit margin 5 is violated.
5 | LMARgin 6 FAIL This bit is set if limit margin 6 is violated.
6 | LMARgin 7 FAIL This bit is set if limit margin 7 is violated.
7 | LMARgin 8 FAIL This bit is set if limit margin 8 is violated.
8 to 14 | Not used
15 | This bit is always 0.


STATus:QUEStionable:POWer Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:POWer Register
STATus:QUEStionable:POWer Register

The STATus:QUEStionable:POWer register contains information about possible overload situations that may occur during operation of the R&S FSW. A separate power register exists for each active channel.

You can read out the register with STATus:​QUEStionable:​POWer:​CONDition? or STATus:​QUEStionable:​POWer[:​EVENt]?

Meaning of the bits used in the STATus:QUEStionable:POWer register
Bit No. | Meaning
0 | OVERload This bit is set if an overload occurs at the RF input, causing signal distortion but not yet causing damage to the device. The R&S FSW displays the keyword "RF OVLD".
1 | UNDerload This bit is set if an underload occurs at the RF input. The R&S FSW displays the keyword "UNLD".
2 | IF_OVerload This bit is set if an overload occurs in the IF path. The R&S FSW displays the keyword "IF OVLD".
3 | Input Overload This bit is set if the signal level at the RF input connector exceeds the maximum. The RF input is disconnected from the input mixer to protect the device. In order to re-enable measurement, decrease the level at the RF input connector and reconnect the RF input to the mixer input. (See "RF Input Protection" or INPut:​ATTenuation:​PROTection:​RESet) The R&S FSW displays the keyword "INPUT OVLD".
4 to 14 | Unused
15 | This bit is always 0.


STATus:QUEStionable:TEMPerature Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:TEMPerature Register
STATus:QUEStionable:TEMPerature Register

The STATus:QUEStionable:TEMPerature register contains information about possible temperature deviations that may occur during operation of the R&S FSW. A separate temperature register exists for each active channel.

You can read out the register with STATus:​QUEStionable:​TEMPerature:​CONDition? or STATus:​QUEStionable:​TEMPerature[:​EVENt]?

Meaning of the bits used in the STATus:QUEStionable:TEMPerature register
Bit No. | Meaning
0 | This bit is set if the frontend temperature sensor deviates by a certain degree from the self-alignment temperature. During warmup, this bit is always 0. For details see "Temperature check".
1 to 14 | Unused
15 | This bit is always 0.


STATus:QUEStionable:TIMe Register

Network and Remote Operation > Remote Control Basics > Status Reporting System > Contents of the Status Registers > STATus:QUEStionable:TIMe Register
STATus:QUEStionable:TIMe Register

The STATus:QUEStionable:TIMe register contains information about possible time errors that may occur during operation of the R&S FSW. A separate time register exists for each active channel.

You can read out the register with STATus:​QUEStionable:​TIME:​CONDition? or STATus:​QUEStionable:​TIME[:​EVENt]?

Meaning of the bits used in the STATus:QUEStionable:TIMe register
Bit No. | Meaning
0 | not used
1 | Sweep time too low This bit is set if the sweep time is too low and thus calibration fails. Note: the STATus:QUEStionable bit for CALibration is not affected by this error.
2 to 14 | Unused
15 | This bit is always 0.


Application of the Status Reporting System

Network and Remote Operation > Remote Control Basics > Status Reporting System > Application of the Status Reporting System
Application of the Status Reporting System

The purpose of the status reporting system is to monitor the status of one or several devices in a measuring system. To do this and react appropriately, the controller must receive and evaluate the information of all devices. The following standard methods are used:

  • Service request (SRQ) initiated by the instrument
  • Serial poll of all devices in the bus system, initiated by the controller in order to find out who sent a SRQ and why
  • Parallel poll of all devices
  • Query of a specific instrument status by means of commands
  • Query of the error queue
Contents
  • Service Request
  • Serial Poll
  • Parallel Poll
  • Query of an instrument status
  • Error Queue


Service Request

Network and Remote Operation > Remote Control Basics > Status Reporting System > Application of the Status Reporting System > Service Request
Service Request

Under certain circumstances, the instrument can send a service request (SRQ) to the controller. Usually this service request initiates an interrupt at the controller, to which the control program can react appropriately. As evident from figure "Graphical overview of the R&S FSW status registers hierarchy", an SRQ is always initiated if one or several of bits 2, 3, 4, 5 or 7 of the status byte are set and enabled in the SRE. Each of these bits combines the information of a further register, the error queue or the output buffer. The ENABle parts of the status registers can be set such that arbitrary bits in an arbitrary status register initiate an SRQ. In order to make use of the possibilities of the service request effectively, all bits should be set to "1" in enable registers SRE and ESE.

Use of the command *OPC to generate an SRQ at the end of a sweep

  1. CALL InstrWrite(analyzer, "*ESE 1") 'Set bit 0 in the ESE (Operation Complete)

  2. CALL InstrWrite(analyzer, "*SRE 32") 'Set bit 5 in the SRE (ESB)

  3. CALL InstrWrite(analyzer, "*INIT;*OPC") ' Generate an SRQ after operation complete

    After its settings have been completed, the instrument generates an SRQ.

The SRQ is the only possibility for the instrument to become active on its own. Each controller program should cause the instrument to initiate a service request if errors occur. The program should react appropriately to the service request.

A detailed example for a service request routine can be found in "Service Request".


Serial Poll

Network and Remote Operation > Remote Control Basics > Status Reporting System > Application of the Status Reporting System > Serial Poll
Serial Poll

In a serial poll, just as with command *STB, the status byte of an instrument is queried. However, the query is realized via interface messages and is thus clearly faster.

The serial poll method is defined in IEEE 488.1 and used to be the only standard possibility for different instruments to poll the status byte. The method also works for instruments which do not adhere to SCPI or IEEE 488.2.

The serial poll is mainly used to obtain a fast overview of the state of several instruments connected to the controller.


Parallel Poll

Network and Remote Operation > Remote Control Basics > Status Reporting System > Application of the Status Reporting System > Parallel Poll
Parallel Poll

In a parallel poll, up to eight instruments are simultaneously requested by the controller using a single command to transmit 1 bit of information each on the data lines, i.e., to set the data line allocated to each instrument to a logical "0" or "1".

In addition to the SRE register, which determines the conditions under which an SRQ is generated, there is a Parallel Poll Enable register (PPE) which is ANDed with the STB bit by bit, considering bit 6 as well. This register is ANDed with the STB bit by bit, considering bit 6 as well. The results are ORed, the result is possibly inverted and then sent as a response to the parallel poll of the controller. The result can also be queried without parallel poll using the command *IST?.

The instrument first has to be set for the parallel poll using the command PPC. This command allocates a data line to the instrument and determines whether the response is to be inverted. The parallel poll itself is executed using PPE.

The parallel poll method is mainly used to find out quickly which one of the instruments connected to the controller has sent a service request. To this effect, SRE and PPE must be set to the same value.


Query of an instrument status

Network and Remote Operation > Remote Control Basics > Status Reporting System > Application of the Status Reporting System > Query of an instrument status
Query of an instrument status

Each part of any status register can be read using queries. There are two types of commands:

  • The common commands *ESR?, *IDN?, *IST?, *STB? query the higher-level registers.
  • The commands of the STATus system query the SCPI registers (STATus:QUEStionable...)

The returned value is always a decimal number that represents the bit pattern of the queried register. This number is evaluated by the controller program.

Queries are usually used after an SRQ in order to obtain more detailed information on the cause of the SRQ.

Contents
  • Decimal representation of a bit pattern


Decimal representation of a bit pattern

Network and Remote Operation > Remote Control Basics > Status Reporting System > Application of the Status Reporting System > Query of an instrument status > Decimal representation of a bit pattern
Decimal representation of a bit pattern

The STB and ESR registers contain 8 bits, the SCPI registers 16 bits. The contents of a status register are specified and transferred as a single decimal number. To make this possible, each bit is assigned a weighted value. The decimal number is calculated as the sum of the weighted values of all bits in the register that are set to 1.

Example:

The decimal value 40 = 32 + 8 indicates that bits no. 3 and 5 in the status register (e.g. the QUEStionable status summary bit and the ESB bit in the STatus Byte ) are set.


Error Queue

Network and Remote Operation > Remote Control Basics > Status Reporting System > Application of the Status Reporting System > Error Queue
Error Queue

Each error state in the instrument leads to an entry in the error queue. The entries of the error queue are detailed plain text error messages that can be looked up in the Error Log or queried via remote control using SYSTem:ERRor[:NEXT]? or SYSTem:ERRor:ALL?. Each call of SYSTem:ERRor[:NEXT]? provides one entry from the error queue. If no error messages are stored there any more, the instrument responds with 0, "No error".

The error queue should be queried after every SRQ in the controller program as the entries describe the cause of an error more precisely than the status registers. Especially in the test phase of a controller program the error queue should be queried regularly since faulty commands from the controller to the instrument are recorded there as well.


Reset Values of the Status Reporting System

Network and Remote Operation > Remote Control Basics > Status Reporting System > Reset Values of the Status Reporting System
Reset Values of the Status Reporting System

The following table contains the different commands and events causing the status reporting system to be reset. None of the commands, except *RST and SYSTem:PRESet, influence the functional instrument settings. In particular, DCL does not change the instrument settings.

Resetting the status reporting system
Event | Switching on supply voltage Power-On-Status-Clear |  | DCL, SDC (Device Clear, Selected Device Clear) | *RST or SYSTem:PRESet | STATus:PRESet | *CLS
Effect | 0 | 1
Clear STB, ESR | - | yes | - | - | - | yes
Clear SRE, ESE | - | yes | - | - | - | -
Clear PPE | - | yes | - | - | - | -
Clear EVENt parts of the registers | - | yes | - | - | - | yes
Clear ENABle parts of all OPERation and QUEStionable registers; Fill ENABle parts of all other registers with "1". | - | yes | - | - | yes | -
Fill PTRansition parts with "1"; Clear NTRansition parts | - | yes | - | - | yes | -
Clear error queue | yes | yes | - | - | - | yes
Clear output buffer | yes | yes | yes | 1) | 1) | 1)
Clear command processing and input buffer | yes | yes | yes | - | - | -
1) The first command in a command line that immediately follows a <PROGRAM MESSAGE TERMINATOR> clears the output buffer.


General Programming Recommendations

Network and Remote Operation > Remote Control Basics > General Programming Recommendations
General Programming Recommendations
Initial instrument status before changing settings

Manual operation is designed for maximum possible operating convenience. In contrast, the priority of remote control is the "predictability" of the instrument status. Thus, when a command attempts to define incompatible settings, the command is ignored and the instrument status remains unchanged, i.e. other settings are not automatically adapted. Therefore, control programs should always define an initial instrument status (e.g. using the *RST command) and then implement the required settings.

Command sequence

As a general rule, send commands and queries in different program messages. Otherwise, the result of the query may vary depending on which operation is performed first (see also "Preventing Overlapping Execution").

Reacting to malfunctions

The service request is the only possibility for the instrument to become active on its own. Each controller program should instruct the instrument to initiate a service request in case of malfunction. The program should react appropriately to the service request.

Error queues

The error queue should be queried after every service request in the controller program as the entries describe the cause of an error more precisely than the status registers. Especially in the test phase of a controller program the error queue should be queried regularly since faulty commands from the controller to the instrument are recorded there as well.


GPIB Languages

Network and Remote Operation > GPIB Languages
GPIB Languages

The R&S FSW analyzer family supports a subset of the GPIB commands used by other devices. Thus it can emulate other devices in order to use existing remote control programs.

The device model to be emulated is selected manually using "SETUP > Network + Remote > GPIB tab > Language". Via the GPIB interface using the SYSTem:​LANGuage command.

In order to emulate device models that are not part of the selection list of the GPIB "Language" setting, you can modify the identification string received in response to the ID command ("Identification String" setting). Thus, any device model whose command set is compatible with one of the supported device models can be emulated.

Supported languages
Language | Comment
SCPI |
71100C | Compatible to 8566A/B
71200C | Compatible to 8566A/B
71209A | Compatible to 8566A/B
8560E |
8561E |
8562E |
8563E |
8564E |
8565E |
8566A | Command sets A and B are available. Command sets A and B differ in the rules regarding the command structure.
8566B |
8568A | Command sets A and B are available. Command sets A and B differ in the rules regarding the command structure.
8568A_DC | Uses DC input coupling by default if supported by the instrument
8568B | Command sets A and B are available. Command sets A and B differ in the rules regarding the command structure.
8568B_DC | Uses DC input coupling by default if supported by the instrument
8591E | Compatible to 8594E
8594E | Command sets A and B are available. Command sets A and B differ in the rules regarding the command structure.
FSEA |
FSEB |
FSEM |
FSEK |
PSA89600 |

Notes:

  • If you select a language other than "SCPI", the GPIB address is set to 18 if it was 20 before.
  • The Start/stop frequency, reference level and number of sweep points are adapted to the selected instrument model.
  • When you switch between remote control languages, the following settings or changes are made:
    SCPI:
    The instrument performs a PRESET.
    8566A/B, 8568A/B, 8594E; FSEA, FSEB, FSEM; FSEK:
    – The instrument performs a PRESET.
    – The following instrument settings are changed:
Instrument settings for emulation of 8566A/B, 8568A/B, 8594E; FSEA, FSEB, FSEM; FSEK instruments
Model | # of Trace Points | Start Freq. | Stop Freq. | Ref Level | Input Coupling
8566A/B | 1001 | 2 GHz | 22 GHz | 0 dBm | AC
8568A/B | 1001 | 0 Hz | 1.5 GHz | 0 dBm | AC
8560E | 601 | 0 Hz | 2.9 GHz | 0 dBm | AC
8561E | 601 | 0 Hz | 6.5 GHz | 0 dBm | AC
8562E | 601 | 0 Hz | 13.2 GHz | 0 dBm | AC
8563E | 601 | 0 Hz | 26.5 GHz | 0 dBm | AC
8564E | 601 | 0 Hz | 40 GHz | 0 dBm | AC
8565E | 601 | 0 Hz | 50 GHz | 0 dBm | AC
8594E | 401 | 0 Hz | 3 GHz | 0 dBm | AC
FSEA | 500 | 0 Hz | 3.5 GHz | -20 dBm | AC
FSEB | 500 | 0 Hz | 7 GHz | -20 dBm | AC
FSEM | 500 | 0 Hz | 26.5 GHz | -20 dBm | AC
FSEK | 500 | 0 Hz | 40 GHz | -20 dBm | AC

Note: The stop frequency indicated in the table may be limited to the corresponding frequency of the R&S FSW, if required.


The IECWIN Tool

Network and Remote Operation > The IECWIN Tool
The IECWIN Tool

The R&S FSW is delivered with IECWIN installed, an auxiliary tool provided free of charge by R&S. IECWIN is a program to send SCPI commands to a measuring instrument either interactively or from a command script.

The R&S IECWIN32 tool is provided free of charge. The functionality may change in a future version without notice.

IECWIN offers the following features:
  • Connection to instrument via several interfaces/protocols (GPIB, VISA, named pipe (if IECWIN is run on the instrument itself), RSIB)
  • Interactive command entry
  • Browsing available commands on the instrument
  • Error checking following every command
  • Execution of command scripts
  • Storing binary data to a file
  • Reading binary data from a file
  • Generation of a log file
For command scripts, IECWIN offers the following features:
  • Synchronization with the instrument on every command
  • Checking expected result for query commands (as string or numeric value)
  • Checking for expected errors codes
  • Optional pause on error
  • Nested command scripts
  • Single step mode
  • Conditional execution, based on the *IDN and *OPT strings

You can use the IECWIN to try out the programming examples provided in the R&S FSW User Manuals.

Starting IECWIN

IECWIN is available from the Windows task bar on the R&S FSW, or by executing the following file:

C:\Program Files (x86)\Rohde-Schwarz\FSW\<1.10 or higher>\iecwin32.exe

You can also copy the program to any Windows PC or laptop. Simply copy the iecwin32.exe, iecwin.chm and rsib32.dll files from the location above to the same folder on the target computer.

When the tool is started, a "Connection settings" dialog box is displayed. Define the connection from the computer the IECWIN tool is installed on to the R&S FSW you want to control. If you are using the tool directly on the R&S FSW, you can use an NT Pipe (COM Parser) connection, which requires no further configuration. For help on setting up other connection types, check the tool's online help (by clicking the "Help" button in the dialog box).

The IECWIN offers an online help with extensive information on how to work with the tool.


Network and Remote Control Settings

Network and Remote Operation > Network and Remote Control Settings
Network and Remote Control Settings

The network and remote control settings are defined in the "Network + Remote" dialog box which is displayed when you press the SETUP key and then select "Network + Remote".

Network settings in secure user mode

Be sure to store all network settings before "Secure User Mode" is enabled; see "Protecting Data Using the Secure User Mode".

If the currently stored network settings are not suitable, you must correct them each time you switch on the R&S FSW in secure user mode, as the settings are not stored permanently in this case.

The remote commands required to define these settings are described in "Configuring the Network and Remote Control".

Step-by-step instructions are provided in "How to Set Up a Network and Remote Control".

Contents
  • General Network Settings
  • GPIB Settings
  • Compatibility Settings
  • LXI Settings


General Network Settings

Network and Remote Operation > Network and Remote Control Settings > General Network Settings
General Network Settings

The R&S FSW can be operated in a local area network (LAN), for example to control the instrument from a remote PC or use a network printer.

The general network settings are defined in the "Network" tab of the "Network + Remote" dialog box.

Risk of network problems

All parameters can be edited here; however, beware that changing the computer name has major effects in a network.

For details, see "How to Set Up a Network and Remote Control".

Network settings in secure user mode

Be sure to store all network settings before "Secure User Mode" is enabled; see "Protecting Data Using the Secure User Mode".

If the currently stored network settings are not suitable, you must correct them each time you switch on the R&S FSW in secure user mode, as the settings are not stored permanently in this case.

└ Computer Name
└ IP Address
└ Subnet Mask
└ DHCP
└ Network Configuration


Computer Name

Network and Remote Operation > Network and Remote Control Settings > General Network Settings > Computer Name
Computer Name

Each instrument is delivered with an assigned computer name, but this name can be changed. The naming conventions of Windows apply. If too many characters and/or numbers are entered, an error message is displayed in the status line.


IP Address

Network and Remote Operation > Network and Remote Control Settings > General Network Settings > IP Address
IP Address

Defines the IP address. The TCP/IP protocol is preinstalled with the IP address 10.0.0.10. If the DHCP server is available ("DHCP On"), the setting is read-only.

The IP address consists of four number blocks separated by dots. Each block contains 3 numbers in maximum (e.g. 100.100.100.100), but also one or two numbers are allowed in a block (as an example see the preinstalled address).

For step-by-step instructions refer to "How to Assign the IP Address".


Subnet Mask

Network and Remote Operation > Network and Remote Control Settings > General Network Settings > Subnet Mask
Subnet Mask

Defines the subnet mask. The TCP/IP protocol is preinstalled with the subnet mask 255.255.255.0. If the DHCP server is available ("DHCP On"), this setting is read-only.

The subnet mask consists of four number blocks separated by dots. Each block contains 3 numbers in maximum (e.g. 100.100.100.100), but also one or two numbers are allowed in a block (as an example see the preinstalled address).

For step-by-step instructions refer to "How to Assign the IP Address".


DHCP

Network and Remote Operation > Network and Remote Control Settings > General Network Settings > DHCP
DHCP

Switches between DHCP server available (On) or not available (Off). If a DHCP server is available in the network, the IP address and subnet mask of the instrument are obtained automatically from the DHCP server.

For step-by-step instructions refer to "How to Assign the IP Address".


Network Configuration

Network and Remote Operation > Network and Remote Control Settings > General Network Settings > Network Configuration
Network Configuration

Opens the standard Windows "Network Configuration" dialog box for further configuration.


GPIB Settings

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings
GPIB Settings

Alternatively to connecting the R&S FSW to a LAN, the GPIB interface can be used to connect a remote PC. For details see "GPIB Interface (IEC 625/IEEE 418 Bus Interface)").

The GPIB settings are defined in the "GPIB" tab of the "Network + Remote" dialog box.

└ GPIB Address
└ Identification String
└ Reset to Factory String
└ Remote Display Update
└ GPIB Terminator
└ *IDN Format
└ I/O Logging


GPIB Address

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings > GPIB Address
GPIB Address

Defines the GPIB address. Values from 0 to 30 are allowed. The default address is 20.

Remote command:

SYSTem:​COMMunicate:​GPIB[:​SELF]:​ADDRess


Identification String

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings > Identification String
Identification String

Defines the identification string for the device which is provided as a response to the *IDN? query. Maximum 36 characters are allowed.

Remote command:

SYSTem:​IDENtify[:​STRing]


Reset to Factory String

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings > Reset to Factory String
Reset to Factory String

Restores the default identification string. Each instrument has a unique ID according to the following syntax:

Rohde&Schwarz,FSW,<Unique number>

Remote command:

SYSTem:​IDENtify:​FACTory


Remote Display Update

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings > Remote Display Update
Remote Display Update

Defines whether the instrument display is updated or switched off when changing from manual operation to remote control.

Remote command:

SYSTem:​DISPlay:​UPDate


GPIB Terminator

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings > GPIB Terminator
GPIB Terminator

Changes the GPIB receive terminator.

According to the standard, the terminator in ASCII is <LF> and/or <EOI>. For binary data transfers (e.g. trace data) from the control computer to the instrument, the binary code used for <LF> might be included in the binary data block, and therefore should not be interpreted as a terminator in this particular case. This can be avoided by changing the receive terminator to EOI.

Remote command:

SYSTem:​COMMunicate:​GPIB[:​SELF]:​RTERminator


*IDN Format

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings > *IDN Format
*IDN Format

Defines the response format to the remote command *IDN? (see *IDN?). This function is intended for re-use of existing control programs together with the R&S FSW.

"Leg" | Legacy format, compatible to the R&S FSP/FSU/FSQ family
"New" | R&S FSW format
Remote command:

SYSTem:​FORMat:​IDENt


I/O Logging

Network and Remote Operation > Network and Remote Control Settings > GPIB Settings > I/O Logging
I/O Logging

Activates or deactivates the SCPI error log function. All remote control commands received by the R&S FSW are recorded in the following log file:

C:\R_S\instr\ScpiLogging\ScpiLog.txt

Logging the commands may be extremely useful for debug purposes, e.g. in order to find misspelled keywords in control programs.

Remote command:

SYSTem:​CLOGging


Compatibility Settings

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings
Compatibility Settings

The R&S FSW can emulate the GPIB interface of other signal and spectrum analyzers, e.g. in order to use existing control applications.

Compatibility with former R&S signal and spectrum analyzers

As a rule, the R&S FSW supports most commands from previous R&S signal and spectrum analyzers such as the FSQ, FSP, FSU, or FSV. However, the default values, in particular the number of sweep points or particular bandwidths, may vary. Therefore, the R&S FSW can emulate these other devices, including their default values, in order to repeat previous measurements or support existing control applications as in legacy systems.

The required settings are configured in the "Compatibility" tab of the "Network+Remote" dialog box.

└ Language
└ IF Gain
└ Sweep Repeat
└ Coupling
└ Wideband
└ FSU/FSQ Preamplifier
└ Revision String
└ Resetting the Factory Revision


Language

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > Language
Language

Defines the system language used to control the instrument.

For details on the available GPIB languages, see "Reference: GPIB Commands of Emulated HP Models".

Note: Emulating previous R&S signal and spectrum analyzers. As of firmware version 1.60, this function is also used to emulate previous R&S signal and spectrum analyzers.
As a rule, the R&S FSW supports most commands from previous R&S signal and spectrum analyzers such as the FSQ, FSP, FSU, or FSV. However, the default values, in particular the number of sweep points or particular bandwidths, may vary. Therefore, the R&S FSW can emulate these other devices, including their default values, in order to repeat previous measurements or support existing control applications as in legacy systems.

Note: For PSA89600 emulation, the option is indicated as "B7J" for the *OPT? query ("B7J, 140" or "B7J, 122" if "Wideband" is activated, see SYSTem:​PSA:​WIDeband).

Remote command:

SYSTem:​LANGuage


IF Gain

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > IF Gain
IF Gain

Configures the internal IF gain settings in HP emulation mode due to the application needs. This setting is only taken into account for resolution bandwidth < 300 kHz.

NORM | Optimized for high dynamic range, overload limit is close to reference level.
PULS | Optimized for pulsed signals, overload limit up to 10 dB above reference level.

This setting is only available if an HP language is selected (see "Language").

Remote command:

SYSTem:​IFGain:​MODE


Sweep Repeat

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > Sweep Repeat
Sweep Repeat

Controls a repeated sweep of the E1 and MKPK HI HP model commands (for details on the commands refer to "Reference: GPIB Commands of Emulated HP Models"). If the repeated sweep is OFF, the marker is set without sweeping before.

Note: In single sweep mode, switch off this setting before you set the marker via the E1 and MKPK HI commands in order to avoid sweeping again.

This setting is only available if a HP language is selected (see "Language").

Remote command:

SYSTem:​RSW


Coupling

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > Coupling
Coupling

Controls the default coupling ratios in the HP emulation mode for:

  • span and resolution bandwidth (Span/RBW)
  • resolution bandwidth and video bandwidth (RBW/VBW)

For FSx, the standard parameter coupling of the instrument is used. As a result, in most cases a shorter sweep time is used than in case of HP.

This setting is only available if a HP language is selected (see "Language").

Remote command:

SYSTem:​HPCoupling


Wideband

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > Wideband
Wideband

This setting defines which option is returned when the *OPT? query is executed, depending on the state of the wideband option.

It is only available for PSA89600 emulation.

"Off" | No wideband is used. The option is indicated as "B7J".
"40 MHz" | The 40 MHz wideband is used. The option is indicated as "B7J, 140".
"80 MHz" | The 80 MHz wideband is used. The option is indicated as "B7J, 122".
Remote command:

SYSTem:​PSA:​WIDeband


FSU/FSQ Preamplifier

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > FSU/FSQ Preamplifier
FSU/FSQ Preamplifier

This setting defines which option is returned when the *OPT? query is executed, depending on the used preamplifier.

It is only available for FSU/FSQ emulation, and only if a preamplifier is used by the R&S FSW (-B24/-B25 option).

Remote command:

SYSTem:​PREamplifier


Revision String

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > Revision String
Revision String

Defines the response to the REV? query for the revision number (HP emulation only, see "GPIB Address"). Max. 36 characters are allowed.

Remote command:

SYSTem:​REVision[:​STRing]


Resetting the Factory Revision

Network and Remote Operation > Network and Remote Control Settings > Compatibility Settings > Resetting the Factory Revision
Resetting the Factory Revision

Resets the response to the REV? query for the revision number to the factory default (HP emulation only, see "Language").

Remote command:

SYSTem:​REVision:​FACTory


LXI Settings

Network and Remote Operation > Network and Remote Control Settings > LXI Settings
LXI Settings

On the R&S FSW the LXI Class C functionality is already installed and enabled; thus, the instrument can be accessed via any web browser (e.g. the Microsoft Internet Explorer) to perform the following tasks:

  • modifying network configurations
  • modifying device configurations
  • monitoring connections from the device to other devices

The "LXI" tab of the "Network + Remote" dialog box provides basic LXI functions and information for the R&S FSW.

Alternatively, you can change the LAN settings using the LXI Web browser interface.

For details see "How to Configure the LAN Using the LXI Browser Interface".

Only user accounts with administrator rights are able to use LXI functionality.

└ Current LXI Configuration
└ LXI Password
└ LXI Manufacturer Description
└ LAN Reset


Current LXI Configuration

Network and Remote Operation > Network and Remote Control Settings > LXI Settings > Current LXI Configuration
Current LXI Configuration

Displays the current LXI information from the R&S FSW (read-only).

"Current version" | Current LXI version
"LXI Extended Features" | Detected LXI features, such as HiSlip (see "HiSLIP Protocol")
"Computer name" | Name of the R&S FSW as defined in the operating system (see also "Computer Name")
"MAC address" | Media Access Control address (MAC address), a unique identifier for the network card in the R&S FSW
"IP address" | IP address of the R&S FSW as defined in the operating system (see also "IP Address").
"ICMP" | Indicates whether the ping responder is active or not
"VXI-11 Discovery" | If enabled, connected devices are detected automatically using the VXI-11 protocol (see "VXI-11 Protocol")
Remote command:

SYSTem:​LXI:​INFo?


LXI Password

Network and Remote Operation > Network and Remote Control Settings > LXI Settings > LXI Password
LXI Password

Password for LAN configuration. The default password is LxiWebIfc.

Remote command:

SYSTem:​LXI:​PASSword


LXI Manufacturer Description

Network and Remote Operation > Network and Remote Control Settings > LXI Settings > LXI Manufacturer Description
LXI Manufacturer Description

Instrument description of the R&S FSW

Remote command:

SYSTem:​LXI:​MDEScription


LAN Reset

Network and Remote Operation > Network and Remote Control Settings > LXI Settings > LAN Reset
LAN Reset

Resets the LAN configuration to its default settings (LCI function).

According to the LXI standard, an LCI must set the following parameters to a default state.

Parameter | Value
TCP/IP Mode | DHCP + Auto IP Address
Dynamic DNS | Enabled
ICMP Ping | Enabled
Password for LAN configuration | LxiWebIfc

The LAN settings are configured in the "Network" tab of the "Network + Remote" dialog box or using the instrument's LXI Browser interface.

Remote command:

SYSTem:​LXI:​LANReset


How to Set Up a Network and Remote Control

Network and Remote Operation > How to Set Up a Network and Remote Control
How to Set Up a Network and Remote Control
Risk of network failure

Before connecting the instrument to the network or configuring the network, consult your network administrator. Errors may affect the entire network.

Remote operation

Remote operation of the instrument from a connected computer is possible using SCPI commands (see "SCPI (Standard Commands for Programmable Instruments)"). Sending remote commands requires the instrument to be configured in a LAN network or connected to a PC via the GPIB interface as described in "How to Configure a Network".

Remote Desktop
In production test and measurement, a common requirement is central monitoring of the T&M instruments for remote maintenance and remote diagnostics. Equipped with the Remote Desktop software of Windows, the R&S FSW ideally meets requirements for use in production. The computer that is used for remote operation is called "controller" here. The following tasks can be performed using Remote Desktop:
  • Access to the control functions via a virtual front panel (soft front panel)
  • Printout of measurement results directly from the controller
  • Storage of measured data on the controller's hard disk

This documentation provides basic instructions on setting up the Remote Desktop for the R&S FSW. For details refer to the Windows 7 operating system documentation.

Contents
  • How to Configure a Network
  • How to Operate the Instrument Without a Network
  • How to Log on to the Network
  • How to Share Directories (only with Microsoft Networks)
  • How to Set Up Remote Desktop
  • How to Start a Remote Control Session from a PC
  • How to Return to Manual Operation


How to Configure a Network

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network
How to Configure a Network

A precondition for operating or monitoring the R&S FSW remotely is that it is connected to a LAN network or a PC connected to the GPIB interface. This is described here.

Windows Firewall Settings

A firewall protects an instrument by preventing unauthorized users from gaining access to it through a network. Rohde & Schwarz highly recommends the use of the firewall on your instrument. R&S instruments are shipped with the Windows firewall enabled and preconfigured in such a way that all ports and connections for remote control are enabled. For more details on firewall configuration see the R&S White Paper "Malware Protection" (available at http://www.rohde-schwarz.com/appnote/1EF73) and the Windows 7 help system.

Contents
  • How to Connect the Instrument to the Network
  • How to Assign the IP Address
  • How to Change the Instrument Name
  • How to Configure the LAN Using the LXI Browser Interface
  • How to Change the GPIB Instrument Address


How to Connect the Instrument to the Network

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Connect the Instrument to the Network
How to Connect the Instrument to the Network

There are two methods to establish a LAN connection to the instrument:

  • A non-dedicated network (Ethernet) connection from the instrument to an existing network made with an ordinary RJ-45 network cable. The instrument is assigned an IP address and can coexist with a computer and with other hosts on the same network.
  • A dedicated network connection (Point-to-point connection) between the instrument and a single computer made with a (crossover) RJ-45 network cable. The computer must be equipped with a network adapter and is directly connected to the instrument. The use of hubs, switches, or gateways is not required, however, data transfer is still performed using the TCP/IP protocol. An IP address has to be assigned to the instrument and the computer, see "How to Assign the IP Address".
    Note: As the R&S FSW uses a 1 GBit LAN, a crossover cable is not necessary (due to Auto-MDI(X) functionality).
►

To establish a non-dedicated network connection, connect a commercial RJ-45 cable to one of the LAN ports.

To establish a dedicated connection, connect a (crossover) RJ-45 cable between the instrument and a single PC.

If the instrument is connected to the LAN, Windows automatically detects the network connection and activates the required drivers.

The network card can be operated with a 1 GBit Ethernet IEEE 802.3u interface.


How to Assign the IP Address

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Assign the IP Address
How to Assign the IP Address
Depending on the network capacities, the TCP/IP address information for the instrument can be obtained in different ways.
  • If the network supports dynamic TCP/IP configuration using the Dynamic Host Configuration Protocol (DHCP), all address information can be assigned automatically.
  • If the network does not support DHCP, or if the instrument is set to use alternate TCP/IP configuration, the addresses must be set manually.

By default, the instrument is configured to use dynamic TCP/IP configuration and obtain all address information automatically. This means that it is safe to establish a physical connection to the LAN without any previous instrument configuration.

Risk of network errors

Connection errors can affect the entire network. If your network does not support DHCP, or if you choose to disable dynamic TCP/IP configuration, you must assign valid address information before connecting the instrument to the LAN. Contact your network administrator to obtain a valid IP address.

Assigning the IP address on the R&S FSW

  1. Press the SETUP key.

  2. Press the "Network + Remote" softkey.

  3. Select the "Network" tab.

  4. In the "Network + Remote" dialog, toggle the "DHCP On/Off" setting to the required mode.

    If DHCP is "Off", you must enter the IP address manually, as described in the following steps.

    Note: When DHCP is changed from "On" to "Off", the previously set IP address and subnet mask are retrieved.

    If DHCP is "On", the IP address of the DHCP server is obtained automatically. The configuration is saved, and you are prompted to restart the instrument. You can skip the remaining steps.

    Note: When a DHCP server is used, a new IP address may be assigned each time the instrument is restarted. This address must first be determined on the instrument itself. Thus, when using a DHCP server, it is recommended that you use the permanent computer name, which determines the address via the DNS server.

  5. Enter the "IP Address", for example 10.0.0.10. The IP address consists of four number blocks separated by dots. Every block contains 3 numbers in maximum.

  6. Enter the "Subnet Mask", for example 255.255.255.0. The subnet mask consists of four number blocks separated by dots. Every block contains 3 numbers in maximum.

  7. Close the dialog box.

    If you have entered an invalid IP address or subnet mask, the message "out of range" is displayed in the status line. If the settings are correct, the configuration is saved, and you are prompted to restart the instrument.

  8. Confirm the displayed message ("Yes" button) to restart the instrument.

Using a DNS server to determine the IP address

If a DNS server is configured on the R&S FSW, the server can determine the current IP address for the connection using the permanent computer name.

  1. Obtain the name of your DNS domain and the IP addresses of the DNS and WINS servers on your network (see "How to Change the Instrument Name").

  2. Press the SETUP key and then the "Network + Remote" softkey.

  3. In the "Network" tab, select the "Open Dialog 'Network Connections'" button.

  4. Double-tap the "Local Area Network" icon.

  5. In the "Local Area Connection Status" dialog box, select the "Properties" button.

    The items used by the LAN connection are displayed.

  6. Tap the entry named "Internet Protocol Version 4 (TCP/IPv4)" to highlight it.

  7. Select the "Properties" button.

  8. On the "General" tab, select "Use the following DNS server addresses" and enter your own DNS addresses.

    For more information refer to the Windows 7 operating system Help.


How to Change the Instrument Name

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Change the Instrument Name
How to Change the Instrument Name

In a LAN that uses a DNS server (Domain Name System server), each PC or instrument connected in the LAN can be accessed via an unambiguous computer name instead of the IP address. The DNS server translates the host name to the IP address. This is especially useful when a DHCP server is used, as a new IP address may be assigned each time the instrument is restarted.

Each instrument is delivered with an assigned computer name, but this name can be changed.

To change the computer name

  1. Press the SETUP key and then the "Network + Remote" softkey.

    The current "Computer Name" is displayed in the "Network" tab.

  2. Enter the new computer name and close the dialog box.

    The configuration is saved, and you are prompted to restart the instrument.

  3. Confirm the displayed message ("Yes" button) to restart the instrument.


How to Configure the LAN Using the LXI Browser Interface

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Configure the LAN Using the LXI Browser Interface
How to Configure the LAN Using the LXI Browser Interface

The instrument's LXI browser interface works correctly with all W3C compliant browsers.

►

In the web browser, open the http://<instrument-hostname> or http://<instrument-ip-address> page, e.g. http://10.113.10.203.

The default password to change LAN configurations is LxiWebIfc.

The "Instrument Home Page" (welcome page) opens.

The instrument home page displays the device information required by the LXI standard including the VISA resource string in read-only format.

►

Press the "Device Indicator" button on the "Instrument Home Page" to activate or deactivate the LXI status icon on the status bar of the R&S FSW. A green LXI status symbol indicates that a LAN connection has been established; a red symbol indicates an error, for example, that no LAN cable is connected. When a device is connecting to the instrument, the LXI logo blinks. The "Device Indicator" setting is not password-protected.

The most important control elements in the navigation pane of the browser interface are the following:

  • "LAN Configuration" opens the menu with configuration pages.
  • "Status" displays information about the LXI status of the instrument.
  • "Help > Glossary" opens a document with a glossary of terms related to the LXI standard.
Contents
  • LAN Configuration


LAN Configuration

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Configure the LAN Using the LXI Browser Interface > LAN Configuration
LAN Configuration
The LAN configuration consists of three parts:
  • "IP configuration" provides all mandatory LAN parameters.
  • "Advanced LAN Configuration" provides LAN settings that are not declared mandatory by the LXI standard.
  • "Ping Client" provides the ping utility to verify the connection between the instrument and other devices.
Contents
  • IP Configuration
  • Advanced LAN Configuration
  • Ping Client


IP Configuration

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Configure the LAN Using the LXI Browser Interface > LAN Configuration > IP Configuration
IP Configuration

The "LAN Configuration > IP configuration" web page displays all mandatory LAN parameters and allows their modification.

The "TCP/IP Mode" configuration field controls how the IP address for the instrument gets assigned (see also "How to Assign the IP Address"). For the manual configuration mode, the static IP address, subnet mask, and default gateway are used to configure the LAN. The automatic configuration mode uses DHCP server or Dynamic Link Local Addressing (Automatic IP) to obtain the instrument IP address.

Changing the LAN configuration is password-protected. The default password is LxiWebIfc (notice upper and lower case characters).

You can change the LXI password in the "Network + Remote" dialog box, see "LXI Settings".


Advanced LAN Configuration

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Configure the LAN Using the LXI Browser Interface > LAN Configuration > Advanced LAN Configuration
Advanced LAN Configuration
The "LAN Configuration > Advanced LAN Configuration" parameters are used as follows:
  • The "Negotiation" configuration field provides different Ethernet speed and duplex mode settings. In general, the "Auto Detect" mode is sufficient.
  • "ICMP Ping" must be enabled to use the ping utility.
  • "VXI-11" is the protocol that is used to detect the instrument in the LAN. According to the standard, LXI devices must use VXI-11 to provide a detection mechanism; other additional detection mechanisms are permitted.
  • mDNS and DNS-SD are two additional protocols: Multicast DNS and DNS Service Discovery. They are used for device communication in zero configuration networks working without DNS and DHCP


Ping Client

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Configure the LAN Using the LXI Browser Interface > LAN Configuration > Ping Client
Ping Client

Ping is a utility that verifies the connection between the LXI-compliant instrument and another device. The ping command uses the ICMP echo request and echo reply packets to determine whether the LAN connection is functional. Ping is useful for diagnosing IP network or router failures. The ping utility is not password-protected.

To initiate a ping between the LXI-compliant instrument and a second connected device:

  1. Enable "ICMP Ping" on the "Advanced LAN Configuration" page (enabled after an LCI).

  2. Enter the IP address of the second device without the ping command and without any further parameters into the "Destination Address" field (e.g. 10.113.10.203).

  3. Select "Submit".


How to Change the GPIB Instrument Address

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Configure a Network > How to Change the GPIB Instrument Address
How to Change the GPIB Instrument Address

In order to operate the instrument via remote control, it must be addressed using the GPIB address. The remote control address is factory-set to 20, but it can be changed if it does not fit in the network environment. For remote control, addresses 0 through 30 are allowed. The GPIB address is maintained after a reset of the instrument settings.

Setting the GPIB address

  1. On the R&S FSW, press the SETUP key.

  2. Press the "Network + Remote" softkey.

  3. In the "Network + Remote" dialog box, select the "GPIB" tab.

  4. In the "GPIB Address" field, enter a value between 0 and 30.

Remote command:

SYST:COMM:GPIB:ADDR 18


How to Operate the Instrument Without a Network

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Operate the Instrument Without a Network
How to Operate the Instrument Without a Network

To operate the instrument without a network connection either temporarily or permanently, no special measures are necessary. Windows 7 automatically detects the interruption of the network connection and does not set up the connection when the instrument is switched on.

If you are not prompted to enter the user name and password, proceed as described in "How to Activate or Deactivate the Automatic Login Mechanism".


How to Log on to the Network

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Log on to the Network
How to Log on to the Network

Windows 7 requires that users identify themselves by entering a user name and password in a login window. You can set up two types of user accounts, either an administrator account with unrestricted access to the computer/domain or a standard user account with limited access. The instrument provides an auto-login function for the administrator account, i.e. login with unrestricted access is carried out automatically in the background. By default, the user name for the administrator account is "Instrument", and the user name for the standard user account is "NormalUser". In both cases the initial password is "894129". You can change the password in Windows 7 for any user at any time. Some administrative tasks require administrator rights (e.g. firmware updates or the configuration of a LAN network). Refer to "General Instrument Setup" to find out which functions are affected.

At the same time you log on to the operating system, you are automatically logged on to the network. As a prerequisite, the user name and the password must be identical on the instrument and on the network.

Contents
  • How to Create Users
  • How to Change the User Password
  • How to Activate or Deactivate the Automatic Login Mechanism


How to Create Users

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Log on to the Network > How to Create Users
How to Create Users

After the software for the network has been installed, the instrument issues an error message the next time it is switched on because there is no user named "instrument" (= default user ID for Windows automatic login) in the network. Thus, a matching user must be created in the R&S FSW and in the network, the password must be adapted to the network password, and the automatic login mechanism must then be deactivated.

The network administrator is responsible for creating new users in the network. A new user can be created on the instrument using the "User Account" dialog box:

  1. Select the "Windows" icon in the toolbar to access the operating system.

  2. In the "Start" menu, select "Control Panel" and then select "User Accounts."

  3. Select "Give other users access to this computer" and then "Add".

    The "Add New User" dialog box is displayed.

  4. Enter the name of the new user in the text field and select "Next".

  5. Define the level of access you want to allow the new user:

    • Select "Standard" to create an account with limited rights.
    • Select "Administrator" to create an account with administrator rights.

    Note: Full firmware functionality requires administrator rights.

  6. Select the "Finish" button.

    The new user is created.


How to Change the User Password

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Log on to the Network > How to Change the User Password
How to Change the User Password

After the new user has been created on the instrument, the password must be adapted to the network password. This is also done using the "User Accounts" dialog box.

  1. Select the "Windows" icon in the toolbar to access the operating system.

  2. Press CTRL + ALT + DELETE, then select "Change a password".

  3. Enter the user account name.

  4. Enter the old password.

  5. Enter the new password in the upper text line and repeat it in the following line.

  6. Press ENTER.

    The new password is now active.


How to Activate or Deactivate the Automatic Login Mechanism

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Log on to the Network > How to Activate or Deactivate the Automatic Login Mechanism
How to Activate or Deactivate the Automatic Login Mechanism
Deactivating the automatic login mechanism

When shipped, the instrument is already configured to automatically log on under Windows 7. To deactivate the automatic login mechanism, perform the following steps:

  1. In the "Start" menu, select "Run".

    The "Run" dialog box is displayed.

  2. Enter the command C:\R_S\INSTR\USER\NO_AUTOLOGIN.REG.

  3. Press the ENTER key to confirm.

    The automatic login mechanism is deactivated. The next time you switch on the instrument, you are prompted to enter your user name and password before the firmware is started.

Reactivating the automatic login mechanism

  1. In the "Start" menu, select "Run".

    The "Run" dialog box is displayed.

  2. Enter the command C:\R_S\INSTR\USER\AUTOLOGIN.REG.

  3. Press the ENTER key to confirm.

    The automatic login mechanism is reactivated. It will be applied the next time the instrument is switched on.


How to Share Directories (only with Microsoft Networks)

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Share Directories (only with Microsoft Networks)
How to Share Directories (only with Microsoft Networks)

Sharing directories makes data available for other users. This is only possible in Microsoft networks. Sharing is a property of a file or directory.

  1. In the "Start" menu, select "Programs", "Accessories" and then select "Windows Explorer".

  2. Select the desired folder with the right mouse button.

  3. In the context menu, select "Sharing with > Specific people".

    The dialog box for sharing a directory is displayed.

  4. Select a user from the list or add a new name and select the "Add" button.

  5. Select the "Share" button.

  6. Select "Done" to close the dialog box.

    The drive is shared and can be accessed by the selected users.


How to Set Up Remote Desktop

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Set Up Remote Desktop
How to Set Up Remote Desktop

Remote Desktop is a Windows application which can be used to access and control the instrument from a remote computer through a LAN connection. While the instrument is in operation, the instrument screen contents are displayed on the remote computer, and Remote Desktop provides access to all of the applications, files, and network resources of the instrument. Thus, remote operation of the R&S FSW is possible.

With Windows 7, Remote Desktop Client is part of the operating system. For other versions of Windows, Microsoft offers the Remote Desktop Client as an add-on.

This section provides basic instructions on setting up the Remote Desktop for the R&S FSW. For details refer to the Windows 7 operating system documentation.

Contents
  • How to Configure the R&S FSW for Remote Operation via Remote Desktop
  • How to Add or Remove Users to the Remote Desktop Users Group
  • How to Configure the Controller
  • How to Start and Close the Remote Desktop
  • How to Shut Down the R&S FSW via Remote Operation


How to Configure the R&S FSW for Remote Operation via Remote Desktop

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Set Up Remote Desktop > How to Configure the R&S FSW for Remote Operation via Remote Desktop
How to Configure the R&S FSW for Remote Operation via Remote Desktop

  1. Create a fixed IP address for the TCP/IP protocol as described in "How to Assign the IP Address".

    Note: To avoid problems, use a fixed IP address.
    When a DHCP server is used, a new IP address is assigned each time the instrument is restarted. This address must first be determined on the instrument itself. Thus, using a DHCP server is not suitable for remote operation of the R&S FSW via Remote Desktop.

  2. Select the "Windows" icon in the toolbar to access the operating system.

  3. In the "Start" menu, select the "Control Panel" and then "System and Security".

  4. In the "System" area, select "Allow remote access".

  5. In the "Remote" tab, in the "Remote Desktop" area, activate the "Allow connections from computers running Remote Desktop" option.

  6. Define which users are to be given access to the R&S FSW via Remote Desktop.

    Note: The user account under which configuration is carried out is automatically enabled for Remote Desktop.

    1. Select the "Select Users" button.

    2. Select the users or create new user accounts as described in "How to Create Users".

    3. Select "OK" to confirm the settings.

  7. The R&S FSW is now ready for connection setup with the Remote Desktop program of the controller.


How to Add or Remove Users to the Remote Desktop Users Group

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Set Up Remote Desktop > How to Add or Remove Users to the Remote Desktop Users Group
How to Add or Remove Users to the Remote Desktop Users Group

Only users in the Remote Desktop Users Group are allowed to connect to the R&S FSW via Remote Desktop. You can add the users to this group directly when you allow remote access on the R&S FSW, as described in "How to Set Up Remote Desktop". Furthermore, you can add or remove users to this group at any time.

  1. Select the "Windows" icon in the toolbar to access the operating system.

  2. In the "Start" menu, select "Control Panel" and then select "User Accounts."

  3. Select "Give other users access to this computer".

    The "User Accounts" dialog box is displayed with a list of users and the user group they are assigned to.

  4. Give existing users the right to access the R&S FSW via Remote Desktop:

    1. Select the user from the list and then select the "Properties" button.

    2. As the level of access you want to allow the user, select "Other", then select "Remote Desktop Users" from the dropdown list.

    3. Select the "Finish" button.

      The user is added to the Remote Desktop Users Group.

  5. Create new users who may access the R&S FSW via Remote Desktop:

    1. Select "Add".

    2. Enter the name of the new remote user in the text field and select "Next".

    3. As the level of access you want to allow the new user, select "Other", then select "Remote Desktop Users" from the dropdown list.

    4. Select the "Finish" button.

      The user is created.

  6. Remove users from the Remote Desktop Users Group:

    1. Select the user from the list and then select the "Remove" button.

    2. Select "OK" to confirm the action.

    Note: Users with administrator rights retain their access rights via Remote Desktop even when they have been removed from the Remote Desktop Users Group.

  7. Select "OK" to close the dialog box.


How to Configure the Controller

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Set Up Remote Desktop > How to Configure the Controller
How to Configure the Controller
Remote Desktop Client

With Windows 7, Remote Desktop Client is part of the operating system and can be accessed via "Start > Programs > Accessories > Remote Desktop Connection".

For other versions of Windows, Microsoft offers the Remote Desktop Client as an add-on.

  1. In the "Start" menu of the controller, select "All Programs > Accessories > Remote Desktop Connection".

    The "Remote Desktop Connection" dialog box is displayed.

  2. Select the "Options >>" button.

    The dialog box is expanded to display the configuration data.

  3. Open the "Experience" tab.

    The settings on this tab are used to select and optimize the connection speed.

  4. In the list, select the appropriate connection (for example: LAN (10 Mbps or higher)).

    Depending on your selection (and how powerful the connection is), the options are activated or deactivated.

  5. To improve the performance, you can deactivate the "Desktop background", "Show window contents while dragging" and "Menu and window animation" options.

  6. Open the "Local Resources" tab to enable printers, local drives and serial interfaces.

  7. If you will need to access drives of the controller from the R&S FSW (e.g. in order to store settings or to copy files from the controller to the R&S FSW), activate the "Disk drives" option.

    Windows will then map drives of the controller to the corresponding network drives.

  8. To use printers connected to the controller while accessing them from the R&S FSW, activate the "Printers" options. Do not change the remaining settings.

  9. Open the "Display" tab.

    The options to configure the R&S FSW screen display are displayed.

  10. Under "Remote desktop size", you can set the size of the R&S FSW window on the desktop of the controller.

  11. Under "Colors", do not change the settings.

  12. Set the "Display the connection bar when I use the full screen" option:

    If activated, a bar showing the network address of the R&S FSW will appear at the top edge of the screen. You can use this bar to reduce, minimize or close the window.

    If deactivated, the only way you can return to the controller desktop from the R&S FSW screen in full screen mode is to select "Disconnect" from the "Start" menu.


How to Start and Close the Remote Desktop

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Set Up Remote Desktop > How to Start and Close the Remote Desktop
How to Start and Close the Remote Desktop
To set up a connection to the R&S FSW

  1. In the "Remote Desktop Connection" dialog box (see "How to Configure the Controller"), open the "General" tab.

  2. In the "Computer" field, enter the IP address of the R&S FSW.

    In the "User name" field, enter instrument to log in as an administrator, or Normal User to log in as a standard user.

    In the "Password" field, enter 894129.

  3. To save the connection configuration for later use:

    1. Select the "Save As" button.

      The "Save As" dialog box is displayed.

    2. Enter the name for the connection information (*.RDP).

  4. To load an existing connection configuration:

    1. Select the "Open" button.

      The "Open" dialog box is displayed.

    2. Select the *.RDP file.

  5. Select the "Connect" button.

    The connection is set up.

  6. If the "Disk drives" option is activated on the "Local Resources" tab, a warning is displayed indicating that the drives are enabled for access from the R&S FSW.

    Select "OK" to confirm the warning.

  7. After a few moments, the R&S FSW screen is displayed.

    If a dark screen appears or a dark square appears in the upper left-hand corner of the screen, you must restart the R&S FSW in order to see the modified screen resolution.

    • Press the key combination ALT + F4.
    • The R&S FSW firmware is shut down, which may take a few seconds.
    • On the desktop, double-tap the "Analyzer" icon.

    The firmware restarts and then automatically opens the "Soft Front Panel", i.e. the user interface on which all front panel controls and the rotary knob are mapped to buttons.

    For more information see "How to Work with the Soft Front Panels".

  8. To deactivate or activate the "Softfrontpanel", press the F6 key.

    After the connection is established, the R&S FSW screen is displayed in the "Remote Desktop" application window.

    The Windows "Start" menu can be made available by expanding the "Remote Desktop" window to full size.

    During the connection with the controller, the login entry is displayed on the R&S FSW screen.

To terminate Remote Desktop control

The connection can be terminated by the controller or by a user at the R&S FSW:

  1. On the controller, close the "Remote Desktop" window at any time.

    The connection to the R&S FSW is terminated.

  2. On the R&S FSW, a user logs on.

    The connection to the controller is terminated as a result. A message is displayed on the controller display indicating that another user has assumed control of the instrument.

Restoring the connection to the R&S FSW

Follow the instructions above for setting up a connection to the R&S FSW. If the connection is terminated and then restored, the R&S FSW remains in the same state.


How to Shut Down the R&S FSW via Remote Operation

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Set Up Remote Desktop > How to Shut Down the R&S FSW via Remote Operation
How to Shut Down the R&S FSW via Remote Operation

  1. Select the R&S FSW softfrontpanel and close the application with the key combination ALT + F4.

  2. Select the desktop and press the key combination ALT + F4.

    A safety query is displayed to warn you that the instrument cannot be reactivated via remote operation and asks you whether you want to continue the shutdown process.

  3. Respond to the safety query with "Yes".

    The connection with the controller is terminated and the R&S FSW is shut down.


How to Start a Remote Control Session from a PC

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Start a Remote Control Session from a PC
How to Start a Remote Control Session from a PC

When you switch on the instrument, it is always in manual operation state ("local" state) and can be operated via the front panel.

To start remote control

  1. Send an addressed command (GTR - Go to Remote) from a controller to the instrument.

    The instrument is switched to remote control ("remote" state). Operation via the front panel is disabled. Only the "Local" softkey is displayed to return to manual operation. The instrument remains in the remote state until it is reset to the manual state via the instrument or via remote control interfaces. Switching from manual operation to remote control and vice versa does not affect the other instrument settings.

  2. During program execution, send the SYSTem:DISPlay:UPDate ON command to activate the display of results (see SYSTem:​DISPlay:​UPDate).

    The changes in the device settings and the recorded measurement values are displayed on the instrument screen.

  3. To obtain optimum performance during remote control, send the SYSTem:DISPlay:UPDate OFF command to hide the display of results and diagrams again (default setting in remote control).

  4. To prevent unintentional return to manual operation, disable the keys of the instrument using the universal command LLO.

    Switching to manual mode is only possible via remote control then. This function is only available for the GPIB interface.

  5. To enable the keys of the R&S FSW again, switch the instrument to local mode (GTL - Go to Local), i.e. deactivate the REN line of the remote control interface.

If the instrument is operated exclusively in remote control, it is recommended that you switch on the power-save mode for the display. For more details on this mode refer to the "Overview".


How to Return to Manual Operation

Network and Remote Operation > How to Set Up a Network and Remote Control > How to Return to Manual Operation
How to Return to Manual Operation

Before you switch back to manual operation, all remote command processing must be completed. Otherwise, the instrument will switch back to remote control immediately.

►

Select the "Local" softkey or the PRESET key, or use the following GPIB command:

status = viGpibControlREN(vi, VI_GPIB_REN_ADDRESS_GTL)


Remote Commands

The commands required to perform measurements in the Spectrum application in a remote environment are described here.

It is assumed that the R&S FSW has already been set up for remote operation in a network as described in "How to Set Up a Network and Remote Control".

Compatibility with former R&S signal and spectrum analyzers

As a rule, the R&S FSW supports most commands from previous R&S signal and spectrum analyzers such as the FSQ, FSP, FSU, or FSV. However, the default values, in particular the number of sweep points or particular bandwidths, may vary. Therefore, the R&S FSW can emulate these other devices, including their default values, in order to repeat previous measurements or support existing control applications as in legacy systems.

Contents
  • Conventions used in SCPI Command Descriptions
  • Common Suffixes
  • Common Commands
  • Selecting the Operating Mode and Application
  • Configuring and Performing Measurements
  • Configuring the Result Display
  • Setting Basic Measurement Parameters
  • Analyzing Measurements (Basics)
  • Managing Settings and Results
  • Configuring the R&S FSW
  • Using the Status Register
  • Commands for Remote Instrument Operation
  • Emulating Other Instruments' Commands
  • Commands for Compatibility
  • Programming Examples


Conventions used in SCPI Command Descriptions

Remote Commands > Conventions used in SCPI Command Descriptions
Conventions used in SCPI Command Descriptions
Note the following conventions used in the remote command descriptions:
  • Command usage
    If not specified otherwise, commands can be used both for setting and for querying parameters.
    If a command can be used for setting or querying only, or if it initiates an event, the usage is stated explicitely.
  • Parameter usage
    If not specified otherwise, a parameter can be used to set a value and it is the result of a query.
    Parameters required only for setting are indicated as Setting parameters.
    Parameters required only to refine a query are indicated as Query parameters.
    Parameters that are only returned as the result of a query are indicated as Return values.
  • Conformity
    Commands that are taken from the SCPI standard are indicated as SCPI confirmed. All commands used by the R&S FSW follow the SCPI syntax rules.
  • Asynchronous commands
    A command which does not automatically finish executing before the next command starts executing (overlapping command) is indicated as an Asynchronous command.
  • Reset values (*RST)
    Default parameter values that are used directly after resetting the instrument (*RST command) are indicated as *RST values, if available.
  • Default unit
    This is the unit used for numeric values if no other unit is provided with the parameter.
  • Manual operation
    If the result of a remote command can also be achieved in manual operation, a link to the description is inserted.


Common Suffixes

Remote Commands > Common Suffixes
Common Suffixes

In the Spectrum application, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<ch> | 1..18 (TX channel) 1..11 (ALT channel) | Channel
<k> | 1..8 (Limit line) 1 | 2 (Display line) | Line
<m> | 1..16 | Marker
<n> | 1..16 | Window
<t> | 1..6 | Trace


Common Commands

Remote Commands > Common Commands
Common Commands

Common commands are described in the IEEE 488.2 (IEC 625-2) standard. These commands have the same effect and are employed in the same way on different devices. The headers of these commands consist of "*" followed by three letters. Many common commands are related to the Status Reporting System.

Available common commands:

List of Commands
*CAL?
*CLS
*ESE
*ESR?
*IDN?
*IST?
*OPC
*OPT?
*PCB
*PRE
*PSC
*RST
*SRE
*STB?
*TRG
*TST?
*WAI


*CAL?

Remote Commands > Common Commands > *CAL?
*CAL?

Calibration query

Initiates a calibration of the instrument and subsequently queries the calibration status. Responses > 0 indicate errors.

Usage: | Query only
Manual operation: | See "Starting a Self-alignment"


*CLS

Remote Commands > Common Commands > *CLS
*CLS

Clear status

Sets the status byte (STB), the standard event register (ESR) and the EVENt part of the QUEStionable and the OPERation registers to zero. The command does not alter the mask and transition parts of the registers. It clears the output buffer.

Usage: Setting only


*ESE

Remote Commands > Common Commands > *ESE
*ESE <Value>

Event status enable

Sets the event status enable register to the specified value. The query returns the contents of the event status enable register in decimal form.

Parameters:
<Value>
Range: 0 to 255


*ESR?

Remote Commands > Common Commands > *ESR?
*ESR?

Event status read

Returns the contents of the event status register in decimal form and subsequently sets the register to zero.

Return values:
<Contents>
Range: 0 to 255
Usage: Query only


*IDN?

Remote Commands > Common Commands > *IDN?
*IDN?

Identification

Returns the instrument identification.

Return values:
<ID> | "Rohde&Schwarz,<device type>,<part number>/serial number>,<firmware version>"
Example: | Rohde&Schwarz,FSW-26,1312.8000K26/100005,1.30
Usage: | Query only
Manual operation: | See "*IDN Format"


*IST?

Remote Commands > Common Commands > *IST?
*IST?

Individual status query

Returns the contents of the IST flag in decimal form. The IST flag is the status bit which is sent during a parallel poll.

Return values:
<ISTflag> | 0 | 1
Usage: | Query only


*OPC

Remote Commands > Common Commands > *OPC
*OPC

Operation complete

Sets bit 0 in the event status register when all preceding commands have been executed. This bit can be used to initiate a service request. The query form writes a "1" into the output buffer as soon as all preceding commands have been executed. This is used for command synchronization.


*OPT?

Remote Commands > Common Commands > *OPT?
*OPT?

Option identification query

Queries the options included in the instrument. For a list of all available options and their description refer to the data sheet.

Return values:
<Options>

The query returns a list of all installed and activated options, separated by commas, where:

B<number> describes hardware options

K<number> describes software options

For PSA89600 emulation, the option is indicated as "B7J" for the *OPT? query ("B7J, 140" if SYST:PSA:WID is activated).

(See SYSTem:​PSA:​WIDeband.)

Note that K9 (Power Meter) and K14 (Spectrograms) are displayed for compatibility reasons only; in fact they are standard functionality of the R&S FSW base unit.

Usage: Query only


*PCB

Remote Commands > Common Commands > *PCB
*PCB <Address>

Pass control back

Indicates the controller address to which remote control is returned after termination of the triggered action.

Setting parameters:
<Address>
Range: 0 to 30
Usage: Setting only


*PRE

Remote Commands > Common Commands > *PRE
*PRE <Value>

Parallel poll register enable

Sets parallel poll enable register to the indicated value. The query returns the contents of the parallel poll enable register in decimal form.

Parameters:
<Value>
Range: 0 to 255


*PSC

Remote Commands > Common Commands > *PSC
*PSC <Action>

Power on status clear

Determines whether the contents of the ENABle registers are preserved or reset when the instrument is switched on. Thus a service request can be triggered when the instrument is switched on, if the status registers ESE and SRE are suitably configured. The query reads out the contents of the "power-on-status-clear" flag.

Parameters:
<Action>
0 | 1
0

The contents of the status registers are preserved.

1

Resets the status registers.


*RST

Remote Commands > Common Commands > *RST
*RST

Reset

Sets the instrument to a defined default status. The default settings are indicated in the description of commands.

The command is equivalent to SYSTem:PRESet.

Note that the factory set default values can be modified to user-defined settings (see MMEMory:​LOAD:​STATe). For more details on default values see "Restoring the Default Instrument Configuration (Preset)".

Usage: Setting only


*SRE

Remote Commands > Common Commands > *SRE
*SRE <Contents>

Service request enable

Sets the service request enable register to the indicated value. This command determines under which conditions a service request is triggered.

Parameters:
<Contents>

Contents of the service request enable register in decimal form. Bit 6 (MSS mask bit) is always 0.

Range: 0 to 255


*STB?

Remote Commands > Common Commands > *STB?
*STB?

Status byte query

Reads the contents of the status byte in decimal form.

Usage: Query only


*TRG

Remote Commands > Common Commands > *TRG
*TRG

Trigger

Triggers all actions waiting for a trigger event. In particular, *TRG generates a manual trigger signal. This common command complements the commands of the TRIGger subsystem.

*TRG corresponds to the INITiate:IMMediate command (see INITiate[:​IMMediate]).

Usage: Event


*TST?

Remote Commands > Common Commands > *TST?
*TST?

Self test query

Triggers selftests of the instrument and returns an error code in decimal form (see Service Manual supplied with the instrument). "0" indicates no errors occured.

Usage: Query only


*WAI

Remote Commands > Common Commands > *WAI
*WAI

Wait to continue

Prevents servicing of the subsequent commands until all preceding commands have been executed and all signals have settled (see also command synchronization and *OPC).

Usage: Event


Selecting the Operating Mode and Application

Remote Commands > Selecting the Operating Mode and Application
Selecting the Operating Mode and Application

The following commands are required to select the operating mode or the application and to configure a Sequencer in a remote environment. The tasks for manual operation are described in "Applications and Operating Modes".

Contents
  • Selecting the Mode and Applications
  • Performing a Sequence of Measurements
  • Programming Example: Performing a Sequence of Measurements


Selecting the Mode and Applications

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications
Selecting the Mode and Applications
List of Commands
DISPlay:ATAB
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:MODE
INSTrument:REName
INSTrument[:SELect]


DISPlay:ATAB

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > DISPlay:ATAB
DISPlay:ATAB <State>

This command switches between the MultiView tab and the most recently displayed measurement channel.

Parameters:
<State>
ON | OFF
ON

The MultiView tab is displayed.

OFF

The most recently displayed measurement channel is displayed.

*RST: OFF
Example:

See "Programming Example: Performing a Sequence of Measurements".


INSTrument:CREate:DUPLicate

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect]).

This command is not available if the MSRA/MSRT Master channel is selected.

This command is not available if the MSRA Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event
Manual operation: | See "Duplicate Current Channel"


INSTrument:CREate[:NEW]

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

See also
  • INSTrument[:​SELect]
  • INSTrument:​DELete
Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements".

Manual operation: See "New Channel"


INSTrument:CREate:REPLace

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.
Manual operation: | See "Replace Current Channel"


INSTrument:DELete

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:MODE

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument:MODE
INSTrument:MODE <OpMode>

The operating mode of the R&S FSW determines which applications are available and active. Whenever you change the operating mode, the currently active measurement channels are stored. The default operating mode is Signal and Spectrum Analyzer mode, however, the presetting can be changed.

For details on operating modes and applications see "Applications and Operating Modes".

Parameters:
<OpMode>
SANalyzer

Signal and Spectrum Analyzer mode

MSRanalyzer

Multi-Standard Radio Analysis (MSRA) mode

RTMStandard

Multi-Standard Realtime (MSRT) mode

Only available if the realtime option (R&S FSW-K160R) is installed.

*RST: SAN
Example: INST:MODE MSR

Switches to MSRA mode.

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: SCPI confirmed


INSTrument:REName

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Remote Commands > Selecting the Operating Mode and Application > Selecting the Mode and Applications > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType> | <ChannelName>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

Also see

  • INSTrument:​CREate[:​NEW]
  • "Programming Example: Performing a Sequence of Measurements"
Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel.

Example: INST SAN

Activates a measurement channel for the Spectrum application.

INST 'MySpectrum'

Selects the measurement channel named 'MySpectrum' (for example before executing further commands for that channel).

Example:

See "Programming Example: Performing a Sequence of Measurements".

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: SCPI confirmed
Manual operation: See "Spectrum"
See "1xEV-DO BTS"
See "1xEV-DO MS"
See "3G FDD BTS"
See "3G FDD UE"
See "Analog Demodulation"
See "cdma2000 BTS"
See "cdma2000 MS"
See "(Multi-Carrier) Group Delay"
See "GSM"
See "I/Q Analyzer"
See "LTE"
See "Noise Figure"
See "Phase Noise"
See "Pulse Measurements"
See "Realtime Spectrum"
See "TD-SCDMA BTS"
See "TD-SCDMA UE"
See "Transient Analysis"
See "Vector Signal Analysis (VSA)"
See "WLAN"
See "New Channel"


Performing a Sequence of Measurements

Remote Commands > Selecting the Operating Mode and Application > Performing a Sequence of Measurements
Performing a Sequence of Measurements

The following commands control the sequencer.

For details on the Sequencer see "The Sequencer Concept".

List of Commands
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
SYSTem:SEQuencer


INITiate:SEQuencer:ABORt

Remote Commands > Selecting the Operating Mode and Application > Performing a Sequence of Measurements > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: | Event
Manual operation: | See "Sequencer State"


INITiate:SEQuencer:IMMediate

Remote Commands > Selecting the Operating Mode and Application > Performing a Sequence of Measurements > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements".

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event
Manual operation: See "Sequencer State"


INITiate:SEQuencer:MODE

Remote Commands > Selecting the Operating Mode and Application > Performing a Sequence of Measurements > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements".

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept".

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements".

Example:

See "Programming Example: Analyzing MSR Signals" .

Manual operation: See "Sequencer Mode"


SYSTem:SEQuencer

Remote Commands > Selecting the Operating Mode and Application > Performing a Sequence of Measurements > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept".

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements".

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements".

Manual operation: See "Sequencer State"


Programming Example: Performing a Sequence of Measurements

Remote Commands > Selecting the Operating Mode and Application > Programming Example: Performing a Sequence of Measurements
Programming Example: Performing a Sequence of Measurements

This example demonstrates how to perform several measurements in a sequence in a remote environment.

//2xSpectrumanalyzer + 2xIQ, start Sequencer at the end, test OPC?
// ------------------------------------------------------------------------

//------Preparing the instrument and first channel -----------
*RST
//Activate new IQ channel
INSTrument:CREate:NEW IQ,'IQ 1'
//Set sweep count for new IQ channel
SENS:SWEEP:COUNT 6
//Change trace modes for IQ channel
DISP:TRAC1:MODE BLANK
DISP:TRAC2:MODE MAXH
DISP:TRAC3:MODE MINH
//Switch to single sweep mode
INIT:CONT OFF
//switch back to first (default) analyzer channel
INST:SEL 'Spectrum';*WAI
//Switch into SEM
SENSe:SWEep:MODE ESPectrum
//Load Sem standard file for W-CDMA
SENSe:ESPectrum:PRESet:STANdard 'WCDMA\3GPP\DL\3GPP_DL.xml'
//Set sweep count in Spectrum channel
SENS:SWEEP:COUNT 5

//----------Creating a second measurement channel ----------------

//Create second IQ channel
INSTrument:CREate:NEW IQ,'IQ 2'
//Set sweep count
SENS:SWEEP:COUNT 2
//Change trace modes
DISP:TRAC1:MODE MAXH
DISP:TRAC2:MODE MINH
//Create new analyzer channel
INSTrument:CREate:NEW SANalyzer,'Spectrum 2'
//Activate ACLR measurement in channel 'Spectrum 2'
CALCulate:MARKer:FUNCtion:POWer:SELect ACPower
//Load W-CDMA Standard
CALCulate:MARKer:FUNCtion:POWer:PRESet FW3Gppcdma
//Change trace modes
DISP:TRAC2:MODE MAXH
DISP:TRAC1:MODE MINH

//--------Performing a sweep and retrieving results----------------

//Change sweep count
SENS:SWEep:COUNt 7
//Single Sweep mode
INIT:CONT OFF
//Switch back to first IQ channel
INST:SEL 'IQ 1';*WAI
//Perform a measurement
INIT:IMM;*OPC?
//Retrieve results
CALC:MARK:Y?
//Activate Multiview
DISPlay:ATAB     ON

//---------Performing a sequence of measurements with the Sequencer------------
//Activate Sequencer
SYSTem:SEQuencer ON
//Start sweep in Sequencer
INITiate:SEQuencer:IMMediate;*OPC?
//Switch into first IQ channel to get results
INST:SEL 'IQ 1';*WAI
CALCulate:MARKer:MAXimum
CALC:MARK:Y?
//Change sweep time in IQ
SENS:SWE:TIME 300us
//Switch to single Sequencer mode
INITiate:SEQuencer:MODE SINGle
//Sweep all channels once, taking the sweep count in each channel into account
INITiate:SEQuencer:IMMediate;*OPC?
//Set marker to maximum in IQ1 and query result
CALCulate:MARKer:MAXimum
CALC:MARK:Y?
//Switch to second IQ channel and retrieve results
INST:SEL 'IQ 2';*WAI
CALCulate:MARKer:MIN
CALC:MARK:Y?
//Switch to first Spectrum channel
INST:SEL 'Spectrum';*WAI
//Query one of the SEM results
CALCulate:MARKer:FUNCtion:POWer:RESult? CPOWer
//Switch to second Spectrum channel
INST:SEL 'Spectrum 2';*WAI
//Query channel power result
CALCulate:MARKer:FUNCtion:POWer:RESult? ACPower


Configuring and Performing Measurements

Remote Commands > Configuring and Performing Measurements
Configuring and Performing Measurements

The following commands are required to configure measurements in a remote environment. The tasks for manual operation are described in "Measurements".

Contents
  • Performing Measurements
  • Configuring Power Measurements
  • Measuring the Channel Power and ACLR
  • Measuring the Carrier-to-Noise Ratio
  • Measuring the Occupied Bandwidth
  • Measuring the Spectrum Emission Mask
  • Measuring Spurious Emissions
  • Analyzing Statistics (APD, CCDF)
  • Measuring the Time Domain Power
  • Measuring the Harmonic Distortion
  • Measuring the Third Order Intercept Point
  • Measuring the AM Modulation Depth
  • Remote Commands for EMI Measurements
  • List Evaluations
  • Measuring the Pulse Power


Performing Measurements

Remote Commands > Configuring and Performing Measurements > Performing Measurements
Performing Measurements
Useful commands for performing measurements described elsewhere
  • INITiate:​ESPectrum
  • INITiate:​SPURious
Remote commands exclusive for performing measurements:
List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
[SENSe:]SWEep:COUNt:CURRent?


ABORt

Remote Commands > Configuring and Performing Measurements > Performing Measurements > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution".

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

Remote Commands > Configuring and Performing Measurements > Performing Measurements > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Example: | INIT:CONT OFF Switches to single sweep mode. DISP:WIND:TRAC:MODE AVER Switches on trace averaging. SWE:COUN 20 Setting the sweep counter to 20 sweeps. INIT;*WAI Starts the measurement and waits for the end of the 20 sweeps. INIT:CONM;*WAI Continues the measurement (next 20 sweeps) and waits for the end. Result: Averaging is performed over 40 sweeps.
Manual operation: | See "Continue Single Sweep"


INITiate:CONTinuous

Remote Commands > Configuring and Performing Measurements > Performing Measurements > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Frequency Sweep"
See "Zero Span"
See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Remote Commands > Configuring and Performing Measurements > Performing Measurements > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

With sweep count or average count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example: | INIT:CONT OFF Switches to single sweep mode. DISP:WIND:TRAC:MODE AVER Switches on trace averaging. SWE:COUN 20 Sets the sweep counter to 20 sweeps. INIT;*WAI Starts the measurement and waits for the end of the 20 sweeps.
Example: | See "Programming Example: Performing a Basic Frequency Sweep".
Manual operation: | See "Frequency Sweep" See "Zero Span" See "Single Sweep/ RUN SINGLE"


[SENSe:]SWEep:COUNt:CURRent?

Remote Commands > Configuring and Performing Measurements > Performing Measurements > [SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:CURRent?

This query returns the current number of started sweeps or measurements. This command is only available if a sweep count value is defined and the instrument is in single sweep mode.

Example: | SWE:COUNt 64 Sets sweep count to 64 INIT:CONT OFF Switches to single sweep mode INIT Starts a sweep (without waiting for the sweep end!) SWE:COUN:CURR? Queries the number of started sweeps
Usage: | Query only


Configuring Power Measurements

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements
Configuring Power Measurements

The following commands work for several power measurements.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:POWer:MODE
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:POWer:SELect
CALCulate<n>:MARKer<m>:FUNCtion:POWer[:STATe]
[SENSe:]POWer:ACHannel:PRESet
[SENSe:]POWer:ACHannel:PRESet:RLEVel
[SENSe:]POWer:TRACe


CALCulate<n>:MARKer<m>:FUNCtion:POWer:MODE

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements > CALCulate<n>:MARKer<m>:FUNCtion:POWer:MODE
CALCulate<n>:MARKer<m>:FUNCtion:POWer:MODE <Mode>

This command selects the trace display mode for power measurements.

Parameters:
<Mode> | WRITe The power is calculated from the current trace. MAXHold The power is calculated from the current trace and compared with the previous power value using a maximum algorithm.
Manual operation: | See "Power Mode"


CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements > CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult? <Measurement>

This command queries the results of power measurements.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement; for all other measurements: irrelevant

Query parameters:
<Measurement>
ACPower | MCACpower

ACLR measurements (also known as adjacent channel power or multicarrier adjacent channel measurements).

Returns the power for every active transmission and adjacent channel. The order is:

• power of the transmission channels

• power of adjacent channel (lower,upper)

• power of alternate channels (lower,upper)

MSR ACLR results:

For MSR ACLR measurements, the order of the returned results is slightly different:

• power of the transmission channels

• total power of the transmission channels for each sub block

• power of adjacent channels (lower, upper)

• power of alternate channels (lower, upper)

• power of gap channels (lower1, upper1, lower2, upper2)

The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

CN

Carrier-to-noise measurements.

Returns the C/N ratio in dB.

CN0

Carrier-to-noise measurements.

Returns the C/N ratio referenced to a 1 Hz bandwidth in dBm/Hz.

CPOWer

Channel power measurements.

Returns the channel power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the channel power of the reference range (in the specified sub block).

PPOWer

Peak power measurements.

Returns the peak power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the peak power of the reference range (in the specified sub block).

OBANdwidth | OBWidth

Occupied bandwidth.

Returns the occupied bandwidth in Hz.

Example:

See "Example: Configuring and Performing an ACLR Measurement".

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Example:

See "Programming example: Measuring the carrier-to-noise ratio".

Example:

See "Programming Example: OBW Measurement".

Example:

See "Programming Examples (-K73)" .

Example:

See "Programming Examples ( BTS)"

Usage: Query only
Manual operation: See "Ch Power ACLR"
See "C/N, C/No"
See "OBW"
See "Spectrum Emission Mask"
See "C/N"
See "C/No"


CALCulate<n>:MARKer<m>:FUNCtion:POWer:SELect

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements > CALCulate<n>:MARKer<m>:FUNCtion:POWer:SELect
CALCulate<n>:MARKer<m>:FUNCtion:POWer:SELect <MeasType>

This command selects a power measurement and turns the measurement on.

Parameters:
<MeasType> | ACPower | MCACpower Adjacent channel leakage ratio (ACLR) aka adjacent channel power or multicarrier adjacent channel. The R&S FSW performs the measurement on the trace selected with [SENSe:​]POWer:​TRACe. CPOWer Channel power measurement with a single carrier. The R&S FSW performs the measurement on the trace selected with [SENSe:​]POWer:​TRACe. OBANdwidth | OBWidth Occupied bandwidth measurement. The R&S FSW performs the measurement on the trace that marker 1 is positioned on. CN Carrier-to-noise ratio measurement. CN0 Carrier-to-noise ratio measurement referenced to 1 Hz bandwidth
Example: | See "Example: Configuring and Performing an ACLR Measurement".
Example: | See "Example: Configuring and Performing an MSR ACLR Measurement".
Example: | See "Programming example: Measuring the carrier-to-noise ratio".
Example: | See "Programming Example: OBW Measurement"
Manual operation: | See "Ch Power ACLR" See "C/N, C/No" See "OBW" See "C/N" See "C/No"


CALCulate<n>:MARKer<m>:FUNCtion:POWer[:STATe]

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements > CALCulate<n>:MARKer<m>:FUNCtion:POWer[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:POWer[:STATe] <State>

This command turns a power measurement on and off.

You can select a particular power measurement with CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "C/N"
See "C/No"


[SENSe:]POWer:ACHannel:PRESet

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements > [SENSe:]POWer:ACHannel:PRESet
[SENSe:]POWer:ACHannel:PRESet <Measurement>

This command determines the ideal span, bandwidths and detector for the current power measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<Measurement> | ACPower | MCACpower ACLR measurement CPOWer channel power measurement OBANdwidth | OBWidth Occupied bandwidth measurement CN Carrier to noise ratio CN0 Carrier to noise ration referenced to a 1 Hz bandwidth
Example: | See "Example: Configuring and Performing an ACLR Measurement".
Example: | See "Programming example: Measuring the carrier-to-noise ratio".
Example: | See "Programming Example: OBW Measurement".
Manual operation: | See "Optimized Settings (Adjust Settings)" See "Adjust Settings" See "Adjust Settings"


[SENSe:]POWer:ACHannel:PRESet:RLEVel

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements > [SENSe:]POWer:ACHannel:PRESet:RLEVel
[SENSe:]POWer:ACHannel:PRESet:RLEVel

This command determines the ideal reference level for the current measurement.

This automatic routine makes sure that the that the signal power level does not overload the R&S FSW or limit the dynamic range by too small a S/N ratio.

To determine the best reference level, the R&S FSW aborts current measurements and performs a series of test sweeps. After it has finished the test, it continues with the actual measurement.

To get a valid result, you have to perform a complete sweep with synchronization to the sweep end. This is only possible in single sweep mode.

Example: | See "Example: Configuring and Performing an ACLR Measurement".
Example: | See "Programming example: Measuring the carrier-to-noise ratio".
Example: | See "Programming Example: OBW Measurement"
Usage: | Event


[SENSe:]POWer:TRACe

Remote Commands > Configuring and Performing Measurements > Configuring Power Measurements > [SENSe:]POWer:TRACe
[SENSe:]POWer:TRACe <TraceNumber>

This command selects the trace channel power measurements are performed on.

For the measurement to work, the corresponding trace has to be active.

Parameters:
<TraceNumber>
Range: | 1 to 6
*RST: | 1
Example: POW:TRAC 2

Assigns the measurement to trace 2.

Manual operation: See "Selected Trace"


Measuring the Channel Power and ACLR

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR
Measuring the Channel Power and ACLR

All remote control commands specific to channel power or ACLR measurements are described here.

See also "Configuring Power Measurements".

Contents
  • Managing Measurement Configurations
  • Configuring the Channels
  • Defining Weighting Filters
  • Selecting the Reference Channel
  • Checking Limits
  • General ACLR Measurement Settings
  • Configuring MSR ACLR Measurements
  • Performing an ACLR Measurement
  • Analyzing Measurement Results
  • Programming Examples for Channel Power Measurements


Managing Measurement Configurations

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Managing Measurement Configurations
Managing Measurement Configurations

The following commands control measurement configurations for ACLR measurements.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:POWer:PRESet
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:CATalog?
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:DELete
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:SAVE


CALCulate<n>:MARKer<m>:FUNCtion:POWer:PRESet

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Managing Measurement Configurations > CALCulate<n>:MARKer<m>:FUNCtion:POWer:PRESet
CALCulate<n>:MARKer<m>:FUNCtion:POWer:PRESet <Standard>

This command loads a measurement configuration.

The measurement configuration for power measurements consists of weighting filter, channel bandwidth and spacing, resolution and video bandwidth, detector and sweep time.

If the "Multi-Standard Radio" standard is selected (see "Standard"), different commands are required to configure ACLR measurements (see "Configuring MSR ACLR Measurements").

Parameters:
<Standard> | For more information see "Reference: Predefined CP/ACLR Standards". If you want to load a customized configuration, the parameter is a string containing the file name.
Example: | See "Example: Configuring and Performing an ACLR Measurement".
Manual operation: | See "Predefined Standards" See "User-Defined Standards"


CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:CATalog?

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Managing Measurement Configurations > CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:CATalog?
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:CATalog?

This command queries all files containing ACLR standards.

Return values:
<Standards> | List of standard files.
Usage: | Query only
Manual operation: | See "User-Defined Standards"


CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:DELete

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Managing Measurement Configurations > CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:DELete
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:DELete <Standard>

This command deletes a file containing an ACLR standard.

Parameters:
<Standard> | String containing the file name of the standard.
Usage: | Event
Manual operation: | See "User-Defined Standards"


CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:SAVE

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Managing Measurement Configurations > CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:SAVE
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:SAVE <Standard>

This command saves the current ACLR measurement configuration as a new ACLR standard.

The measurement configuration for power measurements consists of weighting filter, channel bandwidth and spacing, resolution and video bandwidth, detector and sweep time.

Parameters:
<Standard> | String containing the file name. The file format is xml.
Example: | See "Example: Configuring and Performing an ACLR Measurement".
Manual operation: | See "User-Defined Standards"


Configuring the Channels

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels
Configuring the Channels

The following commands configure channels for channel power and ACLR measurements.

List of Commands
[SENSe:]POWer:ACHannel:ACPairs
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ACHannel
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ALTernate<ch>
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:NAME:ACHannel
[SENSe:]POWer:ACHannel:NAME:ALTernate<ch>
[SENSe:]POWer:ACHannel:NAME:CHANnel<ch>
[SENSe:]POWer:ACHannel:SPACing[:ACHannel]
[SENSe:]POWer:ACHannel:SPACing:ALTernate<ch>
[SENSe:]POWer:ACHannel:SPACing:CHANnel<ch>
[SENSe:]POWer:ACHannel:TXCHannel:COUNt


[SENSe:]POWer:ACHannel:ACPairs

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:ACPairs
[SENSe:]POWer:ACHannel:ACPairs <ChannelPairs>

This command defines the number of pairs of adjacent and alternate channels.

Parameters:
<ChannelPairs>
Range: | 0 to 12
*RST: | 1
Manual operation: See "Number of Channels (Tx, ADJ)"
See "Number of Adjacent Channels (ADJ Count)"


[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ACHannel

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ACHannel
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ACHannel <Bandwidth>

This command defines the channel bandwidth of the adjacent channel.

The adjacent channel is the first pair of channels next to the transmission channels. If you set the channel bandwidth for these channels, the R&S FSW sets the bandwidth of the alternate channels to the same value.

Steep-edged channel filters are available for fast ACLR measurements.

Parameters:
<Bandwidth>
Range: | 100 Hz to 1000 MHz
*RST: | 14 kHz
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Manual operation: See "Channel Bandwidths"
See "Adjacent Channel Bandwidths"


[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ALTernate<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ALTernate<ch>
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ALTernate<ch> <Bandwidth>

This command defines the channel bandwidth of the alternate channels.

If you set the channel bandwidth for the first alternate channel, the R&S FSW sets the bandwidth of the other alternate channels to the same value, but not the other way round. The command works hierarchically: to set a bandwidth of the 3rd and 4th channel, you have to set the bandwidth of the 3rd channel first.

Steep-edged channel filters are available for fast ACLR measurements.

Parameters:
<Bandwidth>
Range: | 100 Hz to 1000 MHz
*RST: | 14 kHz
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Manual operation: See "Channel Bandwidths"
See "Adjacent Channel Bandwidths"


[SENSe:]POWer:ACHannel:BANDwidth|BWIDth[:CHANnel<ch>]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:BANDwidth|BWIDth[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth[:CHANnel<ch>] <Bandwidth>

This command defines the channel bandwidth of the transmission channels.

Steep-edged channel filters are available for fast ACLR measurements.

Parameters:
<Bandwidth>
Range: | 100 Hz to 1000 MHz
*RST: | 14 kHz
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Example:

See "Programming Example: OBW Measurement"

Manual operation: See "Channel Bandwidths"
See "Channel Bandwidth"
See "Channel Bandwidth"


[SENSe:]POWer:ACHannel:NAME:ACHannel

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:NAME:ACHannel
[SENSe:]POWer:ACHannel:NAME:ACHannel <Name>

This command defines a name for the adjacent channel.

For MSR ACLR measurements, the channel names cannot be defined manually. In this case, this command is for query only.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Parameters:
<Name>

String containing the name of the channel

*RST: ADJ
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Channel Names"


[SENSe:]POWer:ACHannel:NAME:ALTernate<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:NAME:ALTernate<ch>
[SENSe:]POWer:ACHannel:NAME:ALTernate<ch> <Name>

This command defines a name for an alternate channel.

For MSR ACLR measurements, the channel names cannot be defined manually. In this case, this command is for query only.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Parameters:
<Name>

String containing the name of the channel

*RST: ALT<1...11>
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Channel Names"


[SENSe:]POWer:ACHannel:NAME:CHANnel<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:NAME:CHANnel<ch>
[SENSe:]POWer:ACHannel:NAME:CHANnel<ch> <Name>

This command defines a name for a transmission channel.

Parameters:
<Name>

String containing the name of the channel

*RST: TX<1...12>
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Channel Names"


[SENSe:]POWer:ACHannel:SPACing[:ACHannel]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:SPACing[:ACHannel]
[SENSe:]POWer:ACHannel:SPACing[:ACHannel] <Spacing>

This command defines the distance from transmission channel to adjacent channel.

For MSR signals, this command defines the distance from the CF of the first Tx channel in the first sub block to the lower adjacent channel, and the distance from the CF of the last Tx channel in the last sub block to the upper adjacent channel.

A change of the adjacent channel spacing causes a change in the spacing of all alternate channels below the adjacent channel.

Parameters:
<Spacing>
Range: | 100 Hz to 2000 MHz
*RST: | 14 kHz
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Usage: SCPI confirmed
Manual operation: See "Channel Spacings"
See "Adjacent Channel Spacings"


[SENSe:]POWer:ACHannel:SPACing:ALTernate<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:SPACing:ALTernate<ch>
[SENSe:]POWer:ACHannel:SPACing:ALTernate<ch> <Spacing>

This command defines the distance from transmission channel to alternate channels.

For MSR signals, this command defines the distance from the CF of the first Tx channel in the first sub block to the lower alternate channel, and the distance from the CF of the last Tx channel in the last sub block to the upper alternate channel.

If you set the channel spacing for the first alternate channel, the R&S FSW adjusts the spacing of alternate channels of a lower order, but not the other way round. The command works hierarchically: to set a distance from the transmission channel to the 2nd and 3rd alternate channel, you have to define a spacing for the 2nd alternate channel first.

Parameters:
<Spacing>
Range: | 100 Hz to 2000 MHz
*RST: | 40 kHz (ALT1), 60 kHz (ALT2), 80 kHz (ALT3), ...
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Manual operation: See "Channel Spacings"
See "Adjacent Channel Spacings"


[SENSe:]POWer:ACHannel:SPACing:CHANnel<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:SPACing:CHANnel<ch>
[SENSe:]POWer:ACHannel:SPACing:CHANnel<ch> <Spacing>

This command defines the distance between transmission channels.

If you set the channel spacing for a transmission channel, the R&S FSW sets the spacing of the lower transmission channels to the same value, but not the other way round. The command works hierarchically: to set a distance between the 2nd and 3rd and 3rd and 4th channel, you have to set the spacing between the 2nd and 3rd channel first.

Parameters:
<Spacing>
Range: | 14 kHz to 2000 MHz
*RST: | 20 kHz
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Channel Spacings"


[SENSe:]POWer:ACHannel:TXCHannel:COUNt

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring the Channels > [SENSe:]POWer:ACHannel:TXCHannel:COUNt
[SENSe:]POWer:ACHannel:TXCHannel:COUNt <Number>

This command defines the number of transmission channels.

The command works for measurements in the frequency domain.

Parameters:
<Number>
Range: | 1 to 18
*RST: | 1
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Number of Channels (Tx, ADJ)"


Defining Weighting Filters

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters
Defining Weighting Filters

The following commands define weighting filters for ACLR measurements.

List of Commands
[SENSe:]POWer:ACHannel:FILTer:ALPHa:ACHannel
[SENSe:]POWer:ACHannel:FILTer:ALPHa[:ALL]
[SENSe:]POWer:ACHannel:FILTer:ALPHa:ALTernate<ch>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ACHannel
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALL
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALTernate<ch>
[SENSe:]POWer:ACHannel:FILTer[:STATe]:CHANnel<ch>


[SENSe:]POWer:ACHannel:FILTer:ALPHa:ACHannel

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer:ALPHa:ACHannel
[SENSe:]POWer:ACHannel:FILTer:ALPHa:ACHannel <Alpha>

This command defines the roll-off factor for the adjacent channel weighting filter.

Parameters:
<Alpha>

Roll-off factor

Range: | 0 to 1
*RST: | 0.22
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Weighting Filters"
See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer:ALPHa[:ALL]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer:ALPHa[:ALL]
[SENSe:]POWer:ACHannel:FILTer:ALPHa[:ALL] <Value>

This command defines the alpha value for the weighting filter for all channels.

Parameters:
<Value>
<numeric value>
*RST: 0.22
Example: POW:ACH:FILT:ALPH:ALL 0.35


[SENSe:]POWer:ACHannel:FILTer:ALPHa:ALTernate<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer:ALPHa:ALTernate<ch>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:ALTernate<ch> <Alpha>

This command defines the roll-off factor for the alternate channel weighting filter.

Parameters:
<Alpha>

Roll-off factor

Range: | 0 to 1
*RST: | 0.22
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Weighting Filters"
See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer:ALPHa:CHANnel<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer:ALPHa:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:CHANnel<ch> <Alpha>

This command defines the roll-off factor for the transmission channel weighting filter.

Parameters:
<Alpha>

Roll-off factor

Range: | 0 to 1
*RST: | 0.22
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer[:STATe]:ACHannel

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer[:STATe]:ACHannel
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ACHannel <State>

This command turns the weighting filter for the adjacent channel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Weighting Filters"
See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALL

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer[:STATe]:ALL
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALL <State>

This command turns the weighting filters for all channels on and off.

Parameters:
<State>
ON | OFF
*RST: OFF


[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALTernate<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer[:STATe]:ALTernate<ch>
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALTernate<ch> <State>

This command turns the weighting filter for an alternate channel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Weighting Filters"
See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer[:STATe]:CHANnel<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Defining Weighting Filters > [SENSe:]POWer:ACHannel:FILTer[:STATe]:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer[:STATe]:CHANnel<ch> <State>

This command turns the weighting filter for a transmission channel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Weighting Filters"


Selecting the Reference Channel

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Selecting the Reference Channel
Selecting the Reference Channel

The following commands define the reference channel for relative ACLR measurements.

List of Commands
[SENSe:]POWer:ACHannel:REFerence:AUTO ONCE
[SENSe:]POWer:ACHannel:REFerence:TXCHannel:AUTO
[SENSe:]POWer:ACHannel:REFerence:TXCHannel:MANual


[SENSe:]POWer:ACHannel:REFerence:AUTO ONCE

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Selecting the Reference Channel > [SENSe:]POWer:ACHannel:REFerence:AUTO ONCE
[SENSe:]POWer:ACHannel:REFerence:AUTO ONCE

This command sets the channel power as the reference for relative ACLR measurements.

Example: | POW:ACH:REF:AUTO ONCE
Usage: | Event
Manual operation: | See "Setting a Fixed Reference for Channel Power Measurements (Set CP Reference)"


[SENSe:]POWer:ACHannel:REFerence:TXCHannel:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Selecting the Reference Channel > [SENSe:]POWer:ACHannel:REFerence:TXCHannel:AUTO
[SENSe:]POWer:ACHannel:REFerence:TXCHannel:AUTO <RefChannel>

This command selects the reference channel for relative measurements.

You need at least one channel for the command to work.

Parameters:
<RefChannel> | MINimum Transmission channel with the lowest power MAXimum Transmission channel with the highest power LHIGhest Lowest transmission channel for lower adjacent channels and highest transmission channel for upper adjacent channels
Example: | POW:ACH:REF:TXCH:AUTO MAX Selects the channel with the peak power as reference channel.
Manual operation: | See "Reference Channel"


[SENSe:]POWer:ACHannel:REFerence:TXCHannel:MANual

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Selecting the Reference Channel > [SENSe:]POWer:ACHannel:REFerence:TXCHannel:MANual
[SENSe:]POWer:ACHannel:REFerence:TXCHannel:MANual <ChannelNumber>

This command defines a reference channel for relative ACLR measurements.

You need at least one channel for the command to work.

Note that this command is not available for MSR ACLR measurements (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

Parameters:
<ChannelNumber>
Range: | 1 to 18
*RST: | 1
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Reference Channel"


Checking Limits

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits
Checking Limits

The following commands configure and query limit checks for channel power and ACLR measurements.

The results of the power limit checks are also indicated in the STAT:QUES:ACPL status registry (see "STATus:QUEStionable:ACPLimit Register").

List of Commands
CALCulate:LIMit:ACPower:ACHannel:ABSolute
CALCulate:LIMit:ACPower:ACHannel:ABSolute:STATe
CALCulate:LIMit:ACPower:ACHannel[:RELative]
CALCulate:LIMit:ACPower:ACHannel:RESult?
CALCulate:LIMit:ACPower:ACHannel[:RELative]:STATe
CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute
CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute:STATe
CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]
CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?
CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]:STATe
CALCulate:LIMit:ACPower[:STATe]


CALCulate:LIMit:ACPower:ACHannel:ABSolute

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ACHannel:ABSolute
CALCulate:LIMit:ACPower:ACHannel:ABSolute <LowerLimit>, <UpperLimit>

This command defines the absolute limit of the adjacent channels.

If you have defined an absolute limit as well as a relative limit, the R&S FSW uses the lower value for the limit check.

Parameters:
<LowerLimit>, <UpperLimit>

The first value defines the limit of the lower adjacent channel, the second value the limit of the upper adjacent channel.

Range: | -200 dBm to 200 dBm
*RST: | -200 dBm
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower:ACHannel:ABSolute:STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ACHannel:ABSolute:STATe
CALCulate:LIMit:ACPower:ACHannel:ABSolute:STATe <State>

This command turns the absolute limit check for the adjacent channels on and off.

You have to activate the general ACLR limit check before using this command with CALCulate:​LIMit:​ACPower[:​STATe].

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower:ACHannel[:RELative]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ACHannel[:RELative]
CALCulate:LIMit:ACPower:ACHannel[:RELative] <LowerLimit>, <UpperLimit>

This command defines the relative limit of the adjacent channels. The reference value for the relative limit is the measured channel power.

If you have defined an absolute limit as well as a relative limit, the R&S FSW uses the lower value for the limit check.

Parameters:
<LowerLimit>, <UpperLimit>

The first value defines the limit of the lower adjacent channel, the second value the limit of the upper adjacent channel.

Range: | 0 dB to 100 dB
*RST: | 0 dB
Default unit: | dB
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower:ACHannel:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ACHannel:RESult?
CALCulate:LIMit:ACPower:ACHannel:RESult?

This command queries the state of the limit check for the adjacent channels in an ACLR measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<LowerACH>, <UpperACH> | text value The command returns two results. The first is the result for the lower, the second for the upper adjacent channel. PASSED Limit check has passed. FAIL Limit check has failed.
Example: | INIT:IMM;*WAI; CALC:LIM:ACP:ACH:RES? PASSED,PASSED
Example: | See "Example: Configuring and Performing an ACLR Measurement".
Usage: | Query only
Manual operation: | See "Limit Checking" See "Limit Checking"


CALCulate:LIMit:ACPower:ACHannel[:RELative]:STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ACHannel[:RELative]:STATe
CALCulate:LIMit:ACPower:ACHannel[:RELative]:STATe <State>

This command turns the relative limit check for the adjacent channels on and off.

You have to activate the general ACLR limit check before using this command with CALCulate:​LIMit:​ACPower[:​STATe].

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute
CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute <LowerLimit>, <UpperLimit>

This command defines the absolute limit of the alternate channels.

If you have defined an absolute limit as well as a relative limit, the R&S FSW uses the lower value for the limit check.

Parameters:
<LowerLimit>, <UpperLimit>

The first value defines the limit of the lower alternate channel, the second value the limit of the upper alternate channel.

Range: | -200 dBm to 200 dBm
*RST: | -200 dBm
Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute:STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute:STATe
CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute:STATe <State>

This command turns the absolute limit check for the alternate channels on and off.

You have to activate the general ACLR limit check before using this command with CALCulate:​LIMit:​ACPower[:​STATe].

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]
CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative] <LowerLimit>, <UpperLimit>

This command defines the relative limit of the alternate channels. The reference value for the relative limit is the measured channel power.

If you have defined an absolute limit as well as a relative limit, the R&S FSW uses the lower value for the limit check.

Parameters:
<LowerLimit>, <UpperLimit>

The first value defines the limit of the lower alternate channel, the second value the limit of the upper alternate channel.

Range: | 0 dB to 100 dB
*RST: | 0 DB
Default unit: | dB
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?
CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?

This command queries the state of the limit check for the adjacent or alternate channels in an ACLR measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<LowerChan>, <UpperChan> | text value The command returns two results. The first is the result for the lower, the second for the upper adjacent or alternate channel. PASSED Limit check has passed. FAIL Limit check has failed.
Example: | INIT:IMM;*WAI; CALC:LIM:ACP:ACH:RES? PASSED,PASSED
Example: | See "Example: Configuring and Performing an ACLR Measurement".
Usage: | Query only


CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]:STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]:STATe
CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]:STATe <State>

This command turns the relative limit check for the alternate channels on and off.

You have to activate the general ACLR limit check before using this command with CALCulate:​LIMit:​ACPower[:​STATe].

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Limit Checking"
See "Limit Checking"


CALCulate:LIMit:ACPower[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Checking Limits > CALCulate:LIMit:ACPower[:STATe]
CALCulate:LIMit:ACPower[:STATe] <State>

This command turns the limit check for ACLR measurements on and off.

In addition, limits must be defined and activated individually for each channel (see CALCulate:​LIMit:​ACPower:​ACHannel[:​RELative]:​STATe, CALCulate:​LIMit:​ACPower:​ALTernate<ch>[:​RELative]:​STATe, CALCulate:​LIMit:​ACPower:​GAP<gap>:​ABSolute:​STATe and CALCulate:​LIMit:​ACPower:​GAP<gap>[:​RELative:​]STATe).

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Limit Checking"
See "Limit Checking"
See "Limit Checking"
See "Limit Checking"


General ACLR Measurement Settings

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > General ACLR Measurement Settings
General ACLR Measurement Settings

The following commands control the measurement algorithm.

Useful commands for the ACLR measurement described elsewhere:
  • [SENSe:​]POWer:​NCORrection
  • [SENSe:​]POWer:​ACHannel:​PRESet
  • [SENSe:​]POWer:​ACHannel:​PRESet:​RLEVel
  • [SENSe:​]POWer:​TRACe
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​MODE
Remote commands exclusive to ACLR measurement
List of Commands
[SENSe:]POWer:HSPeed


[SENSe:]POWer:HSPeed

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > General ACLR Measurement Settings > [SENSe:]POWer:HSPeed
[SENSe:]POWer:HSPeed <State>

This command turns high speed ACLR and channel power measurements on and off.

If on, the R&S FSW performs a measurement on each channel in the time domain. It returns to the frequency domain when the measurement is done.

In some telecommunications standards, high speed measurements use weighting filters with characteristic or steep-edged channel filters for band limitation.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: POW:HSP ON
Manual operation: See "Fast ACLR"


Configuring MSR ACLR Measurements

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements
Configuring MSR ACLR Measurements

If the "Multi-Standard Radio" standard is selected (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet), the channels for the ACLR measurement are configured differently. (For more information see "Measurement on Multi-Standard Radio (MSR) Signals".)

In this case, use the following commands.

Useful commands for configuring MSR ACLR measurements described elsewhere:
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​RESult:​PHZ
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​MODE
  • CALCulate:​LIMit:​ACPower[:​STATe]
  • [SENSe:​]POWer:​ACHannel:​REFerence:​TXCHannel:​AUTO
  • [SENSe:​]POWer:​NCORrection
  • [SENSe:​]POWer:​TRACe
  • [SENSe:​]POWer:​ACHannel:​MODE
  • [SENSe:​]POWer:​ACHannel:​PRESet
Remote commands exclusive to configuring MSR ACLR measurements
List of Commands
CALCulate:LIMit:ACPower:GAP<gap>:ABSolute
CALCulate:LIMit:ACPower:GAP<gap>:ABSolute:STATe
CALCulate:LIMit:ACPower:GAP<gap>[:RELative]
CALCulate:LIMit:ACPower:GAP<gap>[:RELative:]STATe
CALCulate:LIMit:ACPower:GAP<gap>:RESult?
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:GAP<gap>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:GAP<gap>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:SBLock<sb>:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer:STATe:GAP<gap>
[SENSe:]POWer:ACHannel:FILTer:STATe:SBLock<sb>:CHANnel<ch>
[SENSe:]POWer:ACHannel:SBCount
[SENSe:]POWer:ACHannel:SBLock<sb>:BANDwidth|BWIDth[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:CENTer[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:FREQuency:CENTer
[SENSe:]POWer:ACHannel:SBLock<sb>:NAME[:CHANnel<ch>]?
[SENSe:]POWer:ACHannel:SBLock<sb>:RFBWidth
[SENSe:]POWer:ACHannel:SBLock<sb>:TECHnology[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:TXCHannel:COUNt
[SENSe:]POWer:ACHannel:SPACing:GAP<gap>


CALCulate:LIMit:ACPower:GAP<gap>:ABSolute

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > CALCulate:LIMit:ACPower:GAP<gap>:ABSolute
CALCulate:LIMit:ACPower:GAP<gap>:ABSolute <Limit>, <Reserved>

This command defines the absolute limit of the specified gap (CACLR) channel.

If you have defined an absolute limit as well as a relative limit, the R&S FSW uses the lower value for the limit check.

Suffix: |
<gap> | 1 | 2 Gap (CACLR) channel number
Parameters:
<Limit> | Defines the absolute limit of the specified gap channel in dBm.
<Reserved> | Ignored.
Example: | CALC:LIM:ACP:GAP2:ABS 44.2dBm,0
Manual operation: | See "Limit Checking"


CALCulate:LIMit:ACPower:GAP<gap>:ABSolute:STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > CALCulate:LIMit:ACPower:GAP<gap>:ABSolute:STATe
CALCulate:LIMit:ACPower:GAP<gap>:ABSolute:STATe <State>

This command turns the absolute limit check for the specified gap (CACLR) channel on and off.

You have to activate the general ACLR limit check before using this command with CALCulate:​LIMit:​ACPower[:​STATe].

Suffix:
<gap>
1 | 2

Gap (CACLR) channel number

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Limit Checking"


CALCulate:LIMit:ACPower:GAP<gap>[:RELative]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > CALCulate:LIMit:ACPower:GAP<gap>[:RELative]
CALCulate:LIMit:ACPower:GAP<gap>[:RELative] <Limit>, <Reserved>

This command defines the relative limit of the specified gap (CACLR) channel. The reference value for the relative limit is the measured channel power.

If you have defined an absolute limit as well as a relative limit, the R&S FSW uses the lower value for the limit check.

Suffix: |
<gap> | 1 | 2 Gap (CACLR) channel number
Parameters:
<Limit> | Defines the relative limit of the specified gap channel in dB.
<Reserved> | Ignored.
Example: | CALC:LIM:ACP:GAP1:REL 3dB,0
Manual operation: | See "Limit Checking"


CALCulate:LIMit:ACPower:GAP<gap>[:RELative:]STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > CALCulate:LIMit:ACPower:GAP<gap>[:RELative:]STATe
CALCulate:LIMit:ACPower:GAP<gap>[:RELative:]STATe <State>

This command turns the relative limit check for the specified gap (CACLR) channel on and off.

You have to activate the general ACLR limit check before using this command with CALCulate:​LIMit:​ACPower[:​STATe].

Suffix:
<gap>
1 | 2

Gap (CACLR) channel number

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CALC:LIM:ACP:GAP1:REL:STAT ON

Manual operation: See "Limit Checking"


CALCulate:LIMit:ACPower:GAP<gap>:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > CALCulate:LIMit:ACPower:GAP<gap>:RESult?
CALCulate:LIMit:ACPower:GAP<gap>:RESult?

This command queries the state of the limit check for all gap (CACLR) channels in an MSR ACLR measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

The results of the power limit checks are also indicated in the STAT:QUES:ACPL status registry (see "STATus:QUEStionable:ACPLimit Register").

Suffix: |
<gap> | 1 | 2 irrelevant
Return values:
<LowerGap1>, <UpperGap1>, <LowerGap2>, <UpperGap2> | The command returns the results for the four gap channels for each gap (max. 4). PASSED Limit check has passed. FAIL Limit check has failed. NONE No results available, e.g. because limit checking was deactivated
Example: | INIT:IMM;*WAI; CALC:LIM:ACP:GAP2:RES? PASSED,PASSED,
Usage: | Query only
Manual operation: | See "Limit Checking"


[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:GAP<gap>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:BANDwidth|BWIDth:GAP<gap>
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:GAP<gap> <Bandwidth>

This command defines the bandwidth of the specified MSR gap (CACLR) channel.

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix:
<gap>
1 | 2

Gap (CACLR) channel number

Parameters:
<Bandwidth>

numeric value in Hz

*RST: 3.84 MHz
Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Manual operation: See "Gap (CACLR) Channel Bandwidths"


[SENSe:]POWer:ACHannel:FILTer:ALPHa:GAP<gap>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:FILTer:ALPHa:GAP<gap>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:GAP<gap> <Alpha>

This command defines the roll-off factor for the specified gap (CACLR) channel's weighting filter.

Suffix:
<gap>
1 | 2

Gap (CACLR) channel number

Parameters:
<Alpha>

Roll-off factor

Range: | 0 to 1
*RST: | 0.22
Manual operation: See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer:ALPHa:SBLock<sb>:CHANnel<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:FILTer:ALPHa:SBLock<sb>:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:SBLock<sb>:CHANnel<ch> <Alpha>

This command defines the roll-off factor for the specified transmission channel's weighting filter.

Suffix:
<sb>
1 | 2 | 3 | 4 | 5

sub block number

Parameters:
<Alpha>

Roll-off factor

Range: | 0 to 1
*RST: | 0.22
Manual operation: See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer:STATe:GAP<gap>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:FILTer:STATe:GAP<gap>
[SENSe:]POWer:ACHannel:FILTer:STATe:GAP<gap> <State>

This command turns the weighting filter for the specified gap (CACLR) channel on and off.

Suffix:
<gap>
1 | 2

Gap (CACLR) channel number

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Weighting Filters"


[SENSe:]POWer:ACHannel:FILTer:STATe:SBLock<sb>:CHANnel<ch>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:FILTer:STATe:SBLock<sb>:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer:STATe:SBLock<sb>:CHANnel<ch> <State>

This command turns the weighting filter for the specified transmission channel on and off.

Suffix:
<sb>
1 | 2 | 3 | 4 | 5

sub block number

Parameters:
<State>
ON | OFF
*RST: W-CDMA: ON, other technologies: OFF
Manual operation: See "Weighting Filters"


[SENSe:]POWer:ACHannel:SBCount

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBCount
[SENSe:]POWer:ACHannel:SBCount <Number>

This command defines the number of sub blocks, i.e. groups of transmission channels in an MSR signal.

For more information see "Measurement on Multi-Standard Radio (MSR) Signals".

Parameters:
<Number>
Range: | 1 to 5
*RST: | 1
Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Manual operation: See "Number of Sub blocks"


[SENSe:]POWer:ACHannel:SBLock<sb>:BANDwidth|BWIDth[:CHANnel<ch>]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBLock<sb>:BANDwidth|BWIDth[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:BANDwidth|BWIDth[:CHANnel<ch>] <Bandwidth>

This command defines the bandwidth of the specified MSR Tx channel.

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix: |
<sb> | 1 | 2 | 3 | 4 | 5 sub block number
Parameters:
<Bandwidth> | Bandwidth in Hz
Example: | See "Example: Configuring and Performing an MSR ACLR Measurement".
Manual operation: | See "Tx Channel Bandwidth"


[SENSe:]POWer:ACHannel:SBLock<sb>:CENTer[:CHANnel<ch>]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBLock<sb>:CENTer[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:CENTer[:CHANnel<ch>] <Frequency>

This command defines the (absolute) center frequency of the specified MSR Tx channel.

Note that the position of the first Tx channel in the first sub block and the last Tx channel in the last sub block also affect the position of the adjacent channels.

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix: |
<sb> | 1 | 2 | 3 | 4 | 5 sub block number
Parameters:
<Frequency> | absolute frequency in Hz
Example: | See "Example: Configuring and Performing an MSR ACLR Measurement".
Manual operation: | See "Tx Center Frequency"


[SENSe:]POWer:ACHannel:SBLock<sb>:FREQuency:CENTer

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBLock<sb>:FREQuency:CENTer
[SENSe:]POWer:ACHannel:SBLock<sb>:FREQuency:CENTer <Frequency>

This command defines the center of the specified MSR sub block. Note that the position of the sub block also affects the position of the adjacent gap (CACLR) channels.

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix: |
<sb> | 1 | 2 | 3 | 4 | 5 sub block number
Parameters:
<Frequency> | absolute frequency in Hz
Example: | See "Example: Configuring and Performing an MSR ACLR Measurement".
Manual operation: | See "Sub block Center Frequency"


[SENSe:]POWer:ACHannel:SBLock<sb>:NAME[:CHANnel<ch>]?

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBLock<sb>:NAME[:CHANnel<ch>]?
[SENSe:]POWer:ACHannel:SBLock<sb>:NAME[:CHANnel<ch>]? <Name>

This command queries the name of the specified MSR Tx channel.

In MSR ACLR measurements, TX channel names correspond to the specified technology, followed by a consecutive number. The assigned sub block (A,B,C,D,E) is indicated as a prefix (e.g. A: WCDMA1). Channel names cannot be defined manually.

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix: |
<sb> | 1 | 2 | 3 | 4 | 5 sub block number
Parameters:
<Name> | String containing the name of the channel
Example: | POW:ACH:SBL2:NAME:CHAN2? Result: 'B:WCDMA'
Usage: | Query only
Manual operation: | See "Tx Channel Definition"


[SENSe:]POWer:ACHannel:SBLock<sb>:RFBWidth

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBLock<sb>:RFBWidth
[SENSe:]POWer:ACHannel:SBLock<sb>:RFBWidth <Bandwidth>

This command defines the bandwidth of the individual MSR sub block. Note that sub block ranges also affect the position of the adjacent gap channels (CACLR).

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix: |
<sb> | 1 | 2 | 3 | 4 | 5 sub block number
Parameters:
<Bandwidth> | Bandwidth in Hz
Example: | See "Example: Configuring and Performing an MSR ACLR Measurement".
Manual operation: | See "RF Bandwidth"


[SENSe:]POWer:ACHannel:SBLock<sb>:TECHnology[:CHANnel<ch>]

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBLock<sb>:TECHnology[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:TECHnology[:CHANnel<ch>] <Standard>

This command defines the technology used for transmission by the specified MSR Tx channel.

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix: |
<sb> | 1 | 2 | 3 | 4 | 5 sub block number
Parameters:
<Standard> | GSM | WCDMa | LTE_1_40 | LTE_3_00 | LTE_5_00 | LTE_10_00 | LTE_15_00 | LTE_20_00 | USER Technology used for transmission GSM Transmission according to GSM standard WCDMa Transmission according to W-CDMA standard LTE_1_40 | LTE_3_00 | LTE_5_00 | LTE_10_00 | LTE_15_00 | LTE_20_00 Transmission according to LTE standard for different channel bandwidths USER User-defined transmission; no automatic preconfiguration possible
Example: | See "Example: Configuring and Performing an MSR ACLR Measurement".
Manual operation: | See "Technology Used for Transmission"


[SENSe:]POWer:ACHannel:SBLock<sb>:TXCHannel:COUNt

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SBLock<sb>:TXCHannel:COUNt
[SENSe:]POWer:ACHannel:SBLock<sb>:TXCHannel:COUNt <Number>

This command defines the number of transmission channels the specific sub block contains.

This command is for MSR signals only (see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​PRESet).

For details on MSR signals see "Measurement on Multi-Standard Radio (MSR) Signals".

Suffix:
<sb>
1 | 2 | 3 | 4 | 5

sub block number

Parameters:
<Number>
Range: | 1 to 18
*RST: | 1
Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Manual operation: See "Number of Tx Channels (Tx Count)"


[SENSe:]POWer:ACHannel:SPACing:GAP<gap>

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Configuring MSR ACLR Measurements > [SENSe:]POWer:ACHannel:SPACing:GAP<gap>
[SENSe:]POWer:ACHannel:SPACing:GAP<gap> <Spacing>

This command defines the distance from sub block to the specified gap channel.

The channels in the upper gap are identical to those in the lower gap. Thus, in the R&S FSW MSR ACLR measurement, only 2 gap channels are configured.

The spacing for gap channels is defined in relation to the outer edges of the surrounding sub blocks, i.e.

Spacing = [CF of the gap channel] - [left sub block center] + ([RF bandwidth of left sub block] /2)

(See also figure "MSR signal structure" and figure "Sub block definition".)

Suffix:
<gap>
1 | 2

Gap channel number

Parameters:
<Spacing>
numeric value in Hz
*RST: 2.5 MHz
Example:

See "Example: Configuring and Performing an MSR ACLR Measurement".

Usage: SCPI confirmed
Manual operation: See "Gap (CACLR) Channel Spacings"


Performing an ACLR Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Performing an ACLR Measurement
Performing an ACLR Measurement

The following commands are required to perform an ACLR measurement:

CALC:MARK:FUNC:POW:SEL ACP, see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect

CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]

INITiate[:​IMMediate], see "Performing Measurements"


Analyzing Measurement Results

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Analyzing Measurement Results
Analyzing Measurement Results

The following commands analyze and retrieve measurement results for ACLR measurements.

Useful commands for channel power measurements described elsewhere
  • CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?
  • TRACe<n>[:​DATA]
Remote commands exclusive to channel power measurements
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult:PHZ
[SENSe:]POWer:ACHannel:MODE


CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult:PHZ

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Analyzing Measurement Results > CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult:PHZ
CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult:PHZ <State>

This command selects the way the R&S FSW returns results for power measurements.

You can query results with CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?.

Parameters:
<State>
ON | OFF
ON

Channel power density in dBm/Hz

OFF

Channel power in dBm

*RST: OFF
Example: CALC:MARK:FUNC:POW:RES:PHZ ON

Output of results referred to the channel bandwidth.

Manual operation: See "Channel Power Levels and Density (Power Unit)"


[SENSe:]POWer:ACHannel:MODE

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Analyzing Measurement Results > [SENSe:]POWer:ACHannel:MODE
[SENSe:]POWer:ACHannel:MODE <Mode>

This command selects the way the R&S FSW displays the power of adjacent channels.

You need at least one adjacent channel for the command to work.

Parameters:
<Mode>
ABSolute

Shows the absolute power of all channels

RELative

Shows the power of adjacent and alternate channels in relation to the transmission channel

*RST: RELative
Example:

See "Example: Configuring and Performing an ACLR Measurement".

Manual operation: See "Absolute and Relative Values (ACLR Mode)"


Programming Examples for Channel Power Measurements

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Programming Examples for Channel Power Measurements
Programming Examples for Channel Power Measurements

The following programming examples are meant to demonstrate the most important commands to perform channel power measurements in a remote environment.

Contents
  • Example: Configuring and Performing an ACLR Measurement
  • Example: Configuring and Performing an MSR ACLR Measurement


Example: Configuring and Performing an ACLR Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Programming Examples for Channel Power Measurements > Example: Configuring and Performing an ACLR Measurement
Example: Configuring and Performing an ACLR Measurement

In this example we will configure and perform an adjacent-channel power measurement. Note that this example is primarily meant to demonstrate the remote control commands, it does not necessarily reflect a useful measurement task. For most common measurement standards, the R&S FSW performs the measurement optimally with the predefined settings, without further configuration.

//-------------Preparing the measurement---------------------
*RST
//Resets the instrument
INIT:CONT OFF
//Selects single sweep mode.

CALC:MARK:FUNC:POW:SEL ACP
//Activates adjacent-channel power measurement.
CALC:MARK:FUNC:POW:PRES GSM
//Selects the user standard "GSM"

//---------------Setting Up Channels------------
POW:ACH:TXCH:COUN 1
//Creates one transmission channel.
POW:ACH:NAME:CHAN1 'TX Channel'
//Names the first transmission channel 'TX Channel'.
POW:ACH:ACP 2
//Creates two adjacent channels - one adjacent channel and one alternate channel.
POW:ACH:NAME:ACH 'ABC'
//Names the adjacent channel 'ABC'
POW:ACH:NAME:ALT1 'XYZ'
//Names the first alternate channel 'XYZ'.
POW:ACH:BWID:CHAN1 30kHz
//Defines a bandwidth of 30 kHz for the transmission channel.
POW:ACH:BWID:ACH 30kHz
//Defines a bandwidth of 30 kHz for the adjacent channel.
POW:ACH:BWID:ALT1 30kHz
//Defines a bandwidth of 30 kHz for the first alternate channel.
POW:ACH:SPAC 33kHz
//Defines a distance of 33 kHz from the center of the transmission channel to the
//center of the adjacent channel.
//Also adjusts the distance to the alternate channels (66 kHz).
POW:ACH:SPAC:ALT1 100kHz
//Defines a distance of 100 kHz from the center of the transmission channel to the
//center of the first alternate channel.

//---------------Selecting a Reference Channel--
POW:ACH:MODE REL
//Selects relative display of the channel power.
POW:ACH:REF:TXCH:MAN 1
//Defines transmission channel 1 as the reference channel.

//-----------Saving the settings as a user standard--------------
CALC:MARK:FUNC:POW:STAN:SAVE 'my_aclr_standard'
//Saves the user standard with the name "my_aclr_standard".
//Weighting filters can only be defined for user-defined standards.

//---------------Defining Weighting Filters-----
POW:ACH:FILT:ALPH:CHAN1 0.35
//Defines a roll-off factor of 0.35 for the weighting filter of the first
//transmission channel.
POW:ACH:FILT:CHAN1 ON
//Turns the weighting filter for the first transmission channel on.
POW:ACH:FILT:ALPH:ACH 0.35
//Defines a roll-off factor of 0.35 for the weighting filter of the adjacent
//channel.
POW:ACH:FILT:ACH ON
//Turns the weighting filter for the adjacent channel on.
POW:ACH:FILT:ALPH:ALT1 0.35
//Defines a roll-off factor of 0.35 for the weighting filter of the first
//alternate channel.
POW:ACH:FILT:ALT1 ON
//Turns the weighting filter for the first alternate channel on.

//---------------Working with Limits------------
CALC:LIM:ACP:ACH 30DB,30DB
//Defines a relative limit of 30 dB below the power of the reference channel
//for both adjacent channels.
CALC:LIM:ACP:ALT1 25DB,25DB
//Defines a relative limit of 25 dB below the power of the reference channel
//for the first alternate channels.
CALC:LIM:ACP:ACH:ABS -35DBM,-35DBM
//Defines an absolute limit of -35 dBm for both adjacent channels.
CALC:LIM:ACP ON
//Turns the ACLR limit check on.
CALC:LIM:ACP:ACH:STAT ON
//Turns the relative limit check for adjacent channels on.
CALC:LIM:ACP:ACH:ABS:STAT ON
//Turns the absolute limit check for adjacent channels on.
CALC:LIM:ACP:ALT1:ABS:STAT ON
//Turns the absolute limit check for the first alternate channel on.

//--------------Performing the Measurement-----
POW:ACH:PRES ACP;*WAI
//Determines the ideal ACLR measurement configuration.
POW:ACH:PRES:RLEV;*WAI
//Determines the ideal reference level for the measurement.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Limit Check--------------------
CALC:LIM:ACP:ACH:RES?
//Queries the results of the limit check for the adjacent channels.
CALC:LIM:ACP:ALT1:RES?
//Queries the results of the limit check for the first alternate channels.

//---------------Retrieving Results-------------
CALC:MARK:FUNC:POW:RES? ACP
//Returns the results for the ACLR measurement.


Example: Configuring and Performing an MSR ACLR Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Channel Power and ACLR > Programming Examples for Channel Power Measurements > Example: Configuring and Performing an MSR ACLR Measurement
Example: Configuring and Performing an MSR ACLR Measurement

This example demonstrates how to configure and perform an ACLR measurement on a multi-standard radio signal in a remote environment.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST

// Select ACLR measurement
:CALCulate:MARKer:FUNCtion:POWer:SELect ACPower

// Select MSR Standard :CALCulate:MARKer:FUNCtion:POWer:PRESet MSR

//Configure general measurement settings
:SENSe:FREQuency:CENTer 1.25GHz
:SENSe:FREQuency:SPAN 62.0MHz
:SENSe:POWer:ACHannel:SBCount 3

//----------------- Configuring Sub block A

:SENSe:POWer:ACHannel:SBLock1:TXCHannel:COUNt 3
:SENSe:POWer:ACHannel:SBLock1:FREQuency:CENTer 1.230GHZ
:SENSe:POWer:ACHannel:SBLock1:RFBWidth 12MHZ

:SENSe:POWer:ACHannel:SBLock1:CENTer:CHANnel1 1.226GHZ
:SENSe:POWer:ACHannel:SBLock1:CENTer:CHANnel2 1.230GHZ
:SENSe:POWer:ACHannel:SBLock1:CENTer:CHANnel3 1.234GHZ

:SENSe:POWer:ACHannel:SBLock1:TECHnology:CHANnel1 WCDMA
:SENSe:POWer:ACHannel:SBLock1:TECHnology:CHANnel2 WCDMA
:SENSe:POWer:ACHannel:SBLock1:TECHnology:CHANnel3 GSM

:SENSe:POWer:ACHannel:SBLock1:BANDwidth:CHANnel1 2.5MHZ
:SENSe:POWer:ACHannel:SBLock1:BANDwidth:CHANnel2 2.5MHZ
:SENSe:POWer:ACHannel:SBLock1:BANDwidth:CHANnel3 2.5MHZ

//----------------- Configuring Sub block B

:SENSe:POWer:ACHannel:SBLock2:TXCHannel:COUNt 1
:SENSe:POWer:ACHannel:SBLock2:FREQuency:CENTer 1.255GHZ
:SENSe:POWer:ACHannel:SBLock2:RFBWidth 4MHZ

:SENSe:POWer:ACHannel:SBLock2:CENTer:CHANnel1 1.255GHZ

:SENSe:POWer:ACHannel:SBLock2:TECHnology:CHANnel1 LTE_1_40

:SENSe:POWer:ACHannel:SBLock2:BANDwidth:CHANnel1 3.25MHZ

//----------------- Configuring Sub block C

:SENSe:POWer:ACHannel:SBLock3:TXCHannel:COUNt 2
:SENSe:POWer:ACHannel:SBLock3:FREQuency:CENTer 1.268GHZ
:SENSe:POWer:ACHannel:SBLock3:RFBWidth 8MHZ

:SENSe:POWer:ACHannel:SBLock3:CENTer:CHANnel1 1.266GHZ
:SENSe:POWer:ACHannel:SBLock3:CENTer:CHANnel2 1.270GHZ

:SENSe:POWer:ACHannel:SBLock3:BANDwidth:CHANnel1 2.75MHZ
:SENSe:POWer:ACHannel:SBLock3:BANDwidth:CHANnel2 2.75MHZ

//----------------- Configuring ADJ channels

:SENSe:POWer:ACHannel:BANDwidth:ACHannel 1.60MHZ
:SENSe:POWer:ACHannel:BANDwidth:ALTernate1 1.60MHZ

:SENSe:POWer:ACHannel:SPACing:ACHannel 3MHZ
:SENSe:POWer:ACHannel:SPACing:ALTernate1 5MHZ

//----------------- Configuring gap (CACLR) channels

:SENSe:POWer:ACHannel:SPACing:GAP1 2.0MHZ
:SENSe:POWer:ACHannel:SPACing:GAP2 5.0MHZ

:SENSe:POWer:ACHannel:BANDwidth:GAP1 2.0MHZ
:SENSe:POWer:ACHannel:BANDwidth:GAP2 2.0MHZ

//--------------Performing the Measurement-----

//Select single sweep mode.
INIT:CONT OFF
//Initiate a new measurement and wait until the sweep has finished.
INIT;*WAI

//---------------Retrieving Results-------------

//Return the results for the ACLR measurement.
CALC:MARK:FUNC:POW:RES? MCAC
//Results:
//Transmission channels in sub block A
//-13.2346727385,-13.2346723793,-13.2390131759,
//Transmission channels in sub block B
//-17.0863336597,
//Transmission channels in sub block C
//-13.2390127767,-13.2390134744,
//Totals for each sub block
//-8.4649064021,-17.0863336597,-10.2287131689,
//Adjacent channels
//-67.9740721019,-67.9740728014,-0.00434041734,-0.00434041734,
//CACLR channels
//-0.52933512766,-64.9990115835,-64.5012521492,-0.33507330922,
//-64.4924159646,-0.52932552499,-0.52932552495,-64.4934163414


Measuring the Carrier-to-Noise Ratio

Remote Commands > Configuring and Performing Measurements > Measuring the Carrier-to-Noise Ratio
Measuring the Carrier-to-Noise Ratio

The following commands are necessary to perform carrier-to-noise measurements.

  • CALC:MARK:FUNC:POW:SEL CN | CN0, see CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]
  • CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?
  • [SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth[:​CHANnel<ch>]
  • [SENSe:​]POWer:​ACHannel:​PRESet
Programming example: Measuring the carrier-to-noise ratio

This programming example demonstrates how to perform a Carrier-to-noise measurement in a remote environment.

//----------Preparing the measurement------------
*RST
//Reset the instrument
FREQ:CENT 800MHz
//Sets the center frequency to the carrier frequency of 800 MHz.
CALC:MARK:FUNC:POW:SEL CN
//Activates carrier-to-noise ratio measurement.
POW:ACH:PRES CN
//Optimizes the instrument settings according to the channel bandwidth.
POW:ACH:PRES:RLEV
//Determines the ideal reference level for the measurement.

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

// Now turn off the carrier signal and repeat the measurement:
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
CALC:MARK:FUNC:POW:RES? CN
//Returns the carrier-to-noise ratio.


Measuring the Occupied Bandwidth

Remote Commands > Configuring and Performing Measurements > Measuring the Occupied Bandwidth
Measuring the Occupied Bandwidth

All remote control commands specific to occupied bandwidth measurements are described here.

Contents
  • Configuring the Measurement
  • Programming Example: OBW Measurement


Configuring the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Occupied Bandwidth > Configuring the Measurement
Configuring the Measurement

The following commands configure measurements of the occupied bandwidth.

Useful commands for occupied bandwidth measurements described elsewhere
Configuring the channel:
  • [SENSe:​]POWer:​ACHannel:​BANDwidth|BWIDth[:​CHANnel<ch>]
  • [SENSe:​]POWer:​ACHannel:​PRESet
  • [SENSe:​]POWer:​ACHannel:​PRESet:​RLEVel
Defining search limits:
  • CALCulate:​MARKer:​X:​SLIMits[:​STATe]
  • CALCulate:​MARKer:​X:​SLIMits:​LEFT
  • CALCulate:​MARKer:​X:​SLIMits:​RIGHT
Performing the measurement:
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]
Retrieving results:
  • CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer:​SELect
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]
Remote commands exclusive to occupied bandwidth measurements
List of Commands
[SENSe:]POWer:BANDwidth|BWIDth


[SENSe:]POWer:BANDwidth|BWIDth

Remote Commands > Configuring and Performing Measurements > Measuring the Occupied Bandwidth > Configuring the Measurement > [SENSe:]POWer:BANDwidth|BWIDth
[SENSe:]POWer:BANDwidth|BWIDth <Percentage>

This command selects the percentage of the total power that defines the occupied bandwidth.

Parameters:
<Percentage>
Range: | 10 PCT to 99.9 PCT
*RST: | 99 PCT
Example: POW:BWID 95PCT
Example:

See "Programming Example: OBW Measurement".

Manual operation: See "% Power Bandwidth"


Programming Example: OBW Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Occupied Bandwidth > Programming Example: OBW Measurement
Programming Example: OBW Measurement

This programming example demonstrates the measurement example described in "Measurement Example" in a remote environment.

//-------------Configuring the Measurement-----------------------
*RST
//Resets the instrument
FREQ:CENT 800MHz
//Sets the center frequency to 800 MHz.
DISP:TRAC:Y:RLEV -10dBm
//Sets the reference level to -10 dBm.
CALC:MARK:FUNC:POW:SEL OBW
//Activates occupied bandwidth measurement.
POW:BWID 99PCT
//Sets the percentage of power to 99%.
POW:ACH:BAND 21kHz
//Sets the channel bandwidth to 21 kHz.
POW:ACH:PRES OBW
//Optimizes the instrument settings according to the channel bandwidth.
POW:ACH:PRES:RLEV
//Determines the ideal reference level for the measurement.
DET APE
//Sets the trace detector to positive peak.

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
CALC:MARK:FUNC:POW:RES? OBW
//Returns the occupied bandwidth.


Measuring the Spectrum Emission Mask

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask
Measuring the Spectrum Emission Mask

All remote control commands specific to spectrum emission mask measurements are described here.

See also "Configuring Power Measurements".

Contents
  • Managing Measurement Configurations
  • Controlling the Measurement
  • Configuring a Multi-SEM Measurement
  • Configuring a Sweep List
  • Configuring the Reference Range
  • Configuring the Power Classes
  • Configuring MSR SEM Measurements
  • Configuring the List Evaluation
  • Performing an SEM Measurement
  • Retrieving Results
  • Example: SEM Measurement


Managing Measurement Configurations

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Managing Measurement Configurations
Managing Measurement Configurations

The following commands control measurement configurations for SEM measurements.

List of Commands
CALCulate:LIMit:ESPectrum:RESTore
[SENSe:]ESPectrum<sb>:PRESet[:STANdard]
[SENSe:]ESPectrum<sb>:PRESet:RESTore
[SENSe:]ESPectrum<sb>:PRESet:STORe


CALCulate:LIMit:ESPectrum:RESTore

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Managing Measurement Configurations > CALCulate:LIMit:ESPectrum:RESTore
CALCulate:LIMit:ESPectrum:RESTore

This command restores the predefined limit lines for the selected Spectrum Emission Mask standard.

All modifications made to the predefined limit lines are lost and the factory-set values are restored.

Example: CALC:LIM:ESP:REST

Resets the limit lines for the current Spectrum Emission Mask standard to the default setting.


[SENSe:]ESPectrum<sb>:PRESet[:STANdard]

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Managing Measurement Configurations > [SENSe:]ESPectrum<sb>:PRESet[:STANdard]
[SENSe:]ESPectrum<sb>:PRESet[:STANdard] <Standard>

This command loads a measurement configuration.

Standard definitions are stored in an xml file. The default directory for SEM standards is C:\r_s\instr\sem_std.

Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
Parameters:
<Standard> | String containing the file name. If you have stored the file in a subdirectory of the directory mentioned above, you have to include the relative path to the file.
Return values:
<Standard> | The query returns the name of the currently loaded standard.
Example: | See "Example: SEM Measurement".
Manual operation: | See "Standard / MSR Settings" See "Load Standard"


[SENSe:]ESPectrum<sb>:PRESet:RESTore

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Managing Measurement Configurations > [SENSe:]ESPectrum<sb>:PRESet:RESTore
[SENSe:]ESPectrum<sb>:PRESet:RESTore

This command restores the default configurations of predefined SEM standards.

Note that the command will overwrite customized standards that have the same name as predefined standards.

Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
Usage: | Event
Manual operation: | See "Restore Standard Files"


[SENSe:]ESPectrum<sb>:PRESet:STORe

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Managing Measurement Configurations > [SENSe:]ESPectrum<sb>:PRESet:STORe
[SENSe:]ESPectrum<sb>:PRESet:STORe <Standard>

This command saves the current SEM measurement configuration.

Standard definitions are stored in an xml file. The default directory for SEM standards is C:\r_s\instr\sem_std.

Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
Parameters:
<Standard> | String containing the file name. You can save the file in a subdirectory of the directory mentioned above. In that case, you have to include the relative path to the file.
Example: | See "Example: SEM Measurement".
Manual operation: | See "Save Standard"


Controlling the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Controlling the Measurement
Controlling the Measurement

The following commands control the measurement itself.

List of Commands
INITiate:ESPectrum
[SENSe:]SWEep:MODE


INITiate:ESPectrum

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Controlling the Measurement > INITiate:ESPectrum
INITiate:ESPectrum

This command initiates a Spectrum Emission Mask measurement.

Example: | See "Example: SEM Measurement".
Usage: | Event


[SENSe:]SWEep:MODE

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Controlling the Measurement > [SENSe:]SWEep:MODE
[SENSe:]SWEep:MODE <Mode>

This command selects the spurious emission and spectrum emission mask measurements.

You can select other measurements with

  • CALCulate<n>:​MARKer<m>:​FUNCtion:​POWer[:​STATe]
Parameters:
<Mode>
AUTO

Turns on basic spectrum measurements.

ESPectrum

Turns on spectrum emission mask measurements.

LIST

Turns on spurious emission measurements.

*RST: AUTO
Example:

See "Example: SEM Measurement".

Usage: SCPI confirmed
Manual operation: See "Spectrum Emission Mask"
See "Spurious Emissions"


Configuring a Multi-SEM Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Multi-SEM Measurement
Configuring a Multi-SEM Measurement

As of firmware version 1.91, and in the Spectrum application only, spectrum emissions can be measured for multiple s ub blocks of channels (see "SEM with Multiple Sub Blocks ("Multi-SEM")"). Up to three s ub blocks (with two gaps) can be defined. For each s ub block, the familiar configuration settings concerning ranges, limit lines and MSR can be defined in individual tabs (select the s ub block using the <sb> suffix in the corresponding commands). In addition, settings on the s ub blocks themselves must be configured.

Useful commands for multi-SEM measurements described elsewhere:
  • [SENSe:​]ESPectrum<sb>:​RANGe<range>:​MLCalc
Remote commands exclusive to multi-SEM measurements
List of Commands
[SENSe:]ESPectrum<sb>:SBCenter
[SENSe:]ESPectrum:SBCount


[SENSe:]ESPectrum<sb>:SBCenter

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Multi-SEM Measurement > [SENSe:]ESPectrum<sb>:SBCenter
[SENSe:]ESPectrum<sb>:SBCenter <Frequency>

This command defines the center frequency of the selected sub block in a Multi-SEM measurement.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Return values:
<Frequency>

Frequency within the currently defined global span (see [SENSe:​]FREQuency:​SPAN and [SENSe:​]FREQuency:​CENTer).

Range: | 1 to 3
*RST: | 1
Manual operation: See "Sub Block Center Frequency"


[SENSe:]ESPectrum:SBCount

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Multi-SEM Measurement > [SENSe:]ESPectrum:SBCount
[SENSe:]ESPectrum:SBCount <S ub blocks>

This command defines the number of sub blocks in the SEM measurement.

Return values:
<Sub blocks>

Number of sub blocks in the SEM measurement.

Range: | 1 to 3
*RST: | 1
Manual operation: See "Sub Block Count"


Configuring a Sweep List

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List
Configuring a Sweep List

The following commands define a sweep list for SEM measurements.

The sweep list cannot be configured using remote commands during an on-going sweep operation.

See also:
  • CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>:​LIMit[:​STATe]
List of Commands
[SENSe:]ESPectrum<sb>:HighSPeed
[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth[:RESolution]
[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth:VIDeo
[SENSe:]ESPectrum<sb>:RANGe:COUNt?
[SENSe:]ESPectrum<sb>:RANGe<range>:DELete
[SENSe:]ESPectrum<sb>:RANGe<range>:FILTer:TYPE
[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation:AUTO
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN:STATe
[SENSe:]ESPectrum<sb>:RANGe<range>:INSert
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:ABS
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:FUNCtion
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:ABSolute
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:FUNCtion
[SENSe:]ESPectrum<sb>:RANGe:LIMit<PClass>:STATe
[SENSe:]ESPectrum<sb>:RANGe<range>:POINts:MIN[:VALue]
[SENSe:]ESPectrum<sb>:RANGe<range>:MLCalc
[SENSe:]ESPectrum<sb>:RANGe<range>:RLEVel
[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME
[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME:AUTO
[SENSe:]ESPectrum<sb>:RANGe<range>:TRANsducer


[SENSe:]ESPectrum<sb>:HighSPeed

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:HighSPeed
[SENSe:]ESPectrum<sb>:HighSPeed <State>

This command turns high speed mode for SEM measurements on and off.

For more information including restrictions see "Fast SEM Measurements".

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<State>
ON | OFF
*RST: OFF
Example: ESP:HSP ON
Example:

See "Example: SEM Measurement".

Manual operation: See "Fast SEM"


[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth[:RESolution]

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth[:RESolution]
[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth[:RESolution] <RBW>

This command defines the resolution bandwidth for a SEM range.

In case of high speed measurements, the resolution bandwidth has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1...30

Selects the measurement range.

Parameters:
<RBW>

Resolution bandwidth.

Refer to the data sheet for available resolution bandwidths.

*RST: | 30.0 kHz
Default unit: | Hz
Example:

See "Example: SEM Measurement".

Manual operation: See "RBW"


[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth:VIDeo

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth:VIDeo
[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth:VIDeo <VBW>

This command defines the video bandwidth for a SEM range.

In case of high speed measurements, the video bandwidth has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1...30

Selects the measurement range.

Parameters:
<VBW>

Video bandwidth.

Refer to the data sheet for available video bandwidths.

*RST: | 10.0 MHz
Default unit: | Hz
Example:

See "Example: SEM Measurement".

Manual operation: See "VBW"


[SENSe:]ESPectrum<sb>:RANGe:COUNt?

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe:COUNt?
[SENSe:]ESPectrum<sb>:RANGe:COUNt? <Ranges>

This command queries the number of ranges in the sweep list.

Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
Return values:
<Ranges> | Number of ranges in the sweep list.
Example: | See "Example: SEM Measurement".
Usage: | Query only


[SENSe:]ESPectrum<sb>:RANGe<range>:DELete

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:DELete
[SENSe:]ESPectrum<sb>:RANGe<range>:DELete

This command removes a range from the sweep list.

Note that

  • you cannot delete the reference range
  • a minimum of three ranges is mandatory.
Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
<range> | 1...30 Selects the measurement range.
Example: | See "Example: SEM Measurement".
Usage: | Event
Manual operation: | See "Delete Range"


[SENSe:]ESPectrum<sb>:RANGe<range>:FILTer:TYPE

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:FILTer:TYPE
[SENSe:]ESPectrum<sb>:RANGe<range>:FILTer:TYPE <FilterType>

This command selects the filter type for an SEM range.

In case of high speed measurements, the filter has to be identical for all ranges.

The EMI-specific filter types are available if the EMI (R&S FSW-K54) measurement option is installed, even if EMI measurement is not active. For details see "Resolution Bandwidth and Filter Types".

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1...30

Selects the measurement range.

Parameters:
<FilterType>
NORMal

Gaussian filters

CFILter

channel filters

RRC

RRC filters

CISPr | PULSe

CISPR (6 dB) - requires EMI (R&S FSW-K54) option

Return value for query is always PULS.

MIL

MIL Std (6 dB) - requires EMI (R&S FSW-K54) option

P5

5 Pole filters

*RST: NORM

Refer to the datasheet for available filter bandwidths.

Manual operation: See "Filter Type"


[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STARt

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STARt <Frequency>

This command defines the start frequency of a SEM range.

Make sure to set an appropriate span. If you set a span that is

  • smaller than the span the SEM sweep list covers, the R&S FSW will not measure the ranges that are outside the span - results may be invalid.
  • greater than the span the SEM sweep list covers, the R&S FSW will adjust the start frequency of the first SEM range and the stop frequency of the last SEM range to the span

For more information see "Ranges and Range Settings".

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1...30

Selects the measurement range.

Parameters:
<Frequency>

Numeric value. Note that the minimum frequency range of a SEM range is 20 Hz.

*RST: | -12.75 MHz (range 1), -2.515 MHz (range 2), 2.515 MHz (range 3)
Default unit: | Hz
Example:

See "Example: SEM Measurement".

Manual operation: See "Range Start / Range Stop"


[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STOP

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STOP <Frequency>

This command defines the stop frequency of a SEM range.

Make sure to set an appropriate span. If you set a span that is

  • smaller than the span the SEM sweep list covers, the R&S FSW will not measure the ranges that are outside the span - results may be invalid.
  • greater than the span the SEM sweep list covers, the R&S FSW will adjust the start frequency of the first SEM range and the stop frequency of the last SEM range to the span

For more information see "Ranges and Range Settings".

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1...30

Selects the measurement range.

Parameters:
<Frequency>

Numeric value.

*RST: | -2.52 MHz (range 1), 2.52 MHz (range 2), 250.0 MHz (range 3)
Default unit: | Hz
Example:

See "Example: SEM Measurement".

Manual operation: See "Range Start / Range Stop"


[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation <Attenuation>

This command defines the input attenuation for a SEM range.

In case of high speed measurements, the input attenuation has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1...20

Selects the measurement range.

Parameters:
<Attenuation>

Numeric value.

Refer to the data sheet for the attenuation range.

*RST: | 10 dB
Default unit: | dB
Example:

See "Example: SEM Measurement".

Manual operation: See "RF Attenuator"


[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation:AUTO
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation:AUTO <State>

This command turns automatic selection of the input attenuation for a SEM range on and off.

In case of high speed measurements, the input attenuation has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: ESP:RANG2:INP:ATT:AUTO OFF

Deactivates the RF attenuation auto mode for range 2.

Manual operation: See "RF Att. Mode"


[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN <Gain>

This command selects the level of preamplification for a SEM range.

In case of high speed measurements, the level of the preamplifier has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

• R&S FSW8/13: 15dB and 30 dB

• R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF


[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN:STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN:STATe
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN:STATe <State>

This command turns the preamplifier for a SEM range on and off.

In case of high speed measurements, the state of the preamplifier has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Preamp"


[SENSe:]ESPectrum<sb>:RANGe<range>:INSert

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:INSert
[SENSe:]ESPectrum<sb>:RANGe<range>:INSert <Mode>

This command inserts a new SEM range and updates the range numbers accordingly.

Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
<range> | 1..30 Selects the SEM range.
Parameters:
<Mode> | AFTer Inserts a range after the selected range. BEFore Inserts a range before the selected range.
Example: | See "Example: SEM Measurement".
Manual operation: | See "Insert before/after Range"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STARt

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STARt <Level>

This command defines an absolute limit for a SEM range.

Unlike manual operation, you can define an absolute limit anytime and regardless of the limit check mode.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Level>

Absolute limit at the start frequency of a SEM range.

Range: | -400 to 400
*RST: | -13
Default unit: | dBm
Example: SENSe:ESPectrum:RANGe:LIMit:ABSolute:STARt -10

For a detailed example see "Example: SEM Measurement".

Example:

See "Example: SEM Measurement".

Manual operation: See "Abs Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STOP

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STOP <Level>

This command defines an absolute limit for a SEM range.

Unlike manual operation, you can define an absolute limit anytime and regardless of the limit check mode.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Level>

Absolute limit at the stop frequency of a SEM range.

Range: | -400 to 400
*RST: | -13
Default unit: | dBm
Example: SENSe:ESPectrum:RANGe:LIMit:ABSolute:STOP -15

For a detailed example see "Example: SEM Measurement".

Example:

See "Example: SEM Measurement".

Manual operation: See "Abs Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt <Limit>

This command defines a relative limit for a SEM range.

Unlike manual operation, you can define a relative limit regardless of the limit check mode.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the SEM range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Level>

Relative limit at the start frequency of a SEM range.

Range: | -400 to 400
*RST: | -50
Default unit: | dBc
Example: SENS:ESP:RANG:LIM:REL:STAR -10
Example:

See "Example: SEM Measurement".

Manual operation: See "Rel Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:ABS

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:ABS
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:ABS <Limit>

This command defines an absolute limit for the MAX function of the relative limit for a SEM range.

For more information see "Relative limit line functions".

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the SEM range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Level>

Absolute limit at the start frequency of a SEM range to be used in addition to the relative limit if the MAX function is enabled (see [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STARt:​FUNCtion).

Range: | -400 to 400
*RST: | -13
Default unit: | dBm
Example: SENSe:ESPectrum:RANGe:LIMit:RELative:STARt:ABSolute -10

For a detailed example see "Example: SEM Measurement".

Example:

See "Example: SEM Measurement".

Manual operation: See "Rel Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:FUNCtion

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:FUNCtion
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:FUNCtion <Function>

This command enables the use of a function when defining the relative limit for a SEM range.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the SEM range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Function>

Defines the function to be used to determine the relative limit line start value

MAX

The maximum of the relative and the absolute level is used as the limit start value. Use the [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STARt and [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STARt:​ABS commands to define these values.

OFF

No function is used, the relative limit line is defined by a fixed relative start value. Use the [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STARt command to define this value.

*RST: OFF
Example: SENSe:ESPectrum:RANGe:LIMit:RELative:STARt:FUNCtion MAX

For a detailed example see "Example: SEM Measurement".

Example:

See "Example: SEM Measurement".

Manual operation: See "Rel Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP <Limit>

This command defines a relative limit for a SEM range.

Unlike manual operation, you can define a relative limit anytime and regardless of the limit check mode.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the SEM range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Level>

Relative limit at the stop frequency of a SEM range.

Range: | -400 to 400
*RST: | -50
Default unit: | dBc
Example: SENSe:ESPectrum:RANGe:LIMit:RELative:STOP -15

For a detailed example see "Example: SEM Measurement".

Example:

See "Example: SEM Measurement".

Manual operation: See "Rel Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:ABSolute

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:ABSolute
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:ABSolute <Limit>

This command defines an absolute limit for the MAX function of the relative limit for a SEM range.

For more information see "Relative limit line functions".

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the SEM range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Level>

Absolute limit at the stop frequency of a SEM range to be used in addition to the relative limit if the MAX function is enabled (see [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STOP:​FUNCtion).

Range: | -400 to 400
*RST: | -13
Default unit: | dBm
Example: SENSe:ESPectrum:RANGe:LIMit:RELative:STOP:ABSolute -15

For a detailed example see "Example: SEM Measurement".

Example:

See "Example: SEM Measurement".

Manual operation: See "Rel Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:FUNCtion

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:FUNCtion
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:FUNCtion <Function>

This command enables the use of a function when defining the relative limit for a SEM range.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the SEM range.

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<Function>

Defines the function to be used to determine the relative limit line stop value

MAX

The maximum of the relative and the absolute level is used as the limit stop value. Use the [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STOP and [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STOP:​ABSolute commands to define these values.

OFF

No function is used, the relative limit line is defined by a fixed relative stop value. Use the [SENSe:​]ESPectrum<sb>:​RANGe<range>:​LIMit<PClass>:​RELative:​STOP command to define this value.

*RST: OFF
Example: SENSe:ESPectrum:RANGe:LIMit:RELative:STOP:FUNCtion MAX

For a detailed example see "Example: SEM Measurement".

Example:

See "Example: SEM Measurement".

Manual operation: See "Rel Limit Start/Stop <n>"


[SENSe:]ESPectrum<sb>:RANGe:LIMit<PClass>:STATe

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe:LIMit<PClass>:STATe
[SENSe:]ESPectrum<sb>:RANGe:LIMit<PClass>:STATe <State>

This command selects the limit check mode for all SEM ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<PClass>
1..4

Power class for which the limit is defined.

Parameters:
<State>
ABSolute | RELative | AND | OR
ABSolute

Checks only the absolute limits defined.

RELative

Checks only the relative limits. Relative limits are defined as relative to the measured power in the reference range.

AND

Combines the absolute and relative limit. The limit check fails when both limits are violated.

OR

Combines the absolute and relative limit. The limit check fails when one of the limits is violated.

*RST: RELative
Example:

See "Example: SEM Measurement".

Manual operation: See "Limit Check <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:POINts:MIN[:VALue]

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:POINts:MIN[:VALue]
[SENSe:]ESPectrum<sb>:RANGe<range>:POINts:MIN[:VALue] <SweepPoint>

Defines the minimum number of sweep points for the range.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

Parameters:
<SweepPoints>

Minimum number of sweep points per range

Range: | 1 to 32001
*RST: | 1
Example: SENSe1:ESPectrum:RANGe3:POINts:MIN:VALue 400
Manual operation: See "Minimum Sweep Points"


[SENSe:]ESPectrum<sb>:RANGe<range>:MLCalc

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:MLCalc
[SENSe:]ESPectrum<sb>:RANGe<range>:MLCalc <Function>

Defines the function used to calculate the limit line for the n-th power class for overlapping ranges in Multi-SEM measurements. For details see "Limit calculation for individual ranges".

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

Parameters:
<Function>
NONE

(reference ranges only:) the limit of the reference range is used;

Reference ranges always use the function "NONE".

SUM

sum of the two limit lines (calculated for linear powers) is used

MAX

maximum of the two limit lines is used

*RST: SUM (reference range: NONE)
Example:

See "Example: SEM Measurement".

Manual operation: See "Multi-Limit Calc <n>"


[SENSe:]ESPectrum<sb>:RANGe<range>:RLEVel

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:RLEVel
[SENSe:]ESPectrum<sb>:RANGe<range>:RLEVel <RefLevel>

This command defines the reference level for a SEM range.

In case of high speed measurements, the reference level has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

Parameters:
<RefLevel>

Reference level.

Refer to the data sheet for the reference level range.

*RST: 0 dBm
Example:

See "Example: SEM Measurement".

Manual operation: See "Ref. Level"


[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME
[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME <SweepTime>

This command defines the sweep time for a SEM range.

In case of high speed measurements, the sweep time has to be identical for all ranges.

Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
<range> | 1..30 Selects the measurement range.
Parameters:
<SweepTime> | Sweep time. The range depends on the ratios of the span to the RBW and the RBW to the VBW. Refer to the data sheet for more information.
Example: | See "Example: SEM Measurement".
Manual operation: | See "Sweep Time"


[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME:AUTO
[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME:AUTO <State>

This command turns automatic selection of the sweep time for a SEM range on and off.

In case of high speed measurements, the sweep time has to be identical for all ranges.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<range>
1..30

Selects the measurement range.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: ESP:RANG3:SWE:TIME:AUTO OFF

Deactivates the sweep time auto mode for range 3.

Manual operation: See "Sweep Time Mode"


[SENSe:]ESPectrum<sb>:RANGe<range>:TRANsducer

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring a Sweep List > [SENSe:]ESPectrum<sb>:RANGe<range>:TRANsducer
[SENSe:]ESPectrum<sb>:RANGe<range>:TRANsducer <Transducer>

This command selects a transducer factor for a SEM range.

Note that

  • the transducer must cover at least the span of the range
  • the x-axis has to be linear
  • the unit has to be dB
Suffix: |
<sb> | 1 | 2 | 3 Sub block in a Multi-SEM measurement
<range> | 1..30 Selects the measurement range.
Parameters:
<Transducer> | String containing the transducer file name, including the path information.
Example: | See "Example: SEM Measurement".
Manual operation: | See "Transd. Factor"


Configuring the Reference Range

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Reference Range
Configuring the Reference Range

The following commands define the reference range for the SEM sweep list.

List of Commands
[SENSe:]ESPectrum<sb>:BWID
[SENSe:]ESPectrum<sb>:FILTer[:RRC]:ALPHa
[SENSe:]ESPectrum<sb>:FILTer[:RRC][:STATe]
[SENSe:]ESPectrum<sb>:RRANge?
[SENSe:]ESPectrum<sb>:RTYPe


[SENSe:]ESPectrum<sb>:BWID

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Reference Range > [SENSe:]ESPectrum<sb>:BWID
[SENSe:]ESPectrum<sb>:BWID <Bandwidth>

This command defines the channel bandwidth of the reference range.

The bandwidth is available if the power reference is the channel power.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Bandwidth>
minimum span ≤ value ≤ span of reference range
*RST: 3.84 MHz
Example:

See "Example: SEM Measurement".

Manual operation: See "Tx Bandwidth"


[SENSe:]ESPectrum<sb>:FILTer[:RRC]:ALPHa

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Reference Range > [SENSe:]ESPectrum<sb>:FILTer[:RRC]:ALPHa
[SENSe:]ESPectrum<sb>:FILTer[:RRC]:ALPHa <Alpha>

This command defines the roll-off factor for the RRC filter.

The RRC filter is available if the power reference is the channel power.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Alpha>
Range: | 0 to 1
*RST: | 0.22
Example:

See "Example: SEM Measurement".

Manual operation: See "Alpha"


[SENSe:]ESPectrum<sb>:FILTer[:RRC][:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Reference Range > [SENSe:]ESPectrum<sb>:FILTer[:RRC][:STATe]
[SENSe:]ESPectrum<sb>:FILTer[:RRC][:STATe] <State>

This command turns the RRC filter in the reference range on and off.

The RRC filter is available if the power reference is the channel power.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example:

See "Example: SEM Measurement".

Manual operation: See "RRC Filter State"


[SENSe:]ESPectrum<sb>:RRANge?

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Reference Range > [SENSe:]ESPectrum<sb>:RRANge?
[SENSe:]ESPectrum<sb>:RRANge? <RefRange>

This command queries the reference range.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Return values:
<RefRange>

Number of the current reference range.

Range: 1 to 30
Example:

See "Example: SEM Measurement".

Usage: Query only


[SENSe:]ESPectrum<sb>:RTYPe

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Reference Range > [SENSe:]ESPectrum<sb>:RTYPe
[SENSe:]ESPectrum<sb>:RTYPe <Type>

This command defines the type of the power reference.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Type>
PEAK

Measures the highest peak within the reference range.

CPOWer

Measures the channel power within the reference range (integral bandwidth method).

*RST: CPOWer
Example:

See "Example: SEM Measurement".

Manual operation: See "Power Reference Type"


Configuring the Power Classes

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes
Configuring the Power Classes

The following commands define the power classes for SEM measurements.

List of Commands
CALCulate:LIMit:ESPectrum<sb>:LIMits
CALCulate:LIMit:ESPectrum<sb>:MODE
CALCulate:LIMit:ESPectrum<sb>:VALue
CALCulate:LIMit:ESPectrum<sb>:PCLass:COUNt
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>[:EXCLusive]
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:LIMit[:STATe]
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MAXimum
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MINimum


CALCulate:LIMit:ESPectrum<sb>:LIMits

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:LIMits
CALCulate:LIMit:ESPectrum<sb>:LIMits <Max1>,<Max2>,<Max3>

This command sets or queries up to 4 power classes in one step. You can only define values for the number of power classes defined by CALCulate:​LIMit:​ESPectrum<sb>:​PCLass:​COUNt.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Setting parameters:
<Max1>

Defines the value range for power class 1 as -200 to <Max1>.

Only available for CALC:LIM:ESP:PCL:COUNT >=2

If only 2 power classes are defined, the value range for power class 2 is defined as <Max1> to 200.

Range: -199 to + 199
<Max2>

Defines the value range for power class 2 as <Max1> to <Max2>.

Only available for CALC:LIM:ESP:PCL:COUNT >=3

If only 3 power classes are defined, the value range for power class 3 is defined as <Max2> to 200.

Range: -199 to + 199, <Max2> must be higher than <Max1>
<Max3>

Defines the value range for power class 3 as <Max2> to <Max3>.

The value range for power class 4 is defined as <Max3> to 200.

Only available for CALC:LIM:ESP:PCL:COUNT = 4

Range: -199 to + 199, <Max3> must be higher than <Max2>
Return values:
<RangeLimits>

As a result of the query, the range limits including the beginning of the first power class (-200) and the end of the last power class (+200) are indicated.

Example: CALC:LIM:ESP:LIM -50,50,70

Defines the following power classes:

<-200, -50>
<-50, 50>
<50, 70>
<70, 200>

Query:

CALC:LIM:ESP:LIM?

Response:

-200,-50,50,70,200
Example:

See "Example: SEM Measurement".


CALCulate:LIMit:ESPectrum<sb>:MODE

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:MODE
CALCulate:LIMit:ESPectrum<sb>:MODE <Mode>

Which limit line is to be used for an SEM measurement depends on the power class the input signal power belongs to. This command defines wether the power class is determined automatically or manually.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Mode>
AUTO

The power class (and thus the limit line) is assigned dynamically according to the currently measured channel power.

MANUAL

One of the specified power classes is selected manually for the entire measurement. The selection is made with the CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>[:​EXCLusive] command.

*RST: AUTO
Example: CALC:LIM:ESP:MODE AUTO

Activates automatic selection of the limit line.

Example:

See "Example: SEM Measurement".


CALCulate:LIMit:ESPectrum<sb>:VALue

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:VALue
CALCulate:LIMit:ESPectrum<sb>:VALue <Power>

This command activates the manual limit line selection as and specifies the expected power as a value. Depending on the entered value, the associated predefined limit lines is selected.

This command has the same effect as a combination of the CALC:LIM:ESP:MODE MAN and the CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>[:​EXCLusive] commands; however, the power class to be used is not defined directly, but via the expected power. As opposed to CALC:LIM:ESP:MODE AUTO, the power class is not re-assigned to the input signal power dynamically, but only once when the command is executed.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Power>
integer
Range: | -200 to 199
*RST: | 0
Example: CALC:LIM:ESP:VAL 33

Activates manual selection of the limit line and selects the limit line for P = 33.


CALCulate:LIMit:ESPectrum<sb>:PCLass:COUNt

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:PCLass:COUNt
CALCulate:LIMit:ESPectrum<sb>:PCLass:COUNt <NoPowerClasses>

This command sets the number of power classes to be defined. This command must be executed before any new power class values can be defined using CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>:​MAXimum and CALCulate:​LIMit:​ESPectrum<sb>:​PCLass<class>:​MINimum.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<NoPowerClasses>
1 to 4
*RST: 1
Example: CALC:LIM:ESP:PCL:COUN 2

Two power classes can be defined.

Example:

See "Example: SEM Measurement".

Manual operation: See "Adding or Removing a Power Class"


CALCulate:LIMit:ESPectrum<sb>:PCLass<class>[:EXCLusive]

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:PCLass<class>[:EXCLusive]
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>[:EXCLusive] <State>

This command selects the power class used by the measurement if CALCulate:​LIMit:​ESPectrum<sb>:​MODE is set to manual.

Note that:

  • You can only use power classes for which limits are defined.
Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<class>
1...4

power class

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:LIM:ESP:PCL1 ON

Activates the first defined power class.

Example:

See "Example: SEM Measurement".

Manual operation: See "Used Power Classes"


CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:LIMit[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:LIMit[:STATe]
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:LIMit[:STATe] <State>

This command selects the limit check mode for each power class.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<class>
1...4

power class

Parameters:
<State>
ABSolute

Evaluates only limit lines with absolute power values

RELative

Evaluates only limit lines with relative power values

AND

Evaluates limit lines with relative and absolute power values. A negative result is returned if both limits fail.

OR

Evaluates limit lines with relative and absolute power values. A negative result is returned if at least one limit failed.

*RST: REL
Example: CALC:LIM:ESP:PCL:LIM ABS
Manual operation: See "Used Power Classes"


CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MAXimum

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MAXimum
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MAXimum <Level>

This command defines the upper limit of a particular power class.

Note:

  • The last power class always has an upper limit of 200 dBm.
  • The upper limit of a power class must always be the same as the lower limit of the subsequent power class.
  • The power class must already exist (see CALCulate:​LIMit:​ESPectrum<sb>:​PCLass:​COUNt).
Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<class>
1...4

power class

Parameters:
<Level>
Range: -199.9 dBm to 200 dBm
Example: CALC:LIM:ESP:PCL1:MAX -40 dBm

Sets the maximum power value of the first power class to -40 dBm.

Manual operation: See "PMin/PMax"


CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MINimum

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the Power Classes > CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MINimum
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MINimum <Level>

This command defines the lower limit of a particular power class.

Note:

  • The first power class always has a lower limit of -200 dBm.
  • The lower limit of a power class must always be the same as the upper limit of the previous power class.
  • The power class must already exist (see CALCulate:​LIMit:​ESPectrum<sb>:​PCLass:​COUNt).
Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

<class>
1...4

power class

Parameters:
<Level>
Range: -200 dBm to 199.9 dBm
Example: CALC:LIM:ESP:PCL2:MIN -40 dBm

Sets the minimum power value of the second power class to -40 dBm.

Manual operation: See "PMin/PMax"


Configuring MSR SEM Measurements

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements
Configuring MSR SEM Measurements

The following commands configure MSR SEM measurements. For details see "Multi-Standard Radio (MSR) SEM Measurements".

For manual operation see "MSR Settings".

List of Commands
[SENSe:]ESPectrum<sb>:MSR:APPLy
[SENSe:]ESPectrum<sb>:MSR:BAND
[SENSe:]ESPectrum<sb>:MSR:BCATegory
[SENSe:]ESPectrum<sb>:MSR:CLAS
[SENSe:]ESPectrum<sb>:MSR:GSM:CARR
[SENSe:]ESPectrum<sb>:MSR:GSM:CPResent
[SENSe:]ESPectrum<sb>:MSR:LTE:CPResent
[SENSe:]ESPectrum<sb>:MSR:MPOWer
[SENSe:]ESPectrum<sb>:MSR:RFBWidth


[SENSe:]ESPectrum<sb>:MSR:APPLy

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:APPLy
[SENSe:]ESPectrum<sb>:MSR:APPLy

This command configures the SEM sweep list according to the MSR settings defined by previous commands.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Example:
//Select the band category 1
ESP2:MSR:BCAT BC1
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the frequency range of the base station to > 3 GHz
ESP2:MSR:BAND:HIGH
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//Calculate limits for MSR SEM
ESP2:MSR:APPL
Usage: Event
Manual operation: See "Apply to SEM"


[SENSe:]ESPectrum<sb>:MSR:BAND

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:BAND
[SENSe:]ESPectrum<sb>:MSR:BAND <Range>

Defines the frequency range of the bands used by the base station.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Range>
LOW

≤ 3 GHz

HIGH

> 3 GHz

*RST: LOW
Example:
//Select the band category 1
ESP2:MSR:BCAT BC1
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the frequency range of the base station to > 3 GHz
ESP2:MSR:BAND:HIGH
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//Calculate limits for MSR SEM
ESP2:MSR:APPL
Manual operation: See "Bands"


[SENSe:]ESPectrum<sb>:MSR:BCATegory

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:BCATegory
[SENSe:]ESPectrum<sb>:MSR:BCATegory <Category>

This command defines the band category for MSR measurements, i.e. the combination of available carriers to measure.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Category>
1 | 2 | 3
1

2 carriers: LTE FDD and W-CDMA

2

3 carriers: LTE FDD, W-CDMA and GSM/EDGE

3

2 carriers: LTE TDD and TD-SCDMA

*RST: 1
Example:
//Select the band category 1
ESP2:MSR:BCAT BC1
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the frequency range of the base station to > 3 GHz
ESP2:MSR:BAND:HIGH
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//Calculate limits for MSR SEM
ESP2:MSR:APPL
Manual operation: See "Band Category"


[SENSe:]ESPectrum<sb>:MSR:CLAS

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:CLAS
[SENSe:]ESPectrum<sb>:MSR:CLAS <Class>

Defines the class of the base station according to its sending range.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Class>
WIDE

Wide Area

MEDium

Medium Range

LOCal

Local Area

*RST: WIDE
Example:
//Select the band category 1
ESP2:MSR:BCAT BC1
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the frequency range of the base station to > 3 GHz
ESP2:MSR:BAND:HIGH
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//Calculate limits for MSR SEM
ESP2:MSR:APPL
Manual operation: See "Base Station Class"


[SENSe:]ESPectrum<sb>:MSR:GSM:CARR

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:GSM:CARR
[SENSe:]ESPectrum<sb>:MSR:GSM:CARR <Power>

Defines the power of the GSM carrier (if available, see [SENSe:​]ESPectrum<sb>:​MSR:​GSM:​CARR).

This command is only available for band category 2 (see [SENSe:​]ESPectrum<sb>:​MSR:​BCATegory).

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Power>
numeric value
Range: | 0 dBm to 100 dBm
*RST: | 39.0 dBm
Example:
//Select the band category 2
ESP2:MSR:BCAT BC2
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//GSM/Edge present
ESP2:MSR:GSM:CPR
//Power of the GSM carrier is 20dBm
ESP2:MSR:GSM:CARR 20
//Calculate limits for MSR SEM
ESP2:MSR:APPL
Manual operation: See "Power GSM Carrier"


[SENSe:]ESPectrum<sb>:MSR:GSM:CPResent

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:GSM:CPResent
[SENSe:]ESPectrum<sb>:MSR:GSM:CPResent <State>

This command defines whether a GSM/Edge carrier is located at the edge of the specified RF bandwidth. In this case, the specification demands specific limits for the SEM ranges.

This command is only available for band category 2 (see [SENSe:​]ESPectrum<sb>:​MSR:​BCATegory).

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
//Select the band category 2
ESP2:MSR:BCAT BC2
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//GSM/Edge present
ESP2:MSR:GSM:CPR
//Power of the GSM carrier is 20dBm
ESP2:MSR:GSM:CARR 20
Manual operation: See "Carrier Adjacent to RF Bandwidth Edge"


[SENSe:]ESPectrum<sb>:MSR:LTE:CPResent

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:LTE:CPResent
[SENSe:]ESPectrum<sb>:MSR:LTE:CPResent <State>

This command defines whether an LTE FDD 1.4 MHz or 3 MHz carrier is located at the edge of the specified RF bandwidth. In this case, the specification demands specific limits for the SEM ranges.

This command is only available for band category 2 (see [SENSe:​]ESPectrum<sb>:​MSR:​BCATegory).

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
//Select the band category 2
ESP2:MSR:BCAT BC2
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//LTE present
ESP2:MSR:LTE:CPR
//Calculate limits for MSR SEM
ESP2:MSR:APPL
Manual operation: See "Carrier Adjacent to RF Bandwidth Edge"


[SENSe:]ESPectrum<sb>:MSR:MPOWer

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:MPOWer
[SENSe:]ESPectrum<sb>:MSR:MPOWer <Power>

Defines the maximum output power of the base station.

This setting is only available for base stations with a medium range base station class (see [SENSe:​]ESPectrum<sb>:​MSR:​CLAS).

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Power>
Range: | 0 dBm to 100 dBm
Increment: | 1 dB
Example:
//Select the band category 1
ESP2:MSR:BCAT BC1
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the frequency range of the base station to > 3 GHz
ESP2:MSR:BAND:HIGH
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
Manual operation: See "Base Station Maximum Output Power"


[SENSe:]ESPectrum<sb>:MSR:RFBWidth

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring MSR SEM Measurements > [SENSe:]ESPectrum<sb>:MSR:RFBWidth
[SENSe:]ESPectrum<sb>:MSR:RFBWidth <Bandwidth>

This command defines the RF bandwidth of the base station for MSR measurements.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement

Parameters:
<Bandwidth>

Bandwidth in Hz

*RST: 10.0 MHz
Example:
//Select the band category 1
ESP2:MSR:BCAT BC1
//Set the base station class to medium range
ESP2:MSR:CLAS MED
//Set the maximum output power to 10 dBm.
ESP2:MSR:MPOW 10
//Set the frequency range of the base station to > 3 GHz
ESP2:MSR:BAND:HIGH
//Set the base station RF bandwidth to 20 MHz
ESP2:MSR:RFBW 20MHZ
//Calculate limits for MSR SEM
ESP2:MSR:APPL
Manual operation: See "Base Station RF Bandwidth"


Configuring the List Evaluation

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the List Evaluation
Configuring the List Evaluation

The following commands configure the list evaluation.

Useful commands for SEM measurements described elsewhere
  • MMEMory:​STORe:​LIST
Remote commands exclusive to SEM measurements
List of Commands
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:AUTO
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch[:IMMediate]
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:MARGin
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:PSHow


CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the List Evaluation > CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:AUTO
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:AUTO <State>

This command turns the list evaluation on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:ESP:PSE:AUTO OFF

Deactivates the list evaluation.

Example:

See "Example: SEM Measurement".

Manual operation: See "List Evaluation (Result Summary) State"
See "List Evaluation State"


CALCulate<n>:ESPectrum:PSEarch|PEAKsearch[:IMMediate]

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the List Evaluation > CALCulate<n>:ESPectrum:PSEarch|PEAKsearch[:IMMediate]
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch[:IMMediate]

This command initiates a list evaluation.

Usage: Event


CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:MARGin

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the List Evaluation > CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:MARGin
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:MARGin <Threshold>

This command defines the threshold of the list evaluation.

Parameters:
<Margin>
Range: | -200 to 200
*RST: | 200
Default unit: | dB
Example: CALC:ESP:PSE:MARG 100

Sets the margin to 100 dB.

Example:

See "Example: SEM Measurement".

Manual operation: See "Margin"
See "Margin"


CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:PSHow

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Configuring the List Evaluation > CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:PSHow
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:PSHow

This command turns the peak labels in the diagram on and off.

Peak labels are blue squares.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:ESP:PSE:PSH ON

Marks all peaks with blue squares.

Manual operation: See "Show Peaks"
See "Show Peaks"


Performing an SEM Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Performing an SEM Measurement
Performing an SEM Measurement

The following commands are required to perform an SEM measurement:

SENS:SWE:MODE ESP, see [SENSe:​]SWEep:​MODE

INITiate[:​IMMediate], see "Performing Measurements"


Retrieving Results

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Retrieving Results
Retrieving Results

The following commands analyze and retrieve measurement results for SEM measurements.

  • CALCulate:​LIMit<k>:​FAIL?
  • CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?
  • TRACe<n>[:​DATA]
  • TRACe<n>[:​DATA]:​MEMory?
  • TRACe<n>[:​DATA]:​X?


Example: SEM Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Spectrum Emission Mask > Example: SEM Measurement
Example: SEM Measurement

In this example we will configure and perform an SEM measurement. Note that this example is primarily meant to demonstrate the remote control commands, it does not necessarily reflect a useful measurement task. For most common measurement standards, the R&S FSW performs the measurement optimally with the predefined settings, without further configuration.

//------------ Preparing the measurement------------
*RST
//Resets the instrument
SWE:MODE ESP
//Activates SEM Measurement

INIT:CONT OFF
//Selects single sweep mode.

//SEM has to be in single sweep mode to be configured and no sweep operation
//may be running!
// If required, a sweep stop can be ensured by INIT:IMM;*WAI

//------------ Managing Measurement Configurations----------
ESP:PRES 'WCDMA\3GPP\UL\3GPP_UL.xml'
//Loads the 3GPP configuration stored in the file '3GPP_UL.xml'

//------------ Defining the Reference Range-----------------
ESP:RRAN?
//Queries the current reference range.
ESP:RTYP CPOW
//Selects the channel power as the power reference.
ESP:BWID 4 MHZ
//Defines a channel bandwidth of 4 MHz for the power reference.
ESP:FILT:RRC ON
ESP:FILT:ALPH 0.5
//Uses an RRC filter with a roll-off factor of 0.5 when measuring
//the reference power.

//------------ Configuring Power Classes--------------------
CALC:LIM:ESP:PCL:COUN 3
//Defines 3 power classes.
CALC:LIM:ESP:LIM -100,0
//Defines the value ranges of the three power classes as [dBm]:
//power class 1: -200 to -100
//power class 2: -100 to 0
//power class 3: 0 to 200
CALC:LIM:ESP:PCL1:LIM ABS
//Defines an absolute limit check for class 1.
CALC:LIM:ESP:PCL2:LIM REL
//Defines a relative limit check for class 2.
CALC:LIM:ESP:MODE MAN
//Defines a manual selection of the power class.
CALC:LIM:ESP:PCL2 ON
//Activates the use of the second power class for the entire measurement.

//------------ Configuring a Sweep List---------------------
ESP:RANG2:INS AFT
//Inserts a range after range 2.
ESP:RANG1:INS BEF
//Inserts a range before range 1.
ESP:RANG:COUNt?
//Returns the number of measurement ranges in the sweep list (currently 11).
ESP:RANG5:DEL

//Deletes the 11th range.
ESP:RANG1:STOP -10000000

//Defines a stop frequency of -9 MHz for range 1.
ESP:RANG2:STAR -9000000
//Defines a start frequency of -10 MHz for range 2.

ESP:HSP OFF
//Switches off Fast SEM mode so the ranges can be configured individually.

ESP:RANG2:BAND:RES 1000000
//Defines a resolution bandwidth of 1 MHz for range 2.

ESP:RANG2:FILT:TYPE RRC
//Selects an RRC filter for range 2.
ESP:RANG2:BAND:VID 5000000
//Defines a video bandwidth of 5 MHz for range 2.
ESP:RANG2:SWE:TIME 1
//Defines a sweep time of 1 second for range 2.
ESP:RANG2:RLEV 0
//Defines a reference level of 0 dBm for range 2.
ESP:RANG2:INP:ATT 10
//Defines an input attenuation of 10 dB for range 2.

// Create a transducer that can be used.
// It has to cover the corresponding frequency range

SENSe1:CORRection:TRANsducer:SELect 'Transducer'
SENSe1:CORRection:TRANsducer:UNIT 'DB'
SENSe1:CORRection:TRANsducer:COMMent 'Test Transducer'
// Frequency Span 0 MHz bis 20 Ghz
SENSe1:CORRection:TRANsducer:DATA 0e6,5, 20e9,3

ESP:RANG2:TRAN 'Transducer'
//Includes a transducer called 'transducer' for range 2.

//------------ Configuring the limit check------------------

ESP:RANG:LIM1:STAT AND
//Checks the absolute and relative limits for all ranges in power class 1 and
//fails if both limits are violated. Since power class 2 is set to be used for
//the entire measurement, values for Limit Check 1 are irrelevant. They are
//defined here to demonstrate the use of the MAX function for relative limits.
ESP:RANG2:LIM1:REL:STAR:FUNC MAX
//Enables the use of maximum function for relative limit start. If the value
//exceeds the larger of the absolute (-13 dBm) and relative (-10 dBc) start
//values, the check fails.
ESP:RANG2:LIM1:REL:STAR -10
ESP:RANG2:LIM1:REL:STAR:ABS -13
ESP:RANG2:LIM1:REL:STOP:FUNC MAX
ESP:RANG2:LIM1:REL:STOP -10
ESP:RANG2:LIM1:REL:STOP:ABS -13

ESP:RANG:LIM2:STAT OR
//Checks the absolute and relative limits for all ranges in power class 2 and
//fails if either limit is violated. Since power class 2 is set to be used for
//the entire measurement, values for Limit Check 1 are irrelevant.
ESP:RANG2:LIM2:ABS:STAR 10
ESP:RANG2:LIM2:ABS:STOP 10
//Defines an absolute limit of 10 dBm for the entire range 2 for power class 2.
ESP:RANG2:LIM2:REL:STAR -20
ESP:RANG2:LIM2:REL:STOP -20
//Defines a relative limit of -20 dBc for the entire range 2 for power class 2.

//------------ Configuring List Evaluation-----------------
CALC:ESP:PSE:AUTO ON
//Activates list evaluation, i.e. the peak is determined for each range
//after each sweep.
CALC:ESP:PSE:MARG 10dB
//Defines a peak threshold of 10 dB.

//------------ Managing Measurement Configurations----------

ESP:PRES:STOR 'WCDMA\3GPP\UL\3GPP_UL_User.xml'
//Saves the current configuration in a new file named '3GPP_UL_User'
//in the same directory so the standard is not overwritten.

//------------ Performing the measurement-------------------
INIT:ESP
//One sweep

//------------ Checking the Results-------------------------
CALC:LIM:FAIL?
//Queries the result of the limit check for all ranges.
TRAC:DATA? LIST
//Returns the peak for each range of the SEM measurement as a list.


Measuring Spurious Emissions

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions
Measuring Spurious Emissions

All remote control commands specific to spurious emissions measurements are described here.

Contents
  • Initializing the Measurement
  • Configuring a Sweep List
  • Configuring the List Evaluation
  • Performing a Spurious Measurement
  • Retrieving and Saving Settings and Results
  • Programming Example: Spurious Emissions Measurement


Initializing the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Initializing the Measurement
Initializing the Measurement

Note that with the R&S FSW, the spurious measurement must be initialized before you can start configuring the sweep list or list evaluation.

List of Commands
INITiate:SPURious


INITiate:SPURious

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Initializing the Measurement > INITiate:SPURious
INITiate:SPURious

This command initiates a Spurious Emission measurement.

Usage: Event


Configuring a Sweep List

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List
Configuring a Sweep List

The following commands configure the sweep list for spurious emission measurements.

The sweep list cannot be configured using remote commands during an on-going sweep operation.

Useful commands for configuring the sweep described elsewhere:
  • [SENSe:​]SWEep:​MODE
Remote commands exclusive to spurious measurements:
List of Commands
[SENSe:]LIST:RANGe<range>:BANDwidth[:RESolution]
[SENSe:]LIST:RANGe<range>:BANDwidth:VIDeo
[SENSe:]LIST:RANGe:BREak
[SENSe:]LIST:RANGe:COUNt?
[SENSe:]LIST:RANGe<range>:DELete
[SENSe:]LIST:RANGe<range>:DETector
[SENSe:]LIST:RANGe<range>:FILTer:TYPE
[SENSe:]LIST:RANGe<range>[:FREQuency]:STARt
[SENSe:]LIST:RANGe<range>[:FREQuency]:STOP
[SENSe:]LIST:RANGe<range>:INPut:ATTenuation
[SENSe:]LIST:RANGe<range>:INPut:ATTenuation:AUTO
[SENSe:]LIST:RANGe<range>:INPut:GAIN:STATe
[SENSe:]LIST:RANGe<range>:INPut:GAIN[:VALue]
[SENSe:]LIST:RANGe<range>:LIMit:STARt
[SENSe:]LIST:RANGe:LIMit:STATe
[SENSe:]LIST:RANGe<range>:LIMit:STOP
[SENSe:]LIST:RANGe<range>:POINts[:VALue]
[SENSe:]LIST:RANGe<range>:RLEVel
[SENSe:]LIST:RANGe<range>:SWEep:TIME
[SENSe:]LIST:RANGe<range>:SWEep:TIME:AUTO
[SENSe:]LIST:RANGe<range>:TRANsducer


[SENSe:]LIST:RANGe<range>:BANDwidth[:RESolution]

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:BANDwidth[:RESolution]
[SENSe:]LIST:RANGe<range>:BANDwidth[:RESolution] <RBW>

This command defines the resolution bandwidth for a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<RBW>

Resolution bandwidth.

Refer to the data sheet for available resolution bandwidths.

Default unit: Hz
Manual operation: See "RBW"


[SENSe:]LIST:RANGe<range>:BANDwidth:VIDeo

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:BANDwidth:VIDeo
[SENSe:]LIST:RANGe<range>:BANDwidth:VIDeo <VBW>

This command defines the video bandwidth for a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<VBW>

Video bandwidth.

Refer to the data sheet for available video bandwidths.

Default unit: Hz
Manual operation: See "VBW"


[SENSe:]LIST:RANGe:BREak

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe:BREak
[SENSe:]LIST:RANGe:BREak <State>

This command controls the sweep.

Parameters:
<State>
ON

The R&S FSW stops after measuring one range.

To continue with the next range, you have to use INITiate:​CONMeas.

OFF

The R&S FSW sweeps all ranges in one go.

*RST: OFF
Manual operation: See "Stop After Sweep"


[SENSe:]LIST:RANGe:COUNt?

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe:COUNt?
[SENSe:]LIST:RANGe:COUNt?

This command queries the number of ranges in the sweep list.

Return values:
<Ranges> | Number of ranges in the sweep list.
Usage: | Query only


[SENSe:]LIST:RANGe<range>:DELete

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:DELete
[SENSe:]LIST:RANGe<range>:DELete

This command removes a range from the sweep list.

Note that

  • you cannot delete the reference range
  • a minimum of three ranges is mandatory.
Suffix: |
<range> | 1..30 Selects the measurement range.
Usage: | Event


[SENSe:]LIST:RANGe<range>:DETector

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:DETector
[SENSe:]LIST:RANGe<range>:DETector <Detector>

This command selects the detector for a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Detector>
NEGative

minimum peak detector

POSitive

peak detector

SAMPle

sample detector

RMS

RMS detector

AVERage

average detector

*RST: RMS
Manual operation: See "Detector"


[SENSe:]LIST:RANGe<range>:FILTer:TYPE

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:FILTer:TYPE
[SENSe:]LIST:RANGe<range>:FILTer:TYPE <FilterType>

This command selects the filter type for a spurious emission measurement range.

The EMI-specific filter types are available if the EMI (R&S FSW-K54) measurement option is installed, even if EMI measurement is not active. For details see "Resolution Bandwidth and Filter Types".

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<FilterType>
NORMal

Gaussian filters

CFILter

channel filters

RRC

RRC filters

CISPr | PULSe

CISPR (6 dB) - requires EMI (R&S FSW-K54) option

Return value for query is always PULS.

MIL

MIL Std (6 dB) - requires EMI (R&S FSW-K54) option

P5

5 Pole filters

*RST: NORM

The available bandwidths of the filters are specified in the data sheet.

Manual operation: See "Filter Type"


[SENSe:]LIST:RANGe<range>[:FREQuency]:STARt

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>[:FREQuency]:STARt
[SENSe:]LIST:RANGe<range>[:FREQuency]:STARt <Frequency>

This command defines the start frequency of a spurious emission measurement range.

Make sure to set an appropriate span. If you set a span that is

  • smaller than the span the sweep list covers, the R&S FSW will not measure the ranges that are outside the span - results may be invalid.
  • greater than the span the sweep list covers, the R&S FSW will adjust the start frequency of the first range and the stop frequency of the last range to the span

For more information see "Spurious Emissions Measurement".

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Frequency>

Numeric value.

*RST: | -12.75 MHz (range 1), -2.515 MHz (range 2), 2.515 MHz (range 3)
Default unit: | Hz
Manual operation: See "Range Start / Range Stop"


[SENSe:]LIST:RANGe<range>[:FREQuency]:STOP

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>[:FREQuency]:STOP
[SENSe:]LIST:RANGe<range>[:FREQuency]:STOP <Frequency>

This command defines the stop frequency of a spurious emission measurement range.

Make sure to set an appropriate span. If you set a span that is

  • smaller than the span the sweep list covers, the R&S FSW will not measure the ranges that are outside the span - results may be invalid.
  • greater than the span the sweep list covers, the R&S FSW will adjust the start frequency of the first range and the stop frequency of the last range to the span

For more information see"Spurious Emissions Measurement" .

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Frequency>

Numeric value.

*RST: | -2.52 MHz (range 1), 2.52 MHz (range 2), 250.0 MHz (range 3)
Default unit: | Hz
Manual operation: See "Range Start / Range Stop"


[SENSe:]LIST:RANGe<range>:INPut:ATTenuation

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:INPut:ATTenuation
[SENSe:]LIST:RANGe<range>:INPut:ATTenuation <Attenuation>

This command defines the input attenuation for a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Attenuation>

Numeric value.

Refer to the data sheet for the attenuation range.

*RST: | 10 dB
Default unit: | dB
Manual operation: See "RF Attenuator"


[SENSe:]LIST:RANGe<range>:INPut:ATTenuation:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:INPut:ATTenuation:AUTO
[SENSe:]LIST:RANGe<range>:INPut:ATTenuation:AUTO <State>

This command turns automatic selection of the input attenuation for a spurious emission measurement range on and off.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Manual operation: See "RF Att. Mode"


[SENSe:]LIST:RANGe<range>:INPut:GAIN:STATe

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:INPut:GAIN:STATe
[SENSe:]LIST:RANGe<range>:INPut:GAIN:STATe <State>

This command turns the preamplifier for a spurious emission measurement range on and off.

The preamplification is defined by [SENSe:​]LIST:​RANGe<range>:​INPut:​GAIN[:​VALue].

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Preamp"


[SENSe:]LIST:RANGe<range>:INPut:GAIN[:VALue]

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:INPut:GAIN[:VALue]
[SENSe:]LIST:RANGe<range>:INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level for the range.

The command requires option R&S FSW-B24.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

• R&S FSW8/13: 15dB and 30 dB

• R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF


[SENSe:]LIST:RANGe<range>:LIMit:STARt

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:LIMit:STARt
[SENSe:]LIST:RANGe<range>:LIMit:STARt <Level>

This command defines an absolute limit for a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Level>

Absolute limit at the start frequency of a SEM range.

Range: | -400 to 400
*RST: | 13
Default unit: | dBm
Manual operation: See "Abs Limit Start/Stop"


[SENSe:]LIST:RANGe:LIMit:STATe

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe:LIMit:STATe
[SENSe:]LIST:RANGe:LIMit:STATe

This command turns the limit check for all spurious emission measurement ranges on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Limit Check"


[SENSe:]LIST:RANGe<range>:LIMit:STOP

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:LIMit:STOP
[SENSe:]LIST:RANGe<range>:LIMit:STOP <Level>

This command defines an absolute limit for a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Level>

Absolute limit at the stop frequency of a SEM range.

Range: | -400 to 400
*RST: | 13
Default unit: | dBm
Manual operation: See "Abs Limit Start/Stop"


[SENSe:]LIST:RANGe<range>:POINts[:VALue]

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:POINts[:VALue]
[SENSe:]LIST:RANGe<range>:POINts[:VALue] <Points>

This command defines the number of sweep points in a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<Points>

For more information on sweep points see "How Much Data is Measured: Sweep Points and Sweep Count".

*RST: 1001
Manual operation: See "Sweep Points"


[SENSe:]LIST:RANGe<range>:RLEVel

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:RLEVel
[SENSe:]LIST:RANGe<range>:RLEVel <RefLevel>

This command defines the reference level for a spurious emission measurement range.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<RefLevel>

Reference level.

Refer to the data sheet for the reference level range.

*RST: 0 dBm
Manual operation: See "Ref. Level"


[SENSe:]LIST:RANGe<range>:SWEep:TIME

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:SWEep:TIME
[SENSe:]LIST:RANGe<range>:SWEep:TIME <SweepTime>

This command defines the sweep time for a spurious emission measurement range.

Suffix: |
<range> | 1..30 Selects the measurement range.
Parameters:
<SweepTime> | Sweep time. The range depends on the ratios of the span to the RBW and the RBW to the VBW. Refer to the data sheet for more information.
Manual operation: | See "Sweep Time"


[SENSe:]LIST:RANGe<range>:SWEep:TIME:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:SWEep:TIME:AUTO
[SENSe:]LIST:RANGe<range>:SWEep:TIME:AUTO <State>

This command turns automatic selection of the sweep time for a spurious emission measurement range on and off.

Suffix:
<range>
1..30

Selects the measurement range.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Manual operation: See "Sweep Time Mode"


[SENSe:]LIST:RANGe<range>:TRANsducer

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring a Sweep List > [SENSe:]LIST:RANGe<range>:TRANsducer
[SENSe:]LIST:RANGe<range>:TRANsducer <Transducer>

This command selects a transducer factor for a spurious emission measurement range.

Note that

  • the transducer must cover at least the span of the range
  • the x-axis has to be linear
  • the unit has to be dB
Suffix: |
<range> | 1..30 Selects the measurement range.
Parameters:
<Transducer> | String containing the transducer file name, including the path information.
Manual operation: | See "Transducer"


Configuring the List Evaluation

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring the List Evaluation
Configuring the List Evaluation

The following commands configure the list evaluation.

Useful commands for spurious emission measurements described elsewhere
  • MMEMory:​STORe:​LIST
Remote commands exclusive to spurious emission measurements
List of Commands
CALCulate<n>:PSEarch|PEAKsearch:AUTO
CALCulate<n>:PSEarch|PEAKsearch:MARGin
CALCulate<n>:PSEarch|PEAKsearch:PSHow
CALCulate<n>:PSEarch|PEAKsearch:SUBRanges


CALCulate<n>:PSEarch|PEAKsearch:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring the List Evaluation > CALCulate<n>:PSEarch|PEAKsearch:AUTO
CALCulate<n>:PSEarch|PEAKsearch:AUTO <State>

This command turns the list evaluation on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:PSE:AUTO OFF

Deactivates the list evaluation.


CALCulate<n>:PSEarch|PEAKsearch:MARGin

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring the List Evaluation > CALCulate<n>:PSEarch|PEAKsearch:MARGin
CALCulate<n>:PSEarch|PEAKsearch:MARGin <Threshold>

This command defines the threshold of the list evaluation.

Parameters:
<Margin>
Range: | -200 to 200
*RST: | 200
Default unit: | dB
Example: CALC:PSE:MARG 100

Sets the threshold to 100 dB.


CALCulate<n>:PSEarch|PEAKsearch:PSHow

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring the List Evaluation > CALCulate<n>:PSEarch|PEAKsearch:PSHow
CALCulate<n>:PSEarch|PEAKsearch:PSHow

This command turns the peak labels in the diagram on and off.

Peak labels are blue squares.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:PSE:PSH ON

Marks all peaks with blue squares.


CALCulate<n>:PSEarch|PEAKsearch:SUBRanges

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Configuring the List Evaluation > CALCulate<n>:PSEarch|PEAKsearch:SUBRanges
CALCulate<n>:PSEarch|PEAKsearch:SUBRanges <NumberPeaks>

This command defines the number of peaks included in the peak list.

After this number of peaks has been found, the R&S FSW stops the peak search and continues the search in the next measurement range.

Parameters:
<NumberPeaks>
Range: | 1 to 50
*RST: | 25
Example: CALC:PSE:SUBR 10

Sets 10 peaks per range to be stored in the list.

Manual operation: See "Peaks per Range"


Performing a Spurious Measurement

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Performing a Spurious Measurement
Performing a Spurious Measurement

The following commands are required to perform a Spurious measurement:

SENS:SWE:MODE LIST, see [SENSe:​]SWEep:​MODE

INITiate[:​IMMediate], see "Performing Measurements"


Retrieving and Saving Settings and Results

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Retrieving and Saving Settings and Results
Retrieving and Saving Settings and Results

The following commands analyze and retrieve measurement results for Spurious measurements.

Useful commands for spurious emission measurements described elsewhere
  • CALCulate:​LIMit<k>:​FAIL?
  • TRACe<n>[:​DATA]
  • TRACe<n>[:​DATA]:​MEMory?
  • TRACe<n>[:​DATA]:​X?


Programming Example: Spurious Emissions Measurement

Remote Commands > Configuring and Performing Measurements > Measuring Spurious Emissions > Programming Example: Spurious Emissions Measurement
Programming Example: Spurious Emissions Measurement

In the following example, the Spurious Emissions measurement is configured by defining ranges and parameters to create the following sweep list.

Note that this example is primarily meant to demonstrate the remote control commands, it does not necessarily reflect a useful measurement task.

//------------Preparing the measurement-------------
*RST
//Resets the instrument

SWE:MODE LIST
//Activates spurious emissions measurement

INIT:CONT OFF
//Selects single sweep mode.

//Spurious measurement has to be in single sweep mode to be configured
//and no sweep operation may be running!

// If required, a sweep stop can be ensured by INIT:IMM;*WAI

//---------------Configuring a Sweep List----------

LIST:RANG:COUNt?
//Returns the number of measurement ranges in the sweep list.
LIST:RANG4:DEL
//Deletes the fourth range.
LIST:RANG1:STAR 10000000
//Defines a start frequency of 10 MHz for range 1.
LIST:RANG1:STOP 100000000
//Defines a stop frequency of 100 MHz for range 1.
LIST:RANG1:BAND 500000
//Defines a resolution bandwidth of 500 kHz in range 1.
LIST:RANG1:BAND:VID 5000000
//Defines a video bandwidth of 5 MHz for range 1.
LIST:RANG1:INP:ATT:AUTO OFF
//Turns automatic selection of the input attenuation in range 1 off.

LIST:RANG1:INP:ATT 10
//Defines a input attenuation of 10 dBm for range 1.

LIST:RANG1:FILT:TYPE CFILter
//Selects an Channel filter for range 1.
LIST:RANG1:DET SAMP
//Selects a sample detector for range 1.
LIST:RANG1:POIN 601
//Defines 601 sweep points for range 1.
LIST:RANG1:RLEV -20
//Defines a reference level of -20 dBm for range 1.
LIST:RANG1:SWE:TIME 5
//Defines a manual sweep time of 5 second for range 1.

// Create a transducer that can be used.
// It has to cover the corresponding frequency range
//
SENSe1:CORRection:TRANsducer:SELect 'Test'
SENSe1:CORRection:TRANsducer:UNIT 'DB'
SENSe1:CORRection:TRANsducer:COMMent 'Test Transducer'
// Frequency Span 0 MHz to 20 Ghz
SENSe1:CORRection:TRANsducer:DATA 0e6,5, 20e9,3

SENS:LIST:RANG1:TRAN 'Test'
//Includes a transducer called 'Test' for range 1.

LIST:RANG1:LIM:STAR 10
LIST:RANG1:LIM:STOP 10
//Defines an absolute limit of 10 dBm at the start and stop frequencies of range 1.
LIST:RANG:LIM:STAT ON
//Turns the limit check for all ranges on.

//---------------Configuring the List Evaluation----------
CALC:PSE:MARG 100
//Sets the threshold to 100 dB.
CALC:PSE:PSH ON
//Marks all peaks in the diagram with blue squares.
CALC:PSE:SUBR 10
//Sets 10 peaks per range to be stored in the list.

//--------------Performing the Measurement-----

INIT:SPUR; *WAI
//Performs a spurious emission measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
CALC:LIM1:FAIL?
//Queries the result of the check for limit line 1.
TRAC? SPUR
//Queries the peak list of the spurious emission measurement.


Analyzing Statistics (APD, CCDF)

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF)
Analyzing Statistics (APD, CCDF)

All remote control commands specific to statistical measurements are described here.

Contents
  • Activating Statistical Measurements
  • Configuring Statistical Measurements
  • Using Gate Ranges for Statistical Measurements
  • Scaling the Diagram
  • Performing a Statistical Measurement
  • Retrieving Results
  • Programming Example: Measuring Statistics


Activating Statistical Measurements

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Activating Statistical Measurements
Activating Statistical Measurements

The following commands activate statistical measurements.

List of Commands
CALCulate<n>:STATistics:APD[:STATe]
CALCulate<n>:STATistics:CCDF[:STATe]


CALCulate<n>:STATistics:APD[:STATe]

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Activating Statistical Measurements > CALCulate<n>:STATistics:APD[:STATe]
CALCulate<n>:STATistics:APD[:STATe] <State>

This command turns the APD measurement on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:STAT:APD ON

Switches on the APD measurement.

Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "APD"


CALCulate<n>:STATistics:CCDF[:STATe]

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Activating Statistical Measurements > CALCulate<n>:STATistics:CCDF[:STATe]
CALCulate<n>:STATistics:CCDF[:STATe] <State>

This command turns the CCDF on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:STAT:CCDF ON

Switches on the CCDF measurement.

Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "CCDF"


Configuring Statistical Measurements

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Configuring Statistical Measurements
Configuring Statistical Measurements

The following commands configure the measurement.

Useful commands for configuring statistical measurements described elsewhere:
  • [SENSe:​]BANDwidth|BWIDth[:​RESolution]
Remote commands exclusive to statistical measurements:
List of Commands
CALCulate<n>:MARKer<m>:Y:PERCent
CALCulate<n>:STATistics:NSAMples


CALCulate<n>:MARKer<m>:Y:PERCent

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Configuring Statistical Measurements > CALCulate<n>:MARKer<m>:Y:PERCent
CALCulate<n>:MARKer<m>:Y:PERCent <Probability>

This command sets a marker to a particular probability value. You can query the corresponding level with CALCulate<n>:​MARKer<m>:​X.

Using the command turns delta markers into normal markers.

This command is available for CCDF measurements.

Parameters:
<Probability>
Range: 0 % to 100 %
Example: CALC1:MARK:Y:PERC 95PCT

Positions marker 1 to a probability of 95 %.

Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Percent Marker (CCDF only)"


CALCulate<n>:STATistics:NSAMples

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Configuring Statistical Measurements > CALCulate<n>:STATistics:NSAMples
CALCulate<n>:STATistics:NSAMples <Samples>

This command defines the number of samples included in the analysis of statistical measurement functions.

Parameters:
<Samples>
Range: | Min: 100, Max: depends on the RBW filter
*RST: | 100000
Example: CALC:STAT:NSAM 500

Sets the number of measurement points to be acquired to 500.

Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Number of Samples"


Using Gate Ranges for Statistical Measurements

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Using Gate Ranges for Statistical Measurements
Using Gate Ranges for Statistical Measurements

The following commands control gated statistical measurements.

List of Commands
[SENSe:]SWEep:EGATe:TRACe<k>:COMMent
[SENSe:]SWEep:EGATe:TRACe:PERiod
[SENSe:]SWEep:EGATe:TRACe<k>:STARt<range>
[SENSe:]SWEep:EGATe:TRACe<k>[:STATe<range>]
[SENSe:]SWEep:EGATe:TRACe<k>:STOP<range>


[SENSe:]SWEep:EGATe:TRACe<k>:COMMent

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Using Gate Ranges for Statistical Measurements > [SENSe:]SWEep:EGATe:TRACe<k>:COMMent
[SENSe:]SWEep:EGATe:TRACe<k>:COMMent <Comment>

This command defines a comment for the gate of a particular trace.

Parameters:
<Comment> | String containing the comment.
Example: | SWE:EGAT:TRAC1:COMM 'MyComment' Defines a comment for the gate in trace 1.
Example: | See "Programming Example: Measuring Statistics".
Manual operation: | See "Comment"


[SENSe:]SWEep:EGATe:TRACe:PERiod

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Using Gate Ranges for Statistical Measurements > [SENSe:]SWEep:EGATe:TRACe:PERiod
[SENSe:]SWEep:EGATe:TRACe:PERiod <Length>

This command defines the length of the gate for all traces.

The gate length applies to all traces.

Parameters:
<Length>
Range: | 100 ns to 1000 s
*RST: | 2 ms
Example: SWE:EGAT:TRAC1:PER 5ms

Defines the period for gated triggering to 5 ms.

Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Period"


[SENSe:]SWEep:EGATe:TRACe<k>:STARt<range>

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Using Gate Ranges for Statistical Measurements > [SENSe:]SWEep:EGATe:TRACe<k>:STARt<range>
[SENSe:]SWEep:EGATe:TRACe<k>:STARt<range> <Time>

This command defines the start time for a gate range.

Suffix: |
<range> | 1...3 gate range
Parameters:
<Time> | The value range depends on the gate period you have set for the selected trace with [SENSe:​]SWEep:​EGATe:​TRACe:​PERiod. The following rules apply: • the start time may not be higher than the length of the gate • the start time may not be lower than the stop time of the gate range of a lower order The reset values depend on the gate range. • for gate range 1, the start time is 0 ms • for gate range 3, the start time is 2 ms • for gate range 5, the start time is 4 ms
Example: | SWE:EGAT:TRAC1:STAR1 3ms Sets the Starting point for range 1 on trace 1 at 3 ms.
Example: | See "Programming Example: Measuring Statistics".
Manual operation: | See "Range <x> Start/Stop"


[SENSe:]SWEep:EGATe:TRACe<k>[:STATe<range>]

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Using Gate Ranges for Statistical Measurements > [SENSe:]SWEep:EGATe:TRACe<k>[:STATe<range>]
[SENSe:]SWEep:EGATe:TRACe<k>[:STATe<range>] <State>

This command includes or excludes a gate range for a particular trace.

Suffix:
<range>
1...3

gate range

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SWE:EGAT:TRAC1:STAT1 ON

Activates gate range 1 for trace 1.

Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Gated Trigger"
See "Range <x> Use"


[SENSe:]SWEep:EGATe:TRACe<k>:STOP<range>

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Using Gate Ranges for Statistical Measurements > [SENSe:]SWEep:EGATe:TRACe<k>:STOP<range>
[SENSe:]SWEep:EGATe:TRACe<k>:STOP<range> <Time>

This command defines the stop time for a gate range.

Suffix: |
<range> | 1...3 gate range
Parameters:
<Time> | The value range depends on the gate period you have set for the selected trace with [SENSe:​]SWEep:​EGATe:​TRACe:​PERiod. The following rules apply: • the stop time may not be higher than the length of the gate • the stop time may not be lower than the start time The reset values depend on the gate range. • for gate range 1, the stop time is 1 ms • for gate range 3, the stop time is 3 ms • for gate range 5, the stop time is 5 ms
Example: | SWE:EGAT:TRAC1:STOP1 5ms Sets the stopping point for range 1 on trace 1 at 5 ms.
Example: | See "Programming Example: Measuring Statistics".
Manual operation: | See "Range <x> Start/Stop"


Scaling the Diagram

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram
Scaling the Diagram

The following commands set up the diagram for statistical measurements.

List of Commands
CALCulate<n>:STATistics:PRESet
CALCulate<n>:STATistics:SCALe:AUTO ONCE
CALCulate<n>:STATistics:SCALe:X:RANGe
CALCulate<n>:STATistics:SCALe:X:RLEVel
CALCulate<n>:STATistics:SCALe:Y:LOWer
CALCulate<n>:STATistics:SCALe:Y:UNIT
CALCulate<n>:STATistics:SCALe:Y:UPPer


CALCulate<n>:STATistics:PRESet

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram > CALCulate<n>:STATistics:PRESet
CALCulate<n>:STATistics:PRESet

This command resets the scale of the diagram (x- and y-axis).

  • Reference level (x-axis)
    0.0 dBm
  • Display range (x-axis) for APD measurements
    100 dB
  • Display range (x-axis) for CCDF measurements
    20 dB
  • Upper limit of the y-axis
    1.0
  • Lower limit of the y-axis
    1E-6
Example: | CALC:STAT:PRES Resets the scaling for statistical functions
Usage: | Event
Manual operation: | See "Default Settings"


CALCulate<n>:STATistics:SCALe:AUTO ONCE

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram > CALCulate<n>:STATistics:SCALe:AUTO ONCE
CALCulate<n>:STATistics:SCALe:AUTO ONCE

This command initiates an automatic scaling of the diagram (x- and y-axis).

To obtain maximum resolution, the level range is set as a function of the measured spacing between peak power and the minimum power for the APD measurement and of the spacing between peak power and mean power for the CCDF measurement. In addition, the probability scale for the number of test points is adapted.

To get valid results, you have to perform a complete sweep with synchronization to the end of the auto range process. This is only possible in single sweep mode.

Parameters:
ONCE |
Example: | CALC:STAT:SCAL:AUTO ONCE;*WAI Adapts the level setting for statistical measurements.
Usage: | Event
Manual operation: | See "Adjust Settings"


CALCulate<n>:STATistics:SCALe:X:RANGe

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram > CALCulate<n>:STATistics:SCALe:X:RANGe
CALCulate<n>:STATistics:SCALe:X:RANGe <Range>

This command defines the display range of the x-axis for statistical measurements.

The effects are identical to DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe].

Parameters:
<Range>
Range: | 1 dB to 200 dB
*RST: | 100 dB
Example: CALC:STAT:SCAL:X:RANG 20dB
Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Range"


CALCulate<n>:STATistics:SCALe:X:RLEVel

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram > CALCulate<n>:STATistics:SCALe:X:RLEVel
CALCulate<n>:STATistics:SCALe:X:RLEVel <RefLevel>

This command sets the reference level for statistical measurements. The effects are identical to DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel.

Note that in case of statistical measurements the reference level applies to the x-axis.

Parameters:
<RefLevel>

The unit is variable.

If a reference level offset is included, the range is adjusted by that offset.

Range: | -130 dBm to 30 dBm
*RST: | 0 dBm
Example: CALC:STAT:SCAL:X:RLEV -60dBm
Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Ref Level"


CALCulate<n>:STATistics:SCALe:Y:LOWer

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram > CALCulate<n>:STATistics:SCALe:Y:LOWer
CALCulate<n>:STATistics:SCALe:Y:LOWer <Magnitude>

This command defines the lower vertical limit of the diagram.

Parameters:
<Magnitude>

The number is a statistical value and therefore dimensionless.

Range: | 1E-9 to 0.1
*RST: | 1E-6
Example: CALC:STAT:SCAL:Y:LOW 0.001
Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Y-Max / Y-Min"


CALCulate<n>:STATistics:SCALe:Y:UNIT

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram > CALCulate<n>:STATistics:SCALe:Y:UNIT
CALCulate<n>:STATistics:SCALe:Y:UNIT <Unit>

This command selects the unit of the y-axis.

Parameters:
<Unit>
PCT | ABS
*RST: ABS
Example: CALC:STAT:SCAL:Y:UNIT PCT

Sets the percentage scale.

Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Y-Unit"


CALCulate<n>:STATistics:SCALe:Y:UPPer

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Scaling the Diagram > CALCulate<n>:STATistics:SCALe:Y:UPPer
CALCulate<n>:STATistics:SCALe:Y:UPPer <Magnitude>

This command defines the upper vertical limit of the diagram.

Parameters:
<Magnitude>

The number is a statistical value and therefore dimensionless.

Range: | 1E-5 to 1.0
*RST: | 1.0
Example: CALC:STAT:SCAL:Y:UPP 0.01
Example:

See "Programming Example: Measuring Statistics".

Manual operation: See "Y-Max / Y-Min"


Performing a Statistical Measurement

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Performing a Statistical Measurement
Performing a Statistical Measurement

The following commands are required to perform a statistical measurement:

INITiate[:​IMMediate], see "Performing Measurements"


Retrieving Results

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Retrieving Results
Retrieving Results

The following commands are required to retrieve the measurement results.

Useful commands for retrieving results described elsewhere:
  • CALCulate<n>:​MARKer<m>:​X
Remote commands exclusive to statistical results
List of Commands
CALCulate<n>:STATistics:CCDF:X<t>?
CALCulate:STATistics:RESult<t>?


CALCulate<n>:STATistics:CCDF:X<t>?

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Retrieving Results > CALCulate<n>:STATistics:CCDF:X<t>?
CALCulate<n>:STATistics:CCDF:X<t>? <Probability>

This command queries the results of the CCDF.

Query parameters:
<Probability> | P0_01 Level value for 0.01 % probability P0_1 Level value for 0.1 % probability P1 P1: Level value for 1 % probability P10 Level value for 10 % probability
Example: | CALC:STAT:CCDF:X1? P10 Returns the level values that are over 10 % above the mean value.
Example: | See "Programming Example: Measuring Statistics".
Usage: | Query only
Manual operation: | See "CCDF"


CALCulate:STATistics:RESult<t>?

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Retrieving Results > CALCulate:STATistics:RESult<t>?
CALCulate:STATistics:RESult<t>? <ResultType>

This command queries the results of a CCDF or ADP measurement for a specific trace.

Parameters:
<ResultType> | MEAN Average (=RMS) power in dBm measured during the measurement time. PEAK Peak power in dBm measured during the measurement time. CFACtor Determined crest factor (= ratio of peak power to average power) in dB. ALL Results of all three measurements mentioned before, separated by commas: <mean power>,<peak power>,<crest factor>
Example: | CALC:STAT:RES2? ALL Reads out the three measurement results of trace 2. Example of answer string: 5.56,19.25,13.69 i.e. mean power: 5.56 dBm, peak power 19.25 dBm, crest factor 13.69 dB
Example: | See "Programming Example: Measuring Statistics".
Usage: | Query only
Manual operation: | See "APD" See "CCDF"


Programming Example: Measuring Statistics

Remote Commands > Configuring and Performing Measurements > Analyzing Statistics (APD, CCDF) > Programming Example: Measuring Statistics
Programming Example: Measuring Statistics

This example demonstrates how to determine statistical values for a measurement in a remote environment using the gated statistics example described in "APD and CCDF Basics - Gated Triggering".

//-----------Configuring the measurement ------------
*RST
//Reset the instrument
TRIG:SOUR EXT
//Defines the use of an external trigger.
TRIG:HOLD 25us
//Defines a trigger offset of 25 μs.
CALC:STAT:APD ON
//Activates APD measurement.
CALC:STAT:NSAM 1000
//Sets the number of samples to be included in the statistical evaluation to 1000.

//-------------Defining Gate ranges -----------------

SWE:EGAT:TRAC1:COMM 'GSM - useful part'
//Defines a comment for the gate
SWE:EGAT:TRAC1:PER 4.61536ms
//Sets the gate period to 4.61536ms.
SWE:EGAT:TRAC1:STAR1 15us
//Sets the start of range 1 to 15 μs.
SWE:EGAT:TRAC1:STOP1 557.8us
//Sets the end of range 1 to 15 μs (start time) + 542.77 μs (useful part) = 557.8 μs.
SWE:EGAT:TRAC1:STAT1 ON
//Activates the use of range 1.

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
CALC:STAT:RES1? MEAN
//Returns the mean average power for the useful part of the GSM signal.

//------------- Determining the CCDF values-------------------

CALC:STAT:CCDF ON
//Activates CCDF measurement.
CALC:MARK2:Y:PERC 95PCT
//Sets marker 2 to the 95% probability value.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.
CALC:STAT:CCDF:X? P1
//Returns the level value for 10% probability for the CCDF.
CALC:MARK2:X?
//Returns the level for a probability of 95%.

//----------- Scaling the diagram -------------------------
CALC:STAT:SCAL:X:RLEV -70dBm
//Sets the reference level to -70 dBm (x-axis!)
CALC:STAT:SCAL:X:RANG 20dB
//Defines a power level range of 20 dB for the x-axis
CALC:STAT:SCAL:Y:LOW 0.0001
//Sets the minimum of the y-axis to 0.01% probability
CALC:STAT:SCAL:Y:UPP 1.0
//Sets the maximum of the y-axis to 100% probability
CALC:STAT:SCAL:Y:UNIT PCT
//Displays percentage values on y-axis scale


Measuring the Time Domain Power

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power
Measuring the Time Domain Power

All remote control commands specific to time domain power measurements are described here.

Contents
  • Configuring the Measurement
  • Performing a Time Domain Power Measurement
  • Retrieving Measurement Results
  • Programming Example: Time Domain Power


Configuring the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement
Configuring the Measurement

The following remote commands measure the time domain power.

Useful commands for time domain power measurements described elsewhere
  • CALCulate:​MARKer:​X:​SLIMits:​LEFT
  • CALCulate:​MARKer:​X:​SLIMits:​RIGHT
  • CALCulate:​MARKer:​X:​SLIMits[:​STATe]
Remote commands exclusive to time domain power measurements
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AVERage
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PHOLd
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation[:STATe]


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AOFF

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AOFF

This command turns all time domain power evaluation modes off.

Usage: Event


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AVERage

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AVERage
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AVERage <State>

This command switches on or off averaging for the active power measurement in zero span in the window specified by the suffix <n>. If activated, a time domain value is calculated from the trace after each sweep; in the end, all values are averaged to calculate the final result.

The number of results required for the calculation of average is defined with [SENSe:​]AVERage:​COUNt .

Averaging is reset by switching it off and on again.

Synchronization to the end of averaging is only possible in single sweep mode.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INIT:CONT OFF

Switches to single sweep mode.

CALC:MARK:FUNC:SUMM:AVER ON

Switches on the calculation of average.

AVER:COUN 200

Sets the measurement counter to 200.

INIT;*WAI

Starts a sweep and waits for the end.


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PHOLd

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PHOLd
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PHOLd <State>

This command switches on or off the peak-hold function for the active power measurement in zero span in the window specified by the suffix <n>. If activated, the peak for each sweep is compared to the previously stored peak; the maximum of the two is stored as the current peak.

The peak-hold function is reset by switching it off and on again.

Parameters:
<State>
ON | OFF
*RST: OFF


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary[:STATe] <State>

This command turns time domain power measurements on and off. This measurement in only available in zero span.

When you turn the measurement on, the R&S FSW activates a marker and positions it on the peak power level in the marker search range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Time Domain Power".

Manual operation: See "Time Domain Power"


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN[:STATe] <State>

This command turns the evaluation to determine the mean time domain power on and off.

The R&S FSW performs the measurement on the trace marker 1 is positioned on.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Time Domain Power".

Manual operation: See "Results"


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak[:STATe] <State>

This command turns the evaluation to determine the positive peak time domain power on and off.

The R&S FSW performs the measurement on the trace marker 1 is positioned on.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Time Domain Power".

Manual operation: See "Results"


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS[:STATe] <State>

This command turns the evaluation to determine the RMS time domain power on and off.

The R&S FSW performs the measurement on the trace marker 1 is positioned on.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Time Domain Power".

Manual operation: See "Results"


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation[:STATe] <State>

This command turns the evaluation to determine the standard deviation of the time domain power on and off.

The R&S FSW performs the measurement on the trace marker 1 is positioned on.

Parameters:
<State>
ON | OFF
*RST: OFF


Performing a Time Domain Power Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Performing a Time Domain Power Measurement
Performing a Time Domain Power Measurement

The following commands are required to perform a Time Domain Power measurement:

INITiate[:​IMMediate], see "Performing Measurements"


Retrieving Measurement Results

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results
Retrieving Measurement Results

The following commands query the results for time domain measurements.

Contents
  • Measuring the Mean Power
  • Measuring the Peak Power
  • Measuring the RMS Power
  • Measuring the Standard Deviation


Measuring the Mean Power

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Mean Power
Measuring the Mean Power
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:RESult?


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:AVERage:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Mean Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:AVERage:RESult?

This command queries the average mean time domain power. The query is only possible if averaging has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​AVERage.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<MeanPower> | Mean power of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:PHOLd:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Mean Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:PHOLd:RESult?

This command queries the maximum mean time domain power. The query is only possible if the peak hold function has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​PHOLd.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<MeanPower> | Mean power of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Mean Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:RESult?

This command queries the mean time domain power.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<MeanPower> | Mean power of the signal during the measurement time.
Example: | See "Programming Example: Time Domain Power".
Usage: | Query only
Manual operation: | See "Results"


Measuring the Peak Power

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Peak Power
Measuring the Peak Power
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:RESult?


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:AVERage:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Peak Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:AVERage:RESult?

This command queries the average positive peak time domain power. The query is only possible if averaging has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​AVERage.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<PeakPower> | Peak power of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:PHOLd:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Peak Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:PHOLd:RESult?

This command queries the maximum positive peak time domain power. The query is only possible if the peak hold function has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​PHOLd.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<PeakPower> | Peak power of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Peak Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:RESult?

This command queries the positive peak time domain power.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<PeakPower> | Peak power of the signal during the measurement time.
Example: | See "Programming Example: Time Domain Power".
Usage: | Query only
Manual operation: | See "Results"


Measuring the RMS Power

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the RMS Power
Measuring the RMS Power
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:RESult?


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:AVERage:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the RMS Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:AVERage:RESult?

This command queries the average RMS of the time domain power. The query is only possible if averaging has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​AVERage.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<RMSPower> | RMS power of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:PHOLd:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the RMS Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:PHOLd:RESult?

This command queries the maximum RMS of the time domain power. The query is only possible if the peak hold function has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​PHOLd.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<RMSPower> | RMS power of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the RMS Power > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:RESult?

This command queries the RMS of the time domain power.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<RMSPower> | RMS power of the signal during the measurement time.
Example: | See "Programming Example: Time Domain Power".
Usage: | Query only
Manual operation: | See "Results"


Measuring the Standard Deviation

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Standard Deviation
Measuring the Standard Deviation
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:RESult?


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:AVERage:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Standard Deviation > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:AVERage:RESult?

This command queries the average standard deviation of the time domain power. The query is only possible if averaging has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​AVERage.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<StandardDeviation> | Standard deviation of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:PHOLd:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Standard Deviation > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:PHOLd:RESult?

This command queries the maximum standard deviation of the time domain power. The query is only possible if the peak hold function has been activated previously using CALCulate<n>:​MARKer<m>:​FUNCtion:​SUMMary:​PHOLd.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<StandardDeviation> | Standard deviation of the signal during the measurement time.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Retrieving Measurement Results > Measuring the Standard Deviation > CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:RESult?

This command queries the standard deviation of the time domain power.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<StandardDeviation> | Standard deviation of the signal during the measurement time.
Usage: | Query only


Programming Example: Time Domain Power

Remote Commands > Configuring and Performing Measurements > Measuring the Time Domain Power > Programming Example: Time Domain Power
Programming Example: Time Domain Power

This programming example demonstrates the measurement example described in "Measurement Example" in a remote environment.

//-------------Configuring the Measurement-----------------------
*RST
//Resets the instrument

INIT:CONT OFF
//Turns on single sweep mode.

FREQ:CENT 1.8GHz
//Sets the center frequency to 1.8 GHz.

BAND:RES 100kHz
//Sets the bandwidth to 100 kHz.

SWE:TIME 10ms
//Sets the sweep time to 640 µs.

FREQ:SPAN 0
//Sets the instrument to zero span.

CALC:MARK:FUNC:SUMM:STAT ON
//Turns on time domain power measurements.

CALC:MARK:FUNC:SUMM:MEAN ON
CALC:MARK:FUNC:SUMM:PPE ON
CALC:MARK:FUNC:SUMM:RMS ON
//Turns the evalution of the mean, peak and RMS time domain power.

CALC:MARK:X:SLIM ON
//Activates limit lines for evaluation.

CALC:MARK:X:SLIM:LEFT 1ms
//Sets the left limit line to 326 µs.

CALC:MARK:X:SLIM:RIGH 6ms
//Sets the right limit line to 538 µs.

//--------------Performing the Measurement------------------------

INIT;*WAI
//Initiates the measurement and waits until the measurement is finished.

//-------------Retrieving the Results--------------------------------
CALC:MARK:FUNC:SUMM:MEAN:RES?
CALC:MARK:FUNC:SUMM:PPE:RES?
CALC:MARK:FUNC:SUMM:RMS:RES?
//Queries the mean, peak and RMS time domain power.


Measuring the Harmonic Distortion

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion
Measuring the Harmonic Distortion

All remote control commands specific to harmonic distortion measurements are described here.

Contents
  • Activating the Measurement
  • Configuring the Measurement
  • Performing the Measurement
  • Retrieving Results
  • Example: Measuring the Harmonic Distortion


Activating the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Activating the Measurement
Activating the Measurement

The following command activates harmonic distortion measurement.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics[:STATe]


CALCulate<n>:MARKer<m>:FUNCtion:HARMonics[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Activating the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:HARMonics[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics[:STATe] <State>

This command turns the harmonic distortion measurement on and off.

Note the following:

  • If you perform the measurement in the frequency domain, the search range for the frequency of the first harmonic, whose power is determined, is defined by the last span.
  • If you perform the measurement in the time domain, the current center frequency is used as the frequency of the first harmonic. Thus, the frequency search is bypassed. The first harmonic frequency is set by a specific center frequency in zero span before the harmonic measurement is started.
Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:HARM ON

Activates the harmonic distortion measurement.

Example:

See "Example: Measuring the Harmonic Distortion".

Manual operation: See "Harmonic Distortion"


Configuring the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Configuring the Measurement
Configuring the Measurement

The following commands control the harmonic distortion measurement.

Useful commands for harmonic distortion measurements described elsewhere
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​CENTer
  • [SENSe:​]SWEep:​TIME:​AUTO
Remote commands exclusive to harmonic distortion measurements
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:BANDwidth:AUTO
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:NHARmonics
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:PRESet


CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:BANDwidth:AUTO

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:BANDwidth:AUTO
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:BANDwidth:AUTO <State>

This command selects the resolution bandwidth of the harmonic in respect to the bandwidth of the first harmonic.

Parameters:
<State>
ON | OFF | 0 | 1
OFF | 0

identical

ON | 1

a multiple

*RST: 1
Example:

See "Example: Measuring the Harmonic Distortion".

Manual operation: See "Harmonic RBW Auto"


CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:NHARmonics

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:NHARmonics
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:NHARmonics <NoHarmonics>

This command selects the number of harmonics that the R&S FSW looks for.

Parameters:
<NoHarmonics>
Range: | 1 to 26
*RST: | 10
Example:

See "Example: Measuring the Harmonic Distortion".

Manual operation: See "No. of Harmonics"


CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:PRESet

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Configuring the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:PRESet
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:PRESet

This command initiates a measurement to determine the ideal configuration for the harmonic distortion measurement.

The method depends on the span.

  • Frequency domain (span > 0)
    Frequency and level of the first harmonic are determined and used for the measurement list.
  • Time domain (span = 0)
    The level of the first harmonic is determined. The frequency remains unchanged.
Example: | See "Example: Measuring the Harmonic Distortion".
Usage: | Event
Manual operation: | See "Adjust Settings"


Performing the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Performing the Measurement
Performing the Measurement

The following commands are required to perform a harmonic distortion measurement:

INITiate[:​IMMediate], see "Performing Measurements"


Retrieving Results

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Retrieving Results
Retrieving Results

The following commands retrieve the results of the harmonic distortion measurement.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:DISTortion?
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:LIST?


CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:DISTortion?

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Retrieving Results > CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:DISTortion?
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:DISTortion? TOTal

This command queries the total harmonic distortion of the signal.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | <Distortion_%>,<Distortion_dB> Pair of values, one showing the THD in %, one in dB.
Example: | See "Example: Measuring the Harmonic Distortion".
Usage: | Query only
Manual operation: | See "Harmonic Distortion"


CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:LIST?

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Retrieving Results > CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:LIST?
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:LIST?

This command queries the position of the harmonics.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Harmonics> | Returns one value for every harmonic. The first value is the absolute power of the first harmonic. The unit is variable. The other values are power levels relative to the first harmonic. The unit for these is dB.
Example: | See "Example: Measuring the Harmonic Distortion".
Usage: | Query only
Manual operation: | See "Harmonic Distortion"


Example: Measuring the Harmonic Distortion

Remote Commands > Configuring and Performing Measurements > Measuring the Harmonic Distortion > Example: Measuring the Harmonic Distortion
Example: Measuring the Harmonic Distortion
//-------------Configuring the Measurement-------------
*RST
//Resets the instrument.

INIT:CONT OFF
//Turns on single sweep mode.

CALC:MARK:FUNC:HARM ON
//Turns on the harmonic distortion measurement.
CALC:MARK:FUNC:HARM:NHAR 3
//Defines three harmonics to be found.

CALC:MARK:FUNC:HARM:BAND:AUTO OFF
//Turns off automatic bandwidth selection.
CALC:MARK:FUNC:HARM:PRES
//Determines the ideal configuration.

//-------------Performing the Measurement-------------------

INIT;*WAI
//Initiates the measurement and finishes the sweep.

//-------------Retrieving the Results------------------------
CALC:MARK:FUNC:HARM:LIST?
//Queries the position of the harmonics.
CALC:MARK:FUNC:HARM:DIST? TOT
//Queries the total harmonic distortion.


Measuring the Third Order Intercept Point

Remote Commands > Configuring and Performing Measurements > Measuring the Third Order Intercept Point
Measuring the Third Order Intercept Point
Contents
  • Determining the TOI
  • Programming Example: Measuring the TOI


Determining the TOI

Remote Commands > Configuring and Performing Measurements > Measuring the Third Order Intercept Point > Determining the TOI
Determining the TOI

All remote control commands specific to TOI measurements are described here.

Useful commands for TOI measurements described elsewhere
  • CALCulate<n>:​DELTamarker<m>:​X
  • CALCulate<n>:​DELTamarker<m>:​X:​RELative?
  • CALCulate<n>:​DELTamarker<m>:​Y?
  • CALCulate<n>:​MARKer<m>:​X
  • CALCulate<n>:​MARKer<m>:​Y?
Remote commands exclusive to TOI measurements
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:TOI[:STATe]
CALCulate:MARKer:FUNCtion:TOI:SEARchsignal ONCE
CALCulate<n>:MARKer<m>:FUNCtion:TOI:RESult?


CALCulate<n>:MARKer<m>:FUNCtion:TOI[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the Third Order Intercept Point > Determining the TOI > CALCulate<n>:MARKer<m>:FUNCtion:TOI[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:TOI[:STATe] <State>

This command initiates a measurement to determine the third intercept point.

A two-tone signal with equal carrier levels is expected at the RF input of the instrument. Marker 1 and marker 2 (both normal markers) are set to the maximum of the two signals. Delta marker 3 and delta marker 4 are positioned to the intermodulation products. The delta markers can be modified separately afterwards with the CALCulate<n>:​DELTamarker<m>:​X command.

The third-order intercept is calculated from the level spacing between the normal markers and the delta markers.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:TOI ON

Switches on the measurement of the third-order intercept.

Example:

See "Programming Example: Measuring the TOI".

Manual operation: See "TOI"


CALCulate:MARKer:FUNCtion:TOI:SEARchsignal ONCE

Remote Commands > Configuring and Performing Measurements > Measuring the Third Order Intercept Point > Determining the TOI > CALCulate:MARKer:FUNCtion:TOI:SEARchsignal ONCE
CALCulate:MARKer:FUNCtion:TOI:SEARchsignal ONCE

This command initiates a search for signals in the current trace to determine the third intercept point.

Parameters:
ONCE |
Example: | CALC:MARK:FUNC:TOI:SEAR ONCE Executes the search for 2 signals and their intermodulation product at the currently available trace.
Example: | See "Programming Example: Measuring the TOI".
Usage: | Event
Manual operation: | See "Search Signals"


CALCulate<n>:MARKer<m>:FUNCtion:TOI:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the Third Order Intercept Point > Determining the TOI > CALCulate<n>:MARKer<m>:FUNCtion:TOI:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:TOI:RESult?

This command queries the results for the third order intercept point measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<TOI> | Third order intercept point.
Example: | See "Programming Example: Measuring the TOI".
Usage: | Query only
Manual operation: | See "TOI"


Programming Example: Measuring the TOI

Remote Commands > Configuring and Performing Measurements > Measuring the Third Order Intercept Point > Programming Example: Measuring the TOI
Programming Example: Measuring the TOI

This example demonstrates how to determine the TOI in a remote environment.

//-----------Configuring the measurement ------------
*RST
//Reset the instrument
CALC:MARK:FUNC:TOI ON
//Activate TOI measurement.

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.

CALC:MARK:FUNC:TOI:SEAR ONCE
//Initiates a search for signals in the current trace.

//---------------Retrieving Results-------------
CALC:MARK:FUNC:TOI:RES?
//Returns the TOI.


Measuring the AM Modulation Depth

Remote Commands > Configuring and Performing Measurements > Measuring the AM Modulation Depth
Measuring the AM Modulation Depth

All remote control commands specific to AM modulation depth measurements are described here.

Contents
  • Configuring and Performing the Measurement
  • Example: Measuring the AM Modulation Depth


Configuring and Performing the Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the AM Modulation Depth > Configuring and Performing the Measurement
Configuring and Performing the Measurement

The following commands control the measurement.

Useful commands for AM modulation depth described elsewhere
  • CALCulate<n>:​DELTamarker<m>:​X
  • CALCulate<n>:​DELTamarker<m>:​X:​RELative?
  • CALCulate<n>:​MARKer<m>:​X
Remote commands exclusive to AM modulation depth measurements
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:SEARchsignal ONCE
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:RESult?


CALCulate<n>:MARKer<m>:FUNCtion:MDEPth[:STATe]

Remote Commands > Configuring and Performing Measurements > Measuring the AM Modulation Depth > Configuring and Performing the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:MDEPth[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth[:STATe] <State>

This command turns the AM Modulation Depth measurement on and off.

To work correctly, the measurement requires an AM modulated signal.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: Measuring the AM Modulation Depth".

Manual operation: See "AM Mod Depth"


CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:SEARchsignal ONCE

Remote Commands > Configuring and Performing Measurements > Measuring the AM Modulation Depth > Configuring and Performing the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:SEARchsignal ONCE
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:SEARchsignal ONCE

This command initiates a search for the signals required for the AM depth measurement.

Note that the command does not perform a new measurement, but looks for the signals on the current trace.

Parameters:
ONCE |
Example: | CALC:MARK:FUNC:MDEP:SEAR ONCE Executes the search of an AM modulated signal at the currently available trace.
Example: | See "Example: Measuring the AM Modulation Depth".
Usage: | Event
Manual operation: | See "Search Signals"


CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:RESult?

Remote Commands > Configuring and Performing Measurements > Measuring the AM Modulation Depth > Configuring and Performing the Measurement > CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:RESult?

This command queries the results of the AM modulation depth measurement..

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<ModulationDepth> | Modulation depth in %.
Example: | See "Example: Measuring the AM Modulation Depth".
Usage: | Query only
Manual operation: | See "AM Mod Depth"


Example: Measuring the AM Modulation Depth

Remote Commands > Configuring and Performing Measurements > Measuring the AM Modulation Depth > Example: Measuring the AM Modulation Depth
Example: Measuring the AM Modulation Depth

This example demonstrates how to determine the AM modulation depth in a remote environment. Note that without a real input signal this measurement will not return useful results.

//-----------Configuring the measurement ------------
*RST
//Reset the instrument
FREQ:CENT 100MHz
//Set center frequency
FREQ:SPAN 10KHz
// Set span
CALC:MARK:FUNC:MDEP ON
//Activate AM modulation depth measurement.

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT:IMM
// Perform a single measurement
CALC:MARK:FUNC:MDEP:SEAR ONCE
//Initiates a search for signals in the current trace.

//---------------Retrieving Results-------------
CALC:MARK:FUNC:MDEP:RES?
//Queries the measurement results.

//If the results are not accurate, change the position of the
//the temporary markers manually.

//----Changing the position of the temp markers-----
CALC:MARK:X 100MHZ
//Positions the reference marker on 100 MHz.
CALC:DELT2:X 5KHZ
//Positions delta marker 2 and 3 at a distance of 5 kHz to the reference marker.
CALC:DELT3:X 1KHZ
//Corrects the position of delta marker 3 by 1 kHz.

CALC:MARK:FUNC:MDEP:RES?
//Queries the measurement results for the repositioned markers.


Remote Commands for EMI Measurements

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements
Remote Commands for EMI Measurements

The following commands are required to perform EMI measurements in a remote environment. This measurement requires the R&S FSW-K54 option.

The following tasks specific to the EMI application are described here:

Contents
  • Activating EMI Measurement
  • Configuring EMI Markers
  • Configuring the EMI Final Test
  • Configuring EMI Limit Lines
  • Controlling LISN
  • Retrieving EMI Results
  • Evaluating the Results
  • Programming Example: EMI Measurement


Activating EMI Measurement

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Activating EMI Measurement
Activating EMI Measurement

EMI measurement must be activated explicitely.

List of Commands
CALCulate:MARKer:FUNCtion:FMEasurement:STATe


CALCulate:MARKer:FUNCtion:FMEasurement:STATe

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Activating EMI Measurement > CALCulate:MARKer:FUNCtion:FMEasurement:STATe
CALCulate:MARKer:FUNCtion:FMEasurement:STATe <State>

This command turns the EMI measurement marker functionality on and off.

Parameters:
<State> | ON | OFF
Example: | See "Programming Example: EMI Measurement".
Manual operation: | See "EMI"


Configuring EMI Markers

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Configuring EMI Markers
Configuring EMI Markers

The commands required to configure EMI markers are described here.

Useful commands for configuring EMI markers described elsewhere:
  • CALCulate<n>:​MARKer<m>[:​STATe]
    CALCulate<n>:​DELTamarker<m>[:​STATe]
  • CALCulate<n>:​MARKer<m>[:​STATe]
    CALCulate<n>:​DELTamarker<m>[:​STATe]
  • CALCulate<n>:​DELTamarker<m>:​MREF
  • CALCulate<n>:​MARKer<m1>:​LINK:​TO:​MARKer<m2>
    CALCulate<n>:​DELTamarker<m1>:​LINK:​TO:​MARKer<m2>
    CALCulate<n>:​DELTamarker<m>:​LINK
  • CALCulate<n>:​MARKer<m>:​TRACe
Remote commands exclusive to configuring EMI markers
List of Commands
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:DETector
CALCulate:MARKer<m>:FUNCtion:FMEasurement:DETector


CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:DETector

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Configuring EMI Markers > CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:DETector
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:DETector <Detector>

This command selects the detector for a specific deltamarker during the final evaluation.

If the deltamarker is not yet active, the command also turns the deltamarker on.

Parameters:
<Detector>
OFF

no final measurement is performed

AVER

average detector

CAV

CISPR Average detector

CRMS

RMS Average detector

POS

maximum peak detector

QPE

quasipeak detector

*RST: OFF
Manual operation: See "Final Test Detector"


CALCulate:MARKer<m>:FUNCtion:FMEasurement:DETector

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Configuring EMI Markers > CALCulate:MARKer<m>:FUNCtion:FMEasurement:DETector
CALCulate:MARKer<m>:FUNCtion:FMEasurement:DETector <Detector>

This command selects the detector for a specific marker during the final measurement.

If the marker is not yet active, the command also turns the marker on.

Parameters:
<Detector>
OFF

no final measurement is performed

AVER

average detector

CAV

CISPR Average detector

CRMS

RMS Average detector

POS

maximum peak detector

QPE

quasipeak detector

*RST: OFF
Example:

See "Programming Example: EMI Measurement".

Manual operation: See "Final Test Detector"


Configuring the EMI Final Test

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Configuring the EMI Final Test
Configuring the EMI Final Test

The commands required to configure the EMI final test are described here.

Useful commands for configuring EMI final tests described elsewhere:
  • [SENSe:​]BANDwidth|BWIDth[:​RESolution]:​TYPE
  • [SENSe:​]BANDwidth|BWIDth[:​RESolution]
  • DISPlay[:​WINDow<n>]:​TRACe:​X:​SPACing
Remote commands exclusive to configuring EMI final tests
List of Commands
CALCulate:MARKer:FUNCtion:FMEasurement:PSEarch|PEAKsearch:AUTO
CALCulate:MARKer:FUNCtion:FMEasurement:DWELl


CALCulate:MARKer:FUNCtion:FMEasurement:PSEarch|PEAKsearch:AUTO

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Configuring the EMI Final Test > CALCulate:MARKer:FUNCtion:FMEasurement:PSEarch|PEAKsearch:AUTO
CALCulate:MARKer:FUNCtion:FMEasurement:PSEarch|PEAKsearch:AUTO <State>

This command turns an automatic peak search on and off. If enabled, the search is performed automatically after each sweep.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 0
Example: CALC:MARK:FUNC:FME:PEAK:AUTO ON

Activates automatic marker peak search after each sweep.

Example:

See "Programming Example: EMI Measurement".

Manual operation: See "Automatic Peak Search"


CALCulate:MARKer:FUNCtion:FMEasurement:DWELl

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Configuring the EMI Final Test > CALCulate:MARKer:FUNCtion:FMEasurement:DWELl
CALCulate:MARKer:FUNCtion:FMEasurement:DWELl <Time>

This command defines the dwell time during the final measurement.

Parameters:
<Time>
Range: | min value to max value
*RST: | 1 s
Default unit: | seconds
Example:

See "Programming Example: EMI Measurement".

Manual operation: See "Dwell Time"


Configuring EMI Limit Lines

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Configuring EMI Limit Lines
Configuring EMI Limit Lines

The commands required to define limit lines for EMI measurements are described in "Configuring Display and Limit Lines".


Controlling LISN

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Controlling LISN
Controlling LISN

The commands required to control a LISN are described here.

List of Commands
INPut:LISN:PHASe
INPut:LISN:FILTer:HPASs[:STATe]
INPut:LISN:TYPE


INPut:LISN:PHASe

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Controlling LISN > INPut:LISN:PHASe
INPut:LISN:PHASe <Phase>

This command selects the phase of the LISN you want to measure.

Parameters:
<Phase>
L1
L2
L3
N
*RST: L1
Example: INP:LISN:PHAS N

Selects the N phase.

Manual operation: See "Phase"


INPut:LISN:FILTer:HPASs[:STATe]

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Controlling LISN > INPut:LISN:FILTer:HPASs[:STATe]
INPut:LISN:FILTer:HPASs[:STATe] <State>

This command turns the 150 kHz highpass filter for the ENV216 network on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:LISN:HPAS ON

Turns the filter on.

Manual operation: See "150 kHz Highpass Filter"


INPut:LISN:TYPE

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Controlling LISN > INPut:LISN:TYPE
INPut:LISN:TYPE <LISNType>

This command selects the type of network.

Parameters:
<LISNType>
TWOPhase

2-Phase networks

FOURphase

4-Phase networks

ESH3z5
ESH2z5
ENV4200
ENV216
*RST: ---
Example: INP:LISN:TYPE ESH3z5

Selects the ESH3z5 network.

Manual operation: See "LISN Type"


Retrieving EMI Results

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Retrieving EMI Results
Retrieving EMI Results

The commands required to retrieve EMI measurement results are described here.

Useful commands for retrieving EMI measurement results described elsewhere:
  • CALCulate<n>:​MARKer<m>:​X
    CALCulate<n>:​DELTamarker<m>:​X
  • CALCulate<n>:​MARKer<m>:​Y?
    CALCulate<n>:​DELTamarker<m>:​Y?
Remote commands exclusive to retrieving EMI measurement results
List of Commands
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:RESult?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:RESult?
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?


CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:RESult?

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Retrieving EMI Results > CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:RESult?
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:RESult? <Result>

This command queries the result of the EMI measurement at the deltamarker position.

Return values:
<Result> | Absolute power level measured during final EMI measurement.
Example: | CALC:DELT3:FUNC:FME:RES? Queries the result of delta marker 3.
Usage: | Query only


CALCulate:MARKer<m>:FUNCtion:FMEasurement:RESult?

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Retrieving EMI Results > CALCulate:MARKer<m>:FUNCtion:FMEasurement:RESult?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:RESult? <Result>

This command queries the result of the EMI measurement at the marker position.

Return values:
<Result> | Power level. The unit depends on the one you have currently set.
Example: | CALC:MARK1:FUNC:FME:RES? Queries the result of marker 1.
Example: | See "Programming Example: EMI Measurement".
Usage: | Query only


CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Retrieving EMI Results > CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ? <Condition>

This command queries the condition of a deltamarker position in relation to a certain limit line.

Return values:
<Condition> | 0 The deltamarker has passed the limit check. 1 The deltamarker is inside the margins of a limit line. 2 The deltamarker has failed the limit check.
Example: | CALC:DELT2:FUNC:FME:LIM2:COND? Queries the condition of deltamarker 2 in relation to limit line 2.
Usage: | Query only


CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Retrieving EMI Results > CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ? <Condition>

This command queries the condition of a marker position in relation to a certain limit line.

Return values:
<Condition> | 0 The marker has passed the limit check. 1 The marker is inside the margins of a limit line. 2 The marker has failed the limit check.
Example: | CALC:MARK1:FUNC:FME:LIM2:COND? Queries the condition of marker 1 in relation to limit line 2.
Example: | See "Programming Example: EMI Measurement".
Usage: | Query only


CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Retrieving EMI Results > CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?

This command queries the vertical distance from the deltamarker position to the limit line. The unit is dB.

If the deltamarker has been assigned to a different trace than the limit line, or if no limit ine is defined for the marker position, the command returns -200.

Return values:
<Amplitude> | Vertical distance to the limit line in dB.
Example: | CALC:DELT3:FUNC:FME:LIM2:DELT? Queries the distance of deltamarker 3 to the second limit line.
Usage: | Query only


CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Retrieving EMI Results > CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa? <Amplitude>

This command queries the vertical distance from the marker position to the limit line. The unit is dB.

If the marker has been assigned to a different trace than the limit line, or if no limit ine is defined for the marker position, the command returns -200.

Return values:
<Amplitude> | Vertical distance to the limit line in dB.
Example: | CALC:MARK3:FUNC:FME:LIM2:DELT? Queries the distance of marker 3 to the second limit line.
Example: | See "Programming Example: EMI Measurement".
Usage: | Query only


Evaluating the Results

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Evaluating the Results
Evaluating the Results

The commands required to control the demodulation of signals at the marker position are described in "Marker Demodulation".


Programming Example: EMI Measurement

Remote Commands > Configuring and Performing Measurements > Remote Commands for EMI Measurements > Programming Example: EMI Measurement
Programming Example: EMI Measurement

This example demonstrates how to detect electromagnetic interferences (EMI) in a remote environment.

//----------- Preparing the measurement ------------
//Reset the instrument
*RST
//Define the span to be analyzed
FREQ:STAR 150kHz
FREQ:STOP 1GHz
//Configure two traces, one with peak detector, one with average detector
DISP:TRAC1 ON
DISP:TRAC2 ON
DET1 POS
DET2 AVER

//----------- Configuring the measurement ------------
//Select EMI measurement
CALC:MARK:FUNC:FME:STAT ON
//Configure CISPR filter and RBW
BAND:TYPE CISP
BAND:RES 1MHz
//Define the dwell time
CALC:MARK:FUNC:FME:DWEL 1ms
//Configure an auto peak search
CALC:MARK:FUNC:FME:PEAK:AUTO ON
//Configure a logarithmic frequency scaling
DISP:TRAC:X:SPAC LOG
//Configure marker demodulation for marker 1
CALC:MARK:FUNC:DEM ON
//Increase the number of sweep points
SWE:POIN 200000
//Set the unit to V
CALC:UNIT:POW V

//----------- Configuring EMI markers ---------------
//Activate 6 normal EMI markers
CALC:MARK1 ON
CALC:MARK2 ON
CALC:MARK3 ON
CALC:MARK4 ON
CALC:MARK5 ON
CALC:MARK6 ON
//Set  markers 1 to 3  on trace 1. Set markers 4 to 6 on trace 2.
CALC:MARK1:TRAC 1
CALC:MARK2:TRAC 1
CALC:MARK3:TRAC 1
CALC:MARK4:TRAC 2
CALC:MARK5:TRAC 2
CALC:MARK6:TRAC 2
//Use CISPR average detector for all markers during final test
CALC:MARK1:FUNC:FME:DET CAV
CALC:MARK2:FUNC:FME:DET CAV
CALC:MARK3:FUNC:FME:DET CAV
CALC:MARK4:FUNC:FME:DET CAV
CALC:MARK5:FUNC:FME:DET CAV
CALC:MARK6:FUNC:FME:DET CAV

//----------- Configuring a limit check -------------
//Select EN55011A.LIN as limit line 1
CALC:LIM1:NAME "EN55011A.LIN"
//Configure trace 1 to be checked against limit line 1
CALC:LIM1:TRAC1:CHEC ON
//Clear the results of all previous limit checks
CALC:LIM:CLE

//----------- Performing the Measurement ------------
//Select single sweep mode.
INIT:CONT OFF
//Initiate a new measurement and wait until the sweep has finished.
INIT;*WAI

//------------ Retrieving Results -------------------
//Query the results for the EMI measurement
//First marker frequency, then final test level
CALC:MARK1:X?
CALC:MARK1:FUNC:FME:RES?
CALC:MARK2:X?
CALC:MARK2:FUNC:FME:RES?
CALC:MARK3:X?
CALC:MARK3:FUNC:FME:RES?
CALC:MARK4:X?
CALC:MARK4:FUNC:FME:RES?
CALC:MARK5:X?
CALC:MARK5:FUNC:FME:RES?
CALC:MARK6:X?
CALC:MARK6:FUNC:FME:RES?

//Query the result of the limit check for trace 1
CALC:LIM1:FAIL?
//Query the result of the limit check and the distance from the limit line
//for each marker
CALC:MARK1:FUNC:FME:LIM1:COND?
CALC:MARK1:FUNC:FME:LIM1:DELT?
CALC:MARK2:FUNC:FME:LIM1:COND?
CALC:MARK2:FUNC:FME:LIM1:DELT?
CALC:MARK3:FUNC:FME:LIM1:COND?
CALC:MARK3:FUNC:FME:LIM1:DELT?
CALC:MARK4:FUNC:FME:LIM1:COND?
CALC:MARK4:FUNC:FME:LIM1:DELT?
CALC:MARK5:FUNC:FME:LIM1:COND?
CALC:MARK5:FUNC:FME:LIM1:DELT?
CALC:MARK6:FUNC:FME:LIM1:COND?
CALC:MARK6:FUNC:FME:LIM1:DELT?


List Evaluations

Remote Commands > Configuring and Performing Measurements > List Evaluations
List Evaluations

A list evaluation is a mutliple power measurement that measures the power at up to 200 frequencies. The measurement itself is a time domain measurement. Note that if you set a span greater than 0, the R&S FSW aborts the list evaluation.

Noise cancellation in list evaluations

Nnoise cancellation is also available in zero span and thus also for list evaluations. See "Noise cancellation" for details.

List evaluations allow for a different instrument setup for each frequency you want to measure. You can define most of the settings with the commands described here. Settings not covered by the commands listed below can be controlled with the common commands (see "Setting Basic Measurement Parameters". Note that these commands have to be sent prior to the commands that control the list evaluation.

In case of a triggered measurement, a separate trigger event is required for each frequency to initiate that measurement. Note that you have to make changes to the trigger level in the time domain in order for it to take effect for the List Evaluation commands.

The list evaluation is incompatible to other measurement functions (e.g. marker functionality or statistics). If you use a command that controls those functions, the R&S FSW aborts the list evaluation.

The R&S FSW also aborts the list evaluation if you end the remote session.

The commands can be used in two different ways.

  • Instrument setup, measurement and querying of the results in a single command line. This method causes the least delay between the measurement and the result output. However, it requires the control computer to wait for the response from the instrument.
  • Instrument setup and querying of the result list at the end of the measurement: With this method, the control computer may be used for other activities while the measurement is being performed. However, more time is needed for synchronization via service request.
Contents
  • Performing List Evaluations
  • Example: Performing List Evaluation


Performing List Evaluations

Remote Commands > Configuring and Performing Measurements > List Evaluations > Performing List Evaluations
Performing List Evaluations

All remote control commands specific to list evaluations (which are available via remote control only) are described here.

Useful commands for list evaluation described elsewhere:
  • [SENSe:​]POWer:​NCORrection
Remote commands exclusive to list evaluation
List of Commands
[SENSe:]LIST:POWer:RESult?
[SENSe:]LIST:POWer[:SEQuence]
[SENSe:]LIST:POWer:SET
[SENSe:]LIST:POWer:STATe


[SENSe:]LIST:POWer:RESult?

Remote Commands > Configuring and Performing Measurements > List Evaluations > Performing List Evaluations > [SENSe:]LIST:POWer:RESult?
[SENSe:]LIST:POWer:RESult?

This command queries the results of the list evaluation.

This command may be used to obtain measurement results in an asynchronous way, using the service request mechanism for synchronization to the end of the measurement.

If there are no results, the command returns an error.

Return values:
<PowerLevel>

Power level for each frequency included in the measurement.

The command returns up to 3 power levels for each frequency, depending on the number of evaluation modes you have turned on with [SENSe:​]LIST:​POWer:​SET.

The result is a list of floating point values separated by commas. The unit depends on CALCulate<n>:​UNIT:​POWer.

Usage: Query only


[SENSe:]LIST:POWer[:SEQuence]

Remote Commands > Configuring and Performing Measurements > List Evaluations > Performing List Evaluations > [SENSe:]LIST:POWer[:SEQuence]
[SENSe:]LIST:POWer[:SEQuence] <Frequency>, <RefLevel>, <RFAttenuation>, <ElAttenuation>, <FilterType>, <RBW>, <VBW>, <MeasTime>, <TriggerLevel>

This command configures and initiates the List Evaluation measurement.

The list can contain up to 200 entries (frequencies). You can define a different instrument setup for each frequency that is in the list.

If you synchronize the measurement with *OPC, the R&S FSW produces a service request when all frequencies have been measured and the number of individual measurements has been performed.

Note that using the command as a query initiates the measurement and returns the results if all frequencies have been measured. For more information on querying the results see [SENSe:​]LIST:​POWer:​RESult?.

Parameters:
<Frequency>

Defines the receive frequency. Each frequency corresponds to one list entry.

Range: | 0 to Fmax
Default unit: | Hz
<RefLevel>

Defines the reference level for a list entry.

Range: | -130 to 30
Increment: | 0.01
Default unit: | dBm
<RFAttenuation>

Defines the RF attenuation for a list entry.

Range: | 0 to 70
Increment: | 1
Default unit: | dB
<ElAttenuation>

Defines the electronic attenuation for a list entry.

Range: | 0 to 30
Increment: | 1
Default unit: | dB
<FilterType>

Selects the filter type for a list entry. For more information see [SENSe:​]BANDwidth|BWIDth[:​RESolution]:​TYPE.

<RBW>

Defines the resolution bandwidth for a list entry.

<VBW>

Defines the video bandwidth for a list entry.

<MeasTime>

Defines the measurement time for a list entry.

Range: 1 µs to 16000 s
<TriggerLevel>

The trigger level must be 0.

Return values:
<PowerLevel>

Power level for each frequency included in the measurement.

The command returns up to 3 power levels for each frequency, depending on the number of evaluation modes you have turned on with [SENSe:​]LIST:​POWer:​SET.

The result is a list of floating point values separated by commas. The unit depends on CALCulate<n>:​UNIT:​POWer.


[SENSe:]LIST:POWer:SET

Remote Commands > Configuring and Performing Measurements > List Evaluations > Performing List Evaluations > [SENSe:]LIST:POWer:SET
[SENSe:]LIST:POWer:SET <PeakPower>, <RMSPower>, <AVGPower>, <TriggerSource>, <TriggerSlope>, <TriggerOffset>, <GateLength>

This command defines global List Evaluation parameters.

These parameters are valid for every frequency you want to measure.

The state of the first three parameters (<PeakPower>, <RMSPower> and <AVGPower>) define the number of results for each frequency in the list.

Note that you have to set the trigger level after sending this command.

Parameters:
<PeakPower>
ON | OFF | 0 | 1

Turns peak power evaluation on and off.

*RST: 1
<RMSPower>
ON | OFF | 0 | 1

Turns RMS power evaluation on and off.

*RST: 0
<AVGPower>
ON | OFF | 0 | 1

Turns average power evaluation on and off.

*RST: 0
<TriggerSource>
EXTernal | EXT2 | EXT3 | IMMediate | IFPower | RFPower | VIDeo

Selects a trigger source.

For more information see "Configuring Triggered and Gated Measurements".

<TriggerSlope>
NEGative | POSitive

Selects the trigger slop.

<TriggerOffset>

Defines the trigger delay.

Range: | negative measurement time to 30
*RST: | 0
Default unit: | s
<GateLength>

Defines the gate length for gated measurements.

Setting 0 seconds turns gated measurements off.

To perform gated measurements, the trigger source must be different from IMMediate.

Range: | 31.25 ns to 30 s
*RST: | 0 s


[SENSe:]LIST:POWer:STATe

Remote Commands > Configuring and Performing Measurements > List Evaluations > Performing List Evaluations > [SENSe:]LIST:POWer:STATe
[SENSe:]LIST:POWer:STATe <State>

This command turns the List Evaluation off.

Parameters:
<State>
OFF
*RST: OFF


Example: Performing List Evaluation

Remote Commands > Configuring and Performing Measurements > List Evaluations > Example: Performing List Evaluation
Example: Performing List Evaluation

The following example shows a list evaluation with the following configuration.

No | Freq [MHz] | Ref Level [dBm] | RF Attenuation [dB] | El Attenuation [dB] | Filter | RBW | VBW | Meas Time | Trigger Level
1 | 935.2 | 0 | 10 | --- | Normal | 1 MHz | 3 MHz | 440 µs | 0
2 | 935.4 | 0 | 10 | 10 | Channel | 30 kHz | 100 kHz | 440 µs | 0
3 | 935.6 | 0 | 10 | 20 | Channel | 30 kHz | 100 kHz | 440 µs | 0
-----Measurement with synchronization via service request-----
*ESE 1
*SRE 32
// Configures the status reporting system to produce a service request.
LIST:POW:SET ON,ON,OFF,EXT,POS,10us,434us
//Turns on the list evaluation, configures the global list evaluation settings and
//evaluates the peak and RMS power.
LIST:POW
935.2MHZ,0,10,OFF,NORM,1MHZ,3MHZ,440us,0,
935.4MHZ,0,10,10,CFIL,30KHZ,100KHZ,440us,0,
935.6MHZ,0,10,20,CFIL,30KHZ,100KHZ,440us,0;
*OPC
//Defines a list with 3 entries and initiates the measurement with synchronization to the end.
//Analyzer produces a service request
//On service request:
SENS:LIST:POW:RES?
//Returns the results of the measurements, two for each frequency (peak and RMS power).

-----Initiliazing the measurement and querying results simultaneously-----
LIST:POW?
935.2MHZ,0,10,OFF,NORM,1MHZ,3MHZ,440us,0,
935.4MHZ,0,10,10,CFIL,30KHZ,100KHZ,440us,0,
935.6MHZ,0,10,20,CFIL,30KHZ,100KHZ,440us,0
//Defines a list with 3 entries, initiates the measurement and queries the results.
//Result example:
-28.3,-30.6,-38.1


Measuring the Pulse Power

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power
Measuring the Pulse Power

All remote control commands specific to measuring the mean or peak pulse power (e.g. bursts in various telecommunications standards) are described here. This measurement is available via remote control only.

The Pulse Power measurement is a gated measurement that determines the power over a particular number of pulses. The measurement is controlled by an external trigger or the video signal. A separate trigger event is required for each burst included in the measurement. In case of an external trigger source, the trigger level corresponds to the TTL level. In case of a video signal, you can define any threshold.

The figure below shows the relations between the available trigger settings.

The measurement is always on trace 1, either with the peak detector to determine the peak power or the RMS detector to determine the RMS power. Overall, you can configure the measurement independent of the instrument setup with the commands listed below only, which results in faster measurements.

The Pulse Power measurement is incompatible to other measurement functions (e.g. marker functionality or statistics). If you use a command that controls those functions, the R&S FSW aborts the Pulse Power measurement.

The R&S FSW also aborts the Pulse Power measurement if you end the remote session.

The commands can be used in two different ways.

  • Instrument setup, measurement and querying of the results in a single command line. With this method, there is the least delay between the measurement and the result output. However, it requires the control computer to wait for the response from the instrument.
  • Instrument setup and querying of the result list at the end of the measurement: With this method, the control computer may be used for other activities while the measurement is being performed. However, more time is needed for synchronization via service request.
Contents
  • Performing Pulse Power Measurements
  • Example: Performing a Pulse Power Measurement


Performing Pulse Power Measurements

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power > Performing Pulse Power Measurements
Performing Pulse Power Measurements

The following commands control pulse power measurements.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:MSUMmary
[SENSe:]MPOWer:FTYPe
[SENSe:]MPOWer:RESult[:LIST]?
[SENSe:]MPOWer:[:SEQuence]
[SENSe:]MPOWer:RESult:MIN?


CALCulate<n>:MARKer<m>:FUNCtion:MSUMmary

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power > Performing Pulse Power Measurements > CALCulate<n>:MARKer<m>:FUNCtion:MSUMmary
CALCulate<n>:MARKer<m>:FUNCtion:MSUMmary <TimeOffset>,<MeasTime>,<PulsePeriod>,<#OfPulses>

This command configures power measurements on pulses in the time domain.

To evaluate the pulse power, the R&S FSW uses the data captured during a previous measurement. The data recorded during the set measurement time is combined to a measured value for each pulse according to the detector specified and the indicated number of results is output as a list.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<TimeOffset>

Defines a time offset to start the measurement at the first pulse of a trace.

*RST: | 0
Default unit: | s
<MeasTime>

Defines the measurement time.

Default unit: s
<PulsePeriod>

Defines the pulse period

<#OfPulses>

Defines the number of pulses to measure.

Example: CALC:MARK:FUNC:MSUM 50US,450US,576.9US,8

Evaluates data that contains 8 pulses during a measurement time of 450 µs and a pulse period of 576.9 µs. The evaluation starts with an offset of 50 µs.


[SENSe:]MPOWer:FTYPe

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power > Performing Pulse Power Measurements > [SENSe:]MPOWer:FTYPe
[SENSe:]MPOWer:FTYPe <FilterType>

This command selects the filter type for pulse power measurements.

The EMI-specific filter types are available if the EMI (R&S FSW-K54) measurement option is installed, even if EMI measurement is not active. For details see "Resolution Bandwidth and Filter Types".

Parameters:
<FilterType>
CFILter
NORMal
P5
RRC
CISPr | PULSe

CISPR (6 dB) - requires EMI (R&S FSW-K54) option

Return value for query is always PULS.

MIL

MIL Std (6 dB) - requires EMI (R&S FSW-K54) option


[SENSe:]MPOWer:RESult[:LIST]?

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power > Performing Pulse Power Measurements > [SENSe:]MPOWer:RESult[:LIST]?
[SENSe:]MPOWer:RESult[:LIST]?

This command queries the results of the pulse power measurement.

This command may be used to obtain measurement results in an asynchronous way, using the service request mechanism for synchronization to the end of the measurement.

If there are no results, the command returns an error.

Return values:
<PulsePower> | List of pulse powers. The number of values depends on the number of pulses you have been measuring. The unit is dBm.
Usage: | Query only


[SENSe:]MPOWer:[:SEQuence]

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power > Performing Pulse Power Measurements > [SENSe:]MPOWer:[:SEQuence]
[SENSe:]MPOWer:[:SEQuence] <Frequency>, <RBW>, <MeasTime>, <TriggerSource>, <TriggerLevel>, <TriggerOffset>, <Detector>, <#OfPulses>

This command configures and initiates the pulse power measurement.

The R&S FSW caches all measurement parameters that you can set with this command. If you use the command repeatedly, the R&S FSW only changes those settings that you have actually changed before initiating the measurement. Thus, measurement times are kept as low as possible.

If you synchronize the measurement with *OPC, the R&S FSW produces a service request when all frequencies have been measured and the number of individual measurements has been performed.

Note that using the command as a query initiates the measurement and returns the results if all frequencies have been measured. For more information on querying the results see [SENSe:​]LIST:​POWer:​RESult?.

Parameters:
<Frequency>

Defines the pulse frequency.

Range: | 0 to Fmax
Default unit: | Hz
<RBW>

Defines the resolution bandwidth.

<MeasTime>

Defines the measurement time.

Range: 1 µs to 30 s
<TriggerSource>
EXTernal | EXT2 | EXT3 | VIDeo

Selects a trigger source.

For more information see "Configuring Triggered and Gated Measurements".

<TriggerLevel>

Defines a trigger level.

The trigger level is available for the video trigger. In that case, the level is a percentage of the diagram height.

In case of an external trigger, the R&S FSW uses a fix TTL level.

Range: | 0 to 100
Default unit: | PCT
<TriggerOffset>

Defines the trigger delay.

Range: | 0 s to 30 s
*RST: | 0 s
Default unit: | s
<Detector>

Selects the detector and therefore the way the measurement is evaluated.

MEAN

Calculates the RMS pulse power.

PEAK

Calculates the peak pulse power.

<#OfPulses>

Defines the number of pulses included in the measurement.

Range: 1 to 32001
Return values:
<PowerLevel>

Pulse power level.

The result is a list of floating point values separated by commas. The unit is dBm.


[SENSe:]MPOWer:RESult:MIN?

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power > Performing Pulse Power Measurements > [SENSe:]MPOWer:RESult:MIN?
[SENSe:]MPOWer:RESult:MIN?

This command queries the lowest pulse power that has been measured during a pulse power measurement.

If there are no results, the command returns an error.

Return values:
<PulsePower> | Lowest power level of the pulse power measurement. The unit is dBm.
Usage: | Query only


Example: Performing a Pulse Power Measurement

Remote Commands > Configuring and Performing Measurements > Measuring the Pulse Power > Example: Performing a Pulse Power Measurement
Example: Performing a Pulse Power Measurement

The following example shows a pulse power measurement.

-----Measurement with synchronization via service request-----
*ESE 1
*SRE 32
// Configures the status reporting system to produce a service request.
MPOW:FTYP NORM
//Selects a Gaussian filter for the measurement.
MPOW 935.2MHZ,1MHZ,434us,VID,50,5us,MEAN,20;
*OPC
//Configures and initiates a measurement on 20 pulses with synchronization to the end.
//Analyzer produces a service request
//On service request:
MPOW:RES?
//Returns the results of the measurements (20 power levels).
MPOW:RES:MIN?
//Returns the lowest of the 20 power level that have been measured.

-----Initiliazing the measurement and querying results simultaneously-----
MPOW? 935.2MHZ,1MHZ,434us,VID,50,5us,MEAN,20
//Configures, initiates and queries the results of the measurement.
//Result example:
-105.225059509,-105.656074524,-105.423065186,-104.374649048,-103.059822083,-101.29511261,
-99.96534729,-99.7452468872,-99.6610794067,-100.327224731,-100.96686554,-101.450386047,
-102.150642395,-103.240142822,-105.95476532,-110.583129883,-115.7760849,-126.279388428,
-124.620399475,-116.97366333


Configuring the Result Display

Remote Commands > Configuring the Result Display
Configuring the Result Display

The commands required to configure the screen display in a remote environment are described here.

The tasks for manual operation are described in "Result Display Configuration".

Contents
  • General Window Commands
  • Working with Windows in the Display
  • Examples: Configuring the Result Display


General Window Commands

Remote Commands > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

Remote Commands > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView").

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

Remote Commands > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows".


Working with Windows in the Display

Remote Commands > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows".

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Diagram"
See "Marker Table"
See "Marker Peak List"
See "Result Summary"
See "Spectrogram"
<WindowType> parameter values for the Spectrum application
Parameter value | Window type
DIAGram | Diagram
MTABle | Marker table
PEAKlist | Marker peak list
RSUMmary | Result summary
SGRam | Spectrogram


LAYout:CATalog[:WINDow]?

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName> | string Name of the window. In the default state, the name of the window is its index.
<WindowIndex> | numeric value Index of the window.
Example: | LAY:CAT? Result: '2',2,'1',1 Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).
Example: | See "Example 1: Adding and Arranging Windows".
Example: | See "Example 2: Replacing and Removing Windows".
Usage: | Query only


LAYout:IDENtify[:WINDow]?

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName> | String containing the name of the window. In the default state, the name of the window is its index.
Example: | See "Example 2: Replacing and Removing Windows".
Usage: | Event


LAYout:REPLace[:WINDow]

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName> | String containing the name of the existing window. By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.
<WindowType> | Type of result display you want to use in the existing window. See LAYout:​ADD[:​WINDow]? for a list of available window types.
Example: | LAY:REPL:WIND '1',MTAB Replaces the result display in window 1 with a marker table.
Example: | See "Example 2: Replacing and Removing Windows".


LAYout:SPLitter

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows".

Example:

See "Example 2: Replacing and Removing Windows".


LAYout:WINDow<n>:ADD?

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction> | LEFT | RIGHt | ABOVe | BELow
<WindowType> | Type of measurement window you want to add. See LAYout:​ADD[:​WINDow]? for a list of available window types.
Return values:
<NewWindowName> | When adding a new window, the command returns its name (by default the same as its number) as a result.
Example: | LAY:WIND1:ADD? LEFT,MTAB Result: '2' Adds a new window named '2' with a marker table to the left of window 1.
Example: | See "Example 1: Adding and Arranging Windows".
Example: | See "Example 2: Replacing and Removing Windows".
Usage: | Query only


LAYout:WINDow<n>:IDENtify?

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Remote Commands > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Examples: Configuring the Result Display

Remote Commands > Configuring the Result Display > Examples: Configuring the Result Display
Examples: Configuring the Result Display

The following example demonstrates how to configure result displays in a remote environment.

Contents
  • Example 1: Adding and Arranging Windows
  • Example 2: Replacing and Removing Windows


Example 1: Adding and Arranging Windows

Remote Commands > Configuring the Result Display > Examples: Configuring the Result Display > Example 1: Adding and Arranging Windows
Example 1: Adding and Arranging Windows

Starting from the default initial display in the Spectrum application (Frequency Sweep), we will configure the following result displays:

1 Frequency Sweep | 3 Marker Table
2 Spectrogram | 4 Marker Peak List
//--------------Resetting the instrument -----------
*RST
//--------------- Adding new windows --------------------
//Add a Spectrogram window beneath the Frequency Sweep window
LAY:ADD? '1',BEL,SGR
//Result: window number: '2'
//Add a Marker Table window to the right of the Frequency Sweep window
LAY:ADD? '1',RIGH,MTAB
//Result: window number: '3'
//Add a Marker Peak List window to the right of the Spectrogram window
LAY:WIND2:ADD? RIGH,PEAK
//Result: window number: '4'

//--------------- Changing the size of individual windows -------------
//Move the splitter between the Frequency Sweep window and the Marker Table
//window to enlarge the spectrum display to 60% of the entire width.
LAY:SPL 1,3,60
//Move the splitter between the Spectrogram window and the Marker Peak List
//window to enlarge the Spectrogram display to 60% of the entire width.
LAY:SPL 2,4,60

//--------------- Querying all displayed windows ------------------
//Query the name and number of all displayed windows
//(from top left to bottom right)
LAY:CAT?
//Result : '1',1,'2',2,'3',3,'4',4

//------------- Maximizing a Window ------------------
//Maximize the window "2 Spectrogram"
DISP:WIND2:SIZE LARG

//-------------Restore multiple window display -----------
DISP:WIND2:SIZE SMAL


Example 2: Replacing and Removing Windows

Remote Commands > Configuring the Result Display > Examples: Configuring the Result Display > Example 2: Replacing and Removing Windows
Example 2: Replacing and Removing Windows

Starting from the display configured in "Example 1: Adding and Arranging Windows", we will remove and replace result displays to obtain the following configuration:

1 Frequency Sweep

4 Marker Table

//-------------- Preparing the configuration from example 1 -----------
*RST
LAY:ADD? '1',BEL,SGR
LAY:ADD? '1',RIGH,MTAB
LAY:WIND2:ADD? RIGH,PEAK
LAY:CAT?
//Result : '1',1,'2',2,'3',3,'4',4

//Remove Spectrogram
LAY:WIND2:REM
//Remove Marker Table window
LAY:REM '3'
//Replace Marker Peak List window by Marker Table
LAY:REPL '4',MTAB

//--------------- Querying all displayed windows ------------------
//Query the name and number of all displayed windows (from top left to bottom right)
LAY:CAT?
//Result : '1',1,'4',4

//--------------- Changing the size of individual windows -------------
//Move the splitter between the Frequency Sweep window and the Marker Table window
//to enlarge the spectrum display to 80% of the entire height.
LAY:SPL 1,4,80


Setting Basic Measurement Parameters

Remote Commands > Setting Basic Measurement Parameters
Setting Basic Measurement Parameters

All commands that set measurement-independent parameters are described here.

Contents
  • Defining the Frequency and Span
  • Configuring Bandwidth and Sweep Settings
  • Configuring the Vertical Axis (Amplitude, Scaling)
  • Configuring Triggered and Gated Measurements
  • Adjusting Settings Automatically
  • Configuring the Data Input and Output


Defining the Frequency and Span

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span
Defining the Frequency and Span

The commands required to configure the frequency and span settings in a remote environment are described here. The tasks for manual operation are described in "Frequency and Span Configuration".

Contents
  • Defining the Frequency Range
  • Configuring Signal Tracking


Defining the Frequency Range

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range
Defining the Frequency Range
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:FUNCtion:CSTep
DISPlay[:WINDow<n>]:TRACe:X:SPACing
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN:FULL
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP


CALCulate<n>:MARKer<m>:FUNCtion:CENTer

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:FUNCtion:CENTer

This command matches the center frequency to the frequency of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:CENT Sets the center frequency to the frequency of marker 2.
Usage: | Event
Manual operation: | See "Harmonic Distortion" See "Center Frequency = Marker Frequency"


CALCulate<n>:MARKer<m>:FUNCtion:CSTep

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > CALCulate<n>:MARKer<m>:FUNCtion:CSTep
CALCulate<n>:MARKer<m>:FUNCtion:CSTep

This command matches the center frequency step size to the current marker frequency.

The command turns delta markers into normal markers.

Usage: Event


DISPlay[:WINDow<n>]:TRACe:X:SPACing

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > DISPlay[:WINDow<n>]:TRACe:X:SPACing
DISPlay[:WINDow<n>]:TRACe:X:SPACing <ScalingType>

This command selects the scaling of the x-axis.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling.

*RST: LINear
Example: DISP:TRAC:X:SPAC LOG
Manual operation: See "Frequency Axis Scaling"


[SENSe:]FREQuency:CENTer

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Center frequency"
See "Frequency"


[SENSe:]FREQuency:CENTer:STEP

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:CENTer:STEP:LINK

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK <CouplingType>

This command couples and decouples the center frequency step size to the span or the resolution bandwidth.

Parameters:
<CouplingType>
SPAN

Couples the step size to the span. Available for measurements in the frequency domain.

RBW

Couples the step size to the resolution bandwidth. Available for measurements in the time domain.

OFF

Decouples the step size.

*RST: SPAN
Example: FREQ:CENT:STEP:LINK SPAN
Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor <Factor>

This command defines a step size factor if the center frequency step size is coupled to the span or the resolution bandwidth.

Parameters:
<Factor>
1 to 100 PCT
*RST: 10
Example: FREQ:CENT:STEP:LINK:FACT 20PCT
Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:OFFSet

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


[SENSe:]FREQuency:SPAN

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN <Span>

This command defines the frequency span.

If you set a span of 0 Hz in the Spectrum application, the R&S FSW starts a measurement in the time domain.

Parameters:
<Span>

The minimum span for measurements in the frequency domain is 10 Hz. For SEM and spurious emission measurements, the minimum span is 20 Hz.

Range: | 0 Hz to fmax
*RST: | Full span
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Zero Span"
See "Span"
See "Last Span"


[SENSe:]FREQuency:SPAN:FULL

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:SPAN:FULL
[SENSe:]FREQuency:SPAN:FULL

This command restores the full span.

Usage: | Event SCPI confirmed
Manual operation: | See "Full Span" See "Zero Span"


[SENSe:]FREQuency:STARt

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STARt <Frequency>

This command defines a start frequency for measurements in the frequency domain.

Parameters:
<Frequency>
0 to (fmax - min span)
*RST: 0
Example: FREQ:STAR 20MHz
Usage: SCPI confirmed
Manual operation: See "Frequency Sweep"
See "Start / Stop"


[SENSe:]FREQuency:STOP

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Defining the Frequency Range > [SENSe:]FREQuency:STOP
[SENSe:]FREQuency:STOP <Frequency>

This command defines a stop frequency for measurements in the frequency domain.

Parameters:
<Frequency>
min span to fmax
*RST: fmax
Example: FREQ:STOP 2000 MHz
Usage: SCPI confirmed
Manual operation: See "Frequency Sweep"
See "Start / Stop"


Configuring Signal Tracking

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Configuring Signal Tracking
Configuring Signal Tracking

When signal tracking is activated, the maximum signal is determined after each frequency sweep and the center frequency is set to the frequency of this signal. Thus with drifting signals the center frequency follows the signal.

For more details see "Impact of the Frequency and Span Settings"..

List of Commands
CALCulate:MARKer:FUNCtion:STRack[:STATe]
CALCulate:MARKer:FUNCtion:STRack:BANDwidth
CALCulate:MARKer:FUNCtion:STRack:THReshold
CALCulate:MARKer:FUNCtion:STRack:TRACe


CALCulate:MARKer:FUNCtion:STRack[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Configuring Signal Tracking > CALCulate:MARKer:FUNCtion:STRack[:STATe]
CALCulate:MARKer:FUNCtion:STRack[:STATe] <State>

This command turns signal tracking on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Signal Tracking State"


CALCulate:MARKer:FUNCtion:STRack:BANDwidth

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Configuring Signal Tracking > CALCulate:MARKer:FUNCtion:STRack:BANDwidth
CALCulate:MARKer:FUNCtion:STRack:BANDwidth <Bandwidth>

This command defines the bandwidth around the center frequency that is included in the signal tracking process.

Note that you have to turn on signal tracking before you can use the command.

Parameters:
<Bandwidth>
Range: | 10 Hz to Max span
*RST: | (= span/10 on activating the function)
Default unit: | Hz
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Tracking Bandwidth"


CALCulate:MARKer:FUNCtion:STRack:THReshold

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Configuring Signal Tracking > CALCulate:MARKer:FUNCtion:STRack:THReshold
CALCulate:MARKer:FUNCtion:STRack:THReshold <Level>

This command defines the threshold level for the signal tracking process.

Note that you have to turn on signal tracking before you can use the command.

Parameters:
<Level>

The unit depends on CALCulate<n>:​UNIT:​POWer.

Range: | -130 dBm to 30 dBm
*RST: | -120 dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Tracking Threshold"


CALCulate:MARKer:FUNCtion:STRack:TRACe

Remote Commands > Setting Basic Measurement Parameters > Defining the Frequency and Span > Configuring Signal Tracking > CALCulate:MARKer:FUNCtion:STRack:TRACe
CALCulate:MARKer:FUNCtion:STRack:TRACe <TraceNumber>

This command selects the trace on which the largest signal is searched for.

Parameters:
<TraceNumber>
1 to 6
Range: | 1 to 6
*RST: | 1
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Signal Track Trace"


Configuring Bandwidth and Sweep Settings

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings
Configuring Bandwidth and Sweep Settings

The commands required to configure the bandwidth, sweep and filter settings in a remote environment are described here. The tasks for manual operation are described in "Bandwidth, Filter and Sweep Configuration".

Contents
  • Configuring the Bandwidth and Filter
  • Configuring the Sweep


Configuring the Bandwidth and Filter

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter
Configuring the Bandwidth and Filter
List of Commands
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution]:AUTO
[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio
[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE
[SENSe:]BANDwidth|BWIDth:VIDeo
[SENSe:]BANDwidth|BWIDth:VIDeo:AUTO
[SENSe:]BANDwidth|BWIDth:VIDeo:RATio
[SENSe:]BANDwidth|BWIDth:VIDeo:TYPE


[SENSe:]BANDwidth|BWIDth[:RESolution]

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution] <Bandwidth>

This command defines the resolution bandwidth and decouples the resolution bandwidth from the span.

In the Realtime application, the resolution bandwidth is always coupled to the span.

For statistics measurements, this command defines the demodulation bandwidth.

For measurements on I/Q data in the frequency domain, the maximum RBW is 1 MHz.

Parameters:
<Bandwidth>
refer to data sheet
*RST: RBW: AUTO is set to ON; DBW: 3MHz
Example: BAND 1 MHz

Sets the resolution bandwidth to 1 MHz

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Analysis Bandwidth"
See "RBW"
See "Res BW CISPR"
See "Res BW MIL"
See "RBW"


[SENSe:]BANDwidth|BWIDth[:RESolution]:AUTO

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth[:RESolution]:AUTO
[SENSe:]BANDwidth|BWIDth[:RESolution]:AUTO <State>

This command couples and decouples the resolution bandwidth to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: BAND:AUTO OFF

Switches off the coupling of the resolution bandwidth to the span.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "RBW"
See "Default Coupling"


[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth[:RESolution]:RATio
[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio <Ratio>

This command defines the ratio between the resolution bandwidth (Hz) and the span (Hz).

Note that the ratio defined with the remote command (RBW/span) is reciprocal to that of the manual operation (span/RBW).

Parameters:
<Ratio>
Range: | 0.0001 to 1
*RST: | 0.01
Example: BAND:RAT 0.1
Usage: SCPI confirmed
Manual operation: See "Span/RBW"


[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE
[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE <FilterType>

This command selects the resolution filter type.

When you change the filter type, the command selects the next larger filter bandwidth if the same bandwidth is unavailable for that filter.

The EMI-specific filter types are available if the EMI (R&S FSW-K54) measurement option is installed, even if EMI measurement is not active. For details see "Resolution Bandwidth and Filter Types".

Parameters:
<FilterType>
CFILter

Channel filters

NORMal

Gaussian filters

P5

5-pole filters

The 5-pole filter is not available for FFT sweeps.

RRC

RRC filters

CISPr | PULSe

CISPR (6 dB) - requires EMI (R&S FSW-K54) option

Return value for query is always PULS.

MIL

MIL Std (6 dB) - requires EMI (R&S FSW-K54) option

*RST: NORMal
Example: BAND:TYPE NORM
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Filter Type"
See "Res BW CISPR"
See "Res BW MIL"


[SENSe:]BANDwidth|BWIDth:VIDeo

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth:VIDeo
[SENSe:]BANDwidth|BWIDth:VIDeo <Bandwidth>

This command defines the video bandwidth.

The command decouples the video bandwidth from the resolution bandwidths.

Parameters:
<Bandwidth>
refer to data sheet
*RST: AUTO is set to ON
Example: BAND:VID 10 kHz
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "VBW"


[SENSe:]BANDwidth|BWIDth:VIDeo:AUTO

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth:VIDeo:AUTO
[SENSe:]BANDwidth|BWIDth:VIDeo:AUTO <State>

This command couples and decouples the video bandwidth to the resolution bandwidth.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: BAND:VID:AUTO OFF
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "VBW"
See "RBW/VBW"
See "Default Coupling"


[SENSe:]BANDwidth|BWIDth:VIDeo:RATio

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth:VIDeo:RATio
[SENSe:]BANDwidth|BWIDth:VIDeo:RATio <Ratio>

This command defines the coupling ratio of the video bandwidth to the resolution bandwidth (RBW/VBW).

Parameters:
<Ratio>
Range: | 0,001 to 1000
*RST: | 1
Example: BAND:VID:RAT 3

Sets the coupling of video bandwidth to video bandwidth = 3*resolution bandwidth

Usage: SCPI confirmed
Manual operation: See "RBW/VBW"


[SENSe:]BANDwidth|BWIDth:VIDeo:TYPE

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Bandwidth and Filter > [SENSe:]BANDwidth|BWIDth:VIDeo:TYPE
[SENSe:]BANDwidth|BWIDth:VIDeo:TYPE <Mode>

This command selects the position of the video filter in the signal path.

Changing the video filter position is possible only if the resolution bandwidth is ≤ 100 kHz.

Parameters:
<Mode>
LINear

The video filter is applied in front of the logarithmic amplifier.

In linear mode, measurements with a logarithmic level scale result in flatter falling edges compared to logarithmic mode. The reason is the conversion of linear power values into logarithmic level values: if you halve the linear power, the logarithmic level decreases by 3 dB.

LOGarithmic

The video filter is applied after the logarithmic amplifier

*RST: LINear
Example: BAND:VID:TYPE LIN

Video filter ahead of the logarithmic amplifier


Configuring the Sweep

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep
Configuring the Sweep
Useful commands for configuring sweeps described elsewhere:
  • [SENSe:​]AVERage:​COUNt
  • [SENSe:​]AVERage<n>[:​STATe<t>]
  • [SENSe:​]AVERage<n>:​TYPE
Remote commands exclusive to configuring sweeps:
List of Commands
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:OPTimize
[SENSe:]SWEep:POINts
[SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME:AUTO
[SENSe:]SWEep:TYPE
[SENSe:]SWEep:TYPE:USED
[SENSe:]BANDwidth|BWIDth[:RESolution]:FFT


[SENSe:]SWEep:COUNt

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

In case of Power vs Time measurements, the command defines the number of half slots to analyze.

Parameters:
<SweepCount>

When you set a sweep count of 0 or 1, the R&S FSW performs one single sweep in single sweep mode.

In continuous sweep mode, if the sweep count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:OPTimize

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]SWEep:OPTimize
[SENSe:]SWEep:OPTimize <Mode>

In FFT mode, several FFT analysis steps are required to cover the entire measurement span. The span which is covered by one FFT analysis step is called partial span. The partial span cannot be defined directly, but it can be optimized according to measurement requirements.

Optimization parameters in FFT mode

Optimization mode

Description

Dynamic

Optimizes the dynamic range by using the narrowest possible partial span (depending on the RBW).

The autorange function for the internal IF gain calculation is activated to obtain the best control range for the A/D converter.

Speed

Optimizes the sweep rate by using the widest possible partial span (depending on the RBW).

The autorange function for the internal IF gain calculation is deactivated. (Note: set the reference level accordingly to optimize the control range for the A/D converter).

It is recommended that you set the sweep time to "Auto" to optimize the sweep rate (see [SENSe:​]SWEep:​TIME:​AUTO).

Auto

Uses a medium-sized partial span to obtain a compromise between a large dynamic range and a fast sweep rate.

The autorange function for the internal IF gain calculation is activated to obtain the best control range for the A/D converter.

Note: FFT mode and external mixers (R&S FSW-B21)

The partial span optimization modes "Dynamic" and "Auto" include automatic suppression of unwanted mixing products. Thus, when using external mixers (R&S FSW-B21), use the "Speed" mode to obtain similar results in FFT mode as in frequency sweep mode.

Zero span mode

For zero span measurements, the optimization mode defines the selection of the A/D converter prefilter.

Optimization parameters in zero span mode
Optimization mode | Description
Dynamic | The narrowest filter possible (depending on the RBW) is used.
Speed | The widest filter possible (depending on the RBW) is used.
Auto | A medium-sized prefilter is used.

Note: EMI measurements

For EMI measurements (using R&S FSW-K54), "Dynamic" mode is not supported. "Auto" mode always uses "Speed" optimization.

Parameters:
<Mode>
*RST: AUTO
Example: SWE:OPT DYN

Selects optimization for dynamic range.

Manual operation: See "Optimization"


[SENSe:]SWEep:POINts

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]SWEep:POINts
[SENSe:]SWEep:POINts <SweepPoints>

This command defines the number of measurement points analyzed during a sweep.

Note that the number of sweep points is limited to 10001 when measuring spurious emissions.

For EMI measurements, 200001 sweep points are available.

Parameters:
<SweepPoints>
Range: | 101 to 100001
*RST: | 1001
Example: SWE:POIN 251
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Sweep Points"


[SENSe:]SWEep:TIME

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME <Time>

This command defines the sweep (or: data capture) time.

In the Spectrum application, the command decouples the sweep time from the span and resolution and video bandwidths.

Parameters:
<Time>
refer to data sheet
*RST: depends on current settings (determined automatically)
Example: SWE:TIME 10s
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Sweep Time"
See "Sweep Time"
See "Sweep Time"


[SENSe:]SWEep:TIME:AUTO

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]SWEep:TIME:AUTO
[SENSe:]SWEep:TIME:AUTO <State>

This command couples and decouples the sweep time to the span and the resolution and video bandwidths.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: SWE:TIME:AUTO ON

Activates automatic sweep time.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Harmonic Sweep Time"
See "Sweep Time"
See "Default Coupling"


[SENSe:]SWEep:TYPE

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]SWEep:TYPE
[SENSe:]SWEep:TYPE <Type>

This command selects the sweep type.

Parameters:
<Type>
AUTO

Automatic selection of the sweep type between sweep mode and FFT.

FFT

FFT mode

*RST: AUTO
Example: SWE:TYPE FFT
Manual operation: See "Sweep Type"


[SENSe:]SWEep:TYPE:USED

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]SWEep:TYPE:USED
[SENSe:]SWEep:TYPE:USED

This command queries the sweep type if you have turned on automatic selection of the sweep type.

Return values:
<Type>
SWE

Normal sweep

FFT

FFT mode


[SENSe:]BANDwidth|BWIDth[:RESolution]:FFT

Remote Commands > Setting Basic Measurement Parameters > Configuring Bandwidth and Sweep Settings > Configuring the Sweep > [SENSe:]BANDwidth|BWIDth[:RESolution]:FFT
[SENSe:]BANDwidth|BWIDth[:RESolution]:FFT <FilterMode>

Defines the filter mode to be used for FFT filters by defining the partial span size. The partial span is the span which is covered by one FFT analysis.

This command is only available when using the sweep type "FFT".

Note: this command is maintained for compatibility reasons only. For new remote control programs, use the [SENSe:​]SWEep:​OPTimize command.

Parameters:
<FilterMode>
WIDE | AUTO | NARRow
AUTO

Automatically applies the sweep optimization mode that is best for the current measurement.

NARRow

Optimizes the sweep mode for a large dynamic range.

WIDE

Optimizes the sweep mode for high performance.

*RST: AUTO
Example: BAND:TYPE FFT

Select FFT filter.

Example: BAND:FFT NARR

Select narrow partial span for FFT filter.


Configuring the Vertical Axis (Amplitude, Scaling)

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling)
Configuring the Vertical Axis (Amplitude, Scaling)

The following commands are required to configure the amplitude and vertical axis settings in a remote environment.

Contents
  • Amplitude Settings
  • Configuring the Attenuation
  • Configuring a Preamplifier
  • Scaling the Y-Axis


Amplitude Settings

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings
Amplitude Settings

The tasks for manual configuration are described in "Amplitude Settings".

Useful commands for amplitude configuration described elsewhere:
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude configuration:
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:UNIT:POWer
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
[SENSe:]POWer:NCORrection


CALCulate<n>:MARKer<m>:FUNCtion:REFerence

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:FUNCtion:REFerence

This command matches the reference level to the power level of a marker.

If you use the command in combination with a delta marker, that delta marker is turned into a normal marker.

Example: | CALC:MARK2:FUNC:REF Sets the reference level to the level of marker 2.
Usage: | Event
Manual operation: | See "Reference Level = Marker Level"


CALCulate<n>:UNIT:POWer

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > CALCulate<n>:UNIT:POWer
CALCulate<n>:UNIT:POWer <Unit>

This command selects the unit of the y-axis.

The unit applies to all measurement windows.

Parameters:
<Unit>
DBM | V | A | W | DBPW | WATT | DBUV | DBMV | VOLT | DBUA | AMPere
*RST: dBm
Example: CALC:UNIT:POW DBM

Sets the power unit to dBm.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Unit"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Shifting the Display (Offset)"
See "Shifting the Display (Offset)"


[SENSe:]POWer:NCORrection

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > [SENSe:]POWer:NCORrection
[SENSe:]POWer:NCORrection <State>

This command turns noise cancellation on and off.

If noise cancellation is on, the R&S FSW performs a reference measurement to determine its inherent noise and subtracts the result from the channel power measurement result (first active trace only).

For more information see "Noise cancellation".

Parameters:
<State>
ON | OFF
*RST: OFF
Example: POW:NCOR ON
Manual operation: See "Noise cancellation"


Configuring the Attenuation

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring a Preamplifier

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier
Configuring a Preamplifier
List of Commands
INPut:GAIN:STATe
INPut:GAIN[:VALue]


INPut:GAIN:STATe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the preamplification is defined by INPut:​GAIN[:​VALue].

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Scaling the Y-Axis

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis
Scaling the Y-Axis
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y:SPACing


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Note that the command works only for a logarithmic scaling. You can select the scaling with DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing.

Parameters:
<Range>
Range: | 1 dB to 200 dB
*RST: | 100 dB
Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Range"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: | SCPI confirmed
Manual operation: | See "Auto Scale Once"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE <Mode>

This command selects the type of scaling of the y-axis.

When the display update during remote control is off, this command has no immediate effect.

Parameters:
<Mode>
ABSolute

absolute scaling of the y-axis

RELative

relative scaling of the y-axis

*RST: ABSolute
Example: DISP:TRAC:Y:MODE REL
Manual operation: See "Scaling"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

For measurements with the external generator (R&S FSW-B10) the command defines the position of the reference value.

Parameters:
<Position>

0 PCT corresponds to the lower display border, 100% corresponds to the upper display border.

*RST: 100 PCT = frequency display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Reference Position"
See "Ref Level Position"


DISPlay[:WINDow<n>]:TRACe:Y:SPACing

Remote Commands > Setting Basic Measurement Parameters > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis > DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing <ScalingType>

This command selects the scaling of the y-axis.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling in %.

LDB

Linear scaling in the specified unit.

PERCent

Linear scaling in %.

*RST: LOGarithmic
Example: DISP:TRAC:Y:SPAC LIN

Selects linear scaling in %.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Scaling"


Configuring Triggered and Gated Measurements

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements
Configuring Triggered and Gated Measurements

The commands required to configure a triggered or gated measurement in a remote environment are described here. The tasks for manual operation are described in "Trigger and Gate Configuration".

*OPC should be used after requesting data. This will hold off any subsequent changes to the selected trigger source, until after the sweep is completed and the data is returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring Gated Measurements
  • Configuring the Trigger Output


Configuring the Triggering Conditions

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:DTIMe

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

A negative offset is possible for time domain measurements.

For the trigger sources "External" or "IF Power", a common input signal is used for both trigger and gate. Therefore, changes to the gate delay will affect the trigger offset as well.

Parameters:
<Offset>

For measurements in the frequency domain, the range is 0 s to 30 s.

For measurements in the time domain, the range is the negative sweep time to 30 s.

*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q data measurements.

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Note that the variable INPUT/OUTPUT connectors (ports 2+3) must be set for use as input using the OUTPut:​TRIGger<port>:​DIRection command.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IFPower

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IQPower

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .


TRIGger[:SEQuence]:LEVel:RFPower

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm
Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:VIDeo

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:LEVel:VIDeo <Level>

This command defines the level the video signal must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<Level>
Range: | 0 PCT to 100 PCT
*RST: | 50 PCT
Example: TRIG:LEV:VID 50PCT
Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:SLOPe

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For all trigger sources except time you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

For details on trigger sources see "Trigger Source".

Using a trigger or gated measurements turns the squelch off (see[SENSe:​]DEMod:​SQUelch[:​STATe]).

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

For troubleshooting tips see "Uncompleted sequential commands - blocked remote channels".

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

IFPower

Second intermediate frequency

TIME

Time interval

VIDeo

Video mode is available in the time domain and only in the Spectrum application.

PSEN

External power sensor

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Example:

See "Programming Example" .

Manual operation: See "Using the power sensor as an external trigger"
See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "Video"
See "IF Power/BB Power"
See "RF Power"
See "Power Sensor"
See "Time"


TRIGger[:SEQuence]:TIME:RINTerval

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.

Manual operation: See "Trigger Level (Repetition interval)"


Configuring Gated Measurements

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring Gated Measurements
Configuring Gated Measurements
List of Commands
[SENSe:]SWEep:EGATe
[SENSe:]SWEep:EGATe:HOLDoff
[SENSe:]SWEep:EGATe:LENGth
[SENSe:]SWEep:EGATe:POLarity
[SENSe:]SWEep:EGATe:SOURce
[SENSe:]SWEep:EGATe:TYPE


[SENSe:]SWEep:EGATe

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring Gated Measurements > [SENSe:]SWEep:EGATe
[SENSe:]SWEep:EGATe <State>

This command turns gated measurements on and off.

In case of measurements with an external gate, the measured values are recorded as long as the gate is opened. During a sweep the gate can be opened and closed several times. The synchronization mechanisms with *OPC, *OPC? and *WAI remain completely unaffected.

The measurement ends when a particular number of measurement points has been recorded (see [SENSe:​]SWEep:​POINts).

Performing gated measurements turns the squelch off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SWE:EGAT ON

Switches on the external gate mode.

SWE:EGAT:TYPE EDGE

Switches on the edge-triggered mode.

SWE:EGAT:HOLD 100US

Sets the gate delay to 100 μs.

SWE:EGAT:LEN 500US

Sets the gate opening time to 500 μs.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".


[SENSe:]SWEep:EGATe:HOLDoff

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring Gated Measurements > [SENSe:]SWEep:EGATe:HOLDoff
[SENSe:]SWEep:EGATe:HOLDoff <DelayTime>

This command defines the length of the trigger delay.

The trigger delay has no effect on

  • measurements using the "Level" gate mode
  • frequency sweep, FFT sweep, zero span and I/Q mode measurements using an IF Power trigger.
Parameters:
<DelayTime>
Range: | 0 s to 30 s
*RST: | 0 s
Example: SWE:EGAT:HOLD 100us
Manual operation: See "Gate Delay"


[SENSe:]SWEep:EGATe:LENGth

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring Gated Measurements > [SENSe:]SWEep:EGATe:LENGth
[SENSe:]SWEep:EGATe:LENGth <GateLength>

This command defines the gate length.

Parameters:
<GateLength>
Range: | 125 ns to 30 s
*RST: | 400μs
Example: SWE:EGAT:LENG 10ms
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Gate Length"


[SENSe:]SWEep:EGATe:POLarity

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring Gated Measurements > [SENSe:]SWEep:EGATe:POLarity
[SENSe:]SWEep:EGATe:POLarity <Polarity>

This command selects the polarity of an external gate signal.

The setting applies both to the edge of an edge-triggered signal and the level of a level-triggered signal.

Parameters:
<Polarity>
POSitive | NEGative
*RST: POSitive
Example: SWE:EGAT:POL POS
Manual operation: See "Slope"


[SENSe:]SWEep:EGATe:SOURce

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring Gated Measurements > [SENSe:]SWEep:EGATe:SOURce
[SENSe:]SWEep:EGATe:SOURce <Source>

This command selects the signal source for gated measurements.

If an IF power signal is used, the gate is opened as soon as a signal at > -20 dBm is detected within the IF path bandwidth (10 MHz).

For more information see "Trigger Source".

Parameters:
<Source>
EXTernal | EXT2 | EXT3 | IFPower | IQPower | VIDeo | RFPower | PSEN
*RST: IFPower
Example: SWE:EGAT:SOUR IFP

Switches the gate source to IF power.

Manual operation: See "Trigger Source"
See "External Trigger 1/2/3"
See "Video"
See "IF Power/BB Power"
See "RF Power"
See "Power Sensor"


[SENSe:]SWEep:EGATe:TYPE

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring Gated Measurements > [SENSe:]SWEep:EGATe:TYPE
[SENSe:]SWEep:EGATe:TYPE <Type>

This command selects the way gated measurements are triggered.

Parameters:
<Type>
LEVel

The trigger event for the gate to open is a particular power level.

After the gate signal has been detected, the gate remains open until the signal disappears.

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q mode measurements.

EDGE

The trigger event for the gate to open is the detection of the signal edge.

After the gate signal has been detected, the gate remains open until the gate delay is over.

*RST: EDGE
Example: SWE:EGAT:TYPE EDGE
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Gate Mode"


Configuring the Trigger Output

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix: |
<port> | Selects the trigger port to which the output is sent. 2 = trigger port 2 (front) 3 = trigger port 3 (rear)
Example: | See "Programming Example: Performing a Basic Frequency Sweep".
Usage: | Event
Manual operation: | See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

Remote Commands > Setting Basic Measurement Parameters > Configuring Triggered and Gated Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix: |
<port> | Selects the trigger port to which the output is sent. 2 = trigger port 2 (front) 3 = trigger port 3 (rear)
Parameters:
<Length> | Pulse length in seconds.
Example: | See "Programming Example: Performing a Basic Frequency Sweep".
Manual operation: | See "Pulse Length"


Adjusting Settings Automatically

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically
Adjusting Settings Automatically

The commands required to adjust settings automatically in a remote environment are described here. The tasks for manual operation are described in "Adjusting Settings Automatically".

MSRA operating mode

In MSRA operating mode, settings related to data acquisition (measurement time, hysteresis) can only be adjusted automatically in the MSRA Master, not in the MSRA applications.

List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:ALL

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Center frequency
  • Reference level
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:CONFigure:TRIG

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:CONFigure:TRIG <State>

Defines the behaviour of the measurement when adjusting a setting automatically (using SENS:ADJ:LEV ON, for example).

See "Adjusting settings automatically during triggered measurements".

Parameters:
<State>
ON | 1

The measurement for automatic adjustment waits for the trigger.

OFF | 0

The measurement for automatic adjustment is performed immediately, without waiting for a trigger.

*RST: 1


[SENSe:]ADJust:FREQuency

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:FREQuency
[SENSe:]ADJust:FREQuency

This command sets the center frequency to the highest signal level in the current frequency range.

Example: | ADJ:FREQ
Usage: | Event
Manual operation: | See "Adjusting the Center Frequency Automatically (Auto Freq)"


[SENSe:]ADJust:LEVel

Remote Commands > Setting Basic Measurement Parameters > Adjusting Settings Automatically > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Configuring the Data Input and Output

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output
Configuring the Data Input and Output
Contents
  • RF Input
  • Using External Mixers
  • Setting up Probes
  • External Generator Control
  • Working with Power Sensors
  • Configuring the Outputs


RF Input

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect
INPut:UPORt:STATe
INPut:UPORt[:VALue]?


INPut:ATTenuation:PROTection:RESet

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

(See STATus:​QUEStionable:​POWer[:​EVENt]? and "STATus:QUEStionable:POWer Register").

The command works only if the overload condition has been eliminated first.

For details on the protection mechanism see "RF Input Protection".

Usage: Event


INPut:CONNector

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"
See "Unit"


INPut:SELect

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"


INPut:UPORt:STATe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:UPORt:STATe
INPut:UPORt:STATe <State>

This command toggles the control lines of the user ports for the AUX PORT connector. This 9-pole SUB-D male connector is located on the rear panel of the R&S FSW.

See "AUX PORT" for details.

Parameters:
<State>
ON | 1

User port is switched to INPut

OFF | 0

User port is switched to OUTPut

*RST: 1


INPut:UPORt[:VALue]?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > RF Input > INPut:UPORt[:VALue]?
INPut:UPORt[:VALue]?

This command queries the control lines of the user ports.

Example: | INP:UPOR?
Usage: | Query only


Using External Mixers

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers
Using External Mixers

The commands required to work with external mixers in a remote environment are described here. Note that these commands require the R&S FSW-B21 option to be installed and an external mixer to be connected to the front panel of the R&S FSW. In MSRA/MSRT mode, external mixers are not supported.

For details on working with external mixers see "Basics on External Mixers".

Contents
  • Basic Settings
  • Mixer Settings
  • Conversion Loss Table Settings
  • Programming Example: Working with an External Mixer


Basic Settings

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Basic Settings
Basic Settings

The basic settings concern general usage of an external mixer.

List of Commands
[SENSe:]MIXer[:STATe]
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold


[SENSe:]MIXer[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer[:STATe]
[SENSe:]MIXer[:STATe] <State>

Activates or deactivates the use of a connected external mixer as input for the measurement. This command is only available if the R&S FSW-B21 option is installed and an external mixer is connected.

(See "How to Work with External Mixers").

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX ON
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "External Mixer State"


[SENSe:]MIXer:BIAS:HIGH

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS:HIGH <BiasSetting>

This command defines the bias current for the high (second) range.

(See also "Bias Current").

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Manual operation: See "Bias Settings"


[SENSe:]MIXer:BIAS[:LOW]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:BIAS[:LOW] <BiasSetting>

This command defines the bias current for the low (first) range.

(See also "Bias Current").

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Bias Settings"


[SENSe:]MIXer:LOPower

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOPower <Level>

This command specifies the LO level of the external mixer's LO port.

Parameters:
<Level>
numeric value
Range: | 13.0 dBm to 17.0 dBm
Increment: | 0.1 dB
*RST: | 15.5 dBm
Example: MIX:LOP 16.0dBm
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "LO Level"


[SENSe:]MIXer:SIGNal

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:SIGNal
[SENSe:]MIXer:SIGNal <State>

This command specifies whether automatic signal detection is active or not.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Parameters:
<State>
OFF | ON | AUTO | ALL
OFF

No automatic signal detection is active.

ON

Automatic signal detection (Signal ID) is active.

AUTO

Automatic signal detection (Auto ID) is active.

ALL

Both automatic signal detection functions (Signal ID+Auto ID) are active.

*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Signal ID"
See "Auto ID"


[SENSe:]MIXer:THReshold

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Basic Settings > [SENSe:]MIXer:THReshold
[SENSe:]MIXer:THReshold <Value>

This command defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison (see [SENSe:​]MIXer:​SIGNal).

Parameters:
<Value>
<numeric value>
Range: | 0.1 dB to 100 dB
*RST: | 10 dB
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer"

Manual operation: See "Auto ID Threshold"


Mixer Settings

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings
Mixer Settings

The following commands are required to configure the band and specific mixer settings.

List of Commands
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]


[SENSe:]MIXer:FREQuency:HANDover

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:HANDover <Frequency>

This command defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency for each band can be selected freely within the overlapping frequency range.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Frequency> | numeric value
Example: | MIX ON Activates the external mixer. MIX:FREQ:HAND 78.0299GHz Sets the handover frequency to 78.0299 GHz.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Handover Freq."


[SENSe:]MIXer:FREQuency:STARt?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STARt?

This command queries the frequency at which the external mixer band starts.

Example: | MIX:FREQ:STAR? Queries the start frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:FREQuency:STOP?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:FREQuency:STOP?

This command queries the frequency at which the external mixer band stops.

Example: | MIX:FREQ:STOP? Queries the stop frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:HARMonic:BAND:PRESet

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND:PRESet

This command restores the preset frequency ranges for the selected standard waveguide band.

Note:Changes to the band and mixer settings are maintained even after using the PRESET function. Use this command to restore the predefined band ranges.

Example: | MIX:HARM:BAND:PRES Presets the selected waveguide band.
Usage: | Event
Manual operation: | See "Preset Band"


[SENSe:]MIXer:HARMonic:BAND[:VALue]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:BAND[:VALue] <Band>

This command selects the external mixer band. The query returns the currently selected band.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Band> | KA | Q | U | V | E | W | F | D | G | Y | J | USER Standard waveguide band or user-defined band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Band"
Frequency ranges for pre-defined bands
Band | Frequency start [GHz] | Frequency stop [GHz]
KA (A) *) | 26.5 | 40.0
Q | 33.0 | 50.0
U | 40.0 | 60.0
V | 50.0 | 75.0
E | 60.0 | 90.0
W | 75.0 | 110.0
F | 90.0 | 140.0
D | 110.0 | 170.0
G | 140.0 | 220.0
J | 220.0 | 325.0
Y | 325.0 | 500.0
USER | 32.18 (default) | 68.22 (default)
*) The band formerly referred to as "A" is now named "KA".


[SENSe:]MIXer:HARMonic:HIGH:STATe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH:STATe <State>

This command specifies whether a second (high) harmonic is to be used to cover the band's frequency range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX:HARM:HIGH:STAT ON
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Range 1/2"


[SENSe:]MIXer:HARMonic:HIGH[:VALue]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:HIGH[:VALue] <HarmOrder>

This command specifies the harmonic order to be used for the high (second) range.

Parameters:
<HarmOrder
numeric value
Range: 2 to 61 (USER band); for other bands: see band definition
Example: MIX:HARM:HIGH 2
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:HARMonic:TYPE

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic:TYPE <OddEven>

This command specifies whether the harmonic order to be used should be odd, even, or both.

Which harmonics are supported depends on the mixer type.

Parameters:
<OddEven>
ODD | EVEN | EODD
*RST: EVEN
Example: MIX:HARM:TYPE ODD
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Type"


[SENSe:]MIXer:HARMonic[:LOW]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:HARMonic[:LOW] <HarmOrder>

This command specifies the harmonic order to be used for the low (first) range.

Parameters:
<HarmOrder>
numeric value
Range: | 2 to 61 (USER band); for other bands: see band definition
*RST: | 2 (for band F)
Example: MIX:HARM 3
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:LOSS:HIGH

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:HIGH <Average>

This command defines the average conversion loss to be used for the entire high (second) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS:HIGH 20dB
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe:HIGH

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH <FileName>

This command defines the file name of the conversion loss table to be used for the high (second) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL:HIGH 'MyCVLTable'
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe[:LOW]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS:TABLe[:LOW] <FileName>

This command defines the file name of the conversion loss table to be used for the low (first) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL 'mix_1_4' Specifies the conversion loss table mix_1_4.
Example: | See "Configuring a conversion loss table for a user-defined band"
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS[:LOW]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:LOSS[:LOW] <Average>

This command defines the average conversion loss to be used for the entire low (first) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS 20dB
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:PORTs

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:PORTs
[SENSe:]MIXer:PORTs <PortType>

This command specifies whether the mixer is a 2-port or 3-port type.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Mixer Type"


[SENSe:]MIXer:RFOVerrange[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Mixer Settings > [SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:RFOVerrange[:STATe] <State>

If enabled, the band limits are extended beyond "RF Start" and "RF Stop" due to the capabilities of the used harmonics.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "RF Overrange"


Conversion Loss Table Settings

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings
Conversion Loss Table Settings

The following settings are required to configure and manage conversion loss tables.

List of Commands
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber


[SENSe:]CORRection:CVL:BAND

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BAND <Type>

This command defines the waveguide band for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Band>
K | A | KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Note: The band formerly referred to as "A" is now named "KA"; the input parameter "A" is still available and refers to the same band as "KA".

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

*RST: F (90 GHz - 140 GHz)
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BAND KA

Sets the band to KA (26.5 GHz - 40 GHz).

Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Band"


[SENSe:]CORRection:CVL:BIAS

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:BIAS <BiasSetting>

This command defines the bias setting to be used with the conversion loss table.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<BiasSetting>
numeric value
*RST: | 0.0 A
Default unit: | A
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BIAS 3A
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Write to <CVL table name>"
See "Bias"


[SENSe:]CORRection:CVL:CATAlog?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CATAlog?

This command queries all available conversion loss tables saved in the C:\r_s\instr\user\cvl\ directory on the instrument.

This command is only available with option B21 (External Mixer) installed.

Usage: Query only


[SENSe:]CORRection:CVL:CLEAr

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:CLEAr

This command deletes the selected conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:CLE
Usage: | Event
Manual operation: | See "Delete Table"


[SENSe:]CORRection:CVL:COMMent

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:COMMent <Text>

This command defines a comment for the conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Text> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:COMM 'Conversion loss table for FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Comment"


[SENSe:]CORRection:CVL:DATA

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:DATA <Freq>,<Level>

This command defines the reference values of the selected conversion loss tables. The values are entered as a set of frequency/level pairs. A maximum of 50 frequency/level pairs may be entered. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Freq> | numeric value The frequencies have to be sent in ascending order.
<Level> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:DATA 1MHZ,-30DB,2MHZ,-40DB
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Position/Value"


[SENSe:]CORRection:CVL:HARMonic

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:HARMonic <HarmOrder>

This command defines the harmonic order for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<HarmOrder>
numeric value
Range: 2 to 65
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:HARM 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]CORRection:CVL:MIXer

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:MIXer <Type>

This command defines the mixer name in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Type> | string Name of mixer with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX 'FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer Name"


[SENSe:]CORRection:CVL:PORTs

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:PORTs <PortNo>

This command defines the mixer type in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:PORT 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Mixer Type"


[SENSe:]CORRection:CVL:SELect

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SELect <FileName>

This command selects the conversion loss table with the specified file name. If <file_name> is not available, a new conversion loss table is created.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<FileName> | '<File name>'
Example: | CORR:CVL:SEL 'LOSS_TAB_4'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "New Table" See "Edit Table" See "File Name"


[SENSe:]CORRection:CVL:SNUMber

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:CVL:SNUMber <SerialNo>

This command defines the serial number of the mixer for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<SerialNo> | Serial number with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX '123.4567'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer S/N"


Programming Example: Working with an External Mixer

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Using External Mixers > Programming Example: Working with an External Mixer
Programming Example: Working with an External Mixer

This example demonstrates how to work with an external mixer in a remote environment. It is performed in the Spectrum application in the default layout configuration. Note that without a real input signal and connected mixer, this measurement will not return useful results.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//----------- Configuring basic mixer behavior -------------
//Set the LO level of the mixer's LO port to 15 dBm.
SENS:MIX:LOP 15dBm
//Set the bias current to -1 mA .
SENS:MIX:BIAS:LOW -1mA
//----------- Configuring the mixer and band settings -------------
//Use band "V" to full possible range extent for assigned harmonic (6).
SENS:MIX:HARM:BAND V
SENS:MIX:RFOV ON
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)
//Use a 3-port mixer type
SENS:MIX:PORT 3
//Split the frequency range into two ranges;
//range 1 covers 47.48 GHz GHz to 80 GHz; harmonic 6, average conv. loss of 20 dB
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:LOW  20dB
SENS:MIX:HARM:HIGH 8
SENS:MIX:LOSS:HIGH 30dB
//--------- Activating automatic signal identification functions -----------
//Activate both automatic signal identification functions.
SENS:MIX:SIGN ALL
//Use auto ID threshold of 8 dB.
SENS:MIX:THR 8dB

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data for the input signal without distortions
//(default screen configuration)
TRAC:DATA? TRACE3
Configuring a conversion loss table for a user-defined band
//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//--------------Configuring a new conversion loss table --------------
//Define cvl table for range 1 of band as described in previous example
// (extended V band)
SENS:CORR:CVL:SEL 'UserTable'
SENS:CORR:CVL:COMM 'User-defined conversion loss table for USER band'
SENS:CORR:CVL:BAND USER
SENS:CORR:CVL:HARM 6
SENS:CORR:CVL:BIAS -1mA
SENS:CORR:CVL:MIX 'FS_Z60'
SENS:CORR:CVL:SNUM '123.4567'
SENS:CORR:CVL:PORT 3
//Conversion loss is linear from 55 GHz to 75 GHz
SENS:CORR:CVL:DATA 55GHZ,-20DB,75GHZ,-30DB
//----------- Configuring the mixer and band settings -------------
//Use user-defined band and assign new cvl table.
SENS:MIX:HARM:BAND USER
//Define band by two ranges;
//range 1 covers 47.48 GHz to 80 GHz; harmonic 6, cvl table 'UserTable'
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:TABL:LOW 'UserTable'
SENS:MIX:HARM:HIGH 8

SENS:MIX:LOSS:HIGH 30dB
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data (default screen configuration)
TRAC:DATA? TRACe1


Setting up Probes

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


External Generator Control

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control
External Generator Control

External generator control commands are available if the R&S FSW External Generator Control option (R&S FSW-B10) is installed. For each measurement channel one external generator can be configured. To switch between different configurations define multiple measurement channels.

For more information on external generator control see "Basics on External Generator Control".

Contents
  • Measurement Configuration
  • Interface Configuration
  • Source Calibration
  • Programming Example for External Generator Control


Measurement Configuration

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration
Measurement Configuration

The following commands are required to activate external generator control and to configure a calibration measurement with an external tracking generator.

List of Commands
SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal[:STATe]
SOURce:POWer[:LEVel][:IMMediate]:OFFSet


SOURce:EXTernal:FREQuency

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency <Frequency>

This command defines a fixed source frequency for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Frequency>

Source frequency of the external generator.

*RST: 1100050000
Example:

SOUR:EXT:FREQ 10MHz

Manual operation: See "(Manual) Source Frequency"


SOURce:EXTernal:FREQuency:COUPling[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency:COUPling[:STATe] <State>

This command couples the frequency of the external generator output to the R&S FSW.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Default setting: a series of frequencies is defined (one for each sweep point), based on the current frequency at the RF input of the R&S FSW; the RF frequency range covers the currently defined span of the R&S FSW (unless limited by the range of the signal generator)

OFF | 0

The generator uses a single fixed frequency, defined by SOURce:​EXTernal:​FREQuency.

*RST: 1
Example: SOUR:EXT:FREQ:COUP ON
Example:

See "Programming Example for External Generator Control"

Manual operation: See "Source Frequency Coupling"


SOURce:EXTernal:FREQuency[:FACTor]:DENominator

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:DENominator <Value>

This command defines the denominator of the factor with which the analyzer frequency is multiplied in order to obtain the transmit frequency of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the multiplication factor such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Value>
<numeric value>
*RST: 1
Example: SOUR:EXT:FREQ:NUM 4"
"SOUR:EXT:FREQ:DEN 3"

Sets a multiplication factor of 4/3, i.e. the transmit frequency of the generator is 4/3 times the analyzer frequency.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:FREQuency[:FACTor]:NUMerator

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator <Value>

This command defines the numerator of the factor with which the analyzer frequency is multiplied in order to obtain the transmit frequency of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the multiplication factor such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Value>
<numeric value>
*RST: 1
Example: SOUR:EXT:FREQ:NUM 4"
"SOUR:EXT:FREQ:DEN 3"

Sets a multiplication factor of 4/3, i.e. the transmit frequency of the generator is 4/3 times the analyzer frequency.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:FREQuency:OFFSet

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:FREQuency:OFFSet <Offset>

This command defines the frequency offset of the generator with reference to the analyzer frequency.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Select the offset such that the frequency range of the generator is not exceeded if the following formula is applied to the start and stop frequency of the analyzer:

Parameters:
<Offset>
<numeric value>, specified in Hz, kHz, MHz or GHz, rounded to the nearest Hz
*RST: 0 Hz
Example: SOUR:EXT:FREQ:OFFS 10HZ

Sets an offset of the generator output frequency compared to the analyzer frequency of 10 Hz.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "(Automatic) Source Frequency (Numerator/Denominator/Offset)"


SOURce:EXTernal:POWer[:LEVel]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:POWer[:LEVel] <Level>

This command sets the output power of the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<Level>
<numeric value>
*RST: -20 dBm
Example: SOUR:EXT:POW -30dBm

Sets the generator level to -30 dBm

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Source Power"


SOURce:EXTernal[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:EXTernal[:STATe]
SOURce:EXTernal[:STATe] <State>

This command activates or deactivates the connected external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example for External Generator Control".

Manual operation: See "Source State"


SOURce:POWer[:LEVel][:IMMediate]:OFFSet

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Measurement Configuration > SOURce:POWer[:LEVel][:IMMediate]:OFFSet
SOURce:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

This command defines a level offset for the external generator level. Thus, for example, attenuators or amplifiers at the output of the external generator can be taken into account for the setting.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Offset>
Range: | -200 dB to +200 dB
*RST: | 0dB
Example: SOUR:POW:OFFS -10dB

Sets the level offset of the external generator to – 20 dBm.

Usage: SCPI confirmed
Manual operation: See "Source Offset"


Interface Configuration

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Interface Configuration
Interface Configuration

The following commands are required to configure the interface for the connection to the external generator.

List of Commands
SOURce:EXTernal:ROSCillator[:SOURce]
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess


SOURce:EXTernal:ROSCillator[:SOURce]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SOURce:EXTernal:ROSCillator[:SOURce]
SOURce:EXTernal:ROSCillator[:SOURce] <Source>

This command controls selection of the reference oscillator for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

If the external reference oscillator is selected, the reference signal must be connected to the rear panel of the instrument.

Parameters:
<Source>
INTernal

the internal reference is used

EXTernal

the external reference is used; if none is available, an error flag is displayed in the status bar

*RST: INT
Example: SOUR:EXT:ROSC EXT

Switches to external reference oscillator

Manual operation: See "Reference"


SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess <Number>

Changes the IEC/IEEE-bus address of the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Number>
Range: | 0 to 30
*RST: | 28
Example: SYST:COMM:GPIB:RDEV:GEN:ADDR 15
Example:

See "Programming Example for External Generator Control".

Manual operation: See "GPIB Address / TCP/IP Address"


SYSTem:COMMunicate:RDEVice:GENerator:INTerface

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:INTerface <Type>

Defines the interface used for the connection to the external generator.

Parameters:
<Type>
GPIB | TCPip
*RST: GPIB
Example: SYST:COMM:RDEV:GEN:INT TCP
Example:

See "Programming Example for External Generator Control".

Manual operation: See "Interface"


SYSTem:COMMunicate:RDEVice:GENerator:LINK

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:LINK <Type>

This command selects the link type of the external generator if the GPIB interface is used.

The difference between the two GPIB operating modes is the execution speed. While, during GPIB operation, each frequency to be set is transmitted to the generator separately, a whole frequency list can be programmed in one go if the TTL interface is also used. Frequency switching can then be performed per TTL handshake which results in considerable speed advantages.

Parameters:
<Type>
GPIB | TTL
GPIB

GPIB connection without TTL synchronization (for all generators of other manufacturers and some Rohde & Schwarz devices)

TTL

GPIB connection with TTL synchronization (if available; for most Rohde&Schwarz devices)

*RST: GPIB
Example: SYST:COMM:RDEV:GEN:LINK TTL

Selects GPIB + TTL interface for generator operation.

Example:

See "Programming Example for External Generator Control".

Manual operation: See "TTL Handshake"


SYSTem:COMMunicate:RDEVice:GENerator:TYPE

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:RDEVice:GENerator:TYPE <Type>

This command selects the type of external generator.

For a list of the available generator types see "Overview of Generators Supported by the R&S FSW-B10 Option".

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Name>
<Generator name as string value>
*RST: SMU02
Example: SYST:COMM:RDEV:GEN2:TYPE 'SME02'

Selects SME02 as generator 2

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Generator Type"


SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Interface Configuration > SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess <Address>

Configures the TCP/IP address for the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed.

Parameters:
<Address>
TCP/IP address between 0.0.0.0 and 0.255.255.255
*RST: 0.0.0.0
Example: SYST:COMM:TCP:RDEV:GEN:ADDR 130.094.122.195
Manual operation: See "GPIB Address / TCP/IP Address"


Source Calibration

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Source Calibration
Source Calibration

The following commands are required to activate the calibration functions of the external tracking generator. However, they are only available if external generator control is active (see SOURce:​EXTernal[:​STATe]).

Useful commands for source calibration described elsewhere:
  • "Working with Transducers"
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition
Remote commands exclusive to source calibration:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
[SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:METHod
[SENSe:]CORRection:RECall
[SENSe:]CORRection[:STATe]
[SENSe:]CORRection:TRANsducer:GENerator


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Source Calibration > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

The command defines the power value assigned to the reference position in the grid.

For external generator calibration measurements (requires External Generator Control option R&S FSW-B10), this command defines the power offset value assigned to the reference position.

Parameters:
<Value>
*RST: 0 dBm, coupled to reference level
Example: DISP:TRAC:Y:RVAL -20dBm

Sets the power value assigned to the reference position to -20 dBm

Manual operation: See "Reference Value"


[SENSe:]CORRection:COLLect[:ACQuire]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:COLLect[:ACQuire] <MeasType>

This command initiates a reference measurement (calibration). The reference measurement is the basis for the measurement normalization. The result depends on whether a reflection measurement or transmission measurement is performed (see [SENSe:​]CORRection:​METHod).

To obtain a correct reference measurement, a complete sweep with synchronization to the end of the sweep must have been carried out. This is only possible in the single sweep mode.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<MeasType> | THRough "TRANsmission" mode: calibration with direct connection between external generator and device input "REFLection" mode: calibration with short circuit at the input OPEN only allowed in "REFLection" mode: calibration with open input
Example: | INIT:CONT OFF Selects single sweep operation CORR:METH TRAN Selects a transmission measurement. CORR:COLL THR;*WAI Starts the measurement of reference data using direct connection between generator and device input and waits for the sweep end.
Example: | See "Programming Example for External Generator Control".
Usage: | Setting only SCPI confirmed
Manual operation: | See "Calibrate Reflection Short" See "Calibrate Reflection Open"


[SENSe:]CORRection:METHod

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:METHod
[SENSe:]CORRection:METHod

This command selects the type of measurement to be performed with the external generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:

REFLection

Selects reflection measurements.

TRANsmission

Selects transmission measurements.

*RST: TRANsmission
Example: CORR:METH TRAN

Sets the type of measurement to "transmission".

Example:

See "Programming Example for External Generator Control".

Manual operation: See "Calibrate Transmission"
See "Calibrate Reflection Short"
See "Calibrate Reflection Open"


[SENSe:]CORRection:RECall

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:RECall
[SENSe:]CORRection:RECall

This command restores the measurement configuration used for calibration.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Example: | CORR:REC
Usage: | Event
Manual operation: | See "Recall"


[SENSe:]CORRection[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection[:STATe]
[SENSe:]CORRection[:STATe] <State>

This command turns correction of measurement results (normalization) on and off.

The command is available after you have created a reference trace for the selected measurement type with [SENSe:​]CORRection:​COLLect[:​ACQuire].

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CORR ON

Activates normalization.

Example:

See "Programming Example for External Generator Control".

Usage: SCPI confirmed
Manual operation: See "Source Calibration Normalize"


[SENSe:]CORRection:TRANsducer:GENerator

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Source Calibration > [SENSe:]CORRection:TRANsducer:GENerator
[SENSe:]CORRection:TRANsducer:GENerator <Name>

This command uses the normalized measurement data to generate a transducer factor with up to 1001 points. The trace data is converted to a transducer with unit dB and stored in a file with the specified name and the suffix .trd under c:\r_s\instr\trd. The frequency points are allocated in equidistant steps between start and stop frequency.

The generated transducer factor can be further adapted using the commands described in "Working with Transducers").

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active and normalization is switched on.

Parameters:
<Name> | '<name>
Example: | CORR:TRAN:GEN 'SMU01' Creates the transducer file C:\r_s\instr\trd\SMU01.trd.
Usage: | SCPI confirmed
Manual operation: | See "Save As Trd Factor"


Programming Example for External Generator Control

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > External Generator Control > Programming Example for External Generator Control
Programming Example for External Generator Control

The following example demonstrates how to work with an external generator in a remote environment.

It assumes a signal generator of the type SMU04 is connected to the R&S FSW, including TTL synchronization, as described in "External Generator Connections".

//--------------Preparing the instrument -----------

//Reset the instrument
*RST

//Set the frequency span.
SENS:FREQ:STAR 10HZ
SENS:FREQ:STOP 1MHZ

//--------------Configuring the interface -----------

//Set the generator type to SMU04 with a frequency range of 100 kHz to 4GHz
SYST:COMM:RDEV:GEN:TYPE 'SMU04'

//Set the interface used to the GPIB address 28
SYST:COMM:RDEV:GEN:INT GPIB
SYST:COMM:GPIB:RDEV:GEN:ADDR 28

//Activate the use of TTL synchronization to optimize measurement speed
SYST:COMM:RDEV:GEN:LINK TTL

//Activate the use of the external reference frequency at 10 MHz on the generator
SOUR:EXT:ROSC EXT

//--------------Configuring the calibration measurement -----------

//Activate external generator control.
SOUR:EXT:STAT ON
//Set the generator output level to -10 dBm.
SOUR:EXT:POW -10DBM
//Set the frequency coupling to automatic
SOUR:EXT:FREQ:COUP:STAT ON

//--------------Configuring the generator frequency range -----------

//Define a series of frequencies (one for each sweep point) based on the current
//frequency at the RF input of the analyzer; the generator frequency is half the
//frequency of the analyzer, with an offset of 100 kHz;
// analyzer start:            10 Hz
// analyzer stop:             1 MHz
// analyzer span:             999.99 KHz
// generator frequency start: 100.005 KHz
// generator frequency stop:  600 KHz
// generator span:            499.995 KHz

SOUR:EXT:FREQ:FACT:NUM 1
SOUR:EXT:FREQ:FACT:DEN 2
SOUR:EXT:FREQ:OFFS 100KHZ

//--------------Performing the calibration measurement -----------

//Perform a transmission measurement with direct connection between the generator
//and the analyzer and wait till the end
SENS:CORR:METH TRAN
SENS:CORR:COLL:ACQ THR; *WAI

//--------------Retrieving the calibration trace results -----------

//Retrieve the measured frequencies (10 Hz - 600 kHz)
TRAC:DATA:X? TRACE1

//Retrieve the measured power levels; = 0 between 10 Hz and 100 kHz (below
//generator minimum frequency); nominal -5dBm as of 100 kHz;
TRAC:DATA? TRACE1

//--------------Normalizing the calibration trace results -----------

//Retrieve the normalized power levels (= power offsets from calibration results)
//Should be 0 for all sweep points directly after calibration
SENS:CORR:STAT ON
TRAC:DATA? TRACE1

//--------------Changing the display of the calibration results -----------
//Shift the reference line so the -5 dB level is displayed in the center
DISP:TRAC:Y:SCAL:RVAL -5DB
DISP:TRAC:Y:SCAL:RPOS 50PCT


Working with Power Sensors

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors
Working with Power Sensors

The following commands describe how to work with power sensors.

Contents
  • Configuring Power Sensors
  • Configuring Power Sensor Measurements
  • Triggering with Power Sensors


Configuring Power Sensors

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors
Configuring Power Sensors
List of Commands
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine


SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe] <State>

This command turns automatic assignment of a power sensor to the power sensor index on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: SYST:COMM:RDEV:PMET:CONF:AUTO OFF
Manual operation: See "Select"


SYSTem:COMMunicate:RDEVice:PMETer:COUNt?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?

This command queries the number of power sensors currently connected to the R&S FSW.

Parameters:
<NumberSensors> | Number of connected power sensors.
Example: | SYST:COMM:RDEV:PMET:COUN?
Usage: | Query only
Manual operation: | See "Select"


SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensors > SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine <Placeholder>, <Type>, <Interface>, <SerialNo>

This command assigns the power sensor with the specified serial number to the selected power sensor index (configuration).

The query returns the power sensor type and serial number of the sensor assigned to the specified index.

Suffix: |
<p> | 1...4 Power sensor index
Setting parameters:
<Placeholder> | Currently not evaluated
<SerialNo> | Serial number of a connected power sensor
Query parameters:
<Type> | The power sensor type, e.g. "NRP-Z81".
<Interface> | Currently not evaluated
Return values:
<Placeholder> | Currently not used
<Type> | Detected power sensor type, e.g. "NRP-Z81".
<Interface> | Interface the power sensor is connected to; always "USB"
<SerialNo> | Serial number of the power sensor assigned to the specified index
Example: | SYST:COMM:RDEV:PMET2:DEF '','NRP-Z81','','123456' Assigns the power sensor with the serial number '123456' to the configuration "Power Sensor 2". SYST:COMM:RDEV:PMET2:DEF? Queries the sensor assigned to "Power Sensor 2". Result: '','NRP-Z81','USB','123456' The NRP-Z81 power sensor with the serial number '123456' is assigned to the "Power Sensor 2".
Manual operation: | See "Select"


Configuring Power Sensor Measurements

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements
Configuring Power Sensor Measurements
List of Commands
CALibration:PMETer<p>:ZERO:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative:STATe
FETCh:PMETer<p>?
READ:PMETer<p>?
[SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe]
UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer:RATio


CALibration:PMETer<p>:ZERO:AUTO ONCE

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALibration:PMETer<p>:ZERO:AUTO ONCE
CALibration:PMETer<p>:ZERO:AUTO ONCE

This commands starts to zero the power sensor.

Note that you have to disconnect the signals from the power sensor input before you start to zero the power sensor. Otherwise, results are invalid.

Suffix: |
<p> | 1...4 Power sensor index
Parameters:
ONCE |
Example: | CAL:PMET2:ZERO:AUTO ONCE;*WAI Starts zeroing the power sensor 2 and delays the execution of further commands until zeroing is concluded.
Usage: | Event
Manual operation: | See "Zeroing Power Sensor"


CALCulate<n>:PMETer<p>:RELative[:MAGNitude]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude] <RefValue>

This command defines the reference value for relative measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<RefValue>
Range: | -200 dBm to 200 dBm
*RST: | 0
Example: CALC:PMET2:REL -30

Sets the reference value for relative measurements to -30 dBm for power sensor 2.

Manual operation: See "Reference Value"


CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE

This command sets the current measurement result as the reference level for relative measurements.

Suffix: |
<p> | 1...4 Power sensor index
Parameters:
ONCE |
Example: | CALC:PMET2:REL:AUTO ONCE Takes the current measurement value as reference value for relative measurements for power sensor 2.
Usage: | Event
Manual operation: | See "Setting the Reference Level from the Measurement (Meas->Ref)"


CALCulate<n>:PMETer<p>:RELative:STATe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > CALCulate<n>:PMETer<p>:RELative:STATe
CALCulate<n>:PMETer<p>:RELative:STATe <State>

This command turns relative power sensor measurements on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:PMET2:REL:STAT ON

Activates the relative display of the measured value for power sensor 2.


FETCh:PMETer<p>?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > FETCh:PMETer<p>?
FETCh:PMETer<p>?

This command queries the results of power sensor measurements.

Suffix: |
<p> | 1...4 Power sensor index
Return values:
<Level> | Power level that has been measured by a power sensor. The unit is either dBm (absolute measurements) or dB (relative measurements).
Usage: | Query only


READ:PMETer<p>?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > READ:PMETer<p>?
READ:PMETer<p>?

This command initiates a power sensor measurement and queries the results.

Suffix: |
<p> | 1...4 Power sensor index
Usage: | Query only


[SENSe:]PMETer<p>:DCYCle[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:DCYCle[:STATe] <State>

This command turns the duty cycle correction on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:DCYC:STAT ON
Manual operation: See "Duty Cycle"


[SENSe:]PMETer<p>:DCYCle:VALue

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:DCYCle:VALue <Percentage>

This command defines the duty cycle for the correction of pulse signals.

The power sensor uses the duty cycle in combination with the mean power to calculate the power of the pulse.

Suffix:
<p>
1...4

Power sensor

Parameters:
<Percentage>
Range: | 0.001 to 99.999
*RST: | 99.999
Default unit: | %
Example: PMET2:DCYC:STAT ON

Activates the duty cycle correction.

PMET2:DCYC:VAL 0.5

Sets the correction value to 0.5%.

Manual operation: See "Duty Cycle"


[SENSe:]PMETer<p>:FREQuency

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency <Frequency>

This command defines the frequency of the power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Frequency>

The available value range is specified in the data sheet of the power sensor in use.

*RST: 50 MHz
Example: PMET2:FREQ 1GHZ

Sets the frequency of the power sensor to 1 GHz.

Manual operation: See "Frequency Manual"


[SENSe:]PMETer<p>:FREQuency:LINK

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:FREQuency:LINK <Coupling>

This command selects the frequency coupling for power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Coupling>
CENTer

Couples the frequency to the center frequency of the analyzer

MARKer1

Couples the frequency to the position of marker 1

OFF

Switches the frequency coupling off

*RST: CENTer
Example: PMET2:FREQ:LINK CENT

Couples the frequency to the center frequency of the analyzer

Manual operation: See "Frequency Coupling"


[SENSe:]PMETer<p>:MTIMe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe <Duration>

This command selects the duration of power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Duration>
SHORt | NORMal | LONG
*RST: NORMal
Example: PMET2:MTIM SHOR

Sets a short measurement duration for measurements of stationary high power signals for the selected power sensor.

Manual operation: See "Meas Time/Average"


[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt <NumberReadings>

This command sets the number of power readings included in the averaging process of power sensor measurements.

Extended averaging yields more stable results for power sensor measurements, especially for measurements on signals with a low power, because it minimizes the effects of noise.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<NumberReadings>

An average count of 0 or 1 performs one power reading.

Range: | 0 to 256
Increment: | binary steps (1, 2, 4, 8, ...)
Example: PMET2:MTIM:AVER ON

Activates manual averaging.

PMET2:MTIM:AVER:COUN 8

Sets the number of readings to 8.

Manual operation: See "Average Count (Number of Readings)"


[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe] <State>

This command turns averaging for power sensor measurements on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:MTIM:AVER ON

Activates manual averaging.

Manual operation: See "Meas Time/Average"


[SENSe:]PMETer<p>:ROFFset[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe] <State>

This command includes or excludes the reference level offset of the analyzer for power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | 1

Includes the reference level offset in the results.

OFF | 0

Ignores the reference level offset.

*RST: 1
Example:

PMET2:ROFF OFF

Takes no offset into account for the measured power.

Manual operation: See "Use Ref Lev Offset"


[SENSe:]PMETer<p>[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>[:STATe]
[SENSe:]PMETer<p>[:STATe] <State>

This command turns a power sensor on and off.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET1 ON

Switches the power sensor measurements on.

Manual operation: See "State"
See "Select"


[SENSe:]PMETer<p>:UPDate[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > [SENSe:]PMETer<p>:UPDate[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe] <State>

This command turns continuous update of power sensor measurements on and off.

If on, the results are update even if a single sweep is complete.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET1:UPD ON

The data from power sensor 1 is updated continuously.

Manual operation: See "Continuous Value Update"


UNIT<n>:PMETer<p>:POWer

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer <Unit>

This command selects the unit for absolute power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Unit>
DBM | WATT | W
*RST: DBM
Example: UNIT:PMET:POW DBM
Manual operation: See "Unit/Scale"


UNIT<n>:PMETer<p>:POWer:RATio

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Configuring Power Sensor Measurements > UNIT<n>:PMETer<p>:POWer:RATio
UNIT<n>:PMETer<p>:POWer:RATio <Unit>

This command selects the unit for relative power sensor measurements.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Unit>
DB | PCT
*RST: DB
Example: UNIT:PMET:POW:RAT DB
Manual operation: See "Unit/Scale"


Triggering with Power Sensors

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors
Triggering with Power Sensors
List of Commands
[SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger[:STATe]


[SENSe:]PMETer<p>:TRIGger:DTIMe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:DTIMe <Time>

This command defines the time period that the input signal has to stay below the IF power trigger level before the measurement starts.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Time>
Range: | 0 s to 1 s
Increment: | 100 ns
*RST: | 100 µs
Example: PMET2:TRIG:DTIMe 0.001


[SENSe:]PMETer<p>:TRIGger:HOLDoff

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HOLDoff <Holdoff>

This command defines the trigger holdoff for external power triggers.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Holdoff>

Time period that has to pass between the trigger event and the start of the measurement, in case another trigger event occurs.

Range: | 0 s to 1 s
Increment: | 100 ns
*RST: | 0 s
Example: PMET2:TRIG:HOLD 0.1

Sets the holdoff time of the trigger to 100 ms

Manual operation: See "Trigger Holdoff"


[SENSe:]PMETer<p>:TRIGger:HYSTeresis

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis for external power triggers.

The hysteresis in dB is the value the input signal must stay below the IF power trigger level in order to allow a trigger to start the measurement.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
Increment: | 1 dB
*RST: | 0 dB
Example: PMET2:TRIG:HYST 10

Sets the hysteresis of the trigger to 10 dB.

Manual operation: See "Hysteresis"


[SENSe:]PMETer<p>:TRIGger:LEVel

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:LEVel <Level>

This command defines the trigger level for external power triggers.

This command requires the use of an R&S NRP-Z81 power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Level>
-20 to +20 dBm
Range: | -20 dBm to 20 dBm
*RST: | -10 dBm
Example: PMET2:TRIG:LEV -10 dBm

Sets the level of the trigger

Manual operation: See "External Trigger Level"


[SENSe:]PMETer<p>:TRIGger:SLOPe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger:SLOPe <Edge>

This command selects the trigger condition for external power triggers.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<Edge>
POSitive

The measurement starts in case the trigger signal shows a positive edge.

NEGative

The measurement starts in case the trigger signal shows a negative edge.

*RST: POSitive
Example: PMET2:TRIG:SLOP NEG
Manual operation: See "Slope"


[SENSe:]PMETer<p>:TRIGger[:STATe]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Working with Power Sensors > Triggering with Power Sensors > [SENSe:]PMETer<p>:TRIGger[:STATe]
[SENSe:]PMETer<p>:TRIGger[:STATe] <State>

This command turns the external power trigger on and off.

This command requires the use of an R&S NRP-Z81 power sensor.

Suffix:
<p>
1...4

Power sensor index

Parameters:
<State>
ON | OFF
*RST: OFF
Example: PMET2:TRIG ON

Switches the external power trigger on

Manual operation: See "Using the power sensor as an external trigger"


Configuring the Outputs

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF[:SOURce]
OUTPut:IF:IFFRequency
OUTPut:IF:SBANd?
OUTPut:UPORt:STATe
OUTPut:UPORt[:VALue]


DIAGnostic:SERVice:NSOurce

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

For details see "Input from Noise Sources".

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF[:SOURce]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF[:SOURce]
OUTPut:IF[:SOURce] <Source>

Defines the type of signal available at the IF/VIDEO/DEMOD or IF OUT connector on the rear panel of the R&S FSW.

For restrictions and more information see "IF and Video Signal Output".

Parameters:
<Source>
IF

The measured IF value is available at the IF/VIDEO/DEMOD output connector.

The frequency at which the IF value is provided is defined using the OUTPut:​IF:​IFFRequency command.

IF2

The measured IF value is available at the IF OUT output connector at a frequency of 2 GHz and with a bandwidth of 2 GHz.

This parameter is only available for instrument models R&S FSW43/50/67.

VIDeo

The displayed video signal (i.e. the filtered and detected IF signal, 200mV) is available at the IF/VIDEO/DEMOD output connector.

This setting is required to provide demodulated audio frequencies at the output.

*RST: IF
Example: OUTP:IF VID

Selects the video signal for the IF/VIDEO/DEMOD output connector.

Manual operation: See "IF/VIDEO/DEMOD Output"


OUTPut:IF:IFFRequency

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

For more information see "IF and Video Signal Output".

Parameters:
<Frequency>
*RST: 50.0 MHz
Manual operation: See "IF (Wide) Out Frequency"


OUTPut:IF:SBANd?

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:SBANd?
OUTPut:IF:SBANd?

This command queries the sideband provided at the IF OUT connector compared to the sideband of the RF signal. The sideband depends on the current center frequency.

This command is available only if the output is configured for IF2 (see OUTPut:​IF[:​SOURce]).

For more information and prerequisites see "IF 2 GHz Output".

Return values:
<SideBand> | NORMal The sideband at the output is identical to the RF signal. INVerted The sideband at the output is the inverted RF signal sideband.
Example: | OUTP:IF IF2 Activates output at the IF OUTPUT (2 GHZ) connector. OUTP:IF:SBAN? Queries the sideband provided at the connector.
Usage: | Query only
Manual operation: | See "IF/VIDEO/DEMOD Output"


OUTPut:UPORt:STATe

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:UPORt:STATe
OUTPut:UPORt:STATe <State>

This command toggles the control lines of the user ports for the AUX PORT connector. This 9-pole SUB-D male connector is located on the rear panel of the R&S FSW.

Parameters:
<State>
ON

User port is switched to OUTPut

OFF

User port is switched to INPut

*RST: OFF


OUTPut:UPORt[:VALue]

Remote Commands > Setting Basic Measurement Parameters > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:UPORt[:VALue]
OUTPut:UPORt[:VALue] <Value>

This command sets the control lines of the user ports.

The assignment of the pin numbers to the bits is as follows:

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Pin | N/A | N/A | 5 | 3 | 4 | 7 | 6 | 2

Bits 7 and 6 are not assigned to pins and must always be 0.

The user port is written to with the given binary pattern. If the user port is programmed to input instead of output (see INPut:​UPORt:​STATe), the output value is temporarily stored.

Parameters:
<Value>
bit values in hexadecimal format

TTL type voltage levels (max. 5V)

Range: #B00000000 to #B00111111
Example: OUTP:UPOR #B00100100

Sets pins 5 and 7 to 5 V.


Analyzing Measurements (Basics)

Remote Commands > Analyzing Measurements (Basics)
Analyzing Measurements (Basics)

The commands for general analysis tasks are described here.

Contents
  • Zooming into the Display
  • Configuring the Trace Display and Retrieving Trace Data
  • Working with Markers
  • Configuring Display and Limit Lines


Zooming into the Display

Remote Commands > Analyzing Measurements (Basics) > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

Remote Commands > Analyzing Measurements (Basics) > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

Remote Commands > Analyzing Measurements (Basics) > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

Remote Commands > Analyzing Measurements (Basics) > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

Remote Commands > Analyzing Measurements (Basics) > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

Remote Commands > Analyzing Measurements (Basics) > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

Remote Commands > Analyzing Measurements (Basics) > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Configuring the Trace Display and Retrieving Trace Data

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data
Configuring the Trace Display and Retrieving Trace Data

The commands required to work with traces are described here.

Commands required to export traces (and other result data) are described in "Storing Measurement Results".

Contents
  • Configuring Standard Traces
  • Configuring Spectrograms
  • Using Trace Mathematics
  • Retrieving Trace Results
  • Formats for Returned Values: ASCII Format and Binary Format
  • Programming Example: Configuring a Spectrogram


Configuring Standard Traces

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces
Configuring Standard Traces
Useful commands for trace configuration described elsewhere
  • DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]
Remote commands exclusive to trace configuration
List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>:TYPE
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
TRACe<n>:COPY


DISPlay[:WINDow<n>]:TRACe<t>:MODE

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt. Note that synchronization to the end of the measurement is possible only in single sweep mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous <State>

This command turns an automatic reset of a trace on and off after a parameter has changed.

The reset works for trace modes min hold, max hold and average.

Note that the command has no effect if critical parameters like the span have been changed to avoid invalid measurement results

Parameters:
<State>
ON

The automatic reset is off.

OFF

The automatic reset is on.

*RST: OFF
Example: DISP:WIND:TRAC3:MODE:HCON ON

Switches off the reset function.

Manual operation: See "Hold"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 for TRACe1, 0 for TRACe 2 to 6
Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


[SENSe:]AVERage:COUNt

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>

This command defines the number of sweeps that the application uses to average traces.

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweep measurements, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<AverageCount>

If you set a average count of 0 or 1, the application performs one single sweep in single sweep mode.

In continuous sweep mode, if the average count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"
See "Average Count"


[SENSe:]AVERage<n>[:STATe<t>]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > [SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>[:STATe<t>] <State>

This command turns averaging for a particular trace in a particular window on and off.

Parameters:
<State> | ON | OFF
Example: | See "Programming Example: Performing a Basic Frequency Sweep".
Usage: | SCPI confirmed


[SENSe:]AVERage<n>:TYPE

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > [SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>:TYPE <Mode>

This command selects the trace averaging mode.

Parameters:
<Mode>
VIDeo

The logarithmic power values are averaged.

LINear

The power values are averaged before they are converted to logarithmic values.

POWer

The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit.

*RST: VIDeo
Example: AVER:TYPE LIN

Switches to linear average calculation.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Average Mode"


[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion] <Detector>

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector".

For EMI measurements, the trace detector is used for the initial peak search only, not for the final test. The detector for the final test is configured using CALCulate:​MARKer<m>:​FUNCtion:​FMEasurement:​DETector.

If the EMI (R&S FSW-K54) measurement option is installed and the filter type "CISPR" is selected, additional detectors are available, even if EMI measurement is not active. For details see "Detectors and Dwell Time".

Parameters:
<Detector>
APEak

Autopeak

NEGative

Negative peak

POSitive

Positive peak

QPEak

Quasipeak (CISPR filter only)

SAMPle

First value detected per trace point

RMS

RMS value

AVERage

Average

CAVerage

CISPR Average (CISPR filter only)

CRMS

CISPR RMS (CISPR filter only)

*RST: APEak (I/Q Analyzer: RMS)

For more information see "Mapping Samples to Sweep Points with the Trace Detector".

Example: DET POS

Sets the detector to "positive peak".

Example:

See "Programming Example: EMI Measurement".

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Detector"


[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO <State>

This command couples and decouples the detector to the trace mode.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DET:AUTO OFF

The selection of the detector is not coupled to the trace mode.

Manual operation: See "Detector"


TRACe<n>:COPY

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Standard Traces > TRACe<n>:COPY
TRACe<n>:COPY <TraceNumber>, <TraceNumber>

This command copies data from one trace to another.

Parameters:
<TraceNumber>, <TraceNumber> | TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6 The first parameter is the destination trace, the second parameter is the source.
Example: | TRAC:COPY TRACe1,TRACe2 Copies the data from trace 2 to trace 1.
Example: | See "Programming Example: Performing a Basic Frequency Sweep".
Usage: | SCPI confirmed
Manual operation: | See "Copy Trace"


Configuring Spectrograms

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms
Configuring Spectrograms

In addition to the standard "level versus frequency" or "level versus time" spectrum traces, the R&S FSW also provides a spectrogram display of the measured data. A spectrogram shows how the spectral density of a signal varies over time. The x-axis shows the frequency, the y-axis shows the time. The commands required to configure spectrograms in a remote environment are described here. For details and manual operation see "Spectrogram Settings".

When configuring spectrograms, the window suffix is irrelevant. The settings are always applied to the spectrogram window, or to all spectrogram windows, if several are active for the same measurement channel.

For commands to set markers in spectrograms, see "Marker Search (Spectrograms)".

Contents
  • Configuring a Spectrogram Measurement
  • Configuring the Color Map


Configuring a Spectrogram Measurement

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement
Configuring a Spectrogram Measurement
List of Commands
CALCulate:SGRam|SPECtrogram:CLEar[:IMMediate]
CALCulate:SGRam|SPECtrogram:CONT
CALCulate:SGRam|SPECtrogram:FRAMe:COUNt
CALCulate:SGRam|SPECtrogram:FRAMe:SELect
CALCulate:SGRam|SPECtrogram:HDEPth
CALCulate:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate:SGRam|SPECtrogram:TSTamp[:STATe]
CALCulate:SGRam|SPECtrogram[:STATe]


CALCulate:SGRam|SPECtrogram:CLEar[:IMMediate]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram:CLEar[:IMMediate]
CALCulate:SGRam|SPECtrogram:CLEar[:IMMediate]

This command resets the spectrogram and clears the history buffer.

Example: | CALC:SGR:CLE Resets the result display and clears the memory.
Usage: | Event
Manual operation: | See "Clear Spectrogram"


CALCulate:SGRam|SPECtrogram:CONT

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram:CONT
CALCulate:SGRam|SPECtrogram:CONT <State>

This command determines whether the results of the last measurement are deleted before starting a new measurement in single sweep mode.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INIT:CONT OFF

Selects single sweep mode.

INIT;*WAI

Starts the sweep and waits for the end of the sweep.

CALC:SGR:CONT ON

Repeats the single sweep measurement without deleting the results of the last measurement.

Manual operation: See "Single Sweep/ RUN SINGLE"
See "Continue Frame"


CALCulate:SGRam|SPECtrogram:FRAMe:COUNt

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram:FRAMe:COUNt
CALCulate:SGRam|SPECtrogram:FRAMe:COUNt <Frames>

This command defines the number of frames to be recorded in a single sweep.

Parameters:
<Frames>

The maximum number of frames depends on the history depth.

Range: | 1 to history depth
Increment: | 1
*RST: | 1
Example: INIT:CONT OFF

Selects single sweep mode.

CALC:SGR:FRAM:COUN 200

Sets the number of frames to 200.

Manual operation: See "Frame Count"


CALCulate:SGRam|SPECtrogram:FRAMe:SELect

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram:FRAMe:SELect
CALCulate:SGRam|SPECtrogram:FRAMe:SELect <Frame> | <Time>

This command selects a specific frame for further analysis.

The command is available if no measurement is running or after a single sweep has ended.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the distance to frame 0 in seconds. The range depends on the history depth.
Example: | INIT:CONT OFF Stop the continuous sweep. CALC:SGR:FRAM:SEL -25 Selects frame number -25.
Manual operation: | See "Selecting a frame to display"


CALCulate:SGRam|SPECtrogram:HDEPth

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram:HDEPth
CALCulate:SGRam|SPECtrogram:HDEPth <History>

This command defines the number of frames to be stored in the R&S FSW memory.

Parameters:
<History>

The maximum number of frames depends on the number of sweep points.

Range: | 781 to 20000
Increment: | 1
*RST: | 3000
Example: CALC:SGR:SPEC 1500

Sets the history depth to 1500.

Manual operation: See "History Depth"


CALCulate:SGRam|SPECtrogram:TSTamp:DATA?

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate:SGRam|SPECtrogram:TSTamp:DATA? <Frames>

This command queries the starting time of the frames.

The return values consist of four values for each frame. If the Spectrogram is empty, the command returns '0,0,0,0'. The times are given as delta values, which simplifies evaluating relative results; however, you can also calculate the absolute date and time as displayed on the screen.

The frame results themselves are returned with TRAC:DATA? SGR

See TRACe<n>[:​DATA].

Query parameters:
<Frames> | CURRent Returns the starting time of the current frame. ALL Returns the starting time for all frames. The results are sorted in descending order, beginning with the current frame.
Return values:
<Seconds> | Number of seconds that have passed since 01.01.1970 till the frame start
<Nanoseconds> | Number of nanoseconds that have passed in addition to the <Seconds> since 01.01.1970 till the frame start.
<Reserved> | The third and fourth value are reserved for future uses.
Example: | CALC:SGR:TST ON Activates the time stamp. CALC:SGR:TST:DATA? ALL Returns the starting times of all frames sorted in a descending order.
Usage: | Query only
Manual operation: | See "Timestamp"


CALCulate:SGRam|SPECtrogram:TSTamp[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram:TSTamp[:STATe]
CALCulate:SGRam|SPECtrogram:TSTamp[:STATe] <State>

This command activates and deactivates the time stamp.

If the time stamp is active, some commands do not address frames as numbers, but as (relative) time values:

  • CALCulate<n>:​DELTamarker<m>:​SGRam|SPECtrogram:​FRAMe
  • CALCulate<n>:​MARKer<m>:​SGRam|SPECtrogram:​FRAMe
  • CALCulate:​SGRam|SPECtrogram:​FRAMe:​SELect
Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:SGR:TST ON

Activates the time stamp.

Manual operation: See "Timestamp"


CALCulate:SGRam|SPECtrogram[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring a Spectrogram Measurement > CALCulate:SGRam|SPECtrogram[:STATe]
CALCulate:SGRam|SPECtrogram[:STATe] <State>

This command turns the spectrogram on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:SGR ON

Activates the Spectrogram result display.

Manual operation: See "State"


Configuring the Color Map

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring the Color Map
Configuring the Color Map
List of Commands
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring the Color Map > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault

This command restores the original color map.

Usage: | Event
Manual operation: | See "Set to Default"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring the Color Map > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer <Percentage>

This command defines the starting point of the color map.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0 to 66
*RST: | 0
Default unit: | %
Example: DISP:WIND:SGR:COL:LOW 10

Sets the start of the color map to 10%.

Manual operation: See "Start / Stop"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring the Color Map > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe <Shape>

This command defines the shape and focus of the color curve for the spectrogram result display.

Parameters:
<Shape>

Shape of the color curve.

Range: | -1 to 1
*RST: | 0
Manual operation: See "Shape"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring the Color Map > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer <Percentage>

This command defines the end point of the color map.

Parameters:
<Percentage>

Statistical frequency percentage.

Range: | 0 to 66
*RST: | 0
Default unit: | %
Example: DISP:WIND:SGR:COL:UPP 95

Sets the start of the color map to 95%.

Manual operation: See "Start / Stop"


DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Configuring Spectrograms > Configuring the Color Map > DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe] <ColorScheme>

This command selects the color scheme.

For details see "Color Maps".

Parameters:
<ColorScheme>
HOT

Uses a color range from blue to red. Blue colors indicate low levels, red colors indicate high ones.

COLD

Uses a color range from red to blue. Red colors indicate low levels, blue colors indicate high ones.

RADar

Uses a color range from black over green to light turquoise with shades of green in between.

GRAYscale

Shows the results in shades of gray.

*RST: HOT
Example: DISP:WIND:SPEC:COL GRAY

Changes the color scheme of the spectrogram to black and white.

Manual operation: See "Hot/Cold/Radar/Grayscale"


Using Trace Mathematics

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Using Trace Mathematics
Using Trace Mathematics

The following commands control trace mathematics.

List of Commands
CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:MATH:MODE
CALCulate<n>:MATH:POSition
CALCulate<n>:MATH:STATe


CALCulate<n>:MATH[:EXPression][:DEFine]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Using Trace Mathematics > CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:MATH[:EXPression][:DEFine] <Expression>

This command selects the mathematical expression for trace mathematics.

Before you can use the command, you have to turn trace mathematics on.

Parameters:
<Expression> | (TRACE1-TRACE2) Subtracts trace 2 from trace 1. (TRACE1-TRACE3) Subtracts trace 3 from trace 1. (TRACE1-TRACE4) Subtracts trace 4 from trace 1. (TRACE1-TRACE5) Subtracts trace 5 from trace 1. (TRACE1-TRACE6) Subtracts trace 6 from trace 1.
Example: | CALC:MATH:STAT ON Turns trace mathematics on. CALC:MATH:EXPR:DEF (TRACE1-TRACE3) Subtracts trace 3 from trace 1.
Example: | See "Programming Example: Performing a Basic Frequency Sweep".
Usage: | SCPI confirmed
Manual operation: | See "Trace Math Function"


CALCulate<n>:MATH:MODE

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Using Trace Mathematics > CALCulate<n>:MATH:MODE
CALCulate<n>:MATH:MODE <Mode>

This command selects the way the R&S FSW calculates trace mathematics.

Parameters:
<Mode>

For more information on the way each mode works see Trace Math Mode.

LINear

Linear calculation.

LOGarithmic

Logarithmic calculation.

POWer

Linear power calculation.

*RST: LOGarithmic
Example: CALC:MATH:MODE LIN

Selects linear calculation.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Trace Math Mode"


CALCulate<n>:MATH:POSition

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Using Trace Mathematics > CALCulate<n>:MATH:POSition
CALCulate<n>:MATH:POSition <Position>

This command defines the position of the trace resulting from the mathematical operation.

Parameters:
<Position>

Vertical position of the trace in % of the height of the diagram area.

100 PCT corresponds to the upper diagram border.

Range: | -100 to 200
*RST: | 50
Default unit: | PCT
Example: CALC:MATH:POS 100

Moves the trace to the top of the diagram area.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Manual operation: See "Trace Math Position"


CALCulate<n>:MATH:STATe

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Using Trace Mathematics > CALCulate<n>:MATH:STATe
CALCulate<n>:MATH:STATe <State>

This command turns the trace mathematics on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MATH:STAT ON

Turns on trace mathematics.

Example:

See "Programming Example: Performing a Basic Frequency Sweep".

Usage: SCPI confirmed
Manual operation: See "Trace Math Function"
See "Trace Math Off"


Retrieving Trace Results

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Retrieving Trace Results
Retrieving Trace Results

This chapter describes how to retrieve data from standard traces.

For spectrograms see also "Marker Search (Spectrograms)".

For details on the format of the retrieved trace data see also "Formats for Returned Values: ASCII Format and Binary Format".

Commands required to export traces (and other result data) are described in "Storing Measurement Results".

List of Commands
FORMat[:DATA]
TRACe<n>[:DATA]
TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:X?


FORMat[:DATA]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Retrieving Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

For details on data formats see "Formats for Returned Values: ASCII Format and Binary Format".

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


TRACe<n>[:DATA]

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Retrieving Trace Results > TRACe<n>[:DATA]
TRACe<n>[:DATA] <Trace>,<Data> | <ResultType>

This command queries current trace data and measurement results.

If you use it as a setting command, it transfers trace data from an external source to the R&S FSW.

The data format depends on FORMat[:​DATA].

Parameters:
<Trace>

Selects the trace to write the data to.

TRACE1 | ... | TRACE6
<Data>

Contains the data to transfer.

Query parameters:
<ResultType>

Selects the type of result to be returned.

TRACE1 | ... | TRACE6

Returns the trace data for the corresponding trace.

For details see table "Return values for TRACE1 to TRACE6 parameter".

LIST

Returns the results of the peak list evaluation for Spurious Emission and Spectrum Emission Mask measurements.

For SEM measurements, one peak per range is returned.

For spurious emission measurements, the number of peaks returned for each measurement range is defined by the "Peaks per Range" parameter (see CALCulate<n>:​PSEarch|PEAKsearch:​SUBRanges), regardless of the ""Details"" setting.

For details see table "Return values for LIST parameter".

SPURious

Returns the peak list of Spurious Emission measurements.

SPECtrogram | SGRam

Returns the results of the spectrogram result display.

For details see table "Return values for SPECtrogram parameter".

Return values:
<TraceData>

For more information see tables below.

Example: TRAC TRACE1,+A$

Transfers trace data ('+A$') to trace 1.

Example: TRAC? TRACE3

Queries the data of trace 3.

Example:

See "Programming Example: Performing a Basic Frequency Sweep"

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Example: SEM Measurement".

Example:

See "Programming Example" .

Usage: SCPI confirmed
Manual operation: See "Spectrum Emission Mask"
See "Spurious Emissions"
See "List Evaluation (Result Summary) State"
See "List Evaluation State"
Return values for TRACE1 to TRACE6 parameter

The trace data consists of a list of power levels that have been measured. The number of power levels in the list depends on the currently selected number of sweep points. The unit depends on the measurement and on the unit you have currently set.

If you are measuring with the auto peak detector, the command returns positive peak values only.

For SEM or Spurious Emission measurement results, the x-values should be queried as well, as they are not equi-distant (see TRACe<n>[:​DATA]:​X?).

Return values for LIST parameter

For each peak, the command returns 11 values in the following order:

<No>,<StartFreq>,<StopFreq>,<RBW>,<PeakFreq>,<PowerAbs>,<PowerRel>,<PowerDelta>,<LimitCheck>,<Unused1>,<Unused2>

  • <No>: range number
  • <StartFreq>,<StopFreq>: start and stop frequency of the range
  • <RBW>: resolution bandwidth
  • <PeakFreq>: frequency of the peak in a range
  • <PowerAbs>: absolute power of the peak in dBm
  • <PowerRel>: power of the peak in relation to the channel power in dBc
  • <PowerDelta>: distance from the peak to the limit line in dB, positive values indicate a failed limit check
  • <LimitCheck>: state of the limit check (0 = PASS, 1 = FAIL)
  • <Unused1>,<Unused2>: reserved (0.0)
Return values for SPECtrogram parameter

For every frame in the spectrogram, the command returns the power levels that have been measured, one for each sweep point. The number of frames depends on the size of the history depth. The power level depends on the unit you have currently set.


TRACe<n>[:DATA]:MEMory?

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Retrieving Trace Results > TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:MEMory? <Trace>,<OffsSwPoint>,<NoOfSwPoints>

This command queries the previously captured trace data for the specified trace from the memory. As an offset and number of sweep points to be retrieved can be specified, the trace data can be retrieved in smaller portions, making the command faster than the TRAC:DATA? command. This is useful if only specific parts of the trace data are of interest.

If no parameters are specified with the command, the entire trace data is retrieved; in this case, the command is identical to TRAC:DATA? TRACE1

For details on the returned values see the TRAC:DATA? <TRACE...> command.

Query parameters:
<Trace> | TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6
<OffsSwPoint> | The offset in sweep points related to the start of the measurement at which data retrieval is to start.
<NoOfSwPoints> | Number of sweep points to be retrieved from the trace.
Example: | TRAC:DATA:MEM? TRACE1,25,100 Retrieves 100 sweep points from trace 1, starting at sweep point 25.
Usage: | Query only


TRACe<n>[:DATA]:X?

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Retrieving Trace Results > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <TraceNumber>

This command queries the horizontal trace data for each sweep point in the specified window, for example the frequency in frequency domain or the time in time domain measurements.

This is especially useful for traces with non-equidistant x-values, e.g. for SEM or Spurious Emissions measurements.

Query parameters:
<TraceNumber> | Trace number. TRACE1 | ... | TRACE6
Example: | TRAC3:X? TRACE1 Returns the x-values for trace 1 in window 3.
Usage: | Query only
Manual operation: | See "Spectrum Emission Mask"


Formats for Returned Values: ASCII Format and Binary Format

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Formats for Returned Values: ASCII Format and Binary Format
Formats for Returned Values: ASCII Format and Binary Format

When trace data is retrieved using the TRAC:DATA or TRAC:IQ:DATA command, the data is returned in the format defined using the FORMat[:​DATA]. The possible formats are described here.

  • ASCII Format (FORMat ASCII):
    The data is stored as a list of comma separated values (CSV) of the measured values in floating point format.
  • Binary Format (FORMat REAL,32):
    The data is stored as binary data (Definite Length Block Data according to IEEE 488.2), each measurement value being formatted in 32 Bit IEEE 754 Floating-Point-Format.
    The schema of the result string is as follows:
    #41024<value1><value2>…<value n> with
#4 | number of digits (= 4 in the example) of the following number of data bytes
1024 | number of following data bytes (= 1024 in the example)
<Value> | 4-byte floating point value

Reading out data in binary format is quicker than in ASCII format. Thus, binary format is recommended for large amounts of data.


Programming Example: Configuring a Spectrogram

Remote Commands > Analyzing Measurements (Basics) > Configuring the Trace Display and Retrieving Trace Data > Programming Example: Configuring a Spectrogram
Programming Example: Configuring a Spectrogram

This example demonstrates how to configure a spectrogram for a basic frequency sweep in a remote environment. The spectrogram is displayed in addition to the spectrum display, in a new window. In addition, the usage of special spectrogram markers is demonstrated (see "Marker Search (Spectrograms)").

Basic trace settings are demonstrated in the "Programming Example: Performing a Basic Frequency Sweep".

//-----------Preparing the Measurement ------------
*RST
//Resets the instrument
LAY:ADD? '1',BEL,SGR
//Displays a new window below window 1 and activates spectrogram display.
//The new window name is returned as a result: '2'.
//The spectrogram is updated with each new sweep.
INIT:CONT OFF
//Selects single sweep mode.

//--------------Configuring the Spectrogram--------------
CALC:SGR:CLE
//Clears the displayed spectrogram to start a new one.
CALC:SGR:CONT ON
//Configures a continuous spectrogram for a series of measurements.
//The display is not cleared when a new measurement is started.
CALC:SGR:FRAM:COUN 100
//Sets the number of frames to be recorded per sweep to 100.
CALC:SGR:HDEP 1000
//Sets the number of frames to be stored to 1000 (=10 sweeps)
CALC:SGR:TST ON
//Activates a time stamp for each frame.

//--------------Configuring the Color Map----------------
DISP:WIND:SGR:COL GRAY
//Defines a gray-scaled coloring: low values light gray, high values dark gray.
DISP:WIND:SGR:COL:LOW 30
DISP:WIND:SGR:COL:UPP 70
DISP:WIND:SGR:COL:SHAP 0.8
//Defines a color map for a range that comprises 40% of the measurement range,
//excluding 30% at each end. The colors are not scaled linearly; the light gray
//colors are stretched to distinguish low values better.

//--------------Performing the Measurement---------------
SWE:COUN 10
//Defines 10 sweeps to be performed per measurement.
INIT;*WAI
//Initiates a new measurement and waits until the sweeps have finished.
//The spectrogram is updated with each new sweep.

//--------------Positioning Markers----------------------
CALC:MARK:SGR:SAR MEM
//Includes all frames in the memory in the search area

CALC:MARK1:SGR:FRAM -1s
//Sets marker 1 to the frame 1 second after measurement begin. (Note the
//negative value!
CALC:MARK1:MIN
//Sets marker 1 to the minimum level in this frame.
CALC:MARK1:SGR:Y:MIN
//Sets marker 1 to the minimum level for the same frequency the marker is
//currently positioned at in all frames.

CALC:MARK2:SGR:XY:MAX
//Sets marker 2 to the maximum level in the entire spectrogram.

CALC:DELT1:SGR:FRAM 3s
//Sets the deltamarker 1 to the frame captured 3 seconds after marker 1. By default
//it is set to the peak of that frame and displays the level difference to marker 1.
//Note the positive value!
CALC:DELT1:MIN
//Sets deltamarker 1 to the minimum level in this frame.

CALC:DELT3:SGR:XY:MAX
//Sets deltamarker 3 to the maximum level in the entire spectrogram. By default
//its value is the difference to marker 1. We will change it to refer to marker 2.
CALC:DELT3:MREF 2
//Deltamarker 3 now refers to marker 2, both are positioned on the maximum of the
//spectrogram. Thus, D3=0. We will move deltamarker 3 to the next peak level
//for the same frequency.
CALC:DELT3:SGR:Y:MAX:NEXT

//---------------Retrieving Results----------------------
CALC:MARK1:X?
CALC:MARK1:Y?
CALC:MARK1:SGR:FRAM?
//Queries the frequency (x), level (y) and frame values of marker 1.

CALC:MARK2:X?
CALC:MARK2:Y?
CALC:MARK2:SGR:FRAM?
//Queries the frequency (x), level (y) and frame values of marker 2.

CALC:DELT1:X?
CALC:DELT1:Y?
CALC:DELT1:SGR:FRAM?
//Queries the frequency (x), level (y) and frame values of deltamarker 1.

CALC:DELT3:X?
CALC:DELT3:Y?
CALC:DELT3:SGR:FRAM?
//Queries the frequency (x), level (y) and frame values of deltamarker 3.

CALC:SGR:TST:DATA? ALL
//Queries the time stamps of all stored frames.
CALC:SGR:FRAM:SEL -1
//Selects the frame that was captured 1 second after measurement start (Note the
//negative value!). This frame is displayed in the Spectrum window.
TRAC:DATA? SGR
//Retrieves the trace data for the spectrogram. For each frame, the power level
//and frequency at each sweep point are returned.
TRAC:DATA? TRACE1
//Retrieves the trace data for the selected frame only.


Working with Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers
Working with Markers

The commands required to work with markers and marker functions in a remote environment are described here. The tasks for manual operation are described in "Marker Usage".

In the Spectrum application, markers are identical in all windows. Thus, the suffix <n> for the window is generally irrelevant.

Contents
  • Setting Up Individual Markers
  • General Marker Settings
  • Configuring and Performing a Marker Search
  • Positioning the Marker
  • Retrieving Marker Results
  • Marker Search (Spectrograms)
  • Fixed Reference Marker Settings
  • Marker Peak Lists
  • Noise Measurement Marker
  • Phase Noise Measurement Marker
  • Band Power Marker
  • n dB Down Marker
  • Signal Count Marker
  • Marker Demodulation
  • Programming Examples for Using Markers and Marker Functions


Setting Up Individual Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers
Setting Up Individual Markers

The following commands define the position of markers in the diagram.

List of Commands
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X


CALCulate<n>:DELTamarker:AOFF

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:LINK

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:LINK <State>

This command links delta marker <m> to marker 1.

If you change the horizontal position (x-value) of marker 1, delta marker <m> changes its horizontal position to the same value.

Tip: to link any marker to a different marker than marker 1, use the CALCulate<n>:​DELTamarker<m1>:​LINK:​TO:​MARKer<m2> or CALCulate<n>:​MARKer<m1>:​LINK:​TO:​MARKer<m2> commands.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2:LINK ON
Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2> <State>

This command links delta marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, delta marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT4:LINK:TO:MARK2 ON

Links the delta marker 4 to the marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker:MODE

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker:MODE <Mode>

This command defines whether the position of a delta marker is provided as an absolute value or relative to a reference marker. Note that when the position of a delta marker is queried, the result is always an absolute value (see CALCulate<n>:​DELTamarker<m>:​X)!

Parameters:
<Mode>
ABSolute

Delta marker position in absolute terms.

RELative

Delta marker position in relation to a reference marker.

*RST: RELative
Example: CALC:DELT:MODE ABS

Absolute delta marker position.


CALCulate<n>:DELTamarker<m>:MREF

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

The reference may be another marker or the fixed reference.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference. FIXed Selects the fixed reference as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker State"
See "Marker Type"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:TRACe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The position is relative to the reference marker.

To select an absolute position you have to change the delta marker mode with CALCulate<n>:​DELTamarker:​MODE.

A query returns the absolute position of the delta marker.

Range: The value range and unit depend on the measurement and scale of the x-axis.
Example: CALC:DELT:X?

Outputs the absolute x-value of delta marker 1.

Manual operation: See "Marker 1/2/3/4"
See "Marker 1/2/3"
See "Marker Position (X-value)"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:MARKer<m>:AOFF

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2> <State>

This command links normal marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK4:LINK:TO:MARK2 ON

Links marker 4 to marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:MARKer<m>[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker State"
See "Marker Type"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:MARKer<m>:TRACe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | 1 to 6 Trace number the marker is assigned to.
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The unit is either Hz (frequency domain) or s (time domain) or dB (statistics).

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker 1/2/3/4"
See "Marker 1/2/3"
See "Marker Position (X-value)"
See "Marker Table"
See "Marker Peak List"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


General Marker Settings

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > General Marker Settings
General Marker Settings

The following commands control general marker functionality.

See also "Fixed Reference Marker Settings"

Remote commands exclusive to general marker functionality
List of Commands
DISPlay:MTABle
CALCulate:MARKer:X:SSIZe


DISPlay:MTABle

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


CALCulate:MARKer:X:SSIZe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > General Marker Settings > CALCulate:MARKer:X:SSIZe
CALCulate:MARKer:X:SSIZe <StepSize>

This command selects the marker step size mode.

The step size defines the distance the marker moves when you move it with the rotary knob. It therefore takes effect in manual operation only.

Parameters:
<StepSize>
STANdard

the marker moves from one pixel to the next

POINts

the marker moves from one sweep point to the next

*RST: POINts
Example: CALC:MARK:X:SSIZ STAN

Sets the marker step size to one pixel.

Manual operation: See "Marker Stepsize"


Configuring and Performing a Marker Search

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search
Configuring and Performing a Marker Search

The following commands control the marker search.

List of Commands
CALCulate:MARKer:LOEXclude
CALCulate<n>:MARKer:PEXCursion
CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:THReshold
CALCulate:THReshold:STATe


CALCulate:MARKer:LOEXclude

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:LOEXclude
CALCulate:MARKer:LOEXclude <State>

This command turns the suppression of the local oscillator during automatic marker positioning on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:MARK:LOEX ON
Manual operation: See "Exclude LO"


CALCulate<n>:MARKer:PEXCursion

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:PEXCursion <Excursion>

This command defines the peak excursion.

The peak excursion sets the requirements for a peak to be detected during a peak search.

The unit depends on the measurement.

Application/Result display | Unit
Spectrum | dB
Parameters:
<Excursion>

The excursion is the distance to a trace maximum that must be attained before a new maximum is recognized, or the distance to a trace minimum that must be attained before a new minimum is recognized

*RST: 6 dB in the Spectrum application and RF displays
Example: CALC:MARK:PEXC 10dB

Defines peak excursion as 10 dB.

Manual operation: See "Peak Excursion"


CALCulate:MARKer:X:SLIMits[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SLIMits[:STATe] <State>

This command turns marker search limits on and off.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:X:SLIM ON

Switches on search limitation.

Example:

See "Programming Example: Time Domain Power".

Manual operation: See "Search Limits (Left / Right)"
See "Deactivating All Search Limits"
See "Limit State"


CALCulate:MARKer:X:SLIMits:LEFT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:LEFT <SearchLimit>

This command defines the left limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<SearchLimit>

The value range depends on the frequency range or sweep time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: left diagram border
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:LEFT 10MHz

Sets the left limit of the search range to 10 MHz.

Example:

See "Programming Example: Time Domain Power".

Manual operation: See "Search Limits (Left / Right)"
See "Left Limit / Right Limit"


CALCulate:MARKer:X:SLIMits:RIGHT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:RIGHT <SearchLimit>

This command defines the right limit of the marker search range.

If you perform a measurement in the time domain, this command limits the range of the trace to be analyzed.

Parameters:
<Limit>

The value range depends on the frequency range or sweep time.

The unit is Hz for frequency domain measurements and s for time domain measurements.

*RST: right diagram border
Example: CALC:MARK:X:SLIM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:RIGH 20MHz

Sets the right limit of the search range to 20 MHz.

Example:

See "Programming Example: Time Domain Power".

Manual operation: See "Search Limits (Left / Right)"
See "Left Limit / Right Limit"


CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe] <State>

This command adjusts the marker search range to the zoom area.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:X:SLIM:ZOOM ON

Switches the search limit function on.

CALC:MARK:X:SLIM:RIGH 20MHz

Sets the right limit of the search range to 20 MHz.

Manual operation: See "Using Zoom Limits"


CALCulate:THReshold

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate:THReshold
CALCulate:THReshold <Level>

This command defines a threshold level for the marker peak search.

Parameters:
<Level>
Numeric value. The value range and unit are variable.
*RST: -120 dBm
Example: CALC:THR -82DBM

Sets the threshold value to -82 dBm.

Manual operation: See "Search Threshold"


CALCulate:THReshold:STATe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Configuring and Performing a Marker Search > CALCulate:THReshold:STATe
CALCulate:THReshold:STATe <State>

This command turns a threshold for the marker peak search on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:THR:STAT ON

Switches on the threshold line.

Manual operation: See "Deactivating All Search Limits"


Positioning the Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker
Positioning the Marker

This chapter contains remote commands necessary to position the marker on a trace.

Contents
  • Positioning Normal Markers
  • Positioning Delta Markers


Positioning Normal Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers
Positioning Normal Markers

The following commands position markers on the trace.

List of Commands
CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:MAXimum:AUTO

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:AUTO <State>

This command turns an automatic marker peak search for a trace maximum on and off. The R&S FSW performs the peak search after each sweep.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:MAX:AUTO ON

Activates the automatic peak search function for marker 1 at the end of each particular sweep.

Manual operation: See "Auto Max / Min Peak Search"


CALCulate<n>:MARKer<m>:MAXimum:LEFT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Mode for Next Peak in X Direction"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Mode for Next Peak in X Direction" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

In the spectrogram, the command moves a marker horizontally to the highest level in the currently selected frame. The vertical marker position remains the same.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Peak Search"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Mode for Next Peak in X Direction"


CALCulate<n>:MARKer<m>:MINimum:AUTO

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:AUTO <State>

This command turns an automatic marker peak search for a trace minimum on and off. The R&S FSW performs the peak search after each sweep.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:MIN:AUTO ON

Activates the automatic minimum value search function for marker 1 at the end of each particular sweep.

Manual operation: See "Auto Max / Min Peak Search"


CALCulate<n>:MARKer<m>:MINimum:LEFT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Mode for Next Peak in X Direction"


CALCulate<n>:MARKer<m>:MINimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Mode for Next Peak in X Direction" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

In the spectrogram, the command moves a marker horizontally to the minimum level in the currently selected frame. The vertical marker position remains the same.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Search Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Normal Markers > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Mode for Next Peak in X Direction"


Positioning Delta Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers
Positioning Delta Markers

The following commands position delta markers on the trace.

List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

In the spectrogram, the command moves a marker horizontally to the highest level in the currently selected frame. The vertical marker position remains the same.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

In the spectrogram, the command moves a delta marker horizontally to the minimum level in the currently selected frame. The vertical marker position remains the same.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Marker Search Type" See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

In the spectrogram, the vertical marker position remains the same.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Retrieving Marker Results

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Retrieving Marker Results
Retrieving Marker Results

The following commands are used to retrieve the results of markers.

You can use the marker values to position the center frequency or reference level directly using the following commands:

  • CALCulate<n>:​MARKer<m>:​FUNCtion:​CENTer
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​REFerence
Useful commands for retrieving results described elsewhere:
  • CALCulate<n>:​DELTamarker<m>:​X
  • CALCulate<n>:​MARKer<m>:​X
  • CALCulate:​MARKer:​FUNCtion:​FPEaks:​COUNt?
  • CALCulate:​MARKer:​FUNCtion:​FPEeaks:​X?
  • CALCulate:​MARKer:​FUNCtion:​FPEeaks:​Y?
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​NOISe:​RESult?
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​PNOise:​RESult?
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​BPOWer:​RESult?
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​BPOWer:​RESult?
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​RESult?
  • CALCulate<n>:​MARKer<m>:​FUNCtion:​NDBDown:​FREQuency?
  • CALCulate:​MARKer:​FUNCtion:​NDBDown:​QFACtor?
  • CALCulate<n>:​MARKer<m>:​COUNt:​FREQuency?
Remote commands exclusive to retrieving marker results
List of Commands
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:DELTamarker<m>:X:RELative?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1/2/3/4" See "Marker 1/2/3" See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:Y?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Base unit
Parameter, measuring function or result display | Output unit
DBM | DBPW | DBUV | DBMV | DBUA | dB (lin/log)
WATT | VOLT | AMPere | dB (lin), % (log)
statistics function (APD or CCDF) on | dimensionless output
Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:MARKer<m>:Y?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Retrieving Marker Results > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position. The unit is variable and depends on the one you have currently set.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table" See "Marker Peak List" See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


Marker Search (Spectrograms)

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms)
Marker Search (Spectrograms)

The following commands automatically define the marker and delta marker position in the spectrogram.

The usage of these markers is demonstrated in "Programming Example: Configuring a Spectrogram".

Contents
  • Using Markers
  • Using Delta Markers


Using Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers
Using Markers

The following commands control spectrogram markers.

Useful commands for spectrogram markers described elsewhere

The following commands define the horizontal position of the markers.

  • CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT
  • CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT
  • CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]
  • CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt
  • CALCulate<n>:​MARKer<m>:​MINimum:​LEFT
  • CALCulate<n>:​MARKer<m>:​MINimum:​NEXT
  • CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]
  • CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt
Remote commands exclusive to spectrogram markers
List of Commands
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe <Frame> | <Time>

This command positions a marker on a particular frame.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the (negative) distance to frame 0 in seconds. The range depends on the history depth.
Example: | CALC:MARK:SGR:FRAM -20 Sets the marker on the 20th frame before the present. CALC:MARK2:SGR:FRAM -2s Sets second marker on the frame 2 seconds ago.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Frame (Spectrogram only)"


CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea <SearchArea>

This command defines the marker search area for all markers.

Parameters:
<SearchArea>
VISible

Performs a search within the visible frames.

Note that the command does not work if the spectrogram is not visible for any reason (e.g. if the display update is off).

MEMory

Performs a search within all frames in the memory.

*RST: VISible
Manual operation: See "Marker Search Area"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

This command moves a marker to the highest level of the spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

This command moves a marker to the minimum level of the spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

This command moves a marker vertically to the next lower peak level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

This command moves a marker vertically to the highest level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command looks for the peak level in the whole spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

This command moves a marker vertically to the next higher minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Markers > CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

This command moves a marker vertically to the minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command first looks for the peak level for all frequencies and moves the marker vertically to the minimum level.

Usage: | Event
Manual operation: | See "Marker Search Type"


Using Delta Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers
Using Delta Markers

The following commands control spectrogram delta markers.

Useful commands for spectrogram markers described elsewhere

The following commands define the horizontal position of the delta markers.

  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT
  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT
  • CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT
  • CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt
Remote commands exclusive to spectrogram markers
List of Commands
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe <Frame> | <Time>

This command positions a delta marker on a particular frame. The frame is relative to the position of marker 1.

The command is available for the spectrogram.

Parameters:
<Frame> | Selects a frame directly by the frame number. Valid if the time stamp is off. The range depends on the history depth.
<Time> | Selects a frame via its time stamp. Valid if the time stamp is on. The number is the distance to frame 0 in seconds. The range depends on the history depth.
Example: | CALC:DELT4:SGR:FRAM -20 Sets fourth deltamarker 20 frames below marker 1. CALC:DELT4:SGR:FRAM 2 s Sets fourth deltamarker 2 seconds above the position of marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Frame (Spectrogram only)"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea <SearchArea>

This command defines the delta marker search area.

Parameters:
<SearchArea>
VISible

Performs a search within the visible frames.

Note that the command does not work if the spectrogram is not visible for any reason (e.g. if the display update is off).

MEMory

Performs a search within all frames in the memory.

*RST: VISible
Manual operation: See "Marker Search Area"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]

This command moves a marker to the highest level of the spectrogram over all frequencies.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]

This command moves a delta marker to the minimum level of the spectrogram over all frequencies.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe

This command moves a marker vertically to the next higher level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow

This command moves a marker vertically to the next higher level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT

This command moves a delta marker vertically to the next higher level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]

This command moves a delta marker vertically to the highest level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command looks for the peak level in the whole spectrogram.

Usage: | Event
Manual operation: | See "Marker Search Type"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes only frames above the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes only frames below the current marker position. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT

This command moves a delta marker vertically to the next minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak in Y Direction"


CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Search (Spectrograms) > Using Delta Markers > CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]

This command moves a delta marker vertically to the minimum level for the current frequency.

The search includes all frames. It does not change the horizontal position of the marker.

If the marker hasn't been active yet, the command first looks for the peak level in the whole spectrogram and moves the marker vertically to the minimum level.

Usage: | Event
Manual operation: | See "Marker Search Type"


Fixed Reference Marker Settings

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Fixed Reference Marker Settings
Fixed Reference Marker Settings

The following commands configure a fixed reference marker.

List of Commands
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]

This command moves the fixed reference marker to the peak power.

Example: | CALC:DELT:FUNC:FIX:RPO:MAX Sets the reference point level for delta markers to the peak of the selected trace.
Usage: | Event
Manual operation: | See "Defining a Fixed Reference" See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X <RefPoint>

This command defines the horizontal position of the fixed delta marker reference point. The coordinates of the reference may be anywhere in the diagram.

Parameters:
<RefPoint>

Numeric value that defines the horizontal position of the reference.

For frequency domain measurements, it is a frequency in Hz.

For time domain measurements, it is a point in time in s.

*RST: Fixed Reference: OFF
Example: CALC:DELT:FUNC:FIX:RPO:X 128 MHz

Sets the frequency reference to 128 MHz.

Manual operation: See "Defining a Fixed Reference"
See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y <RefPointLevel>

This command defines the vertical position of the fixed delta marker reference point. The coordinates of the reference may be anywhere in the diagram.

Parameters:
<RefPoint>

Numeric value that defines the vertical position of the reference.

The unit and value range is variable.

*RST: Fixed Reference: OFF
Example: CALC:DELT:FUNC:FIX:RPO:Y -10dBm

Sets the reference point level for delta markers to -10 dBm.

Manual operation: See "Defining a Fixed Reference"
See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet <Offset>

This command defines a level offset for the fixed delta marker reference point.

Parameters:
<Offset>
Numeric value
*RST: | 0
Default unit: | dB


CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Fixed Reference Marker Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe] <State>

This command activates or deactivates a marker that defines a fixed reference point for relative marker analysis.

If necessary, the command activates a marker and positions it on the peak power.

Subsequently, you can change the coordinates of the fixed reference independent of the marker. The fixed reference is independent of the trace and is applied to all active delta markers.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT:FUNC:FIX ON

Switches on the measurement with fixed reference value for all delta markers.

CALC:DELT:FUNC:FIX:RPO:X 128 MHZ

Sets the frequency reference to 128 MHz.

CALC:DELT:FUNC:FIX:RPO:Y 30 DBM

Sets the reference level to +30 dBm.

Manual operation: See "Defining a Fixed Reference"


Marker Peak Lists

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists
Marker Peak Lists
Useful commands for peak lists described elsewhere
  • CALCulate<n>:​MARKer:​PEXCursion
  • MMEMory:​STORe:​PEAK
  • "Configuring and Performing a Marker Search"
Remote commands exclusive to peak lists
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe] <State>

This command turns labels for peaks found during a peak search on and off.

The labels correspond to the marker number in the marker peak list.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: CALC:MARK:FUNC:FPE:ANN:LAB:STAT OFF

Removes the peak labels from the diagram

Manual operation: See "Displaying Marker Numbers"


CALCulate:MARKer:FUNCtion:FPEaks:COUNt?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?

This command queries the number of peaks that have been found during a peak search.

The actual number of peaks that have been found may differ from the number of peaks you have set to be found because of the peak excursion.

Return values:
<NumberOfPeaks> |
Example: | CALC:MARK:FUNC:FPE:COUN? Queries the number of peaks.
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate] <Peaks>

This command initiates a peak search.

Parameters:
<Peaks>

This parameter defines the number of peaks to find during the search.

Note that the actual number of peaks found during the search also depends on the peak excursion you have set with CALCulate<n>:​MARKer:​PEXCursion.

Range: 1 to 200
Example: CALC:MARK:PEXC 5

Defines a peak excursion of 5 dB, i.e. peaks must be at least 5 dB apart to be detected as a peak.

CALC:MARK:FUNC:FPE 10

Initiates a search for 10 peaks on the current trace.


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE <MaxNoPeaks>

This command defines the maximum number of peaks that the R&S FSW looks for during a peak search.

Parameters:
<MaxNoPeaks>

Maximum number of peaks to be determined.

Range: | 1 to 200
*RST: | 50
Example: CALC:MARK:FUNC:FPE:LIST:SIZE 10

The marker peak list will contain a maximum of 10 peaks.

Manual operation: See "Maximum Number of Peaks"


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT <SortMode>

This command selects the order in which the results of a peak search are returned.

Parameters:
<SortMode>
X

Sorts the peaks according to increasing position on the x-axis.

Y

Sorts the peaks according to decreasing position on the y-axis.

*RST: X
Example: CALC:MARK:FUNC:FPE:SORT Y

Sets the sort mode to decreasing y values

Manual operation: See "Sort Mode"


CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT <State>

This command turns a peak search on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:FPE:STAT ON

Activates marker peak search

Manual operation: See "Peak List State"


CALCulate:MARKer:FUNCtion:FPEeaks:X?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:X?

This command queries the position of the peaks on the x-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the x-axis. The unit depends on the measurement.
Usage: | Query only


CALCulate:MARKer:FUNCtion:FPEeaks:Y?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Peak Lists > CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?

This command queries the position of the peaks on the y-axis.

The order depends on the sort order that has been set with CALCulate<n>:​MARKer<m>:​FUNCtion:​FPEaks:​SORT.

Return values:
<PeakPosition> | Position of the peaks on the y-axis. The unit depends on the measurement.
Usage: | Query only


Noise Measurement Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Noise Measurement Marker
Noise Measurement Marker

The following commands control the noise measurement marker function.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:NOISe:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NOISe[:STATe]


CALCulate<n>:MARKer<m>:FUNCtion:NOISe:RESult?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Noise Measurement Marker > CALCulate<n>:MARKer<m>:FUNCtion:NOISe:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NOISe:RESult?

This command queries the result of the noise measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<NoiseLevel> | Current noise level. The unit is the one currently active.
Example: | INIT:CONT OFF Switches to single sweep mode. CALC:MARK2 ON Switches on marker 2. CALC:MARK:FUNC:NOIS ON Switches on noise measurement. INIT;*WAI Starts a sweep and waits for the end. CALC:MARK2:NOIS:RES? Outputs the noise result of marker 2.
Usage: | Query only
Manual operation: | See "Noise Measurement State"


CALCulate<n>:MARKer<m>:FUNCtion:NOISe[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Noise Measurement Marker > CALCulate<n>:MARKer<m>:FUNCtion:NOISe[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:NOISe[:STATe] <State>

This command turns the noise measurement at the marker position on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:NOIS ON

Switches on the noise measurement.

Manual operation: See "Noise Measurement State"
See "Switching All Noise Measurements Off"


Phase Noise Measurement Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Phase Noise Measurement Marker
Phase Noise Measurement Marker

The following commands control the phase noise measurement marker function.

Useful commands for phase noise markers described elsewhere
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​MAXimum[:​PEAK]
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​X
  • CALCulate<n>:​DELTamarker<m>:​FUNCtion:​FIXed:​RPOint:​Y
Remote commands exclusive to phase noise markers
List of Commands
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]


CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Phase Noise Measurement Marker > CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO <State>

This command turns an automatic peak search for the fixed reference marker at the end of a sweep on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT:FUNC:PNO:AUTO ON

Activates an automatic peak search for the reference marker in a phase-noise measurement.

Manual operation: See "Defining a Reference Point"


CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Phase Noise Measurement Marker > CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?

This command queries the result of a phase noise measurement.

If necessary, the command activates the measurement first.

Return values:
<PhaseNoise> |
Example: | CALC:DELT2:FUNC:PNO:RES? Outputs the result of phase-noise measurement of the deltamarker 2.
Usage: | Query only
Manual operation: | See "Phase Noise Measurement State"


CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Phase Noise Measurement Marker > CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe] <State>

This command turns the phase noise measurement at the delta marker position on and off.

The reference marker for phase noise measurements is either a normal marker or a fixed reference. If necessary, the command turns on the reference marker.

The correction values for the bandwidth and the log amplifier are taken into account in the measurement.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT:FUNC:PNO ON

Switches on the phase-noise measurement with all delta markers.

CALC:DELT:FUNC:FIX:RPO:X 128 MHZ

Sets the frequency reference to 128 MHz.

CALC:DELT:FUNC:FIX:RPO:Y 30 DBM

Sets the reference level to +30 dBm

Manual operation: See "Phase Noise Measurement State"
See "Switching All Phase Noise Measurements Off"


Band Power Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker
Band Power Marker

The following commands control the marker for band power measurements.

Contents
  • Using Markers
  • Using Delta Markers


Using Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Markers
Using Markers
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:MODE
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:SPAN
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer[:STATe]


CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:MODE

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Markers > CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:MODE
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:MODE <Mode>

This command selects the way the results for a band power marker are displayed.

Parameters:
<Mode>
POWer

Result is displayed as a power in dBm.

DENSity

Result is displayed as a density in dBm/Hz.

*RST: POWer
Example: CALC:MARK4:FUNC:BPOW:MODE DENS

Configures marker 4 to show the measurement results in dBm/Hz.

Manual operation: See "Power Mode"


CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:RESult?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Markers > CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:RESult?

This command queries the results of the band power measurement.

Return values:
<Power> | Signal power over the marker bandwidth.
Example: | Activate the band power marker: CALC:MARK:FUNC:BPOW:STAT ON Select the density mode for the result: CALC:MARK:FUNC:BPOW:MODE DENS Query the result: CALC:MARK:FUNC:BPOW:RES? Response: 20dBm/Hz
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:SPAN

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Markers > CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:SPAN
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:SPAN <Span>

This command defines the bandwidth around the marker position.

Parameters:
<Span>

Frequency. The maximum span depends on the marker position and R&S FSW model.

*RST: | 5% of current span
Default unit: | Hz
Example: CALC:MARK:FUNC:BPOW:SPAN 2MHz

Measures the band power over 2 MHz around the marker.

Manual operation: See "Span"


CALCulate<n>:MARKer<m>:FUNCtion:BPOWer[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Markers > CALCulate<n>:MARKer<m>:FUNCtion:BPOWer[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer[:STATe] <State>

This command turns markers for band power measurements on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK4:FUNC:BPOW:STAT ON

Activates or turns marker 4 into a band power marker.

Manual operation: See "Band Power Measurement State"
See "Switching All Band Power Measurements Off"


Using Delta Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Delta Markers
Using Delta Markers
List of Commands
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:MODE
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:SPAN
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer[:STATe]


CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:MODE

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Delta Markers > CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:MODE
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:MODE <Mode>

This command selects the way the results for a band power delta marker are displayed.

Parameters:
<Mode>
POWer

Result is displayed as a power in dBm.

DENSity

Result is displayed as a density in dBm/Hz.

*RST: POWer


CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:RESult?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Delta Markers > CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:RESult?

This command queries the results of the band power measurement.

Return values:
<Power> | Signal power over the delta marker bandwidth.
Usage: | Query only


CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:SPAN

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Delta Markers > CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:SPAN
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:SPAN <Span>

This command defines the bandwidth around the delta marker position.

Parameters:
<Span>

Frequency. The maximum span depends on the marker position and R&S FSW model.

*RST: | 5% of current span
Default unit: | Hz


CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Band Power Marker > Using Delta Markers > CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer[:STATe] <State>

This command turns delta markers for band power measurements on and off.

If neccessary, the command also turns on a reference marker.

Parameters:
<State>
ON | OFF
*RST: OFF


n dB Down Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > n dB Down Marker
n dB Down Marker

The following commands control the n dB down markers.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?
CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown <Distance>

This command defines the distance of the n dB down markers to the reference marker.

Parameters:
<Distance>

Distance of the temporary markers to the reference marker in dB.

For a positive offset, the markers T1 and T2 are placed below the active reference point.

For a negative offset (for example for notch filter measurements), the markers T1 and T2 are placed above the active reference point.

*RST: 6dB
Example: CALC:MARK:FUNC:NDBD 3dB

Sets the distance to the reference marker to 3 dB.


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?

This command queries the position of the n dB down markers on the x-axis when measuring in the frequency domain.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Frequency> | <frequency 1> absolute frequency of the n dB marker to the left of the reference marker in Hz <frequency 2> absolute frequency of the n dB marker to the right of the reference marker in Hz.
Example: | INIT:CONT OFF Switches to single sweep mode. CALC:MARK:FUNC:NDBD ON Switches on the n dB down function. INIT;*WAI Starts a sweep and waits for the end. CALC:MARK:FUNC:NDBD:FREQ? This command would return, for example, 100000000, 200000000, meaning that the first marker position is at 100 MHz, the second marker position is at 200 MHz
Usage: | Query only
Manual operation: | See "n dB down Delta Value"


CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > n dB Down Marker > CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?
CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?

This command queries the Q factor of n dB down measurements.

Return values:
<QFactor> |
Usage: | Query only


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?

This command queries the distance of the n dB down markers from each other.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Distance>

The result depends on the span.

In case of frequency domain measurements, the command returns the bandwidth between the two n dB down markers in Hz.

In case of time domain measurements, the command returns the pulse width between the two n dB down markers in seconds.

Example: INIT:CONT OFF

Switches to single sweep mode.

CALC:MARK:FUNC:NDBD ON

Switches on the n dB down function.

INIT;*WAI

Starts a sweep and waits for the end.

CALC:MARK:FUNC:NDBD:RES?

Outputs the measured value.

Usage: Query only
Manual operation: See "n dB down Marker State"


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe <State>

This command turns the n dB Down marker function on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK:FUNC:NDBD:STAT ON

Turns the n dB Down marker on.

Manual operation: See "n dB down Marker State"


CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > n dB Down Marker > CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?

This command queries the position of the n dB down markers on the x-axis when measuring in the time domain.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<TimeX1> | absolute position in time of the n dB marker to the left of the reference marker in seconds
<TimeX2> | absolute position in time of the n dB marker to the right of the reference marker in seconds
Example: | INIT:CONT OFF Switches to single sweep mode CALC:MARK:FUNC:NDBD ON Switches on the n dB down function. INIT;*WAI Starts a sweep and waits for the end. CALC:MARK:FUNC:NDBD:TIME? Outputs the time values of the temporary markers.
Usage: | Query only
Manual operation: | See "n dB down Delta Value"


Signal Count Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Signal Count Marker
Signal Count Marker

The following commands control the frequency counter.

List of Commands
CALCulate<n>:MARKer<m>:COUNt
CALCulate<n>:MARKer<m>:COUNt:FREQuency?
CALCulate<n>:MARKer<m>:COUNt:RESolution


CALCulate<n>:MARKer<m>:COUNt

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Signal Count Marker > CALCulate<n>:MARKer<m>:COUNt
CALCulate<n>:MARKer<m>:COUNt <State>

This command turns the frequency counter at the marker position on and off.

The frequency counter works for one marker only. If you perform a frequency count with another marker, the R&S FSW deactivates the frequency count of the first marker.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INIT:CONT OFF

Switches to single sweep mode.

CALC:MARK ON

Switches on marker 1.

CALC:MARK:COUN ON

Switches on the frequency counter for marker 1.

INIT;*WAI

Starts a sweep and waits for the end.

CALC:MARK:COUN:FREQ?

Outputs the measured value.

Manual operation: See "Signal Count Marker State"


CALCulate<n>:MARKer<m>:COUNt:FREQuency?

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Signal Count Marker > CALCulate<n>:MARKer<m>:COUNt:FREQuency?
CALCulate<n>:MARKer<m>:COUNt:FREQuency?

This command queries the frequency at the marker position.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Before you can use the command, you have to turn on the frequency counter.

Return values:
<Frequency> | Frequency at the marker position.
Example: | INIT:CONT OFF Switches to single sweep mode. CALC:MARK ON Switches on marker 2. CALC:MARK:COUN ON Activates the frequency counter for marker 1. INIT;*WAI Starts a sweep and waits for the end. CALC:MARK:COUN:FREQ? Outputs the measured value of marker 1.
Usage: | Query only
Manual operation: | See "Signal Count Marker State"


CALCulate<n>:MARKer<m>:COUNt:RESolution

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Signal Count Marker > CALCulate<n>:MARKer<m>:COUNt:RESolution
CALCulate<n>:MARKer<m>:COUNt:RESolution <Resolution>

This command defines the resolution of the frequency counter.

Parameters:
<Resolution>
0.001 | 0.01 | 0.1 | 1 | 10 | 100 | 1000 | 10000 Hz
*RST: 0.1 Hz
Example: CALC:MARK:COUN:RES 1kHz

Sets the resolution of the frequency counter to 1 kHz.

Manual operation: See "Resolution"


Marker Demodulation

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Demodulation
Marker Demodulation

The following commands control the demodulation of AM and FM signals at the marker position.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:CONTinuous
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:HOLDoff
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:SELect
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation[:STATe]
[SENSe:]DEMod:SQUelch:LEVel
[SENSe:]DEMod:SQUelch[:STATe]


CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:CONTinuous

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Demodulation > CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:CONTinuous
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:CONTinuous <State>

This command turns continuous demodulation of the signal at the marker position in the frequency domain on and off.

In the time domain continuous demodulation is always on.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC2:MARK3:FUNC:DEM:CONT ON

Switches on the continuous demodulation.

Manual operation: See "Continuous Demodulation"


CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:HOLDoff

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Demodulation > CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:HOLDoff
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:HOLDoff <Duration>

This command defines for how long the the signal at the marker position is demodulated.

In the time domain continuous demodulation is always on.

Parameters:
<Duration>
Range: | 10 ms to 1000 s
*RST: | Marker demodulation = OFF
Example: CALC:MARK:FUNC:DEM:HOLD 3s
Manual operation: See "Marker Stop Time"


CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:SELect

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Demodulation > CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:SELect
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:SELect <DemodMode>

This command selects the demodulation mode at the marker position.

Parameters:
<DemodMode>
AM

AM demodulation

FM

FM demodulation

*RST: AM
Example: CALC:MARK:FUNC:DEM:SEL FM
Manual operation: See "Modulation"


CALCulate<n>:MARKer<m>:FUNCtion:DEModulation[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Demodulation > CALCulate<n>:MARKer<m>:FUNCtion:DEModulation[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation[:STATe] <State>

This command turns the audio demodulator on and off when the measurement reaches a marker position.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3:FUNC:DEM ON

Switches on the demodulation for marker 3.

Example:

See "Programming Example: EMI Measurement".

Manual operation: See "Marker Demodulation State"


[SENSe:]DEMod:SQUelch:LEVel

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Demodulation > [SENSe:]DEMod:SQUelch:LEVel
[SENSe:]DEMod:SQUelch:LEVel <Threshold>

This command defines the threshold for selective demodulation.

All signals below the threshold are not demodulated.

Parameters:
<Threshold>

Percentage of the display height.

Range: | 0 to 100
*RST: | 50
Example: DEM:SQU:LEV 80

Sets the squelch level to 80% of the displayed signal.

Manual operation: See "Squelch level"


[SENSe:]DEMod:SQUelch[:STATe]

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Marker Demodulation > [SENSe:]DEMod:SQUelch[:STATe]
[SENSe:]DEMod:SQUelch[:STATe] <State>

This command turns selective demodulation at the marker position on and off.

For selective demodulation, the R&S FSW turns on a video trigger whose level correponds to the squelch level. Therefore it turns other triggers or gates off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DEM:SQU ON

Signals below the level threshold are not sent to the audio output.

Manual operation: See "Squelch"


Programming Examples for Using Markers and Marker Functions

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions
Programming Examples for Using Markers and Marker Functions

Various programming examples on how to use markers and the special marker functions are provided here.

The use of spectrogram markers is demonstrated in "Programming Example: Configuring a Spectrogram".

Contents
  • Example: Basic Markers
  • Example: Marker Search in Spectrograms
  • Basic Frequency Sweep Measurement for Marker Function Examples
  • Example: Using a Fixed Reference Marker
  • Example: Obtaining a Marker Peak List
  • Example: Measuring Noise Density
  • Example: Measuring Phase Noise
  • Example: Measuring the Power in a Channel Using Band Power Markers
  • Example: Measuring Characteristic Bandwidths (Using the n dB Down Marker)
  • Examples: Demodulating Marker Values and Providing Audio Output
  • Example: Performing a Highly Accurate Frequency Measurement Using the Signal Count Marker


Example: Basic Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Basic Markers
Example: Basic Markers

This example demonstrates how to configure and define markers for a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Programming Example: Performing a Basic Frequency Sweep" has been performed and thus does not begin by presetting the instrument.

//--------------Configuring marker behavior ------------------
DISP:MTAB ON
//Marker information is always displayed in a separate table.
CALC:MARK:X:SSIZ STAN
//The marker moves from one pixel to the next instead of sweep points in manual op.
CALC:MARK:PEXC 6dB
//Defines a peak excursion of 6 dB.
CALC:MARK:X:SLIM ON
CALC:MARK:X:SLIM:LEFT 50MHz
CALC:MARK:X:SLIM:RIGH 150MHz
//Restricts the search area for peaks to the frequencies between 50 and 150 MHz.
CALC:THR -100dBm
CALC:THR:STAT ON
//Configures a threshold level for peak searches at -100 dBm.

//--------------Defining and positioning markers -------------
CALC:MARK1 ON
//Activates marker 1 and sets it to the peak of trace 1.
CALC:MARK2:TRAC 2
//Activates marker 2 and sets it to the peak of trace 2.
CALC:MARK3:X 150MHz
//Activates marker 3 and sets it to the freq. 150 MHz  on trace 1.
CALC:MARK4:TRAC 4
//Activates marker 4 and sets it to the peak of trace 4.

CALC:MARK1:MAX:AUTO ON
//Moves M1 to the current peak of trace 1 after each sweep.
CALC:MARK2:MAX:NEXT
//Moves M2 to the next lower peak of trace 2.

CALC:DELT5 ON
CALC:DELT5:LINK ON
//Activates delta marker 5 and links it to marker 1. If M1 moves, so does D5.
CALC:DELT5:MREF 4
//Changes the reference for D5 to marker 4. D5 now shows the difference between
//the peak of trace 1 after each sweep and the value at the same position in
//trace 4, which is a copy of trace 1, averaged over 10 sweeps.
CALC:DELT5:MODE REL
//Shows the difference as relative values.

CALC:DELT6 ON
CALC:DELT6:MAX:NEXT
//Activates delta marker 6 and sets it to the next lower maximum of trace 1.
//Thus it shows the difference between the two highest peaks in trace 1.

//--------------Retrieving marker values ---------------------
CALC:MARK1:Y?
CALC:MARK2:Y?
CALC:MARK3:Y?
CALC:MARK4:Y?
CALC:DELT5:Y?
CALC:DELT6:Y?
//Retrieves the marker levels of each active normal and delta marker.
CALC:DELT5:X:REL?
CALC:DELT6:X:REL?
//Retrieves the frequency difference between the delta marker and marker 1.

//--------------Deactivating all markers ---------------------
//CALC:MARK:AOFF
//CALC:DELT:AOFF


Example: Marker Search in Spectrograms

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Marker Search in Spectrograms
Example: Marker Search in Spectrograms

This example demonstrates how to search for peak values in spectrograms in a remote environment. It assumes a spectrogram is already available (see "Programming Example: Configuring a Spectrogram") and thus does not begin by presetting the instrument.

//---------------- Analyzing the results using markers -------------------
//Set marker1 on the peak power in the most recent spectrum and query
//its position
CALC2:SPEC:FRAM:SEL 0
CALC2:MARK1 ON
CALC2:MARK1:X?
CALC2:MARK1:Y?

//Set marker2 on the peak power in frame at -324ms and query its position
CALC2:MARK2 ON
CALC2:MARK2:SGR:FRAM -324ms
CALC2:MARK2:X?
CALC2:MARK2:Y?

//Set marker3 on peak power level in the entire spectrogram in memory and
//query its position
CALC2:MARK3 ON
CALC2:MARK:SPEC:SAR MEM
CALC2:MARK3:SPEC:XY:MAX
CALC2:MARK3:X?
CALC2:MARK3:Y?

//Move marker 3 to the next lower peak level for the same frequency
CALC2:MARK3:SPEC:Y:MAX:NEXT
CALC2:MARK3:X?
CALC2:MARK3:Y?

//Set marker 4 to the highest level in the (visible) spectrogram.
CALC2:MARK:SPEC:SAR VIS
CALC2:MARK4:SPEC:XY:MAX
//Move marker 4 to the next higher level in the frames above its current position.
CALC2:MARK4:SPEC:Y:MAX:ABOV


Basic Frequency Sweep Measurement for Marker Function Examples

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Basic Frequency Sweep Measurement for Marker Function Examples
Basic Frequency Sweep Measurement for Marker Function Examples

Since markers can only be placed on an existing trace, the following example provides a simple frequency sweep measurement to be used as a basis for the subsequent marker function scripts.

//-------------- Configuring the basic frequency sweep -------------
*RST
//Resets the instrument
INIT:CONT OFF
//Selects single sweep mode.
FREQ:CENT 100MHz
//Defines the center frequency
FREQ:SPAN 200MHz
//Sets the span to 100 MHz on either side of the center frequency.
DISP:TRAC1:Y:RLEV 0dBm
//Sets the reference level to 0 dBm.

//------- Performing the measurement -------------------------
INIT;*WAI
//Performs a measurement and waits for it to end


Example: Using a Fixed Reference Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Using a Fixed Reference Marker
Example: Using a Fixed Reference Marker

This example demonstrates how to configure and use reference markers in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Basic Frequency Sweep Measurement for Marker Function Examples" has been performed and thus does not begin by presetting the instrument.

//-----------Configuring the reference marker ------------
//Activate a fixed reference marker. It is set to the current maximum of trace 1.
CALC:DELT:FUNC:FIX ON
//Set the reference frequency to 128 MHz.
CALC:DELT:FUNC:FIX:RPO:X 128 MHZ
//Set the reference level to +30 dBm.
CALC:DELT:FUNC:FIX:RPO:Y 30 DBM

//Use the fixed reference marker as a reference for deltamarker 2
CALC:DELT2:MREF FIX

//Reset the reference marker to the current maximum of trace 1
CALC:DELT:FUNC:FIX:RPO:MAX
//Query the new position of the reference marker
CALC:DELT:FUNC:FIX:RPO:X?
CALC:DELT:FUNC:FIX:RPO:Y?


Example: Obtaining a Marker Peak List

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Obtaining a Marker Peak List
Example: Obtaining a Marker Peak List

This example demonstrates how to obtain a marker peak list in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Basic Frequency Sweep Measurement for Marker Function Examples" has been performed and thus does not begin by presetting the instrument.

In this example, the peak search is restricted to the frequency range of 50 MHz to 150 MHz. The top 5 power levels with a peak excursion of 10dB and a minimum of -100 dBm are to be determined and displayed with their marker numbers. The results are sorted by frequency values. The resulting peak list is then exported to a file.

//----------- Configuring the peak search ------------
CALC:MARK:X:SLIM ON
CALC:MARK:X:SLIM:LEFT 50MHz
CALC:MARK:X:SLIM:RIGH 150MHz
CALC:MARK:PEXC 10DB
CALC:THR -100DBM
CALC:THR:STAT ON

CALC:MARK:FUNC:FPE:STAT ON
CALC:MARK:FUNC:FPE:LIST:SIZE 5
CALC:MARK:FUNC:FPE:SORT X
CALC:MARK:FUNC:FPE:ANN:LAB ON

//--------------- Retrieving results -------------
CALC:MARK:FUNC:FPE:COUN?
CALC:MARK:FUNC:FPE:X?
CALC:MARK:FUNC:FPE:Y?

//------------ Exporting the peak list ------------
MMEM:STOR:PEAK 'PeakList'


Example: Measuring Noise Density

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Measuring Noise Density
Example: Measuring Noise Density

This example demonstrates how to measure noise density using noise markers in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Basic Frequency Sweep Measurement for Marker Function Examples" has been performed and thus does not begin by presetting the instrument.

CALC:MARK1:FUNC:NOIS ON
//Switches on noise measurement at marker 1.

INIT;*WAI
//Performs a measurement and waits for it to end

CALC:MARK1:FUNC:NOIS:RES?
//Queries the measured noise level (per Hz bandwidth)


Example: Measuring Phase Noise

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Measuring Phase Noise
Example: Measuring Phase Noise

This example demonstrates how to measure phase noise using markers in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Basic Frequency Sweep Measurement for Marker Function Examples" has been performed and thus does not begin by presetting the instrument.

//------------- Configuring the phase noise marker -------------------
DET SAMP
//Switches to Sample detector

CALC:MARK1 ON
//Activates marker1 and sets it to the maximum power level

CALC:DELT:FUNC:PNO ON
//Activates phase noise marker function

CALC:DELT1 ON
CALC:DELT1:X 100kHz

CALC:DELT2 ON
CALC:DELT2:X 500kHz

CALC:DELT3 ON
CALC:DELT3:X 1MHz

CALC:DELT4 ON
CALC:DELT4:X 1.5MHz

//Activates the phase noise measurement function for offsets 100kHz/500kHz/1MHz/1.5MHz.

BAND:VID?
//Queries the used VBW (= 0.1*RBW)

//-------- Querying the phase noise results ------------------------------

CALC:DELT1:FUNC:PNO:RES?
CALC:DELT2:FUNC:PNO:RES?
CALC:DELT3:FUNC:PNO:RES?
CALC:DELT4:FUNC:PNO:RES?
//Queries the difference in level between the peak and the noise power density
//measured at the deltamarkers, referred to the carrier power level (dBc)


Example: Measuring the Power in a Channel Using Band Power Markers

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Measuring the Power in a Channel Using Band Power Markers
Example: Measuring the Power in a Channel Using Band Power Markers

This example demonstrates how to measure the power in a specific channel or band using markers in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Basic Frequency Sweep Measurement for Marker Function Examples" has been performed and thus does not begin by presetting the instrument.

//------------- Configuring the band power marker -------------------
CALC:MARK1 ON
//Activates marker1 and sets it to the maximum power level
CALC:MARK1:FUNC:BPOW:STAT ON
//Activates the band power measurement for the band around marker 1
CALC:MARK1:FUNC:BPOW:SPAN 30MHz
//Sets the bandwidth to be measured to 30 MHz
CALC:MARK1:FUNC:BPOW:MODE DENS
//Sets the result to be a density (power per Hz bandwidth)

CALC:DELT2 ON
//Activates deltamarker2
CALC:DELT2:FUNC:BPOW:STAT ON
//Activates the band power measurement for the band around deltamarker 2
CALC:DELT2:FUNC:BPOW:SPAN 30MHz
//Sets the bandwidth to be measured to 30 MHz
CALC:DELT2:FUNC:BPOW:MODE DENS
//Sets the result to be a density (power per Hz bandwidth)

CALC:DELT3 ON
//Activates deltamarker3
CALC:DELT3:FUNC:BPOW:STAT ON
//Activates the band power measurement for the band around deltamarker 3
CALC:DELT3:FUNC:BPOW:SPAN 30MHz
//Sets the bandwidth to be measured to 30 MHz
CALC:DELT3:FUNC:BPOW:MODE DENS
//Sets the result to be a density (power per Hz bandwidth)

//---------------Retrieving Results-------------
CALC:MARK1:FUNC:BPOW:RES?
//Returns the power sum for the specified bandwidth around marker 1.
CALC:DELT2:FUNC:BPOW:RES?
//Returns the power sum for the specified bandwidth around deltamarker 2.
CALC:DELT3:FUNC:BPOW:RES?
//Returns the power sum for the specified bandwidth around deltamarker 3.


Example: Measuring Characteristic Bandwidths (Using the n dB Down Marker)

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Measuring Characteristic Bandwidths (Using the n dB Down Marker)
Example: Measuring Characteristic Bandwidths (Using the n dB Down Marker)

This example demonstrates how to measure a characteristic bandwidth using markers in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Programming Example: Performing a Basic Frequency Sweep" has been performed and thus does not begin by presetting the instrument.

//------------- Configuring the n dB down marker -------------------
CALC:MARK1 ON
//Activates marker1 and sets it to the maximum power level
CALC:MARK1:FUNC:NDBD 3DB
//Sets the level offset to 3 dB
CALC:MARK1:FUNC:NDBD:STAT ON
//Activates the n dB down measurement

//---------------Retrieving Results-------------
CALC:MARK:FUNC:NDBD:RES?
//Returns the bandwidth at the specified power offset.
CALC:MARK:FUNC:NDBD:FREQ?
//Returns the frequencies of the temporary markers at the power offsets
CALC:MARK:FUNC:NDBD:QFAC?
//Returns the quality factor of the resulting bandwidth


Examples: Demodulating Marker Values and Providing Audio Output

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Examples: Demodulating Marker Values and Providing Audio Output
Examples: Demodulating Marker Values and Providing Audio Output

The following examples demonstrate how to demodulate markers and provide audio output in a remote environment.

Contents
  • Example: Providing Audio Output for Individual Marker Values
  • Example: Demodulating and Providing Audio Output Continuously


Example: Providing Audio Output for Individual Marker Values

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Examples: Demodulating Marker Values and Providing Audio Output > Example: Providing Audio Output for Individual Marker Values
Example: Providing Audio Output for Individual Marker Values

This example demonstrates how to demodulate markers and provide audio output in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Programming Example: Performing a Basic Frequency Sweep" has been performed and thus does not begin by presetting the instrument.

Audio output is provided for 5s each time the signal reaches its initial maximum, however only if it is higher than -90 dBm (10% of the total y-axis range) in order to ignore noise.

//------------- Configuring the marker demodulation -------------------
CALC:MARK1 ON
//Activates marker1 and sets it to the maximum power level
CALC:MARK1:FUNC:DEM:SEL FM
//Selects FM demodulation
CALC:MARK1:FUNC:DEM:HOLD 5s
//Defines an output duration of 5s
DEM:SQU:LEV 10
//Sets a squelch level for noise
DEM:SQU ON
//Activates squelching
CALC:MARK1:FUNC:DEM ON
//Activates demodulation

//------- Performing the measurement -------------------------
INIT;*WAI
//Performs a measurement and waits for it to end

//---------------Retrieving Results-------------
//Results are only provided as audio output!


Example: Demodulating and Providing Audio Output Continuously

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Examples: Demodulating Marker Values and Providing Audio Output > Example: Demodulating and Providing Audio Output Continuously
Example: Demodulating and Providing Audio Output Continuously

This example demonstrates how to demodulate markers and provide audio output in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Programming Example: Performing a Basic Frequency Sweep" has been performed and thus does not begin by presetting the instrument.

//------------- Configuring the marker demodulation -------------------
CALC:MARK1 ON
//Activates marker1
CALC:MARK1:FUNC:DEM:SEL FM
//Selects FM demodulation
DEM:SQU:LEV 10
//Sets a squelch level for noise
DEM:SQU ON
//Activates squelching
CALC:MARK1:FUNC:DEM:CONT ON
//Activates continuous demodulation

//------- Performing the measurement -------------------------
INIT:CONT ON
//Performs a measurement and provides continuous audio output

//---------------Retrieving Results-------------
//Results are only provided as audio output!


Example: Performing a Highly Accurate Frequency Measurement Using the Signal Count Marker

Remote Commands > Analyzing Measurements (Basics) > Working with Markers > Programming Examples for Using Markers and Marker Functions > Example: Performing a Highly Accurate Frequency Measurement Using the Signal Count Marker
Example: Performing a Highly Accurate Frequency Measurement Using the Signal Count Marker

This example demonstrates how to determine highly accurate frequency values using signal count markers in a basic spectrum measurement in a remote environment. It assumes that the basic frequency sweep described in "Programming Example: Performing a Basic Frequency Sweep" has been performed and thus does not begin by presetting the instrument.

//------------- Configuring the signal count marker -------------------
CALC:MARK1 ON
//Activates marker1
CALC:MARK1:COUN ON
//Switches on the frequency counter for marker 1.
CALC:MARK1:COUN:RES 1kHz
//Sets the resolution of the frequency counter to 1kHz

//------- Performing the measurement -------------------------
INIT;*WAI
//Performs a measurement and waits for it to end

//---------------Retrieving Results-------------
CALC:MARK1:COUN:FREQ?
//Returns the signal counter value as the precise marker frequency.


Configuring Display and Limit Lines

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines
Configuring Display and Limit Lines

The commands required to configure display and limit lines in a remote environment are described here. The tasks for manual operation are described in "How to Work with Display and Limit Lines".

Contents
  • Configuring Display Lines
  • Defining Limit Checks


Configuring Display Lines

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Configuring Display Lines
Configuring Display Lines

The following commands configure vertical and horizontal display lines.

List of Commands
CALCulate<n>:DLINe<k>
CALCulate<n>:DLINe<k>:STATe
CALCulate<n>:FLINe<k>
CALCulate<n>:FLINe<k>:STATe
CALCulate<n>:TLINe<Line>
CALCulate<n>:TLINe<Line>:STATe


CALCulate<n>:DLINe<k>

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Configuring Display Lines > CALCulate<n>:DLINe<k>
CALCulate<n>:DLINe<k> <Position>

This command defines the (vertical) position of a display line.

Parameters:
<Position>

The value range is variable.

You can use any unit you want, the R&S FSW then converts the unit to the currently selected unit. If you omit a unit, the R&S FSW uses the currently selected unit.

*RST: (state is OFF)
Example: CALC:DLIN -20dBm

Positions the display line at -20 dBm.

Manual operation: See "Horizontal Line 1/2"


CALCulate<n>:DLINe<k>:STATe

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Configuring Display Lines > CALCulate<n>:DLINe<k>:STATe
CALCulate<n>:DLINe<k>:STATe <State>

This command turns a display line on and off

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DLIN2:STAT ON

Turns on display line 2.


CALCulate<n>:FLINe<k>

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Configuring Display Lines > CALCulate<n>:FLINe<k>
CALCulate<n>:FLINe<k> <Frequency>

This command defines the position of a frequency line.

Parameters:
<Frequency>

Note that you can not set a frequency line to a position that is outside the current span.

Range: | 0 Hz to Fmax
*RST: | (STATe to OFF)
Example: CALC:FLIN2 120MHz

Sets frequency line 2 to a frequency of 120 MHz.

Manual operation: See "Vertical Line 1/2"


CALCulate<n>:FLINe<k>:STATe

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Configuring Display Lines > CALCulate<n>:FLINe<k>:STATe
CALCulate<n>:FLINe<k>:STATe <State>

This command turns a frequency line on and off

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:FLIN2:STAT ON

Turns frequency line 2 on.


CALCulate<n>:TLINe<Line>

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Configuring Display Lines > CALCulate<n>:TLINe<Line>
CALCulate<n>:TLINe<Line> <Time>

This command defines the position of a time line.

Parameters:
<Time>

Note that you can not set a time line to a position that is higher than the current sweep time.

Range: | 0 s to 1600 s
*RST: | (STATe to OFF)
Example: CALC:TLIN 10ms

Sets the first time line to 10 ms.

Manual operation: See "Vertical Line 1/2"


CALCulate<n>:TLINe<Line>:STATe

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Configuring Display Lines > CALCulate<n>:TLINe<Line>:STATe
CALCulate<n>:TLINe<Line>:STATe <State>

This command turns a time line on and off

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:TLIN:STAT ON

Turns the first time line on.


Defining Limit Checks

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks
Defining Limit Checks

Note that in remote control, upper and lower limit lines are configured using separate commands. Thus, you must decide in advance which you want to configure. The x-values for both upper and lower limit lines are defined as a common control line. This control line is the reference for the y-values for both upper and lower limit lines.

Contents
  • Configuring Limit Lines
  • Managing Limit Lines
  • Checking the Results of a Limit Check
  • Programming Example: Using Limit Lines


Configuring Limit Lines

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines
Configuring Limit Lines
List of Commands
CALCulate:LIMit:COMMent
CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:CONTrol:DOMain
CALCulate:LIMit<k>:CONTrol:MODE
CALCulate:LIMit<k>:CONTrol:OFFSet
CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:CONTrol:SPACing
CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:LOWer:MARGin
CALCulate:LIMit<k>:LOWer:MODE
CALCulate:LIMit<k>:LOWer:OFFSet
CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:SPACing
CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:LOWer:THReshold
CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:UNIT
CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:LIMit<k>:UPPer:MARGin
CALCulate:LIMit<k>:UPPer:MODE
CALCulate:LIMit<k>:UPPer:OFFSet
CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:SPACing
CALCulate:LIMit<k>:UPPer:STATe
CALCulate:LIMit<k>:UPPer:THReshold


CALCulate:LIMit:COMMent

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit:COMMent
CALCulate:LIMit:COMMent <Comment>

This command defines a comment for a limit line.

Parameters:
<Comment> | String containing the description of the limit line. The comment may have up to 40 characters.
Manual operation: | See "Comment"


CALCulate:LIMit<k>:CONTrol[:DATA]

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:CONTrol[:DATA] <LimitLinePoints>

This command defines the horizontal definition points of a limit line.

Parameters:
<LimitLinePoints>

Variable number of x-axis values.

Note that the number of horizontal values has to be the same as the number of vertical values set with CALCulate:​LIMit<k>:​LOWer[:​DATA] or CALCulate:​LIMit<k>:​UPPer[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

The unit is Hz or s.

*RST: -
Usage: SCPI confirmed
Manual operation: See "Data points"


CALCulate:LIMit<k>:CONTrol:DOMain

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:CONTrol:DOMain
CALCulate:LIMit<k>:CONTrol:DOMain <SpanSetting>

This command selects the domain of the limit line.

Parameters:
<SpanSetting>
FREQuency | TIME
*RST: FREQuency
Manual operation: See "X-Axis"


CALCulate:LIMit<k>:CONTrol:MODE

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:CONTrol:MODE
CALCulate:LIMit<k>:CONTrol:MODE <Mode>

This command selects the horizontal limit line scaling.

Parameters:
<Mode>
ABSolute

Limit line is defined by absolute physical values (Hz or s).

RELative

Limit line is defined by relative values related to the center frequency (frequency domain) or the left diagram border (time domain).

*RST: ABSolute


CALCulate:LIMit<k>:CONTrol:OFFSet

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:CONTrol:OFFSet
CALCulate:LIMit<k>:CONTrol:OFFSet <Offset>

This command defines an offset for a complete limit line.

Compared to shifting the limit line, an offset does not actually change the limit line definition points.

Parameters:
<Offset>

Numeric value.

The unit depends on the scale of the x-axis.

*RST: 0
Manual operation: See "X-Offset"


CALCulate:LIMit<k>:CONTrol:SHIFt

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:CONTrol:SHIFt <Distance>

This command moves a complete limit line horizontally.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Numeric value. The unit depends on the scale of the x-axis.
Manual operation: | See "Shift x"


CALCulate:LIMit<k>:CONTrol:SPACing

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:CONTrol:SPACing
CALCulate:LIMit<k>:CONTrol:SPACing <InterpolMode>

This command selects linear or logarithmic interpolation for the calculation of limit lines from one horizontal point to the next.

Parameters:
<InterpolMode>
LINear | LOGarithmic
*RST: LIN
Example: CALC:LIM:CONT:SPAC LIN


CALCulate:LIMit<k>:LOWer[:DATA]

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:LOWer[:DATA] <LimitLinePoints>

This command defines the vertical definition points of a lower limit line.

Parameters:
<LimitLinePoints>

Variable number of level values.

Note that the number of vertical values has to be the same as the number of horizontal values set with CALCulate:​LIMit<k>:​CONTrol[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

The unit depends on CALCulate:​LIMit<k>:​UNIT.

*RST: Limit line state is OFF
Usage: SCPI confirmed
Manual operation: See "Data points"


CALCulate:LIMit<k>:LOWer:MARGin

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer:MARGin
CALCulate:LIMit<k>:LOWer:MARGin <Margin>

This command defines an area around a lower limit line where limit check violations are still tolerated.

Parameters:
<Margin>
numeric value
*RST: | 0
Default unit: | dB
Manual operation: See "Margin"


CALCulate:LIMit<k>:LOWer:MODE

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer:MODE
CALCulate:LIMit<k>:LOWer:MODE <Mode>

This command selects the vertical limit line scaling.

Parameters:
<Mode>
ABSolute

Limit line is defined by absolute physical values.

The unit is variable.

RELative

Limit line is defined by relative values related to the reference level (dB).

*RST: ABSolute
Manual operation: See "X-Axis"


CALCulate:LIMit<k>:LOWer:OFFSet

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer:OFFSet
CALCulate:LIMit<k>:LOWer:OFFSet <Offset>

This command defines an offset for a complete lower limit line.

Compared to shifting the limit line, an offset does not actually change the limit line definition points.

Parameters:
<Offset>
Numeric value.
*RST: | 0
Default unit: | dB
Manual operation: See "Y-Offset"


CALCulate:LIMit<k>:LOWer:SHIFt

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:SHIFt <Distance>

This command moves a complete lower limit line vertically.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Defines the distance that the limit line moves. The unit depends on CALCulate:​LIMit<k>:​UNIT.
Manual operation: | See "Shift y"


CALCulate:LIMit<k>:LOWer:SPACing

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer:SPACing
CALCulate:LIMit<k>:LOWer:SPACing <InterpolType>

This command selects linear or logarithmic interpolation for the calculation of a lower limit line from one horizontal point to the next.

Parameters:
<InterpolType>
LINear | LOGarithmic
*RST: LIN
Manual operation: See "X-Axis"
See "Y-Axis"


CALCulate:LIMit<k>:LOWer:STATe

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:LOWer:STATe <State>

This command turns a lower limit line on and off.

Before you can use the command, you have to select a limit line with CALCulate:​LIMit<k>:​NAME.

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "Visibility"


CALCulate:LIMit<k>:LOWer:THReshold

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:LOWer:THReshold
CALCulate:LIMit<k>:LOWer:THReshold <Threshold>

This command defines a threshold for relative limit lines.

The R&S FSW uses the threshold for the limit check, if the limit line violates the threshold.

Parameters:
<Threshold>

Numeric value.

The unit depends on CALCulate:​LIMit<k>:​UNIT.

*RST: -200 dBm
Manual operation: See "Threshold"


CALCulate:LIMit<k>:NAME

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:NAME <Name>

This command selects a limit line that already exists or defines a name for a new limit line.

Parameters:
<Name>

String containing the limit line name.

*RST: REM1 to REM8 for lines 1 to 8
Example:

See "Programming Example: EMI Measurement".

Manual operation: See "Name"


CALCulate:LIMit<k>:UNIT

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UNIT
CALCulate:LIMit<k>:UNIT <Unit>

This command defines the unit of a limit line.

Parameters:
<Unit>
DBM | DBPW | WATT | DBUV | DBMV | VOLT | DBUA | AMPere | DB | DBUV_M | DBUA_M | (unitless)

If you select dB as the limit line unit, the command automatically turns the limit line into a relative limit line.

*RST: DBM
Manual operation: See "Y-Axis"


CALCulate:LIMit<k>:UPPer[:DATA]

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:LIMit<k>:UPPer[:DATA] <LimitLinePoints>

This command defines the vertical definition points of an upper limit line.

Parameters:
<LimitLinePoints>

Variable number of level values.

Note that the number of vertical values has to be the same as the number of horizontal values set with CALCulate:​LIMit<k>:​CONTrol[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

The unit depends on CALCulate:​LIMit<k>:​UNIT.

*RST: Limit line state is OFF
Usage: SCPI confirmed
Manual operation: See "Data points"


CALCulate:LIMit<k>:UPPer:MARGin

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer:MARGin
CALCulate:LIMit<k>:UPPer:MARGin <Margin>

This command defines an area around an upper limit line where limit check violations are still tolerated.

Parameters:
<Margin>
numeric value
*RST: | 0
Default unit: | dB
Manual operation: See "Margin"


CALCulate:LIMit<k>:UPPer:MODE

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer:MODE
CALCulate:LIMit<k>:UPPer:MODE <Mode>

This command selects the vertical limit line scaling.

Parameters:
<Mode>
ABSolute

Limit line is defined by absolute physical values.

The unit is variable.

RELative

Limit line is defined by relative values related to the reference level (dB).

*RST: ABSolute
Manual operation: See "X-Axis"


CALCulate:LIMit<k>:UPPer:OFFSet

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer:OFFSet
CALCulate:LIMit<k>:UPPer:OFFSet <Offset>

This command defines an offset for a complete upper limit line.

Compared to shifting the limit line, an offset does not actually change the limit line definition points.

Parameters:
<Offset>
Numeric value.
*RST: | 0
Default unit: | dB
Manual operation: See "Y-Offset"


CALCulate:LIMit<k>:UPPer:SHIFt

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:SHIFt <Distance>

This command moves a complete upper limit line vertically.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Defines the distance that the limit line moves. The unit depends on CALCulate:​LIMit<k>:​UNIT.
Usage: | Event
Manual operation: | See "Shift y"


CALCulate:LIMit<k>:UPPer:SPACing

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer:SPACing
CALCulate:LIMit<k>:UPPer:SPACing <InterpolType>

This command selects linear or logarithmic interpolation for the calculation of an upper limit line from one horizontal point to the next.

Parameters:
<InterpolType>
LINear | LOGarithmic
*RST: LIN
Manual operation: See "X-Axis"
See "Y-Axis"


CALCulate:LIMit<k>:UPPer:STATe

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer:STATe
CALCulate:LIMit<k>:UPPer:STATe <State>

This command turns an upper limit line on and off.

Before you can use the command, you have to select a limit line with CALCulate:​LIMit<k>:​NAME.

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "Visibility"


CALCulate:LIMit<k>:UPPer:THReshold

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Configuring Limit Lines > CALCulate:LIMit<k>:UPPer:THReshold
CALCulate:LIMit<k>:UPPer:THReshold <Limit>

This command defines an absolute limit for limit lines with a relative scale.

The R&S FSW uses the threshold for the limit check, if the limit line violates the threshold.

Parameters:
<Limit>

Numeric value.

The unit depends on CALCulate:​LIMit<k>:​UNIT.

*RST: | -200
Default unit: | dBm
Manual operation: See "Threshold"


Managing Limit Lines

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Managing Limit Lines
Managing Limit Lines
Useful commands for managing limit lines described in the R&S FSW User Manual:
  • MMEMory:​SELect[:​ITEM]:​LINes:​ALL
  • MMEMory:​STORe:​TYPE
  • MMEMory:​LOAD:​TYPE
Remote commands exclusive to managing limit lines:
List of Commands
CALCulate:LIMit:ACTive?
CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:TRACe<t>:CHECk


CALCulate:LIMit:ACTive?

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Managing Limit Lines > CALCulate:LIMit:ACTive?
CALCulate:LIMit:ACTive?

This command queries the names of all active limit lines.

Return values:
<LimitLines> | String containing the names of all active limit lines in alphabetical order.
Example: | CALC:LIM:ACT? Queries the names of all active limit lines.
Usage: | Query only
Manual operation: | See "Visibility"


CALCulate:LIMit<k>:COPY

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Managing Limit Lines > CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:COPY <Line>

This command copies a limit line.

Parameters:
<Line> | 1 to 8 number of the new limit line <name> String containing the name of the limit line.
Example: | CALC:LIM1:COPY 2 Copies limit line 1 to line 2. CALC:LIM1:COPY 'FM2' Copies limit line 1 to a new line named FM2.
Manual operation: | See "Copy Line"


CALCulate:LIMit<k>:DELete

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Managing Limit Lines > CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:DELete

This command deletes a limit line.

Usage: | Event
Manual operation: | See "Delete Line"


CALCulate:LIMit<k>:STATe

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Managing Limit Lines > CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:STATe <State>

This command turns the limit check for a specific limit line on and off.

To query the limit check result, use CALCulate:​LIMit<k>:​FAIL?.

Note that a new command exists to activate the limit check and define the trace to be checked in one step (see CALCulate:​LIMit<k>:​TRACe<t>:​CHECk).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:LIM:STAT ON

Switches on the limit check for limit line 1.

Usage: SCPI confirmed
Manual operation: See "Disable All Lines"


CALCulate:LIMit<k>:TRACe<t>:CHECk

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Managing Limit Lines > CALCulate:LIMit<k>:TRACe<t>:CHECk
CALCulate:LIMit<k>:TRACe<t>:CHECk <State>

This command turns the limit check for a specific trace on and off.

To query the limit check result, use CALCulate:​LIMit<k>:​FAIL?.

Note that this command replaces the two commands from previous signal and spectrum analyzers (which are still supported, however):
  • CALCulate:​LIMit<k>:​TRACe
  • CALCulate:​LIMit<k>:​STATe
Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:LIM3:TRAC2:CHEC ON

Switches on the limit check for limit line 3 on trace 2.

Example:

See "Programming Example: EMI Measurement".

Manual operation: See "Traces to be Checked"


Checking the Results of a Limit Check

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Checking the Results of a Limit Check
Checking the Results of a Limit Check
List of Commands
CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit<k>:FAIL?


CALCulate:LIMit:CLEar[:IMMediate]

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Checking the Results of a Limit Check > CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit:CLEar[:IMMediate]

This command deletes the result of the current limit check.

The command works on all limit lines in all measurement windows at the same time.

Example: | CALC:LIM:CLE Deletes the result of the limit check.
Example: | See "Programming Example: EMI Measurement".
Usage: | SCPI confirmed


CALCulate:LIMit<k>:FAIL?

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Checking the Results of a Limit Check > CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:FAIL?

This command queries the result of a limit check.

Note that for SEM measurements, the limit line suffix <k> is irrelevant, as only one specific SEM limit line is checked for the currently relevant power class.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | 0 PASS 1 FAIL
Example: | INIT;*WAI Starts a new sweep and waits for its end. CALC:LIM3:FAIL? Queries the result of the check for limit line 3.
Example: | See "Example: SEM Measurement".
Usage: | Query only SCPI confirmed
Manual operation: | See "Spectrum Emission Mask" See "Limit Check <n>" See "Limit Check"


Programming Example: Using Limit Lines

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Programming Example: Using Limit Lines
Programming Example: Using Limit Lines

The following examples demonstrate how to work with limit lines in a remote environment.

Contents
  • Example: Configuring Limit Lines
  • Example: Performing a Limit Check


Example: Configuring Limit Lines

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Programming Example: Using Limit Lines > Example: Configuring Limit Lines
Example: Configuring Limit Lines

This example demonstrates how to configure 2 limit lines - an upper and a lower limit - for a measurement in a remote environment.

//------------- Configuing the limit lines ---------------------
CALC:LIM1:NAME 'FM1'
//Names limit line 1 'FM1'.

CALC:LIM1:CONT:MODE ABS
//Selects absolute scaling for the horizontal axis.
CALC:LIM1:CONT 1 MHz,50MHz,100 MHz,150MHz,200MHz
//Defines 5 horizontal definition points for limit line 1.
CALC:LIM1:UPP:MODE ABS
//Selects an absolute vertical scale for limit line 1.
CALC:LIM1:UNIT DBM
//Selects the unit dBm for limit line 1.
CALC:LIM1:UPP -10,-5,0,-5,-10
//Defines 5 definition points for limit line 1.

CALC:LIM1:UPP:MARG 5dB
//Defines an area of 5 dB around limit line 1 where limit check violations
//are still tolerated.

CALC:LIM1:UPP:SHIF -10DB
//Shifts the limit line 1 by -10 dB.
CALC:LIM1:UPP:OFFS -3dB
//Defines an additional -3 dB offset for limit line 1.

CALC:LIM3:NAME 'FM3'
//Names limit line 3 'FM3'.

CALC:LIM3:LOW:MODE REL
//Selects a relative vertical scale for limit line 3.
CALC:LIM3:UNIT DB

CALC:LIM3:CONT 1 MHz,50MHz,100 MHz,150MHz,200MHz
//Defines 5 horizontal definition points for limit line 3.
CALC:LIM3:LOW -90,-60,-40,-60,-90
//Defines 5 definition points relative to the reference level for limit line 3.

CALC:LIM3:LOW:SHIF 2
//Shifts the limit line 3 by 2dB.
CALC:LIM3:LOW:OFFS 3
//Defines an additional 3 dB offset for limit line 3.

CALC:LIM3:LOW:THR -200DBM
//Defines a power threshold of -200dBm that must be exceeded for limit to be checked

CALC:LIM3:LOW:MARG 5dB
//Defines an area of 5dB around limit line 3 where limit check violations
//are still tolerated.

//-------------- Storing the limit lines -----------------------
MMEM:SEL:CHAN:LIN:ALL ON
MMEM:STOR:TYPE CHAN
MMEM:STOR:STAT 1,'LimitLines_FM1_FM3'


Example: Performing a Limit Check

Remote Commands > Analyzing Measurements (Basics) > Configuring Display and Limit Lines > Defining Limit Checks > Programming Example: Using Limit Lines > Example: Performing a Limit Check
Example: Performing a Limit Check

This example demonstrates how to perform a limit check during a basic frequency sweep measurement in a remote environment. The limit lines configured in "Example: Configuring Limit Lines" are assumed to exist and be active.

//--------------Preparing the instrument ---------------------
*RST
//Resets the instrument
INIT:CONT OFF
//Selects single sweep mode.

//--------------Configuring the measurement -------------
FREQ:CENT 100MHz
//Defines the center frequency
FREQ:SPAN 200MHz
//Sets the span to 100 MHz on either side of the center frequency.
SENS:SWE:COUN 10
//Defines 10 sweeps to be performed in each measurement.
DISP:TRAC1:Y:RLEV 0dBm
//Sets the reference level to 0 dBm.
TRIG:SOUR IFP
TRIG:LEV:IFP -10dBm
//Defines triggering when the second intermediate frequency rises to a level
//of -10 dBm.

//--------------Configuring the Trace--------------------------
DISP:TRAC2 ON
DISP:TRAC2:MODE AVER
DISP:TRAC3 ON
DISP:TRAC3:MODE MAXH
//Configures 3 traces: 1 (default): clear/write; 2: average; 3: max hold

//------------- Configuring the limit check -------------------
MMEM:LOAD:TYPE REPL
MMEM:LOAD:STAT 1,'LimitLines_FM1_FM3'
//Loads the limit lines stored in 'LimitLines_FM1_FM3'
CALC:LIM1:NAME 'FM1'
CALC:LIM1:UPP:STAT ON
//Activates upper limit FM1 as line 1.
CALC:LIM3:NAME 'FM3'
CALC:LIM3:LOW:STAT ON
//Activates lower limit line FM3 as line 3.
CALC:LIM:ACT?
//Queries the names of all active limit lines
//Result: 'FM1,FM3'
CALC:LIM1:TRAC3:CHEC ON
//Activates the upper limit to be checked against trace3 (maxhold trace)
CALC:LIM3:TRAC2:CHEC ON
//Activates the upper limit to be checked against trace2 (average trace)
CALC:LIM:CLE
//Clears the previous limit check results

//------------- Performing the measurement---------------------
INIT;*WAI
//Initiates a new measurement and waits until the last sweep has finished.

//-------------- Retrieving limit check results----------------------------

CALC:LIM1:FAIL?
//Queries the result of the upper limit line check
CALC:LIM3:FAIL?
//Queries the result of the lower limit line check


Managing Settings and Results

Remote Commands > Managing Settings and Results
Managing Settings and Results

The commands required to store and load instrument settings and import and export measurement results in a remote environment are described here. The tasks for manual operation are described in "Data Management".

Addressing drives

The various drives can be addressed via the "mass storage instrument specifier" <msis> using the conventional Windows syntax. The internal hard disk is addressed by "C:". For details on storage locations refer to "Storage Location and File Name".

The file names (<FileName> parameter) are given as string parameters enclosed in quotation marks. They also comply with Windows conventions. Windows file names do not distinguish between uppercase and lowercase notation.

Wildcards

The two characters "*" and "?" can be used as "wildcards", i.e., they are variables for a selection of several files. The question mark "?" replaces exactly one character, the asterisk replaces any of the remaining characters in the file name. "*.*" thus means all files in a directory.

Path names

Storage locations can be specified either as absolute (including the entire path) or relative paths (including only subfolders of the current folder). Use the MMEM:CDIR? query to determine the current folder.

Secure user mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MHz. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

Contents
  • General Data Storage and Loading Commands
  • Selecting the Items to Store
  • Storing and Loading Instrument Settings
  • Storing or Printing Screenshots
  • Storing Measurement Results
  • Examples: Managing Data


General Data Storage and Loading Commands

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands
General Data Storage and Loading Commands
See also:
  • FORMat[:​DATA]
List of Commands
FORMat:DEXPort:DSEParator
MMEMory:CATalog?
MMEMory:CATalog:LONG?
MMEMory:CDIRectory
MMEMory:COMMent
MMEMory:COPY
MMEMory:DATA
MMEMory:DELete
MMEMory:MDIRectory
MMEMory:MOVE
MMEMory:MSIS
MMEMory:NAME
MMEMory:NETWork:DISConnect
MMEMory:NETWork:MAP
MMEMory:NETWork:UNUSeddrives?
MMEMory:NETWork:USEDdrives?
MMEMory:RDIRectory


FORMat:DEXPort:DSEParator

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Saving the Result Summary (Evaluation List) to a File"
See "Saving the Evaluation List"
See "Decimal Separator"
See "Exporting the Peak List"


MMEMory:CATalog?

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:CATalog?
MMEMory:CATalog?

This command returns the contents of a particular directory.

Query parameters:
<Path>

String containing the path and directory.

If you leave out the path, the command returns the contents of the directory selected with MMEMory:​CDIRectory.

The path may be relative or absolute. Using wildcards ('*') is possible to query a certain type of files only.

Return values:
<FileNames>

List of file and directory names, separated by commas

Example: MMEM:CAT? 'C:\R_S\Instr\user\SPOOL?.PNG'

Returns all files in C:\R_S\Instr\user whose names start with SPOOL, have 6 letters and the extension ".PNG", e.g.:

SPOOL1.PNG,SPOOL2.PNG,SPOOL3.PNG

Usage: Query only
SCPI confirmed
Manual operation: See "Selecting the Storage Location - Drive/ Path/ Files"


MMEMory:CATalog:LONG?

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:CATalog:LONG?
MMEMory:CATalog:LONG? <Path>

This command returns the contents of a particular directory with additional information about the files.

Query parameters:
<Path>

String containing the path and directory.

If you leave out the path, the command returns the contents of the directory selected with MMEMory:​CDIRectory.

The path may be relative or absolute. Using wildcards ('*') is possible to query a certain type of files only.

Return values:
<UsedDiskSpace>

Byte size of all files in the directory.

<FreeDiskSpace>

Remaining disk space in bytes.

<FileInfo>
<NameFileN>,<SuffixFileN>,<SizeFileN>

Describes the individual file.

<NameFileN>

Name of the file.

<SuffixFileN>

Type of the file. Possible suffixes are: ASCii, BINary, DIRectory, STAT

<SizeFileN>

Size of the file in bytes.

Usage: Query only


MMEMory:CDIRectory

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:CDIRectory
MMEMory:CDIRectory <Directory>

This command changes the current directory.

Parameters:
<Directory> | String containing the path to another directory. The path may be relative or absolute.
Usage: | SCPI confirmed


MMEMory:COMMent

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:COMMent
MMEMory:COMMent <Comment>

This command defines a comment for the stored settings.

Parameters:
<Comment> | String containing the comment.
Example: | MMEMory:COMMent "ACP measurement with Standard Tetra from 23.05." MMEMory::MMEMory:STORe1:STATe 1, "ACP_T" As a result, in the selection list for recall settings, the comment "ACP measurement with Standard Tetra from 23.05." is added to the ACP entry.
Manual operation: | See "Comment"


MMEMory:COPY

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:COPY
MMEMory:COPY <SourceFile>,<DestinationFile>

This command copies one or more files to another directory.

Parameters:
<SourceFile> | String containing the path and file name of the source file.
<DestinationFile> | String containing the path and name of the target file. The path may be relative or absolute.
Usage: | SCPI confirmed


MMEMory:DATA

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:DATA
MMEMory:DATA <FileName>, [<Block>]

This command writes block data into a file. The delimiter must be set to EOI to obtain error-free data transfer.

When you query the contents of a file, you can save them in a file on the remote control computer.

The command is useful for reading stored settings files or trace data from the instrument or for transferring them to the instrument.

Parameters:
<FileName> | String containing the path and name of the target file.
<Block> | Data block with the following structure. # Hash sign. <number> Length of the length information. <number> Length information of the binary data (number of bytes). <data> Binary data with the indicated <number> of bytes.
Example: | MMEM:NAME '\Public\User\Testfile.txt' Creates a new file called 'testfile.txt'. MMEM:DATA 'Testfile.txt',#220Contents of the file The parameter means: #2: hash sign and length of the length information (20 bytes = 2 digits) 20: indicates the number of subsequent binary data bytes. Contents of the file: store 20 binary bytes (characters) to the file.
Usage: | SCPI confirmed


MMEMory:DELete

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:DELete
MMEMory:DELete <FileName>

This command deletes a file.

Parameters:
<FileName> | String containing the path and file name of the file to delete. The path may be relative or absolute.
Usage: | Event SCPI confirmed


MMEMory:MDIRectory

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:MDIRectory
MMEMory:MDIRectory <Directory>

This command creates a new directory.

Parameters:
<Directory> | String containing the path and new directory name The path may be relative or absolute.
Usage: | Event


MMEMory:MOVE

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:MOVE
MMEMory:MOVE <SourceFile>,<NewFileName>

This command moves a file to another directory.

The command also renames the file if you define a new name in the target directory.

If you do not include a path for <NewFileName>, the command just renames the file.

Parameters:
<SourceFile> | String containing the path and file name of the source file.
<NewFileName> | String containing the path and name of the target file.
Example: | MMEM:MOVE 'C:\TEST01.CFG','SETUP.CFG' Renames TEST01.CFG in SETUP.CFG in directory C:\.
Usage: | Event SCPI confirmed


MMEMory:MSIS

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:MSIS
MMEMory:MSIS <Device>

This command selects the default storage device used by all MMEMory commands.

Parameters:
<Device>
'A:' | 'C:' | … | 'Z:'

String containing the device drive name

*RST: 'C:'
Usage: SCPI confirmed


MMEMory:NAME

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:NAME
MMEMory:NAME <FileName>

This command creates a new and empty file.

It also sets the file name for screenshots taken with HCOPy[:​IMMediate<device>]. Note that you have to route the printer output to a file.

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:NAME 'C:\R_S\instr\user\PRINT1.BMP' Selects the file name.
Usage: | Event SCPI confirmed


MMEMory:NETWork:DISConnect

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:NETWork:DISConnect
MMEMory:NETWork:DISConnect <Drive>

This command disconnects a network drive.

Parameters:
<Drive> | String containing the drive name.
Usage: | Event


MMEMory:NETWork:MAP

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:NETWork:MAP
MMEMory:NETWork:MAP <Drive>, <HostName> [, <UserName>, <Password>][, <Reconnect>]

This command maps a drive to a server or server directory of the network.

Note that you have to allow sharing for a server or folder in Microsoft networks first.

Parameters:
<Drive> | String containing the drive name or path of the directory you want to map.
<HostName> | String containing the host name of the computer or the IP address and the share name of the drive. '<\host name or IP address\share name>'
<UserName> | String containing a user name in the network. The user name is optional.
<Password> | String containing the password corresponding to the <UserName>. The password is optional.
<Reconnect> | ON | OFF ON Reconnects at logon with the same user name. OFF Does not reconnect at logon.
Usage: | Event


MMEMory:NETWork:UNUSeddrives?

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:NETWork:UNUSeddrives?
MMEMory:NETWork:UNUSeddrives?

This command returns a list of unused network drives.

Return values:
<DriveName> | List of network drives in alphabetically descending order, e.g. 'W:,V:,U:,...'
Usage: | Query only


MMEMory:NETWork:USEDdrives?

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:NETWork:USEDdrives?
MMEMory:NETWork:USEDdrives? <State>

This command returns a list of all network drives in use.

Parameters:
<State> | You do not have to use the parameter. If you do not include the parameter, the command returns a list of all drives in use. This is the same behavior as if you are using the parameter OFF. ON Returns a list of all drives in use including the folder information. OFF Returns al list of all drives in use.
Usage: | Query only


MMEMory:RDIRectory

Remote Commands > Managing Settings and Results > General Data Storage and Loading Commands > MMEMory:RDIRectory
MMEMory:RDIRectory <Directory>

This command deletes the indicated directory.

Parameters:
<Directory> | String containing the path of the directory to delete. Note that the directory you want to remove may contain no contents.
Usage: | Event


Selecting the Items to Store

Remote Commands > Managing Settings and Results > Selecting the Items to Store
Selecting the Items to Store

The following commands select the items to be included in the configuration file.

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored.

List of Commands
MMEMory:SELect:CHANnel[:ITEM]:ALL
MMEMory:SELect[:ITEM]:ALL
MMEMory:SELect:CHANnel[:ITEM]:DEFault
MMEMory:SELect[:ITEM]:DEFault
MMEMory:SELect:CHANnel[:ITEM]:HWSettings
MMEMory:SELect[:ITEM]:HWSettings
MMEMory:SELect:CHANnel[:ITEM]:LINes:ALL
MMEMory:SELect[:ITEM]:LINes:ALL
MMEMory:SELect:CHANnel[:ITEM]:NONE
MMEMory:SELect[:ITEM]:NONE
MMEMory:SELect:CHANnel[:ITEM]:SGRam
MMEMory:SELect[:ITEM]:SGRam
MMEMory:SELect:CHANnel[:ITEM]:TRACe[:ACTive]
MMEMory:SELect[:ITEM]:TRACe[:ACTive]
MMEMory:SELect:CHANnel[:ITEM]:TRANsducer:ALL
MMEMory:SELect[:ITEM]:TRANsducer:ALL


MMEMory:SELect:CHANnel[:ITEM]:ALL

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:ALL
MMEMory:SELect:CHANnel[:ITEM]:ALL
MMEMory:SELect[:ITEM]:ALL

This command includes all items when storing or loading a configuration file.

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored or loaded.

The items are:

  • Hardware configuration: MMEMory:​SELect[:​ITEM]:​HWSettings
  • Limit lines: MMEMory:​SELect[:​ITEM]:​LINes:​ALL
  • Spectrogram data: MMEMory:​SELect[:​ITEM]:​SGRam
  • Trace data: MMEMory:​SELect[:​ITEM]:​TRACe[:​ACTive]
  • Transducers: MMEMory:​SELect[:​ITEM]:​TRANsducer:​ALL
Example: | MMEM:SEL:ALL
Usage: | Event
Manual operation: | See "Items"


MMEMory:SELect:CHANnel[:ITEM]:DEFault

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:DEFault
MMEMory:SELect:CHANnel[:ITEM]:DEFault
MMEMory:SELect[:ITEM]:DEFault

This command selects the current settings as the only item to store to and load from a configuration file.

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored or loaded.

Manual operation: See "Items"


MMEMory:SELect:CHANnel[:ITEM]:HWSettings

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:HWSettings
MMEMory:SELect:CHANnel[:ITEM]:HWSettings <State>
MMEMory:SELect[:ITEM]:HWSettings <State>

This command includes or excludes hardware settings when storing or loading a configuration file.

Hardware settings include:

  • general instrument configuration
  • measurement hardware configuration including markers
  • limit lines
    Note that a configuration may include no more than 8 limit lines. This number includes active limit lines as well as inactive limit lines that were used last.
    Therefore the combination of inactivate limit lines depends on the sequence of use with MMEMory:​LOAD:​STATe.
  • color settings
  • configuration for the hardcopy output

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored or loaded.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: MMEM:SEL:HWS ON
Manual operation: See "Items"


MMEMory:SELect:CHANnel[:ITEM]:LINes:ALL

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:LINes:ALL
MMEMory:SELect:CHANnel[:ITEM]:LINes:ALL <State>
MMEMory:SELect[:ITEM]:LINes:ALL <State>

This command includes or excludes all limit lines (active and inactive) when storing or loading a configuration file.

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored or loaded.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MMEM:SEL:LIN:ALL ON
Manual operation: See "Items"


MMEMory:SELect:CHANnel[:ITEM]:NONE

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:NONE
MMEMory:SELect:CHANnel[:ITEM]:NONE
MMEMory:SELect[:ITEM]:NONE

This command does not include any of the following items when storing or loading a configuration file.

  • Hardware configuration: MMEMory:​SELect[:​ITEM]:​HWSettings
  • Limit lines: MMEMory:​SELect[:​ITEM]:​LINes:​ALL
  • Trace data: MMEMory:​SELect[:​ITEM]:​TRACe[:​ACTive]
  • Transducers: MMEMory:​SELect[:​ITEM]:​TRANsducer:​ALL
Example: | MMEM:SEL:NONE
Usage: | Event
Manual operation: | See "Items"


MMEMory:SELect:CHANnel[:ITEM]:SGRam

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:SGRam
MMEMory:SELect:CHANnel[:ITEM]:SGRam <State>
MMEMory:SELect[:ITEM]:SGRam <State>

This command includes or excludes spectrogram data when storing or loading a configuration file.

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored or loaded.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MMEM:SEL:SGR ON

Adds the spectrogram data to the list of data subsets.


MMEMory:SELect:CHANnel[:ITEM]:TRACe[:ACTive]

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:TRACe[:ACTive]
MMEMory:SELect:CHANnel[:ITEM]:TRACe[:ACTive] <State>
MMEMory:SELect[:ITEM]:TRACe[:ACTive] <State>

This command includes or excludes trace data when storing or loading a configuration file.

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored or loaded.

Parameters:
<State>
ON | OFF
*RST: OFF, i.e. no traces is stored
Example: MMEM:SEL:TRAC ON
Manual operation: See "Items"


MMEMory:SELect:CHANnel[:ITEM]:TRANsducer:ALL

Remote Commands > Managing Settings and Results > Selecting the Items to Store > MMEMory:SELect:CHANnel[:ITEM]:TRANsducer:ALL
MMEMory:SELect:CHANnel[:ITEM]:TRANsducer:ALL <State>
MMEMory:SELect[:ITEM]:TRANsducer:ALL <State>

This command includes or excludes transducer factors when storing or loading a configuration file.

Depending on the used command, either the items from the entire instrument (MMEMory:SELect[:ITEM]...), or only those from the currently selected channel (MMEM:SELect:CHANnel[:ITEM]...) are stored or loaded.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MMEM:SEL:TRAN:ALL ON
Manual operation: See "Items"
See "Save"


Storing and Loading Instrument Settings

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings
Storing and Loading Instrument Settings

See also:

  • INSTrument[:​SELect] to select the channel.
List of Commands
MMEMory:CLEar:ALL
MMEMory:CLEar:STATe
MMEMory:LOAD:AUTO
MMEMory:LOAD:STATe
MMEMory:LOAD:TYPE
MMEMory:STORe:STATe
MMEMory:STORe:STATe:NEXT
MMEMory:STORe:TYPE
SYSTem:PRESet
SYSTem:PRESet:CHANnel[:EXECute]


MMEMory:CLEar:ALL

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:CLEar:ALL
MMEMory:CLEar:ALL

This command deletes all instrument configuration files in the current directory.

You can select the directory with MMEMory:​CDIRectory.

Example: | MMEM:CLE:ALL
Usage: | Event


MMEMory:CLEar:STATe

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:CLEar:STATe
MMEMory:CLEar:STATe 1,<FileName>

This command deletes a instrument configuration file.

Parameters:
1 |
<FileName> | String containing the path and name of the file to delete. The string may or may not contain the file's extension.
Example: | MMEM:CLE:STAT 1,'TEST'
Usage: | Event


MMEMory:LOAD:AUTO

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:LOAD:AUTO
MMEMory:LOAD:AUTO 1, 'Factory' | <FileName>

This command restores an instrument configuration and defines that configuration as the default state.

The default state is restored after a preset (*RST) or after you turn on the R&S FSW.

Parameters:
1 |
'Factory' | <FileName> | 'Factory' Restores the factory settings as the default state. '<file_name> String containing the path and name of the configuration file. Note that only instrument settings files can be selected for the startup recall function; channel settings files cause an error.
Example: | MMEM:LOAD:AUTO 1,'C:\R_S\Instr\user\TEST'
Usage: | Event
Manual operation: | See "Startup Recall"


MMEMory:LOAD:STATe

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:LOAD:STATe
MMEMory:LOAD:STATe 1, <FileName>

This command restores and activates an instrument configuration stored in a *.dfl file.

Note that files with other formats cannot be loaded with this command.

The contents that are reloaded from the file are defined by the last selection made either in the "Save/Recall" dialogs (manual operation) or through the MMEMory:SELect[:ITEM] commands (remote operation; the settings are identical in both cases).

By default, the selection is limited to the user settings ("User Settings" selection in the dialogs, HWSettings in SCPI). The selection is not reset by PRESET or *RST.

As a consequence, the results of a SCPI script using the MMEMory:LOAD:STATe command without a previous MMEMory:SELect[:ITEM] command may vary, depending on previous actions in the GUI or in previous scripts, even if the script starts with the *RST command.

It is therefore recommended that you use the appropriate MMEMory:SELect[:ITEM] command before using MMEMory:LOAD:STATe.

Parameters:
1
<FileName>

String containing the path and name of the file to load.

The string may or may not include the file's extension.

Example: MMEM:SEL:ALL

//Save all items (User Settings, All Traces, All Limit Lines) from the R&S FSW.

MMEM:LOAD:STAT 1,'C:\R_S\Instr\user\TEST01'

//Reloads all items

In the "Recall" dialog, select only "User Settings" and "All Limit Lines".

MMEM:LOAD:STAT 1,'C:\R_S\Instr\user\TEST01'

//Reloads user settings and all limit lines.

*RST

//Reset instrument.

MMEM:LOAD:STAT 1,'C:\R_S\Instr\user\TEST01'

//Selected items are retained. Reloads user settings and all limit lines.

Restart the instrument (using the ON/OFF key on the front panel).

MMEM:LOAD:STAT 1,'C:\R_S\Instr\user\TEST01'

// Selected items are set to default. Reloads only the user settings.

Usage: SCPI confirmed
Manual operation: See "Recall"
See "Recall in New Channel / Recall in Current Channel"


MMEMory:LOAD:TYPE

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:LOAD:TYPE
MMEMory:LOAD:TYPE <Mode>

This command defines whether the channel-specific settings that will be loaded with the subsequent MMEM:LOAD:STAT command will replace the current channel or activate a new channel.

Parameters:
<Mode>
NEW | REPLace
NEW

The loaded settings will be activated in a new channel.

REPLace

The loaded settings will replace the currently active channel.

*RST: NEW
Example: INST:SEL 'SPECTRUM2'

Selects measurement channel 'SPECTRUM2'.

MMEM:STOR:TYP CHAN

Specifies that channel-specific data is to be stored.

MMEM:STOR:STAT 1, 'C:\R_S\Instr\user\Spectrum'

Stores the settings from channel 'SPECTRUM2' to the file 'C:\R_S\Instr\user\Spectrum'.

MMEM:LOAD:TYPE NEW

Specifies that channel-specific settings are to be activated in a new channel.

MMEM:LOAD:STAT 1, 'C:\R_S\Instr\user\Spectrum'

Loads the channel-specific settings from the file 'C:\R_S\Instr\user\Spectrum' to the new channel 'SPECTRUM2*'.


MMEMory:STORe:STATe

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:STORe:STATe
MMEMory:STORe:STATe 1,<FileName>

This command saves the current instrument configuration in a *.dfl file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Parameters:
1 |
<FileName> | String containing the path and name of the target file. The file extension is .dfl.
Example: | MMEM:STOR:STAT 1,'Save' Saves the current device settings in the file Save.dfl.
Usage: | Event SCPI confirmed
Manual operation: | See "Save File" See "Save"


MMEMory:STORe:STATe:NEXT

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:STORe:STATe:NEXT
MMEMory:STORe:STATe:NEXT

This command saves the current instrument configuration in a *.dfl file.

The file name depends on the one you have set with MMEMory:​STORe:​STATe. This command adds a consecutive number to the file name.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Example: | MMEM:STOR:STAT 1,'Save' Saves the current device settings in the file Save.dfl. MMEM:STOR:STAT:NEXT Saves the current device settings in the file Save_001.dfl MMEM:STOR:STAT:NEXT Saves the current device settings in the file Save_002.dfl
Usage: | Event
Manual operation: | See "Save File"


MMEMory:STORe:TYPE

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > MMEMory:STORe:TYPE
MMEMory:STORe:TYPE <Mode>

This command defines whether the data from the entire instrument or only from the current channel is stored with the subsequent MMEM:STOR... command.

Parameters:
<Mode>
INSTrument | CHANnel
*RST: INST
Example: INST:SEL 'SPECTRUM2'

Selects measurement channel 'SPECTRUM2'.

MMEM:STOR:TYPE CHAN

Specifies that channel-specific data is to be stored.

MMEM:STOR:PEAK 'SpectrumPeaks'

Stores the peak list from channel 'SPECTRUM2' to the file 'SpectrumPeaks'.


SYSTem:PRESet

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > SYSTem:PRESet
SYSTem:PRESet

This command presets the R&S FSW.

Example: | SYST:PRES
Usage: | Event SCPI confirmed


SYSTem:PRESet:CHANnel[:EXECute]

Remote Commands > Managing Settings and Results > Storing and Loading Instrument Settings > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration".

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Storing or Printing Screenshots

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots
Storing or Printing Screenshots
Useful commands to configure screenshots described elsewhere
  • MMEMory:​NAME
Remote commands exclusive to configure screenshots
List of Commands
DISPlay:LOGO
HCOPy:ABORt
HCOPy:CMAP<item>:DEFault<colors>
HCOPy:CMAP<item>:HSL
HCOPy:CMAP<item>:PDEFined
HCOPy:DESTination<device>
HCOPy:DEVice:COLor
HCOPy:DEVice:LANGuage<device>
HCOPy[:IMMediate<device>]
HCOPy[:IMMediate<device>]:NEXT
HCOPy:ITEM:ALL
HCOPy:ITEM:WINDow:TEXT
HCOPy:PAGE:ORIentation<device>
HCOPy:TDSTamp:STATe<device>
SYSTem:COMMunicate:PRINter:ENUMerate:FIRSt?
SYSTem:COMMunicate:PRINter:ENUMerate[:NEXT]?
SYSTem:COMMunicate:PRINter:SELect<device>


DISPlay:LOGO

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > DISPlay:LOGO
DISPlay:LOGO <State>

Activates/deactivates the printout of the Rohde & Schwarz company logo in the upper left corner.

Parameters:
<State>
ON | OFF
*RST: ON
Example: DISP:LOGO OFF
Manual operation: See "Print Logo"


HCOPy:ABORt

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:ABORt
HCOPy:ABORt

This command aborts a running hardcopy output.

Example: | HCOP:ABOR
Usage: | Event SCPI confirmed


HCOPy:CMAP<item>:DEFault<colors>

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:CMAP<item>:DEFault<colors>
HCOPy:CMAP<item>:DEFault<colors>

This command defines the color scheme for print jobs.

Suffix: |
<item> | Selects the item for which the color scheme is to be defined. For more information see "CMAP Suffix Assignment".
<colors> | 1...4 1 Current colors with a white background and a black grid. 2 Optimized colors. 3 Customized colors. 4 Current screen colors (setting for hardcopies).
Example: | HCOP:CMAP:DEF2 Selects the optimized color set for the color settings of a printout or a hardcopy.
Usage: | Event
Manual operation: | See "Print colors"


HCOPy:CMAP<item>:HSL

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:CMAP<item>:HSL
HCOPy:CMAP<item>:HSL <Color>

This command selects the color for various screen elements in print jobs.

Suffix: |
<item> | Selects the item for which the color scheme is to be defined. For more information see "CMAP Suffix Assignment".
Parameters:
<Color> | hue tint sat saturation lum brightness The value range is 0 to 1 for all parameters.
Example: | HCOP:CMAP2:HSL 0.3,0.8,1.0 Changes the grid color
Manual operation: | See "Defining User-specific Colors"


HCOPy:CMAP<item>:PDEFined

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:CMAP<item>:PDEFined
HCOPy:CMAP<item>:PDEFined <Color>

This command selects a predefined color for various screen elements in print jobs.

Suffix: |
<item> | Selects the item for which the color scheme is to be defined. For more information see "CMAP Suffix Assignment".
Parameters:
<Color> | BLACk | BLUE | BROWn | GREen | CYAN | RED | MAGenta | YELLow | WHITe | DGRAy | LGRAy | LBLUe | LGREen | LCYan | LRED | LMAGenta
Example: | HCOP:CMAP2:PDEF GRE
Manual operation: | See "Predefined Colors"


HCOPy:DESTination<device>

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:DESTination<device>
HCOPy:DESTination<device> <Destination>

This command selects the destination of a print job.

Suffix:
<device>
1 | 2

Printing device.

Parameters:
<Destination>
'MMEM'

Sends the hardcopy to a file.

You can select the file name with MMEMory:​NAME.

You can select the file format with HCOPy:​DEVice:​LANGuage<device>.

'SYST:COMM:PRIN'

Sends the hardcopy to a printer.

You can select the printer withSYSTem:​COMMunicate:​PRINter:​SELect<device> .

'SYST:COMM:CLIP'

Sends the hardcopy to the clipboard.

The format should be WEMF.

*RST: 'SYST:COMM:CLIP'
Usage: SCPI confirmed
Manual operation: See "Device"


HCOPy:DEVice:COLor

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:DEVice:COLor
HCOPy:DEVice:COLor <State>

This command turns color printing on and off.

Parameters:
<State>
ON

Color printing

OFF

Black and white printing

*RST: OFF
Example: HCOP:DEV:COL ON
Usage: SCPI confirmed


HCOPy:DEVice:LANGuage<device>

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:DEVice:LANGuage<device>
HCOPy:DEVice:LANGuage<device> <Format>

This command selects the file format for a print job.

Suffix:
<device>
1 | 2

Printing device.

Parameters:
<Format>
GDI

Graphics Device Interface.

Default format for the output to a printer configured under Windows. Must be selected for the output to the printer interface.

Can be used for the output to a file. The printer driver configured under Windows is used in this case and a printer-specific file format is thus generated.

BMP, JPG, PNG

Data format for output to files only.

Usage: SCPI confirmed
Manual operation: See "Output Medium"


HCOPy[:IMMediate<device>]

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy[:IMMediate<device>]
HCOPy[:IMMediate<device>]

This command initiates a print job.

If you are printing to a file, the file name depends on MMEMory:​NAME.

Suffix: |
<device> | 1 | 2 Printing device.
Usage: | Event SCPI confirmed
Manual operation: | See "Printing or Storing a Screenshot (Print Screen)"


HCOPy[:IMMediate<device>]:NEXT

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy[:IMMediate<device>]:NEXT
HCOPy[:IMMediate<device>]:NEXT

This command initiates a print job.

If you are printing to a file, the file name depends on MMEMory:​NAME. This command adds a consecutive number to the file name.

Suffix: |
<device> | 1 | 2 Printing device.
Usage: | Event
Manual operation: | See "Printing or Storing a Screenshot (Print Screen)"


HCOPy:ITEM:ALL

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:ITEM:ALL
HCOPy:ITEM:ALL

This command includes all screen elements in the printout.

The screen elements include comments, title, time and date.

Usage: | SCPI confirmed
Manual operation: | See "Printing or Storing a Screenshot (Print Screen)"


HCOPy:ITEM:WINDow:TEXT

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:ITEM:WINDow:TEXT
HCOPy:ITEM:WINDow:TEXT <Comment>

This command defines a comment to be added to the printout.

Parameters:
<Comment> | String containing the comment.
Usage: | SCPI confirmed
Manual operation: | See "Comment"


HCOPy:PAGE:ORIentation<device>

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:PAGE:ORIentation<device>
HCOPy:PAGE:ORIentation<device> <Orientation>

The command selects the format of the print job.

The command is only available if the output device is a printer.

Suffix:
<device>
1 | 2

Printing device.

Parameters:
<Orientation>
LANDscape | PORTrait
*RST: PORTrait
Usage: SCPI confirmed
Manual operation: See "Orientation"


HCOPy:TDSTamp:STATe<device>

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > HCOPy:TDSTamp:STATe<device>
HCOPy:TDSTamp:STATe<device> <State>

This command includes or excludes the time and date in the printout.

Suffix:
<device>
1 | 2

Printing device.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Print Date and Time"


SYSTem:COMMunicate:PRINter:ENUMerate:FIRSt?

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > SYSTem:COMMunicate:PRINter:ENUMerate:FIRSt?
SYSTem:COMMunicate:PRINter:ENUMerate:FIRSt?

This command queries the name of the first available printer.

To query the name of other installed printers, use SYSTem:​COMMunicate:​PRINter:​ENUMerate[:​NEXT]?.

Return values:
<PrinterName> | String containing the name of the first printer as defined in Windows. If the command cannot find a printer, it returns an empty string (' ').
Usage: | Query only
Manual operation: | See "Printer Name"


SYSTem:COMMunicate:PRINter:ENUMerate[:NEXT]?

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > SYSTem:COMMunicate:PRINter:ENUMerate[:NEXT]?
SYSTem:COMMunicate:PRINter:ENUMerate[:NEXT]?

This command queries the name of available printers.

You have to use SYSTem:​COMMunicate:​PRINter:​ENUMerate:​FIRSt? for this command to work properly.

Return values:
<PrinterName> | String containing the name of one printer as defined in Windows. To get a complete list of printers you have to send this query several times until no more printers could be found. In that case, the return value is an empty string (' '). Further queries after the empty string result in an error.
Usage: | Query only
Manual operation: | See "Printer Name"


SYSTem:COMMunicate:PRINter:SELect<device>

Remote Commands > Managing Settings and Results > Storing or Printing Screenshots > SYSTem:COMMunicate:PRINter:SELect<device>
SYSTem:COMMunicate:PRINter:SELect<device> <PrinterName>

This command selects the printer that processes jobs sent by the R&S FSW.

Use HCOPy:​DESTination<device> to select another output destination.

Suffix:
<device>
1 | 2

Printing device.

Parameters:
<PrinterName>

String containing the printer name.

Use

• SYSTem:​COMMunicate:​PRINter:​ENUMerate:​FIRSt? and

• SYSTem:​COMMunicate:​PRINter:​ENUMerate[:​NEXT]?

to query all available printers.

*RST: NONE
Manual operation: See "Printer Name"


Storing Measurement Results

Remote Commands > Managing Settings and Results > Storing Measurement Results
Storing Measurement Results

The following commands can be used to store the results of a measurement.

Useful commands for storing results described elsewhere:
  • FORMat[:​DATA]
Remote commands exclusive to storing results:
List of Commands
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
MMEMory:STORe:LIST
MMEMory:STORe:PEAK
MMEMory:STORe<n>:SGRam
MMEMory:STORe:SPURious
MMEMory:STORe<n>:TRACe


FORMat:DEXPort:HEADer

Remote Commands > Managing Settings and Results > Storing Measurement Results > FORMat:DEXPort:HEADer
FORMat:DEXPort:HEADer <State>

If enabled, additional instrument and measurement settings are included in the header of the export file for result data. If disabled, only the pure result data from the selected traces and tables is exported.

See "Reference: ASCII File Export Format" for details.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Usage: SCPI confirmed
Manual operation: See "Include Instrument Measurement Settings"


FORMat:DEXPort:TRACes

Remote Commands > Managing Settings and Results > Storing Measurement Results > FORMat:DEXPort:TRACes
FORMat:DEXPort:TRACes <Selection>

This command selects the data to be included in a data export file (see MMEMory:​STORe<n>:​TRACe).

For details on exporting data see "Trace / Data Export Configuration".

Parameters:
<Selection>
SINGle

Only a single trace is selected for export, namely the one specified by the MMEMory:​STORe<n>:​TRACe command.

ALL

Selects all active traces and result tables (e.g. Result Summary, marker peak list etc.) in the current application for export to an ASCII file.

The <trace> parameter for the MMEMory:​STORe<n>:​TRACe command is ignored.

*RST: SINGle
Usage: SCPI confirmed
Manual operation: See "Export all Traces and all Table Results"


MMEMory:STORe:LIST

Remote Commands > Managing Settings and Results > Storing Measurement Results > MMEMory:STORe:LIST
MMEMory:STORe:LIST <FileName>

This command exports the SEM and spurious emission list evaluation to a file.

The file format is *.dat.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:LIST 'test' Stores the current list evaluation results in the test.dat file.
Manual operation: | See "Saving the Result Summary (Evaluation List) to a File" See "Saving the Evaluation List"


MMEMory:STORe:PEAK

Remote Commands > Managing Settings and Results > Storing Measurement Results > MMEMory:STORe:PEAK
MMEMory:STORe:PEAK <FileName>

This command exports the marker peak list to a file.

The file format is *.dat.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:PEAK 'test' Saves the current marker peak list in the file test.dat.
Usage: | Event
Manual operation: | See "Exporting the Peak List"


MMEMory:STORe<n>:SGRam

Remote Commands > Managing Settings and Results > Storing Measurement Results > MMEMory:STORe<n>:SGRam
MMEMory:STORe<n>:SGRam <FileName>

This command exports spectrogram data to an ASCii file.

The file contains the data for every frame in the history buffer. The data corresponding to a particular frame begins with information about the frame number and the time that frame was recorded.

Note that, depending on the size of the history buffer, the process of exporting the data can take a while.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:SGR 'Spectrogram' Copies the spectrogram data to a file.
Manual operation: | See "Export Trace to ASCII File"


MMEMory:STORe:SPURious

Remote Commands > Managing Settings and Results > Storing Measurement Results > MMEMory:STORe:SPURious
MMEMory:STORe:SPURious <FileName>

This command exports the marker peak list available for spurious emission measurements to a file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Parameters:
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:SPUR 'test' Saves the current marker peak list in the file test.dat.
Usage: | Event


MMEMory:STORe<n>:TRACe

Remote Commands > Managing Settings and Results > Storing Measurement Results > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

For details on the file format see "Reference: ASCII File Export Format".

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode".

Parameters:
<Trace> | Number of the trace to be stored (This parameter is ignored if the option "Export all Traces and all Table Results" is activated in the Export configuration settings, see FORMat:​DEXPort:​TRACes).
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Usage: | SCPI confirmed
Manual operation: | See "Export Trace to ASCII File"


Examples: Managing Data

Remote Commands > Managing Settings and Results > Examples: Managing Data
Examples: Managing Data
Contents
  • Storing Data
  • Loading Data
  • Storing Instrument Settings
  • Loading Instrument Settings
  • Printing to a File
  • Printing on a Printer


Storing Data

Remote Commands > Managing Settings and Results > Examples: Managing Data > Storing Data
Storing Data
MMEM:MSIS 'C:'
//Selects drive C: as the default storage device.
-----Connecting a network drive--------
MMEM:NETW:USED?
//Returns a list of all drives in use in the network.
MMEM:NETW:UNUS?
//Returns a list of free drive names in the network.
MMEM:NETW:MAP 'T:','Server\ACLRTest'
//Maps drive T: to the directory 'Server\ACLRTest'
-----Saving data on the instrument-----
MMEM:MDIR 'C:\R_S\INST\USER\ACLRTest'
//Creates a directory called 'ACLRTest' on drive C:
MMEM:NAME 'C:\R_S\INST\USER\Test001.txt'
//Creates a file called 'Test001.txt'
MMEM:COMM 'ACLR test results'
//Creates a comment for the file.
MMEM:DATA 'Test001.txt',#212FileContents
//Writes 12 characters to the file 'Test001.txt'
-----Copying the data to another location---
MMEM:COPY 'C:\R_S\INST\USER\Results\Test001.txt','T:'
//Copies the specified file to network drive T:.
MMEM:DEL 'C:\R_S\INST\USER\Results\Test001.txt'
//Deletes the specified file from the instrument hard disk.
//or
MMEM:MOVE 'C:\R_S\INST\USER\Results\Test001.xml','D:\TestResults.txt'//
//Moves the file 'Test001.txt' to drive T:, renames it to 'Testresults.txt'
//and removes it from the instrument hard disk.
MMEM:RDIR 'C:\R_S\INST\USER\Results'
//Deletes the directory called 'Results' from drive C:, unless it still contains any content.
-----Disconnecting the network drive---
MMEM:NETW:DISC 'T:'
//Disconnect drive T:.


Loading Data

Remote Commands > Managing Settings and Results > Examples: Managing Data > Loading Data
Loading Data
MMEM:CDIR?
//Returns the path of the current directory.
//e.g.
C:\R_S\Instr\user\
MMEM:CDIR 'C:\R_S\INST\USER\Results'
//Changes the current directory.
MMEM:CAT? 'C:\R_S\INST\USER\Results\*.xml'
//or
MMEM:CAT? '*.xml'
//Returns a list of all xml files in the directory 'C:\R_S\INST\USER\Results'.
MMEM:CAT:LONG? '*.xml'
//Returns additional information about the xml files in the directory 'C:\R_S\INST\USER\Results'.


Storing Instrument Settings

Remote Commands > Managing Settings and Results > Examples: Managing Data > Storing Instrument Settings
Storing Instrument Settings

In this example we will store the instrument settings for the "Spectrum" channel.

INST:SEL 'SPECTRUM'
//Selects measurement channel 'SPECTRUM'.
MEMM:STOR:TYPE CHAN
//Specifies that channel-specific data is to be stored.
MMEM:STOR:STAT 1, 'C:\R_S\Instr\user\Spectrum'
//Stores the channel settings from the 'Spectrum' channel
// to the file 'Spectrum.dfl'.


Loading Instrument Settings

Remote Commands > Managing Settings and Results > Examples: Managing Data > Loading Instrument Settings
Loading Instrument Settings

In this example we will load the hardware settings from the configuration file Spectrum.dfl to a new "Spectrum2" channel.

Folgende zeile hat maximale länge
01234567890123456789012345678901234567890123456789012345678901234567890123456789

MEMM:LOAD:TYPE NEW
//Specifies that settings will be loaded to a new channel besides the existing
//'Spectrum' channel.
MMEM:SEL:CHAN:HWS ON
//Selects only hardware settings to be loaded.
MMEM:LOAD:STAT 1, 'C:\R_S\Instr\user\Spectrum'
//Loads the channel-specific settings from the file 'C:\R_S\Instr\user\Spectrum.dfl'
//to a new channel. The new channel is named 'Spectrum2' to avoid a naming conflict
//with the existing 'Spectrum' channel.
INST:REN 'Spectrum2','Spectrum3'
//Renames the loaded channel to 'Spectrum3'.


Printing to a File

Remote Commands > Managing Settings and Results > Examples: Managing Data > Printing to a File
Printing to a File
HCOP:DEST 'MMEM'
//Prints the data to a file.
HCOP:DEV:LANG BMP
//Selects bmp as the file format.
MMEM:NAME 'C:\R_S\INST\USER\Screenshot.bmp'
//Selects the file name for the printout.
HCOP:ITEM:ALL
//Prints all screen elements
HCOP:ITEM:WIND:TEXT 'ACLRResults'
//Adds a comment to the printout.
HCOP
//Stores the printout in a file called 'Screenshot.bmp'.
HCOP:NEXT
//Stores the printout in a file called 'Screenshot_001.bmp'.


Printing on a Printer

Remote Commands > Managing Settings and Results > Examples: Managing Data > Printing on a Printer
Printing on a Printer
HCOP:DEST2 'SYST:COMM:PRIN'
//Prints the data on a printer.
SYST:COMM:PRIN:ENUM:FIRS?
SYST:COMM:PRIN:ENUM?
//Returns the available printers, e.g.
'LASER on LPT1'
''
//Means that one printer is available.
SYST:COMM:PRIN:SEL2 'LASER on LPT1'
//Selects the printer for the print job on device 2.
HCOP:PAGE:ORI2 LAND
//Selects the landscape format for the printout.
HCOP:TDST:STAT2 ON
//Includes date and time on the printout.
HCOP:ITEM:ALL
//Prints all screen elements
HCOP
//Initiates the printout.


Configuring the R&S FSW

Remote Commands > Configuring the R&S FSW
Configuring the R&S FSW

The remote commands required to set up the R&S FSW are described here.

Contents
  • Configuring the Reference Frequency
  • Calibration and Temperature Checks
  • Working with Transducers
  • Customizing the Screen Layout
  • Configuring the Network and Remote Control
  • Checking the System Configuration
  • Using Service Functions


Configuring the Reference Frequency

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency
Configuring the Reference Frequency
List of Commands
[SENSe:]ROSCillator:LBWidth
[SENSe:]ROSCillator:O100
[SENSe:]ROSCillator:O640
SOURce:EXTernal:ROSCillator:EXTernal:FREQuency
[SENSe:]ROSCillator:OSYNc
[SENSe:]ROSCillator:SOURce
[SENSe:]ROSCillator:SOURce:EAUTo?
[SENSe:]ROSCillator:TRANge


[SENSe:]ROSCillator:LBWidth

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > [SENSe:]ROSCillator:LBWidth
[SENSe:]ROSCillator:LBWidth <Bandwidth>

Defines the loop bandwidth, that is, the speed of internal synchronization with the reference frequency. The setting requires a compromise between performance and increasing phase noise.

For a variable external reference frequency with a narrow tuning range (+/- 0.5 ppm), the loop bandwidth is fixed to 0.1 Hz and cannot be changed.

Parameters:
<Bandwidth>
0.1 Hz | 1 Hz | 3 Hz | 10 Hz | 30 Hz | 100 Hz | 300 Hz

The possible values depend on the reference source and tuning range (see table "Available Reference Frequency Input").

Default unit: Hz
Example: ROSC:LBW 3
Manual operation: See "Loop Bandwidth"


[SENSe:]ROSCillator:O100

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > [SENSe:]ROSCillator:O100
[SENSe:]ROSCillator:O100 <State>

If enabled, a 100 MHz reference signal is provided to the REF OUTPUT 100 MHZ connector.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: ROSC:O100 ON
Manual operation: See "Reference Frequency Output"


[SENSe:]ROSCillator:O640

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > [SENSe:]ROSCillator:O640
[SENSe:]ROSCillator:O640 <State>

If enabled, a 640 MHz reference signal is provided to the REF OUTPUT 640 MHZ connector.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: ROSC:O640 ON
Manual operation: See "Reference Frequency Output"


SOURce:EXTernal:ROSCillator:EXTernal:FREQuency

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > SOURce:EXTernal:ROSCillator:EXTernal:FREQuency
SOURce:EXTernal:ROSCillator:EXTernal:FREQuency <Frequency>

This command defines the frequency of the external reference oscillator.

If the external reference oscillator is selected, the reference signal must be connected to the rear panel of the instrument.

Parameters:
<Frequency>
Range: 1 MHz to 20 MHz
Example: ROSC:EXT:FREQ 13MHZ

Sets the frequency to 13 MHz.

SOUR:EXT:ROSC:EXT:FREQ 13MHZ
Manual operation: See "Reference Frequency Input"


[SENSe:]ROSCillator:OSYNc

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > [SENSe:]ROSCillator:OSYNc
[SENSe:]ROSCillator:OSYNc <State>

If enabled, a 100 MHz reference signal is provided to the SYNC TRIGGER OUTPUT connector.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: ROSC:OSYN ON
Manual operation: See "Reference Frequency Output"


[SENSe:]ROSCillator:SOURce

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > [SENSe:]ROSCillator:SOURce
[SENSe:]ROSCillator:SOURce <Source>

This command selects the reference oscillator.

If you want to select the external reference, it must be connected to the R&S FSW.

Parameters:
<Source>
INTernal

the internal reference is used (10 MHz)

EXTernal

the external reference from REF INPUT 1..20 MHZ connector is used with a variable frequency; if none is available, an error flag is displayed in the status bar

E10

the external reference from REF INPUT 1..20 MHZ connector is used with a fixed 10 MHZ frequency; if none is available, an error flag is displayed in the status bar

E100

the external reference from REF INPUT 100 MHZ connector is used; if none is available, an error flag is displayed in the status bar

EAUTo

the external reference is used as long as it is available, then the instrument switches to the internal reference

SYNC

the external reference is used; if none is available, an error flag is displayed in the status bar

Example: ROSC:SOUR EXT
Usage: SCPI confirmed
Manual operation: See "Reference Frequency Input"
See "Behavior in case of missing external reference"


[SENSe:]ROSCillator:SOURce:EAUTo?

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > [SENSe:]ROSCillator:SOURce:EAUTo?
[SENSe:]ROSCillator:SOURce:EAUTo?

This command queries the current reference type in case you have activated an automatic switch to the internal reference if the external reference is missing.

Parameters:
<Reference> | INT internal reference EXT external reference
Example: | SENS:ROSC:SOUR:EAUT? Queries the currently available reference type.
Usage: | Query only
Manual operation: | See "Behavior in case of missing external reference"


[SENSe:]ROSCillator:TRANge

Remote Commands > Configuring the R&S FSW > Configuring the Reference Frequency > [SENSe:]ROSCillator:TRANge
[SENSe:]ROSCillator:TRANge <Range>

Defines the tuning range. The tuning range is only available for the variable external reference frequency. It determines how far the frequency may deviate from the defined level in parts per million (10-6).

For more information see table "Available Reference Frequency Input".

Parameters:
<Range>

The possible values depend on the reference source (see table "Available Reference Frequency Input").

SMALl

With this smaller deviation (+/- 0.5 ppm) a very narrow fixed loop bandwidth of 0.1 Hz is realized. With this setting the instrument can synchronize to an external reference signal with a very precise frequency. Due to the very narrow loop bandwidth, unwanted noise or spurious components on the external reference input signal are strongly attenuated. Furthermore, the loop requires about 30 seconds to reach a locked state. During this locking process, "NO REF" is displayed in the status bar.

WIDE

The larger deviation (+/- 6 ppm) allows the instrument to synchronize to less precise external reference input signals.

Example: ROSC:TRAN WIDE
Manual operation: See "Tuning Range"


Calibration and Temperature Checks

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks
Calibration and Temperature Checks

The following commands control calibration and temperature checks on the R&S FSW.

List of Commands
CALibration[:ALL]?
CALibration:RESult?
DIAGnostic:SERVice:INPut:MC:DISTance
DIAGnostic:SERVice:INPut:PULSed:CFRequency
DIAGnostic:SERVice:INPut:RF:SPECtrum
DIAGnostic:SERVice:INPut:AIQ[:TYPE]
DIAGnostic:SERVice:INPut[:SELect]
DIAGnostic:SERVice:STESt:RESult?
SOURce:TEMPerature:FRONtend?


CALibration[:ALL]?

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > CALibration[:ALL]?
CALibration[:ALL]?

This command initiates a calibration (self-alignment) routine and queries if calibration was successful.

During the acquisition of correction data the instrument does not accept any remote control commands.

In order to recognize when the acquisition of correction data is completed, the MAV bit in the status byte can be used. If the associated bit is set in the Service Request Enable (SRE) register, the instrument generates a service request after the acquisition of correction data has been completed.

Return values:
<CalibrationState> | 0 The command returns a '0' if calibration was successful.
Example: | *CLS Resets the status management. *SRE 16 Enables MAV bit in the Service Request Enable register. *CAL? Starts the correction data recording, and then a service request is generated.
Usage: | Query only SCPI confirmed
Manual operation: | See "Starting a Self-alignment"


CALibration:RESult?

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > CALibration:RESult?
CALibration:RESult?

This command returns the results collected during calibration.

Return values:
<CalibrationData> | String containing the calibration data.
Example: | CAL:RES? would return, e.g. Total Calibration Status: PASSED, Date (dd/mm/yyyy): 12/07/2004, Time: 16:24:54,Runtime: 00.06
Usage: | Query only
Manual operation: | See "Alignment Results"


DIAGnostic:SERVice:INPut:MC:DISTance

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > DIAGnostic:SERVice:INPut:MC:DISTance
DIAGnostic:SERVice:INPut:MC:DISTance <Bandwidth>

This command selects the distance of the peaks of the microwave calibration signal for calibration of the YIG filter.

This command is only available for instrument models R&S FSW13/26.

Parameters:
<Bandwidth> | SMALl Small offset of combline frequencies. WIDE Wide offset of combline frequencies.
Manual operation: | See "Calibration Frequency MW"


DIAGnostic:SERVice:INPut:PULSed:CFRequency

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > DIAGnostic:SERVice:INPut:PULSed:CFRequency
DIAGnostic:SERVice:INPut:PULSed:CFRequency <Frequency>

This command defines the frequency of the calibration signal.

Before you can use the command, you have to feed in a calibration signal with DIAGnostic:​SERVice:​INPut[:​SELect].

Parameters:
<Frequency>

Possible frequencies of the calibration signal are fix.

If you define a frequency that is not available, the R&S FSW uses the next available frequency. Example: a frequency of 20 MHz is rounded up to the next available frequency (21.33 MHz).

*RST: | 64 MHz
Default unit: | Hz
Manual operation: See "Calibration Frequency RF"


DIAGnostic:SERVice:INPut:RF:SPECtrum

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > DIAGnostic:SERVice:INPut:RF:SPECtrum
DIAGnostic:SERVice:INPut:RF:SPECtrum <Bandwidth>

This command selects the bandwidth of the calibration signal.

Parameters:
<Bandwidth> | NARRowband Narrowband signal for power calibration of the frontend. BROadband Broadband signal for calibration of the IF filter.
Manual operation: | See "Spectrum"


DIAGnostic:SERVice:INPut:AIQ[:TYPE]

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > DIAGnostic:SERVice:INPut:AIQ[:TYPE]
DIAGnostic:SERVice:INPut:AIQ[:TYPE] <SignalType>

This command defines the type of calibration signal to be used for Analog Baseband. This command is only available if the R&S FSW-B71 option is installed.

Parameters:
<SignalType>
AC

1.5625 MHz square wave AC signal

DC

DC signal

DCZ

no signal

*RST: AC
Example: DIAG:SERV:INP:AIQ:TYPE DCZ
Manual operation: See "Calibration Signal Type"


DIAGnostic:SERVice:INPut[:SELect]

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > DIAGnostic:SERVice:INPut[:SELect]
DIAGnostic:SERVice:INPut[:SELect] <Signal>

This command activates or deactivates the use of an internal calibration signal as input for the R&S FSW.

Parameters:
<Signal>
CALibration

Uses the calibration signal as RF input.

MCALibration

Uses the calibration signal for the microwave range as RF input.

RF

Uses the signal from the RF input.

AIQ

Uses the Analog Baseband calibration signal as input to the optional Analog Baseband interface. This signal is only available if the R&S FSW-B71 option is installed.

*RST: RF
Example: DIAG:SERV:INP CAL

Uses the calibration signal as RF input.

Manual operation: See "None"
See "Calibration Frequency RF"
See "Calibration Frequency MW"
See "Calibration Analog Baseband"


DIAGnostic:SERVice:STESt:RESult?

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > DIAGnostic:SERVice:STESt:RESult?
DIAGnostic:SERVice:STESt:RESult?

This command queries the self test results.

Return values:
<Results> | String of data containing the results. The rows of the self test result table are separated by commas.
Example: | DIAG:SERV:STES:RES? would return, e.g. "Total Selftest Status: PASSED", "Date (dd/mm/yyyy): 09/07/2004 TIME: 16:24:54", "Runtime: 00:06", "...
Usage: | Query only


SOURce:TEMPerature:FRONtend?

Remote Commands > Configuring the R&S FSW > Calibration and Temperature Checks > SOURce:TEMPerature:FRONtend?
SOURce:TEMPerature:FRONtend?

This command queries the current frontend temperature of the R&S FSW.

During self-alignment, the instrument's (frontend) temperature is also measured (as soon as the instrument has warmed up completely). This temperature is used as a reference for a continuous temperature check during operation. If the current temperature deviates from the stored self-alignment temperature by a certain degree, a warning is displayed in the status bar indicating the resulting deviation in the measured power levels. A status bit in the STATUs:QUEStionable:TEMPerature register indicates a possible deviation.

Return values:
<Temperature> | Temperature in degrees Celsius.
Example: | SOUR:TEMP:FRON? Queries the temperature of the frontend sensor.
Usage: | Query only


Working with Transducers

Remote Commands > Configuring the R&S FSW > Working with Transducers
Working with Transducers

The following commands configure and control transducer factors.

Useful commands for transducer managament described elsewhere
  • MMEMory:​SELect[:​ITEM]:​TRANsducer:​ALL
Remote commands exclusive to transducer management
List of Commands
[SENSe:]CORRection:TRANsducer:ADJust:RLEVel[:STATe]
[SENSe:]CORRection:TRANsducer:COMMent
[SENSe:]CORRection:TRANsducer:DATA
[SENSe:]CORRection:TRANsducer:DELete
[SENSe:]CORRection:TRANsducer:SCALing
[SENSe:]CORRection:TRANsducer:SELect
[SENSe:]CORRection:TRANsducer[:STATe]
[SENSe:]CORRection:TRANsducer:UNIT


[SENSe:]CORRection:TRANsducer:ADJust:RLEVel[:STATe]

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer:ADJust:RLEVel[:STATe]
[SENSe:]CORRection:TRANsducer:ADJust:RLEVel[:STATe] <State>

This command turns an automatic adjustment of the reference level to the transducer on and off.

Before you can use the command, you have to select and turn on a transducer.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Adjusting the Reference Level"


[SENSe:]CORRection:TRANsducer:COMMent

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer:COMMent
[SENSe:]CORRection:TRANsducer:COMMent <Comment>

This command defines the comment for the selected transducer factor.

Before you can use the command, you have to select and turn on a transducer.

Parameters:
<Comment>
*RST: (empty comment)
Example:

See "Example: SEM Measurement".

Manual operation: See "Comment"


[SENSe:]CORRection:TRANsducer:DATA

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer:DATA
[SENSe:]CORRection:TRANsducer:DATA <Frequency>,<Level>

This command defines the shape of the transducer factor.

Parameters:
<Frequency>, <Level> | The unit for <Frequency> is Hz. Frequencies have to be sorted in ascending order. The unit for <Level> depends on[SENSe:​]CORRection:​TRANsducer:​UNIT .
Example: | See "Example: SEM Measurement".
Manual operation: | See "Data points"


[SENSe:]CORRection:TRANsducer:DELete

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer:DELete
[SENSe:]CORRection:TRANsducer:DELete

This command deletes the currently selected transducer factor.

Before you can use the command, you have to select a transducer.

Example: | CORR:TRAN:DEL
Usage: | Event
Manual operation: | See "Delete Line"


[SENSe:]CORRection:TRANsducer:SCALing

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer:SCALing
[SENSe:]CORRection:TRANsducer:SCALing <ScalingType>

This command selects the frequency scaling of the transducer factor.

Parameters:
<ScalingType>
LINear | LOGarithmic
*RST: LINear
Manual operation: See "X-Axis Scaling"


[SENSe:]CORRection:TRANsducer:SELect

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer:SELect
[SENSe:]CORRection:TRANsducer:SELect <Name>

This command selects a transducer factor.

Parameters:
<Name> | String containing the name of the transducer factor. If the name does not exist yet, the R&S FSW creates a transducer factor by that name.
Example: | CORR:TRAN:SEL 'FACTOR1'
Example: | See "Example: SEM Measurement".
Manual operation: | See "Activating/Deactivating" See "Create New Line" See "Name"


[SENSe:]CORRection:TRANsducer[:STATe]

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer[:STATe]
[SENSe:]CORRection:TRANsducer[:STATe] <State>

This command turns the selected transducer factor on or off.

Before you can use the command, you have to select a transducer.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Example: SEM Measurement".

Manual operation: See "Activating/Deactivating"


[SENSe:]CORRection:TRANsducer:UNIT

Remote Commands > Configuring the R&S FSW > Working with Transducers > [SENSe:]CORRection:TRANsducer:UNIT
[SENSe:]CORRection:TRANsducer:UNIT <Unit>

This command selects the unit of the transducer factor.

Before you can use the command, you have to select and turn on a transducer.

Parameters:
<Unit>
string as defined in table below
*RST: DB
Example: CORR:TRAN:UNIT 'DBUV'
Example:

See "Example: SEM Measurement".

Manual operation: See "Unit"
String | Unit
'DB' | dB
'DBM' | dBm
'DBMV' | dBmV
'DBUV' | dBμV
'DBUV/M' | dBμV/m
'DBUA' | dBμA
'DBUA/M' | dBμA/m
'DBPW' | dBpW
'DBPT' | dBpT


Customizing the Screen Layout

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout
Customizing the Screen Layout

The remote commands required to set up the display of the R&S FSW are described here.

Contents
  • General Display Settings and Items
  • Colors and Themes
  • CMAP Suffix Assignment


General Display Settings and Items

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items
General Display Settings and Items

The following commands add, remove or customize general display and screen elements.

Useful commands for general display settings described elsewhere
  • DISPlay:​MTABle
  • DISPlay:​FORMat
Remote commands exclusive to general display settings
List of Commands
DISPlay:ANNotation:CBAR
DISPlay:ANNotation:FREQuency
DISPlay:PSAVe:HOLDoff
DISPlay:PSAVe[:STATe]
DISPlay:SBAR[:STATe]
DISPlay:SKEYs[:STATe]
DISPlay:TBAR[:STATe]
DISPlay:TOUChscreen:STATe
DISPlay[:WINDow]:TIME
DISPlay[:WINDow]:TIME:FORMat
SYSTem:DISPlay:FPANel[:STATe]


DISPlay:ANNotation:CBAR

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:ANNotation:CBAR
DISPlay:ANNotation:CBAR <State>

This command hides or displays the channel bar information.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DISP:ANN:CBAR OFF
Usage: SCPI confirmed
Manual operation: See "Channel Bar"


DISPlay:ANNotation:FREQuency

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:ANNotation:FREQuency
DISPlay:ANNotation:FREQuency <State>

This command turns the label of the x-axis on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DISP:ANN:FREQ OFF
Usage: SCPI confirmed
Manual operation: See "Diagram Footer (Annotation)"


DISPlay:PSAVe:HOLDoff

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:PSAVe:HOLDoff
DISPlay:PSAVe:HOLDoff <Minutes>

This command defines the time until the R&S FSW turns the display power save mode on.

Parameters:
<Minutes>

Minutes until power save mode starts. Note that the number you enter may have no dimension.

Range: | 1 to 100
*RST: | 15
Example: DISP:PSAV:HOLD 30
Manual operation: See "Display Power Save Function"


DISPlay:PSAVe[:STATe]

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:PSAVe[:STATe]
DISPlay:PSAVe[:STATe] <State>

This command turns the power save mode of the display on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:PSAVe ON

Switches on the power-save mode.

Manual operation: See "Display Power Save Function"


DISPlay:SBAR[:STATe]

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:SBAR[:STATe]
DISPlay:SBAR[:STATe] <State>

This command turns the status bar on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DISP:SBAR:OFF
Manual operation: See "Status Bar"


DISPlay:SKEYs[:STATe]

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:SKEYs[:STATe]
DISPlay:SKEYs[:STATe] <State>

This command turns the softkey bar on and off.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DISP:SKEY:OFF
Manual operation: See "Softkey Bar"


DISPlay:TBAR[:STATe]

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:TBAR[:STATe]
DISPlay:TBAR[:STATe] <State>

This command turns the toolbar on or off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:TOOL ON
Manual operation: See "Toolbar"


DISPlay:TOUChscreen:STATe

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay:TOUChscreen:STATe
DISPlay:TOUChscreen:STATe <State>

This command controls the touch screen functionality.

Parameters:
<State>
ON | 1

Touch screen is active for entire screen

OFF | 0

Touch screen is inactivate for entire screen

FRAMe

Touch screen is inactivate for the diagram area of the screen, but active for softkeys, toolbars and menus.

*RST: 1
Example: DISP:TOUC:STAT ON
Manual operation: See "Deactivating and Activating the Touchscreen"


DISPlay[:WINDow]:TIME

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay[:WINDow]:TIME
DISPlay[:WINDow]:TIME <State>

This command adds or removes the date and time from the display.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:TIME ON
Manual operation: See "Date and Time"


DISPlay[:WINDow]:TIME:FORMat

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > DISPlay[:WINDow]:TIME:FORMat
DISPlay[:WINDow]:TIME:FORMat <Format>

This command selects the time and date format.

Parameters:
<Format>
DE

dd.mm.yyyy hh:mm:ss

24 hour format.

US

mm/dd/yyyy hh:mm:ss

12 hour format.

*RST: DE
Example: DISP:TIME ON

Switches the screen display of date and time on.

DISP:TIME:FORM US

Switches the date and time format to US.

Manual operation: See "Date and Time Format"


SYSTem:DISPlay:FPANel[:STATe]

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > General Display Settings and Items > SYSTem:DISPlay:FPANel[:STATe]
SYSTem:DISPlay:FPANel[:STATe] <State>

This command includes or excludes the front panel keys when working with the remote desktop.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Manual operation: See "Front Panel"
See "Mini Front Panel"


Colors and Themes

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > Colors and Themes
Colors and Themes
Useful commands to customize display colors described elsewhere

The HCOPY commands define the print colors and thus only take effect on the display colors, if the display shows the printing colors.

  • HCOPy:​CMAP<item>:​DEFault<colors>
  • HCOPy:​CMAP<item>:​HSL
  • HCOPy:​CMAP<item>:​PDEFined
Remote commands exclusive to customize the display colors and themes
List of Commands
DISPlay:CMAP<item>:DEFault<colors>
DISPlay:CMAP<item>:HSL
DISPlay:CMAP<item>:PDEFined
DISPlay:THEMe:CATalog?
DISPlay:THEMe:SELect


DISPlay:CMAP<item>:DEFault<colors>

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > Colors and Themes > DISPlay:CMAP<item>:DEFault<colors>
DISPlay:CMAP<item>:DEFault<colors>

This command resets the color scheme for the display.

Suffix: |
<item> | Selects the item for which the color scheme is to be defined. For more information see "CMAP Suffix Assignment".
<colors> | 1...4 1 Current colors with a white background and a black grid. 2 Optimized colors. 3 Customized colors. 4 Current screen colors (setting for hardcopies).
Example: | DISP:CMAP:DEF2 Selects default setting 2 for setting the colors.
Usage: | Event SCPI confirmed
Manual operation: | See "Screen colors"


DISPlay:CMAP<item>:HSL

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > Colors and Themes > DISPlay:CMAP<item>:HSL
DISPlay:CMAP<item>:HSL <Color>

This command selects the color for various screen elements in the display.

Suffix: |
<item> | Selects the item for which the color scheme is to be defined. For more information see "CMAP Suffix Assignment".
Parameters:
<Color> | hue tint sat saturation lum brightness The value range is 0 to 1 for all parameters.
Example: | DISP:CMAP2:HSL 0.3,0.8,1.0 Changes the grid color.


DISPlay:CMAP<item>:PDEFined

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > Colors and Themes > DISPlay:CMAP<item>:PDEFined
DISPlay:CMAP<item>:PDEFined <Color>

This command selects a predefined color for various screen elements.

Suffix: |
<item> | Selects the item for which the color scheme is to be defined. For more information see "CMAP Suffix Assignment".
Parameters:
<Color> | BLACk | BLUE | BROWn | GREen | CYAN | RED | MAGenta | YELLow | WHITe | DGRAy | LGRAy | LBLUe | LGREen | LCYan | LRED | LMAGenta
Example: | DISP:CMAP2:PDEF GRE
Manual operation: | See "Restoring the User Settings to Default Colors"


DISPlay:THEMe:CATalog?

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > Colors and Themes > DISPlay:THEMe:CATalog?
DISPlay:THEMe:CATalog?

This command queries all available display themes.

Parameters:
<Themes> | String containing all available display themes.
Example: | DISP:THEMe:CAT?
Usage: | Query only


DISPlay:THEMe:SELect

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > Colors and Themes > DISPlay:THEMe:SELect
DISPlay:THEMe:SELect <Theme>

This command selects the display theme.

Parameters:
<Theme>

String containing the name of the theme.

*RST: SPL
Example: DISP:THEM:SEL "OceanBlue"
Manual operation: See "Theme"


CMAP Suffix Assignment

Remote Commands > Configuring the R&S FSW > Customizing the Screen Layout > CMAP Suffix Assignment
CMAP Suffix Assignment

Several commands to change the color settings of individual items of the display or printout are available. Which item is to be configured is defined using a <CMAP> suffix. The following assignment applies:

Suffix | Description
CMAP1 | Background
CMAP2 | Grid
CMAP3 *) | Common Text
CMAP4 *) | Check Status OK
CMAP5 *) | Check Status Error
CMAP6 *) | Text Special 1
CMAP7 *) | Text Special 2
CMAP8 | Trace 1
CMAP9 | Trace 2
CMAP10 | Trace 3
CMAP11 | Marker Info Text
CMAP12 | Limit Lines
CMAP13 | Limit and Margin Check – "Pass"
CMAP14 | Limit and Margin Check – "Fail"
CMAP15 *) | Softkey Text
CMAP16 *) | Softkey Background
CMAP17 *) | Selected Field Text
CMAP18 *) | Selected Field Background
CMAP19 *) | Softkey 3D Bright Part
CMAP20 *) | Softkey 3D Dark Part
CMAP21 *) | Softkey State "On"
CMAP22 *) | Softkey State "Dialog open"
CMAP23 *) | Softkey Text Disabled
CMAP24 | Logo
CMAP25 | Trace 4
CMAP26 | Grid – Minorlines
CMAP27 | Marker
CMAP28 | Display Lines
CMAP29 *) | Sweepcount – Text
CMAP30 | Limit and Margin Check – Text
CMAP31 | Limit and Margin Check – \"Margin\"
CMAP32 *) | Table Overall – Title Text
CMAP33 *) | Table Overall – Title Background
CMAP34 *) | Table Overall – Text
CMAP35 *) | Table Overall – Background
CMAP36 *) | Table Value – Title Text
CMAP37 *) | Table Value – Title Background
CMAP38 *) | Table Value – Text
CMAP39 *) | Table Value – Background
CMAP40 | Trace 5
CMAP41 | Trace 6

*) these settings can only be defined via the theme (DISPlay:​THEMe:​SELect) and are thus ignored in the SCPI command


Configuring the Network and Remote Control

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control
Configuring the Network and Remote Control

The following commands are required to configure a network or remote control for the R&S FSW.

Useful commands for configuring remote control described elsewhere:
  • SYSTem:​LANGuage
Remote commands exclusive to configuring a network and remote control
List of Commands
SYSTem:COMMunicate:GPIB[:SELF]:ADDRess
SYSTem:COMMunicate:GPIB[:SELF]:RTERminator
SYSTem:DISPlay:UPDate
SYSTem:IDENtify:FACTory
SYSTem:IDENtify[:STRing]
SYSTem:LXI:INFo?
SYSTem:LXI:LANReset
SYSTem:LXI:MDEScription
SYSTem:LXI:PASSword


SYSTem:COMMunicate:GPIB[:SELF]:ADDRess

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:COMMunicate:GPIB[:SELF]:ADDRess
SYSTem:COMMunicate:GPIB[:SELF]:ADDRess <Address>

This command sets the GPIB address of the R&S FSW.

Parameters:
<Address>
Range: | 0 to 30
*RST: | (no influence on this parameter, factory default 20)
Example: SYST:COMM:GPIB:ADDR 18
Usage: SCPI confirmed
Manual operation: See "GPIB Address"


SYSTem:COMMunicate:GPIB[:SELF]:RTERminator

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:COMMunicate:GPIB[:SELF]:RTERminator
SYSTem:COMMunicate:GPIB[:SELF]:RTERminator <Terminator>

This command selects the GPIB receive terminator.

According to the standard the terminator in ASCII is <LF> and/or <EOI>. For binary data transfers (e.g. trace data) from the control computer to the instrument, the binary code (0AH) used for <LF> might be included in the binary data block, and therefore should not be interpreted as a terminator in this particular case. This can be avoided by changing the receive terminator to EOI.

Output of binary data from the instrument to the control computer does not require such a terminator change.

Parameters:
<Terminator>
LFEOI | EOI
*RST: (no influence on this parameter, factory default LFEOI)
Example: SYST:COMM:GPIB:RTER EOI
Manual operation: See "GPIB Terminator"


SYSTem:DISPlay:UPDate

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:DISPlay:UPDate
SYSTem:DISPlay:UPDate <State>

This command turns the display during remote operation on and off.

If on, the R&S FSW updates the diagrams, traces and display fields only.

The best performance is obtained if the display is off during remote control operation.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SYST:DISP:UPD ON
Manual operation: See "Remote Display Update"


SYSTem:IDENtify:FACTory

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:IDENtify:FACTory
SYSTem:IDENtify:FACTory

This command resets the query to *IDN? to its default value.

Usage: | Event
Manual operation: | See "Reset to Factory String"


SYSTem:IDENtify[:STRing]

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:IDENtify[:STRing]
SYSTem:IDENtify[:STRing] <String>

This command defines the response to *IDN?.

Parameters:
<String> | String containing the description of the instrument.
Manual operation: | See "Identification String"


SYSTem:LXI:INFo?

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:LXI:INFo?
SYSTem:LXI:INFo?

This command queries the LXI settings.

Return values:
<LXIInfo> | <current version> | <LXI class> | <Computername> | <MAC adress> | <IP adress> | <Auto MDIX> String containing the current LXI parameters. • <version> • <LXIClass> • <ComputerName> • <MACAddress> • <IPAddress> • <AutoMDIX>
Usage: | Query only
Manual operation: | See "Current LXI Configuration"


SYSTem:LXI:LANReset

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:LXI:LANReset
SYSTem:LXI:LANReset

This command resets the LAN configuration as required by the LXI standard. The command also resets the LXI password and instrument description.

Usage: | Event
Manual operation: | See "LAN Reset"


SYSTem:LXI:MDEScription

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:LXI:MDEScription
SYSTem:LXI:MDEScription <Description>

This command defines the LXI instrument description.

Parameters:
<Description> | String containing the instrument description.
Manual operation: | See "LXI Manufacturer Description"


SYSTem:LXI:PASSword

Remote Commands > Configuring the R&S FSW > Configuring the Network and Remote Control > SYSTem:LXI:PASSword
SYSTem:LXI:PASSword <Password>

This command defines the LXI password.

Parameters:
<Password> | String containing the password.
Return values:
<Password> | The query returns the current password.
Manual operation: | See "LXI Password"


Checking the System Configuration

Remote Commands > Configuring the R&S FSW > Checking the System Configuration
Checking the System Configuration

The following commands are required to check the system configuration on the R&S FSW.

Useful commands for obtaining system information described elsewhere:
  • DIAGnostic:​SERVice:​SINFo?
Remote commands exclusive to obtaining system information:
List of Commands
DIAGnostic:INFO:CCOunter?
DIAGnostic:SERVice:BIOSinfo?
DIAGnostic:SERVice:HWINfo?
DIAGnostic:SERVice:VERSinfo?
SYSTem:ERRor:CLEar:ALL
SYSTem:ERRor:EXTended?
SYSTem:ERRor:LIST?
SYSTem:ERRor[:NEXT]?
SYSTem:FORMat:IDENt
SYSTem:PRESet:COMPatible
SYSTem:SECurity[:STATe]


DIAGnostic:INFO:CCOunter?

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > DIAGnostic:INFO:CCOunter?
DIAGnostic:INFO:CCOunter? <Relay>

This command queries how many switching cycles the individual relays have performed since they were installed.

Query parameters:
<Relay> | ACDC Mechanical Attenuation Coupling ATT5 Mechanical Attenuation 05 DB ATT10 Mechanical Attenuation 10 DB ATT20 Mechanical Attenuation 20 DB ATT40 Mechanical Attenuation 40 DB CAL Mechanical Calibration Source EATT Electrical Attenuation Bypass PREamp Preamplifier Bypass
Return values:
<Cycles> | Number of switching cycles.
Example: | DIAG:INFO:CCO? CAL
Usage: | Query only
Manual operation: | See "Relay Cycle Counter"


DIAGnostic:SERVice:BIOSinfo?

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > DIAGnostic:SERVice:BIOSinfo?
DIAGnostic:SERVice:BIOSinfo?

This command queries the BIOS version of the CPU board.

Return values:
<BiosInformation> | String containing the BIOS version.
Example: | DIAG:SERV:BIOS? Returns the BIOS version.
Usage: | Query only


DIAGnostic:SERVice:HWINfo?

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > DIAGnostic:SERVice:HWINfo?
DIAGnostic:SERVice:HWINfo?

This command queries hardware information.

Return values:
<Hardware> | String containing the following information for every hardware component. <component>: name of the hardware component <serial#>: serial number of the component <order#>: order number of the component <model>: model of the component <code>: code of the component <revision>: revision of the component
Example: | DIAG:SERV:HWIN? Queries the hardware information. "FRONTEND|100001/003|1300.3009|03|01|00|00", "MOTHERBOARD|123456/002|1300.3080|02|00|00|00", ...
Usage: | Query only


DIAGnostic:SERVice:VERSinfo?

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > DIAGnostic:SERVice:VERSinfo?
DIAGnostic:SERVice:VERSinfo?

This command queries information about the hardware and software components.

Return values:
<Information>

String containing the version of hardware and software components including the types of licenses for installed firmware options.

Example: DIAG:SERV:VERS?

Queries the version information.

Response:

Instrument Firmware |1.10
BIOS |FSW Analyzer BIOS V1.03-1-32-4-3 IPC10
Image Version |1.2.0
PCI-FPGA |9.01
SA-FPGA |2.43
MB-FPGA |2.0.8.0
SYNTH-FPGA |3.9.0.0
REF-FPGA |3.4.0.0
Data Sheet Version |01.00
Time Control Management |active
Analog Demod K7| |permanent
Usage: Query only
SCPI confirmed


SYSTem:ERRor:CLEar:ALL

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > SYSTem:ERRor:CLEar:ALL
SYSTem:ERRor:CLEar:ALL

This command deletes all contents of the "System Messages" table.

Example: | SYST:ERR:CLE:ALL
Usage: | Event
Manual operation: | See "Clear All Messages"


SYSTem:ERRor:EXTended?

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > SYSTem:ERRor:EXTended?
SYSTem:ERRor:EXTended? <MessageType>[, <ChannelName>]

This command queries all system messages, or all messages of a defined type, displayed in the status bar for a specific measurement channel (application).

Note: This command queries the strings displayed for manual operation. For remote programs, do not define processing steps depending on these results. Instead, query the results of the STATus:QUEStionable:EXTended:INFO status register, which indicates whether messages of a certain type have occurred (see "STATus:QUEStionable:EXTended:INFO Register").

Query parameters:
<MessageType> | ALL | INFO | WARNing | ERRor | FATal | MESSage
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Return values:
<Messages> | String containing all messages of the selected type for the specified measurement channel. Each message is separated by a comma and inserted in parentheses. If no messages are available, empty parentheses are returned.
Example: | SYST:ERR:EXT? ALL Returns all messages for the currently active application, e.g. "Message 1","Message 2".
Example: | SYST:ERR:EXT? FAT,'Spectrum2' Queries fatal errors in the 'Spectrum2' application. If none have occurred, the result is: " ".
Usage: | Query only


SYSTem:ERRor:LIST?

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > SYSTem:ERRor:LIST?
SYSTem:ERRor:LIST?

This command queries the system messages.

Return values:
<Messages> | String containing all messages in the "System Messages" table.
Example: | SYST:ERR:LIST?
Usage: | Query only


SYSTem:ERRor[:NEXT]?

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > SYSTem:ERRor[:NEXT]?
SYSTem:ERRor[:NEXT]?

This command queries the most recent error queue entry and deletes it.

Positive error numbers indicate device-specific errors, negative error numbers are error messages defined by SCPI. If the error queue is empty, the error number 0, "No error", is returned.

For details on error queues see "Status Reporting System".

Usage: Query only


SYSTem:FORMat:IDENt

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > SYSTem:FORMat:IDENt
SYSTem:FORMat:IDENt <IDNFormat>

This command selects the response format to the *IDN? query.

Parameters:
<IDNFormat>
LEGacy

Format is compatible to R&S FSP/FSU/FSQ/FSG family.

NEW | FSL

R&S FSW format

Format is also compatible to the R&S FSL and R&S FSV family

*RST: not reset!
Example: SYST:FORM:IDEN LEG

Adapts the return value of *IDN? to the R&S FSP/FSU/FSQ family.

Manual operation: See "*IDN Format"


SYSTem:PRESet:COMPatible

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > SYSTem:PRESet:COMPatible
SYSTem:PRESet:COMPatible <OpMode>

This command defines the operating mode that is activated when you switch on the R&S FSW or press the PRESET key.

For details on operating modes see "Applications and Operating Modes".

Parameters:
<OpMode>
SANalyzer

(Default:) Defines Signal and Spectrum Analyzer operating mode as the presetting.

MSRA

Defines Multi-Standard Radio Analysis (MSRA) as the preset default operating mode.

RTSM

Defines Multi-Standard Realtime (MSRT) as the preset default operating mode.

*RST: SAN
Usage: Event
Manual operation: See "Preset Mode"


SYSTem:SECurity[:STATe]

Remote Commands > Configuring the R&S FSW > Checking the System Configuration > SYSTem:SECurity[:STATe]
SYSTem:SECurity[:STATe] <State>

Activates or queries secure user mode.

Note: Before you activate secure user mode, store any instrument settings that are required beyond the current session, such as predefined instrument settings, transducer files, or self-alignment data.

Note: Initially after installation of the R&S FSW-K33 option, secure user mode must be enabled manually once before remote control is possible. This is necessary to prompt for a change of passwords.

For details on the secure user mode see "Protecting Data Using the Secure User Mode".

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The R&S FSW automatically reboots and starts in secure user mode. In secure user mode, no data is written to the instrument's internal solid-state drive. Data that the R&S FSW normally stores on the solid-state drive is redirected to SDRAM.

OFF | 0

The R&S FSW is set to normal instrument mode. Data is stored to the internal solid-state drive.

*RST: 0
Manual operation: See "Secure User Mode"


Using Service Functions

Remote Commands > Configuring the R&S FSW > Using Service Functions
Using Service Functions
List of Commands
DIAGnostic:SERVice:SFUNction
DIAGnostic:SERVice:SFUNction:LASTresult?
DIAGnostic:SERVice:SFUNction:RESults:DELete
DIAGnostic:SERVice:SFUNction:RESults:SAVE
DIAGnostic:SERVice:SINFo?


DIAGnostic:SERVice:SFUNction

Remote Commands > Configuring the R&S FSW > Using Service Functions > DIAGnostic:SERVice:SFUNction
DIAGnostic:SERVice:SFUNction <ServiceFunction>

This command starts a service function.

The service functions are available after you have entered the level 1 or level 2 system password.

Parameters:
<ServiceFunction> | String containing the ID of the service function. The ID of the service function is made up out of five numbers, separated by a point. • function group number • board number • function number • parameter 1 (see the Service Manual) • parameter 2 (see the Service Manual)
Usage: | Event
Manual operation: | See "Service Function" See "Send"


DIAGnostic:SERVice:SFUNction:LASTresult?

Remote Commands > Configuring the R&S FSW > Using Service Functions > DIAGnostic:SERVice:SFUNction:LASTresult?
DIAGnostic:SERVice:SFUNction:LASTresult?

This command queries the results of the most recent service function you have used.

Usage: Query only


DIAGnostic:SERVice:SFUNction:RESults:DELete

Remote Commands > Configuring the R&S FSW > Using Service Functions > DIAGnostic:SERVice:SFUNction:RESults:DELete
DIAGnostic:SERVice:SFUNction:RESults:DELete

This command deletes the results of the most recent service function you have used.

Usage: | Event
Manual operation: | See "Clear Results"


DIAGnostic:SERVice:SFUNction:RESults:SAVE

Remote Commands > Configuring the R&S FSW > Using Service Functions > DIAGnostic:SERVice:SFUNction:RESults:SAVE
DIAGnostic:SERVice:SFUNction:RESults:SAVE <FileName>

This command saves the results of the most recent service function you have used.

Parameters:
<FileName> | String containing the file name.
Manual operation: | See "Save Results"


DIAGnostic:SERVice:SINFo?

Remote Commands > Configuring the R&S FSW > Using Service Functions > DIAGnostic:SERVice:SINFo?
DIAGnostic:SERVice:SINFo? <FileName>

This command creates a *.zip file with important support information. The *.zip file contains the system configuration information ("device footprint"), the current eeprom data and a screenshot of the screen display (if available).

This data is stored to the C:\R_S\Instr\user\ directory on the instrument. As a result of this command, the created file name (including the drive and path) is returned. You can use the resulting file name information as a parameter for the MMEM:COPY command to store the file on the controller PC.

(See MMEMory:​COPY)

If you contact the Rohde&Schwarz support to get help for a certain problem, send this file to the support in order to identify and solve the problem faster.

Return values:
<FileName>
C:\R_S\Instr\user\<R&S Device ID>_<CurrentDate>_<CurrentTime>

String containing the drive, path and file name of the created support file, where the file name consists of the following elements:

<R&S Device ID>: The unique R&S device ID indicated in the "Versions + Options" information

(See "Information on Versions and Options")

<CurrentDate>: The date on which the file is created (<YYYYMMDD>)

<CurrentTime>: The time at which the file is created (<HHMMSS>)

Example: DIAG:SERV:SINF?

Result:

"c:\R&S\instr\user\FSW-26_1312.8000K26-100005-xx_20130116_165858.zip"

Copy to controller PC:

MMEM:COPY "c:\R&S\instr\user\FSW-26_
1312.8000K26-100005-xx_20130116_165858.zip",
"S:\Debug\FSW-26_1312.8000K26-100005-xx_
20130116_165858.zip"
Usage: Query only
Manual operation: See "Creating R&S Support Information"


Using the Status Register

Remote Commands > Using the Status Register
Using the Status Register

For more information on the contents of the status registers see:

  • "STATus:OPERation Register"
  • "STATus:QUEStionable:ACPLimit Register"
  • "STATus:QUEStionable:EXTended Register"
  • "STATus:QUEStionable:FREQuency Register"
  • "STATus:QUEStionable:LIMit Register"
  • "STATus:QUEStionable:LMARgin Register"
  • "STATus:QUEStionable:POWer Register"
  • "STATus:QUEStionable:TEMPerature Register"
  • "STATus:QUEStionable:TIMe Register"
Contents
  • General Status Register Commands
  • Reading Out the CONDition Part
  • Reading Out the EVENt Part
  • Controlling the ENABle Part
  • Controlling the Negative Transition Part
  • Controlling the Positive Transition Part


General Status Register Commands

Remote Commands > Using the Status Register > General Status Register Commands
General Status Register Commands
List of Commands
STATus:PRESet
STATus:QUEue[:NEXT]?


STATus:PRESet

Remote Commands > Using the Status Register > General Status Register Commands > STATus:PRESet
STATus:PRESet

This command resets the edge detectors and ENABle parts of all registers to a defined value. All PTRansition parts are set to FFFFh, i.e. all transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition from 1 to 0 in a CONDition bit is not detected. The ENABle part of the STATus:OPERation and STATus:QUEStionable registers are set to 0, i.e. all events in these registers are not passed on.

Usage: Event


STATus:QUEue[:NEXT]?

Remote Commands > Using the Status Register > General Status Register Commands > STATus:QUEue[:NEXT]?
STATus:QUEue[:NEXT]?

This command queries the most recent error queue entry and deletes it.

Positive error numbers indicate device-specific errors, negative error numbers are error messages defined by SCPI. If the error queue is empty, the error number 0, "No error", is returned.

This command is identical to the SYSTem:​ERRor[:​NEXT]? command.

Usage: Query only


Reading Out the CONDition Part

Remote Commands > Using the Status Register > Reading Out the CONDition Part
Reading Out the CONDition Part

For more information on the condition part see "Structure of a SCPI Status Register".

List of Commands
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:EXTended:CONDition?
STATus:QUEStionable:EXTended:INFO:CONDition?
STATus:QUEStionable:FREQuency:CONDition?
STATus:QUEStionable:LIMit<n>:CONDition?
STATus:QUEStionable:LMARgin<n>:CONDition?
STATus:QUEStionable:POWer:CONDition?
STATus:QUEStionable:TEMPerature:CONDition?
STATus:QUEStionable:TIME:CONDition?


STATus:OPERation:CONDition?

Remote Commands > Using the Status Register > Reading Out the CONDition Part > STATus:OPERation:CONDition?
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ACPLimit:CONDition? <ChannelName>
STATus:QUEStionable:EXTended:CONDition? <ChannelName>
STATus:QUEStionable:EXTended:INFO:CONDition? <ChannelName>
STATus:QUEStionable:FREQuency:CONDition? <ChannelName>
STATus:QUEStionable:LIMit<n>:CONDition? <ChannelName>
STATus:QUEStionable:LMARgin<n>:CONDition? <ChannelName>
STATus:QUEStionable:POWer:CONDition? <ChannelName>
STATus:QUEStionable:TEMPerature:CONDition? <ChannelName>
STATus:QUEStionable:TIME:CONDition? <ChannelName>

These commands read out the CONDition section of the status register.

The commands do not delete the contents of the CONDition section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


Reading Out the EVENt Part

Remote Commands > Using the Status Register > Reading Out the EVENt Part
Reading Out the EVENt Part

For more information on the event part see "Structure of a SCPI Status Register".

List of Commands
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:EXTended[:EVENt]?
STATus:QUEStionable:EXTended:INFO[:EVENt]?
STATus:QUEStionable:FREQuency[:EVENt]?
STATus:QUEStionable:LIMit<n>[:EVENt]?
STATus:QUEStionable:LMARgin<n>[:EVENt]?
STATus:QUEStionable:POWer[:EVENt]?
STATus:QUEStionable:TEMPerature[:EVENt]?
STATus:QUEStionable:TIME[:EVENt]?


STATus:OPERation[:EVENt]?

Remote Commands > Using the Status Register > Reading Out the EVENt Part > STATus:OPERation[:EVENt]?
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:ACPLimit[:EVENt]? <ChannelName>
STATus:QUEStionable:EXTended[:EVENt]? <ChannelName>
STATus:QUEStionable:EXTended:INFO[:EVENt]? <ChannelName>
STATus:QUEStionable:FREQuency[:EVENt]? <ChannelName>
STATus:QUEStionable:LIMit<n>[:EVENt]? <ChannelName>
STATus:QUEStionable:LMARgin<n>[:EVENt]? <ChannelName>
STATus:QUEStionable:POWer[:EVENt]? <ChannelName>
STATus:QUEStionable:TEMPerature[:EVENt]? <ChannelName>
STATus:QUEStionable:TIME[:EVENt]? <ChannelName>

These commands read out the EVENt section of the status register.

At the same time, the commands delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


Controlling the ENABle Part

Remote Commands > Using the Status Register > Controlling the ENABle Part
Controlling the ENABle Part

For more information on the enable part see "Structure of a SCPI Status Register".

List of Commands
STATus:OPERation:ENABle
STATus:QUEStionable:ENABle
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:EXTended:ENABle
STATus:QUEStionable:EXTended:INFO:ENABle
STATus:QUEStionable:FREQuency:ENABle
STATus:QUEStionable:LIMit<n>:ENABle
STATus:QUEStionable:LMARgin<n>:ENABle
STATus:QUEStionable:POWer:ENABle
STATus:QUEStionable:TEMPerature:ENABle
STATus:QUEStionable:TIME:ENABle


STATus:OPERation:ENABle

Remote Commands > Using the Status Register > Controlling the ENABle Part > STATus:OPERation:ENABle
STATus:OPERation:ENABle <SumBit>
STATus:QUEStionable:ENABle <SumBit>
STATus:QUEStionable:ACPLimit:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:EXTended:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:EXTended:INFO:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:FREQuency:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:LMARgin<n>:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:POWer:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:TEMPerature:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:TIME:ENABle <SumBit>,<ChannelName>

These commands control the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to bereported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Controlling the Negative Transition Part

Remote Commands > Using the Status Register > Controlling the Negative Transition Part
Controlling the Negative Transition Part

For more information on the positive transition part see "Structure of a SCPI Status Register".

List of Commands
STATus:OPERation:NTRansition
STATus:QUEStionable:NTRansition
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:EXTended:NTRansition
STATus:QUEStionable:EXTended:INFO:NTRansition
STATus:QUEStionable:FREQuency:NTRansition
STATus:QUEStionable:LIMit<n>:NTRansition
STATus:QUEStionable:LMARgin<n>:NTRansition
STATus:QUEStionable:POWer:NTRansition
STATus:QUEStionable:TEMPerature:NTRansition
STATus:QUEStionable:TIME:NTRansition


STATus:OPERation:NTRansition

Remote Commands > Using the Status Register > Controlling the Negative Transition Part > STATus:OPERation:NTRansition
STATus:OPERation:NTRansition <SumBit>
STATus:QUEStionable:NTRansition <SumBit>
STATus:QUEStionable:ACPLimit:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:EXTended:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:EXTended:INFO:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:FREQuency:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LMARgin<n>:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:POWer:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:TEMPerature:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:TIME:NTRansition <SumBit>,<ChannelName>

These commands control the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Controlling the Positive Transition Part

Remote Commands > Using the Status Register > Controlling the Positive Transition Part
Controlling the Positive Transition Part

For more information on the negative transition part see "Structure of a SCPI Status Register".

List of Commands
STATus:OPERation:PTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:EXTended:PTRansition
STATus:QUEStionable:EXTended:INFO:PTRansition
STATus:QUEStionable:FREQuency:PTRansition
STATus:QUEStionable:LIMit<n>:PTRansition
STATus:QUEStionable:LMARgin<n>:PTRansition
STATus:QUEStionable:POWer:PTRansition
STATus:QUEStionable:TEMPerature:PTRansition
STATus:QUEStionable:TIME:PTRansition


STATus:OPERation:PTRansition

Remote Commands > Using the Status Register > Controlling the Positive Transition Part > STATus:OPERation:PTRansition
STATus:OPERation:PTRansition <SumBit>
STATus:QUEStionable:PTRansition <SumBit>
STATus:QUEStionable:ACPLimit:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:EXTended:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:EXTended:INFO:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:FREQuency:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LMARgin<n>:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:POWer:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:TEMPerature:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:TIME:PTRansition <SumBit>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Commands for Remote Instrument Operation

Remote Commands > Commands for Remote Instrument Operation
Commands for Remote Instrument Operation

The following commands are required to shutdown or reboot the R&S FSW from a remote PC.

List of Commands
SYSTem:CLOGging
SYSTem:REBoot
SYSTem:SHUTdown


SYSTem:CLOGging

Remote Commands > Commands for Remote Instrument Operation > SYSTem:CLOGging
SYSTem:CLOGging <State>

This command turns logging of remote commands on and off.

Parameters:
<State>
ON

Writes all remote commands that have been sent to a file.

The destination is C:\R_S\instr\ScpiLogging\ScpiLog.txt.

OFF
*RST: OFF
Manual operation: See "I/O Logging"


SYSTem:REBoot

Remote Commands > Commands for Remote Instrument Operation > SYSTem:REBoot
SYSTem:REBoot

This command reboots the instrument, including the operating system.

Usage: Event


SYSTem:SHUTdown

Remote Commands > Commands for Remote Instrument Operation > SYSTem:SHUTdown
SYSTem:SHUTdown

This command shuts down the instrument.

Usage: Event


Emulating Other Instruments' Commands

Remote Commands > Emulating Other Instruments' Commands
Emulating Other Instruments' Commands

The R&S FSW analyzer family supports a subset of the GPIB commands of several HP and PSA instruments.

For details see "GPIB Languages".

Contents
  • Setting up Instrument Emulation
  • Reference: GPIB Commands of Emulated HP Models
  • Reference: Command Set of Emulated PSA Models


Setting up Instrument Emulation

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation
Setting up Instrument Emulation

The following commands are required to set up the use of commands to emulate other instruments.

List of Commands
SYSTem:HPCoupling
SYSTem:IFGain:MODE
SYSTem:LANGuage
SYSTem:PREamplifier
SYSTem:PSA:WIDeband
SYSTem:REVision:FACTory
SYSTem:REVision[:STRing]
SYSTem:RSW


SYSTem:HPCoupling

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:HPCoupling
SYSTem:HPCoupling <CouplingType>

Controls the default coupling ratios in the HP emulation mode for:

  • span and resolution bandwidth (Span/RBW) and
  • resolution bandwidth and video bandwidth (RBW/VBW)

For FSP (=FSW), the standard parameter coupling of the instrument is used. As a result, in most cases a shorter sweep time is used than in case of HP.

This command is only available if a HP language is selected using SYSTem:​LANGuage.

Parameters:
<CouplingType>
HP | FSP
*RST: FSP
Example: SYSTem:HPC HP
Manual operation: See "Coupling"


SYSTem:IFGain:MODE

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:IFGain:MODE
SYSTem:IFGain:MODE <Mode>

Configures the internal IF gain settings in HP emulation mode due to the application needs. This setting is only taken into account for resolution bandwidth < 300 kHz and is only available if a HP language is selected using SYSTem:​LANGuage.

Parameters:
<Mode>
NORM | PULS
NORM

Optimized for high dynamic range, overload limit is close to reference level.

PULS

Optimized for pulsed signals, overload limit up to 10 dB above reference level.

*RST: NORM
Example: SYST:IFG:MODE PULS
Manual operation: See "IF Gain"


SYSTem:LANGuage

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:LANGuage
SYSTem:LANGuage <Language>

This command defines the system language.

For details see "GPIB Languages".

Note: as of firmware version 1.60, this command is also used to emulate previous R&S signal and spectrum analyzers, making the SYST:COMP command obsolete.

Note: For PSA89600 emulation, the option is indicated as "B7J" for the *OPT? query ("B7J, 140" if "Wideband" is activated).

Parameters:
<Language>
"SCPI" | "8560E" | "8561E" | "8562E" | "8563E" | "8564E" | "8565E" | "8566A" | "8566B" | "8568A" | "8568A_DC" | "8568B" | "8568B_DC" | "8591E" | "8594E" | "71100C" | "71200C" | "71209A" | "PSA89600" | "FSP" | "FSU" | "FSQ" | "FSV" | "FSEA" | "FSEB" | "FSEM" | "FSEK"
*RST: SCPI
Example: SYST:LANG '8560E'

Sets the system language to 8560E to simulate the HP model.

Usage: SCPI confirmed
Manual operation: See "Language"


SYSTem:PREamplifier

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:PREamplifier
SYSTem:PREamplifier <Option>

This setting defines which option is returned when the *OPT? query is executed, depending on the used preamplifier.

It is only available for FSU/FSQ emulation, and only if a preamplifier is used by the R&S FSW (-B24/-B25 option).

Parameters:
<Option>
B23 | B24
*RST: B23
Manual operation: See "FSU/FSQ Preamplifier"


SYSTem:PSA:WIDeband

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:PSA:WIDeband
SYSTem:PSA:WIDeband <State>

This command defines which option is returned when the *OPT? query is executed, depending on the state of the wideband option.

It is only available for PSA89600 emulation.

Parameters:
<State>
ON | OFF | HIGH
OFF

The option is indicated as "B7J"

ON

The 40 MHz wideband is used.

The option is indicated as "B7J, 140".

HIGH

The 80 MHz wideband is used.

The option is indicated as "B7J, 122".

*RST: OFF
Manual operation: See "Language"
See "Wideband"


SYSTem:REVision:FACTory

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:REVision:FACTory
SYSTem:REVision:FACTory

Resets the response to the REV? query to the default value, e.g. after a user string was defined using the SYSTem:​REVision[:​STRing] command. (REV? query available for HP emulation only, see SYSTem:​LANGuage.)

Example: | Define the system language: SYST:LANG '8563E' Set the response back to factory setting: SYS:REV:FACT Query the revision: REV? Response: 920528
Manual operation: | See "Resetting the Factory Revision"


SYSTem:REVision[:STRing]

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:REVision[:STRing]
SYSTem:REVision[:STRing] <Name>

Sets the response to the REV? query to the defined string (HP emulation only, see SYSTem:​LANGuage).

Parameters:
<Name> |
Example: | Define the system language: SYST:LANG '8563E' Query the revision: REV? Response: 920528 Set the response to 'NewRevision': SYST:REV:STR 'NewRevision' Query the response: SYST:REV:STR? Response: NewRevision
Manual operation: | See "Revision String"


SYSTem:RSW

Remote Commands > Emulating Other Instruments' Commands > Setting up Instrument Emulation > SYSTem:RSW
SYSTem:RSW <State>

Controls a repeated sweep of the E1 and MKPK HI HP model commands (for details on the commands refer to "Reference: GPIB Commands of Emulated HP Models"). If the repeated sweep is OFF, the marker is set without sweeping before.

This command is only available if a HP language is selected using SYSTem:​LANGuage

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SYSTem:RSW ON
Manual operation: See "Sweep Repeat"


Reference: GPIB Commands of Emulated HP Models

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models
Reference: GPIB Commands of Emulated HP Models

The R&S FSW analyzer family supports a subset of the GPIB commands of HP models 8560E, 8561E, 8562E, 8563E, 8564E, 8565E, 8566A, 8566B, 8568A, 8568B and 8594E.

Despite the differences in system architecture and device features, the supported commands have been implemented in a way to ensure a sufficiently high degree of correspondence with the original.

This includes the support of syntax rules for not only newer device families (B and E models) but for the previous A family as well.

In many cases the selection of commands supported by the R&S FSW is sufficient to run an existing GPIB program without adaptation.

After the introduction, this section includes the following topics:

Contents
  • Command Set of Models 8560E, 8561E, 8562E, 8563E, 8564E, 8565E, 8566A/B, 8568A/B, 8591E, 8594E, 71100C, 71200C, and 71209A
  • Special Features of the Syntax Parsing Algorithms for 8566A and 8568A Models
  • Special Behavior of Commands
  • Model-Dependent Default Settings
  • Data Output Formats
  • Trace Data Output Formats
  • Trace Data Input Formats
  • GPIB Status Reporting


Command Set of Models 8560E, 8561E, 8562E, 8563E, 8564E, 8565E, 8566A/B, 8568A/B, 8591E, 8594E, 71100C, 71200C, and 71209A

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > Command Set of Models 8560E, 8561E, 8562E, 8563E, 8564E, 8565E, 8566A/B, 8568A/B, 8591E, 8594E, 71100C, 71200C, and 71209A
Command Set of Models 8560E, 8561E, 8562E, 8563E, 8564E, 8565E, 8566A/B, 8568A/B, 8591E, 8594E, 71100C, 71200C, and 71209A

As with the original units, the R&S FSW includes the command set of the A models in the command set of the B models.

The HP model 8591E is compatible to HP model 8594E, the HP models 71100C, 71200C, and 71209A are compatible to HP models 8566A/B.

Command | Supported subset | Function | Corresp. HP-Models | Status
A1 | A1 | Clear/Write A | HP 8566A/ HP 8568A | available
A2 | A2 | Max Hold A | HP 8566A/ HP 8568A | available
A3 | A3 | View A | HP 8566A/ HP 8568A | available
A4 | A4 | Blank A | HP 8566A/ HP 8568A | available
ABORT 1) | ABORT | Stop previous function | HP 856xE/ HP 8566B/HP 8568B/HP 8594E | available
ADD |  | Add | HP 8566B/ HP 8568B/ HP 8594E | available
ADJALL | ADJALL | Adjust all | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
ADJCRT 2) | ADJCRT | Adjust CRT | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
ADJIF 2) | ADJIF | Auto adjust IF | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
AMB | AMB ON|OFF AMB 1|0 AMB? | Trace A – B -> Trace A | HP 856xE/ HP 8594E | available
AMBPL | AMBPL ON|OFF AMBPL 1|0 AMBPL? |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
AMPCORDATA | AMPCORDATA <freq>,<amp>,.. AMPCORDATA? | Amplitude Correction Data | HP 856xE | available
AMPCOR | AMPCOR ON|OFF AMPCOR 1|0 AMPCOR? | Amplitude Correction | HP 856xE | available
AMPCORSIZE | AMPCORSIZE? | Amplitude Correction Data Array Size | HP 856xE | available
AMPCORRCL | AMPCORRCL <numeric value> | Amplitude Correction Recall | HP 856xE | available
AMPCORSAVE | AMPCORSAVE <numeric value> | Amplitude Correction Save | HP 856xE | available
ANNOT | ANNOT ON|OFF ANNOT 1|0 ANNOT? | Annotation | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
APB | APB | Trace A + B -> Trace A | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
AT | AT <numeric_value> DB | DM AT DN AT UP AT AUTO AT? | Attenuation | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
AUNITS | AUNITS DBM | DBMV | DBUV | AUNITS? | Amplitude Units | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
AUTOCPL | AUTOCPL | Coupling default | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
AXB | AXB | Exchange trace A and B | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
B1 | B1 | Clear/Write B | HP 8566A/ HP 8568A | available
B2 | B2 | Max Hold B | HP 8566A/ HP 8568A | available
B3 | B3 | View B | HP 8566A/ HP 8568A | available
B4 | B4 | Blank B | HP 8566A/ HP 8568A | available
BL | BL | Trace B – Display Line -> Trace B | HP 8566A/ HP 8568A | available
BML | BML | Trace B – Display Line -> Trace B | HP 856xE/ HP8594E | available
BTC | BTC | Transfer Trace B -> C | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
BXC | BXC | Exchange Trace B and C | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
BLANK | BLANK TRA|TRB|TRC | Blank Trace | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
C1 | C1 | A-B off | HP 8566A/ HP 8568A | available
C2 | C2 | A-B -> A | HP 8566A/ HP 8568A | available
CA | CA | Couple Attenuation | HP 8566A/ HP 8568A | available
CAL 1) | CAL ALL CAL ON CAL OFF | Start analyzer self alignment | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
CF | CF <numeric_value> HZ|KHZ|MHZ|GHZ CF UP CF DN CF? | Center Frequency | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
CHANPWR | CHANPWR TRA|TRB, <numeric_value>,? | Channel Power Measurement | HP 856xE/ HP 8594E | available
CHPWRBW | CHPWRBW <numeric_value> HZ|KHZ|MHZ|GHZ | Channel Power Bandwidth | HP 856xE/ HP 8594E | available
CLRW | CLRW TRA|TRB|TRC | Clear/Write Trace | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
CLS 1) | CLS | Clear all status bits | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
CONTS | CONTS |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
COUPLE | COUPLE AC|DC | Input coupling | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
CR | CR | Couple RBW | HP 8566A/ HP 8568A | available
CS | CS | Couple Step Size | HP 8566A/ HP 8568A | available
CT | CT | Couple SWT | HP 8566A/ HP 8568A | available
CTA |  | Convert to absolute units | HP 8566B/ HP 8568B/ HP 8594E | available
CV | CV | Couple VBW | HP 8566A/ HP 8568A | available
D1 2) | D1 | Display Size normal | HP 8566A/ HP 8568A | available
DA 2) | DA | Display address |  | available
DEMOD 1) | DEMOD ON|OFF|AM|FM | AF Demodulator | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
DEMODAGC 2) | DEMODAGC ON|OFF|1|0 DEMODAGC? | Demodulation AGC | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
DEMODT | DEMODT <numeric_value> S|MS|US|SC DEMODT UP|DN DEMODT? | Demodulation time | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
DET | DET POS|SMP|NEG DET? | Detector | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
DISPOSE 2) | ONEOS | TRMATH | ONSWP | ALL | <numeric_value> |  |  | available
DIV |  | Divide | HP 8566B/ HP 8568B/ HP 8594E | available
DL | DL <numeric_value> DB|DM DL DN DL UP DL ON DL OFF DL? | Display Line | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
DLE | DLE ON|OFF | Display Line enable | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
DONE | DONE DONE? | Done query | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
DW 2) | DW | Write to display and increment address |  | available
E1 | E1 | Peak Search | HP 8566A/ HP 8568A | available
E2 | E2 | Marker to Center Freq. | HP 8566A/ HP 8568A | available
E3 | E3 | Deltamarker Step Size | HP 8566A/ HP 8568A | available
E4 | E4 | Marker to Ref. Level | available | available
EDITDONE |  | limit line edit done | HP 856xE | available
EDITLIML |  | edit limit line | HP 856xE | available
ERR | ERR 250 cal level error ERR 300 LO unlock ERR 472 cal error digital filter ERR 473 cal error analog filter ERR 552 cal error log amp ERR 902 unscale tracking generator ERR 906 oven cold ERR 117 numeric unit error ERR 112 Unrecognized Command | Now some FSx errors are mapped to HP errors. | HP8568A HP856xE | not yet available
ERR? | ERR? | Error queue query | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | not yet available
EX | EX | Exchange trace A and B | HP 8566A/ HP 8568A | available
FA | FA <numeric_value> HZ|KHZ|MHZ|GHZ FA UP FA DN FA? | Start Frequency | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
FB | FB <numeric_value> HZ|KHZ|MHZ|GHZ FB UP FB DN FB? | Stop Frequency | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
FDSP |  | Frequency display off | 8560E 8561E 8562E 8563E 8564E 8565E | available
FOFFSET 1) | FOFFSET <numeric_value> HZ|KHZ|MHZ|GHZ FOFFSET? | Frequency Offset | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
FREF | FREF INT|EXT | Reference Frequency | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
FS | FS | Full Span | HP 8566A/ HP 8568A | available
FUNCDEF |  | Define Function Function must be in one line between delimiters @ | HP 8594E/ HP 856xE/ HP 8566B | available
GATE 1) | GATE ON|OFF GATE 1|0 |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
GATECTL 1) | GATECTL EDGE|LEVEL GATECTL? |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
GD 1) | GD <numeric_value> US|MS|SC GD DN GD UP GD? |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
GL 1) | GL <numeric_value> US|MS|SC GL DN GL UP GL? |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
GP 1) | GP POS|NEG GP? |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
GRAT 2) | GRAT ON|OFF | Graticule | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
I1 | I1 |  | HP 8566A/ HP 8568A | available
I2 | I2 |  | HP 8566A/ HP 8568A | available
ID | ID ID? | Identify | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
INZ 1) | INZ 75 INZ 50 INZ? | Input Impedance | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
IP | IP | Instrument preset | HP 8566A/ HP 8568A | available
KEYDEF | KEYDEF | Key definition | HP 8566B/ HP 856xE/ HP 859xE | available
KEYEXEC | KEYEXEC | Key execute | HP 8566B | available
KS= | KS= <numeric_value> HZ|KHZ|MHZ|GHZ KS= DN KS= UP KS=? | Marker Frequency Counter Resolution | HP 8566A/ HP 8568A | available
KS/ | KS/ | Manual Peaking | HP 8566A/ HP 8568A | available
KS( | KS( | Lock register | HP 8566A/ HP 8568A | available
KS) | KS) | Unlock register | HP 8566A/ HP 8568A | available
KS91 | KS91 | Read Amplitude Error | HP 8566A/ HP 8568A | available
KSA | KSA | Amplitude Units in dBm | HP 8566A/ HP 8568A | available
KSB | KSB | Amplitude Units in dBmV | HP 8566A/ HP 8568A | available
KSC | KSC | Amplitude Units in dBuV | HP 8566A/ HP 8568A | available
KSD | KSD | Amplitude Units in V | HP 8566A/ HP 8568A | available
KSE | KSE <numeric_value>|<char data>@ | Title mode | HP 8566A/ HP 8568A | available
KSG | KSG KSG ON KSG <numeric_value> | Video Averaging on | HP 8566A/ HP 8568A | available
KSH | KSH | Video Averaging Off | HP 8566A/ HP 8568A | available
KSK |  | Marker to Next Peak | HP 8566A/ HP 8568A | available
KSL |  | Marker Noise off | HP 8566A/ HP 8568A | available
KSM |  | Marker Noise on | HP 8566A/ HP 8568A | available
KSO | KSO | Deltamarker to span | HP 8566A/ HP 8568A | available
KSP | KSP <numeric_value> | HPIB address | HP 8566A/ HP 8568A | available
KSQ 2) | KSQ | Band lock off | HP 8566A/ HP 8568A | available
KST | KST | Fast Preset | HP 8566A/ HP 8568A | available
KSV | KSV <numeric_value> HZ|KHZ|MHZ|GHZ KSV? | Frequency Offset | HP 8566A/ HP 8568A | available
KSW | KSW | Error Correction Routine | HP 8566A/ HP 8568A | available
KSX | KSX | Correction Values On | HP 8566A/ HP 8568A | available
KSY | KSY | Correction Values Off | HP 8566A/ HP 8568A | available
KSZ | KSZ <numeric_value> DB KSZ? | Reference Value Offset | HP 8566A/ HP 8568A | available
KSa | KSa | Normal Detection | HP 8566A/ HP 8568A | available
KSb | KSb | Pos Peak Detection | HP 8566A/ HP 8568A | available
KSd | KSd | Neg Peak Detection | HP 8566A/ HP 8568A | available
KSe | KSe | Sample Detection | HP 8566A/ HP 8568A | available
KSg |  | CRT beam off |  | available
KSh |  | CRT beam on |  | available
KSj | KSj | View Trace C | HP 8566A/ HP 8568A | available
KSk | KSk | Blank Trace C | HP 8566A/ HP 8568A | available
KSl | KSl | Transfer B to C | HP 8566A/ HP 8568A | available
KSm | KSm | Graticule off | HP 8566A/ HP 8568A | available
KSn2) | KSn | Grid on | HP 8566A/ HP 8568A | available
KSo | KSn | Character display off | HP 8566A/ HP 8568A | available
KSp | KSp | Character display on | HP 8566A/ HP 8568A | available
KSr | KSr | Create service request | HP 8566A/ HP 8568A | available
KSt 2) | KSt | Band lock on | HP 8566A/ HP 8568A | available
KSv 2) | KSv | Signal ident on | HP 8566A/ HP 8568A | available
L0 | L0 | Display line off | HP 8566A/ HP 8568A | available
LB | LB <numeric_value>|<char data>@ | Label | HP 8566A/ HP 8568A | available
LF | LF | Low frequency band preset | HP 8566A/ HP 8568A | available
LIMD |  | limit line delta | HP 856xE | available
LIMF |  | limit line frequency | HP 856xE | available
LIMIFAIL |  | limit fail query | HP 856xE | available
LIMIPURGE |  | purge limit line | HP 856xE | available
LIMIRCL |  | recall limit line | HP 856xE | available
LIMIREL |  | relative limit line | HP 856xE | available
LIMISAV |  | save limit line | HP 856xE | available
LIMITEST |  | limit line test | HP 856xE | available
LIML |  | lower limit line value | HP 856xE | available
LIMM |  | middle limit line value | HP 856xE | available
LIMTFL |  | flat limit line segment | HP 856xE | available
LIMTSL |  | slope limit line segment | HP 856xE | available
LIMU |  | upper limit line value | HP 856xE | available
LG | LG <numeric_value> DB | DM LG? | Amplitude Scale Log | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
LL 2) | LL | Plot command | HP 8566A/ HP 8568A | available
LN | LN | Amplitude Scale Lin | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
M1 | M1 | Marker Off | HP 8566A/ HP 8568A | available
M2 | M2 M2 <numeric_value> HZ|KHZ|MHZ|GHZ M2 DN M2 UP M2? | Marker Normal | HP 8566A/ HP 8568A | available
M3 | M3 M3 <numeric_value> HZ|KHZ|MHZ|GHZ M3 DN M3 UP M3? | Delta Marker | HP 8566A/ HP 8568A | available
M4 | M4 <numeric_value> HZ|KHZ|MHZ|GHZ | Marker Zoom | HP 8566A/ HP 8568A | available
MA | MA | Marker Amplitude | HP 8566A/ HP 8568A | available
MC0 | MC0 | Marker Count off | HP 8566A/ HP 8568A | available
MC1 | MC1 | Marker Count on | HP 8566A/ HP 8568A | available
MDS | MDS | Measurement data size | HP 8566B | available
MEAS |  | Measurement status | HP 856xE | available
MF | MF MF? | Marker Frequency | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MINH1) | MINH TRC | Minimum Hold | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKA | MKA <numeric_value> MKA? | Marker Amplitude | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKACT | MKACT 1 MKACT? | Select the active marker | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | not available
MKBW 1) | MKBW <numeric_value> MKBW ON MKBW OFF | N dB Down | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKD | MKD MKD <numeric_value> HZ|KHZ| MHZ|GHZ MKD DN MKD UP MKD ON MKD OFF MKD? | Delta Marker | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKDR | MKDR <numeric_value> HZ|KHZ| MHZ|GHZ| S|SC|MS|MSEC|USMKDR? | Delta Marker reverse | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKDR? |  | Delta Marker reverse query |  | available
MKF | MKF <numeric_value> HZ|KHZ|MHZ|GHZ MKF? | Set Marker Frequency | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKFC | MKFC ON|OFF | Frequency Counter on/off | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKFCR 1) | MKFCR <numeric_value> HZ|KHZ| MHZ|GHZ MKFCR DN MKFCR UP MKFCR? | Frequency Counter Resolution | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKMIN | MKMIN | Marker -> Min | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKN | MKN MKN <numeric_value> HZ|KHZ|MHZ|GHZ MKN DN MKN UP MKN ON MKN OFF MKN? | Normal Marker | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKNOISE | MKNOISE ON|OFF MKNOISE 1|0 MKNOISE? | Noise Measurement | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKOFF | MKOFF MKOFF ALL | Marker off | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKP | MKP <numeric_value> MKP? | Marker position | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKPK | MKPK MKPK HI MKPK NH MKPK NR MKPK NL | Marker Search | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKPT | MKPT MKPT HI MKPT NH MKPT NR MKPT NL | Marker Peak Threshold | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKPX | MKPX <numeric_value> DB MKPX DN MKPX UP MKPX? | Peak Excursion | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKRL | MKRL | Ref Level = Marker Level | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKSP | MKSP | Deltamarker to span | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKSS | MKSS | CF Stepsize = Marker Freq | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKT | MKT <numeric_value> S|MS|US|SC MKT? | MKF = fstart + MKT/SWT*Span | HP 856xE/ HP 8594E | available
MKTRACE | MKTRACE TRA|TRB|TRC | Marker to Trace | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKTRACK | MKTRACK ON|OFF MKTRACK 1|0 MKTRACK? | Signal Track | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MKTYPE | MKTYPE AMP MK TYPE? | Marker type | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
ML |  | Mixer level | HP 856xE | available
MOV | MOV TRA|TRB|TRC, TRA|TRB|T RC | Move Trace Contents | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
MPY |  | Multiply | HP 8566B/ HP 8568B/ HP 8594E | available
MT0 | MT0 | Marker Track Off | HP 8566A/ HP 8568A | available
MT1 | MT1 | Marker Track On | HP 8566A/ HP 8568A | available
MXMH | MXMH TRA|TRB | Maximum Hold | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
NORMALIZE | NORMALIZE | Normalize trace | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | not available available
NRL 1) | NRL <numeric_value> DB | DM NRL? | Normalized Reference Level | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
NRPOS | NRPOS <numeric_value> NRL? | Normalize position | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
O1 | O1 | Format ASCII, Values 0 to 4095 | HP 8566A/ HP 8568A | available
O2 | O2 | Format Binary, Values 0 to 4095 | HP 8566A/ HP 8568A | available
O3 | O3 | Format ASCII | HP 8566A/ HP 8568A | available
OA | OA | Output All | HP 8566A/ HP 8568A | available
OL | OL <80 characters> OL? | Output Learn String | HP 8566A/ HP 8568A | available
OT | OT | Output Trace Annotations | HP 8566A/ HP 8568A | available
PA | PA <numeric_value>, <numeric_value | Plot command | HP 8566A/ HP 8568A | available
PD | PD <numeric_value>, <numeric_value | Plot command | HP 8566A/ HP 8568A | available
PH_MKF |  | Spot frequency in Hz | HP 856xE | available
PH_FMIN |  | Min offset frequency to be measured | HP 856xE | available
PH_FMAX |  | Max offset frequency to be measured | HP 856xE | available
PH_MKA |  | Queries amplitude at the spot frequency | HP 856xE | available
PH_DRIFT |  | 0: for stable signals, 1: for drifty | HP 856xE | available
PH_RLVL |  | Reference level for the log plot | HP 856xE | available
PH_SMTHV |  | Trace smoothing | HP 856xE | available
PH_VBR |  | Filtering | HP 856xE | available
PH_RMSPT |  | Amount of data points to skip when doing the integration | HP 856xE | available
PH_RMSFL |  | Lower integration frequency in Hz | HP 856xE | available
PH_RMSFU |  | Upper integration frequency in Hz | HP 856xE | available
PH_EXIT |  | Quits phase noise | HP 856xE | available
PH_F_UDT |  | Updates internal frequency variables | HP 856xE | available
PH_LMT_L |  | Apply limits to PH_FMIN and PH_FMAX | HP 856xE | available
PH_MEAS |  | Generates log frequency plot | HP 856xE | available
PH_MKF_D |  | Updates the spot frequency | HP 856xE | available
PH_RMS |  | Requests the rms phase noise | HP 856xE | available
PH_RMSFT |  | Updates internal frequency variables | HP 856xE | available
PH_RMSX |  | Calculates the rms phase noise | HP 856xE | available
PH_SPOTF |  | Executes the spot frequency measurement | HP 856xE | available
PLOTORG 2) | PLOTORG DSP|GRT | Plot command | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
PLOTSRC 2) | PLOTSRC ANNT|GRT|TRB| TRA|ALLDSP|GRT | Plot command | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
PP | PP | Preselector Peaking | HP 8566A/ HP 8568A | available
PRINT 1) | PRINT PRINT 1|0 | Hardcopy | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
PSDAC 2) | PSDAC <numeric_value> PSDAC UP|DN | Preselector DAC value | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
PSTATE 2) | PSTATE ON|OFF|1|0 | Protect State | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
PU | PU | Pen Up | HP 8566A/ HP 8568A | available
PWRBW | PWRBW | Power Bandwidth | HP 8566B/ HP 859x/ HP 856xE | available
R1 | R1 | Set Status Bit Enable | HP 8566A/ HP 8568A | available
R2 | R2 | Set Status Bit Enable | HP 8566A/ HP 8568A | available
R3 | R3 | Set Status Bit Enable | HP 8566A/ HP 8568A | available
R4 | R4 | Set Status Bit Enable | HP 8566A/ HP 8568A | available
RB | RB <numeric_value> HZ|KHZ|MHZ|GHZ RB DN RB UP RB AUTO RB? | Resolution Bandwidth | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
RBR | RBR <numeric_value> RBR DN RBR UP RBR? | Resolution Bandwidth Ratio | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
RC1…6 | RC1…6 | Recall Last State | HP 8566A/ HP 8568A | available
RCLS | RCLS <numeric_value> | Recall State Register | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
RCLT | RCLT TRA|TRB, <number> | Recall Trace | HP856xE/ HP8594E | available
RESET | RESET | Instrument preset | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
REV | REV REV? | Firmware revision | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
RL | RL <numeric_value> DB|DM RL DN RL UP RL? | Reference Level | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
RLCAL | RLCAL <numeric_value> RL? | Reference Level Calibration | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
RCLOSCAL | RCLOSCAL | Recall Open/Short Average | HP 856xE/ HP 8594E | not available
RCLTHRU | RCLTHRU | Recall Thru | HP 856xE/ HP 8594E | not available
RLPOS 1) | RLPOS <numeric_value> RLPOS DN RLPOS UP RLPOS? | Reference Level Position | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
ROFFSET | ROFFSET <numeric_value> DB | DM ROFFSET? | Reference Level Offset | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
RQS | RQS | Service Request Bit mask | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
S1 | S1 | Continuous Sweep | HP 8566A/ HP 8568A | available
S2 | S2 | Single Sweep | HP 8566A/ HP 8568A | available
SADD |  | add a limit line segment | HP 856xE | available
SAVES | SAVES <numeric_value> | Save State Register | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
SAVET | SAVET TRA|TRB,<number> | Save Trace | HP856xE/ HP8594E | available
SDEL |  | delete limit line segment | HP 856xE | available
SDON |  | limit line segment done | HP 856xE | available
SEDI |  | edit limit line segment | HP 856xE | available
SMOOTH | SMOOTH TRA|TRB|TRC, <number of points> | Smooth Trace | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
SNGLS | SNGLS | Single Sweep | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
SQUELCH 2) | SQUELCH <numeric_value> DM | DB SQUELCH UP|DN SQUELCH ON|OFF | Squelch | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
SP | SP <numeric_value> HZ|KHZ|MHZ|GHZ SP DN SP UP SP? | Span | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
SRCNORM 1) | SRCNORM ON|OFF SRCNORM 1|0 | Source Normalization | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | not available
SRCPOFS 1) | SRCPOFS <numeric_value> DB | DM SRCPOFS DN SRCPOFS UP SRCPOFS? | Source Power Offset | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | not available
SRCPWR 1) | SRCPWR <numeric_value> DB | DM SRCPWR DN SRCPWR UP SRCPWR ON SRCPWR OFF SRCPWR? | Source Power | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | not available
SS | SS <numeric_value> HZ|KHZ|MHZ|GHZ SS DN SS UP SS AUTO SS? | CF Step Size | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
ST | ST <numeric_value> US|MS|SC ST DN ST UP ST AUTO ST? | Sweep Time | HP 8566A/ HP 8568A/ HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
STB | STB | Status byte query | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
STOREOPEN | STOREOPEN | Store Open | HP 856xE/ HP 8594E | not available
STORESHORT | STORESHORT | Store Short | HP 856xE/ HP 8594E | not available
STORETHRU | STORETHRU | Store Thru | HP 856xE/ HP 8594E | not available
SUB |  | Subtract | HP 8566B/ HP 8568B/ HP 8594E | available
SUM |  | sum of trace amplitudes | HP 8566B/ HP 8568B/ HP 8594E | available
SV1…6 | SV1…6 | Save State | HP 8566A/ HP 8568A | available
SWPCPL 2) | SWPCPL SA | SR SWPCPL? | Sweep Couple | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
SWPOUT 2) | SWPOUT FAV|FAVA|RAMP SWPOUT? | Sweep Output | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
T0 | T0 | Threshold off | HP 8566A/ HP 8568A | available
T1 | T1 | Free Run Trigger | HP 8566A/ HP 8568A | available
T2 2) | T2 | Line Trigger | HP 8566A/ HP 8568A | available
T3 | T3 | External Trigger | HP 8566A/ HP 8568A | available
T4 | T4 | Video Trigger | HP 8566A/ HP 8568A | available
TA | TA | Transfer A | HP 8566A/ HP 8568A | available
TACL | TACL? | Returns instantaneous measurement results. See TRACe<trace #>:IMMediate:LEVel? for full description. |  | not available
TBCL | TBCL? |  |  |
TCCL | TCCL? |  |  |
TACR | TACR? | Returns instantaneous measurement results. See TRACe<trace #>:IMMediate:LEVel? for full description. |  | not available
TBCR | TBCR? |  |  |
TCCR | TCCR? |  |  |
TB | TB | Transfer B | HP 8566A/ HP 8568A | available
TDF | TDF P TDF M TDF B TDF A TDF I | Trace Data Format | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
TH | TH <numeric_value> DB|DM TH DN TH UP TH ON TH OFF TH AUTO TH? | Threshold | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
THE | THE ON| OFF | Threshold Line enable | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
TIMEDSP 1) | TIMEDSP ON|OFF TIMEDSP 1|0 TIMEDSP? | Time Display | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
TM | TM FREE|VID|EXT|LINE2) TM? | Trigger Mode | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
TM LINE 2) | TM LINE | Trigger Line | HP 8566B | available
TRA | TRA B TRA A TRA I | Transfer A | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
TRB | TRB B TRB A TRB I | Transfer B | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
TRSTAT | TRSTAT? | Trace State Query | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
TS | TS | Take Sweep | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
UR 2) | UR | Plot Command | HP 8566A/ HP 8568A | available
VARDEF | VARDEF | Variable definition, arrays are not supported | HP 8566B/ HP 8568B/ HP 8594E | available
VAVG | VAVG VAVG TRA|TRB|TRC | Video Averaging | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
VB | VB <numeric_value> HZ|KHZ|MHZ|GHZ VB DN VB UP VB AUTO VB? | Video Bandwidth | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
VBR 1) | VBR <numeric_value> VBR DN VBR UP VBR? | Video Bandwidth Ratio | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
VIEW | VIEW TRA|TRB|TRC |  | HP 856xE/ HP 8566B/ HP 8568B/ HP 8594E | available
VTL | VTL <numeric_value> DB|DM VTL DN VTL UP VTL? | Video Trigger Level | HP 856xE/ HP 8594E | not available
1) HP 8594E only
2) Command is accepted without error message, but is ignored


Special Features of the Syntax Parsing Algorithms for 8566A and 8568A Models

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > Special Features of the Syntax Parsing Algorithms for 8566A and 8568A Models
Special Features of the Syntax Parsing Algorithms for 8566A and 8568A Models

The command syntax is very different for models A and B. Different names are assigned to identical instrument functions, and the command structure likewise differs considerably between models A and models B.

The command structure for models A is as follows:

<command>::= <command code>[<SPC>][<data>|<step>][<SPC>][<delimiter>][<command code>]…<delimiter>

<data>::= <Value>[<SPC>][<units code>][<SPC>][<delimiter>][<SPC>][<data>]…

<step>::= UP|DN

where

<command code> = see Table "Supported Commands"

<Value> = integer or floating-point numerical value

<units code> = DM | -DM | DB | HZ | KZ | MZ | GZ | MV | UV | SC | MS | US

<delimiter> = <CR> | <LF> | <,> | <;> | <ETX>

<SPC> = 3210

<ETX> = 310

Command sections given in [ ] are optional.

The R&S FSW GPIB hardware differs from that used in the HP analyzers. Therefore, the following constraint exists:

<LF>| <EOI> are still used as delimiters since the GPIB hardware is able to identify them. The other delimiters are identified and evaluated during syntax analysis.


Special Behavior of Commands

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > Special Behavior of Commands
Special Behavior of Commands

Command

Known Differences

ABORT

Does not automatically set the command complete bit (bit 4) in the status byte. An additional DONE is required for that purpose.

ANNOT

Only frequency axis annotation is affected.

AT

AT DN/UP: Step size

CAL

The CAL commands do not automatically set the command complete bit (bit 4) in the status byte. An additional DONE command is required for that purpose.

CF

Default value, range, step size

CR

Default ratio Span/RBW

CT

Formula for coupled sweep time

CV

Default ratio RBW/VBW

DEMOD

requires option R&S FSW-B3

DET

DET? returns SAMP instead of SMP on the R&S FSW.

DET not automatically set the command complete bit (bit 4) in the status byte. An additional DONE is required for that purpose.

ERR?

Deletes the error bit in the status register but always returns a '0' in response.

FA

Default value, range, step size

FB

Default value, range, step size

ID

Query of instrument ID. The instrument ID defined in "SETUP > Network + Remote > GPIB > Identification String" is returned.

M2

Default value, range, step size

M3

Default value, range, step size

MKACT

Only marker 1 is supported as the active marker.

MKBW

Default value

MKPT

Step size

MKPX

Step size

OL?

Storage of instrument settings:

80 characters are returned as information on the instrument settings.

The contents of the 80 characters returned does not correspond to the original data contents of the 8566A/8568A family.

OL

Readout of instrument settings:

The 80 characters read by means of OL? are accepted as information on the corresponding instrument settings.

The contents of the 80 characters read does not correspond to the original data contents of the 8566A/8568A family.

RB

Default value, range, step size

RL

Default value, step size

RLPOS

Adapts the position of the reference level even if the tracking generator normalization is not active.

RQS

Supported bits:

1 (Units key pressed)

2 (End of Sweep)

3 (Device error)

4 (Command complete)

5 (Illegal command)


Model-Dependent Default Settings

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > Model-Dependent Default Settings
Model-Dependent Default Settings

If the GPIB language is switched over to an 85xx model, the GPIB address is automatically switched over to 18 provided that the default address of the R&S FSW (20) is still set. If a different value is set, this value is maintained. Upon return to SCPI, this address remains unchanged.

The following table shows the default settings obtained after a change of the GPIB language and for the commands IP, KST and RESET:

Model | # of Trace Points | Start Freq. | Stop Freq. | Ref Level | Input Coupling
8566A/B | 1001 | 2 GHz | 22 GHz | 0 dBm | AC
8568A/B | 1001 | 0 Hz | 1.5 GHz | 0 dBm | AC
8560E | 601 | 0 Hz | 2.9 GHz | 0 dBm | AC
8561E | 601 | 0 Hz | 6.5 GHz | 0 dBm | AC
8562E | 601 | 0 Hz | 13.2 GHz | 0 dBm | AC
8563E | 601 | 0 Hz | 26.5 GHz | 0 dBm | AC
8564E | 601 | 0 Hz | 40 GHz | 0 dBm | AC
8565E | 601 | 0 Hz | 50 GHz | 0 dBm | AC
8594E | 401 | 0 Hz | 3 GHz | 0 dBm | AC
Stop frequency

The stop frequency given in the table may be limited to the corresponding frequency range of the R&S FSW.

Command LF sets the stop frequency for 8566A/B to a maximum value of 2 GHz.

Test points (trace points)

The number of trace points is switched over only upon transition to the REMOTE state.


Data Output Formats

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > Data Output Formats
Data Output Formats

In the case of the SCPI and IEEE488.2 standards, the output formats for numerical data are flexible to a large extent. The output format for the HP units, by contrast, is accurately defined with respect to the number of digits. The memory areas for reading instrument data have therefore been adapted accordingly in the remote-control programs for instruments of this series.

Therefore, in response to a query, the R&S FSW returns data of the same structure as that used by the original instruments; this applies in particular to the number of characters returned.

Two formats are currently supported when trace data is output: Display Units (command O1) and physical values (command O2, O3 or TDF P). As to the "Display Units" format, the level data of the R&S FSW is converted to match the value range and the resolution of the 8566/8568 series. Upon transition to the REMOTE state, the R&S FSW is reconfigured such that the number of test points (trace points) corresponds to that of the 85xx families (1001 for 8566A/B and 8568A/B, 601 for 8560E to 8565E, 401 for 8594E).


Trace Data Output Formats

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > Trace Data Output Formats
Trace Data Output Formats

All formats are supported for trace data output: display units (command O1), display units in two byte binary data (command O2 or TDF B and MDS W), display units in one byte binary data (command O4 or TDF B and MDS B) and physical values (commands O3 or TDF P). With format "display units" the level data is converted into value range and resolution of the 8566/8568 models. On transition to REMOTE state the number of trace points are reconfigured in order to be conform to the selected instrument model (1001 for 8566A/B and 8568 A/B, 601 for 8560E to 8565E, 401 for 8594E).


Trace Data Input Formats

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > Trace Data Input Formats
Trace Data Input Formats

Trace data input is only supported for binary date (TDF B, TDF A, TDF I, MDS W, MDS B).


GPIB Status Reporting

Remote Commands > Emulating Other Instruments' Commands > Reference: GPIB Commands of Emulated HP Models > GPIB Status Reporting
GPIB Status Reporting

The assignment of status bits by commands R1, R2, R3, R4, RQS is supported.

The STB command and the serial poll respond with an 8-bit value with the following assignment:

Bit enabled by RQS | Description
0 | not used (value 0)
1 | Units key pressed
2 | End of Sweep
3 | Device Error
4 | Command Complete
5 | Illegal Command
6 | Service Request
7 | not used (value 0)

Bits 0 and 7 are not used and always have the value 0.

Please note that the R&S FSW reports any key pressed on the front panel rather than only the unit keys if bit 1 was enabled.

Another difference is the behavior of bit 6 when using the STB? query. On the HP analyzers this bit monitors the state of the SRQ line on the bus. On the R&S FSW this is not possible. Therefore this bit is set, as soon as one of the bits 1 to 5 is set. It won't be reset by performing a serial poll.


Reference: Command Set of Emulated PSA Models

Remote Commands > Emulating Other Instruments' Commands > Reference: Command Set of Emulated PSA Models
Reference: Command Set of Emulated PSA Models

The R&S FSW analyzer family supports a subset of the GPIB commands of PSA89600 instruments.

Despite the differences in system architecture and device features, the supported commands have been implemented in a way to ensure a sufficiently high degree of correspondence with the original.

In many cases the selection of commands supported by the R&S FSW is sufficient to run an existing GPIB program without adaptation.

Supported 89600 commands

*CAL?

*CLS

*ESE

*ESR?

*IDN?

*IST?

*OPC

*OPT?

*PCB

*PRE

*PSC

*RST

*SRE

*STB?

*TRG

*TST?

*WAI

:CALibration:AUTO OFF|ON|ALERt

:CALibration:TCORrections AUTO|ON|OFF

:CONFigure:WAVeform

:DIAGnostic:EABY ON|OFF

:DIAGnostic:LATCh:VALue <numeric>

:DIAGnostic:LATCh:SELect <string>

:DISPlay:ANNotation:TITLe:DATA <string>

:DISPlay:ENABle OFF|ON

:DISPlay:WINDow:TRACe:Y:[SCALe]:PDIVision <numeric>

:DISPlay:WINDow:TRACe:Y:[SCALe]:RLEVel <numeric>

:DISPlay:WINDow:TRACe:Y:[SCALe]:RLEVel:OFFSet <numeric>

:FORMat:BORDer NORMal|SWAPped

:FORMat[:DATA] ASCii|REAL|UINT|MATLAB,<numeric>

:INITiate:CONTinuous OFF|ON

:INITiate[:IMMediate]

:INSTrument:CATalog?

:INSTrument:NSELect <numeric>

:MMEMory:CATalog? <dir_name>

:MMEMory:COPY <‘file_name1’>,<‘file_name2’>

:MMEMory:DATA <‘file_name’>,<definite_length_block>

:MMEMory:DELete <‘file_name’>

:MMEMory:LOAD:STATe 1,<‘file_name’>

:MMEMory:LOAD:TRACe 1,<‘file_name’>

:MMEMory:MDIRectory <‘dir_name’>

:MMEMory:MOVE <‘file_name1’>,<‘file_name2’>

:MMEMory:STORe:STATe 1,<‘file_name’>

:MMEMory:STORe:TRACe <numeric>,<‘file_name’>

:READ:WAVform?

[:SENSe]:FREQuency:CENTer <numeric>

[:SENSe]:FREQuency:STARt <numeric>

[:SENSe]:FREQuency:STOP <numeric>

[:SENSe]:FREQuency:SPAN <numeric>

[:SENSe]:POWer:ATTenuation <numeric>

[:SENSe]:ROSCillator:EXTernal:FREQuency <numeric>

[:SENSe]:ROSCillator:OUTPut OFF|ON

[:SENSe]:ROSCillator:SOURce INTernal|EXTernal|EAUTo

[:SENSe]:SPECtrum:TRIGger:SOURce EXTernal<1|2>|IF|IMMediate

[:SENSe]:WAVeform:ADC:RANGe P6

[:SENSe]:WAVeform:APER?

[:SENSe]:WAVeform:AVERage:TACount <numeric>

[:SENSe]:WAVeform:BWIDth:ACTive?

[:SENSe]:WAVeform:BWIDth:TYPE FLAT|GAUSsian

[:SENSe]:WAVeform:IFGain <numeric>

[:SENSe]:WAVeform:IFPath NARRow|WIDE

[:SENSe]:WAVeform:NCPTrace ON|OFF

[:SENSe]:WAVeform:PDIT ON|OFF

[:SENSe]:WAVeform:SRATe <numeric>

[:SENSe]:WAVeform:SWEep:TIME <numeric>

[:SENSe]:WAVeform:TRIGger:EOFFset?

[:SENSe]:WAVeform:TRIGger:INTerpolation ON|OFF

[:SENSe]:WAVeform:TRIGger:SOURce EXTernal<1|2>|IF|IMMediate

:STATus:QUEStionable:CONDition?

:STATus:QUEStionable:ENABle <number>

:STATus:QUEStionable:NTRansition <number>

:STATus:QUEStionable:PTRansition <number>

:STATus:QUEStionable[:EVENt]?

:STATus:QUEStionable:CALibration:CONDition?

:STATus:QUEStionable:CALibration:ENABle <number>

:STATus:QUEStionable:CALibration:NTRansition <number>

:STATus:QUEStionable:CALibration:PTRansition <number>

:STATus:QUEStionable:CALibration[:EVENt]?

:STATus:QUEStionable:FREQuency:CONDition?

:STATus:QUEStionable:FREQuency:ENABle <number>

:STATus:QUEStionable:FREQuency:NTRansition <number>

:STATus:QUEStionable:FREQuency:PTRansition <number>

:STATus:QUEStionable:FREQuency[:EVENt]?

:STATus:QUEStionable:INTegrity:CONDition?

:STATus:QUEStionable:INTegrity:ENABle <number>

:STATus:QUEStionable:INTegrity:NTRansition <number>

:STATus:QUEStionable:INTegrity:PTRansition <number>

:STATus:QUEStionable:INTegrity[:EVENt]?

:STATus:OPERation:CONDition?

:STATus:OPERation:ENABle <integer>

:STATus:OPERation:NTRansition <integer>

:STATus:OPERation:PTRansition <integer>

:STATus:OPERation[:EVENt]?

:SYSTem:COMMunicate:GPIB[:SELF]:ADDRess <integer>

:SYSTem:DATE <year>,<month>,<day>

:SYSTem:ERRor[:NEXT]?

:SYSTem:KLOCK?

:SYSTem:MESSage <string>

:SYSTem:PRESet

:SYSTem:TIME <hour>,<minute>,<second>

:SYSTem:VERSion?

:TRACe:COPY <src_trace>,<dest_trace>

:TRACe[:DATA] TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6, <definite_length_block> | <comma_separated_ASCII_data>

:TRACe:MODE WRITe|MAXHold|MINHold|VIEW|BLANk

:TRIGger[:SEQuence]:DELay <numeric>

:TRIGger[:SEQuence]:DELay:STATe OFF|ON|0|1

:TRIGger[:SEQuence]:EXTermal:DELay <numeric>

:TRIGger[:SEQuence]:EXTermal:LEVel <numeric>

:TRIGger[:SEQuence]:EXTermal:SLOPe POSitive|NEGative

:TRIGger[:SEQuence]:HOLDoff <numeric>

:TRIGger[:SEQuence]:IF:DELay <numeric>

:TRIGger[:SEQuence]:IF:LEVel <numeric>

:TRIGger[:SEQuence]:IF:SLOPe POSitive|NEGative

:TRIGger[:SEQuence]:SLOPe POSitive|NEGative

:TRIGger[:SEQuence]:SOURce IMMediate|VIDeo|EXTernal<1|2>

:TRIGger[:SEQuence]:VIDeo:LEVel <numeric>

:TRIGger[:SEQuence]:VIDeo:LEVel:FREQuency <freq>


Commands for Compatibility

Remote Commands > Commands for Compatibility
Commands for Compatibility

The following commands are provided for compatibility to other signal analyzers only. For new remote control programs use the specified alternative commands.

List of Commands
CALCulate:LIMit<k>:TRACe
DISPlay[:WINDow<n>]:STATe
DISPlay[:WINDow<n>]:TYPE
SOURce:EXTernal:FREQuency:SWEep[:STATe]
SYSTem:COMPatible
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:RFPower:HOLDoff


CALCulate:LIMit<k>:TRACe

Remote Commands > Commands for Compatibility > CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe <TraceNumber>

This command links a limit line to one or more traces.

Note that this command is maintained for compatibility reasons only. Limit lines no longer need to be assigned to a trace explicitely. The trace to be checked can be defined directly (as a suffix) in the new command to activate the limit check (see CALCulate:​LIMit<k>:​TRACe<t>:​CHECk).

Parameters:
<TraceNumber>
1 to 6
*RST: 1
Example: CALC:LIM2:TRAC 3

Assigns limit line 2 to trace 3.


DISPlay[:WINDow<n>]:STATe

Remote Commands > Commands for Compatibility > DISPlay[:WINDow<n>]:STATe
DISPlay[:WINDow<n>]:STATe <State>

This command changes the display state of the selected measurement window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs

(See "Working with Windows in the Display").

Parameters:
<State>
ON | OFF
OFF

The window is closed.

*RST: OFF
Usage: SCPI confirmed


DISPlay[:WINDow<n>]:TYPE

Remote Commands > Commands for Compatibility > DISPlay[:WINDow<n>]:TYPE
DISPlay[:WINDow<n>]:TYPE <WindowType>

This command selects the results displayed in a measurement window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<WindowType>
DIAGram

Selects a diagram.

MTABle

Selects a marker table

PEAKlist

Selects a peak list

RSUMmary

Selects a result summary.

SGRam

Selects a spectrogram.


SOURce:EXTernal:FREQuency:SWEep[:STATe]

Remote Commands > Commands for Compatibility > SOURce:EXTernal:FREQuency:SWEep[:STATe]
SOURce:EXTernal:FREQuency:SWEep[:STATe] <State>

Note that this command is maintained for compatibility reasons only. It is not required in new remote control programs.

This command activates or deactivates the frequency sweep for the selected generator.

This command is only valid if External Generator Control (R&S FSW-B10) is installed and active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SOUR:EXT:FREQ:SWE ON

Activates the frequency sweep for the external generator.


SYSTem:COMPatible

Remote Commands > Commands for Compatibility > SYSTem:COMPatible
SYSTem:COMPatible <Mode>

This command enables compatibility to other spectrum and signal analyzers by R&S.

Compatibility is necessary, for example, regarding the number of sweep points.

Note that this command is maintained for compatibility reasons only. Use the SYST:LANG command for new remote control programs (see SYSTem:​LANGuage).

Parameters:
<Mode> | DEFault | FSU | FSP | FSQ | FSV
Example: | SYST:COMP FSP


TRIGger[:SEQuence]:BBPower:HOLDoff

Remote Commands > Commands for Compatibility > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:RFPower:HOLDoff

Remote Commands > Commands for Compatibility > TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:RFPower:HOLDoff <Time>

This command defines the holding time before the next trigger event. Note that this command is available for any trigger source, not just RF Power.

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Time>
Default unit: S


Programming Examples

Remote Commands > Programming Examples
Programming Examples

Some advanced programming examples for complex measurement tasks are provided here.

Contents
  • Programming Example: Performing a Basic Frequency Sweep
  • Service Request


Programming Example: Performing a Basic Frequency Sweep

Remote Commands > Programming Examples > Programming Example: Performing a Basic Frequency Sweep
Programming Example: Performing a Basic Frequency Sweep

This example demonstrates how to configure and perform a basic frequency sweep measurement in a remote environment.

//--------------Preparing the measurement ---------------------
*RST
//Resets the instrument
INIT:CONT OFF
//Selects single sweep mode.

//--------------Configuring the Frequency and Span-------------
FREQ:CENT 100MHz
//Defines the center frequency
FREQ:SPAN 200MHz
//Sets the span to 100 MHz on either side of the center frequency.

//Activate signal tracking to keep the center frequency on the signal peak:
CALC:MARK:FUNC:STR ON
CALC:MARK:FUNC:STR:BAND 20MHz
CALC:MARK:FUNC:STR:THR -90dBm
CALC:MARK:FUNC:STR:TRAC 1
//After each sweep the maximum on trace 1 is searched within a range of 20 MHz
//around the center frequency. It must have a minimum power of -90dBm.

//--------------Configuring the Bandwidth----------------------
BAND:AUTO OFF
BAND 1MHz
BAND:TYPE RRC
//Defines the RBW as 1 MHz using an RRC filter

BAND:VID:AUTO OFF
BAND:VID 500kHz
//Decouples the VBW from the RBW and decreases it to smooth the trace.

//--------------Configuring the Sweep--------------------------
SENS:SWE:COUN 10
//Defines 10 sweeps to be performed in each measurement.
SENS:SWE:POIN 500
//During each sweep, 500 trace points will be measured.
SENS:SWE:TIME:AUTO OFF
SENS:SWE:TIME 50ms
//Decouples the sweep time from the RBW,VBW and span and increases it to
//make the measurement more precise.

//--------------Configuring Attenuation------------------------
//Only if electronic attenuator is available:
//INP:EATT:STAT ON
//Switches on the electronic attenuator.
//INP:EATT 30dB
//Sets the electronic attenuation to 30 dB.
INP:ATT 10dB
//Sets the mechanical attenuation to 10 dB and couples the reference level
//to the attenuation instead of vice versa.

//--------------Configuring the Amplitude and Scaling----------
DISP:TRAC1:Y:RLEV -10dBm
//Sets the reference level to -10 dBm.
DISP:TRAC1:Y:RLEV:OFFS 10dB
//Shifts the trace display in the diagram up by 10dB.
CALC:UNIT:POW V
//Sets the unit of the y-axis to Volt. The reference level is now 70.711 mV.
DISP:TRAC1:Y:SPAC LOG
//Uses logarithmic scaling with absolute values (V).
DISP:TRAC1:Y 110dB
//Increases the displayed range of the y-axis to 110 dB.
DISP:TRAC1:Y:RPOS 80PCT
//Shifts the display of the reference level down, it is no longer the top line
//in the diagram. The reference level is displayed as a red line.

//--------------Triggering-------------------------------------
TRIG:SOUR IFP
TRIG:LEV:IFP -10dBm
TRIG:SLOP POS
TRIG:DTIM 50ms
TRIG:IFP:HYST 5dB
TRIG:HOLD 10ms
//Defines triggering when the second intermediate frequency rises to a level
//of -10 dBm, with a dropout time of 50 ms, a hysteresis of 5 dB and a delay
//of 10 ms.

SWE:EGAT ON
SWE:EGAT:TYPE EDGE
SWE:EGAT:LENG 5ms
//Defines gating. Values are measured for 5 ms after triggering.

OUTP:TRIG2:DIR OUTP
OUTP:TRIG2:OTYP UDEF
OUTP:TRIG2:LEV HIGH
OUTP:TRIG2:PULS:LENG 100us
OUTP:TRIG2:PULS:IMM
//Configures a high trigger signal with a pulse length of 100 us to be output at
//the front TRIGGER INPUT/OUTPUT connector once.

//--------------Configuring the Trace--------------------------
DISP:TRAC2 ON
DISP:TRAC2:MODE AVER
DISP:TRAC3 ON
DISP:TRAC3:MODE MAXH
//Configures 3 traces: 1 (default): clear/write; 2: average; 3: max hold

SENS:DET1 POS
SENS:DET2 RMS
SENS:DET3 POS
//Configures traces 1 and 3 to use the positive peak detector; trace 2 uses
//the RMS detector.

TRAC:COPY TRACE4,TRACE1
//Copies trace 1 to a new trace 4 which will then be averaged.

SENS:AVER:STAT4 ON
SENS:AVER:COUN 10
SENS:AVER:TYPE LIN
//Configures trace 4 to be averaged linearly over 10 sweeps.

CALC:MATH:STAT ON
CALC:MATH:MODE LIN
CALC:MATH (TRACE1-TRACE2)
CALC:MATH:POS 100
//Calculates the linear difference between the measured and average values.
//The resulting trace is displayed at the top of the diagram.

//--------------Performing the Measurement---------------------
INIT;*WAI
//Initiates a new measurement and waits until the last sweep has finished.

//---------------Retrieving Results----------------------------
TRAC:DATA? TRACE1
TRAC:DATA? TRACE2
TRAC:DATA? TRACE3
TRAC:DATA? TRACE4
//Returns one power and one frequency value per sweep point for each trace.


Service Request

Remote Commands > Programming Examples > Service Request
Service Request

The service request routine requires an extended initialization of the instrument in which the relevant bits of the transition and enable registers are set. In addition the service request event must be enabled in the VISA session.

Contents
  • Initiate Service Request
  • Waiting for the Arrival of a Service Request
  • Waiting Without Blocking the Keyboard and Mouse
  • Service Request Routine
  • Reading Out the Output Buffer
  • Reading Error Messages
  • Evaluation of SCPI Status Registers
  • Evaluation of Event Status Register


Initiate Service Request

Remote Commands > Programming Examples > Service Request > Initiate Service Request
Initiate Service Request
REM ---- Example of initialization of the SRQ in the case
' of errors -------
PUBLIC SUB SetupSRQ()
CALL InstrWrite (analyzer, "*CLS") 'Reset status reporting system
CALL InstrWrite (analyzer, "*SRE 168") 'Enable service request for
'STAT:OPER, STAT:QUES and ESR
'register
CALL InstrWrite (analyzer, "*ESE 60") 'Set event enable bit for
'command, execution, device-
'dependent and query error
CALL InstrWrite (analyzer, "STAT:OPER:ENAB 32767")
'Set OPERation enable bit for
'all events
CALL InstrWrite (analyzer, "STAT:OPER:PTR 32767")
'Set appropriate OPERation
'Ptransition bits
CALL InstrWrite (analyzer, "STAT:QUES:ENAB 32767")
'Set questionable enable bits
'for all events
CALL InstrWrite (analyzer, "STAT:QUES:PTR 32767")
'Set appropriate questionable
'Ptransition bits
CALL viEnableEvent(analyzer, VI_EVENT_SERVICE_REQ, VI_QUEUE, 0)
'Enable the event for service
'request
Status = viWaitOnEvent(analyzer, VI_EVENT_SERVICE_REQ, SRQWaitTimeout, VI_NULL,
 VI_NULL)
IF (status = VI_SUCCESS) THEN CALL Srq
'If SRQ is recognized =>
'subroutine for evaluation
END SUB
REM ***********************************************************************
Private mbSession As MessageBasedSession

Sub Main()
    Console.WriteLine("Example of initialization    _
                of the SRQ in the case of errors.")
    Dim SRQWaitTimeout = 4000 ' Timeout As Integer for WaitOnEvent
    'Opening session
    Try
        'FSW is alias, instead of use resource string.
                'For example on TCP use TCPIP0::192.168.1.2::inst0::INSTR
        mbSession = CType(ResourceManager.GetLocalManager().Open("FSW"), _
                                      MessageBasedSession)
        mbSession.TerminationCharacterEnabled = True
        Try
            mbSession.Write("*CLS") 'Reset status reporting system
            mbSession.Write("*SRE 168") 'Enable service request for
            'STAT:OPER, STAT:QUES and ESR register
            mbSession.Write("*ESE 60") 'Set event enable bit for
            'command, execution, device-dependent and query error
            mbSession.Write("STAT:OPER:ENAB 32767")
            'Set OPERation enable bit for all events
            mbSession.Write("STAT:OPER:PTR 32767")
            'Set appropriate OPERation Ptransition bits
            mbSession.Write("STAT:QUES:ENAB 32767")
            'Set questionable enable bits for all events
            mbSession.Write("STAT:QUES:PTR 32767")
            'Set appropriate questionable Ptransition bits
            Console.WriteLine("Wait on event - Blocking")
            mbSession.EnableEvent(MessageBasedSessionEventType.ServiceRequest, _
                                                EventMechanism.Queue)
            'Enable the event for service request

            '------------------------------------------------
            ' Your command plase use here
            ' mbSession.Write("Your command")
            '------------------------------------------------

            Dim Status = mbSession.WaitOnEvent( _
                                MessageBasedSessionEventType.ServiceRequest, SRQWaitTimeout)
            If (Status.EventType() = _
                                MessageBasedSessionEventType.ServiceRequest) Then
                Console.WriteLine("SRQ is recognized")
                'If SRQ is recognized => subroutine for evaluation
                Srq()
            End If
        Catch exp As Exception
            Console.WriteLine(exp.Message)
        End Try
    Catch exp As InvalidCastException
        Console.WriteLine("Resource selected must be a message-based session")
    Catch exp As Exception
        Console.WriteLine(exp.Message)
    End Try

    ' Close session
    mbSession.Dispose()
    ' Wait for end
    Console.WriteLine("Press any key to end")
    Console.ReadKey()
End Sub


Waiting for the Arrival of a Service Request

Remote Commands > Programming Examples > Service Request > Waiting for the Arrival of a Service Request
Waiting for the Arrival of a Service Request

There are basically two methods of waiting for the arrival of a service request:

Blocking (user inputs not possible):

This method is appropriate if the waiting time until the event to be signaled by an SRQ is short (shorter than the selected timeout), if no response to user inputs is required during the waiting time, and if – as the main criterion – the event is absolutely certain to occur.

Reason:

From the time the viWaitOnEvent() function is called until the occurrence of the expected event, it does not allow the program to respond to mouse clicks or key entries during the waiting time. Moreover, it returns an error if the SRQ event does not occur within the predefined timeout period.

The method is, therefore, in many cases not suitable for waiting for measurement results, especially when using triggered measurements.

The following function calls are required:

Status = viWaitOnEvent(analyzer, VI_EVENT_SERVICE_REQ, SRQWaitTimeout, VI_NULL,
 VI_NULL)
'Wait for service request user
'inputs are not possible during
'the waiting time!
IF (status = VI_SUCCESS) THEN CALL Srq
'If SRQ is recognized =>
'subroutine for evaluation
'--------- Sweep in first Spectrum Tab and query marker --------------------
Dim Status = mbSession.WaitOnEvent( _
MessageBasedSessionEventType.ServiceRequest, SRQWaitTimeout)
'Wait for service request user inputs are not possible
'during the waiting time!
If (Status.EventType() = MessageBasedSessionEventType.ServiceRequest) Then
'If SRQ is recognized => subroutine for evaluation
    Srq()
End If
Non-blocking (user inputs possible):

This method is recommended if the waiting time until the event to be signaled by an SRQ is long (longer than the selected timeout), and user inputs should be possible during the waiting time, or if the event is not certain to occur. This method is, therefore, the preferable choice for waiting for the end of measurements, i.e. the output of results, especially in the case of triggered measurements.

The method necessitates a waiting loop that checks the status of the SRQ line at regular intervals and returns control to the operating system during the time the expected event has not yet occurred. In this way, the system can respond to user inputs (mouse clicks, key entries) during the waiting time.

It is advisable to employ the Hold() auxiliary function, which returns control to the operating system for a selectable waiting time (see section "Waiting Without Blocking the Keyboard and Mouse"), so enabling user inputs during the waiting time.

result% = 0
For i = 1 To 10 'Abort after max. 10 loop
'iterations
Status = viWaitOnEvent(analyzer, VI_EVENT_SERVICE_REQ, VI_TMO_IMMEDIATE, VI_NULL,
 VI_NULL)
'Check event queue
If (status = VI_SUCCESS) Then
result% = 1
CALL Srq 'If SRQ is recognized =>
'subroutine for evaluation
Else
CALL Hold(20) 'Call hold function with
'20 ms 'waiting time. User inputs
'are possible.
Endif
Next i
If result% = 0 Then
Debug.Print "Timeout Error; Program aborted"'Output error message
STOP 'Stop software
Endif


Waiting Without Blocking the Keyboard and Mouse

Remote Commands > Programming Examples > Service Request > Waiting Without Blocking the Keyboard and Mouse
Waiting Without Blocking the Keyboard and Mouse

A frequent problem with remote control programs using Visual Basic is to insert waiting times without blocking the keyboard and the mouse.

If the program is to respond to user inputs also during a waiting time, control over the program events during this time must be returned to the operating system. In Visual Basic, this is done by calling the DoEvents function. This function causes keyboard-or mouse-triggered events to be executed by the associated elements. For example, it allows the operation of buttons and input fields while the user waits for an instrument setting to be completed.

The following programming example describes the Hold() function, which returns control to the operating system for the period of the waiting time selectable in milliseconds.

Rem ***********************************************************************
Rem The waiting function below expects the transfer of the desired
Rem waiting time in milliseconds. The keyboard and the mouse remain
Rem operative during the waiting period, thus allowing desired elements
Rem to be controlled
Rem ***********************************************************************
Public Sub Hold(delayTime As Single)
Start = Timer 'Save timer count on calling the
'function
Do While Timer < Start + delayTime/1000 'Check timer count
DoEvents 'Return control to operating
'system to enable control of
'desired elements as long as
'timer has not elapsed
Loop
End Sub
Rem ***********************************************************************

The waiting procedure is activated simply by calling Hold(<Waiting time in milliseconds>).


Service Request Routine

Remote Commands > Programming Examples > Service Request > Service Request Routine
Service Request Routine

A service request is processed in the service request routine.

The variables userN% and userM% must be pre-assigned usefully!

REM ------------ Service request routine ----------------------------------
Public SUB Srq()
ON ERROR GOTO noDevice 'No user existing
CALL viReadSTB(analyzer, STB%) 'Serial poll, read status byte
IF STB% > 0 THEN 'This instrument has bits set in
'the STB
SRQFOUND% = 1
IF (STB% AND 16) > 0 THEN CALL Outputqueue
IF (STB% AND 4) > 0 THEN CALL ErrorQueueHandler
IF (STB% AND 8) > 0 THEN CALL Questionablestatus
IF (STB% AND 128) > 0 THEN CALL Operationstatus
IF (STB% AND 32) > 0 THEN CALL Esrread
END IF
noDevice:
END SUB 'End of SRQ routine
REM ***********************************************************************
REM ---------- Subroutine for evaluation Service Request Routine ----------

Public Sub Srq()
    Try
        Dim mySTB As Short = mbSession.ReadStatusByte()
                                'Serial poll, read status byte
        Console.WriteLine("Reading Service Request Routine:" + mySTB.ToString())
        If mySTB > 0 Then 'This instrument has bits set in the STB
            If (mySTB And 16) > 0 Then Call Outputqueue()
            If (mySTB And 4) > 0 Then Call ErrorQueueHandler()
            If (mySTB And 8) > 0 Then Call Questionablestatus()
            If (mySTB And 128) > 0 Then Call Operationstatus()
            If (mySTB And 32) > 0 Then Call Esrread()
        End If
    Catch exp As Exception
        Console.WriteLine(exp.Message)
    End Try
End Sub 'End of SRQ routine

Reading out the status event registers, the output buffer and the error/event queue is effected in subroutines.


Reading Out the Output Buffer

Remote Commands > Programming Examples > Service Request > Reading Out the Output Buffer
Reading Out the Output Buffer
REM -------- Subroutine for the individual STB bits -----------------------
Public SUB Outputqueue() 'Reading the output buffer
result$ = SPACE$(100) 'Make space for response
CALL InstrRead(analyzer, result$)
Debug.Print "Contents of Output Queue:"; result$
END SUB
REM ***********************************************************************
REM -------- Subroutine for the output queue -----------------------
Public Sub Outputqueue() 'Reading the output buffer
    Try
        Dim result As String = mbSession.ReadString()
        Console.WriteLine("Contents of Output Queue:" + result)
    Catch exp As Exception
        Console.WriteLine(exp.Message)
    End Try
End Sub


Reading Error Messages

Remote Commands > Programming Examples > Service Request > Reading Error Messages
Reading Error Messages
REM -------- Subroutine for reading the error queue -----------------------
Public SUB ErrorQueueHandler()
ERROR$ = SPACE$(100) 'Make space for error variable
CALL InstrWrite (analyzer, "SYSTEM:ERROR?")
CALL InstrRead(analyzer, ERROR$)
Debug.Print "Error Description:"; ERROR$
END SUB
REM ***********************************************************************
REM -------- Subroutine for reading the error queue -----------------------
Sub ErrorQueueHandler()
    Dim result As String
    Dim hasErr As Boolean = True
    Do
        mbSession.Write("SYST:ERR?")
        result = mbSession.ReadString()
        Dim parts As String() = result.Split(",")
        If parts(0) = 0 Then
            hasErr = False
            Console.WriteLine(result)
        Else
            Console.WriteLine(result)
        End If
    Loop While hasErr
End Sub


Evaluation of SCPI Status Registers

Remote Commands > Programming Examples > Service Request > Evaluation of SCPI Status Registers
Evaluation of SCPI Status Registers
REM ------ Subroutine for evaluating Questionable Status Register ---------
Public SUB Questionablestatus()
Ques$ = SPACE$(20)
'Preallocate blanks to text
'variable
CALL InstrWrite (analyzer, "STATus:QUEStionable:EVENt?")
CALL InstrRead(analyzer, Ques$)
Debug.Print "Questionable Status:"; Ques$
END SUB
REM ***********************************************************************
REM ------ Subroutine for evaluating Operation Status Register ------------
Public SUB Operationstatus()
Oper$ = SPACE$(20) 'Preallocate blanks to text
'variable
CALL InstrWrite (analyzer, "STATus:OPERation:EVENt?")
CALL InstrRead(analyzer, Oper$)
Debug.Print "Operation Status:"; Oper$
END SUB
REM ***********************************************************************
REM ------ Subroutine for evaluating Questionable Status Register ---------
Public Sub Questionablestatus()
    Dim myQSR As String = Nothing
    Try
        myQSR = mbSession.Query("STATus:QUEStionable:EVENt?") 'Read QSR
        Console.WriteLine("Questionable Status:" + myQSR)
    Catch exp As Exception
        Console.WriteLine(exp.Message)
    End Try
End Sub

REM ------ Subroutine for evaluating Operation Status Register ------------
Public Sub Operationstatus()
    Dim myOSR As String = Nothing
    Try
        myOSR = mbSession.Query("STATus:OPERation:EVENt?") 'Read OSR
        Console.WriteLine("Operation Status:" + myOSR)
    Catch exp As Exception
        Console.WriteLine(exp.Message)
    End Try
End Sub


Evaluation of Event Status Register

Remote Commands > Programming Examples > Service Request > Evaluation of Event Status Register
Evaluation of Event Status Register
REM ------ Subroutine for evaluating the Event Status Register ------------
Public SUB Esrread()
Esr$ = SPACE$(20) 'Preallocate blanks to text
'variable
CALL InstrWrite (analyzer, "*ESR?") 'Read ESR
CALL InstrRead(analyzer, Esr$)
IF (VAL(Esr$) AND 1) > 0 THEN Debug.Print "Operation complete"
IF (VAL(Esr$) AND 2) > 0 THEN Debug.Print "Request Control"
IF (VAL(Esr$) AND 4) > 0
THEN Debug.Print "Query Error"
IF (VAL(Esr$) AND 8) > 0
THEN Debug.Print "Device dependent error"
IF (VAL(Esr$) AND 16) > 0
THEN Debug.Print "Execution Error; Program aborted"'Output error message
STOP 'Stop software
END IF
IF (VAL(Esr$) AND 32) > 0
THEN Debug.Print "Command Error; Program aborted"'Output error message
STOP 'Stop software
END IF
IF (VAL(Esr$) AND 64) > 0 THEN Debug.Print "User request"
IF (VAL(Esr$) AND 128) > 0 THEN Debug.Print "Power on"END SUB
REM **********************************************************************
REM ------ Subroutine for evaluating the Event Status Register ------------
Public Sub Esrread()
    Try
        Dim myESR As Short = mbSession.Query("*ESR?") 'Read ESR
        If (myESR And 1) > 0 Then Console.WriteLine("Operation complete")
        If (myESR And 2) > 0 Then Console.WriteLine("Request Control")
        If (myESR And 4) > 0 Then Console.WriteLine("Query Error")
        If (myESR And 8) > 0 Then Console.WriteLine("Device dependent error")
        If (myESR And 16) > 0 Then
            Console.WriteLine("Execution Error; Program aborted") 'Output error message
            Stop 'Stop software
        End If
        If (myESR And 32) > 0 Then
            Console.WriteLine("Command Error; Program aborted") 'Output error message
            Stop 'Stop software
        End If
        If (myESR And 64) > 0 Then Console.WriteLine("User request")
        If (myESR And 128) > 0 Then Console.WriteLine("Power on")
    Catch exp As Exception
        Console.WriteLine(exp.Message)
    End Try
End Sub


Maintenance

The R&S FSW does not require regular maintenance. Maintenance is essentially restricted to cleaning the R&S FSW. It is however advisable to check the nominal data from time to time.

Instrument damage caused by cleaning agents

Cleaning agents contain substances that may damage the instrument, for example cleaning agents that contain a solvent may damage the front panel labeling, plastic parts, or the display.

Never use cleaning agents such as solvents (thinners, acetone, etc), acids, bases, or other substances.

The outside of the instrument can be cleaned sufficiently using a soft, lint-free dust cloth.

The storage temperature range for the R&S FSW is specified in thr data sheet. The instrument must be protected against dust if it is to be stored for a long period.

When transporting or shipping the instrument, it is advisable to use the original packing material (especially the two protective covers for the front and rear panel).


Optimizing and Troubleshooting

If the results do not meet your expectations, the following sections may contain helpful hints and information.

Contents
  • Error Information
  • Error Messages in Remote Control Mode
  • Troubleshooting Remote Operation
  • Minimizing the Measurement Duration
  • Improving Averaging Results
  • Miscellaneous Troubleshooting Hints
  • Obtaining Technical Support


Error Messages in Remote Control Mode

Optimizing and Troubleshooting > Error Messages in Remote Control Mode
Error Messages in Remote Control Mode

In remote control mode error messages are entered in the error/event queue of the status reporting system and can be queried with the command SYSTem:ERRor?. The answer format of R&S FSW to the command is as follows:

<error code>, "<error text with queue query>; <remote control command concerned>"

The indication of the remote control command with prefixed semicolon is optional.

Example:

The command TEST:COMMAND generates the following answer to the query SYSTem:ERRor?

-113,"Undefined header;TEST:COMMAND"

There are two types of error messages:

  • Error messages defined by SCPI are marked by negative error codes. These messages are defined and described in the SCPI standard and not listed here.
  • Device-specific error messages use positive error codes. These messages are described below.
Device-specific error messages

Error code

Error text in the case of queue poll

Error explanation

1052

Frontend LO is Unlocked

This message is displayed when the phase regulation of the local oscillator fails in the RF front-end.

1060

Trigger-Block Gate Delay Error- gate length < Gate Delay

This message is displayed when the gate signal length is not sufficient for the pull-in delay with a predefined gate delay.

1064

Tracking LO is Unlocked

This message is displayed when the phase regulation of the local oscillator fails on the external generator module.

2028

Hardcopy not possible during measurement sequence

This message is displayed when a printout is started during scan sequences that cannot be interrupted. Such sequences are for example:

  • Recording the system error correction data (alignment)
  • Instrument self test

In such cases synchronization to the end of the scan sequence should be performed prior to starting the printout.

2033

Printer Not Available

This message is displayed when the selected printer is not included in the list of available output devices. A possible cause is that the required printer driver is missing or incorrectly installed.

2034

CPU Temperature is too high

This message is displayed when the temperature of the processor exceeds 70 °C.

Power Sensor errors
Status bar message | Description
Zeroing could not be performed | Zeroing could not be performed because the RF power applied is too high.
Power sensor zero failed |


Troubleshooting Remote Operation

Optimizing and Troubleshooting > Troubleshooting Remote Operation
Troubleshooting Remote Operation

If problems arise during measurement, try the following methods to solve them.

Uncompleted sequential commands - blocked remote channels

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel in order to abort the measurement.

To regain control over a blocked remote channel

  1. Send a "Device Clear" command from the control instrument to the R&S FSW to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

    • Visa: viClear()
    • GPIB: ibclr()
    • RSIB: RSDLLibclr()

    The remote channel currently processing the uncompleted command is then ready to receive further commands again.

  2. On the remote channel performing the measurement, send the SCPI command ABORt to abort the current measurement and reset the trigger system.

Ignored commands

When a remote command attempts to define incompatible settings, the command is ignored and the instrument status remains unchanged, i.e. other settings are not automatically adapted. Therefore, control programs should always define an initial instrument status (e.g. using the *RST command) and then implement the required settings.

Detecting false commands

If a remote program does not provide the expected results and you are using a GPIB connection, you can log the commands and any errors that may occur. To activate the SCPI error log function, in the "Network + Remote" dialog box, in the "GPIB" tab, select"I/O Logging".

All remote control commands received by the R&S FSW are recorded in the following log file:

C:\R_S\instr\ScpiLogging\ScpiLog.txt

Logging the commands may be extremely useful for debug purposes, e.g. in order to find misspelled keywords in control programs. However, remember to turn off the logging function after debugging to avoid unnecessary access to the hard drive and use of storage space.


Minimizing the Measurement Duration

Optimizing and Troubleshooting > Minimizing the Measurement Duration
Minimizing the Measurement Duration
If you want to minimize the measurement duration, try the following methods to optimize the measurement:
  • Reduce the span of the measurement to the relevant parts of the signal only.
  • Increase the RBW to minimize the measurement time; however, consider the requirements of the standard if you need to measure according to standard!
  • Take advantage of the speed optimization mode in the "Sweep" settings if you do not require the larger dynamic range (see "Optimization").
  • Reduce the sweep time and thus the amount of data to be captured and calculated; however, consider the requirements regarding the standard deviation.
  • To determine average (or peak) values, use an RMS detector (or peak detector) with a higher sweep time instead of trace averaging to obtain better average power results in less time. Furthermore, enforce the use of the sweep type "FFT" (as opposed to "Auto"; in Sweep mode, the averaging effect of the RMS detector may be less efficient).
  • When performing multiple measurements, use multiple measurement channels to switch between measurements rather than changing the settings within one channel repeatedly.
    Take advantage of the Sequencer function to switch between multiple measurements automatically or continuously (see also "Running a Sequence of Measurements").


Improving Averaging Results

Optimizing and Troubleshooting > Improving Averaging Results
Improving Averaging Results

Instead of trace averaging, use an RMS detector with a higher sweep time to obtain better average power results in less time. Furthermore, enforce the use of the sweep type "FFT" (as opposed to "Auto"; in Sweep mode, the averaging effect of the RMS detector may be less efficient).

In FFT mode, FFTs are calculated per bin and combined using the RMS detector. For trace averaging, on the other hand, the local oscillator must be switched repeatedly for each trace, which takes additional time.

Generally, a higher sweep time leads to more data to be averaged and thus stabilizes the results. In FFT mode, a higher sweep time means more FFTs are calculated and combined per bin.

Thus, in the same capture time, the FFT mode with an RMS detector can provide better results than an averaged trace.


Miscellaneous Troubleshooting Hints

Optimizing and Troubleshooting > Miscellaneous Troubleshooting Hints
Miscellaneous Troubleshooting Hints
└ Power levels for low frequency signals not correct
└ Invalid trace display


Power levels for low frequency signals not correct

Optimizing and Troubleshooting > Miscellaneous Troubleshooting Hints > Power levels for low frequency signals not correct
Power levels for low frequency signals not correct

By default, the R&S FSW uses AC coupling for RF input. For very low frequencies, the input signal may be distorted with this setting. In this case, use DC coupling instead. To change the setting, select INPUT/OUPUT > "Input Source Config > Radio Frequency > Input Coupling > DC".


Invalid trace display

Optimizing and Troubleshooting > Miscellaneous Troubleshooting Hints > Invalid trace display
Invalid trace display

If output to the IF 2 GHZ OUT connector is activated, the measured values are no longer sent to the display; thus, the trace data currently displayed on the R&S FSW becomes invalid. A message in the status bar indicates this situation.


Obtaining Technical Support

Optimizing and Troubleshooting > Obtaining Technical Support
Obtaining Technical Support

If problems occur, the instrument generates error messages which in most cases will be sufficient for you to detect the cause of an error and find a remedy.

Error messages are described in "Optimizing and Troubleshooting".

In addition, our customer support centers are there to assist you in solving any problems that you may encounter with your R&S FSW. We will find solutions more quickly and efficiently if you provide us with the information listed below.
  • System Configuration: The "System Configuration" dialog box (in the "Setup" menu) provides information on:
    – Hardware Info: hardware assemblies
    – Versions and Options: the status of all software and hardware options installed on your instrument
    – System Messages: messages on any errors that may have occurred

    An .xml file with information on the system configuration ("device footprint") can be created automatically (using the DIAGnostic:SERVice:SINFo command or as described in "To collect the support information").
  • Error Log: The RSError.log file (in the log directory of the main installation directory) contains a chronological record of errors.
  • Support file: a *.zip file with important support information can be created automatically. The *.zip file contains the system configuration information ("device footprint"), the current eeprom data and a screenshot of the screen display.

See also "Service Functions".

To collect the support information

  1. Press the SETUP key.

  2. Select "Service > R&S Support" and then "Create R&S Support Information".

    The file is stored as C:\R_S\instr\user\service.zip.

    Attach the support file to an e-mail in which you describe the problem and send it to the customer support address for your region as listed at the beginning of the R&S FSW Getting Started manual.

Packing and transporting the instrument

If the instrument needs to be transported or shipped, e.g. due to damage during delivery, observe the notes described in "Unpacking and Checking the Instrument".


List of remote commands (base unit)
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:TRIG
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]BANDwidth|BWIDth:VIDeo
[SENSe:]BANDwidth|BWIDth:VIDeo:AUTO
[SENSe:]BANDwidth|BWIDth:VIDeo:RATio
[SENSe:]BANDwidth|BWIDth:VIDeo:TYPE
[SENSe:]BANDwidth|BWIDth[:RESolution]
[SENSe:]BANDwidth|BWIDth[:RESolution]:AUTO
[SENSe:]BANDwidth|BWIDth[:RESolution]:FFT
[SENSe:]BANDwidth|BWIDth[:RESolution]:RATio
[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE
[SENSe:]CORRection:COLLect[:ACQuire]
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:METHod
[SENSe:]CORRection:RECall
[SENSe:]CORRection:TRANsducer:ADJust:RLEVel[:STATe]
[SENSe:]CORRection:TRANsducer:COMMent
[SENSe:]CORRection:TRANsducer:DATA
[SENSe:]CORRection:TRANsducer:DELete
[SENSe:]CORRection:TRANsducer:GENerator
[SENSe:]CORRection:TRANsducer:SCALing
[SENSe:]CORRection:TRANsducer:SELect
[SENSe:]CORRection:TRANsducer:UNIT
[SENSe:]CORRection:TRANsducer[:STATe]
[SENSe:]CORRection[:STATe]
[SENSe:]DEMod:SQUelch:LEVel
[SENSe:]DEMod:SQUelch[:STATe]
[SENSe:]ESPectrum:SBCount
[SENSe:]ESPectrum<sb>:BWID
[SENSe:]ESPectrum<sb>:FILTer[:RRC]:ALPHa
[SENSe:]ESPectrum<sb>:FILTer[:RRC][:STATe]
[SENSe:]ESPectrum<sb>:HighSPeed
[SENSe:]ESPectrum<sb>:MSR:APPLy
[SENSe:]ESPectrum<sb>:MSR:BAND
[SENSe:]ESPectrum<sb>:MSR:BCATegory
[SENSe:]ESPectrum<sb>:MSR:CLAS
[SENSe:]ESPectrum<sb>:MSR:GSM:CARR
[SENSe:]ESPectrum<sb>:MSR:GSM:CPResent
[SENSe:]ESPectrum<sb>:MSR:LTE:CPResent
[SENSe:]ESPectrum<sb>:MSR:MPOWer
[SENSe:]ESPectrum<sb>:MSR:RFBWidth
[SENSe:]ESPectrum<sb>:PRESet:RESTore
[SENSe:]ESPectrum<sb>:PRESet:STORe
[SENSe:]ESPectrum<sb>:PRESet[:STANdard]
[SENSe:]ESPectrum<sb>:RANGe:COUNt?
[SENSe:]ESPectrum<sb>:RANGe:LIMit<PClass>:STATe
[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth:VIDeo
[SENSe:]ESPectrum<sb>:RANGe<range>:BANDwidth[:RESolution]
[SENSe:]ESPectrum<sb>:RANGe<range>:DELete
[SENSe:]ESPectrum<sb>:RANGe<range>:FILTer:TYPE
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:ATTenuation:AUTO
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN
[SENSe:]ESPectrum<sb>:RANGe<range>:INPut:GAIN:STATe
[SENSe:]ESPectrum<sb>:RANGe<range>:INSert
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:ABSolute:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:ABS
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STARt:FUNCtion
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:ABSolute
[SENSe:]ESPectrum<sb>:RANGe<range>:LIMit<PClass>:RELative:STOP:FUNCtion
[SENSe:]ESPectrum<sb>:RANGe<range>:MLCalc
[SENSe:]ESPectrum<sb>:RANGe<range>:POINts:MIN[:VALue]
[SENSe:]ESPectrum<sb>:RANGe<range>:RLEVel
[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME
[SENSe:]ESPectrum<sb>:RANGe<range>:SWEep:TIME:AUTO
[SENSe:]ESPectrum<sb>:RANGe<range>:TRANsducer
[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STARt
[SENSe:]ESPectrum<sb>:RANGe<range>[:FREQuency]:STOP
[SENSe:]ESPectrum<sb>:RRANge?
[SENSe:]ESPectrum<sb>:RTYPe
[SENSe:]ESPectrum<sb>:SBCenter
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN:FULL
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP
[SENSe:]LIST:POWer:RESult?
[SENSe:]LIST:POWer:SET
[SENSe:]LIST:POWer:STATe
[SENSe:]LIST:POWer[:SEQuence]
[SENSe:]LIST:RANGe:BREak
[SENSe:]LIST:RANGe:COUNt?
[SENSe:]LIST:RANGe:LIMit:STATe
[SENSe:]LIST:RANGe<range>:BANDwidth:VIDeo
[SENSe:]LIST:RANGe<range>:BANDwidth[:RESolution]
[SENSe:]LIST:RANGe<range>:DELete
[SENSe:]LIST:RANGe<range>:DETector
[SENSe:]LIST:RANGe<range>:FILTer:TYPE
[SENSe:]LIST:RANGe<range>:INPut:ATTenuation
[SENSe:]LIST:RANGe<range>:INPut:ATTenuation:AUTO
[SENSe:]LIST:RANGe<range>:INPut:GAIN:STATe
[SENSe:]LIST:RANGe<range>:INPut:GAIN[:VALue]
[SENSe:]LIST:RANGe<range>:LIMit:STARt
[SENSe:]LIST:RANGe<range>:LIMit:STOP
[SENSe:]LIST:RANGe<range>:POINts[:VALue]
[SENSe:]LIST:RANGe<range>:RLEVel
[SENSe:]LIST:RANGe<range>:SWEep:TIME
[SENSe:]LIST:RANGe<range>:SWEep:TIME:AUTO
[SENSe:]LIST:RANGe<range>:TRANsducer
[SENSe:]LIST:RANGe<range>[:FREQuency]:STARt
[SENSe:]LIST:RANGe<range>[:FREQuency]:STOP
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]
[SENSe:]MPOWer:[:SEQuence]
[SENSe:]MPOWer:FTYPe
[SENSe:]MPOWer:RESult:MIN?
[SENSe:]MPOWer:RESult[:LIST]?
[SENSe:]PMETer<p>:DCYCle:VALue
[SENSe:]PMETer<p>:DCYCle[:STATe]
[SENSe:]PMETer<p>:FREQuency
[SENSe:]PMETer<p>:FREQuency:LINK
[SENSe:]PMETer<p>:MTIMe
[SENSe:]PMETer<p>:MTIMe:AVERage:COUNt
[SENSe:]PMETer<p>:MTIMe:AVERage[:STATe]
[SENSe:]PMETer<p>:ROFFset[:STATe]
[SENSe:]PMETer<p>:TRIGger:DTIMe
[SENSe:]PMETer<p>:TRIGger:HOLDoff
[SENSe:]PMETer<p>:TRIGger:HYSTeresis
[SENSe:]PMETer<p>:TRIGger:LEVel
[SENSe:]PMETer<p>:TRIGger:SLOPe
[SENSe:]PMETer<p>:TRIGger[:STATe]
[SENSe:]PMETer<p>:UPDate[:STATe]
[SENSe:]PMETer<p>[:STATe]
[SENSe:]POWer:ACHannel:ACPairs
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ACHannel
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:ALTernate<ch>
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth:GAP<gap>
[SENSe:]POWer:ACHannel:BANDwidth|BWIDth[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:FILTer:ALPHa:ACHannel
[SENSe:]POWer:ACHannel:FILTer:ALPHa:ALTernate<ch>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:GAP<gap>
[SENSe:]POWer:ACHannel:FILTer:ALPHa:SBLock<sb>:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer:ALPHa[:ALL]
[SENSe:]POWer:ACHannel:FILTer:STATe:GAP<gap>
[SENSe:]POWer:ACHannel:FILTer:STATe:SBLock<sb>:CHANnel<ch>
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ACHannel
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALL
[SENSe:]POWer:ACHannel:FILTer[:STATe]:ALTernate<ch>
[SENSe:]POWer:ACHannel:FILTer[:STATe]:CHANnel<ch>
[SENSe:]POWer:ACHannel:MODE
[SENSe:]POWer:ACHannel:NAME:ACHannel
[SENSe:]POWer:ACHannel:NAME:ALTernate<ch>
[SENSe:]POWer:ACHannel:NAME:CHANnel<ch>
[SENSe:]POWer:ACHannel:PRESet
[SENSe:]POWer:ACHannel:PRESet:RLEVel
[SENSe:]POWer:ACHannel:REFerence:AUTO ONCE
[SENSe:]POWer:ACHannel:REFerence:TXCHannel:AUTO
[SENSe:]POWer:ACHannel:REFerence:TXCHannel:MANual
[SENSe:]POWer:ACHannel:SBCount
[SENSe:]POWer:ACHannel:SBLock<sb>:BANDwidth|BWIDth[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:CENTer[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:FREQuency:CENTer
[SENSe:]POWer:ACHannel:SBLock<sb>:NAME[:CHANnel<ch>]?
[SENSe:]POWer:ACHannel:SBLock<sb>:RFBWidth
[SENSe:]POWer:ACHannel:SBLock<sb>:TECHnology[:CHANnel<ch>]
[SENSe:]POWer:ACHannel:SBLock<sb>:TXCHannel:COUNt
[SENSe:]POWer:ACHannel:SPACing:ALTernate<ch>
[SENSe:]POWer:ACHannel:SPACing:CHANnel<ch>
[SENSe:]POWer:ACHannel:SPACing:GAP<gap>
[SENSe:]POWer:ACHannel:SPACing[:ACHannel]
[SENSe:]POWer:ACHannel:TXCHannel:COUNt
[SENSe:]POWer:BANDwidth|BWIDth
[SENSe:]POWer:HSPeed
[SENSe:]POWer:NCORrection
[SENSe:]POWer:TRACe
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]ROSCillator:LBWidth
[SENSe:]ROSCillator:O100
[SENSe:]ROSCillator:O640
[SENSe:]ROSCillator:OSYNc
[SENSe:]ROSCillator:SOURce
[SENSe:]ROSCillator:SOURce:EAUTo?
[SENSe:]ROSCillator:TRANge
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:EGATe
[SENSe:]SWEep:EGATe:HOLDoff
[SENSe:]SWEep:EGATe:LENGth
[SENSe:]SWEep:EGATe:POLarity
[SENSe:]SWEep:EGATe:SOURce
[SENSe:]SWEep:EGATe:TRACe:PERiod
[SENSe:]SWEep:EGATe:TRACe<k>:COMMent
[SENSe:]SWEep:EGATe:TRACe<k>:STARt<range>
[SENSe:]SWEep:EGATe:TRACe<k>:STOP<range>
[SENSe:]SWEep:EGATe:TRACe<k>[:STATe<range>]
[SENSe:]SWEep:EGATe:TYPE
[SENSe:]SWEep:MODE
[SENSe:]SWEep:OPTimize
[SENSe:]SWEep:POINts
[SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME:AUTO
[SENSe:]SWEep:TYPE
[SENSe:]SWEep:TYPE:USED
*CAL?
*CLS
*ESE
*ESR?
*IDN?
*IST?
*OPC
*OPT?
*PCB
*PRE
*PSC
*RST
*SRE
*STB?
*TRG
*TST?
*WAI
ABORt
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:DETector
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?
CALCulate:DELTamarker<m>:FUNCtion:FMEasurement:RESult?
CALCulate:LIMit:ACPower:ACHannel:ABSolute
CALCulate:LIMit:ACPower:ACHannel:ABSolute:STATe
CALCulate:LIMit:ACPower:ACHannel:RESult?
CALCulate:LIMit:ACPower:ACHannel[:RELative]
CALCulate:LIMit:ACPower:ACHannel[:RELative]:STATe
CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute
CALCulate:LIMit:ACPower:ALTernate<ch>:ABSolute:STATe
CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?
CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]
CALCulate:LIMit:ACPower:ALTernate<ch>[:RELative]:STATe
CALCulate:LIMit:ACPower:GAP<gap>:ABSolute
CALCulate:LIMit:ACPower:GAP<gap>:ABSolute:STATe
CALCulate:LIMit:ACPower:GAP<gap>:RESult?
CALCulate:LIMit:ACPower:GAP<gap>[:RELative:]STATe
CALCulate:LIMit:ACPower:GAP<gap>[:RELative]
CALCulate:LIMit:ACPower[:STATe]
CALCulate:LIMit:ACTive?
CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit:COMMent
CALCulate:LIMit:ESPectrum:RESTore
CALCulate:LIMit:ESPectrum<sb>:LIMits
CALCulate:LIMit:ESPectrum<sb>:MODE
CALCulate:LIMit:ESPectrum<sb>:PCLass:COUNt
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:LIMit[:STATe]
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MAXimum
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>:MINimum
CALCulate:LIMit:ESPectrum<sb>:PCLass<class>[:EXCLusive]
CALCulate:LIMit:ESPectrum<sb>:VALue
CALCulate:LIMit<k>:CONTrol:DOMain
CALCulate:LIMit<k>:CONTrol:MODE
CALCulate:LIMit<k>:CONTrol:OFFSet
CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:CONTrol:SPACing
CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:LOWer:MARGin
CALCulate:LIMit<k>:LOWer:MODE
CALCulate:LIMit<k>:LOWer:OFFSet
CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:SPACing
CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:LOWer:THReshold
CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe<t>:CHECk
CALCulate:LIMit<k>:UNIT
CALCulate:LIMit<k>:UPPer:MARGin
CALCulate:LIMit<k>:UPPer:MODE
CALCulate:LIMit<k>:UPPer:OFFSet
CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:SPACing
CALCulate:LIMit<k>:UPPer:STATe
CALCulate:LIMit<k>:UPPer:THReshold
CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:MARKer:FUNCtion:FMEasurement:DWELl
CALCulate:MARKer:FUNCtion:FMEasurement:PSEarch|PEAKsearch:AUTO
CALCulate:MARKer:FUNCtion:FMEasurement:STATe
CALCulate:MARKer:FUNCtion:FPEaks:COUNt?
CALCulate:MARKer:FUNCtion:FPEeaks:X?
CALCulate:MARKer:FUNCtion:FPEeaks:Y?
CALCulate:MARKer:FUNCtion:NDBDown:QFACtor?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MARKer:FUNCtion:STRack:BANDwidth
CALCulate:MARKer:FUNCtion:STRack:THReshold
CALCulate:MARKer:FUNCtion:STRack:TRACe
CALCulate:MARKer:FUNCtion:STRack[:STATe]
CALCulate:MARKer:FUNCtion:TOI:SEARchsignal ONCE
CALCulate:MARKer:LOEXclude
CALCulate:MARKer:X:SLIMits:LEFT
CALCulate:MARKer:X:SLIMits:RIGHT
CALCulate:MARKer:X:SLIMits:ZOOM[:STATe]
CALCulate:MARKer:X:SLIMits[:STATe]
CALCulate:MARKer:X:SSIZe
CALCulate:MARKer<m>:FUNCtion:FMEasurement:DETector
CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:CONDition ?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:LIMit<k>:DELTa?
CALCulate:MARKer<m>:FUNCtion:FMEasurement:RESult?
CALCulate:SGRam|SPECtrogram:CLEar[:IMMediate]
CALCulate:SGRam|SPECtrogram:CONT
CALCulate:SGRam|SPECtrogram:FRAMe:COUNt
CALCulate:SGRam|SPECtrogram:FRAMe:SELect
CALCulate:SGRam|SPECtrogram:HDEPth
CALCulate:SGRam|SPECtrogram:TSTamp:DATA?
CALCulate:SGRam|SPECtrogram:TSTamp[:STATe]
CALCulate:SGRam|SPECtrogram[:STATe]
CALCulate:STATistics:RESult<t>?
CALCulate:THReshold
CALCulate:THReshold:STATe
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:MODE
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer:SPAN
CALCulate<n>:DELTamarker<m>:FUNCtion:BPOWer[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:X
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed:RPOint:Y:OFFSet
CALCulate<n>:DELTamarker<m>:FUNCtion:FIXed[:STATe]
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:AUTO
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise:RESult?
CALCulate<n>:DELTamarker<m>:FUNCtion:PNOise[:STATe]
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:SARea
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DLINe<k>
CALCulate<n>:DLINe<k>:STATe
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:AUTO
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:MARGin
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch:PSHow
CALCulate<n>:ESPectrum:PSEarch|PEAKsearch[:IMMediate]
CALCulate<n>:FLINe<k>
CALCulate<n>:FLINe<k>:STATe
CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:SGRam|SPECtrogram:SARea
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:COUNt
CALCulate<n>:MARKer<m>:COUNt:FREQuency?
CALCulate<n>:MARKer<m>:COUNt:RESolution
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:MODE
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer:SPAN
CALCulate<n>:MARKer<m>:FUNCtion:BPOWer[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:CENTer
CALCulate<n>:MARKer<m>:FUNCtion:CSTep
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:CONTinuous
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:HOLDoff
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation:SELect
CALCulate<n>:MARKer<m>:FUNCtion:DEModulation[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:ANNotation:LABel[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:LIST:SIZE
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:SORT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks:STAT
CALCulate<n>:MARKer<m>:FUNCtion:FPEaks[:IMMediate]
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:BANDwidth:AUTO
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:DISTortion?
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:LIST?
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:NHARmonics
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics:PRESet
CALCulate<n>:MARKer<m>:FUNCtion:HARMonics[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth:SEARchsignal ONCE
CALCulate<n>:MARKer<m>:FUNCtion:MDEPth[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:MSUMmary
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:FREQuency?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:STATe
CALCulate<n>:MARKer<m>:FUNCtion:NDBDown:TIME?
CALCulate<n>:MARKer<m>:FUNCtion:NOISe:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:NOISe[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:POWer:MODE
CALCulate<n>:MARKer<m>:FUNCtion:POWer:PRESet
CALCulate<n>:MARKer<m>:FUNCtion:POWer:RESult:PHZ
CALCulate<n>:MARKer<m>:FUNCtion:POWer:SELect
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:CATalog?
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:DELete
CALCulate<n>:MARKer<m>:FUNCtion:POWer:STANdard:SAVE
CALCulate<n>:MARKer<m>:FUNCtion:POWer[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:REFerence
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:AVERage
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:MEAN[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PHOLd
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:PPEak[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:RMS[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:AVERage:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:PHOLd:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary:SDEViation[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:SUMMary[:STATe]
CALCulate<n>:MARKer<m>:FUNCtion:TOI:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:TOI[:STATe]
CALCulate<n>:MARKer<m>:MAXimum:AUTO
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:AUTO
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:FRAMe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:XY:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:ABOVe
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:BELow
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum:NEXT
CALCulate<n>:MARKer<m>:SGRam|SPECtrogram:Y:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y:PERCent
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MATH:MODE
CALCulate<n>:MATH:POSition
CALCulate<n>:MATH:STATe
CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:PMETer<p>:RELative:STATe
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]
CALCulate<n>:PMETer<p>:RELative[:MAGNitude]:AUTO ONCE
CALCulate<n>:PSEarch|PEAKsearch:AUTO
CALCulate<n>:PSEarch|PEAKsearch:MARGin
CALCulate<n>:PSEarch|PEAKsearch:PSHow
CALCulate<n>:PSEarch|PEAKsearch:SUBRanges
CALCulate<n>:STATistics:APD[:STATe]
CALCulate<n>:STATistics:CCDF:X<t>?
CALCulate<n>:STATistics:CCDF[:STATe]
CALCulate<n>:STATistics:NSAMples
CALCulate<n>:STATistics:PRESet
CALCulate<n>:STATistics:SCALe:AUTO ONCE
CALCulate<n>:STATistics:SCALe:X:RANGe
CALCulate<n>:STATistics:SCALe:X:RLEVel
CALCulate<n>:STATistics:SCALe:Y:LOWer
CALCulate<n>:STATistics:SCALe:Y:UNIT
CALCulate<n>:STATistics:SCALe:Y:UPPer
CALCulate<n>:TLINe<Line>
CALCulate<n>:TLINe<Line>:STATe
CALCulate<n>:UNIT:POWer
CALibration:PMETer<p>:ZERO:AUTO ONCE
CALibration:RESult?
CALibration[:ALL]?
DIAGnostic:INFO:CCOunter?
DIAGnostic:SERVice:BIOSinfo?
DIAGnostic:SERVice:HWINfo?
DIAGnostic:SERVice:INPut:AIQ[:TYPE]
DIAGnostic:SERVice:INPut:MC:DISTance
DIAGnostic:SERVice:INPut:PULSed:CFRequency
DIAGnostic:SERVice:INPut:RF:SPECtrum
DIAGnostic:SERVice:INPut[:SELect]
DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:SFUNction
DIAGnostic:SERVice:SFUNction:LASTresult?
DIAGnostic:SERVice:SFUNction:RESults:DELete
DIAGnostic:SERVice:SFUNction:RESults:SAVE
DIAGnostic:SERVice:SINFo?
DIAGnostic:SERVice:STESt:RESult?
DIAGnostic:SERVice:VERSinfo?
DISPlay:ANNotation:CBAR
DISPlay:ANNotation:FREQuency
DISPlay:ATAB
DISPlay:CMAP<item>:DEFault<colors>
DISPlay:CMAP<item>:HSL
DISPlay:CMAP<item>:PDEFined
DISPlay:FORMat
DISPlay:LOGO
DISPlay:MTABle
DISPlay:PSAVe:HOLDoff
DISPlay:PSAVe[:STATe]
DISPlay:SBAR[:STATe]
DISPlay:SKEYs[:STATe]
DISPlay:TBAR[:STATe]
DISPlay:THEMe:CATalog?
DISPlay:THEMe:SELect
DISPlay:TOUChscreen:STATe
DISPlay[:WINDow]:TIME
DISPlay[:WINDow]:TIME:FORMat
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:DEFault
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:LOWer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:SHAPe
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor:UPPer
DISPlay[:WINDow<n>]:SGRam|SPECtrogram:COLor[:STYLe]
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:STATe
DISPlay[:WINDow<n>]:TRACe:X:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TYPE
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FETCh:PMETer<p>?
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
FORMat[:DATA]
HCOPy:ABORt
HCOPy:CMAP<item>:DEFault<colors>
HCOPy:CMAP<item>:HSL
HCOPy:CMAP<item>:PDEFined
HCOPy:DESTination<device>
HCOPy:DEVice:COLor
HCOPy:DEVice:LANGuage<device>
HCOPy:ITEM:ALL
HCOPy:ITEM:WINDow:TEXT
HCOPy:PAGE:ORIentation<device>
HCOPy:TDSTamp:STATe<device>
HCOPy[:IMMediate<device>]
HCOPy[:IMMediate<device>]:NEXT
INITiate:CONMeas
INITiate:CONTinuous
INITiate:ESPectrum
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SPURious
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:LISN:FILTer:HPASs[:STATe]
INPut:LISN:PHASe
INPut:LISN:TYPE
INPut:SELect
INPut:UPORt:STATe
INPut:UPORt[:VALue]?
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:MODE
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:CATalog:LONG?
MMEMory:CATalog?
MMEMory:CDIRectory
MMEMory:CLEar:ALL
MMEMory:CLEar:STATe
MMEMory:COMMent
MMEMory:COPY
MMEMory:DATA
MMEMory:DELete
MMEMory:LOAD:AUTO
MMEMory:LOAD:STATe
MMEMory:LOAD:TYPE
MMEMory:MDIRectory
MMEMory:MOVE
MMEMory:MSIS
MMEMory:NAME
MMEMory:NETWork:DISConnect
MMEMory:NETWork:MAP
MMEMory:NETWork:UNUSeddrives?
MMEMory:NETWork:USEDdrives?
MMEMory:RDIRectory
MMEMory:SELect:CHANnel[:ITEM]:ALL
MMEMory:SELect:CHANnel[:ITEM]:DEFault
MMEMory:SELect:CHANnel[:ITEM]:HWSettings
MMEMory:SELect:CHANnel[:ITEM]:LINes:ALL
MMEMory:SELect:CHANnel[:ITEM]:NONE
MMEMory:SELect:CHANnel[:ITEM]:SGRam
MMEMory:SELect:CHANnel[:ITEM]:TRACe[:ACTive]
MMEMory:SELect:CHANnel[:ITEM]:TRANsducer:ALL
MMEMory:SELect[:ITEM]:ALL
MMEMory:SELect[:ITEM]:DEFault
MMEMory:SELect[:ITEM]:HWSettings
MMEMory:SELect[:ITEM]:LINes:ALL
MMEMory:SELect[:ITEM]:NONE
MMEMory:SELect[:ITEM]:SGRam
MMEMory:SELect[:ITEM]:TRACe[:ACTive]
MMEMory:SELect[:ITEM]:TRANsducer:ALL
MMEMory:STORe:LIST
MMEMory:STORe:PEAK
MMEMory:STORe:SPURious
MMEMory:STORe:STATe
MMEMory:STORe:STATe:NEXT
MMEMory:STORe:TYPE
MMEMory:STORe<n>:SGRam
MMEMory:STORe<n>:TRACe
OUTPut:IF:IFFRequency
OUTPut:IF:SBANd?
OUTPut:IF[:SOURce]
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:UPORt:STATe
OUTPut:UPORt[:VALue]
READ:PMETer<p>?
SOURce:EXTernal:FREQuency
SOURce:EXTernal:FREQuency:COUPling[:STATe]
SOURce:EXTernal:FREQuency:OFFSet
SOURce:EXTernal:FREQuency:SWEep[:STATe]
SOURce:EXTernal:FREQuency[:FACTor]:DENominator
SOURce:EXTernal:FREQuency[:FACTor]:NUMerator
SOURce:EXTernal:POWer[:LEVel]
SOURce:EXTernal:ROSCillator:EXTernal:FREQuency
SOURce:EXTernal:ROSCillator[:SOURce]
SOURce:EXTernal[:STATe]
SOURce:POWer[:LEVel][:IMMediate]:OFFSet
SOURce:TEMPerature:FRONtend?
STATus:OPERation:CONDition?
STATus:OPERation:ENABle
STATus:OPERation:NTRansition
STATus:OPERation:PTRansition
STATus:OPERation[:EVENt]?
STATus:PRESet
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ENABle
STATus:QUEStionable:EXTended:CONDition?
STATus:QUEStionable:EXTended:ENABle
STATus:QUEStionable:EXTended:INFO:CONDition?
STATus:QUEStionable:EXTended:INFO:ENABle
STATus:QUEStionable:EXTended:INFO:NTRansition
STATus:QUEStionable:EXTended:INFO:PTRansition
STATus:QUEStionable:EXTended:INFO[:EVENt]?
STATus:QUEStionable:EXTended:NTRansition
STATus:QUEStionable:EXTended:PTRansition
STATus:QUEStionable:EXTended[:EVENt]?
STATus:QUEStionable:FREQuency:CONDition?
STATus:QUEStionable:FREQuency:ENABle
STATus:QUEStionable:FREQuency:NTRansition
STATus:QUEStionable:FREQuency:PTRansition
STATus:QUEStionable:FREQuency[:EVENt]?
STATus:QUEStionable:LIMit<n>:CONDition?
STATus:QUEStionable:LIMit<n>:ENABle
STATus:QUEStionable:LIMit<n>:NTRansition
STATus:QUEStionable:LIMit<n>:PTRansition
STATus:QUEStionable:LIMit<n>[:EVENt]?
STATus:QUEStionable:LMARgin<n>:CONDition?
STATus:QUEStionable:LMARgin<n>:ENABle
STATus:QUEStionable:LMARgin<n>:NTRansition
STATus:QUEStionable:LMARgin<n>:PTRansition
STATus:QUEStionable:LMARgin<n>[:EVENt]?
STATus:QUEStionable:NTRansition
STATus:QUEStionable:POWer:CONDition?
STATus:QUEStionable:POWer:ENABle
STATus:QUEStionable:POWer:NTRansition
STATus:QUEStionable:POWer:PTRansition
STATus:QUEStionable:POWer[:EVENt]?
STATus:QUEStionable:PTRansition
STATus:QUEStionable:TEMPerature:CONDition?
STATus:QUEStionable:TEMPerature:ENABle
STATus:QUEStionable:TEMPerature:NTRansition
STATus:QUEStionable:TEMPerature:PTRansition
STATus:QUEStionable:TEMPerature[:EVENt]?
STATus:QUEStionable:TIME:CONDition?
STATus:QUEStionable:TIME:ENABle
STATus:QUEStionable:TIME:NTRansition
STATus:QUEStionable:TIME:PTRansition
STATus:QUEStionable:TIME[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEue[:NEXT]?
SYSTem:CLOGging
SYSTem:COMMunicate:GPIB:RDEVice:GENerator:ADDRess
SYSTem:COMMunicate:GPIB[:SELF]:ADDRess
SYSTem:COMMunicate:GPIB[:SELF]:RTERminator
SYSTem:COMMunicate:PRINter:ENUMerate:FIRSt?
SYSTem:COMMunicate:PRINter:ENUMerate[:NEXT]?
SYSTem:COMMunicate:PRINter:SELect<device>
SYSTem:COMMunicate:RDEVice:GENerator:INTerface
SYSTem:COMMunicate:RDEVice:GENerator:LINK
SYSTem:COMMunicate:RDEVice:GENerator:TYPE
SYSTem:COMMunicate:RDEVice:PMETer:COUNt?
SYSTem:COMMunicate:RDEVice:PMETer<p>:CONFigure:AUTO[:STATe]
SYSTem:COMMunicate:RDEVice:PMETer<p>:DEFine
SYSTem:COMMunicate:TCPip:RDEVice:GENerator:ADDRess
SYSTem:COMPatible
SYSTem:DISPlay:FPANel[:STATe]
SYSTem:DISPlay:UPDate
SYSTem:ERRor:CLEar:ALL
SYSTem:ERRor:EXTended?
SYSTem:ERRor:LIST?
SYSTem:ERRor[:NEXT]?
SYSTem:FORMat:IDENt
SYSTem:HPCoupling
SYSTem:IDENtify:FACTory
SYSTem:IDENtify[:STRing]
SYSTem:IFGain:MODE
SYSTem:LANGuage
SYSTem:LXI:INFo?
SYSTem:LXI:LANReset
SYSTem:LXI:MDEScription
SYSTem:LXI:PASSword
SYSTem:PREamplifier
SYSTem:PRESet
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:COMPatible
SYSTem:PSA:WIDeband
SYSTem:REBoot
SYSTem:REVision:FACTory
SYSTem:REVision[:STRing]
SYSTem:RSW
SYSTem:SECurity[:STATe]
SYSTem:SEQuencer
SYSTem:SHUTdown
TRACe<n>:COPY
TRACe<n>[:DATA]
TRACe<n>[:DATA]:MEMory?
TRACe<n>[:DATA]:X?
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval
UNIT<n>:PMETer<p>:POWer
UNIT<n>:PMETer<p>:POWer:RATio