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Introduction 
IDERA ER/Studio Team Server is a model and metadata collaboration platform that provides greater 
meaning, understanding and context to enterprise data. Database professionals, developers, and business 
analysts gain better comprehension and compliance using integrated model, metadata & collaboration 
tools. Team Server's collaborative enterprise glossary brings together the entire organization to foster 
improved metadata, business definitions, governance, compliance, and security policies. Online models 
showcase data relationships, while powerful search capabilities help users locate enterprise data with ease. 
Integration with IDERA’s database management tools, including Performance IQ licenses for Team Server, 
extends the reach of enterprise metadata with interactive “on-the-fly” tool-tips containing glossary 
definitions, policy information and associated metadata in the client tools. 

Product benefits by audience 
Data Consumers • Integrate effective data comprehension capabilities in to 

daily workflows, delivering context and meaning to every 
user.  

• Enable collaboration around data among teams across 
business units or business functions.  

• Support corporate compliance initiatives by driving 
responsible use of sensitive or private data 

Data Modeling Professionals • Integrate the glossary's business definitions with internal 
web assets to provide on-the-fly business context with 
tool-tips and pop-ups.  

• Create a single registry of all available data sources.  

• Adhere to industry regulations and business standards 
regarding security and privacy, by alerting users who 
view or modify sensitive data within the tools. 

Data Management Professionals & 
Developers 

• Develop applications faster by using business terms 
to easily locate data elements. 

• Monitor access to and use of business glossaries and 
associated functions, to understand immediate data 
management requirements. 

• View in-line metadata in DBArtisan & Rapid SQL. 

• Monitoring capability with Performance IQ Team 
Server. 
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About this guide 
This guide is intended to help you get started using IDERA Team Server as part of the ER/Studio product 
family. 

The design of the guide is to enable you to, read through and see the exciting features 
that Team Server delivers, or if you have a demo environment set up, you can follow our 
evaluation step-by-step sections. These sections are highlighted with the ‘mouse’ icon 
and allow you to get first-hand experience at the exciting new features. 

Should you wish to experience some of the more advanced features in the evaluation, 
you will be required to configure your installation so that these features can be 
demonstrated. These sections are highlighted with the ‘configuration/tools’ icon. 

 

The reading sections enable you to walk you through some more complicated features 
and give an overview for you to read through only. These are highlighted by the 
‘reading’ icon. 

To complete this guide fully, you will need to have latest versions of DBArtisan or Rapid SQL and Team 
Server installed. For more information, an up to date installation guide is available online. Please see 
https://www.idera.com/support/productdocuments for details. 

You will need additional files for this evaluation, they can be found under Evaluation Resources on the 
main page of the Team Server wiki 
(http://docwiki.embarcadero.com/TeamServer/ERStudio/2016/en/Main_Page). 

The tutorials are divided into 14 sessions in three parts, do them all at once or complete them individually 
as your time permits. You can use this basic tutorial as a road map of some product highlights, but also to 
help you find your own path in exploring Team Server. 

Part 1 - The basics 

• Getting Started with IDERA Team Server 

• ER/Studio Team Server - glossaries and terms 

• Create a new glossary 

• Import glossaries and terms 

• Searching for terms - A usage example 

• Filtering search terms 

Part 2 - Set up, Alerts and DB Team Server 

• Setting up for further evaluation 

• ER/Studio Data Architect configuration 

• ER/Studio Team Server configuration 

• ER objects - Viewing alerts  

• DB Team Server and DB PowerStudio product integration 

Part 3 - Advanced features 

• ER/Studio Team Server - More features 

• People 

• Glossary tooltips 

http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page
http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page
http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page
http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page
http://docwiki.embarcadero.com/TeamServer/ERStudio/en/Main_Page
https://www.idera.com/support/productdocuments
http://docwiki.embarcadero.com/TeamServer/ERStudio/2016/en/Main_Page
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Getting started with IDERA Team Server 
When you first log in to Team Server, you are presented with the Welcome page. 

NOTE: The default login being Username =Admin > Password =Admin. 
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The graphic below names and describes the functionality of some key elements of the Team Server user 
interface. 

 
Home page displays 
the social interface, 
showing recent activity 
and team 
communication. 

 
 
Items that you have followed 
are listed here to give you 
easy one-click access. As are 
users who have followed you. 
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ER/Studio Team Server glossaries and terms 
Now that you have logged in, you can start to explore the rich features of Team Server. 

Your Home Page has Streams to keep you informed of any modifications or activity with, for example, ER 
Objects, Glossaries or Terms that you have an interest in. These are especially useful to keep in touch with 
any discussions. 

The top navigation menu allows you to navigate through the features available. The left menu bar gives 
further features related to the current top menu item. 

Create a new glossary 
1. To create a new Glossary, on the top menu bar click on the Glossaries tab. 

2. On the top right of the window, click the New Glossary button to open the New Glossary dialog. 

3. Enter the Name, ‘My Glossary’ and a Definition of your choosing. 

4. Click Save to create your new Glossary.  

That’s it! 

Creating Terms in your new Glossary is just as easy. However, if you would like to create many Glossaries 
and Terms quickly and easily, we have an import function that can create Glossaries and Terms simply. 

Import glossaries and terms 
1. To import a .csv file, on the top menu bar click on the Glossaries tab. 

2. On the top right of the window, click the Load Glossaries button. 

3. Browse and locate the glossaries_demo.csv file that is supplied for this example and click the Load 
button. 

NOTE:  You are welcome to choose the glossaries_full.csv file, which is a much larger file, 
packed with Glossaries and Terms available for you to use. Please be aware that it will 
take a few minutes to import the fully loaded csv file. 

You can download the supplied files under Evaluation Resources on the main page of 
the Team Server wiki 
(http://docwiki.embarcadero.com/TeamServer/ERStudio/2016/en/Main_Page). 

You can now start to explore and relate Terms to your ER Objects. 

http://docwiki.embarcadero.com/TeamServer/ERStudio/2016/en/Main_Page


ER/Studio Team Server Evaluation Guide 9 

Searching for terms – A usage example 
To search for a Term, on the top menu bar click on the Terms tab. 

1. In the Search Bar, type ‘Customer’. 

TIP: You will notice that as you type, the search function matches results while you are 
typing. This makes your time spent looking for items more efficient. 

2. From the search results, click on the item Customer with a Term Type of Sales. 

 The description of this Sales Glossary Term is “A person or organization that has expressed 
interest in a product by contacting our sales department.” However, in the Marketing 
department, this may be referred to as a ‘Prospect’. Clearly defined business terms made 
available in your organization can explain and simplify the use of the same terms in different 
departments. 

3. From the left Menu bar, click Related Terms, to see which other Terms might be useful to you, 
that you may not have directly searched for. 

 In this example you can see that ‘Prospect’ is a related term. Misunderstandings of similar 
terms in your organization can be overcome by relating terms, allowing your users to easily 
find and clarify business terms. 

 

Filtering search terms 
As you have found already, searching for Terms can be simple but powerful; giving your users the 
capability to collaborate effectively. 

Sometimes users across your organization can be confused with different abbreviations and searching on 
the Internet can often just confuse matters. Your organization’s Glossary, is the single, common source for 
truthful metadata for your organization. 
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If you would like to narrow your search, you can filter what is included in the search by changing the values 
in the Search In filters. 

1. Click on Terms  in the top navigation menu, in the search box, type ‘FOS’. 

2. In the ‘Search In’ tick boxes, clear all items except Aliases/Synonyms. 

 

 Only Factory Outlet Store is remaining from the search results. The Search In filters enable 
you to search not only queries the Term name, but also Aliases/Synonyms, Abbreviations, 
Definition, Notes (not by default) and Custom Attributes. 

Setting up for further evaluation 
Before viewing Model data in ER/Studio Team Server you will need to synchronize with the Repository 
data. Adding a Model to the Repository is done from ER/Studio. 

Open ER/Studio Data Architect. If you need assistance on installation please see: Installing ER/Studio Data 
Architect. 

 

http://docwiki.embarcadero.com/ERStudioDA/2016/en/Installing_Embarcadero_ER/Studio_Data_Architect
http://docwiki.embarcadero.com/ERStudioDA/2016/en/Installing_Embarcadero_ER/Studio_Data_Architect
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ER/Studio Data Architect configuration 
1. From your ER/Studio DA program window, Open the AOE.dm1 file which is found with the 

evaluation files under Evaluation Resources on the main page of the Team Server wiki 
(http://docwiki.embarcadero.com/TeamServer/ERStudio/2016/en/Main_Page). 

2. Click the Repository Login in the menu bar Repository > Log In. 

 

3. Log in using the name and password that you set during the Repository install. 

4. In the Data Model Window (the left pane) right click theAOE.dm1 Model icon and from the 
context menu, click Add Diagram. On the Add Diagram options window, click OK to add the 
diagram to the Repository. 

 

5. Right Click the AOE.DM1 model icon again. You will now see more options available. Click Check 
Out Diagram. At this point you can also choose to check out the model exclusively if you require. 
For this demo, you can accept the default setting. 

 You have now added a diagram and checked out a diagram from the Repository! 

This allows many users to collaborate on a model and check in their changes for others to 

see. The icons change from a ‘locked’ padlock , to an open padlock  to show which 
objects you have checked out. Your model should now have green ‘open padlock’ icons. 

http://docwiki.embarcadero.com/TeamServer/ERStudio/2016/en/Main_Page
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Setting up a sensitive data alert 

6. Click the Data Dictionary tab to change the Data Model window to a Data Dictionary window. 

 

Expand the following selection Data Dictionary > AOE_DD > Data Security Information > Data 
Security Classification and double-click Privacy Level. You will be asked to check out the item 
from the Repository, click Check Out to open the editor. 

7. In the Data Security Property Editor, change to the Binding Information tab and in the Object 
Class List, click on Attribute. In the Object list pane, expand AOE.DM1 > AOE PDM > CrtCrd. 
Select the tickbox for CrtCrd, which will include: CrdCrdID, CrdTyp, CrdNmb, ExpMonth, ExpYear, 
MdfDte. 

 

 
8. Double click CrdNmb and set the Value Override as ‘Regulated Customer Info’. 

9. Click OK to close the editor. 

10. Right click Data Dictionary > AOE_DD and click Check In Data Dictionary. 

11. Click OK to sync your changes. Then click Yes and OK in the following popup windows. 

NOTE:  You have now bound information to columns in ER/Studio Data Architect. 

12. Finally, right click the AOE.DM1 in the data model window and choose Check In Diagram. 
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ER/Studio Team Server configuration 
Now that you have synchronized your ER/Studio model to the Repository, we are going to publish the data 
model on Team Server to be able of view it and work it. 

1. Log in to Team Server using a web browser and browsing to the server address/port, and 
username and password that you chose during installation. 

2. Click the My Settings > Admin menu on the right of the top menu bar. 

 
3. In the administration page, you have access to ER/Studio Publication. 

NOTE:  To publish the model, you will need to have added it to the Repository from ER/ Studio 
DA, which is listed on page 9. 

4. Click the tickbox for the AOE.DM1 Project in the main window. 

 

5. From the Actions menu, click ‘Publish Selected’ to sync the Repository data to ER/ Studio Team 
Server. 

6. If this is the first time you have visited the web page, you may have popups blocked in your web 
browser. If this is the case, you will need to ‘Allow pop-ups’ for your server’s address by clicking on 
the alert bar. 

7. Once the publication process has completed, you will see the status as Published. If you would like 
to check on progress, please click refresh. 

You have now published the Repository data in Team Server and it is ready to work! 
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ER/Studio Team Server configuration – Adding an alert 

1. To set up an Alert, click on the ER Objects tab in the top Navigation menu. 

2. In the Search Box, type in ‘Privacy Level’. Click on the Security Object Privacy Level in the Object 
list. 

 
3. On the Privacy Level Security Object page, click on Alerts from the left menu. 

4. To create a new Alert, click the New Condition button. 

5. Fill out the New Condition Alert settings, Value, Regulated Customer Info, Warning and any 
additional text you require. 

 
6. Save the new Alert. 
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ER objects – Viewing alerts 
Searching for ER Objects is made simple in Team Server. 

1. From the top navigation menu, click ER Objects. 

2. In the search box, type ‘credit card’. You will see from the search result that the column CrdNmb is 
listed. 

 The name of the column does not correspond with your search, but because Team Server is 
searching all fields, it makes it easy to find Objects that are abbreviated or shortened. 

3. Open the ER Object CrdNmb and you can see the security alert that you set up earlier! 

 
4. If you have a DB Artisan Team Server license, the alert that you see here is also available when 

viewing the column in DB Artisan. 

Relating terms 
It is very easy to relate Objects to Glossary Terms. 

1. On the top navigation menu, Click on Terms. 

2. Type ‘CLV’ in search box. 

3. Click on Customer Lifetime Value term. 

4. Click Related ER Objects 

5. Click on Relate tab 

6. In the search box, type ‘datefirstpurchase’ and relate it to the Customer Lifetime Value term using 
the Relate button. 

Terms – Advanced use 

You have already imported terms, and seen how relating different terms can be useful. 

Let’s have a look at a more advanced term. 

NOTE:  The related objects used here were set up in a previous section, see Relating Terms. 

1. On the top navigation menu, Click Terms. 

2. Type ‘Customer Lifetime Value’ in to the search box. 

TIP: You can also type ‘CLV’ as the search will find the term through its abbreviation. 

3. Click the Term Customer Lifetime Value to open the Term. 
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In this example, you may have been asked to organize the data required for the CLV equation. 
Normally this information would be in disparate locations and finding and confirming that data 
may be a difficult process. 

With the Terms you have set up in previous sections, you can simply click ‘Related ER Objects’ and collect 
all of the data required for the equation. While having ‘Stewards’ listed for your Terms, you can easily find 
the organization’s expert for that particular data. 
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DB Team Server and DB PowerStudio 
product integration 
DB Team Server can be integrated with the following DB Power Studio products: 

• DBArtisan - aimed primarily at DBAs, DBArtisan provides a comprehensive DBMS toolbox. General 
feature categories include object management, a SQL editing, execution, and debugging 
environment, and a variety of monitoring and analysis tools. 

• Rapid SQL - aimed at developers, Rapid SQL also features object management and a SQL editing, 
execution, and debugging environment. A collection of coding aids is also provided. 

The following section is a read through only. To demo these features you will need a working data source 
and a DB Artisan installation. If you need an introduction to the features and benefits of these products, 
see DB Artisan product page and Rapid SQL product page for details. 

Enabling and configuring DB Team Server usage 
If you are familiar with either product, then you know that the Options Editor (File > Options) is where you 
set up DBArtisan/Rapid SQL features. A Team Server panel lets you enable DB Team Server usage and 
provide the URL required to connect. Once configured, a Tools > Login command lets you sign in to your 
DB Team Server instance. 

 

https://www.idera.com/dbartisan-database-administration-solution
https://www.idera.com/rapid-sql-ide
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Using Team Server as the data source catalog 
DBArtisan and Rapid SQL, also provides the option of registering data sources from the Team Server 
Repository. To allow that, there are two options. In Quick Start Setup, select Use Team Server as the data 
source catalog. 

 
You can also go to Tool>Options>Datasources and select Team Server based datasource catalog. 
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For organizations with multiple copies of Rapid SQL or DBArtisan, when a datasource definition must be 
changed due to an operational change, the change can be made in one location and automatically 
propagated to all Rapid SQL/DBArtisan instances. When registering a datasource to DBArtisan or Rapid 
SQL, a single control attaches the locally registered datasource to the Team Server version. 

 
Once initially registered, an attached, local datasource definition is resynchronized with the Team Server 
version each time you connect to that datasource. 

Other datasource management features 
A Rapid SQL or DBArtisan user has access to a feature (Datasource > Reconcile Data Sources) that lets you 
manage multiple Team Server and local datasource definitions simultaneously. 
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A full set of options is provided for managing the relationship between Team Server datasource definitions 
and those registered locally. 

Advanced datasource search 
In addition to simple browsing of datasources available on a DB Team Server instance, a Datasource > 
Team Server Data Source Search command issued from DBArtisan or Rapid SQL opens a dialog that lets 
you perform an advanced search of datasources. 

 
You can search by name or by one or more ANDed criteria. Specific conditions include items such as 
database type and version as well as operational characteristics like performance and storage details. The 
advanced search mechanism attempts to anticipate the differing needs across an enterprise. For example: 

• IT personnel might be interested in all datasources with free space issues. 

• A developer might be looking for all datasources of a specific DBMS type and version. 

• A quality assurance engineer might be looking for a specifically-configured datasource in order to 
duplicate a customer issue. 

Using model data in the SQL editor 
Rapid SQL and DBArtisan both have powerful SQL Editor environments that let you develop, debug, and 
execute SQL scripts. Key features include automated coding assistance and error detection options. When 
you open a SQL Editor (File > New > ISQL in DBArtisan or File > New SQL in Rapid SQL) against a 
datasource attached to a DB Team Server definition, editor features can make use of associated model 
data. 

For example, if a line of code references an object with associated meta data, a warning icon is displayed 
in the gutter, beside the page number. On execution, details from the model data for that object 
definition are displayed in the Error pane. 
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Similarly, when hovering the mouse over a column name, table name or view name, a tooltip showing the 
entity/attribute description is displayed. 

 
Subsequently clicking in the tooltip opens a browser window on DB Team Server, with the associated 
ER/Studio model data definition for that object. 

While those features provide immediate access to model data from DB Team Server, you can also have 
entity/attribute information automatically written to a script. The Format feature, primarily aimed at 
beautifying code, is initiated using the Format button. 

 
When invoked, a comment with element/attribute details is written to each line referencing an element 
with associated model data. 

 
A developer subsequently opening script, a function or procedure for example, can quickly see that it 
references data that may be regulated. 
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Other DB Team Server functionality 
Miscellaneous DB Team Server functionality in Rapid SQL and DBArtisan includes: 

• Users can monitor their own activity stream or the activity stream for a datasource definition. Similarly, 
users can open a window to monitor their notifications. 

• Rapid SQL and DBArtisan let you open a browser window on the connected DB Team Server for direct 
access to Team Server features. 
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ER/Studio Team Server – More features 

People 
Collaborating is made easy with Team Server. On the top navigation menu through the People menu item, 
you have access to follow, discuss and collaborate with your social connections. 

Glossary tooltips 
To enable the Glossary Tool Tip feature: 

1. Ensure you are running your Team Server window in Mozilla Firefox. 

2. On the top navigation menu, click Glossaries and then click Glossary Tool Tip. 

3. Install Greasemonkey add-on using the Add to Firefox link provided. 

4. You may also receive a warning before installing similar to the following pop up message. Click 
‘Install Now’ to proceed with the add-on installation. 

 
5. When the install has finished, click Add Glossary Tool Tip. 

6. Click OK to install. NOTE: You may be required to restart your browser. 

7. Click My Settings > Admin. 

8. From the left navigation bar, click Glossary Tool Tip. 

9. In the top right of the page, click New Association. 

10. Fill out the fields of the New Association pop-up window, clicking Add to save each field before 
adding another. 

URL Patterns - The URL list of the web sites/pages that you would like to associate with your 
Glossary. Type in this field http://en.wikipedia.org/**. 

Glossaries - A list of one or more Glossaries that you would like to associate with the web sites in 
the URL Patterns field. Type ‘Sales’ then click Add. 

Definitions - You can add a definition of your association between the URL and Glossary. 

http://en.wikipedia.org/
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11. Click Save. 

12. Go to http://en.wikipedia.org/wiki/Customert to watch the magic! 

On the page that opens, you can see how the fields are highlighted, and when you hover your mouse over 
the highlighted ‘customer’ words, a definition is given from your Sales glossary. 

 

Conclusion 

Thank you for completing the tutorials. It should have given you a good start to continue working with your 
diagrams in a collaborative environment. You should now know how to import and relate Glossaries and 
Terms, create Data Sources and Object alerts, and set up Glossary Tool Tips to enable user collaboration 
and simplify data compliance in your organization. 

Additional evaluation resources 
IDERA, Inc. provides a variety of resources to help support your evaluation and selection of a Data 
Modeling product for your organization. 

Web site Visit our Web site for current product and company information, educational materials, and 
supporting information. Visit https://www.idera.com. 

Support Please log a case through the website at https://www.embarcadero.com/support 
 

Telephone Support 

We encourage you to call us anytime you would like help or have questions during your evaluation, we 
value your feedback. Open a case online at: https://www.embarcadero.com/support 

North America and Latin America (Hours: Monday to Friday, 7:00am to 5:00pm Pacific time) 

United States/Canada: 800-523-7070 

Brazil: +55-11-3741-5555 

All Other Americas: 800-523-7070 

Europe, Africa and the Middle East (Hours: Monday to Friday, 9:00am to 5:30pm UK time English Only) 

France 0805 101 052 

Germany 0800 664 7528 

UK & Ireland 0800 007 5465 

Netherlands 0800 020 0098 

All Other EMEA +1 831 431 5320 

Asia Pacific: 

Japan +81 3 4577 4520 

All other APAC +1 831-431-5100 

http://en.wikipedia.org/wiki/Customert
https://www.idera.com/
https://www.embarcadero.com/support
https://www.embarcadero.com/support
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