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Introduction

IDERA ER/Studio Team Server is a model and metadata collaboration platform that provides greater
meaning, understanding and context to enterprise data. Database professionals, developers, and business
analysts gain better comprehension and compliance using integrated model, metadata & collaboration
tools. Team Server's collaborative enterprise glossary brings together the entire organization to foster
improved metadata, business definitions, governance, compliance, and security policies. Online models
showcase data relationships, while powerful search capabilities help users locate enterprise data with ease.
Integration with IDERA’s database management tools, including Performance 1Q licenses for Team Server,
extends the reach of enterprise metadata with interactive “on-the-fly” tool-tips containing glossary
definitions, policy information and associated metadata in the client tools.

Product benefits by audience

Data Consumers

Integrate effective data comprehension capabilities in to
daily workflows, delivering context and meaning to every
user.

Enable collaboration around data among teams across
business units or business functions.

Support corporate compliance initiatives by driving
responsible use of sensitive or private data

Data Modeling Professionals

Integrate the glossary's business definitions with internal
web assets to provide on-the-fly business context with
tool-tips and pop-ups.

Create a single registry of all available data sources.

Adhere to industry regulations and business standards
regarding security and privacy, by alerting users who
view or modify sensitive data within the tools.

Data Management Professionals &
Developers

Develop applications faster by using business terms to
easily locate data elements.

Monitor access to and use of business glossaries and
associated functions, to understand immediate data
management requirements.

View in-line metadata in DBArtisan & Rapid SQL.

Monitoring capability with Performance 1Q Team Server.
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About this guide

This guide is intended to help you get started using IDERA Team Server as part of the ER/Studio product
family.

The design of the guide is to enable you to, read through and see the exciting features
that Team Server delivers, or if you have a demo environment set up, you can follow our
evaluation step-by-step sections. These sections are highlighted with the ‘'mouse’ icon
and allow you to get first-hand experience at the exciting new features.

Should you wish to experience some of the more advanced features in the evaluation,
you will be required to configure your installation so that these features can be
demonstrated. These sections are highlighted with the ‘configuration/tools” icon.

The reading sections enable you to walk you through some more complicated features
and give an overview for you to read through only. These are highlighted by the
‘reading’ icon.

To complete this guide fully, you will need to have latest versions of DBArtisan or Rapid SQL and Team
Server installed. For more information, an up-to-date installation guide is available online. Please see
https://www.idera.com/support/productdocuments for details.

You will need additional files for this evaluation, they can be found under Evaluation Resources on the
main page of the Team Server wiki
(http://docwiki.embarcadero.com/TeamServer/ERStudio/183/en/Main_Page).

The tutorials are divided into 14 sessions in three parts, do them all at once or complete them individually
as your time permits. You can use this basic tutorial as a road map of some product highlights, but also to
help you find your own path in exploring Team Server.

Part 1 - The basics
e  Getting Started with IDERA Team Server

e ER/Studio Team Server - glossaries and terms

e Create a new glossary

e Import glossaries and terms

e Searching for terms - A usage example

e Filtering search terms

Part 2 - Set up, Alerts and DB Team Server

e Setting up for further evaluation

e ER/Studio Data Architect configuration

e ER/Studio Team Server configuration

e ER objects - Viewing alerts

e DB Team Server and DB PowerStudio product integration

Part 3 - Advanced features

e ER/Studio Team Server - More features

e People

e Glossary tooltips
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Getting started with IDERA Team Server

When you first log in to Team Server, you are presented with the Welcome page.
NOTE: The default login being Username =Admin > Password =Admin.

The graphic below names and describes the functionality of some key elements of the Team Server user
interface.

Home page displays

the social interface, ltems that you have followed

showing recent activity are listed here to give you
and team easy one-click access. As are

communication. users who have followed you.

Followers
ﬁ At Hom \Write a comment...
™ lauram
Stream 0 :
Search
Description

next page > |1D . itermns per page Following

%2 Communi
N : h
admin is following glossary Home === Glossary

0 Documentation
wt 27, 2015 21956 PM  [JRESRE) Share Delete

%)

previous page 1

(} lauram
Peaple
testuser created glossary Home E testuser
% People
E Jul 27, 2015 2:12:24 PM m Share Delete

q lauram posted to person lauram
e I have imported a lot of terms this week. Feel free to check.

ul 27, 2015 1:33:09 Ph m Share Delete

admin created glossary Test
Jut17, 2015 2:00:37 P (ISR Share Delete
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ER/Studio Team Server glossaries and terms

Now that you have logged in, you can start to explore the rich features of Team Server.

Your Home Page includes Streams to keep you informed of any modifications or activity with, for example,
ER Objects, Glossaries or Terms that you have an interest in. These are especially useful to keep in touch
with any discussions.

The top navigation menu allows you to navigate through the features available. The left menu bar gives
further features related to the current top menu item.

Create a new glossary

1. To create a new Glossary, on the top menu bar click on the Glossaries tab.

{7’7" ’ 2. On the top right of the window, click the New Glossary button to open the New Glossary
dialog.
Enter the Name, ‘My Glossary’ and a Definition of your choosing.
4. Click Save to create your new Glossary.
That's it!

Creating Terms in your new Glossary is just as easy. However, if you would like to create many Glossaries
and Terms quickly and easily, we have an import function that can create Glossaries and Terms simply.

Import glossaries and terms

1. Toimport a .csv file, on the top menu bar click on the Glossaries tab.
2. On the top right of the window, click the Load Glossaries button.

3. Browse and locate the glossaries_demo.csvfile that is supplied for this example and click
the Load button.

NOTE:  You are welcome to choose the glossaries_full.csv file, which is a much larger
file, packed with Glossaries and Terms available for you to use. Please be aware
that it will take a few minutes to import the fully loaded csv file.

You can download the supplied files under Evaluation Resources on the main
page of the Team Server wiki
(http://docwiki.embarcadero.com/TeamServer/ERStudio/183/en/Main_Page).

You can now start to explore and relate Terms to your ER Objects.
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Searching for terms — A usage example

To search for a Term, on the top menu bar click on the Terms tab.
1. Inthe Search Bar, type ‘Customer’.

TIP:  You will notice that as you type, the search function matches results while you are typing.
This makes your time spent looking for items more efficient.

2. From the search results, click on the item Customer with a Term Type of Sales.

“W The description of this Sales Glossary Term is “A person or organization that has expressed
interest in a product by contacting our sales department.” However, in the Marketing
department, this may be referred to as a ‘Prospect’. Clearly defined business terms made
available in your organization can explain and simplify the use of the same terms in different
departments.

3. From the left Menu bar, click Related Terms, to see which other Terms might be useful to you,
that you may not have directly searched for.

~% In this example you can see that ‘Prospect’ is a related term. Misunderstandings of similar
terms in your organization can be overcome by relating terms, allowing your users to easily
find and clarify business terms.

stream Customer
Description Sales
Discussions
Followers
I! Related Glossaries View Relate
E Related Terms
Related ER Objects Customer
Marketing
A persen or organization who has made a preduct purchase.

Prospect
Sales

A person or organization that has expressed interest in a product by contacting our sales department.

Filtering search terms

As you have found already, searching for Terms can be simple but powerful; giving your users the
capability to collaborate effectively.

Sometimes users across your organization can be confused with different abbreviations and searching on
the Internet can often just confuse matters. Your organization’s Glossary, is the single, common source for
truthful metadata for your organization.
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If you would like to narrow your search, you can filter what is included in the search by changing the values

in the Search In filters.
1. Click on Terms in the top navigation menu, in the search box, type ‘FOS’.

2. Inthe ‘Search In" tick boxes, clear all items except Aliases/Synonyms.

Home  Glossaries Terms

All Terms
My Terms

Search In:

Aliases/Synonyms

Abbreviations

! ustom Attributes

Only Factory Outlet Store is remaining from the search results. The Search In filters enable
you to search not only queries the Term name, but also Aliases/Synonyms, Abbreviations,

Definition, Notes (not by default) and Custom Attributes.

-

Setting up for further evaluation

Before viewing Model data in ER/Studio Team Server you will need to synchronize with the Repository
data. Adding a Model to the Repository is done from ER/Studio.

Open ER/Studio Data Architect. If you need assistance on installation please see: Installing ER/Studio Data
Architect.
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ER/Studio Data Architect configuration

1. From your ER/Studio DA program window, Open the AOE.dm1 file which is found with the
evaluation files under Evaluation Resources on the main page of the Team Server wiki
(http://docwiki.embarcadero.com/TeamServer/ERStudio/183/en/Main_Page).

2. Click the Repository Login in the menu bar Repository > Log In.

Tools | Repositery | Help
Project Center
Diagrams i
Data Dictionary 3
Releases 3
Administration 3
Security 4

-'_| Log In... N

Log Out

Log in using the name and password that you set during the Repository install.

4. In the Data Model Window (the left pane) right click theAOE.dm 7 Model icon and from
the context menu, click Add Diagram. On the Add Diagram options window, click OK to
add the diagram to the Repository.

R * J
q AOE.DML - Physical Model View: AOE DW(CLV) /_;

| ADE D1
Lnglcal Get Latest Diagram

3 Mai Check Qut Diagram

= Check In Diagram 4

E
] F
" ke

e

..‘_.j Add Diagram

5. Right Click the AOE.DM1 model icon again. You will now see more options available. Click
Check Out Diagram. At this point you can also choose to check out the model exclusively
if you require. For this demo, you can accept the default setting.

“ You have now added a diagram and checked out a diagram from the Repository!

This allows many users to collaborate on a model and check /n their changes for others to

see. The icons change from a 'locked’ padlock , to an open padlock f'i to show which
objects you have checked out. Your model should now have green ‘open padlock’ icons.
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Setting up a sensitive data alert

SR A e

Click the Data Dictionary tab to change the Data Model window to a Data Dictionary
window.

\‘5 Data Model Data Dictiona Hi# C'ata Lineage Macro
il ry ge | &

Iy
For Help, press F1

Expand the following selection Data Dictionary > AOE_DD > Data Security Information
> Data Security Classification and double-click Privacy Level. You will be asked to check
out the item from the Repository, click Check Out to open the editor.

In the Data Security Property Editor, change to the Binding Information tab and in the
Object Class List, click on Attribute. In the Object list pane, expand AOE.DM1 > AOE
PDM > CrtCrd. Select the tickbox for CrtCrd, which will include: CrdCrdID, CrdTyp,
CrdNmb, ExpMonth, ExpYear, MdfDte.

f} Data Secunty Property Editor

Name l Value Binding Information l

Object Class List Object List
2|Aﬂribma || & moE DM
| Entity B2 Logical
Mode! ® {7y AOEDW
@5 Submodsl Bl ADE PDM
& View O g A
O BT AdrTyp
[ B AWBuidvm
O E BIoMs
[ B Cet
O E CetliCrd
[ B CctTyp
O EgCw
O B CmrAdr
= :
W
W
W
W
W
3 L4y MdfDte
0 @By

Double click CrdNmb and set the Value Override as ‘Regulated Customer Info'.

Click OK to close the editor.

Right click Data Dictionary > AOE_DD and click Check In Data Dictionary.

Click OK to sync your changes. Then click Yes and OK in the following popup windows.
NOTE: You have now bound information to columns in ER/Studio Data Architect.

Finally, right click the AOE.DM1 in the data model window and choose Check In
Diagram.
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ER/Studio Team Server configuration

Now that you have synchronized your ER/Studio model to the Repository, we are going to publish the data
model on Team Server to be able of view it and work it.

1. Login to Team Server using a web browser and browsing to the server address/port, and
username and password that you chose during installation.

2. Click the My Settings > Admin menu on the right of the top menu bar.

My Settings * | Log Out

Help
Preferences

Admin h

Activity

3. Inthe administration page, you have access to ER/Studio Publication.

NOTE:  To publish the model, you will need to have added it to the Repository from ER/
Studio DA.

4.  Click the checkbox for the AOE.DM1 Project in the main window.

Repository Management | FR /Studio Publications
Licenses Use this page to manage publications and to recover from errors during check-in process.

Solution Permissions Actions

efresh | Publish Selected | Download Log File
ER/Studio Publications
Scheduled  Status Date

Selection Action Status
Subscriptions
O & Projects
Managed Attributes
. = ) 11/05/2015
P @Agﬂdml Publish[™] @ Not Published 0 =
Object Alerts W

5. From the Actions menu, click ‘Publish Selected’ to sync the Repository data to ER/ Studio
Team Server.

6. If this is the first time you have visited the web page, you may have popups blocked in
your web browser. If this is the case, you will need to ‘Allow pop-ups’ for your server's
address by clicking on the alert bar.

7. Once the publication process has completed, you will see the status as Published. If you
would like to check on progress, please click refresh.

You have now published the Repository data in Team Server and it is ready to work!
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ER/Studio Team Server configuration — Adding an alert

1. Tosetup an Alert, click on the ER Objects tab in the top Navigation menu.

2. Inthe Search Box, type in 'Privacy Leve!. Click on the Security Object Privacy Level in the
Object list.

Privacy Level
@ AOE.DM1 > AOQE_DD » Data Security Classification

ER Object > Security
This privacy level property specified the level of privacy for a given piece of information in...

3. On the Privacy Level Security Object page, click on Alerts from the left menu.
4. To create a new Alert, click the New Condition button.

5. Fill out the New Condition Alert settings, Value, Regulated Customer Info, Warning and
any additional text you require.

New Condition Alert ®

Show Alert for Matching
2 Bound Object

® value

Matching Value

Regulated Customer Inﬁ::E
Alert Level

@ Warning

D Info
MNotification Text

Regulated Customer Information!
Mot to be replicated without proper

approval.
Csove [ conca

6. Save the new Alert.

ER/Studio Team Server Evaluation Guide 13



ER objects — Viewing alerts

Searching for ER Objects is made simple in Team Server.
1. From the top navigation menu, click ER Objects.

2. Inthe search box, type ‘credit card’. You will see from the search result that the column
CrdNmb is listed.

“ The name of the column does not correspond with your search, but because Team
Server is searching all fields, it makes it easy to find Objects that are abbreviated or
shortened.

3. Open the ER Object CrdNmb and you can see the security alert that you set up earlier!

CrdNmb

Column
AOE DML > AQE PDM > CrtCrd > CrdMmb
Mot linked to any term [Create Linked Term]

Regulated Customer Information! Mot to be replicated without proper approval.

4. If you have a DB Artisan Team Server license, the alert that you see here is also available
when viewing the column in DB Artisan.

Relating terms

It is very easy to relate Objects to Glossary Terms.

1. On the top navigation menu, click on Terms. E Customer Lifetime Value

Business Terms

Click on Relate tab

2. Type 'CLV'in search box. Dot

3. Click on Customer Lifetime Value term.

4. Click Related ER Objects view | Foundmn | Relate |
5. B
6.

In the search box, type 'datefirstpurchase’ and relate it to the Customer Lifetime Value
term using the Relate button.

Terms — Advanced use

You have already imported terms, and seen how relating different terms can be useful.

Let's have a look at a more advanced term.

NOTE: The related objects used here were set up in a previous section, see Relating Terms.
1. On the top navigation menu, click Terms.

2. Type 'Customer Lifetime Value' in to the search box.

TIP: You can also type ‘CLV' as the search will find the term through its abbreviation.

3. Click the Term Customer Lifetime Value to open the Term.
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- Customer Lifetime Value
| Description Business Terms
==

Followers Created by admin on Apr 25, 201 ;m

B Related Glossaries Namne

Customer Lifetime Value
B Related Terms Term Entity Type
ﬂ Related ER Objects Business Terms
L

n ri r
CLV = GC- - — M. —_—
; (1 +d}| Z (] +d‘}1—{].5

i—1

A0 Inthis example, you may have been asked to organize the data required for the CLV equation.
Normally this information would be in disparate locations and finding and confirming that data

may be a difficult process.

With the Terms you have set up in previous sections, you can simply click ‘Related ER Objects’ and collect
all of the data required for the equation. While having ‘Stewards' listed for your Terms, you can easily find
the organization’s expert for that particular data.
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DB Team Server and DB PowerStudio
product integration

DB Team Server can be integrated with the following DB Power Studio products:

e DBArtisan - aimed primarily at DBAs, DBArtisan provides a comprehensive DBMS toolbox. General
feature categories include object management, a SQL editing, execution, and debugging
environment, and a variety of monitoring and analysis tools.

¢ Rapid SQL - aimed at developers, Rapid SQL also features object management and a SQL editing,
execution, and debugging environment. A collection of coding aids is also provided.

The following section is a read through only. To demo these features you will need a working data source
and a DB Artisan installation. If you need an introduction to the features and benefits of these products,

see DB Artisan product page and Rapid SQL product page for details.

Enabling and configuring DB Team Server usage

If you are familiar with either product, then you know that the Options Editor (File >
Options) is where you set up DBArtisan/Rapid SQL features. A Team Server panel lets
you enable DB Team Server usage and provide the URL required to connect. Once
configured, a Tools > Login command lets you sign in to your DB Team Server instance.

== T y
1 Options | R |
Type filtter text [ Team Server l
- Datasource
- General [/] Use Team Server
(- Connection
e Team Server URL: | hitp://ROMLABERCOMNO1:81
- LDAP Confi ti
1 B g “Mate: to be able to modify the Team Server URL, please make sure you are not logged in
- Logging and no restrictions are imposed by the Administrator.
- Mail - -
- Perf Center Team Server - Log In | 2|
- Team Senver
Team Server URL: http:/fROMLABER.COMO1:81
. User: MyAccount ="
Password: T
[] Keep me signed in

16
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Using Team Server as the data source catalog

DBArtisan and Rapid SQL, also provides the option of registering data sources from the
Team Server Repository. To allow that, there are two options. In Quick Start Setup, select
Use Team Server as the data source catalog.

Quick Start Setup

** DBArtisan Quick Start Setup

Before you begin using this application you should register at least one
data source

() Manually set up an initial data source

() Automatically discover and register data sources

se Team Server as the data source catalog;

() Import data sources

() Setup data sources at a later time

T T

You can also go to Tool>Options>Datasources and select Team Server based datasource catalog.

E - - - e ! 3
Options M
|Type filter text | Datasource

- Datasource
[+~ General Datasource Storage Management
- Connection .

T S _»Windows Registry datasource catalog

Rt ok Legacy datasource storage that is compatible with previous versions of Embarcadero
- Explorer products.
- 15QL (1 File based datasource catalog
- Debug Datazources are stored in the cument user's application data folder.
() DDL Bxtract () Metwork shared datasource catalog
- Results Datasources are located in @ commen resource that is shareable between multiple users.
[ Data Transfer Datz!soun:g c:l'!anges are not propagated to other users and are not retained between instances

Miaration Ogti of this application.
. Migration ions
2 . E Location of shared managed datasources file:

. Data Editor

piiuesy Bililder -
- Space Analyst ] erver based d roe catalog!

E Diatasources are located on Team Server and are shareable between multiple users. Datazource
- DB Monitor
changes are propagated to Team Server.

Recent Datasource List Contains: 8 Datasounces (1-32)
[+ Resort the Datasource Combo based on Connection state
[ Default to Alias Usage When Defining New Datasources
Datasource Category Settings
[+] Color the status bar using the datasource’s category color
[v] Color the tabs using the datasource’s category color

[+ Include categony short name in the datasource toolbar combo

| ok || Camcel || Hp |
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For organizations with multiple copies of Rapid

SQL or DBArtisan, when a datasource definition must be

changed due to an operational change, the change can be made in one location and automatically
propagated to all Rapid SQL/DBArtisan instances. When registering a datasource to DBArtisan or Rapid
SQL, a single control attaches the locally registered datasource to the Team Server version.

Database Type

Available database types:

Connection Information

Security Parameters El!-”BM he

Custom Driver Properties %IWSQL
Datasource Properties ﬁjOmcle

Datasource Group Elim Sybase Adaptive Server

i Sybase 13

s Generic ODBC
El Generic JOBC

Efim Microsoft SGL Server

Efs Windows Azure SQL Database
%T&mda’fa (Technical Preview)

Related Team Server Data Source:

)
10

11}

@E@ROMLABSAL1Z2_2_Conn @
ROMLABARTSQL12
ROMLAESGLOE 3

ROMLABSGL1Z 1

Once initially registered, an attached, local datasource definition is resynchronized with the Team Server

version each time you connect to that datasour

ce.

Other datasource management features

A Rapid SQL or DBArtisan user has access to a feature (Datasource > Reconcile Data

“&j‘ Sources) that lets you manage
simultaneously.

multiple Team Server and local datasource definitions

Reconcile Team Server Data Sources (Admin)

Matching data sources (Select Team Server and local data sources to link)

[ Team Server Name Local Name Type Server/Instance Mam f>
D ROMLABSYBIQ152_1 ROMLABSYBIQ152_1 Sybase IQ  ROMLABSYBIQ152_1

[ ROMLABSQLOS_3 romlabsglos_3 M3 S0L romlabsgl0a_3 £
[l @@ROMLABSQL12 2 C... ROMLABSQL1Z 2 Conn M3 SQL ROMLABSQL12_2

D ROMLABSOLO2 jdbc ROMLABSOLO2 Sybase I  ROMLABSOLOZ2

[ rOMIARSON 12 4 ROM ARSOI 12 1 M5 501 ROMI ARSOI 12 1 =

Unmatched Team Server data sources [Select Team Server data sources to import and link)

[[] Team Server Name

[] ROMLABARTSY 157 _jdbc
[] $ROMLABSY157_1_Conn_02

[ sybase IQ Demo
71 nRCTEST

Type
Sybaze |
Sybase — N

QDBC |
NRC

| »

m

Unmatched local data sources (Select local data sources to export to Team Server and link)

[[] Data Source Name

[] saMDE 10
[C] SAMPLE
[ sadad

Type
DBE2 =

DB2
NRC

Reconcile Cancel

&

18
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A full set of options is provided for managing the relationship between Team Server datasource definitions
and those registered locally.

Advanced datasource search

™) In addition to simple browsing of datasources available on a DB Team Server instance, a
& Datasource > Team Server Data Source Search command issued from DBArtisan or

Rapid SQL opens a dialog that lets you perform an advanced search of datasources.

Team Server Data Source Search | X ]
Search:
ROM [A]] search Save |w

[ MName - ][ s v] ROM -
[ Data source type - ][ |= - l E]

MName Type Wersion £
- ROMLABSOLDZ jdbe Sybase 10 [
- ROMLABSQLOS_3 MS SGL :
- ROMLABSGLIZ_1 MS SGL -
Close
R —— — =]

You can search by name or by one or more AND criteria. Specific conditions include items such as
database type and version as well as operational characteristics like performance and storage details. The
advanced search mechanism attempts to anticipate the differing needs across an enterprise. For example:

e |T personnel might be interested in all datasources with free space issues.
e A developer might be looking for all datasources of a specific DBMS type and version.

e A quality assurance engineer might be looking for a specifically-configured datasource in order to
duplicate a customer issue.

Using model data in the SQL editor

] Rapid SQL and DBArtisan both have powerful SQL Editor environments that let you
II & | develop, debug, and execute SQL scripts. Key features include automated coding
assistance and error detection options. When you open a SQL Editor (File > New > ISQL
in DBArtisan or File > New SQL in Rapid SQL) against a datasource attached to a DB
Team Server definition, editor features can make use of associated model data.

For example, if a line of code references an object with associated meta data, a warning icon is displayed
in the gutter, beside the page number. On execution, details from the model data for that object
definition are displayed in the Error pane.
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1 select #

2 &  from gim.dbo.BROKER t1

3 where t1.BROKER_FIRST_NAMES is not nul
4 and t1.BROKER_LAST_NAME is null'

D
Error x
Batch | line | Column | Error type | Error Message

2 b Metadata Information BROKER {Broker) Data Steward : Larry

4 28 @ Syntax Encountered unexpected token “nulll™

Similarly, when hovering the mouse over a column name, table name or view name, a tooltip showing the
entity/attribute description is displayed.

1 select *
2 from gim.dbo.BROKER. t1
3 where t1.BROKER FIRST NAME is not null and t1.BROKER LAST MNAME is null

&l Metadata Information: BROKER (Broker) Data Steward: Larry
5

Subsequently clicking in the tooltip opens a browser window on DB Team Server, with the associated
ER/Studio model data definition for that object.

While those features provide immediate access to model data from DB Team Server, you can also have
entity/attribute information automatically written to a script. The Format feature, primarily aimed at
beautifying code, is initiated using the Format button.

When invoked, a comment with element/attribute details is written to each line referencing an element
with associated model data.

2 | select t1.coll "Agent_First_Name"

2 , t1.col2 "Agent_Middle_Initial"

3 , t1.col3 "Agent_Last_Name"

4 , tl.col9 "Agent_Years_With_Firm"

5 from GIM.dbo.FINTAB_44 /* Entity: Finance_Agent_Table *_f|

A developer subsequently opening script, a function or procedure for example, can quickly see that it
references data that may be regulated.

20 ER/Studio Team Server Evaluation Guide



Other DB Team Server functionality

Miscellaneous DB Team Server functionality in Rapid SQL and DBArtisan includes:

e Users can monitor their own activity stream or the activity stream for a datasource definition. Similarly,
users can open a window to monitor their notifications.

e Rapid SQL and DBArtisan let you open a browser window on the connected DB Team Server for direct
access to Team Server features.
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ER/Studio Team Server — More features

People

Collaborating is made easy with Team Server. On the top navigation menu through the
People menu item, you have access to follow, discuss and collaborate with your social
connections.

Glossary tooltips

To enable the Glossary Tool Tip feature:

1.
/7

2
3.
4

0 © N o v

10.

22

Ensure you are running your Team Server window in Mozilla Firefox.
On the top navigation menu, click Glossaries and then click Glossary Tool Tip.
Install Greasemonkey add-on using the Add to Firefox link provided.

You may also receive a warning before installing similar to the following pop up message.
Click ‘Install Now' to proceed with the add-on installation.

Software Installation l =5

Install add-ons only from authors whom you trust.

.
Malicious software can damage your computer or violate your privacy.

You have asked to install the following item:

q . Greasemonkey (Author not verifie)
g https://addons.mozilla.org/firefox/downloads/latest/748/addon-748- latest.xpifsre=d|

When the install has finished, click Add Glossary Tool Tip.

Click OK to install. NOTE: You may be required to restart your browser.
Click My Settings > Admin.

From the left navigation bar, click Glossary Tool Tip.

In the top right of the page, click New Association.

Fill out the fields of the New Association pop-up window, clicking Add to save each field
before adding another.

URL Patterns - The URL list of the web sites/pages that you would like to associate with
your Glossary. Type in this field http://en.wikipedia.org/**.

Glossaries - A list of one or more Glossaries that you would like to associate with the web
sites in the URL Patterns field. Type ‘Sales’ then click Add.

Definitions - You can add a definition of your association between the URL and Glossary.
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11. Click Save.

12. Go to http://en.wikipedia.org/wiki/Customert to watch the magic!

On the page that opens, you can see how the fields are highlighted, and when you hover your mouse over
the highlighted ‘customer’ words, a definition is given from your Sales glossary.

Customer

. . A person or organization that has expressed interest
From WIF%I;:ldIE_ the 1 in a product by contacting our sales department.
View in Team Server &

"Glientele™ redirects here. For the British rock band, see The Glientele.

Conclusion

Thank you for completing the tutorials. It should have given you a good start to continue working with your
diagrams in a collaborative environment. You should now know how to import and relate Glossaries and
Terms, create Data Sources and Object alerts, and set up Glossary Tool Tips to enable user collaboration
and simplify data compliance in your organization.

Additional evaluation resources

IDERA, Inc. provides a variety of resources to help support your evaluation and selection of a Data
Modeling product for your organization.

Web site Visit our Web site for current product and company information, educational materials, and
supporting information. Visit https://www.idera.com.
Support Please log a case through the website at https://www.embarcadero.com/support

Telephone Support

We encourage you to call us anytime you would like help or have questions during your evaluation, we
value your feedback. Open a case online at: https://www.embarcadero.com/support

North America and Latin America (Hours: Monday to Friday, 7:00am to 5:00pm Pacific time)
United States/Canada: 800-523-7070
Brazil: +55-11-3741-5555
All Other Americas: 800-523-7070
Europe, Africa and the Middle East (Hours: Monday to Friday, 9:00am to 5:30pm UK time English Only)
France 0805 101 052
Germany 0800 664 7528
UK & Ireland 0800 007 5465
Netherlands 0800 020 0098
All Other EMEA +1 831 431 5320
Asia Pacific:
Japan +81 3 4577 4520
All other APAC +1 831-431-5100
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