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Introduction 

This guide provides an overview of the CodeGear™ RAD Studio 2009 development 

environment to get you started using the product right away. It also tells you where to 

look for details about the tools and features available in RAD Studio. 

Chapter 2, “Tour of the IDE” describes the main tools on the CodeGear™ RAD Studio 

2009 desktop, or integrated development environment (IDE). Chapter 3, “Starting Your 

First Visual Application” explains how to use some of these tools to create an applica-

tion.  Chapter 4, “More Advanced Topics” describes the more advanced features in 

RAD Studio, like VCL, RTL, or the included third party add-ins. Chapter 5, “EDN and 

Partners”, displays a list of code-related articles on various products and the partners 

of Embarcadero. 

For various examples on using CodeGear™ RAD Studio 2009 to write programs such 

as a text editor or database application, see the Demos directory of your CodeGear™ 

RAD Studio 2009 installation, also accessible from the Start menu folder. Other online 

resources are available at the following address: www.embarcadero.com. 

What is RAD Studio?What is RAD Studio?What is RAD Studio?What is RAD Studio? 
RAD Studio is an object-oriented, visual programming environment for rapid applica-

tion development (RAD). Using CodeGear™ RAD Studio 2009, you can create highly 

efficient  visual applications with a minimum of manual coding, using either the Delphi, 

C++, or Delphi Prism programming languages. To learn about using Prism to cre-

ate .NET applications, see the Prism Primer at prismwiki.codegear.com. 

CodeGear™ RAD Studio 2009 provides all the tools you need to model applications, 

design user interfaces, automatically generate and edit code, and also the tools 

needed to compile, debug, and deploy applications. The tools available in the IDE de-

pend on the version of RAD Studio you are using.  
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Finding informationFinding informationFinding informationFinding information 

You can find information about CodeGear™ RAD Studio 2009 in the following ways: 

• Web-based product documentation 

• F1F1F1F1    help and online help system 

For information... For information... For information... For information...     

about new features in this release, refer to the www.embarcadero.com web site. 

 

Web-based product documentation 

You can get help online by visiting the www.embarcadero.com web site and navigating 

to one of the following: 

• Developer network—http://dn.embarcadero.com—where you can find news and 

articles about Embarcadero products. 

• QualityCentral—http://qc.embarcadero.com—where you can read, create, update, 

or manage reports about issues in the Embarcadero products. 

• CodeCentral—http://cc.embarcadero.com—where you can find, comment upon, 

upload, and download code snippets for the Embarcadero products.  

• Blogs—http://blogs.embarcadero.com—you can find useful information in articles 

written by the Embarcadero employees. 

The http://docs.embarcadero.com web site also includes a list of books and additional 

technical documents for all of the Embarcadero products. 

 

F1 Help and online help system 

You can get context-sensitive help in any part of the development environment, in-

cluding in menu items, in dialog boxes, in toolbars, and in components by selecting 

the item and pressing F1F1F1F1.                               
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Pressing the FFFF1111 key while a menu item is selected displays context-sensitive help for 

the item. For example, pressing F1F1F1F1 on the Trace Into Trace Into Trace Into Trace Into menu item... 

...displays the following help page. 

Figure 1Figure 1Figure 1Figure 1----1. 1. 1. 1. The Trace IntoTrace IntoTrace IntoTrace Into menu item in RunRunRunRun 

Figure 1Figure 1Figure 1Figure 1----2. 2. 2. 2. F1F1F1F1 Help for the Trace Into Trace Into Trace Into Trace Into menu item 

Finding information 
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Error messages from the compiler and linker appear in a special window below the 

Code Editor. To get help with compilation errors, select a message from the list and 

press F1F1F1F1.  

Useful information about using the help viewer can be found at  

http://edn.embarcadero.com/article/37562. 

Finding information 
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Tour of the IDE 

 

 

 

First lookFirst lookFirst lookFirst look 

When you start CodeGear™ RAD Studio 2009, the integrated development environ-

ment (IDE) launches and displays several tools and menus.  

The IDE helps you visually design user interfaces, set object properties, write code, 

view, and manage your application in various ways.   

The default IDE desktop layout includes some of the most commonly used tools. You 

can use the View View View View menu to display or hide certain tools. You can also customize your 

desktop by moving or deleting elements, and you can save the desktop layouts that 

work best for you.  
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Welcome PageWelcome PageWelcome PageWelcome Page    

When you open RAD Studio, the Welcome Page appears with a number of links to 

developer resources, such as product-related articles, training, and online Help.  

As you develop projects, you can quickly access them from the list of recent projects at 

the top of the page. To return to the Welcome Page from another main window such 

as the Code Editor or Design window, click the Welcome Page tab at the top of the 

window. If you close the Welcome Page, you can reopen it by choosing View >      View >      View >      View >      

Welcome PageWelcome PageWelcome PageWelcome Page. 

Click this tab to return to the Welcome Page. 

Figure 2Figure 2Figure 2Figure 2----1. 1. 1. 1. The RAD Studio Welcome Page 

Welcome Page  
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The following pages describe and show screenshots of the various available options 

when a RAD Studio project is open. You can create a new project by clicking 

File > New > VCL Forms Application File > New > VCL Forms Application File > New > VCL Forms Application File > New > VCL Forms Application ----    DelphiDelphiDelphiDelphi or File > New > File > New > File > New > File > New >     

VCL Forms Application VCL Forms Application VCL Forms Application VCL Forms Application ----    C++BuilderC++BuilderC++BuilderC++Builder, for Delphi and C++Builder, respectively. A 

more detailed explanation on how to create a project is given in Chapter 3, “Starting 

your first RAD Studio application”. 



The Structure View displays a 

hierarchical view of your components’ 

parent-child relationships. 

The menus and toolbars provide several features 

and tools to help you write an application. 

The Object Inspector is used to change 

objects’ properties and create event handlers. 

The Form Designer contains a blank 

form on which to start designing the 

user interface for your application. 

An application can include several 

forms. 

 The Tool Palette contains ready-made 

components to add to your projects. 

The main window, which occupies the top of the screen, contains the menu bar and 

the toolbars. 

The menu bar 

Toolbars providing fast access to various tools that 

you can use to operate on the current project 

Figure 2Figure 2Figure 2Figure 2----2. 2. 2. 2. The default layout for creating a RAD Studio application 

Figure 2Figure 2Figure 2Figure 2----3. 3. 3. 3. The main menu bar   

Welcome Page 
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Toggle 

Form/Unit 

View 

Form 

View 

Desktop 

layout setting 

Save current 

desktop 

Set debug 

Back 

Forward 

Run 

List of 

projects 

you can run 

Pause 

Program 

reset 

Trace 

into 

Step 

over 

Run Until 

Return 

ToolbarsToolbarsToolbarsToolbars    

RAD Studio toolbars provide quick access to frequently used operations and com-

mands. The toolbars are displayed below in more detail. 

Most toolbar operations are duplicated in the drop-down menus. 

New 

items 

Open 

Save 

Save All 

Open 

Project 

Add file 

to project 

Remove 

file from 

project 

To find out what a button does, hover the mouse over it for a moment until a tooltip 

appears. You can hide any toolbar by right-clicking the toolbar and selecting the con-

text menu command HideHideHideHide. To display a toolbar that is not showing, choose ViewViewViewView > > > > 

ToolbarsToolbarsToolbarsToolbars and check the toolbar you want. 

Many operations have keyboard shortcuts as well as toolbar buttons. When a keyboard 

shortcut is available, the dropdown menu displays the shortcut next to the command. 

 

Shortcut key for the Save All Save All Save All Save All command 

Figure 2Figure 2Figure 2Figure 2----4. 4. 4. 4. The main toolbars 

Figure 2Figure 2Figure 2Figure 2----5. 5. 5. 5. Shortcut keys in the FileFileFileFile menu 

Toolbars 
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About 

Help 

contents 



You can right-click on many tools and icons to display a menu of commands appropri-

ate to the object you are highlighting. These are called context menus. The toolbars 

are also customizable. You can add the commands you want to the toolbar or move 

the commands to different locations on the toolbar. 

 

 

 

 

 

 

 

Toolbar customization context menu 

Figure 2Figure 2Figure 2Figure 2----6. 6. 6. 6. Customizing the toolbars 

Tools 
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ToolsToolsToolsTools    

The tools available in the RAD Studio IDE depend on the version of RAD Studio you 

are using. Every SKU of RAD Studio contains the following tools:  

• Accessibility Options 

• Form Designer 

• Tool Palette 

• Object Inspector 

• Project Manager 

• Data Explorer 

• Structure View 

• History Manager 

• Code Editor 

• File Browser 

 

The following sections describe each of these tools.  
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Accessibility options 

The IDE's main menu supports MS Active Accessibility (MSAA). This means that you 

can use the Windows accessibility tools from the Start Start Start Start menu by choosing  

All Programs > Accessories > AccessibilityAll Programs > Accessories > AccessibilityAll Programs > Accessories > AccessibilityAll Programs > Accessories > Accessibility. 

    

Form Designer 

The Form Designer in RAD Studio allows you to rapidly prototype, build, and modify 

the user interface of your application. Typically, a form represents a window or an 

HTML page in the user interface.  

Select the form that best suits your application design, whether it is a Web application 

that provides business logic functionality over the Web or a Windows application that 

provides processing and high-performance content display.  

In RAD Studio, the user interface of an application is built using components that can 

be either visual or nonvisual and can be added to the form using the Tool Palette, 

which is discussed in the next section. Visual components appear on your form at the 

time the program is run. Nonvisual components do not appear on the form at run 

time, but they change the behavior of your application. Both types of components can 

be accessed at run time from your application’s code. 

 

 

A TTimer component, providing a 

basic synchronization system 

(nonvisual) 

A TButton component 

(visual) 

Form Designer 

Another TButton component 

A TOpenDialog component, providing 

a basic open dialog window 

(nonvisual) 

A TMemo text editing box component 

(visual) 

Figure 2Figure 2Figure 2Figure 2----7. 7. 7. 7. Creating a basic RAD Studio application using the Form Designer 



 

 

 

 

 

 

 

  

 

 

 

The RAD Studio Form Designer is based on the WYSIWYG (What You See Is What You 

Get) concept, allowing you to design your application's user interface with as little ef-

fort as possible. 

The same concept applies to the possibility of seeing the way components will behave 

at run time before compiling your applications.   

This is the case, for instance, of database-aware components. You can develop live da-

tabase queries and connections at design time. Database viewing components can 

show data from a selected database. This way you can check if the behavior at design 

time will be the intended one at run time. 

The Form Designer also allows you to build user interfaces for your VCL for the Web 

applications, making the development as simple as possible. 

To start using the Form Designer, you must first create a VCL for the Web or a VCL for 

Win32 form using the project templates from the Object repository.  

After you place components on the form, or Form Designer, you can arrange them the 

way they should look on your user interface. Every component's attributes can be 

viewed and changed with the Object Inspector pane. You can use the Object Inspec-

tor for many purposes, including the following: 

• To set design-time properties for the components you place on the form. 

• To create event handlers, filter-visible properties, and events, making the connec-

tion between your application’s visual appearance and the code that makes your 

application run. 

 

For more information…For more information…For more information…For more information…    

See “Adding the components using the Form Designer” and “Customizing the com-

ponents using the Object Inspector” in the next chapter. 

Form Designer 
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Tool PaletteTool PaletteTool PaletteTool Palette 

The Tool Palette contains items to help you develop your application. The Tool Palette 

is displayed as a category panel group, usually located in the right column. Each of the 

categories in Tool Palette contains icons that represent visual or nonvisual compo-

nents.  

The categories divide the components into functional groups. For example, in Design 

mode, the StandardStandardStandardStandard and Win32Win32Win32Win32 categories include Windows controls such as a but-

ton, or an edit box; the DialogsDialogsDialogsDialogs category includes common dialog boxes to use for file 

operations such as opening and saving files. 

The contents of the Tool Palette change when switching between Design mode and 

Code Editor mode. More information on the Code Editor is given in a later section. 

Thus, if you are viewing a form in Design mode,  the Tool Palette displays components 

that are appropriate for that form. You can double-click a control to add it to your 

form. You can also drag a control to a desired position on the form.  

 

 

 

Type any component name, and Search automatically filters the com-

ponent list and locates the component, provided that is installed.  

List of components in the Standard Standard Standard Standard category 

List of components sorted by category 

Figure 2Figure 2Figure 2Figure 2----8. 8. 8. 8. The    Tool Palette showing the Standard Standard Standard Standard components category 

Tool Palette 
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If you are viewing code in the Code Editor, the Tool Palette displays project types that 

you can add to your project group and file types that you can add to your project. 

In addition to the components that are installed with RAD Studio, you can add custom-

ized or third-party components to the Tool Palette and save them in their own cate-

gory. 

You can also create templates that are composed of one or more components. After 

arranging components on a form, setting their properties, and writing code for them, 

you can save them as a component template.  

Later, by selecting the template from the Tool Palette, you can place the preconfig-

ured components on a form in a single step; all associated properties and event-

handling code are added to your project at the same time. You can reposition the 

components independently, reset their properties, and create or modify event han-

dlers for them just as if you had placed each component in a separate operation. 

Each component has specific attributes—properties, events, and methods—that en-

able you to control your application. 

After you place components on the form, or Form Designer, you can arrange compo-

nents the way they should look on your user interface. For the components you place 

on the form, use the Object Inspector to customize their behavior, as shown in the fol-

lowing section. 

List of components in the Delphi Projects Delphi Projects Delphi Projects Delphi Projects category 

Types of projects to create, sorted by category 

Figure 2Figure 2Figure 2Figure 2----9. 9. 9. 9. The    Tool Palette in Code Editor mode, showing the standard Delphi Projects Delphi Projects Delphi Projects Delphi Projects templates 

Tool Palette 
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Object InspectorObject InspectorObject InspectorObject Inspector 

The Object Inspector allows you to customize the properties of the components that 

make up the application user interface and create event handlers at design time. Each 

visual and nonvisual component has a set of published properties and events, which 

the Object Inspector displays and allows to be modified visually, using the PropertiesPropertiesPropertiesProperties 

and EventsEventsEventsEvents tabs. User interfaces created with RAD Studio are event-driven, meaning 

that any component can react to an externally or internally generated event. The 

Object Inspector allows you to automatically generate code that is executed when 

such an event is fired. 

Name of the component 

You can customize the Object Inspector by right-clicking 

it. A popup menu will be shown with a list of customiza-

tion options such as the arrangement style of properties 

or the filtering options. 

Context menu displaying the available options 

for customizing the Object Inspector 

Figure 2Figure 2Figure 2Figure 2----10. Properties10. Properties10. Properties10. Properties tab in the Object Inspector Figure 2Figure 2Figure 2Figure 2----11. Events11. Events11. Events11. Events tab in the Object Inspector 

Figure 2Figure 2Figure 2Figure 2----12. 12. 12. 12. Customizing the Object Inspector    

Object Inspector 
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List of properties and their values 

for the selected component 

List of possible events for 

the selected component —

double-click an event to 

automatically create the 

code skeleton of the event. 



 

 

 

 

 

 

 

 

 

Project ManagerProject ManagerProject ManagerProject Manager 

To build an application or a DLL using Delphi or C++Builder, you need to create a pro-

ject. The Project Manager displays a hierarchical file list of your project or project 

group, so you can view and organize the files.  

You can use the Project Manager to combine and display information on related pro-

jects into a single project group. By organizing related projects into a group, such as 

multiple executables, you can compile them at the same time. You can also set project 

options to resolve the dependencies between projects.  

The buttons at the top of the Project Manager enable you to perform the following 

tasks:  

ActivateActivateActivateActivate—Activate the currently selected project. 

NewNewNewNew—Add another project to the current project group. If only one project currently 

exists, a project group is created for you automatically. 

RemoveRemoveRemoveRemove—Remove a project from the current project group. 

ViewViewViewView—View the file tree hierarchy in multiple ways. 

SyncSyncSyncSync—Synchronize the project manager with the medium where the actual project or 

project group files are stored. 

ExpandExpandExpandExpand—Expand all child nodes from the one that is currently selected. 

CollapseCollapseCollapseCollapse—Collapse all child nodes from the one that is currently selected. 

Hierarchical view of the files inside 

the current project 

Available operations for the current 

project 

Available operations to apply to the 

project hierarchy 

Figure 2Figure 2Figure 2Figure 2----13. 13. 13. 13. Hierarchical file list of the project, 

displayed by the Project Manager 

Project Manager 
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File BrowserFile BrowserFile BrowserFile Browser 

The File Browser allows you to conveniently manage files at a specified path. All the 

files are displayed in a tree view, allowing easy hierarchical browsing. To show the File 

Browser, choose View > File BrowserView > File BrowserView > File BrowserView > File Browser. 

The File Browser is especially useful for managing files that are not normally part of the 

project itself, and thus not present in the Project Manager. The context menu shown 

by the File Browser when a file is right-clicked is based on the Windows Explorer 

menu, with two new options specific to RAD Studio. These two options allow you to 

either open the selected files with RAD Studio itself or to add them to the currently 

open project. 

A useful feature of the File Browser is the ability to filter the displayed files based on a 

set of masks. After clicking the Filter Filter Filter Filter button at the top of the File Browser window, a 

new dialog box asking for a semicolon-separated list of masks appears. As an exam-

ple, setting the mask to *.txt; *.exe displays only executables and text files. 

 

 

 

 

 

 

 

 

 

 

 

Allows you to display only files that 

match a particular file name pattern  

Hierarchical view of the existing files and folders, 

providing basic file explorer features 

Dialog box that allows you to specify the file name pattern 

used to filter the existing files and folders  

Figure 2Figure 2Figure 2Figure 2----14. 14. 14. 14. Browsing files and folders using File Browser    

Figure 2Figure 2Figure 2Figure 2----15. 15. 15. 15. Setting up the file filter used in the File Browser    

File Browser 
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Structure ViewStructure ViewStructure ViewStructure View 

The contents of the Structure View reflect the current mode in the IDE. The Structure 

View shows either the hierarchy of the source code that is currently open in the Code 

Editor, or the components currently displayed in the Designer. The tree diagram is syn-

chronized with the Object Inspector and the Form Designer so that when you change 

mode in the Structure View, the mode also changes for both the Object Inspector and 

the form itself.  

To display the Structure View, choose View > StructureView > StructureView > StructureView > Structure. 

If the Structure View is displaying the structure of Designer components, you can sin-

gle-click a component in the tree diagram to focus it on the form. 

If displaying the structure of source code or HTML, you can double-click an item in the 

list to jump to its declaration or location in the Code Editor.  

Hierarchical view of the components and source 

code used in the current project 

Hierarchical view of the resources used 

in the current project, sorted by 

classes, variables/constants, and units 

Figure 2Figure 2Figure 2Figure 2----16. 16. 16. 16. Structure View in Form Designer mode    

Figure 2Figure 2Figure 2Figure 2----17. 17. 17. 17. Structure View in Code Editor mode    

Structure View 
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If your code contains syntax errors, they are displayed in the Errors pane of the  

Structure View. To locate an error in the Code Editor, double-click it in the Errors pane. 

You can also use the Source View to change related components’ relationships. For 

example, if you add a panel and a check box component to your form, the two compo-

nents are siblings. In the Structure View, however, if you drag the check box on top of 

the panel icon, the check box becomes the child of the panel. 

The Structure View is useful for displaying the relationships between database objects. 

You can also double-click any Designer component in the Structure View to open the 

Code Editor to a place where you can write an event handler for that component. 

You can control the content and appearance of the Structure View by choosing Tools Tools Tools Tools 

> Options > Environment Options > Explorer > Options > Environment Options > Explorer > Options > Environment Options > Explorer > Options > Environment Options > Explorer and changing the settings. The fol-

lowing options page should be displayed. 

For more information…For more information…For more information…For more information…    

Access the “Structure View” help page. 

Figure 2Figure 2Figure 2Figure 2----18. 18. 18. 18. Structure View explorer options    

Structure View 
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The Code EditorThe Code EditorThe Code EditorThe Code Editor    

The Code Editor occupies the center pane of the IDE window. The Code Editor is a full

-featured, customizable, UTF8 editor that provides syntax highlighting, source code 

browsing, multiple-undo capability, and context-sensitive Help for language elements.  

As you design the user interface for your application, RAD Studio generates portions 

of the underlying code. Whenever you modify the properties of an object, your 

changes are automatically reflected in the source files.   

Because all of your programs share common features, RAD Studio auto-generates 

code to get you started. You can think of the auto-generated code as an outline that 

you can use to create your program.  

 

The Code Editor provides the following features to help you write code:  

• Code Navigation 

 Method Hopping, Bookmarks, Finding Classes, Finding Units 

• Code Folding   

• Change Bars  

• Block Comments 

• Live Templates 

• SyncEdit  

• Code Insight  

  Code Parameter Hints, Code Hints, Help Insight, Class Completion, 

  Block  Completion, Error Insight, Code Browsing 

• Refactoring  

• Keystroke Macros  

• To-Do Lists  

• Custom Template Libraries 

The Code Editor 
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Code NavigationCode NavigationCode NavigationCode Navigation 

To navigate code while you are using the Code Editor, you can use one of the follow-

ing methods. 

 

Method HoppingMethod HoppingMethod HoppingMethod Hopping    

You can navigate between methods using a series of editor hotkeys. You can also limit 

hopping to the methods of the current class by setting class lock.  

For example, if class lock is enabled and you are in a method of TComponent, then 

hopping is only available within the methods of TComponent. The keyboard shortcuts 

for Method Hopping are as follows. 

 

 

 

 

 

    

    

BookmarksBookmarksBookmarksBookmarks    

Bookmarks provide a convenient way to navigate long files. You can mark a location in 

your code with a Bookmark and jump to that location from anywhere in the file. 

You can use up to ten Bookmarks, numbered 0 through 9, within a file. To toggle a 

Bookmark at the current line, simply press CTRL+SHIFT+digitCTRL+SHIFT+digitCTRL+SHIFT+digitCTRL+SHIFT+digit. 

When you set a Bookmark, a book icon is displayed in the left gutter of the Code Edi-

tor, as in the following image. 

CTRL+Q CTRL+Q CTRL+Q CTRL+Q followed by    LLLL    toggles class lock  

CTRL+ALT+HOME CTRL+ALT+HOME CTRL+ALT+HOME CTRL+ALT+HOME     moves to the first method in the file  

CTRL+ALT+END CTRL+ALT+END CTRL+ALT+END CTRL+ALT+END     moves to the last method in the file 

CTRL+ALT+MOUSE WHEEL CTRL+ALT+MOUSE WHEEL CTRL+ALT+MOUSE WHEEL CTRL+ALT+MOUSE WHEEL     scrolls through methods  

Keyboard shortcutKeyboard shortcutKeyboard shortcutKeyboard shortcut    EffectEffectEffectEffect    

Table 2Table 2Table 2Table 2----1. 1. 1. 1. Method Hopping keyboard shortcuts 

The Code Editor 
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Bookmark sign that marks 

a particular line of code 

Ellipsis symbol specifying that the 

block of code is collapsed 

Click the plus sign to expand the code. 

Finding ClassesFinding ClassesFinding ClassesFinding Classes    

Use the Search > Find Class Search > Find Class Search > Find Class Search > Find Class command to see a list of available classes that you can 

select. If you double-click a class, the IDE automatically navigates to its declaration. 

Finding UnitsFinding UnitsFinding UnitsFinding Units    

Depending on your programming language, you can use a refactoring feature to lo-

cate namespaces or units. If you are using the Delphi language, you can use the 

Search > Find Unit Search > Find Unit Search > Find Unit Search > Find Unit command to locate and add units to your code file. The Find Type 

window allows regular expressions. 

 

Code FoldingCode FoldingCode FoldingCode Folding    

Code Folding lets you collapse sections of code to create a hierarchical view of your 

code and to make it easier to read and navigate. To create Code Folding regions, see 

the help topic “Using Code Folding”. 

Code Folding regions have plus (+) and minus (-) signs located on the gutter of the 

Code Editor, used to collapse and expand a region of code, respectively.  

The collapsed code is not deleted, but hidden from view.  

Figure 2Figure 2Figure 2Figure 2----19. 19. 19. 19. Setting Bookmarks    in the source code    

Figure 2Figure 2Figure 2Figure 2----20. 20. 20. 20. Collapsed blocks of code    

The Code Editor 
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Change BarsChange BarsChange BarsChange Bars    

The left margin of the Code Editor displays a yellow change bar to indicate lines that 

have been changed but not yet saved in the current editing session. A green change 

bar indicates the changes that have been made since the last FileFileFileFile >>>> Save Save Save Save operation. 

You can, however, customize the Change Bars to display in colors other than the de-

fault green and yellow. To do this, go to Tools > Options > Editor Options > ColorTools > Options > Editor Options > ColorTools > Options > Editor Options > ColorTools > Options > Editor Options > Color, 

select the Modified Line Modified Line Modified Line Modified Line element    and change the foreground and the background 

colors. 

Block CommentsBlock CommentsBlock CommentsBlock Comments————CTRL+/ CTRL+/ CTRL+/ CTRL+/     

You can comment-out a section of code by selecting the code in the Code Editor and 

pressing CTRL+/ CTRL+/ CTRL+/ CTRL+/ (slash). Each line of the selected code is then prefixed with // and is 

ignored by the compiler. Pressing CTRL+/ CTRL+/ CTRL+/ CTRL+/ adds or removes the slashes, based on 

whether the first line of the selected code is prefixed with //.  

When using the Visual Studio or Visual Basic key mappings, use CTRL+K+C CTRL+K+C CTRL+K+C CTRL+K+C to add 

and remove comment slashes. 

Live TemplatesLive TemplatesLive TemplatesLive Templates    

Live Templates allow you to have a dictionary of pre-written code that can be inserted 

into your programs while you are working with the Code Editor. You can access Live 

Templates by going to View > TemplatesView > TemplatesView > TemplatesView > Templates. 

Using Live Templates reduces the amount of typing that you must do.  

You can find further information concerning Live Templates in the help, by accessing 

the pages entitled “Creating Live Templates” and “Using Live Templates”. 

Figure 2Figure 2Figure 2Figure 2----21. 21. 21. 21. Expanding the list of Live Templates for Delphi    

The Code Editor 
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List of available Delphi templates 



 

 

 

 

 

A blue rectangle encloses each occurrence 

of the identifier. 

SyncEditSyncEditSyncEditSyncEdit    

The SyncEdit feature lets you simultaneously edit identical identifiers in the code.  

As you change the first identifier, the same change is performed automatically on the 

other identifiers. For example, in a procedure that contains three occurrences of Self, 

you can edit the first occurrence only and all the other occurrences will change auto-

matically. 

To use SyncEdit: 

1. In the Code Editor, select a block of code that contains identical identifiers.  

2. Click the SyncEdit Mode icon that appears in the left gutter. The first identical 

identifier is highlighted and the others are outlined. The cursor is positioned on the 

first identifier. If the code contains multiple sets of identical identifiers, you can 

press TABTABTABTAB to move between each identifier in the selection.  

3. Begin editing the first identifier. As you change the identifier, the same change is 

performed automatically on the other identifiers. By default, the identifier is re-

placed. To change the identifier without replacing it, use the arrow keys before you 

begin typing.  

4.   When you have finished changing the identifiers, you can exit Sync Edit mode by 

clicking the SyncEdit Mode icon, or by pressing the EscEscEscEsc key.  

NoteNoteNoteNote: SyncEdit determines identical identifiers by matching text strings; it does not 

analyze the identifiers. For example, it does not distinguish between two like-named 

identifiers of different types in different scopes. Therefore, SyncEdit is intended for 

small sections of code, such as a single method or a page of text. For changing larger 

portions of code, consider using refactoring, which is a more advanced method of im-

proving your code, without changing its functionality. Further details on refactoring are 

given in a later section. 

Figure 2Figure 2Figure 2Figure 2----22. 22. 22. 22. Highlighting all the occurrences of an identifier in a section of code    

The Code Editor 
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SyncEdit Mode icon 



 

 

 

 

 

 

 

Code completion window that appears when pressing 

CTRL+SPACE CTRL+SPACE CTRL+SPACE CTRL+SPACE at the current cursor position 

Code InsightCode InsightCode InsightCode Insight 

Code Insight refers to a subset of features embedded in the Code Editor (such as 

Code Parameter Hints, Code Hints, Help Insight, Code Completion, Class Completion, 

Block Completion, and Code Browsing) that aid in the code writing process. These 

features help identify common statements you want to insert into your code, and assist 

you in the selection of properties and methods. Some of these features are described 

in more detail in the following sub-sections.  

To enable and configure Code Insight features, choose Tools > Options > Editor Tools > Options > Editor Tools > Options > Editor Tools > Options > Editor 

Options Options Options Options and click Code Insight. 

Figure 2Figure 2Figure 2Figure 2----23. 23. 23. 23. Code Completion popup window showing the list of available options    

Help InsightHelp InsightHelp InsightHelp Insight—CTRL+SHIFT+H CTRL+SHIFT+H CTRL+SHIFT+H CTRL+SHIFT+H     

Help Insight displays a hint containing information about the symbol, such as type, file, 

line number where declared, and any XML documentation associated with the symbol 

(if available).  

Invoke Help Insight by hovering the mouse over an identifier in your code, while work-

ing in the Code Editor. You can also invoke Help Insight by pressing CTRL+SHIFT+HCTRL+SHIFT+HCTRL+SHIFT+HCTRL+SHIFT+H. 

The Code Editor 
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Code CompletionCode CompletionCode CompletionCode Completion————CTRL+SPACECTRL+SPACECTRL+SPACECTRL+SPACE    

To invoke Code Completion, press CTRL+SPACE CTRL+SPACE CTRL+SPACE CTRL+SPACE while using the Code Editor. A 

popup window displays a list of symbols that are valid at the cursor location. You can 

type characters to match those in the selection and press Return Return Return Return to insert the text in 

the code at the cursor location. 



Class CompletionClass CompletionClass CompletionClass Completion—CTRL+SHIFT+C CTRL+SHIFT+C CTRL+SHIFT+C CTRL+SHIFT+C     

Class Completion simplifies the process of defining and implementing new classes by 

generating skeleton code for the class members that you declare.  

Position the cursor within a class declaration in the interface section of a unit and press 

CTRL+SHIFT+CCTRL+SHIFT+CCTRL+SHIFT+CCTRL+SHIFT+C. Any unfinished property declarations are completed.  

For any methods that require an implementation, empty methods are added to the 

implementation section.  

Class Completion can also be achieved by choosing the option Complete class at Complete class at Complete class at Complete class at     

cursorcursorcursorcursor from the editor context menu. 

Block CompletionBlock CompletionBlock CompletionBlock Completion—ENTERENTERENTERENTER    

When you press ENTERENTERENTERENTER in a block of code that was incorrectly closed (while working in 

the Code Editor), a closing block token is inserted at the first empty line following the 

cursor position. 

For instance, if you are using the Code Editor with the Delphi language, and you type 

the token begin and then press ENTERENTERENTERENTER, the Code Editor automatically completes the 

statement so that you have: begin end;.  

Block Completion also works for the C++ language. 

Code Parameter HintsCode Parameter HintsCode Parameter HintsCode Parameter Hints—CTRL+SHIFT+SPACE CTRL+SHIFT+SPACE CTRL+SHIFT+SPACE CTRL+SHIFT+SPACE     

Code Parameter Hints display a hint containing argument names and types for method 

calls. You can invoke Code Parameter Hints by pressing CTRL+SHIFT+SPACECTRL+SHIFT+SPACECTRL+SHIFT+SPACECTRL+SHIFT+SPACE, after 

opening a left bracket of a function call. 

 

The Code Editor 
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Parameter Hint message that appears when 

you type the left bracket of a function call 

Figure 2Figure 2Figure 2Figure 2----24. 24. 24. 24. Using Code Parameter Hints to 

show the required types for the parameters     



 

 

 

 

 

 

 

 

 

 

Code HintsCode HintsCode HintsCode Hints    

Code Hints display a hint containing information about the symbol such as type, file, 

and line number where declared. You can display Code Hints by hovering the mouse 

over an identifier in your code, while working in the Code Editor.  

Code hint message that appears when the mouse 

hovers over an identifier in the source code 

Note: Note: Note: Note: Code Hints only work when the Help Insight feature is disabled.  

Figure 2Figure 2Figure 2Figure 2----25. 25. 25. 25. Displaying in-place Code Hints    

Error InsightError InsightError InsightError Insight    

When you type an expression that generates compiler errors, the expression is under-

lined in red. 

Also, the list of errors generated by the expression appears in the Errors pane of the 

Structure View. 

The Code Editor 
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This line of code is underlined in red 

to indicate an error 

Figure 2Figure 2Figure 2Figure 2----26. 26. 26. 26. Automatic marking of errors in the code    

Code BrowsingCode BrowsingCode BrowsingCode Browsing—CTRL+Click CTRL+Click CTRL+Click CTRL+Click  

While using the Code Editor to edit a VCL Form application, you can hold down the 

CTRLCTRLCTRLCTRL key while hovering the mouse over the name of any class, variable, property, 

method, or other identifier.  



 

 

 

 

 

 

 

The mouse pointer turns into a hand and the identifier appears highlighted and under-

lined. Click the identifier and the Code Editor jumps to the declaration of the identi-

fier, opening the source file, if necessary. You can do the same thing by right-clicking 

an identifier and choosing Find DeclarationFind DeclarationFind DeclarationFind Declaration.   

Code browsing can only find and open units in the project Search path or Source path, 

or in the product Browsing or Library path. Directories are searched in the following 

order:  

1. The project Search path 

2. The project Source path, the directory in which the project was saved 

3. The global Browsing path  

4. The global Library path 

5. The Library path, that is searched only if there is no project open in the IDE 

These paths can be modified by editing the corresponding values in the list of 

Directories, available by going to: Tools > Options > Environment Options >Tools > Options > Environment Options >Tools > Options > Environment Options >Tools > Options > Environment Options >    

Delphi Options > Library Delphi Options > Library Delphi Options > Library Delphi Options > Library ----    Win32.Win32.Win32.Win32.    

 

RefactoringRefactoringRefactoringRefactoring 

Refactoring is the process of improving your code without changing its external func-

tionality. 

For example, you can turn a selected code fragment into a method by using the ex-

tract refactoring method. The IDE moves the extracted code outside of the current 

method, determines the needed parameters, generates local variables if necessary, 

determines the return type, and replaces the code fragment with a call to the new 

method.  

Several other refactoring methods, such as renaming a symbol and declaring a vari-

able, are also available. 

 

Keystroke MacrosKeystroke MacrosKeystroke MacrosKeystroke Macros 

You can record a series of keystrokes as a macro while editing code. The red button at 

the bottom of the code window starts the recording. After you record a macro, you 

can play it back to repeat the keystrokes during the current IDE session. Recording a 

macro replaces the previously recorded macro. 

The Code Editor 
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ToToToTo----Do ListsDo ListsDo ListsDo Lists    

A To-Do List records the tasks that need to be completed for a project. After you add 

a task to the To-Do List, you can edit the task, add it to your code as a comment, indi-

cate that it has been completed, and then remove it from the list.  

You can filter the list to display only the tasks that are of interest to you. 

To display the To-Do List window, select View > ToView > ToView > ToView > To----Do List.Do List.Do List.Do List. 

 

Custom Template LibrariesCustom Template LibrariesCustom Template LibrariesCustom Template Libraries    

RAD Studio allows you to create multiple custom template libraries to use as the basis 

for creating future projects. Template libraries let you declare how projects can look, 

and they enable you to add new types of projects to the Object Repository. 
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History ManagerHistory ManagerHistory ManagerHistory Manager    

The History Manager lets you compare versions of a file, including multiple backup 

versions, saved local changes, and the buffer of unsaved changes for the active file. 

If the current file is under version control, all types of revisions are available in the His-

tory Manager. 

The History Manager is displayed on the HistoryHistoryHistoryHistory tab, which lies at the center of the 

IDE to the right of the Code Code Code Code tab.  

The History Manager contains the following tabbed pages. 

PagePagePagePage    DescriptionDescriptionDescriptionDescription    

Contents Displays the current and previous versions of the file. 

Info Displays all labels and comments for the active file. 

Diff Displays the differences between the selected versions 
of the file. 

Table 2Table 2Table 2Table 2----2. 2. 2. 2. History Manager pages 



The following image shows the Diff page of the History Manager, comparing two dif-

ferent versions of a .dfm file. The differences are shown using plus/minus signs and the 

corresponding lines are highlighted in green/magenta. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Name of the file 

The lines of code are highlighted to indicate 

differences between the two files. 

Current version 

of the file 

Previous version of the file 

Figure 2Figure 2Figure 2Figure 2----27. 27. 27. 27. Comparing two versions of a file using the Diff Diff Diff Diff page    

History Manager 
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IconIconIconIcon    DescriptionDescriptionDescriptionDescription    

 The latest saved file version. 

 A backup file version. 

 The file version that is in the buffer and includes unsaved 

changes. 

 A file version that is stored in a version control repository. 

 A file version that you have checked out from a version 

control repository. 

Table 2Table 2Table 2Table 2----3. 3. 3. 3. Revision icons on the Diff Diff Diff Diff page 

Revision icons are used to represent file versions in the revision lists and they are de-

scribed in the following table. 
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Data ExplorerData ExplorerData ExplorerData Explorer    

Figure 2Figure 2Figure 2Figure 2----28. 28. 28. 28. Exploring the list of available database connections     

The currently available database connections 

RAD Studio offers a variety of database and connectivity tools to simplify the develop-

ment of database applications. 

The Data Explorer is located, by default, in the upper right corner of the IDE. The Data 

Explorer allows you to create and modify database connections that can easily be used 

later in your database applications. 

NoteNoteNoteNote: Data Explorer works for databases that use the DBExpress connection type.  

After you create a database connection, you can use the Data Explorer to create, view 

and modify tables, views, procedures, function, and synonyms. You can click an item 

from the expanded connection type entry. A menu that allows you to refresh the data 

or create a new item will appear. 
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Starting your first RAD Studio application 

 

 

 

 

 

This chapter explains how to use the Rapid Application Development tools of  

CodeGear™ RAD Studio 2009 to create a GUI (Graphical User Interface) application. 

You start with creating the main form, customizing it, and adding the necessary visual 

and nonvisual components.  

The sections of code in the application to handle user actions are called event  

handlers, which you also need to implement. After following the steps, given both for   

Delphi and C++, you will have a basic text editor, with a few additional features like 

word-wrapping and the ability to change the font and display the current cursor posi-

tion in the status bar. The event handlers that implement these features refer to click-

ing options in the main menu and to typing or clicking inside the edit box. 

Starting your first RAD Studio application 3-1 



Using project templates from the Object RepositoryUsing project templates from the Object RepositoryUsing project templates from the Object RepositoryUsing project templates from the Object Repository 

First, create a project in CodeGear™ RAD Studio 2009 by clicking File > New File > New File > New File > New and 

choosing VCL Forms Application > C++BuilderVCL Forms Application > C++BuilderVCL Forms Application > C++BuilderVCL Forms Application > C++Builder or VCL Forms Application > Del-VCL Forms Application > Del-VCL Forms Application > Del-VCL Forms Application > Del-

phiphiphiphi, depending on the language you want to use to develop the text editor. At this 

point, the File File File File menu and its OpenOpenOpenOpen command submenu should be displayed as in the 

following image. 

 

 

Create a new application, using 

Delphi. 

Create a new application, using 

C++Builder. 

Figure 3Figure 3Figure 3Figure 3----1. 1. 1. 1. Description of all options in the FileFileFileFile menu    

Figure 3Figure 3Figure 3Figure 3----2. 2. 2. 2. Expanding the NewNewNewNew option in the FileFileFileFile menu    

Using project templates from the Object Repository 
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Create a new application. 

Open an existing file. 

Open an existing project. 

Reopen a recently opened project. 

Save the current file as a specified file, possibly 

different from the current one. 

Save the current file by overwriting 

its previous version. 

Save the current project as a 

specified project, possibly different 

from the current one. 
Save all files in the current project, 

by overwriting their previous versions. 

Close the current 

file. 
Add a unit to the current list of units used 

by the application. 
Print the currently opened 

file. 
Exit the RAD Studio IDE. 

Close all files in the current project. 



         

 

 

 

 

 

 

 

 

 

After clicking the menu item to create a project, several files are automatically gener-

ated, using the VCL Forms Application template, also including the main form. After 

the files are generated, the main form is displayed in the Form Designer. The next im-

ages give a screenshot of the IDE at this step, using Delphi or C++Builder, respec-

tively. 

Figure 3Figure 3Figure 3Figure 3----3. 3. 3. 3. The default layout for creating a RAD Studio application (Delphi view) 

Using project templates from the Object Repository 
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Figure 3Figure 3Figure 3Figure 3----4. 4. 4. 4. The default layout for creating a RAD Studio application (C++Builder view) 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Before adding any components, you should start by doing some basic customization 

to the form. Make sure that the main form is activated (click it once otherwise) and that 

the Object Inspector window is visible in the lower left quadrant (if not, press F11F11F11F11    to 

display it). With the Properties Properties Properties Properties tab selected, look for the Caption property and change 

its value to Text Editor; also, change the value of the Name property to TextEdi-

torForm. 

To make the design of the project more visually balanced, set the main form to initially 

be positioned in the center of the screen. To do this, change the value of the Position 

property to poScreenCenter by clicking the value field for Position and then select-

ing the value from the dropdown list. For the same reason, make the form square-

shaped, by changing the values of both Width    and Height to 400, or any other num-

ber you prefer, as long as the number does not exceed the current screen size. 

After making these changes, the main form should look like the following images, us-

ing Delphi or C++Builder, respectively. 

Basic customization of the main formBasic customization of the main formBasic customization of the main formBasic customization of the main form    

Basic customization of the main form 
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Figure 3Figure 3Figure 3Figure 3----5. 5. 5. 5. Basic customization of the main form (Delphi view) 

Figure 3Figure 3Figure 3Figure 3----6. 6. 6. 6. Basic customization of the main form (C++Builder view) 

Basic customization of the main form 
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Adding the components using the Form DesignerAdding the components using the Form DesignerAdding the components using the Form DesignerAdding the components using the Form Designer    

Now that you have set up the main form, you can proceed with arranging the neces-

sary components to create your text editor application. First, you need to add a menu 

bar providing the basic options for file manipulation, editing, and also other options 

like changing the font or toggling word wrap. 

Adding an action managerAdding an action managerAdding an action managerAdding an action manager        

Add an action manager to the form to automatically provide the basic functionality of 

your application. To do so, make sure the DesignDesignDesignDesign tab is selected, go to the Tool  

Palette and type the text action in the search box, in order to locate the  

TActionManager component. The Tool Palette should look as in the following image. 

Double-click the TActionManager button to add it to the form. Now you should 

change the name of the ActionManager to suit your application. To do this, make sure 

Object Inspector is visible (if not, press F11F11F11F11    to display it) and click the Action Manager 

icon to activate it. Click the Name property and change its value to ActionMgr. 

Adding the main menuAdding the main menuAdding the main menuAdding the main menu        

To put a main menu bar on the form, simply locate the TActionMainMenuBar compo-

nent in the Tool Palette. Double-click TActionMainMenuBar to add it to the form. 

Adding a Status BarAdding a Status BarAdding a Status BarAdding a Status Bar        

Next, you should also put a status bar on the form. To do this, type status in the 

search box of the Tool Palette to locate the TStatusBar component. Using this filter, 

the Tool Palette will look like the following image. 

 

Figure 3Figure 3Figure 3Figure 3----7. 7. 7. 7. Using the action filter in the Tool Palette to select TActionManager 

Adding the components using the Form Designer 
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As with the previous components, double-click TStatusBar to add it to the form.  

Adding a text boxAdding a text boxAdding a text boxAdding a text box        

The only component left to add is a text box, giving your application its main function-

ality—that of a text editor. Type memo in the search box and locate the TMemo com-

ponent. The Tool Palette should now display the components whose names include 

the word memo, as in the following image. 

Double-click TMemo to add it to the form. The main form should now display the ac-

tion manager, the action main menu bar, the status bar, and the memo we have previ-

ously added to the form, similar to the following image. 

Figure 3Figure 3Figure 3Figure 3----8. 8. 8. 8. Using the status filter in the Tool Palette to select TStatusBar    

Figure 3Figure 3Figure 3Figure 3----9. 9. 9. 9. Using the memo filter in the Tool Palette to select TMemo 

Figure 3Figure 3Figure 3Figure 3----10. 10. 10. 10. Basic text editor form 
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Starting your first RAD Studio application 3-7  



 

 

 

 

 

 

 

 

 

 

 

 

 

 

Adding the main menu commandsAdding the main menu commandsAdding the main menu commandsAdding the main menu commands        

To finish designing the form, you must add the options to be displayed in the main 

menu. Start by double-clicking the action manager component on the form to open 

the ActionsActionsActionsActions editor.  

The following window should be displayed. 

This button allows you to add new actions. 

The list of currently 

added actions 

The list of categories in which 

the currently added actions live 

You are now ready to create the items in the main menu. Press CTRL+Insert CTRL+Insert CTRL+Insert CTRL+Insert to add 

new standard actions or click the down-arrow of the New Action New Action New Action New Action icon and choose 

New Standard Action... New Standard Action... New Standard Action... New Standard Action... from the menu. The image below shows this menu. 

While pressing CTRLCTRLCTRLCTRL, select all items in the Edit category and also TFileOpen, TFile-

SaveAs, and TFileExit from the File category, then click OKOKOKOK. 

The following image shows how the Standard Action Classes list should display, with 

the items in the File category selected. 

Figure 3Figure 3Figure 3Figure 3----11. 11. 11. 11. The main elements of the Actions Actions Actions Actions page in the Action Manager 

Figure 3Figure 3Figure 3Figure 3----12. 12. 12. 12. Adding a New Standard Action    

Adding the components using the Form Designer 
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After clicking OKOKOKOK, wait until the menu items are automatically generated. You may no-

tice that the object inspector displays the properties of each menu item, as they are 

created. 

 

Defining Action PropertiesDefining Action PropertiesDefining Action PropertiesDefining Action Properties    

Since you need other options as well, you must define your own custom actions. To do 

this, from the Actions Editor, select File from the CategoriesCategoriesCategoriesCategories list and click the New Ac-New Ac-New Ac-New Ac-

tiontiontiontion button twice to create two new, non-standard actions. 

You can now customize the newly created actions. Click Action1 in the Actions Actions Actions Actions list and 

use the Object Inspector to change its Name property to New and its ShortCut    to 

CTRL+N. . . . Also, click Action2 and change its Name to Save and its ShortCut property to 

CTRL+S. 

Now, use the Move Up Move Up Move Up Move Up and Move Down Move Down Move Down Move Down arrows to put the actions in the right order, 

as in the following image. 

Figure 3Figure 3Figure 3Figure 3----13. 13. 13. 13. Selecting the Standard Actions that  

implement the basic file and text operations     

Figure 3Figure 3Figure 3Figure 3----14. 14. 14. 14. Arranging the actions in the    File File File File menu and 

finishing adding the Standard Actions    

Adding the components using the Form Designer 
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Figure 3Figure 3Figure 3Figure 3----15. 15. 15. 15. The final look of the FileFileFileFile menu 

Adding word wrap and font capabilitiesAdding word wrap and font capabilitiesAdding word wrap and font capabilitiesAdding word wrap and font capabilities        

To give your text additional features—word-wrapping and the ability to change the 

font—you need to add another main menu option. Click (No Category) from the     

CategoriesCategoriesCategoriesCategories list and press CTRL+Insert CTRL+Insert CTRL+Insert CTRL+Insert on the keyboard to create a new standard ac-

tion. The Standard Actions Classes Standard Actions Classes Standard Actions Classes Standard Actions Classes list is displayed. 

Select TFontEdit from the Dialogs category and click OKOKOKOK. In the ActionsActionsActionsActions list, click Se-

lect Font and use the Object Inspector to change its Category property to Format. Do 

this by selecting CategoryCategoryCategoryCategory and type the word Format. Also, write Font    as its Caption 

property. 

With the Format category selected in the Categories Categories Categories Categories list, press the New Action button 

to define a new action. Change its Name to WordWrap and its Caption to Word Wrap, 

using the Object Inspector. 

Now drag each item from the Categories Categories Categories Categories list to the menu bar at the top of the main 

form, in this order: FileFileFileFile, EditEditEditEdit, FormatFormatFormatFormat. 

The following image shows how the FileFileFileFile menu should look. 

Adding the components using the Form Designer 
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Finally, close the Actions Editor to continue with customizing your application. 



 

 

 

 

 

 

 

 

Customizing the components Customizing the components Customizing the components Customizing the components     

In the previous section of this chapter, “Arranging the components in the Form De-

signer”, you have added all the required components to your form and then config-

ured the action manager. Before you continue with writing code for the event han-

dlers, you must first customize the properties of the newly placed components.  

To customize a component, first select the component in the Form Designer. Then you 

can edit the properties of the component in the Object Inspector. 

Follow these steps to customize the memo component: 

1. Select the memo component in the Form Designer by clicking the memo compo-

nent. 

2. Find the memo component in the Object Inspector (if the Object Inspector is not 

visible, press F11 F11 F11 F11 or click View > Object InspectorView > Object InspectorView > Object InspectorView > Object Inspector). 

3. Set the Align property to alClient. This makes the memo component occupy all 

the free space available on the form. 

4. Set the Name property to TextMemo. Naming your component properly is very im-

portant because your code needs to access the component using that name. Set-

ting a name you can easily remember is essential. 

5. Set the ScrollBars property to ssBoth. This setting ensures that both the vertical 

and horizontal scroll bars are displayed in the memo and allows users to easily 

scroll through its contents. 

6. Set WordWrap to False. WordWrap tells the memo to wrap all text on several 

lines if the text does not fit in a single line. A False value disables word wrapping. 

7. Find the Lines property and press the '...' 

button located in the value box. A new 

edit dialog appears, allowing you to edit 

the initial contents of the memo, as in the 

image on the right. Delete all the text 

and then press OKOKOKOK to clear the memo. 

Contents of the memo box 

Figure 3Figure 3Figure 3Figure 3----16. 16. 16. 16. Editing the contents of the memo 

Customizing the components  
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After you have customized the memo, select the status bar component and customize 

it as follows. 

1.  Select the status bar in the DesignDesignDesignDesign window. 

2.  Set the Name property to TextStatus. 

3. Find the Panels property and press the "..." button at the right side of the value 

box. This will display a new dialog box that allows adding and customizing panels 

displayed in the status bar. 

4.   Press the Insert Insert Insert Insert key three times to add three panels. The panel editor should look 

as in the following image. You do not need to customize these panels, so just close the 

dialog. 

This concludes all customization you need to perform on your components. 

Before proceeding with writing any code, save all the changes you have made to the 

project, as follows. Click File > Save As File > Save As File > Save As File > Save As and save the unit as TextEditor. Also, click 

File > Save ProjectFile > Save ProjectFile > Save ProjectFile > Save Project As As As As and save the project as TextEditor_proj. 

Figure 3Figure 3Figure 3Figure 3----17. 17. 17. 17. Panel editor showing the list of added status panels  

Customizing the components 
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The currently defined status panels 



 

 

 

 

 

 

 

Coding responses to user actions in the Code EditorCoding responses to user actions in the Code EditorCoding responses to user actions in the Code EditorCoding responses to user actions in the Code Editor 

By following the instructions in this section, you will make your application interactive 

and provide it with the functionality you want. You will code event handlers, that is, the 

responses to clicking the various options in the main menu. 

Before proceeding with writing any code, define the String variable, which you need 

throughout the execution of the application to retain the name of the currently 

opened text file. First make sure you are in Code Editor mode by selecting the CodeCodeCodeCode 

tab, next to the DesignDesignDesignDesign tab in the status bar. To toggle between Form Designer and 

Code Editor mode, press F12F12F12F12.  

In Delphi, define a String variable called CurrentFile in the private section of the 

TTextEditorForm class, in the interface part, as in the following image. 

In C++, use the tabs at the bottom of the Code Editor window to display the 

TextEditor.h file. Also declare the currentFile variable in the private section of 

TTextEditorForm, as in the following image. 

Figure 3Figure 3Figure 3Figure 3----18. 18. 18. 18. Defining the CurrentFile private variable (Delphi view) 

Coding responses to user actions in the Code Editor 
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CurrentFile 

 



 

 

 

 

 

 

 

 

 

 

 

 

Creating an event handler for the New command Creating an event handler for the New command Creating an event handler for the New command Creating an event handler for the New command     

You are now ready to define the responses to clicking the menu items. In the Form De-

signer, click  File > New File > New File > New File > New on the menu bar in your text editor form. Then select the 

EventsEventsEventsEvents tab in the Object Inspector, as in the following image. Click the plus sign (+) to 

expand the Action list if necessary. 

Double-click here to write the 

code for the OnExecute event. 

Figure 3Figure 3Figure 3Figure 3----19. 19. 19. 19. Defining the currentFile private variable (C++Builder view) 

Figure 3Figure 3Figure 3Figure 3----20. 20. 20. 20. Opening the EventsEventsEventsEvents tab in the Object Inspector 

Coding responses to user actions in the Code Editor 
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Declaration of 

currentFile 



 

 

 

 

 

 

 

 

 

Double-click the edit box corresponding to the OnExecute event. The Code Editor 

opens and displays the following function skeleton, using Delphi or C++Builder, re-

spectively. 

Figure 3Figure 3Figure 3Figure 3----21. 21. 21. 21. Automatic generation of the code skeleton for the OnExecute event (Delphi view) 

Figure 3Figure 3Figure 3Figure 3----22. 22. 22. 22. Automatic generation of the code skeleton for the OnExecute event (C++Builder view) 
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Now write the code that executes when the user selects FileFileFileFile >>>> NewNewNewNew, inside the code 

skeleton previously generated, as in the following lines of code. 

procedure TTextEditorForm.NewExecute(Sender: TObject); 

var 

  UserResponse : Integer; 

begin 

  if TextMemo.Lines.Count > 0 then 

  begin 

    UserResponse := MessageDlg( 

      'This will clear the current document. ' + 

      'Do you want to continue?', mtInformation, 

      mbYesNo, 0); 

 

    if UserResponse = mrYes then 

    begin 

      TextMemo.Clear; 

      CurrentFile := ''; 

    end; 

  end; 

end; 

void __fastcall TTextEditorForm::NewExecute(TObject *Sender) 

{ 

  if (TextMemo->Lines->Count > 0) 

  { 

    int userResponse = MessageDlg( 

      String("This will clear the current document. ") 

      + "Do you want to continue?", mtInformation, 

      TMsgDlgButtons() << mbYes << mbNo, 0); 

 

    if (userResponse == mrYes) { 

      TextMemo->Clear(); 

      currentFile = ""; 

    } 

  } 

} 

Coding responses to user actions in the Code Editor 
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Creating the event handlers for the Open commandCreating the event handlers for the Open commandCreating the event handlers for the Open commandCreating the event handlers for the Open command    

Return to the form and double-click the OnAccept event of the File > Open File > Open File > Open File > Open item and 

write the code displayed below. 

procedure TTextEditorForm.FileOpen1Accept(Sender: TObject); 

var 

  FileName: String; 

begin 

  FileName := FileOpen1.Dialog.FileName; 

  if FileExists(FileName) then 

  begin 

    TextMemo.Lines.LoadFromFile(FileName); 

    CurrentFile := FileName; 

    Self.Caption := 'Text Editor - ' + ExtractFileName(FileName); 

  end; 

end; 

void __fastcall TTextEditorForm::FileOpen1Accept(TObject *Sender) 

{ 

  String fileName = FileOpen1->Dialog->FileName; 

  if (FileExists(fileName)) { 

    TextMemo->Lines->LoadFromFile(fileName); 

    currentFile = fileName; 

    this->Caption = "Text Editor - " + ExtractFileName(fileName); 

  } 

} 

Coding responses to user actions in the Code Editor 
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Creating the event handlers for the SaveAs commandCreating the event handlers for the SaveAs commandCreating the event handlers for the SaveAs commandCreating the event handlers for the SaveAs command    

Double-click the OnAccept event of FileFileFileFile >>>> SaveAsSaveAsSaveAsSaveAs and write the following code. 

procedure TTextEditorForm.FileSaveAs1Accept(Sender: TObject); 

var 

  FileName: String; 

  UserResponse : Integer; 

begin 

  FileName := FileSaveAs1.Dialog.FileName; 

 

  if FileExists(FileName) then 

  begin 

    UserResponse := MessageDlg( 

      'File already exists. ' + 

      'Do you want to overwrite?', mtInformation, 

      mbYesNo, 0); 

    if UserResponse = mrNo then 

      Exit(); 

  end; 

 

  TextMemo.Lines.SaveToFile(FileName); 

  CurrentFile := FileName; 

  Self.Caption := ExtractFileName(FileName); 

end; 

void __fastcall TTextEditorForm::FileSaveAs1Accept(TObject *Sender) 

{ 

  String fileName = FileSaveAs1->Dialog->FileName; 

 

  if (FileExists(fileName)) { 

    int userResponse = MessageDlg( 

      String("File already exists. ") + 

      "Do you want to overwrite?", mtInformation, 

      TMsgDlgButtons() << mbYes << mbNo, 0); 

    if (userResponse == mrNo) { 

      return; 

    } 

  } 

 

  TextMemo->Lines->SaveToFile(fileName); 

  currentFile = fileName; 

  this->Caption = ExtractFileName(fileName); 

} 

Coding responses to user actions in the Code Editor 
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Creating the event handlers for the Save commandCreating the event handlers for the Save commandCreating the event handlers for the Save commandCreating the event handlers for the Save command    

Double-click the OnExecute event of File > Save File > Save File > Save File > Save and write the following lines of code. 

procedure TTextEditorForm.SaveExecute(Sender: TObject); 

begin 

  if CurrentFile = '' then 

    Self.FileSaveAs1.Execute() 

  else 

    TextMemo.Lines.SaveToFile(CurrentFile); 

end; 

void __fastcall TTextEditorForm::SaveExecute(TObject *Sender) 

{ 

  if (currentFile == "") { 

    this->FileSaveAs1->Execute(); 

  } 

  else { 

    TextMemo->Lines->SaveToFile(currentFile); 

  } 

} 

Coding responses to user actions in the Code Editor 
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Creating the event handlers for the Font commandCreating the event handlers for the Font commandCreating the event handlers for the Font commandCreating the event handlers for the Font command    

Double-click the OnAccept event of Format > FontFormat > FontFormat > FontFormat > Font and write the following code. 

Creating the event handlers for the Word Wrap commandCreating the event handlers for the Word Wrap commandCreating the event handlers for the Word Wrap commandCreating the event handlers for the Word Wrap command    

Next, double-click the OnExecute event of Format > Word Wrap Format > Word Wrap Format > Word Wrap Format > Word Wrap and write the follow-

ing code. 

procedure TTextEditorForm.FontEdit1Accept(Sender: TObject); 

begin 

  TextMemo.Font := FontEdit1.Dialog.Font; 

end; 

procedure TTextEditorForm.WordWrapExecute(Sender: TObject); 

begin 

  { Toggle the word wrapping state. } 

  TextMemo.WordWrap := not TextMemo.WordWrap; 

  WordWrap.Checked := TextMemo.WordWrap; 

  if TextMemo.WordWrap = True then 

    { Only vertical scrollbars are needed when word wrapping is set. } 

    TextMemo.ScrollBars := ssVertical 

  else 

    TextMemo.ScrollBars := ssBoth; 

end; 

Coding responses to user actions in the Code Editor 
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void __fastcall TTextEditorForm::FontEdit1Accept(TObject *Sender) 

{ 

  TextMemo->Font = FontEdit1->Dialog->Font; 

} 

void __fastcall TTextEditorForm::WordWrapExecute(TObject *Sender) 

{ 

  { Toggle the word wrapping state. } 

  TextMemo->WordWrap = !TextMemo->WordWrap;  

  WordWrap->Checked = TextMemo->WordWrap; 

  if (TextMemo->WordWrap == True) { 

    { Only vertical scrollbars are needed when word wrapping is set. } 

    TextMemo->ScrollBars = ssVertical; 

  } 

  else { 

    TextMemo->ScrollBars = ssBoth; 

  } 

} 



 Creating event handlers for the status barCreating event handlers for the status barCreating event handlers for the status barCreating event handlers for the status bar    

Finally, use the status bar to display the current cursor position and also the number of 

lines of the currently opened text file. To do this, double-click the OnMouseDown 

event of the TextMemo component and write the following code, in Delphi and C++ 

respectively. The CaretPos property is used to indicate the coordinates of the caret in-

side the text memo box. 

Coding responses to user actions in the Code Editor 
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Next, double-click the OnKeyDown event of TextMemo and write the code below. The 

OnKeyDown event is triggered whenever you press a key inside the text memo box. 

procedure TTextEditorForm.TextMemoKeyDown(Sender: TObject; 

  var Key: Word; Shift: TShiftState); 

begin 

  TextMemoMouseDown(Sender, mbLeft, Shift, 0, 0); 

end; 

procedure TTextEditorForm.TextMemoMouseDown(Sender: TObject; 

  Button: TMouseButton; Shift: TShiftState; X, Y: Integer); 

begin 

  TextStatus.Panels.Items[0].Text := 

    'L: ' + IntToStr(TextMemo.CaretPos.Y + 1); 

  TextStatus.Panels.Items[1].Text := 

    'C: ' + IntToStr(TextMemo.CaretPos.X + 1); 

  TextStatus.Panels.Items[2].Text := 

    'Lines: ' + IntToStr(TextMemo.Lines.Count); 

end; 

void __fastcall TTextEditorForm::TextMemoMouseDown(TObject *Sender, 

  TMouseButton Button, TShiftState Shift, int X, int Y) 

{ 

  TextStatus->Panels->Items[0]->Text = 

    "L: " + String (TextMemo->CaretPos.y + 1); 

  TextStatus->Panels->Items[1]->Text = 

    "C: " + String (TextMemo->CaretPos.x + 1); 

  TextStatus->Panels->Items[2]->Text = 

    "Lines: " + IntToStr (TextMemo->Lines->Count); 

} 

void __fastcall TTextEditorForm::TextMemoKeyDown(TObject *Sender, 

  WORD &Key, TShiftState Shift) 

{ 

  TextMemoMouseDown(Sender, mbLeft, Shift,  0, 0); 

} 



 

 

 

 

 

 

 

 

 

 

 

 

Compiling and running the applicationCompiling and running the applicationCompiling and running the applicationCompiling and running the application    

Before you can actually see your application running, you must first compile it. To com-

pile your application, press SHIFTSHIFTSHIFTSHIFT----F9 F9 F9 F9 or select Project > CompileProject > CompileProject > CompileProject > Compile. You then see a dia-

log box displaying the progress of the compilation. If your application contains any 

syntactical errors, you will have to correct them and then recompile.  

Compiles the project 

Builds the entire project 

Figure 3Figure 3Figure 3Figure 3----23. Project 23. Project 23. Project 23. Project menu options for compiling and building the project 

Figure 3Figure 3Figure 3Figure 3----24. 24. 24. 24. Dialog showing the success of compiling the application 

Figure 3Figure 3Figure 3Figure 3----25. 25. 25. 25. Dialog showing the success of building the application 
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After you compile the application, you can see how it behaves at run time. Press F9F9F9F9 or 

click Run > Run Run > Run Run > Run Run > Run to run your application in debug mode. 

Choose this option to run the application. 

There are a few other options available, but those options are beyond the scope of 

this book.  

Note: Note: Note: Note: You can directly run the application without compiling it first. RAD Studio auto-

matically detects whether compilation is required and compiles the project if neces-

sary. 

Even if the application successfully compiles and runs, it might still not perform as you 

intended. The next section in this chapter, called “Debugging the application”, de-

scribes how to use some of the RAD Studio debugging features to rapidly find and fix 

bugs. 

Figure 3Figure 3Figure 3Figure 3----26. 26. 26. 26. Running the application from the RunRunRunRun menu 

Debugging the application 

Starting your first RAD Studio application 3-23  

Debugging the applicationDebugging the applicationDebugging the applicationDebugging the application    

To get a glimpse of the basic debugging features in RAD Studio, first set a breakpoint 

on the first line of the FileSaveAs1Accept function, by clicking on the bar at the left of 

the line of code.  



 

 

 

Figure 3Figure 3Figure 3Figure 3----27. 27. 27. 27. Debugging the FileSaveAs1Accept procedure (Delphi code) 

Figure 3Figure 3Figure 3Figure 3----28. 28. 28. 28. Debugging the FileSaveAs1Accept function (C++Builder code) 

Debugging the application 

3-24 Getting Started with Delphi® and C++Builder® 2009  

The Code Editor window should look like the following image. 

Breakpoint on the first line 

of the procedure 

Breakpoint on the first line 

of the function 



 

 

 

 

 

 

 

 

 

 

 

 

 

Press F9F9F9F9 to run the application, write something in the text box of the text editor and 

click File > Save AsFile > Save AsFile > Save AsFile > Save As. Name your text file, making sure that a file with the same name 

does not already exist at the current location. After clicking SaveSaveSaveSave, the application 

should stop at the breakpoint you have previously set, and the code editor window 

should display as in the image below. 

To see the value of the FileName variable, select the FileName word in the first line of 

FileSaveAs1Accept    and drag it to the Watch List, as in the following images. 

Figure 3Figure 3Figure 3Figure 3----29. 29. 29. 29. Application stopping at the specified breakpoint (Delphi view) 

Figure 3Figure 3Figure 3Figure 3----30. 30. 30. 30. Dragging the FileName variable to the Watch List (Delphi view) 
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Lines of code that may execute 

during the debugging process 

The currently executing line of 

code in the debugging process 

The FileName variable is now 

added to the Watch List. 



 

 

 

 

 

 

 

 

 

 

 

 

 

Press F8F8F8F8 to advance to the following line of code, so that the value of FileName is up-

dated. To expand the value of FileName, hover the mouse cursor over its label in the 

Watch List and wait. 

The result should look as in the following images. 

Figure 3Figure 3Figure 3Figure 3----31. 31. 31. 31. Dragging the fileName variable to the Watch List (C++Builder view) 

Figure 3Figure 3Figure 3Figure 3----32. 32. 32. 32. Advancing to the next line of code to change the value of FileName (Delphi view) 
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Pressing F8F8F8F8    once more jumps over the ifififif statement, since a file with the given name 

does not already exist at the current location. The screen should now look like the fol-

lowing images. 

Figure 3Figure 3Figure 3Figure 3----33. 33. 33. 33. Advancing to the next line of code to change the value of FileName (C++Builder view) 

Figure 3Figure 3Figure 3Figure 3----34. 34. 34. 34. Jumping over the ifififif statement (Delphi view) 
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Press F8F8F8F8    until you get to the last line of the FileSaveAs1Accept    function. Now move 

the mouse cursor over the name of the CurrentFile variable to instantly view its value, 

as in the following images. 

Figure 3Figure 3Figure 3Figure 3----35. 35. 35. 35. Jumping over the ifififif statement (C++Builder view) 

Figure 3Figure 3Figure 3Figure 3----36. 36. 36. 36. Viewing the value of CurrentFile (Delphi view) 
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To end the debugging session, press the stop button on the Debug Debug Debug Debug toolbar, also dis-

played in the following image.  

Figure 3Figure 3Figure 3Figure 3----37. 37. 37. 37. Viewing the value of CurrentFile (C++Builder view) 

Figure 3Figure 3Figure 3Figure 3----38. 38. 38. 38. The Debug Debug Debug Debug toolbar 

Debugging the application 
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Click here to stop debugging  the application. 



 

 

 

Debugging the application 
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4444 
More Advanced Topics 

 

VCL and RTLVCL and RTLVCL and RTLVCL and RTL    

 

As seen in the previous chapters, CodeGear™ RAD Studio 2009 offers a powerful Inte-

grated Development Environment that makes building native Windows applications 

extremely easy. The Visual Component Library (also known as VCL) offers a large num-

ber of visual and nonvisual components that can be used to build almost any desired 

user interface. Besides the VCL, RAD Studio provides an extensive library of routines 

and classes, called the Run Time Library (known as RTL), that provides the common 

functionality needed in all applications. 

This chapter lists the most important classes, data types, and functions that can be 

found both in the VCL and RTL. 

The most important components of the VCL are: 

• A standard set of components that include all controls provided by the Windows UI 

framework. This set consists of components such as buttons, edits, menus, and so 

on. The VCL also extends some of these controls, offering you even more function-

ality than is normally provided by the Windows controls. 

• An extended set of components not normally present in the Windows UI frame-

work. These components are built on top of the standard set. 

• Actions, which is a key concept extensively used in VCL applications, allow you to 

centralize all the interaction logic of your user interface. 
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• A number of data-aware controls that can be linked to a data source at design 

time. These components are widely used in database applications. 

• Ribbon controls that allow you to build the next generation of user interfaces that 

integrate nicely with the Windows Vista and Microsoft Office 2007 look-and-feel. 

• DBExpress and dbGo database frameworks. These frameworks can be used with all 

the data-aware controls, simplifying your application development more than ever. 

• Internet Direct, also known as Indy, that provides an extensive number of compo-

nents used in Internet-connected applications. Indy includes client and server com-

ponents for today’s most used communication protocols on the Internet. 

• DataSnap, which allows you to build distributed applications. 

• Easy integration of any exposed OLE and ActiveX objects in your application. RAD 

Studio provides a set of tools that allow creating a wrapper component over any 

public ActiveX. This wrapper component can be used as any normal VCL compo-

nent inside your application. 

Even though this is not the full list of components available in the VCL, the above men-

tioned are the most widely used and appreciated VCL components. To see all avail-

able components, check out the Tool Palette in RAD Studio. 

The most useful features in the RTL, which are available both in Delphi and 

C++Builder, are: 

• An extensive support for strings. This support includes handling of Unicode strings 

(the default encoding used by RAD Studio), ANSI and UTF-8 strings, various string 

handling routines, and much more. 

• A large number of date and time manipulation routines. 

• Extensive support for file and stream operations. 

• Routines and classes that provide Windows API support. You, as a developer, will 

often be required to use Windows API directly because a certain functionality is not 

provided by the RTL. RAD Studio provides developers with the ability to use the full 

Windows API directly. RAD Studio also provides easy-to-use classes like TRegistry 

for registry handling. 

 

VCL and RTL 
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• Variant data types and various support routines to make COM integration easy. 

Variant data types have long been used in Microsoft COM and OLE technologies. 

Variants are useful when you do not know the exact data type you are operating on. 

The Delphi language compiler provides native support for Variants, integrating 

some of the dynamic language concepts, found in other languages such as Java, 

PHP, and others. 

• Run-time Type Information, also known as RTTI, that provides an easy way to obtain 

metadata about types, classes, and interfaces at runtime. 

 

Another important part of the RTL is provided by the generic collections, which is spe-

cific to the Delphi language. This collection of generic classes can be used in any ap-

plication that requires lists, dictionaries, and other container classes. There are also 

nongeneric counterparts for these classes. 

 

The C++Builder equivalent of the generic collections is given by the STL library, pro-

vided by Dinkumware as a third party add-in. This is presented in the next section. 

 

For more information... For more information... For more information... For more information...     

See “Win32 Developer's Guide” in the bundled Help. 

 

VCL and RTL 
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Third party addThird party addThird party addThird party add----insinsinsins    

 

Dinkumware    (STL) is a collection of template libraries for C++, included in C++Builder. 

It includes containers such as vectors, lists, sets, maps, bitsets. It also includes algo-

rithms for applying widely used operations, like sorting a container or searching inside 

a container. To implement the algorithms, STL introduces iterators in all five flavors for 

operating on a container: input, output, forward, backward, bidirectional. Functors, or 

function objects, are also introduced for overloading operators.  

 

Boost    is a set of  libraries for C++ that significantly expand the language using tem-

plate meta-programming. A fully tested and preconfigured subset of Boost is included 

in C++Builder. Include paths have been set for the Boost libraries, and any other nec-

essary libraries should be automatically linked. As an example, to use the Boost  

minmax library, your code should specify: 

 

#include <boost/algorithm/minmax.hpp>. 

    

Intraweb    is a collection of visual components, a framework designed to allow you to 

create web applications or Apache plug-ins. It allows you to create web applications 

with the same ease you use the VCL.  

 

Indy    is an Open Source group. The Indy project maintains several active Open Source 

projects which have evolved from the original Indy (Internet Direct) project. Indy offers 

client and server components using Internet protocols, such as tcp, udp, echo, ftp, 

http, telnet, and many others. It also provides components for I/O handling, intercepts, 

SASL, UUE, MIME, XXE encoders, and others. 

Third party add-ins 
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• Dinkumware (STL)Dinkumware (STL)Dinkumware (STL)Dinkumware (STL)    

• BoostBoostBoostBoost    

• IntrawebIntrawebIntrawebIntraweb    

• IndyIndyIndyIndy    
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EDN and Partners 

 

Other resourcesOther resourcesOther resourcesOther resources    

 

EDNEDNEDNEDN    

    
The Embarcadero Developer Network (EDN), located at dn.embarcadero.com, is a col-

lection of code-related articles on various products, including 3rdRail, Turbo Ruby, 

Blackfish SQL, C++Builder, Delphi, Delphi for PHP, Delphi Prism, Interbase, and 

JBuilder. 

The EDN website keeps an up-to-date calendar of the most important events related 

to Embarcadero products and also gives the latest news in product updates. As a fea-

ture of this website, the calendar can be customized to show the events concerning a 

single Embarcadero product. 

An important developers’ resource is the CodeCentral page, as part of the EDN. This 

is located at the following link: cc.embarcadero.com. CodeCentral is a collection of 

code snippets contributed by various members, using all the programming languages 

featured in EDN. 
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PartnersPartnersPartnersPartners    

The companies behind all the included third party add-ins are mentioned in the follow-

ing list: 

• DINKUMWARE Ltd for Dinkumware, at http://www.dinkumware.com 

• The Boost open source project, at www.boost.org 

• ATOZED Software for IntraWeb, at http://www.atozed.com/IntraWeb 

• The Indy Project, at http://www.indyproject.org 

 

A complete list of the RAD Studio 2009 partners can be found at the following links: 

• http://cc.embarcadero.com/partners/delphicpp2009/CBuilder/index.html 

• http://cc.embarcadero.com/partners/delphicpp2009/Prism/index.html 

• http://cc.embarcadero.com/partners/delphicpp2009/Delphi/index.html 
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