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Introduction to PowerSQL 

Embarcadero PowerSQL simplifies SQL development for application developers with many features 
for improving productivity and reducing errors. A rich SQL IDE with code completion, real-time error 
checking, code formatting, and sophisticated object validation tools help streamline coding tasks. 
PowerSQL’s user interface helps improve overall productivity with database object look up 
functionality and side-by-side views of application code and SQL code. PowerSQL offers native 
support for IBM DB2 for LUW, Oracle, Microsoft SQL Server, and Sybase, as well as JDBC support for 
other DBMS. PowerSQL is available as a stand-alone application or as an Eclipse plug-in. 

Product Benefits 
• SQL Code Assist ensures 100% object name accuracy without the requirement to connect to 

a database, plus real-time SQL syntax validation. 

• SQL Project Insight provides project-level SQL file cataloging and search features to 
streamline project organization and maintenance. 

• The Migration Wizard imports data sources from Eclipse DTP (Data Tools Project) or Quest 
TOAD. 

• Data Source Explorer enables you to navigate, search, extract DDL, execute commands, and 
browse an outline, without having to open the SQL file. 

• Formatting Profiles ensure consistent, quality code layout for easy review and extension. 
Profiles can be customized and shared. 
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About This Evaluation Guide 

This evaluation guide enables you to get started with PowerSQL. 

Its purpose is to provide you with the foundation needed to fully utilize the features and benefits of the 
products, and apply them to your own enterprise. This guide contains information on how to get the 
application up and running, and how to browse data sources, and create, modify, and execute SQL 
code for the purpose of database development. 

This guide is divided into five sections: 

 Session 1: Getting Started with PowerSQL 

 Session 2: Working with Data Source Explorer 

 Session 3: Working with SQL Code Assist 

 Session 4: Executing SQL Code 

 Session 5: Working with SQL Project Insight 

Once you have started, you can select Help from the Menu Bar to find additional resources that 
complement and build upon the features and tasks presented in this guide. 



PowerSQL 1.1 Evaluation Guide 

5 of 25 

Session 1: Getting Started with PowerSQL 

Install PowerSQL 
Launch the installation program via the Installer included in your software package and follow the 
instructions in the Wizard to complete it. 

PowerSQL can be installed as a standalone application (RCP installation) or as an Eclipse plug-in 
(Plug-In installation). 

• The RCP installation provides an enclosed application that runs PowerSQL in a contained 
framework. 

• The Eclipse plug-in installation leverages Eclipse plug-in capabilities to run within the Eclipse 
framework. You must have a previously installed version of Eclipse on your machine prior to 
installing PowerSQL as a plug-in. 

 
PowerSQL can be installed as a Standalone application or as a plug-in for an existing Eclipse installation. 

Both the RCP and plug-in versions of PowerSQL provide full functionality. 

You may be required to restart your machine to complete the installation of PowerSQL. It is also 
recommended that you copy the installer to the desktop of your machine prior to running the Installer. 

Note: PowerSQL can be installed with a 14-day trial license, after which you must purchase a 
permanent license to continue using the product. 
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To start PowerSQL: 

• From the Desktop, choose the Windows Start menu and then select Programs > 
Embarcadero > PowerSQL > PowerSQL. 

 

User Interface Overview 
The PowerSQL application environment is known as the Workbench. The Workbench provides an 
interface through which you create, manage, and execute SQL code. 

The Workbench is composed of common interface elements that provide tools to accomplish the 
creation, management, and execution of SQL code. These objects provide a uniform system for 
working with jobs and data sources. 

 

The Workbench provides an environment to define, manage, and execute SQL code. 
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• The Welcome Page is the first screen you will see when you initially launch the application. 
This screen provides links to documentation and other help files/tutorials to further familiarize 
you with the product. It provides easy access to information that may be of value to new users. 

 
The Welcome page provides links to help tutorials and provides access to the application environment. 

• The Workbench Space is composed of Views, Editors, and the Menu Bar and Command 
Toolbar. Views and Editors are interface components that enable you to define and execute 
SQL code, as well as manage resources. 

• The Menu Bar and Command Toolbar contain commands that execute various functional 
aspects of the application such as launching Views and Editors, navigation commands, and 
environment preference settings. The Toolbar contains icons that represent specific menu 
commands. For example, the Search command can be launched via the Search > Search 
menu in the Menu Bar, and also via the Search icon in the Command Toolbar. 

• Views are Workbench interface components typically used to navigate a hierarchy of 
information, open Editors, or display the properties of various application elements. For 
example, the Data Source Explorer view provides a tree of all data sources in the 
environment and the comparison jobs associated with each. You can launch these jobs 
directly from Data Source Explorer, modify the connection properties of data sources, or 
create and edit configuration archives from this View. 

• Editors are Workbench interface components typically used to access PowerSQL 
functionality. For example, the SQL Editor provides a means to view, edit, and save SQL 
code. Editors are largely differentiated from Views in that they operate on an individual level 
rather than a supportive one. 
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Session 2: Working with Data Source Explorer 

Data Source Explorer provides a tree view of all data sources registered in PowerSQL. In addition, it 
breaks down the components of each data source and categorizes databases and corresponding 
database objects by object type and underlying SQL code. This feature provides you with a view of the 
contents of data sources in your enterprise in an easily navigated and cataloged interface. 

 
SQL Project Insight sorts databases and database objects by category within Data Source Explorer. 

If data sources are particularly large or complex, or you are only developing specific objects, you can 
apply database object filters on the view in Data Source Explorer. 
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Adding Data Sources 
In order to view and edit data source objects, you need to register data sources to be used as sources 
in the environment by providing connection information and other details to PowerSQL. 

Data sources are registered and managed in Data Source Explorer. Each time you register a new 
data source you need to specify its connection information and organize it in the View, as needed. 
Once a data source has been registered, it remains stored in a catalog and does not need to be re-
registered each time you open PowerSQL. It can be used in multiple jobs, archived, or otherwise 
“shared” with regards to the general functionality of the application. 

 
The Data Source Explorer View provides an organizational tree of registered data sources and the comparison jobs and 
archives associated with them. 

 

To add a data source: 

Highlight Data Source Explorer and choose File > New > Data Source from the Menu Bar. The Data 
Source Wizard appears. 
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Browsing Data Sources 
In order to develop and maintain SQL code on data sources within your enterprise, you need to 
access database objects within the application environment. It is important to be able to view 
databases, database objects, and the underlying code in an organized manner, especially when 
maintaining a large system. 

You use Data Source Explorer’s tree structure to view and access databases, tables, and other 
objects on data sources, by expanding the nodes of each registered data source. When you create 
new SQL files, you can execute them on a specified data source, and these new objects automatically 
appear in the tree. 

 
The Data Source Explorer tree provides a list of databases, database objects, and underlying code stored per individual 
registered data source. 

All objects listed in Data Source Explorer are organized, in descending order, by data source, by 
database or login, by database object, by object type, by underlying SQL code. If you double-click an 
object, PowerSQL automatically extracts the code and places it in an editor. 
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To browse a data source: 

Expand the node of the data source whose databases, database objects and SQL code you want to 
view. If you want to view the code of a specified object, double-click the object to open the code in the 
editor. 
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Session 3: Working with SQL Code Assist 

SQL Code Assist is an interface component that enables the development and formatting of SQL code 
for the purposes of creating and modifying database objects. It provides a front end application for the 
delivery of code through its object code extraction capabilities. 

Code Assist provides a number of key features that assist in the coding process, ensuring greater 
accuracy in coding, faster development cycles, and a general increase in efficiency overall. 

 
SQL Editor provides key features to ensure an increase in code accuracy and overall development efficiency. 

The following key features are provided with SQL Code Assist: 

• Code Extraction 

• Code Highlighting 

• Automatic Error Detection 

• Code Complete 

• Hyperlinks 

• Code Formatting 

• Code Folding 

• Code Quality Checks 

In order to access SQL Editor, you need to create a new file or edit existing code from Data Source 
Explorer. 

Additionally, SQL Project Explorer provides a tree structure for all files created in PowerSQL. You 
can access files from here by double-clicking the file name you want to open as well. 
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SQL Project Explorer provides a tree of all files developed and saved in PowerSQL. 

To create a new file: 

Choose File > New > SQL File. 

A blank instance of SQL Editor appears in the Workbench. If you save this file, it is automatically 
added to the SQL Project Explorer. 

To edit an existing file: 

Use Data Source Explorer or Project Explorer to navigate to the code you want to modify and double-
click it. 

An instance of SQL Editor appears in the Workbench, populated with the extracted code of the 
specified object or SQL project file. 
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Code Extraction 
SQL Editor provides the ability to extract the underlying SQL code of database objects registered in 
PowerSQL to provide a front end application for the development and modification of data sources in 
your enterprise. 

To extract underlying SQL code: 

• Navigate to a database object in Data Source Explorer and select Extract via the right-click 
menu. 

The object’s underlying SQL code appears in SQL Editor and is ready for editing and further 
modification. 

Code Highlighting 
SQL Editor identifies commands and provides syntax highlighting changes that are automatically 
added to the code as you add lines, which enables you to clearly and quickly understand code when 
you read it in the interface. 

The following syntax highlighting is automatically added to lines of code in SQL Editor: 

Code Formatting 

Comments Green italic font 

SQL Commands Dark blue font 

Syntax Errors Red underlined font 

Coding Errors Red font 

 

• Comments: green italics 

• SQL Commands: dark blue 

• Syntax Errors: red underline 

• Coding Errors: red 

Additionally, SQL Editor provides a purple change bar in the left-hand column that indicates if a line of 
code has been modified from the original text. You can hover over this change bar to view the original 
code line. A red square icon in the right-hand column indicates that there are errors in the code line. 
You can hover over the icon to view the error count. 
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The purple change bar indicates if a line of code has been changed from its original text. Hover your mouse over the change bar 
to view the original text. 
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Automatic Error Detection 
The automatic error detection functionality of the editor highlights errors and typos in the code as you 
work in “real time”. 

Automatic error detection automatically identifies and analyzes SELECT, FROM, WHERE, GROUP 
BY, HAVING, and ORDER BY statements. If it detects any syntax errors while you type these 
statements, the line is automatically flagged by the error icon in the left-hand column of SQL Editor. 
You can hover your mouse over the icon to view any errors. 

 
Syntax errors are automatically flagged by line as you work with code in SQL Editor. Hover the mouse over the error icon to 
view the specific error message. 

Additionally, all semantic errors are recorded in the Problems view, an interface component that 
automatically logs errors and warnings as you work with files. 

 
The Problems view logs errors and warnings as you work with files in SQL Editor. 

You can double-click on a line in the Problems view and PowerSQL will automatically navigate you to 
that issue in SQL Editor. 
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Code Complete 
SQL Editor provides suggestion capabilities for both DML statements and objects. It has the ability to 
look up object names in order to avoid errors when defining table names, columns, etc. in the 
development process. 

This feature provides lists of object and code suggestions that will make the development process 
more efficient as you will not be forced to manually look up object names and other statement values. 

SQL Editor provides code assist for SELECT, UPDATE, INSERT, and DELETE statements and object 
suggestion support for tables, alias tables, columns, alias columns, schemas, and catalogs. 

To activate code assist: 

1. Click the line on which you want to activate the code assist feature. 

2. Press CTRL + Spacebar on your keyboard. Code assist analyzes the line and presents a list 
of suggestions as appropriate based on the elements of the statement. 

Hyperlinks 
Hyperlinks are used in SQL Editor to provide links to tables, columns, packages and other reference 
objects. When you select a hyperlinked object from a piece of code, a new editor opens and displays 
the source. 

Additionally, hyperlinks can be used to link procedures or the function of a call statement, as well as 
function calls in DML statements. 

To enable a hyperlink, hover your mouse over the object name and hold the CTRL key. It becomes 
underlined and changes color. 

Code Formatting 
Code formatting is automatically applied to a file as you develop it in SQL code. This enables you to 
set global formatting preferences one time, and then apply it to all code development, saving time and 
allowing for a more efficient code development process. 

The code formatter can be accessed by selecting CTRL + Shift + F in the editor. All code is 
automatically formatted based on parameters specified on the Code Formatter node of the 
Preferences panel. (Select Window > Preferences in the Main Menu to access this panel.) 
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Code formatting parameters can be globally set and then applied to all development work in SQL Editor. 

In addition to formatting code per individual file, you can also format an entire group of files from 
Project Explorer. Select the directory of files that you want to apply formatting to and execute the 
Format command from the right-click menu. The files will be automatically formatted based on the 
global preferences. 

Code Folding 
The code folding feature automatically sorts code into a tree-like outline structure in SQL Editor. This 
increases navigation and clarification capacities during the code development process. It ensures that 
the file will be easily understood should any future work be required on the code. 

As you work in SQL Editor, collapsible nodes are automatically inserted into the appropriate lines of 
code. Statements can then be expanded or collapsed as needed, and this feature is especially useful 
when working on parts of particularly large or complicated files. 
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Code Quality Checks 
On Oracle-based code, the code quality checking feature provides suggestions regarding improved 
code on a statement-by-statement basis. As you work in SQL editor, markers provides annotations 
that prevent and fix common mistakes in the code. 

Notes regarding code quality suggestions appear in a window on any line of code where the editor 
detects an error, or otherwise detects that the code may not be as efficient as it might be. Code quality 
check annotations are activated by clicking the light bulb icon in the margin, or by selecting Ctrl + l on 
your keyboard. 

The following common errors are detected by the code quality check function in the editor: 

 Statement is missing valid JOIN criteria 

 Invalid or missing outer join operator 

 Transitivity issues 

 Nested query in WHERE clause 

 Wrong place for conditions in a HAVING clause 

 Index suppressed by a function or an arithmetic operator 

 Mismatched or incompatible column types 

 Null column comparison 

 

To activate code quality checks: 

 Click the light bulb icon in the margin of the editor or select Ctrl + l on your keyboard. 

The editor suggestions appear in a window beneath the selected statement. When you click a 
suggested amendment, the affected code is automatically updated. 
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Session 4: Executing SQL Code 

When you have finished developing or modifying code, you can then execute the file from within the 
PowerSQL environment, on the database of your choosing. This enables you to immediately execute 
code upon completion of its development. Alternatively, you can save files for execution at a later point 
in time. 

In order to execute a file, you must first associate it with a target database. This is performed by using 
the drop down menus located in the Toolbar. When a SQL file is open in the Workbench, the menus 
are enabled. Select a data source and a corresponding database to associate the file with and then 
click the green arrow icon to execute the file. 

 
The pair of drop down menus indicate that the SQL file is associated with the dataotb19 data source and EMBCM database. 
When the green arrow icon on the right-hand side of the menus is selected, the file is executed on the specified data source and 
database. 

Additionally, if you have turned off auto-committal in the Preferences panel (Window > Preferences) 
you can commit and execute transactions via the Commit Transaction and Start Transaction icons 
located beside the Execute icon. 

To execute a file: 

Open the file you want to run and ensure it is associated with the correct database, then click the 
Execute icon. PowerSQL executes the code on the database you specified. 

To execute a transaction: 

Open the transaction file you want to run and ensure it is associated with the correct database, then 
click the Start Transaction icon. PowerSQL executes the transaction on the database you specified. 

To commit a transaction: 

Open the transaction file you want to commit, ensure it is associated with the correct database, and 
click the Commit Transaction icon. PowerSQL commits the transaction on the database you 
specified. 
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Configuring SQL Execution Parameters 
If you do not want to use the default execution options provided by PowerSQL, use the SQL Session Options 
dialog to modify the configuration parameters that determine how PowerSQL executes code. These options 
ensure that code is executed the way you want on a execution-per-execution basis, ensuring accuracy and 
flexibility when running new or modified code. 

 
SQL Sessions Options provide you with the flexibility to adjust execution parameters on a session-by- session basis. 

To modify SQL session options: 

1. Click the SQL Session Options icon in the Toolbar. The SQL Sessions Options dialog 
appears. 

2. Click on the individual parameters in the Value column to change the configuration of each 
property, as specified. 

3. Click Finish. The session options are changed and PowerSQL executes the code as specified 
by your options. 

Note: SQL Session Options are only applied to the currently-selected code, and are not retained 
across different files with regards to execution. 
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Session 5: Working with SQL Project Insight 

SQL Project Explorer provides a tree view of all projects created in PowerSQL for the purpose of 
organizing and storing SQL development files. This provides a place to keep work in progress 
organized, as well as maintaining a common directory structure from which the development and 
execution of files can be implemented. 

 
SQL Project Explorer provides a directory structure to organize and maintain SQL files. 

When you save a file in SQL Editor, SQL Project Insight is able to determine the type of SQL file you 
created and automatically organizes it in the proper directory folder in SQL Project Explorer. 
Additionally, SQL Project Explorer contains a folder for all data source connections you have indicated 
when creating a file: 
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• Connections lists all data source connections of the files associated with the project. 

• Creation Scripts contains DDL statements and statements that define database objects. 

• General SQL is a category for all other SQL files not used in database object creation. This 
includes DML files, etc. 

• Large Scripts contains all files larger than the currently indicated file size preference. This 
limit can be modified on the Preferences panel. (Select Windows>Preferences in the Menu 
Bar.) 

Additionally, SQL Project Insight flags files that contain semantic or syntactic errors with a red X icon 
beside the name of the file in the tree. This enables you to quickly look through the files listed and find 
erroneous files without having to open each file in SQL Editor. 

SQL Project Insight also features a code indexer that provides a preview look at code in each file. As 
with error detection, the indexer enables you to search through SQL files without having to open the 
files in the editor. 

To create a new file: 

1. Select File > New > SQL Project from the Main Menu. 

The New Project Wizard appears. 

2. Enter the appropriate information in the fields provided by the wizard. 

3. Click Finish. 

The new project icon appears in the SQL Project Explorer view under the name you 
specified. If you did not indicate a default location, the project appears in the appropriate 
directory when you open it in PowerSQL. 

Once you have created and saved a file, it appears in the appropriate directory and node in SQL 
Project Explorer. If you specify a data source to which the file is associated, that data source name 
appears under the Connections node. 

Additionally, the Outline view and Quick Outline function in SQL Editor displays the hierarchical 
structure of the SQL code. This provides easy navigation during the development process, especially 
for users who are not extremely familiar with SQL code. 

 
The Quick Outline function displays the hierarchical structure of the code file currently on display in 
SQL Editor. 
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To open the Outline view: 

• Select Window > Show View > Outline on the Menu Bar. 

The Outline view appears in the Workbench, displaying the hierarchy of the code open in 
SQL Editor. 

To use Quick Outline: 

• In SQL Editor, press Ctrl + O. 

The Quick Outline pane opens and displays a hierarchical view of the code open in SQL 
Editor. 
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Additional Evaluation Resources 

Embarcadero Technologies Product Support 
The Embarcadero Web site is an excellent source of additional product information, including white 
papers, articles, FAQs, discussion groups and the Embarcadero Knowledge Base. 

Go to www.embarcadero.com/support or click any of the links below to find: 

• Documentation 

• Online Demos 

• Technical Papers 

• Discussion Forums 

• Knowledge Base 

Licensing Your Embarcadero Technologies Product 
All Embarcadero Technologies products include a 30-day trial period. To continue using the product 
without interruption, we recommend that you license it as soon as possible. To license your product, 
use the License Request Wizard found in the Help menu of your respective product. If you have not 
yet purchased your Embarcadero Technologies product, contact sales@embarcadero.com, or 
uk.sales@embarcadero.com for sales in the EMEA region. 

Embarcadero Technologies Technical Support 
If you have a valid maintenance contract with Embarcadero Technologies, the Embarcadero Technical 
Support team is available to assist you with any problems you have with the application. Our 
maintenance contract also entitles registered users of Embarcadero Technologies’ products to 
download free software upgrades during the active contract period. 

To save you time, Embarcadero Technologies maintains a Knowledge Base of commonly encountered 
issues and hosts Discussion Forums that allow users to discuss their experiences using our products 
and any quirks they may have discovered. 

For additional information regarding Embarcadero Technologies Technical Support, go to the Support 
page on our Web site. 

Embarcadero Technologies on the Web 
To download evaluations of other Embarcadero Technologies products or to learn more about our 
company and our products visit us at www.embarcadero.com. 


